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Introduction
Welcome to the product guide for Microsoft® Office InfoPathTM 2003, the information gathering program in the Microsoft Office System. This product guide includes InfoPath feature enhancements in Microsoft Office 2003 Service Pack 1 (SP1), which are [image: image83.jpg]tiamlnfaolgath“zooe,
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flagged throughout this document with the button.
Today's organizations create and use massive amounts of information, from sales figures to performance appraisals to purchase orders. Gathering this data is a top priority for teams and organizations. For example, a Microsoft study shows that as part of the process of gathering and managing information, currently 70 million workers, or 59% of working adults in the United States, complete forms on a regular basis as part of their job responsibilities.
Currently, many information workers collect that information via inefficient processes such as paper forms, or electronically using documents, spreadsheets and e-mail. Others have built custom in-house applications using Web-based or proprietary forms tools. Because of the difficulty of extracting and reusing information from these applications or tools, information workers often must retype information leading to data-entry errors and inefficient business processes.
Moreover, key decision makers are often unable to make informed decisions because the information they need is trapped within documents or databases in another part of the organization. Technologies such as the Extensible Markup Language (XML) and Web services have been helpful in improving business processes from server to server, but to date they have not been connected directly to information workers at their desktops. This has meant that information workers have not had a way to interact with Web services directly to access and use the enterprise information that they need.
InfoPath was designed to address all of these customer needs. It streamlines the process of gathering information and makes it easy to reuse that information throughout the organization. InfoPath is the “premier smart client” for Web services—a user-friendly application that enables information workers at their desktops to use Web services to access and use enterprise information.
The Uses for InfoPath 
InfoPath XE "InfoPath:Introduction"  provides information workers with a set of tools that enable the creation of dynamic forms to gather and share information across a wide range of formal and informal business processes. Unlike traditional forms packages, InfoPath provides a high degree of information-gathering flexibility, enabling people to obtain the information they need in a timely fashion and to make well-informed decisions.
Furthermore, because the native file format for InfoPath is XML and the application supports any customer-defined XML schema, as well as interoperability with Web services, the information gathered in InfoPath can easily be integrated with an organization’s databases and servers. This means that any information gathered with InfoPath can be reused and repurposed by anyone or any process in the organization, which greatly increases productivity and the power of that information.
As a member of the Microsoft Office System, InfoPath supports three key activities: the creation of dynamic forms, the completion of these forms, and submission of these forms to the systems and processes that need the information collected in the forms.
· InfoPath provides a robust, flexible, easy-to-use design environment that enables the creation of dynamic forms that information workers can use to gather information, either for formal ongoing business processes or for informal team projects.
· The same rich InfoPath client also provides an application environment in which information workers can complete forms quickly and easily. 
· InfoPath then connects this information to organizational business processes and makes that information easy to reuse through its support of XML, customer-defined schemas, and Web services. 
For example, InfoPath can help improve the efficiency and productivity of a company’s sales force and sales information. Before InfoPath was available, a salesperson returning from a business trip might have filed a trip report document, entered new sales figures and pricing into a customer relationship management (CRM) or enterprise resource planning (ERP) application as a separate task, and completed an expense report using a custom-developed expense reporting solution. She would have needed to enter the same information—client contact information, sales figures, pricing—multiple times, in different applications that do not share or cross-validate that information. The information within one business process, such as the trip report document, would be difficult to reuse in the other business processes without manually reentering that information.
InfoPath can improve this error-prone and inefficient process. Using the powerful design tools in InfoPath, a form designer can quickly and easily create a trip report form for the sales force. Before departing on a trip, a sales representative can download the form from the corporate intranet site, put it on her laptop, and add information to the form after each client visit. Because InfoPath enables a user to work with forms offline, a sales representative can complete an entire trip form while on the road. She can submit the completed form as soon as she reconnects with the corporate network. The information submitted in an InfoPath form can be passed directly to a Web service that then repurposes the information for all the various reports that the salesperson used to complete in separate processes, such as the trip report, the expense report, and the updates to the CRM and ERP systems. 
Moreover, the information gathered through InfoPath is now easy to reuse in all of the company’s business processes, such as purchase order creation, fulfillment, shipping, and customer shipment notification—even though these might be different systems in different locations. Finally, InfoPath is a valuable tool for the team’s informal processes, as the sales manager can use InfoPath’s integration with Microsoft Windows® SharePointTM Products and Technologies to review the entire sales team’s reports in one convenient summary view.
Information gathered through InfoPath can be stored directly in a database, on a Web server or file share, or on a server running SharePoint. From there, the information can be analyzed or easily repurposed, eliminating the need to retype the information as it is used in different documents or transactions. 
The bottom line? InfoPath provides individuals and organizations with more flexibility than is available from other form solutions, enabling a level of inter-application and inter-process integration that has never before been so easy to achieve.
The Advantages of InfoPath Over Existing Approaches
 XE "InfoPath:Advantages over other approaches" \r "AdvantagesOverOtherApproaches" As a method of gathering information and integrating it with business processes, InfoPath provides numerous advantages over paper forms, text documents, Web forms, and custom-built solutions. 
	InfoPath vs. Paper Forms

	
	InfoPath
	Paper Forms

	Improved Efficiency

	Information collected in an InfoPath form can be submitted directly to a Web service, a URL, a database, or other location through an e‑mail message; no rekeying of information is required.
	Information in a paper-based form must be rekeyed into a system; a process that takes time and increases the possibility of error.

	Reusability
	The information collected in a single InfoPath form can be used by many different systems and processes because the information is stored as XML.
	Information collected in a paper-based form can only be reused by other systems if someone rekeys that information into the other systems.

	Rich Authoring Environment

	InfoPath forms support richly formatted data, including information formatted with bold, italic, and underlined fonts, information formatted in a variety of list and tabular formats, and information that takes the form of a graphic or picture, all of which can be bound to the XML schema for easy reuse throughout the organization. InfoPath also provides spell checking support and real time data validation capabilities. 
	Paper-based forms provide no worthwhile support for richly formatted data, as the data must be rekeyed or scanned into the process for which the form has been developed—and the UI through which the information is entered may not support rich text.

	More Rapid Response to Change
	InfoPath forms can be updated, revised, and made available for use within a matter of moments.
	Paper-based forms must be reprinted in order to accommodate updates or changes, and that process can be a lengthy one, particularly if the forms are multipart forms. The expense involved with revising forms can also be significant.


	InfoPath vs. Traditional Text Documents

	
	InfoPath
	Traditional Text Documents

	Connection to Business Processes
	Because InfoPath relies on an underlying XML schema that can be recognized by many different business systems and processes, the information captured in a single InfoPath form can be easily shared within the organization. 
	Traditional text documents are typically created with one system or process in mind, and they are designed to present only that process. The greater the number of processes, the greater the number of documents that need to be managed and maintained. 

	Reusability
	InfoPath communicates with ADO.NET DataSets and Web services in a bi-directional manner, enabling the information stored in databases and servers to populate fields within InfoPath forms. This increases the speed and accuracy of filling out forms.
	Traditional text documents cannot exchange data with Web services or ADO.NET DataSets, so users must rekey all the information the form requires every time they complete the form.


	InfoPath vs. Web Forms

	
	InfoPath
	Web Forms

	Reusability
	The information collected in a single InfoPath form can be used by many different systems and processes because the information is stored as XML.
	Information collected in a Web form can only be reused by other systems if the Web form saves the information in a format such as XML that many systems can use. Not all Web forms do this.

	Rich Authoring Environment
	InfoPath forms support richly formatted data, including information formatted with bold, italic, and underlined fonts, information formatted in a variety of list and tabular formats, and information that takes the form of a graphic or picture, all of which can be bound to the XML schema for easy reuse throughout the organization. InfoPath also provides built-in support for the spelling checker.
	Web forms generally provide no support for richly formatted text, lists, the easy inclusion of graphics, or spell checking.

	Validation
	InfoPath validates user input according to rules created by the form designer, and the form will alert users immediately when input does not appear valid. 
	Web forms do not offer real-time validation of data; a user is alerted of an error only after attempting to submit a form. This process is slow and often out of sequence.


	Flexibility of Form Completion
	InfoPath enables users to begin working on a form and save the incomplete form for later completion and submission. InfoPath forms can even be completed offline and submitted when the user reconnects to the network. Because InfoPath provides the ability to work offline, users no longer have to worry about losing their information and are free to work at their own pace.
	Users must complete the form in real time. There is no option to save an incomplete Web form for completion at a later date. All the information a user entered is lost if a user cannot complete the form in one sitting. Web forms must be completed while the user is online.


	InfoPath vs. Custom-Built Solutions

	
	InfoPath
	Custom-Built Solutions

	Deployment Investment
	InfoPath provides instant access to both a design and form completion environment that can be tailored quickly to meet the needs of your entire organization. InfoPath enables the rapid creation of forms by individuals who may not have sophisticated coding skills, and as a member of the Microsoft Office System, it builds on user familiarity with the conventions of Microsoft Office. An organization can update forms automatically when using a shared forms repository. Support is also available from Microsoft, so there is a source for answers to questions.
	Custom-developed solutions require a large investment of time and resources. Designers need sophisticated skills to code forms and any underlying form logic (such as validation and/or constraining rules), and this adds time and expense to form development and deployment. 


	Rich, Flexible Authoring Environment
	InfoPath forms support richly formatted data, including information formatted with bold, italic, and underlined fonts, information formatted in a variety of list and tabular formats, and information that takes the form of a graphic or picture, all of which can be bound to the XML schema for easy reuse throughout the organization. InfoPath includes a spell checker that can use the same custom dictionaries and autocorrect lists that other Microsoft Office System products use.
	A custom-built solution may not provide as flexible an authoring or forms completion environment. It may not take full advantage of existing investments in other business systems.

	Increased Productivity
	InfoPath provides a design environment that facilitates the rapid creation and modification of forms, which in turn ensures that forms are always ready to capture the information required by the organization.
	A custom-built solution may not provide a design environment that enables such rapid creation of forms—which would compromise the organization’s ability to gather and consume information quickly and efficiently.


The bottom line? Today, InfoPath is the only application that provides all of the capabilities for structured document creation and editing in a single, easy-to-use package. Other information gathering products require users to write code or to possess advanced XML knowledge in order to build or even fill out forms. InfoPath is the only application that combines all of the necessary features into a single, easy-to-use product that empowers information workers of all skill levels.
Overview of InfoPath XE “InfoPath features: Overview"  Features
WYSIWYG design mode. The InfoPath XE "InfoPath:Design mode"  design mode makes it easy to customize existing forms or build a custom form from scratch or from an existing data source. It provides drag-and-drop insertion of controls, data validation, a view of the underlying schema, and an interactive preview so that users know exactly how the form will behave and look when completed and a publishing wizard that simplifies form deployment. 
Familiar environment for filling out forms. As part of the Microsoft Office system, InfoPath provides a familiar environment in which users can fill out forms while the XML is created behind the scenes. InfoPath combines a forms editing experience with that of a word processor, bringing rich text editing, including inline spelling checker and AutoCorrect capabilities, to the world of structured form creation. It supports direct ink entry for Tablet PC users. All this enables users to work with structured documents without needing to know anything about XML. It also reduces the amount of training required to become productive with the tool. 
Sample forms. InfoPath XE “InfoPath:Sample forms”  provides numerous sample forms that can be easily customized in design mode to fit specific business needs. InfoPath also provides sample forms that can be used as a designer resource, demonstrating how InfoPath can automate and be integrated into a number of different business processes. 
Programmability. InfoPath XE “InfoPath:Programmability”  includes a script editor, object model, editing controls, and XML output suitable for a variety of form files, which give designers the ability to add custom scripting, control the run-time behavior, and integrate custom forms directly with a server or Web service. With the Microsoft Office InfoPath 2003 Toolkit for Visual Studio® .NET, which can be downloaded from the Microsoft Developer Network (MSDN) website, you can use Microsoft Visual Studio .NET 2003 to create, debug, and build InfoPath projects that use managed code built in Microsoft Visual C# or Microsoft Visual Basic.
Integration with the Microsoft Office System and other Microsoft products. InfoPath XE “InfoPath:Office integration”  is integrated with other Office and Microsoft products to provide additional functionality. For instance, InfoPath can be used in conjunction with SharePoint as a way to increase team collaboration by providing a single location for InfoPath forms to be stored and shared. InfoPath can also export information to Microsoft Excel, and InfoPath forms can be shared through Microsoft Office Outlook®. Forms, including completed forms, can be exported to a Web page format and viewed (in a read-only form) by an individual using Microsoft Internet Explorer. 
Other familiar features include:
· Dr. Watson XE “Dr. Watson support”  support. InfoPath includes support for Dr. Watson, which allows users to send data back to Microsoft if detailed information is necessary for support or troubleshooting.
· Help support. Users can get assistance on features by using the standard Office Help task pane and by typing queries in the “Type a question for help” box on the menu bar. In addition, users who are connected to the Internet can search for up-to-date help, templates, training, or additional online content on Microsoft Office Online. The InfoPath Help menu also provides a link to resources on the Microsoft Developer Network (MSDN). MSDN offers a solution developer’s kit (SDK) and other development content to help solution designers create form templates. 
· Product tour. InfoPath has product tour to help users learn more about the functionality of the product.
· Terminal Services XE “Terminal services support”  support. InfoPath can be run as an application delivered through Terminal Services running on Microsoft Windows Server.
· Windows Logo requirements. InfoPath meets all Windows Logo requirements.
· Tablet PC support. If you use a tablet pen to fill out forms, you can write directly in fields on the form, and then convert that ink to text. Depending on the design of your form, you can also add handwritten notes or drawings to certain fields, and then save the ink along with your form. If you design forms for Tablet PC users, you can now specify background pictures for ink picture controls. 
InfoPath has been internationalized to support organizations and users in a wide range of locations, including Asia, South America, and Europe.
InfoPath Feature Enhancements in Office 2003 Service Pack 1 ( XE “Enhancements in Office 2003 SP1)" 
[image: image84.emf]The release of the InfoPath feature enhancements in Office 2003 Service Pack 1 extends and enhances the core functionality built into the initial release of the product. The enhancements to InfoPath in Office 2003 SP1 are flagged in this guide with the button and include:

· New and improved controls

· Better ways to work with data

· Improved support for data connections

· Microsoft Visual Studio .NET 2003 integration

· Layout enhancements

· Better integration with existing business processes, such as Microsoft BizTalk Server 2004 Human Workflow Services
· Printing improvements, including page breaks, margin, and print settings
InfoPath 2003 enhancements in Office 2003 SP1 (SP1) provide support for rules, data validation, and expanded conditional formatting. SP1 supports the creation of forms using languages that run right-to-left as well as left-to-right (even in the same form). It has enhanced support for secondary data sources, and includes support for value calculations within a form. SP1 enhances support for ink and Tablet PCs, digital signatures, Microsoft ActiveX controls, document recovery, ADO.NET DataSets, and SharePoint data connections. It also expands deployment security offerings to increase the security with which organizations can deploy forms.
InfoPath in Action
Converting Data to Knowledge  XE “InfoPath:Benefits:Converting data to knowledge” 
When organizations gather data via traditional forms, they often lose the context that accompanies that data—the salesperson’s personal knowledge of a comment that a client made during a meeting, for example. Organizations end up collecting data, but not knowledge. Unlike simple form-creation programs, InfoPath is a flexible information-gathering application that enables people to connect data with context. By enabling a user to expand and collapse entire groups or sections of the form, adding comments and context, InfoPath helps an organization capture more knowledge. With that knowledge, people throughout the organization can make faster, well-informed decisions. 
InfoPath forms are flexible and highly dynamic. They can be designed with optional sections or with sections that expand and repeat as necessary. A purchase order form, for example, could be designed to present an initial display of only one line item to be purchased—but additional lines could be added by the individual filling out the form simply by clicking a button on the form. Forms can also be designed to include hidden sections which will appear in the form only when the user performs a specific action or provides information that fulfills specific conditions. 
	Feature
	Description
	Invocation

	Repeating and Optional Sections, Tables, and Choice Groups
	

	Repeating Sections

[image: image1]
 XE “InfoPath features:Repeating sections" 
	InfoPath forms can include sections, tables, recursive sections, and choice groups that repeat. The initial form view starts with one instance of a repeating control, and users can add more sections when and if necessary.
The Repeating Section, Repeating Table, Repeating Recursive Section, and Repeating Choice Group controls enable form designers to identify form components that the users can repeat when filling out a form. InfoPath includes support for hint text beneath a repeating control. This hint text can be customized by the form designer.

	To include a repeating section, repeating table, repeating recursive section, or choice group in a form, the form designer can drag the appropriate control from the Controls task pane to the desired location in the form (see Figure 1 in the screen shot appendix).
To add more instances of a repeating control while filling out a form, the user simply presses Ctrl+Enter at the end of a table or section and another row or section is added.  XE "How to...:Add repeating sections" 
Alternatively, the user can click on the shortcut menu button in the margin of a row in a repeating section (see Figure 2 in the screen shot appendix) or add a section by selecting a command from the right-click context menu, or from the Section submenu in the Insert menu.

	Optional Sections XE “InfoPath features:Optional elements and sections" 

	Form designers can add optional sections. These sections can be called up by following a prompt specified in the properties for the section. A user might see the prompt, “Click here to insert a Time Report” at the bottom of a Status Report form. By clicking on that prompt, the form will display the optional time report, which would not otherwise be visible. 
This control enables designers to identify data sections that will be added on demand by the end user.
	Select the Optional Section control from the Controls task pane. 
Using the Show insert button and hint text option in the Section Properties dialog box, they can create instructional text (such as “Click here to insert a Time Report”) that tells the form user how to add the optional section.  XE "How to...:Add optional sections" 

	Filters
	

	Filtering information in repeating sections

[image: image2]
	Form designers can create filters that enable users to work with subsets of entries in a repeating section or a repeating table (see Figure 6 and Figure 7 in the screen shot appendix). A filtered repeating section or table displays only the rows that meet conditions specified in the properties of these controls. The conditions can be either static (when, for example, the form designer always wants to display employee records for employees working in a particular office), or dynamic (the person filling out the form will be able to choose from a list control the location of the employees whose records he or she wants to see). List box filters can be created manually, automatically derived from other values in a form, or automatically derived from an external data source such as a database, a Web service, a file, or a SharePoint library or list. 
The condition builder enables a designer to build filters based on the value in a field, a user’s role in the organization (as defined in Active Directory directory services), or whether a specified data block has been digitally signed. Boolean operators and extensions enable a designer to set the parameters of the condition; extensions to the Boolean operators include pattern matching operators (e.g., phone number, zip+4, social security number, and others, including designer-defined patterns). Condition builder options are the same for filters, data validation, conditional formatting, and rules.
	Filters typically work with a combination of a drop-down list and a repeating table or repeating section in which to display the filtered information.
By editing the properties dialog box for the list, a designer can create the list that is used to filter data (see Figure 3 in the screen shot appendix). 
By double-clicking the repeating section or repeating table and selecting the Display tab, the designer can specify filter conditions for the control (see Figure 4 and Figure 5 in the screen shot appendix).  XE "How to...:Using filters" 

	Cascading Lists using Filters

[image: image3]
	Designers can use InfoPath filters to create cascading lists—that is, a list box or drop-down list whose values depend on the selected value in another list. For example, one drop-down list might offer a list of countries where a company has offices. A second drop-down list might list the cities where those offices are located. Using a filter, the country selected in the first drop-down list can constrain the second drop-down list to present only the cities in the selected country. 
	To filter information in cascading lists, designers must create the two lists on the page by dragging the drop-down list or list box controls to the desired location. They must also create or identify the data source that identifies both the countries and the cities within those countries where the offices reside.
By selecting options on the Data tab in the Properties dialog box for the first list, the designer can identify the values to display in the list (see Figure 8 in the screen shot appendix). Designers can enter values manually or they can bind the list to another data source. 
By selecting options on the Data tab in the Properties dialog box for the second list, the designer can identify a data source containing the information about the office locations. Using a filter, the designer can constrain the values presented in the second list (see Figure 9 in the screen shot appendix).  XE "How to...:Creating cascading lists" 

	Managing by Condition 
	

	Conditional Formatting, Visibility, and Disabling 

[image: image4]
	Form designers can apply conditional formatting to the majority of controls, causing them to appear in specific ways when one or more specific conditions are met. Form designers can use the condition builder to specify whether a control is shown or hidden, disabled, or presented with specific formatting. The condition builder enables a designer to control formatting and control presentation based on the value in a field, a user’s role in the organization (as defined in Active Directory services), or whether a specified data block has been digitally signed. Boolean operators and extensions enable a designer to set the parameters of the condition; extensions to the Boolean operators include pattern matching operators (e.g., phone number, zip+4, social security number, and others, including designer-defined patterns). 
Certain controls (including repeating sections and tables, recursive sections, lists, choice groups, and master/detail controls) enable the form designer to specify whether a user can insert or delete the control.
	By opening the properties dialog box for a control and then clicking the Display tab, the designer can create and control conditional formatting. If specified conditions are true, the field can be formatted to display specific font characteristics, font colors, or shading. By selecting the Hide this control, Disable this control or Don’t allow users to insert or delete this control check boxes in response to specified conditions, the control will respond as indicated if the conditions are true (see Figure 10 in the screen shot appendix). Text Box, Rich Text Box, and Date Picker controls support Read-only as an additional response.
 XE "How to...:Conditional formatting"  XE "How to...:Disabling controls" 

	Defining Conditional Rules

[image: image5]
	SP1 provides enhanced functionality based on specified conditions. Using the condition builder, a designer can identify the circumstances in which one or more actions will take place. The condition builder enables a designer to build conditions based on the value in a field, a user’s role in the organization (as defined in Active Directory services), or whether a specified data block has been digitally signed. Comparative, logical, and pattern matching constraints enable a designer to set the parameters of the condition. Once the designer has defined the conditional rules, he or she can define the action to be taken in response to those conditions. Actions range from presenting a dialog box and switching the view to submitting a form, querying a database, and opening and closing a new form.
	By clicking the Rules button on the Properties page of the selected control, a designer can specify the conditions that will apply to that control (See Figure 11 in the screen shot appendix). After defining the condition, the designer can specify the action to be taken in response to the condition (see Figure 12 in the screen shot appendix).  XE "How to...:Working with rules " 


Increase Efficiency XE "InfoPath:Benefits:Increasing efficiency" 
InfoPath provides an efficient and accurate way to collect information and make well-informed decisions XE "InfoPath:Benefits:Better decision-making" .
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Designers can create rich, highly dynamic forms with little or no coding— saving valuable development time and money. At the same time, designers who want to incorporate managed code into their InfoPath projects can use the Microsoft Office InfoPath 2003 Toolkit for Visual Studio .NET to streamline their development efforts.
· InfoPath forms can validate data to help ensure that the information being gathered is accurate and meets the organization’s business criteria—avoiding costly errors. 
· Organizations can gather information in a manner that is consistent and that suits the needs of the team or organization.
Because InfoPath provides powerful data and schema validation features, InfoPath forms help ensure that the data you collect can be used efficiently within your organization. The forms can require specific fields to adhere to specific formats and can flag fields that have incorrectly formatted information. And because the information gathered through InfoPath is stored as XML data that can be readily passed to any process that accepts XML input, the information gathered through an InfoPath form can be quickly and efficiently entered into the key processes supporting your organization—without rekeying that information and running the risk of data reentry error.
InfoPath also provides a way to gather information consistently. A sales manager might want to collect contact information and travel itineraries for a large team of sales representatives. By sending out an e-mail message with this request, the manager may get contact information and travel itineraries returned in 50 different ways—some of which will not even be complete. By sending out an InfoPath form, the representatives will return information in a form that is consistent and complete.
Conversely, InfoPath enables the creation of forms that can present information from multiple data sources. A form might derive its basic schema from an existing database in the organization, but it might populate individual drop down lists within the form with data derived from a secondary source such as a set of SharePoint lists.
InfoPath supports a broad range of XML-related technologies, which enables an organization to capitalize on existing investments and which enables form designers to create forms that can quickly and easily link users with business processes. Some of the technologies and standards that InfoPath supports include:
· W3C standards XE “InfoPath features:W3C standards" . InfoPath is built on non-proprietary industry standards such as XML 1.0 SE, Namespaces in XML, DOM 1.0, XML DSIG, XML Schema Part 1: Structures and Part 2: Datatypes, XSLT 1.0, XHTML 1.0, UDDI 1.0, WSDL 1.1 and SOAP 1.1.  XE "InfoPath features:Support for any W3C schema" 

 XE "Schema:Support for any W3C schema" 
· Object Models (OM). InfoPath supports the Document Object Model (DOM), the Canvas OM, and OMs for validation, submit, and other actions.  XE "Form development:DOM support” 

 XE “Form development:OM support” 
InfoPath also provides support for Microsoft JScript and Microsoft Visual Basic Scripting Edition (VBScript), enabling designers to use the scripting models with which they are already familiar to further enhance the rich functionality of InfoPath forms.
	Feature
	Description
	Invocation

	Validation
	

	Real-Time Schema Validation XE “InfoPath features:Schema validation” 

 XE “Schema:Validation” 
	InfoPath provides client side-validation and error reporting on the data and structure of a form being developed. If the schema calls for a numeric entry in a field and a user enters an alphabetic entry, InfoPath will alert the user of an error inline. 
	InfoPath performs validation automatically based on the characteristics of the schema. No designer or user invocation is required.

	Built-in Validation Rules

[image: image6]
 XE “InfoPath features:Validation rules”  XE "InfoPath:Enhancements in Office 2003 SP1:Rules" 
	InfoPath provides the ability to create custom (business logic) validation through the user interface. InfoPath provides both inline and dialog box alerts. Form designers can add one or more validation requirements for any given control using the condition builder. The condition builder enables a designer to build filters based on the value in a field, a user’s role in the organization (as defined in Active Directory services), or whether a specified data block has been digitally signed. Boolean operators and extensions enable a designer to set the parameters of the condition; extensions to the Boolean operators include pattern matching operators (e.g., phone number, zip+4, social security number, and others, including designer-defined patterns). Condition builder options are the same for filters, data validation, conditional formatting, and rules.
	In design mode, select a field or control and open its Properties dialog box. Select the Data tab and click the Data Validation button. Click the Add button to create the validation criteria, the alert type, and message text for that field.  XE “How to...:Create or modify validation rules" 

	Real-Time Custom Validation XE “InfoPath features: Field validation" 
	In addition to the real-time schema validation and built-in validation rules described above, InfoPath also enables forms designers to specify complex real-time client side-validation and error reporting through the use of code. Form designers can have InfoPath validate input against custom-defined business requirements. Designers can write code based on a range of predefined events, including events triggered by changes in form data.
Designers can control whether the error alert will be an inline alert, which identifies errors by highlighting the non-compliant field and offers a screen tip and an optionally displayed error message, or a dialog box alert, which immediately displays an error message and rejects the non-compliant input.
	Real time validation is automatic when data validation criteria have been applied to a field or control. As the user enters information in the form, InfoPath automatically validates it.
Form designers can indicate whether an alert will be an inline alert or a dialog box alert from within their code.  XE "How to...:Validation alerts, setting up" 

	Form Design
	

	Form Design from Scratch, from an Existing Customer-Defined Schema, from a New Data Connection, or an XML file

[image: image7]
 XE “InfoPath features:Designing forms with generic schema" 

 XE "Schema:Designing from a generic schema"  XE "InfoPath:Enhancements in Office 2003 SP1:Support for any W3C schema" 

	InfoPath enables designers to create forms from scratch, from any W3C schema, or from an organization’s existing schema. Schema can be an existing XSD, random XML snippets, or derived from an existing database or Web service. InfoPath includes data connection tools that make it easy to connect to Web services that use ADO.NET DataSets.
If building a form from scratch, form designers can drag controls onto their form, and InfoPath creates a schema behind the scene.

	To build from an existing schema, open the Design a Form task pane in design mode. Click either New from XML Document or Schema or New from Data Connection, and then browse for the .xsd file, .xml file, database, or Web service you want to work with (see Figure 13 in the screen shot appendix). XE "How to...:Design forms" 
To build a form from scratch, open the Design a Form task pane in design mode, and then click New Blank Form. Designers can then drag controls from the Controls task pane (see Figure 14 in the screen shot appendix). As they do this, InfoPath creates the XML schema in the background. XE "How to...:Design forms" 

	Main and Secondary Data Sources

[image: image8]
 XE "InfoPath:Enhancements in Office 2003 SP1:Secondary data sources" 
	InfoPath enables designers to make use of multiple data sources when building and presenting forms with rich functionality. A form’s main data source corresponds to the groups and fields containing the data that underlies the form and is saved as the form file. When an end user fills out the form, the controls display the actual data in the main data source, and allow the data to be updated during editing. 
InfoPath also enables designers to bind most controls to secondary data sources. Form designers can link one or more secondary data sources to a given form. Information from secondary data sources is not saved with the main data source.
	Form designers can specify an existing data source as the main data source when creating a form by clicking New from XML Document or Schema or New from Data Connection on the Design a Form task pane. If the form designer chooses the New Blank Form option, InfoPath will create a main data source from scratch.
To add one or more secondary data sources to a form, click Data Connections on the Tools menu. In the Data Connections dialog box, click Add, and follow the steps in the wizard.  XE "How to...:Working with main and secondary data sources" 

 XE "Data sources" 
The Data Source task pane provides a list of available data sources, so that the form designer can see both the main data source and any secondary data sources. The groups and fields from secondary data sources can be dragged onto the form, in the same manner as groups and fields from the main data source, in order to create controls in the view for displaying or editing that data.

	WYSIWYG Form Design

[image: image9]
 XE “InfoPath features:WYSIWYG design tools"  XE "InfoPath:Enhancements in Office 2003 SP1:Design mode enhancements" 

	InfoPath provides a “what you see is what you get” (WYSIWYG) design environment, with layout control features that enable designers to create forms quickly and easily. InfoPath provides a Layout Tables task pane that enables designers to add tabular sections to lay out the form quickly, just as in Web design. The task pane also offers features to split and merge cells to make the modifications of the inserted tables easier.
InfoPath provides powerful paragraph formatting capabilities, which enable a form designer to specify alignment, background color, indentation, and spacing settings for cells and tables within a form.
InfoPath also includes the Symbol dialog box, which makes it easy for form designers to include a wide variety of symbols, accented characters, mathematical operators, and decorative characters, such as those included with Wingdings, in a form. 
Additionally InfoPath includes a table-drawing tool, which helps form designers quickly draw custom tables — for example, one that contains cells of different heights or a varying number of columns per row.
	When in InfoPath design mode, select the Layout Table task pane (see Figure 15 in the screen shot appendix).  XE "How to...:WYSIWYG design mode" 
To change paragraph or spacing characteristics for text, select the Paragraph task pane (see Figure 16 in the screen shot appendix).
To copy text formatting from one location to another, click Format Painter ([image: image10.png]


) on the Standard toolbar.
To draw a table, click Draw Table on the Table menu.

	Right-to-Left Language Formatting Support

[image: image11]
 XE "InfoPath:Enhancements in Office 2003 SP1:Right-to-left language support" 
	Microsoft InfoPath supports left-to-right as well as right-to-left text orientation. It also provides features designed to support languages that work in a right-to-left or a combined right-to-left, left-to-right environment for text entering, editing, and display.
	To change the form direction, click the appropriate Form Direction button ([image: image12.png]


) in the Formatting toolbar or the Format menu. Designers can orient individual paragraphs with the appropriate Paragraph Direction button ([image: image13.png]


)in the Formatting toolbar or in the Format menu.  XE "How to...:Using right-to-left language orientation" 
To change the direction of a control, open its Properties dialog, and choose the Display tab.
To change the direction of a table, open the Table Properties page from the Table menu. 

	Tree-Type Schema Representation with Drag-and-Drop XE “InfoPath features:Schema representation" 

 XE "Schema:Representation" 
 XE “InfoPath features:Drag and drop from schema " 

 XE "Schema:Drag and drop fields or groups in form" 
	InfoPath represents XML schema in a branching tree format for easy identification of relationships and dependencies.
When developing a form, designers can drag an element from the schema displayed in the task pane and drop it into the form; InfoPath automatically determines the type of data represented by the schema and inserts the appropriate default control.
	In InfoPath design mode, select an XML field or group from the Data Source task pane and drag it to the desired location in the form (see Figure 17 in the screen shot appendix).  XE "How to...:Drag and drop schema objects" 

	Basic Schema Editing  XE "Schema:Editing"   XE “InfoPath features:Schema editing" 

	InfoPath enables designers to name, move, or change the data type of fields and groups if the user started from scratch or if the schema allows this type of change. 
	To add a field or group, open a form in design mode, select a field or group from the Data Source task pane, and then click Add. In the Add Field or Group dialog box, enter information about the new field or group (see Figure 18 in the screen shot appendix).
To edit an existing field or group, open the Data Source task pane, and then double-click the field or group to open the Field or Group Properties dialog box.
To move a field or group, open the Data Source task pane, and then click the arrow next to the field or group you want to move. On the menu, click Move. Select the desired location in the Move Field or Group dialog box.  XE "How to...:Edit schema " 

	Color Schemes XE “InfoPath features:Form color schemes" 
	InfoPath has numerous color schemes that can be applied to any form created in the design mode, including the sample forms that come with InfoPath. 
	In InfoPath design mode, open the Color Schemes task pane and click the desired color scheme.  XE "How to...:Color schemes" 

	Editing Preview XE “InfoPath features:Previewing forms" 

	Form designers can preview their form design to see how end users will interact with the form without actually having to leave the InfoPath design mode.
	In design mode, click Preview Form on the Standard toolbar. Or, on the File menu, point to Preview Form, and then select the option you want.  XE "How to...:Preview forms in design mode" 

	Fill out a Form Dialog Box

[image: image14]
 XE "InfoPath:Enhancements in Office 2003 SP1:User interface enhancements" 
	InfoPath has an enhanced interface for organizing, opening, and updating forms. The new Fill Out a Form dialog box replaces the Fill Out a Form task pane as the place to select forms. It offers immediate access to favorites, custom categories, and recently used forms. It also allows users to update form templates before going offline. Additionally, it provides a link to design mode as well as to the animated product tour that is designed to help novice users learn how to use InfoPath.
	The Fill Out a Form dialog box appears when opening InfoPath, when selecting Fill Out a Form from the File menu, or when closing the last form currently open in InfoPath (see Figure 19 in the screen shot appendix). Users can simply click the form they want to fill out, design, or update.



	Forms Design: Controls
	

	Standard Control Toolbox XE “InfoPath features:Controls" \t "See InfoPath Controls" 

 XE “InfoPath controls:Standard toolbox"

	InfoPath includes all the controls that designers expect from a forms design package—from text box and drop-down list box controls to controls for rich text boxes, option buttons, numbered and bulleted lists, hyperlinks, pictures, expression boxes, as well as optional and repeating sections.

	In design mode, form designers can open the Controls task pane and gain ready access to all the controls (see Figure 14 in the screen shot appendix). 
Designers building a form from scratch need only drag the controls onto their form; InfoPath automatically creates the XML schema in the background.  XE "How to...:Controls:Accessing" 

	Managing Controls XE “InfoPath controls:Converting controls"

 XE “InfoPath controls:Rebinding controls"

 XE “InfoPath controls:Automatic label insertion"
	InfoPath enables designers to convert a control from one type to another. It also enables designers to rebind a control to a different field or group in the schema. InfoPath also automatically converts control labels from their unfriendly schema format names (such as “FirstName”) to a human readable format (“First Name”) after drag-and-drop of an element from the data source into the view.
	In design mode, right-click the control to be converted. On the shortcut menu, click Change to.  XE "How to...:Controls:Converting" 
In design mode, right-click on the control to be rebound. On the shortcut menu, click Change Binding.  XE "How to...:Controls:Rebinding" 

	Customize Control Properties XE “InfoPath controls:Customizable control properties"

[image: image15]
 XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	InfoPath provides designers with an interface for changing the characteristics of controls. For example, the form designer can customize the scrolling behavior, wrapping behavior, and default text associated with a text box. InfoPath also provides the ability to enable or disable AutoComplete or the spelling checker for text fields. Within text boxes and other controls, designers can specify maximum line lengths, whether to support paragraph breaks, and whether to align text vertically with surrounding text and labels.
	In design mode, right-click the control to be customized, and then choose Properties. In the Properties dialog box, click the Display tab to customize non-font parameters (see Figure 20 in the screen shot appendix). 
 XE “How to...:Controls:Customizing properties" To specify display font parameters, select the control and choose the display font characteristics from the Font task pane.

	Deriving Form Values using Formulas 

[image: image16]
 XE "InfoPath:Enhancements in Office 2003 SP1:Using formulas and form values" 
	InfoPath enables form developers to use existing form values and complex formulas to calculate values for specific fields. 
	To enter a formula in the default value field of a control, click the Data tab on the control’s property dialog box (see Figure 21 in the screen shot appendix). Click the formula button (fx) and use the Insert Formula dialog box (see Figure 22 in the screen shot appendix) to construct the formula. Form designers can click the Insert Field or Group and Insert Function buttons to facilitate formula creation; the Verify Formula button tests and validates the formula.  XE "How to...:Work with formulas" 
InfoPath formulas are simplified views of XPath expressions. To view the XPath expression or to edit it directly, select the Edit XPath check box on the Insert Formula dialog box.

	Population of List Box Controls from Form Values or a Database Lookup XE “InfoPath controls:Database source support"

[image: image17]
 XE "InfoPath:Enhancements in Office 2003 SP1:Data connections" 
	List box controls can be populated with manually entered data, data that exists elsewhere in a form, or data gathered from a backend source (such as a database or SharePoint list). InfoPath can gather data from one or more data sources.
	In InfoPath design mode, right-click on the control to be populated. Select Properties and in the List Box Entries portion of the dialog box that appears, identify the source from which the information should be drawn. Designers can browse for a specific database, Web service, or file from which to populate the control.  XE "How to...:Populate control values from a database" 

 XE "How to...:Populate controls with existing form values" 
To populate a control from a source other than the main data source, click Data Connections on the Tools menu. A data connection wizard guides the designer through the process of integrating secondary data sources.

	Button Controls with Built-in and Rule-based Behaviors XE “InfoPath controls:Button behavior "

[image: image18]
 XE "InfoPath:Enhancements in Office 2003 SP1:Rules" 
	InfoPath provides designers with button controls that are predefined. With a predefined button for submitting form data, for example, a form designer need only specify the database, Web service, or server to which the data should be sent; there is no complicated coding involved. Similarly, the designer need only specify a database, Web service, or server in order to instigate a query that will result in form data being gathered. The complexities of creating the query have already been taken care of. 
When using a button to submit to a Web service, a wizard enables the form designer to specify whether to submit only a selected node and its contents, only the contents of the node, the entire InfoPath form (including processing instructions), or the contents of the form as a string. Form designers can also specify whether upon submission the form should be closed, remain open, or whether a new form should be opened. 
Form designers can also choose to direct button behavior through the use of rules. Using the condition builder, a designer could define a rule that causes a Submit button to send a form to one user as an e‑mail attachment if certain conditions exist—but to another user if other conditions exist.

	Buttons can be placed in a form by dragging the Button control from the Control task pane to the view. 
By right-clicking the control and selecting the Button Properties dialog box, the designer can specify whether the button will run code or perform a custom action based upon one or more rules, refresh one or more secondary data sources, or submit the form to a Web service, a URL, or other destination (see Figure 30 in the screen shot appendix).  XE "How to...:Submitting data, managing behavior " 
To specify submission characteristics for submitting to a Web service, the designer can follow the steps in the Data Connection wizard by clicking the Add button on the Submitting Forms dialog box.

	Support for Custom Controls

[image: image19]
 XE "InfoPath:Enhancements in Office 2003 SP1:ActiveX controls" 
	InfoPath supports hosting ActiveX controls in forms. These can be pre-existing ActiveX controls (with some constraints) or ActiveX controls written specifically for InfoPath. ActiveX Controls written for InfoPath can manipulate the XML data directly to provide unique views on the data or to modify the data in ways that your business requires.
	To add an ActiveX control, click Add or Remove Custom Controls on the Controls task pane (see Figure 24 in the screen shot appendix), By following steps in the Add Custom Control Wizard, the form designer can specify binding options for the control.  XE "How to...:Add ActiveX controls" 


	Standard Controls 
	

	Text Box
	Used for gathering input that does not require complex formatting.
	These controls are available from the Controls task pane (see Figure 14 in the screen shot appendix) in the design mode.
Certain controls are also available from the Insert menu. XE “InfoPath features:Controls" 

 XE "Form development:Controls" 

	Rich Text Box
	Used for gathering input that requires support for paragraph breaks, font formatting, images, tables, etc. 
Note that the data in a rich text box is stored as a single entity in the resultant XML file. If the data collected in the list or table needs to be easily parsed on the back end, the designer should use other controls.
	

	Drop-down List Box
	Used for displaying a drop-down list.
	

	List Box
	Used for displaying a scrollable list.
	

	Date Picker (Calendar Control)
	Used for selecting dates from a calendar.
	

	Check Box
	Used for controlling a set of two options.
	

	Option Button
	Used for controlling a set of two or more options.
	

	Button
	Used to insert a button on a form for running custom code, refreshing one or more secondary data sources, or submitting a form. Buttons can also perform more complex actions using rules.
	

	Section
	Used for delineating simple data sections. Other controls can be inserted inside this section.
	


	Repeating and Optional Controls
	

	Optional Section
	Used to create sections that may or may not appear in the form, depending upon the conditions specified by the form designer and/or the needs of the user.
	These controls are available from the Controls task pane (see Figure 14 in the screen shot appendix) in the design mode.

Certain controls are also available on the Insert menu.

	Repeating Section
	Used to create sections that can be repeated by the user when filling out a form.
	

	Repeating Table
	Used to help form designers create tables that are explicitly bound to data elements in the schema. A form designer would use a repeating table control when the data in the table needs to be processed on the back end.
	

	Master/Detail


[image: image20] XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	Used to manage large amounts of data efficiently. For example, a form that lets a human resources department manage employee records can contain a number of fields describing each employee. The Master/Detail control enables the form to display minimal information about each employee and allow more detailed information to be accessed from this abbreviated list.
	

	Bulleted List

	Used for creating an input field formatted as a bulleted list that is bound to an element in the schema.
	

	Numbered List
	Used for creating an input field formatted as a numbered list that is bound to an element in the schema. 
	

	Plain List

	Used for creating an input field formatted as a plain list that is bound to an element in the schema. 
	


	File and Picture Controls
	

	File Attachment


[image: image21] XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	Used for enabling a user to attach a file to a form.
	These controls are available from the Controls task pane (see Figure 14 in the screen shot appendix) in the design mode.

	Picture
	Used for enabling a user to import a picture and bind it to the form.
	

	Ink Picture
	Used to enable Tablet PC users to incorporate ink-based input.
	


	Advanced Controls 
	

	Hyperlink

	Used to insert a hyperlink bound to data in the form.
	These controls are available from the Controls task pane (see Figure 14 in the screen shot appendix) in the design mode.



	Expression Box (Static Text Control)


	The expression box control displays simple XML data or a transform on that data (such as the merging of two nodes). It is a read-only control that displays in the form.
	

	Vertical Label
	Used to insert vertical text in a form.
	

	Scrolling Region
	Used to create a fixed-sized scrollable region in the form. 
	

	Choice Group

 SHAPE  \* MERGEFORMAT 



 XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	Used to enable a user to replace one section with another section when completing a form. For example, choice groups allow the selection of two different address options: an option for international addresses and an option for addresses in the United States.
	

	Repeating Choice Group


[image: image23]
 XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	Used to enable the use of many choice groups, depending on the user’s requirements.
	

	Choice Section


[image: image24]
 XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	Used to add more choices to a choice group or repeating choice group control.
	

	Repeating Recursive Section
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 XE "InfoPath:Enhancements in Office 2003 SP1:Controls" 
	Used to create recursive structures of arbitrary depth. Recursive sections have the same properties as an ordinary section except that digital signatures are not allowed. The only property that can be set in the internal recursive block is the default value of the XML fragment for the further recursive sections inserted within the outermost instance.
	


	Development 
	

	Integration with Microsoft Visual Studio .NET 2003

[image: image26]
 XE "InfoPath:Enhancements in Office 2003 SP1:Visual Studio .NET 2003 integration" 
	SP1 enables managed code support for business logic. Designers can use Visual Studio .NET 2003 to create, debug and build InfoPath solutions that make use of C# or Visual Basic. Designers can use Visual Studio to write the form’s code, and Visual Studio interacts with InfoPath designer as an external form development application. Designers can then build a project in debug or release mode. They can create new form templates or re-use existing ones to add managed code business logic (see Figure 25 in the screen shot appendix).
	To make use of the integration between Visual Studio .NET and InfoPath, the form designer must first install Microsoft Office InfoPath 2003 Toolkit for Visual Studio. NET.  XE "How to...:Working with Microsoft Visual Studio .NET 2003" 
To design InfoPath form templates using managed code, open Visual Studio .NET and take the following steps:
Select New Project from the File menu
On the New Projects dialog box, select Project Types.
Under Microsoft Office System Projects click either Visual Basic Projects or Visual C# Projects, depending on the language you need.  XE "Form development:Visual Basic projects" 

 XE "Form development:Visual C# projects" 
Select InfoPath Form Template under Templates.
Select Create New Form Template if you want to create a new, blank form.
Select Open Existing Form Template and select the form template using Browse if you want to create a project from an existing form template.

	Resource Management XE "Form development:Resource management" 
	InfoPath enables designers to add resources (DLL files, secondary XML files, etc.) to a solution.
	In design mode, click Resource Manager on the Tools menu. In the Resource Files dialog box, the form designer can add, remove, rename, or export resource files.  XE "How to...:Manage resources" 

	Roundtrip Form Template Changes Made Outside InfoPath XE “Form development:Hand-editing sections" 
	InfoPath enables designers to hand-edit their Extensible Stylesheet Language Transformation (XSLT) within blocks marked “verbatim” and subsequently work on those files again in the designer. All of the changes are retained and the blocks are clearly marked in the designer to indicate that these are hand-edited sections. Designers can also hand-edit the manifest.
	Designers can edit their XSLT in a text editor such as Microsoft Notepad or the Microsoft Visual Studio® development environment. Any text between blocks marked “verbatim” will be retained exactly as written when the file is opened in InfoPath XE "How to...:Manually edit XSLT" .

	Extract Form Files XE “Form development:Save as a folder
	Form designers can view and work with a form template's form files by saving them to a folder. The Extract Form Files feature saves the form files to a folder, which allows designers to manually make changes to individual files
	In design mode, click Extract Form Files on the File menu. InfoPath prompts the designer for a location for the folder.  XE "How to...:Export forms" 

	Custom Editing Behaviors
	Form designers can add repeating sections to their forms and control exactly which fragment of XML gets inserted when end users add a section. Additionally, form designers can specify where the user interface options for inserting these sections appear in the menus. They can even create a form-specific toolbar for exposing these commands.
	In design mode, right-click the Repeating Section control and choose Properties. On the Data tab, click Modify and Edit Default Values to change the fragment of XML that is inserted. To change the default user interface location or to add these commands to a form-specific toolbar, click Customize Commands.

	Custom Dialog Boxes XE “Form development:Custom dialog boxes" 
	Form designers can create custom HTML dialog boxes for their form solutions. By linking these custom dialog boxes through scripts or managed code, a form designer can add, for example, custom wizards or data catalogs.
	Form designers can use any HTML editing tool to create custom dialog boxes. They can be linked into forms through scripts or managed code attached to InfoPath events such as onBeforeChange, onValidate, or onAfterChange.


	Custom Task Pane XE “Form development:Custom task pane" 
	Form designers can create a custom HTML task pane for their form template, leveraging Office task pane infrastructure.
	In design mode, click Form Options on the Tools menu. In the Form Options dialog box, click the Advanced tab and check Enable custom task pane. InfoPath prompts the designer to provide a name and location for the custom task pane.  XE "How to...:Task pane customization" 

	Built-in Script Tool and Debugger XE “Form development:Debugger" 

[image: image27]
 XE "InfoPath:Enhancements in Office 2003 SP1:Visual Studio .NET 2003 integration" 
	Designers choosing not to make use of Microsoft Visual Studio .NET 2003 can use Microsoft Script Editor (MSE), which is integrated into InfoPath.
InfoPath supports both the Microsoft Visual Basic® Scripting Edition (VBScript) language and Microsoft JScript®.  XE “Form development:Coding support" 

 XE “Form development:Microsoft JScript" 

 XE “Form development:Microsoft Visual Basic Scripting Edition language" 
	In design mode, point to Programming on the Tools menu, and then click Microsoft Script Editor. 
Script editor (MSE) does not provide XE "How to...:Code, editing and debugging"  integrated debugging. In order to debug you need to add the ‘debugger’ (JScript) or ‘stop’ (VBscript) statement in the code when you want the debugger to be invoked.

	Disabling InfoPath Menu Options
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 XE "InfoPath:Enhancements in Office 2003 SP1:Disabling InfoPath features" 
	Form designers can disable certain InfoPath options and features, including the following:
Save and Save As
Export to Web
Export to Microsoft Office Excel
Print
Send to Mail Recipient
Autosave (AutoRecover)
By disabling certain commands, a designer can ensure, for example, that a form intended for submission only cannot be saved or sent in an e‑mail message to another user. 
	To enable or disable user access to InfoPath features, click Form Options on the Tools menu. In the Form Options dialog box, select the Open and Save tab.
Developers can use custom code to override the Save command by selecting the Save using custom code check box on the Open and Save tab, and then inserting custom code.

	Software Developers Kit
	

	Advanced Sample Forms
	The Software Developers Kit for Microsoft Office InfoPath 2003 (SDK) provides sample forms for interoperability with Microsoft SQL ServerTM 2000 and Microsoft BizTalk® Server, as well as SharePoint, and Excel.  XE "InfoPath:Sample forms" 
	In design mode, click Open on the File menu. In the Open dialog box, browse to <drive>:\Program Files\Microsoft Office 2003 Developer Resources\Microsoft Office InfoPath 2003 SDK\Samples\, which is where the Microsoft InfoPath SDK installs developer forms by default.  XE "InfoPath:Solution developer kit (SDK)" 



Share Information Throughout the Organization 
 XE "InfoPath:Benefits:Share information throughout the organization" InfoPath makes it easy for organizations—or teams within an organization—to reuse and repurpose the information collected across business processes. Because it is based on XML, the information captured in InfoPath forms can be shared with any process that makes use of an XML schema. Also, InfoPath helps make it easier to integrate information with business processes because the application has built-in support for Web services and interoperability with XML-enabled servers and databases.
Moreover, InfoPath enables the creation of forms that can be used to share information across many different processes. A single trip report form, for example, can provide properly formatted XML data to a CRM system that has one XML schema, a petty cash system that relies on another XML schema, a travel planning system that uses yet another schema, and so on. All the information required by each of these systems can be captured once in an InfoPath form and disseminated—through a Web service, through an http call, or through script or managed code—to each of the appropriate systems, without rekeying or redundant data entry. This makes InfoPath a very efficient solution for sharing information throughout the organization. 
	Feature
	Description
	Invocation

	Repurpose
	
	

	Multiple Views of Forms XE “Form development:Views, multiple" 
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 XE "InfoPath:Enhancements in Office 2003 SP1:Views" 
	InfoPath lets form designers create multiple views of a form. One view might be a summary version of the form, for example; another might show the full version of the form. InfoPath enables designers to specify the default view, as well as which views are available to end users in the view menu. Each view uses the same underlying data, either showing, hiding, or reordering parts of the data. 
Each view can have a unique header and/or footer when printed. Headers and footers can make use of built-in AutoText features (such as document name, short/long date, page number, and more). Form designers can also distinguish the text characteristics associated with each view (specifying the font, size, and color characteristics for text boxes, date pickers, and other controls within the view).
	In InfoPath design mode, open the Views task pane. The initial view appears in the task pane window. By clicking Add a New View under Actions, the designer can create additional views (see Figure 26 and Figure 27 in the screen shot appendix). 
By cutting and pasting layout elements between views in design mode (or by dragging fields or groups from the Data Source task pane), the designer can create precisely the new views desired. 
To manage the headers and footers XE "How to...:Views, managing multiple"  associated with a view, click Header and Footer on the View menu in design mode. 
To manage text characteristics for a particular view, open the View Properties page for the view, and then click the Text Settings tab.

	Merge Form XE “Form development:Merging forms"  Information
	InfoPath lets users merge information from multiple forms into a single form. Merging forms enables an individual to consolidate information from many different users, for example, or to gather information in a single form that has been collected in other forms. 
By default, InfoPath will merge any repeating sections within a form (including fields contained within a repeating section, repeating tables, or lists) and concatenate non-repeating rich text fields. To go beyond this basic merging behavior, a designer can also create an XSLT file by hand to customize the functionality.
	While filling out a form, click Merge Data on the File menu. In the Merge Data dialog box, you can choose one or more forms to merge.
This can also be done within form libraries on SharePoint sites. XE "How to...:Merge forms" 

	Exporting Information  XE "Exporting forms" 
 XE "Exporting forms:To XML" 
	End users can export their current view to the Web in an .mht format. Because this format is recognized by browsers, those without InfoPath are able to view the content of a form. 
End users can also export selected form data to Excel for analysis. 
	While filling out a form, point to Export to on the File menu, and then click Web. To create a Single File Web page (.mht) file. To create a spreadsheet instead, point to Export to on the File menu, and then click Microsoft Office Excel.  XE "How to...:Export forms" The Export to Excel Wizard guides the user through the process of exporting their data.  XE "How to...:Export forms" 

 XE "How to...:Export forms" 


	Development 
	

	Publish Forms to Shared Folders or Web Servers XE "InfoPath features:Publishing forms" 
	InfoPath forms can easily be published to a shared folder on the local network or a Web server.
	To publish to a shared folder, click Publish on the File menu. On the first page of the wizard, click Next. Click To a shared folder on this computer or on a network, and then click Next. Follow the steps in the wizard.
To publish to a web server, click Publish on the File menu. On the first page of the wizard page, click Next. Click To a Web server, and then click Next. Follow the steps in the wizard. 

	Integration with SharePoint  XE "InfoPath features:SharePoint integration" 
	Form designers can share forms with others in the organization by publishing them to form libraries on a SharePoint website. Users can also fill out forms via form libraries. Using InfoPath with form libraries on SharePoint sites enables efficient collaboration and data collection in a familiar, Office-integrated environment.

	To publish a form template to a SharePoint form library, click Publish on the File menu. On the first page of the wizard, click Next. Click To a SharePoint form library, and then click Next. Select Create a new form library and click Next. Follow the steps in the wizard.
To fill out a form in a SharePoint form library, team members can click the Fill Out This Form command in the form library. A new blank form based on the form template will open in InfoPath, ready to be filled out.  XE "How to...:Integrating with SharePoint" 

	XML Property Promotion with SharePoint Form Libraries
	Because InfoPath and SharePoint form libraries are XML enabled, forms can directly populate field data into form library columns; this is called XML property promotion. Users of the form library can then use this information to sort and track information contained in a form library without needing to open the form. Available column headings are based on settings in the form template.
	To sort and arrange data in a form library, simply click on the available column headings.
To set the available column headings for a form template in InfoPath design mode, click Form Options on the Tools menu. In the Form Options dialog box, click the Form Library Columns tab. Do one or more of the following:
To add a form field to the list, click Add. Choose a field or group from the data source, type the column name you want to appear in the form library column, and click OK.
To delete a column from the list, select it, and click Remove.
To change a column in a form library, select the corresponding column in the list, and click Modify. Choose a different field or group from your data source, modify the column name, and click OK.  XE "How to...:Integrating with SharePoint" 


	Support for Workflow Roles and Rules
 SHAPE  \* MERGEFORMAT 



 XE "InfoPath:Enhancements in Office 2003 SP1: Workflow roles and rules" 
	InfoPath makes use of roles and rules to facilitate the integration of InfoPath forms with workflow services. Roles associate certain users with certain organizational roles, and form designers can tailor the presentation of information in a form based upon user roles. 
Using roles and rules, a designer can create forms that behave in particular manners, depending on who is completing a form and depending upon the information they put into the form. For example, a form designer can create a form that allows a user who is not a manager to submit an expense report directly to the expense department if the amount of the expense is less than $1,000. If the amount is greater than that, the submit button on the form will route the form to the user’s manager for approval. The roles and rules associated with the form would then allow a user identified as a “manager” to review the form but not change any form fields. A rule would require the manager to sign the form digitally before either approving or rejecting the request. If the manager clicks an “approved” button, the form would then be routed to the finance organization; if the manager clicks the “rejected” button, the form would require the manager to attach an explanatory note and then route the form back to the user. 
	To create roles for a form, the form designer clicks the User Roles option on the Tools menu. The Manage User Roles dialog box enables a form designer to create or modify user roles.
A form designer can attach one or more rules to all but a few InfoPath controls by double-clicking the control to open its properties, and then clicking the Rules button. 
A designer can add rules for Submit by selecting Submitting Forms from the Tools menu and specifying Custom submit using rules in the Submit to drop-down list and then clicking the Rules button. Similarly, a designer can add rules to be considered when a document is opened by selecting Form Options from the Tools menu, choosing the Open and Save tab, then clicking the Rules button.
 When creating rules, the Set Condition button enables form designers to specify the conditions that govern rule operations; the Add Action button enables the designer to identify an action to be taken if the specified conditions are met.  XE "How to...:Working with workflow services" 


	Support for Human Workflow Services
 SHAPE  \* MERGEFORMAT 



 XE "InfoPath:Enhancements in Office 2003 SP1:Human Workflow Services" 
	InfoPath also supports Human Workflow Services (HWS), a Microsoft BizTalk Server 2004 service that enables a client application to build and manage a human-oriented workflow. InfoPath provides an end-user task pane, called the Workflow task pane, that helps users start and track HWS Actions and respond to HWS tasks. InfoPath also provides three types of submit operations to interact with HWS:
Start a workflow 
Extend a workflow 
Respond to a task 
When designing the actions and workflow structure in HWS, designers should keep in mind that InfoPath allows users to start only one new action based on the current state. The workflow is considered done when the activity flow is inactive, whereupon the user can initiate another action.
	To integrate HWS with InfoPath, form designers must enable the Workflow task pane and HWS submit adaptors. Once enabled, form developers can create forms that can submit a form directly to HWS through the use of buttons in the HWS task pane. 
After a user starts an HWS action, the action is running and tracked by HWS; InfoPath displays the status of the action and who is assigned the task (see Figure 23). When a task is assigned to a user, InfoPath displays the status of the task, a button to respond directly to the task, and one or more buttons to start new actions. InfoPath can also display HWS status information in the HWS pane, which shows when the workflow started and whether the workflow is in progress or not.  XE "How to...:Working with workflow services" 

	Built-in E-Mail Integration XE "InfoPath features:E-mail integration" 
	InfoPath enables users to collaborate on their forms out of band, outside the normal business process, through built-in e-mail integration with Microsoft Office Outlook 2003.
	When filling out a form, click Send to Mail Recipient on the File menu (see Figure 28 in the screen shot appendix).  XE "How to...:E-mail forms" 

	Interacting with Data Repositories XE "InfoPath features:Submit button" 

 XE "InfoPath features:Query button" : Submit and Query

[image: image32]
 XE "InfoPath:Enhancements in Office 2003 SP1:Submit options" 
	InfoPath enables users to submit form data to a database using the ADO protocol, to an HTTP server, using the POST method, or to a Web service through the SOAP protocol. InfoPath can also interact with SharePoint servers.
Designers can also type in custom messages to be presented upon the success or failure of submission, as well as specify what should happen to the form upon submission (remain open, close, etc.).
When creating a form based on a database or Web service, InfoPath automatically creates a separate query view, which allows end users to enter information to filter their database query and get back the desired records.
	By right-clicking the control and clicking Button Properties on the shortcut menu or by selecting Submitting Forms from the Tools menu, a designer can specify whether the button will submit the form to a Web service, a URL, SharePoint, or another destination through the use of custom code. The designer can also manage post-submission actions in the Button Properties dialog box (see Figure 29 and Figure 30 in the screen shot appendix).  XE "How to...:Submit forms" 
 A query view is created by default when the form designer creates a new form based on a database or Web service. 

	Form Submission using E‑mail

[image: image33] XE "InfoPath:Enhancements in Office 2003 SP1:Submit using e-mail" 
	In addition to submitting a form to a Web service, database, or URL, InfoPath can also submit forms to a specified destination using e‑mail. 
	To specify e‑mail as the submit mechanism, open the Submitting Forms dialog box from the Tools menu. Check the Enable Submit Commands and Buttons option button, then select E‑mail from the Submit to drop-down list. Designers can add a data connection or choose one from the Add a data connection for submit drop-down list. When adding a data connection, the designer can identify one or more e‑mail recipients for the form and enter boilerplate message by clicking the Add button beside the drop down list.  XE "How to...:Submit forms" 
When the user clicks the Submit button, either in the standard toolbar or in the form itself (if one is embedded in the form), InfoPath invokes the user’s e‑mail client and sends the form to the recipient specified by the designer. If a designer has attached any rules to the submit process, they run at the time the user clicks the Submit button.


	Document Security
	

	Digital Signatures Support XE "InfoPath features:Digital signatures" 
 SHAPE  \* MERGEFORMAT 



 XE "InfoPath:Enhancements in Office 2003 SP1:Digital signature enhancements" 
	InfoPath provides verifiable, non-repudiatable counter- and co- signing through XML Digital Signatures. Form designers can specify whether to allow forms to be signed or not, as well as whether Signatures should be applied to the full form or just specific portions of a form (partial Signatures). When viewing a Signature, it is also possible to see a view of the form as it existed when a user signed it. 
When a form is signed, additional information is stored into the digital signature XML block to verify the intention of the signer and to provide additional information about the form.
A capture of the view as it was presented to the signer when the form was signed
The system date and time of the transaction
The version of the operating system used
The version of Office used
The version of InfoPath used
The number of monitors and the screen resolution of the primary monitor on the machine used to sign
The name of the view opened at the time the signature was added
The fingerprint of the form template used to add the signature
This additional information is part of the signature, and cannot be removed without invalidating the signature.
Form designers have added control over the use and presentation of digital Signatures with Section and Optional Section controls. Checking the Show signatures in the section check box will cause a form to display additional signature information to the user. 

	To enable users to use digital signatures, the designer clicks Form Options on the Tools menu. In the Form Options dialog box, on the Digital Signatures tab, the designer can specify options under Allow users to digitally sign this form (see Figure 31 in the screen shot appendix).
Form designers can specify whether specific portions of a form or the entire form must be signed. Designers can also specify whether signatures are independent or aggregate (see Figure 32 in the screen shot appendix). 
To control the display of additional information about signed sections, the form designer can click the Digital Signatures tab in the Section Properties dialog box.
 Users can sign sections or entire forms by clicking Digital Signatures on the Tools menu. A wizard guides the user through the process. XE "How to...:Digital signatures" 


Manage Information More Flexibly
InfoPath gives teams and organizations more flexibility in dealing with rapidly changing business conditions. The application enables form designers to create and modify forms quickly and easily to adapt to changing business needs. It also enables form users to interact with forms as they would interact with other documents. Users can work on a form, complete it partially, and save it for later completion. They can save the form locally, work on it while disconnected from the network, and submit the form later when once again linked to the network. Because InfoPath supports richly formatted text, users can complete forms using formatted text, bulleted lists, tables, and even graphics. InfoPath even enables designers to create forms with optional and repeating sections—so the form dynamically expands to accommodate the information that users need to enter.
	Feature
	Description
	Invocation

	Editing
	

	Rich Formatting of Text
	InfoPath enables form designers and end users to use richly formatted text in the forms. Within text boxes, designers and end users can format information using bold, italic, and underlined fonts; they can specify non-default font sizes and colors; they can also format information as numbered or bulleted lists.
	Font formatting in rich text boxes can be managed while filling out a form by selecting the Font task pane (see Figure 35 in the screen shot appendix).  XE "How to...:Design forms:With rich text" 

	Hyperlinks
	InfoPath enables form designers and end users to insert hyperlinks in rich formatting areas.
InfoPath recognizes URLs and e-mail addresses and automatically formats them as hyperlinks.
	URLs and e-mail addresses are automatically recognized as hyperlinks when entered in a rich text field. 
Hyperlinks can also be attached to selected text in a rich text field. To attach a hyperlink, highlight the text and select Hyperlink from the Insert menu. Enter the URL in the Link to field and modify the display text if and as appropriate.  XE "How to...:Hyperlinks, use of" 

	Lists
	InfoPath offers the ability to add bulleted and numbered lists into rich text areas.
	Open the Bullets and Numbering task pane to choose a list format.  XE "How to...:Design forms:Lists" 

	Tables

	InfoPath supports the insertion of tables into form sections that support rich formatting.
End users can set borders or shading of tables. End users can also split and merge the cells in a table.
	On the Table menu, point to Insert, and then click the option you want to create a table in a rich text field.  XE "How to...:Design forms:Tables" 
On the Table menu, click Borders and Shading to change borders and shading. 
Select the cells to be split or merged and then, on the Table menu, click Merge Cells or Split Cells. 


	Editing
	

	Inline Images and Graphics Support
	InfoPath enables users to insert inline images, clip art, or other graphics into rich text portions of their forms.
	With the insertion point positioned where the image will be placed, point to Picture on the Insert menu, and then click the option you want.  XE "How to...:Images, use of" 

	Spelling Checker and AutoCorrect

	InfoPath provides built-in spelling checker support for both form designers and form users. InfoPath users can set spelling checker to occur as they type (misspelled or unrecognized words appear underlined with a red squiggly line) or they can use spelling checker to check an entire form. 
InfoPath can learn to correct common misspellings and typos.
	On the Tools menu, click Spelling to check selected text or, if no text is selected, an entire form.
On the Tools menu, click Options, and then click the Spelling tab to control spelling checker behavior.
Right-clicking on a misspelled word displays a shortcut menu with options for correcting the error.  XE "How to...:Check spelling" 

	Tablet PC Support
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 XE "InfoPath:Enhancements in Office 2003 SP1:Tablet PC support" 
	InfoPath supports the tablet pen features of the Tablet PC. Using a tablet pen to fill out forms, an individual can write directly in fields on a form and then convert the ink to text. Depending on the design of the form, the user can also add handwritten notes or drawings to certain fields, and then save the ink along with the form. Designers building forms specifically for Tablet PC users can specify background pictures for ink picture controls.
	When in Ink Entry mode on a Tablet PC, a user can complete forms with a Tablet PC pen. Ink is automatically converted to text. A form designer does not have to do anything special to create ink-enabled forms; standard InfoPath controls accept ink input.  XE "How to...:Taking advantage of Tablet PC ink input" 

	Offline Support XE "InfoPath features:Offline support" 
	InfoPath provides the ability to save forms locally during design or editing. A user can leave a form partially complete and then reopen the form at a later time and resume form completion, without losing the information entered earlier.
	On the File menu, click Save or Save As from the File menu.  XE "How to...:Save forms for offline completion" 

	Find and Replace
	Form designers and end users alike can use the familiar Find and Replace tools within InfoPath. 
	On the Edit menu, click Find or Find and Replace.  XE "How to...:Find and replace" 

	AutoComplete
	Like Internet Explorer, InfoPath can keep track of responses entered into form fields. When the user subsequently encounters a known field (a phone number field, for example), InfoPath can offer a drop-down list of likely responses.
	InfoPath keeps track of responses; no action is required of the user except to select the appropriate response (if there is one) from the drop-down list.
In design mode, AutoComplete can be disabled for a specific control by opening the Properties dialog box, clicking the Display tab, and then clearing the Enable AutoComplete check box. XE "How to...:Autocompletion of forms" 

	Drag-and-Drop Editing
	Users can drag data (including text and graphics) from one location to another, either while designing a form or while filling one out. 
	Select the data to be moved and then drag it to the target location.

	Automated Document Recovery
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 XE "InfoPath:Enhancements in Office 2003 SP1:Autorecovery" 
	If InfoPath stops responding while a user is filling out a form, the user can close the program in a controlled manner. The files they were working on are analyzed for errors, and the information in them is recovered if possible.
InfoPath saves an autorecovery snapshot of a form every 10 minutes. Users can override the default snapshot frequency.
	InfoPath attempts to save a form in the event of an unplanned program closure by default. 
Users can modify the autorecovery snapshot period by clicking Options on the Tools menu and specifying AutoRecover options on the Advanced tab.  XE "How to...:Recover forms" 

	Sample Forms
	

	Sample Forms
	InfoPath ships with a number of sample forms which are customizable by users in design mode.  XE "InfoPath:Sample forms" 
	In design mode, open the Design a Form task pane, and then click Customize a Sample. XE "How to...:Design forms:From samples" 

	Printing
	

	Page Setup XE "InfoPath features:Printing forms" 
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 XE "InfoPath:Enhancements in Office 2003 SP1:Printing enhancements" 
	InfoPath enables end users to select paper sizes, output orientation, and margins. Form designers can use Page Setup to specify defaults for printers, number of copies, print range, collation, and other settings.
	On the File menu, click Page Setup.  XE "How to...:Print:Page setup" 

	Header and Footer Support
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 XE "InfoPath:Enhancements in Office 2003 SP1:Printing enhancements" 
	Each view of a form can have a unique header and footer when printed. Headers and footers can make use of built-in AutoText features (such as document name, short/long date, page number, and more).
	To set up headers and footers, click Header and Footer on the View menu. Header and footer options can be managed on the Print Settings tab in the View Properties dialog box.  XE "How to...:Print:Headers and footers" 

	Page Breaks
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 XE "InfoPath:Enhancements in Office 2003 SP1:Printing enhancements" 
	When designing a form that may be printed, form designers can control printed output by deliberately inserting page breaks at those points where they want the form to break. Such breaks appear only in the printed output; they have no effect on the layout when a user is filling out an InfoPath form online.
	In design mode, place the insertion point where the page break should occur, and then click Page Break on the Insert menu.  XE "How to...:Print:Page breaks" 

	Print Preview
	End users can see a preview of what they are going to print before actually printing. 
Forms printed by end users look good by default; there are, for example, no drop-down arrows or scrollbars on list boxes.
	On the File menu, click Print Preview.  XE "How to...:Print: Previewing output" 

	Custom Print View Support
	Form designers can define print views specific to each of the other views in their forms.
	In design mode, open the Views task pane. In the Select a view list, click a view, and then click the View Properties button. Click the Print Settings tab to specify the print view to be associated with the selected view (see Figure 26 and Figure 27 in the screen shot appendix). 

	Creating a Print View for Microsoft Word 
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 XE "InfoPath:Enhancements in Office 2003 SP1:Printing enhancements" 
	Microsoft InfoPath provides form developers with a wizard that enables the creation of a custom print view based upon an existing XSL transformation (XSLT) file. The SDK provides a tool that enables designers to create an XSL file. Users can use this print view to print form data in Microsoft Office Word 2003. 
	To create a print view for Microsoft Office Word, open the Views task pane, and click Add Print View for Word under Actions (see Figure 36 in the screen shot appendix).  XE "How to...:Print:Microsoft Word support" 


Take Advantage of Existing IT Investments
IT professionals can take advantage of their existing investments in business systems, their existing XML schema XE "Schema:Use of existing schemas" , and their existing knowledge base when deploying InfoPath. Because InfoPath forms submit information formatted against an XML schema, the information gathered through InfoPath can be used in business systems that can work with XML-based input. As systems and processes evolve, form designers can update new InfoPath forms quickly and efficiently, and these forms will be silently upgraded throughout the organization when the form is next opened.
InfoPath builds on the user’s familiarity with the longstanding operation conventions of Microsoft Office. Users familiar with Microsoft Office will find it easy both to design forms in InfoPath and to use forms designed in InfoPath. The application has been internationalized to meet the needs of a wide range of users. It provides East Asian find and replace, clipboard, grid support and proofing tools. It is available in multiple languages, including:
· French
· German
· Spanish
· Italian
· Dutch
· Swedish
· Brazilian Portuguese
· Korean
· Japanese
· Chinese (Simplified)
· Chinese (Traditional)
· Chinese (Hong Kong)
InfoPath has been designed to work securely and effectively within an environment already filled with sensitive systems and processes. It helps to protect these existing investments by supporting a range of deployment options, including:
· Administrator-configurable installs. Administrators can custom-install the product to include or exclude functionality. InfoPath can provide support for lockdown environments, too.
· Zero administration install of form packages. If an end user opens a form in the editor, it is seamlessly installed in the background.
Using the Microsoft Office Resource Kit, administrators have a range of options for just how to deploy InfoPath within the organization. The application can be deployed on a LAN, on individual workstations through the use of an automated tool such as the Microsoft Systems Management Server, even as an application running on Microsoft Windows 2000 Server with Windows Terminal Services. It can be installed by users with help from an installation wizard; it can also be installed against policy templates, which can specify just which features to install on a given user’s system. Through the use of policy templates developed with the Office Resource Kit, for example, an administrator can disable the InfoPath design mode for all users except those specified as form designers. 
End users with special needs can also take advantage of InfoPath. Support for Microsoft Active Accessibility means better interaction with assistive technology. Users who employ screen reader technologies can use InfoPath right out of the box. The application can also be used in conjunction with the accessibility features built into the Windows Operating System and the Microsoft Office System, such as the narrator, sticky keys, and other features.
	Feature
	Description
	Invocation

	IT Management 
	

	Detect and Repair XE "InfoPath features:Deployment management features " 
	InfoPath offers the ability to detect an error and repair itself when a user’s installation becomes corrupted (if, for example, a DLL gets deleted). 
	On the Help menu, click Detect and Repair.  XE "How to...:Detect and repair errors" 

	Design-mode Lockdown
	The InfoPath design mode can be disabled for a specific form, preventing end users from making unauthorized changes to a form template. Administrators can restrict access to design mode on a system-wide basis by setting a registry key switch. Administrators can even configure the InfoPath installer to set this restrictive registry key by default, enabling the default install of InfoPath to restrict access to design mode.
	In design mode, click Form Options on the Tools menu. On the General tab, select the Enable Protection check box.  XE "How to...:Ensure security:Lockdown design mode" 

	Secure Creation and Deployment of Forms 
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 XE "InfoPath:Enhancements in Office 2003 SP1:Security enhancements" 
	Form designers can apply one of three levels of security to an InfoPath form:
Restricted
Domain
Full Trust
The Restricted security zone restricts all communication outside of the form template. 
The Domain security zone sandboxes a form to a particular zone as defined in Internet Explorer security settings on the machine. The form is allowed to communicate with other data inside of this domain but is restricted from retrieving data from other domains unless it is located on a trusted site or in the local machine Internet Explorer security zone. Forms in the Intranet zone attempting to access data outside their domain will cause a prompt to the user.
The Full Trust security zone will allow users to run a form with full trust on the local machine. This security zone can only be used when using a form with a signature that matches a trusted root publisher on your machine or by installing the form and setting the requireFullTrust XSF attribute to yes. By using this setting, users can access object model calls to the local machine such as file save as well as disable certain security prompts that appear when running in a more restrictive security zone.
	By default, InfoPath automatically creates forms that fall into either the Restricted or Domain security zones, depending upon the features a designer uses. The default security setting is always as secure as possible, given the features employed.
To override the default security zone settings, the form designer must access the Security tab by clicking Form Options on the Tools menu (see Figure 37). 
Note: to create a fully trusted form in InfoPath, the designer will need to sign the form using a certificate from a trusted root. To sign a form, access the Security tab by clicking Form Options on the Tools menu, and then click the Select Certificate button (see Figure 37 in the screen shot appendix).  XE "How to...:Creating secure forms" 

	Versioning of Form Templates
	InfoPath automatically stamps a date, time and version number for a form template when it is saved in design mode. For sandboxed solutions, InfoPath uses this stamp to ensure that the user filling out a form is always using the latest template. 

	Each time a user opens an InfoPath form based on a sandboxed solution, InfoPath checks to see whether a newer version of the form template is available. If a newer version is available, InfoPath updates the template in the background. 

	Form Deployment through E‑mail
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 XE "InfoPath:Enhancements in Office 2003 SP1:Deploying forms through e-mail" 
	InfoPath enables form designers to distribute form templates using e‑mail.
Note: If you are developing a form that will be updated regularly then the form should still be published to a shared location before being sent to users through e-mail. This enables you to update the forms by publishing newer versions to the shared location but will also allow you to distribute the form template immediately to users who may not have VPN access to the share.
Note also that if you are developing a form that requires domain level security then you will need to publish it to a shared location in order for it to open. Because form templates will only open in the security level they request, forms opened directly from mail will run as Restricted unless they can retrieve updates from a shared location. 
	All forms created in the InfoPath designer can be mailed to users. To mail a form template, a form designer must do the following while in the design mode:
· On the File menu, click Send Form as Attachment (you will be required to save the form template at least once before doing this).
· Type names in the To box of the e-mail message.
· Send the mail message.
 XE "How to...:Deploy forms using e-mail" 

	Backward Compatibility
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 XE "InfoPath:Enhancements in Office 2003 SP1:Compatibility" 
	The InfoPath feature enhancements in Office 2003 SP1 introduce a wide range of new features and functionality. Forms created in earlier versions of InfoPath will function exactly as they did before, and take advantage of all the bug fixes in the SP1 update. To guarantee compatibility, certain updated functionality will not be available to existing forms unless they are upgraded for SP1 compatibility.
The InfoPath feature enhancements in Office 2003 SP1 can also be disabled so that InfoPath installs with only the SP1 bug fixes. 
	In order for existing forms to take advantage of the updated functionality of InfoPath SP1, they must have SP1 features added to them:
· Open the existing form in design mode using InfoPath 2003 SP1.
· Select Add Service Pack Features to Form on the Tools menu.
Once the InfoPath feature enhancements in Office 2003 have been enabled for a form, the form can only be accessed by InfoPath 2003 SP1; those users who do not have SP1 installed will be unable to use the updated form.
To disable the InfoPath feature enhancements in Office 2003 SP1, select Options and the Tools menu, then check the Disable Service Pack features checkbox on the Advanced tab.  XE "How to...:Disabling SP1 features" 


	End User Ease of Use Features
	

	List of Most Recently Used Form Templates
	End users have quick access to most recently used form templates.
	Users can choose from the recent files list on the File menu, or from the list of recently filled-out forms on the Fill out a Form dialog box or task pane, or from the list of existing forms that the user has been designing on the Design a Form task pane.  XE "How to...:Manage documents:Recently-used forms" 

	Switch Views

	If a form template has more than one view, end users can switch between views.
	Users can switch between different views by clicking commands on the View menu.  XE "How to...:Manage documents:Switch views”

	Customizable Toolbars
	InfoPath uses the Office toolbar, and users can add or hide buttons to fit their editing needs. 
	To customize a toolbar, click Customize on the Tools menu, and then click the Toolbars tab.  XE "How to...:Customize toolbars”

	Dr. Watson Support
	InfoPath allows users to send data back to Microsoft on crashes so Microsoft can track down crashing bugs in the product. XE "Dr. Watson support" 
	Dr. Watson support is automatic and requires no user setup.

	Help Support

	InfoPath provides standard Office Help and the Type a question for help box.  XE "InfoPath:Online help" 
	Help is available through the Help menu as well as through the Type a question for help menu bar interface.  XE "How to...:Help, accessing:”

	Tour of Product

	InfoPath comes with an animated tour to help new users get started.  XE "InfoPath:Product tour" 
Help is available at all times when designing or filling out a form.
	In the Fill Out a Form dialog box, click Take a Tour of InfoPath. 
To get help, press F1 or click Microsoft Office InfoPath Help on the Help menu.  XE "How to...:View product tour”


	Accessibility
	

	High-Contrast / Large Font for Accessibility
	The InfoPath interface responds to the themes defining the character of the Windows interface.  XE "InfoPath:Accessibility features" 
	Themes set in the Display Properties page define the look of the InfoPath interface.  XE "How to...:Accessibility options:Manage display”

	Keyboard Shortcuts / Access Keys
	All functionality can be handled through the keyboard.  XE "InfoPath:Accessibility features" 
	Many menu options have associated keyboard shortcuts.  XE "How to...:Accessibility options:Keyboard shortcuts”  XE "How to...:Keyboard shortcuts”
Users can also navigate the menus using the Alt and Arrow keys.

	Tab Index Ordering
	Form designers can define the sequence of fields to which the insertion point will jump when a user presses the tab key when filling out a form.
	In design mode, double-click the control where you want the user to start when filing out a form. In the Properties dialog box, click the Advanced tab. Enter “1” in the Tab index field. Click OK to close the properties dialog box and then right-click on the next field that the user should complete. Select the Properties page from the pop-up menu and click the Advanced tab. Enter “2” in the Tab index field.
Repeat this process, increasing the tab index field number each time, until the tab index order has been satisfactorily created.


System Requirements XE "System requirements" 
System Requirements:
· PC with an Intel Pentium 233 MHz or higher processor; Intel Pentium III recommended. 
· Microsoft Windows 2000 with Service Pack 3 or Windows XP or later operating system. 
· Microsoft Internet Explorer 6.0 or later.
For Windows 2000 and Windows XP:
· 128 MB of RAM or greater for the operating system 
· 100 MB of available hard disk space; optional installation files cache (recommended) requires an additional 290 MB of available hard-disk space
Other:
· CD-ROM drive
· Super VGA (800 x 600) or higher-resolution monitor with 256 colors
· Microsoft Mouse, Microsoft IntelliMouse®, or compatible pointing device
· Microsoft Windows Server 2003 running Microsoft Windows SharePoint Services is required for certain advanced collaboration functionality
· .NET framework 1.1 if forms use managed code
· Microsoft Office InfoPath 2003 Toolkit for Visual Studio .NET
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Figure 2: Inserting Repeating Sections
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Figure 3: The Drop Down List Properties Box
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Figure 4: The Repeating Table Properties Page
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Figure 5: Specifying Filter Conditions for a Repeating Table
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Figure 6: A Filtered List (1)
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Figure 7: A Filtered List (2)
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Figure 8: Identifying the List Box Values in a Cascading List
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Figure 9: Creating Cascading Drop-Down Lists with Filters (2)
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Figure 10: The Conditional Format Dialog Box
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Figure 11: The Condition Builder Dialog Box for Rules
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Figure 12: Identifying the Action to Take in Response to a Condition for a Rule
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	Figure 13: Design a Form Task Pane
	Figure 14: Controls Task Pane
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Figure 15: WYSIWYG Form Design 
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	Figure 16: The Paragraph Task Pane
	Figure 17: Tree-Type Schema Representation
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Figure 18: Basic Schema Editing 
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Figure 19: The Fill Out a Form Dialog Box
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Figure 20: Customize the Display Properties of a Control
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Figure 21: The Data Tab in the Text Box Properties Page
Figure 22: The Insert Formula Dialog Box
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Figure 23: The Human Workflow Service Task Pane 
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Figure 24: Adding Custom Controls
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Figure 25: Creating Managed Code for an InfoPath Project using Microsoft Visual Studio .NET 2003
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Figure 26: Multiple Views of a Form
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Figure 27: Multiple Views of a Form (Summary)
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Figure 28: Built-in E-Mail Integration
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Figure 29: Configuring Submit Button Properties
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Figure 30: Enabling Form Submission
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Figure 31: Managing Digital Signatures
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Figure 32: Defining Digital Signature Options
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Figure 33: Digitally Signed Forms
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Figure 34: Reviewing Digital Signature Details
[image: image79.png]Form1, - Microsoft Office InfoPath; 2003
P Ele Edt View Insert Formst Tools Table Help Type a question for help.
AT FEE AR e A KA =R A AP ) |

g [verdana) 0 Bz uE=
Tneline One EXpanEIon Discussions

Bullets and Numbering
-_ starcpate £nd Date
Gordon Ash 1/13/2004 1/14/2004 .

R
[Tuesday, January 13, 2004

Start Date Appointment

1/13/2004  purpose

Start Time Local Financing Negotiatians
9:00 AM

1

Location:

e Date Potter County

1/13/2004 | O Click here to insert the Appointment Address section

End Time!
11:00 AM

Additionsl Info;

Jlcontacts
Name Fritle Company Telephone
George P of First National
willoughby ~|Development |Bank of
Potter County

« Good access from local roads
« Local econamy needs the jobs
« Strong four-season recreation potential

Sl Start rubering ot

| Form template's location: Ci\Documents and Sektings|Hark A R Mikchelly Documents|Active Business Files|WRA\Microsoftis Offic




Figure 35: Rich Formatting Options
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Figure 36: Creating a Print View for Word
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Figure 37: Managing Security Zones and Creating Fully Trusted Forms
Glossary
	Bind
	To connect a control to a field or group in the data source so that data entered into the control is saved. When a control is unbound, it is not connected to a field or group, and so data entered into the control will not be saved.

	COM (Component Object Model)
	A specification developed by Microsoft for building software components that can be assembled into programs or can add functionality to existing programs running on Microsoft Windows operating systems.

	Conditional formatting
	Changing the appearance of a control, including its visibility, based on values entered into the form.

	Control
	A graphical user interface object, such as a text box, check box, scroll bar, or command button, that lets users control the program. You use controls to display data or choices, perform an action, or make the user interface easier to read.

	Custom installed form
	A form that is installed with a custom setup program and that usually has access to files and settings on the computer.

	Custom task pane
	A Hypertext Markup Language (HTML) file whose content is displayed in a window next to a form. Custom task panes can provide form-specific commands and Help content. 

	Data source
	The collection of fields and groups that define and store the data for an InfoPath form. Controls in the form are bound to the fields and groups in the data source.

	Data type
	Property of a field that defines the kinds of data the field can store. Data types include Text, Rich Text, Whole Number, Decimal, True/False, Hyperlink, Date, Time, Date and Time, and Picture.

	Data validation
	The process of testing the accuracy of data; a set of rules you can apply to a control to specify the type and range of data that users can enter.

	Design mode
	The InfoPath design environment in which you can create or modify a form template.

	Dialog box alert
	A data validation alert that opens a dialog box with a custom error message when invalid data is entered into a control.

	DOM (Document Object Model)
	A World Wide Web Consortium specification that describes the structure of dynamic HTML and XML documents in a way that allows them to be manipulated through a Web browser.

	Editable region
	Any area of a form in which you can insert content such as text, tables, or pictures.

	Event
	An action recognized by an object, such as a mouse click or key press, for which you can define a response. An event can be caused by a user action or a Visual Basic statement, or it can be triggered by the system.

	Event handler
	The script function code in an InfoPath form that responds to a form event or data validation event.

	Expression box
	A control on a form that displays read-only data as the result of a lookup or calculation against the data using an XPath expression.

	Field
	An element or attribute in the data source that can contain data. If the field is an element, it can contain attribute fields. Fields store the data that is entered into controls.

	Form
	In InfoPath, a document with a set of controls into which users can enter information. InfoPath forms can contain features such as rich text boxes, date pickers, optional and repeating sections, data validation, and conditional formatting.

	Form area
	The area of the InfoPath workspace that displays the form you are working with.

	Form definition file
	An XML file with an .xsf extension that contains information about all other files and components used within a form, including user interface customizations, XML schemas, views, business logic, events, and deployment settings.

	Form files
	A collection of files that are used to implement an InfoPath form. File types can include HTML, XML, XSD, XSLT, script, and other file types that are necessary to support the functionality of the form.

	Form library
	A folder in which a collection of forms based on the same template is stored and shared. Each form in a form library is associated with user-defined information that is displayed in the content listing for that library.

	Form library columns
	Information from forms displayed in columns in a SharePoint form library. For every form in the library, columns display information entered into controls that the form designer designated as form library columns.

	Form template
	In InfoPath, a file or set of files that defines the data structure, appearance, and behavior of a form.

	Group
	An element in the data source that can contain fields and other groups. Controls that contain other controls, such as repeating tables and sections, are bound to groups.

	HTML (Hypertext Markup Language)
	Acronym for Hypertext Markup Language. The standard markup language used for documents on the World Wide Web. HTML uses tags to indicate how Web browsers should display page elements such as text and graphics and how to respond to user actions.

	Inline alert
	A data validation alert that marks controls that contain invalid data with a dashed red border. Users can right-click controls to display custom error messages.

	JavaScript
	A cross-platform, World Wide Web scripting language. JavaScript code is inserted directly into an HTML page. JavaScript makes it possible to build Java programs. The script anchor represents a script written in JavaScript.

	JScript
	An interpreted, object-based scripting language that borrows from C, C++, and Java. It is the Microsoft implementation of the ECMA 262 language specification.

	Layout table
	A collection of cells used to arrange form content such as text or controls.

	List control
	A control on a form that can be formatted as a bulleted, numbered, or plain list. A user can enter text into a list control, which repeats as needed. 

	Method
	A procedure similar to a statement or function that operates on specific objects. For example, you can apply the Print method to the Debug object to transfer printed output to the Immediate window. 

	Microsoft Script Editor (MSE)
	A programming environment used to create, edit, and debug Microsoft JScript or Microsoft VBScript code on an InfoPath form.

	Microsoft Windows Installer (MSI)
	A tool that is used to create installation packages for software that is to be deployed on 32-bit Windows operating systems.

	Object
	A table, chart, graphic, equation, or other form of information. Objects created in one application, for example spreadsheets, and linked or embedded in another application are OLE objects.

	Object browser
	A dialog box that displays information about objects, properties, methods, and constants in the current project and in referenced object libraries, and that you use to search for an element, get help on it, or paste it into a module.

	Object model
	A hierarchical library of objects and collections that represent the content and functionality of an application. Objects and collections have properties, methods, and events that can be used to manipulate and interact with an application.

	Object model diagram
	A graphical representation of the objects and collections that are contained within a specified object model.

	Optional section
	A control on a form that contains other controls and that usually does not appear by default. Users can insert and remove optional sections when filling out the form.

	Parameter
	A value that is assigned to a variable at the beginning of an operation or before an expression is evaluated by a program. A parameter can be text, a number, or an argument name assigned to another value.

	Property
	A named attribute of a control, a field, or an object that you set to define one of the object's characteristics (such as size, color, or screen location) or an aspect of its behavior (such as whether the object is hidden).

	Reference field
	A field that is associated with another field so that their properties always match. If the properties in one field are changed, the properties in the other field are updated automatically.

	Reference group
	A group that is associated with another group so that their properties and the properties of the groups and fields they contain always match. If the properties of one group are changed, the other group is updated automatically.

	Repeating field
	A field in the data source that can occur more than once. Controls such as bulleted, numbered, and plain lists; repeating sections; and repeating tables can be bound to repeating fields.

	Repeating group
	A group in the data source that can occur more than once. Controls such as repeating sections and repeating tables are bound to repeating fields.

	Repeating section
	A control on a form that contains other controls and that repeats as needed. Users can insert multiple sections when filling out the form. 

	Repeating table
	A control on a form that contains other controls in a table format and that repeats as needed. Users can insert multiple rows when filling out the form.

	Resource manager
	The interface for adding and removing resource files that support the functionality of a form.

	Rule
	One or more conditions and actions that automatically perform tasks based on events and values in the form.

	Scripting language
	A simple programming language designed to perform special or limited tasks, sometimes associated with a particular application or function.

	Secondary data source
	An XML data file, database, or Web service that is used by a form for the entries in a list box or for script actions.

	Section
	A control on a form that contains other controls. 

	Table
	One or more rows of cells commonly used to display numbers and other items for quick reference and analysis. Items in a table are organized into rows and columns.

	Task pane
	A window within an Office application that provides commonly used commands. Its location and small size allow you to use these commands while still working on your files.

	Text box
	A control into which a user can enter text. Rich text boxes allow data entry with text formatting choices.

	URI (Uniform Resource Identifier)
	A character string used to identify a resource on the Internet by type and location.

	URN (Uniform Resource Name)
	A scheme for uniquely identifying resources that may be available on the Internet by name, without regard to where they are located.

	URL (Uniform Resource Locator)
	An address that specifies a protocol (such as HTTP or FTP) and a location of an object, document, World Wide Web page, or another destination on the Internet or an intranet—for example, http://www.microsoft.com

	Valid
	Error free, or acceptable according to an established set of rules or standards. For example, data entered into a form is valid if it meets the criteria set in the form's data validation rules.

	View
	A form-specific display setting that can be saved with a form template and applied to form data when the form is being filled out. Users can switch between views to choose the amount of data shown in the form.

	VBscript (Visual Basic Scripting Edition)
	An interpreted, object-based scripting language that is a subset of the Microsoft Visual Basic programming language. 

	XHTML (Extensible Hypertext Markup Language)
	A markup language that extends HTML and reformulates it as XML.

	XML (Extensible Markup Language)
	A condensed form of Standard Generalized Markup Language (SGML) that enables developers to create customized tags that offer flexibility in organizing and presenting information.

	XML attribute
	An XML structural construct. A name-value pair, separated by an equal sign and included in a tagged element, that modifies features of an element. All attribute values are text strings and must be enclosed in quotation marks.

	XML data
	Data that is saved in an XML format. InfoPath forms are saved as XML data files.

	XML element
	An XML structure that consists of a start tag, an end tag, and the information between the tags. Elements can have attributes and can contain other elements.

	XML parser
	A software component used to process XML documents by validating their structure and producing views or transformations of their content.

	XML schema
	A formal specification, written in XML, that defines the structure of an XML document, including element names and rich data types, which elements can appear in combination, and which attributes are available for each element.

	XML signature
	An XML-based digital signature that can be used to help secure the data contained in XML documents. XML Signatures are a standard governed by the World Wide Web Consortium (W3C). 

	XML template file
	An XML file that contains the sample data that is displayed in the fields of a form before a user fills it out.

	XSD
	An XML schema definition.

	XSL
	An XML vocabulary for specifying formatting semantics. An XSL style sheet specifies the presentation of a class of XML documents by describing how an instance of the class is transformed into an XML document that uses the formatting vocabulary.

	XSLT (XSL Transformations)
	A language that is used to transform XML documents into other types of documents, such as HTML or XML. It is designed for use as part of XSL.
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Find and replace, 40
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Keyboard shortcuts, 47
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Recently-used forms, 47
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Manually edit XSLT, 30

Merge forms, 33
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Page breaks, 42

Page setup, 41

Previewing output, 42

Recover forms, 41

Save forms for offline completion, 40

Submit forms, 36, 37
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Using filters, 13

Using right-to-left language orientation, 21

Validation alerts, setting up, 18

View product tour, 47

Views, managing multiple, 32

Work with formulas, 24
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Working with Microsoft Visual Studio .NET 2003, 29

Working with rules, 15

Working with workflow services, 35, 36

WYSIWYG design mode, 21

InfoPath

Accessibility features, 47

Advantages over other approaches, 4–7
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Better decision-making, 16
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Increasing efficiency, 16

Share information throughout the organization, 31

Design mode, 8

Enhancements in Office 2003 SP1

ActiveX controls, 25

Autorecovery, 41

Compatibility, 46

Controls, 23, 27, 28

Data connections, 24

Deploying forms through e-mail, 46

Design mode enhancements, 21

Digital signature enhancements, 38

Disabling InfoPath features, 31

Human Workflow Services, 36

Printing enhancements, 41, 42

Right-to-left language support, 21

Rules, 18, 25

Secondary data sources, 20

Security enhancements, 45

Submit options, 36

Submit using e-mail, 37

Support for any W3C schema, 19

Tablet PC support, 40

User interface enhancements, 23

Using formulas and form values, 24

Views, 32

Visual Studio .NET 2003 integration, 29, 31

Workflow roles and rules, 35

Introduction, 2

Office integration, 9

Online help, 47

Product tour, 47

Programmability, 8

Sample forms, 8, 31, 41

Solution developer kit (SDK), 31

InfoPath controls

Automatic label insertion, 23

Button behavior, 25

Converting controls, 23

Customizable control properties, 23

Database source support, 24

Rebinding controls, 23

Standard toolbox, 23

InfoPath features

Controls, 26, See InfoPath Controls

Deployment management features, 44

Designing forms with generic schema, 19

Digital signatures, 38

Drag and drop from schema, 22

E-mail integration, 36

Field validation, 18

Form color schemes, 22

Offline support, 40

Optional elements and sections, 12

Overview, 8

Previewing forms, 22

Printing forms, 41

Publishing forms, 33

Query button, 36

Repeating sections, 12

Schema editing, 22

Schema representation, 22

Schema validation, 18

SharePoint integration, 34

Submit button, 36

Support for any W3C schema, 17

Validation rules, 18

W3C standards, 17

WYSIWYG design tools, 21

Schema

Designing from a generic schema, 19

Drag and drop fields or groups in form, 22

Editing, 22

Representation, 22

Support for any W3C schema, 17

Use of existing schemas, 42

Validation, 18

System requirements, 49

Terminal services support, 9
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