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Introduction

Microsoft Project has a very interesting calendar feature, where a user could choose the start and ending dates of projects, set actual, early, late start and finish dates, set constraint dates, portray the project time line over a time-scale, and several other project management and scheduling features. However, MS Project lacks the same functionality for Hijri dates. Suppose you are in Saudi Arabia, where the official calendar is the Hijri Calendar and all your project dates and deadlines are set in Hijri, however, you still wish to utilize Microsoft project for managing your project, in that case converting between Gregorian to Hijri dates manually would be a hassle. MS Project Hijri Calendar Add-In can help you display the Hijri equivalent of every Gregorian date field in your project task tables. It is updated with every change that happens to its equivalent Gregorian, and vice versa. Not only that, but the user can also pick the custom text fields s/he wishes to reserve for the Hijri date and can like wise easily remove this binding. This add-In only supports Microsoft Project Standard and Professional editions, in future versions, we could consider adding it to Project Server. In the following guide will we explain to you the different things you can do with this Add-In, how to install and use it, and how you can utilize its functionality to the fullest in your Microsoft Project. This Add-on is designed based on Um AlQura Algorithm.
Features

a) The add-In main feature lies in giving you the ability to add Hijri column support for Gregorian date Fields in your project. It can create a Hijri column for example for the following sample Date Columns:
	Added Hijri Fields
	Gregorian Fields
	Task Tables

	Hijri Start, Hijri Finish
	Start, Finish
	Entry, Usage

	Hijri Early Start, Hijri Early Finish
	Early Start, Early Finish
	Export

	Hijri Late Start, Hijri Late Finish
	Late Start, Late Finish
	Schedule

	Hijri Actual Start, Hijri Actual Finish
	Actual Start, Actual Finish
	Tracking

	Hijri Baseline Start, Hijri Baseline Finish
	Baseline Start, Baseline Finish
	Baseline

	Hijri Created 
	Created
	Export

	Hijri Constraint Date
	Constraint Date
	Constraint Dates


1- Create Hijri field mapping for every Gregorian date field for the current table in the current view

2- You can choose the text field that you would like to bind that Hijri field to.

3- Any change that happens to the Hijri date field is mapped to its equivalent Gregorian date field and vise versa. 

4- Any project calculation or task changes to any of the fields that affect the Gregorian date fields, directly reflects on the Hijri date fields.

5- You can remove the binding between the custom Hijri field and the Gregorian date field, so that custom hosting text field can be reusable by another field.
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b) The Hijri Date format is the Arabic date format dd-mm-yyyy, irrespective of the Date format specified in the user's regional settings; however the date separators are those specified by the regional settings.
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c) The AddIn can support up to 100 simultaneously opened projects without any confusion between the available or empty text fields for hijri binding in that project or the other.

d) The AddIn persists the Hijri Data and the Links between fields, and restores the bindings if you save, close and open your project any number of times.

Installation
The Hijri Calendar Add-In ships with two main dlls, the HijriCalAddIn.dll and the HijriAlg.dll.
1- Unzip the contents of your zip file HijriAddIn to the following location C:\Program Files\Microsoft Office\OFFICE11; from this location the MS Project application can see the required libraries for its Hijri calendar Add-In. (The zip file contains the HijriAlg.dll and some image files)
2- Register the HijriCalAddIn. There are several ways with which you can register an Add-In dll, and load it, the following are two of these ways:

From Microsoft Project Add In dialog
1- Place the HijriCalAddIn.dll that ships with the following document, in the following folder C:\Documents and Settings\{Current User Folder}\Application Data\Microsoft\AddIns 

2- From the Tools menu, choose ComAddIns. If you don't have ComAddIns showing in the Tools menu, follow these instructions to add it:

· On the Tools menu, point to Customize, and then click Toolbars. 

· Click the Commands tab, and then click Tools in the Categories list. 

· Drag COM Add-Ins from the Commands box over the Tools menu on the menu bar. When the Tools menu commands appear, point to where you want the COM Add-Ins command to appear on the menu, and then release the mouse button. 

· In the Customize dialog box, click Close. 

3- On the Tools menu, click COM Add-Ins. 

4- In the Add-Ins available list: 

5- To load an add-in, select the check box next to its name. If the add-in you want is not in the list, click Add, locate the HijriCalAddIn.dll, and then click OK.
 From regsvr32
1- Place HijriCalAddIn.dll anywhere on your hard drive.
2- From start menu, click Run, and type cmd, this will bring up the command prompt; stand on the directory where you saved the dll. 

3- Type: regsvr32 HijriCalAddIn.dll and you will be promoted that the Add-In has been successfully installed.

Now open you Microsoft Project and you will find the Hijri Calendar toolbar, attached to the top bars. If you do not see it, follow these steps to make it appear:
1- From the Tools menu | choose Customize | Toolbars, find the Hijri Calendar Toolbar and check it.

2- Now you can see the Hijri Calendar toolbar. 
Usage

Scenarios
Add Hijri Fields to current table with existing Gregorian date fields 
1- Click the Hijri calendar support Add-In icon, an Add Hijri Field Form is displayed[image: image3.bmp].

2- The Add Hijri Field form, would list all the Gregorian date fields available in the current table of your current view. These fields are listed in the ComboBox titled Date Field. The form also displays all the available Text fields (i.e. those fields that have not been assigned to equivalent Gregorian date fields) in the ComboBox titled Hijri Field. 

3- Choose a Gregorian date field and the Hijri text field you wish to bind to it and click OK.
4- The Add In will create a new Hijri field and assign it to the Gregorian date field you have chosen, and place it just before your Gregorian date field.

5- You can repeat the same above scenario, with another table by switching to another table or view, and Clicking on the Add Hijri Fields button. You can similarly add new Hijri fields for the date fields in this table. 

6- Any change that happens to a Gregorian date field is mapped to its equivalent Hijri date field.

7- After the fields have been added, Hijri dates are calculated for every equivalent Gregorian date. 
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Change a Gregorian Date Cell
1- Choose any of the Gregorian Date cells, and change the existing date (Fig.1). 
2- Accept the change you made in the Gregorian date, and you will notice that the equivalent Hijri date changes accordingly and maybe several others depending on the successors, predecessors, parent and children of the current task (Fig.2).  
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Fig.1 Before changing the circled Gregorian cell
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Fig.2 After changing the circled Gregorian cell 
Change a Hijri Date Cell
1- Now we are going to do the same with the equivalent Hijri Cell; change the Hijri cell from 18-11-1420 to 29-11-1420 (Fig.3). Make sure that the date is in a valid Hijri Date format, dd/mm/yyyy (with the same date separators used in the Gregorian dates).
2- Accept the change you made in the Hijri date, and you will notice that the equivalent Hijri date changes accordingly and maybe several others depending on the successors, predecessors, parent and children of the current task (Fig.4).  
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Fig.3 Before changing the circled Hijri cell
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Fig.4 After changing the circled Hijri cell

Adding an already created Hijri Column to another table
Now suppose you have another table that has Start and Finish Gregorian dates to which you wish to map the above created Hijri fields. In this case, you don’t have to create new fields for the Hijri display in this table, since the start and Finish dates in this table are an exact duplicate of the above table. So you could just inform Microsoft project to display the previously created Hijri fields as columns of the current table. 

1- Stand on the column you wish to place the new Hijri column beside, and select it.

2- Right click, and choose Insert Column.
3- From the List box for Field ID, choose the text field you reserved for your Hijri field with the title you specified for it.
Removing Hijri Date Fields from current table
1- Stand on the table you wish to delete its Hijri date fields, click on the Remove Hijri Fields [image: image9.bmp]
2- A form called Remove Hijri Fields appears, with a combo box that has all the custom Hijri fields that you have created for Gregorian date fields in this current table.
3- Select the Hijri field you want to remove the binding for, and click OK.
4- The Hijri column will disappear from the current view, and if you click on Add Hijri Fields, the form will display the text field that was previously bound to the Hijri deleted field as one of your available text fields for binding to Gregorian date fields. The Gregorian date field list would also show released Gregorian date that was bound to the deleted Hijri field as one of the available Gregorian date fields for Hijri binding.
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Displaying Hijri date on Gantt chart
Hijri Fields like any other custom fields can be used to display Hijri dates on charts. 

1- From the View menu, choose Gantt chart. Right click anywhere on your Gantt chart, and choose Bar Styles… 
2- Switch to the Bar Text tab, now you can choose your previously created Hijri Field, that shows as one of the custom text fields in the list if available fields, to show on either the left, right, bottom, top or inside your task bar.

3- In our case we will choose the Left to be Text2 (HijriStart), for Right Text3 (HijriFinish), and for Top we could choose to show the resource names.
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The Gantt chart would accordingly look like this:
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Note: you could also repeat the same steps with the Tracking view, to show Hijri field of the Tracking Gantt view.
Displaying Hijri date on Calendar View

Like you were able to display your custom Hijri field on your Gantt chart, you could do the same for the calendar view. 

1- Navigate to  View | Calendar 
2- Right click anywhere on your Calendar view, choose Bar Styles, select the task type that you would like to display your Hijri field for, in our case, we selected All, and we chose to show the start Hijri field on each of these tasks.

Note: you can choose to display more than one field by separating them with a semicolon, as we can see in the following snapshot.
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This is how our calendar would like afterwards:
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Displaying Hijri date fields on the Network diagram
1- Go to View | Network Diagram.

2- Right click anywhere on the Network Diagram, and choose Box Styles.

3- Next to the Date Template field box, click on the button More Templates, and from the Date Templates dialog, click New, and start creating a new template.

4- Choose the fields you wish to display in this boxes of this new template, in our case, we chose to show the name and the Hijri start and Finish dates.
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5- Press OK, and there goes your network diagram, with Hijri dates on it.
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Of course these are not the only views, in which you can display Hijri fields. Like we have shown, anywhere you can display custom fields; you can display Hijri fields as well. Those views were just examples of the varieties you can create using the Hijri fields created by the Hijri Calendar Add-In

Limitations

1. If you attempt to modify Hijri Fields whose Gregorian equivalents are linked to one or more fields, you will not be prompted with the Scheduling wizard messages that ask you whether you wish to keep or delete the links, however, the default scheduling actions will take place.

2. You should not change the name of the custom text fields reserved for the Hijri dates. The Hijri Calendar AddIn relies on the Custom Field Name of the text field to identify its Hijri fields assigned to Gregorian date fields. 
Note: that you can change the title of the column in the current view, so a single field can have multiple column titles but there is only one custom field name that you should not change.

3- If you change the date separator from the regional and language options date section, your change will not be reflected in the existing dates of the Hijri columns unless you press the Refresh button. However new Hijri values will automatically use the new date separator.

4- The Current version of the Add-In does not support the Project Server yet. This feature could incorporated in next version of the Add-In.
Notes
1- If you click the Add Hijri Button and nothing happens, make sure you have Macros enabled. From the Menu Tools | Macro | Security choose medium for the security option. Now close the project and re-open, and try again.
2- Creating bindings between Gregorian date fields that exist in more than one table and new Hijri text fields does not mean that the new Hijri column will appear in every table with the same Gregorian fields. It will create the column in the current view only, and you can add the Hijri column by request afterwards in the rest of the tables with same Gregorian fields, as was detailed in Adding an already created Hijri Column to another table.
3- If you have a Gregorian date field say "Start" in your table and you click Add but you are prompted that "No Gregorian date fields have not been assigned Hijri equivalents", then you must have assigned the Start field before in another table. To see the equivalent Hijri, Insert Column and choose the text field with the title "HijriStart".

4- If you attempt to change a Hijri field in the parent task, you will not be able to cancel the change you attempted unless you click the cancel button in the top edit box.

5- If you click on the Add In buttons and nothing happens, or if you get an error stating "ActiveX component can't create object", please repeat the registration steps at the Installation section, for the Dll to load correctly again.

Contact Us

If you found the Hijri Add-In of use to yourself or your organization, please send us your feedback at vsarabic@microsoft.com 















