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Introduction

Welcome to the product guide for Microsoft® Office InfoPath™ 2003, a new member of the Microsoft Office System of products. 

Today's organizations create and use massive amounts of information, from sales figures to performance appraisals to purchase orders. Gathering this data is a top priority for teams and organizations. For example, a Microsoft study shows that as part of the process of gathering and managing information, currently 70 million workers, or 59% of working adults in the U.S., complete forms on a regular basis as part of their job responsibilities.

Currently, many information workers collect that information via inefficient processes such as paper forms, or electronically using documents, spreadsheets and email. Others have built custom in-house applications using Web-based or proprietary forms tools. Because of the difficulty of extracting and reusing information from these applications or tools, information workers often must re-type information leading to data entry errors and inefficient business processes.

Moreover, key decision makers are often unable to make informed decisions because the information they need is trapped within documents or databases in another part of the organization. Technologies such as Extensible Markup Language (XML) Web services have been helpful in improving business processes from server to server, but to date they have not been connected directly to information workers at their desktops. This has meant that information workers have not had a way to interact with XML Web services directly to access and use the enterprise information that they need.
InfoPath was designed to address all of these customer needs. It streamlines the process of gathering information and makes it easy to reuse that information throughout the organization. InfoPath is the “premier smart client” for XML Web services—a user-friendly application that enables information workers at their desktops to use XML Web services to access and use enterprise information.
The Uses for InfoPath 

InfoPath XE "InfoPath:Introduction"  provides information workers with a set of tools that enable the creation of dynamic forms to gather and share information across a wide range of formal and informal business processes. Unlike traditional forms packages, InfoPath provides a high degree of information-gathering flexibility, enabling people to obtain the information they need in a timely fashion and to make well-informed decisions.

Furthermore, because the native file format for InfoPath is XML and the application supports any customer-defined XML schema, as well as interoperability with XML Web services, the information gathered in InfoPath can easily be integrated with the organization’s databases and servers. This means that any information gathered with InfoPath can be reused and repurposed by anyone or any process in the organization, which greatly increases the productivity and power of that information.

As a member of the Microsoft Office System, InfoPath supports three key activities: the creation of dynamic forms, the completion of these forms, and submission of these forms to the systems and processes that need the information collected in the forms.

· InfoPath provides a robust, flexible, easy-to-use design tool that enables the creation of dynamic forms that information workers can use to gather information, either for formal ongoing business processes or for informal team projects.
· The same rich InfoPath client also provides an application environment in which information workers can complete forms quickly and easily. 

· InfoPath then connects this information to organizational business processes and makes that information easy to reuse through its support of XML, customer-defined schemas, and XML Web services. 
For example, InfoPath can help improve the efficiency and productivity of a company’s sales force and sales information. Prior to InfoPath, a salesperson returning from a business trip might have filed a trip report using Microsoft Word, entered new sales figures and pricing into a CRM or ERP application as a separate task, and completed an expense report using a custom-developed Microsoft Excel solution. She would have needed to enter the same information—client contact information, sales figures, pricing—multiple times, in different applications that do not share or cross-validate that information. The information within one business process, such as the trip reports in Word, would be difficult to reuse in the other business processes without manually reentering that information.
InfoPath can improve this error-prone and inefficient process. Using the powerful design tools in InfoPath, a form designer can quickly and easily create a trip report form for the sales force. Before departing on a trip, a sales representative can download the form from the corporate intranet site, put it on her laptop, and add information to the form after each client visit. Because InfoPath enables a user to work with forms offline, a sales representative can complete an entire trip form while on the road. She can submit the completed form as soon as she reconnects with the corporate network. The information submitted in an InfoPath form can be passed directly to an XML Web service that then repurposes the information for all the various reports that the sales person used to complete in separate processes, such as the trip report, the expense report, and the updates to the CRM and ERP systems. 
Moreover, the information gathered through InfoPath is now easy to reuse in all of the company’s business processes, such as purchase order creation, fulfillment, shipping, and customer shipment notification—even though these might be different systems in different locations. Finally, InfoPath is a valuable tool for the team’s informal processes, as the sales manager can use InfoPath’s integration with Microsoft® Windows® SharePoint™ Services (WSS) to review the entire sales team’s reports in one convenient summary view.
Information gathered through InfoPath can be stored directly in a database, on a Web server or file share, or on a server running WSS. From there, the information could be analyzed or easily repurposed, eliminating the need to retype the information as it is used in different documents or transactions. 
The bottom line? InfoPath provides individuals and organizations with more flexibility than is available in current digital formats, enabling a level of inter-application and inter-process integration that has never before been so easy to achieve.
The Advantages of InfoPath Over Existing Approaches

 XE "InfoPath:Advantages over other approaches" \r "AdvantagesOverOtherApproaches" As a method of gathering information and integrating it with business processes, InfoPath provides numerous advantages over paper forms, text documents, Web forms, and custom-built solutions. 
	InfoPath vs. Paper Forms

	
	InfoPath
	Paper Forms

	Improved Efficiency
	Information collected in an InfoPath form can be submitted directly to a Web service, a URL, a database, or similar destination; no rekeying of information is required.
	Information in a paper-based form must be rekeyed into a system; a process that takes time and increases the possibility of error.

	Reusability
	The information collected in a single InfoPath form can be used by many different systems and processes because the information is stored as XML.
	Information collected in a paper-based form can only be reused by other systems if someone rekeys that information into the other systems.

	Rich Authoring Environment
	InfoPath forms support richly formatted data, including information formatted with boldface, italic, and underlined fonts, information formatted in a variety of list and tabular formats, and information that takes the form of a graphic or picture, all of which can be bound to the XML schema for easy reuse throughout the organization.
	Paper-based forms provide no worthwhile support for richly formatted data, as the data must be rekeyed or scanned into the process for which the form has been developed—and the UI through which the information is entered may not support rich text.

	More Rapid Response to Change
	InfoPath forms can be updated, revised, and made available for use within a matter of moments.
	Paper-based forms must be reprinted in order to accommodate updates or changes, and that process can be a lengthy one, particularly if the forms are multipart forms. The expense involved with revising forms can also be significant.


	InfoPath vs. Traditional Text Documents

	 
	InfoPath
	Traditional Text Documents

	Connection to Business Processes
	Because InfoPath relies on an underlying XML schema that can be recognized by many different business systems and processes, the information captured in a single InfoPath form can be easily shared within the organization. 
	Traditional text documents are typically created with one system or process in mind, and they are designed to present only that process. The greater the number of processes, the greater the number of documents that need to be managed and maintained. 

	Reusability
	The information collected in a single InfoPath form can be used by many different systems and processes because the information is stored as XML. Moreover, InfoPath also communicates with ADO databases and XML Web services in a bi-directional manner, enabling the information stored in databases and servers to populate fields within InfoPath forms. This increases the speed and accuracy of filling out forms.
	Information collected in a traditional text document is designed to be consumed by a specific system or process that recognizes the format of that document. The information captured in the document can only be reused by other systems if someone cuts and pastes that information into the other text documents formatted to be recognized by those systems. Traditional text documents also cannot communicate via XML Web services or to ADO databases, so users must rekey information every time they complete the form.


	InfoPath vs. Web Forms

	
	InfoPath
	Web Forms

	Reusability
	The information collected in a single InfoPath form can be used by many different systems and processes because the information is stored as XML.
	Information collected in a Web form can only be reused by other systems if the Web form saves the information in a format such as XML that many systems can use. Not all Web forms do this.

	Rich Authoring Environment
	InfoPath forms support richly formatted data, including information formatted with boldface, italic, and underlined fonts, information formatted in a variety of list and tabular formats, and information that takes the form of a graphic or picture, all of which can be bound to the XML schema for easy reuse throughout the organization. InfoPath also provides built-in spelling checker support.
	Web forms generally provide no support for richly formatted text, lists, or the easy inclusion of graphics. 

	Validation
	InfoPath validates user input according to rules created by the form designer, and the form will alert users immediately when input does not appear valid. 
	Web forms do not offer real time validation of data; a user is alerted of an error only after attempting to submit a form. 

	Flexibility of Form Completion
	InfoPath enables users to begin working on a form and save the incomplete form for later completion and submission. InfoPath forms can even be completed offline and submitted when the user is later connected to the network. Because InfoPath provides the ability to work offline, users no longer have to worry about losing their information and are free to work at their own pace.
	Users must complete the form in real time. There is no option to save an incomplete Web form for completion at a later date. All the information a user entered is lost if a user cannot complete the form in one sitting. Web forms must be completed while the user is online.


	InfoPath vs. Custom-Built Solutions

	
	InfoPath
	Custom-Built Solutions

	Deployment Investment
	InfoPath provides instant access to both a design and form completion environment that can be tailored quickly to meet the needs of your entire organization. As a member of the Microsoft Office System, InfoPath builds on user’s familiarity with the conventions of Microsoft Office and the Office application interface. The application can also receive automatic updates and patches from Microsoft. Microsoft support is available, too, so there is always a source for answers to questions.
	Custom-developed solutions require a large investment of time and resources. A solution must be specified, approved, designed, tested, and documented before it can be rolled out for use in the organization. The organization may have to develop training programs for designers and end users; it will also have to develop help desk facilities to respond to user and designer questions. It will also be responsible for identifying and remedying application bugs, maintaining application security, and issuing application updates.

	Rich, Flexible Authoring Environment
	InfoPath forms support richly formatted data, including information formatted with boldface, italic, and underlined fonts, information formatted in a variety of list and tabular formats, and information that takes the form of a graphic or picture, all of which can be bound to the XML schema for easy reuse throughout the organization. 
	A custom-built solution may not provide as flexible an authoring or forms completion environment. 

	Increased Productivity
	InfoPath provides a design environment that facilitates the rapid creation and modification of forms, which in turn ensures that forms are always ready to capture the information required by the organization.
	A custom-built solution may not provide a design environment that enables such rapid creation of forms—which would compromise the organization’s ability to gather and consume information efficiently.


The bottom line? Today, InfoPath is the only application that provides all of the capabilities for structured document creation and editing in a single, easy-to-use package. Some products allow rich text editing with flat structures, while others provide repeated structure with little rich text editing. Most existing products require users to write code or to possess advanced XML knowledge in order to build or even fill out forms. InfoPath is the only application that combines all of the necessary features into a single, easy-to-use product that empowers information workers of all skill levels.

Overview of InfoPath XE "InfoPath Features: Overview"  Features

WYSIWYG design mode. The InfoPath XE "InfoPath:Design mode"  design mode makes it easy to customize existing forms or build a custom form from scratch or from an existing data source. It provides drag-and-drop insertion of controls, data validation, a view of the underlying schema, and an interactive preview so that users know exactly how the form will behave and look when completed, and a publishing wizard that simplifies form deployment. 

Familiar environment for filling out forms. As part of the Microsoft Office system, InfoPath provides a familiar environment in which users can fill out forms while the XML is created behind the scenes. InfoPath combines a forms editing experience with that of a word processor, bringing rich text editing, including spelling checker and auto-correct, to the world of structured form creation. This enables users to work with structured documents without needing to know anything about XML. It also reduces the amount of training required to become productive with the tool. 
Sample forms. InfoPath XE "InfoPath:Sample Forms"  provides numerous sample forms that can be easily customized in design mode to fit specific business needs. InfoPath also provides sample forms that can be used as a designer resource, demonstrating how InfoPath can automate and be integrated into a number of different business processes. 

Programmability. InfoPath XE "InfoPath:Programmability"  includes a script editor, object model, editing controls, and a clear text XML format for various form files, which give designers the ability to add custom scripting, control the run-time behavior, and integrate custom forms directly with a server or Web service.

Integration with Office and other Microsoft products. InfoPath XE "InfoPath:Office Integration"  is fully integrated with other Office and Microsoft products to provide additional functionality. For instance, InfoPath can be used in conjunction with Windows SharePoint Services as a way to increase team collaboration by providing a single location for InfoPath forms to be stored and shared. InfoPath can also export information to Microsoft Excel, and InfoPath forms can be shared through Microsoft® Office Outlook® and Microsoft Internet Explorer.
Other familiar features include:
· Dr. Watson XE "Dr. Watson support"  support. InfoPath includes support for Dr. Watson, which allows users to send data back to Microsoft on crashes so Microsoft can track down crashing bugs in the product.

· Help support. Users can get assistance on features using the standard Office help mode and the "Type a question for help" well in the toolbar.
· Product training. InfoPath has product training to help users learn more about the functionality of the product.
· Terminal Services XE "Terminal Services support"  support. InfoPath can be run as an application delivered through Microsoft® Windows® 2000 Server with Terminal Services.

· Windows Logo requirements. InfoPath meets Windows Logo requirements.
InfoPath has been internationalized to support organizations and users in a wide range of locations, including Asia, South America, and Europe.

InfoPath in Action

Converting Data to Knowledge  XE "InfoPath:Benefits:Converting data to knowledge" 
When organizations gather data via traditional forms, they often lose the context that accompanies that data—the salesperson’s personal knowledge of a comment that a client made during the meeting, for example. Organizations end up collecting data, but not knowledge. Unlike traditional forms packages, InfoPath is a flexible information-gathering application that enables people to connect data with context. By enabling a user to expand and collapse entire groups or sections of the form, adding comments and context, InfoPath helps an organization capture more knowledge. With that knowledge, people throughout the organization can make faster, well-informed decisions. 
InfoPath forms are flexible and highly dynamic. They can be designed with optional sections or with sections that expand and repeat as necessary. A purchase order form, for example, could be designed to present an initial display of only one line item to be purchased—but additional lines could be added by the individual filling out the form simply by clicking a button on the form. Forms can also be designed to include hidden sections which will appear in the form only when the user performs a specific action or provides information that fulfills specific conditions. 
	Feature
	Description
	Invocation

	Repeating Optional Sections 
	

	Repeating Sections

 XE "InfoPath Features:Repeating sections" 
	InfoPath forms can have sections that repeat. The initial view starts with one section, and users can add more sections when and if necessary.

The repeating section control enables form designers to identify sections and table rows that can be repeated by the user when filling out a form.


	To add more sections when completing a form, the user can click on the drop-down menu arrow in the margin of a row in a repeating section (see Figure 1 in the screen shot appendix) or add a section by selecting an item from the Section flyout in the Insert menu (see Figure 2 in the screen shot appendix).  XE "How to...:Add repeating sections" 
Alternately, the user can right-click within a section to see a pop-up menu of insertion choices (see Figure 3 in the screen shot appendix).
To create a repeating section in a form while using the editor, select the Repeating Section or Repeating Table control in the Controls task pane (see Figure 4 in the screen shot appendix) and drag it to the location in the form where you want to insert the repeating section.



	Optional Sections XE "InfoPath Features:Optional elements and sections" 

	Form designers can add optional sections. These sections can be called up by following a prompt specified in the section’s Property field. A user might see the prompt, “Click here to insert a Time Report” at the bottom of a Status Report form. By clicking on that prompt, the form will display the optional time report, which would not otherwise be visible. 

This control enables designers to identify data sections that will be added on demand by the end user.
	Select the Optional Section control from the Controls task pane. 

To add instructional text (such as “Click here to insert a Time Report”), select the optional section and open the Section Properties dialog to the Data tab. Check the Show Instructional Text option at the bottom of the tab and enter the appropriate message in the field provided.  XE "How to...:Add optional sections" 

	Conditional Formatting
	

	Conditional Formatting and Visibility XE "InfoPath Features:Conditional formatting" 

	Form designers can apply conditional formatting to fields and sections, causing them to appear in specific ways when specific conditions are met. Form designers can specify whether a field or section is shown or hidden, based on conditions in the data. 

	By selecting a field and opening the Display tab on the Properties page, the designer can create and control conditional formatting. If a specified condition is true, the field can be formatted to display specific font characteristics, font colors, and background colors. By checking the “Hide this control” option in the Conditional Format definition window, the section or control will be hidden if the condition is true (see Figure 5 in the screen shot appendix).  XE "How to...:Conditional formatting" 


Increase Efficiency XE "InfoPath:Benefits:Increasing Efficiency" 
InfoPath provides an efficient and accurate way to collect information and make well-informed decisions XE "InfoPath:Benefits:Better decision-making" .

· Designers can create rich, highly dynamic forms with little or no coding— saving valuable development time and money.

· InfoPath forms can validate data to help ensure that the information being gathered is accurate and meets the organization’s business criteria—avoiding costly errors. 

· Organizations can gather information in a manner that is consistent and that suits the needs of the team or organization.

Because InfoPath provides powerful data and schema validation features, InfoPath forms help ensure that the data you collect can be used efficiently within your organization. The forms can require specific fields to adhere to specific formats and flag those fields in which users have entered data that does not meet expectations. And because the information gathered through InfoPath is stored as XML data that can be readily passed to any process that accepts XML input, the information gathered through an InfoPath form can be quickly and efficiently entered into the key processes supporting your organization—without rekeying that information and running the risk of data reentry error.
InfoPath also provides a way to gather information consistently. A sales manager might want to collect contact information and travel itineraries for a large team of sales representatives. By sending out an e-mail message with this request, the manager may get contact information and travel itineraries returned in 50 different ways—some of which will not even be complete. By sending out an InfoPath form, the representatives will return information in a form that is consistent and complete.

InfoPath supports a broad range of XML-related technologies, which enables an organization to capitalize on existing investments and which enables form designers to create forms that can quickly and easily link users with business processes. Some of the technologies and standards that InfoPath supports include:
· W3C standards XE "InfoPath Features:W3C standards" . InfoPath is built on non-proprietary industry standards such as XML 1.0 SE, Namespaces in XML, DOM 1.0, XML DSIG, XSD 1.0 (XML Schema Part 1: Structures), XSD 1.0 (XML Schema Part 2: Datatypes), XSLT 1.0, XHTML 1.0, UDDI 1.0, WSDL 1.1 and SOAP 1.1.

· Object Models (OM). InfoPath supports the Document Object Model (DOM), the Canvas OM, and OMs for validation, submit, and other actions.  XE "Form Development:DOM Support" 

 XE "Form Development:OM Support" 
InfoPath also provides support for JScript and VBScript, enabling designers to use the scripting models with which they are already familiar to further enhance the rich functionality of InfoPath forms.
	Feature
	Description
	Invocation

	Validation
	

	Real-Time Schema Validation XE "InfoPath Features:Schema validation"  XE "Schema:Validation" 
	InfoPath provides client side-validation and error-reporting on the data and structure of a form being developed. If the schema calls for a numeric entry in a field and a user enters an alphabetic entry, InfoPath will alert the user of an error inline. 
	InfoPath performs validation automatically based on the characteristics of the schema. No designer or user invocation is required.

	Built-in Validation Rules XE "InfoPath Features:Validation rules" 
	InfoPath provides the ability to create custom (business logic) validation through the user interface. InfoPath provides both inline and dialog box alerts.
	When in InfoPath design mode, select a field or control and open the Property page. Select the Data tab and click the Data Validation button. Click the Add button to create the validation criteria, the alert type, and message text for that field.  XE "How to...:Create or modify validation rules" 

	Real-Time Custom Validation XE "InfoPath Features: Field validation" 
	In addition to the real-time schema validation and built-in validation rules described above, InfoPath also enables forms designers to specify complex real-time client side-validation and error-reporting through the use of scripts. Form designers can have InfoPath validate input against custom-defined business requirements. Designers can write scripts based on a set of predefined events: 

 onBeforeChange

 onValidate

 onAfterChange

Through scripts, form designers can control whether the error alert will be an inline alert, which identifies errors by highlighting the non-compliant field and offers a screen tip and an optionally-displayed error message, or a dialog box alert, which immediately displays an error message and rejects the non-compliant input.
	Real time validation is automatic when data validation criteria have been applied to a field or control. As the user enters information in the form, InfoPath automatically validates it.
Form designers can indicate whether an alert will be an Inline Alert or a Dialog Box Alert from within their scripts.  XE "How to...:Validation alerts, setting up" 


	Form Design
	

	Form Design from Scratch, from an Existing Customer-Defined Schema, or an XML file XE "InfoPath Features:Designing forms with generic schema" 

 XE "Schema:Designing from a generic schema" 

	InfoPath enables designers to create forms using an organization’s existing schema or from scratch. Schema can be an existing XSD or derived from an existing database or Web service. 

If building a form from scratch, form designers can drag and drop controls into their form, and InfoPath creates a schema behind the scene.


	To build from an existing schema, select the Design a Form task pane in InfoPath design mode. Click New from Data Source and browse for the XSD file, XML file, database, or Web service you want to work with (see Figure 6 in the screen shot appendix). XE "How to...:Design forms" 
To build a form from scratch, select the Design a Form task pane in InfoPath design mode. Click New Blank Form. Designers can then drag and drop controls from the Controls task pane (see Figure 7 in the screen shot appendix). As they do this, InfoPath creates the XML schema in the background. XE "How to...:Design forms" 

	WYSIWYG Form Design XE "InfoPath Features:WYSIWYG design tools" 

	InfoPath provides a “what you see is what you get” (WYSIWYG) design environment, with layout control features that enable designers to create forms quickly and easily. InfoPath provides a Layout task pane that enables designers to add tabular sections to lay out the form quickly. The task pane also offers features to split and merge cells to make the modifications of the inserted tables easier.
	When in InfoPath design mode, Select the Layout task pane (see Figure 8 in the screen shot appendix).  XE "How to...:WYSIWYG design mode" 


	Tree-Type Schema Representation with Drag-and-Drop XE "InfoPath Features:Schema representation" 

 XE "Schema:Representation" 
 XE "InfoPath Features:Drag and drop from schema " 

 XE "Schema:Drag and drop fields or groups in form" 
	InfoPath represents XML schema in a branching tree format for easy identification of relationships and dependencies.
When developing a form, designers can drag an element from the schema displayed in the task pane and drop it into the form; InfoPath automatically determines the type of data represented by the schema and inserts the appropriate default control.
	When in InfoPath design mode, select an XML field or group from the Data Source task pane and drop it in the desired location in the form (see Figure 9 in the screen shot appendix).  XE "How to...:Drag and drop schema objects" 


	Form Design
	

	Basic Schema XE "Schema:Editing"  Editing XE "InfoPath Features:Schema Editing" 

	InfoPath enables designers to name, move, or change the data type of fields and groups if the user started from scratch or if the schema allows this type of change. 
	To add a field or group, enter the InfoPath design mode and select a field or group from the Data Source task pane. Click the Add button below the schema tree. In the Add Field or Group window, enter the information about the new field or group (see Figure 10 in the screen shot appendix).
To edit an existing field or group, select from the schema tree in the Data Source task pane. Click on the drop-down list arrow and select Properties.
To move a field or group, select from the schema tree in the Data Source task pane. Click on the drop-down list arrow and select Move. Select the desired location in the Move Field or Group window.  XE "How to...:Edit schema " 

	Color Schemes XE "InfoPath Features:Form color schemes" 
	InfoPath has numerous color schemes that can be applied to any form created in the design mode, or to the sample forms that ship out-of-box. 
	When in InfoPath design mode, select the Color Schemes task pane and click the desired color scheme.  XE "How to...:Color schemes" 

	Editing Preview XE "InfoPath Features:Previewing forms" 

	Form designers can preview their form design to see how end users will interact with the form without actually having to leave the InfoPath design mode.
	In the design mode, click the Preview Form button in the Standard toolbar. Or, select the Preview Form flyout from the File menu.  XE "How to...:Preview forms in design mode" 


	Forms Design: Controls
	

	Standard Control Toolbox XE "InfoPath Features:Controls" \t "See InfoPath Controls" 

 XE "InfoPath Controls:Standard toolbox"

	InfoPath includes all the controls that designers expect from a forms design package—from text box and drop-down list box controls to controls for rich text boxes, option buttons, numbered and bulleted lists, hyperlinks, pictures, expression boxes, as well as optional and repeating sections.


	In the InfoPath design mode, designers can open the Controls task pane and gain ready access to all the controls (see Figure 7 in the screen shot appendix). 

Designers building a form from scratch need only drag and drop the controls into place; InfoPath automatically creates the XML schema in the background.  XE "How to...:Controls:Accessing" 

	Managing Controls XE “InfoPath Controls:Converting controls"

 XE “InfoPath Controls:Rebinding controls"

 XE “InfoPath Controls:Automatic label insertion"
	InfoPath enables designers to convert a control from one type to another. It also enables designers to rebind a control to a different field or group in the schema. InfoPath also automatically converts control labels from their unfriendly schema format names (such as “FirstName”) to a human readable format (“First Name”) after drag-and-drop of an element from the data source into the view.
	In InfoPath design mode, right-click on the control to be converted. Then, select Change to… from the pop-up menu.  XE "How to...:Controls:Converting" 
In InfoPath design mode, right-click on the control to be rebound. Then, select Change Binding… from the pop-up menu.  XE "How to...:Controls:Rebinding" 

	Customize Control Properties XE “InfoPath Controls:Customizable control properties"

	InfoPath provides designers with an interface for changing the characteristics of controls. The font size, scrolling behavior, wrapping behavior, and default text for a box, for example, can all be customized. InfoPath also provides the ability to set the spelling checker and auto-complete on or off for text fields.
	In InfoPath design mode, right-click on the control to be customized. Select Properties and click the Display tab (see Figure 11 in the screen shot appendix).  XE "How to...:Controls:Customizing properties" 

	Population of Controls from a Database Lookup XE “InfoPath Controls:Database source support"
	List box controls can be populated with data that is coming from a database backend.
	In InfoPath design mode, right-click on the control to be populated. Select Properties and then identify the source from which the information should be drawn. Designers can browse for a specific database, Web service, or file from which to populate the control. A secondary data source wizard guides the designer through the process.

	Button Control with Built-in Behaviors XE “InfoPath Controls:Button behavior "

	InfoPath provides designers with button controls that are predefined. With a predefined button for submitting form data, for example, a form designer need only specify the database, Web service, or server to which the data should be sent; there is no complicated coding involved. Similarly, the designer need only specify a database, Web service, or server in order to instigate a query that will result in form data being gathered. The complexities of creating the query have already been taken care of.
	Buttons can be placed in a form by dragging the Button control from the Control task pane to the view. 

By right-clicking the control and selecting the Button Properties page, the designer can specify whether the button will execute a script, refresh a DOM, or submit the form to a Web service, a URL, or other destination (see Figure 14 in the screen shot appendix).  XE "How to...:Submitting data, managing behavior " 


	Controls
	

	Text Box
	Used for gathering input that does not require complex formatting.
	These controls are available from the Controls task pane (see Figure 7 in the screen shot appendix) in the design mode.

They are also available from the Insert menu. XE "InfoPath Features:Controls"  XE "Form Development:Controls" 

	Rich Text Box
	Used for gathering input that requires support for paragraph breaks, font formatting, images, tables, etc. 

Note that the data in a rich text box is stored as a single entity in the resultant XML file. If the data collected in the list or table needs to be easily parsed on the back end, the designer should use other controls.
	

	Drop-down
	Used for displaying a drop-down list.
	

	List Box
	Used for displaying a scrollable list.
	

	Date Picker 
	Used for selecting dates from a calendar.
	

	Check Box
	Used for controlling an exclusive list of options.
	

	Radio Button
	Used for controlling a non-exclusive list of options.
	

	Section


	Used for delineating simple data sections. Other controls can be inserted inside this section.
	

	Repeating Table
	Used to help form designers create tables that are explicitly bound to data elements in the schema. A form designer would use a repeating table control when the data in the table needs to be parsed on the back end.
	

	Bulleted List
	Used for creating an input field formatted as a bulleted list that is bound to an element in the schema.
	

	Numbered List
	Used for creating an input field formatted as a numbered list that is bound to an element in the schema. 
	

	Plain List
	Used for creating an input field formatted as a plain list that is bound to an element in the schema. 
	

	Button
	Used to insert a button on a form for running a script, refreshing a DOM, or submitting a form.
	

	Hyperlink
	Used to insert a hyperlink bound to data in the form.
	

	Picture
	Used for enabling a user to import a picture and bind it to the form.
	

	Expression Box (Static Text Control)
	The InfoPath expression box control displays simple XML data or a transform on that data (such as the merging of two nodes). It is a read-only control that displays in the form.
	

	Ink Picture
	Used for capturing signatures and other ink entry such as drawings on a Tablet PC XE "InfoPath Features:Table PC Ink Entries"  XE "How to...:Capture Ink input on a Tablet PC" 
	


	Development 
	

	Resource Management XE "Form Development:Resource management" 
	InfoPath enables designers to add resources (DLLs, secondary XML files, etc.) to a solution.
	Select Resource Manager from the Tools menu. The resource manager window enables the designer to add, remove, rename, or export resources.  XE "How to...:Manage resources" 

	Roundtrip Form Template Changes Made Outside the Environment XE "Form Development:Hand-editing sections" 
	InfoPath enables designers to hand-edit their XSLT within blocks marked “verbatim” and subsequently work on those files again in the designer. All of the changes are retained and the blocks are clearly marked in the designer to indicate that these are hand-edited sections.
	Designers can edit their XSLT in a text editor such as Notepad or the Microsoft® Visual Studio® development environment. Any text between blocks marked “verbatim” will be retained exactly as written when the file is opened in InfoPath XE "How to...:Manually edit XSLT" .

	Export Form Files XE "Form Development:Save as a folder
	InfoPath allows users to save out the individual form files to perform additional development.
	Select Export Form Files from the File menu. InfoPath prompts the designer for a location for the folder.  XE "How to...:Export forms" 

	Custom Editing Behaviors
	Form designers can add repeating sections to their forms and control exactly which fragment of XML gets inserted when end users add a section. Additionally, form designers can specify where the UI options for inserting these sections appear in the menus. They can even create a form-specific toolbar for exposing these commands.
	In design mode, right-click the Repeating Section control and choose Properties. On the Data tab, click Edit Default Values to change the fragment of XML that is inserted. To change the default UI location or to add these commands to a form-specific toolbar, click Customize Commands.

	Custom Dialog Boxes XE "Form Development:Custom dialog boxes" 
	Form designers can create custom HTML dialog boxes for their form solutions. By linking these custom dialog boxes through scripts, a form designer can add, for example, custom wizards or data catalogs.
	Form designers can use any HTML editing tool to create custom dialog boxes. They can be linked into forms through scripts attached to InfoPath events such as onBeforeChange, onValidate, or onAfterChange.




	Development 
	

	Custom Task Pane XE "Form Development:Custom task pane" 
	Form designers can create a custom HTML task pane for their form template, leveraging Office task pane infrastructure.
	Select Form Options from the Tools menu; select the Advanced tab and check Enable custom task pane. InfoPath prompts the designer to provide a custom task pane name and location.  XE "How to...:Task pane customization" 

	Built-in Script Tool and Debugger XE "Form Development:Debugger" 
	Designers can use Microsoft Script Editor which is integrated into InfoPath.

InfoPath supports both Visual Basic Script and JScript.  XE "Form Development:Script support" 

 XE "Form Development:JScript" 

 XE "Form Development:VBScript" 
	To access the script editor directly, select Microsoft Script Editor from the Script flyout in the Tools menu.  XE "How to...:Scripts, editing and debugging" 

	Software Developers Kit
	

	Advanced Sample Forms
	The Software Development Kit for Microsoft Office InfoPath 2003 (SDK) provides sample forms for interoperability with SQL Server™, BizTalk® Server, Windows® SharePoint™ Services, and Excel.  XE "InfoPath:Sample Forms" 
	In design mode, select the Design a Form task pane. Then, click Customize a Sample to see a list of the included sample forms.


Share Information Throughout the Organization 

 XE "InfoPath:Benefits:Share information throughout the organization" InfoPath makes it easy for organizations—or teams within an organization—to reuse and repurpose the information collected across business processes. Because it is based on XML, the information captured in InfoPath forms can be shared with any process that makes use of an XML schema. Also, InfoPath helps make it easier to integrate information with business processes because the application has built-in support for XML Web services and interoperability with XML-enabled servers and databases.
Moreover, InfoPath enables the creation of forms that can be used to share information across many different processes. A single trip report form, for example, can provide properly formatted XML data to a CRM system that has one XML schema, a petty cash system that relies on another XML schema, a travel planning system that uses yet another schema, and so on. All the information required by each of these systems can be captured once in an InfoPath form and disseminated—through a Web service, through an http call, or through script—to each of the appropriate systems, without rekeying or redundant data entry. This makes InfoPath a very efficient solution for sharing information throughout the organization. 
	Feature
	Description
	Invocation

	Repurpose
	
	

	Multiple Views of Forms XE "Form Development:Views, multiple" 
	InfoPath enables the creation of multiple views of a form. One view might be a summary version of the form, for example; another might be a view of the full version of the form. InfoPath enables designers to specify the default view, as well as which views are available to end users in the view menu. Each view uses the same underlying data, either showing, hiding, or reordering parts of the data.
	In InfoPath design mode, open the Views task pane. The initial view appears in the task pane window, and by clicking Add a New View in the Actions section of the Views task pane the designer can create additional views (see Figure 16 and Figure 17 in the screen shot appendix). 

By cutting and pasting layout elements between views in the InfoPath design mode (or by dragging and dropping from the Data Source task pane), the designer can create precisely the new views desired.  XE "How to...:Views, managing multiple" 

	Merge Form XE "Form Development:Merging forms"  Information
	InfoPath provides the ability to merge information from multiple instances of a form into a single form. Merging forms enables an individual to consolidate information from many different users, for example, or to gather information in a single form that has been collected in other forms. 

By default, InfoPath will merge any repeating sections within a form (including fields contained within a repeating section, repeating tables, or lists). To go beyond this basic merging behavior, a designer can also create an XSLT file by hand to customize the functionality.
Forms developed from a blank template are enabled for merging data by default. Form designers can disable forms for merger.
	While filling out a form, select Merge Data from the File menu. The merge data dialog box enables you to identify the forms to merge.
This can also be done within form libraries in Windows SharePoint Services.
Form designers can disable forms for merger by selecting the Form Options option on the Tools menu. On the General tab, deselect Enable forms for merging.  XE "How to...:Merge forms" 

	Exporting Information  XE "Exporting Forms" 
 XE "Exporting Forms:To XML" 
	End users can export their current view to the Web in an .MHT format. The current view can be exported in a file format recognized by browsers, enabling others without InfoPath to view the content of a form. 

End users can also export selected form data to Excel for analysis. 
	In the InfoPath edit mode, select Export to… flyout from the File menu. Chose Web from the flyout to create an .MHT file for viewing in a browser. Choose Microsoft Office Excel to create an Excel spreadsheet.  XE "How to...:Export forms" An InfoPath export wizard guides the user through the export steps.  XE "How to...:Export forms" 

 XE "How to...:Export forms" 


	Development 
	

	Publish Forms to Shared Folders or Web Servers XE "InfoPath Features:Publishing forms" 
	InfoPath forms can easily be published to a shared folder on the local network or a Web server.
	To publish a form template to a shared folder, click Publish on the File menu while in the InfoPath design mode. On the Introduction page, click Next. Click To a shared folder on this computer or on a network and click Next. Follow the steps in the wizard.

To publish to a Web server, click Publish on the File menu. On the Introduction page, click Next. Select To a Web server and then click Next. Follow the steps in the wizard. 



	Integration with Windows SharePoint Services (WSS)  XE "InfoPath Features:SharePoint integration" 
	Form designers can share forms with others in the organization via form libraries in a WSS Web site. Users can also fill out forms via form libraries in WSS. Using InfoPath with form libraries in WSS enables efficient collaboration and data collection in a familiar, Office-integrated environment.


	To publish a form template to a WSS form library, click Publish on the File menu while in the InfoPath design mode. On the Introduction page, click Next. Click To a SharePoint form library and click Next. Follow the steps in the wizard.

To fill out a form in a WSS form library, team members can click the Fill Out this Form command in WSS. A new blank form based on the form template will open in InfoPath, ready to be filled out.

	XML Property Promotion with WSS
	Because InfoPath and WSS form libraries are XML enabled, forms can directly populate field data into form library columns; this is called XML property promotion. Users of the form library can then use this information to sort and track information contained in a form library without needing to open the form. Available column headings are based on settings in the form template.
	To sort and arrange data in a form library, simply click on the available column headings.

To set the available column headings for a form template in InfoPath design mode, click Form Options on the Tools menu. In the Form Options dialog box, click the Form Library Columns tab. Do one or more of the following:

· To add a form field to the list, click Add. Choose a field or group from the data source, type the column name you want to appear in the form library column, and click OK.

· To delete a column from the list, select it, and click Remove.

· To change a column in a form library, select the corresponding column in the list, and click Modify. Choose a different field or group from your data source, modify the column name, and click OK.




	Development 
	

	Built-in E-Mail Integration XE "InfoPath Features:E-mail integration" 
	InfoPath enables users to collaborate on their forms out of band, outside the normal business process, through built-in e-mail integration with Microsoft Office Outlook 2003.
	Select Send to Mail Recipient from the File menu (see Figure 12 in the screen shot appendix).  XE "How to...:E-mail forms" 

	Interacting with Data Repositories XE "InfoPath Features:Submit button" 

 XE "InfoPath Features:Query button" : Submit and Query
	InfoPath enables users to submit form data to a database using the ADO protocol, to an HTTP server, using the POST method, or to a Web service through the SOAP protocol.

Designers can also type in custom messages to be presented upon the success or failure of submission, as well as specify what should happen to the form upon submission (remain open, close, etc.).
When creating a form based on a database or Web service, InfoPath automatically creates a separate query view, which allows end users to enter information to filter their database query and get back the desired records.
	A Submit button can be placed in a form by dragging the Button control from the Control task pane to the view. 

By right-clicking the control and selecting the Button Properties page, a designer can specify whether the button will submit the form to a Web service, a URL, or another destination through a script. The designer can also manage post-submission actions on the Button Properties page (see Figure 13 and Figure 14 in the screen shot appendix).  XE "How to...:Submit forms" 
 A query view is created by default when the form designer creates a new form based on a database or Web service. 

	Document Security
	

	Digital Signatures Support XE "InfoPath Features:Digital signatures" 
	InfoPath provides counter-signing through digital signatures. Form designers can specify whether to allow forms to be signed or not.
	To enable users to use digital signatures, the designer selects Form Options from the Tools menu. By clicking the Security tab, the designer can select and clear the “Allow Users to digitally sign this form” box.

Users can sign these forms by selecting Digital Signatures… from the Tools menu.  XE "How to...:Digital signatures" 


Manage Information More Flexibly

InfoPath gives teams and organizations more flexibility in dealing with rapidly changing business conditions. The application enables form designers to create and modify forms quickly and easily to adapt to changing business needs. It also enables form users to interact with forms as they would interact with other documents. Users can work on a form, complete it partially, and save it for later completion. They can save the form locally, work on it while disconnected from the network, and submit the form later when once again linked to the network. Because InfoPath supports richly formatted text, users can complete forms using formatted text, bulleted lists, tables, and even graphics. InfoPath even enables designers to create forms with optional and repeating sections—so the form dynamically expands to accommodate the information that users need to enter.
	Feature
	Description
	Invocation

	Editing
	

	Rich Formatting of Text
	InfoPath enables form designers and end users to use richly formatted text in the forms. Within text boxes, designers and end users can format information using bold, italic, and underlined fonts; they can specify non-default font sizes and colors; they can also format information as numbered or bulleted lists.
	Font formatting in rich text boxes can be managed while filling out a form by selecting the Font or Bullets and Numbering task pane (see Figure 15 in the screen shot appendix).  XE "How to...:Design forms:With rich text" 

	Hyperlinks
	InfoPath enables form designers and end users to insert hyperlinks in rich formatting areas.

InfoPath recognizes URLs and e-mail addresses and automatically formats them as hyperlinks.
	URLs and e-mail addresses are automatically recognized as hyperlinks when entered in a rich text field. 
Hyperlinks can also be attached to selected text in a rich text field. To attach a hyperlink, highlight the text and select Hyperlink from the Insert menu. Enter the URL in the Link to field and modify the display text if and as appropriate.  XE "How to...:Hyperlinks, use of" 

	Lists
	InfoPath offers the ability to add bulleted and numbered lists into rich text areas.
	Select the Bullets and Numbering task pane to choose a list format.  XE "How to...:Design forms:Lists" 

	Tables


	InfoPath supports the insertion of tables into form sections that support rich formatting.

End users can set borders or shading of tables. End users can also split and merge the cells in a table.
	Select the Insert flyout from the Table menu to create a table in a rich text field.  XE "How to...:Design forms:Tables" 
Click Borders and Shading… from the Table menu to change borders and shading. 

Select the cells to be split or merged and then click Merge Cells or Split Cells on the Table menu. 


	Editing
	

	Inline Images and Graphics Support
	InfoPath enables users to insert inline images, clip art, or other graphics into rich text portions of their forms.
	With the insertion point positioned where the image will be placed, select the Picture flyout from the Insert menu.  XE "How to...:Images, use of" 

	Spelling Checker and AutoCorrect


	InfoPath provides built-in spelling checker support for both form designers and form users. InfoPath users can set spelling checker to occur as they type (misspelled or unrecognized words appear underlined with a red squiggly line) or they can use spelling checker to check an entire form. 

InfoPath can learn to correct common misspellings and typos.
	Select Spelling from the Tools menu to check selected text or, if no text is selected, an entire form.

Select Options from the Tools menu and click the Spelling tab to control spelling checker behavior.

Right-clicking on a misspelled word displays a pop-up menu with options for correcting the error.  XE "How to...:Check spelling" 

	Ink Capture
	InfoPath provides an Ink Picture control to capture signatures, drawings and other content that will be stored as ink. XE "InfoPath Features:Table PC Ink Entries"  XE "How to...:Capture Ink input on a Tablet PC" 
	On a Tablet PC, you can immediately start inking in forms that include ink capture areas.  

The Ink toolbar will automatically appear with Pen and Eraser tools when ink entry is available 

	Offline Support XE "InfoPath Features:Offline support" 
	InfoPath provides the ability to save forms locally during design or editing. A user having to leave a form incomplete can reopen the form at a later time and resume form completion, without losing the information entered earlier.
	Select Save or Save As from the File menu.  XE "How to...:Save forms for offline completion" 

	Find and Replace
	Form designers and end users alike can use the familiar Find and Replace tools within InfoPath. 
	Select Find or Find and Replace from the Edit menu.  XE "How to...:Find and replace" 

	Auto-Complete
	Like Internet Explorer, InfoPath can keep track of responses entered into form fields. When the user subsequently encounters a known field (a phone number field, for example), InfoPath can offer a drop-down list of likely responses.
	InfoPath keeps track of responses; no action is required of the user except to select the appropriate response (if there is one) from the drop-down list.

In design mode, Auto-Complete can be disabled for a specific field in a form by bringing up Properties and selecting or clearing the Auto-Complete item on the Display tab. XE "How to...:Autocompletion of forms" 

	Drag-and-Drop Editing
	Users can drag and drop data (including text and graphics) from one location to another either while designing a form or completing one. 
	Select the data to be moved, drag it to the target location, and drop it by releasing the left mouse button.


	Sample Forms
	

	Sample Forms
	InfoPath ships with a number of sample forms which are customizable by users in InfoPath design mode.  XE "InfoPath:Sample Forms" 
	In InfoPath design mode, select the Design a Form task pane and click Customize a Sample… XE "How to...:Design forms:From samples" 

	Printing
	

	Page Setup XE "InfoPath Features:Printing forms" 
	InfoPath enables end users to select paper sizes, output orientation, and margins.
	Select Page Setup from the File menu.  XE "How to...:Print:Page setup" 

	Print Preview
	End users can see a preview of what they are going to print before actually printing. 

Forms printed out by end users look good by default; there are, for example, no drop-down arrows or scrollbars on list boxes.
	Select Print Preview from the File menu.  XE "How to...:Print: Previewing output" 

	Custom Print View Support
	Form designers can define print views specific to each of the other views in their forms.
	In design mode, select the Views task pane. Select a view and click Create Print View for this Version in the Actions section of the task pane (see Figure 18 and Figure 19 in the screen shot appendix).
To change the print view associated with a particular View, select a view and click the View Properties button in the Views task pane. Click the Print Settings tab to specify the print view to be associated with the selected view. 


Take Advantage of Existing IT Investments

IT professionals can take advantage of their existing investments in business systems, their existing XML schema XE "Schema:Use of existing schemas" , and their existing knowledge base when deploying InfoPath. Because InfoPath forms submit information formatted against an XML schema, the information gathered through InfoPath can be used in business systems that can work with XML-based input. As systems and processes evolve, form designers can update new InfoPath forms quickly and efficiently, and these forms will be silently upgraded throughout the organization when the form is next opened.

InfoPath builds on the user’s familiarity with the longstanding operation conventions of Microsoft Office. Users familiar with Microsoft Office will find it easy both to design forms in InfoPath and to use forms designed in InfoPath. The application has been internationalized to meet the needs of a wide range of users. It provides East Asian find and replace, clipboard, grid support and proofing tools. It is available in multiple languages, including:
Chinese (Pan)

Chinese (Simplified)

Chinese (Traditional)  

Czech

Danish

Dutch

English

Finnish

French

German

Greek

Hungarian

Italian

Japanese

Korean

Norwegian

Polish

Portuguese (Brazilian)

Portuguese (Portugal)

Romanian

Russian

Slovenian

Spanish

Swedish

Turkish
InfoPath has been designed to work securely and effectively within an environment already filled with sensitive systems and processes. It helps to protect these existing investments by supporting a range of deployment options, including:
· Administrator-configurable installs. Administrators can custom-install the product to include or exclude functionality. InfoPath can provide support for lockdown environments, too.
· Zero administration install of form packages. If an end user opens a form in the editor, it is seamlessly installed in the background.
Using the Microsoft Office Resource Kit, administrators have a range of options for just how to deploy InfoPath within the organization. The application can be deployed on a LAN, on individual workstations through the use of an automated tool such as the Microsoft Systems Management Server, even as an application running on Microsoft Windows 2000 Server with Windows Terminal Services. It can be installed by users with help from an installation wizard; it can also be installed against policy templates, which can specify just which features to install on a given user’s system. Through the use of policy templates developed with the Office Resource Kit, for example, an administrator can disable the InfoPath design mode for all users except those specified as form designers. 
End users with special needs can also take advantage of InfoPath. Support for Microsoft Active Accessibility means better interaction with assistive technology. Users who employ screen reader technologies can use InfoPath right out of the box. The application can also be used in conjunction with the accessibility features built into the Windows Operating System and Microsoft Office, such as the narrator, sticky keys, and other features.
	Feature
	Description
	Invocation

	IT Management 
	

	Detect and Repair XE "InfoPath Features:Deployment management features " 
	InfoPath offers the ability to detect an error and repair itself when a user’s installation becomes corrupted (if, for example, a DLL gets deleted). 
	Select Detect and Repair… from the Help menu.  XE "How to...:Detect and repair errors" 

	Design-mode Lockdown
	The InfoPath design mode can be disabled for a specific form, preventing end users from making unauthorized changes to a form template.
	In InfoPath design mode, select Form Options from the Tools menu, and check the Enable Protection option in the protection section of the page.  XE "How to...:Ensure security:Lockdown design mode" 

	Secure Deployment of Forms
	InfoPath forms are “sandboxed,” meaning that they are secure and cannot inappropriately access any resources on the local system (such as a hard drive). By default, the form can only access data from within the domain where the form template has been deployed and cannot access any objects not marked as “safe for scripting.” 
Administrators can also perform a customized install that places forms in a URN location. URN-based forms have the same privileges as an HTML file saved on a local file system. They can access resources on the local system and get/send data cross-domain, but they still cannot use objects not marked “safe for scripting.”

Administrators can also identify forms as “fully-trusted” solutions. These have all the same characteristics of the URN-based forms, but they can access objects that have not been marked “safe for scripting.”
	InfoPath forms are sandboxed by default. 

Administrators can create URN-based forms and “fully-trusted” forms.

	Versioning of Form Templates
	InfoPath automatically stamps a date, time and version number for a form template when it is saved in design mode. For sandboxed solutions, InfoPath uses this stamp to ensure that the user filling out a form is always using the latest template. 


	Each time a user opens an InfoPath form based on a sandboxed solution, InfoPath checks to see whether a newer version of the form template is available. If a newer version is available, InfoPath updates the template in the background. 


	End User Ease of Use Features
	

	List of Most Recently Used Form Templates
	End users have quick access to most recently used form templates.
	Users can choose from the recent files list on the File menu, from the list of recently filled-out forms on the Fill out a Form task pane, or from the list of existing forms that the user has been designing on the Design a Form task pane.  XE "How to...:Manage documents:Recently-used forms" 

	Switch Views

	If a form template has more than one view, end users can switch between views.
	Users can select the view from the View menu.  XE "How to...:Manage documents:Switch views”

	Customizable Toolbars
	InfoPath uses the Office toolbar, and users can add/ hide buttons to fit their editing needs. 
	To customize a toolbar, select Customize in the toolbars section of the View menu.  XE "How to...:Customize toolbars:”

	Dr. Watson Support
	InfoPath allows users to send data back to Microsoft on crashes so Microsoft can track down crashing bugs in the product. XE "Dr. Watson support" 
	Dr. Watson support is automatic and requires no user setup.

	Help Support

	InfoPath provides standard Office help and the “Type a question for help.”  XE "InfoPath:Online help" 
	Help is available through the Help menu as well as through the Type a question for help menu bar interface.  XE "How to...:Help, accessing:”

	Tour of Product

	InfoPath includes a flash-based tour of its capabilities.  XE "InfoPath:Product tour" 
Online help is available at all times from both InfoPath design mode and InfoPath edit mode.
	Select Take a Tour of InfoPath from the Get Started section of the Fill out a Form task pane or select Microsoft Office InfoPath Tour from the Help menu. 

To get help, click the Question Mark Symbol (?) in the standard toolbar or select Microsoft Office InfoPath Help from the Help menu.  XE "How to...:View product tour”


	Accessibility
	

	High-Contrast / Large Font for Accessibility
	The InfoPath interface responds to the themes defining the character of the Windows interface.  XE "InfoPath:Accessibility features" 
	Themes set in the Windows Display Control Panel define the look of the InfoPath interface.  XE "How to...:Accessibility options:Manage display”

	Keyboard Shortcuts / Access Keys
	All functionality can be handled through the keyboard.  XE "InfoPath:Accessibility features" 
	Many menu options have associated keyboard shortcuts.  XE "How to...:Accessiblity options:Keyboard shortcuts”  XE "How to...:Keyboard shortcuts”
Users can also navigate the menus using the Alt and Arrow keys.

	Tab Index Ordering
	By default, form users tab through form fields in the order determined by the form and table layout. Users will start with the top section of the form, then move to the next section. Within a two-column table layout with multiple controls in each cell, for example, users will move from the uppermost control in a top left-side cell to the lowermost control in the same cell before jumping to uppermost control in the top right-side cell. They will complete the top right-side cell before jumping to the uppermost control in the left-side cell in the next row, and then continue in this manner through the form.
Form designers can override these defaults by defining the sequence of fields to which the insertion point will jump when a user presses the tab key when filling out a form.
	To override the default tab index ordering, do the following: in InfoPath design mode, right-click the field where a user should start when filing out a form. Select the Properties page from the pop-up menu and click the Advanced tab. Enter “1” in the Tab index field. Click OK to close the properties dialog box and then right-click on the next field that the user should complete. Select the Properties page from the pop-up menu and click the Advanced tab. Enter “2” in the Tab index field.
Repeat this process, increasing the tab index field number each time, until the tab index order has been satisfactorily created.


InfoPath 2003 System Requirements XE "System Requirements" 
System Requirements:

· PC with Pentium 233 MHz or higher processor. Pentium III recommended. 

· Microsoft Windows 2000 with Service Pack 3 or later or Microsoft Windows XP or later operating system. 

· 128MB of RAM or above recommended.

· 100MB of available hard disk space (hard disk usage will vary depending on configuration; custom installation choices may require more or less hard disk space).

· Optional installation files cache (recommended) requires an additional 100 MB of available hard disk space.

· Super VGA (800X600) or higher resolution monitor.
· Additional items or services required to use certain features:

· Microsoft Windows Server™ 2003 running Windows® SharePoint™ Services required for certain advanced collaboration functionality.
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Figure 1: Inserting Repeating Content with the Drop Down Arrow
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Figure 2: Inserting a Repeating Section with the Flyout Menu
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Figure 3: Inserting Repeating Sections
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Figure 4: The Repeating Section Control
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Figure 5: The Conditional Formatting Definition Window 
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	Figure 6: The Form Design Task Pane
	Figure 7: The Controls Task Pane
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Figure 8: WYSIWYG Form Design 
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Figure 9: Tree-Type Schema Representation 
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Figure 10: Basic Schema Editing 

[image: image12.png]Submitting Forms




Figure 11: Customize Control Properties
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Figure 12:Built-in E-Mail Integration
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Figure 13: Submitting Form Information
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Figure 14: Submitting Form Information to a Backend Service
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Figure 15: Rich Formatting Options
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Figure 16: Multiple Views of a Form
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Figure 17: Multiple Views of a Form (Summary)
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Figure 18: Creating a Print View
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Figure 19: A Print View
Glossary

	Bind
	To connect a control to a field or group in the data source so that data entered into the control is saved. When a control is unbound, it is not connected to a field or group, and so data entered into the control will not be saved.

	COM (Component Object Model)
	A specification developed by Microsoft for building software components that can be assembled into programs or can add functionality to existing programs running on Microsoft Windows operating systems.

	Conditional formatting
	Changing the appearance of a control, including its visibility, based on values entered into the form.

	Control
	A graphical user interface object, such as a text box, check box, scroll bar, or command button, that lets users control the program. You use controls to display data or choices, perform an action, or make the user interface easier to read.

	Custom installed form
	A form that is installed with a custom setup program and that usually has access to files and settings on the computer.

	Custom task pane
	A Hypertext Markup Language (HTML) file whose content is displayed in a window next to a form. Custom task panes can provide form-specific commands and Help content. 

	Data source
	The collection of fields and groups that define and store the data for an InfoPath form. Controls in the form are bound to the fields and groups in the data source.

	Data type
	Property of a field that defines the kinds of data the field can store. Data types include Text, Rich Text, Whole Number, Decimal, True/False, Hyperlink, Date, Time, Date and Time, and Picture.

	Data validation
	The process of testing the accuracy of data; a set of rules you can apply to a control to specify the type and range of data that users can enter.

	Design mode
	The InfoPath design environment in which you can create or modify a form template.

	Dialog box alert
	A data validation alert that opens a dialog box with a custom error message when invalid data is entered into a control.

	DOM (Document Object Model)
	A World Wide Web Consortium specification that describes the structure of dynamic HTML and XML documents in a way that allows them to be manipulated through a Web browser.

	Editable region
	Any area of a form in which you can insert content such as text, tables, or pictures.

	Event
	An action recognized by an object, such as a mouse click or key press, for which you can define a response. An event can be caused by a user action or a Visual Basic statement, or it can be triggered by the system.

	Event handler
	The script function code in an InfoPath form that responds to a form event or data validation event.

	Expression box
	A control on a form that displays read-only data as the result of a lookup or calculation against the data using an XPath expression.

	Field
	An element or attribute in the data source that can contain data. If the field is an element, it can contain attribute fields. Fields store the data that is entered into controls.

	Form
	In InfoPath, a document with a set of controls into which users can enter information. InfoPath forms can contain features such as rich text boxes, date pickers, optional and repeating sections, data validation, and conditional formatting.

	Form area
	The area of the InfoPath workspace that displays the form you are working with.

	Form definition file
	An XML file with an .xsf extension that contains information about all other files and components used within a form, including user interface customizations, XML schemas, views, business logic, events, and deployment settings.

	Form files
	A collection of files that are used to implement an InfoPath form. File types can include HTML, XML, XSD, XSLT, script, and other file types that are necessary to support the functionality of the form.

	Form library
	A folder in which a collection of forms based on the same template is stored and shared. Each form in a form library is associated with user-defined information that is displayed in the content listing for that library.

	Form library columns
	Information from forms displayed in columns in a Windows SharePoint Services form library. For every form in the library, columns display information entered into controls that the form designer designated as form library columns.

	Form template
	In InfoPath, a file or set of files that defines the data structure, appearance, and behavior of a form.

	Group
	An element in the data source that can contain fields and other groups. Controls that contain other controls, such as repeating tables and sections, are bound to groups.

	HTML (Hypertext Markup Language)
	Acronym for Hypertext Markup Language. The standard markup language used for documents on the World Wide Web. HTML uses tags to indicate how Web browsers should display page elements such as text and graphics and how to respond to user actions.

	Inline alert
	A data validation alert that marks controls that contain invalid data with a dashed red border. Users can right-click controls to display custom error messages.

	JavaScript
	A cross-platform, World Wide Web scripting language. JavaScript code is inserted directly into an HTML page. JavaScript makes it possible to build Java programs. The script anchor represents a script written in JavaScript.

	JScript
	An interpreted, object-based scripting language that borrows from C, C++, and Java. It is the Microsoft implementation of the ECMA 262 language specification.

	Layout table
	A collection of cells used to arrange form content such as text or controls.

	List control
	A control on a form that can be formatted as a bulleted, numbered, or plain list. A user can enter text into a list control, which repeats as needed. 

	Method
	A procedure similar to a statement or function that operates on specific objects. For example, you can apply the Print method to the Debug object to transfer printed output to the Immediate window. 

	Microsoft Script Editor (MSE)
	A programming environment used to create, edit, and debug Microsoft JScript or Microsoft VBScript code on an InfoPath form.

	Microsoft Windows Installer (MSI)
	A tool that is used to create installation packages for software that is to be deployed on 32-bit Windows operating systems.

	Object
	A table, chart, graphic, equation, or other form of information. Objects created in one application, for example spreadsheets, and linked or embedded in another application are OLE objects.

	Object browser
	A dialog box that displays information about objects, properties, methods, and constants in the current project and in referenced object libraries, and that you use to search for an element, get help on it, or paste it into a module.

	Object model
	A hierarchical library of objects and collections that represent the content and functionality of an application. Objects and collections have properties, methods, and events that can be used to manipulate and interact with an application.

	Object model diagram
	A graphical representation of the objects and collections that are contained within a specified object model.

	Optional section
	A control on a form that contains other controls and that usually does not appear by default. Users can insert and remove optional sections when filling out the form.

	Parameter
	A value that is assigned to a variable at the beginning of an operation or before an expression is evaluated by a program. A parameter can be text, a number, or an argument name assigned to another value.

	Property
	A named attribute of a control, a field, or an object that you set to define one of the object's characteristics (such as size, color, or screen location) or an aspect of its behavior (such as whether the object is hidden).

	Reference field
	A field that is associated with another field so that their properties always match. If the properties in one field are changed, the properties in the other field are updated automatically.

	Reference group
	A group that is associated with another group so that their properties and the properties of the groups and fields they contain always match. If the properties of one group are changed, the other group is updated automatically.

	Repeating field
	A field in the data source that can occur more than once. Controls such as bulleted, numbered, and plain lists; repeating sections; and repeating tables can be bound to repeating fields.

	Repeating group
	A group in the data source that can occur more than once. Controls such as repeating sections and repeating tables are bound to repeating fields.

	Repeating section
	A control on a form that contains other controls and that repeats as needed. Users can insert multiple sections when filling out the form. 

	Repeating table
	A control on a form that contains other controls in a table format and that repeats as needed. Users can insert multiple rows when filling out the form.

	Resource manager
	The interface for adding and removing resource files that support the functionality of a form.

	Scripting language
	A simple programming language designed to perform special or limited tasks, sometimes associated with a particular application or function.

	Secondary data source
	An XML data file, database, or Web service that is used by a form for the entries in a list box or for script actions.

	Section
	A control on a form that contains other controls. 

	Table
	One or more rows of cells commonly used to display numbers and other items for quick reference and analysis. Items in a table are organized into rows and columns.

	Task pane
	A window within an Office application that provides commonly used commands. Its location and small size allow you to use these commands while still working on your files.

	Text box
	A control into which a user can enter text. Rich text boxes allow data entry with text formatting choices.

	URI (Uniform Resource Identifier)
	A character string used to identify a resource on the Internet by type and location.

	URN (Uniform Resource Name)
	A scheme for uniquely identifying resources that may be available on the Internet by name, without regard to where they are located.

	URL (Uniform Resource Locator)
	An address that specifies a protocol (such as HTTP or FTP) and a location of an object, document, World Wide Web page, or another destination on the Internet or an intranet—for example, http://www.microsoft.com

	Valid
	Error free, or acceptable according to an established set of rules or standards. For example, data entered into a form is valid if it meets the criteria set in the form's data validation rules.

	View
	A form-specific display setting that can be saved with a form template and applied to form data when the form is being filled out. Users can switch between views to choose the amount of data shown in the form.

	VBscript (Visual Basic Scripting Edition)
	An interpreted, object-based scripting language that is a subset of the Microsoft Visual Basic programming language. 

	XHTML (Extensible Hypertext Markup Language)
	A markup language that extends HTML and reformulates it as XML.

	XML (Extensible Markup Language)
	A condensed form of Standard Generalized Markup Language (SGML) that enables developers to create customized tags that offer flexibility in organizing and presenting information.

	XML attribute
	An XML structural construct. A name-value pair, separated by an equal sign and included in a tagged element, that modifies features of an element. All attribute values are text strings and must be enclosed in quotation marks.

	XML data
	Data that is saved in an XML format. InfoPath forms are saved as XML data files.

	XML element
	An XML structure that consists of a start tag, an end tag, and the information between the tags. Elements can have attributes and can contain other elements.

	XML parser
	A software component used to process XML documents by validating their structure and producing views or transformations of their content.

	XML schema
	A formal specification, written in XML, that defines the structure of an XML document, including element names and rich data types, which elements can appear in combination, and which attributes are available for each element.

	XML signature
	An XML-based digital signature that can be used to help secure the data contained in XML documents. XML Signatures are a standard governed by the World Wide Web Consortium (W3C). 

	XML template file
	An XML file that contains the sample data that is displayed in the fields of a form before a user fills it out.

	XSD
	An XML schema definition.

	XSL
	An XML vocabulary for specifying formatting semantics. An XSL style sheet specifies the presentation of a class of XML documents by describing how an instance of the class is transformed into an XML document that uses the formatting vocabulary.

	XSLT (XSL Transformations)
	A language that is used to transform XML documents into other types of documents, such as HTML or XML. It is designed for use as part of XSL.
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Submit forms, 25
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