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Extensible Components

This section describes the extensible components and provides examples of how you can modify them.
Main Ribbon Tabs

The Ribbon contains commands that affect or change document content. The overwhelming majority of the commands in the Ribbon are buttons. In many cases, gallery controls roll up the effect of many button clicks and dialog settings into a single click. The Ribbon displays commands organized into tabs and groups. You can add your own groups to existing tabs, and you can add your own top-level tabs. You can also use the extensive control set to add controls to your groups.
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Figure 1. Example of the Ribbon UI
RECOMMENDATION: Extend the Ribbon if your solution…
Contains commands that affect document content. Examples include commands that assist in reviewing a document, laying out a document, or inserting special content in a document.

The Microsoft Office Button

The Microsoft Office Button menu contains commands that operate on the document as a whole, such as Print and Save. If your add-in has similar functionality, you can add it at the top-level of the menu or in one of the sub-menus.
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Figure 2. Example of a sub menu
RECOMMENDATION: Extend the Microsoft Office Button menu if your solution…
Adds commands that affect the document file as a whole. Examples include sharing, printing, sending, or changing file permissions.

Ribbon Contextual Tab Sets
The contextual tab sets work only with built-in objects, such as tables, charts, and pictures. Your add-in or solution can add a tab to one of the built-in tab sets, or add a group to one of the built-in contextual tabs. 
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Figure 3. Adding your add in to a contextual tab
RECOMMENDATION: Extend the Contextual Tab Sets if your solution…
Contains commands that operate on one of the built-in Office object types, like pictures, tables, and charts. Only add your own tab to an existing contextual tab set if you have enough commands to fill the tab. If you do not, add your command as a group on an existing contextual tab.

Custom Task Panes
Custom task panes typically display data or information about the contents of a document, or present dynamic content that users can apply to the document. Similar to built-in Office task panes, custom task panes typically display UI that is not suited for inclusion in the one-click command space of the Ribbon or the Microsoft Office Button menu. Examples include the XML structure of a document and the Research Pane. 
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Figure 4. The research task pane is an example of something that is not suited to a one-click command space
By default, task panes should be 200 pixels wide and docked to the right side of the screen. Unlike Office 2003, the 2007 release allows multiple simultaneous task panes open at the same time. To ensure the best user experience, user actions should open and close these task panes rather than having them launch automatically.

RECOMMENDATION: Create a custom task pane if…
Your solution needs to present data about a document that is required to be visible, in a non-modal fashion, use a custom task pane. However, only display this task pane based on user actions. Also use if you need to use custom controls that are outside of the Ribbon control set.

UI Design Tenets

When thinking about the user interface for your solution, remember the following tenets.

· Keep the command UI relatively static. Labels, icons, and visibility states of individual controls almost never change at runtime. For example, in Office 2003 Show Gridlines became Hide Gridlines after the user clicked it. This was determined to be less than ideal for users. In the 2007 release, in adherence to this principle, the Show Gridlines button is a toggle button and its label remains Show Gridlines. Only in special circumstances does the visibility of a tab or group or the label of a control change. Exceptions to this tenet include special groups appearing in certain languages, and an Inking group that appears when on a Tablet PC.

[image: image5.png]g select -

[ Show Gridines
B properties
Table




Figure 5. The revised Show Gridlines button as a toggle
· No surprises. Task panes or dialogs do not appear automatically on document open. Only user actions should open and close task panes or dialogs. Ideally, all task panes are opened using a button in the Ribbon. For example, clicking the launcher button on the Clipboard group open and closes the Clipboard task pane. 
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Figure 6. To open the clipboard, users must click the launcher button
· Group commands logically. The New UI organizes commands by task or feature set. For example, all the page layout-related commands are on the Page Layout tab. Try to place your commands on the appropriate tab. If they do not fit in existing tabs, add to the Add-Ins tab.
· Do not duplicate commands. Unlike menus and toolbars, where the same commands often appeared both in menus and on toolbars, the Ribbon unifies the command space, so commands typically appear only once in the Ribbon.
Important Considerations

Consider alternatives before adding a custom tab. A few additional, top-level tabs on a user's screen can adversely affect the user experience. The high-level groupings of the tabs are general enough that your solution should fall in one of the categories. If it does not, add your controls in a custom group on the Add-Ins tab. In many ways, the add-ins tab replaces the Tools menu in Office 2003. If you must add a tab, make sure: 
1. You do not logically fall under one of the existing tabs.

2. You have sufficient content to fill an entire tab. If you do not, a group on the add-ins tab is the preferred alternative.

Minimize potential for conflict with other solutions. As long as add-ins contribute custom groups and controls, they almost never conflict with existing controls. Once add-ins start hiding built-in tabs or changing the behavior of built-in controls, however, the chances for conflict increase significantly. For these cases, the Ribbon extensibility follows a rule of "the last add-in wins," similar to Office 2003. Here are some specific recommendations for minimizing conflicts:

· Do not hide built-in tabs or groups. Other add-ins may add controls to these tabs or depend on certain built-in controls for the scenarios they solve.

· Do not use the startFromScratch feature, unless your customizations are attached to particular document. StartFromScratch hides all of the built-in UI and is only useful for creating a completely customized experience.

· Do not use command repurposing to disable or change the behavior of built-in commands, or change built-in commands in any way. Other solutions may depend on certain behaviors from built-in commands.

If you expect to deploy your add-ins in diverse environments, you should avoid these features because they may conflict with other user-installed add-ins. StartFromScratch, hiding built-in tabs and groups, and command repurposing are features that are designed for corporate developers, who typically know a user's full computer state. 
Design Tips

· If your solution previously added duplicate commands to menus and toolbars in Office 2003, add only one set of commands in a group on the appropriate Ribbon tab in the 2007 release.

· If you want to add a group to the Ribbon, and cannot find an appropriate tab for your group, add your group to the Add-Ins tab.

· Only add a custom tab if your solution provides enough commands to fill its own tab. Otherwise, a group on the Add-Ins tab preserves the best end-user experience.

· If you are adding to a built-in tab, consider adding your commands as a splitButton—with the primary action as the main button, and secondary actions on the menu portion of the splitButton. The splitButton is a new control in the 2007 release.

· If you are adding content to the Ribbon that is highly dynamic, or controls that cannot be known at the time of add-in load, populate a dynamicMenu control as necessary at run time, or use a gallery control.

Remember that it is possible to use visibility callbacks to show and hide your tabs, groups, and controls as necessary. To mimic the built-in UI behavior, however, it makes more sense to disable individual controls, instead of hiding them, when they are not applicable.

Migrating your Solution to the New User Experience

If your solution currently has legacy CommandBars content appearing on the Add-Ins tab, you may want to migrate it forward to take full advantage of the new UI control types and placement. 

Simple Migration

A simple migration involves moving an add-in to the 2007 release without fundamentally rethinking its commands. Examine all of the commands the solution exposes in Office 2003, and then put them in the right place based on the new organization.

For example, the "Contoso Image Grabber" is an add-in that worked great in Office 2003 and continues to work in the 2007 release. It connects to Contoso's database of images and inserts an image from the database. In Office 2003, this add-in appeared at the bottom of the Tools menu in a submenu. Where should it go in the 2007 release?
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Figure 7. Placement of the Contoso Image Grabber in Office 2003
Since the primary purpose of the add-in is to insert images, the best place for this add-in is on the Insert tab. The add-in has several commands, but only one that deals specifically with inserting an image, and the others take you to add-in help or change settings for the add-in. 
We know it does not belong in the file menu, because it affects document content directly. We also know that, since it has so few commands, it certainly doesn't deserve its own tab. Based on the information we have about this add-in, the best UI placement for this add-in is a split button on the Insert tab, in a group right after the Illustrations group. The main button of the split button is the add-in's primary action—grabbing an image—and the other buttons for this add-in appear in the sub menu of the splitButton.
[image: image8.png]Document1 - Microsoft Word

B - I —

@ 2 Cover Page * == (g cip At @ B, Hypertink =] Header ~

) Blank Page. T smartart 4 Bookmark [ Footer ~





Figure 8. The primary action of the Contoso Image Grabber add-in appears in the Insert tab
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Figure 9. The other actions of the Contoso Image Grabber add-in appear on a sub menu
What if none of the built-in tabs were logical placements? Does it make sense to create a built-in tab for it? In Office 2003, this add-in appeared on the Tools menu. The 2007 release replaces the Tools menu with the Add-Ins tab. Therefore, if there is no logical tab on which to place an add-in, and it only has a few commands, the next best place is a custom group on the Add-Ins tab.

Full Migration

A full migration involves reviewing the new control types in the Ribbon and considering how to redesign an add-in to take advantage of new menus and gallery controls. Often, this involves rolling up settings and options often found in dialogs, and presenting them as options in a gallery or menu control, so users get one-click access to common settings. One example of this behavior from the built-in UI is the Margins gallery.

In Microsoft Office Word 2003, setting margins involved going to the Page Setup dialog and tweaking individual settings.
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Figure 10. Page setup in Office 2003 Editions
In Microsoft Office Word 2007, the UI rolls up the common sets of choices in the Margins gallery on the Page Layout tab.
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Figure 11. Page setup in the 2007 release
The custom margins button at the bottom of the gallery opens the old Page Setup dialog, but with one-click access to common settings, dialog usage decreases and users can be more efficient.
Additional Resources
For more information about the new user interface for the 2007 release of Microsoft Office suites, see the following:
· Customizing the Office (2007) Ribbon User Interface for Developers (Part 1 of 2): http://msdn2.microsoft.com/en-us/aa367088(office.12).aspx 
· Customizing the Office (2007) Ribbon User Interface for Developers (Part 2 of 2) http://msdn2.microsoft.com/en-us/aa367530(office.12).aspx 
· Developer Overview of the User Interface for the 2007 Microsoft Office System: http://msdn2.microsoft.com/en-us/aa320640(office.12).aspx 
· Download: 2007 Office System Document: Lists of Control IDs: http://www.microsoft.com/downloads/details.aspx?FamilyId=4329D9E9-4D11-46A5-898D-23E4F331E9AE&displaylang=en 
· Office Noir: Chapter II: The Ribbon Bar: http://channel9.msdn.com/Showpost.aspx?postid=186383 
· Screencast: Extending the Office 2007 UI with a Custom Ribbon: http://download.microsoft.com/download/a/6/1/a61dd5df-f52c-42d5-a95c-7a7fb7a6a466/ExtendedRibbon.wmv 
· Screencast: Extending the Office 2007 UI with a Custom Task Pane: http://download.microsoft.com/download/a/6/1/a61dd5df-f52c-42d5-a95c-7a7fb7a6a466/CustomTaskPane.wmv 
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