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Introduction

The Internet provides us with an easy way to publish and find information. However, information on the Internet is not always readily available to all users. Some people are unable to access the Internet through traditional Web browsers such as Microsoft® Internet Explorer without the use of assistive technologies that enhance the way they interact with information. These assistive technologies include screen readers and Braille devices, audio browsers, screen magnifiers, text-only browsers, and voice input software. Other users, such as mobile professionals, are increasingly turning to alternative technologies to browse the Web—technologies such as cell phones and handheld computers with low-resolution displays. For each of these groups of users, it is important that a Web site provide alternatives.

Tim Berners-Lee, World Wide Web Consortium (W3C) Director and developer of the World Wide Web, said it best: “The power of the Web is in its universality. Access by everyone regardless of disability is an essential aspect.” It is estimated that 10 percent of the population in the United States has some kind of disability that affects their ability to use computers and access the Internet. Additionally, adhering to accessibility standards may be the law or a policy in your country, state or municipality, school, or organization.

Web programming today facilitates many types of non-text Web elements such as images, frames, applets, and tables. Yet most assistive technologies provide input to their users by interpreting text. What happens when an assistive device encounters a non-text element? In some cases, the device might stall. In other cases, the device simply provides no information about the element.

Today it is quite possible for Web developers to enable anyone to access the information on a Web page. When information on the Internet is accessible, everyone—including users of assistive and alternative technologies—can find and benefit from it. With every release of the Microsoft FrontPage® Web site creation and management tool, the focus on making accessible Web pages is getting stronger. And Microsoft Office FrontPage 2003 is the best release yet. 

With help from FrontPage 2003, Web designers can reach the largest audience possible. This white paper provides information on features, design techniques, and suggestions for creating accessible Web content, with special emphasis on using and modifying the new accessibility checker. These tips are intended to help you make your Web site more accessible. This is not a complete list, but it will offer some ideas and things to think about as you design and edit your Web site with FrontPage.

Using the Accessibility Checker

The FrontPage 2003 accessibility checker enables you to check your pages for accessibility issues and correct them before you publish your pages to the Web. The accessibility checker helps to ensure that your Web site conforms to accessibility guidelines, which will help ensure that your Web site will be usable by people with disabilities. The accessibility checker can be run in Design view, Code view, or Split view.

To use the accessibility checker
1. Open the Web or page that you want to check (CTRL+O).

2. On the Tools menu, click Accessibility (F8, or ALT+T and then Y).

3. In the Accessibility dialog box, in the Check where section, select just the current page that you have open, all open pages, or all pages in your site. 
Note: All options in the Accessibility dialog box can be selected or cleared by pressing the TAB key and/or the UP ARROW and DOWN ARROW keys.

4. Under Check for, select W3C Web Content Accessibility Guidelines (WCAG) Priority 1, WCAG Priority 2, Access Board Section 508 (U.S. federal government) guidelines, or all three. 
Note: The Access Board Section 508 checkbox is tied to the WCAG Priority 1 checkbox (the Section 508 guidelines include WCAG Priority 1). So when Access Board Section 508 is selected, WCAG Priority 1 is selected. If you clear the WCAG Priority 1 checkbox, the Access Board Section 508 checkbox is cleared. 

5. Once you’ve made your selections, click the Check button (ENTER).
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Figure 1: The Accessibility dialog box.

When the accessibility checker is finished running, a list with the page name, line number, issue type, checkpoint number that was violated, and a problem summary will appear in the Accessibility dialog box. You can scroll through the list of errors using the Next and Previous buttons or the UP ARROW and DOWN ARROW keys.
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Figure 2: The Accessibility dialog box with the completed accessibility report in the window.

This report can be saved to work on at another time or shared with a colleague. Click the Generate HTML Report button, and the checker will generate a new Web page called Accessibility_Report.htm that can be saved in your site or to your hard drive. When this report is viewed in your browser, each checkpoint violation identified is also a link to the WCAG guideline at the W3C site. 

What Are the Web Content Accessibility Guidelines?

The World Wide Web Consortium develops common protocols that promote the evolution and interoperability of the World Wide Web, including standards for Hypertext Markup Language (HTML), Extensible HTML (XHTML), cascading style sheets (CSS), and accessibility. The W3C Web Content Accessibility Guidelines 1.0 (WCAG 1.0) explain how to make Web content accessible to people with disabilities. Since the Section 508 guidelines include the WCAG Priority 1 guidelines, Priority 1 guidelines must be satisfied to meet the Section 508 guidelines. WCAG Priority 2 guidelines should be satisfied to meet the accessibility standards put forward by the W3C, but are not required by Section 508. 

While the primary goal of the guidelines is to promote accessibility, following them also will make your Web content more available to all users, whatever technology they are using or constraints they may be operating under (noisy surroundings, under-illuminated or over-illuminated rooms, or a hands-free environment, for example). Following these guidelines will help people find information on the Web more quickly through the use of clear language, descriptive alternative text for images, and properly titled frame pages. These guidelines do not discourage content developers from using images or multimedia plug-ins, but rather encourage making all content more accessible to a wider audience. 

What Is Section 508?

Section 508 of the U.S. Rehabilitation Act requires that people with disabilities, seeking information or services from a federal agency, have access to and use of information and data that is comparable to that provided to people who are not disabled (unless an undue burden would be imposed on the agency). The Section 508 standards are guidelines that must be followed by U.S. federal agencies when purchasing products and producing Web pages. 

WCAG or Section 508: Which Should I Use? 

Government agencies or agencies under contract to the U.S. federal government for Web design or Web development services are required to comply with the Section 508 guidelines. For other governments and organizations, you should check to see if there is a policy or law requiring you to make your Web sites accessible. In many cases, policies and laws incorporate some or all of WCAG in addition to the Section 508 guidelines. Even if you are not subject to any law or policy, it is a good idea to comply with WCAG Priority 1 to ensure the widest possible audience for your Web site.
Modifying the Accessibility Checker

The FrontPage 2003 accessibility checker is based on an Extensible Markup Language (XML) called XML Patterns (XMLP) and works by searching for the existence or absence of various patterns in an HTML document, such as “does the document contain an IMG tag without an alt attribute” or “does the document contain dynamic scripting effects but no NOSCRIPT block”. These patterns can be translated into XPath (a non-XML language used to identify particular parts of XML documents)—for example: 
//img[@alt] or //script[./following-sibling::noscript]
The accessibility checker uses two XML files:

· WCAG1_0.xml, which contains the rules used by the accessibility checker.
· WCAG_str.xml, which contains the error description and summary displayed by the accessibility checker when a violation is found. This file is included by WCAG1_0.xml.
These files can be modified to customize the error messages displayed by the accessibility checker and to add new accessibility guidelines and checkpoints.

Customizing the Accessibility Checker Error Messages

Each accessibility checkpoint has, at minimum, three entries in WCAG_str.xml:

· A variable containing the number of the checkpoint—for example, WCAG 1.1.
· A variable containing a brief summary of the violation. This text appears in the Accessibility dialog box in the Problem Summary column. An example of a Problem Summary is “Image is missing a text equivalent (either an alt="X" or longdesc="X").”
· A variable containing a description of the violation and how to fix it. This text appears in the Accessibility dialog box in the Problem Details section. An example of a Problem Details message is: “Image is missing a text equivalent (either an alt="X" or longdesc="X"). Consider brief alternative text that describes the information that the image conveys. You can use the picture properties dialog to add alternative text.”
Each of these variables has a name to link it to the associated rule in WCAG1_0.xml. For example, in WCAG_str.xml, a variable with a name of Checkpoint1_1 is associated with the category $Checkpoint1_1. Some checkpoints have more than one condition that can cause an accessibility violation. For example, the alternative text for images may be missing, too short, or too long, or the image name or size may be missing. For each of these conditions, there is a pair of variables: a summary and a description. The summary and/or the description can be tailored to your organization’s needs.

To customize the accessibility checker’s error messages

1. Open the WCAG_str.xml file (located at C:\Program Files\Microsoft Office\OFFICE11\1033\Accessibility\).
2. Locate the error message to be customized.

3. Type the customized error message, and save the file to its original location.

Note: It is good practice to save a copy of the original file as a backup before making any modifications.
Dissecting the Rule Set Document

Before you make any changes to the rule set document, it’s a good idea to learn about its elements and syntax. To begin, open the WCAG1_0.xml file (located at C:\Program Files\Microsoft Office\OFFICE11\1033\Accessibility\). Use this file to find examples of the following XMLP elements and attributes.

The XP:CATEGORY element contains a text string or variable reference describing in plain English the category of enclosed rules. The category element has two attributes (name and href) and may contain any number of XP:RULE child elements.

The XP:RULE element begins and ends an XMLP rule and is a child of the XP:CATEGORY element. The XP:RULE element has the attribute of context, which defines the context in which the rule should be tested. For example, 
<xp:rule context="(//img) | (//noembed)"> 
states that the rule should be tested anywhere the IMG tag or the NOEMBED tag is found.

The XP:PATTERN element is a child of XP:RULE and can have up to three attributes: 

· Is-assert, which can be true or false. If this attribute is set to true, then the pattern matches if the match query does not return any nodes. The default value is false.
· Match, which is an XPath query run in the context set by the XP:RULE parent element’s context attribute. The value for the match attribute defines what must be present or absent in conjunction with the context value of the XP:RULE element. For example, in the context described in the rule above, 

<xp:pattern match="@alt | @longdesc"> 

checks for instances of the IMG or NOEMBED tags and the presence of alt or longdesc attributes. If either attribute is included, the pattern is processed.
· Priority, which is an integer indicating the priority of the pattern. This value is returned within the corresponding report match section if this pattern asserts and appears in the accessibility report generated by the accessibility checker.
The XP:REPORT element indicates the violation type—error, warning, or checkpoint—and contains the XMLP code necessary to report this rule break.

The XP:SUMMARY element is a child of the XP:REPORT element and calls in the Summary message from WCAG_str.xml, the value of which is retrieved by the XP:VALUE-OF element immediately following the XP:REPORT element.
The XP:MESSAGE element is a child of the XP:REPORT element and calls in the Description message from WCAG_str.xml, the value of which is retrieved by the XP:VALUE-OF element immediately following the XP:REPORT element.
Modifying an Existing Rule in the Rule Set Document

You may want (or find it necessary) to customize the existing set of rules. In the pattern example given above, the accessibility checker checks for the absence of the alt and longdesc attributes for images. You may want to test for the absence of the title attribute as well. This is done in two parts:

To modify the rule set document

1. Open the WCAG1_0.xml file (located at C:\Program Files\Microsoft Office\OFFICE11\1033\Accessibility\).

2. Find the string 

<xp:value-of select="$str1_1_MissingAltAndLongDesc_Summary"/>

and add “AndTitle” so that the string reads 

<xp:value-of select="$str1_1_MissingAltAndLongDescAndTitle_Summary"/>
3. Find the string 

<xp:value-of select="$str1_1_MissingAltAndLongDesc"/>

and add “AndTitle” so that the string reads 

<xp:value-of select="$str1_1_MissingAltAndLongDescAndTitle"/>
4. Find the string 

<xp:pattern match="@alt | @longdesc" is-assert="true" priority="1"> 

and add “| @title” so that it reads 

<xp:pattern match="@alt | @longdesc | @title" is-assert="true" priority="1">
5. Save your changes and close the file.
To modify the compliance string document

1. Open the WCAG_str.xml file (located at C:\Program Files\Microsoft Office\OFFICE11\1033\Accessibility\).

2. Find the string 

<xp:variable name="str1_1_MissingAltAndLongDesc">

and add “AndTitle” so that the string reads 

<xp:variable name="str1_1_MissingAltAndLongDescAndTitle">

3. Modify the description text to indicate that the title attribute is also missing. For example, edit the message to read “Image is missing a text equivalent (alt="X" or longdesc="X" or title="X"). Consider brief alternative text that describes the information that the image conveys. You can use the picture properties dialog to add alternative text.”

4. Find the string 

<xp:variable name="str1_1_MissingAltAndLongDesc_Summary">

and add “AndTitle” so that the string reads 

<xp:variable name="str1_1_MissingAltAndLongDescAndTitle_Summary">

5. Modify the summary message to include the fact that the title attribute is missing. For example, edit the message to read “Image is missing a text equivalent (alt="X" or longdesc="X" or title="X").”

6. Save your changes and close the file.
Adding a New Condition to an Existing Checkpoint

To add a new condition to an existing checkpoint category, the following elements should be added to the appropriate XP:CATEGORY element: 

<xp:rule>
<xp:pattern>
<xp:report>
<xp:summary>
   <xp:value-of>
<xp:message>
   <xp:value-of>

Each new condition added to WCAG1_0.xml for an existing category also must have its associated description and summary added to WCAG_str.xml (see “To modify the compliance string document” above for information on how to add description and summary text to WCAG_str.xml).
Adding a New Category

To add a new category to the rule set, the following elements should be added:
<xp:category>
<xp:rule>
<xp:pattern> 
<xp:report>
<xp:summary>
   <xp:value-of>
<xp:message>
   <xp:value-of>

Each new category added to WCAG1_0.xml must also have its associated name, description, and summary added to WCAG_str.xml (see above).

Using Single-Column Text

When developing a Web site, it is best to place all text in a single column. Multiple-column text is hard to read by most screen readers because they read text from left to right regardless of certain cells and formatting. Additionally, the single-column approach is best for serving visually impaired users who use screen magnification software.
For some types of sites, of course, this may not be practicable. If this is the case, consider providing an alternate linear version. For a multicolumn table, to take an example, use separate paragraphs to represent the information in each cell, and sequence the paragraphs in the order that one would read them in the table.

Using a DOCTYPE Declaration

A DOCTYPE declaration is necessary if you want to validate your document, and a valid document helps to ensure a minimum level of accessibility. A DOCTYPE declaration does not guarantee compliance but indicates a target standard for compliance. Web site authors should validate their HTML using an HTML validator (WDG HTML Validator or W3C Markup Validation Service, for example) to help find errors that indicate noncompliance. 
A DOCTYPE declaration is a statement that declares the language (HTML, for example) and language version (4.01, for example) being used in the document and should appear at the very top of the Web page, before the HTML tag. A valid DOCTYPE declaration tells the browser to render the page in standards-compliant mode for the declared HTML version. A valid DOCTYPE consists of two parts: a declaration of the HTML specification you are coding to, and a link to the document type definition (DTD).

The following is an example of a valid DOCTYPE declaration, with the version (HTML 4.01 Transitional) appearing in the first line and the DTD Universal Resource Indicator (URI) appearing in the second: 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
      "http://www.w3.org/TR/html4/loose.dtd">

If a DOCTYPE declaration does not include a link to a DTD, the browser will assume the version and display the pages based on that assumption. A Web page with a transitional DOCTYPE declaration without a DTD, for example, will display in “quirks” mode, meaning the browser will assume that you have written to outdated HTML specifications. The browser then will try to render your page in backward-compatible mode. The W3C maintains a list of valid DTDs.
There are two ways you can automatically include a DOCTYPE in your Web pages using FrontPage 2003:

· Create a code snippet

· Modify the Normal template 

Creating a Code Snippet

A code snippet is a fragment of code or text that you can define in FrontPage and reuse in all your Web sites. You can modify existing code snippets or create your own, and code snippets can be associated with keywords for quick access and insertion. FrontPage 2003 provides several predefined code snippets including HTML 2.0, 3.2, and 4.01 Transitional DOCTYPE declarations. The HTML 4.01 Transitional DOCTYPE code snippet (keyword dt4) needs to be modified to include a DTD reference to be fully standards-compliant. 

To modify the HTML 4.01 Transitional DOCTYPE code snippet

1. On the Tools menu, click Page Options (ALT+T and then A).
2. In the Page Options dialog box, click the Code Snippets tab (press the DOWN ARROW key to Page Options, and then the RIGHT ARROW key to get to the Code Snippets tab).

3. Select the dt4 code snippet, and click Modify (ALT+M) to open the Modify Code Snippet dialog box.

4. In the Keyword box, replace the keyword dt4 with dt4 Transitional. 

5. In the Description box, replace HTML 4.01 DOCTYPE with HTML 4.01 Transitional DOCTYPE. 

6. In the Text box, replace the code in the window with the following HTML 4.01 Transitional DOCTYPE declaration with DTD (the single pipe character is necessary, and indicates the line break once the code has been inserted in the page): 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
     "http://www.w3.org/TR/html4/loose.dtd">
|
To use the HTML 4.01 Transitional DOCTYPE code snippet

1. Open a Web page (CTRL+O) and switch to Code view (CTRL+PAGE UP or CTRL+PAGE DOWN). 
2. Position the cursor before the HTML tag, and press CTRL+ENTER. 
3. From the Code Snippet drop-down list, choose dt4. 
To create a new DOCTYPE code snippet

1. On the Tools menu, click Page Options (ALT+T and then A).
2. In the Page Options dialog box, click the Code Snippets tab (press the DOWN ARROW key to Page Options, and then the RIGHT ARROW key to the Code Snippets tab).

3. Click the Add button to open the Add Code Snippet dialog box.

4. In the Keyword box, enter a keyword for your new code snippet.

5. In the Description box, enter a description of your new code snippet.

6. In the Text box, enter the desired DOCTYPE declaration (or copy and paste it in from another source).

Modifying the Normal.htm Template 

FrontPage 2003 uses a default template when you open a new page (new_page_1.htm). This default template is called Normal.htm and is located at C:\Program Files\Microsoft Office\Templates\1033\Pages11\normal.tem\normal.htm. You can open this file and edit it like you would any other Web page. 

To modify the Normal.htm template

1. Open the Normal.htm file (press CTRL+O, and then browse to C:\Program Files\Microsoft Office\Templates\1033\Pages11\normal.tem\normal.htm). 
2. Place the cursor before the HTML tag, and copy (CTRL+C) and paste (CTRL+V) the following HTML 4.01 Transitional DOCTYPE declaration:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
     "http://www.w3.org/TR/html4/loose.dtd">
3. On the File menu, click Save (CTRL+S).

You also can add metatags to your template.
To add metatags to the Normal.htm template

1. Open the Normal.htm file. 

2. On the File menu, choose Properties (ALT+F, then R, and then R again).

3. On the Custom tab, in the HTTP-EQUIV or User Variable boxes, click the Add button. 

4. Type the name and value of each metatag you want to include in your default template. For more information about HTTP-EQUIV and User metatags, see A Dictionary of HTML META Tags.

5. On the File menu, click Save (CTRL+S).

Note: There are two situations in which FrontPage 2003 does not create Web pages using the template. When you create a new Web site and a home page is created for that Web (either Index.htm or Default.htm), the Normal.htm is not used as a template for that page. However, all new pages you create in that Web from that point on are based on the template. Also, there are several FrontPage wizards you can use to create a new Web site. These wizards do not use the Normal.htm file as a template when creating the new Web site.

Providing Text Equivalents for All Images and Non-Text Elements

You should add alternative text (the alt or longdesc attribute) to all images on your Web site. A longdesc attribute is recommended when the alternative text exceeds 250 characters. FrontPage 2003 supports adding both alt and longdesc attributes to images using the Picture Properties dialog box. 

Adding alternative text will provide important information to site visitors who are using screen readers or browsers that don’t show images, or users who have turned off images to make Web pages load faster. This is especially important when your images are used for hyperlinks. The alternative text should be meaningful and informative. For example, instead of saying “Click here,” your alt text can read “Link to the Home Page.” The alternative text should convey the same information that the image conveys to a user that can see the image. 

To add alternative text to an image

1. Select the image (position the cursor to the left of the picture and press SHIFT+RIGHT ARROW).

2. On the Format menu, click Properties (ALT+O and then T).

3. In the Picture Properties dialog box, click the General tab (press the RIGHT ARROW key until you reach the General tab).

4. In the Alternative Representations section, in the Text box, enter your alternative text (press ALT+X to move the cursor to the Text box). If you have alternative text that is 250 characters or more, enter your alternative text in the Long Description box.

Alternative text also should be provided for:
· Symbols 
· Animations 
· Applets 
· Objects 
· ASCII art 
· Frames 
· Scripts 
· Picture bullets 
· Picture spacers 
· Horizontal rules 
· Buttons 
· Video and audio 
Using Image Maps Properly

Whenever possible, use client-side image maps rather than server-side image maps. By default, FrontPage 2003 image maps are all client-side. Client-side image maps are more user-friendly for users with assistive technologies. However, in some instances, the image map cannot be represented by a standard geometric shape. For example, you might want to provide users with a map of your state. The state map has active regions for each county. If you must use a server-side image map, be sure to provide redundant text links for all active regions of the map.

To provide redundant text links for server-side image maps, you can:

1. Provide a list of text links for active regions of the image map. 

2. Include the links in the body of the OBJECT element. 

3. If the image map uses the IMG element, place the text links in the document after the IMG element and note the location of the links. 

Each area of an image map used as a hyperlink must have alternative text associated with it to make it accessible to people with disabilities. 

To provide text equivalents for active regions of an image map

1. Double-click an image-map hot spot.

2. In the Edit Hyperlink dialog box, click the ScreenTip button (ALT+P). 

3. In the Set Hyperlink ScreenTip dialog box, in the ScreenTip text box, enter the alternative text for the hot spot.

Using Accessible Plug-Ins for Multimedia Elements

Be cautious when inserting the latest technologies into your Web site. Multimedia presentations offered through products such as Flash, Java, and Shockwave are seldom accessible to users who are not up to date with the latest technologies. There also are numerous Web browsers that simply do not have the capability to integrate such technology into their platform.

If new technologies are used in your site to communicate a specific point vital to the user experience, consider offering a more traditional presentation in addition to your multimedia. If you must incorporate a new technology that requires a plug-in, the plug-in itself should be accessible.

If you provide multimedia files in special formats, you also must provide a link to the Uniform Resource Locator (URL) where the media player can be downloaded. When you provide information to users that can be accessed through specific applications or plug-ins, the applications and plug-ins should be accessible.

Creating Accessible Multimedia Presentations

For multimedia presentations, you should synchronize equivalent text with the presentation itself. Synchronizing equivalent information with a presentation is the same concept as using captions for a television program. The text equivalent of the animation is presented on screen. The animation and the text equivalent are synchronized so that the text equivalent describes the animation.

When you synchronize presentations in the same way for Web content, you are assisting people with vision and hearing difficulties. For people with visual impairments, the screen reader interprets the animation. For people with hearing impairments, the text version adequately describes the animation and the sound.

Because people accessing your Web content might have visual and hearing impairments, make your content describe the animation and the sound accurately. For example, be sure to describe noises that indicate the tone or mood of the animation, like a door slamming or a crowd cheering.

Avoiding the Use of Color Alone to Convey Essential Information

We all have seen Web forms with instructions that say “fields marked in red are required.” You certainly don’t want to frustrate the user by continually kicking back the form until they’ve completed the required fields without guidance as to what is a required field. However, you can’t depend on the ability of the user to discern the color. Your visitor may be blind and can’t see which fields are marked in red, or colorblind and unable to differentiate the color red from other colors used on the site.

One way to avoid using color to identify critical information is to place an asterisk next to the required form fields. The asterisk will be read aloud by the screen reader. Place the instructions “fields marked with an asterisk are required” at the beginning of the form, alerting the user of the required fields before he or she starts filling out the form.

Setting a Logical Keyboard Order in Forms

To help users navigate through a form using the keyboard, you should ensure a logical tab order (the order in which the cursor moves through the form information as the user presses the TAB key). Form elements should be numbered sequentially to assist the user in navigating the form.

To set the tab order for form fields

1. Click the form field (position the cursor to the left of the form field and press SHIFT+RIGHT ARROW). 

2. On the Format menu, click Properties (ALT+ENTER).

3. In the Tab Order box, enter a number for the form element. 

4. Click OK. 

5. Repeat steps 1 through 4 for additional form elements, numbering them in ascending order.
Labeling Form Field Controls

Properly marked up form fields make it easier for a person using a screen reader to know what the form field is and what kind of data to enter into the field. All form fields should be identified with a label, which will be read aloud by a screen reader as a user navigates through the form. 

To insert label tags for form fields

1. In Design view, select the form field label (Name:, for example) and the associated form field.

2. On the Insert menu, click Form, and then choose Label (ALT+I, then R, and then A).
The resulting code will look like this: 

<p><label for="fp1">Enter your First name here: </label> 
<input type="text" name="firstname" size="20" tabindex="1" id="fp1"></p>

Providing Keyboard Shortcuts for Form Fields and Hyperlinks

Assigning keyboard shortcuts (accesskey attributes) to the links and form fields on your page allows keyboard users to navigate the page easier by using just two keys (ALT+key) to get to a specific place in a page. For consistency and usability, you should use the same access keys for the same links on all pages in your site.

To add an accesskey attribute to a hyperlink

1. Switch to Code view.

2. Inside the A HREF tag, type accesskey="", adding a letter between the quotation marks.
The resulting code will look something like this: 

<a href="http://www.wingtiptoys.com/contact_us.htm" accesskey="C">Contact Us</a>
To add an accesskey attribute to a form field

1. In the form field label, select a single letter to use as a shortcut.

2. On the Formatting toolbar, click the Underline button. 
Using Cascading Style Sheets

If done correctly, cascading style sheets can contribute greatly to the accessibility of your Web site and make it easier to maintain at the same time. Imagine changing a single value on one page of your site, and having the change reflected on all the pages throughout your site. 

Here are some general rules: 

· Don’t rely on specific fonts or colors to convey your message. While you can specify fonts and colors using CSS, the fonts and colors specified may not exist on all computers. 
· Don’t use cascading style sheets to fix the size of your text in points or pixels. A person with low vision may need to increase the size to read the text on your page. “CSS Techniques for Web Content Accessibility Guidelines 1.0” recommends that you use the "em" unit to set font sizes.
· Use the Heading tags (H1–H6) to indicate the organization and structure of your page, not to modify the font size.
· Don’t assume that your visitors are using the same browser window size and screen resolution that you are using. Use an adjustable layout that will shrink or expand as necessary.
· Provide sufficient contrast between text colors and backgrounds.
· Ensure that pages are usable even if your visitor:
· Is using a browser that doesn’t support style sheets
· Has style-sheet support turned off
· Needs to use his or her own style sheet
Identifying the Primary Language of the Document 

Identifying the primary language of your Web page will enable screen readers to properly pronounce abbreviations and acronyms on the page. This can be done in FrontPage 2003 by modifying the template used for new Web pages (see “Using a DOCTYPE Declaration”) or by manually inserting the language metatag in each page.
To insert the language metatag

1. On the File menu, click Properties (ALT+F, then R, and then R again).
2. In the Page Properties dialog box, click the Language tab.

3. In the Page language section, in the Mark Current Language as drop-down list, choose the desired language.
You also should identify changes in language for words or phrases on a page. A language change within a page is coded with a SPAN tag. 

To identify changes in language in selected text

1. Select the phrase or phrases that are in a different language. 

2. On the Tools menu, click Set Language (ALT+T and then L).
3. In the Set Language dialog box, choose the language from the Mark Selected Text as drop-down list.
The resulting code will look like this: 

<p>And with a certain <span lang="fr">je ne sais quoi</span>, she entered both the room, and his life, forever.</p>

A list of language codes can be found at the Unicode site.
Making Data Tables Accessible

To be accessible, a data table must be properly marked up with CAPTION elements and headers attributes. In addition, each table header should be identified with a unique id attribute and its associated cell should be marked up with a headers attribute tied to the id attribute. The CAPTION element and summary attribute are read aloud by a screen reader, and properly marked up TABLE HEADERS and cells can be navigated using special keyboard combinations in a screen reader. 

The CAPTION element should contain a short description of the table’s purpose. The CAPTION should go immediately after the TABLE element. 

To insert a CAPTION element

1. In Design view, position your cursor immediately before the TABLE tag.

2. On the Table menu, click Insert, and then choose Caption (ALT+A, then I, and then A).

3. Type the desired caption.
The summary attribute should be used to provide a longer narrative description of the table, its structure, and its contents. The contents of the summary attribute will be read aloud by a screen reader.

To insert a summary attribute

1. In Design view, select the table. 

2. Switch to Code view. 

3. Place the cursor in the TABLE tag, and then type summary="". In between the quotes, add a description of the table contents. For example:

<table summary="This table charts the income and outgo for last month and this month">
The TABLE HEADER (TH) defines a cell that contains header information. 

To identify a cell or row of cells as header cells

1. In Design view, select the cell or cells.

2. On the Table menu, click Table Properties, and then choose Cell (ALT+A, then I, and then E).

3. In the Cell Properties dialog box, select Header Cell (tab to the Header Cell checkbox and press ENTER to select it).
Each TABLE HEADER should have a unique id attribute to associate the row or column with the data in associated cells. 

To add id attributes to TABLE HEADER tags

1. Switch to Code view. 

2. Inside the TH tags, type id="" and include a header that describe the cell’s content. Your code should resemble the following:

<th id="header1">Month</th>
<th id="header2">Income</th>
<th id="header3">Outgo</th>
<th id="header4">Difference</th>
Each TABLE DATA tag should also have a headers attribute to associate the TABLE DATA tag with the associated table header cell.

To add headers attributes to TABLE DATA tags:

1. Switch to Code view. 

2. Inside the TD tags, type headers="" and include the header that describe the cell’s content. Using the sample id attributes above, your code should resemble the following:

<td headers="header1">June</td>
<td headers="header2">$55,987.00</td>
<td headers="header3">$56,775.00</td>
<td headers="header4">$778.00-</td>

Creating Titles for All Frames

In many ways, the best approach in the development of an accessible Web site is to stay away from frames. Frames pages can create problems for any nontraditional browser. Trying to convey the concept of a frame through a screen reader is extremely difficult. Consider providing a non-frames version of your Web site if frames are deemed necessary. 
If you use a FrontPage frames template page as the base for your frames page, FrontPage creates a NOFRAMES page for you. Complete that page with the information conveyed by the frames page so users who are using technologies that do not support frames can access the same information.
Accessible Web content can include frames. However, the frames must have descriptive text so that users with browsers that do not support frames can access them. Frames should have a descriptive title that indicates the type of information contained on the page. For instance, a frame that will display the latest news story might be titled “Latest News” or “Current News.”

When you have created your frames page in FrontPage 2003 and are saving the document, you will be prompted for a page title for each frame in your frames page. In the Save As dialog box, the File Name box will contain a default frames title. To change it, click the Change Title button above the File Name box. In the Set Page Title dialog box, enter your new descriptive title.

If you wish to update an existing set of frames with more descriptive titles, right-click in the frame you wish to update (or select the frame and press SHIFT+F10) and choose Page Properties. In the Title box of the General tab, enter the new descriptive title.

FrontPage 2003 also supports accessible inline frames, or i-frames. I-frames should have alternative text and titles, just as frames should. Because some browsers and assistive technologies do not support i-frames or frames, the alternative text should provide the page visitor with the information that is contained in the i-frame element.

Using Metatags to Enhance Accessibility, Usability, and Searchability

W3C recommends the use of metadata because it makes documents easier to find and use. Metadata enhances accessibility while also enhancing general usability. Metadata can give the user preliminary information about the document, such as the language, author, subject, title, owner, purpose, age appropriateness, keywords, and more. Metadata can make use of an unlimited number of metatags.

Be sure to take advantage of the title, keyword, and description metatags. These three metatags are standard to many search services and engines. Search engine crawlers often place a high priority on these metatags and their values.

To insert a page title

1. On the File menu, click Properties (ALT+F and then R).

2. In the Page Properties dialog box, under the General tab, in the Title box, enter your new page title. 
Content type and content language metatags can be added to your default template used for all new pages (see “Using a DOCTYPE Declaration”).
Description and keyword metatags can be added to each page individually. 

To add description and keyword metatags

1. On the File menu, click Properties (ALT+F, then R, and then R again). 

2. In the Page Properties dialog box, under the General tab, in the Page Description box, include your page description. 

3. In the Keywords box, include your keywords.
Guidelines for Blinking or Flashing Elements

If you use blinking or flashing elements, be aware that these elements are a potential source of harm to some Web site visitors. You should avoid screens that flash at frequencies between 2 and 55 hertz.

Ensure that moving, blinking, scrolling, or auto-updating objects or pages can be paused or stopped. Moving text can be unreadable for some people with cognitive or visual disabilities, and can cause such a distraction that the rest of the page becomes unreadable as well. Also, many screen readers are unable to read moving text. If you do insert Flash objects or other animation into your Web site, include alt text as mentioned in “Providing Text Equivalents for All Images and Non-Text Elements.” 
Note: The BLINK and MARQUEE elements are not defined in any W3C HTML specification, and W3C recommends these elements not be used.

Considering an Alternative Accessible Page 

Alternative accessible pages should be created only when it is not possible to make the original page accessible. This means that you must make every attempt to make the original page accessible. If you determine that it is not possible to make the original page accessible, then you may create an alternative page that is accessible. The alternative page should provide the page visitor with an equivalent experience, and thus it should be updated as often as the original page.

Conclusion 

Web surfing is not limited to users who sit in front of a computer screen viewing the Internet on the latest browser with the fastest computer processor. As the audience has expanded in both participants and Web clients, the need to provide a browsing experience for everyone becomes essential. It is good business to build a Web site that can be viewed by as many participants as possible.

Microsoft Office FrontPage 2003 provides tools for building an accessible Web site, helping you to create the Web site you want, exactly the way you want it, while making it accessible to as many people as is possible.

Additional Resources
Section 508

· The “Electronic and Information Technology Accessibility Standards” outline the final accessibility standards as covered by Section 508 of the Rehabilitation Act.
Microsoft

· To learn more about Microsoft’s efforts to support Section 508 of the Rehabilitation Act, see “Microsoft and Section 508” on the Microsoft Accessibility Web site.
· Microsoft has put together more information about accessible Web design guidelines; see “Accessibility” on the MSDN® Web site.
· For more information about using XMLP to modify the accessibility checker, see the FrontPage 2003 SDK.
· A complete list of FrontPage 2003 keyboard shortcuts is available on the Office Online beta site.
W3C

· W3C has developed a set of universal guidelines for Web development; see the Web Content Accessibility Guidelines 1.0. 
· The W3C Web Accessibility Initiative, in coordination with organizations around the world, pursues accessibility of the Web through five primary areas of work: technology, guidelines, tools, education and outreach, and research and development.
· More information about XPath is available at the W3C Web site. 
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