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Updates

February 2007
· Added Recommendations section

· Added installation and configuration procedures for Windows SharePoint Services (WSS) 3.0 and Microsoft Office SharePoint Server (MOSS)

· Added Troubleshooting Enterprise Portal section as Appendix A
Introduction
Use this document to install and configure Enterprise Portal (EP) for Microsoft Dynamics AX 4.0 or Microsoft Dynamics AX 4.0 with Service Pack (SP) 1 on a computer that is running Windows Server 2003. This document emphasizes the procedures to install and configure EP. For more information about EP in particular, or Microsoft Dynamics AX 4.0 generally, see Help.
Prerequisites

· A valid Microsoft Dynamics AX license for Enterprise Portal. To obtain a license, contact your Microsoft Dynamics AX certified partner.
Recommendations
· Install the core Microsoft Dynamics AX installation (file server, object server, client, and database) before setting up and configuring EP. For more information, see the Microsoft Dynamics AX Implementation Guide.
· Verify that the core Microsoft Dynamics AX installation meets all requirements, including Active Directory directory services configured in native mode. For more information, see Hardware and Software Requirements.
· Verify that you are not trying to deploy EP on a 64-bit computer. EP is currently not supported on 64-bit computers.

· Install all service packs for Microsoft® SQL Server™, if applicable.
· Verify that you are not setting up EP on a computer that is configured as a Microsoft Dynamics AX reporting server. For more information, see Set up and configure ad hoc reporting.
· Uninstall Internet Explorer Enhanced Security Configuration (Start > Control Panel > Add or Remove Programs > Add/Remove Windows Components).
Create the Business Connector Proxy in Active Directory
The proxy is a Microsoft Windows domain account that enables Business Connector to act on behalf of Microsoft Dynamics AX users when users authenticate with the Application Object Server (AOS). You must set up and configure the proxy as described here. If you do not set up and configure the proxy as described here, remote users cannot connect to Microsoft Dynamics AX using EP.

Important If a malicious user learns the Business Connector proxy credentials (name and password), that user could gain unauthorized access to sensitive data. Therefore, only Microsoft Dynamics AX administrators should know the proxy credentials.
1. Create a unique user in Active Directory in the form domain\username, for example, domain\bcproxy. This user must not have the same name as an existing user in Microsoft Dynamics AX. For the procedure to add a new user, see the Active Directory documentation.

2. Assign a password to the user.

3. Optional. Select the Password does not expire option.

4. Select the No interactive logon rights option.

5. Close Active Directory.

Install Internet Information Services (IIS)

1. Click Start, click Control Panel, click Add or Remove Programs, and then click Add/Remove Windows Components. 
2. Select Application server, and then click Details.

3. Select ASP.NET (and keep all other default selections).

4. Select Internet Information Services (IIS), and then click Details.

5. Verify that FrontPage 2002 Server Extensions are not selected.
6. Click OK to complete the installation.

Enable ASP.NET 2.0

1. At the command prompt, open the following directory: \WINNT\Microsoft.NET\Framework\v2.0.50727

2. Type: 
aspnet_regiis.exe -iru -enable
3. After the install completes,  type iisreset, and then press Enter.

Prepare SQL Server
Your Microsoft Dynamics AX 4.0 installation uses either Microsoft® SQL Server™ 2005 or Microsoft SQL Server 2000 with Service Pack (SP) 4 or later versions. You must configure your SQL server as described here to support EP. If you install WSS or MOSS with the Microsoft Data Engine (MSDE), EP will not support search.

Important On systems that use an Oracle database for Microsoft Dynamics AX, you must use MSDE for WSS. 

SQL Server 2005

6. Open Microsoft SQL Server Management Studio (Start > All Programs > Microsoft SQL Server 2005 > Microsoft SQL Server Management Studio).

7. In the left pane, right-click the SQL Server, and then click Properties.

8. Click Security.

9. Under Server Authentication, click Windows Authentication Mode, and then click OK. 
10. In the left pane, expand the Security node. 

11. Right-click Logins, and then select New login.

12. In the Login name text box, enter the name of the Business Connector proxy in the form domain/name.
13. In the Default Database drop-down list, select the Dynamics AX database.

14. Click Server Roles, select dbcreator, and then click OK.
SQL Server 2000 with SP4 

15. On the computer that is running SQL Server 2000 with SP4, open Enterprise Manager (Start > All Programs > SQL Server > Enterprise Manager).

16. In Enterprise Manager, expand Microsoft SQL Servers, and then expand SQL Server Group.

17. Right-click the SQL Server, and then click Properties.

18. On the Security tab, in the Authentication section, select Windows only, and then click OK. 

19. In the left pane, expand the Security node. 

20. Right-click Logins, and then select New login.

21. In the Login name text box, enter the name of the Business Connector proxy in the form domain/name.

22. In the Default Database drop-down list, select the Dynamics AX database.

23. Click Server Roles, select dbcreator, and then click OK.
Install and configure Windows SharePoint Services

This section describes how to install and configure WSS 3.0 and Microsoft Office SharePoint Server (MOSS). WSS 3.0 is a free download from Microsoft. If you intend to use MOSS, you must purchase a license. 
1. If WSS 2.0 is currently installed on your server, uninstall it using Add Or Remove Programs.

2. Uninstall IIS and reinstall IIS according to the procedure earlier in this white paper.

3. If you have already installed a Microsoft Dynamics AX client on this computer, verify that the Ax32.exe.config file exists in this location on your server: %System Drive%\Program Files\Microsoft Dynamics AX\40\Client\Bin. If the file does not exist, locate it on your Microsoft Dynamics AX DVD (in the \retail\bin directory) and copy it to the specified location.

4. Install the .NET Framework 3.0 here.

5. Install WSS 3.0 here, or install MOSS by using the product DVD. When you are prompted, select the Basic installation. 
6. After the installation is complete, select the option to run the SharePoint Products and Technologies Configuration wizard.

7. Click Next.
8. After the wizard completes, click Finish. SharePoint opens the default team site.
Set the WSS 3.0/MOSS Authentication Provider

1. Open the SharePoint Central Administration page (Start > Administrative Tools > SharePoint 3.0 Central Administration.)

2. Click the Application Management tab.
3. Under Application Security, click Authentication Providers.

4. Click Default. The Edit Authentication page opens.

5. Under IIS Authentication Settings, verify that Integrated Windows authentication is selected, and then select NTLM.
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6. Click Save.

7. Click the Operations tab.

8. Under Security Configuration, click Service accounts.

9. Click the Web application pool option.
10. In the Web Service drop-down list, select Windows SharePoint Services Web Application.

11. In the Application Pool drop-down list, select SharePoint - 80.

12. Select the Configurable option.

13. In the User name text box, enter the BC proxy username in the form domain/name.

14. Enter the BC proxy password, and then click OK.

15. Open IIS Manager (Start > Run > type inetmgr, and then press Enter).

16. In the left pane, expand the local computer, expand Applications Pools, right-click the SharePoint Central Admin V3 pool, and then click Properties.

17. Click the Identity tab.

18. Click the Configurable option.

19. Enter the BC proxy credentials in the form domain/name, and then click OK.

20. At the command prompt, type iisreset /noforce, and then press Enter.
Configure ASP.NET

24. In a basic text editor like Notepad, open the web.config file. The file is typically located in the %SYSTEMDRIVE%\Inetpub\wwwroot folder or the %SYSTEMDRIVE%\\Inetpub\wwwroot\wss\VirtualDirectories\80 folder, but the location depends on options that you select.
25. Press CTRL + F to open the Find dialog box.

26. Find the following tag:

<trust level="WSS_Minimal" originUrl="" /> 

27. Replace it with this tag (changes in bold): 

<trust level="WSS_Medium" originUrl="" />

28. Find the following tag:
<httpRuntime maxRequestLength="51200" />
29. Replace it with this tag (changes in bold):
<httpRuntime executionTimeout="6000" maxRequestLength="51200" />

30. Add the following items to the list of <safecontrols>:

<SafeControl Assembly="Microsoft.Dynamics.WebParts, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="Microsoft.Dynamics.WebParts" TypeName="*" Safe="True" />
<SafeControl Assembly="Microsoft.Dynamics.ClrBridge, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="ClrInterop" TypeName="*" Safe="True" />
31. Press CTRL+S to save your changes.

32. Close the web.config file.

33. At the command prompt, type iisreset /noforce, and then press Enter.

Add the BC proxy account to the appropriate Windows group

34. Open Computer Management (Start > All Programs > Administrative Tools).

35. Expand Local Users and Groups, and then click Groups.
36. Right-click the Performance Monitor Users group, and then click Add to group.

37. Click Add.

38. Enter the BC proxy name in the form domain/name, and then click OK.

39. Repeat this process for the following groups:

· Power users

· IIS_WPG

· WSS_WPG 
Configure IIS for SharePoint Services and EP
Set IIS to use Windows Integrated authentication

1. Open IIS Manager (Start > Run > type inetmgr, and then press Enter).
2. Right-click the Web sites directory, and then click Properties.

3. On the Directory Security tab, in the Authentication and access control section, click Edit.
4. Select Integrated Windows authentication, and then click OK.
5. Accept the changes for all Web sites.

Set the application pool identity

1. In the left pane of IIS Manager, expand Application Pools.

2. Right-click the SharePoint Services content application pool (not the administration application pool), and then click Properties. 

3. On the Identity tab, select Configurable.
4. Enter the Business Connector proxy account username and password in the form domain/name. 

5. Click Apply, and then click OK.
6. Right-click the SharePoint Services application pool again, and then select Recycle.
Verify the WSS sites are using ASP.NET v2
1. In the left pane of IIS manager, expand the Web sites directory.

2. Right-click the SharePoint – 80 site, and then click Properties.
3. Click the ASP.NET tab.

4. In the ASP.Net version drop-down list, verify that v2.0.50727 is selected. If it is not selected, select it now. 
Note If you do not have the option to select v2.0.5.727, restart IIS (at the command prompt, type iisreset, and then press Enter). After IIS restarts, select v2.0.50727 in the ASP.NET version drop-down list.
5. Click OK.
6. Repeat this process for the SharePoint Central Administration v3 site.
7. At the command prompt, type iisreset /noforce, and then press Enter.

Install EP
1. Insert the Microsoft Dynamics AX DVD into your drive. If the Microsoft Dynamics AX Setup Wizard does not open automatically, double-click the Autorun.hta file in the root directory of the DVD.

2. On the Select installation type page, click Custom installation, and then click Next.

3. On the Select computer role page, select EP server, and then click Next to complete the wizard.
Configure and Deploy EP
40. In the Microsoft Dynamics AX client, open the EP Configuration Wizard (Administration > Setup > Internet > EP > Configuration Wizard).

41. Click Next.

42. On the Configure user groups page, specify the groups that you want to use. The list shown in the wizard is based on available licenses.

43. On the Configure the Business Connector Proxy page, enter the proxy information.

44. On the Map document types to document categories page, select a document category for each document type in the list. You can perform this mapping later. For more information about document categories and document management, see “Appendix A: Configure document management for EP” later in this document.

45. On the Configure module document categories page, right-click each module to which you want to add a category, click New category, and select a category. 

46. On the Configure document management page, type the number of days that documents should be included in the list of latest documents.

47. On the Configure transaction summaries page, specify a schedule for generating transaction summaries displayed on EP. 
48. Click Next to complete the wizard. The Manage EP Deployments form opens.
49. Select the Enabled option for your SharePoint content site, for example, http://servername. 
Create the EP site

50. In the Microsoft Dynamics AX client, open the Web sites form (Administration > Setup > Internet > EP > Web sites).
51. Click Create site. The WSS 3.0/MOSS Create Site Collection page opens.

52. Ensure that the SharePoint – 80 site is the active Web application. In the Web Application drop-down list, select Change Web Application.

53. Select the SharePoint – 80 application, and then click OK.

54. Enter a name (for example, companyname_EP).
55. Enter a Web address (for example, http://servername/sites/EP).
56. Under Template Selection, click Custom, select one of the following options, and then click OK.

	Option
	Description

	Microsoft Dynamics Enterprise Portal
	Create personalized, role-based Web portals so that specific customers, vendors, business partners, and employees can access business information and conduct transactions. 

Note   All members of EP must be validated through Active Directory directory service.

	Microsoft Dynamics Public
	Create Web sites for customers and prospective customers. You can publish relevant product and campaign information from Microsoft Dynamics AX, or create surveys that store data in the Microsoft Dynamics AX. By default, Customer Web allows anonymous access to the site.


57. Enter administrator details.

58. Leave Quota Template set to No Quota.
59. Click OK. WSS 3.0/MOSS creates the Web site. 

60. Copy the URL on the Top-Level Site Successfully Created page.

61. In the Microsoft Dynamics AX client, on the Web sites form, click Register site. 

62. Enter the Web site URL (the URL that WSS 3.0/MOSS displayed on the Top-Level Site Successfully Created page) in the Internal URL field. 

63. Under Type, select Full.

64. Press CTRLl+S to save changes.

65. Click the View in Browser button to view the site.

66. On the Register Site page, select a company with which you want to associate the site, and then click Register.

Create external users for Web access

Microsoft Dynamics AX users can be internal, such as employees, or external, such as vendors or customers. An external Web user is any individual who accesses Microsoft Dynamics AX only by using EP or a Web browser.

Set up your Internet-facing topology for external users

67. From a Microsoft Dynamics AX client, click Administration > Setup > Internet > External Web users.

68. Select the type of Internet-facing topology that you are using, and fill in the required information.

For more information, see “Plan Active Directory user topology” in the Microsoft Dynamics AX Implementation Guide.

Add external users to the list of users

69. From a Microsoft Dynamics AX client, click Administration > Users.

70. On the Overview tab, create new users or click Import to access the Active Directory Import Wizard. 

Assign user groups based on EP roles

71. From a Microsoft Dynamics AX client, click Administration > Users. 

72. On the Overview tab, select a user. 

73. On the Groups tab, select all the user groups in the Remaining groups list that correspond to the user's EP roles.

For more information about how to determine which user groups correspond to the user's EP roles, see “Appendix E: About EP roles and user groups” later in this document.

74. Click the left arrow button (<) to move the selected groups into the Selected groups list.

75. Press CTRL+S to save changes.

Enable Web access for each Web user

To enable Web access for a Web user, you must set the user type and associate the user with the appropriate Web sites. For each Web site, you must also assign the user to the appropriate site group. 

EP uses WSS site groups to manage security across the EP site. Each user must be a member of at least one site group in order to view or access the EP site. For more information about how to create site groups, see Microsoft Windows SharePoint Services Help.

76. From a Microsoft Dynamics AX client, click Administration > Setup > User relations.

77. On the Overview tab, click the Wizard button, or select the user for whom you want to enable Web access. 

78. On the General tab, select Internal users or External users as the user type.

If the user is external, select whether the user is a customer or a vendor, and then select the appropriate account.

79. On the Web sites tab, select the Web site that you want to associate with the selected user.

80. For the selected Web site, click the Site Group arrow, and select the appropriate SharePoint site group for that user. 

81. Repeat steps 4 and 5 for each Web site that the user has to access. 

To assign a user to multiple SharePoint site groups, press CTRL+N to create a new line, select the desired Web site, and then select an additional site group for that user.

82. Press CTRL+S to save changes.

Appendix A: Troubleshooting EP
If the resolution for an EP problem is not obvious, check the Windows Application Event Viewer for errors (Start > Administrative Tools > Computer Management > Event Viewer > Application). These application events can provide clues to the source of the problem. 
You receive an error message that contains a phrase such as "assembly not found," "could not be created," or "threw an exception."
You might not have ASP.NET 2.0 installed or registered. See “Enable ASP.NET 2.0” earlier in this document.
You receive an error message that contains a phrase such as "access denied" or "do not have permission,"
or you receive one of the following messages:

· "Cannot add the specified assembly to the global assembly cache" or "w3wp.exe unhandled exception (System.UnauthorizedAccessException)"
· "No .NET Business Connector session found"
Verify the following:
· The Business Connector proxy exists in Active Directory.
· The Business Connector is a member of the dbcreator role in SQL Server.
· The Business Connector proxy is a member of the Performance Monitor Users, Power Users, IIS_WPG, and WSS_WPG Windows groups.

· The IIS application pool identity for your SharePoint 80 site uses the Business Connector proxy (see “Configure IIS for SharePoint Services and EP” in this white paper).
· You are a member of the Admin group in Microsoft Dynamics AX and a member of the Administrators group on the server.

When you open the Manage EP Deployments form in Microsoft Dynamics AX, you receive an error message that states: “Clr object is not initialized.”

Verify that the Ax32.exe.config file exists in this location on your server running Microsoft Dynamics AX: %System Drive%\Program Files\Microsoft Dynamics AX\40\Client\Bin. If the file does not exist, locate it on your Microsoft Dynamics AX DVD (in the \retail\bin directory), and copy it to the specified location.

If the problem persists, verify that you entered the <SafeControl> entries that are specified in the “Configure ASP.NET” section of this white paper. After you have verified these items, use the Manage EP Deployments form to enable and update the Web site.

You cannot locate or install EP templates

You must use an EP template when you create your top-level Web site in Windows SharePoint Services. If you do not see the EP public or private templates on the Custom tab in WSS, follow this procedure:
83. Use Windows Explorer to verify that the templates exist on the server. By default, the templates are stored in the following folder: C:\Inetpub\wwwroot\wpcatalog. If this folder does not exist, EP was not installed correctly. Uninstall and reinstall EP. 

84. If the templates are on the server, redeploy the Web site. From a Microsoft Dynamics AX client on your EP server, click Administration > Setup > Internet > EP > Manage deployments.

85. Clear the Enabled check box for the virtual server. When you are prompted, click Yes to remove the deployment.

86. Select the Enabled check box for the virtual server. A message box states that the Web parts were deployed successfully.

87. In Windows SharePoint Administration, click the Create a top-level Website link, and verify that EP templates are now in the templates list.
Error message: "The Web site http://server/sites/site_name was not created correctly. Exception: No .NET Business Connector session could be found."
The Business Connector might not be configured correctly. To verify the configuration, follow this procedure:
88. On the server that runs IIS and hosts your EP site, click Start > Administrative Tools > Microsoft Dynamics AX Configuration Utility.
89. In the Configuration target list, click Business Connector (non-interactive use only).

90. On the Connection tab, verify the server name and the TCP/IP port. If the port is blank, you can assume that it is running on port 2712. To verify the actual port on the AOS server, view Dynamics Information events in the Application Event log after the AOS has started.
91. If it is necessary, update the configuration or create a new configuration (click Manage > Create configuration). 

For more information, see Manage a Business Connector non-interactive configuration91fd7a36-5a5f-4a2d-b85c-c7ecaec9c405.

Error message: "http://server/sites/site_name was not created correctly. Exception: Thread was being aborted."

This error occurs because of a connection time-out after you select the Microsoft Dynamics AX template while you are creating a new top-level Web site in Windows SharePoint Administration. To resolve this problem, follow these procedures:

· Change the Connection timeout and Http Keep-Alive properties on the server that runs IIS.
· Change connection time-out properties in the web.config file.
Change the Connection timeout and HTTP Keep-Alive properties on the server that runs IIS

92. Open the Internet Information Services Manager (Start > Run, type inetmgr, and then press ENTER).

93. Expand the local computer, expand the Web sites directory, right-click the Web site that hosts your EP site (typically the Default Web site), and then click Properties.

94. On the Web Site tab, specify a new value in the Connection timeout field. The default value is 120 seconds. 

For example, if the server requires up to 4 minutes to create a new site using EP templates, specify a value of 240 seconds.

95. Select Enable HTTP Keep-Alives (if it is not selected), and then click OK.

96. Restart IIS (at a command prompt, enter iisreset, and then press ENTER).

Change connection time-out properties in the web.config file

97. In a basic text editor such as Notepad, open the web.config file %SYSTEMDRIVE%\Inetpub\wwwroot 
-or- 
%SYSTEMDRIVE%\\Inetpub\wwwroot\wss\VirtualDirectories\80 folder
98. Press CTRL + F to open the Find dialog box.

99. Find the following tag:

<httpRuntime maxRequestLength="51200" />

100. Replace it with this tag:

<httpRuntime executionTimeout="6000" maxRequestLength="51200" />

101. Find the following tag (you might have to search from the beginning of the file):

</sectionGroup>
102. Add the following tags on new lines after the </sectionGroup> tag:

<sectionGroup name="DynamicsAX">
<section name="Deployment" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
</sectionGroup>
103. Find the following tag:

</SharePoint>
104. Add the following tags on new lines after the </SharePoint> tag:

<DynamicsAX>

<Deployment SiteCreationTimeOut="1200" />

</DynamicsAX>

105. Save your changes, and close the web.config file.

106. At the command prompt, type iisreset, and then press ENTER.
107. Try to create the top-level Web site in SharePoint Portal Administration.

After EP is installed, the Application Integration Framework doesn't work

For Application Integration Framework (AIF) to run on the same computer as WSS and EP, the virtual directory that AIF is using must be excluded from the SharePoint managed path. 

108. Open the SharePoint Central Administration page (Start > All Programs > Administrative Tools > SharePoint Central Administration). 

109. Click Configure virtual server settings, and then click the name of the site that you are managing. 

110. Under Virtual Server Management, click Define managed paths.

111. Under Add a New Path, enter the AIF virtual directory path, select Excluded path, and then click OK.

Error message: "An X++ exception has occurred"

Microsoft Dynamics AX allows for one EP site per company. Verify that the company you are logged on to does not already have a registered EP site (Administration > Setup > Internet > EP > Web sites).
Appendix B: Configure document management for EP
EP integrates Microsoft Dynamics AX document management functionality with the Microsoft SharePoint user interface. Therefore, users can perform many of the same document management tasks from EP that they can perform from the Document handling form in the Microsoft Dynamics AX client application.

For example, users can perform the following tasks from EP:

· Add or delete a document (note or file) from a Microsoft Dynamics AX record.

· View or edit the properties of a document that is attached to a Microsoft Dynamics AX record.

· Open a document that is attached to a Microsoft Dynamics AX record.

· View a list of all documents for single record or a specific record type.

· View a list of the latest documents for a single record or a list of Microsoft Dynamics AX records.

Specify which documents to include in the list of latest documents

Administrators can specify the number of days that new documents are shown in the list of latest documents on EP. 

112. From a Microsoft Dynamics AX client, click Administration > Setup > Internet > EP > Parameters.

113. Click the Documents tab.

114. In the Number of days field, type the number of days that you want new documents to be included in the list of latest documents. 

Configure document types and categories

You can use the Configuration wizard to determine which document types are associated with document categories in EP and to map document categories to specific modules.

115. From a Microsoft Dynamics AX client, click Administration > Setup > Internet > Enterprise Portal > Configuration wizard.

116. On the Map document types to document categories page, select a document category for each document type in the list, and then click Next.

117. On the Configure module document categories page, right-click each module to which you want to add a category, click New category, and select a category. Click Next to continue.

Appendix C: Set up transaction summaries for EP
You must configure the transaction summary batch job to display any of the following transaction summaries in Web parts on EP:

· Purchase totals including quantity, amount, weight, and volume

· Customer balances

· Inventory on hand

· Vendor balances

Setting up a transaction summary batch job requires that you do the following: 

· Create a batch group - batch groups enable you to add a group of batch jobs to the processing list at the same time.

· Associate the transaction summary batch job with a batch group, and configure the frequency with which the batch job is processed. 

· Add the batch group to the processing list.

Configure transaction summaries

You can use the Transaction summary form to set the frequency with which transaction summaries are generated. 

118. Open Administration > Setup > Internet > Enterprise Portal > Transaction summary.

119. Associate the transaction summary to a group from the Batch group list.

120. Select the Batch processing check box to run the job as a batch without being associated with a batch group.

121. Click Recurrence to set the frequency with which the transaction summary is run.

122. Click OK to close the dialog box.

Start batch processing

123. Open Basic > Periodic > Batch > Processing.

124. In the Group list, select the batch group that you have associated with the transaction summary job, and then click OK.

The job starts to process on the schedule you defined.

Appendix D: Administer product groups

The products in the inventory table must be organized and filtered into product groups before they can be presented on the EP. The product groups are organized in a tree structure with two possible node types: 

· Group node - Used to hold item nodes and group nodes on a lower level in the product group hierarchy. 

· Item node - Used to hold the selected product items from your inventory. 

Set up product groups

125. From a Microsoft Dynamics AX Client, click Administration > Setup > Internet > Enterprise Portal > Product groups.

126. To create a new product group, on the File menu, click New (or activate the upper window and press CTRL+N). Then:

a. In the Product group field, enter an identifier for the product group. 

b. In the Name field, enter a descriptive name for the product group. 

c. In the Type list, select Group node or Item node. 

· The Top field indicates whether the product group is the top node in the hierarchy. If it is a top node, it is marked with a green check mark.

· The Selection field indicates whether a selection is made by using the Query tool (available only when the selected type is Item node). 

127. To create more product groups, repeat step 2. 

128. To add component groups to the Group node, press CTRL+N, and select the product group that you want to include.

Important   Component groups can be added to the lower pane only if Group node is selected in the Type list for the product group that is selected in the upper pane. Component groups that are added in the lower pane must be available as product groups in the upper pane; the list of available component groups consists of the product groups in the upper pane.

129. If the selected product group in the upper pane is of the Item node type, click Select items to open the Item selection form.

This option can be selected only if Item node is selected in the Type list for the selected product group. 

130. In the Item selection form, click Select, and select the items that you want to allocate to the selected Item node. 
131. Click OK to return to the Item selection form, and then click OK to finish selecting items.

132. To create more product groups of the Item node type, repeat steps 5 through 8. When you have created all the necessary product groups, assign each item node to a group node.

Setting up product group and item presentations

When a customer clicks on a product group in the EP, a list of product items within that group is presented. The text and the image for the product group appears above the list of products. 

When a customer clicks on a product item, the product is presented with a picture, a summary, and a product description. 

Note   

· The number of tabs in the lower pane change according to the Item or the Product group that is selected in the Type field. 

· If the Product group is selected in the Type field, two tabs are available: Text and Image. 

· If Item is selected in the Type field, four tabs are available: Description, Summary, Product description, and Image. 

Set up product group or item presentations

133. Open the Presentations form (Administration > Setup > Internet > Enterprise Portal > Product catalog manager). 

134. In the Type field list, select either Product group or Item. 

135. In the Language field, select the language for the description, if the version supports multiple languages. 

136. For each tab in which you can write text, click Edit to begin adding or editing information for the selected Product group or Item. You can format the text in the HTML editor. 

For a Product group  

· On the Text tab, click Edit to add or edit the heading for the product group. The heading appears when a user selects a product group. 

· In the Brief description field, write the heading that appears when all the product groups are presented on the first page. This heading appears before the heading that is added on the Text tab.  

· On the Image tab, click Append to insert an image. 

· In the Add image form, select whether you want to append the image to all languages or only the current one. 

· Click OK, and then locate the image that you want to add to the current node. 

For an Item  

· On the Description tab, you can add or edit a description for each item. The description appears on the Description tab of the Web page that shows item information. In the Brief description field on the Description tab, you can add or edit a heading, which is displayed as a link to additional item details, for each item, when all the items within a product group are displayed. 

· On the Summary tab, you can add a summary. The summary appears with the brief description and on the Overview tab of the Web page that shows item information. 

· On the Product description tab, you can add a more detailed description for each item. The information appears underneath the description on the Description tab of the Web page that shows item information. 

· On the Image tab, click Append to insert an image. 

· In the Add image form, select whether you want to append the image to all languages or only the current one. 

· Click OK, and then locate the image that you want to add to the current node.  

137. Follow these processes for all the product groups and items. 

Note   The supported image formats on the Internet are GIF and JPG.

Appendix E: Set up search for EP
By using the Search feature in EP, users can search for Microsoft Dynamics AX records and documents and list items that are stored in WSS, including announcements and discussions. 

To enable search for both Microsoft Dynamics AX and Microsoft Windows SharePoint documents, ensure the following:

· The Microsoft Dynamics AX search indexes are configured and enabled.

· Search is enabled for Microsoft SQL Server and Microsoft Windows SharePoint Services.

If both of these steps are not completed, you receive mixed results. For example, if you enable search for SQL Server and WSS, but you do not set up the Microsoft Dynamics AX search indexes, EP users can search for SharePoint documents but not for records that are stored in Microsoft Dynamics AX.

Set up the search indexes

To set up search indexes for EP, you must use the Microsoft Dynamics AX data crawler setup. The following two procedures describe how to set up the data crawler manually.

Note   The resulting search index is company account specific. This means that the index of the tables and fields is available only within the company account where the index was created. If two Web sites are running on different company accounts, tables must be indexed for both Web sites. For each company account, a data crawler must be started to perform the index.

Select the tables and fields to include in the search index

138. From a Microsoft Dynamics AX client, click Basic > Setup > Data Crawler > Table setup.

139. Add a new table from the list of tables. 

140. Select a table in the list, and then click the Text index tab.

141. To enable text index, select the Enable text index check box. 

142. Select the fields to be indexed from the Text index pane, and then click the less-than (<) button to add the fields to the Other fields pane. 

143. Close the form to save changes.

Start the data crawler to create the search index

144. From a Microsoft Dynamics AX client, click Basic > Setup > Data Crawler.
145. Select a company account. 

The Overview tab provides the status for the data crawlers that have been created for different company accounts.

146. Click the Crawler tab. 

147. If the status is Stopped, select a crawler speed, and then click Start crawler to start the data crawler for the selected company account. 

Enable search for SQL Server and Windows SharePoint Services

In order to make search available to users on your EP site, you must enable full-text indexing for the SQL server that hosts the WSS database for EP. To enable search for Microsoft SQL Server 2000, you must install the full-text search feature for SQL Server 2000 and then enable search in Windows SharePoint Services.

Note   SQL Server 2000 full-text search supports only one language for each database. If you are supporting Windows SharePoint Services Web sites in several languages, and if you want to enable full-text searching in those languages, consider hosting each language on a separate virtual server that has a separate database per language.

Enable search for SQL Server 2000

148. On your computer that is running SQL Server, run the SQL Server 2000 Setup program. 

149. On the setup screen, click SQL Server 2000 Components, and then click Install Database Server.

The SQL Server 2000 Installation Wizard opens.

150. On the Welcome screen, click Next. 

151. On the Computer Name screen, select the computer type, and then click Next. 

152. On the Installation Selection panel, select Upgrade, remove, or add components to an existing instance of SQL Server, and then click Next. 

153. On the Instance Name panel, clear the Default check box, and then in the Instance Name box, select your instance of SQL Server for WSS, and then click Next. 

154. Select Add components to your existing installation, and then click Next. 

155. On the Select Components panel, in the Sub-Components list, select Full-Text Search, and then click Next. 

156. Click Next again to begin the installation. 

157. Click Finish. 

Enable search for Windows SharePoint Services

After you have configured SQL Server 2000 to support full-text searching, you are ready to enable search for Windows SharePoint Services.

158. Open SharePoint Central Administration (Start > All Programs > Administrative Tools > SharePoint Central Administration).

159. Under Component Configuration, click Configure full-text search.

160. In the Search Settings section, select the Enable full-text search and index component check box.

161. Click OK.

Appendix F: About EP roles and user groups

The EP for Microsoft Dynamics AX is a role-based application, which means that the collection of content available to a user on the EP site varies according to the user's job function. 

As an administrator, as soon as you determine which role (or roles) a user has to have on the EP site, the role indicates the set of user groups to which that user has to be assigned in order to access the appropriate content on the EP site. 

Roles and corresponding user groups

The following table introduces the EP roles and lists the predefined user groups that correspond to each role. By default, the user groups listed here are created when you configure the EP. However, you can also create your own roles by creating additional user groups and combinations of user groups. 

	Role Name
	Description
	User Groups

	Employee
	The internal role that is assigned to all employees. It can be extended with other internal roles. The employee role gives access to the functionality that is included in the employee self-service Web application.
	EP_Empl 

EP_Int

	Sales
	An internal role that is assigned in addition to the employee role. The sales representative role gives access to all sales-related functionality, such as Sales order, Customers, and sales-related reports.
	EP_Empl 

EP_Int 

EP_Sales

	Consultant
	An internal role that is assigned in addition to the employee role. The consultant role gives access to the functionality in the projects module, such as hour registration.
	EP_Empl 

EP_Cons 

EP_Int

	Vendor
	An external role that gives access to the Vendor Self Service Web application.
	EP_Vendor 

EP_Ext

	Customer
	An external role that gives access to the Customer Self-Service Web application.
	EP_Cust 

EP_Ext

	Guest
	An external role that gives users access to view the product catalog and sign up to become customers. The guest role allows anonymous Web users to log on to the EP customer site with limited functionality. 
	EP_Cust 

EP_Ext 

(The same user groups as the customer role)

	Administrator
	An internal role that is assigned to the individuals who will be configuring and administering Microsoft Dynamics AX. It is important to restrict the number of Microsoft Dynamics AX users who are members of the Administrator group.
	EP_Admin 

EP_Empl 

EP_int


Note   Users can be assigned to more than one role. In that situation, they must be assigned to the corresponding user groups for both roles. You cannot assign users to both internal and external roles.

Employee role

By default, the functionality that is available to the Employee role is very limited. However, you can add additional functionality to the employee role.

Users who are assigned the Employee role can do the following:  

· Look up contact information about their colleagues.  

· Complete and analyze questionnaires.

· View and delete their alerts, and view and disable their alert rules.

Sales role

Users who are assigned to the Sales role can perform tasks within these areas: 

· Quotation: create, edit, accept, and send (mail/letter)

· Sales order: create, edit, and send (mail/letter)

· Customer: create and edit

· Credit note: create, update, and send (mail/letter)

· Contact person: create, edit, and delete

· Prices: update price and discount

· Product information: send (mail/letter)

· Questionnaire: complete and analyze

· Alerts: View and delete their alerts, and view and disable their alert rules

Users who are assigned to the Sales role can view and create the following reports: 

· Sales by week, month, quarter, and year (current year and the year before, list and graph) 

· Sales by region 

· Sales by customer 

· Price list by customer 

· Sales price list by customer (all customers/by customer) 

· Customer turnover 

· Sales by person 

· Pricelist 

· Sales prices 

· Price/Discount list 

· Top 100 (by revenue and margin) 

· Blanket orders 

· Sales forecast per item (all customers/by customer) 

Consultant role

Users who are assigned to the Consultant role can do the following: 

· Register hours on projects.

· Browse invoices and invoice proposals.

· Browse hour, cost, revenue, item, and on-account transactions.

· View and create reports for total of hours per project.

· View and create reports for hours per journal.

· Complete and analyze questionnaires.

· View and delete their alerts, and view and disable their alert rules.

Vendor role

Users who are assigned to the Vendor role can do the following: 

· Change their address, telephone number, Web address, telex, fax, language, and e-mail. Some fields, such as account number, currency, balance, and balance in currency, are view-only fields. 

· Set up and change contact person (title, name, telephone extension, telephone, mobile phone, pager, e-mail, and personal address information). 

· View purchase orders (header and lines). 

· View items (view-only mode). 

· View journals (purchase order, packing slip, and invoice). 

· Update prices and discounts. 

· View delivery due date. 

· View supply performance. 

· View supply capacity. 

· Complete questionnaires.

Customer role

Users who are assigned to the Customer role can do the following: 

· Browse the product catalog. 

· Add items to the shopping basket. 

· Create orders online. 

· Add items to the shopping basket without ordering, and then return to the shopping module later to finish the order. 

· Complete questionnaires.

Guest role

Users who are assigned to the Guest role can do the following: 

· Browse the product catalog, but they cannot order. 

· Create a registration request to become a customer. 

Administrator role

Users who are assigned to the Administrator role can do the following:

· Manage Web users.

· Control some of the parameters for Users, General, Accounts receivable, Inventory, and Customer Self-Service.

· Control setup parameters, such as Style sheet and Language.

· Refresh the Microsoft Dynamics AX data from within the Web interface.

Important   Restrict the number of Microsoft Dynamics AX users who are members of the Administrators group. If a regular Microsoft Dynamics AX user is made a member of the Administrators group, that user can potentially view reports or data that they should not be allowed to see. Ideally, only those individuals who are configuring and administering Microsoft Dynamics AX should be members of the Administrators group. 
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