ADOMD.NET

ADOMD.NET is a standard .NET data provider that is designed to communicate with multidimensional data sources, such as Microsoft® SQL Server™ 2000 Analysis Services. ADOMD.NET uses XML for Analysis version 1.1 to communicate with multidimensional data sources, using either TCP/IP or HTTP streams to transmit and receive SOAP requests and responses that are compliant with the XML for Analysis specification. Multidimensional data can be retrieved and manipulated by using the ADOMD.NET object model. Using ADOMD.NET, you also can view and manipulate meta data either by retrieving OLE DB-compliant schema rowsets or by using the ADOMD.NET object model.

The ADOMD.NET data provider is represented by the Microsoft.AnalysisServices.AdomdClient namespace.

Topic | Description
ADOMD.NET Overview | Describes the architecture and implementation of ADOMD.NET, including prerequisites and redistribution instructions.
ADOMD.NET Programming | Describes how you can use ADOMD.NET to retrieve data and meta data from multidimensional data sources.
ADOMD.NET Reference | Details the objects contained in the Microsoft.AnalysisServices.AdomdClient namespace.


Using the ADOMD.NET SDK

The ADOMD.NET SDK appears in a window that contains these panes:

  • The Navigation pane is located on the left. It contains the Contents, Index, Search, and Favorites tabs. The topics on the Contents tab are organized hierarchically by task or subject.
  • The Topic pane, located on the right, displays the selected topic or the default topic.
  • The Toolbar pane appears directly below the ADOMD.NET SDK title bar. It contains the navigation and command buttons.

From the Navigation pane you can find information in the ADOMD.NET SDK by navigating through the Contents tab (which contains the table of contents for the SDK topics), typing a keyword from the Index tab, or typing a word or phrase and performing a search from the Search tab.

For more information about these navigation options, see Finding a Topic.

Using the Toolbar Buttons

You can find topics in the ADOMD.NET SDK by using the following navigational buttons on the toolbar:

Toolbar Button | Description
Previous | Displays the previous topic listed in the Contents tab.
Next | Displays the next topic listed in the Contents tab.
Back | Displays the last topic you viewed.
Forward | Displays the next topic in a previously displayed sequence of topics.

Other buttons on the toolbar are shown in the following table.

Note The toolbar in your Help Viewer might not contain all of these navigational buttons.

Toolbar Button | Description
Hide | Hides the Navigation pane. When the Navigation pane is hidden, click Show to show the Navigation pane. If you close the ADOMD.NET SDK with the Navigation pane hidden, the pane is hidden the next time you open the ADOMD.NET SDK.
Locate | Displays the location of a topic in the Navigation pane.
Font | Changes the font size in the Topic pane.
Print | Prints the selected topic, with the option to print all subtopics.
Options | Changes several options for viewing topics, and provides another way to explore the documentation.

Displaying Information in the ADOMD.NET SDK

To display additional information that is related to the current topic in the ADOMD.NET SDK, use the See Also icon.

The See Also icon appears at the top of SDK topics that contain related topics. Click the icon to see the list of related topics.

Navigating the ADOMD.NET SDK

Here are some tips for navigating the ADOMD.NET SDK:

  • Colored, underlined text indicates links to other topics. To link to another topic, including Web pages, click the colored, underlined text.
  • Many topics contain a list of related topics, titled See Also. To jump to a related topic, click the title of the topic you want to view.
  • If you use a particular topic often, you can add it to your Favorites list. For more information, see Finding a Topic.
  • For shortcut menu commands, right-click the Contents tab or the Topic pane. For more information, see Using Accessibility Features in the ADOMD.NET SDK.

Copying and Printing a Help Topic

To copy or print a topic, use these procedures.

To copy a topic

  1. In the Topic pane, right-click the topic you want to copy, and then click Select All.
  2. Right-click again, and then click Copy.
  3. Open the document to which you want to copy the topic.
  4. Position your cursor where you want the information to appear.
  5. On the Edit menu, click Paste.

    Note If you want to copy only part of a topic, select the text you want to copy, right-click, and then click Copy.

To print a topic

There are several ways to print a topic:

  • Right-click anywhere in the Topic pane, and then click Print.
  • On the toolbar, click the Print button.
  • In the Navigation pane, go to the Contents tab, right-click the topic or book name, and then click Print.

The ADOMD.NET SDK displays two dialog boxes for printing:

  • If you are using the Contents tab in the Navigation pane, and the Navigation pane is the active pane, the ADOMD.NET SDK displays the Print Topics dialog box. If you are using Microsoft Internet Explorer version 5.5, do not click Print the Selected headings and all subtopics, because the subtopics might not print.
  • In all other cases, the ADOMD.NET SDK displays the Print dialog box. If you are using Internet Explorer 5.5 or Internet Explorer 5 and you click Print all linked topics on the Options tab, linked topics may not always print.

Using the Shortcut Menu Commands

The following table shows the shortcut menu commands you can use to display and customize information.

Command | Description
Right-click in the Contents tab, and then click Close All. | Closes all books or folders. This command works only if the Contents tab is displayed.
Right-click in the topic, and then click Print. | Prints the topic.

These commands can be accessed using the keyboard. Press SHIFT+F10 to display the shortcut menu, and then click the appropriate shortcut keys. You can also enable MouseKeys, a feature that enables you to move the mouse cursor using the numeric keypad. Use a MouseKey combination to display the shortcut menu, and then click the appropriate shortcut keys. For more information on MouseKeys, see the Microsoft Windows documentation.


Documentation Conventions

The following conventions are used in the ADOMD.NET SDK to distinguish elements of text.

Convention | Used for
UPPERCASE | MDX statement and clause names
Initial Capitals | Paths and file names
Bold | Cell properties, column names, command prompt utilities, commands, database names, dialog box options, formats, functions, intrinsic member properties, menus, programming elements, stored procedures, table names, and text that must be typed exactly as shown
Italic | User-supplied variables, parameters
Monospace
 Code samples, syntax examples, display text, error messages, and examples

Changing the Way Topics Appear

The size and position of the ADOMD.NET SDK window and the Navigation and Topic panes can be changed easily:

  • To resize the Navigation or Topic pane, point to the split bar between the two panes. When the pointer changes to a double-headed arrow, drag the split bar right or left.
  • To shrink or enlarge the ADOMD.NET SDK window, point to any corner of the window. When the pointer changes to a double-headed arrow, drag the corner.
  • To change the height or width of the ADOMD.NET SDK window, point to the top, bottom, left, or right edge of the ADOMD.NET SDK window. When the pointer changes to a double-headed arrow, drag the edge.
  • To reposition the ADOMD.NET SDK window on your screen, click the title bar and drag the window to a new position.

    Note When you open the ADOMD.NET SDK, it appears with the size and position settings that were last specified.


Finding a Topic

To find a topic in the ADOMD.NET SDK, use the tabs in the Navigation pane:

  • Click the Contents tab to browse the table of contents, which is an expandable, hierarchical list of topics.
  • Click the Index tab to see a list of index entries, and then type a term that you want to search for or scroll through the list of terms. Topics are often indexed under more than one entry.
  • Click the Search tab and then type the term that you want, to locate every occurrence of a word or phrase that may be contained in the ADOMD.NET SDK. For more information, see Using the Search Tab.

    Note The results of a search are displayed in three columns: Title, Location, and Rank. The ranking of topics under the Rank column is not determined by any standard (for example, alphabetical order or greatest number of hits). Do not use the ranking to determine which topics to view.

  • Click the navigation buttons on the toolbar. For more information, see Using the ADOMD.NET SDK.

Creating and Using the Favorites List

The Favorites list provides a convenient way to access topics that you frequently refer to.

  • To start creating a list of favorite topics, locate a topic you want to make a favorite topic, click the Favorites tab, and then click Add.
  • To return to a favorite topic, click the Favorites tab, select the topic, and then click Display.
  • If you want to rename a topic, on the Favorites tab select the topic, and then type a new name in the Current topic box.
  • To remove a favorite topic, on the Favorites tab select the topic, and then click Remove.

Accessing a Topic Using a URL

You can use a URL to direct someone to a topic in the ADOMD.NET SDK.

To direct someone to a topic in the ADOMD.NET SDK

  1. On the page to which you want to direct someone, in the Navigation pane right-click the topic, and then click Jump to URL.
  2. Copy the URL that appears in the Current URL box, and then paste it in an e-mail message or other document.
  3. Instruct the person receiving the URL on how to paste the URL in the Jump to this URL dialog box.

The URL can also be pasted in the Address box in Microsoft Internet Explorer. However, this method does not bring up the ADOMD.NET SDK; only the topic that you selected is displayed.


Using the Search Tab

The ADOMD.NET SDK includes a Search tab that allows you to search through every word in the ADOMD.NET SDK to find a match. For example, if you perform a full-text search on the word "index", every topic that contains the word "index" is listed. You can precisely define a search by using wildcard expressions, nested expressions, and Boolean operators. You can also request similar word matches, search only the topic titles, or search the results of an earlier search.

All instances of search terms that are found in the topic files can appear highlighted. To specify highlighting, on the Search tab click the Options button, and then click Search Highlight On. If you are viewing a long topic, only the first 500 instances of a search word or phrase are highlighted. This feature is available with Microsoft Internet Explorer 4.0 or later.

Searching for Topics

A search query consists of the word or phrase you want to find. You can use wildcard expressions, nested expressions, Boolean operators, similar word matches, a previous results list, or topic titles to further define your search query.

The basic rules for formulating queries are:

  • Search queries are not case-sensitive, so you can type your query in uppercase or lowercase characters.
  • You can search for any combination of letters (a-z) and numbers (0-9).
  • Punctuation marks such as the period, colon, semicolon, comma, and hyphen are ignored during a search.
  • Group the elements of your query using double quotation marks or parentheses to set apart each element. You cannot search for quotation marks.

If you are searching for a file name with an extension, you should group the entire string in double quotation marks ("filename.ext"). Otherwise, the period breaks the file name into two separate terms. The default operation between terms is AND, which is the logical equivalent to "filename AND ext".

To find information with full-text search

  1. Click the Search tab, and then type the word or phrase you want to find.
  2. Click the arrow button to add Boolean operators to your search.
  3. Click List Topics, select the topic you want, and then click Display.
  4. To sort the topic list, click the Title, Location, or Rank column heading.

    Note The ranking of topics under the Rank column is not determined by any standard (for example, alphabetical order or most hits). Do not use the ranking to determine which topics to view.

Searching for Words or Phrases

You can use wildcard expressions when searching for words or phrases. Wildcard expressions allow you to search for one or more characters using a question mark or asterisk. The table describes the results of these different kinds of searches.

Search for | Example | Results
A single word | select | Topics that contain the word "select". (The search will also find grammatical variations, such as "selector" and "selection".)
A phrase | "new operator" or new operator | Topics that contain the literal phrase "new operator" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying "new AND operator", which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | esc* or 80?86 | Topics that contain the terms "ESC", "escape", "escalation", and so on. The asterisk cannot be the only character in the term. Topics that contain the terms "80186", "80286", "80386", and so on. The question mark cannot be the only character in the term.

Select the Match similar words check box at the bottom of the Search tab to include minor grammatical variations for the phrase you search.

Defining Search Terms

The AND, OR, NOT, and NEAR operators enable you to precisely define your search by creating a relationship between search terms. The following table shows how you can use each of these operators. If an operator is not specified, AND is used. For example, the following query:

spacing border printing

is equivalent to "spacing AND border AND printing".

Search for | Example | Results
Both terms in the same topic. | dib AND palette | Topics containing both the words "dib" and "palette".
Either term in a topic. | raster OR vector | Topics containing either the word "raster" or the word "vector" or both.
The first term without the second term. | ole NOT dde | Topics containing the word "OLE", but not the word "DDE".
Both terms in the same topic, close together. | user NEAR kernel | Topics containing the word "user" within eight words of the word "kernel".

The characters |, &, and ! do not work as Boolean operators (you must use OR, AND, and NOT).

Note If you have a search phrase that begins with one of the operators AND, OR, NOT, or NEAR, you must enclose the phrase with double quotation marks; otherwise, these words are interpreted as operators, and the search cannot be performed. For example, a search for the phrase NOT FOR REPLICATION returns an error message, and a search for the phrase "NOT FOR REPLICATION" succeeds.

Using Nested Expressions When Searching

Nested expressions allow you to create complex search queries. For example, "control AND ((active OR dde) NEAR window)" finds topics containing the word "control" along with the words "active" and "window" close together, and topics containing "control" along with the words "dde" and "window" close together.

The basic rules for searching Help topics using nested expressions are:

  • Use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example: "Control NOT active OR dde" finds topics containing the word "control" without the word "active", or topics containing the word "dde". On the other hand, "control NOT (active OR dde)" finds topics containing the word "control" without either of the words "active" or "dde".
  • You cannot nest expressions more than five levels deep.

To search only the last group of topics from a previous search

You can search through a long results list from a previous search by using this option.

  1. On the Search tab, select the Search previous results check box.
  2. Click List Topics, select the topic you want, and then click Display.

If you want to search through all of the files in the ADOMD.NET SDK, the Search previous results check box must be cleared. If you have previously used this feature, when you click the Search tab, this check box remains selected.

To find words similar to your search term

You can include minor grammatical variations for the phrase you search. For example, a search on the word "add" finds "add", "adds", and "added".

  1. Click the Search tab, type the word or phrase you want to find, and then select the Match similar words check box.
  2. Click List Topics, select the topic you want, and then click Display.

This feature locates only variations of the word with common suffixes. For example, a search on the word "add" finds "added", but it does not find "additive".

To search for words in the titles of ADOMD.NET SDK topics

  1. Click the Search tab, type the word or phrase you want to find, and then select the Search titles only check box.
  2. Click List Topics, select the topic you want, and then click Display.


ADOMD.NET SDK

Using Accessibility Features in the ADOMD.NET SDK

The following topics describe the accessibility features that can be used for navigating the ADOMD.NET SDK.

For more information about accessibility features and services, see the Accessibility page at the Microsoft Accessibility Web site.

Changing the Appearance of the Text

The formatting, font, and color of the text in ADOMD.NET SDK can be changed.

To change formatting or styles for accessibility

  1. On the Options menu, click Internet Options, and then click Accessibility.
  2. In the Accessibility dialog box, select the options you want, and then click OK.

These changes do not apply to the Navigation pane or toolbar of ADOMD.NET SDK. This procedure also changes your accessibility settings for Microsoft Internet Explorer.

To change the font size of a topic

  • On the Options menu, click Internet Options, and then click Fonts.

These changes do not apply to the Navigation pane or toolbar of the ADOMD.NET SDK. This procedure also changes your font settings for Internet Explorer.

To change colors in the Topic pane of ADOMD.NET SDK

  1. In Microsoft Internet Explorer, on the Tools menu, click Internet Options.
  2. On the General tab, click Colors.
  3. In the Colors dialog box, select the options you want, and then click OK.
  4. To apply the new color settings, in the Internet Options dialog box, click OK.

These changes do not apply to the Navigation pane or toolbar of the ADOMD.NET SDK. This procedure also changes your color settings for Internet Explorer.

Using Keyboard Shortcuts

The following tables show the keyboard shortcuts that can be used for navigating the ADOMD.NET SDK.

ADOMD.NET SDK

To | Press
Close the ADOMD.NET SDK. | ALT+F4
Switch between the ADOMD.NET SDK window and other open windows. | ALT+TAB
Display the Options menu. | ALT+O
Change Internet Explorer settings. The Internet Options dialog box contains accessibility settings. To change these settings, click the General tab, and then click Accessibility. | ALT+O, and then press I
Hide or show the Navigation pane. | ALT+O, and then press T
Print a topic. | ALT+O, and then press P
Move back to the previous topic. | ALT+LEFT ARROW, or ALT+O, and then press B
Move forward to the next topic (provided you have just previously viewed it). | ALT+RIGHT ARROW, or ALT+O, and then press F
Turn on or off search highlighting. | ALT+O, and then press O
Switch between the Navigation pane and the Topic pane. | F6
Scroll through the table of contents in the Contents tab, displaying each topic as you scroll. | ALT+UP ARROW, or ALT+DOWN ARROW
Scroll through a topic. | UP ARROW and DOWN ARROW, or PAGE UP and PAGE DOWN
Scroll through all the links in a topic or through all the options on a tab in the Navigation pane. | TAB
Display the Documentation Feedback form. | SHIFT+CTRL+F
Display the See Also topics for a particular topic. | SHIFT+CTRL+S

Contents Tab

To | Press
Display the table of contents in the Contents tab. | ALT+C
Open and close a book or folder. | Numeric keypad PLUS SIGN and MINUS SIGN, or LEFT ARROW and RIGHT ARROW
Select a topic. | DOWN ARROW and UP ARROW
Display the selected topic. | ENTER

Index Tab

To | Press
Display the Index tab. | ALT+N
Type a keyword to search for. | ALT+W, and then type the word
Select a keyword in the list. | UP ARROW and DOWN ARROW
Display the associated topic. | ALT+D

Search Tab

To | Press
Display the Search tab. | ALT+S
Type a keyword to search for. | ALT+W, and then type the word
Start a search. | ALT+L
Select a topic in the results list. | ALT+T, and then UP ARROW and DOWN ARROW
Display the selected topic. | ALT+D
Search for a word or phrase in a topic. | CTRL+F
Search for a keyword in the result list of a prior search. | ALT+U
Search for words similar to the keyword. For example, to find words such as "running" and "runs" for the keyword "run." | ALT+M
Search only through topic titles. | ALT+R

Favorites Tab

To | Press
Display the Favorites tab. | ALT+I
Add the currently displayed topic to the Favorites list. | ALT+A
Select a topic in the Favorites list. | ALT+P, and then UP ARROW and DOWN ARROW
Display the selected topic. | ALT+D
Remove the selected topic from the list. | ALT+R


Accessibility for People with Disabilities

Microsoft is committed to making its products and services easier for everyone to use. This topic provides information about the following features, products, and services that make Microsoft Windows® 2000, Windows XP, and the ADOMD.NET SDK more accessible for people with disabilities:

  • Features and hints for customizing Windows 2000 or Windows XP
  • Microsoft services for people who are deaf or hard-of-hearing
  • Microsoft software documentation online, or on audiocassette, floppy disk, or CD
  • Third-party utilities that enhance accessibility
  • Other products and services for people with disabilities

    Note The information in this section applies only to users who license Microsoft products in the United States. If you obtained this product outside the United States, your package contains a subsidiary information card listing Microsoft support services telephone numbers and addresses. You can contact your subsidiary to find out whether the types of products and services described in this section are available in your area.

Customizing Windows

There are many ways you can customize Windows operating systems to make your computer more accessible.

Accessibility features have been built into Windows since the introduction of Windows 95. These features are useful for individuals who have difficulty typing or using a mouse, have moderately impaired vision, or who are deaf or hard-of-hearing. The features can be installed during setup, or you can add them later from your Windows installation disks.

For information about installing and using these features, look up "accessibility" in the Windows Help Index.

You also can use Control Panel and other built-in features to adjust the appearance and behavior of Windows to suit varying vision and motor abilities. These include adjusting colors and sizes, sound volume, and the behavior of the mouse and keyboard.

Dvorak keyboard layouts make the most frequently typed characters on a keyboard more accessible if you have difficulty using the standard QWERTY layout. There are three Dvorak layouts: one if you are a two-handed user, one if you type with your left hand only, and one if you type with your right hand only. You do not need to purchase any special equipment to use these features.

The specific features available, and whether they are built-in or must be obtained separately, depend on which operating system you are using.

Microsoft Services for People Who Are Deaf or Hard-of-Hearing

If you are deaf or hard-of-hearing, complete access to Microsoft product and customer services is available through a text telephone (TTY/TDD) service.

Customer Service

You can contact the Microsoft Sales Information Center on a text telephone by dialing (800) 892-5234 between 6:30 A.M. and 5:30 P.M. Pacific time.

Technical Assistance

For technical assistance in the United States, you can contact Microsoft Technical Support on a text telephone at (425) 635-4948 between 6:00 A.M. and 6:00 P.M. Pacific time, Monday through Friday, excluding holidays. In Canada, dial (905) 568-9641 between 8:00 A.M. and 8:00 P.M. eastern time, Monday through Friday, excluding holidays. Microsoft support services are subject to the prices, terms, and conditions in place at the time the service is used.

Microsoft Documentation in Alternative Formats

In addition to the standard forms of documentation, many Microsoft products are available in other formats to make them more accessible.

If you have difficulty reading or handling printed documentation, you can obtain many Microsoft publications from Recording for the Blind & Dyslexic, Inc. RFB&D distributes these documents to registered, eligible members of their distribution service, either on audio cassettes or on floppy disks. The RFB&D collection contains more than 80,000 titles, including Microsoft product documentation and books from Microsoft Press®. You can download many of these books from the Microsoft Accessibility page at the Microsoft Accessibility Web site.

For more information, contact Recording for the Blind & Dyslexic at the following address or phone numbers:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540 		Phone:
Fax:
Web: 		(609) 452-0606
(609) 987-8116
www.rfbd.org/

Utilities to Enhance Accessibility

A wide variety of hardware and software products are available to make personal computers easier to use for people with disabilities. Among the different types of products available for the Windows operating systems are:

  • Programs that enlarge or alter the color of information on the screen for people with visual impairments
  • Programs that describe information on the screen in Braille or synthesized speech for people who are blind or have difficulty reading
  • Hardware and software utilities that modify the behavior of the mouse and keyboard
  • Programs that enable people to "type" by using a mouse or their voice
  • Word or phrase prediction software that allow users to type more quickly and with fewer keystrokes
  • Alternative input devices, such as single switch or puff-and-sip devices, for people who cannot use a mouse or a keyboard

Getting More Accessibility Information

In addition to the features and resources already described in this section, other products, services, and resources for people with disabilities are available from Microsoft and other organizations.

Microsoft

Microsoft provides a catalog of accessibility aids that can be used with the Windows operating system. You can obtain this catalog from our Web site or by phone:

Microsoft Sales Information Center
One Microsoft Way
Redmond, WA 98052-6393 		Web:
Voice telephone:
Text telephone: 		Microsoft Accessibility Web site
(800) 426-9400
(800) 892-5234

Trace R&D Center

The Trace R&D Center at the University of Wisconsin-Madison publishes a database of more than 18,000 products and other information for people with disabilities. The database is available on their site on the World Wide Web. The Trace R&D Center also publishes a book, titled Trace ResourceBook, which provides descriptions and photographs of about 2,000 products.

To obtain these materials, contact:

Trace R&D Center University of Wisconsin-Madison
5901 Research Park Boulevard
Madison, WI 53719-1252 		Web:
Fax: 		www.trace.wisc.edu/
(608) 262-8848


Additional Resources

This table provides Internet resources for information about Microsoft SQL Server and related products and technologies.

Resource | Address
Microsoft Support Services | support.microsoft.com/directory
Microsoft newsgroups | news://news.microsoft.com/
Microsoft Windows Hardware Compatibility List | www.microsoft.com/hcl
Microsoft MSDN® | msdn.microsoft.com
Professional Association for SQL Server | www.sqlpass.org/
Microsoft SQL Server Developer Center | msdn.microsoft.com/sql/
SQL Server Magazine | www.sqlmag.com/
Microsoft SQL Server Support | support.microsoft.com/support/sql
TechNet site | www.microsoft.com/technet/
Microsoft SQL Server | www.microsoft.com/sql


ADOMD.NET SDK Copyright and Disclaimer

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1988-2004 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, Active Directory, MSDN, SQL Server, Visual Basic, Visual C++, Visual C#, Visual Studio, and Win32 are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


ADOMD.NET Overview

ADOMD.NET provides client access to multidimensional data sources, such as Microsoft® SQL Server™ 2000 Analysis Services. Client applications can use ADOMD.NET to connect to multidimensional data sources for retrieving and manipulating data and metadata.

A standard .NET data provider, ADOMD.NET is used with other providers that support the XML for Analysis version 1.1 specification to communicate with data sources, using either TCP/IP or HTTP streams to transmit and receive SOAP requests and responses that are compliant with the XML for Analysis specification. Data can then be retrieved in a multidimensional format and examined using the ADOMD.NET object model. Using ADOMD.NET, you also can view and manipulate metadata in two ways: by retrieving OLE DB-compliant schema rowsets or by using the ADOMD.NET object model.


Redistributing ADOMD.NET

When you write applications that use ADOMD.NET, you must redistribute ADOMD.NET along with your application. To redistribute ADOMD.NET with your application, include the ADOMD.NET setup.exe installation file in your setup program, and have that setup file launch from your setup program.

The files will then be installed in C:\Program Files\Microsoft.NET\ADOMD\1.0\.

Note To view restrictions regarding the distribution of ADOMD.NET, refer to the End-User License Agreement (EULA) that ships with the ADOMD.NET SDK.


ADOMD.NET Object Architecture

The ADOMD.NET data provider is a standard .NET data provider, and can be used to communicate with multidimensional data sources. The following diagram illustrates the ADOMD.NET object hierarchy:

ADOMD.NET Object Model

Interaction with the ADOMD.NET object hierarchy typically starts with one or more of the objects in the topmost layer:

  • The AdomdConnection represents both a connection to a multidimensional data source and the multidimensional data source metadata. For example, you can connect to an Microsoft SQL Server 2000 Analysis Services local cube (.cub) file, and then examine the Cubes property to obtain metadata about the cubes present on the multidimensional data source. This object also represents the implementation of the IDbConnection interface, an interface that is required by all .NET data providers.
  • The AdomdCommand represents a Multidimensional Expressions (MDX) statement or query. Once a connection is established to a multidimensional data source, you use AdomdCommand objects to execute MDX statements and to return results in the form of CellSet or AdomdDataReader objects.
  • The AdomdDataReader is a fast, efficient way of retrieving multidimensional data from the Execute or ExecuteReader method of an AdomdCommand object. This object implements the IDbDataAdapter interface from the System.Data namespace of the .NET Framework class library.
  • The CellSet represents the result set of an MDX statement or query retrieved from the Execute or ExecuteCellSet method of an AdomdCommand. Once an AdomdCommand has returned a CellSet, you can then examine the multidimensional data contained by the CellSet. CellSet objects are used whenever multidimensional data must be cached and manipulated.

All other objects in the ADOMD.NET object hierarchy support these four objects by either organizing data for the topmost objects or supplying additional metadata about them. The following list describes some of the objects with which a client application frequently interacts:

  • The OlapInfo represents the metadata for a cube: information about the axes, cells, and cubes referenced by the cellset. It can be referenced from the CellSet to retrieve information about the cubes referenced by the cellset.
  • The CubeDef also represents the metadata for a cube. It can be referenced from the AdomdConnection to retrieve information about cubes stored on a multidimensional data source. The CubeDef provides access to information about the dimensions, measures, and named sets defined for a cube, as well as to the properties of the cube itself.

    Important Although the CubeDef can also be referenced from the CellSet, this functionality exists solely for backward compatibility. Use the OlapInfo to retrieve information about cubes referenced by a CellSet.

  • The AdomdDataAdapter implements the IDbDataAdapter interface from the System.Data namespace of the .NET Framework class library, and provides read-only support for existing .NET client applications.


Migrating from ADO MD to ADOMD.NET

The ADOMD.NET library is similar to the ActiveX Data Objects Multidimensional (ADO MD) library, an extension of the ActiveX Data Objects (ADO) library that is used to access multidimensional data in Component Object Model (COM) based client applications. Migrating existing client applications from ADO MD to ADOMD.NET is easy, but there are a few important differences regarding migration:

  • Unlike ADO MD, ADOMD.NET does not rely on ADO to provide connectivity. Instead of requiring references to both Adodb.dll and Adomd.dll, a single reference to Microsoft.AnalysisServices.AdomdClient.dll is all that is necessary to provide both data connectivity and data access to client applications. In ADOMD.NET, the AdomdConnection class provides connectivity support, as well as access to metadata.
  • The ADO MD Catalog class is no longer supported. Metadata for multidimensional objects from the data source can be retrieved using the Cubes property of the AdomdConnection.
  • Unlike ADO MD, the CellSet class in ADOMD.NET is no longer used to execute queries. Instead, the AdomdCommand class is used to execute queries and return ADOMD.NET CellSet objects.
  • While the ADO MD Position class is supported for backward compatibility, the metadata used to display a cellset returned in a CellSet can be more flexibly accessed in ADOMD.NET by using the Set and Tuple objects.
  • Several new classes have been added in ADOMD.NET to support the .NET data provider model, provide better error handling, and better encapsulate multidimensional data and metadata. In particular, use the OlapInfo, AxesInfo, CellsInfo, and CubesInfo classes to retrieve metadata about a cellset, instead of the CubeDef class. The CubeDef class should still be used, however, to retrieve cube metadata from a multidimensional data source.

Migration Example

The following code example, drawn from ADO MD 2.8 documentation, is written in Microsoft Visual Basic® 6.0 and uses ADO MD to demonstrate how to connect to and query a Microsoft SQL Server 2000 Analysis Services data source:

Private Sub cmdCellSettoDebugWindow_Click()
Dim cat As New ADOMD.Catalog
Dim cst As New ADOMD.Cellset
Dim i As Integer
Dim j As Integer
Dim k As Integer
Dim strServer As String
Dim strSource As String
Dim strColumnHeader As String
Dim strRowText As String

On Error GoTo Error_cmdCellSettoDebugWindow_Click
Screen.MousePointer = vbHourglass
'*-----------------------------------------------------------------------
'* Set server to local host.
'*-----------------------------------------------------------------------
    strServer = "LOCALHOST"

'*-----------------------------------------------------------------------
'* Set MDX query string source.
'*-----------------------------------------------------------------------
    strSource = strSource & "SELECT "
    strSource = strSource & "{[Measures].members} ON COLUMNS,"
    strSource = strSource & _
        "NON EMPTY [Store].[Store City].members ON ROWS"
    strSource = strSource & " FROM Sales"

'*-----------------------------------------------------------------------
'* Set active connection.
'*-----------------------------------------------------------------------
        cat.ActiveConnection = "Data Source=" & strServer & _
            ";Provider=msolap;"

'*-----------------------------------------------------------------------
'* Set cellset source to MDX query string.
'*-----------------------------------------------------------------------
        cst.Source = strSource

'*-----------------------------------------------------------------------
'* Set cellset active connection to current connection
'*-----------------------------------------------------------------------
    Set cst.ActiveConnection = cat.ActiveConnection

'*-----------------------------------------------------------------------
'* Open cellset.
'*-----------------------------------------------------------------------
    cst.Open

'*-----------------------------------------------------------------------
'* Allow space for row header text.
'*-----------------------------------------------------------------------
strColumnHeader = vbTab & vbTab & vbTab & vbTab & vbTab & vbTab

'*-----------------------------------------------------------------------
'* Loop through column headers.
'*-----------------------------------------------------------------------
       For i = 0 To cst.Axes(0).Positions.Count - 1
            strColumnHeader = strColumnHeader & _
                cst.Axes(0).Positions(i).Members(0).Caption & vbTab & _
                    vbTab & vbTab & vbTab
       Next
       Debug.Print vbTab & strColumnHeader & vbCrLf

'*-----------------------------------------------------------------------
'* Loop through row headers and provide data for each row.
'*-----------------------------------------------------------------------
        strRowText = ""
        For j = 0 To cst.Axes(1).Positions.Count - 1
            strRowText = strRowText & _
                cst.Axes(1).Positions(j).Members(0).Caption & vbTab & _
                    vbTab & vbTab & vbTab
            For k = 0 To cst.Axes(0).Positions.Count - 1
                strRowText = strRowText & cst(k, j).FormattedValue & _
                    vbTab & vbTab & vbTab & vbTab
            Next
            Debug.Print strRowText & vbCrLf
            strRowText = ""
        Next

    Screen.MousePointer = vbDefault
Exit Sub

Error_cmdCellSettoDebugWindow_Click:
   Beep
   Screen.MousePointer = vbDefault
   MsgBox "The following error has occurred:" & vbCrLf & _
      Err.Description, vbCritical, " Error!"
   Exit Sub
End Sub

The following example, written in Visual Basic.NET and using ADOMD.NET, demonstrates how to perform the same actions as the previous Visual Basic 6.0 example:

Private Sub DisplayCellSetInOutputWindow()
    Dim conn As AdomdConnection
    Dim cmd As AdomdCommand
    Dim cst As CellSet
    Dim i As Integer
    Dim j As Integer
    Dim k As Integer
    Dim strServer As String = "LOCALHOST"
    Dim strSource As String = "SELECT [Measures].members ON COLUMNS, " & _
        "NON EMPTY [Store].[Store City].members ON ROWS FROM SALES"
    Dim strOutput As New System.IO.StringWriter

    '*-----------------------------------------------------------------------
    '* Open connection.
    '*-----------------------------------------------------------------------
    Try
        ' Create a new AdomdConnection object, providing the connection
        ' string.
        conn = New AdomdConnection("Data Source=" & strServer & _
        ";Provider=msolap;")
        ' Open the connection.
        conn.Open()
    Catch ex As Exception
        Throw New ApplicationException( _
            "An error occurred while connecting.")
    End Try

    '*-----------------------------------------------------------------------
    '* Open cellset.
    '*-----------------------------------------------------------------------
    Try
        ' Create a new AdomdCommand object, providing the MDX query string.
        cmd = New AdomdCommand(strSource, conn)
        ' Run the command and return a CellSet object.
        cst = cmd.ExecuteCellSet()
    Catch ex As Exception
        Throw New ApplicationException( _
            "An error occurred while opening the cellset.")
    End Try

    '*-----------------------------------------------------------------------
    '* Concatenate output.
    '*-----------------------------------------------------------------------

    ' Include spacing to account for row headers.
    strOutput.Write(vbTab, 6)

    ' Iterate through the first axis of the CellSet object and
    ' retrieve column headers.
    For i = 0 To cst.Axes(0).Set.Tuples.Count - 1
        strOutput.Write(cst.Axes(0).Set.Tuples(i).Members(0).Caption)
        strOutput.Write(vbTab, 4)
    Next
    strOutput.WriteLine()

    ' Iterate through the second axis of the CellSet object and
    ' retrieve row headers and cell data.
    For j = 0 To cst.Axes(1).Set.Tuples.Count - 1
        ' Append the row header.
        strOutput.Write(cst.Axes(1).Set.Tuples(j).Members(0).Caption)
        strOutput.Write(vbTab, 4)

        ' Append the cell data for that row.
        For k = 0 To cst.Axes(0).Set.Tuples.Count - 1
            strOutput.Write(cst.Cells(k, j).FormattedValue)
            strOutput.Write(vbTab, 4)
        Next
        strOutput.WriteLine()
    Next

    ' Display the output.
    Debug.WriteLine(strOutput.ToString)

    '*-----------------------------------------------------------------------
    '* Release resources.
    '*-----------------------------------------------------------------------
    Try
        conn.Close()
    Catch ex As Exception
        ' Ignore errors.
    Finally
        cst = Nothing
        cmd = Nothing
        conn = Nothing
    End Try
End Sub


Fundamentals of Multidimensional Data Access

Multidimensional data sources are different from other types of data sources in that they use multiple, hierarchically structured dimensions to organize information. The following diagram illustrates a traditional relational database, used to store order information.

A traditional relational database architecture

Each table in the relational database represents two-dimensional data. At the intersection of each row and column is a single element of data, called a field. The specific columns to be viewed in an SQL query are specified with a SELECT statement, and the rows to be retrieved are limited by a WHERE clause. To provide a form of hierarchical structure, relationships are constructed between tables.

Multidimensional data, on the other hand, can be represented by structures with more than two dimensions. These structures, called cubes, have multiple dimensions. At the intersection of dimensions in a cube, there may be more than one element of data, called a measure. The following diagram illustrates a cube that employs three dimensions, Route, Service and Time; and two measures, Packages and Last. Each dimension is broken down into different levels, each of which is broken down further into members. For example, the Source dimension supplies the Eastern Hemisphere level, which is broken down into four members, Africa, Asia, Australia, and Europe.

A three-dimensional cube with Route, Service and Time dimensions

As you can see, the querying of even simple data out of a multidimensional data source can be a complex task. A cube can have more than three dimensions, for example, or it may only have one dimension.

Accessing Data with Multidimensional Expressions

Because most data stores contain two-dimensional entities, most languages used for data definition and manipulation are designed to retrieve data in two dimensions: a column dimension and a row dimension. Using such a language on a multidimensional data store is, at best, complex and frustrating.

MDX, an acronym for Multidimensional Expressions, is a syntax that supports the definition and manipulation of multidimensional objects and data. MDX is similar in many ways to the Structured Query Language (SQL) syntax, but is not an extension of the SQL language; in fact, some of the functionality that is supplied by MDX can be supplied by SQL, although not as efficiently or intuitively.

As with an SQL query, each MDX query requires a data request (the SELECT clause), a starting point (the FROM clause), and a filter (the WHERE clause). These and other keywords provide the tools used to extract specific portions of data from a cube for analysis. MDX also supplies a robust set of functions for the manipulation of retrieved data, as well as the ability to extend MDX with user-defined functions.

MDX, like SQL, provides data definition language (DDL) syntax for managing data structures. There are MDX commands for creating (and deleting) cubes, dimensions, measures, and their subordinate objects.

The concepts of cubes, dimensions, levels, members, and measures are important to the understanding of MDX syntax. Further reading on these topics is recommended if you are new to online analytical processing (OLAP) databases.For more information about MDX, see SQL Server 2000 Books Online.

Cells, Tuples, and Sets

As SQL returns a subset of two-dimensional data from tables, MDX returns a subset of multidimensional data from cubes called a cellset. A cellset contains one or more cells from a multidimensional data source. Rather than describing the myriad ways a cellset can be constructed, you should first familiarize yourself with the multidimensional data elements used to construct a cellset.

A cube consists of a collection of cells, organized along dimensions included in the cube. Each member in a dimension is treated like a point on an axis. A cell is the intersection of one member from each dimension included in the cube. The cell contains a value and can also have other properties associated with it used to determine its appearance, data type, format, and so on.

Because a cell represents an intersection of one member from each dimension, we have an easy way to refer to a single cell — we can use an expression, called a tuple, to uniquely identify the cell. A tuple consists of an ordered collection of one member from each dimension, either explicitly or implicitly declared. In other words, a tuple is a multidimensional coordinate.

A tuple cannot contain more than one member from any single dimension, for the same reason that a coordinate cannot contain two points from the same axis. A tuple differs from a coordinate, however, because of the ability to use default members. If a tuple does not explicitly include a member from each dimension, the default member for each dimension not explicitly included is implicitly referenced by the tuple.

For example, a cube with one measure, named SalesQuantity, and two dimensions that use the (All) member as their default member, named Product and Customer, resolve all of the following examples to the same cell location:

([Measures].[SalesQuantity])
([Measures].[SalesQuantity], [Product].[All Products])
([Measures].[SalesQuantity], [Product].[All Products], [Customer].[All Customers])

An ordered collection of tuples is referred to as a set. In an MDX query, axis and slicer dimensions are composed of such sets of tuples. The following example is a description of a set of tuples in the SalesQuantity cube described in the last example:

{[Product].[Tools], [Product].[Plants], [Customer].[North America].Members}

Sets can be constructed from other sets, as well, using functions like the MDX Crossjoin function. In addition, it is possible to create a named set. A named set is a set with an alias, used to make your MDX query easier to understand and, if it is particularly complex, easier to process.

Axis and Slicer Dimensions

In SQL, it is usually necessary to restrict the amount of data returned from a query on a table. For example, you may want to see only two fields of a table with forty fields, and you want to see them only if a third field meets a specific criteria. You can accomplish this by specifying columns in the SELECT statement, using a WHERE statement to restrict the rows that are returned based on specific criteria.

In MDX, those concepts also apply. A SELECT statement is used to select the dimensions and members to be returned, referred to as axis dimensions. The WHERE statement is used to restrict the returned data to specific dimension and member criteria, referred to as a slicer dimension. An axis dimension is expected to return data for multiple members, while a slicer dimension is expected to return data for a single member.

The terms "axis dimension" and "slicer dimension" are used to differentiate the dimensions of the cells in the source cube of the query, indicated in the FROM clause, from the dimensions of the cells in the result cube, which can be composed of multiple cube dimensions.

Calculated Members

Calculated members are members that are based not on data, but on evaluated expressions in MDX. They are returned in the same fashion as a normal member. MDX supplies a robust set of functions that can be used to create calculated members, giving you extensive flexibility in the manipulation of multidimensional data.

User-Defined Functions

MDX provides extensibility in the form of user-defined functions that can be accessed by queries or statements. You create and register your own functions that operate on multidimensional data as well as accept arguments and return values in the MDX syntax.


Comparison of SQL and MDX

 ADOMD.NET SDK

Comparison of SQL and MDX Syntax

The Multidimensional Expressions (MDX) syntax is similar to the syntax of Structured Query Language (SQL). In many ways, the functionality supplied by MDX is also similar to that of SQL; with effort, you can even duplicate some of the functionality provided by MDX in SQL.

However, there are some striking differences between SQL and MDX. Here we provide a guide to these conceptual differences between SQL and MDX, from the perspective of an SQL developer.

Dimensions

The principal difference between SQL and MDX is the ability of MDX to reference multiple dimensions. Although it is possible to use SQL exclusively to query cubes in SQL Server 2000, MDX provides commands that are designed specifically to retrieve data as multidimensional data structures with almost any number of dimensions.

SQL refers to only two dimensions when processing queries: columns and rows. Because SQL was designed to handle only two-dimensional tabular data, the terms "column" and "row" have meaning in SQL syntax.

MDX, in comparison, can process one, two, three, or more dimensions in queries. Each dimension is referred to as an axis. The terms "column" and "row" in MDX are used only as aliases for the first two axis dimensions in an MDX query. Other dimensions are also aliased, but the aliases "column" and "row" hold no meaning to MDX. MDX supports such aliases for display purposes; many OLAP tools are incapable of displaying a result set with more than two dimensions. MDX can even process "zero-axis" queries that return only one cell from a cube, determined by a tuple constructed from the default member of each dimension in the cube.

SELECT and WHERE Clauses

In SQL, the SELECT clause is used to define the column layout for a query, and the WHERE clause is used to define the row layout. However, in MDX the SELECT clause can be used to define several axis dimensions, while the WHERE clause is used to restrict multidimensional data to a specific dimension or member.

In SQL, the WHERE clause is used to filter the data returned by a query. In MDX, the WHERE clause is used to provide a slice of the data returned by a query. While the two concepts are similar, they are not equivalent.

The SQL query uses the WHERE clause to contain an arbitrary list of items that should (or should not) be returned in the result set. Although a long list of conditions in the filter can narrow the scope of the data that is retrieved, there is no requirement that the elements in the clause will produce a clear and concise subset of data.

In MDX, however, the concept of a slice means that each member in the WHERE clause identifies a distinct portion of data from a different dimension. Because of the organizational structure of multidimensional data, it is not possible to request a slice for multiple members of the same dimension. Because of this, the WHERE clause in MDX can provide a clear and concise subset of data.

Creating Queries

The process of creating an SQL query is also different from that of creating an MDX query. The creator of an SQL query visualizes and defines the structure of a two-dimensional rowset and writes a query on one or more tables to populate that rowset. In contrast, the creator of an MDX query usually visualizes and defines the structure of a multidimensional dataset and writes a query on a single cube to populate it. This could result in a multidimensional dataset with any number of dimensions; a one-dimensional dataset is possible, for example.

The visualization of an SQL result set is very intuitive; the set is a two-dimensional grid of columns and rows. The visualization of an MDX result set is not necessarily intuitive, however. Because a multidimensional result set can have more than three dimensions, it can be challenging to visualize the structure. To refer to such two-dimensional data in SQL, the name of a column and the unique identification of a row are used to refer to a single cell of data, called a field. However, MDX uses a very specific and uniform syntax to refer to cells of data, whether the data forms a single cell or a group of cells.

Although SQL and MDX share similar syntax, the MDX syntax is remarkably robust, and it can be complex. However, because MDX was designed to provide a simple, effective way of querying multidimensional data, it addresses the conceptual differences between two-dimensional and multidimensional querying in a consistent and easily understood fashion.

Structure of the Basic MDX Query

To specify a dataset, a Multidimensional Expressions (MDX) query must contain the following information:

  • The number of axes (up to 128)
  • The members from each dimension to include on each axis
  • The name of the cube that sets the context
  • The members from a slicer dimension on which data is sliced for members from the axis dimensions

This information can be complex. MDX syntax provides the information in a simple and straightforward manner, using the MDX SELECT statement.

Basic MDX Syntax: SELECT Statement

In MDX, the SELECT statement is used to specify a dataset that contains a subset of multidimensional data. A basic MDX query is structured in the following way:

SELECT [<axis_specification>
       [, <axis_specification>...]]
  FROM [<cube_specification>]
[WHERE [<slicer_specification>]]

The basic MDX SELECT statement contains a SELECT clause and a FROM clause, with an optional WHERE clause. These syntax elements are shown in the following example:

SELECT
   { [Measures].[Unit Sales], [Measures].[Store Sales] } ON COLUMNS,
   { [Time].[1997], [Time].[1998] } ON ROWS
FROM Sales
WHERE ( [Store].[USA].[CA] )

The SELECT clause determines the axis dimensions of an MDX SELECT statement. Two axis dimensions are defined in this MDX query example. For more information about the construction of axis dimensions in a SELECT clause, see Specifying the Contents of an Axis Dimension.

The FROM clause determines which multidimensional data source is to be used when extracting data to populate the result set of the MDX SELECT statement.

A WHERE clause optionally determines which dimension or member to use as a slicer dimension; this restricts the extracting of data to a specific dimension or member. The WHERE clause in this example restricts the data extract for the axis dimensions to a specific member of the Store dimension. For more information about the construction of a slicer dimension in a WHERE clause, see Specifying the Contents of a Slicer Dimension.

An MDX SELECT statement supports other optional syntax elements, such as the WITH keyword, and the use of MDX functions to construct members by calculation for inclusion in an axis or slicer dimension.

SQL and MDX

The syntax format of the MDX SELECT statement is similar to that of SQL syntax; however, there are several primary differences:

  • MDX syntax distinguishes sets by surrounding tuples or members with braces (the { and } characters.) For more information about member, tuple, and set syntax, see Members, Tuples, and Sets.
  • MDX queries can have up to 128 axis dimensions in the SELECT statement, but only the first 5 axes have aliases. An axis can be referred to either by its ordinal position within an MDX query, or by its alias if it has been assigned an alias. In the previous example, the COLUMNS and ROWS axis aliases are used. The example query could also have been written in the following way, using the ordinal position of each axis:
    SELECT
   { [Measures].[Unit Sales], [Measures].[Store Sales] } ON AXIS(0),
   { [Time].[1997], [Time].[1998] } ON AXIS(1)
FROM Sales
WHERE ( [Store].[USA].[CA] )
  • As with an SQL query, the FROM clause names the source of the data for the MDX query. However, unlike an SQL query, the FROM clause in an MDX query is restricted to a single cube. Information from other cubes can be retrieved, however, on a value-by-value basis using the LookupCube function.
  • In the MDX query, the WHERE clause describes the slicer dimensions. If a dimension is not mentioned as part of the WHERE clause, Microsoft SQL Server 2000 Analysis Services assumes that any dimension not assigned to an axis dimension is a slicer dimension, and the dimension is filtered on its default members. The WHERE clause can change the filtering process for specified dimensions, allowing fine control of included data.


Members

A member is an item in a dimension that represents one or more occurrences of data. A member is the lowest level of reference when describing cell data in a cube. For example, the following diagram is shaded to represent the Time.[2nd half].[3rd quarter] member:

A three-dimensional cube with the Time.[2nd half].[3rd quarter] member shaded

The bracket characters [ and ] are always used if the name of a member contains a space or a number. Bracket characters can also be used around a single string; the member Time shown in the previous diagram could also be represented as:

[Time].[2nd half].[4th quarter]

Member Names and Member Keys

A member can be referenced by either its member name or its member key. The previous example referenced the member by its member name, 4th quarter, in the Time dimension. However, the member name can be duplicated in the case of dimensions with nonunique member names, or it can be changed in the case of changing dimensions, resulting in unexpected results.

A more precise method for referencing members is to reference the member key. The member key is used by the dimension to identify a specific member. The ampersand (&) character is used in MDX to differentiate a member key from a member name, as shown in the following example:

[Time].[2nd half].&[Q4]

In this case, the member key of the 4th quarter member, Q4, is used. Referencing the member key ensures proper member identification in changing dimensions and in dimensions with nonunique member names.

The ampersand character can be used to indicate a member key reference in any MDX expression.

The right bracket (]) can be used as an escape character in MDX if the member name or member key contains a right bracket, as shown in the following example:

[Premier [150]] 98]

Calculated Members

Members can also be created as part of an MDX query. These created members return data based on evaluated expressions instead of stored data in a cube to be queried. These members are called calculated members. They provide a great deal of the power and flexibility of MDX. The WITH keyword is used in an MDX query to define a calculated member. For example, if you want to provide a forecasted estimate of all of the packages by adding 10 percent of the existing value of the Packages measure, you can simply create a calculated member that provides the information. Then you can use it just like any other member in the cube, as demonstrated in the following example:

WITH MEMBER [Measures].[PackagesForecast] AS
'[Measures].[Packages] * 1.1'

For more information about calculated members, see the MDX documentation in SQL Server 2000 Books Online.

Member Functions

MDX supplies a number of functions for retrieving members from other MDX entities, such as dimensions and levels, so that explicit references to a member are not always necessary. For example, you can use the FirstChild function to retrieve the first child member of the Time dimension, or you can explicitly state the member, as demonstrated in the following examples:

Time.[1st half]

or

Time.FirstChild


Tuples

A tuple consists of an ordered collection of one member from each dimension, either explicitly or implicitly declared, that represents a multidimensional coordinate.

A tuple cannot contain more than one member from any single dimension, for the same reason that a coordinate cannot contain two points from the same axis. A tuple differs from a coordinate, however, because a tuple can use default members. If a tuple does not explicitly include a member from each dimension, the default member for each dimension not explicitly included is implicitly referenced by the tuple. Put another way, a tuple is a vector of members; think of a tuple as one or more records in the underlying database whose value in these columns falls under these categories.

In MDX, the tuple syntax depends on its complexity. If a tuple is composed of only one member from a single dimension, often referred to as a simple tuple, then the following syntax is acceptable:

Time.[2nd half]

If a tuple is composed of members from more than one dimension, the members represented by the tuple must be enclosed in parentheses, as demonstrated in the following example:

(Time.[2nd half], Route.nonground.air)

A tuple composed of a single member can also be enclosed in parentheses, but this is not required. Tuples are often grouped together in sets for use in MDX queries.

Tuple Functions

There are a few MDX functions that return tuples. These functions include Current, Item, and StrToTuple. They can be used anywhere that a tuple is accepted.

Tuples and Dimensionality

A tuple can encompass members in multiple dimensions, but not multiple members from the same dimension. The term dimensionality is used to indicate the dimensions described by the members in a tuple. Order plays a factor in the dimensionality of a tuple, and can affect the use of a tuple within a set.


Sets

A set is an ordered collection of zero, one, or more tuples. A set is most commonly used to define axis and slicer dimensions in an MDX query. As such, a set may have only a single tuple; in certain cases it may be empty. The following example shows a set of two tuples:

{ (Time.[1st half], Route.nonground.air), (Time.[2nd half], Route.nonground.sea) }

A set can contain more than one occurrence of the same tuple. The following set is acceptable:

{ Time.[2nd half], Time.[2nd half] }

A set refers either to a set of member combinations, represented as tuples, or to the values in the cells that the tuples in the set represent, depending on the context of usage for the set. If the set is being evaluated over a scalar value or function, the tuples in the set are resolved first; their values are retrieved and each value is evaluated over the scalar value or function (such as BottomPercent or BottomSum). If the set is being evaluated over a non-scalar value or function (such as CrossJoin), the set is treated as a collection of tuples, and each tuple is evaluated over the non-scalar value or function.

In MDX syntax, tuples are enclosed in braces to construct a set.

Important Sets composed of a single tuple are not considered tuples; they are interpreted as sets by MDX. Certain MDX functions accept tuples as parameters, and will raise an error if a single tuple set is passed. Tuples and single-tuple sets are not interchangeable.

Set Functions

Explicitly typing tuples and enclosing them in braces is not the only way to retrieve a set. MDX supports a wide variety of functions that return sets.

The colon operator allows you to use the natural order of members to create a set. For example, the following set:

{[1st quarter]:[4th quarter]}

retrieves the same set of members as the following set:

{[1st quarter], [2nd quarter], [3rd quarter], [4th quarter]}

The colon operator is an inclusive function; the members on both sides of the colon operator are included in the resulting set.

Other MDX functions that return sets can be used either by themselves or as part of a comma-delimited list of members. For example, all of the following MDX expressions are valid:

{Time.Children}
{Time.Children, Route.nonground.air}
{Time.Children, Route.nonground.air, Source.Children}

Sets and Dimensionality

Like tuples, sets also have dimensionality. A set is composed of tuples, and the dimensionality of a set is expressed by the dimensionality of each tuple within it. Because of this parallel, tuples within a set must have the same dimensionality. In other words, this example cannot work as a set:

{ (Time.[2nd half], Route.nonground.air), (Route.nonground.air, Time.[2nd half]) }

The order of tuples in a set is important; it affects, for example, the nesting order in an axis dimension. The first tuple represents the first, or outermost, dimension; the second tuple represents the next outermost dimension; and so on.

Named Sets

A named set is a set for which an alias has been created. A named set is most commonly used in complex MDX queries to increase readability and ease of maintenance.


Axis and Slicer Dimensions

When formulating a Multidimensional Expressions (MDX) query, an application typically looks at the cubes to be queried and divides the set of dimensions into two subsets:

  • Axis dimensions, for which data is retrieved for multiple members
  • Slicer dimensions, for which data is retrieved for a single member

Because axis and slicer dimensions can be constructed from multiple dimensions of the cube to be queried, these terms are used to differentiate the dimensions employed by the cube to be queried from the dimensions created in the cube returned by an MDX query.

For example, assume that the TestCube cube exists with two simple dimensions, Route and Time. Because the measures of the cube are part of the Measures dimension, this cube has three dimensions in all. The query is designed to provide a matrix in which the Packages measure can be compared across routes and times.

In the following MDX query example, the Route and Time dimensions are used as axis dimensions and the Measures dimension is used as the slicer dimension. The Members function indicates that the members of the dimension or level are to be used to construct a set, instead of having to explicitly state each member of a given dimension or level in an MDX query.

SELECT
   { Route.nonground.Members } ON COLUMNS,
   { Time.[1st half].Members } ON ROWS
FROM TestCube
WHERE ( [Measures].[Packages] )

The resulting grid of values resembles the following table, which shows the value of the Packages measure at each intersection of the COLUMNS and ROWS axis dimensions.

 | air | sea
1st quarter | 60 | 50
2nd quarter | 45 | 45

MDX evaluates the axis and slicer dimensions first, building the structure of the result cube before retrieving the information from the cube to be queried.

The slicer dimension is similar to an axis dimension in its purpose, but has limitations that axis dimensions do not share.

Note Microsoft SQL Server 2000 Analysis Services supports a maximum of 128 shared or private dimensions in a cube, in addition to the Measures dimension. Therefore, MDX queries on Analysis Services cubes are limited to a maximum of 129 axes.

See Also

Specifying the Contents of an Axis Dimension

Specifying the Contents of a Slicer Dimension


Specifying the Contents of an Axis Dimension

Axis dimensions determine the edges of a multidimensional result set. Multidimensional Expressions (MDX) uses the SELECT clause to specify axis dimensions by assigning a set to a particular axis. The SELECT clause in an MDX query has the following syntax:

SELECT [<axis_specification>
       [, <axis_specification>...]]

Each <axis_specification> value defines one axis dimension. The number of axes in the dataset is equal to the number of <axis_specification> values in the MDX query. An MDX query can support up to 128 specified axes, but very few MDX queries use more than 5 axes.

The breakdown of the <axis_specification> syntax is:

<axis_specification> ::= <set> ON <axis_name>
<axis_name> ::= COLUMNS | ROWS | PAGES | SECTIONS | CHAPTERS | AXIS(<index>)

Each axis dimension is associated with a number: 0 for the x-axis, 1 for the y-axis, 2 for the z-axis, and so on. The <index> value is the axis number. To refer to the first 5 axis dimensions, the predefined aliases COLUMNS, ROWS, PAGES, SECTIONS, and CHAPTERS can be used in place of AXIS(0), AXIS(1), AXIS(2), AXIS(3), and AXIS(4), respectively.

An MDX query cannot skip axes, and so aliases must be consecutive if used. That is, a query that includes one or more <axis_name> values must not exclude lower-numbered or intermediate axes. For example, a query cannot have a ROWS axis without a COLUMNS axis, or have COLUMNS and PAGES axes without a ROWS axis.

However, you can specify a SELECT clause with no axes (that is, an empty SELECT clause). In this case, all dimensions are slicer dimensions, and the MDX query selects one cell.

Each <set> value defines the contents of the axis. For more information about sets, see Sets.


Specifying the Contents of a Slicer Dimension

Slicer dimensions filter multidimensional data. You can use them to limit the data returned by including them in the WHERE clause of a Multidimensional Expressions (MDX) query.

Dimensions that are not explicitly assigned to an axis are assumed to be slicer dimensions. They filter with their default members. The default member of a dimension can be explicitly specified in its Default Member property in Analysis Manager. This property is equivalent to the DefaultMember property in Decision Support Objects (DSO). If no default member is explicitly specified, the default member is the All member if an (All) level exists, or else an arbitrary member of the highest level. (The name of the All member can be changed when the dimension is defined, and so may not necessarily be [All].)

Slicer dimensions can also be specified explicitly by using the WHERE clause of the MDX syntax. The WHERE clause in an MDX query has the following syntax:

[WHERE [<slicer_specification>]]

The member name [All] is probably not unique within the cube, because many dimensions possess an [All] level. We recommend that you qualify it with the dimension name to make it unambiguous. The following example demonstrates the use of the WHERE clause and the All member as one component of the <slicer_specification> value:

WHERE ( [Route].[All], [Time].[1st half] )

A slicer dimension can accept only expressions that evaluate to a single tuple. If the <slicer_specification> value cannot be resolved into a single tuple, an error occurs.


Establishing Cube Context

The FROM clause in an MDX query indicates the cube on which you want the Multidimensional Expressions (MDX) query to run. The following syntax indicates which cube supplies the context for the MDX query:

FROM <cube_specification>

The <cube_specification> value is completed with the name of a single cube.

For example, for an MDX query that runs against the SalesCube cube, the FROM clause is:

FROM SalesCube

This does not limit you to working with only one cube at a time; you can use the LookupCube function to retrieve data from other cubes outside the cube context.

Unlike SQL, in an MDX query the FROM clause does not usually permit joins. Therefore the following syntax causes an error:

FROM SalesCube, OtherCube

However, some OLAP providers may permit the joining of cubes along congruent dimensions. If two cubes share a dimension, the cubes can be joined using this syntax, in a way similar to that of linked cubes. For more information about joining cubes, see your OLAP provider documentation.


ADOMD.NET Programming

Microsoft® SQL Server™ ADOMD.NET, like ActiveX Data Objects Multidimensional (ADO MD), serves as a bridge between an application and a data source. ADOMD.NET is different from most data providers because it works with multidimensional data. As a result it supports functionality that is very different from other .NET data providers.

The AdomdConnection, AdomdCommand, AdomdDataReader, and AdomdDataAdapter objects represent the ADOMD.NET implementation of the core elements of the .NET Framework data provider model. The following table describes these objects.

Object | Description
AdomdCommand | Represents a command to run against a multidimensional data source.
AdomdConnection | Represents a connection to a multidimensional data source.
AdomdDataAdapter | Represents a set of command-related properties that are used to populate a flattened rowset. It is implemented by .NET Framework data providers.
AdomdDataReader | Provides a means of reading a forward-only result set obtained by running a command at a data source. It is implemented by ADOMD.NET to access multidimensional data sources.

ADOMD.NET also supports a robust object model for retrieving data and metadata from multidimensional data sources, as shown in the following table.

Object | Description
AdomdCacheExpiredException | Represents an exception thrown by ADOMD.NET when a cached version of an ADOMD.NET object is no longer valid.
AdomdConnectionException | Represents an exception thrown by ADOMD.NET when the connection could not be opened or was disconnected.
AdomdError | Represents a provider-specific error.
AdomdErrorResponseException | Represents an exception thrown by ADOMD.NET when a response is received from a provider that indicates an error.
AdomdException | Represents an exception thrown by ADOMD.NET objects when an error occurs.
AdomdRestriction | Restricts the information returned when retrieving schema information from a connection.
AdomdSchemaGuid | Contains a list of common schema rowset identifiers for retrieving schema rowsets.
AdomdTransaction | Represents a transaction to be performed at a multidimensional data source.
AdomdUnknownResponseException | Represents an exception thrown by ADOMD.NET when a response has been returned from the provider that is not understood.
AxesInfo | Represents metadata pertaining to the axes that are associated with a CellSet.
Axis | Represents an axis of a given cellset.
Cell | Represents a cell in a given cellset.
CellInfo | Represents metadata pertaining to the cells that are associated with a CellSet.
CellProperty | Represents a cell property for a given cell.
CellSet | Represents a cellset that is returned as a result of a query.
CubeDef | Represents the metadata for a cube.
CubeInfo | Represents metadata pertaining to a cube that is associated with a CellSet.
Dimension | Represents a dimension within a cube.
Hierarchy | Represents a hierarchy contained by a dimension or set.
Level | Represents a level within a hierarchy.
LevelProperty | Represents a single level property for a given level.
Measure | Represents a measure within a cube.
Member | Represents a single member within a hierarchy, tuple, level, or member.
MemberFilter | Represents a single filter to be applied when retrieving a collection of members.
MemberProperty | Represents a single member property for a given member.
NamedSet | Represents a named set for a given cube.
OlapInfo | Represents metadata associated with a CellSet class.
OlapInfoAxis | Represents metadata pertaining to an axis that is associated with a CellSet class.
OlapInfoCube | Represents metadata pertaining to a cube that is associated with a CellSet class.
OlapInfoHierarchy | Represents metadata of a hierarchy that is contained in a CellSet class.
OlapInfoProperty | Represents metadata pertaining to hierarchy, cell, and cube objects that are contained in a CellSet class.
Position | Represents a tuple on an axis.
Set | Represents an ordered collection of zero or more tuples, which are organized along hierarchies.
Tuple | Represents an ordered collection of members from different dimensions.

Connected Access

The AdomdDataReader provides a fast, efficient way of reading data from a multidimensional data source while connected. The AdomdDataReader implements the IDbDataReader interface from the System.Data namespace of the .NET Framework class library, so that any application capable of binding to a standard .NET data provider can bind to ADOMD.NET for retrieving data.

The AdomdDataAdapter implements the IDbDataAdapter interface to populate a flattened rowset.

Disconnected Access

The CellSet class provides a robust way of accessing and manipulating multidimensional data in both disconnected and connected states. Supported by numerous objects for accessing data and metadata, such as the Cell, Member, Tuple, Set, Hierarchy, Dimension, Axis, and Hierarchy objects, complex data discovery and manipulation can be performed without requiring an active connection to a multidimensional data source. Properties that require a connection before being used include Hierarchy.Name, Hierarchy.Description, Hierarchy.ParentDimension, Hierarchy.DefaultMember, Hierarchy.DisplayFolder, Hierarchy.Caption, Hierarchy.HierarchyOrigin, Hierarchy.Levels, Hierarchy.Properties, and Member.FetchAllProperties.

.NET Data Access Support

ADOMD.NET does not fully support the use of a DataSet, due to the limitations of relational data access when viewing multidimensional data. However, ADOMD.NET partially supports the standard IDataAdapter and IDataReader interfaces for retrieving data.

Possible Exceptions

The following table lists possible exceptions that may occur when accessing or manipulating ADOMD.NET objects:

Exception type | Condition
AdomdCacheExpiredException | The underlying data has changed on the server, and must be refreshed.
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection has been broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.


Establishing Connections

In ADOMD.NET, you use an AdomdConnection to establish connections with multidimensional data sources, such as Analysis Services databases. ADOMD.NET uses an internal client implementation of the XML for Analysis protocol to establish a session with an instance of Analysis Services.

The AdomdConnection supports a connection string that is similar in format to the OLE DB connection string format. For more information about setting names and values in valid connection strings, see AdomdConnection.ConnectionString Property.

Opening a Connection

To open a connection in ADOMD.NET, you must first specify a valid multidimensional data source and database in the ConnectionString property of the AdomdConnection. You can also provide a valid connection string when creating an instance of an AdomdConnection class, as demonstrated in the following example:

[Visual Basic .NET]
Dim advwrksConnection As New AdomdConnection("Data Source=localhost;Catalog=AdventureWorksAS")

ADOMD.NET supports both TCP-based and HTTP-based connections to multidimensional data sources, as well as connections to Analysis Services local cube (.cub) files.

There are many connection string properties, each defined by the provider that you are connecting to. There are several, however, that are supported by the ADOMD.NET client. The list of these connection strings and their purpose can be found in AdomdConnection.ConnectionString Property.

Closing a Connection

An AdomdConnection should be explicitly closed once it is no longer needed. The Close and Dispose methods of the AdomdConnection can be used to explicitly close the connection.

Connections that are not explicitly closed, but simply allowed to fall out of scope, may not release server resources rapidly enough to allow high-concurrency Analysis Services client applications to efficiently open connections. Depending on how the connection was created, the session used by the AdomdConnection can remain active if the connection is not explicitly closed.

Important Do not call the Close or Dispose methods of an AdomdConnection, an AdomdDataReader, or any other managed object in the Finalize method of any implemented class. In a finalizer, release unmanaged resources only if they are directly owned by the implemented class. If the implemented class does not own any unmanaged resources, do not include a Finalize method in the class definition.

Integrated Security and Connections

Windows Integrated Security is the most secure way of establishing and securing a connection to an instance of Analysis Services. It does not expose security credentials, such as a user name or password, during the authentication process, but instead uses the security identifier of the currently executing process to establish identity. For most client applications, this security identifier represents the identity of the currently logged-on user.


Connections and Sessions in ADOMD.NET

In XML for Analysis, sessions provide support for stateful operations during multidimensional data access. Sessions are used to frame the scope and context of commands and transactions for a multidimensional data source.

ADOMD.NET is designed to function only with XML for Analysis compliant providers that provide session support. If you use ADOMD.NET to attempt to connect to a multidimensional data source with an XML for Analysis compliant provider that does not support sessions, an exception is thrown.

Managing Sessions in ADOMD.NET

The SessionID property of the AdomdConnection contains the identifier of the active session associated with the AdomdConnection. By using this property well, you can effectively control both client and server statefulness in your application. Multiple AdomdConnection objects can be connected to a single active session, and a single AdomdConnection can be disconnected from one session and reconnected to another session.

If this property is not set to a valid session ID when the Open method is called, the AdomdConnection requests a new session ID from the provider and, if successful, sets the value of this property to the session ID of the newly created session. ADOMD.NET initiates a session by sending an XML for Analysis BeginSession header to the provider. If this property is set to a valid session ID when the Open method is called, the AdomdConnection attempts to connect to the specified session. If the AdomdConnection cannot connect to the specified session, an exception is thrown.

After the AdomdConnection is connected to a valid session, an XML for Analysis Session header is sent to the provider with every request for data or metadata made by an application, and with the session ID set to the value of the SessionID property. A session ID does not guarantee that a session remains valid. If the session expires (for example, if it times out or the connection is lost), the provider can choose to end and roll back the actions of that session. As a result, all subsequent method calls from the AdomdConnection throw an exception. Your application must be able to catch such exceptions any time data or metadata is retrieved from the provider, because an exception is thrown only when the next request is sent to the provider, not when the session actually expires.

If the Close method is called without specifying the value of the endSession parameter, or if the endSession parameter is set to true, then both the connection to the session and the session associated with the AdomdConnection are closed. ADOMD.NET sends an XML for Analysis EndSession header to the provider, with the session ID set to the value of the SessionID property. If the Close method is called with the endSession parameter set to false, the session associated with the AdomdConnection remains active but the connection to the session is closed.

The following example demonstrates how to create, disconnect from, and reconnect to a session in ADOMD.NET:

[Visual Basic]
Public Function CreateSession(ByVal connectionString As String) As String
    Dim strSessionID As String, objConnection As New AdomdConnection

    Try
        ' First, attempt to connect to the specified data source.
        ' If the connection string is not valid, or if the specified
        ' provider doesn't support sessions, an exception is thrown.
        objConnection.ConnectionString = connectionString
        objConnection.Open()

        If objConnection.State = ConnectionState.Open Then
            ' Now that the connection is open, retrieve the new
            ' active session ID.
            strSessionID = objConnection.SessionID
            ' Close the connection, but leave the session open.
            objConnection.Close(False)
        End If
    Catch ex As AdomdConnectionException
        ' The connection could not be opened or was disconnected.
        ' This error can occur at any time, if the provider is
        ' disconnected from the server.
        strSessionID = ""
        Throw ex
    Catch ex As AdomdErrorResponseException
        ' A response is received from a provider that indicates an error.
        strSessionID = ""
        Throw ex
    Catch ex As AdomdUnknownResponseException
        ' A response has been returned from the provider that
        ' was not understood.
        strSessionID = ""
        Throw ex
    Catch ex As AdomdCacheExpiredException
        ' A cached version of an ADOMD.NET object is no longer valid.
        ' This error is typically raised when reviewing metadata.
        strSessionID = ""
        Throw ex
    Catch ex As AdomdException
        ' Any other error raised by ADOMD.NET.
        strSessionID = ""
        Throw ex
    Catch ex As Exception
        ' Any other error.        strSessionID = ""
        Throw ex
    Finally
        objConnection = Nothing
        CreateSession = strSessionID
    End Try

End Function


Retrieving Metadata

Metadata is crucial to applications that retrieve and manipulate multidimensional data. When retrieving data from a relational data source, the dimensionality of such data is predictable, even with nested datasets: result sets from a relational database are typically two-dimensional or scalar in structure. However, data retrieved from multidimensional data sources can be of variable dimensionality, organized along potentially deep hierarchies. In order to display and allow users to interact with multidimensional data, a large amount of metadata must also be supplied so that applications can appropriately frame the multidimensional data. ADOMD.NET supports three basic forms of metadata retrieval: working with connection metadata, working with cellsets, and retrieving schema rowsets.

  • Connection metadata ADOMD.NET provides a robust object model for viewing the cubes and subordinate objects contained by a multidimensional data source, as exposed through metadata upon connection to the server. Not all metadata for a given multidimensional data source is available at this point — only that which is necessary for a client application to display in order to allow the user to interactively construct commands. The AdomdConnection provides this information through a collection of CubeDef objects, with each CubeDef representing a single cube and all of its associated subordinate objects, such as dimensions and named sets.
  • Cellset metadata After a command that returns a cellset is run, ADOMD.NET retrieves both the data and the metadata for the cellset using the CellSet. The metadata is necessary for client applications to display and interact with cellset data. For example, many client applications provide functionality for "drilling down" on, or hierarchically displaying the child positions of, a specified position in a cellset. In ADOMD.NET, the Axes and FilterAxis properties of the CellSet represent the metadata of the query and slicer axes in the returned cellset. Both properties return references to Axis objects, which in turn contain the positions represented on each axis.
  • Schema rowsets Finally, ADOMD.NET can retrieve the full range of OLE DB, OLE DB for OLAP, OLE DB for Data Mining, and XML for Analysis schema rowsets. The AdomdSchemaGuid class contains a list of fields that represent the schema rowsets most commonly supported by data providers and multidimensional data sources. The GUIDs contained within the AdomdSchemaGuid are used with the GetSchemaDataSet method of the AdomdConnection to retrieve both general and provider-specific metadata from a provider or multidimensional data source. The GetSchemaDataSet method can use both schema names and GUIDs to retrieve schema rowsets.

    Note Keep in mind that if the metadata changes while you are reading it, the AdomdCacheExpiredException exception is thrown.


Working with Connection Metadata

In ADOMD.NET, an AdomdConnection not only represents a connection to a multidimensional data source, but also the metadata for that multidimensional data source. The AdomdConnection provides access to information on the cubes and related subordinate objects defined on a multidimensional data source.

When working with metadata, the CubeDef is used to retrieve information about not just a cube, but about its subordinate objects as well. Each AdomdConnection has a collection of CubeDef objects that represent the cubes available to the user or application.

Use the CubeDef to represent metadata in client applications designed to support multiple OLAP products or for general metadata display and access purposes, because the CubeDef displays cube and subordinate object metadata using a set of properties that is common across all XML for Analysis compliant providers.


Working with Cellset Metadata

Each cellset has its own set of metadata that assists in defining and displaying the information. In ADOMD.NET, the Axes and FilterAxis properties of the CellSet contain this metadata. The Axes property returns a collection of Axis objects that represent the query axes of a cellset, while the FilterAxis property returns an Axis that represents the slicer axis of a cellset.

Each Axis contains a collection of Position objects that represent the set of tuples available for that axis. Each Position represents a single tuple, represented by a Tuple, that contains one or more members, represented by a collection of Member objects.

Each OlapInfo contains an AxesInfo, an CellInfo, and an CubeInfo, providing access to the underlying metadata of a CellSet.


Retrieving Schema Rowsets

You can obtain schema information from your multidimensional data source by using the GetSchemaDataSet method of the AdomdConnection in ADOMD.NET. Schema information in a multidimensional data source includes databases or catalogs available from the multidimensional data source, and cubes and mining models in a database.

The ADOMD.NET data provider exposes schema information through functionality made available by your specific provider and multidimensional data source, such as the use of the XML for Analysis Discover method.

The GetSchemaDataSet method takes as arguments a globally unique identifier (GUID) that identifies which schema information to return, an array of restrictions on those returned columns, or the name of the schema information to return. The GetSchemaDataSet method returns a DataSet, from the System.Data namespace of the .NET Framework class library, populated with the schema information.


Executing Commands

After establishing a connection to a multidimensional data source, you can execute commands and return results from the multidimensional data source using an AdomdCommand. You can create a command using the AdomdCommand constructor, which takes optional arguments of a command to run at the data source and an AdomdConnection. You can also create a command for a particular AdomdConnection by using the CreateCommand method of the AdomdConnection. The command of the AdomdCommand can be queried and modified using the CommandText property.

The AdomdCommand exposes several Execute methods you can use to perform the intended action:

  • When returning results as a stream of data, use ExecuteReader to return an AdomdDataReader. The returned result will be in a flattened format, not in a multi-dimensional format.
  • Use ExecuteCellset to return a CellSet.
  • Use ExecuteNonQuery to run commands that do not return rows.
  • Use ExecuteXMLReader to return an XMLReader containing the data in an XML for Analysis compliant format.


Retrieving Data

In ADOMD.NET, you can retrieve data using three different objects — CellSet, AdomdDataReader, and XmlReader — by calling one of the Execute methods of the AdomdCommand. Each object is designed to balance overhead, speed, and flexibility based on the needs of your application:

  • The CellSet provides the most interactivity and flexibility when working with multidimensional data, and it stores most of the information from the original query. However, the CellSet also requires the most overhead of the three data retrieval methods, and is the slowest to retrieve fully, because the CellSet provides a many-featured object model designed for navigating both the data and metadata of a multidimensional cellset.
  • The AdomdDataReader provides a good balance between overhead and interactivity when working with multidimensional data. Designed for forward-only retrieval, the AdomdDataReader doesn't support a large object model for representing data or metadata, nor does it allow for more complex multidimensional features like cell writeback. What it does do, however, is handle large amounts of multidimensional data quickly and effectively. The AdomdDataReader also provides a set of strongly typed methods for retrieving cellset data.
  • The XmlReader object uses the least overhead and is the fastest of the three objects in terms of data retrieval, but supplies the least interactivity of the three objects. The XmlReader provides passthrough functionality, returning the raw XML for Analysis response from the underlying provider.


Retrieving Data Using the CellSet

The CellSet is to ADOMD.NET what the System.Data.DataSet is to ADO.NET: an in-memory cache of data that can be manipulated in a disconnected state. The CellSet consists of a collection of Cell objects, hierarchically organized according to the tuples in the axes represented by the Axes and FilterAxis properties. Each Cell represents the value at the intersection of one position from every axis within the cellset.

After creating an instance of the AdomdCommand class, you create an instance of a CellSet class by calling the Execute or ExecuteCellSet method of the AdomdCommand to retrieve a multidimensional cellset from a data source, as shown in the following example:

[Visual Basic]

Dim objReader As CellSet = objCommand.ExecuteCellSet()

[C#]

CellSet objReader = objCommand.ExecuteCellSet();

The data and metadata used to populate the CellSet is returned by the XML for Analysis compliant provider using the MDDataSet format with the AxisFormat property set to TupleFormat. The MDDataSet format provides both data and metadata for cellsets in a well-structured format. For more information about the MDDataSet format, see the XML for Analysis specification.


Retrieving Data Using the AdomdDataReader

You can use the ADOMD.NET AdomdDataReader to retrieve a read-only, forward-only stream of data from a multidimensional data source. Results are returned as the query executes, and are stored in the network buffer on the client until you request them using the Read method of the AdomdDataReader. Using the AdomdDataReader can increase application performance both by retrieving data as soon as it is available, rather than waiting for the entire results of the query to be returned, and (by default) storing only one row at a time in memory, reducing system overhead.

After creating an instance of the AdomdCommand, you create an instance of an AdomdDataReader by calling the Execute (if executing a DataMining or SQL query) or ExecuteReader method of the AdomdCommand to retrieve rows from a data source, as shown in the following example:

[Visual Basic]

Dim objReader As AdomdDataReader = objCommand.ExecuteReader()

[C#]

AdomdDataReader objReader = objCommand.ExecuteReader();

You use the Read method of the AdomdDataReader to obtain a row from the results of the query. You can access each column of the returned row by passing the name or ordinal reference of the column to the AdomdDataReader. However, for best performance, the AdomdDataReader provides a series of methods that allow you to access column values in their native data types (GetDateTime, GetDouble, GetGuid, GetInt32, and so on). For a list of typed accessor methods, see AdomdDataReader Members. Using the typed accessor methods, when the underlying data type is known, reduces the amount of type conversion required when retrieving the column value.

The concept of a row in multidimensional data access is somewhat different, because of the variable dimensionality inherent in such data. ADOMD.NET uses the Resultset format, a tabular format as described in the XML for Analysis specification, to provide data for the AdomdDataReader — essentially a depth-first hierarchically flattened rowset.

The following code example iterates through a AdomdDataReader, and returns the first two values, as strings, from each row.

[Visual Basic]

If Not (objReader Is Nothing) AndAlso _
            objReader.FieldCount > 1 Then

            Do While objReader.Read()
                If Not (objReader.IsDBNull(0)) AndAlso _
                    Not (objReader.IsDBNull(1)) Then

                    Console.WriteLine(vbTab & "{0}" & vbTab & "{1}", _
                        objReader.GetString(0), objReader.GetString(1))
                End If
            Loop
        Else
            Console.WriteLine("No rows returned.")
        End If

        objReader.Close()

[C#]

if (objReader != null) && (objReader.FieldCount > 1)
  {
  while (objReader.Read())
    If (objReader.IsDBNull(0)=false) && (objReader.IsDBNull(0)=false)
    {
    Console.WriteLine("\t{0}\t{1}", _
        objReader.GetString(0), objReader.GetString(1));
    }
  }
else
  Console.WriteLine("No rows returned.");

objReader.Close();

The AdomdDataReader provides an unbuffered stream of data that allows procedural logic to efficiently process results from a multidimensional data source sequentially. The AdomdDataReader is a good choice when retrieving large amounts of data for display purposes because the data is not cached in memory.

Closing the AdomdDataReader

You should always call the Close method when you have finished using the AdomdDataReader. While an instance of an AdomdDataReader class is open, the AdomdConnection is in use exclusively by that AdomdDataReader. You cannot execute any commands for the AdomdConnection, including creating another AdomdDataReader or XmlReader, until the original AdomdDataReader is closed.

Important Do not call the Close or Dispose methods of an AdomdConnection, AdomdDataReader, XmlReader, or any other managed object in the Finalize method of any implemented class. In a finalizer, only release unmanaged resources that are directly owned by the implemented class. If the implemented class does not own any unmanaged resources, do not include a Finalize method in the class definition.

Multiple Result Sets

Due to the nature of multidimensional data access, the AdomdDataReader does not support multiple or hierarchical result sets. The AdomdDataReader does support nested rowsets.

Getting Schema Information from the AdomdDataReader

While an instance of an AdomdDataReader class is open, you can retrieve schema information about the current cellset using the GetSchemaTable method. GetSchemaTable returns a DataTable populated with rows and columns that contain the schema information for the current cellset. The DataTable will contain one row for each column of the cellset. Each column of the schema table row maps to a property of the column returned in the cellset, where the ColumnName column is the name of the property and the value of the column is the value of the property. The following code example writes out the schema information for an AdomdDataReader:

[Visual Basic]

Dim schemaTable As DataTable = objReader.GetSchemaTable()

Dim objRow As DataRow
Dim objColumn As DataColumn

For Each objRow In schemaTable.Rows
  For Each objColumn In schemaTable.Columns
    Console.WriteLine(objColumn.ColumnName & " = " & objRow(objColumn).ToString())
  Next
  Console.WriteLine()
Next

[C#]

DataTable schemaTable = objReader.GetSchemaTable();

foreach (DataRow objRow in schemaTable.Rows)
{
  foreach (DataColumn objColumn in schemaTable.Columns)
    Console.WriteLine(objColumn.ColumnName + " = " + objRow[objColumn]);
  Console.WriteLine();
}


Retrieving Data Using the XmlReader

The XmlReader class, part of the System.Xml namespace for the .NET Framework class library, is similar to the AdomdDataReader class: it provides fast, non-cached, forward-only access to data. The XmlReader class provides direct access to the XML for Analysis response received by ADOMD.NET when the ExecuteXmlReader method of the AdomdCommand is called.

After creating an instance of the AdomdCommand class, you create an instance of an XmlReader class by calling the ExecuteXmlReader method of the AdomdCommand to retrieve a multidimensional cellset from a data source, as shown in the following example:

[Visual Basic]

Dim objReader As XmlReader = objCommand.ExecuteXmlReader()

[C#]

XmlReader objReader = objCommand.ExecuteXmlReader();

The XML data is presented in the native format used by the XML for Analysis provider. Typically, the MDDataSet format is used by most XML for Analysis providers as the native format for MDX queries, while the Rowset format is used for data mining queries. The MDDataSet format provides both data and metadata for cellsets in a well-structured format. For more information about the MDDataSet format, see the XML for Analysis specification.

If there is no need for an in-memory multidimensional view of the data using the CellSet, the XmlReader is well suited for retrieving XML data, especially for large quantities of data. Because XmlReader streams data, it does not have to retrieve and cache all the data before exposing it to the caller, as would be the case if a CellSet were used to convert the XML for Analysis response to a multidimensional object model representation. Keep in mind that you must parse the XML yourself if using the XmlReader.

Closing the XmlReader

You should always call the Close method when you have finished using the XmlReader. While an XmlReader is open, the associated AdomdConnection is in use exclusively by that XmlReader. You cannot execute any commands using the AdomdConnection, including creating another XmlReader or AdomdDataReader, until the original XmlReader is closed.

Important Do not call the Close or Dispose methods of an AdomdConnection, an AdomdDataReader, an XmlReader, or any other managed object in the Finalize method of any implemented class. In a finalizer, release only those unmanaged resources that are directly owned by the implemented class. If the implemented class does not own any unmanaged resources, do not include a Finalize method in the class definition.


Performing Transactions

The AdomdTransaction is used to manage transaction context for a given AdomdConnection in ADOMD.NET. The AdomdTransaction class is the implementation of the System.Data.IDbTransaction interface, part of the .NET Framework class library and implemented by all .NET data providers that support transactions.

The AdomdTransaction supports only read-committed transactions, in which shared locks are held while the data is being read to avoid dirty reads. However, the data can be changed before the end of the transaction, resulting in non-repeatable reads or phantom data.

Starting a Transaction

You create an instance of an AdomdTransaction class by calling the BeginTransaction method of the AdomdConnection, as shown in the following example:

[Visual Basic]

Dim objTransaction As AdomdTransaction = objConnection.BeginTransaction()

[C#]

AdomdTransaction objTransaction = objConnection.BeginTransaction();

When the AdomdTransaction is instantiated, a BEGIN TRANSACTION MDX statement is run against the provider, framing further commands within the newly established transaction.

Rolling Back a Transaction

You can use the AdomdTransaction to roll back an existing incomplete transaction by calling the Rollback method of the AdomdTransaction. If this method is called on an existing complete transaction, an exception is thrown.

Committing a Transaction

After you call the BeginTransaction method to start a transaction, you can complete the transaction by calling the Commit method of the AdomdTransaction. If this method is called on an existing complete transaction, an exception is thrown.


ADOMD.NET Reference

The ADOMD.NET data provider is represented by a single namespace, Microsoft.AnalysisServices.AdomdClient, which represents the redistributable ADOMD.NET data provider.

Topic | Description
Microsoft.AnalysisServices.AdomdClient Namespace | Contains the .NET data provider portion of ADOMD.NET.


Microsoft.AnalysisServices.AdomdClient Namespace

The Microsoft.AnalysisServices.AdomdClient namespace represents the redistributable ADOMD.NET data provider.

The ADOMD.NET data provider is used to access multidimensional data sources, such as Microsoft SQL Server 2000 Analysis Services, in managed code. Using the AdomdConnection, you can connect to a multidimensional data source, and you can then run queries and statements using an AdomdCommand to return AdomdDataReader and CellSet objects containing multidimensional data. You can also use the AdomdConnection to view metadata for multidimensional data sources, either by examining the CubeDef and related objects or by retrieving schema rowsets directly from the data source.

For more information, see Microsoft.AnalysisServices.AdomdClient Hierarchy.

Classes

Class | Description
AdomdCommand | Represents a command to run against a multidimensional data source.
AdomdConnection | Represents a connection to a multidimensional data source.
AdomdDataAdapter | Represents a set of command-related properties that are used to fill the dataset, and is implemented by .NET Framework data providers that access relational databases.
AdomdDataReader | Provides a means of reading a forward-only result set obtained by running a command at a data source, and is implemented by ADOMD.NET to access multidimensional data sources.
AdomdCacheExpiredException | Represents an exception thrown by ADOMD.NET when a cached version of an ADOMD.NET object is no longer valid.
AdomdConnectionException | Represents an exception thrown by ADOMD.NET when the connection could not be opened or was disconnected.
AdomdError | Represents a provider-specific error.
AdomdErrorCollection | Represents a collection of AdomdError objects.
AdomdErrorResponseException | Represents an exception thrown by ADOMD.NET when a response is received from a provider which indicates an error.
AdomdException | Represents the base exception thrown by the ADOMD.NET objects.
AdomdProperty | Represents a property on a command.
AdomdPropertyCollection | Gets a collection of AdomdProperty objects contained in an AdomdCommand.
AdomdRestriction | Restricts the information returned when retrieving schema information from a connection.
AdomdRestrictionCollection | Gets a collection of AdomdRestriction objects.
AdomdSchemaGuid | Contains a list of common schema rowset identifiers for retrieving schema rowsets.
AdomdTransaction | Represents a transaction to be performed at a multidimensional data source.
AdomdUnknownResponseException | Represents an exception thrown by ADOMD.NET when a response has been returned from the provider that is not understood.
AxesInfo | Represents metadata of the axes that are contained in a CellSet.
Axis | Represents an axis within a given cellset.
AxisCollection | Contains a read-only collection of Axis objects contained by a CellSet.
Cell | Represents a cell in a given cellset. A cell represents the unique logical intersection of one position from every axis in the cellset.
CellCollection | Contains a read-only collection of Cell objects contained by a CellSet.
CellInfo | Represents metadata pertaining to the cells that are associated with a CellSet.
CellProperty | Represents a cell property for a given cell.
CellPropertyCollection | Contains a read-only collection of CellProperty objects contained by a Cell.
CellSet | Represents a cellset that is returned as a result of a query.
CubeCollection | Contains a read-only, on-demand list of CubeDef objects contained by an AdomdConnection.
CubeDef | Represents the metadata for a cube.
CubeInfo | Represents metadata pertaining to a cube that is associated with a CellSet.
Dimension | Represents a dimension within a cube.
DimensionCollection | Contains a read-only, on-demand collection of Dimension objects contained in a CubeDef.
Hierarchy | Represents a user hierarchy contained by a dimension or set.
HierarchyCollection | Contains a read-only, on-demand collection of Hierarchy objects contained in a Dimension or a Set.
Level | Represents a level within a hierarchy.
LevelCollection | Contains a read-only, on-demand collection of Level objects contained by a Hierarchy.
LevelProperty | Represents a single level property for a given level.
LevelPropertyCollection | Contains a read-only, on-demand collection of LevelProperty objects contained by a Level.
Measure | Represents a measure within a cube.
MeasureCollection | Contains a read-only, on-demand collection of Measure objects contained by a CubeDef.
Member | Represents a single member within a hierarchy, tuple, level, or member.
MemberCollection | Contains a read-only, on-demand collection of Member objects contained by a Level or a Tuple.
MemberFilter | Represents a single filter to be applied when retrieving a collection of members.
MemberProperty | Represents a single member property for a given member.
MemberPropertyCollection | Contains a read-only, on-demand collection of MemberProperty objects contained by a Member.
NamedSet | Represents a named set for a given cube.
NamedSetCollection | Gets a read-only, on-demand collection of NamedSet objects contained by a CubeDef.
NamedSet | Represents a named set for a given cube.
NamedSetCollection | Contains a read-only, on-demand collection of NamedSet objects contained by a CubeDef.
OlapInfo | Represents metadata of a CellSet.
OlapInfoAxis | Represents metadata of an axis in a CellSet.
OlapInfoAxisCollection | Gets a read-only, on-demand collection of OlapInfoAxis objects.
OlapInfoCube | Represents metadata of a cube in a CellSet.
OlapInfoCubeCollection | Gets a read-only, on-demand collection of OlapInfoCube objects.
OlapInfoHierarchy | Represents metadata of a hierarchy in a CellSet.
OlapInfoHierarchyCollection | Gets a read-only, on-demand collection of OlapInfoHierarchy objects.
OlapInfoProperty | Represents metadata of hierarchy, cell, and cube objects in a CellSet.
OlapInfoPropertyCollection | Gets a read-only, on-demand collection of OlapInfoProperty objects.
Position | Represents a tuple on an axis.
PositionCollection | Contains a read-only collection of Position objects contained by an Axis.
Property | Represents a property of various ADOMD.NET objects.
PropertyCollection | Gets a read-only, on-demand collection of Property objects.
Set | Represents an ordered collection of zero or more tuples, which are organized along hierarchies.
Tuple | Represents an ordered collection of members from different hierarchies.
TupleCollection | Contains a read-only collection of Tuple objects contained by a Set or an Axis.

Structures

Structure | Description
AdomdDataReader.Enumerator | Supports iterating over records in the AdomdDataReader.
AdomdErrorCollection.Enumerator | Supports iterating over an AdomdErrorCollection and reading its individual AdomdError objects.
AdomdPropertyCollection.Enumerator | Supports iterating over an AdomdPropertyCollection and reading its individual properties.
AdomdRestrictionCollection.Enumerator | Supports iterating over an AdomdRestrictionCollection and reading its individual AdomdRestriction objects.
AxisCollection.Enumerator | Supports iterating over an AxisCollection and reading its individual axes.
CellCollection.Enumerator | Supports iterating over a CellCollection and reading its individual cells.
CellPropertyCollection.Enumerator | Supports iterating over a CellPropertyCollection and reading its individual cell properties.
CubeCollection.Enumerator | Supports iterating over a CubeCollection and reading its individual cubes.
DimensionCollection.Enumerator | Supports iterating over a DimensionCollection and reading its individual dimensions.
HierarchyCollection.Enumerator | Supports iterating over a HierarchyCollection and reading its individual hierarchies.
LevelCollection.Enumerator | Supports iterating over a LevelCollection and reading its individual levels.
LevelPropertyCollection.Enumerator | Supports iterating over a LevelPropertyCollection and reading its individual level properties.
MeasureCollection.Enumerator | Supports iterating over a MeasureCollection and reading its individual measures.
MemberCollection.Enumerator | Supports iterating over a MemberCollection and reading its individual members.
MemberPropertyCollection.Enumerator | Supports iterating over a MemberPropertyCollection and reading its individual member properties.
NamedSetCollection.Enumerator | Supports iterating over a NamedSetCollection and reading its individual named sets.
OlapInfoAxisCollection.Enumerator | Supports iterating over an OlapInfoAxisCollection and reading its individual OlapInfoAxis objects.
OlapInfoCubeCollection.Enumerator | Supports iterating over an OlapInfoCubeCollection and reading its individual OlapInfoCube objects.
OlapInfoHierarchyCollection.Enumerator | Supports iterating over an OlapInfoHierarchyCollection and reading its individual OlapInfoHierarchy objects.
OlapInfoPropertyCollection.Enumerator | Supports iterating over an OlapInfoPropertyCollection and reading its individual OlapInfoProperty objects.
PositionCollection.Enumerator | Supports iterating over a PositionCollection and reading its individual positions.
PropertyCollection.Enumerator | Supports iterating over a PropertyCollection and reading its individual properties.
TupleCollection.Enumerator | Supports iterating over a TupleCollection and reading its individual tuples.

Enumerations

Enumeration | Description
ConnectionExceptionCause | Describes the reason for the connection exception.
MemberFilterType | Represents the type of a MemberFilter.
DimensionTypeEnum | Describes the type of a dimension.
HierarchyOrigin | Describes the overall structure of a hierarchy.
LevelTypeEnum | Describes the type of a level.
MemberTypeEnum | Describes the type of a member.
SchemaObjectType | Describes the type of object retrieved by the GetSchemaObject method of the CubeDef.

See Also

.NET Framework Class Library


Microsoft.AnalysisServices.AdomdClient Hierarchy

Note: This namespace, class, or member is supported only in version 1.1 of the .NET Framework.

System.Object

Microsoft.AnalysisServices.AdomdClient.AdomdError

Microsoft.AnalysisServices.AdomdClient.AdomdErrorCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.AdomdProperty

Microsoft.AnalysisServices.AdomdClient.AdomdRestriction

Microsoft.AnalysisServices.AdomdClient.AdomdSchemaGuid

Microsoft.AnalysisServices.AdomdClient.AdomdTransaction ---- System.Data.IDbTransaction, System.IDisposable

Microsoft.AnalysisServices.AdomdClient.AxesInfo

Microsoft.AnalysisServices.AdomdClient.Axis

Microsoft.AnalysisServices.AdomdClient.AxisCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Cell

Microsoft.AnalysisServices.AdomdClient.CellCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.CellInfo

Microsoft.AnalysisServices.AdomdClient.CellProperty

Microsoft.AnalysisServices.AdomdClient.CellPropertyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.CellSet

Microsoft.AnalysisServices.AdomdClient.CubeCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.CubeDef

Microsoft.AnalysisServices.AdomdClient.CubeInfo

Microsoft.AnalysisServices.AdomdClient.Dimension

Microsoft.AnalysisServices.AdomdClient.DimensionCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Hierarchy

Microsoft.AnalysisServices.AdomdClient.HierarchyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Level

Microsoft.AnalysisServices.AdomdClient.LevelCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.LevelProperty

Microsoft.AnalysisServices.AdomdClient.LevelPropertyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Measure

Microsoft.AnalysisServices.AdomdClient.MeasureCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Member

Microsoft.AnalysisServices.AdomdClient.MemberCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

MemberFilter

Microsoft.AnalysisServices.AdomdClient.MemberProperty

Microsoft.AnalysisServices.AdomdClient.MemberPropertyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.NamedSet

Microsoft.AnalysisServices.AdomdClient.NamedSetCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.OlapInfo

Microsoft.AnalysisServices.AdomdClient.OlapInfoAxis

Microsoft.AnalysisServices.AdomdClient.OlapInfoAxisCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.OlapInfoCube

Microsoft.AnalysisServices.AdomdClient.OlapInfoCubeCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.OlapInfoHierarchy

Microsoft.AnalysisServices.AdomdClient.OlapInfoHierarchyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.OlapInfoProperty

Microsoft.AnalysisServices.AdomdClient.OlapInfoPropertyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Position

Microsoft.AnalysisServices.AdomdClient.PositionCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Property

Microsoft.AnalysisServices.AdomdClient.PropertyCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.Set

Microsoft.AnalysisServices.AdomdClient.Tuple

Microsoft.AnalysisServices.AdomdClient.TupleCollection ---- System.Collections.ICollection, System.Collections.IEnumerable

System.Exception

Microsoft.AnalysisServices.AdomdClient.AdomdException ---- System.Runtime.Serialization.ISerializable

Microsoft.AnalysisServices.AdomdClient.AdomdCacheExpiredException ---- System.Runtime.Serialization.ISerializable

Microsoft.AnalysisServices.AdomdClient.AdomdConnectionException ---- System.Runtime.Serialization.ISerializable

Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException ---- System.Runtime.Serialization.ISerializable

Microsoft.AnalysisServices.AdomdClient.AdomdUnknownResponseException ---- System.Runtime.Serialization.ISerializable

System.MarshalByRefObject

Microsoft.AnalysisServices.AdomdClient.AdomdDataReader ---- System.Data.IDataReader, System.IDisposable, System.Data.IDataRecord, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.AdomdPropertyCollection ---- System.Collections.IList, System.Collections.ICollection, System.Collections.IEnumerable

Microsoft.AnalysisServices.AdomdClient.AdomdRestrictionCollection ---- System.Collections.IList, System.Collections.ICollection, System.Collections.IEnumerable

System.ComponentModel.Component

Microsoft.AnalysisServices.AdomdClient.AdomdCommand ---- System.Data.IDbCommand, System.ICloneable

Microsoft.AnalysisServices.AdomdClient.AdomdConnection ---- System.Data.IDbConnection, System.ICloneable

System.Data.Common.DataAdapter

System.Data.Common.DbDataAdapter

Microsoft.AnalysisServices.AdomdClient.AdomdDataAdapter ---- System.Data.IDbDataAdapter ---- System.ComponentModel.IComponent ---- System.System.Data.IDataAdapter ---- System.ICloneable ---- System.IDisposable

System.ValueType

Microsoft.AnalysisServices.AdomdClient.AdomdDataReader.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.AdomdErrorCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.AdomdPropertyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.AdomdRestrictionCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.AxisCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.CellCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.CellPropertyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.CubeCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.DimensionCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.HierarchyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.LevelCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.LevelPropertyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.MeasureCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.MemberCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.MemberPropertyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.NamedSetCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.OlapInfoAxisCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.OlapInfoCubeCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.OlapInfoHierarchyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.OlapInfoPropertyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.PositionCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.PropertyCollection.Enumerator ---- System.Collections.IEnumerator

Microsoft.AnalysisServices.AdomdClient.TupleCollection.Enumerator ---- System.Collections.IEnumerator

System.Enum

Microsoft.AnalysisServices.AdomdClient.ConnectionExceptionCause

Microsoft.AnalysisServices.AdomdClient.DimensionTypeEnum

Microsoft.AnalysisServices.AdomdClient.HierarchyOrigin

Microsoft.AnalysisServices.AdomdClient.LevelTypeEnum

Microsoft.AnalysisServices.AdomdClient.MemberFilterType

Microsoft.AnalysisServices.AdomdClient.MemberTypeEnum

Microsoft.AnalysisServices.AdomdClient.SchemaObjectType

See Also

Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCacheExpiredException Class

Represents an exception thrown by ADOMD.NET when a cached version of an ADOMD.NET object is no longer valid.

For a complete list of AdomdCacheExpiredException class members, see AdomdCacheExpiredException Members.

System.Object
System.Exception
Microsoft.AnalysisServices.AdmodClient.AdomdException
Microsoft.AnalysisServices.AdomdClient.AdomdCacheExpiredException

 [Visual Basic]
<Serializable>
Public NotInheritable Class AdomdCacheExpiredException
   Inherits AdomdException
[C#]
[Serializable]
public sealed class AdomdCacheExpiredException : AdomdException
[C++]
[Serializable]
public __gc __sealed class AdomdCacheExpiredException : public AdomdException
[JScript]
public
   Serializable
class AdomdCacheExpiredException extends AdomdException
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdCacheExpiredException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCacheExpiredException Members

AdomdCacheExpiredException Class

Public Properties

public property HelpLink (inherited from System.Exception) | Gets or sets a link to the Help file associated with this exception.
public property InnerException (inherited from System.Exception) | Gets the Exception that caused the current exception.
public property Message (inherited from System.Exception) | Gets a message that describes the current exception.
public property Source (inherited from System.Exception) | Gets or sets the name of the application or object that causes the error.
public property StackTrace (inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetObjectData (inherited from System.Exception) | Overridden. Sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Exception) | Creates and returns a string representation of the current exception.

Protected Properties

protected property HResult (inherited from System.Exception) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdCacheExpiredException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand Class

Represents a command to run against a multidimensional data source.

For a complete list of AdomdCommand class members, see AdomdCommand Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Microsoft.AnalysisServices.AdomdClient.AdomdCommand

[Visual Basic]
NotInheritable Public Class AdomdCommand
   Inherits Component
   Implements IDbCommand, ICloneable
[C#]
public sealed class AdomdCommand : Component, IDbCommand,
   ICloneable
[C++]
public __gc __sealed class AdomdCommand : public Component,
   IDbCommand, ICloneable
[JScript]
public class AdomdCommand extends Component implements IDbCommand,
   ICloneable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand Members

AdomdCommand Class

Public Constructors

public constructor AdomdCommand Constructor Initializes a new AdomdCommand.

Public Properties

public property CommandStream | Gets or sets the command to run, using a Stream.
public property CommandText | Gets or sets the command to run.
public property CommandTimeout | Gets or sets the time to wait for a command to run before terminating the attempt to run the command and generating an error..
public property CommandType | This member is reserved for future use.
public property Connection | Gets or sets the AdomdConnection used by the AdomdCommand.
public property Properties | Gets an AdomdPropertyCollection that contains the properties associated with the AdomdCommand.
public property UpdatedRowSource | This member is reserved for future use.

Public Methods

public method Cancel | Attempts to cancel the execution of the AdomdCommand.
public method Clone | Creates and returns an AdomdCommand based on the current AdomdCommand.
public method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Execute | Runs the command and returns an object.
public method ExecuteCellSet | Runs the AdomdCommand and returns a CellSet.
public method ExecuteNonQuery | Runs the AdomdCommand without returning any results.
public method ExecuteReader | Overloaded. Runs the AdomdCommand and returns an AdomdDataReader.
public method ExecuteScalar | This member is reserved for future use.
public method ExecuteXmlReader | Runs the AdomdCommand and returns an XmlReader.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method Prepare | This member is reserved for future use.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdCommand Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand Constructor

Initializes a new instance of the AdomdCommand class.

Overload List

Initializes a new instance of the AdomdCommand class with default values.

[Visual Basic] Public Sub New()
[C#] public AdomdCommand();
[C++] public: AdomdCommand();
[JScript] public function AdomdCommand();

Initializes a new instance of the AdomdCommand class with the text of the command.

[Visual Basic] Public Sub New(String)
[C#] public AdomdCommand(String);
[C++] public: AdomdCommand(String*);
[JScript] public function AdomdCommand(String);

Initializes a new instance of the AdomdCommand class with the text of the command and an instance of an AdomdConnection.

[Visual Basic] Public Sub New(String, AdomdConnection)
[C#] public AdomdCommand(String, AdomdConnection);
[C++] public: AdomdCommand(String*, AdomdConnection*);
[JScript] public function AdomdCommand(String, AdomdConnection);
See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand Constructor ()

Initializes a new instance of the AdomdCommand class with default values.

[Visual Basic]
Public Sub New()
[C#]
public AdomdCommand();
[C++]
public: AdomdCommand();
[JScript]
public function AdomdCommand();
Remarks

The default constructor initializes any fields to their default values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdCommand Constructor Overload List


AdomdCommand Constructor (String)

Initializes a new instance of the AdomdCommand class with the text of the command.

[Visual Basic]
Public Sub New( _
   ByVal commandText As String
)
[C#]
public AdomdCommand(
   string commandText
);
[C++]
public: AdomdCommand(
   String* commandText

);
[JScript]
public function AdomdCommand(
   commandText : String
);
Arguments [JScript]
commandText
The command to be run by the AdomdCommand.
Parameters [Visual Basic, C#, C++]
commandText
The command to be run by the AdomdCommand.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdCommand Constructor Overload List


AdomdCommand Constructor (String, AdomdConnection)

Initializes a new instance of the AdomdCommand class with the text of the command and an AdomdConnection.

[Visual Basic]
Public Sub New( _
   ByVal commandText As String, ByVal connection As AdomdConnection
)
[C#]
public AdomdCommand(
   string commandText, AdomdConnection connection
);
[C++]
public: AdomdCommand(
   String* commandText, AdomdConnection* connection

);
[JScript]
public function AdomdCommand(
   commandText : String, connection : AdomdConnection
);
Arguments [JScript]
commandText
The command to be run by the AdomdCommand.
connection
The AdomdConnection on which to run the AdomdCommand.
Parameters [Visual Basic, C#, C++]
commandText
The command to be run by the AdomdCommand.
connection
The AdomdConnection on which to run the AdomdCommand.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdCommand Constructor Overload List


AdomdCommand Properties

The properties of the AdomdCommand class are listed here. For a complete list of AdomdCommand class members, see AdomdCommand Members.

Public Properties

public property CommandStream | Gets or sets the command to run, using a Stream.
public property CommandText | Gets or sets the command to run.
public property CommandTimeout | Gets or sets the time to wait for a command to run before terminating the attempt to run the command and generating an error.
public property CommandType | This member is reserved for future use.
public property Connection | Gets or sets the AdomdConnection used by the AdomdCommand.
public property Properties | Gets an AdomdPropertyCollection that contains the properties associated with the AdomdCommand.
public property UpdatedRowSource | This member is reserved for future use.

See Also

AdomdCommand Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.CommandStream Property

Gets or sets the command to run, using a Stream.

[Visual Basic]
Public Property CommandStream As Stream
[C#]
public Stream CommandStream {get; set;}
[C++]
public: __property Stream* get_CommandStream();
public: __property void set_CommandStream(Stream*);
[JScript]
public function get CommandStream() : Stream;
public function set CommandStream(Stream);
Property Value

A Stream that contains the XML-based command for the AdomdCommand.

Exceptions

Exception type | Condition
InvalidOperationException | If the Stream does not support reading, the CanRead property of the Stream is not set to true.

Remarks

You can use either the CommandText property or the CommandStream property to provide a command to be run by the AdomdCommand. If both properties are set, or if neither property is set, an exception is thrown when the AdomdCommand attempts to run the command.

The AdomdCommand assumes that the Stream contains an XML for Analysis compliant command (a command that can be framed by the <Command> tag within an XML for Analysis request).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | CommandText


AdomdCommand.CommandText Property

Gets or sets the command to run.

[Visual Basic]
Public Property CommandText As String  Implements _
   IDbCommand.CommandText
[C#]
public string CommandText {get; set;}
[C++]
public: __property String* get_CommandText();
public: __property void set_CommandText(String*);
[JScript]
public function get CommandText() : String;
public function set CommandText(String);
Property Value

A String that contains the command for the AdomdCommand. The default value is an empty string.

Implements

IDbCommand.CommandText

Remarks

You can use either the CommandText property or the CommandStream property to provide a command to be run by the AdomdCommand. If both properties are set, or if neither property is set, an exception is thrown when the AdomdCommand attempts to run the command.

The CommandText property can take either a Multidimensional Expressions (MDX) command or an XML for Analysis compliant command (a command that can be framed by the <Command> tag within an XML for Analysis request).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | CommandStream


AdomdCommand.CommandTimeout Property

Gets or sets the time to wait for a command to run before terminating the attempt to run the command and generating an error.

 [Visual Basic]
Public Property CommandTimeout As Integer  Implements _
   IDbCommand.CommandTimeout
[C#]
public int CommandTimeout {get; set;}
[C++]
public: __property int get_CommandTimeout();
public: __property void set_CommandTimeout(int);
[JScript]
public function get CommandTimeout() : int;
public function set CommandTimeout(int);
Property Value

An Integer that contains the time, in seconds, to wait for the command to run.

Implements

IDbCommand.CommandTimeout

Exceptions

Exception type | Condition
InvalidOperationException | The property is set to a number less than 0.

Remarks

If this property is set to 0, the AdomdCommand waits indefinitely while attempting to run a command. This setting is not recommended.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.CommandType Property

This member is reserved for future use.

[Visual Basic]
Public Property CommandType As CommandType  Implements _
   IDbCommand.CommandType
[C#]
public CommandType CommandType {get; set;}
[C++]
public: __property CommandType get_CommandType();
public: __property void set_CommandType(CommandType);
[JScript]
public function get CommandType() : CommandType;
public function set CommandType(CommandType);
Implements

IDbCommand.CommandType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Connection Property

Gets or sets the AdomdConnection used by the AdomdCommand.

[Visual Basic]
Public Property Connection As  AdomdConnection
[C#]
public AdomdConnection Connection {get; set;}
[C++]
public: __property AdomdConnection* get_Connection();
public: __property void set_Connection(AdomdConnection*);
[JScript]
public function get Connection() : AdomdConnection;
public function set Connection(AdomdConnection);
Property Value

An AdomdConnection, or a null value if no AdomdConnection is associated with the AdomdCommand. The default value is a null value.

Remarks

Before attempting to run an AdomdCommand, you must set the Connection property to a valid AdomdConnection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Properties Property

Gets an instance of an AdomdPropertyCollection class that contains the properties associated with the AdomdCommand.

[Visual Basic]
Public ReadOnly Property Properties As AdomdPropertyCollection
[C#]
public AdomdPropertyCollection Properties {get;}
[C++]
public: __property AdomdPropertyCollection* get_Properties();
[JScript]
public function get Properties() : AdomdPropertyCollection;
Property Value

An AdomdPropertyCollection that contains the properties associated with the command.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.UpdatedRowSource Property

This member is reserved for future use.

[Visual Basic]
Public Overridable Property UpdatedRowSource As UpdateRowSource  _
   Implements IDbCommand.UpdatedRowSource
[C#]
public virtual UpdateRowSource UpdatedRowSource {get; set;}
[C++]
public: __property virtual UpdateRowSource get_UpdatedRowSource();
public: __property virtual void
   set_UpdatedRowSource(UpdateRowSource);
[JScript]
public function get UpdatedRowSource() : UpdateRowSource;
public function set UpdatedRowSource(UpdateRowSource);
Property Value

An UpdateRowSource enumeration value.

Implements

IDbCommand.UpdatedRowSource

Exceptions

Exception type | Condition
NotSupportedException | The member is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand Methods

The methods of the AdomdCommand class are listed here. For a complete list of AdomdCommand class members, see AdomdCommand Members.

Public Methods

public method Cancel | Attempts to cancel the execution of the AdomdCommand.
public method Clone | Creates and returns an AdomdCommand based on the current AdomdCommand.
public method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Execute | Runs the AdomdCommand and returns an Object.
public method ExecuteCellSet | Runs the AdomdCommand and returns a CellSet.
public method ExecuteNonQuery | Runs the AdomdCommand without returning any results.
public method ExecuteReader | Overloaded. Runs the AdomdCommand and returns an AdomdDataReader.
public method ExecuteScalar | This member is reserved for future use.
public method ExecuteXmlReader | Runs the AdomdCommand and returns an XmlReader.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method Prepare | This member is reserved for future use.
public method ToString (inherited from System.Object) | Gets a String object that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdCommand Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Cancel Method

Attempts to cancel the execution of the AdomdCommand.

[Visual Basic]
Public Sub Cancel() Implements IDbCommand.Cancel
[C#]
public void Cancel();
[C++]
public: void Cancel();
[JScript]
public function Cancel();
Implements

IDbCommand.Cancel

Remarks

If AdomdCommand is not running a command at the time the Cancel method is called, nothing happens. However, if the AdomdCommand is running a command at the time the Cancel method is called, an AdomdErrorResponseException is thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Clone Method

Creates and returns an instance of an AdomdCommand class based on the current AdomdCommand.

[Visual Basic]
Public Function Clone() As AdomdCommand
[C#]
public AdomdCommand Clone();
[C++]
public: AdomdCommand* Clone();
[JScript]
public function Clone() : AdomdCommand;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();
Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Execute Method

Runs the AdomdCommand and returns an Object.

[Visual Basic]
Public Function Execute() As Object
[C#]
public object Execute();
[C++]
public: Object* Execute();
[JScript]
public function Execute() : Object;
Return Value

An Object.

Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

Remarks

The Execute method attempts to run the command contained by the AdomdCommand and, depending on the format of the results returned by the provider, returns either an AdomdDataReader or a CellSet. If the results cannot be formatted into either an AdomdDataReader or a CellSet, or if the provider returned no results, the method returns a null value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.ExecuteCellSet Method

Runs the AdomdCommand and returns a CellSet.

[Visual Basic]
Public Function ExecuteCellSet() As CellSet
[C#]
public CellSet ExecuteCellSet();
[C++]
public: CellSet* ExecuteCellSet();
[JScript]
public function ExecuteCellSet() : CellSet;
Return Value

A CellSet.

Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The return value was not a valid CellSet.
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

Remarks

The ExecuteCellSet method attempts to run the command contained by the AdomdCommand and returns a CellSet that contains the results of the command.

If the provider does not return a valid multidimensional data set, an exception is thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.ExecuteNonQuery Method

Runs the AdomdCommand without returning any results.

[Visual Basic]
Public Overridable Function ExecuteNonQuery() As Integer Implements _
   _
   IDbCommand.ExecuteNonQuery
[C#]
public virtual int ExecuteNonQuery();
[C++]
public: virtual int ExecuteNonQuery();
[JScript]
public function ExecuteNonQuery() : int;
Return Value

A value of 1.

Implements

IDbCommand.ExecuteNonQuery

Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

Remarks

You can use the ExecuteNonQuery method to run commands that typically do not return a CellSet, such as data definition language (DDL) commands or writeback commands.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.ExecuteReader Method

Runs the AdomdCommand and returns an AdomdDataReader.

Overload List

Runs the AdomdCommand and returns an AdomdDataReader.

[Visual Basic] Overloads Public Function ExecuteReader() As AdomdDataReader
[C#] public AdomdDataReader ExecuteReader();
[C++] public: AdomdDataReader* ExecuteReader();
[JScript] public function ExecuteReader() : AdomdDataReader;

Runs the AdomdCommand using the specified CommandBehavior enumeration value and returns an AdomdDataReader.

[Visual Basic] Overloads Public Function ExecuteReader(System.Data.CommandBehavior) As AdomdDataReader
[C#] public AdomdDataReader ExecuteReader(System.Data.CommandBehavior);
[C++] public: AdomdDataReader* ExecuteReader(System.Data.CommandBehavior);
[JScript] public function ExecuteReader(System.Data.CommandBehavior) : AdomdDataReader;
See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.ExecuteReader Method ()

Runs the AdomdCommand and returns an AdomdDataReader.

[Visual Basic]
Public Overloads Function ExecuteReader() As AdomdDataReader
[C#]
public AdomdDataReader ExecuteReader();
[C++]
public: AdomdDataReader* ExecuteReader();
[JScript]
public function ExecuteReader() : AdomdDataReader;
Return Value

An AdomdDataReader.

Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

Remarks

While the AdomdDataReader is in use, the AdomdCommand and the associated AdomdConnection are busy serving the AdomdDataReader. While in this state, the AdomdConnection or AdomdCommand can only be closed; no other operations can be performed on them. This remains the case until the Close or Dispose method of the AdomdDataReader is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdCommand.ExecuteReader Overload List


AdomdCommand.ExecuteReader Method (System.Data.CommandBehavior)

Runs the AdomdCommand using the specified CommandBehavior enumeration value and returns an AdomdDataReader.

[Visual Basic]
Public Overloads Function ExecuteReader( _
   ByVal behavior As CommandBehavior _
) As AdomdDataReader
[C#]
public AdomdDataReader ExecuteReader(
   CommandBehavior behavior
);
[C++]
public: AdomdDataReader* ExecuteReader(
   CommandBehavior behavior
);
[JScript]
public function ExecuteReader(
   behavior : CommandBehavior
) : AdomdDataReader
Parameters
behavior
A CommandBehavior enumeration value that indicates the behavior of the AdomdCommand during or after execution.

Note CommandBehavior.KeyInfo and CommandBehavior.SingleResult are not supported, and are ignored.

Return Value

An AdomdDataReader.

Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

Remarks

While the AdomdDataReader is in use, the associated AdomdConnection is busy serving the AdomdDataReader. While in this state, the AdomdConnection can only be closed; no other operations can be performed on it. This remains the case until the Close or Dispose method of the AdomdDataReader is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdCommand.ExecuteReader Overload List


AdomdCommand.ExecuteScalar Method

This member is reserved for future use.

[Visual Basic]
Public Overridable Function ExecuteScalar() As Object Implements _
   IDbCommand.ExecuteScalar
[C#]
public virtual object ExecuteScalar();
[C++]
public: virtual Object* ExecuteScalar();
[JScript]
public function ExecuteScalar() : Object;
Implements

IDbCommand.ExecuteScalar

Exceptions

Exception type | Condition
NotSupportedException | The member is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.ExecuteXmlReader Method

Runs the AdomdCommand and returns an XmlReader.

[Visual Basic]
Public Function ExecuteXmlReader() As XmlReader
[C#]
public XmlReader ExecuteXmlReader();
[C++]
public: XmlReader* ExecuteXmlReader();
[JScript]
public function ExecuteXmlReader() : XmlReader;
Return Value

An XmlReader that contains the results of the command.

Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

Remarks

This method, instead of translating the XML for Analysis response from an XML format into an AdomdDataReader or CellSet, returns an XmlReader that directly references the XML for Analysis response in its native XML format.

While the XmlReader is in use, the associated AdomdConnection is busy serving the XmlReader. While in this state, the AdomdConnection can only be closed; no other operations can be performed on it. This remains the case until the Close method of the XmlReader is called.

You should be prepared to catch any exception that can be thrown while using the XmlReader, such as the XmlException. For more information about the XmlReader, see XmlReader Class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdCommand.Prepare Method

This member is reserved for future use.

[Visual Basic]
Public Overridable Sub Prepare() Implements IDbCommand.Prepare
[C#]
public virtual void Prepare();
[C++]
public: virtual void Prepare();
[JScript]
public function Prepare();
Implements

IDbCommand.Prepare

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdCommand Class | AdomdCommand Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection Class

Represents a connection to a multidimensional data source.

For a complete list of AdomdConnection class members, see AdomdConnection Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Microsoft.AnalysisServices.AdomdClient.AdomdConnection

[Visual Basic]
Public NotInheritable Class AdomdConnection
   Inherits Component
   Implements IDbConnection, ICloneable
[C#]
public sealed class AdomdConnection : Component, IDbConnection,
   ICloneable
[C++]
public __gc __sealed class AdomdConnection : public Component,
   IDbConnection, ICloneable
[JScript]
public class AdomdConnection extends Component implements
   IDbConnection, ICloneable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The AdomdConnection represents a connection with a multidimensional data source (for example, a connection to an instance of Microsoft SQL Server 2000 Analysis Services.) Each connection is associated with an XML for Analysis session. If an AdomdConnection goes out of scope, the connection is not closed. To close the connection, you must explicitly call the Close or Dispose method of the AdomdConnection. If the Close or Dispose method is not called, the session associated with the AdomdConnection remains active and can be reused by another AdomdConnection. For more information on managing sessions, see SessionID Property.

Example
[Visual Basic]

The following subroutine, given arguments used to build a connection string, attempts to connect to a specified instance of Analysis Services and return an AdomdConnection:

Public Function Connect(Optional ByVal ServerID As String = "localhost", _
    Optional ByVal DatabaseID As String = "", _
    Optional ByVal UserID As String = "", _
    Optional ByVal Password As String = "") As AdomdConnection

    Dim strConnectionString As String
    Dim objConnection As AdomdConnection

    Try
        ' First, build the connection string.
        '
        ' The ConnectionString property consists of

        ' key/value pairs seperated by semicolons.
        ' - The format, as a regular expression, should be:
        ' (<Key>=<Value>)*([[;]/*(<Key>=<Value>)])

        ' The connection string can take "Datasource", "Data Source",
        ' or "Location" for this parameter.
        If ServerID <> "" Then
            strConnectionString &= "Data Source=" & ServerID & ";"
        End If

        ' The connection string can take "Catalog" or "Initial Catalog"
        ' for this parameter.
        If DatabaseID <> "" Then
            strConnectionString &= "Initial Catalog=" & DatabaseID & ";"
        End If

        ' The connection string can take "UID", "User ID",
        ' "Authenticated User", or "UserName" for this parameter.
        If UserID <> "" Then
            strConnectionString &= "User ID=" & UserID & ";"
        End If

        ' The connection string can take "PWD" or "Password"
        ' for this parameter.
        If Password <> "" Then
            strConnectionString &= "Password=" & Password & ";"
        End If

        ' Get a reference to an AdomdConnection object.
        objConnection = New AdomdConnection()

        ' Assign the connection string and attempt to
        ' open a connection.
        objConnection.ConnectionString = strConnectionString
        objConnection.Open()

        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing meta data.
            Debug.WriteLine(ex)
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
    Finally
        Debug.Write("The connection ")
        If objConnection.State = ConnectionState.Open Then
            Debug.WriteLine("is connected!")
        Else
            Debug.WriteLine("failed to connect!")
        End If
    End Try

    ' Return the AdomdConnection object.
    Return objConnection
End Function
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection Members

AdomdConnection Class

Public Constructors

public constructor AdomdConnection Constructor Overloaded. Initializes a new AdomdConnection.

Public Properties

public property ClientVersion | Gets the version of the ADOMD.NET client used by the AdomdConnection.
public property ConnectionString | Gets or sets the string used to open a multidimensional data source.
public property ConnectionTimeout | Gets the time to wait for a connection to be established before terminating the attempt to connect and generating an error..
public property Container (inherited from System.ComponentModel.Component) | Gets an instance of an IContainer object that contains the Component.
public property Cubes | Gets a CubeCollection that represents the collection of cubes contained by a multidimensional data source.
public property Database | Gets the name of the current database to be used after the AdomdConnection is open.
public property ProviderVersion | Gets the version of the XML for Analysis provider used by the AdomdConnection.
public property ServerVersion | Gets the version of the server used by the AdomdConnection.
public property SessionID | Gets or sets the string identifier of the session opened with the server by the AdomdConnection.
public property Site (inherited from System.ComponentModel.Component) | Gets or sets an instance of an ISite object for the Component.
public property State | Gets the current state of the AdomdConnection.

Public Methods

public method BeginTransaction | Begins a new transaction.
public method ChangeDatabase | Changes the current database of the open AdomdConnection.
public method Clone | Creates and returns an AdomdConnection based on the current AdomdConnection.
public method Close | Overloaded. Closes the connection to the database.
public method CreateCommand | Creates and returns an AdomdCommand associated with the AdomdConnection.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from System.ComponentModel.Component) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetSchemaDataSet | Overloaded. Returns schema information from a data source, after applying the specified restrictions.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Open | Opens a connection with a multidimensional data source using the settings specified in the ConnectionString property of the AdomdConnection.
public method ToString (inherited from System.ComponentModel.Component) | Gets a String that represents the current Object.

Public Events

public event Disposed (inherited from System.ComponentModel.Component) Adds an event handler to listen for the Disposed event on the component.

Protected Properties

protected property DesignMode (inherited from System.ComponentModel.Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from System.ComponentModel.Component) | Gets the list of event handlers that are attached to the Component.

Protected Methods

protected method Dispose | Overloaded. Releases the resources used by the Component.
protected method Finalize (inherited from System.ComponentModel.Component) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method GetService (inherited from System.ComponentModel.Component) | Returns an object that represents a service provided by the Component or its Container.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdConnection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection Constructor

Initializes a new instance of the AdomdConnection class.

Overload List

Initializes a new instance of the AdomdConnection class with default values.

[Visual Basic] Public Sub New()
[C#] public AdomdConnection();
[C++] public: AdomdConnection();
[JScript] public function AdomdConnection();

Initializes a new instance of the AdomdConnection class using values from a specified AdomdConnection class.

[Visual Basic] Public Sub New(AdomdConnection)
[C#] public AdomdConnection(AdomdConnection);
[C++] public: AdomdConnection(AdomdConnection*);
[JScript] public function AdomdConnection(AdomdConnection);

Initializes a new instance of the AdomdConnection class using the specified connection string.

[Visual Basic] Public Sub New(System.String)
[C#] public AdomdConnection(System.String);
[C++] public: AdomdConnection(System.String);
[JScript] public function AdomdConnection(System.String);
See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection Constructor ()

Initializes a new instance of the AdomdConnection class with default values.

[Visual Basic]
Public Sub New()
[C#]
public AdomdConnection();
[C++]
public: AdomdConnection();
[JScript]
public function AdomdConnection();
Remarks

The default constructor initializes any fields to their default values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection Constructor Overload List


AdomdConnection Constructor (AdomdConnection)

Initializes a new instance of the AdomdConnection class using values from a specified AdomdConnection class. The session identifier and command state will not be the same.

[Visual Basic]
Public Sub New( _
   ByVal connection As AdomdConnection _
)
[C#]
public AdomdConnection(
   AdomdConnection connection
);
[C++]
public: AdomdConnection(
   AdomdConnection* connection
);
[JScript]
public function AdomdConnection(
   connection : AdomdConnection
);
Arguments [JScript]
connection
An AdomdConnection from which to retrieve connection information.
Parameters [Visual Basic, C#, C++]
connection
An AdomdConnection from which to retrieve connection information.
Remarks

This constructor uses the AdomdConnection to create a new AdomdConnection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection Constructor Overload List


AdomdConnection Constructor (System.String)

Initializes a new instance of the AdomdConnection class using the specified connection string.

[Visual Basic]
Public Sub New( _
   ByVal connectionString As String _
)
[C#]
public AdomdConnection(
   string connectionString
);
[C++]
public: AdomdConnection(
   String connectionString
);
[JScript]
public function AdomdConnection(
   connectionString : String
);
Arguments [JScript]
connectionString
A String that contains the connection string to be used by the AdomdConnection.
Parameters [Visual Basic, C#, C++]
connectionString
A String that contains the connection string to be used by the AdomdConnection.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection Constructor Overload List


AdomdConnection Properties

The properties of the AdomdConnection class are listed here. For a complete list of AdomdConnection class members, see AdomdConnection Members.

Public Properties

public property ClientVersion | Gets the version of the ADOMD.NET client that implements the AdomdConnection.
public property ConnectionString | Gets or sets the string used to open a multidimensional data source.
public property ConnectionTimeout | Gets the time to wait for a connection to be established before terminating the attempt to connect and generating an error..
public property Container (inherited from System.ComponentModel.Component) | Gets an instance of an IContainer object that contains the Component.
public property Cubes | Gets a CubeCollection that represents the collection of cubes contained by a multidimensional data source.
public property Database | Gets the name of the database to be used after the AdomdConnection is open.
public property ProviderVersion | Gets the version of the XML for Analysis provider used by the AdomdConnection.
public property ServerVersion | Gets the version of the server used by the AdomdConnection.
public property SessionID | Gets or sets the string identifier of the session opened with the server by the AdomdConnection.
public property Site (inherited from System.ComponentModel.Component) | Gets or sets an ISite object for the Component.
public property State | Gets the current state of the AdomdConnection.

Protected Properties

protected property DesignMode (inherited from System.ComponentModel.Component) | Gets a value that indicates whether the Component is currently in design mode.
protected property Events (inherited from System.ComponentModel.Component) | Gets the list of event handlers that are attached to the Component.

See Also

AdomdConnection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.ClientVersion Property

Gets the version of the ADOMD.NET client that implements the AdomdConnection.

[Visual Basic]
Public ReadOnly Property ClientVersion As String
[C#]
public string ClientVersion {get;}
[C++]
public: __property String* get_ClientVersion();
[JScript]
public function get ClientVersion() : String;
Property Value

A String that contains the version of the client.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.ConnectionString Property

Gets or sets the string used to open a multidimensional data source.

[Visual Basic]
Public Overridable Property ConnectionString As String  Implements _
   IDbConnection.ConnectionString
[C#]
public virtual string ConnectionString {get; set;}
[C++]
public: __property virtual String* get_ConnectionString();
public: __property virtual void set_ConnectionString(String*);
[JScript]
public function get ConnectionString() : String;
public function set ConnectionString(String);
Property Value

A String that contains the connection string used by the AdomdConnection.

Implements

IDbConnection.ConnectionString

Remarks

The ConnectionString property is designed to match the OLE DB connection string format as closely as possible. You can use the ConnectionString property to connect to a multidimensional data source that supports the XML for Analysis 1.1 specification.

Many of the connection string values have corresponding read-only properties. When the connection string is set, all of these properties are updated, except when an error is detected. Detection of an error prevents all properties from being updated.

Resetting the ConnectionString on a closed connection resets all connection string values (and related properties), including the password. For example, if you set a connection string that includes Catalog= AdventureWorksAS, and then reset the connection string to DataSource=localhost;Password=MyPassword, the Database property is no longer set to the AdventureWorksAS database. (The Catalog setting of the connection string corresponds to the Database property.)

A preliminary validation of the connection string is performed when the property is set. When an application calls the Open method, the connection string is parsed and individual properties are evaluated based on their level of support. If the AdomdConnection directly supports a property provided in the connection string, the value for that property is validated. If the value is not valid or is unsupported, an exception is thrown. If the property is not directly supported by the AdomdConnection, but the property can be used to construct a valid XML element, the property and its value are passed directly to the underlying provider. If such a property contains a value that is not valid or is unsupported, an exception is thrown at that time.

Values can be delimited by single or double quotes (for example, name='value' or name="value"). Either single or double quotes may be used within a connection string by using the other delimiter (for example, name="value's" or name= 'value"s', but not name='value's' or name= ""value""). All blank characters are ignored, except those placed within a value or within quotes. Keyword value pairs must be separated by a semicolon (;). If a semicolon is part of a value, it also must be delimited by quotes. No escape sequences are supported. The value type is irrelevant. Names are not case sensitive. If a property name occurs more than once in the connection string, the value associated with the last occurrence is used.

Caution In this release, the application should use caution when constructing a connection string based on user input (for example, when retrieving user ID and password information from a dialog box, and appending it to the connection string). The application should ensure that a user cannot embed extra connection string parameters in these values (for example, entering a password as validpassword;database=somedb in an attempt to connect to a different database).

The following table describes the connection string settings directly supported by the AdomdConnection. Provider-specific connection strings settings may also be set, but are not listed here.

Setting name | Setting aliases | Description
Timeout | None | Sets the time to wait for a command to run before terminating the attempt to run the command and generating an error.
Connection Timeout | None | Sets the time to wait for a connection to be established before terminating the attempt to connect and generating an error.
Data Source DataSource
Location 		Sets the instance or local cube (.cub) file to which the AdomdConnection establishes a connection.
UserName Authenticated User
UID
User ID 		Sets the user ID or name used by the AdomdConnection to establish a connection.
Password | PWD | Sets the password used by the AdomdConnection to establish a connection with the specified user name.
Catalog | Initial Catalog | Sets the database to which the AdomdConnection establishes a connection.
ProtectionLevel Protection Level Sets the level of protection used by the provider to sign or encrypt the connection. The available settings are:
  • NONE Performs no authentication of data sent to the server
  • CONNECT Authenticates only when the client establishes the connection with the server.
  • PKT INTEGRITY Authenticates that all data received is from the client and that it has not been changed in transit.
  • PKT PRIVACY Encrypts the data and authenticates that the data is received from the client and that it has not been changed in transit.
Safety Options | Safety Options | Sets the safety level used to determine how security for user-defined functions and actions is handled.
AutoSyncPeriod | Auto Synch Period | Sets the time, in milliseconds, that elapses before objects automatically synchronize with the server.
ConnectTo | None | Sets the method used to connect to the server. If set to 8.0, the connection uses in-process XML for Analysis to connect to the server. If set to 9.0, the connection uses XML for Analysis. If set to Default, the connection first tries XML for Analysis, and then attempts to use in-process XML for Analysis.
Provider | None | Sets the name of the provider for the data source. The default value is MSOLAP.
DataSourceInfo | None | Sets the provider-specific information required to access the data source.
Integrated Security | None | Sets the control access to use. If set to SSPI, an SSPI supported security package is used for user authentication. If set to Basic, the UserName and Password settings is required. An HTTP connection can use only the setting of Basic.
CreateCube | None | Sets the CREATE CUBE statement that is used during creation of a local cube.
Protocol Format | None | Sets the format of the XML sent to the server. Settings can be Default, XML, or Binary.
Encryption Password | None | Sets the password used to decrypt local cubes.
Impersonation Level | None | Sets the level of impersonation that the server is allowed to use when impersonating the client. The available settings are Anonymous, Identify, Impersonate, and Delegate. The default is Impersonate. For more information, see the DBPROP_INIT_IMPERSONATION_LEVEL topic in the OLE DB Programmer's Reference.
SSPI | None | Sets the security package to use for user authentication. Available settings include Negotiate, Kerberos, NTLM, and Anonymous User. The default is Negotiate.
UseExistingFile | None | Sets whether to use or overwrite the existing file. If set to True, the local file must already exist, and the cube is either created if the cube does not exist, or used if the cube does exist. If set to False, the existing local cube is overwritten. The default is False.
Character Encoding | None | Sets how characters are encoded. The default is the string UTF-8.
Use Encryption for Data | None | Sets whether encryption is used between the client and server. If set to True, all data sent between the client and server is encrypted with SSL encryption, provided that the server has a certificate installed.
Packet Size | None | Sets the packet size, in bytes, of network communications between client and server. The value must between 512 and 32767. The default is 4096.
Extended Properties | None | Sets the connection string properties that are to override the connection string in which Extended Properties is contained. This property is itself a connection string, the properties of which override the connection string in which Extended Properties is contained. Extended Properties can contain another Extended Properties, the properties of which maintain precedence. Extended Properties supports unlimited nesting.

Several connection string settings map to a corresponding property in the AdomdConnection. The following table lists the connection string settings their corresponding AdomdConnection property.

Setting name | Property name
ConnectionTimeout | ConnectionTimeout
Catalog | Database

Connecting to Local Cube Files

To connect to an existing local cube file, you must provide the full path and file name of a valid local cube file in the Data Source connection string setting and, if applicable, a valid password in the Password connection string setting. If the local cube file does not already exist, a new local cube file is created and protected by the password, provided that a password was specified. If a local cube is to be created, additional settings must be specified in the connection string, such as INSERTINTO or CREATECUBE.

Setting Safety Options

The value of the Safety Options property determines whether unsafe libraries can be registered and loaded by Microsoft PivotTable® Service or the server. If an attempt is made to load an unsafe library or reference an unsafe user-defined function while safety checking is enabled, then PivotTable Service returns the following error:

User defined function <function name> cannot be used, because the class that implements it is not safe for initialization or scripting, which is required by client settings.

The value of the Safety Options property determines whether the PASSTHROUGH keyword is allowed in local cubes. If a client application attempts to create a local cube with an INSERT INTO statement that contains the PASSTHROUGH keyword, or if a client application attempts to refresh a local cube that contains an INSERT INTO statement that uses the PASSTHROUGH keyword, an error is raised.

The following table lists the possible values for the Safety Options property.

Value Description
0 For connections to a local cube, or by an Internet Information Services (IIS) server, this value is the same as DBPROPVAL_MSMD_SAFETY_OPTIONS_ALLOW_SAFE.

For all other connections, this value is the same as DBPROPVAL_MSMD_SAFETY_OPTIONS_ALLOW_ALL.
1 This value enables all user-defined function libraries without verifying that the libraries are safe for initialization and scripting, and also allows usage of the PASSTHROUGH keyword in local cubes.

MDSCHEMA_ACTIONS results are unfiltered.

Security Note This option is not recommended.
2 This value ensures that all classes for a particular user-defined function library are checked to ensure that they are safe for initialization and scripting, and also prevents usage of the PASSTHROUGH keyword in local cubes.

MDSCHEMA_ACTIONS results of type HTML and command line are filtered out. MDSCHEMA_ACTIONS results of type URL are filtered out unless the CONTENT column begins with HTTP:// or HTTPS://.
3 This value prevents user-defined functions from being used during the session and prevents usage of the PASSTHROUGH keyword in local cubes.

MDSCHEMA_ACTIONS results are empty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.ConnectionTimeout Property

Gets the time to wait for a connection to be established before terminating the attempt to connect and generating an error.

[Visual Basic]
Public Overridable ReadOnly Property ConnectionTimeout As Integer  _
   Implements IDbConnection.ConnectionTimeout
[C#]
public virtual int ConnectionTimeout {get;}
[C++]
public: __property virtual int get_ConnectionTimeout();
[JScript]
public function get ConnectionTimeout() : int;
Property Value

An Integer that contains the time (in seconds) to wait while trying to establish a connection. The default is 0 (infinite).

Implements

IDbConnection.ConnectionTimeout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Cubes Property

Gets an instance of a CubeCollection that represents the collection of cubes contained by a multidimensional data source.

[Visual Basic]
Public ReadOnly Property Cubes As CubeCollection
[C#]
public CubeCollection Cubes {get;}
[C++]
public: __property CubeCollection* get_Cubes();
[JScript]
public function get Cubes() : CubeCollection;
Property Value

A CubeCollection that contains the cubes for a multidimensional data source.

Exceptions

Exception type | Condition
AdomdCacheExpiredException | The cubes were changed on the server after the connection was established.

Remarks

OLAP administrators will be able to view dimension cubes, as well as regular cubes, which allows administrators to browse dimension structure and members for dimensions that do not belong to a cube. The name of the dimensions will start with the character $.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Database Property

Gets the name of the database to be used after the AdomdConnection is open.

[Visual Basic]
Public Overridable ReadOnly Property Database As String   _
   Implements IDbConnection.Database
[C#]
public virtual string Database {get;}
[C++]
public: __property virtual String* get_Database();
[JScript]
public function get Database() : String;
Property Value

A String that contains the name of the database used by the AdomdConnection.

Implements

IDbConnection.Database

Remarks

If the State property of the AdomdConnection has a value of ConnectionState.Open, the value for this property is retrieved from the provider for the current database. Otherwise, the value for this property is taken from the Catalog connection string setting of the ConnectionString property. To change this property, you must use the ChangeDatabase method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.ProviderVersion Property

Gets the version of the XML for Analysis provider used by the AdomdConnection.

[Visual Basic]
Public ReadOnly Property ProviderVersion As String
[C#]
public string ProviderVersion {get;}
[C++]
public: __property String* get_ProviderVersion();
[JScript]
public function get ProviderVersion() : String;
Property Value

A String that contains the version of the provider.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.ServerVersion Property

Gets the version of the server used by the AdomdConnection.

[Visual Basic]
Public ReadOnly Property ServerVersion As String
[C#]
public string ServerVersion {get;}
[C++]
public: __property String* get_ServerVersion();
[JScript]
public function get ServerVersion() : String;
Property Value

A String that contains the version of the server.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.SessionID Property

Gets or sets the string identifier of the session opened with the server by the AdomdConnection.

[Visual Basic]
Public Property SessionID As String
[C#]
public string SessionID {get; set;}
[C++]
public: __property String* get_SessionID();
public: __property void set_SessionID(String*);
[JScript]
public function get SessionID() : String;
public function set SessionID(String);
Property Value

A String that contains a string identifier that represents the unique ID of a session.

Exceptions

Exception type | Condition
InvalidOperationException | The session ID was set after the connection was opened.

Remarks

The value of this property can only be set before the connection is opened.

Each session has a unique ID for connection purposes. You can use this property, along with the Open and Close methods, to pool sessions. Because an AdomdConnection can be destroyed without destroying the session, the session ID can be used to maintain state by reconnecting to a specific active session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.State Property

Gets the current state of the AdomdConnection.

[Visual Basic]
Public Overridable ReadOnly Property State As ConnectionState  _
   Implements IDbConnection.State
[C#]
public virtual ConnectionState State {get;}
[C++]
public: __property virtual ConnectionState get_State();
[JScript]
public function get State() : ConnectionState;
Property Value

A ConnectionState enumeration value that represents the current connection state of the AdomdConnection.

Implements

IDbConnection.State

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection Methods

The methods of the AdomdConnection class are listed here. For a complete list of AdomdConnection class members, see AdomdConnection Members.

Public Methods

public method BeginTransaction | Begins a new transaction.
public method ChangeDatabase | Changes the current database of the open AdomdConnection.
public method Clone | Creates and returns an AdomdConnection based on the current AdomdConnection.
public method Close | Overloaded. Closes the connection to the database.
public method CreateCommand | Creates and returns an AdomdCommand associated with the AdomdConnection.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose (inherited from System.ComponentModel.Component) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetSchemaDataSet | Overloaded. Returns schema information from a data source, after applying the specified restrictions.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method Open | Opens a connection with a multidimensional data source using the settings specified in the ConnectionString property of the AdomdConnection.
public method ToString (inherited from System.ComponentModel.Component) | Gets a String that represents the current Object.

Protected Methods

protected method Dispose | Overloaded. Releases the resources used by the Component.
protected method Finalize (inherited from System.ComponentModel.Component) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method GetService (inherited from System.ComponentModel.Component) | Returns an object that represents a service provided by the Component or its Container.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdConnection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.BeginTransaction Method

Begins a new transaction.

Overload List

Begins a new transaction.

[Visual Basic] Overloads Public Function BeginTransaction() As AdomdTransaction
[C#] public AdomdTransaction BeginTransaction();
[C++] public: AdomdTransaction* BeginTransaction();
[JScript] public function BeginTransaction() : AdomdTransaction;

Begins a new transaction with the specified IsolationLevel enumeration value.

[Visual Basic] Overloads Public Function BeginTransaction(System.Data.IsolationLevel) As AdomdTransaction
[C#] public AdomdTransaction BeginTransaction(System.Data.IsolationLevel);
[C++] public: AdomdTransaction* BeginTransaction(System.Data.IsolationLevel);
[JScript] public function BeginTransaction(System.Data.IsolationLevel) : AdomdTransaction;
See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.BeginTransaction Method ()

Begins a new transaction.

[Visual Basic]
Public Overloads Function BeginTransaction() As AdomdTransaction
[C#]
public AdomdTransaction BeginTransaction();
[C++]
public: AdomdTransaction* BeginTransaction();
[JScript]
public function BeginTransaction() : AdomdTransaction;
Return Value

An AdomdTransaction that represents the newly started transaction.

Remarks

Once the transaction has completed, you must explicitly commit the transaction by using the Commit method or roll back the transaction by using the Rollback method of the AdomdTransaction.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection.BeginTransaction Overload List


AdomdConnection.IDbConnection.BeginTransaction Method (System.Data.IsolationLevel)

 ADOMD.NET SDK

AdomdConnection.BeginTransaction Method (System.Data.IsolationLevel)

Begins a new transaction with the specified IsolationLevel enumeration value.

Note Only IsolationLevel.ReadCommitted is supported.

[Visual Basic]
Public Overloads Function BeginTransaction( _
   ByVal isolationLevel As IsolationLevel _
) As AdomdTransaction
[C#]
public AdomdTransaction BeginTransaction(
   IsolationLevel isolationLevel
);
[C++]
public: AdomdTransaction* BeginTransaction(
   IsolationLevel isolationLevel
);
[JScript]
public function BeginTransaction(
   isolationLevel : IsolationLevel
) : AdomdTransaction;
ClassTopic;
Arguments [JScript]
isolationLevel
An IsolationLevel enumeration value.
Parameters [Visual Basic, C#, C++]
isolationLevel
An IsolationLevel enumeration value.
Return Value

An AdomdTransaction that represents the newly started transaction.

Remarks

Once the transaction has completed, you must explicitly commit the transaction by using the Commit method or roll back the transaction by using the Rollback method of the AdomdTransaction. Only IsolationLevel.ReadCommitted is supported.

Exceptions

Exception type | Condition
NotSupportedException | The member was called with an unsupported isolation level.
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException An error occurred because one of the following conditions was met:
  • The connection was not set.
  • The connection was not opened.
  • Either the CommandText property or the CommandStream property was improperly set.
  • Both the CommandText property and the CommandStream property were set.
  • Neither the CommandText property nor the CommandStream property was set.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection.BeginTransaction Overload List


AdomdConnection.ChangeDatabase Method

Changes the current database of the open AdomdConnection.

[Visual Basic]
Public Overridable Sub ChangeDatabase( _
   ByVal database As String _
) Implements IDbConnection.ChangeDatabase
[C#]
public virtual void ChangeDatabase(
   string database
);
[C++]
public: virtual void ChangeDatabase(
   String* database
);
[JScript]
public function ChangeDatabase(
   database : String
);
Arguments [JScript]
database
The name of the database to which the AdomdConnection should connect.
Parameters [Visual Basic, C#, C++]
database
The name of the database to which the AdomdConnection should connect.
Implements

IDbConnection.ChangeDatabase

Exceptions

Exception type | Condition
InvalidOperationException | The database parameter is set to a null value, an empty string, or a string containing only spaces. The AdomdConnection is not connected to a valid session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Clone Method

Creates and returns an instance of an AdomdConnection based on the current AdomdConnection. Session ID and state will not be cloned.

[Visual Basic]
Public Function Clone() As AdomdConnection
[C#]
public AdomdConnection Clone();
[C++]
public: AdomdConnection* Clone();
[JScript]
public function Clone() : AdomdConnection;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Close Method

Closes the connection to the database.

Overload List

Closes the connection to the database and ends the session.

[Visual Basic] Public Overloads Overridable Sub Close() Implements IDbConnection.Close
[C#] public virtual new void Close();
[C++] public: virtual void Close();
[JScript] public function Close();

Closes the connection to the database, indicating whether to end the session.

[Visual Basic] Public Overloads Sub Close(System.Boolean)
[C#] public void Close(System.Boolean);
[C++] public: void Close(System.Boolean);
[JScript] public function Close(System.Boolean);
See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Close Method ()

Closes the connection to the database and ends the session.

[Visual Basic]
Public Overloads Overridable Sub Close() Implements _
   IDbConnection.Close
[C#]
public virtual new void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();
Implements

IDbConnection.Close

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection.Close Overload List


AdomdConnection.Close Method (System.Boolean)

Closes the connection to the database, indicating whether to end the session.

[Visual Basic]
Public Overloads Sub Close( _
   ByVal endSession As Boolean _
)
[C#]
public void Close(
   bool endSession
);
[C++]
public: void Close(
   bool endSession
);
[JScript]
public function Close(
   endSession : Boolean
);
Arguments [JScript]
endSession
A Boolean that indicates whether to end the session associated with the AdomdConnection.
Parameters [Visual Basic, C#, C++]
endSession
A Boolean that indicates whether to end the session associated with the AdomdConnection.
Remarks

If the Close method is called without specifying the value of the endSession parameter, or if the endSession parameter is set to true, then both the connection and the session associated with the connection is closed. If the Close method is called with the endSession parameter set to false, the session associated with the AdomdConnection remains active, but the connection is closed.

If the Dispose method is called with the disposing parameter set to true, the Close method is called without specifying the value of the endSession parameter.

You can reconnect to an active session after calling this method by setting the SessionID property to a valid active session ID and then calling the Open method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection.Close Overload List


AdomdConnection.CreateCommand Method

Creates and returns an AdomdCommand associated with the AdomdConnection.

[Visual Basic]
Public Function CreateCommand() As AdomdCommand _
[C#]
public AdomdCommand CreateCommand();
[C++]
public: AdomdCommand* CreateCommand();
[JScript]
public function CreateCommand() : AdomdCommand;
Return Value

An AdomdCommand associated with the connection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Releases unmanaged resources used by the AdomdConnection and optionally releases the managed resources.

[Visual Basic] Protected Overloads Overrides Sub Dispose(System.Boolean)
[C#] protected override void Dispose(System.Boolean);
[C++] protected: void Dispose(System.Boolean);
[JScript] protected override function Dispose(System.Boolean);

Inherited from System.ComponentModel.Component.

[Visual Basic] Public Overloads Overridable Sub Dispose() Implements IDisposable.Dispose
[C#] public virtual void Dispose();
[C++] public: virtual void Dispose();
[JScript] public function Dispose();
See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Dispose Method (System.Boolean)

Releases unmanaged resources used by the AdomdConnection and optionally releases the managed resources.

[Visual Basic]
Protected Overrides Overloads Sub Dispose() Implements IDisposable.Dispose
[C#]
protected override void Dispose();
[C++]
protected: void Dispose(
);
[JScript]
protected override function Dispose(
);
Arguments [JScript]
disposing
A Boolean that, if set to true, indicates that the managed resources should be released.
Parameters [Visual Basic, C#, C++]
disposing
A Boolean that, if set to true, indicates that the managed resources should be released.
Remarks

When disposing is set to true, this method releases all resources held by any managed objects referenced by the AdomdConnection. This method invokes the Dispose method for each referenced managed object.

This method is called by the Close method with disposing set to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdConnection.Dispose Overload List


AdomdConnection.GetSchemaDataSet Method

Returns schema information from a data source.

Overload List

Returns schema information from a data source as indicated by a GUID, after applying the specified restrictions.

[Visual Basic] Overloads Public Function GetSchemaDataSet(System.Guid, System.Object()) As DataSet
[C#] public DataSet GetSchemaDataSet(System.Guid, System.Object[]);
[C++] public: DataSet* GetSchemaDataSet(System.Guid, System.Object[]);
[JScript] public function GetSchemaDataSet(System.Guid, System.Object[]) : DataSet;

Returns schema information from a data source as indicated by a schema name, after applying the specified restrictions.

[Visual Basic] Overloads Public Function GetSchemaDataSet(System.String, AdomdRestrictionCollection) As DataSet
[C#] public DataSet GetSchemaDataSet(System.String, AdomdRestrictionCollection);
[C++] public: DataSet* GetSchemaDataSet(System.String, AdomdRestrictionCollection*);
[JScript] public function GetSchemaDataSet(System.String, AdomdRestrictionCollection) : DataSet;

Returns schema information from a data source as indicated by a schema name and namespace, after applying the specified restrictions.

[Visual Basic] Overloads Public Function GetSchemaDataSet(System.String, System.String, AdomdRestrictionCollection) As DataSet
[C#] public DataSet GetSchemaDataSet(System.String, System.String, AdomdRestrictionCollection);
[C++] public: DataSet* GetSchemaDataSet(System.String, System.String, AdomdRestrictionCollection*);
[JScript] public function GetSchemaDataSet(System.String, System.String, AdomdRestrictionCollection) : DataSet;
See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.GetSchemaDataSet Method (System.String, AdomdRestrictionCollection)

Returns schema information from a data source as indicated by a schema name, after applying the specified restrictions.

[Visual Basic]
Public Function GetSchemaDataSet( _
   ByVal schemaName As String, _
   ByVal restrictions() As AdomdRestrictionCollection _
) As DataSet
[C#]
public DataSet GetSchemaDataSet(
   string schemaName ,
   AdomdRestrictionCollection[] restrictions
);
[C++]
public: DataSet* GetSchemaDataSet(
   String * schemaName ,
   AdomdRestrictionCollection* restrictions __gc[]
);
[JScript]
public function GetSchemaDataSet(
   schemaName: String,
   restrictions : AdomdRestrictionCollection[]
) : DataSet;
Arguments [JScript]
schemaName
The name of the schema to retrieve.
restrictions
A collection of AdomdRestriction objects that specifies the values for the restriction columns used by the schema table.
Parameters [Visual Basic, C#, C++]
schemaName
The name of the schema to retrieve.
restrictions
A collection of AdomdRestriction objects that specifies the values for the restriction columns used by the schema table.
Return Value

A DataSet that represents the contents of the specified OLE DB schema table.

Remarks

The schema table is returned as a DataSet that has the same format as the OLE DB schema rowset specified by the parameter schema parameter. Use the restrictions parameter to filter the rows to be returned in the DataSet (for example, by specifying cube name and dimension name restrictions for the dimensions schema)..

Note If the schema contains nested rowsets, more tables may be returned in the DataSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.GetSchemaDataSet Method (System.String, System.String, AdomdRestrictionCollection)

Returns schema information from a data source as indicated by a schema name and namespace, after applying the specified restrictions.

[Visual Basic]
Public Function GetSchemaDataSet( _
   ByVal schemaName As String, _
   ByVal schemaNameSpace As String, _
   ByVal restrictions() As AdomdRestrictionCollection _
) As DataSet
[C#]
public DataSet GetSchemaDataSet(
   string schemaName ,
   string schemaNamespace ,
   AdomdRestrictionCollection[] restrictions
);
[C++]
public: DataSet* GetSchemaDataSet(
   String * schemaName ,
   String * schemaNameSpace ,
   AdomdRestrictionCollection* restrictions __gc[]
);
[JScript]
public function GetSchemaDataSet(
   schemaName: String,
   schemaNameSpace: String,
   restrictions : AdomdRestrictionCollection[]
) : DataSet;
Arguments [JScript]
schemaName
The name of the schema to retrieve.
schemaNamespace
The name of the schema namespace to retrieve.
restrictions
A collection of AdomdRestriction restrictions that specifies the values for the restriction columns used by the schema table.
Parameters [Visual Basic, C#, C++]
schemaName
The name of the schema to retrieve.
schemaNamespace
The name of the schema namespace to retrieve.
restrictions
A collection of AdomdRestriction objects that specifies the values for the restriction columns used by the schema table.
Return Value

A DataSet that represents the contents of the specified OLE DB schema table.

Remarks

The schema table is returned as a DataSet that has the same format as the OLE DB schema rowset specified by the schema parameter. Use the restrictions parameter to filter the rows to be returned in the DataSet (for example, by specifying restrictions for table name, type, owner, or schema).

Note If the schema contains nested rowsets, more tables may be returned in the DataSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.GetSchemaDataSet Method (Guid, Object[])

Returns schema information from a data source as indicated by a GUID, after applying the specified restrictions.

[Visual Basic]
Public Function GetSchemaDataSet( _
   ByVal schema As Guid, _
   ByVal restrictions() As Object _
) As DataSet
[C#]
public DataSet GetSchemaDataSet(
   Guid schema,
   object[] restrictions
);
[C++]
public: DataSet* GetSchemaDataSet(
   Guid schema,
   Object* restrictions __gc[]
);
[JScript]
public function GetSchemaDataSet(
   schema : Guid,
   restrictions : Object[]
) : DataSet;
Arguments [JScript]
schema
A Guid that specifies the schema table to return.
restrictions
An array of Object objects that specifies the values for the restriction columns used by the schema table. These are applied in the order of the restriction columns. That is, the first restriction value applies to the first restriction column, the second restriction value applies to the second restriction column, and so on.
Parameters [Visual Basic, C#, C++]
schema
A Guid object that specifies the schema table to return.
restrictions
An array of Object objects that specifies the values for the restriction columns used by the schema table. These are applied in the order of the restriction columns. That is, the first restriction value applies to the first restriction column, the second restriction value applies to the second restriction column, and so on.
Return Value

A DataSet that represents the contents of the specified OLE DB schema rowset.

Remarks

The schema rowset is returned as a DataSet that has the same format as the OLE DB schema rowset specified by the schema parameter. Use the restrictions parameter to filter the rows to be returned in the DataSet (for example, by specifying restrictions for table name, type, owner, or schema). When you pass values in the array, include empty strings or nulls for array elements that do not contain values. If you pass an empty array to restrictions, all rows are returned in default order. Values in the array correspond to the order of the columns in the OLEDB or OLEDB for OLAP specifications.

If a Guid is provided that is not associated with a schema rowset, or if the schema rowset associated with the provided Guid is not supported by the server, the InvalidOperationException exception is thrown. Similarly, an exception is thrown if an error occurs while retrieving the schema rowset from the provider.

The AdomdSchemaGuid contains a collection of Guid objects that represents the most commonly supported OLE DB and XML for Analysis schema rowsets. For more information about the AdomdSchemaGuid, see AdomdSchemaGuid.

Note If the schema contains nested rowsets, more tables may be returned in the DataSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnection.Open Method

Opens a connection with a multidimensional data source using the settings specified in the ConnectionString property of the AdomdConnection.

[Visual Basic]
Public Overridable Sub Open() Implements IDbConnection.Open
[C#]
public virtual void Open();
[C++]
public: virtual void Open();
[JScript]
public function Open();
Implements

IDbConnection.Open

Remarks

The Open method establishes a connection to a multidimensional data source. If the SessionID property is set to a valid active session ID, the Open method uses the specified session. Otherwise, the Open method requests a new session before connecting.

If the Catalog connection string setting in the ConnectionString property specifies a local cube (.cub) file, a local connection is opened using the local cube file.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnection Class | AdomdConnection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnectionException Class

Represents an exception thrown by ADOMD.NET when the connection could not be opened or was disconnected.

For a complete list of AdomdConnectionException class members, see AdomdConnectionException Members.

System.Object
System.Exception
Microsoft.AnalysisServices.AdmodClient.AdomdException
Microsoft.AnalysisServices.AdomdClient.AdomdConnectionException

[Visual Basic]
<Serializable>
Public NotInheritable Class AdomdConnectionException
   Inherits AdomdException
[C#]
[Serializable]
public sealed class AdomdConnectionException : AdomdException
[C++]
[Serializable]
public __gc __sealed class AdomdConnectionException : public AdomdException
[JScript]
public
   Serializable
class AdomdConnectionException extends AdomdException
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdConnectionException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnectionException Members

AdomdConnectionException Class

Public Properties

public property ErrorCode (inherited from AdomdException) | Gets the value of the ErrorCode property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property Errors (inherited from AdomdException) | Gets a reference to the AdomdErrorCollection contained by the AdomdConnectionException.
public property ExceptionCause | Gets the cause of the exception.
public property HelpLink (inherited from AdomdException) | Gets the value of the HelpLink property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property InnerException (inherited from AdomdException) | Gets the Exception that caused the current exception.
public property Message (inherited from AdomdException) | Gets the value of the Message property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property Source (inherited from AdomdException) | Gets the value of the Source property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property StackTrace (inherited from AdomdException) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from AdomdException) | Gets the name of the method that threw the current exception.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from AdomdException) | When overridden in a derived class, returns an Exception that represents the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetObjectData (inherited from System.Exception) | Sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from AdomdException) | Creates and returns a string representation of the current exception.

Protected Properties

protected property HResult (inherited from AdomdException) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdConnectionException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnectionException Properties

The properties of the AdomdConnectionException class are listed here. For a complete list of AdomdConnectionException class members, see AdomdConnectionException Members.

Public Properties

public property ExceptionCause | Gets the cause of the exception.
public property HelpLink (inherited from System.Exception) | Gets or sets a link to the Help file associated with this exception.
public property InnerException (inherited from System.Exception) | Gets the Exception that caused the current exception.
public property Message (inherited from System.Exception) | Gets a message that describes the current exception.
public property Source (inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
public property StackTrace (inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from System.Exception) | Gets the method that throws the current exception.

Protected Properties

protected property HResult (inherited from System.Exception) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

See Also

AdomdConnectionException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnectionException.ExceptionCause Property

Gets the cause of the exception.

[Visual Basic]
Public ReadOnly Property ExceptionCause As ConnectionExceptionCause
[C#]
public ConnectionExceptionCause ExceptionCause {get;}
[C++]
public: __property ConnectionExceptionCause * get_ExceptionCause();
[JScript]
public function get ExceptionCause() : ConnectionExceptionCause;
Property Value

An enumerator representing the possible reasons that can cause AdomdConnectionException to be raised. Possible values are ConnectionExceptionCause.Unspecified and ConnectionExceptionCause.AuthenticationFailed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

ConnectionExceptionCause Enumeration | AdomdConnectionException Class | AdomdConnectionException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnectionException Methods

The methods of the AdomdConnectionException class are listed here. For a complete list of AdomdConnectionException class members, see AdomdConnectionException Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetObjectData (inherited from System.Exception) | Overridden. Sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Exception) | Creates and returns a string representation of the current exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdConnectionException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdConnectionException.GetObjectData Method

Sets the specified SerializationInfo with information about the exception.

[Visual Basic]
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext)
[C#]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
);
[C++]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Parameters
info
A SerializationInfo that holds the serialized object data about the exception being thrown.
context
A StreamingContext that contains contextual information about the source or destination.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdConnectionException Class | AdomdConnectionException Members | Microsoft.AnalysisServices.AdomdClient Namespace


ConnectionExceptionCause Enumeration

Describes the reason for the connection exception.

[Visual Basic]
<Serializable>
Public Enum ConnectionExceptionCause
[C#]
[Serializable]
public enum ConnectionExceptionCause
[C++]
[Serializable]
__value public enum ConnectionExceptionCause
[JScript]
public
   Serializable
enum ConnectionExceptionCause
Members

Member name | Description
Unspecified | Specifies that the AdomdConnectionException was caused by an unspecified error.
AuthenticationFailed | Specifies that the AdomdConnectionException was caused by an authentication failure.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdConnectionException.ExceptionCause | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter Class

Represents a .NET data adapter for a multidimensional data source.

For a list of all members of this type, see AdomdDataAdapter Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DataAdapter
System.Data.Common.DbDataAdapter
Microsoft.AnalysisServices.AdomdClient.AdomdDataAdapter

[Visual Basic]
NotInheritable Public Class AdomdDataAdapter
   Inherits DbDataAdapter
   Implements IDbDataAdapter
[C#]
public sealed class AdomdDataAdapter : DbDataAdapter,
   IDbDataAdapter
[C++]
public __gc __sealed class AdomdDataAdapter : public DbDataAdapter,
   IDbDataAdapter
[JScript]
public class AdomdDataAdapter extends DbDataAdapter implements
   IDbDataAdapter
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The AdomdDataAdapter is the ADOMD.NET implementation of the System.Data.IDbDataAdapter interface from the .NET Framework class library.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter Members

AdomdDataAdapter Class

Public Constructors

public constructor AdomdDataAdapter Constructor Overloaded. Initializes a new AdomdDataAdapter class.

Public Properties

public property SelectCommand Gets or sets an AdomdCommand used for retrieving multidimensional data.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.
public method Update | This member is reserved for future use.

Protected Methods

protected method CreateRowUpdatedEvent (inherited from DbDataAdapter) | This member is reserved for future use.
protected method CreateRowUpdatingEvent (inherited from DbDataAdapter) | This member is reserved for future use.
protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.
protected method OnRowUpdated (inherited from DbDataAdapter) | This member is reserved for future use.
protected method OnRowUpdating (inherited from DbDataAdapter) | This member is reserved for future use.

See Also

AdomdDataAdapter Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter Constructor

Initializes a new instance of the AdomdDataAdapter class.

Overload List

Initializes a new instance of the AdomdDataAdapter class with default values.

[Visual Basic] Public Sub New()
[C#] public AdomdDataAdapter();
[C++] public: AdomdDataAdapter();
[JScript] public function AdomdDataAdapter();

Initializes a new instance of the AdomdDataAdapter class using a specified AdomdCommand.

[Visual Basic] Public Sub New(AdomdCommand)
[C#] public AdomdDataAdapter(AdomdCommand);
[C++] public: AdomdDataAdapter(AdomdCommand*);
[JScript] public function AdomdDataAdapter(AdomdCommand);

Initializes a new instance of the AdomdDataAdapter class using the specified command text and AdomdConnection.

[Visual Basic] Public Sub New(System.String, AdomdConnection)
[C#] public AdomdDataAdapter(System.String, AdomdConnection);
[C++] public: AdomdDataAdapter(System.String, AdomdConnection*);
[JScript] public function AdomdDataAdapter(System.String, AdomdConnection);

Initializes a new instance of the AdomdDataAdapter class using the specified command text and connection string.

[Visual Basic] Public Sub New(System.String, System.String)
[C#] public AdomdDataAdapter(System.String, System.String);
[C++] public: AdomdDataAdapter(System.String, System.String);
[JScript] public function AdomdDataAdapter(System.String, System.String);
See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter Constructor ()

Initializes a new instance of the AdomdDataAdapter class with default values.

[Visual Basic]
Public Sub New()
[C#]
public AdomdDataAdapter();
[C++]
public: AdomdDataAdapter();
[JScript]
public function AdomdDataAdapter();
Remarks

The default constructor initializes any fields to their default values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataAdapter Constructor Overload List


AdomdDataAdapter Constructor (AdomdCommand)

Initializes a new instance of the AdomdDataAdapter class using a specified AdomdCommand as a select command.

[Visual Basic]
Public Sub New( _
   ByVal selectCommand As AdomdCommand _
)
[C#]
public AdomdDataAdapter(
   AdomdCommand selectCommand
);
[C++]
public: AdomdDataAdapter(
   AdomdCommand* selectCommand
);
[JScript]
public function AdomdDataAdapter(
   selectCommand : AdomdCommand
);
Arguments [JScript]
selectCommand
An AdomdCommand with which to set the SelectCommand property.
Parameters [Visual Basic, C#, C++]
selectCommand
An AdomdCommand with which to set the SelectCommand property.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataAdapter Constructor Overload List


AdomdDataAdapter Constructor (System.String, AdomdConnection)

Initializes a new instance of the AdomdDataAdapter class using the specified command text and AdomdConnection.

[Visual Basic]
Public Sub New( _
   ByVal selectCommandText As String, _
   ByVal selectConnection As AdomdConnection
)
[C#]
public AdomdDataAdapter(
   string selectCommandText,
   AdomdConnection selectConnection
);
[C++]
public: AdomdDataAdapter(
   String selectCommandText,
   AdomdConnection* selectConnection
);
[JScript]
public function AdomdDataAdapter(
   selectCommandText : String,
   selectConnection : AdomdConnection
);
Arguments [JScript]
selectCommandText
A String used as a SelectCommand property of the adapter.
selectConnection
An AdomdConnection with which the connection will be initialized.
Parameters [Visual Basic, C#, C++]
selectCommandText
A String used as a SelectCommand property of the adapter.
selectConnection
An AdomdConnection with which the connection is to be initialized.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataAdapter Constructor Overload List


AdomdDataAdapter Constructor (System.String, System.String)

Initializes a new instance of the AdomdDataAdapter class using the specified command text and connection string.

[Visual Basic]
Public Sub New( _
   ByVal selectCommandText As String, _
   ByVal selectConnectionString As String _
)
[C#]
public AdomdDataAdapter(
   string selectCommandText,
   string selectConnectionString
);
[C++]
public: AdomdDataAdapter(
   String selectCommandText,
   String selectConnectionString
);
[JScript]
public function AdomdDataAdapter(
   selectCommandText : String,
   selectConnectionString : String
);
Arguments [JScript]
selectCommandText
A String used as a SelectCommand property of the adapter.
selectConnectionString
A String with which the connection will be initialized.
Parameters [Visual Basic, C#, C++]
selectCommandText
A String used as a SelectCommand property of the adapter.
selectConnectionString
A String with which the connection is initialized.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataAdapter Constructor Overload List


AdomdDataAdapter Properties

The properties of the AdomdDataAdapter class are listed here. For a complete list of AdomdDataAdapter class members, see AdomdDataAdapter Members.

Public Properties

public property SelectCommand Gets or sets an AdomdCommand used for retrieving multidimensional data.

See Also

AdomdDataAdapter Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter.SelectCommand Property

Gets or sets a command used to retrieve data from a multidimensional data source.

[Visual Basic]
Public Shadows Property SelectCommand As AdomdCommand
[C#]
public new AdomdCommand SelectCommand {get; set;}
[C++]
public: __property AdomdCommand* get_SelectCommand();
public: __property void set_SelectCommand(AdomdCommand*);
[JScript]
public hide function get SelectCommand() : AdomdCommand;
public function set SelectCommand(AdomdCommand);
Property Value

An AdomdCommand that contains the command used to retrieve data from a multidimensional data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter Methods

The methods of the AdomdDataAdapter class are listed here. For a complete list of AdomdDataAdapter class members, see AdomdDataAdapter Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.
public method Update | This member is reserved for future use.

Protected Methods

protected method CreateRowUpdatedEvent (inherited from DbDataAdapter) | This member is reserved for future use.
protected method CreateRowUpdatingEvent (inherited from DbDataAdapter) | This member is reserved for future use.
protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.
protected method OnRowUpdated (inherited from DbDataAdapter) | This member is reserved for future use.
protected method OnRowUpdating (inherited from DbDataAdapter) | This member is reserved for future use.

See Also

AdomdDataAdapter Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter.Update Method

Note This member is not supported.

Overload List

Note This member is not supported.

[Visual Basic] Overloads Overrides Public Function Update(System.Data.DataSet) As Integer Implements IDataAdapter.Update
[C#] public override int Update(System.Data.DataSet);
[C++] public: int Update(System.Data.DataSet);
[JScript] public override function Update(System.Data.DataSet) : int;

Note This member is not supported.

[Visual Basic] Overloads Overrides Protected Function Update(System.Data.DataRow(), System.Data.Common.DataTableMapping) As Integer
[C#] protected override int Update(System.Data.DataRow[], System.Data.Common.DataTableMapping);
[C++] protected: int Update(System.Data.DataRow[], System.Data.Common.DataTableMapping);
[JScript] protected override function Update(System.Data.DataRow[], System.Data.Common.DataTableMapping) : int;

Inherited from System.Data.Common.DbDataAdapter.

[Visual Basic] Overloads Public Function Update(System.Data.DataRow()) As Integer
[C#] public int Update(System.Data.DataRow[]);
[C++] public: int Update(System.Data.DataRow[]);
[JScript] public function Update(System.Data.DataRow[]) : int;

Inherited from System.Data.Common.DbDataAdapter.

[Visual Basic] Overloads Public Function Update(System.Data.DataTable) As Integer
[C#] public int Update(System.Data.DataTable);
[C++] public: int Update(System.Data.DataTable);
[JScript] public function Update(System.Data.DataTable) : int;

Inherited from System.Data.Common.DbDataAdapter.

[Visual Basic] Overloads Public Function Update(System.Data.DataSet, System.String) As Integer
[C#] public int Update(System.Data.DataSet, System.String);
[C++] public: int Update(System.Data.DataSet, System.String);
[JScript] public function Update(System.Data.DataSet, System.String) : int;
See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataAdapter.Update Method (System.Data.DataSet)

This member is reserved for future use.

[Visual Basic]
Overrides Public Overloads Function Update( _
   ByVal dataSet As DataSet _
) As Integer Implements IDataAdapter.Update
[C#]
public override int Update(
   DataSet dataSet
);
[C++]
public: int Update(
   DataSet* dataSet
);
[JScript]
public override function Update(
   dataSet : DataSet
) : int;
Parameters
dataSet
The Dataset used to update the data source.
Implements

IDataAdapter.Update

Exceptions

Exception type | Condition
NotSupportedException | The member is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataAdapter.Update Overload List


AdomdDataAdapter.Update Method (System.Data.DataRow[], System.Data.Common.DataTableMapping)

This member is reserved for future use.

[Visual Basic]
Overrides Protected Overloads Function Update( _
   ByVal dataRows() As DataRow, _
   ByVal tableMapping As DataTableMapping _
) As Integer
[C#]
protected override int Update(
   DataRow[] dataRows,
   DataTableMapping tableMapping
);
[C++]
protected: int Update(
   DataRow* dataRows[],
   DataTableMapping* tableMapping
);
[JScript]
protected override function Update(
   dataRows : DataRow[],
   tableMapping : DataTableMapping
) : int;
Parameters
dataRows
An array of DataRow objects used to update the data source.
tableMapping
The TableMappings collection to use.
Exceptions

Exception type | Condition
NotSupportedException | The member is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataAdapter Class | AdomdDataAdapter Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataAdapter.Update Overload List


AdomdDataReader Class

Provides a means of reading a forward-only result set obtained by running a command, and can be used to access multidimensional data sources.

For complete list of AdomdDataReader class members, see AdomdDataReader Members.

System.Object
System.MarshalByRefObject
Microsoft.AnalysisServices.AdomdClient.AdomdDataReader

[Visual Basic]
Public NotInheritable Class AdomdDataReader
   Implements MarshalByRefObject, IDataReader, _
      IDisposable, IDataRecord, IEnumerable
[C#]
public sealed class AdomdDataReader : MarshalByRefObject, IDataReader,
   IDisposable, IDataRecord, IEnumerable
[C++]
public __gc __sealed class AdomdDataReader : public MarshalByRefObject,
   IDataReader, IDisposable, IDataRecord, IEnumerable
[JScript]
public class AdomdDataReader implements MarshalByRefObject, IDataReader,
   IDisposable, IDataRecord, Ienumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The AdomdDataReader class is the implementation of the IDataReader interface for ADOMD.NET. All .NET data providers implement the IDataReader interface as a way of quickly reading forward-only result sets. For more information about the IDataReader interface, see "IDataReader Interface" in the .NET Framework class library documentation.

To create an AdomdDataReader, you must call the ExecuteReader method of the AdomdCommand, rather than directly using a constructor.

While the AdomdDataReader is in use, the AdomdCommand and the associated AdomdConnection are busy serving the AdomdDataReader. While in this state, no operations can be performed on the AdomdConnection or AdomdCommand objects other than closing them. This remains the case until the Close or Dispose method of the AdomdDataReader is called. Changes made to a result set by another process or thread while data is being read may be visible to the user of the AdomdDataReader. However, the precise behavior is timing dependent.

IsClosed and RecordsAffected are the only properties that you can call after the AdomdDataReader is closed.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader Members

AdomdDataReader Class

Public Properties

public property Depth | Gets a value indicating the depth of nesting for the current row.
public property FieldCount | Gets a value indicating the number of columns in the current row.
public property IsClosed | Gets a value indicating whether the data reader is closed.
public property Item | Overloaded. Gets the value of a column in its native format. In C#, this property is the indexer for the AdomdDataReader class.
public property RecordsAffected | This member is reserved for future use.

Public Methods

public method Close | Closes the AdomdDataReader.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of the Object are equal.
public method GetBoolean | Returns a Boolean that contains the value from the specified column.
public method GetByte | Returns a Byte that contains the value from the specified column.
public method GetBytes | This member is reserved for future use.
public method GetChar | Returns a Char that contains the value from the specified column.
public method GetChars | This member is reserved for future use.
public method GetData | Returns an IDataReader interface to be used when a column points to more remote structured data.
public method GetDataTypeName | Returns a String that contains the full name of the data type for the specified column.
public method GetDateTime | Returns a DateTime that contains the value from the specified column.
public method GetDecimal | Returns a Decimal that contains the value from the specified column.
public method GetDouble | Returns a Double that contains the value from the specified column.
public method GetEnumerator | Returns an IEnumerator interface for iterating through the collection.
public method GetFieldType | Returns a Type that represents the data type of the specified column.
public method GetFloat | Returns a Float that contains the value from the specified column.
public method GetGuid | Returns a Guid that contains the value from the specified column.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetInt16 | Returns an Int16 that contains the value from the specified column.
public method GetInt32 | Returns an Int32 that contains the value from the specified column.
public method GetInt64 | Returns an Int64 that contains the value from the specified column.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetName | Returns the name of the specified column.
public method GetOrdinal | Returns the ordinal position of the specified column.
public method GetSchemaTable | Returns a DataTable that describes the column meta data of the AdomdDataReader.
public method GetString | Returns a String that contains the value from the specified column.
public method GetTimeSpan | Returns a TimeSpan that contains the value from the specified column.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method GetValue | Returns the value for the specified column in its native format.
public method GetValues | Gets an array of values for all of the columns in the current row.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsDBNull | Returns a Boolean that contains a value indicating whether the column is set to null.
public method NextResult | This member is reserved for future use.
public method Read | Advances the AdomdDataReader to the next row.
public method ToString (inherited from System.Object) | Gets a String object that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdDataReader Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader Properties

The properties of the AdomdDataReader class are listed here. For a complete list of AdomdDataReader class members, see AdomdDataReader Members.

Public Properties

public property Depth | Gets a value indicating the depth of nesting for the current row.
public property FieldCount | Gets a value indicating the number of columns in the current row.
public property IsClosed | Gets a value indicating whether the data reader is closed.
public property Item | Overloaded. Gets the value of a column in its native format. In C#, this property is the indexer for the AdomdDataReader class.
public property RecordsAffected | This member is reserved for future use.

See Also

AdomdDataReader Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Depth Property

Gets a value indicating the depth of nesting for the current row.

[Visual Basic]
Public Overridable ReadOnly Property Depth As Integer Implements _
   IDataReader.Depth
[C#]
public virtual int Depth {get;}
[C++]
public: __property virtual int get_Depth();
[JScript]
public function get Depth() : int;
Property Value

An Integer that contains the depth of nesting for the current row.

Implements

IDataReader.Depth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.FieldCount Property

Gets a value indicating the number of columns in the current row.

[Visual Basic]
Public Overridable ReadOnly Property FieldCount As Integer  _
   Implements IDataRecord.FieldCount
[C#]
public virtual int FieldCount {get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;
Property Value

An Integer that contains the number of columns in the current row.

Implements

IDataRecord.FieldCount

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.IsClosed Property

Gets a value indicating whether the data reader is closed.

[Visual Basic]
Public Overridable ReadOnly Property IsClosed As Boolean  _
   Implements IDataReader.IsClosed
[C#]
public virtual bool IsClosed {get;}
[C++]
public: __property virtual bool get_IsClosed();
[JScript]
public function get IsClosed() : Boolean;
Property Value

A Boolean that contains a value indicating whether the data reader is closed.

Implements

IDataReader.IsClosed

Remarks

The IsClosed property and the RecordsAffected property are the only properties that can be called when an AdomdDataReader is closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Item Property

Gets the value of a specified column in its native format.

[C#] In C#, this property is the indexer for the AdomdDataReader class.

Overload List

Gets the value of a specified column in its native format, given the name of the column.

[Visual Basic] Public Overloads Overridable Default ReadOnly Property Item(System.String) As Object Implements IDataRecord.Item
[C#] public virtual object this[System.String] {get;}
[C++] public: __property virtual Object* get_Item(System.String);
[JScript] AdomdDataReader.Item (System.String)

Gets the value of a specified column in its native format, given the ordinal position of the column.

[Visual Basic] Public Overloads Overridable Default ReadOnly Property Item(System.Int32) As Object Implements IDataRecord.Item
[C#] public virtual object this[System.Int32] {get;}
[C++] public: __property virtual Object* get_Item(System.Int32);
[JScript] AdomdDataReader.Item (System.Int32)
See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Item Property (System.String)

Gets the value of a specified column in its native format, given the name of the column.

[C#] In C#, this property is the indexer for the AdomdDataReader class.

[Visual Basic]
Public Overloads Overridable Default ReadOnly Property Item( _
   ByVal strColumn As String _
) As Object  Implements IDataRecord.Item
[C#]
public virtual object this[
   string strColumn
] {get;}
[C++]
public: __property virtual Object* get_Item(
   String* strColumn
);
[JScript]
returnValue = AdomdDataReaderObject.Item(strColumn);
-or-
returnValue = AdomdDataReaderObject(strColumn);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
strColumn
The name of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
strColumn
The name of the column to be retrieved.
Property Value

An Object that contains the value of the specified column.

Implements

IDataRecord.Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataReader.Item Overload List


AdomdDataReader.Item Property (System.Int32)

Gets the value of a specified column in its native format, given the ordinal position of the column.

[C#] In C#, this property is the indexer for the AdomdDataReader class.

[Visual Basic]
Public Overloads Overridable Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Object  Implements IDataRecord.Item
[C#]
public virtual object this[
   int index
] {get;}
[C++]
public: __property virtual Object* get_Item(
   int index
);
[JScript]
returnValue = AdomdDataReaderObject.Item(index);
-or-
returnValue = AdomdDataReaderObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the column to be retrieved.
Property Value

An Object that contains the value of the specified column.

Implements

IDataRecord.Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdDataReader.Item Overload List


AdomdDataReader.RecordsAffected Property

This member is reserved for future use.

[Visual Basic]
Public Overridable ReadOnly Property RecordsAffected As Integer  _
   Implements IDataReader.RecordsAffected
[C#]
public virtual int RecordsAffected {get;}
[C++]
public: __property virtual int get_RecordsAffected();
[JScript]
public function get RecordsAffected() : int;
Property Value

An Integer that contains the value -1.

Implements

IDataReader.RecordsAffected

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader Methods

The methods of the AdomdDataReader class are listed here. For a complete list of AdomdDataReader class members, see AdomdDataReader Members.

Public Methods

public method Close | Closes the AdomdDataReader.
public method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBoolean | Returns a Boolean that contains the value from the specified column.
public method GetByte | Returns a Byte that contains the value from the specified column.
public method GetBytes | This member is reserved for future use.
public method GetChar | Returns a Char that contains the value from the specified column.
public method GetChars | This member is reserved for future use.
public method GetData | Returns an IDataReader interface to be used when a column points to more remote structured data.
public method GetDataTypeName | Returns a String that contains the full name of the data type for the specified column.
public method GetDateTime | Returns a DateTime that contains the value from the specified column.
public method GetDecimal | Returns a Decimal that contains the value from the specified column.
public method GetDouble | Returns a Double that contains the value from the specified column.
public method GetEnumerator | Gets an IEnumerator interface for iterating through the collection.
public method GetFieldType | Returns a Type that represents the data type of the specified column.
public method GetFloat | Returns a Float that contains the value from the specified column.
public method GetGuid | Returns a Guid that contains the value from the specified column.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetInt16 | Returns an Int16 that contains the value from the specified column.
public method GetInt32 | Returns an Int32 that contains the value from the specified column.
public method GetInt64 | Returns an Int64 that contains the value from the specified column.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
public method GetName | Returns the name of the specified column.
public method GetOrdinal | Returns the ordinal position of the specified column.
public method GetSchemaTable | Returns a DataTable that describes the column metadata of the AdomdDataReader.
public method GetString | Returns a String that contains the value from the specified column.
public method GetTimeSpan | Returns a TimeSpan that contains the value from the specified column.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method GetValue | Returns the value for the specified column in its native format.
public method GetValues | Gets an array of values for all of the columns in the current row.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
public method IsDBNull | Returns a Boolean that contains a value indicating whether the column is set to null.
public method NextResult | This member is reserved for future use.
public method Read | Advances the AdomdDataReader to the next row.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdDataReader Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Close Method

Closes the AdomdDataReader.

[Visual Basic]
Public Overridable Sub Close() Implements IDataReader.Close
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();
Implements

IDataReader.Close

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security:

Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();
Implements

IDisposable.Dispose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetBoolean Method

Returns a Boolean that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetBoolean( _
   ByVal ordinal As Integer _
) As Boolean Implements IDataRecord.GetBoolean
[C#]
public virtual bool GetBoolean(
   int ordinal
);
[C++]
public: virtual bool GetBoolean(
   int ordinal
);
[JScript]
public function GetBoolean(
   ordinal : int
) : Boolean;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Boolean that contains the value of the specified column.

Implements

IDataRecord.GetBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetByte Method

Returns a Byte that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetByte( _
   ByVal ordinal As Integer _
) As Byte Implements IDataRecord.GetByte
[C#]
public virtual byte GetByte(
   int ordinal
);
[C++]
public: virtual unsigned char GetByte(
   int ordinal
);
[JScript]
public function GetByte(
   ordinal : int
) : Byte;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Byte that contains the value of the specified column.

Implements

IDataRecord.GetByte

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetBytes Method

This member is reserved for future use.

[Visual Basic]
Public Overridable Function GetBytes( _
   ByVal ordinal As Integer, _
   ByVal dataIndex As Long, _
   ByVal buffer() As Byte, _
   ByVal bufferIndex As Integer, _
   ByVal length As Integer _
) As Long Implements IDataRecord.GetBytes
[C#]
public virtual long GetBytes(
   int ordinal,
   long dataIndex,
   byte[] buffer,
   int bufferIndex,
   int length
);
[C++]
public: virtual __int64 GetBytes(
   int ordinal,
   __int64 dataIndex,
   unsigned char buffer __gc[],
   int bufferIndex,
   int length
);
[JScript]
public function GetBytes(
   ordinal : int,
   dataIndex : long,
   buffer : Byte[],
   bufferIndex : int,
   length : int
) : long;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
dataIndex
The zero-based index within the column from which to begin reading data.
buffer
The buffer into which to read the stream of bytes.
bufferIndex
The zero-based index within the buffer from which to begin writing data.
length
The number of bytes to read from the column.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
dataIndex
The zero-based index within the column from which to begin reading data.
buffer
The buffer into which to read the stream of bytes.
bufferIndex
The zero-based index within the buffer from which to begin writing data.
length
The number of bytes to read from the column.
Return Value

A Long that contains the number of bytes actually read from the column.

Exceptions

Exception type | Condition
NotSupportedException | The method is called.

Implements

IDataRecord.GetBytes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetChar Method

Returns a Char that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetChar( _
   ByVal ordinal As Integer _
) As Char Implements IDataRecord.GetChar
[C#]
public virtual char GetChar(
   int ordinal
);
[C++]
public: virtual __wchar_t GetChar(
   int ordinal
);
[JScript]
public function GetChar(
   ordinal : int
) : Char;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Char that contains the value of the specified column.

Implements

IDataRecord.GetChar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetChars Method

Returns an array of Char objects that contain a stream of values from the specified column.

[Visual Basic]
Public Overridable Function GetChars( _
   ByVal ordinal As Integer, _
   ByVal dataIndex As Long, _
   ByVal buffer() As Char, _
   ByVal bufferIndex As Integer, _
   ByVal length As Integer _
) As Long Implements IDataRecord.GetChars
[C#]
public virtual long GetChars(
   int ordinal,
   long dataIndex,
   char[] buffer,
   int bufferIndex,
   int length
);
[C++]
public: virtual __int64 GetChars(
   int ordinal,
   __int64 dataIndex,
   __wchar_t buffer __gc[],
   int bufferIndex,
   int length
);
[JScript]
public function GetChars(
   ordinal : int,
   dataIndex : long,
   buffer : Char[],
   bufferIndex : int,
   length : int
) : long;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
dataIndex
The zero-based index within the column from which to begin reading data.
buffer
The buffer into which to read the stream of characters.
bufferIndex
The zero-based index within the buffer from which to begin writing data.
length
The number of characters to read from the column.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
dataIndex
The zero-based index within the column from which to begin reading data.
buffer
The buffer into which to read the stream of characters.
bufferIndex
The zero-based index within the buffer from which to begin writing data.
length
The number of characters to read from the column.
Return Value

A Long that contains the number of characters actually read from the column.

Exceptions

Exception type | Condition
IndexOutOfRangeException | The value of dataIndex is greater than Int32.MaxValue. The value of bufferIndex is less than 0 or greater than the total of length and the length of buffer.

Implements

IDataRecord.GetChars

Remarks

The GetChars method returns the number of available characters in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetChars has already been used to obtain characters from the field.

If you pass a null reference (Nothing in Visual Basic) in the buffer parameter, GetBytes returns the length of the column in characters.

No conversions are performed; therefore the data retrieved must already be a character array.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetData Method

Returns an IDataReader interface to be used when a column points to more remote structured data.

[Visual Basic]
Public Overridable Function GetData( _
   ByVal ordinal As Integer _
) As IDataReader Implements IDataRecord.GetData
[C#]
public virtual IDataReader GetData(
   int ordinal
);
[C++]
public: virtual IDataReader* GetData(
   int ordinal
);
[JScript]
public function GetData(
   ordinal : int
) : IDataReader;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to find.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to find.
Return Value

An IDataReader interface that points to more remote structured data referenced by the column.

Implements

IDataRecord.GetData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetDataTypeName Method

Returns a String that contains the full name of the data type for the specified column.

[Visual Basic]
Public Overridable Function GetDataTypeName( _
   ByVal index As Integer _
) As String Implements IDataRecord.GetDataTypeName
[C#]
public virtual string GetDataTypeName(
   int index
);
[C++]
public: virtual String* GetDataTypeName(
   int index
);
[JScript]
public function GetDataTypeName(
   index : int
) : String;
Arguments [JScript]
index
The zero-based ordinal position of the column to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based ordinal position of the column to find.
Return Value

A String that contains the full name of the data type for the specified column.

Implements

IDataRecord.GetDataTypeName

Remarks

The data type information can differ from the type information returned by GetFieldType, especially where the underlying data types do not map one for one to the runtime types supported by the language. (For example, DataTypeName may be "integer", but Type.Name may be "Int32".)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetDateTime Method

Returns a DateTime that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetDateTime( _
   ByVal ordinal As Integer _
) As DateTime Implements IDataRecord.GetDateTime
[C#]
public virtual DateTime GetDateTime(
   int ordinal
);
[C++]
public: virtual DateTime GetDateTime(
   int ordinal
);
[JScript]
public function GetDateTime(
   ordinal : int
) : DateTime;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A DateTime that contains the value, converted to local system time, of the specified column.

Implements

IDataRecord.GetDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetDecimal Method

Returns a Decimal that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetDecimal( _
   ByVal ordinal As Integer _
) As Decimal Implements IDataRecord.GetDecimal
[C#]
public virtual decimal GetDecimal(
   int ordinal
);
[C++]
public: virtual Decimal GetDecimal(
   int ordinal
);
[JScript]
public function GetDecimal(
   ordinal : int
) : Decimal;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Decimal that contains the value of the specified column.

Implements

IDataRecord.GetDecimal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetDouble Method

Returns a Double that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetDouble( _
   ByVal ordinal As Integer _
) As Double Implements IDataRecord.GetDouble
[C#]
public virtual double GetDouble(
   int ordinal
);
[C++]
public: virtual double GetDouble(
   int ordinal
);
[JScript]
public function GetDouble(
   ordinal : int
) : double;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Double that contains the value of the specified column.

Implements

IDataRecord.GetDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetEnumerator Method

Gets an IEnumerator interface for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Return Value

An IEnumerator interface for iterating through the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetFieldType Method

Returns a Type that represents the data type of the specified column.

[Visual Basic]
Public Overridable Function GetFieldType( _
   ByVal ordinal As Integer _
) As Type Implements IDataRecord.GetFieldType
[C#]
public virtual Type GetFieldType(
   int ordinal
);
[C++]
public: virtual Type* GetFieldType(
   int ordinal
);
[JScript]
public function GetFieldType(
   ordinal : int
) : Type;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to find.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to find.
Return Value

A Type that contains the type of the Object returned by the GetValue method.

Implements

IDataRecord.GetFieldType

Remarks

This information may be used to increase performance by indicating the strongly typed accessor to call.

If the data contained in the column changes from row to row, the type returned will be Object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetFloat Method

Returns a Float that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetFloat( _
   ByVal ordinal As Integer _
) As Single Implements IDataRecord.GetFloat
[C#]
public virtual float GetFloat(
   int ordinal
);
[C++]
public: virtual float GetFloat(
   int ordinal
);
[JScript]
public function GetFloat(
   ordinal : int
) : float;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Single that contains the value of the specified column.

Implements

IDataRecord.GetFloat

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetGuid Method

Returns a Guid that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetGuid( _
   ByVal ordinal As Integer _
) As Guid Implements IDataRecord.GetGuid
[C#]
public virtual Guid GetGuid(
   int ordinal
);
[C++]
public: virtual Guid GetGuid(
   int ordinal
);
[JScript]
public function GetGuid(
   ordinal : int
) : Guid;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A Guid that contains the value of the specified column.

Implements

IDataRecord.GetGuid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetInt16 Method

Returns an Int16 that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetInt16( _
   ByVal ordinal As Integer _
) As Short Implements IDataRecord.GetInt16
[C#]
public virtual short GetInt16(
   int ordinal
);
[C++]
public: virtual short GetInt16(
   int ordinal
);
[JScript]
public function GetInt16(
   ordinal : int
) : Int16;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

An Int16 that contains the value of the specified column.

Implements

IDataRecord.GetInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetInt32 Method

Returns an Int32 that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetInt32( _
   ByVal ordinal As Integer _
) As Integer Implements IDataRecord.GetInt32
[C#]
public virtual int GetInt32(
   int ordinal
);
[C++]
public: virtual int GetInt32(
   int ordinal
);
[JScript]
public function GetInt32(
   ordinal : int
) : int;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

An Int32 that contains the value of the specified column.

Implements

IDataRecord.GetInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetInt64 Method

Returns an Int64 that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetInt64( _
   ByVal ordinal As Integer _
) As Long Implements IDataRecord.GetInt64
[C#]
public virtual long GetInt64(
   int ordinal
);
[C++]
public: virtual __int64 GetInt64(
   int ordinal
);
[JScript]
public function GetInt64(
   ordinal : int
) : long;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

An Int64 that contains the value of the specified column.

Implements

IDataRecord.GetInt64

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetName Method

Returns the name of the specified column.

[Visual Basic]
Public Overridable Function GetName( _
   ByVal ordinal As Integer _
) As String Implements IDataRecord.GetName
[C#]
public virtual string GetName(
   int ordinal
);
[C++]
public: virtual String* GetName(
   int ordinal
);
[JScript]
public function GetName(
   ordinal : int
) : String;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to find.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to find.
Return Value

A String that contains the name of the specified column.

Implements

IDataRecord.GetName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetOrdinal Method

Returns the ordinal position of the specified column.

[Visual Basic]
Public Overridable Function GetOrdinal( _
   ByVal name As String _
) As Integer Implements IDataRecord.GetOrdinal
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;
Arguments [JScript]
name
The name of the column to find.
Parameters [Visual Basic, C#, C++]
name
The name of the column to find.
Return Value

An Integer that contains the ordinal position of the specified column.

Implements

IDataRecord.GetOrdinal

Remarks

GetOrdinal performs a case-insensitive lookup.

GetOrdinal is kana-width insensitive.

Because ordinal-based lookups are more efficient than named lookups, it is inefficient to call GetOrdinal within a loop. Save time by calling GetOrdinal once and assigning the results to an integer variable for use within the loop.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetSchemaTable Method

Returns a DataTable that describes the column metadata of the AdomdDataReader.

[Visual Basic]
Public Overridable Function GetSchemaTable() As DataTable _
   Implements _
   IDataReader.GetSchemaTable
[C#]
public virtual DataTable GetSchemaTable();
[C++]
public: virtual DataTable* GetSchemaTable();
[JScript]
public function GetSchemaTable() : DataTable;
Return Value

A DataTable that contains the schema information for the current result of the AdomdDataReader.

Implements

IDataReader.GetSchemaTable

Remarks

The following table describes the columns, in order, returned in the DataTable to present schema information about the current result.

Name | Data type | Description
ColumnName | String | The caption of the column; this might not be unique. If this cannot be determined, a null value is returned. This name always reflects the most recent renaming of the column in the current view or command text.
ColumnOrdinal | Int32 | The ordinal number of the column. This is zero for the bookmark column of the row, if any. Other columns are numbered starting with one. This column cannot contain a null value.
ColumnSize | Int32 | This column always returns 0.
NumericPrecision | Int32 | This column always returns 0.
NumericScale | Int32 | This column always returns 0.
DataType | Type | Returns the .NET Framework type of the column.
ProviderType | Object | The indicator of the column's data type. If the data type of the column varies from row to row, this must be Object. This column cannot contain a null value.
IsLong | Boolean | Set if the column contains a Binary Long Object (BLOB) that contains very long data. The definition of very long data is provider-specific. The setting of this flag typically corresponds to the value of the IS_LONG column in the PROVIDER_TYPES rowset for the data type.
AllowDBNull | Boolean | Set if the consumer can set the column to a null value, or if the provider cannot determine whether or not the consumer can set the column to a null value. Otherwise, not set. A column may contain null values, even if it cannot be set to a null value.
IsReadOnly | Boolean | Returns true if the column can be modified; otherwise false. This column always returns true.
IsRowVersion | String | Set if the column contains a persistent row identifier that cannot be written to, and has no meaningful value except to identity the row.
IsUnique | Boolean | Returns true if no two rows in the base table (the table returned in BASETABLENAME) can have the same value in this column. IsUnique is guaranteed to be true if the column constitutes a key by itself or if there is a constraint of type UNIQUE that applies only to this column. Otherwise, this column returns false if the column can contain duplicate values in the base table.The default of this column is false.
IsKey | Boolean | Returns true if the column is one of a set of columns in the rowset that, taken together, uniquely identify the row. The set of columns with IsKey set to true must uniquely identify a row in the rowset. There is no requirement that this set of columns is a minimal set of columns. This set of columns may be generated from a base table primary key, a unique constraint or a unique index. Otherwise, returns false if the column is not required to uniquely identify the row. This column always returns false.
IsAutoIncrement | Boolean | This column returns true if the column assigns values to new rows in fixed increments. Otherwise, this column returns false. This column always returns false.
BaseSchemaName | String | The name of the schema in the data store that contains the column. A null value if the base schema name cannot be determined. This column always returns a null value.
BaseCatalogName | String | The name of the catalog in the data store that contains the column. A null value if the base catalog name cannot be determined. This column always returns a null value.
BaseTableName | String | The name of the table or view in the data store that contains the column. A null value if the base table name cannot be determined. This column always returns a null value.
BaseColumnName | String | The name of the column in the result. This might be different than the column name returned in the ColumnName column if an alias was used. A null value is returned if the base column name cannot be determined or if the rowset column is derived, but not identical to, a column in the result. This column always returns a null value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetString Method

Returns a String that contains the value from the specified column.

[Visual Basic]
Public Overridable Function GetString( _
   ByVal ordinal As Integer _
) As String Implements IDataRecord.GetString
[C#]
public virtual string GetString(
   int ordinal
);
[C++]
public: virtual String* GetString(
   int ordinal
);
[JScript]
public function GetString(
   ordinal : int
) : String;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A String that contains the value of the specified column.

Implements

IDataRecord.GetString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetTimeSpan Method

Returns a TimeSpan that contains the value from the specified column.

[Visual Basic]
Public Function GetTimeSpan( _
   ByVal ordinal As Integer _
) As TimeSpan
[C#]
public TimeSpan GetTimeSpan(
   int ordinal
);
[C++]
public: TimeSpan GetTimeSpan(
   int ordinal
);
[JScript]
public function GetTimeSpan(
   ordinal : int
) : TimeSpan;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

A TimeSpan that contains the value of the specified column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security:

Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetValue Method

Returns the value for the specified column in its native format.

[Visual Basic]
Public Overridable Function GetValue( _
   ByVal ordinal As Integer _
) As Object Implements IDataRecord.GetValue
[C#]
public virtual object GetValue(
   int ordinal
);
[C++]
public: virtual Object* GetValue(
   int ordinal
);
[JScript]
public function GetValue(
   ordinal : int
) : Object;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to be retrieved.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to be retrieved.
Return Value

An Object that contains the value of the specified column.

Implements

IDataRecord.GetValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.GetValues Method

Gets an array of values for all of the columns in the current row.

[Visual Basic]
Public Overridable Function GetValues( _
   ByVal values() As Object _
) As Integer Implements IDataRecord.GetValues
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values __gc[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;
Arguments [JScript]
values
An array of Object objects into which to copy the column values.
Parameters [Visual Basic, C#, C++]
values
An array of Object objects into which to copy the column values.
Return Value

An Integer that contains the number of instances copied into the array of Object objects.

Implements

IDataRecord.GetValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.IsDBNull Method

Returns a Boolean that contains a value indicating whether the column is set to null.

[Visual Basic]
Public Overridable Function IsDBNull( _
   ByVal ordinal As Integer _
) As Boolean Implements IDataRecord.IsDBNull
[C#]
public virtual bool IsDBNull(
   int ordinal
);
[C++]
public: virtual bool IsDBNull(
   int ordinal
);
[JScript]
public function IsDBNull(
   ordinal : int
) : Boolean;
Arguments [JScript]
ordinal
The zero-based ordinal position of the column to find.
Parameters [Visual Basic, C#, C++]
ordinal
The zero-based ordinal position of the column to find.
Return Value

A Boolean containing true if the column is set to null; false otherwise.

Implements

IDataRecord.IsDBNull

Remarks

Call this method to check for null column values before calling the typed methods used to retrieve column values (for example, GetByte, GetChar, and so on), to avoid raising an error.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.NextResult Method

Advances the AdomdDataReader to the next result, when reading the results of batch statements.

[Visual Basic]
Public Overridable Function NextResult() As Boolean Implements _
   IDataReader.NextResult
[C#]
public virtual bool NextResult();
[C++]
public: virtual bool NextResult();
[JScript]
public function NextResult() : Boolean;
Return Value

Always false.

Implements

IDataReader.NextResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Read Method

Advances the AdomdDataReader to the next row.

[Visual Basic]
Public Overridable Function Read() As Boolean Implements _
   IDataReader.Read
[C#]
public virtual bool Read();
[C++]
public: virtual bool Read();
[JScript]
public function Read() : Boolean;
Return Value

A Boolean that contains true if there are more rows; false otherwise.

Implements

IDataReader.Read

Remarks

The default position of the AdomdDataReader is prior to the first record. Therefore, you must call the Read method first before attempting to access any data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader Class | AdomdDataReader Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator Structure

Supports iterating over an AdomdDataReader and reading its individual records.

For a list of all members of this type, see AdomdDataReader.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.AdomdDataReader.Enumerator

[Visual Basic]
Public Structure AdomdDataReader.Enumerator
   Implements IEnumerator
[C#]
public struct AdomdDataReader.Enumerator : IEnumerator
[C++]
public __value struct AdomdDataReader.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Remarks

Because the AdomdDataReader is a forward-only source of data, you can iterate the associated enumerator only once.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdDataReader.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator Members

AdomdDataReader.Enumerator Structure

Public Properties

public property Current Gets the current IDataRecord interface in the AdomdDataReader.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next IDataRecord interface in the AdomdDataReader.
public method Reset | This member is reserved for future use.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AdomdDataReader.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator Properties

The properties of the AdomdDataReader.Enumerator structure are listed here. For a complete list of AdomdDataReader.Enumerator structure members, see AdomdDataReader.Enumerator Members.

Public Properties

public property Current Gets the current IDataRecord interface in the AdomdDataReader.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AdomdDataReader.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator.Current Property

Gets the current IDataRecord interface in the AdomdDataReader.

[Visual Basic]
Public ReadOnly Property Current As System.Data.IDataRecord
[C#]
public System.Data.IDataRecord Current {get;}
[C++]
public: __property System.Data.IDataRecord* get_Current();
[JScript]
public function get Current() : System.Data.IDataRecord;
Property Value

The IDataRecord interface in the AdomdDataReader, if the enumerator has not passed the end of the records.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last IDataRecord interface in the AdomdDataReader.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader.Enumerator Structure | AdomdDataReader.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

AdomdDataReader.Enumerator Structure | AdomdDataReader.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator Methods

The methods of the AdomdDataReader.Enumerator structure are listed here. For a complete list of AdomdDataReader.Enumerator structure members, see AdomdDataReader.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next IDataRecord interface in the AdomdDataReader.
public method Reset Moves the enumerator to a position before the first IDataRecord interface in the AdomdDataReader.

Note This method is not supported.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdDataReader.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator.MoveNext Method

Moves to the next IDataRecord interface in the AdomdDataReader.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the records.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader.Enumerator Structure | AdomdDataReader.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdDataReader.Enumerator.Reset Method

This member is reserved for future use.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdDataReader.Enumerator Structure | AdomdDataReader.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError Class

Represents a server or provider-specific error.

For a complete list of AdomdError class members, see AdomdError Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AdomdError

[Visual Basic]
<Serializable>
NotInheritable Public Class AdomdError
[C#]
[Serializable]
public sealed class AdomdError
[C++]
[Serializable]
public __gc __sealed class AdomdError
[JScript]
public
   Serializable
class AdomdError
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The AdomdError represents an XML for Analysis error received or raised by the provider during the execution of a statement or query. The properties of the AdomdError map directly to the subelements of the Error element in the XML for Analysis 1.1 specification, as described in the following table.

AdomdError property name | XML for Analysis error subelement name
ErrorCode | ErrorCode
HelpLink | HelpFile
Message | Description
Source | Source

The AdomdError objects themselves are not directly raised in ADOMD.NET. Instead, they are contained within the AdomdErrors collection of an AdomdException.

For more information about the AdomdException class, see AdomdException Class.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdError Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError Members

AdomdError Class

Public Properties

public property ErrorCode | Gets the error code of the AdomdError.
public property HelpLink | Gets a link to the Help file associated with the AdomdError.
public property Message | Gets the error message of the AdomdError.
public property Source | Gets the name of the application or object that caused the error associated with the AdomdError.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of the Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdError Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError Properties

The properties of the AdomdError class are listed here. For a complete list of AdomdError class members, see AdomdError Members.

Public Properties

public property ErrorCode | Gets the error code of the AdomdError.
public property HelpLink | Gets a link to the Help file associated with the AdomdError.
public property Message | Gets the error message of the AdomdError.
public property Source | Gets the name of the application or object that caused the error associated with the AdomdError.

See Also

AdomdError Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError.ErrorCode Property

Gets the error code of the AdomdError.

[Visual Basic]
Public ReadOnly Property ErrorCode As Integer
[C#]
public int ErrorCode {get;}
[C++]
public: __property int get_ErrorCode();
[JScript]
public function get ErrorCode() : Int;
Property Value

An Int that contains the error code of the AdomdError.

Remarks

The ErrorCode property represents the numeric error code contained in an XML for Analysis error.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdError Class | AdomdError Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError.HelpLink Property

Gets a link to the Help file associated with the AdomdError.

[Visual Basic]
Public ReadOnly Property HelpLink As String
[C#]
public string HelpLink {get;}
[C++]
public: __property String* get_HelpLink();
[JScript]
public function get HelpLink() : String;
Property Value

A String that contains the Uniform Resource Name (URN) or Uniform Resource Locator (URL) of a link to a Help file.

Remarks

The HelpLink property returns either a URN or URL to the Help file or topic that describes the error represented by the AdomdError. If no Help file or topic is associated with the error, this property returns an empty string ("").

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdError Class | AdomdError Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError.Message Property

Gets the error message of the AdomdError.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property String* get_Message();
[JScript]
public function get Message() : String;
Property Value

A String that contains the error text and description returned by the component or object that generated the error.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdError Class | AdomdError Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError.Source Property

Gets the name of the application or object that caused the error associated with the AdomdError.

[Visual Basic]
Public ReadOnly Property Source As String
[C#]
public string Source {get;}
[C++]
public: __property String* get_Source();
[JScript]
public function get Source() : String;
Property Value

A String that contains the name of the application or object that caused the error.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdError Class | AdomdError Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError Methods

The methods of the AdomdError class are listed here. For a complete list of AdomdError class members, see AdomdError Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdError Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdError.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the Message property value of the AdomdError.

Remarks

For more information about the Message property, see Message Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdError Class | AdomdError Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection Class

Gets a collection of AdomdError objects.

For a list of all members of this type, see AdomdErrorCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AdomdErrorCollection

[Visual Basic]
<Serializable>
NotInheritable Public Class AdomdErrorCollection
   Implements ICollection, IEnumerable
[C#]
[Serializable]
public sealed class AdomdErrorCollection : ICollection,
   IEnumerable
[C++]
[Serializable]
public __gc __sealed class AdomdErrorCollection : public
   ICollection, IEnumerable
[JScript]
public
   Serializable
class AdomdErrorCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection Members

AdomdErrorCollection Class

Public Properties

public property Count | Gets the number of AdomdError objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Gets the specified AdomdError from the collection. In C#, this property is the indexer for the AdomdErrorCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdErrorCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection Properties

The properties of the AdomdErrorCollection class are listed here. For a complete list of AdomdErrorCollection class members, see AdomdErrorCollection Members.

Public Properties

public property Count | Gets the number of AdomdError objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Gets the specified AdomdError from the collection. In C#, this property is the indexer for the AdomdErrorCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

AdomdErrorCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Count Property

Gets the number of AdomdError objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of AdomdError objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Item Property

Gets the specified AdomdError from the collection by its index.

[C#] In C#, this property is the indexer for the AdomdErrorCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As AdomdError
[C#]
public AdomdError this[
   int index
] {get;}
[C++]
public: __property AdomdError* get_Item(
   int index
);
[JScript]
returnValue = AdomdErrorCollectionObject.Item(index);
-or-
returnValue = AdomdErrorCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the AdomdError to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the AdomdError to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection Methods

The methods of the AdomdErrorCollection class are listed here. For a complete list of AdomdErrorCollection class members, see AdomdErrorCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdErrorCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As AdomdError, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   AdomdError[] array,
   int index
);
[C++]
public: void CopyTo(
   AdomdError* array[],
   int index
);
[JScript]
public function CopyTo(
   array : AdomdError[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array class in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

AdomdErrorCollection Class | AdomdErrorCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator Structure

Supports iterating over a AdomdErrorCollection and reading its individual AdomdError objects.

For a list of all members of this type, see AdomdErrorCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.AdomdErrorCollection.Enumerator

[Visual Basic]
Public Structure AdomdErrorCollection.Enumerator
   Implements IEnumerator
[C#]
public struct AdomdErrorCollection.Enumerator : IEnumerator
[C++]
public __value struct AdomdErrorCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdErrorCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator Members

AdomdErrorCollection.Enumerator Structure

Public Properties

public property Current Gets the current AdomdError in the AdomdErrorCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next AdomdError in the AdomdErrorCollection.
public method Reset | Moves the enumerator to a position before the first AdomdError in the AdomdErrorCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AdomdErrorCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator Properties

The properties of the AdomdErrorCollection.Enumerator structure are listed here. For a complete list of AdomdErrorCollection.Enumerator structure members, see AdomdErrorCollection.Enumerator Members.

Public Properties

public property Current Gets the current AdomdError in the AdomdErrorCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AdomdErrorCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator.Current Property

Gets the current AdomdError in the AdomdErrorCollection.

[Visual Basic]
Public ReadOnly Property Current As AdomdError
[C#]
public AdomdError Current {get;}
[C++]
public: __property AdomdError* get_Current();
[JScript]
public function get Current() : AdomdError;
Property Value

The AdomdError in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last AdomdError in the AdomdErrorCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection.Enumerator Structure | AdomdErrorCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

AdomdErrorCollection.Enumerator Structure | AdomdErrorCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator Methods

The methods of the AdomdErrorCollection.Enumerator structure are listed here. For a complete list of AdomdErrorCollection.Enumerator structure members, see AdomdErrorCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next AdomdError in the AdomdErrorCollection.
public method Reset | Moves the enumerator to a position before the first AdomdError in the AdomdErrorCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdErrorCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator.MoveNext Method

Moves to the next AdomdError in the AdomdErrorCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection.Enumerator Structure | AdomdErrorCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first AdomdError in the AdomdErrorCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorCollection.Enumerator Structure | AdomdErrorCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException Class

Represents an exception thrown by ADOMD.NET when a response is received from a provider which indicates an error. This exception contains a collection of AdomdError objects that contain information about each problem reported by the provider.

For a complete list of AdomdErrorResponseException class members, see AdomdErrorResponseException Members.

System.Object
System.Exception
Microsoft.AnalysisServices.AdmodClient.AdomdException
Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException

 [Visual Basic]
<Serializable>
Public NotInheritable Class AdomdErrorResponseException
   Inherits AdomdException
[C#]
[Serializable]
public sealed class AdomdErrorResponseException : AdomdException
[C++]
[Serializable]
public __gc __sealed class AdomdErrorResponseException : public AdomdException
[JScript]
public
   Serializable
class AdomdErrorResponseException extends AdomdException
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException Members

AdomdErrorResponseException Class

Public Properties

public property ErrorCode | Overridden. Gets the value of the ErrorCode property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property Errors | Overridden. Gets a reference to the AdomdErrorCollection contained by the AdomdErrorResponseException.
public property HelpLink | Overridden. Gets the value of the HelpLink property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property InnerException (inherited from AdomdException) | Gets the Exception that caused the current exception.
public property Message | Overridden. Gets the value of the Message property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property Source | Overridden. Gets the value of the Source property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property StackTrace (inherited from AdomdException) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from AdomdException) | Gets the name of the method that threw the current exception.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from AdomdException) | When overridden in a derived class, returns an Exception that represents the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetObjectData (inherited from System.Exception) | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from AdomdException) | Creates and returns a string representation of the current exception.

Protected Properties

protected property HResult (inherited from AdomdException) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdErrorResponseException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException Properties

The properties of the AdomdErrorResponseException class are listed here. For a complete list of AdomdErrorResponseException class members, see AdomdErrorResponseException Members.

Public Properties

public property ErrorCode | Overridden. Gets the value of the ErrorCode property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property Errors | Overridden. Gets a reference to the AdomdErrorCollection contained by the AdomdErrorResponseException.
public property HelpLink | Overridden. Gets the value of the HelpLink property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property InnerException (inherited from AdomdException) | Gets the Exception that caused the current exception.
public property Message | Overridden. Gets the value of the Message property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property Source | Overridden. Gets the value of the Source property from the first AdomdError in the AdomdErrorCollection contained by the exception.
public property StackTrace (inherited from AdomdException) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from AdomdException) | Gets the name of the method that threw the current exception.

Protected Properties

protected property HResult (inherited from AdomdException) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

See Also

AdomdErrorResponseException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException.ErrorCode Property

Gets the value of the ErrorCode property from the first AdomdError in the AdomdErrorCollection contained by the exception.

[Visual Basic]
Public ReadOnly Property ErrorCode As Integer
[C#]
public int ErrorCode {get;}
[C++]
public: __property int get_ErrorCode();
[JScript]
public function get ErrorCode() : Int;
Property Value

An unsigned integer representing the ErrorCode property from the first AdomdError in the AdomdErrorCollection contained by the exception.

Remarks

The ErrorCode property typically contains the HRESULT of an error raised by the XML for Analysis Services provider or server.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorResponseException Class | AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException.Errors Property

Gets a reference to the AdomdErrorCollection contained by the exception.

[Visual Basic]
Public ReadOnly Property Errors As AdomdErrorCollection
[C#]
public AdomdErrorCollection Errors {get;}
[C++]
public: __property AdomdErrorCollection* get_Errors();
[JScript]
public function get Errors() : AdomdErrorCollection;
Property Value

An AdomdErrorCollection that describes the series of errors that led to the exception. The collection contains one or more instances of AdomdError that encapsulate the errors received by the AdomdConnection.

Example
[Visual Basic]

The following subroutine iterates through the Errors collection of an AdomdErrorResponseException in reverse order (from earliest error to latest error), displaying the properties of each AdomdError in the collection:

Public Sub ListAdomdErrors(ByRef ExceptionToCheck As AdomdErrorResponseException)
    Dim errorCount As Integer = ExceptionToCheck.Errors.Count
    Dim errorIndex As Integer

    Debug.WriteLine("Found " & errorCount & _
        " error(s) in AdomdErrorResponseException:")

    With ExceptionToCheck.Errors
        For errorIndex = errorCount - 1 To 0 Step -1
            Debug.WriteLine("Error " & errorIndex & ":")
            Debug.WriteLine("  ErrorCode:  " & _
                .Item(errorIndex).ErrorCode.ToString)
            Debug.WriteLine("  Source:     " & _
                .Item(errorIndex).Source)
            Debug.WriteLine("  Message:    " & _
                .Item(errorIndex).Message)
            Debug.WriteLine("  HelpLink:   " & _
                .Item(errorIndex).HelpLink)
        Next
    End With
End Sub
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorResponseException Class | AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException.HelpLink Property

Gets the value of the HelpLink property from the first AdomdError in the AdomdErrorCollection contained by the exception.

[Visual Basic]
Public Overrides ReadOnly Property HelpLink As String
[C#]
public override string HelpLink {get;}
[C++]
public: __property String* get_HelpLink();
[JScript]
public override function get HelpLink() : String;
Property Value

A string representing the Uniform Resource Name (URN) or Uniform Resource Locator (URL) of the Help file referenced by the first AdomdError in the AdomdErrorCollection contained by the exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorResponseException Class | AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException.Message Property

Gets the value of the Message property from the first AdomdError in the AdomdErrorCollection contained by the exception.

[Visual Basic]
Public Overrides ReadOnly Property Message As String
[C#]
public override string Message {get;}
[C++]
public: __property String* get_Message();
[JScript]
public override function get Message() : String;
Property Value

Either a string explaining the reason for the error or an empty string ("") from the first AdomdError in the AdomdErrorCollection contained by the exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorResponseException Class | AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException.Source Property

Gets the value of the Source property from the first AdomdError in the AdomdErrorCollection contained by the exception.

[Visual Basic]
Public Overrides ReadOnly Property Source As String
[C#]
public override string Source {get;}
[C++]
public: __property String* get_Source();
[JScript]
public override function get Source() : String;
Property Value

A string containing the name of the application or object from the first AdomdError in the AdomdErrorCollection contained by the exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorResponseException Class | AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException Methods

The methods of the AdomdErrorResponseException class are listed here. For a complete list of AdomdErrorResponseException class members, see AdomdErrorResponseException Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetObjectData (inherited from System.Exception) | Overridden. Sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Exception) | Creates and returns a string representation of the current exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdErrorResponseException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdErrorResponseException.GetObjectData Method

Sets the specified SerializationInfo with information about the exception.

[Visual Basic]
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext)
[C#]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
);
[C++]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Parameters
info
A SerializationInfo that holds the serialized object data about the exception being thrown.
context
A StreamingContext that contains contextual information about the source or destination.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdErrorResponseException Class | AdomdErrorResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdException Class

Represents an exception thrown by ADOMD.NET.

For a complete list of AdomdException class members, see AdomdException Members.

System.Object
System.Exception
Microsoft.AnalysisServices.AdomdClient.AdomdException
Microsoft.AnalysisServices.AdomdClient.AdomdCacheExpiredException
Microsoft.AnalysisServices.AdomdClient.AdomdConnectionException
Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException
Microsoft.AnalysisServices.AdomdClient.AdomdUnknownResponseException

[Visual Basic]
<Serializable>
Public Class AdomdException
   Inherits System.Exception
[C#]
[Serializable]
public class AdomdException : System.Exception
[C++]
[Serializable]
public __gc class AdomdException : public System.Exception
[JScript]
public
   Serializable
class AdomdException extends System.Exception
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdException Members

AdomdException Class

Public Properties

public property HelpLink (inherited from System.Exception) | Gets or sets a link to the Help file associated with this exception.
public property InnerException (inherited from System.Exception) | Gets the Exception that caused the current exception.
public property Message (inherited from System.Exception) | Gets a message that describes the current exception.
public property Source (inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
public property StackTrace (inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetObjectData (inherited from System.Exception) | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Exception) | Creates and returns a string representation of the current exception.

Protected Constructors

public property AdomdException Constructor Overridden. Initializes a new instance of the AdomdException class with serialized data.

Protected Properties

protected property HResult (inherited from System.Exception) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AdomdException class using the specified serialization and stream context.

[Visual Basic]
Public Sub New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
[C#]
public AdomdException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
);
[C++]
public: AdomdException(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
);
[JScript]
public function AdomdException(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Parameters
info
The data necessary to serialize or deserialize an object.
context
Description of the source and destination of the specified serialized stream.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdException Class | AdomdException Members | Microsoft.AnalysisServices.AdomdClient Namespace |


AdomdProperty Class

Represents a property of a command.

For a list of all members of this type, see AdomdProperty Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AdomdProperty

[Visual Basic]
NotInheritable Public Class AdomdProperty
[C#]
public sealed class AdomdProperty
[C++]
public __gc __sealed class AdomdProperty
[JScript]
public class AdomdProperty
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty Members

For more information about the AdomdProperty class, see AdomdProperty Class.

Public Constructors

public constructor AdomdProperty Constructor Overloaded. Initializes a new AdomdProperty.

Public Properties

public property Name | Gets or sets a string representing the name of the AdomdProperty.
public property Namespace | Gets or sets a string representing the namespace of the AdomdProperty.
public property Parent | Gets an object representing the parent of the AdomdProperty.
public property Value | Gets or sets an object representing the value of the AdomdProperty.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty Constructor

Initializes a new instance of the AdomdProperty class.

Overload List

Initializes a new instance of the AdomdProperty class with the name and value of the property.

[Visual Basic] Public Sub New(System.String, System.Object)
[C#] public AdomdProperty(System.String, System.Object);
[C++] public: AdomdProperty(System.String, System.Object);
[JScript] public function AdomdProperty(System.String, System.Object);

Initializes a new instance of the AdomdProperty class with the name, namespace, and value of the property.

[Visual Basic] Public Sub New(System.String, System.String, System.Object)
[C#] public AdomdProperty(System.String, System.String, System.Object);
[C++] public: AdomdProperty(System.String, System.String, System.Object);
[JScript] public function AdomdProperty(System.String, System.String, System.Object);
See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty Constructor (System.String, System.Object)

Initializes a new instance of the AdomdProperty class with the name and value of the property.

[Visual Basic]

Public Sub New( _
   ByVal name As String, _
   ByVal propertyValue As Object _
)
[C#]
public AdomdProperty(
   string name,
   object propertyValue
);
[C++]
public: AdomdProperty(
   String* name,
   Object* propertyValue
);
[JScript]
public function AdomdProperty(
   name : String,
   propertyValue : Object
);
Parameters
name
The name of the property to be created.
propertyValue
The value of the property to be created.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdProperty Constructor Overload List


AdomdProperty Constructor (System.String, System.String, System.Object)

Initializes a new instance of the AdomdProperty class with the name, namespace, and value of the property.

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal propertyNamespace As String, _
   ByVal propertyValue As Object _
)
[C#]
public AdomdProperty(
   string name,
   string propertyNamespace,
   object propertyValue
);
[C++]
public: AdomdProperty(
   String* name,
   String* propertyNamespace,
   Object* propertyValue
);
[JScript]
public function AdomdProperty(
   name : String,
   propertyNamespace : String,
   propertyValue : Object
);
Parameters
name
The name of the property to be created.
propertyNamespace
The namespace of the property to be created.
propertyValue
The value of the property to be created.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdProperty Constructor Overload List


AdomdProperty Properties

The properties of the AdomdProperty class are listed here. For a complete list of AdomdProperty class members, see AdomdProperty Members.

Public Properties

public property Name | Gets or sets a string representing the name of the AdomdProperty.
public property Namespace | Gets or sets a string representing the namespace of the AdomdProperty.
public property Parent | Gets an object representing the parent of the AdomdProperty.
public property Value | Gets or sets an object representing the value of the AdomdProperty.

See Also

AdomdProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty.Name Property

Gets or sets a String representing the name of the AdomdProperty.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);
Property Value

A String that contains the name for the AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty.Namespace Property

Gets or sets a String representing the namespace of the AdomdProperty.

[Visual Basic]
Public Property Namespace As String
[C#]
public string Namespace {get; set;}
[C++]
public: __property String* get_Namespace();
public: __property void set_Namespace(String*);
[JScript]
public function get Namespace() : String;
public function set Namespace(String);
Property Value

A String that contains the namespace for the AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty.Parent Property

Gets an Object representing the parent of the AdomdProperty.

[Visual Basic]
Public ReadOnly Property Parent As Object
[C#]
public object Parent {get;}
[C++]
public: __property Object* get_Parent();
[JScript]
public function get Parent() : Object;
Property Value

An Object that contains the parent for the AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdProperty.Value Property

Gets or sets an Object representing the value of the AdomdProperty.

[Visual Basic]
Public Overridable Property Value As Object
[C#]
public virtual object Value {get; set;}
[C++]
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);
Property Value

An Object that contains the value for the AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdProperty Class | AdomdProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection Class

This class gets a collection of AdomdProperty objects contained in an AdomdCommand.

For a list of all members of this type, see AdomdPropertyCollection Members.

System.Object
System.MarshalByRefObject
Microsoft.AnalysisServices.AdomdClient.AdomdPropertyCollection

[Visual Basic]
NotInheritable Public Class AdomdPropertyCollection
   Inherits MarshalByRefObject
   Implements IList, ICollection, IEnumerable
[C#]
public sealed class AdomdPropertyCollection : MarshalByRefObject,
   IList, ICollection, IEnumerable
[C++]
public __gc __sealed class AdomdPropertyCollection : public
   MarshalByRefObject, IList, ICollection, IEnumerable
[JScript]
public class AdomdPropertyCollection extends MarshalByRefObject
   implements IList, ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection Members

For more information about the AdomdPropertyCollection class, see AdomdPropertyCollection overview.

Public Properties

public property Count | Gets the number of AdomdProperty objects in the collection.
public property IsFixedSize | Gets a value indicating whether the AdomdPropertyCollection has a fixed size.
public property IsReadOnly | Gets a value indicating whether the AdomdPropertyCollection is read-only.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Dimension from the collection. In C#, this property is the indexer for the AdomdPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method Add | Overloaded. Adds an AdomdProperty to the end of the AdomdPropertyCollection.
public method Clear | Removes all AdomdProperty objects from the AdomdPropertyCollection.
public method Contains | Determines whether an AdomdProperty is in the AdomdPropertyCollection.
public method CopyTo | Copies the elements of the collection to the specified array.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Overloaded. Returns the specified AdomdProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this AdomdPropertyCollection.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method IndexOf | Returns the zero-based index of the first occurrence of an AdomdProperty in the AdomdPropertyCollection or in a portion of it.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this AdomdPropertyCollection.
public method Insert | Inserts an AdomdProperty into the AdomdPropertyCollection at the specified index.
public method Remove | Removes the first occurrence of a specific AdomdProperty from the AdomdPropertyCollection.
public method RemoveAt | Removes the AdomdProperty at the specified index of the AdomdPropertyCollection.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IList.Item Gets or sets the element at the specified index.

In C#, this property is the indexer for the AdomdPropertyCollection class.

See Also

AdomdPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection Properties

The properties of the AdomdPropertyCollection class are listed here. For a complete list of AdomdPropertyCollection class members, see the AdomdPropertyCollection Members topic.

Public Properties

public property Count | Gets the number of AdomdProperty objects in the collection.
public property IsFixedSize | Gets a value indicating whether the AdomdPropertyCollection has a fixed size.
public property IsReadOnly | Gets a value indicating whether the AdomdPropertyCollection is read-only.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
public property Item | Overloaded. Gets the specified Dimension from the collection. In C#, this property is the indexer for the AdomdPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

System.Collections.IList.Item Gets or sets the element at the specified index.

In C#, this property is the indexer for the AdomdPropertyCollection class.

See Also

AdomdPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Count Property

Gets the number of AdomdProperty objects in the AdomdPropertyCollection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of AdomdProperty objects in the AdomdPropertyCollection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IsFixedSize Property

Gets a value indicating whether the AdomdPropertyCollection has a fixed size.

[Visual Basic]
Public Overridable ReadOnly Property IsFixedSize As Boolean  _
   Implements IList.IsFixedSize
[C#]
public virtual bool IsFixedSize {get;}
[C++]
public: __property virtual bool get_IsFixedSize();
[JScript]
public function get IsFixedSize() : Boolean;
Property Value

true if the AdomdPropertyCollection has a fixed size; false otherwise. The default is false.

Implements

IList.IsFixedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security:

Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IsReadOnly Property

Gets a value indicating whether the AdomdPropertyCollection is read-only.

[Visual Basic]
Public Overridable ReadOnly Property IsReadOnly As Boolean  _
   Implements IList.IsReadOnly
[C#]
public virtual bool IsReadOnly {get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;
Property Value

true if the AdomdPropertyCollection is read-only; false otherwise. The default is false.

Implements

IList.IsReadOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the AdomdPropertyCollection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Item Property

Gets the specified AdomdProperty from the AdomdPropertyCollection by its index.

[C#] In C#, this property is the indexer for the AdomdPropertyCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As AdomdProperty
[C#]
public AdomdProperty this[
   int index
] {get; set;}
[C++]
public: __property AdomdProperty* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   AdomdProperty*
);
[JScript]
returnValue = AdomdPropertyCollectionObject.Item(index);
AdomdPropertyCollectionObject.Item(index) = returnValue;
-or-
returnValue = AdomdPropertyCollectionObject(index);
AdomdPropertyCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the AdomdProperty to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the AdomdProperty to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the AdomdPropertyCollection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the AdomdPropertyCollection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.System.Collections.IList.Item Property

Gets the specified AdomdProperty from the AdomdPropertyCollection by its index.

[C#] In C#, this property is the indexer for the AdomdPropertyCollection class.

[Visual Basic]
Private Default Property Item( _
   ByVal index As Integer _
) As Object Implements IList.Item
[C#]
object IList.this[
   int index
] {get; set;}
[C++]
private: __property Object* System::Collections::IList::get_Item(
   int index
);
private: __property void System::Collections::IList::set_Item(
   int index,
   Object*
);
[JScript]
private function get IList.get_Item(index : int) : Object;
private function set IList.set_Item(index : int, value : Object);
-or-
private function get IList.get_Item(index : int) : Object;
private function set IList.set_Item(index : int, value : Object);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the AdomdProperty to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the AdomdProperty to find.
Implements

IList.Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection Methods

The methods of the AdomdPropertyCollection class are listed here. For a complete list of AdomdPropertyCollection class members, see AdomdPropertyCollection Members.

Public Methods

public method Add | Overloaded. Adds an AdomdProperty to the end of the AdomdPropertyCollection.
public method Clear | Removes all AdomdProperty objects from the AdomdPropertyCollection.
public method Contains | Determines whether an AdomdProperty is in the AdomdPropertyCollection.
public method CopyTo | Copies the elements of the collection to the specified array.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Overloaded. Returns the specified AdomdProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this AdomdPropertyCollection.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method IndexOf | Returns the zero-based index of the first occurrence of an AdomdProperty in the AdomdPropertyCollection or in a portion of it.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this AdomdPropertyCollection.
public method Insert | Inserts an AdomdProperty into the AdomdPropertyCollection at the specified index.
public method Remove | Removes the first occurrence of a specific AdomdProperty from the AdomdPropertyCollection.
public method RemoveAt | Removes the AdomdProperty at the specified index of the AdomdPropertyCollection.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Add Method

Adds an AdomdProperty to the AdomdPropertyCollection.

Overload List

Adds an AdomdProperty to the collection.

[Visual Basic] Overloads Public Function Add(AdomdProperty) As AdomdProperty
[C#] public AdomdProperty Add(AdomdProperty);
[C++] public: AdomdProperty* Add(AdomdProperty*);
[JScript] public function Add(AdomdProperty) : AdomdProperty;

Creates a new AdomdProperty with the specified property name and value.

[Visual Basic] Overloads Public Function Add(System.String, System.Object) As AdomdProperty
[C#] public AdomdProperty Add(System.String, System.Object);
[C++] public: AdomdProperty* Add(System.String, System.Object);
[JScript] public function Add(System.String, System.Object) : AdomdProperty;

Creates a new AdomdProperty with the specified property name, namespace, and value.

[Visual Basic] Overloads Public Function Add(System.String, System.String, System.Object) As AdomdProperty
[C#] public AdomdProperty Add(System.String, System.String, System.Object);
[C++] public: AdomdProperty* Add(System.String, System.String, System.Object);
[JScript] public function Add(System.String, System.String, System.Object) : AdomdProperty;
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Add Method (AdomdProperty)

Adds an AdomdProperty to the AdomdPropertyCollection.

[Visual Basic]
Public Overloads Function Add( _
   ByVal value As AdomdProperty _
) As AdomdProperty
[C#]
public AdomdProperty Add(
   AdomdProperty value
);
[C++]
public: AdomdProperty* Add(
   AdomdProperty* value
);
[JScript]
public function Add(
   value : AdomdProperty
) : AdomdProperty;
Parameters
value
The AdomdProperty to be added.
Return Value

An AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdPropertyCollection.Add Overload List


AdomdPropertyCollection.Add Method (System.String, System.Object)

Creates a new AdomdProperty with the specified property name and value.

[Visual Basic]
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal value As Object _
) As AdomdProperty
[C#]
public AdomdProperty Add(
   string propertyName,
   object value
);
[C++]
public: AdomdProperty* Add(
   String* propertyName,
   Object* value
);
[JScript]
public function Add(
   propertyName : String,
   value : Object
) : AdomdProperty;
Parameters
propertyName
The name of the AdomdProperty to be created.
value
The value of the AdomdProperty to be created.
Return Value

An AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdPropertyCollection.Add Overload List


AdomdPropertyCollection.Add Method (System.String, System.String, System.Object)

Creates a new AdomdProperty with the specified property name, namespace, and value.

[Visual Basic]
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal propertyNamespace As String, _
   ByVal value As Object _
) As AdomdProperty
[C#]
public AdomdProperty Add(
   string propertyName,
   string propertyNamespace,
   object value
);
[C++]
public: AdomdProperty* Add(
   String* propertyName,
   String* propertyNamespace,
   Object* value
);
[JScript]
public function Add(
   propertyName : String,
   propertyNamespace : String,
   value : Object
) : AdomdProperty;
Parameters
propertyName
The name of the AdomdProperty to be created.
propertyNamespace
The namespace of the AdomdProperty to be created.
value
The value of the AdomdProperty to be created.
Return Value

An AdomdProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdPropertyCollection.Add Overload List


AdomdPropertyCollection.Clear Method

Removes all properties from the AdomdPropertyCollection.

[Visual Basic]
Public Overridable Sub Clear() Implements IList.Clear
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();
Implements

IList.Clear

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Contains Method

Determines whether a property is in the AdomdPropertyCollection.

[Visual Basic]
Public Function Contains( _
   ByVal value As AdomdProperty _
) As Boolean
[C#]
public bool Contains(
   AdomdProperty value
);
[C++]
public: bool Contains(
   AdomdProperty* value
);
[JScript]
public function Contains(
   value : AdomdProperty
) : Boolean;
Parameters
value
The AdomdProperty to find.
Return Value

A Boolean that contains true if the AdomdProperty exists in the collection; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.CopyTo Method

Copies the elements of the AdomdPropertyCollection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As AdomdProperty, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   AdomdProperty[] array,
   int index
);
[C++]
public: void CopyTo(
   AdomdProperty* array[],
   int index
);
[JScript]
public function CopyTo(
   array : AdomdProperty[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Find Method

Gets the specified AdomdProperty from the AdomdPropertyCollection by its name.

Note If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Overload List

Gets the specified AdomdProperty from the collection by its name.

[Visual Basic] Overloads Public Function Find(System.String) As AdomdProperty
[C#] public AdomdProperty Find(System.String);
[C++] public: AdomdProperty* Find(System.String);
[JScript] public function Find(System.String) : AdomdProperty;

Gets the specified AdomdProperty from the collection by its name and namespace.

[Visual Basic] Overloads Public Function Find(System.String, System.String) As AdomdProperty
[C#] public AdomdProperty Find(System.String, System.String);
[C++] public: AdomdProperty* Find(System.String, System.String);
[JScript] public function Find(System.String, System.String) : AdomdProperty;
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Find Method (System.String)

Gets the specified AdomdProperty from the AdomdPropertyCollection by its name.

[Visual Basic]
Public Overloads Function Find( _
   ByVal propertyName As String _
) As AdomdProperty
[C#]
public AdomdProperty Find(
   string propertyName
);
[C++]
public: AdomdProperty* Find(
   String* propertyName
);
[JScript]
public function Find(
   propertyName : String
) : AdomdProperty;
Parameters
propertyName
The name of the AdomdProperty to find.
Return Value

An AdomdProperty.

Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdPropertyCollection.Find Overload List


AdomdPropertyCollection.Find Method (System.String, System.String)

Gets the specified AdomdProperty from the AdomdPropertyCollection by its name and namespace.

[Visual Basic]
Public Overloads Function Find( _
   ByVal propertyName As String, _
   ByVal propertyNamespace As String _
) As AdomdProperty
[C#]
public AdomdProperty Find(
   string propertyName,
   string propertyNamespace
);
[C++]
public: AdomdProperty* Find(
   String* propertyName,
   String* propertyNamespace
);
[JScript]
public function Find(
   propertyName : String,
   propertyNamespace : String
) : AdomdProperty;
Parameters
propertyName
The name of the AdomdProperty to find.
propertyNamespace
The namespace of the AdomdProperty to find.
Return Value

An AdomdProperty.

Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdPropertyCollection.Find Overload List


AdomdPropertyCollection.GetEnumerator Method

Gets an Enumerator for iterating through the AdomdPropertyCollection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IList.Add Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function Add( _
   ByVal value As Object _
) As Integer Implements IList.Add
[C#]
int IList.Add(
   object value
);
[C++]
private: int IList::Add(
   Object* value
);
[JScript]
private function IList.Add(
   value : Object
) : int;
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IList.Contains Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function Contains( _
   ByVal value As Object _
) As Boolean Implements IList.Contains
[C#]
bool IList.Contains(
   object value
);
[C++]
private: bool IList::Contains(
   Object* value
);
[JScript]
private function IList.Contains(
   value : Object
) : Boolean;
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IList.IndexOf Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function IndexOf( _
   ByVal value As Object _
) As Integer Implements IList.IndexOf
[C#]
int IList.IndexOf(
   object value
);
[C++]
private: int IList::IndexOf(
   Object* value
);
[JScript]
private function IList.IndexOf(
   value : Object
) : int;
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IList.Insert Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
) Implements IList.Insert
[C#]
void IList.Insert(
   int index,
   object value
);
[C++]
private: void IList::Insert(
   int index,
   Object* value
);
[JScript]
private function IList.Insert(
   index : int,
   value : Object
);
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IList.Remove Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub Remove( _
   ByVal value As Object _
) Implements IList.Remove
[C#]
void IList.Remove(
   object value
);
[C++]
private: void IList::Remove(
   Object* value
);
[JScript]
private function IList.Remove(
   value : Object
);
See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a property in the AdomdPropertyCollection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As AdomdProperty _
) As Integer
[C#]
public int IndexOf(
   AdomdProperty value
);
[C++]
public: int IndexOf(
   AdomdProperty* value
);
[JScript]
public function IndexOf(
   value : AdomdProperty
) : int;
Parameters
value
The AdomdProperty to locate in the AdomdPropertyCollection.
Return Value

The index of value if found in the list; -1 otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Insert Method

Inserts a property into the AdomdPropertyCollection at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As AdomdProperty _
)
[C#]
public void Insert(
   int index,
   AdomdProperty value
);
[C++]
public: void Insert(
   int index,
   AdomdProperty* value
);
[JScript]
public function Insert(
   index : int,
   value : AdomdProperty
);
Parameters
index
The zero-based index at which value should be inserted.
value
The AdomdProperty to insert into the AdomdPropertyCollection.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.Remove Method

Removes the first occurrence of a specified property from the AdomdPropertyCollection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As AdomdProperty _
)
[C#]
public void Remove(
   AdomdProperty value
);
[C++]
public: void Remove(
   AdomdProperty* value
);
[JScript]
public function Remove(
   value : AdomdProperty
);
Parameters
value
The AdomdProperty to remove from the AdomdPropertyCollection.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdPropertyCollection.RemoveAt Method

Removes the property at the specified index of the AdomdPropertyCollection.

[Visual Basic]
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
) Implements IList.RemoveAt
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);
Parameters
index
The zero-based index of the AdomdProperty to remove.
Implements

IList.RemoveAt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdPropertyCollection Class | AdomdPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction Class

Restricts the information returned when retrieving schema information from a connection.

For a list of all members of this type, see AdomdRestriction Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AdomdRestriction

[Visual Basic]
NotInheritable Public Class AdomdRestriction
[C#]
public sealed class AdomdRestriction
[C++]
public __gc __sealed class AdomdRestriction
[JScript]
public class AdomdRestriction
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction Members

AdomdRestriction Class

Public Constructors

public constructor AdomdRestriction Constructor Overloaded. Initializes a new AdomdRestriction.

Public Properties

public property Name | Gets or sets the name of the AdomdRestriction.
public property Namespace | Gets or sets the XML namespace with which the AdomdRestriction will be serialized.
public property Parent | Gets the containing collection, or null if the AdomdRestriction is not in a collection.
public property Value | Gets or sets the value of the AdomdRestriction.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdRestriction Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction Constructor

Initializes a new instance of the AdomdRestriction class.

Overload List

Initializes a new instance of the AdomdRestriction class, using name and value parameters.

[Visual Basic] Public Sub New(System.String, System.Object)
[C#] public AdomdRestriction(System.String, System.Object);
[C++] public: AdomdRestriction(System.String, System.Object);
[JScript] public function AdomdRestriction(System.String, System.Object);

Initializes a new instance of the AdomdRestriction class, using name, namespace, and value parameters.

[Visual Basic] Public Sub New(System.String, System.String, System.Object)
[C#] public AdomdRestriction(System.String, System.String, System.Object);
[C++] public: AdomdRestriction(System.String, System.String, System.Object);
[JScript] public function AdomdRestriction(System.String, System.String, System.Object);
See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction Constructor (System.String, System.Object)

Initializes a new instance of the AdomdRestriction class using name and value parameters.

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal restrictionValue As Object _
)
[C#]
public AdomdRestriction(
   string name,
   object restrictionValue
);
[C++]
public: AdomdRestriction(
   String* name,
   Object* restrictionValue
);
[JScript]
public function AdomdRestriction(
   name : String,
   restrictionValue : Object
);
Parameters
name
The name of the restriction.
restrictionValue
The value of the restriction.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestriction Constructor Overload List


AdomdRestriction Constructor (System.String, System.String, System.Object)

Initializes a new instance of the AdomdRestriction class, using name, namespace, and value parameters.

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal restrictionNamespace As String, _
   ByVal restrictionValue As Object _
)
[C#]
public AdomdRestriction(
   string name,
   string restrictionNamespace,
   object restrictionValue
);
[C++]
public: AdomdRestriction(
   String* name,
   String* restrictionNamespace,
   Object* restrictionValue
);
[JScript]
public function AdomdRestriction(
   name : String,
   restrictionNamespace : String,
   restrictionValue : Object
);
Parameters
name
The name of the restriction.
restrictionNamespace
The namespace with which the restriction is to be serialized. If blank, the restriction uses the default Discover namespace.
restrictionValue
The value of the restriction.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestriction Constructor Overload List


AdomdRestriction Properties

The properties of the AdomdRestriction class are listed here. For a complete list of AdomdRestriction class members, see AdomdRestriction Members.

Public Properties

public property Name | Gets or sets the name of the AdomdRestriction.
public property Namespace | Gets or sets the XML namespace with which the AdomdRestriction will be serialized.
public property Parent | Gets the containing collection, or null if the AdomdRestriction is not in a collection.
public property Value | Gets or sets the value of the AdomdRestriction.

See Also

AdomdRestriction Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction.Name Property

Gets or sets the name of the AdomdRestriction.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);
Property Value

A String that contains the name of the AdomdRestriction.

Remarks

The name of the AdomdRestriction is used to map the restriction to the underlying restriction column that the AdomdRestriction will apply to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction.Namespace Property

Gets or sets the XML namespace with which the AdomdRestriction will be serialized.

[Visual Basic]
Public Property Namespace As String
[C#]
public string Namespace {get; set;}
[C++]
public: __property String* get_Namespace();
public: __property void set_Namespace(String*);
[JScript]
public function get Namespace() : String;
public function set Namespace(String);
Property Value

A String that contains the namespace with which the AdomdRestriction will be serialized.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction.Parent Property

Gets the containing collection, or null if the AdomdRestriction is not in a collection.

[Visual Basic]
Public ReadOnly Property Parent As Object
[C#]
public object Parent {get;}
[C++]
public: __property Object* get_Parent();
[JScript]
public function get Parent() : Object;
Property Value

Gets an instance of the containing collection for the AdomdRestriction, or null if the AdomdRestriction is not yet in a collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestriction.Value Property

Gets or sets the value of the AdomdRestriction.

[Visual Basic]
Public Overridable Property Value As Object
[C#]
public virtual object Value {get; set;}
[C++]
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);
Property Value

An Object that contains the value of the AdomdRestriction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestriction Class | AdomdRestriction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection Class

Gets a collection of AdomdRestriction objects.

For a list of all members of this type, see AdomdRestrictionCollection Members.

System.Object
System.MarshalByRefObject
Microsoft.AnalysisServices.AdomdClient.AdomdRestrictionCollection

[Visual Basic]
NotInheritable Public Class AdomdRestrictionCollection
   Inherits MarshalByRefObject
   Implements IList, ICollection, IEnumerable
[C#]
public sealed class AdomdRestrictionCollection :
   MarshalByRefObject, IList, ICollection, IEnumerable
[C++]
public __gc __sealed class AdomdRestrictionCollection : public
   MarshalByRefObject, IList, ICollection, IEnumerable
[JScript]
public class AdomdRestrictionCollection extends MarshalByRefObject
   implements IList, ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection Members

AdomdRestrictionCollection overview

Public Constructors

public constructor AdomdRestrictionCollection Constructor Initializes a new AdomdRestrictionCollection.

Public Properties

public property Count | Gets the number of AdomdRestriction objects in the collection.
public property IsFixedSize | Gets a value indicating whether the AdomdRestrictionCollection has a fixed size.
public property IsReadOnly | Gets a value indicating whether the AdomdRestrictionCollection is read-only.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified AdomdRestriction object from the collection. In C#, this property is the indexer for the AdomdRestrictionCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method Add | Overloaded. Adds a restriction to the end of the AdomdRestrictionCollection.
public method Clear | Removes all restrictions from the AdomdRestrictionCollection.
public method Contains | Determines whether a restriction is in the AdomdRestrictionCollection.
public method CopyTo | Copies the elements of the collection to the specified array.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Overloaded. Returns the specified AdomdRestriction from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this AdomdRestrictionCollection.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method IndexOf | Returns the zero-based index of the first occurrence of a restriction in the AdomdRestriction or in a portion of it.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this AdomdRestrictionCollection.
public method Insert | Inserts a restriction into the AdomdRestrictionCollection at the specified index.
public method Remove | Removes the first occurrence of a specific restriction from the AdomdRestrictionCollection.
public method RemoveAt | Removes the restriction at the specified index of the AdomdRestrictionCollection.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IList.Item Gets or sets the element at the specified index.

In C#, this property is the indexer for the AdomdRestrictionCollection class.

See Also

AdomdRestrictionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection Constructor

Initializes a new instance of the AdomdRestrictionCollection class.

[Visual Basic]
Public Sub New()
[C#]
public AdomdRestrictionCollection();
[C++]
public: AdomdRestrictionCollection();
[JScript]
public function AdomdRestrictionCollection();
Remarks

The default constructor initializes any fields to their default values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection Properties

The properties of the AdomdRestrictionCollection class are listed here. For a complete list of AdomdRestrictionCollection class members, see AdomdRestrictionCollection Members.

Public Properties

public property Count | Gets the number of AdomdRestriction objects in the collection.
public property IsFixedSize | Gets a value indicating whether the AdomdRestrictionCollection has a fixed size.
public property IsReadOnly | Gets a value indicating whether the AdomdRestrictionCollection is read-only.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified AdomdRestriction from the collection. In C#, this property is the indexer for the AdomdRestrictionCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Explicit Interface Implementations

System.Collections.IList.Item Gets or sets the element at the specified index.

In C#, this property is the indexer for the AdomdRestrictionCollection class.

See Also

AdomdRestrictionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Count Property

Gets the number of AdomdRestriction objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of AdomdRestriction objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IsFixedSize Property

Gets a value indicating whether the AdomdRestrictionCollection has a fixed size.

[Visual Basic]
Public Overridable ReadOnly Property IsFixedSize As Boolean  _
   Implements IList.IsFixedSize
[C#]
public virtual bool IsFixedSize {get;}
[C++]
public: __property virtual bool get_IsFixedSize();
[JScript]
public function get IsFixedSize() : Boolean;
Property Value

true if the AdomdRestrictionCollection has a fixed size; false otherwise. The default is false.

Implements

IList.IsFixedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IsReadOnly Property

Gets a value indicating whether the AdomdRestrictionCollection is read-only.

[Visual Basic]
Public Overridable ReadOnly Property IsReadOnly As Boolean  _
   Implements IList.IsReadOnly
[C#]
public virtual bool IsReadOnly {get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;
Property Value

true if the AdomdRestrictionCollection is read-only; false otherwise. The default is false.

Implements

IList.IsReadOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

true if the AdomdRestrictionCollection is synchronized (thread safe); false otherwise. The default is false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Item Property

Gets the specified AdomdRestriction from the collection by its index.

[C#] In C#, this property is the indexer for the AdomdRestrictionCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As AdomdRestriction
[C#]
public AdomdRestriction this[
   int index
] {get; set;}
[C++]
public: __property AdomdRestriction* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   AdomdRestriction*
);
[JScript]
returnValue = AdomdRestrictionCollectionObject.Item(index);
AdomdRestrictionCollectionObject.Item(index) = returnValue;
-or-
returnValue = AdomdRestrictionCollectionObject(index);
AdomdRestrictionCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the AdomdRestriction to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the AdomdRestriction to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.System.Collections.IList.Item Property

Gets the specified AdomdRestriction from the AdomdRestrictionCollection collection by its index.

[C#] In C#, this property is the indexer for the AdomdRestrictionCollection class.

[Visual Basic]
Private Default Property Item( _
   ByVal index As Integer _
) As Object Implements IList.Item
[C#]
object IList.this[
   int index
] {get; set;}
[C++]
private: __property Object* System::Collections::IList::get_Item(
   int index
);
private: __property void System::Collections::IList::set_Item(
   int index,
   Object*
);
[JScript]
private function get IList.get_Item(index : int) : Object;
private function set IList.set_Item(index : int, value : Object);
-or-
private function get IList.get_Item(index : int) : Object;
private function set IList.set_Item(index : int, value : Object);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the AdomdRestriction to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the AdomdRestriction to find.
Implements

IList.Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection Methods

The methods of the AdomdRestrictionCollection class are listed here. For a complete list of AdomdRestrictionCollection class members, see AdomdRestrictionCollection Members.

Public Methods

public method Add | Overloaded. Adds a restriction to the end of the AdomdRestrictionCollection.
public method Clear | Removes all restrictions from the AdomdRestrictionCollection.
public method Contains | Determines whether a restriction is in the AdomdRestrictionCollection.
public method CopyTo | Copies the elements of the collection to the specified array.
public method CreateObjRef (inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Overloaded. Returns the specified AdomdRestriction from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetLifetimeService (inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this AdomdRestrictionCollection.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method IndexOf | Returns the zero-based index of the first occurrence of a restriction in the AdomdRestrictionCollection.
public method InitializeLifetimeService (inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this AdomdRestrictionCollection.
public method Insert | Inserts a restriction into the AdomdRestrictionCollection at the specified index.
public method Remove | Removes the first occurrence of a specific restriction from the AdomdRestrictionCollection.
public method RemoveAt | Removes the restriction at the specified index of the AdomdRestrictionCollection.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdRestrictionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Add Method

Adds an AdomdRestriction to the AdomdRestrictionCollection collection.

Overload List

Adds an AdomdRestriction to the collection.

[Visual Basic] Overloads Public Function Add(AdomdRestriction) As AdomdRestriction
[C#] public AdomdRestriction Add(AdomdRestriction);
[C++] public: AdomdRestriction* Add(AdomdRestriction*);
[JScript] public function Add(AdomdRestriction) : AdomdRestriction;

Creates a new AdomdRestriction with the specified property name and value.

[Visual Basic] Overloads Public Function Add(System.String, System.Object) As AdomdRestriction
[C#] public AdomdRestriction Add(System.String, System.Object);
[C++] public: AdomdRestriction* Add(System.String, System.Object);
[JScript] public function Add(System.String, System.Object) : AdomdRestriction;

Creates a new AdomdRestriction with the specified property name, namespace, and value.

[Visual Basic] Overloads Public Function Add(System.String, System.String, System.Object) As AdomdRestriction
[C#] public AdomdRestriction Add(System.String, System.String, System.Object);
[C++] public: AdomdRestriction* Add(System.String, System.String, System.Object);
[JScript] public function Add(System.String, System.String, System.Object) : AdomdRestriction;
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Add Method (AdomdRestriction)

Adds an AdomdRestriction to the collection.

[Visual Basic]
Public Overloads Function Add( _
   ByVal value As AdomdRestriction _
) As AdomdRestriction
[C#]
public AdomdRestriction Add(
   AdomdRestriction value
);
[C++]
public: AdomdRestriction* Add(
   AdomdRestriction* value
);
[JScript]
public function Add(
   value : AdomdRestriction
) : AdomdRestriction;
Parameters
value
The AdomdRestriction to be added.
Return Value

An AdomdRestriction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestrictionCollection.Add Overload List


AdomdRestrictionCollection.Add Method (System.String, System.Object)

Creates a new AdomdRestriction with the specified property name and value.

[Visual Basic]
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal value As Object _
) As AdomdRestriction
[C#]
public AdomdRestriction Add(
   string propertyName,
   object value
);
[C++]
public: AdomdRestriction* Add(
   String* propertyName,
   Object* value
);
[JScript]
public function Add(
   propertyName : String,
   value : Object
) : AdomdRestriction;
Parameters
propertyName
The name of the AdomdRestriction to be created.
value
The value of the AdomdRestriction to be created.
Return Value

An AdomdRestriction class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestrictionCollection.Add Overload List


AdomdRestrictionCollection.Add Method (System.String, System.String, System.Object)

Creates a new AdomdRestriction with the specified property name, namespace, and value.

[Visual Basic]
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal propertyNamespace As String, _
   ByVal value As Object _
) As AdomdRestriction
[C#]
public AdomdRestriction Add(
   string propertyName,
   string propertyNamespace,
   object value
);
[C++]
public: AdomdRestriction* Add(
   String* propertyName,
   String* propertyNamespace,
   Object* value
);
[JScript]
public function Add(
   propertyName : String,
   propertyNamespace : String,
   value : Object
) : AdomdRestriction;
Parameters
propertyName
The name of the AdomdRestriction to be created.
propertyNamespace
The namespace of the AdomdRestriction to be created.
value
The value of the AdomdRestriction to be created.
Return Value

An AdomdRestriction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestrictionCollection.Add Overload List


AdomdRestrictionCollection.Clear Method

Removes all restrictions from the AdomdRestrictionCollection.

[Visual Basic]
Public Overridable Sub Clear() Implements IList.Clear
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();
Implements

IList.Clear

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Contains Method

Determines whether a restriction is in the AdomdRestrictionCollection.

[Visual Basic]
Public Function Contains( _
   ByVal value As AdomdRestriction _
) As Boolean
[C#]
public bool Contains(
   AdomdRestriction value
);
[C++]
public: bool Contains(
   AdomdRestriction* value
);
[JScript]
public function Contains(
   value : AdomdRestriction
) : Boolean;
Parameters
value
The AdomdRestriction to find.
Return Value

A Boolean that contains true if the AdomdRestriction exists in the collection; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.CopyTo Method

Copies the elements of the AdomdRestrictionCollection collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As AdomdRestriction, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   AdomdRestriction[] array,
   int index
);
[C++]
public: void CopyTo(
   AdomdRestriction* array[],
   int index
);
[JScript]
public function CopyTo(
   array : AdomdRestriction[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Find Method

Gets the specified AdomdRestriction from the collection by its name.

Note If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Overload List

Gets the specified AdomdRestriction from the collection by its name.

[Visual Basic] Overloads Public Function Find(System.String) As AdomdRestriction
[C#] public AdomdRestriction Find(System.String);
[C++] public: AdomdRestriction* Find(System.String);
[JScript] public function Find(System.String) : AdomdRestriction;

Gets the specified AdomdRestriction from the collection by its name and namespace.

[Visual Basic] Overloads Public Function Find(System.String, System.String) As AdomdRestriction
[C#] public AdomdRestriction Find(System.String, System.String);
[C++] public: AdomdRestriction* Find(System.String, System.String);
[JScript] public function Find(System.String, System.String) : AdomdRestriction;
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Find Method (System.String)

Gets the specified AdomdRestriction from the collection by its name.

[Visual Basic]
Public Overloads Function Find( _
   ByVal propertyName As String _
) As AdomdRestriction
[C#]
public AdomdRestriction Find(
   string propertyName
);
[C++]
public: AdomdRestriction* Find(
   String* propertyName
);
[JScript]
public function Find(
   propertyName : String
) : AdomdRestriction;
Parameters
propertyName
The name of the AdomdRestriction to find.
Return Value

An AdomdRestriction.

Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestrictionCollection.Find Overload List


AdomdRestrictionCollection.Find Method (System.String, System.String)

Gets the specified AdomdRestriction from the collection by its name and namespace.

[Visual Basic]
Public Overloads Function Find( _
   ByVal propertyName As String, _
   ByVal propertyNamespace As String _
) As AdomdRestriction
[C#]
public AdomdRestriction Find(
   string propertyName,
   string propertyNamespace
);
[C++]
public: AdomdRestriction* Find(
   String* propertyName,
   String* propertyNamespace
);
[JScript]
public function Find(
   propertyName : String,
   propertyNamespace : String
) : AdomdRestriction;
Parameters
propertyName
The name of the AdomdRestriction to find.
propertyNamespace
The namespace of the AdomdRestriction to find.
Return Value

An AdomdRestriction.

Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AdomdRestrictionCollection.Find Overload List


AdomdRestrictionCollection.GetEnumerator Method

Gets an instance of the Enumerator class for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IList.Add Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function Add( _
   ByVal value As Object _
) As Integer Implements IList.Add
[C#]
int IList.Add(
   object value
);
[C++]
private: int IList::Add(
   Object* value
);
[JScript]
private function IList.Add(
   value : Object
) : int;
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IList.Contains Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function Contains( _
   ByVal value As Object _
) As Boolean Implements IList.Contains
[C#]
bool IList.Contains(
   object value
);
[C++]
private: bool IList::Contains(
   Object* value
);
[JScript]
private function IList.Contains(
   value : Object
) : Boolean;
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IList.IndexOf Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function IndexOf( _
   ByVal value As Object _
) As Integer Implements IList.IndexOf
[C#]
int IList.IndexOf(
   object value
);
[C++]
private: int IList::IndexOf(
   Object* value
);
[JScript]
private function IList.IndexOf(
   value : Object
) : int;
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IList.Insert Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
) Implements IList.Insert
[C#]
void IList.Insert(
   int index,
   object value
);
[C++]
private: void IList::Insert(
   int index,
   Object* value
);
[JScript]
private function IList.Insert(
   index : int,
   value : Object
);
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IList.Remove Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub Remove( _
   ByVal value As Object _
) Implements IList.Remove
[C#]
void IList.Remove(
   object value
);
[C++]
private: void IList::Remove(
   Object* value
);
[JScript]
private function IList.Remove(
   value : Object
);
See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a restriction in the AdomdRestrictionCollection collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As AdomdRestriction _
) As Integer
[C#]
public int IndexOf(
   AdomdRestriction value
);
[C++]
public: int IndexOf(
   AdomdRestriction* value
);
[JScript]
public function IndexOf(
   value : AdomdRestriction
) : int;
Parameters
value
The AdomdRestriction to locate in the AdomdRestrictionCollection collection.
Return Value

The index of value if found in the list; -1 otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Insert Method

Inserts a restriction into the AdomdRestrictionCollection collection at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As AdomdRestriction _
)
[C#]
public void Insert(
   int index,
   AdomdRestriction value
);
[C++]
public: void Insert(
   int index,
   AdomdRestriction* value
);
[JScript]
public function Insert(
   index : int,
   value : AdomdRestriction
);
Parameters
index
The zero-based index at which value should be inserted.
value
The AdomdRestriction to insert into the AdomdRestrictionCollection.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Remove Method

Removes the first occurrence of a specific restriction from the AdomdRestrictionCollection collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As AdomdRestriction _
)
[C#]
public void Remove(
   AdomdRestriction value
);
[C++]
public: void Remove(
   AdomdRestriction* value
);
[JScript]
public function Remove(
   value : AdomdRestriction
);
Parameters
value
The AdomdRestriction to remove from the AdomdRestrictionCollection collection.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.RemoveAt Method

Removes the restriction at the specified index of the AdomdRestrictionCollection collection.

[Visual Basic]
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
) Implements IList.RemoveAt
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);
Parameters
index
The zero-based index of the AdomdRestriction to remove.
Implements

IList.RemoveAt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection Class | AdomdRestrictionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator Structure

Supports iterating over an AdomdRestrictionCollection and reading its individual AdomdRestriction objects.

For a list of all members of this type, see AdomdRestrictionCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.AdomdRestrictionCollection.Enumerator

[Visual Basic]
Public Structure AdomdRestrictionCollection.Enumerator
   Implements IEnumerator
[C#]
public struct AdomdRestrictionCollection.Enumerator : IEnumerator
[C++]
public __value struct AdomdRestrictionCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdRestrictionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator Members

AdomdRestrictionCollection.Enumerator Structure

Public Properties

public property Current Gets the current AdomdRestriction in the AdomdRestrictionCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next AdomdRestriction in the AdomdRestrictionCollection.
public method Reset | Moves the enumerator to a position before the first AdomdRestriction in the AdomdRestrictionCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AdomdRestrictionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator Properties

The properties of the AdomdRestrictionCollection.Enumerator structure are listed here. For a complete list of AdomdRestrictionCollection.Enumerator structure members, see AdomdRestrictionCollection.Enumerator Members.

Public Properties

public property Current Gets the current AdomdRestriction in the AdomdRestrictionCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AdomdRestrictionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator.Current Property

Gets the current AdomdRestriction in the AdomdRestrictionCollection.

[Visual Basic]
Public ReadOnly Property Current As AdomdRestriction
[C#]
public AdomdRestriction Current {get;}
[C++]
public: __property AdomdRestriction* get_Current();
[JScript]
public function get Current() : AdomdRestriction;
Property Value

The AdomdRestriction in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last AdomdRestriction in the AdomdRestrictionCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection.Enumerator Structure | AdomdRestrictionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

AdomdRestrictionCollection.Enumerator Structure | AdomdRestrictionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator Methods

The methods of the AdomdRestrictionCollection.Enumerator structure are listed here. For a complete list of AdomdRestrictionCollection.Enumerator structure members, see AdomdRestrictionCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next AdomdRestriction in the AdomdRestrictionCollection.
public method Reset | Moves the enumerator to a position before the first AdomdRestriction in the AdomdRestrictionCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdRestrictionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator.MoveNext Method

Moves to the next AdomdRestriction in the AdomdRestrictionCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection.Enumerator Structure | AdomdRestrictionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdRestrictionCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first AdomdRestriction in the AdomdRestrictionCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdRestrictionCollection.Enumerator Structure | AdomdRestrictionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid Class

Contains the most commonly available schema rowset GUIDs used by the GetSchemaDataset method of the AdomdConnection.

For a complete list of AdomdSchemaGuid class members, see AdomdSchemaGuid Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AdomdSchemaGuid

[Visual Basic]
NotInheritable Public Class AdomdSchemaGuid
[C#]
public sealed class AdomdSchemaGuid
[C++]
public __gc __sealed class AdomdSchemaGuid
[JScript]
public class AdomdSchemaGuid
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

Each field in the AdomdSchemaGuid class maps to an OLE DB or XML for Analysis schema rowset. For more information about OLE DB schema rowsets, see "Appendix B: Schema Rowsets," in the OLE DB Programmer's Reference. For more information about XML for Analysis schema rowsets, see the XML for Analysis 1.1 specification.

Note Some members of the AdomdSchemaGuid class (such as the CATALOGS schema rowset) may not be supported by your provider. Refer to your database documentation to determine whether you can retrieve this schema information using other techniques.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid Members

AdomdSchemaGuid Class

Public Fields

public field static (Shared in Visual Basic) Actions | Contains the GUID of the MDSCHEMA_ACTIONS rowset.
public field static (Shared in Visual Basic) Catalogs | Contains the GUID of the DBSCHEMA_CATALOGS schema rowset.
public field static (Shared in Visual Basic) Columns | Contains the GUID of the DBSCHEMA_COLUMNS schema rowset.
public field static (Shared in Visual Basic) Commands | Contains the GUID of the MDSCHEMA_COMMANDS schema rowset.
public field static (Shared in Visual Basic) Connections | This member supports the ADOMD.NET infrastructure and is not intended to be used directly from your code.
public field static (Shared in Visual Basic) Cubes | Contains the GUID of the MDSCHEMA_CUBES schema rowset.
public field static (Shared in Visual Basic) DatabaseSecurity | Contains the GUID of the MDSCHEMA_DATABASE_SECURITY schema rowset.
public field static (Shared in Visual Basic) DataSources | Contains the GUID of the DISCOVER_DATASOURCES schema rowset.
public field static (Shared in Visual Basic) DBConnections | Contains the GUID of the DISCOVER_DB_CONNECTIONS schema rowset.
public field static (Shared in Visual Basic) Dimensions | Contains the GUID of the MDSCHEMA_DIMENSIONS schema rowset.
public field static (Shared in Visual Basic) Enumerators | Contains the GUID of the DISCOVER_ENUMERATORS schema rowset.
public field static (Shared in Visual Basic) Functions | Contains the GUID of the MDSCHEMA_FUNCTIONS schema rowset.
public field static (Shared in Visual Basic) Hierarchies | Contains the GUID of the MDSCHEMA_HIERARCHIES schema rowset.
public field static (Shared in Visual Basic) Keywords | Contains the GUID of the DISCOVER_KEYWORDS schema rowset.
public field static (Shared in Visual Basic) Levels | Contains the GUID of the MDSCHEMA_LEVELS schema rowset.
public field static (Shared in Visual Basic) Literals | Contains the GUID of the DISCOVER_LITERALS schema rowset.
public field static (Shared in Visual Basic) Locations | Contains the GUID of the DISCOVER_LOCATIONS schema rowset.
public field static (Shared in Visual Basic) Measures | Contains the GUID of the MDSCHEMA_MEASURES schema rowset.
public field static (Shared in Visual Basic) MemberProperties | Contains the GUID of the MDSCHEMA_PROPERTIES schema rowset.
public field static (Shared in Visual Basic) Members | Contains the GUID of the MDSCHEMA_MEMBERS schema rowset.
public field static (Shared in Visual Basic) MiningColumns | Contains the GUID of the MINING_COLUMNS schema rowset.
public field static (Shared in Visual Basic) MiningFunctions | Contains the GUID of the MINING_FUNCTIONS schema rowset.
public field static (Shared in Visual Basic) MiningModelContent | Contains the GUID of the MINING_MODEL_CONTENT schema rowset.
public field static (Shared in Visual Basic) MiningModelContentPmml | Contains the GUID of the MODEL_CONTENT_PMML schema rowset.
public field static (Shared in Visual Basic) MiningModels | Contains the GUID of the MINING_MODELS schema rowset.
public field static (Shared in Visual Basic) MiningServiceParameters | Contains the GUID of the SERVICE_PARAMETERS schema rowset.
public field static (Shared in Visual Basic) MiningServices | Contains the GUID of the MINING_SERVICES schema rowset.
public field static (Shared in Visual Basic) ProviderTypes | Contains the GUID of the PROVIDER_TYPES schema rowset.
public field static (Shared in Visual Basic) SchemaRowsets | Contains the GUID of the DISCOVER_SCHEMA_ROWSETS schema rowset.
public field static (Shared in Visual Basic) Sets | Contains the GUID of the MDSCHEMA_SETS schema rowset.
public field static (Shared in Visual Basic) Tables | Contains the GUID of the DBSCHEMA_TABLES schema rowset.
public field static (Shared in Visual Basic) TablesInfo | Contains the GUID of the DBSCHEMA_TABLES_INFO schema rowset.
public field static (Shared in Visual Basic) XmlaProperties | Contains the GUID of the DISCOVER_PROPERTIES schema rowset.

See Also

AdomdSchemaGuid Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid Fields

The fields of the AdomdSchemaGuid class are listed here. For a complete list of AdomdSchemaGuid class members, see the AdomdSchemaGuid Members topic.

Public Fields

public field static (Shared in Visual Basic) Actions | Contains the GUID of the MDSCHEMA_ACTIONS rowset.
public field static (Shared in Visual Basic) Catalogs | Contains the GUID of the DBSCHEMA_CATALOGS schema rowset.
public field static (Shared in Visual Basic) Columns | Contains the GUID of the DBSCHEMA_COLUMNS schema rowset.
public field static (Shared in Visual Basic) Commands | Contains the GUID of the MDSCHEMA_COMMANDS schema rowset.
public field static (Shared in Visual Basic) Connections | This member supports the ADOMD.NET infrastructure and is not intended to be used directly from your code.
public field static (Shared in Visual Basic) Cubes | Contains the GUID of the MDSCHEMA_CUBES schema rowset.
public field static (Shared in Visual Basic) DatabaseSecurity | This GUID is reserved for future use.
public field static (Shared in Visual Basic) DataSources | Contains the GUID of the DISCOVER_DATASOURCES schema rowset.
public field static (Shared in Visual Basic) DBConnections | This GUID is reserved for future use.
public field static (Shared in Visual Basic) Dimensions | Contains the GUID of the MDSCHEMA_DIMENSIONS schema rowset.
public field static (Shared in Visual Basic) Enumerators | Contains the GUID of the DISCOVER_ENUMERATORS schema rowset.
public field static (Shared in Visual Basic) Functions | Contains the GUID of the MDSCHEMA_FUNCTIONS schema rowset.
public field static (Shared in Visual Basic) Hierarchies | Contains the GUID of the MDSCHEMA_HIERARCHIES schema rowset.
public field static (Shared in Visual Basic) Keywords | Contains the GUID of the DISCOVER_KEYWORDS schema rowset.
public field static (Shared in Visual Basic) Levels | Contains the GUID of the MDSCHEMA_LEVELS schema rowset.
public field static (Shared in Visual Basic) Literals | Contains the GUID of the DISCOVER_LITERALS schema rowset.
public field static (Shared in Visual Basic) Locations | This GUID is reserved for future use.
public field static (Shared in Visual Basic) Measures | Contains the GUID of the MDSCHEMA_MEASURES schema rowset.
public field static (Shared in Visual Basic) MemberProperties | Contains the GUID of the MDSCHEMA_PROPERTIES schema rowset.
public field static (Shared in Visual Basic) Members | Contains the GUID of the MDSCHEMA_MEMBERS schema rowset.
public field static (Shared in Visual Basic) MiningColumns | Contains the GUID of the MINING_COLUMNS schema rowset.
public field static (Shared in Visual Basic) MiningFunctions | Contains the GUID of the MINING_FUNCTIONS schema rowset.
public field static (Shared in Visual Basic) MiningModelContent | Contains the GUID of the MINING_MODEL_CONTENT schema rowset.
public field static (Shared in Visual Basic) MiningModelContentPmml | Contains the GUID of the MODEL_CONTENT_PMML schema rowset.
public field static (Shared in Visual Basic) MiningModels | Contains the GUID of the MINING_MODELS schema rowset.
public field static (Shared in Visual Basic) MiningServiceParameters | Contains the GUID of the SERVICE_PARAMETERS schema rowset.
public field static (Shared in Visual Basic) MiningServices | Contains the GUID of the MINING_SERVICES schema rowset.
public field static (Shared in Visual Basic) ProviderTypes | Contains the GUID of the PROVIDER_TYPES schema rowset.
public field static (Shared in Visual Basic) SchemaRowsets | Contains the GUID of the DISCOVER_SCHEMA_ROWSETS schema rowset.
public field static (Shared in Visual Basic) Tables | Contains the GUID of the DBSCHEMA_TABLES schema rowset.
public field static (Shared in Visual Basic) TablesInfo | Contains the GUID of the DBSCHEMA_TABLES_INFO schema rowset.
public field static (Shared in Visual Basic) XmlaProperties | Contains the GUID of the DISCOVER_PROPERTIES schema rowset.

See Also

AdomdSchemaGuid Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Actions Field

Contains the GUID of the MDSCHEMA_ACTIONS rowset.

[Visual Basic]
Public Shared ReadOnly Actions As Guid
[C#]
public static readonly Guid Actions;
[C++]
public: static Guid Actions;
[JScript]
public static var Actions : Guid;
Remarks

The MDSCHEMA_ACTIONS rowset contains information that allows OLAP tools to be easily integrated with other applications by providing descriptive and content information to perform user-defined actions.

The GUID for this schema rowset is A07CCD08-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Catalogs Field

Contains the GUID of the DBSCHEMA_CATALOGS schema rowset.

[Visual Basic]
Public Shared ReadOnly Catalogs As Guid
[C#]
public static readonly Guid Catalogs;
[C++]
public: static Guid Catalogs;
[JScript]
public static var Catalogs : Guid;
Remarks

The GUID for this schema rowset is C8B52211-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Columns Field

Contains the GUID of the DBSCHEMA_COLUMNS schema rowset.

[Visual Basic]
Public Shared ReadOnly Columns As Guid
[C#]
public static readonly Guid Columns;
[C++]
public: static Guid Columns;
[JScript]
public static var Columns : Guid;
Remarks

The GUID for this schema rowset is C8B52214-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Commands Field

Contains the GUID of the MDSCHEMA_COMMANDS schema rowset.

[Visual Basic]
Public Shared ReadOnly Commands As Guid
[C#]
public static readonly Guid Commands;
[C++]
public: static Guid Commands;
[JScript]
public static var Commands : Guid;
Remarks

The GUID for this schema rowset is A07CCD09-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Connections Field

This member supports the ADOMD.NET infrastructure and is not intended to be used directly from your code.

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Cubes Field

Contains the GUID of the MDSCHEMA_CUBES schema rowset.

[Visual Basic]
Public Shared ReadOnly Cubes As Guid
[C#]
public static readonly Guid Cubes;
[C++]
public: static Guid Cubes;
[JScript]
public static var Cubes : Guid;
Remarks

The GUID for this schema rowset is C8B522D8-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.DatabaseSecurity Field

This GUID is reserved for future use.

[Visual Basic]
Public Shared ReadOnly DatabaseSecurity As Guid
[C#]
public static readonly Guid DatabaseSecurity;
[C++]
public: static Guid DatabaseSecurity;
[JScript]
public static var DatabaseSecurity : Guid;
Remarks

The GUID for this schema rowset is A07CCD31-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.DataSources Field

Contains the GUID of the DISCOVER_DATASOURCES schema rowset.

[Visual Basic]
Public Shared ReadOnly DataSources As Guid
[C#]
public static readonly Guid DataSources;
[C++]
public: static Guid DataSources;
[JScript]
public static var DataSources : Guid;
Remarks

The GUID for this schema rowset is 06C03D41-F66D-49F3-B1B8-987F7AF4CF18.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.DBConnections Field

This GUID is reserved for future use.

[Visual Basic]
Public Shared ReadOnly DBConnections As Guid
[C#]
public static readonly Guid DBConnections;
[C++]
public: static Guid DBConnections;
[JScript]
public static var DBConnections : Guid;
Remarks

The GUID for this schema rowset is A07CCD2A-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Dimensions Field

Contains the GUID of the MDSCHEMA_DIMENSIONS schema rowset.

[Visual Basic]
Public Shared ReadOnly Dimensions As Guid
[C#]
public static readonly Guid Dimensions;
[C++]
public: static Guid Dimensions;
[JScript]
public static var Dimensions : Guid;
Remarks

The GUID for this schema rowset is C8B522D9-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Enumerators Field

Contains the GUID of the DISCOVER_ENUMERATORS schema rowset.

[Visual Basic]
Public Shared ReadOnly Enumerators As Guid
[C#]
public static readonly Guid Enumerators;
[C++]
public: static Guid Enumerators;
[JScript]
public static var Enumerators : Guid;
Remarks

The GUID for this schema rowset is 55A9E78B-ACCB-45B4-95A6-94C5065617A7.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Functions Field

Contains the GUID of the MDSCHEMA_FUNCTIONS schema rowset.

[Visual Basic]
Public Shared ReadOnly Functions As Guid
[C#]
public static readonly Guid Functions;
[C++]
public: static Guid Functions;
[JScript]
public static var Functions : Guid;
Remarks

The GUID for this schema rowset is A07CCD07-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Hierarchies Field

Contains the GUID of the MDSCHEMA_HIERARCHIES schema rowset.

[Visual Basic]
Public Shared ReadOnly Hierarchies As Guid
[C#]
public static readonly Guid Hierarchies;
[C++]
public: static Guid Hierarchies;
[JScript]
public static var Hierarchies : Guid;
Remarks

The GUID for this schema rowset is C8B522DA-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Keywords Field

Contains the GUID of the DISCOVER_KEYWORDS schema rowset.

[Visual Basic]
Public Shared ReadOnly Keywords As Guid
[C#]
public static readonly Guid Keywords;
[C++]
public: static Guid Keywords;
[JScript]
public static var Keywords : Guid;
Remarks

The GUID for this schema rowset is 1426C443-4CDD-4A40-8F45-572FAB9BBAA1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Levels Field

Contains the GUID of the MDSCHEMA_LEVELS schema rowset.

[Visual Basic]
Public Shared ReadOnly Levels As Guid
[C#]
public static readonly Guid Levels;
[C++]
public: static Guid Levels;
[JScript]
public static var Levels : Guid;
Remarks

The GUID for this schema rowset is C8B522DB-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Literals Field

Contains the GUID of the DISCOVER_LITERALS schema rowset.

[Visual Basic]
Public Shared ReadOnly Literals As Guid
[C#]
public static readonly Guid Literals;
[C++]
public: static Guid Literals;
[JScript]
public static var Literals : Guid;
Remarks

The GUID for this schema rowset is C3EF5ECB-0A07-4665-A140-B075722DBDC2.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Locations Field

This GUID is reserved for future use.

[Visual Basic]
Public Shared ReadOnly Locations As Guid
[C#]
public static readonly Guid Locations;
[C++]
public: static Guid Locations;
[JScript]
public static var Locations : Guid;
Remarks

The GUID for this schema rowset is A07CCD92-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Measures Field

Contains the GUID of the MDSCHEMA_MEASURES schema rowset.

[Visual Basic]
Public Shared ReadOnly Measures As Guid
[C#]
public static readonly Guid Measures;
[C++]
public: static Guid Measures;
[JScript]
public static var Measures : Guid;
Remarks

The GUID for this schema rowset is C8B522DC-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MemberProperties Field

Contains the GUID of the MDSCHEMA_PROPERTIES schema rowset.

[Visual Basic]
Public Shared ReadOnly MemberProperties As Guid
[C#]
public static readonly Guid MemberProperties;
[C++]
public: static Guid MemberProperties;
[JScript]
public static var MemberProperties : Guid;
Remarks

The GUID for this schema rowset is C8B522DD-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Members Field

Contains the GUID of the MDSCHEMA_MEMBERS schema rowset.

[Visual Basic]
Public Shared ReadOnly Members As Guid
[C#]
public static readonly Guid Members;
[C++]
public: static Guid Members;
[JScript]
public static var Members : Guid;
Remarks

The GUID for this schema rowset is C8B522DE-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningColumns Field

Contains the GUID of the MINING_COLUMNS schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningColumns As Guid
[C#]
public static readonly Guid MiningColumns;
[C++]
public: static Guid MiningColumns;
[JScript]
public static var MiningColumns : Guid;
Remarks

The GUID for this schema rowset is 3ADD8A78-D8B9-11D2-8D2A-00E029154FDE.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningFunctions Field

Contains the GUID of the MINING_FUNCTIONS schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningFunctions As Guid
[C#]
public static readonly Guid MiningFunctions;
[C++]
public: static Guid MiningFunctions;
[JScript]
public static var MiningFunctions : Guid;
Remarks

The GUID for this schema rowset is 3ADD8A79-D8B9-11D2-8D2A-00E029154FDE.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningModelContent Field

Contains the GUID of the MINING_MODEL_CONTENT schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningModelContent As Guid
[C#]
public static readonly Guid MiningModelContent;
[C++]
public: static Guid MiningModelContent;
[JScript]
public static var MiningModelContent : Guid;
Remarks

The GUID for this schema rowset is 3ADD8A76-D8B9-11D2-8D2A-00E029154FDE.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningModelContentPmml Field

Contains the GUID of the MODEL_CONTENT_PMML schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningModelContentPMML As Guid
[C#]
public static readonly Guid MiningModelContentPMML;
[C++]
public: static Guid MiningModelContentPMML;
[JScript]
public static var MiningModelContentPMML : Guid;
Remarks

The GUID for this schema rowset is 4290B2D5-0E9C-4AA7-9369-98C95CFD9D13.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningModels Field

Contains the GUID of the MINING_MODELS schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningModels As Guid
[C#]
public static readonly Guid MiningModels;
[C++]
public: static Guid MiningModels;
[JScript]
public static var MiningModels : Guid;
Remarks

The GUID for this schema rowset is 3ADD8A77-D8B9-11D2-8D2A-00E029154FDE.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningServiceParameters Field

Contains the GUID of the SERVICE_PARAMETERS schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningServiceParameters As Guid
[C#]
public static readonly Guid MiningServiceParameters;
[C++]
public: static Guid MiningServiceParameters;
[JScript]
public static var MiningServiceParameters : Guid;
Remarks

The GUID for this schema rowset is 3ADD8A75-D8B9-11D2-8D2A-00E029154FDE.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.MiningServices Field

Contains the GUID of the MINING_SERVICES schema rowset.

[Visual Basic]
Public Shared ReadOnly MiningServices As Guid
[C#]
public static readonly Guid MiningServices;
[C++]
public: static Guid MiningServices;
[JScript]
public static var MiningServices : Guid;
Remarks

The GUID for this schema rowset is 3ADD8A95-D8B9-11D2-8D2A-00E029154FDE.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.ProviderTypes Field

Contains the GUID of the PROVIDER_TYPES schema rowset.

[Visual Basic]
Public Shared ReadOnly ProviderTypes As Guid
[C#]
public static readonly Guid ProviderTypes;
[C++]
public: static Guid ProviderTypes;
[JScript]
public static var ProviderTypes : Guid;
Remarks

The GUID for this schema rowset is C8B5222C-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.SchemaRowsets Field

Contains the GUID of the DISCOVER_SCHEMA_ROWSETS schema rowset.

[Visual Basic]
Public Shared ReadOnly SchemaRowsets As Guid
[C#]
public static readonly Guid SchemaRowsets;
[C++]
public: static Guid SchemaRowsets;
[JScript]
public static var SchemaRowsets : Guid;
Remarks

The GUID for this schema rowset is EEA0302B-7922-4992-8991-0E605D0E5593.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Sets Field

Contains the GUID of the MDSCHEMA_SETS schema rowset.

[Visual Basic]
Public Shared ReadOnly Sets As Guid
[C#]
public static readonly Guid Sets;
[C++]
public: static Guid Sets;
[JScript]
public static var Sets : Guid;
Remarks

The GUID for this schema rowset is A07CCD0B-8148-11D0-87BB-00C04FC33942.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.Tables Field

Contains the GUID of the DBSCHEMA_TABLES schema rowset.

[Visual Basic]
Public Shared ReadOnly Tables As Guid
[C#]
public static readonly Guid Tables;
[C++]
public: static Guid Tables;
[JScript]
public static var Tables : Guid;
Remarks

The GUID for this schema rowset is C8B52229-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.TablesInfo Field

Contains the GUID of the DBSCHEMA_TABLES_INFO schema rowset.

[Visual Basic]
Public Shared ReadOnly TablesInfo As Guid
[C#]
public static readonly Guid TablesInfo;
[C++]
public: static Guid TablesInfo;
[JScript]
public static var TablesInfo : Guid;
Remarks

The GUID for this schema rowset is C8B522E0-5CF3-11CE-ADE5-00AA0044773D.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdSchemaGuid.XmlaProperties Field

Contains the GUID of the DISCOVER_PROPERTIES schema rowset.

[Visual Basic]
Public Shared ReadOnly XmlaProperties As Guid
[C#]
public static readonly Guid XmlaProperties;
[C++]
public: static Guid XmlaProperties;
[JScript]
public static var XmlaProperties : Guid;
Remarks

The GUID for this schema rowset is 4B40ADFB-8B09-4758-97BB-636E8AE97BCF.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

AdomdSchemaGuid Class | AdomdSchemaGuid Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction Class

Represents a transaction to be performed at a multidimensional data source.

For a complete list of AdomdTransaction class members, see AdomdTransaction Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AdomdTransaction

[Visual Basic]
NotInheritable Public Class AdomdTransaction
   Implements IDbTransaction, IDisposable
[C#]
public sealed class AdomdTransaction : IDbTransaction, IDisposable
[C++]
public __gc __sealed class AdomdTransaction : public
   IDbTransaction, IDisposable
[JScript]
public class AdomdTransaction implements IDbTransaction,
   IDisposable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The AdomdTransaction class implements the System.Data.IDbTransaction interface for ADOMD.NET, and represents the standard transaction mechanism of a .NET data provider. The class is instantiated by the BeginTransaction method of the AdomdConnection.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction Members

AdomdTransaction Class

Public Properties

public property Connection | Gets the AdomdConnection that the AdomdTransaction uses.
public property IsolationLevel | Gets the isolation level that the AdomdTransaction uses.

Public Methods

public method Commit | Commits the transaction that the AdomdTransaction represents.
public method Dispose | Overridden. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method Rollback | Rolls back a transaction in a pending state that the AdomdTransaction represents.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdTransaction Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction Properties

The properties of the AdomdTransaction class are listed here. For a complete list of AdomdTransaction class members, see AdomdTransaction Members.

Public Properties

public property Connection | Gets the AdomdConnection that the AdomdTransaction uses.
public property IsolationLevel | Gets the isolation level that the AdomdTransaction uses.

See Also

AdomdTransaction Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction.Connection Property

Gets the AdomdConnection that the AdomdTransaction uses.

[Visual Basic]
Public ReadOnly Property Connection As AdomdConnection
[C#]
public AdomdConnection Connection {get;}
[C++]
public: __property AdomdConnection* get_Connection();
[JScript]
public function get Connection() : AdomdConnection;
Property Value

An AdomdConnection that contains a valid AdomdConnection reference.

Remarks

A single application can have multiple database connections, each with zero or more transactions. This property enables you to determine the connection object associated with a particular transaction.

AdomdTransaction objects cannot be reused across multiple AdomdConnection objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdTransaction Class | AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction.IsolationLevel Property

Gets the isolation level that the AdomdTransaction uses.

[Visual Basic]
Public Overridable ReadOnly Property IsolationLevel As _
   IsolationLevel  Implements IDbTransaction.IsolationLevel
[C#]
public virtual IsolationLevel IsolationLevel {get;}
[C++]
public: __property virtual IsolationLevel get_IsolationLevel();
[JScript]
public function get IsolationLevel() : IsolationLevel;
Property Value

A System.Data.IsolationLevel enumeration value that represents the isolation level of the AdomdTransaction.

Implements

IDbTransaction.IsolationLevel

Remarks

Nested transactions are not supported. Therefore, the value of the IsolationLevel property applies to the entire transaction.

This property always returns System.Data.IsolationLevel.ReadCommitted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdTransaction Class | AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction Methods

The methods of the AdomdTransaction class are listed here. For a complete list of AdomdTransaction class members, see AdomdTransaction Members.

Public Methods

public method Commit | Commits the transaction that the AdomdTransaction represents.
public method Dispose | Overridden. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method Rollback | Rolls back a transaction in a pending state that the AdomdTransaction represents.
public method ToString (inherited from System.Object) | Returns a String object hat represents the current Object.

Protected Methods

protected method Finalize | Overridden. Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdTransaction Class | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction.Commit Method

Commits the transaction that the AdomdTransaction represents.

[Visual Basic]
Public Overridable Sub Commit() Implements IDbTransaction.Commit
[C#]
public virtual void Commit();
[C++]
public: virtual void Commit();
[JScript]
public function Commit();
Implements

IDbTransaction.Commit

Remarks

This method commits the transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdTransaction Class | AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Overridable Sub Dispose() Implements IDisposable.Dispose
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();
Implements

IDisposable.Dispose

Remarks

When this method is called, any uncommitted transactions that the AdomdTransaction represents are rolled back by the Rollback method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdTransaction Class | AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction.Finalize Method

Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.

[C#] In C#, finalizers are expressed using destructor syntax.

[C++] In C++, finalizers are expressed using destructor syntax.

[Visual Basic]
Protected Overrides Sub Finalize()
[C#]
~AdomdTransaction();
[C++]
~AdomdTransaction();
[JScript]
protected override function Finalize();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdTransaction Class | AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdTransaction.Rollback Method

Rolls back a transaction in a pending state that the AdomdTransaction represents.

[Visual Basic]
Public Overridable Sub Rollback() Implements _
   IDbTransaction.Rollback
[C#]
public virtual void Rollback();
[C++]
public: virtual void Rollback();
[JScript]
public function Rollback();
Implements

IDbTransaction.Rollback

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AdomdTransaction Class | AdomdTransaction Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdUnknownResponseException Class

Represents an exception thrown by ADOMD.NET when a response has been returned from the provider that is not understood.

For a complete list of AdomdUnknownResponseException class members, see AdomdUnknownResponseException Members.

System.Object
System.Exception
Microsoft.AnalysisServices.AdmodClient.AdomdException
Microsoft.AnalysisServices.AdomdClient.AdomdUnknownResponseException

 [Visual Basic]
<Serializable>
Public NotInheritable Class AdomdUnknownResponseException
   Inherits AdomdException
[C#]
[Serializable]
public sealed class AdomdUnknownResponseException : AdomdException
[C++]
[Serializable]
public __gc __sealed class AdomdUnknownResponseException : public AdomdException
[JScript]
public
   Serializable
class AdomdUnknownResponseException extends AdomdException
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AdomdUnknownResponseException Members | Microsoft.AnalysisServices.AdomdClient Namespace


AdomdUnknownResponseException Members

AdomdUnknownResponseException Class

Public Properties

public property HelpLink (inherited from System.Exception) | Gets or sets a link to the Help file associated with this exception.
public property InnerException (inherited from System.Exception) | Gets the Exception that caused the current exception.
public property Message (inherited from System.Exception) | Gets a message that describes the current exception.
public property Source (inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
public property StackTrace (inherited from System.Exception) | Creates and returns a string representation of the frames on the call stack at the time the current exception was thrown.
public property TargetSite (inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetBaseException (inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public method GetObjectData (inherited from System.Exception) | Overridden. Sets the SerializationInfo with information about the exception.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Exception) | Creates and returns a string representation of the current exception.

Protected Properties

protected property HResult (inherited from System.Exception) Gets or sets an HRESULT, a coded numeric value that is assigned to a specific exception.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AdomdUnknownResponseException Class | Microsoft.AnalysisServices.AdomdClient Namespace


AxesInfo Class

Represents metadata pertaining to the axes that are associated with an instance of a CellSet class.

For a list of all members of this type, see AxesInfo Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AxesInfo

[Visual Basic]
NotInheritable Public Class AxesInfo
[C#]
public sealed class AxesInfo
[C++]
public __gc __sealed class AxesInfo
[JScript]
public class AxesInfo
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AxesInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxesInfo Members

AxesInfo Class

Public Properties

public property Axes | Gets an OlapInfoAxisCollection that represents metadata pertaining to the axes that are associated with the AxesInfo.
public property FilterAxis | Gets an OlapInfoAxis that represents metadata pertaining to the filter axis that are associated with the AxesInfo.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AxesInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


AxesInfo Properties

The properties of the AxesInfo class are listed here. For a complete list of AxesInfo class members, see AxesInfo Members.

Public Properties

public property Axes | Gets an OlapInfoAxisCollection that represents metadata pertaining to the axes that are associated with the AxesInfo.
public property FilterAxis | Gets an OlapInfoAxis that represents metadata pertaining to the filter axis that are associated with the AxesInfo.

See Also

AxesInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


AxesInfo.Axes Property

Gets an OlapInfoAxisCollection that represents metadata pertaining to the axes that are associated with the AxesInfo.

[Visual Basic]
Public ReadOnly Property Axes As OlapInfoAxisCollection
[C#]
public OlapInfoAxisCollection Axes {get;}
[C++]
public: __property OlapInfoAxisCollection* get_Axes();
[JScript]
public function get Axes() : OlapInfoAxisCollection;
Property Value

An OlapInfoAxisCollection that represents metadata pertaining to the axes associated with the AxesInfo.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxesInfo Class | AxesInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxesInfo.FilterAxis Property

Gets an OlapInfoAxis that represents metadata pertaining to the filter axis that is associated with the AxesInfo.

[Visual Basic]
Public ReadOnly Property FilterAxis As OlapInfoAxis
[C#]
public OlapInfoAxis FilterAxis {get;}
[C++]
public: __property OlapInfoAxis* get_FilterAxis();
[JScript]
public function get FilterAxis() : OlapInfoAxis;
Property Value

An OlapInfoAxis that represents metadata pertaining to the filter axis associated with the AxesInfo.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxesInfo Class | AxesInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Class

Represents an axis within a cellset.

For a complete list of Axis class members, see Axis Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Axis

[Visual Basic]
Public Class Axis
[C#]
public class Axis
[C++]
public __gc class Axis
[JScript]
public class Axis
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread-safe.

Remarks

An Axis represents one query or slicer axis returned in a cellset (and represented by a CellSet.) An axis is essentially a set of ordered, congruent tuples used to organize the cells in a cellset.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Members

Axis Class

Public Properties

public property Name | Gets the name of the Axis.
public property Positions | Gets a PositionCollection that contains the positions for the Axis.
public property Set | Gets a Set that contains the set for the Axis.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Axis are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Axis are not equal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Axis Class | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Properties

The properties of the Axis class are listed here. For a complete list of Axis class members, see Axis Members.

Public Properties

public property Name | Gets the name of the Axis.
public property Positions | Gets a PositionCollection that contains the positions for the Axis.
public property Set | Gets a Set that contains the set for the Axis.

See Also

Axis Class | Microsoft.AnalysisServices.AdomdClient Namespace


Axis.Name Property

Gets the name of the Axis.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the Axis.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis.Positions Property

Gets a PositionCollection that contains the positions for the Axis.

[Visual Basic]
Public ReadOnly Property Positions As PositionCollection
[C#]
public PositionCollection Positions {get;}
[C++]
public: __property PositionCollection* get_Positions();
[JScript]
public function get Positions() : PositionCollection;
Property Value

A PositionCollection that contains the positions of the Axis.

Note The Positions is available for backward compatibility. Each Position in the Positions property has a corresponding Tuple in the Set contained by that axis. Use of the Set is recommended.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis.Set Property

Gets a Set that contains the set for the Axis.

[Visual Basic]
Public ReadOnly Property Set As Set
[C#]
public Set Set {get;}
[C++]
public: __property Set* get_Set();
[JScript]
public function get Set() : Set;
Property Value

A Set that contains the set for the Axis.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Methods

The methods of the Axis class are listed here. For a complete list of Axis class members, see Axis Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Axis Class | Microsoft.AnalysisServices.AdomdClient Namespace


Axis.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the Axis.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Operators

The operators of the Axis class are listed here. For a complete list of Axis class members, see Axis Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Axis are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Axis are not equal.

See Also

Axis Class | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Equality Operator

Determines whether two specified instances of Axis are equal.

[Visual Basic]
returnValue = Axis.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Axis o1,
   Axis o2
);
[C++]
public: static bool op_Equality(
   Axis* o1,
   Axis* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
An Axis.
o2
An Axis.
Parameters [C#, C++]
o1
An Axis.
o2
An Axis.
Return Value

true if o1 and o2 represent the same Axis; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


Axis Inequality Operator

Determines whether two specified instances of Axis are equal.

[Visual Basic]
returnValue = Axis.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Axis o1,
   Axis o2
);
[C++]
public: static bool op_Inequality(
   Axis* o1,
   Axis* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
An Axis.
o2
An Axis.
Parameters [C#, C++]
o1
An Axis.
o2
An Axis.
Return Value

true if o1 and o2 do not represent the same Axis; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Axis Class | Axis Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection Class

Gets a read-only collection of Axis objects contained by a Cellset.

For a complete list of AxisCollection class members, see AxisCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.AxisCollection

[Visual Basic]
NotInheritable Public Class AxisCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class AxisCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class AxisCollection : public ICollection,
   IEnumerable
[JScript]
public class AxisCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The AxisCollection is used by a CellSet to represent the axes returned by a query. Each Axis contained by an AxisCollection represents a set of congruent tuples organized along one or more hierarchies. For more information about the Axis, see Axis Class.

Note The filter axis is not contained in this collection. To access the filter axis, you must reference the OlapInfo.AxesInfo.FilterAxes property of the CellSet.

Example
[Visual Basic]

The following subroutine, given a CellSet, iterates through the AxisCollection (represented by the Axes property of the CellSet) and displays information for each axis.

Public Sub ListAxes(ByRef cellsetToCheck As CellSet)

    ' Check the parameter before performing actions on it.
    If cellsetToCheck Is Nothing Then
        Throw New System.ArgumentNullException("cellsetToCheck")
    Else
        ' Iterate through the axes of the
        ' CellSet object. The Axes property of the
        ' CellSet object returns a reference to the
        ' AxisCollection object.

        Try
            Dim axisToCheck As Axis

            Debug.WriteLine("Found " & cellsetToCheck.Axes.Count & _
                " axes in cellset:")

            For Each axisToCheck In cellsetToCheck.Axes

                Debug.WriteLine("  Name:  " & _
                    axisToCheck.Name)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing meta data.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection Members

AxisCollection Class

Public Properties

public property Count | Gets the number of Axis objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
public property Item | Overloaded. Gets the specified Axis from the collection. In C#, this property is the indexer for the AxisCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Axis from the collection.
public method GetEnumerator | Gets an IEnumerator interface for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AxisCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection Properties

The properties of the AxisCollection class are listed here. For a complete list of AxisCollection class members, see AxisCollection Members.

Public Properties

public property Count | Gets the number of Axis objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Axis from the collection. In C#, this property is the indexer for the AxisCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

AxisCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Count Property

Gets the number of Axis objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of Axis objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Item Property

Gets the specified Axis from the AxisCollection collection.

[C#] In C#, this property is the indexer for the AxisCollection class.

Overload List

Gets the specified Axis from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As Axis
[C#] public Axis this[System.Int32] {get;}
[C++] public: __property Axis* get_Item(System.Int32);
[JScript] AxisCollection.Item (System.Int32)

Gets the specified Axis from the collection by its name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As Axis
[C#] public Axis this[System.String] {get;}
[C++] public: __property Axis* get_Item(System.String);
[JScript] AxisCollection.Item (System.String)
See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Item Property (System.Int32)

Gets the specified Axis from the AxisCollection collection by its index.

[C#] In C#, this property is the indexer for the AxisCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Axis
[C#]
public Axis this[
   int index
] {get;}
[C++]
public: __property Axis* get_Item(
   int index
);
[JScript]
returnValue = AxisCollectionObject.Item(index);
-or-
returnValue = AxisCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Axis to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Axis to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AxisCollection.Item Overload List


AxisCollection.Item Property (System.String)

Gets the specified Axis from the AxisCollection collection by its name.

[C#] In C#, this property is the indexer for the AxisCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Axis
[C#]
public Axis this[
   string index
] {get;}
[C++]
public: __property Axis* get_Item(
   String* index
);
[JScript]
returnValue = AxisCollectionObject.Item(index);
-or-
returnValue = AxisCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the Axis to find.
Parameters [Visual Basic, C#, C++]
index
The name of the Axis to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | AxisCollection.Item Overload List


AxisCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the AxisCollection collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the AxisCollection collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection Methods

The methods of the AxisCollection class are listed here. For a complete list of AxisCollection class members, see AxisCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an IEnumerator interface for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AxisCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.CopyTo Method

Copies the elements of the AxisCollection collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Axis, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Axis[] array,
   int index
);
[C++]
public: void CopyTo(
   Axis* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Axis[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Find Method

Gets the specified Axis from the AxisCollection collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As Axis
[C#]
public Axis Find(
   string name
);
[C++]
public: Axis* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : Axis;
Parameters
name
The name of the Axis to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.


AxisCollection.GetEnumerator Method

Gets an Enumerator for iterating through the AxisCollection collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

AxisCollection Class | AxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator Structure

Supports iterating over an AxisCollection and reading its individual axes.

For a list of all members of this type, see AxisCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.AxisCollection.Enumerator

[Visual Basic]
Public Structure AxisCollection.Enumerator
   Implements IEnumerator
[C#]
public struct AxisCollection.Enumerator : IEnumerator
[C++]
public __value struct AxisCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

AxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator Members

AxisCollection.Enumerator Structure

Public Properties

public property Current Gets the current axis in the AxisCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next axis in the AxisCollection.
public method Reset | Moves the enumerator to a position before the first axis in the AxisCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AxisCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator Properties

The properties of the AxisCollection.Enumerator structure are listed here. For a complete list of AxisCollection.Enumerator structure members, see AxisCollection.Enumerator Members.

Public Properties

public property Current Gets the current axis in the AxisCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

AxisCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator.Current Property

Gets the current axis in the AxisCollection.

[Visual Basic]
Public ReadOnly Property Current As Axis
[C#]
public Axis Current {get;}
[C++]
public: __property Axis* get_Current();
[JScript]
public function get Current() : Axis;
Property Value

The axis in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last axis in the AxisCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection.Enumerator Structure | AxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

AxisCollection.Enumerator Structure | AxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator Methods

The methods of the AxisCollection.Enumerator structure are listed here. For a complete list of AxisCollection.Enumerator structure members, see AxisCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next axis in the AxisCollection.
public method Reset | Moves the enumerator to a position before the first axis in the AxisCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

AxisCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator.MoveNext Method

Moves to the next axis in the AxisCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection.Enumerator Structure | AxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


AxisCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first axis in the AxisCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

AxisCollection.Enumerator Structure | AxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Class

Represents a cell in a given cellset.

For a complete list of Cell class members, see Cell Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Cell

[Visual Basic]
NotInheritable Public Class Cell
[C#]
public sealed class Cell
[C++]
public __gc __sealed class Cell
[JScript]
public class Cell
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

In Analysis Services, a cell represents the unique logical intersection of one position from every axis in the cellset. Because every logical intersection in a cellset may or may not have a corresponding record in a fact table, not every cell in a cellset contains data.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Members

Cell Class

Public Properties

public property CellProperties | Gets a CellPropertyCollection that contains a collection of cell properties for the Cell.
public property FormattedValue | Gets a string representing the formatted value of the Cell.
public property Value | Gets the value of the Cell.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Cell are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Cell are not equal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Cell Class | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Properties

The properties of the Cell class are listed here. For a complete list of Cell class members, see Cell Members.

Public Properties

public property CellProperties | Gets a CellPropertyCollection that contains a collection of cell properties for the Cell.
public property FormattedValue | Gets a string representing the formatted value of the Cell.
public property Value | Gets the value of the Cell.

See Also

Cell Class | Microsoft.AnalysisServices.AdomdClient Namespace


Cell.CellProperties Property

Gets an instance of the CellPropertyCollection class that contains the cell properties for the Cell.

[Visual Basic]
Public ReadOnly Property CellProperties As CellPropertyCollection
[C#]
public CellPropertyCollection CellProperties {get;}
[C++]
public: __property CellPropertyCollection* get_CellProperties();
[JScript]
public function get CellProperties() : CellPropertyCollection;
Property Value

A CellPropertyCollection that contains the cell properties for the Cell.

Remarks

Additional cell properties other than the intrinsic cell properties implemented by the Cell can be associated with a given cell. This property is used to retrieve a CellPropertyCollection that contains additional cell properties associated with the Cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell.FormattedValue Property

Gets a string representing the formatted value of the Cell.

[Visual Basic]
Public ReadOnly Property FormattedValue As String
[C#]
public string FormattedValue {get;}
[C++]
public: __property String* get_FormattedValue();
[JScript]
public function get FormattedValue() : String;
Property Value

A String that contains the formatted value of the Cell.

Remarks

The formatting of the value for this property is typically determined by the value of a provider-specific cell property. In Microsoft SQL Server 2000 Analysis Services, the FORMAT_STRING cell property is used to determine the formatting for the value of this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell.Value Property

Gets the value of the Cell.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;
Property Value

An Object that contains the value of the Cell.

Remarks

Unless the run-time type of the value for a Cell is known in advance, use the GetType method of the Object to determine the run-time type before attempting to use the Object that is returned by this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Methods

The methods of the Cell class are listed here. For a complete list of Cell class members, see Cell Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Cell Class | Microsoft.AnalysisServices.AdomdClient Namespace


Cell.Equals Method

Determines whether two instances of Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Cell.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Operators

The operators of the Cell class are listed here. For a complete list of Cell class members, see Cell Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Cell are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Cell are not equal.

See Also

Cell Class | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Equality Operator

Determines whether two specified instances of Cell are equal.

[Visual Basic]
returnValue = Cell.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Cell o1,
   Cell o2
);
[C++]
public: static bool op_Equality(
   Cell* o1,
   Cell* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Cell.
o2
A Cell.
Parameters [Visual Basic, C#, C++]
o1
A Cell.
o2
A Cell.:
Return Value

true if o1 and o2 represent the same Cell; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


Cell Inequality Operator

Determines whether two specified instances of Cell are not equal.

[Visual Basic]
returnValue = Cell.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Cell o1,
   Cell o2
);
[C++]
public: static bool op_Inequality(
   Cell* o1,
   Cell* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Cell.
o2
A Cell.
Parameters [Visual Basic, C#, C++]
o1
A Cell.
o2
A Cell.
Return Value

true if o1 and o2 do not represent the same Cell; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Cell Class | Cell Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection Class

Contains a read-only collection of Cell objects contained by a CellSet.

For a complete list of CellCollection class members, see CellCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CellCollection

[Visual Basic]
NotInheritable Public Class CellCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class CellCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class CellCollection : public ICollection,
   IEnumerable
[JScript]
public class CellCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a CellSet and the number of cells for which to display information, iterates through the CellCollection collection and displays information for each cell:

Public Sub ListCellCollection(ByRef CellSetToCheck As CellSet, _
    Optional ByVal Count As Integer = 10)

    ' Because cellsets can represent tens of thousands of cells,
    ' the Count parameter limits the output to a
    ' specified number of cells.

    If CellSetToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CellSetToCheck")
    Else
        ' Iterate through the Hierarchies collection of the
        ' Dimension object.

        Dim cellToCheck As Cell
        Dim cellCount As Long
        Dim cellIndex As Long

        Try
            cellCount = CellSetToCheck.CellCollection.Count
            Debug.WriteLine("Found " & cellCount & _
                " cell(s) in cellset:")

            If cellCount > Count Then cellCount = Count

            If cellCount > 0 Then
                For cellIndex = 0 To cellCount - 1
                    cellToCheck = CellSetToCheck.CellCollection(cellIndex)

                    Debug.WriteLine("  Value:           " & _
                        cellToCheck.Value)
                    Debug.WriteLine("  -- Formatting Properties --")
                    Debug.WriteLine("  BackColor:" & _
                        cellToCheck.CellProperties("BackColor"))
                    Debug.WriteLine("  ForeColor:" & _
                        cellToCheck.CellProperties("ForeColor"))
                    Debug.WriteLine("  FormatString:    " & _
                        cellToCheck.CellProperties("FormatString"))
                    Debug.WriteLine("  FormattedValue:  " & _
                        cellToCheck.FormattedValue)
                Next
            End If
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection Members

CellCollection Class

Public Properties

public property Count | Gets the number of Cell objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Cell from the collection. In C#, this property is the indexer for the CellCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current instance.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection Properties

The properties of the CellCollection class are listed here. For a complete list of CellCollection class members, see CellCollection Members.

Public Properties

public property Count | Gets the number of Cell objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Cell from the collection. In C#, this property is the indexer for the CellCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CellCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Count Property

Gets the number of Cell objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of Cell objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Item Property

Gets the specified Cell from the collection.

[C#] In C#, this property is the indexer for the CellCollection class.

Overload List

Gets the specified Cell from the collection by an ICollection interface that contains a collection of absolute axis indexes.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Collections.ICollection) As Cell
[C#] public Cell this[System.Collections.ICollection] {get;}
[C++] public: __property Cell* get_Item(System.Collections.ICollection);
[JScript] CellCollection.Item (System.Collections.ICollection)

Gets the specified Cell from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As Cell
[C#] public Cell this[System.Int32] {get;}
[C++] public: __property Cell* get_Item(System.Int32);
[JScript] CellCollection.Item (System.Int32)

Gets the specified Cell from the collection by an array of absolute axis indexes.

[Visual Basic] Public Overloads Default ReadOnly Property Item(ParamArray System.Int32()) As Cell
[C#] public Cell this[System.Int32[]] {get;}
[C++] public: __property Cell* get_Item(System.Int32[]);
[JScript] CellCollection.Item (System.Int32[])

Gets the specified Cell from the collection by its coordinate.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32, System.Int32) As Cell
[C#] public Cell this[System.Int32, System.Int32] {get;}
[C++] public: __property Cell* get_Item(System.Int32, System.Int32);
[JScript] CellCollection.Item (System.Int32, System.Int32)
See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Item Property (System.Collections.ICollection)

Gets the specified Cell from the collection by an ICollection interface that contains a collection of absolute axis indexes.

[C#] In C#, this property is the indexer for the CellCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal indexes As ICollection _
) As Cell
[C#]
public Cell this[
   ICollection indexes
] {get;}
[C++]
public: __property Cell* get_Item(
   ICollection* indexes
);
[JScript]
returnValue = CellCollectionObject.Item(indexes);
-or-
returnValue = CellCollectionObject(indexes);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
indexes
An ICollection interface that contains a number of elements less than or equal to the count of axes in the CellSet referenced by the collection.
Parameters [Visual Basic, C#, C++]
indexes
An ICollection that contains a number of elements less than or equal to the count of axes in the CellSet referenced by the collection.
Remarks

The ICollection represents a tuple created by referencing a single point from each axis represented in the CellSet referenced by the collection. The index of each element in the ICollection matches the index of each axis in the Axes collection of the CellSet, and the value of each element represents a zero-based index of rows for each axis.

The following diagram illustrates the Axes collection of a CellSet. The Axes collection contains three axes, numbered from 0 to 2. A single tuple from each axis is then selected to identify a tuple representing a single Cell.

Diagram showing intersection of tuples along three axes.

Tuple 4 is selected from Axes.Item(0), tuple 2 is selected from Axes.Item(1), and tuple 5 is selected from Axes.Item(2). Therefore, the ICollection should contain three elements, also numbered from 0 to 2 and assigned the values 4, 2, and 5, respectively.

If the ICollection contains more elements than the CellSet.Axes collection, an exception is thrown.

Examples
[Visual Basic]

The following example shows a wrapper function that, given a CellSet and a list of axis indexes, safely calls the Item property using an ICollection:

Public Function GetCellByArray(_
    ByRef CellSetToUse As CellSet, _
    ByVal ParamArray AxisIndexes() As Int32) As Cell

    ' Trap the various errors that can occur when
    ' retrieving a Cell object reference using an ICollection.
    If CellSetToUse Is Nothing Then
        Throw New System.ArgumentNullException("CellSetToUse")
    ElseIf AxisIndexes Is Nothing Then
        Throw New System.ArgumentNullException("AxisIndexes")
    ElseIf AxisIndexes.Length = 0 Then
        Throw New System.ArgumentNullException("AxisIndexes")
    ElseIf AxisIndexes.Length > CellSetToUse.Axes.Count Then
        Throw New System.ArgumentOutOfRangeException("AxisIndexes")
    Else
        Try
            ' Cast the ParamArray object as an ICollection object,
            ' just to be safe.
            Dim AxisArrayList As New ICollection(AxisIndexes)

            Return CellSetToUse.CellCollection.Item(AxisArrayList)
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Function

The following example shows a function that, given a CellSet and a list of axis indexes, calculates the index of a Cell within the CellCollection collection.

Public Function GetCellIndexFromAxisIndexes(_
    ByRef CellSetToUse As CellSet, _
    ByVal ParamArray AxisIndexes() As Int32) As Int32
    ' Trap the various errors that can occur when
    ' calculating a Cell index using an ICollection.
    If CellSetToUse Is Nothing Then
        Throw New System.ArgumentNullException("CellSetToUse")
    ElseIf AxisIndexes.Length = 0 Then
        Throw New System.ArgumentNullException("AxisIndexes")
    ElseIf AxisIndexes.Length > CellSetToUse.Axes.Count Then
        Throw New System.ArgumentOutOfRangeException("AxisIndexes")
    Else
        Dim currentIndex As Int32 = 0
        Dim currentOrdinal As Int32 = 0
        Dim currentMultiple As Int32 = 1

        Try
            For currentIndex = 0 To AxisIndexes.Length - 1
                currentOrdinal += currentMultiple * AxisIndexes(currentIndex)
                currentMultiple *= CellSetToUse.Axes(currentIndex).Tuples.Count
            Next
        Catch e As System.Exception
            Throw e
        End Try

        Return currentOrdinal
    End If
End Function
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CellCollection.Item Overload List


CellCollection.Item Property (System.Int32)

Gets the specified Cell from the collection by its index.

[C#] In C#, this property is the indexer for the CellCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Cell
[C#]
public Cell this[
   int index
] {get;}
[C++]
public: __property Cell* get_Item(
   int index
);
[JScript]
returnValue = CellCollectionObject.Item(index);
-or-
returnValue = CellCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Cell to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Cell to find.
Remarks

Cells are stored in the CellCollection in a depth-first flattened structure, in which each axis is fully expressed in sequence.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CellCollection.Item Overload List


CellCollection.Item Property (System.Int32[])

Gets the specified Cell from the collection by an array of absolute axis indexes.

[C#] In C#, this property is the indexer for the CellCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal ParamArray indexes() As Integer _
) As Cell
[C#]
public Cell this[
   params int[] indexes
] {get;}
[C++]
public: __property Cell* get_Item(
   int indexes __gc[]
);
[JScript]
returnValue = CellCollectionObject.Item(indexes);
-or-
returnValue = CellCollectionObject(indexes);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
indexes
An array of Integer values that contains a number of elements less than or equal to the count of axes in the CellSet the collection references.
Parameters [Visual Basic, C#, C++]
indexes
An array of Integer values that contains a number of elements less than or equal to the count of axes in the CellSet the collection references.
Remarks

The array of Integer values represents a tuple created by referencing a single point from each axis represented in the CellSet the collection references. The index of each element in the array of Integer values matches the index of each axis in the Axes collection of the CellSet, and the value of each element represents a zero-based index of rows for each axis.

The following diagram illustrates the Axes collection of a CellSet. The Axes collection contains three axes, numbered from 0 to 2. A single tuple from each axis is then selected to identify a tuple representing a single Cell.

Diagram showing intersection of tuples along three axes.

Tuple 4 is selected from Axes.Item(0), tuple 2 is selected from Axes.Item(1), and tuple 5 is selected from Axes.Item(2). Therefore, the array of Integer values should contain three elements, also numbered from 0 to 2 and assigned the values 4, 2, and 5, respectively.

If the array of Integer values contains more elements than the CellSet.Axes collection, an exception is thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CellCollection.Item Overload List


CellCollection.Item Property (System.Int32, System.Int32)

Gets the specified Cell from the collection by its coordinate.

Note This property is optimized and should only be used with cellsets that contain exactly two axes.

[C#] In C#, this property is the indexer for the CellCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index1 As Integer, _
   ByVal index2 As Integer _
) As Cell
[C#]
public Cell this[
   int index1,
   int index2
] {get;}
[C++]
public: __property Cell* get_Item(
   int index1,
   int index2
);
[JScript]
returnValue = CellCollectionObject.Item(index1, index2);
-or-
returnValue = CellCollectionObject(index1, index2);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index1
The zero-based index on the first axis of the Cell to find.
index2
The zero-based index on the second axis of the Cell to find.
Parameters [Visual Basic, C#, C++]
index1
The zero-based index on the first axis of the Cell to find.
index2
The zero-based index on the second axis of the Cell to find.
Remarks

This property is optimized two-dimensional cellsets. Any attempt to use this with a cellset that contains more or less than two dimensions raises an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CellCollection.Item Overload List


CellCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection Methods

The methods of the CellCollection class are listed here. For a complete list of CellCollection class members, see CellCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Cell, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Cell[] array,
   int index
);
[C++]
public: void CopyTo(
   Cell* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Cell[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

CellCollection Class | CellCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator Structure

Supports iterating over a CellCollection and reading its individual cells.

For a list of all members of this type, see CellCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.CellCollection.Enumerator

[Visual Basic]
Public Structure CellCollection.Enumerator
   Implements IEnumerator
[C#]
public struct CellCollection.Enumerator : IEnumerator
[C++]
public __value struct CellCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator Members

CellCollection.Enumerator Structure

Public Properties

public property Current Gets the current cell in the CellCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next cell in the CellCollection.
public method Reset | Moves the enumerator to a position before the first cell in the CellCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

CellCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator Properties

The properties of the CellCollection.Enumerator structure are listed here. For a complete list of CellCollection.Enumerator structure members, see CellCollection.Enumerator Members.

Public Properties

public property Current Gets the current cell in the CellCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

CellCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator.Current Property

Gets the current cell in the CellCollection.

[Visual Basic]
Public ReadOnly Property Current As Cell
[C#]
public Cell Current {get;}
[C++]
public: __property Cell* get_Current();
[JScript]
public function get Current() : Cell;
Property Value

The cell in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last cell in the CellCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection.Enumerator Structure | CellCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

CellCollection.Enumerator Structure | CellCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator Methods

The methods of the CellCollection.Enumerator structure are listed here. For a complete list of CellCollection.Enumerator structure members, see CellCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next cell in the CellCollection.
public method Reset | Moves the enumerator to a position before the first cell in the CellCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator.MoveNext Method

Moves to the next cell in the CellCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection.Enumerator Structure | CellCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first cell in the CellCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellCollection.Enumerator Structure | CellCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellInfo Class

Represents metadata pertaining to the cells that are associated with an instance of a CellSet class.

For a list of all members of this type, see CellInfo Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CellInfo

[Visual Basic]
NotInheritable Public Class CellInfo
[C#]
public sealed class CellInfo
[C++]
public __gc __sealed class CellInfo
[JScript]
public class CellInfo
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellInfo Members

CellInfo Class

Public Properties

public property CellProperties Gets an OlapInfoPropertyCollection that represents metadata pertaining to the cell properties that are associated with the CellInfo.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellInfo Properties

The properties of the CellInfo class are listed here. For a complete list of CellInfo class members, see CellInfo Members.

Public Properties

public property CellProperties Gets an OlapInfoPropertyCollection that represents metadata pertaining to the cell properties that are associated with the CellInfo.

See Also

CellInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellInfo.CellProperties Property

Gets an OlapInfoPropertyCollection that represents metadata pertaining to the hierarchy properties that are associated with the CellInfo.

[Visual Basic]
Public ReadOnly Property CellProperties As _
   OlapInfoPropertyCollection
[C#]
public OlapInfoPropertyCollection CellProperties {get;}
[C++]
public: __property OlapInfoPropertyCollection* get_CellProperties();
[JScript]
public function get CellProperties() : OlapInfoPropertyCollection;
Property Value

Returns an OlapInfoPropertyCollection that represents metadata pertaining to the hierarchy properties that are associated with the CellInfo.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellInfo Class | CellInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Class

Represents a cell property for a given cell.

For a complete list of CellProperty class members, see CellProperty Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CellProperty

[Visual Basic]
NotInheritable Public Class CellProperty
[C#]
public sealed class CellProperty
[C++]
public __gc sealed class CellProperty
[JScript]
public class CellProperty
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

In Microsoft SQL Server 2000 Analysis Services, cell properties contain information about the content and format of cells in a cube. Cell properties are most commonly used to assist in the visual presentation of cell data.

In ADOMD.NET, the CellProperty class is used to represent cell properties for a given Cell.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Members

CellProperty Class

Public Properties

public property Name | Gets the name of the CellProperty.
public property Namespace | Gets the namespace of the CellProperty.
public property Value | Gets the value of the CellProperty.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of an Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of CellProperty are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of CellProperty are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Properties

The properties of the CellProperty class are listed here. For a complete list of CellProperty class members, see CellProperty Members.

Public Properties

public property Name | Gets the name of the CellProperty.
public property Namespace | Gets the namespace of the CellProperty.
public property Value | Gets the value of the CellProperty.

See Also

CellProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty.Name Property

Gets the name of the CellProperty.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the CellProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty.Namespace Property

Gets the namespace of the CellProperty.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the namespace of the CellProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty.Value Property

Gets the value of the CellProperty.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;
Property Value

An Object that contains the value of the CellProperty.

Remarks

Unless the run-time type of the value for a CellProperty is known in advance, use the GetType method of the Object to determine the run-time type before attempting to use the Object that is returned by this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty.Equals Method

Determines whether two instances of Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the CellProperty.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Methods

The methods of the CellProperty class are listed here. For a complete list of CellProperty class members, see CellProperty Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Property Value

A String that contains the name of the CellProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Operators

The operators of the CellProperty class are listed here. For a complete list of CellProperty class members, see CellProperty Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of CellProperty are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of CellProperty are unequal.

See Also

CellProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Equality Operator

Determines whether two specified instances of CellProperty are equal.

[Visual Basic]
returnValue = CellProperty.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   CellProperty o1,
   CellProperty o2
);
[C++]
public: static bool op_Equality(
   CellProperty* o1,
   CellProperty* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A CellProperty.
o2
A CellProperty.
Parameters [Visual Basic, C#, C++]
o1
A CellProperty.
o2
A CellProperty.
Return Value

true if o1 and o2 represent the same CellProperty; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellProperty Inequality Operator

Determines whether two specified instances of CellProperty are unequal.

[Visual Basic]
returnValue = CellProperty.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   CellProperty o1,
   CellProperty o2
);
[C++]
public: static bool op_Inequality(
   CellProperty* o1,
   CellProperty* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A CellProperty.
o2
A CellProperty.
Parameters [Visual Basic, C#, C++]
o1
A CellProperty.
o2
A CellProperty.
Return Value

true if o1 and o2 represent the same CellProperty; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellProperty Class | CellProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection Class

Contains a collection of CellProperty objects contained by a Cell.

For a complete list of CellPropertyCollection class members, see CellPropertyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CellPropertyCollection

[Visual Basic]
NotInheritable Public Class CellPropertyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class CellPropertyCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class CellPropertyCollection : public
   ICollection, IEnumerable
[JScript]
public class CellPropertyCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The CellPropertyCollection is populated when a Cell is created. Each cell in a cellset can have zero or more intrinsic or custom cell properties associated with it, represented by CellProperty objects maintained by the CellPropertyCollection collection.

Example
[Visual Basic]

The following subroutine iterates through the CellPropertyCollection collection of a specified Cell.

Public Sub ListCellPropertyCollection(ByRef CellToCheck As Cell)
    'Assumes CellToCheck is not null.
    Dim cellProperty As CellProperty

    Debug.WriteLine("Found " & CellToCheck.CellProperties.Count & _
        " cell properties in cell:")

    For Each cellProperty In CellToCheck.CellProperties
        Debug.WriteLine("  Name:  " & cellProperty.Name)
        Debug.WriteLine(" Value:  " & cellProperty.Value)
    Next
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection Members

CellPropertyCollection Class

Public Properties

public property Count | Gets the number of CellProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified CellProperty from the collection. In C#, this property is the indexer for the CellPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of the Object are equal.
public method Find | Returns the specified CellProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection Properties

The properties of the CellPropertyCollection class are listed here. For a complete list of CellPropertyCollection class members, see CellPropertyCollection Members.

Public Properties

public property Count | Gets the number of CellProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified CellProperty from the collection. In C#, this property is the indexer for the CellPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CellPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Count Property

Gets the number of CellProperty objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of CellProperty objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Item Property

Gets the specified CellProperty from the collection.

[C#] In C#, this property is the indexer for the CellPropertyCollection class.

Overload List

Gets the specified CellProperty from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As CellProperty
[C#] public CellProperty this[System.Int32] {get;}
[C++] public: __property CellProperty* get_Item(System.Int32);
[JScript] CellPropertyCollection.Item (System.Int32)

Gets the specified CellProperty from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As CellProperty
[C#] public CellProperty this[System.String] {get;}
[C++] public: __property CellProperty* get_Item(System.String);
[JScript] CellPropertyCollection.Item (System.String)
See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Item Property (System.Int32)

Gets the specified CellProperty from the collection by its index.

[C#] In C#, this property is the indexer for the CellPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As CellProperty
[C#]
public CellProperty this[
   int index
] {get;}
[C++]
public: __property CellProperty* get_Item(
   int index
);
[JScript]
returnValue = CellPropertyCollectionObject.Item(index);
-or-
returnValue = CellPropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the CellProperty to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the CellProperty to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CellPropertyCollection.Item Overload List


CellPropertyCollection.Item Property (System.String)

Gets the specified CellProperty from the collection by its name.

Note The search performed is case-insensitive.

[C#] In C#, this property is the indexer for the CellPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal propName As String _
) As CellProperty
[C#]
public CellProperty this[
   string propName
] {get;}
[C++]
public: __property CellProperty* get_Item(
   String* propName
);
[JScript]
returnValue = CellPropertyCollectionObject.Item(propName);
-or-
returnValue = CellPropertyCollectionObject(propName);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
propName
The name of the CellProperty to find.
Parameters [Visual Basic, C#, C++]
propName
The name of the CellProperty to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CellPropertyCollection.Item Overload List


CellPropertyCollection.SyncRoot Property

Gets an Object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An Object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection Methods

The methods of the CellPropertyCollection class are listed here. For a complete list of CellPropertyCollection class members, see CellPropertyCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of the Object are equal.
public method Find | Returns the specified CellProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current Object.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As CellProperty, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   CellProperty[] array,
   int index
);
[C++]
public: void CopyTo(
   CellProperty* array[],
   int index
);
[JScript]
public function CopyTo(
   array : CellProperty[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Find Method

Gets the specified CellProperty from the collection by its name.

Note The search performed is case-insensitive.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As CellProperty
[C#]
public CellProperty Find(
   string name
);
[C++]
public: CellProperty* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : CellProperty;
Parameters
name
The name of the CellProperty to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.


CellPropertyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

CellPropertyCollection Class | CellPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator Structure

Supports iterating over a CellPropertyCollection and reading its individual cell properties.

For a list of all members of this type, see CellPropertyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.CellPropertyCollection.Enumerator

[Visual Basic]
Public Structure CellPropertyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct CellPropertyCollection.Enumerator : IEnumerator
[C++]
public __value struct CellPropertyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator Members

CellPropertyCollection.Enumerator Structure

Public Properties

public property Current Gets the current cell property in the CellPropertyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next cell property in the CellPropertyCollection.
public method Reset | Moves the enumerator to a position before the first cell property in the CellPropertyCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

CellPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator Properties

The properties of the CellPropertyCollection.Enumerator structure are listed here. For a complete list of CellPropertyCollection.Enumerator structure members, see CellPropertyCollection.Enumerator Members.

Public Properties

public property Current Gets the current cell property in the CellPropertyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

CellPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator.Current Property

Gets the current cell property in the CellPropertyCollection.

[Visual Basic]
Public ReadOnly Property Current As CellProperty
[C#]
public CellProperty Current {get;}
[C++]
public: __property CellProperty* get_Current();
[JScript]
public function get Current() : CellProperty;
Property Value

The cell property in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last cell property in the CellPropertyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection.Enumerator Structure | CellPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

CellPropertyCollection.Enumerator Structure | CellPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator Methods

The methods of the CellPropertyCollection.Enumerator structure are listed here. For a complete list of CellPropertyCollection.Enumerator structure members, see CellPropertyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next cell property in the CellPropertyCollection.
public method Reset | Moves the enumerator to a position before the first cell property in the CellPropertyCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator.MoveNext Method

Moves to the next CellProperty in the CellPropertyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection.Enumerator Structure | CellPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellPropertyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first cell property in the CellPropertyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellPropertyCollection.Enumerator Structure | CellPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet Class

Represents a cellset that is returned as a result of a query.

For a complete list of CellSet class members, see CellSet Members.

System.Object
...Microsoft.AnalysisServices.AdomdClient.CellSet

[Visual Basic]
Public NotInheritable Class CellSet
[C#]
public sealed class CellSet
[C++]
public __gc __sealed class CellSet
[JScript]
public class CellSet
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

In ADOMD.NET, the CellSet encapsulates a multidimensional result set that is the result of running a command. A multidimensional result set contains a discrete collection of data points, or cells, that are organized along multiple dimensions, or axes.

A CellSet is created when the Execute or ExecuteCellSet method of the AdomdCommand is called to run a command. For more information about the AdomdCommand, see AdomdCommand Class.

Example
[Visual Basic]

The following subroutine, given a CellSet, examines and displays information about the object:

Public Sub ListCellSetInfo(ByRef CellSetToCheck As CellSet)
    If CellSetToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CellSetToCheck")
    Else
        Console.WriteLine("The cellset has {0} cells " & _
            "organized along {1} axes.", _
            CellSetToCheck.Cells.Count, _
            CellSetToCheck.Axes.Count)
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet Members

CellSet overview

Public Properties

public property Axes | Gets an AxisCollection that contains the axes of the CellSet.
public property Cells | Gets a CellCollection that contains the cells of the CellSet.
public property FilterAxis | Gets an Axis that represents the filter axis of the CellSet.
public property Item | Gets a Cell by its index. In C#, this property is the indexer for the CellSet class.
public property OlapInfo | Gets an OlapInfo describing the CellSet.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method static (Shared in Visual Basic) LoadXml | Returns a CellSet created from a server response, passed in as an XmlReader.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet Properties

The properties of the CellSet class are listed here. For a complete list of CellSet class members, see CellSet Members.

Public Properties

public property Axes | Gets an AxisCollection that contains the axes of the CellSet.
public property Cells | Gets a CellCollection that contains the cells of the CellSet.
public property FilterAxis | Gets an Axis that represents the filter axis of the CellSet.
public property Item | Gets a Cell by its index. In C#, this property is the indexer for the CellSet class.

See Also

CellSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet.Axes Property

Gets an instance of the AxisCollection class that contains the axes of the CellSet.

[Visual Basic]
Public ReadOnly Property Axes As AxisCollection
[C#]
public AxisCollection Axes {get;}
[C++]
public: __property AxisCollection* get_Axes();
[JScript]
public function get Axes() : AxisCollection;
Property Value

An AxisCollection that contains the axes of the CellSet.

Remarks

In Microsoft SQL Server 2000 Analysis Services, the data represented by a cellset is organized along one or more axes. To visually organize this information, the CellSet supplies an Axis for each query axis. These objects are available within an AxisCollection collection that the Axes property provides.

Filter and Query Axes

A typical MDX SELECT statement defines one or more axes for which data is displayed. These are called query axes. For example, the following MDX SELECT statement defines two query axes, COLUMNS and ROWS, in a query against the Budget cube in the FoodMart 2000 database:

SELECT
   [Account].Children ON COLUMNS,
   [Store].Children ON ROWS
FROM
   Budget

You might assume that this MDX query represents a cellset with two axes. In fact, three axes are represented — two query axes and a filter axis.

A filter axis filters multidimensional data in the same way as a query axis. However, a filter axis is always present in an MDX query, and unless defined otherwise, it consists of the default member of each hierarchy that is not explicitly referenced by a query axis. You can use the WHERE clause of an MDX SELECT statement to define a filter axis explicitly. For example, the following MDX query returns the same results as the previous MDX query, but the filter axis that was implied in the previous query is now explicitly declared:

SELECT
   [Account].Children ON COLUMNS,
   [Store].Children ON ROWS
FROM
   Budget
WHERE
   ([Measures].DEFAULTMEMBER, [Category].DEFAULTMEMBER, [Time].DEFAULTMEMBER)

Another difference between a filter axis and a query axis is that a filter axis must resolve to a single tuple, whereas a query axis must resolve to a single set.

Because the filter axis is often implicitly included rather than explicitly declared in MDX queries, it is important to remember that a filter axis always exists. The filter axis is not included in the collection returned by this property; for zero-dimensional MDX queries, this property returns an empty collection. To retrieve the filter axis, use the FilterAxis property to retrieve a reference to an Axis that represents the filter axis. For more information about the FilterAxis property, see CellSet.FilterAxis Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellSet Class | CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet.Cells Property

Gets an instance of the CellCollection class that contains the cells of the CellSet.

[Visual Basic]
Public ReadOnly Property Cells As CellCollection
[C#]
public CellCollection Cells {get;}
[C++]
public: __property CellCollection* get_Cells();
[JScript]
public function get Cells() : CellCollection;
Property Value

A CellCollection that contains the cells for the CellSet.

Remarks

In ADOMD.NET, the data represented by a cellset is organized along one or more axes. To display and manipulate this data, the CellSet supplies an instance of a Cell for each intersection of positions across all axes. These objects are available within a CellCollection collection that the Cells property provides.

For more information about displaying and manipulating cells within a cellset, see CellCollection Class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellSet Class | CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet.FilterAxis Property

Gets an instance of an Axis class that represents the filter axis of the CellSet.

[Visual Basic]
Public ReadOnly Property FilterAxis As Axis
[C#]
public Axis FilterAxis {get;}
[C++]
public: __property Axis* get_FilterAxis();
[JScript]
public function get FilterAxis() : Axis;
Property Value

An Axis that contains the filter axis for the CellSet.

Remarks

For more information about query and filter axes, see CellSet.Axes Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellSet Class | CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet.Item Property

Gets an instance of a Cell by its index.

[C#] In C#, this property is the indexer for the CellSet class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Cell
[C#]
public Cell this[
   int index
] {get;}
[C++]
public: __property Cell* get_Item(
   int index
);
[JScript]
returnValue = CellSetObject.Item(index);
-or-
returnValue = CellSetObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Cell to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Cell to find.
Remarks

This property is functionally equivalent to CellSet.Cells.Item(index). For more information about the Item property of the CellCollection, see CellCollection.Item Property (System.Int32)l.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellSet Class | CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet.OlapInfo Property

Gets an instance of an OlapInfo class describing the CellSet.

[Visual Basic]
Public ReadOnly Property OlapInfo As OlapInfo
[C#]
public OlapInfo OlapInfo {get;}
[C++]
public: __property OlapInfo* get_OlapInfo();
[JScript]
public function get OlapInfo() : OlapInfo;
Return Value

An OlapInfo describing the CellSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellSet Class | CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet Methods

The methods of the CellSet class are listed here. For a complete list of CellSet class members, see CellSet Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method static (Shared in Visual Basic) LoadXml | Returns a CellSet created from a server response, passed in as an XmlReader.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CellSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


CellSet.LoadXml Method

Returns a CellSet created from a server response, passed in as an XmlReader.

[Visual Basic]
Public Shared Function LoadXml( _
   ByVal xmlTextReader As XmlReader _
) As CellSet
[C#]
public static CellSet LoadXml(
   XmlReader xmlTextReader
);
[C++]
public: static CellSet* LoadXml(
   XmlReader* xmlTextReader
);
[JScript]
public static function LoadXml(
   xmlTextReader : XmlReader
) : CellSet;
Parameters
xmlTextReader
XmlReader containing the server response to return as a CellSet.
Return Value

A CellSet, created from the xmlTextReader parameter.

Exceptions

Exception type | Condition
ArgumentNullException | The xmlTextReader was set to null.
ArgumentException | The State property of xmlTextReader was Error, EndOfFile, or Closed.
InvalidOperationException | The XML returned by the provider was not a valid cellset response.
AdomdErrorResponseException | The XML returned by the provider was a valid error response.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CellSet Class | CellSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Class

Represents the metadata for a cube.

For a complete list of CubeDef class members, see CubeDef Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CubeDef

[Visual Basic]
NotInheritable Public Class CubeDef
[C#]
public sealed class CubeDef
[C++]
public __gc __sealed class CubeDef
[JScript]
public class CubeDef
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

In Microsoft SQL Server 2000 Analysis Services, a cube is a collection of measures and dimensions.

In ADOMD.NET, the CubeDef represents only the metadata of a cube. You cannot retrieve cell data from a CubeDef; instead, this object provides a mechanism for retrieving metadata about a given cube as well as its dimensions, measures, and named sets for a client application.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Members

CubeDef Class

Public Properties

public property Caption | Gets the caption of the CubeDef.
public property Description | Gets the description of the CubeDef.
public property Dimensions | Gets a DimensionCollection that contains the dimensions for the CubeDef class.
public property LastProcessed | Gets the date and time on which the CubeDef was last processed.
public property LastUpdated | Gets the date and time on which the CubeDef was last updated.
public property Measures | Gets a MeasureCollection that contains the measures for the CubeDef.
public property Name | Gets the name of the CubeDef.
public property NamedSets | Gets a NamedSetCollection that contains the named sets for the CubeDef.
public property ParentConnection | Gets an AdomdConnection that contains the CubeDef.
public property Properties | Gets a collection of Property objects that describe the CubeDef.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetSchemaObject | Returns an object associated with the CubeDef from a specified schema rowset.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of CubeDef are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of CubeDef are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CubeDef Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Properties

The properties of the CubeDef class are listed here. For a complete list of CubeDef class members, see CubeDefMembers.

Public Properties

public property Caption | Gets the caption of the CubeDef.
public property Description | Gets the description of the CubeDef.
public property Dimensions | Gets a DimensionCollection that contains the dimensions for the CubeDef class.
public property LastProcessed | Gets the date and time on which the CubeDef was last processed.
public property LastUpdated | Gets the date and time on which the CubeDef was last updated.
public property Measures | Gets a MeasureCollection that contains the measures for the CubeDef.
public property Name | Gets the name of the CubeDef.
public property NamedSets | Gets a NamedSetCollection that contains the named sets for the CubeDef.
public property ParentConnection | Gets an AdomdConnection that contains the CubeDef.
public property Properties | Gets a collection of Property objects that describe the CubeDef.

Protected Properties

protected property CubeName | Supports the ADOMD.NET infrastructure and is not intended to be used directly in your code.
protected property SchemaObjectType | Supports the ADOMD.NET infrastructure and is not intended to be used directly in your code.

See Also

CubeDef Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Caption Property

Gets the caption of the CubeDef.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the CubeDef.

Remarks

The Caption property should be used when displaying the name of the CubeDef to the user, such as in the user interface or reports.

If no caption is specified, the value of the Name property is returned. The value of this property is identical to the value of the CUBE_CAPTION column of the CUBES schema rowset for the specified cube.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Description Property

Gets the description of the CubeDef.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the CubeDef.

Remarks

The Description property contains descriptive text that is assigned to the cube. This descriptive text is typically used for display purposes.

The value of this property is identical to the value of the DESCRIPTION column of the CUBES schema rowset for the specified cube.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Dimensions Property

Gets an instance of the DimensionCollection class that contains the dimensions for the CubeDef class.

[Visual Basic]
Public ReadOnly Property Dimensions As DimensionCollection
[C#]
public DimensionCollection Dimensions {get;}
[C++]
public: __property DimensionCollection* get_Dimensions();
[JScript]
public function get Dimensions() : DimensionCollection;
Property Value

A DimensionCollection that contains dimensions for the CubeDef.

Remarks

In Microsoft SQL Server 2000 Analysis Services, each cube has at least one dimension associated with it. The Dimensions property is used to retrieve a collection of Dimension objects that are associated with a given cube. For more information about Dimension objects, see Dimension Class.

Note The Dimensions property does not include the Measures dimension.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.LastProcessed Property

Gets the date and time on which the CubeDef was last processed.

[Visual Basic]
Public ReadOnly Property LastProcessed As DateTime
[C#]
public DateTime LastProcessed {get;}
[C++]
public: __property DateTime get_LastProcessed();
[JScript]
public function get LastProcessed() : DateTime;
Property Value

A DateTime that contains the date on which the CubeDef was last processed.

Remarks

The value of this property is the local system time, derived from the value of the LAST_SCHEMA_UPDATE column of the CUBES schema rowset for the specified cube.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.LastUpdated Property

Gets the date and time on which the CubeDef was last updated.

[Visual Basic]
Public ReadOnly Property LastUpdated As DateTime
[C#]
public DateTime LastUpdated {get;}
[C++]
public: __property DateTime get_LastUpdated();
[JScript]
public function get LastUpdated() : DateTime;
Property Value

A DateTime that contains the date on which the CubeDef was last updated.

Remarks

The value of this property is the local system time, derived from the value of the LAST_DATA_UPDATE column of the CUBES schema rowset for the specified cube.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Measures Property

Gets an instance of the MeasureCollection class that contains the measures for the CubeDef.

[Visual Basic]
Public ReadOnly Property Measures As MeasureCollection
[C#]
public MeasureCollection Measures {get;}
[C++]
public: __property MeasureCollection* get_Measures();
[JScript]
public function get Measures() : MeasureCollection;
Property Value

A MeasureCollection that contains the measures for the CubeDef.

Remarks

In Microsoft SQL Server 2000 Analysis Services, each cube has at least one measure associated with it. The Measures property is used to retrieve a collection of Measure objects that represent the measures associated with a given cube. For more information about Measure objects, see Measure Class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Name Property

Gets the name of the CubeDef.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the CubeDef.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.NamedSets Property

Gets an instance of the NamedSetCollection class that contains the named sets for the CubeDef.

[Visual Basic]
Public ReadOnly Property NamedSets As NamedSetCollection
[C#]
public NamedSetCollection NamedSets {get;}
[C++]
public: __property NamedSetCollection* get_NamedSets();
[JScript]
public function get NamedSets() : NamedSetCollection;
Property Value

A NamedSetCollection that contains the named sets for the CubeDef.

Remarks

Named sets provide an alias for commonly used set expressions in a given cube. Instead of copying and pasting lengthy set expressions into queries, a query can reference the alias of a named set.

The NamedSets property retrieves a collection of NamedSet objects that represent the named sets associated with a given cube. For more information about NamedSet objects, see NamedSet Class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.ParentConnection Property

Gets an instance of the AdomdConnection class that contains the CubeDef.

[Visual Basic]
Public ReadOnly Property ParentConnection As AdomdConnection
[C#]
public AdomdConnection ParentConnection {get;}
[C++]
public: __property AdomdConnection* get_ParentConnection();
[JScript]
public function get ParentConnection() : AdomdConnection;
Property Value

An AdomdConnection that contains the CubeDef.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | AdomdConnection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Properties Property

Gets an instance of a PropertyCollection class that contains the properties associated with the CubeDef.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

A PropertyCollection that contains the properties associated with the cube.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Methods

The methods of the CubeDef class are listed here. For a complete list of CubeDef class members, see CubeDef Members.

Public Methods

public method Equals (inherited from System.Object) | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetSchemaObject | Returns an object associated with the CubeDef from a specified schema rowset.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CubeDef Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.Equals Method

Determines whether two instances of Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Cell.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.GetSchemaObject Method

Returns an object associated with the CubeDef from a specified schema rowset.

[Visual Basic]
Public Function GetSchemaObject( _
   ByVal schemaObjectType As SchemaObjectType, _
   ByVal uniqueName As String _
) As Object
[C#]
public object GetSchemaObject(
   SchemaObjectType schemaObjectType,
   string uniqueName
);
[C++]
public: Object* GetSchemaObject(
   SchemaObjectType schemaObjectType,
   String* uniqueName
);
[JScript]
public function GetSchemaObject(
   schemaObjectType : SchemaObjectType,
   uniqueName : String
) : Object;
Parameters
schemaObjectType
The SchemaObjectType enumeration value that represents the type of object to find.
uniqueName
The unique name of the object to find.
Return Value

A Object that contains an object associated with the CubeDef.

Remarks

This method can be used to retrieve Dimension, Hierarchy, Level, Member, Measure, and NamedSet objects that are associated with the CubeDef without navigating the collections associated with these objects.

If the uniqueName parameter is set to an empty string, or if the specified object cannot be found, an exception is raised.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the CubeDef.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Operators

The operators of the CubeDef class are listed here. For a complete list of CubeDef class members, see CubeDef Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two instances of CubeDef are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two instances of CubeDef are unequal.

See Also

CubeDef Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Equality Operator

Determines whether two instances of CubeDef are equal.

[Visual Basic]
returnValue = CubeDef.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   CubeDef o1,
   CubeDef o2
);
[C++]
public: static bool op_Equality(
   CubeDef* o1,
   CubeDef* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A CubeDef.
o2
A CubeDef.
Parameters [Visual Basic, C#, C++]
o1
A CubeDef.
o2
A CubeDef.
Return Value

true if o1 and o2 represent the same CubeDef; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeDef Inequality Operator

Determines whether two instances of CubeDef are unequal.

[Visual Basic]
returnValue = CubeDef.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   CubeDef o1,
   CubeDef o2
);
[C++]
public: static bool op_Inequality(
   CubeDef* o1,
   CubeDef* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A CubeDef.
o2
A CubeDef.
Parameters [Visual Basic, C#, C++]
o1
A CubeDef.
o2
A CubeDef.
Return Value

true if o1 and o2 do not represent the same CubeDef; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeDef Class | CubeDef Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection Class

Contains a read-only, on-demand list of CubeDef objects contained by an AdomdConnection.

For a complete list of CubeCollection class members, see CubeCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CubeCollection

[Visual Basic]
NotInheritable Public Class CubeCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class CubeCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class CubeCollection : public ICollection,
   IEnumerable
[JScript]
public class CubeCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a connected instance of an AdomdConnection, iterates through the CubeCollection collection and displays various properties:

Public Sub ListCubes(ByRef ConnectionToCheck As AdomdConnection)

    ' Check the parameter before performing actions on it.
    If ConnectionToCheck Is Nothing Then
        Throw New System.ArgumentNullException("ConnectionToCheck")
    ElseIf ConnectionToCheck.State <> ConnectionState.Open Then
        Throw New System.ArgumentException( _
            "The specified connection is not open.")
    Else
        ' Iterate through the Cubes collection of the
        ' AdomdConnection object.

        Try
            ' Note that this example does not provide
            ' information about the various collections, such as
            ' NamedSets, provided by the Cube object. Because
            ' these collections are loaded on demand, you should
            ' reference them only if you need information
            ' from them.
            Dim cubeToCheck As CubeDef

            Debug.WriteLine("Found " & ConnectionToCheck.Cubes.Count & _
                " cubes in database:")

            For Each cubeToCheck In ConnectionToCheck.Cubes
                Debug.WriteLine("Cube:  " & cubeToCheck.Name)
                Debug.WriteLine("  Caption:        " & _
                    cubeToCheck.Caption)
                Debug.WriteLine("  Description:    " & _
                    cubeToCheck.Description)
                Debug.WriteLine("  LastProcessed:  " & _
                    cubeToCheck.LastProcessed)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection Members

CubeCollection Class

Public Properties

public property Count | Gets the number of CubeDef objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified CubeDef from the collection. In C#, this property is the indexer for the CubeCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified CubeDef from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CubeCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection Properties

The properties of the CubeCollection class are listed here. For a complete list of CubeCollection class members, see CubeCollection Members.

Public Properties

public property Count | Gets the number of CubeDef objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified CubeDef from the collection. In C#, this property is the indexer for the CubeCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CubeCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Count Property

Gets the number of CubeDef objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of CubeDef objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Item Property

Gets the specified CubeDef from the collection.

[C#] In C#, this property is the indexer for the CubeCollection class.

Overload List

Gets the specified CubeDef from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As CubeDef
[C#] public CubeDef this[System.Int32] {get;}
[C++] public: __property CubeDef* get_Item(System.Int32);
[JScript] CubeCollection.Item (System.Int32)

Gets the specified CubeDef from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As CubeDef
[C#] public CubeDef this[System.String] {get;}
[C++] public: __property CubeDef* get_Item(System.String);
[JScript] CubeCollection.Item (System.String)
See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Item Property (System.Int32)

Gets the specified CubeDef from the collection by its index.

[C#] In C#, this property is the indexer for the CubeCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As CubeDef
[C#]
public CubeDef this[
   int index
] {get;}
[C++]
public: __property CubeDef* get_Item(
   int index
);
[JScript]
returnValue = CubeCollectionObject.Item(index);
-or-
returnValue = CubeCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the CubeDef to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the CubeDef to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CubeCollection.Item Overload List


CubeCollection.Item Property (System.String)

Gets the specified CubeDef from the collection by its name.

[C#] In C#, this property is the indexer for the CubeCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As CubeDef
[C#]
public CubeDef this[
   string index
] {get;}
[C++]
public: __property CubeDef* get_Item(
   String* index
);
[JScript]
returnValue = CubeCollectionObject.Item(index);
-or-
returnValue = CubeCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the CubeDef to find.
Parameters [Visual Basic, C#, C++]
index
The name of the CubeDef to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | CubeCollection.Item Overload List


CubeCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection Methods

The methods of the CubeCollection class are listed here. For a complete list of CubeCollection class members, see CubeCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified CubeDef from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CubeCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As CubeDef, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   CubeDef[] array,
   int index
);
[C++]
public: void CopyTo(
   CubeDef* array[],
   int index
);
[JScript]
public function CopyTo(
   array : CubeDef[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Find Method

Gets the specified CubeDef from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As CubeDef
[C#]
public CubeDef Find(
   string index
);
[C++]
public: CubeDef* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : CubeDef;
Parameters
index
The name of the CubeDef to find.
Remarks

The Find method returns null if the object is not found, whereas the Item property throws an exception if the object is not found.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

CubeCollection Class | CubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator Structure

Supports iterating over a CubeCollection and reading its individual cubes.

For a list of all members of this type, see CubeCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.CubeCollection.Enumerator

[Visual Basic]
Public Structure CubeCollection.Enumerator
   Implements IEnumerator
[C#]
public struct CubeCollection.Enumerator : IEnumerator
[C++]
public __value struct CubeCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator Members

CubeCollection.Enumerator Structure

Public Properties

public property Current Gets the current cube in the CubeCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next cube in the CubeCollection.
public method Reset | Moves the enumerator to a position before the first cube in the CubeCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

CubeCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator Properties

The properties of the CubeCollection.Enumerator structure are listed here. For a complete list of CubeCollection.Enumerator structure members, see CubeCollection.Enumerator Members.

Public Properties

public property Current Gets the current cube in the CubeCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

CubeCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator.Current Property

Gets the current cube in the CubeCollection.

[Visual Basic]
Public ReadOnly Property Current As CubeDef
[C#]
public CubeDef Current {get;}
[C++]
public: __property CubeDef* get_Current();
[JScript]
public function get Current() : CubeDef;
Property Value

The cube in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last cube in the CubeCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection.Enumerator Structure | CubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator.System.Collections.IEnumerator.Current Property

Supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

CubeCollection.Enumerator Structure | CubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator Methods

The methods of the CubeCollection.Enumerator structure are listed here. For a complete list of CubeCollection.Enumerator structure members, see CubeCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next cube in the CubeCollection.
public method Reset | Moves the enumerator to a position before the first cube in the CubeCollection.
public method ToString (inherited from System.ValueType) | Gets a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CubeCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator.MoveNext Method

Moves to the next cube in the CubeCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection.Enumerator Structure | CubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first cube in the CubeCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeCollection.Enumerator Structure | CubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeInfo Class

Represents metadata pertaining to a cube that is associated with an instance of a CellSet class.

For a list of all members of this type, see CubeInfo Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.CubeInfo

[Visual Basic]
NotInheritable Public Class CubeInfo
[C#]
public sealed class CubeInfo
[C++]
public __gc __sealed class CubeInfo
[JScript]
public class CubeInfo
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

CubeInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


CubeInfo Members

CubeInfo Class

Public Properties

public property Cubes Gets an OlapInfoCubeCollection that represents metadata pertaining to the cubes that are associated with the CubeInfo.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

CubeInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeInfo Properties

The properties of the CubeInfo class are listed here. For a complete list of CubeInfo class members, see CubeInfo Members.

Public Properties

public property Cubes Gets an OlapInfoCubeCollection object that represents metadata pertaining to the cubes that are associated with the CubeInfo.

See Also

CubeInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


CubeInfo.Cubes Property

Gets an OlapInfoCubeCollection that represents metadata pertaining to the hierarchies that are associated with the CubeInfo.

[Visual Basic]
Public ReadOnly Property Cubes As OlapInfoCubeCollection
[C#]
public OlapInfoCubeCollection Cubes {get;}
[C++]
public: __property OlapInfoCubeCollection* get_Cubes();
[JScript]
public function get Cubes() : OlapInfoCubeCollection;
Property Value

Returns an OlapInfoCubeCollection that represents metadata pertaining to the hierarchies that are associated with the CubeInfo.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

CubeInfo Class | CubeInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Class

Represents a dimension within a cube.

For a complete list of Dimension class members, see Dimension Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Dimension

[Visual Basic]
NotInheritable Public Class Dimension
[C#]
public sealed class Dimension
[C++]
public __gc __sealed class Dimension
[JScript]
public class Dimension
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

In ADOMD.NET, a dimension is a collection of hierarchies.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Members

Dimension Class

Public Properties

public property AttributeHierarchies | Note This member is not supported
public property Caption | Gets the caption of the Dimension.
public property Description | Gets the description of the Dimension.
public property DimensionType | Gets the dimension type of the Dimension.
public property Hierarchies | Gets a HierarchyCollection that contains the dimension hierarchies for the Dimension.
public property Name | Gets the name of the Dimension.
public property ParentCube | Gets a CubeDef that contains the Dimension.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Dimension.
public property UniqueName | Gets the unique name of the Dimension.
public property WriteEnabled | Gets a value indicating whether or not the Dimension is write enabled.

Public Methods

public method Equals | Overridden. Determines whether two instances of Dimension are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Dimension.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Dimension are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Dimension are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Dimension Class | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Properties

The properties of the Dimension class are listed here. For a complete list of Dimension class members, see Dimension Members.

Public Properties

public property AttributeHierarchies | This member is reserved for future use.
public property Caption | Gets the caption of the Dimension.
public property Description | Gets the description of the Dimension.
public property DimensionType | Gets the dimension type of the Dimension.
public property Hierarchies | Gets a HierarchyCollection that contains the dimension hierarchies for the Dimension.
public property Name | Gets the name of the Dimension.
public property ParentCube | Gets a CubeDef that contains the Dimension.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Dimension.
public property UniqueName | Gets the unique name of the Dimension.
public property WriteEnabled | Gets a value that indicates whether the Dimension is write enabled.

See Also

Dimension Class | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.AttributeHierarchies Property

This member is reserved for future use.

[Visual Basic]
Public ReadOnly Property AttributeHierarchies As HierarchyCollection
[C#]
public HierarchyCollection AttributeHierarchies {get;}
[C++]
public: __property HierarchyCollection* get_AttributeHierarchies();
[JScript]
public function get AttributeHierarchies() : HierarchyCollection;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.Caption Property

Gets the caption of the Dimension.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the Dimension.

Remarks

The Caption property should be used when displaying the name of the Dimension to the user, such as in the user interface or reports.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.Description Property

Gets the description of the Dimension.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the Dimension.

Remarks

The Description property contains descriptive text that is assigned to the dimension. This descriptive text is typically used for display purposes.

The value of this property is identical to the value of the DESCRIPTION column of the DIMENSIONS schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.DimensionType Property

Gets the dimension type of the Dimension.

[Visual Basic]
Public ReadOnly Property DimensionType As DimensionTypeEnum
[C#]
public DimensionTypeEnum DimensionType {get;}
[C++]
public: __property DimensionTypeEnum get_DimensionType();
[JScript]
public function get DimensionType() : DimensionTypeEnum;
Property Value

A DimensionTypeEnum enumeration value that represents the dimension type of the Dimension.

Remarks

In Microsoft SQL Server 2000 Analysis Services, dimensions can be one of several different types, each with different functionality. For example, a time dimension has certain characteristics not shared by other dimensions, such as account dimensions, that make it useful for time series analysis.

For more information about the DimensionTypeEnum enumeration, see DimensionTypeEnum Enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.Hierarchies Property

Gets a HierarchyCollection that contains the dimension hierarchies for the Dimension.

[Visual Basic]
Public ReadOnly Property Hierarchies As HierarchyCollection
[C#]
public HierarchyCollection Hierarchies {get;}
[C++]
public: __property HierarchyCollection* get_Hierarchies();
[JScript]
public function get Hierarchies() : HierarchyCollection;
Property Value

A HierarchyCollection that contains the dimension hierarchies for the Dimension.

Remarks

This property retrieves the user hierarchies associated with a given dimension.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.Name Property

Gets the name of the Dimension.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the Dimension.

Remarks

The Name property returns the dimension name of the Dimension. To get the unique name of a Dimension, use the UniqueName property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.ParentCube Property

Gets a CubeDef that contains the Dimension.

[Visual Basic]
Public ReadOnly Property ParentCube As CubeDef
[C#]
public CubeDef ParentCube {get;}
[C++]
public: __property CubeDef* get_ParentCube();
[JScript]
public function get ParentCube() : CubeDef;
Property Value

A CubeDef that represents the parent cube of the Dimension.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.Properties Property

Gets a PropertyCollection that contains the properties associated with the Dimension.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

A PropertyCollection that contains the properties associated with the dimension.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.UniqueName Property

Gets the unique name of the Dimension.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the unique name of the Dimension.

Remarks

The UniqueName property returns the fully-qualified unique name of the Dimension. To get the dimension name of the Dimension, use the Name property.

Warning Because this value is provider specific and may change in the future, it should be used in whole, and not be parsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.WriteEnabled Property

Gets a value that indicates whether the Dimension is write enabled.

[Visual Basic]
Public ReadOnly Property WriteEnabled As Boolean
[C#]
public bool WriteEnabled {get;}
[C++]
public: __property bool get_WriteEnabled();
[JScript]
public function get WriteEnabled() : Boolean;
Property Value

A Boolean set to true if the Dimension is write enabled. It is set to false if the Dimension is not write enabled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Methods

The methods of the Dimension class are listed here. For a complete list of Dimension class members, see Dimension Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Dimension are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Dimension.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Dimension Class | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.Equals Method

Determines whether two specified instances of Dimension are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Arguments [Visual Basic, JScript]
o1
A Dimension.
o2
A Dimension.
Parameters [C#, C++]
o1
A Dimension.
o2
A Dimension.
Return Value

true if o1 and o2 represent the same Dimension; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the Dimension.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Operators

The operators of the Dimension class are listed here. For a complete list of Dimension class members, see Dimension Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Dimension are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Dimension are unequal.

See Also

Dimension Class | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Equality Operator

Determines whether two specified instances of Dimension are equal.

[Visual Basic]
returnValue = Dimension.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Dimension o1,
   Dimension o2
);
[C++]
public: static bool op_Equality(
   Dimension* o1,
   Dimension* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Dimension.
o2
A Dimension.
Parameters [Visual Basic, C#, C++]
o1
A Dimension.
o2
A Dimension.
Return Value

true if o1 and o2 represent the same Dimension; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


Dimension Inequality Operator

Determines whether two specified instances of Cell are unequal.

[Visual Basic]
returnValue = Dimension.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Dimension o1,
   Dimension o2
);
[C++]
public: static bool op_Inequality(
   Dimension* o1,
   Dimension* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Dimension.
o2
A Dimension.
Parameters [Visual Basic, C#, C++]
o1
A Dimension.
o2
A Dimension.
Return Value

true if o1 and o2 do not represent the same Dimension; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Dimension Class | Dimension Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection Class

Contains a read-only, on-demand collection of Dimension objects contained in a CubeDef.

For a complete list of DimensionCollection class members, see DimensionCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.DimensionCollection

[Visual Basic]
NotInheritable Public Class DimensionCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class DimensionCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class DimensionCollection : public
   ICollection, IEnumerable
[JScript]
public class DimensionCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a CubeDef, iterates through the DimensionCollection collection and displays information about each dimension:

Public Sub ListDimensionCollection(ByRef CubeToCheck As CubeDef)

    ' Check the parameter before performing actions on it.
    If CubeToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CubeToCheck")
    Else
        ' Iterate through the Dimensions collection of the
        ' CubeDef object.

        Try
            Dim dimToCheck As Dimension

            Debug.WriteLine("Found " & CubeToCheck.Dimensions.Count & _
                " dimensions in cube:")

            For Each dimToCheck In CubeToCheck.Dimensions
                Debug.WriteLine("Dimension:  " & dimToCheck.Name)
                Debug.WriteLine("  Caption:        " & _
                    dimToCheck.Caption)
                Debug.WriteLine("  Description:    " & _
                    dimToCheck.Description)
                Debug.WriteLine("  UniqueName:     " & _
                    dimToCheck.UniqueName)
                Debug.WriteLine("  The dimension " & _
                    IIf(dimToCheck.WriteEnabled = True, "is", "is not") & _
                    " write-enabled.")
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection Members

DimensionCollection Class

Public Properties

public property Count | Gets the number of Dimension objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Dimension from the collection. In C#, this property is the indexer for the DimensionCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two Object instances are equal.
public method Find | Returns the specified Dimension from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

DimensionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection Properties

The properties of the DimensionCollection class are listed here. For a complete list of DimensionCollection class members, see DimensionCollection Members.

Public Properties

public property Count | Gets the number of Dimension objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Dimension from the collection. In C#, this property is the indexer for the DimensionCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

DimensionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Count Property

Gets the number of Dimension objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of Dimension objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Item Property

Gets the specified Dimension from the collection.

[C#] In C#, this property is the indexer for the DimensionCollection class.

Overload List

Gets the specified Dimension from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As Dimension
[C#] public Dimension this[System.Int32] {get;}
[C++] public: __property Dimension* get_Item(System.Int32);
[JScript] DimensionCollection.Item (System.Int32)

Gets the specified Dimension from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As Dimension
[C#] public Dimension this[System.String] {get;}
[C++] public: __property Dimension* get_Item(System.String);
[JScript] DimensionCollection.Item (System.String)
See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Item Property (System.Int32)

Gets the specified Dimension from the collection by its index.

[C#] In C#, this property is the indexer for the DimensionCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Dimension
[C#]
public Dimension this[
   int index
] {get;}
[C++]
public: __property Dimension* get_Item(
   int index
);
[JScript]
returnValue = DimensionCollectionObject.Item(index);
-or-
returnValue = DimensionCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Dimension to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Dimension to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | DimensionCollection.Item Overload List


DimensionCollection.Item Property (System.String)

Gets the specified Dimension from the collection by its name.

[C#] In C#, this property is the indexer for the DimensionCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Dimension
[C#]
public Dimension this[
   string index
] {get;}
[C++]
public: __property Dimension* get_Item(
   String* index
);
[JScript]
returnValue = DimensionCollectionObject.Item(index);
-or-
returnValue = DimensionCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the Dimension to find.
Parameters [Visual Basic, C#, C++]
index
The name of the Dimension to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | DimensionCollection.Item Overload List


DimensionCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection Methods

The methods of the DimensionCollection class are listed here. For a complete list of DimensionCollection class members, see DimensionCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an IEnumerator interface for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

DimensionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Dimension, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Dimension[] array,
   int index
);
[C++]
public: void CopyTo(
   Dimension* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Dimension[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Find Method

Gets the specified Dimension from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As Dimension
[C#]
public Dimension Find(
   string index
);
[C++]
public: Dimension* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : Dimension;
Parameters
index
The name of the Dimension to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

DimensionCollection Class | DimensionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator Structure

Supports iterating over a DimensionCollection and reading its individual dimensions.

For a list of all members of this type, see DimensionCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.DimensionCollection.Enumerator

[Visual Basic]
Public Structure DimensionCollection.Enumerator
   Implements IEnumerator
[C#]
public struct DimensionCollection.Enumerator : IEnumerator
[C++]
public __value struct DimensionCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

DimensionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator Members

DimensionCollection.Enumerator Structure

Public Properties

public property Current Gets the current dimension in the DimensionCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next dimension in the DimensionCollection.
public method Reset | Moves the enumerator to a position before the first dimension in the DimensionCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

DimensionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator Properties

The properties of the DimensionCollection.Enumerator structure are listed here. For a complete list of DimensionCollection.Enumerator structure members, see DimensionCollection.Enumerator Members.

Public Properties

public property Current Gets the current dimension in the DimensionCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

DimensionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator.Current Property

Gets the current dimension in the DimensionCollection.

[Visual Basic]
Public ReadOnly Property Current As Dimension
[C#]
public Dimension Current {get;}
[C++]
public: __property Dimension* get_Current();
[JScript]
public function get Current() : Dimension;
Property Value

The dimension in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last dimension in the DimensionCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection.Enumerator Structure | DimensionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

DimensionCollection.Enumerator Structure | DimensionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator Methods

The methods of the DimensionCollection.Enumerator structure are listed here. For a complete list of DimensionCollection.Enumerator structure members, see DimensionCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next dimension in the DimensionCollection.
public method Reset | Moves the enumerator to a position before the first dimension in the DimensionCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

DimensionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator.MoveNext Method

Moves to the next dimension in the DimensionCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection.Enumerator Structure | DimensionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first dimension of the DimensionCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

DimensionCollection.Enumerator Structure | DimensionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


DimensionTypeEnum Enumeration

Represents the dimension type of a Dimension.

[Visual Basic]
<Serializable>
Public Enum DimensionTypeEnum
[C#]
[Serializable]
public enum DimensionTypeEnum
[C++]
[Serializable]
__value public enum DimensionTypeEnum
[JScript]
public
   Serializable
enum DimensionTypeEnum
Remarks

The DimensionType property of the Dimension provides client applications with information about the contents of the dimension. For example, a client application may benefit from knowing that one dimension is based on geography, and another dimension is based on time. When accepting user inputs for these dimensions (say, in the construction of an MDX statement), the client application can use a map-based control for the Geography dimension and a calendar-based control for the Time dimension.

Members

Member name | Description
Accounts | Describes a dimension that contains an accounts structure with parent-child relationships.
BillOfMaterials | Describes a dimension that represents a material/component breakdown. The parent-child relationship implies a parent composed of its children.
Channel | Describes a dimension that contains information about a distribution channel.
Currency | Describes a dimension that contains currency information.
Customers | Describes a dimension that contains customer information. The lowest level represents individual customers.
Geography | Describes a dimension that contains a geographic hierarchy.
Measure | Describes a dimension that contains measures.
Organization | Describes a dimension that represents the reporting structure of an organization.
Other | Describes a dimension of the default dimension type, which is used for dimensions that are not time dimensions or measure dimensions.
Products | Describes a dimension that contains product information. The lowest level represents individual products.
Promotion | Describes a dimension that contains information about marketing and advertising promotions.
Quantitative | Describes a dimension that contains quantitative elements (for example, income level, or number of children).
Rates | Describes a dimension that contains different types of rates (for example, buy, sell, or discounted).
Scenario | Describes a dimension that contains different business scenarios.
Time | Indicates that a dimension refers to time (for example, year, month, week, day, and so on).
Unknown | Describes a dimension with an unknown or unspecified type.
Utility | Describes a dimension that contains only calculated members. This type of dimension is usually used for data visualization techniques.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Class

Represents a dimension hierarchy contained by a dimension or set.

For a complete list of Hierarchy class members, see Hierarchy Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Hierarchy

[Visual Basic]
NotInheritable Public Class Hierarchy
[C#]
public sealed class Hierarchy
[C++]
public __gc __sealed class Hierarchy
[JScript]
public class Hierarchy
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A hierarchy represents a set of members and their positions relative to one another. From the top of the pyramidal structure to the bottom, the members are progressively more detailed. User hierarchies are defined to represent a hierarchy that has meaning to the user or application.

In ADOMD.NET, the Hierarchy can represent both parent-child hierarchies and user hierarchies. The HierarchyOrigin property is used to differentiate between the hierarchy structures.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Members

Hierarchy Class

Public Properties

public property Caption | Gets the caption of the Hierarchy.
public property DefaultMember | Gets the unique name of the default member for the Hierarchy.
public property Description | Gets the description of the Hierarchy.
public property DisplayFolder | This member is reserved for future use.
public property HierarchyOrigin | Gets the hierarchy type of the Hierarchy.
public property Levels | Gets a LevelCollection that contains the levels of the Hierarchy.
public property Name | Gets the name of the Hierarchy.
public property ParentDimension | Gets a Dimension that contains the Hierarchy.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Hierarchy.
public property UniqueName | Gets the unique name of the Hierarchy.

Public Methods

public method Equals | Overridden. Determines whether two instances of Hierarchy are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Hierarchy.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two Hierarchy objects are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two Hierarchy objects are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Hierarchy Class | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Properties

The properties of the Hierarchy class are listed here. For a complete list of Hierarchy class members, see Hierarchy Members.

Public Properties

public property Caption | Gets the caption of the Hierarchy.
public property DefaultMember | Gets the unique name of the default member for the Hierarchy.
public property Description | Gets the description of the Hierarchy.
public property DisplayFolder | This member is reserved for future use.
public property HierarchyOrigin | Gets the hierarchy type of the Hierarchy.
public property Levels | Gets a LevelCollection that contains the levels of the Hierarchy.
public property Name | Gets the name of the Hierarchy.
public property ParentDimension | Gets a Dimension that contains the Hierarchy.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Hierarchy.
public property UniqueName | Gets the unique name of the Hierarchy.

See Also

Hierarchy Class | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.Caption Property

Gets the caption of the Hierarchy.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the Hierarchy.

Remarks

The Caption property should be used when displaying the name of the Hierarchy to the user, such as in the user interface or reports.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.DefaultMember Property

Gets the unique name of the default member for the Hierarchy.

[Visual Basic]
Public ReadOnly Property DefaultMember As String
[C#]
public string DefaultMember {get;}
[C++]
public: __property String* get_DefaultMember();
[JScript]
public function get DefaultMember() : String;
Property Value

A String that contains the unique name of the default member for the Hierarchy.

Remarks

Just as each dimension has a default hierarchy used to resolve queries, each hierarchy has a default member. The default member is typically used when a dimension is not explicitly specified by a tuple used in a query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.Description Property

Gets the description of the Hierarchy.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the Hierarchy.

Remarks

The Description property contains descriptive text that is assigned to the hierarchy. This descriptive text is typically used for display purposes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.DisplayFolder Property

This member is reserved for future use.

[Visual Basic]
Public ReadOnly Property DisplayFolder As String
[C#]
public string DisplayFolder {get;}
[C++]
public: __property String* get_DisplayFolder();
[JScript]
public function get DisplayFolder() : String;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.HierarchyOrigin Property

Gets the hierarchy type of the Hierarchy.

[Visual Basic]
Public ReadOnly Property HierarchyOrigin As HierarchyOrigin
[C#]
public HierarchyOrigin HierarchyOrigin {get;}
[C++]
public: __property HierarchyOrigin get_HierarchyOrigin();
[JScript]
public function get HierarchyOrigin() : HierarchyOrigin;
Property Value

A HierarchyOrigin enumeration value that represents the hierarchy type of the Hierarchy.

Remarks

For more information about hierarchy types, see HierarchyOrigin Enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.Levels Property

Gets a LevelCollection that contains the levels of the Hierarchy.

[Visual Basic]
Public ReadOnly Property Levels As LevelCollection
[C#]
public LevelCollection Levels {get;}
[C++]
public: __property LevelCollection* get_Levels();
[JScript]
public function get Levels() : LevelCollection;
Property Value

A LevelCollection that contains the levels of the Hierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.Name Property

Gets the name of the Hierarchy.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the Hierarchy.

Remarks

The Name property returns the name of the Hierarchy. To get the unique name of a Hierarchy, use the UniqueName property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.ParentDimension Property

Gets a Dimension that contains the Hierarchy.

[Visual Basic]
Public ReadOnly Property ParentDimension As Dimension
[C#]
public Dimension ParentDimension {get;}
[C++]
public: __property Dimension* get_ParentDimension();
[JScript]
public function get ParentDimension() : Dimension;
Property Value

A Dimension that contains the Hierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.Properties Property

Gets a PropertyCollection that contains the properties associated with the Hierarchy.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

A PropertyCollection that contains the properties associated with the hierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.UniqueName Property

Gets the unique name of the Hierarchy.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the key of the Hierarchy.

Remarks

The UniqueName property returns the fully-qualified unique name of the Hierarchy. To get the name of the Hierarchy, use the Name property.

Warning Because this value is provider specific and may change in the future, it should be used in whole, and not be parsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Methods

The methods of the Hierarchy class are listed here. For a complete list of Hierarchy class members, see Hierarchy Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Hierarchy Class | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.Equals Method

Determines whether two instances of Hierarchy are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Hierarchy.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy.ToString Method

Returns a String that represents the current Hierarchy.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the Hierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Operators

The operators of the Hierarchy class are listed here. For a complete list of Hierarchy class members, see Hierarchy Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two Hierarchy objects are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two Hierarchy objects are unequal.

See Also

Hierarchy Class | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Equality Operator

Determines whether two Hierarchy objects are equal.

[Visual Basic]
returnValue = Hierarchy.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Hierarchy o1,
   Hierarchy o2
);
[C++]
public: static bool op_Equality(
   Hierarchy* o1,
   Hierarchy* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Hierarchy.
o2
A Hierarchy.
Parameters [Visual Basic, C#, C++]
o1
A Hierarchy.
o2
A Hierarchy object.
Return Value

true if o1 and o2 represent the same Hierarchy; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


Hierarchy Inequality Operator

This operator determines whether two Hierarchy objects are unequal.

[Visual Basic]
returnValue = Hierarchy.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Hierarchy o1,
   Hierarchy o2
);
[C++]
public: static bool op_Inequality(
   Hierarchy* o1,
   Hierarchy* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Hierarchy.
o2
A Hierarchy.
Parameters [Visual Basic, C#, C++]
o1
A Hierarchy.
o2
A Hierarchy.
Return Value

true if o1 and o2 do not represent the same Hierarchy; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Hierarchy Class | Hierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection Class

Contains a read-only, on-demand collection of Hierarchy objects contained in a Dimension or a Set.

For a complete list of HierarchyCollection class members, see HierarchyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.HierarchyCollection

[Visual Basic]
NotInheritable Public Class HierarchyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class HierarchyCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class HierarchyCollection : public
   ICollection, IEnumerable
[JScript]
public class HierarchyCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

While the HierarchyCollection externally represents a collection of Hierarchy objects, the collection is internally loaded and managed in one of two ways, depending on the parent of the collection:

  • If the parent object was referenced as a result of a query, as in the case of a Set referenced from an Axis, the collection represents the members referenced by that query.
  • If the parent object was referenced as a result of a request for metadata, as in the case of a Dimension referenced from a CubeDef, the collection represents the members referenced by the definition of the parent object.
Example
[Visual Basic]

The following subroutine, given a Dimension, iterates through the HierarchyCollection collection and displays information about each hierarchy:

Public Overloads Sub ListHierarchies(ByRef DimToCheck As Dimension)

    ' Check the parameter before performing actions on it.
    If DimToCheck Is Nothing Then
        Throw New System.ArgumentNullException("DimToCheck")
    Else
        ' Iterate through the Hierarchies collection of the
        ' Dimension object.

        Try
            Dim hierToCheck As Hierarchy

            Debug.WriteLine("Found " & DimToCheck.Hierarchies.Count & _
                " hierarchies in dimension:")

            For Each hierToCheck In DimToCheck.Hierarchies
                Debug.WriteLine("Hierarchy:  " & hierToCheck.Name)
                Debug.WriteLine("  Caption:        " & _
                    hierToCheck.Caption)
                Debug.WriteLine("  Description:    " & _
                    hierToCheck.Description)
                Debug.WriteLine("  UniqueName:     " & _
                    hierToCheck.UniqueName)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection Members

HierarchyCollection Class

Public Properties

public property Count | Gets the number of Hierarchy objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Gets the specified Hierarchy from the collection. In C#, this property is the indexer for the HierarchyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Hierarchy from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

HierarchyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection Properties

The properties of the HierarchyCollection class are listed here. For a complete list of HierarchyCollection class members, see HierarchyCollection Members.

Public Properties

public property Count | Gets the number of Hierarchy objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Gets the specified Hierarchy from the collection. In C#, this property is the indexer for the HierarchyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

HierarchyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Count Property

Gets the number of Hierarchy objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of Hierarchy objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Item Property

Gets the specified Hierarchy from the collection.

[C#] In C#, this property is the indexer for the HierarchyCollection class.

Overload List

Gets the specified Hierarchy from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As Hierarchy
[C#] public Hierarchy this[System.Int32] {get;}
[C++] public: __property Hierarchy* get_Item(System.Int32);
[JScript] HierarchyCollection.Item (System.Int32)

Gets the specified Hierarchy from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As Hierarchy
[C#] public Hierarchy this[System.String] {get;}
[C++] public: __property Hierarchy* get_Item(System.String);
[JScript] HierarchyCollection.Item (System.String)
See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Item Property (System.Int32)

Gets the specified Hierarchy from the collection by its index.

[C#] In C#, this property is the indexer for the HierarchyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Hierarchy
[C#]
public Hierarchy this[
   int index
] {get;}
[C++]
public: __property Hierarchy* get_Item(
   int index
);
[JScript]
returnValue = HierarchyCollectionObject.Item(index);
-or-
returnValue = HierarchyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Hierarchy to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Hierarchy to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | HierarchyCollection.Item Overload List


HierarchyCollection.Item Property (System.String)

Gets the specified Hierarchy from the collection by its name.

[C#] In C#, this property is the indexer for the HierarchyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Hierarchy
[C#]
public Hierarchy this[
   string index
] {get;}
[C++]
public: __property Hierarchy* get_Item(
   String* index
);
[JScript]
returnValue = HierarchyCollectionObject.Item(index);
-or-
returnValue = HierarchyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the Hierarchy to find.
Parameters [Visual Basic, C#, C++]
index
The name of the Hierarchy to find.
Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException | The Hierarchy was not found in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | HierarchyCollection.Item Overload List


HierarchyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection Methods

The methods of the HierarchyCollection class are listed here. For a complete list of HierarchyCollection class members, see HierarchyCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Hierarchy from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

HierarchyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Hierarchy, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Hierarchy[] array,
   int index
);
[C++]
public: void CopyTo(
   Hierarchy* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Hierarchy[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Find Method

Gets the specified Hierarchy from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As Hierarchy
[C#]
public Hierarchy Find(
   string index
);
[C++]
public: Hierarchy* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : Hierarchy;
Parameters
index
The name of the Hierarchy to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

HierarchyCollection Class | HierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator Structure

Supports iterating over a HierarchyCollection and reading its individual hierarchies.

For a list of all members of this type, see HierarchyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.HierarchyCollection.Enumerator

[Visual Basic]
Public Structure HierarchyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct HierarchyCollection.Enumerator : IEnumerator
[C++]
public __value struct HierarchyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

HierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator Members

HierarchyCollection.Enumerator Structure

Public Properties

public property Current Gets the current hierarchy in the HierarchyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next hierarchy in the HierarchyCollection.
public method Reset | Moves the enumerator to a position before the first hierarchy in the HierarchyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

HierarchyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator Properties

The properties of the HierarchyCollection.Enumerator structure are listed here. For a complete list of HierarchyCollection.Enumerator structure members, see HierarchyCollection.Enumerator Members.

Public Properties

public property Current Gets the current hierarchy in the HierarchyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

HierarchyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator.Current Property

Gets the current hierarchy in the HierarchyCollection.

[Visual Basic]
Public ReadOnly Property Current As Hierarchy
[C#]
public Hierarchy Current {get;}
[C++]
public: __property Hierarchy* get_Current();
[JScript]
public function get Current() : Hierarchy;
Property Value

The current hierarchy of the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last hierarchy in the HierarchyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection.Enumerator Structure | HierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

HierarchyCollection.Enumerator Structure | HierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator Methods

The methods of the HierarchyCollection.Enumerator structure are listed here. For a complete list of HierarchyCollection.Enumerator structure members, see HierarchyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next hierarchy in the HierarchyCollection.
public method Reset | Moves the enumerator to a position before the first hierarchy in the HierarchyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

HierarchyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator.MoveNext Method

Moves to the next hierarchy in the HierarchyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection.Enumerator Structure | HierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first hierarchy in the HierarchyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

HierarchyCollection.Enumerator Structure | HierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


HierarchyOrigin Enumeration

Describes the overall structure of a hierarchy.

[Visual Basic]
<Serializable>
Public Enum HierarchyOrigin
[C#]
[Serializable]
public enum HierarchyOrigin
[C++]
[Serializable]
__value public enum HierarchyOrigin
[JScript]
public
   Serializable
enum HierarchyOrigin
Members

Member name | Description
AttributeHierarchy Specifies that the hierarchy is an attribute hierarchy.

Note This enumeration is not supported.
ParentChildHierarchy | Specifies that the hierarchy is a parent-child hierarchy.
UserHierarchy | Specifies that the hierarchy is a user-defined hierarchy.

Example
[Visual Basic]

The following subroutine examines a CellSet, listing each axis and the hierarchies contained by each axis, and then displays the HierarchyOrigin value for each Hierarchy.

    Public Sub ListHierarchyOrigins(ByRef CellSetToCheck As CellSet)
        Dim SampleAxis As Microsoft.AnalysisServices.AdomdClient.Axis
        Dim SampleHierarchy As Hierarchy

        With CellSetToCheck

            ' First, output the number of axes contained by the cellset.
            Console.WriteLine("The cellset has {0} axes.", _
                CellSetToCheck.Axes.Count)

            ' Iterate through each axis to examine the
            ' hierarchies for each axis.
            For Each SampleAxis In CellSetToCheck.Axes
                Console.WriteLine("Axis '{0}' has {1} hierarchies.", _
                    SampleAxis.Name, _
                    SampleAxis.Set.Hierarchies.Count)

                ' Iterate through each hierarchy contained by an axis.
                For Each SampleHierarchy In SampleAxis.Set.Hierarchies
                    ' Check the HierarchyOrigin value to determine if the
                    ' hierarchy is balanced or unbalanced.
                    Dim TempString As String
                    Select Case SampleHierarchy.HierarchyOrigin
                        Case HierarchyOrigin.ParentChildHierarchy
                           TempString = "Parent/Child Hierarchy"
                        Case HierarchyOrigin.UserHierarchy
                           TempString = "User defined hierarchy"
                        Case HierarchyOrigin.AttributeHierarchy
                           TempString = "Attribute Hierarchy"
                        Case Else
                           TempString = "unknown"
                    End Select
                    Console.WriteLine("The structure for hierarchy '{0}' is {1}.", _
                        SampleHierarchy.Name, _
                        TempString)
                Next
            Next
        End With
    End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Hierarchy | Microsoft.AnalysisServices.AdomdClient Namespace


Level Class

Represents a level within a hierarchy.

For a complete list of Level class members, see Level Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Level

[Visual Basic]
NotInheritable Public Class Level
[C#]
public sealed class Level
[C++]
public __gc __sealed class Level
[JScript]
public class Level
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

Dimensions are complex structures in Microsoft SQL Server 2000 Analysis Services, containing members that are organized into levels, which in turn are organized into hierarchies. In ADOMD.NET, levels are represented by the Level class.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level Members

Level Class

Public Properties

public property Caption | Gets the caption of the Level.
public property Description | Gets the description of the Level.
public property LevelNumber | Gets the ordinal position of the Level within the parent hierarchy.
public property LevelProperties | Gets a LevelPropertyCollection that contains a collection of level properties for the Level.
public property LevelType | Gets the level type of the Level.
public property MemberCount | Gets the number of members contained by the Level.
public property Name | Gets the name of the Level.
public property ParentHierarchy | Gets a Hierarchy that contains the Level.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Level.
public property UniqueName | Gets the unique name of the Level.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public property GetMembers | Overloaded. Returns a MemberCollection that contains a collection of members for the Level.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Level are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Level are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Level Class | Microsoft.AnalysisServices.AdomdClient Namespace


Level Properties

The properties of the Level class are listed here. For a complete list of Level class members, see Level Members.

Public Properties

public property Caption | Gets the caption of the Level.
public property Description | Gets the description of the Level.
public property LevelNumber | Gets the ordinal position of the Level within the parent hierarchy.
public property LevelProperties | Gets a LevelPropertyCollection that contains a collection of level properties for the Level.
public property LevelType | Gets the level type of the Level.
public property MemberCount | Gets the number of members contained by the Level.
public property Name | Gets the name of the Level.
public property ParentHierarchy | Gets a Hierarchy obect that contains the Level.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Level.
public property UniqueName | Gets the unique name of the Level.

See Also

Level Class | Microsoft.AnalysisServices.AdomdClient Namespace


Level.Caption Property

Gets the caption of the Level.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the Level.

Remarks

The Caption property should be used when displaying the name of the Level to the user, such as in user interfaces or reports.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.Description Property

Gets the description of the Level.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the Level.

Remarks

The Description property contains descriptive text that is assigned to the level. This descriptive text is typically used for display purposes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.LevelNumber Property

Gets the ordinal position of the Level within the parent hierarchy.

[Visual Basic]
Public ReadOnly Property LevelNumber As Integer
[C#]
public int LevelNumber {get;}
[C++]
public: __property int get_LevelNumber();
[JScript]
public function get LevelNumber() : int;
Property Value

An Integer that contains the ordinal position of the Level within the parent hierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.LevelProperties Property

Gets a LevelPropertyCollection that contains a collection of member properties for the Level.

[Visual Basic]
Public ReadOnly Property LevelProperties As LevelPropertyCollection
[C#]
public LevelPropertyCollection LevelProperties {get;}
[C++]
public: __property LevelPropertyCollection* get_LevelProperties();
[JScript]
public function get LevelProperties() : LevelPropertyCollection;
Property Value

A LevelPropertyCollection that contains a collection of level properties for the Level.

Remarks

In Microsoft SQL Server 2000 Analysis Services, a dimension attribute can have a set of related attributes that depend on the dimension attribute. If you use a dimension attribute with related attributes to construct a level in a hierarchy, the related attributes are called member properties. These properties provide additional data to members within the level.

Level properties differ from member properties in that level properties contain the names and metadata associated with the member properties available on the members within that level, while member properties contain the actual data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.LevelType Property

Gets the level type of the Level.

[Visual Basic]
Public ReadOnly Property LevelType As LevelTypeEnum
[C#]
public LevelTypeEnum LevelType {get;}
[C++]
public: __property LevelTypeEnum get_LevelType();
[JScript]
public function get LevelType() : LevelTypeEnum;
Property Value

A LevelTypeEnum enumeration value that represents the level type of the Level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.MemberCount Property

Gets the number of members contained by the Level.

[Visual Basic]
Public ReadOnly Property MemberCount As Long
[C#]
public long MemberCount {get;}
[C++]
public: __property __int64 get_MemberCount();
[JScript]
public function get MemberCount() : long;
Property Value

A Long that contains the number of members contained by the Level

Remarks

The value of this property represents the approximate number of members contained by the Level. If you need the exact number of members contained by the Level, you should use the Count property of the collection returned by the GetMembers method of the Level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.Name Property

Gets the name of the Level.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the Level.

Remarks

The Name property returns the unqualified name of the level that the Level represents. To get the fully qualified name of a Level, use the UniqueName property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.ParentHierarchy Property

Gets a Hierarchy that contains the Level.

[Visual Basic]
Public ReadOnly Property ParentHierarchy As Hierarchy
[C#]
public Hierarchy ParentHierarchy {get;}
[C++]
public: __property Hierarchy* get_ParentHierarchy();
[JScript]
public function get ParentHierarchy() : Hierarchy;
Property Value

A Hierarchy.

Remarks

Each level is associated with one hierarchy. The Hierarchy property returns the parent Hierarchy that is associated with the specified Level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.Properties Property

Gets a PropertyCollection that contains the properties associated with the Level.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

A PropertyCollection that contains the properties associated with the level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.UniqueName Property

Gets the unique name of the Level.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the unique name of the Level.

Remarks

Typically, the UniqueName property returns the fully qualified name of the level. For example, the fully qualified unique name for the Month level of the Fiscal hierarchy in the Time dimension is [Time].[Fiscal].[Month].

To retrieve only the name of the level, use the Name property of the Level. For more information about the Name property, see Level.Name Property.

Warning Because this value is provider specific and may change in the future, it should be used in whole, and not be parsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level Methods

The methods of the Level class are listed here. For a complete list of Level class members, see Level Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public property GetMembers | Overloaded. Returns a MemberCollection that contains a collection of members for the Level.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Level Class | Microsoft.AnalysisServices.AdomdClient Namespace


Level.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.GetMembers Method

Returns a MemberCollection that contains a collection of members for the Level.

Overload List

Returns a MemberCollection that contains a collection of members for the Level.

[Visual Basic] Overloads Public Function GetMembers() As MemberCollection
[C#] public MemberCollection GetMembers();
[C++] public: MemberCollection* GetMembers();
[JScript] public function GetMembers() : MemberCollection;

Returns a MemberCollection that contains a collection of members for the Level. The returned object contains up to count members, and begins at the position indicated by the start parameter.

[Visual Basic] Overloads Public Function GetMembers(ByVal start As Long, ByVal count As Long) As MemberCollection
[C#] public MemberCollection GetMembers(long start, long count);
[C++] public: MemberCollection* GetMembers(__int64 start, __int64 count);
[JScript] public function GetMembers(start : long, count : long) : MemberCollection;

Returns a MemberCollection that contains a collection of members for the Level. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameters.

[Visual Basic] Overloads Public Function GetMembers(ByVal start As Long, ByVal count As Long, ByVal ParamArray filters() as MemberFilter) As MemberCollection
[C#] public MemberCollection GetMembers(long start, long count, params MemberFilter[] filters);
[C++] public: MemberCollection* GetMembers(__int64 start, __int64 count, MemberFilter*[] filters);
[JScript] public function GetMembers(start : long, count : long, filters : MemberFilter[]) : MemberCollection;

Returns a MemberCollection that contains a collection of members for the Level. The returned object will contain up to count members, and will begin at the position indicated by the start parameter, and be filtered by the filters parameters. Each member caches the properties indicated by the Array passed into the properties parameter.

Note For performance reasons, this overload should be used only if non-default member properties are needed. Default member properties include Name, UniqueName, Caption, ChildCount, MemberType, LevelName, and LevelNumber.

[Visual Basic] Overloads Public Function GetMembers(ByVal start As Long, ByVal count As Long, ByVal properties() as String, ByVal ParamArray filters() As MemberFilter) As MemberCollection
[C#] public MemberCollection GetMembers(long start, long count, string[] properties, params MemberFilter[] filters);
[C++] public: MemberCollection* GetMembers(__int64 start, __int64 count, String* properties[], MemberFilter*[] filters);
[JScript] public function GetMembers(start : long, count : long, properties : String[], filters : MemberFilter[]) : MemberCollection;
See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.GetMembers Method ()

Returns a MemberCollection that contains a collection of members for the Level.

Note This method loads all members of the level. If there are a large number of members, this method may take a long time to execute.

[Visual Basic]
Overloads Public Function GetMembers() As MemberCollection
[C#]
public MemberCollection GetMembers();
[C++]
public: MemberCollection* GetMembers();
[JScript]
public function GetMembers() : MemberCollection;
Return Value

A MemberCollection that contains a collection of members for the Level.

Remarks

The GetMembers method provides a collection of Member objects that represent the members that are associated with the level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.GetMembers Method (System.Int64, System.Int64)

Returns a MemberCollection that contains a collection of members for the Level. The returned object contains up to count members, and begins at the position indicated by the start parameter.

 [Visual Basic]
Public Overloads Function GetMembers(ByVal start As Long, ByVal count As Long) As MemberCollection
[C#]
public MemberCollection MemberCollection GetMembers(long start, long count);
[C++]
public: MemberCollection* GetMembers(__int64 start, __int64 count);
[JScript]
public function GetMembers(start : long, count : long) : MemberCollection;
Arguments [JScript]
start
The position to begin returning members. This argument is 0-based.
count
The number of members to return.
Parameters [Visual Basic, C#, C++]
start
The position to begin returning members. This parameter is 0-based.
count
The number of members to return.
Return Value

A MemberCollection that contains a collection of members for the Level.

Remarks

The GetMembers method provides a collection of Member objects that represent the members that are associated with the level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.GetMembers Method (System.Int64, System.Int64, MemberFilter[])

Returns a MemberCollection that contains a collection of members for the Level. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameter.

 [Visual Basic]
Public Overloads Function GetMembers(ByVal start As Long, ByVal count As Long, ByVal ParamArray filters() as MemberFilter) As MemberCollection
[C#]
public MemberCollection GetMembers(long start, long count, params MemberFilter[] filters);
[C++]
public: MemberCollection* GetMembers(__int64 start, __int64 count, MemberFilter*[] filters);
[JScript]
public function GetMembers(start : long, count : long, filters : MemberFilter[]) : MemberCollection;
Arguments [JScript]
start
The position to begin returning members. This argument is 0-based.
count
The number of members to return.
filters
An array of MemberFilter objects that filter the returned MemberCollection.
Parameters [Visual Basic, C#, C++]
start
The position to begin returning members. This parameter is 0-based.
count
The number of members to return.
filters
An array of MemberFilter objects that filter the returned MemberCollection.
Return Value

A MemberCollection that contains a collection of members for the Level.

Remarks

The GetMembers method provides a collection of Member objects that represent the members that are associated with the level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.GetMembers Method (System.Int64, System.Int64, System.String[], MemberFilter[])

Returns a MemberCollection that contains a collection of members for the Level. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameter. Each member caches the properties indicated by the Array passed into the properties parameter.

Note For performance reasons, this overload should only be used if non-default member properties are needed. Default member properties include , , , , Description, LevelDepth, LevelName, Parent, ParentLevel, and .

[Visual Basic]
Public Overloads Function GetMembers(ByVal start As Long, ByVal count As Long, ByVal properties() as String, ByVal ParamArray filters() As MemberCollection
[C#]
public MemberCollection GetMembers(long start, long count, string[] properties, params MemberFilter[] filters);
[C++]
public: MemberCollection* GetMembers(__int64 start, __int64 count, String* properties[], MemberFilter*[] filters);
[JScript]
public function GetMembers(start : long, count : long, properties : String[], filters : MemberFilter[]) : MemberCollection;
Arguments [JScript]
start
The position to begin returning members. This argument is 0-based.
count
The number of members to return.
properties
An Array indicated the properties to cache.
filters
An array of MemberFilter objects that filter the returned MemberCollection.
Parameters [Visual Basic, C#, C++]
start
The position to begin returning members. This parameter is 0-based.
count
The number of members to return.
properties
An Array indicated the properties to cache.
filters
An array of MemberFilter objects that filter the returned MemberCollection.
Return Value

A MemberCollection that contains a collection of members for the Level.

Remarks

The GetMembers method provides a collection of Member objects that represent the members that are associated with the level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the Level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level Operators

The operators of the Level class are listed here. For a complete list of Level class members, see Level Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two Level objects are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two Level objects are unequal.

See Also

Level Class | Microsoft.AnalysisServices.AdomdClient Namespace


Level Equality Operator

Determines whether two instances of Level are equal.

[Visual Basic]
returnValue = Level.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Level o1,
   Level o2
);
[C++]
public: static bool op_Equality(
   Level* o1,
   Level* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Level.
o2
A Level.
Parameters [Visual Basic, C#, C++]
o1
A Level.
o2
A Level.
Return Value

true if o1 and o2 represent the same Level; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


Level Inequality Operator

Determines whether two instances of Level are unequal.

[Visual Basic]
returnValue = Level.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Level o1,
   Level o2
);
[C++]
public: static bool op_Inequality(
   Level* o1,
   Level* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Level.
o2
A Level.
Parameters [Visual Basic, C#, C++]
o1
A Level.
o2
A Level.
Return Value

true if o1 and o2 do not represent the same Level; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Level Class | Level Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection Class

Contains a read-only, on-demand collection of Level objects contained in a Hierarchy.

For a complete list of LevelCollection class members, see LevelCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.LevelCollection

[Visual Basic]
NotInheritable Public Class LevelCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class LevelCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class LevelCollection : public ICollection,
   IEnumerable
[JScript]
public class LevelCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection Members

LevelCollection Class

Public Properties

public property Count | Gets the number of Level objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Level from the collection. In C#, this property is the indexer for the LevelCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Level from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection Properties

The properties of the LevelCollection class are listed here. For a complete list of LevelCollection class members, see LevelCollection Members.

Public Properties

public property Count | Gets the number of Level objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Level from the collection. In C#, this property is the indexer for the LevelCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

LevelCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Count Property

Gets the number of Level objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

Gets the number of Level objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Item Property

Gets the specified Level from the collection.

[C#] In C#, this property is the indexer for the LevelCollection class.

Overload List

Gets the specified Level from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As Level
[C#] public Level this[System.Int32] {get;}
[C++] public: __property Level* get_Item(System.Int32);
[JScript] LevelCollection.Item (System.Int32)

Gets the specified Level from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As Level
[C#] public Level this[System.String] {get;}
[C++] public: __property Level* get_Item(System.String);
[JScript] LevelCollection.Item (System.String)
See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Item Property (System.Int32)

Gets the specified Level from the collection by its index.

[C#] In C#, this property is the indexer for the LevelCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Level
[C#]
public Level this[
   int index
] {get;}
[C++]
public: __property Level* get_Item(
   int index
);
[JScript]
returnValue = LevelCollectionObject.Item(index);
-or-
returnValue = LevelCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Level to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Level to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | LevelCollection.Item Overload List


LevelCollection.Item Property (System.String)

Gets the specified Level from the collection by its name.

[C#] In C#, this property is the indexer for the LevelCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Level
[C#]
public Level this[
   string index
] {get;}
[C++]
public: __property Level* get_Item(
   String* index
);
[JScript]
returnValue = LevelCollectionObject.Item(index);
-or-
returnValue = LevelCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the Level to find.
Parameters [Visual Basic, C#, C++]
index
The name of the Level to find.
Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException | The Level was not found in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | LevelCollection.Item Overload List


LevelCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection Methods

The methods of the LevelCollection class are listed here. For a complete list of LevelCollection class members, see LevelCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Level from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Level, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Level[] array,
   int index
);
[C++]
public: void CopyTo(
   Level* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Level[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Find Method

Gets the specified Level from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As Level
[C#]
public Level Find(
   string index
);
[C++]
public: Level* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : Level;
Parameters
index
The name of the Level to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

LevelCollection Class | LevelCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator Structure

Supports iterating over a LevelCollection and reading its individual levels.

For a list of all members of this type, see LevelCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.LevelCollection.Enumerator

[Visual Basic]
Public Structure LevelCollection.Enumerator
   Implements IEnumerator
[C#]
public struct LevelCollection.Enumerator : IEnumerator
[C++]
public __value struct LevelCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

LevelCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator Members

LevelCollection.Enumerator Structure

Public Properties

public property Current Gets the current level in the LevelCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next level in the LevelCollection.
public method Reset | Moves the enumerator to a position before the first level in the LevelCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

LevelCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator Properties

The properties of the LevelCollection.Enumerator structure are listed here. For a complete list of LevelCollection.Enumerator structure members, see LevelCollection.Enumerator Members.

Public Properties

public property Current Gets the current level in the LevelCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

LevelCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator.Current Property

Gets the current level in the LevelCollection.

[Visual Basic]
Public ReadOnly Property Current As Level
[C#]
public Level Current {get;}
[C++]
public: __property Level* get_Current();
[JScript]
public function get Current() : Level;
Property Value

The current level in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last level in the LevelCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection.Enumerator Structure | LevelCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

LevelCollection.Enumerator Structure | LevelCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator Methods

The methods of the LevelCollection.Enumerator structure are listed here. For a complete list of LevelCollection.Enumerator structure members, see LevelCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next level in the LevelCollection.
public method Reset | Moves the enumerator to a position before the first level in the LevelCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator.MoveNext Method

Moves to the next level in the LevelCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection.Enumerator Structure | LevelCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first level of the LevelCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelCollection.Enumerator Structure | LevelCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Class

Represents a member property available on members in the level.

For a complete list of LevelProperty class members, see LevelProperty Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.LevelProperty

[Visual Basic]
NotInheritable Public Class LevelProperty
[C#]
public sealed class LevelProperty
[C++]
public __gc __sealed class LevelProperty
[JScript]
public class LevelProperty
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

The LevelProperty represents the definition of a member property for members in a given level. The LevelProperty differs from the MemberProperty in that the LevelProperty contains metadata representing a member property, and the MemberProperty contains data represented by a member property.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Members

LevelProperty Class

Public Properties

public property Caption | Gets the caption of the LevelProperty.
public property Description | Gets the description of the LevelProperty.
public property Name | Gets the name of the LevelProperty.
public property ParentLevel | Gets a Level that contains the LevelProperty.
public property UniqueName | Gets the fully-qualified name of the LevelProperty.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two instances LevelProperty are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two instances LevelProperty are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Properties

The properties of the LevelProperty class are listed here. For a complete list of LevelProperty class members, see LevelProperty Members.

Public Properties

public property Caption | Gets the caption of the LevelProperty.
public property Description | Gets the description of the LevelProperty.
public property Name | Gets the name of the LevelProperty.
public property ParentLevel | Gets a Level that contains the LevelProperty.
public property UniqueName | Gets the fully-qualified name of the LevelProperty.

See Also

LevelProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.Caption Property

Gets the caption of the LevelProperty.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the LevelProperty.

Remarks

The Caption property should be used when displaying the name of the LevelProperty to the user, such as in user interfaces or reports.

The value of this property is identical to the value of the PROPERTY_CAPTION column of the PROPERTIES schema rowset for the specified level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.Description Property

Gets the description of the LevelProperty.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the LevelProperty.

Remarks

The Description property contains descriptive text that is assigned to the level property. This descriptive text is typically used for display purposes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.Name Property

Gets the name of the LevelProperty.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the LevelProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.ParentLevel Property

Gets a Level that contains the LevelProperty.

[Visual Basic]
Public ReadOnly Property ParentLevel As Level
[C#]
public Level ParentLevel {get;}
[C++]
public: __property Level* get_ParentLevel();
[JScript]
public function get ParentLevel() : Level;
Property Value

A Level that contains the LevelProperty.

Remarks

The ParentLevel property returns a level that contains the property the LevelProperty represents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.UniqueName Property

Gets the fully-qualified name of the LevelProperty.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the fully-qualified name of the LevelProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Methods

The methods of the LevelProperty class are listed here. For a complete list of LevelProperty class members, see LevelProperty Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.Equals Method

Determines whether two instances of LevelProperty are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the LevelProperty.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the LevelProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Operators

The operators of the LevelProperty class are listed here. For a complete list of LevelProperty class members, see LevelProperty Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two instances of LevelProperty are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two instances of LevelProperty are unequal.

See Also

LevelProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Equality Operator

Determines whether two LevelProperty objects are equal.

[Visual Basic]
returnValue = LevelProperty.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   LevelProperty o1,
   LevelProperty o2
);
[C++]
public: static bool op_Equality(
   LevelProperty* o1,
   LevelProperty* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A LevelProperty.
o2
A LevelProperty.
Parameters [C#, C++]
o1
A LevelProperty.
o2
A LevelProperty.
Return Value

true if o1 and o2 represent the same LevelProperty; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelProperty Inequality Operator

Determines whether two LevelProperty objects are unequal.

[Visual Basic]
returnValue = LevelProperty.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   LevelProperty o1,
   LevelProperty o2
);
[C++]
public: static bool op_Inequality(
   LevelProperty* o1,
   LevelProperty* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A LevelProperty.
o2
A LevelProperty.
Parameters [C#, C++]
o1
A LevelProperty.
o2
A LevelProperty.
Return Value

true if o1 and o2 do not represent the same LevelProperty; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelProperty Class | LevelProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection Class

Represents a read-only, on-demand collection of LevelProperty objects contained by a Level.

For a complete list of LevelPropertyCollection class members, see LevelPropertyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.LevelPropertyCollection

[Visual Basic]
NotInheritable Public Class LevelPropertyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class LevelPropertyCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class LevelPropertyCollection : public
   ICollection, IEnumerable
[JScript]
public class LevelPropertyCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a Level, iterates through the LevelPropertyCollection collection and displays information about each level property:

Public Overloads Sub ListLevelPropertyCollection(ByRef LevelToCheck As Level)

    ' Check the parameter before performing actions on it.
    If LevelToCheck Is Nothing Then
        Throw New System.ArgumentNullException("LevelToCheck")
    Else
        ' Iterate through the LevelProperties collection of the
        ' Level object.

        Try
            Dim propToCheck As LevelProperty

            Debug.WriteLine("Found " & LevelToCheck.LevelProperties.Count & _
                " level properties in level:")

            For Each propToCheck In LevelToCheck.LevelProperties
                Debug.WriteLine("Level Property:  " & propToCheck.Name)
                Debug.WriteLine("  Caption:        " & _
                    propToCheck.Caption)
                Debug.WriteLine("  Description:    " & _
                    propToCheck.Description)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub

[Visual Basic]
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection Members

LevelPropertyCollection Class

Public Properties

public property Count | Gets the number of LevelProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified LevelProperty from the collection. In C#, this property is the indexer for the LevelPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified LevelProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection Properties

The properties of the LevelPropertyCollection class are listed here. For a complete list of LevelPropertyCollection class members, see LevelPropertyCollection Members.

Public Properties

public property Count | Gets the number of LevelProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified LevelProperty from the collection. In C#, this property is the indexer for the LevelPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

LevelPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Count Property

Gets the number of LevelProperty objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of LevelProperty objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Item Property

Gets the specified LevelProperty from the collection.

[C#] In C#, this property is the indexer for the LevelPropertyCollection class.

Overload List

Gets the specified LevelProperty from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As LevelProperty
[C#] public LevelProperty this[System.Int32] {get;}
[C++] public: __property LevelProperty* get_Item(System.Int32);
[JScript] LevelPropertyCollection.Item (System.Int32)

Gets the specified LevelProperty from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As LevelProperty
[C#] public LevelProperty this[System.String] {get;}
[C++] public: __property LevelProperty* get_Item(System.String);
[JScript] LevelPropertyCollection.Item (System.String)
See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Item Property (System.Int32)

Gets the specified LevelProperty from the collection by its index.

[C#] In C#, this property is the indexer for the LevelPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As LevelProperty
[C#]
public LevelProperty this[
   int index
] {get;}
[C++]
public: __property LevelProperty* get_Item(
   int index
);
[JScript]
returnValue = LevelPropertyCollectionObject.Item(index);
-or-
returnValue = LevelPropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the LevelProperty to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the LevelProperty to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | LevelPropertyCollection.Item Overload List


LevelPropertyCollection.Item Property (System.String)

Gets the specified LevelProperty from the collection by its name.

[C#] In C#, this property is the indexer for the LevelPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As LevelProperty
[C#]
public LevelProperty this[
   string index
] {get;}
[C++]
public: __property LevelProperty* get_Item(
   String* index
);
[JScript]
returnValue = LevelPropertyCollectionObject.Item(index);
-or-
returnValue = LevelPropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the LevelProperty to find.
Parameters [Visual Basic, C#, C++]
index
The name of the LevelProperty to find.
Exceptions

Exception type | Condition
AdomdErrorResponseException | The provider returned an error in response.
AdomdUnknownResponseException | The provider sent an unrecognizable response.
AdomdConnectionException | The connection was broken.
InvalidOperationException | The Level was not found in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | LevelPropertyCollection.Item Overload List


LevelPropertyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection Methods

The methods of the LevelPropertyCollection class are listed here. For a complete list of LevelPropertyCollection class members, see LevelPropertyCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified LevelProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As LevelProperty, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   LevelProperty[] array,
   int index
);
[C++]
public: void CopyTo(
   LevelProperty* array[],
   int index
);
[JScript]
public function CopyTo(
   array : LevelProperty[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Find Method

Gets the specified LevelProperty from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As LevelProperty
[C#]
public LevelProperty Find(
   string index
);
[C++]
public: LevelProperty* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : LevelProperty;
Parameters
index
The name of the LevelProperty to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

LevelPropertyCollection Class | LevelPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator Structure

Supports iterating over a LevelPropertyCollection and reading its individual level properties.

For a list of all members of this type, see LevelPropertyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.LevelPropertyCollection.Enumerator

[Visual Basic]
Public Structure LevelPropertyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct LevelPropertyCollection.Enumerator : IEnumerator
[C++]
public __value struct LevelPropertyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

LevelPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator Members

LevelPropertyCollection.Enumerator Structure

Public Properties

public property Current Gets the current level property inthe LevelPropertyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next level property inthe LevelPropertyCollection.
public method Reset | Moves the enumerator to a position before the first level property inthe LevelPropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

LevelPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator Properties

The properties of the LevelPropertyCollection.Enumerator structure are listed here. For a complete list of LevelPropertyCollection.Enumerator structure members, see LevelPropertyCollection.Enumerator Members.

Public Properties

public property Current Gets the current level property inthe LevelPropertyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

LevelPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator.Current Property

Gets the current level property inthe LevelPropertyCollection.

[Visual Basic]
Public ReadOnly Property Current As LevelProperty
[C#]
public LevelProperty Current {get;}
[C++]
public: __property LevelProperty* get_Current();
[JScript]
public function get Current() : LevelProperty;
Property Value

The current level property inthe collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last level property inthe LevelPropertyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection.Enumerator Structure | LevelPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

LevelPropertyCollection.Enumerator Structure | LevelPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator Methods

The methods of the LevelPropertyCollection.Enumerator structure are listed here. For a complete list of LevelPropertyCollection.Enumerator structure members, see LevelPropertyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next level property inthe LevelPropertyCollection.
public method Reset | Moves the enumerator to a position before the first level property inthe LevelPropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

LevelPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator.MoveNext Method

Moves to the next level property inthe LevelPropertyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection.Enumerator Structure | LevelPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelPropertyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first level property inthe LevelPropertyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

LevelPropertyCollection.Enumerator Structure | LevelPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


LevelTypeEnum Enumeration

Represents the level type of a Level.

[Visual Basic]
<Serializable>
Public Enum LevelTypeEnum
[C#]
[Serializable]
public enum LevelTypeEnum
[C++]
[Serializable]
__value public enum LevelTypeEnum
[JScript]
public
   Serializable
enum LevelTypeEnum
Remarks

The LevelType property of the Level exists primarily for transmitting formatting instructions to an application. For example, a Level with a LevelType property set to LevelTypeEnum.TimeDays might indicate to an application that the members of the level should be expressed in text format (that is, "Sunday", "Monday", "Tuesday", and so on). The value LevelTypeEnum.Regular can be used to signify a level that does not require any special formatting.

Members

Member name | Description
Account | Indicates that a level exists within an account dimension.
All | Indicates the top (All) level of a dimension (the one that precalculates all the members of all lower levels).
BomResource | Indicates that a level is part of a bill of materials dimension.
Calculated | Indicates that a level is calculated.
Channel | Indicates that a level exists within a distribution channel dimension.
Company | Indicates that a level contains information about a company.
CurrencyDestination | Indicates that a level contains information about the resulting currency after a foreign exchange conversion.
CurrencySource | Indicates that a level contains information about the starting currency before a foreign exchange conversion.
Customer | Indicates that a level contains information about an individual customer.
CustomerGroup | Indicates that a level contains information about a customer group.
CustomerHousehold | Indicates that a level contains information about an entire household.
GeoCity | Indicates that a level refers to a city name.
GeoContinent | Indicates that a level refers to a continent name.
GeoCountry | Indicates that a level refers to a country or region name.
GeoCounty | Indicates that a level refers to a county name.
GeoPoint | Indicates that a level refers to a location type that does not fit into the other geographic categories.
GeoPostalCode | Indicates that a level refers to a postal code.
GeoRegion | Indicates that a level refers to a custom-defined region.
GeoStateOrProvince | Indicates that a level refers to a state or province name.
OrgUnit | Indicates that a level refers to the name of a unit within a larger organization.
Person | Indicates that a level refers to an individual within a larger organization.
Product | Indicates that a level refers to an individual product.
ProductGroup | Indicates that a level refers to a product group.
Promotion | Indicates that a level refers to a promotion.
Quantitative | Indicates that a level refers to a quantitative member within a quantitative dimension.
Regular | Indicates that the level is not related to time.
Representative | Indicates that a level refers to a sales representative.
Reserved1 | Reserved for future use.
Scenario | Indicates that a level refers to a scenario.
Time | Indicates that the level is related to time.
TimeDays | Indicates that a level refers to days. It must be used in a dimension whose type is Time.
TimeHalfYears | Indicates that a level refers to half-years. It must be used in a dimension whose type is Time.
TimeHours | Indicates that a level refers to hours. It must be used in a dimension whose type is Time.
TimeMinutes | Indicates that a level refers to minutes. It must be used in a dimension whose type is Time.
TimeMonths | Indicates that a level refers to months. It must be used in a dimension whose type is Time.
TimeQuarters | Indicates that a level refers to (calendar) quarters. It must be used in a dimension whose type is Time.
TimeSeconds | Indicates that a level refers to seconds. It must be used in a dimension whose type is Time.
TimeUndefined | Indicates that a level refers to an indeterminate or nonstandard measurement of time. It must be used in a dimension whose type is Time.
TimeWeeks | Indicates that a level refers to weeks. It must be used in a dimension whose type is Time.
TimeYears | Indicates that a level refers to years. It must be used in a dimension whose type is Time.
Utility | Indicates that a level exists in a utility dimension.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Microsoft.AnalysisServices.AdomdClient Namespace


Measure Class

Represents a measure within a cube.

For a complete list of Measure class members, see Measure Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Measure

[Visual Basic]
NotInheritable Public Class Measure
[C#]
public sealed class Measure
[C++]
public __gc __sealed class Measure
[JScript]
public class Measure
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A measure represents the data within a fact table that is being organized and aggregated by the cube.

In ADOMD.NET, the Measure represents the metadata for a measure within a cube. A measure is not explicitly identified in a cellset, because a measure is treated as a member for querying purposes and is represented by a Member within the Members collection of a CellSet.

For more information about the CellSet, see CellSet Class.

Example
[Visual Basic]

The following subroutine, given a CubeDef, iterates through the Measures collection and displays information for each Measure:

Public Sub ListMeasures(ByRef CubeToCheck As CubeDef)

    ' Check the parameter before performing actions on it.
    If CubeToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CubeToCheck")
    Else
        ' Iterate through the Measures collection of the
        ' CubeDef object.

        Try
            Dim measureToCheck As Measure

            Debug.WriteLine("Found " & CubeToCheck.Measures.Count & _
                " measure(s) in cube:")

            For Each measureToCheck In CubeToCheck.Measures
                Debug.WriteLine("Measure:  " & measureToCheck.Name)
                Debug.WriteLine("  Caption:        " & _
                    measureToCheck.Caption)
                Debug.WriteLine("  Description:    " & _
                    measureToCheck.Description)

            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure Members

Measure Class

Public Properties

public property Caption | Gets the caption of the Measure.
public property Description | Gets the description of the Measure.
public property DisplayFolder | This member is reserved for future use.
public property Expression | Gets the MDX expression used to aggregate the Measure.
public property Name | Gets the name of the Measure.
public property NumericPrecision | Gets the numeric precision value for the Measure.
public property NumericScale | Gets the numeric scale for the Measure.
public property ParentCube | Gets a CubeDef that contains the Measure.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Measure.
public property UniqueName | Gets the unique name of the Measure.
public property Units | Gets a description of the unit of measure for the Measure.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Measure are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Measure are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Measure Class | Microsoft.AnalysisServices.AdomdClient Namespace


Measure Properties

The properties of the Measure class are listed here. For a complete list of Measure class members, see Measure Members.

Public Properties

public property Caption | Gets the caption of the Measure.
public property Description | Gets the description of the Measure.
public property DisplayFolder | This member is reserved for future use.
public property Expression | Gets the MDX expression used to aggregate the Measure.
public property Name | Gets the name of the Measure.
public property NumericPrecision | Gets the numeric precision value for the Measure.
public property NumericScale | Gets the numeric scale for the Measure.
public property ParentCube | Gets a CubeDef that contains the Measure.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Measure.
public property UniqueName | Gets the unique name of the Measure.
public property Units | Gets a description of the unit of measure for the Measure.

See Also

Measure Class | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Caption Property

Gets the caption of the Measure.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the Measure.

Remarks

The Caption property should be used when displaying the name of the Measure to the user, such as in user interfaces or in reports.

The value of this property is identical to the value of the MEASURE_CAPTION column of the MEASURES schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Description Property

Gets the description of the Measure.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the Measure.

Remarks

The Description property contains descriptive text that is assigned to the measure. This descriptive text is typically used for display purposes.

The value of this property is identical to the value of the DESCRIPTION column of the MEASURES schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.DisplayFolder Property

This member is reserved for future use.

[Visual Basic]
Public ReadOnly Property DisplayFolder As String
[C#]
public string DisplayFolder {get;}
[C++]
public: __property String* get_DisplayFolder();
[JScript]
public function get DisplayFolder() : String;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Expression Property

Gets the MDX expression that is used to aggregate the Measure.

[Visual Basic]
Public ReadOnly Property Expression As String
[C#]
public string Expression {get;}
[C++]
public: __property String* get_Expression();
[JScript]
public function get Expression() : String;
Property Value

A String containing the MDX expression that is used to aggregate values for a Measure.

Remarks

Calculated measures use MDX expressions to supply their values, instead of binding to columns in a data source. The Expression property contains the MDX expression used to supply the values for a Measure only if the the Measure is a calculated measure. Otherwise, this property contains an empty string ("").

The value of this property is identical to the value of the EXPRESSION column of the MEASURES schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Name Property

Gets the name of the Measure.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the member name of the Measure.

Remarks

Because measures are essentially a specialized form of member, measures are subject to the same issues regarding member names and member keys as members.

In Analysis Services, member names can be derived from a column in the dimension table other than the column that supplies member keys for a given level. Although member keys must be unique within the scope of a level, member names can be changed in a changing dimension and are not necessarily unique within a dimension or hierarchy. You can reference a member either by its member name or its unique name. Using the unique name ensures precise member identification in these cases.

The Name property returns the member name of the Measure. To get the unique name of a Measure, use the UniqueName property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.NumericPrecision Property

Gets the numeric precision value for the Measure.

[Visual Basic]
Public ReadOnly Property NumericPrecision As Integer
[C#]
public IntegerNumericPrecision {get;}
[C++]
public: __property int get_NumericPrecision();
[JScript]
public function get NumericPrecision() : int;
Property Value
[Visual Basic, C#, C++]

An Integer that contains a value representing the numeric precision of the Measure.

[JScript]

An int that contains a value representing the numeric precision of the Measure.

Remarks

The NumericPrecision property describes the numeric precision, or the maximum number of digits, of the OLE DB data type for the measure. If the measure does not have a numeric data type, this property returns a value of 0. Otherwise, the value of this property represents the maximum numeric precision for the specified data type as supported by the underlying data source.

For more information about numeric precision in OLE DB, see Chapter 13, "Data Types in OLE DB" in the OLE DB documentation.

The value of this property is identical to the value of the NUMERIC_PRECISION column of the MEASURES schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.NumericScale Property

Gets the numeric scale for the Measure.

[Visual Basic]
Public ReadOnly Property NumericScale As Short
[C#]
public short NumericScale {get;}
[C++]
public: __property short get_NumericScale();
[JScript]
public function get NumericScale() : Int16;
Property Value
[Visual Basic, C#, C++]

A Short that contains a value representing the numeric scale of the Measure.

[JScript]

An Int16 that contains a value representing the numeric scale of the Measure.

Remarks

The NumericScale property describes the numeric scale, or the maximum number of digits to the right of the decimal point, of the OLE DB data type for the measure. If the measure does not have a numeric data type, this property returns a value of 0. Otherwise, the value of this property represents the numeric scale for the specified data type as supported by the underlying data source.

For more information about numeric scale in OLE DB, see Chapter 13, "Data Types in OLE DB" in the OLE DB documentation.

The value of this property is identical to the value of the NUMERIC_SCALE column of the MEASURES schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.ParentCube Property

Gets a CubeDef that contains the Measure.

[Visual Basic]
Public ReadOnly Property ParentCube As CubeDef
[C#]
public CubeDef ParentCube {get;}
[C++]
public: __property CubeDef* get_ParentCube();
[JScript]
public function get ParentCube() : CubeDef;
Property Value

A CubeDef that contains the Measure.

Remarks

The ParentCube property returns a cube that contains the measure represented by the Measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Properties Property

Gets an AdomdPropertyCollection that contains the properties associated with the Measure.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

An AdomdPropertyCollection that contains the properties associated with the measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.UniqueName Property

Gets the unique name of the Measure.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the unique name of the Measure.

Remarks

The UniqueName property returns the fully qualified unique name of the Measure. To get the member name of the Measure, use the Name property.

Warning Because this value is provider specific and may change in the future, it should be used in whole, and not be parsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Units Property

Gets a description of the unit of measure for the Measure.

[Visual Basic]
Public ReadOnly Property Units As String
[C#]
public string Units {get;}
[C++]
public: __property String* get_Units();
[JScript]
public function get Units() : String;
Property Value

A String that contains a description of the unit of measure for the Measure.

Remarks

The Units property contains a string representation of the unit of measure for the Measure, such as "pounds" or "boxes shipped," and is typically used for display and reporting purposes. If no such string representation is provided for the measure, this property contains an empty string ("").

The value of this property is identical to the value of the MEASURE_UNITS column of the MEASURES schema rowset for the specified measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure Methods

The methods of the Measure class are listed here. For a complete list of Measure class members, see Measure Members.

Public Methods

public method Equals (inherited from System.Object) | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Measure Class | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.Equals Method

Determines whether two instances of Measure are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Cell.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure.ToString Method

Returns a String that represents the current instance of the Measure.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the Measure.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure Operators

The operators of the Measure class are listed here. For a complete list of Measure class members, see Measure Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two instances of Measure are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two instances of Measure are unequal.

See Also

Measure Class | Microsoft.AnalysisServices.AdomdClient Namespace


Measure Equality Operator

Determines whether two instances of Measure are equal.

[Visual Basic]
returnValue = Measure.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Measure o1,
   Measure o2
);
[C++]
public: static bool op_Equality(
   Measure* o1,
   Measure* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Measure.
o2
A Measure.
Parameters [Visual Basic, C#, C++]
o1
A Measure.
o2
A Measure.
Return Value

true if o1 and o2 represent the same Measure instance; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


Measure Inequality Operator

Determines whether two instances of Measure are unequal.

[Visual Basic]
returnValue = Measure.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Measure o1,
   Measure o2
);
[C++]
public: static bool op_Inequality(
   Measure* o1,
   Measure* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Measure.
o2
A Measure.
Parameters [Visual Basic, C#, C++]
o1
A Measure.
o2
A Measure.
Return Value

true if o1 and o2 do not represent the same Measure; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Measure Class | Measure Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection Class

Gets a read-only, on-demand collection of Measure objects contained by a CubeDef.

For a complete list of MeasureCollection class members, see MeasureCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.MeasureCollection

[Visual Basic]
NotInheritable Public Class MeasureCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class MeasureCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class MeasureCollection : public ICollection,
   IEnumerable
[JScript]
public class MeasureCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a CubeDef, iterates through the Measures collection and displays information about each measure.

Public Sub ListMeasureCollection(ByRef CubeToCheck As CubeDef)

    ' Check the parameter before performing actions on it.
    If CubeToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CubeToCheck")
    Else
        ' Iterate through the Measures collection of the
        ' CubeDef object.

        Try
            Dim measureToCheck As Measure

            Debug.WriteLine("Found " & CubeToCheck.Measures.Count & _
                " measure(s) in cube:")

            For Each measureToCheck In CubeToCheck.Measures
                Debug.WriteLine("Measure:  " & measureToCheck.Name)
                Debug.WriteLine("  Caption:        " & _
                    measureToCheck.Caption)
                Debug.WriteLine("  Description:    " & _
                    measureToCheck.Description)

            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection Members

MeasureCollection Class.

Public Properties

public property Count | Gets the number of Measure objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Measure from the collection. In C#, this property is the indexer for the MeasureCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Measure from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns the String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MeasureCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection Properties

The properties of the MeasureCollection class are listed here. For a complete list of MeasureCollection class members, see MeasureCollection Members.

Public Properties

public property Count | Gets the number of Measure objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Measure from the collection. In C#, this property is the indexer for the MeasureCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

MeasureCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Count Property

Gets the number of Measure objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

Gets the number of Measure objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Item Property

Gets the specified Measure from the collection.

[C#] In C#, this property is the indexer for the MeasureCollection class.

Overload List

Gets the specified Measure from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As Measure
[C#] public Measure this[System.Int32] {get;}
[C++] public: __property Measure* get_Item(System.Int32);
[JScript] MeasureCollection.Item (System.Int32)

Gets the specified Measure from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As Measure
[C#] public Measure this[System.String] {get;}
[C++] public: __property Measure* get_Item(System.String);
[JScript] MeasureCollection.Item (System.String)
See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Item Property (System.Int32)

Gets the specified Measure from the collection by its index.

[C#] In C#, this property is the indexer for the MeasureCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Measure
[C#]
public Measure this[
   int index
] {get;}
[C++]
public: __property Measure* get_Item(
   int index
);
[JScript]
returnValue = MeasureCollectionObject.Item(index);
-or-
returnValue = MeasureCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Measure to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Measure to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | MeasureCollection.Item Overload List


MeasureCollection.Item Property (System.String)

Gets the specified Measure from the collection by its name.

[C#] In C#, this property is the indexer for the MeasureCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Measure
[C#]
public Measure this[
   string index
] {get;}
[C++]
public: __property Measure* get_Item(
   String* index
);
[JScript]
returnValue = MeasureCollectionObject.Item(index);
-or-
returnValue = MeasureCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the Measure to find.
Parameters [Visual Basic, C#, C++]
index
The name of the Measure to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | MeasureCollection.Item Overload List


MeasureCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection Methods

The methods of the MeasureCollection class are listed here. For a complete list of MeasureCollection class members, see MeasureCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Measure from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MeasureCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Measure, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Measure[] array,
   int index
);
[C++]
public: void CopyTo(
   Measure* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Measure[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Find Method

Returns the specified Measure from the collection.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As Measure
[C#]
public Measure Find(
   string index
);
[C++]
public: Measure* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : Measure;
Parameters
index
The name of the Measure to find.
Remarks

The Find method returns null if the object is not found, while the Item property throws an exception if the object is not found.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

MeasureCollection Class | MeasureCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator Structure

Supports iterating over a MeasureCollection and reading its individual measures.

For a list of all members of this type, see MeasureCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.MeasureCollection.Enumerator

[Visual Basic]
Public Structure MeasureCollection.Enumerator
   Implements IEnumerator
[C#]
public struct MeasureCollection.Enumerator : IEnumerator
[C++]
public __value struct MeasureCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MeasureCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator Members

MeasureCollection.Enumerator Structure

Public Properties

public property Current Gets the current measure in the MeasureCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next measure in the MeasureCollection.
public method Reset | Moves the enumerator to a position before the first measure in the MeasureCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

MeasureCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator Properties

The properties of the MeasureCollection.Enumerator structure are listed here. For a complete list of MeasureCollection.Enumerator structure members, see MeasureCollection.Enumerator Members.

Public Properties

public property Current Gets the current measure in the MeasureCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

MeasureCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator.Current Property

Gets the current measure in the MeasureCollection object.

[Visual Basic]
Public ReadOnly Property Current As Measure
[C#]
public Measure Current {get;}
[C++]
public: __property Measure* get_Current();
[JScript]
public function get Current() : Measure;
Property Value

The current measure in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last measure in the MeasureCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection.Enumerator Structure | MeasureCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

MeasureCollection.Enumerator Structure | MeasureCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator Methods

The methods of the MeasureCollection.Enumerator structure are listed here. For a complete list of MeasureCollection.Enumerator structure members, see MeasureCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Gets the Type of the current instance.
public method MoveNext | Moves to the next measure in the MeasureCollection.
public method Reset | Moves the enumerator to a position before the first measure in the MeasureCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MeasureCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator.MoveNext Method

Moves to the next measure in the MeasureCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection.Enumerator Structure | MeasureCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MeasureCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first measure in the MeasureCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MeasureCollection.Enumerator Structure | MeasureCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member Class

Represents a single member within a hierarchy, tuple, level, or member.

For a complete list of Member class members, see Member Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Member

[Visual Basic]
NotInheritable Public Class Member
[C#]
public sealed class Member
[C++]
public __gc __sealed class Member
[JScript]
public class Member
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A member is an item in a hierarchy that represents one or more records in the underlying relational database. A member is the lowest level of reference used when accessing cell data in a cube.

Members are used to construct tuples, which in turn are used to construct sets. Members are organized hierarchically; a member can have other members associated with it. For example, in a time dimension that contains three levels named Year, Month, and Day, the members of the Day level are leaf members because they have no child members. The members in the Year and Month levels are nonleaf members, because each member in the Month level has at least 28 child members from the Day level and each member in the Year level has 12 child members from the Month level.

The Member encapsulates the information necessary to describe a member, including a collection of Member objects that contain child members, if applicable.

The information available to a Member depends on the parent of the Members collection from which the Member was retrieved. While the Members collection externally represents a collection of Member objects for a specified Hierarchy, Tuple, Level, or Member, the collection is internally loaded and managed in one of two ways, depending on the parent of the Hierarchy, Tuple, Level, or Member:

  • If the parent object was referenced through a CubeDef in order to retrieve metadata from the server, the collection represents the members that are defined for the parent object.
  • If the parent object was referenced through a CellSet in order to retrieve metadata from a query, the collection represents the members that are retrieved for the set (or axis) that contains the parent object.
Example
[Visual Basic]

The following subroutine, given a Hierarchy, iterates through the Members collection and displays information for each Member:

Public Overloads Sub ListMembers(ByRef HierarchyToCheck As Hierarchy)

    ' Check the parameter before performing actions on it.
    If HierarchyToCheck Is Nothing Then
        Throw New System.ArgumentNullException("HierarchyToCheck")
    Else
        ' Iterate through the Members collection of the
        ' Hierarchy object.

        Try
            Dim memberToCheck As Member

            Debug.WriteLine("Found " & HierarchyToCheck.Members.Count & _
                " member(s) in hierarchy:")

            For Each memberToCheck In HierarchyToCheck.Members
                Debug.WriteLine("Member:  " & memberToCheck.Name)
                Debug.WriteLine("  Caption:          " & _
                    memberToCheck.Caption)
                Debug.WriteLine("  UniqueName:       " & _
                    memberToCheck.UniqueName)

                Debug.WriteLine("  No. of children:  " & _
                    memberToCheck.Children.Count)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member Members

Member Class

Public Properties

public property Caption | Gets the caption of the Member.
public property ChildCount | Gets the estimated count of child members contained in the Member.
public property Description | Gets the descriptive text of the Member.
public property DrilledDown | Returns whether no children immediately follow the member on the axis.
public property LevelDepth | Gets the ordinal position of the level that contains the Member.
public property LevelName | Gets the name of the level that contains the Member.
public property MemberProperties | Gets a MemberPropertyCollection that contains a collection of member properties for the Member.
public property Name | Gets the name of the Member.
public property Parent | Gets a reference to the parent Member, if applicable, that contains the Member.
public property ParentLevel | Gets a Level that contains the Member.
public property ParentSameAsPrevious | Returns whether the parent of this position member is the same as the parent of the immediately preceding member.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Member.
public property Type | Gets the member type of the Member.
public property UniqueName | Overridden. Gets the unique name of the Member.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public property FetchAllProperties | Retrieves all member properties from the server.
public property GetChildren | Overloaded. Returns a MemberCollection that contains a collection of child members for the Member.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType | Overridden. Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Member are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Member are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Member Class | Microsoft.AnalysisServices.AdomdClient Namespace


Member Properties

The properties of the Member class are listed here. For a complete list of Member class members, see Member Members.

Public Properties

public property Caption | Gets the caption of the Member.
public property ChildCount | Gets the estimated count of child members contained in the Member.
public property Description | Gets the descriptive text of the Member.
public property DrilledDown | Returns whether no children immediately follow the member on the axis.
public property LevelDepth | Gets the ordinal position of the level that contains the Member.
public property LevelName | Gets the name of the level that contains the Member.
public property MemberProperties | Gets a MemberPropertyCollection that contains a collection of member properties for the Member.
public property Name | Gets the name of the Member.
public property Parent | Gets a reference to the Member, if applicable, that contains the Member.
public property ParentLevel | Gets a Level that contains the Member.
public property ParentSameAsPrevious | Returns whether the parent of this position member is the same as the parent of the immediately preceding member.
public property Properties | Gets a PropertyCollection that contains the properties associated with the Member.
public property Type | Gets the member type of the Member.
public property UniqueName | Overridden. Gets the unique name of the Member.

See Also

Member Class | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Caption Property

Gets the caption of the Member.

[Visual Basic]
Public ReadOnly Property Caption As String
[C#]
public string Caption {get;}
[C++]
public: __property String* get_Caption();
[JScript]
public function get Caption() : String;
Property Value

A String that contains the caption of the Member.

Remarks

The Caption property should be used when displaying the name of the Member to the user, such as in the user interface or reports.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.ChildCount Property

Gets the estimated count of child members contained in the Member.

[Visual Basic]
Public ReadOnly Property ChildCount As Long
[C#]
public long ChildCount {get;}
[C++]
public: __property __int64 get_ChildCount();
[JScript]
public function get ChildCount() : long;
Property Value

A Long that contains the estimated number of child members contained by the Member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Description Property

Gets the descriptive text of the Member.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description of the Member.

Remarks

The Description property contains descriptive text that is assigned to the member. This descriptive text is typically used for display purposes.

Note Unless explicitly requested in the query, this property is always Empty until FetchAllProperties is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.DrilledDown Property

Indicates whether no children immediately follow the member on the axis.

[Visual Basic]
Public ReadOnly Property DrilledDown As Boolean
[C#]
public bool DrilledDown {get;}
[C++]
public: __property bool get_DrilledDown();
[JScript]
public function get DrilledDown() : Boolean;
Return Value

true if there are no child members of the current member on the axis; false if there are one or more child members of the current member on the axis.

Remarks

Use the DrilledDown property to determine whether there is at least one child of this member on the axis immediately following this member. This information is useful when displaying the member.

Note Accessing this property returns a NotSupportedExeption exception if the Member is populated by GetChildren, GetMembers, or GetSchemaObject.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.LevelDepth Property

Gets the ordinal position of the level that contains the Member.

[Visual Basic]
Public ReadOnly Property LevelDepth As Long
[C#]
public int LevelDepth {get;}
[C++]
public: __property __int64 get_LevelDepth();
[JScript]
public function get LevelDepth() : long;
Property Value

An int that contains the ordinal position within the parent hierarchy of the level that contains the Member.

Remarks

This property is functionally equivalent to Member.ParentLevel.LevelNumber, but it provides better performance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.LevelName Property

Gets the name of the level that contains the Member.

[Visual Basic]
Public ReadOnly Property LevelName As String
[C#]
public string LevelName {get;}
[C++]
public: __property String* get_LevelName();
[JScript]
public function get LevelName() : String;
Property Value

A String that contains the name of the level that contains the Member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.MemberProperties Property

Gets a MemberPropertyCollection that contains a collection of member properties for the Member.

[Visual Basic]
Public ReadOnly Property MemberProperties As MemberPropertyCollection
[C#]
public MemberPropertyCollection MemberProperties {get;}
[C++]
public: __property MemberPropertyCollection* get_MemberProperties();
[JScript]
public function get MemberProperties() : MemberPropertyCollection;
Property Value

A MemberPropertyCollection that contains a collection of member properties that is associated with the Member.

Remarks

Members have several intrinsic properties, such as Caption and UniqueName, that are implemented by the Member class. In addition, each member can be associated with one or more user-defined properties. These additional properties, which are called member properties, provide users with additional information about the member.

The MemberProperties property returns a collection of MemberProperty objects that represent the member properties that are associated with the Member. The actual contents of the collection depend on the source of the Member:

  • If the Member was referenced through a CubeDef in order to retrieve metadata from the server, the collection represents the member properties that are defined for the level of the member represented by the Member.
  • If the Member was referenced through a CellSet in order to retrieve metadata from a query, the collection represents the member properties that are retrieved for the set (or axis) that contains the member represented by the Member.

    Note This property is always Empty if the Member is populated through GetSchemaObject.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Name Property

Gets the name of the Member.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the member name of the Member.

Remarks

In Microsoft SQL Server 2000 Analysis Services, member names can be derived from a column in the dimension table other than the column that supplies member keys for a given level. Although member keys must be unique within a level, member names can be changed in a changing dimension, and they are not necessarily unique within a dimension or hierarchy. You can reference a member by either its member name or its member key. Using the member key ensures precise member identification in these cases. The ampersand (&) character is used in Multidimensional Expressions (MDX) to differentiate a member key from a member name, as shown in the following example:

[Time].[Time].[2nd half].&[Q4]

In this case, the member key of the fourth quarter member, Q4, is used.

The Name property returns the member name of the Member. To get the member key of a Member, use the UniqueName property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Parent Property

Gets a reference to the parent Member, if applicable, that contains the Member.

[Visual Basic]
Public ReadOnly Property Parent As Member
[C#]
public Member Parent {get;}
[C++]
public: __property Member* get_Parent();
[JScript]
public function get Parent() : Member;
Property Value

A Member that contains the parent member of the Member.

Remarks

This property may throw a NotSupportedException exception for CellSet members if the provider did not provide cube information.

Note Accessing this property may require a round-trip to the server.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.ParentLevel Property

This property gets a Level that contains the Member.

[Visual Basic]
Public ReadOnly Property ParentLevel As Level
[C#]
public Level ParentLevel {get;}
[C++]
public: __property Level* get_ParentLevel();
[JScript]
public function get ParentLevel() : Level;
Property Value

A Level that contains the Member.

Remarks

Each member is associated with a level within a hierarchy. Levels specify the contents and structure of the hierarchy. That is, the level definitions determine the members that are included and their positions relative to one another within the hierarchy.

The ParentLevel property returns a Level with which the Member is associated for a given hierarchy.

Note Accessing this property may require a round-trip to the server if the Member is populated by CellSet, GetChildren, or GetMembers.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.ParentSameAsPrevious Property

Returns whether the parent of this position member is the same as the parent of the immediately preceding member.

[Visual Basic]
Public ReadOnly Property ParentSameAsPrevious As Boolean
[C#]
public bool ParentSameAsPrevious {get;}
[C++]
public: __property bool get_ParentSameAsPrevious();
[JScript]
public function get ParentSameAsPrevious() : Boolean;
Return Value

true if the parent of this position member is the same as the parent of the immediately preceding member; false otherwise.

Remarks

Accessing this property returns a NotSupportedExeption exception if the Member is populated by GetChildren, GetMembers, or GetSchemaObject.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Properties Property

Gets a PropertyCollection that contains the properties associated with the Member.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

A PropertyCollection that contains the properties associated with the member.

Remarks

If the Member is populated by CellSet, GetChildren, or GetMembers, this property is always Empty until FetchAllProperties is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Type Property

Gets the member type of the Member.

[Visual Basic]
Public ReadOnly Property Type As MemberTypeEnum
[C#]
public MemberTypeEnum Type {get;}
[C++]
public: __property MemberTypeEnum get_Type();
[JScript]
public function get Type() : MemberTypeEnum;
Property Value

A MemberTypeEnum enumeration value that represents the member type of the Member.

Remarks

Unless this property has been explicitly requested in the query, accessing this property raises an InvalidOperationException exception if the Member is populated by a CellSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.UniqueName Property

Gets the unique name of the Member.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the member key of the Member.

Remarks

The UniqueName property returns the fully-qualified unique name of the Member. To get the member name of the Member, use the Name property.

Warning Because this value is provider specific and may change in the future, it should be used in whole, and not be parsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member Methods

The methods of the Member class are listed here. For a complete list of Member class members, see Member Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public property FetchAllProperties | Retrieves all member properties from the server.
public property GetChildren | Overloaded. Returns a MemberCollection that contains a collection of child members for the Member.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Member Class | Microsoft.AnalysisServices.AdomdClient Namespace


Member.Equals Method

Determines whether two instances of Member are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters [Visual Basic, C#, C++]
obj
An object of the same type as the Member.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.FetchAllProperties Method

Retrieves all member properties from the server.

[Visual Basic]
Public Function FetchAllProperties()
[C#]
public void FetchAllProperties();
[C++]
public: void FetchAllProperties();
[JScript]
public function FetchAllProperties();
Remarks

Which properties are available on a Member depends on how the Member was created. The following table lists the properties that require population by FetchAllProperties:

Property | Cellset | GetChildren or GetMembers | GetSchemaObject
Description | Empty String until FetchAllProperties called* | Empty String until FetchAllProperties called* | Available
Properties | Empty until FetchAllProperties called | Empty until FetchAllProperties called | Available
Type | Error until FetchAllProperties called* | Available | Available

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.GetChildren Method

Returns an instance of the MemberCollection class that contains a collection of child members for the Member.

Overload List

Returns a MemberCollection that contains a collection of child members for the Member.

[Visual Basic] Overloads Public Function GetChildren() As MemberCollection
[C#] public MemberCollection GetChildren();
[C++] public: MemberCollection* GetChildren();
[JScript] public function GetChildren() : MemberCollection;

Returns a MemberCollection that contains a collection of child members for the Member. The returned object contains up to count members, and begins at the position indicated by the start parameter.

[Visual Basic] Overloads Public Function GetChildren(ByVal start As Long, ByVal count As Long) As MemberCollection
[C#] public MemberCollection GetChildren(long start, long count);
[C++] public: MemberCollection* GetChildren(__int64 start, __int64 count);
[JScript] public function GetChildren(start : long, count : long) : MemberCollection;

Returns a MemberCollection that contains a collection of child members for the Member. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameters.

[Visual Basic] Overloads Public Function GetChildren(ByVal start As Long, ByVal count As Long, ByVal ParamArray filters() as MemberFilter) As MemberCollection
[C#] public MemberCollection GetChildren(long start, long count, params MemberFilter[] filters);
[C++] public: MemberCollection* GetChildren(__int64 start, __int64 count, MemberFilter*[] filters);
[JScript] public function GetChildren(start : long, count : long, filters : MemberFilter[]) : MemberCollection;

Returns a MemberCollection that contains a collection of child members for the Member. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameters. Each member caches the properties indicated by the Array passed into the properties parameter.

Note For performance reasons, this overload should only be used if non-default member properties are needed. Default member properties include Name, UniqueName, Caption, ChildCount, MemberType, MemberName, and MemberNumber.

[Visual Basic] Overloads Public Function GetChildren(ByVal start As Long, ByVal count As Long, ByVal properties() as String, ByVal ParamArray filters() As MemberFilter) As MemberCollection
[C#] public MemberCollection GetChildren(long start, long count, string[] properties, params MemberFilter[] filters);
[C++] public: MemberCollection* GetChildren(__int64 start, __int64 count, String* properties[], MemberFilter*[] filters);
[JScript] public function GetChildren(start : long, count : long, properties : String[], filters : MemberFilter[]) : MemberCollection;
See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.GetChildren Method ()

Returns a MemberCollection that contains a collection of child members for the Member.

[Visual Basic]
Overloads Public Function GetChildren() As MemberCollection
[C#]
public MemberCollection GetChildren();
[C++]
public: MemberCollection* GetChildren();
[JScript]
public function GetChildren() : MemberCollection;
Return Value

A MemberCollection that contains a collection of members for the Member.

Remarks

A nonleaf member is associated with one or more members from lower levels in the hierarchy. For example, in a time dimension that contains the levels Year, Month, and Day, the members of the Day level are leaf members. Each member in the Year level is associated with 12 child members from the Month level, and each member in the Month level is associated with at least 28 child members from the Day level.

The GetChildren method returns a collection of Member objects that represents the child members associated with the Member.

Note This property is not supported if the Member is referenced through a CellSet in order to retrieve metadata from a query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.GetChildren Method (System.Int64, System.Int64)

Returns a MemberCollection that contains a collection of child members for the Member. The returned object contains up to count members, and begins at the position indicated by the start parameter.

 [Visual Basic]
Public Overloads Function GetChildren(ByVal start As Long, ByVal count As Long) As MemberCollection
[C#]
public MemberCollection MemberCollection GetChildren(long start, long count);
[C++]
public: MemberCollection* GetChildren(__int64 start, __int64 count);
[JScript]
public function GetChildren(start : long, count : long) : MemberCollection;
Arguments [JScript]
start
The position to begin returning members. This argument is 0-based.
count
The number of members to return.
Parameters [Visual Basic, C#, C++]
start
The position to begin returning members. This parameter is 0-based.
count
The number of members to return.
Return Value

A MemberCollection that contains a collection of members for the Member.

Remarks

A nonleaf member is associated with one or more members from lower levels in the hierarchy. For example, in a time dimension that contains the levels Year, Month, and Day, the members of the Day level are leaf members. Each member in the Year level is associated with 12 child members from the Month level, and each member in the Month level is associated with at least 28 child members from the Day level.

The GetChildren method returns a collection of Member objects that represents the child members associated with the Member.

Note This property is not supported if the Member is referenced through a CellSet in order to retrieve metadata from a query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.GetChildren Method (System.Int64, System.Int64, MemberFilter[])

Returns a MemberCollection that contains a collection of child members for the Member. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameters.

 [Visual Basic]
Public Overloads Function GetChildren(ByVal start As Long, ByVal count As Long, ByVal ParamArray filters() as MemberFilter) As MemberCollection
[C#]
public MemberCollection GetChildren(long start, long count, params MemberFilter[] filters);
[C++]
public: MemberCollection* GetChildren(__int64 start, __int64 count, MemberFilter*[] filters);
[JScript]
public function GetChildren(start : long, count : long, filters : MemberFilter[]) : MemberCollection;
Arguments [JScript]
start
The position to begin returning members. This argument is 0-based.
count
The number of members to return.
filters
An array of MemberFilter objects that filters the returned MemberCollection.
Parameters [Visual Basic, C#, C++]
start
The position to begin returning members. This parameter is 0-based.
count
The number of members to return.
filters
An array of MemberFilter objects that filters the returned MemberCollection.
Return Value

Returns a MemberCollection that contains a collection of members for the Member.

Remarks

A nonleaf member is associated with one or more members from lower levels in the hierarchy. For example, in a time dimension that contains the levels Year, Month, and Day, the members of the Day level are leaf members. Each member in the Year level is associated with 12 child members from the Month level, and each member in the Month level is associated with at least 28 child members from the Day level.

The GetChildren method returns a collection of Member objects that represents the child members associated with the Member.

Note This property is not supported if the Member was referenced through a CellSet in order to retrieve metadata from a query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.GetChildren Method (System.Int64, System.Int64, System.String[], MemberFilter[])

Returns a MemberCollection that contains a collection of child members for the Member. The returned object contains up to count members, begins at the position indicated by the start parameter, and is filtered by the filters parameters. Each member caches the properties indicated by the Array passed into the properties parameter.

Note For performance reasons, this overload should be used only if non-default member properties are needed. Default member properties include Name, UniqueName, Caption, ChildCount, Description, LevelDepth, LevelName, Parent, ParentLevel, and Type.

 [Visual Basic]
Public Overloads Function GetChildren(ByVal start As Long, ByVal count As Long, ByVal properties() as String, ByVal ParamArray filters() As MemberCollection
[C#]
public MemberCollection GetChildren(long start, long count, string[] properties, params MemberFilter[] filters);
[C++]
public: MemberCollection* GetChildren(__int64 start, __int64 count, String* properties[], MemberFilter*[] filters);
[JScript]
public function GetChildren(start : long, count : long, properties : String[], filters : MemberFilter[]) : MemberCollection;
Arguments [JScript]
start
The position to begin returning members. This argument is 0-based.
count
The number of members to return.
properties
The properties to populate.
filters
An array of MemberFilter objects that filters the returned MemberCollection.
Parameters [Visual Basic, C#, C++]
start
The position to begin returning members. This parameter is 0-based.
count
The number of members to return.
properties
The properties to populate.
filters
An array of MemberFilter objects that will filter the returned MemberCollection.
Return Value

Returns a MemberCollection that contains a collection of members for the Member.

Remarks

A nonleaf member is associated with one or more members from lower levels in the hierarchy. For example, in a time dimension that contains the levels Year, Month, and Day, the members of the Day level are leaf members. Each member in the Year level is associated with 12 child members from the Month level, and each member in the Month level is associated with at least 28 child members from the Day level.

The GetChildren method returns a collection of Member objects that represents the child members associated with the Member.

Note This property is not supported if the Member is referenced through a CellSet in order to retrieve metadata from a query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the Member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member Operators

The operators of the Member class are listed here. For a complete list of Member class members, see Member Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Member are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Member are unequal.

See Also

Member Class | Microsoft.AnalysisServices.AdomdClient Namespace


Member Equality Operator

Determines whether two instances of Member are equal.

[Visual Basic]
returnValue = Member.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Member o1,
   Member o2
);
[C++]
public: static bool op_Equality(
   Member* o1,
   Member* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Member.
o2
A Member.
Parameters [Visual Basic, C#, C++]
o1
A Member.
o2
A Member.
Return Value

true if o1 and o2 represent the same Member; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


Member Inequality Operator

Determines whether two instances of Member are unequal.

[Visual Basic]
returnValue = Member.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Member o1,
   Member o2
);
[C++]
public: static bool op_Inequality(
   Member* o1,
   Member* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Member.
o2
A Member.
Parameters [Visual Basic, C#, C++]
o1
A Member.
o2
A Member.
Return Value

true if o1 and o2 do not represent the same Member; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Member Class | Member Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection Class

Gets a read-only, on-demand collection of Member objects contained by a Position, a Level, or a Tuple.

For a complete list of MemberCollection class members, see MemberCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.MemberCollection

[Visual Basic]
NotInheritable Public Class MemberCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class MemberCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class MemberCollection : public ICollection,
   IEnumerable
[JScript]
public class MemberCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

Although the MemberCollection externally represents a collection of Member objects, the collection is internally loaded and managed in one of two ways, depending on the parent of the collection:

  • If the parent object was referenced as a result of a query, as in the case of a Tuple, the collection represents the members referenced by that query.
  • If the parent object was referenced as a result of a request for metadata, the collection represents the members referenced by the definition of the parent object.
Example
[Visual Basic]

The following subroutine, given a Level, iterates through the MemberCollection and displays information for each member.

Public Overloads Sub ListMembers(ByRef LevelToCheck As Level)

    ' Check the parameter before performing actions on it.
    If LevelToCheck Is Nothing Then
        Throw New System.ArgumentNullException("LevelToCheck")
    Else
        ' Iterate through the Members collection of the
        ' Level object.

        Try
            Dim memberToCheck As Member

            Debug.WriteLine("Found " & LevelToCheck.GetMembers().Count& _
                " member(s) in level:")

            For Each memberToCheck In LevelToCheck.GetMembers()
                Debug.WriteLine("Member:  " & memberToCheck.Name)
                Debug.WriteLine("  Caption:          " & _
                    memberToCheck.Caption)
                Debug.WriteLine("  UniqueName:       " & _
                    memberToCheck.UniqueName)

                ' Note that the Children property loads a collection
                ' of Member objects on demand and
                ' therefore, slows performance when first
                ' referenced--you should instead use the
                ' ChildCount property.
                Debug.WriteLine("  No. of children:  " & _
                    memberToCheck.ChildCount)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection Members

MemberCollection Class

Public Properties

public property Count | Gets the number of Member objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Member from the collection. In C#, this property is the indexer for the MemberCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Member from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection Properties

The properties of the MemberCollection class are listed here. For a complete list of MemberCollection class members, see MemberCollection Members.

Public Properties

public property Count | Gets the number of Member objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Member from the collection. In C#, this property is the indexer for the MemberCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

MemberCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Count Property

Gets the number of Member objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

Gets the number of Member objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Item Property

Gets the specified Member from the collection.

[C#] In C#, this property is the indexer for the MemberCollection class.

Overload List

Gets the specified Member from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As Member
[C#] public Member this[System.Int32] {get;}
[C++] public: __property Member* get_Item(System.Int32);
[JScript] MemberCollection.Item (System.Int32)

Gets the specified Member from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As Member
[C#] public Member this[System.String] {get;}
[C++] public: __property Member* get_Item(System.String);
[JScript] MemberCollection.Item (System.String)
See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Item Property (System.Int32)

Gets the specified Member from the collection by its index.

[C#] In C#, this property is the indexer for the MemberCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Member
[C#]
public Member this[
   int index
] {get;}
[C++]
public: __property Member* get_Item(
   int index
);
[JScript]
returnValue = MemberCollectionObject.Item(index);
-or-
returnValue = MemberCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Member to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Member o find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | MemberCollection.Item Overload List


MemberCollection.Item Property (System.String)

Gets the specified Member from the collection by its name.

[C#] In C#, this property is the indexer for the MemberCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Member
[C#]
public Member this[
   string index
] {get;}
[C++]
public: __property Member* get_Item(
   String* index
);
[JScript]
returnValue = MemberCollectionObject.Item(index);
-or-
returnValue = MemberCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the Member to find.
Parameters [Visual Basic, C#, C++]
index
The name of the Member to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | MemberCollection.Item Overload List


MemberCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection Methods

The methods of the MemberCollection class are listed here. For a complete list of MemberCollection class members, see MemberCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified Member from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Member, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Member[] array,
   int index
);
[C++]
public: void CopyTo(
   Member* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Member[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Find Method

Returns the specified Member from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As Member
[C#]
public Member Find(
   string index
);
[C++]
public: Member* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : Member;
Parameters
index
The name of the Member to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

MemberCollection Class | MemberCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator Structure

Supports iterating over a MemberCollection and reading its individual members.

For a list of all members of this type, see MemberCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.MemberCollection.Enumerator

[Visual Basic]
Public Structure MemberCollection.Enumerator
   Implements IEnumerator
[C#]
public struct MemberCollection.Enumerator : IEnumerator
[C++]
public __value struct MemberCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MemberCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator Members

MemberCollection.Enumerator Structure

Public Properties

public property Current Gets the current member in the MemberCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next member in the MemberCollection.
public method Reset | Moves the enumerator to a position before the first member in the MemberCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

MemberCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator Properties

The properties of the MemberCollection.Enumerator structure are listed here. For a complete list of MemberCollection.Enumerator structure members, see MemberCollection.Enumerator Members.

Public Properties

public property Current Gets the current member in the MemberCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

MemberCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator.Current Property

Gets the current member in the MemberCollection.

[Visual Basic]
Public ReadOnly Property Current As Member
[C#]
public Member Current {get;}
[C++]
public: __property Member* get_Current();
[JScript]
public function get Current() : Member;
Property Value

The current member of the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last member in the MemberCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection.Enumerator Structure | MemberCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

MemberCollection.Enumerator Structure | MemberCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator Methods

The methods of the MemberCollection.Enumerator structure are listed here. For a complete list of MemberCollection.Enumerator structure members, see MemberCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next member in the MemberCollection.
public method Reset | Moves the enumerator to a position before the first member in the MemberCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator.MoveNext Method

Moves to the next member in the MemberCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection.Enumerator Structure | MemberCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first member in the MemberCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberCollection.Enumerator Structure | MemberCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter Class

Represents a single filter to be applied when retrieving a collection of members.

System.Object
Microsoft.AnalysisServices.AdomdClient.MemberFilter

[Visual Basic]
Public Class MemberFilter
[C#]
public class MemberFilter
[C++]
public __gc __ class MemberFilter
[JScript]
public class MemberFilter
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

This object is used in the Level.GetMembers method and the Member.GetChildren method.

The MemberFilter represents a single filter to be applied when retrieving a collection of members.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter Members

MemberFilter Class

Public Properties

public property PropertyName | Gets or sets the name of the property to filter on.
public property PropertyValue | Gets or sets the value of the property to filter for.
public property FilterType | Gets or sets the type of filtering to use.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberFilter Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter Constructor

Initializes a new instance of the MemberFilter class.

Overload List

Initializes a new instance of the MemberFilter class with the property name and the property value.

[Visual Basic] Public Sub New(ByVal propertyName as String, ByVal propertyValue as String)
[C#] public MemberFilter(string propertyName, string propertyValue);
[C++] public: MemberFilter(String propertyName, String propertyValue);
[JScript] public function MemberFilter(propertyName: String, propertyValue: String);

Initializes a new instance of the MemberFilter class with the property name, the property value, and the type of the filter.

[Visual Basic] Public Sub New(ByVal propertyName as String, ByVal filterType as MemberFilterType, ByVal propertyValue as String)
[C#] public MemberFilter(string propertyName, MemberFilterType filterType, string propertyValue);
[C++] public: MemberFilter(String propertyName, MemberFilterType filterType, String propertyValue);
[JScript] public function MemberFilter(propertyName: String, filterType : MemberFilterType, propertyValue: String);
See Also

MemberFilter Class | MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter Constructor (string, string)

Initializes a new instance of the MemberFilter class with the property name and the property value.

[Visual Basic]
Public Sub New(ByVal propertyName as String, ByVal propertyValue as String)
[C#]
public MemberFilter(string propertyName, string propertyValue);
[C++]
public: MemberFilter(String propertyName, String propertyValue);
[JScript]
public function MemberFilter(propertyName: String, propertyValue: String);
Arguments [JScript]
propertyName
The name of the property to filter on.
propertyValue
The value of the property to filter for.
Parameters [Visual Basic, C#, C++]
propertyName
The name of the property to filter on.
propertyValue
The value of the property to filter for.
Remarks

The default type of the filter is the MemberFilterType.Equals type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberFilter Class | MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace | MemberFilter Constructor Overload List


MemberFilter Constructor (string, MemberFilter, string)

Initializes a new instance of the MemberFilter class with the property name, the property value, and the type of the filter.

[Visual Basic]
Public Sub New(ByVal propertyName as String, ByVal filterType as MemberFilterType, ByVal propertyValue as String)
[C#]
public MemberFilter(string propertyName, MemberFilterType filterType, string propertyValue);
[C++]
public: MemberFilter(String propertyName, MemberFilterType filterType, String propertyValue);
[JScript]
public function MemberFilter(propertyName: String, filterType : MemberFilterType, propertyValue: String);
Arguments [JScript]
propertyName
The name of the property that to filter on.
filterType
The type of filtering to apply to the property.
propertyValue
The value of the property to filter for.
Parameters [Visual Basic, C#, C++]
propertyName
The name of the property that to filter on.
filterType
The type of filtering to apply to the property.
propertyValue
The value of the property to filter for.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberFilter Class | MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace | MemberFilter Constructor Overload List


MemberFilter Properties

The properties of the MemberFilter class are listed here. For a complete list of MemberFilter class members, see MemberFilter Members.

Public Properties

public property PropertyName | Gets or sets the name of the property to filter on.
public property PropertyValue | Gets or sets the value of the property to filter for.
public property FilterType | Gets or sets the type of filtering to use.

See Also

MemberFilter Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter.PropertyName Filter

ADOMD.NET SDK

MemberFilter.PropertyName Property

Gets or sets the name of the property to filter on.

[Visual Basic]
Public Property PropertyName As String
[C#]
public string PropertyName {get;set;}
[C++]
public: __property String* get_PropertyName();
public: __property void set_PropertyName(String*);
 [JScript]
public function get PropertyName() : String;
public function set PropertyName(String);
Property Value

An instance of a String object that contains the name of the property that will be filtered on. Examples include Caption, Name, UniqueName, or the name of a user-defined member property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries From Partially Trusted Code.

See Also

MemberFilter Class | MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter.PropertyValue Property

Gets or sets the value of the property to filter for.

[Visual Basic]
Public Property PropertyValue As String
[C#]
public string PropertyValue {get;set;}
[C++]
public: __property String* get_PropertyValue();
public: __property void set_PropertyValue(String*);
 [JScript]
public function get PropertyValue() : String;
public function set PropertyValue(String);
Property Value

A String that contains the value to filter for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberFilter Class | MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter.FilterType Property

Gets or sets the type of filtering to use.

[Visual Basic]
Public Property PropertyValue As MemberFilterType
[C#]
public MemberFilterType PropertyValue {get;set;}
[C++]
public: __property MemberFilterType * get_PropertyValue();
public: __property void set_PropertyValue(MemberFilterType *);
 [JScript]
public function get PropertyValue() : MemberFilterType;
public function set PropertyValue(MemberFilterType);
Property FilterType

A MemberFilterType enumeration that determines the behavior of this MemberFilter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberFilter Class | MemberFilter Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilter Methods

The methods of the MemberFilter class are listed here. For a complete list of MemberFilter class members, see MemberFilter Members.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberFilter Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Class

Represents a single member property for a given member.

For a complete list of MemberProperty class members, see MemberProperty Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.MemberProperty

[Visual Basic]
NotInheritable Public Class MemberProperty
[C#]
public sealed class MemberProperty
[C++]
public __gc __sealed class MemberProperty
[JScript]
public class MemberProperty
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

In the axis specification for a given axis in a multidimensional query, the set expression selects tuples with which to populate the axis. The cellset returns basic information about each member in each tuple, such as member name, parent level, and number of children. Members often have additional properties associated with them, referred to as member properties, which are available for all members at a given level.

The MemberProperty represents a single member property for a Member.

Example
[Visual Basic]

The following subroutine, given a Member, iterates through the MemberProperties collection and displays information for each MemberProperty in the collection:

Public Sub ListMemberProperties(ByRef MemberToCheck As Member)

    ' Check the parameter before performing actions on it.
    If MemberToCheck Is Nothing Then
        Throw New System.ArgumentNullException("MemberToCheck")
    Else
        ' Iterate through the MemberProperties collection of the
        ' Member object.

        Try
            Dim propToCheck As MemberProperty

            Debug.WriteLine("Found " & _
                MemberToCheck.MemberProperties.Count & _
                " member properties in member:")

            For Each propToCheck In MemberToCheck.MemberProperties
                Debug.WriteLine("Member Property:  " & propToCheck.Name)
                Debug.WriteLine("  Value:        " & _
                    propToCheck.Value)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Members

MemberProperty Class

Public Properties

public property Name | Gets the name of the MemberProperty.
public property UniqueName | Gets the fully-qualified name of the MemberProperty.
public property Value | Gets the value of the MemberProperty.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of MemberProperty are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of MemberProperty are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Properties

The properties of the MemberProperty class are listed here. For a complete list of MemberProperty class members, see MemberProperty Members.

Public Properties

public property Name | Gets the name of the MemberProperty.
public property UniqueName | Gets the fully-qualified name of the MemberProperty.
public property Value | Gets the value of the MemberProperty.

See Also

MemberProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace

Using Libraries from Partially Trusted Code


MemberProperty.Name Property

Gets the name of the MemberProperty.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the MemberProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty.UniqueName Property

Gets the fully-qualified name of the MemberProperty.

[Visual Basic]
Public ReadOnly Property UniqueName As String
[C#]
public string UniqueName {get;}
[C++]
public: __property String* get_UniqueName();
[JScript]
public function get UniqueName() : String;
Property Value

A String that contains the fully-qualified name of the MemberProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty.Value Property

Gets the value of the MemberProperty.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;
Property Value

An Object that contains the value of the MemberProperty.

Remarks

Unless the run-time type of the value for a MemberProperty is known in advance, use the GetType method of the Object to determine the run-time type before attempting to use the Object that is returned by this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Methods

The methods of the MemberProperty class are listed here. For a complete list of MemberProperty class members, see MemberProperty Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty.Equals Method

Determines whether two instances of MemberProperty are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Cell.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the MemberProperty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Operators

The operators of the MemberProperty class are listed here. For a complete list of MemberProperty class members, see MemberProperty Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of MemberProperty are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of MemberProperty are unequal.

See Also

MemberProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Equality Operator

Determines whether two specified instances of MemberProperty are equal.

[Visual Basic]
returnValue = MemberProperty.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   MemberProperty o1,
   MemberProperty o2
);
[C++]
public: static bool op_Equality(
   MemberProperty* o1,
   MemberProperty* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A MemberProperty.
o2
A MemberProperty.
Parameters [Visual Basic, C#, C++]
o1
A MemberProperty.
o2
A MemberProperty.
Return Value

true if o1 and o2 represent the same MemberProperty; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberProperty Inequality Operator

Determines whether two specified instances of MemberProperty are unequal.

[Visual Basic]
returnValue = MemberProperty.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   MemberProperty o1,
   MemberProperty o2
);
[C++]
public: static bool op_Inequality(
   MemberProperty* o1,
   MemberProperty* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A MemberProperty.
o2
A MemberProperty.
Parameters [Visual Basic, C#, C++]
o1
A MemberProperty.
o2
A MemberProperty.
Return Value

true if o1 and o2 do not represent the same MemberProperty; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberProperty Class | MemberProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection Class

Gets a read-only, on-demand collection of MemberProperty objects contained by a Member.

For a complete list of MemberPropertyCollection class members, see MemberPropertyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.MemberPropertyCollection

[Visual Basic]
NotInheritable Public Class MemberPropertyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class MemberPropertyCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class MemberPropertyCollection : public
   ICollection, IEnumerable
[JScript]
public class MemberPropertyCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

Although the MemberPropertyCollection collection externally represents a collection of MemberProperty objects for a specified Member, the collection is internally loaded and managed in one of two ways, depending on the parentage of the Member:

  • If the Member was referenced through the use of a CubeDef in order to retrieve metadata from the server, the collection represents the member properties that are defined for the level of the member represented by the Member.
  • If the Member was referenced through the use of a CellSet in order to retrieve metadata from a query, the collection represents the member properties that are retrieved for the set (or axis) containing the member represented by the Member.
Example
[Visual Basic]

The following subroutine, given a Member, iterates through the MemberPropertyCollection collection and displays information for each member property:

Public Sub ListMemberPropertyCollection(ByRef MemberToCheck As Member)

    ' Check the parameter before performing actions on it.
    If MemberToCheck Is Nothing Then
        Throw New System.ArgumentNullException("MemberToCheck")
    Else
        ' Iterate through the MemberProperties collection of the
        ' Member object.

        Try
            Dim propToCheck As MemberProperty

            Debug.WriteLine("Found " & _
                MemberToCheck.MemberProperties.Count & _
                " member properties in member:")

            For Each propToCheck In MemberToCheck.MemberProperties
                Debug.WriteLine("Member Property:  " & propToCheck.Name)
                Debug.WriteLine("  Value:        " & _
                    propToCheck.Value)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection Members

MemberPropertyCollection Class

Public Properties

public property Count | Overridden. Gets the number of MemberProperty objects in the collection.
public property IsSynchronized | Overridden. Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified MemberProperty from the collection. In C#, this property is the indexer for the MemberPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Gets the specified MemberProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection Properties

The properties of the MemberPropertyCollection class are listed here. For a complete list of MemberPropertyCollection class members, see MemberPropertyCollection Members.

Public Properties

public property Count | Gets the number of MemberProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified MemberProperty from the collection. In C#, this property is the indexer for the MemberPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

MemberPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Count Property

Gets the number of MemberProperty objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public override function get Count() : int;
Property Value

The number of MemberProperty objects in the MemberPropertyCollection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public override function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Item Property

Gets the specified MemberProperty from the collection.

[C#] In C#, this property is the indexer for the MemberPropertyCollection class.

Overload List

Gets the specified MemberProperty from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As MemberProperty
[C#] public MemberProperty this[System.Int32] {get;}
[C++] public: __property MemberProperty* get_Item(System.Int32);
[JScript] MemberPropertyCollection.Item (System.Int32)

Gets the specified MemberProperty from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As MemberProperty
[C#] public MemberProperty this[System.String] {get;}
[C++] public: __property MemberProperty* get_Item(System.String);
[JScript] MemberPropertyCollection.Item (System.String)
See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Item Property (System.Int32)

Gets the specified MemberProperty from the collection by its index.

[C#] In C#, this property is the indexer for the MemberPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As MemberProperty
[C#]
public MemberProperty this[
   int index
] {get;}
[C++]
public: __property MemberProperty* get_Item(
   int index
);
[JScript]
returnValue = MemberPropertyCollectionObject.Item(index);
-or-
returnValue = MemberPropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the MemberProperty to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the MemberProperty to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | MemberPropertyCollection.Item Overload List


MemberPropertyCollection.Item Property (System.String)

Gets the specified MemberProperty from the collection by its name.

[C#] In C#, this property is the indexer for the MemberPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As MemberProperty
[C#]
public MemberProperty this[
   string index
] {get;}
[C++]
public: __property MemberProperty* get_Item(
   String* index
);
[JScript]
returnValue = MemberPropertyCollectionObject.Item(index);
-or-
returnValue = MemberPropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the MemberProperty to find.
Parameters [Visual Basic, C#, C++]
index
The name of the MemberProperty to find.
Exceptions

Exception type | Condition
InvalidOperationException | The specified member did not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | MemberPropertyCollection.Item Overload List


MemberPropertyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection Methods

The methods of the MemberPropertyCollection class are listed here. For a complete list of MemberPropertyCollection class members, see MemberPropertyCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Gets the specified MemberProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As MemberProperty, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   MemberProperty[] array,
   int index
);
[C++]
public: void CopyTo(
   MemberProperty* array[],
   int index
);
[JScript]
public function CopyTo(
   array : MemberProperty[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Find Method

Returns the specified MemberProperty from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As MemberProperty
[C#]
public MemberProperty Find(
   string index
);
[C++]
public: MemberProperty* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : MemberProperty;
Parameters
index
The name of the MemberProperty to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

MemberPropertyCollection Class | MemberPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator Structure

Supports iterating over a MemberPropertyCollection and reading its individual member properties.

For a list of all members of this type, see MemberPropertyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.MemberPropertyCollection.Enumerator

[Visual Basic]
Public Structure MemberPropertyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct MemberPropertyCollection.Enumerator : IEnumerator
[C++]
public __value struct MemberPropertyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

MemberPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator Members

MemberPropertyCollection.Enumerator Structure

Public Properties

public property Current Gets the current member property of the MemberPropertyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next member property in the MemberPropertyCollection.
public method Reset | Moves the enumerator to a position before the first member property of the MemberPropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

MemberPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator Properties

The properties of the MemberPropertyCollection.Enumerator structure are listed here. For a complete list of MemberPropertyCollection.Enumerator structure members, see MemberPropertyCollection.Enumerator Members.

Public Properties

public property Current Gets the current member property in the MemberPropertyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

MemberPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator.Current Property

Gets the current member property in the MemberPropertyCollection.

[Visual Basic]
Public ReadOnly Property Current As MemberProperty
[C#]
public MemberProperty Current {get;}
[C++]
public: __property MemberProperty* get_Current();
[JScript]
public function get Current() : MemberProperty;
Property Value

The current member property in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last member property in the MemberPropertyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection.Enumerator Structure | MemberPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

MemberPropertyCollection.Enumerator Structure | MemberPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator Methods

The methods of the MemberPropertyCollection.Enumerator structure are listed here. For a complete list of MemberPropertyCollection.Enumerator structure members, see MemberPropertyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of an Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next member property in the MemberPropertyCollection.
public method Reset | Moves the enumerator to a position before the first member property in the MemberPropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

MemberPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator.MoveNext Method

Moves to the next member property in the MemberPropertyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection.Enumerator Structure | MemberPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberPropertyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first member property in the MemberPropertyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

MemberPropertyCollection.Enumerator Structure | MemberPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


MemberFilterType Enumeration

Represents the type of filtering to apply to the member property when using a MemberFilter.

[Visual Basic]
<Serializable>
Public Enum MemberFilterType
[C#]
[Serializable]
public enum MemberFilterType
[C++]
[Serializable]
__value public enum MemberFilterType
[JScript]
public
   Serializable
enum MemberFilterType
Remarks

The FilterType property of the MemberFilter identifies how the filter will be applied, when calling GetMembers on the Level, or GetChildren on the Member.

Members

Member name | Description
Equals | The property value will be tested to equal the specified filter value.
BeginsWith | The property value will be tested to begin with the specified filter value.
EndsWith | The property value will be tested to end with the specified filter value.
Contains | The property value will be tested to contain the specified filter value.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Microsoft.AnalysisServices.AdomdClient.Level.GetMembers

Microsoft.AnalysisServices.AdomdClient.Member.GetChildren

Microsoft.AnalysisServices.AdomdClient Namespace


MemberTypeEnum Enumeration

Represents the member type of a Member.

[Visual Basic]
<Serializable>
Public Enum MemberTypeEnum
[C#]
[Serializable]
public enum MemberTypeEnum
[C++]
[Serializable]
__value public enum MemberTypeEnum
[JScript]
public
   Serializable
enum MemberTypeEnum
Remarks

MemberTypeEnum.Formula takes precedence over MemberTypeEnum.Measure. Therefore, if a calculated member exists on the Measures dimension, the Type property of the Member that represents that calculated member is set to MemberTypeEnum.Formula, not MemberTypeEnum.Measure.

Members

Member name | Description
All | The member is an All member.
Formula | The member is a calculated member or calculated measure.
Measure | The member is a measure.
Regular | The member is a regular member.
Unknown | The member type is unknown.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Class

Represents a named set for a given cube.

For a complete list of NamedSet class members, see NamedSet Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.NamedSet

[Visual Basic]
NotInheritable Public Class NamedSet
[C#]
public sealed class NamedSet
[C++]
public __gc __sealed class NamedSet
[JScript]
public class NamedSet
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A named set is a persisted set expression, which is associated with an alias and defined as part of the structure of a cube. In Multidimensional Expressions (MDX), a set expression can be a lengthy and complex declaration. A named set makes it easier to manage a set expression that is used regularly in MDX or XML for Analysis queries involving the cube, and provides a way of maintaining the set expression independently of the queries that use it.

A NamedSet encapsulates the alias and set expression of a named set, so that the metadata of the named set can be examined and incorporated into queries.

Example
[Visual Basic]

The following subroutine, given a CubeDef, iterates through the NamedSets collection and displays information about each NamedSet in the collection:

Public Sub ListNamedSets(ByRef CubeToCheck As CubeDef)

    ' Check the parameter before performing actions on it.
    If CubeToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CubeToCheck")
    Else
        ' Iterate through the NamedSets collection of the
        ' CubeDef object.

        Try
            Dim nsetToCheck As NamedSet

            Debug.WriteLine("Found " & CubeToCheck.NamedSets.Count & _
                " named set(s) in cube:")

            For Each nsetToCheck In CubeToCheck.NamedSets
                Debug.WriteLine("Named Set:  " & nsetToCheck.Name)
                Debug.WriteLine("    Description:  " & _
                    nsetToCheck.Description)
                Debug.WriteLine("    Expression:   " & _
                    nsetToCheck.Expression)
            Next
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing metadata.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Members

NamedSet Class

Public Properties

public property Description | Gets the description of the NamedSet.
public property Expression | Gets the MDX set expression that is used to define the NamedSet.
public property Name | Gets the name of the NamedSet.
public property ParentCube | Gets a CubeDef that contains the NamedSet.
public property Properties | Gets a PropertyCollection that contains the properties associated with the NamedSet.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of NamedSet are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of NamedSet are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

NamedSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Properties

The properties of the NamedSet class are listed here. For a complete list of NamedSet class members, see NamedSet Members.

Public Properties

public property Description | Gets the description of the NamedSet.
public property Expression | Gets the MDX set expression that is used to define the NamedSet.
public property Name | Gets the name of the NamedSet.
public property ParentCube | Gets a CubeDef that contains the NamedSet.
public property Properties | Gets a PropertyCollection that contains the properties associated with the NamedSet.

See Also

NamedSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.Description Property

Gets the description of the NamedSet.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;
Property Value

A String that contains the description for the NamedSet.

Remarks

The information for this property is retrieved from the DESCRIPTION column of the MDSCHEMA_SETS schema rowset.

Note This property always returns an empty string when the NamedSet references a named set that was created in an earlier version of Microsoft SQL Server 2000 Analysis Services.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.Expression Property

Gets the MDX set expression that defines the NamedSet.

[Visual Basic]
Public ReadOnly Property Expression As String
[C#]
public string Expression {get;}
[C++]
public: __property String* get_Expression();
[JScript]
public function get Expression() : String;
Property Value

A String containing the set expression that defines the NamedSet.

Remarks

The set expression in a NamedSet can include any literal or function that can normally be incorporated into a set expression in MDX. The information for this property is retrieved from the EXPRESSION column of the MDSCHEMA_SETS schema rowset.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.Name Property

Gets the name of the NamedSet.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that contains the name of the NamedSet.

Remarks

The information for this property is retrieved from the SET_NAME column of the MDSCHEMA_SETS schema rowset.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.ParentCube Property

Gets a CubeDef that contains the NamedSet.

[Visual Basic]
Public ReadOnly Property ParentCube As CubeDef
[C#]
public CubeDef ParentCube {get;}
[C++]
public: __property CubeDef* get_ParentCube();
[JScript]
public function get ParentCube() : CubeDef;
Property Value

A CubeDef that contains the NamedSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.Properties Property

Gets a PropertyCollection that contains the properties associated with the NamedSet.

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public PropertyCollection Properties {get;}
[C++]
public: __property PropertyCollection* get_Properties();
[JScript]
public function get Properties() : PropertyCollection;
Property Value

A PropertyCollection that contains the properties associated with the named set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Methods

The methods of the NamedSet class are listed here. For a complete list of NamedSet class members, see NamedSet Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

NamedSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.Equals Method

Determines whether two instances of NamedSet are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the NamedSet.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that contains the name of the NamedSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Operators

The operators of the NamedSet class are listed here. For a complete list of NamedSet class members, see NamedSet Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of NamedSet are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of NamedSet are unequal.

See Also

NamedSet Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Equality Operator

Determines whether two specified instances of NamedSet are equal.

[Visual Basic]
returnValue = NamedSet.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   NamedSet o1,
   NamedSet o2
);
[C++]
public: static bool op_Equality(
   NamedSet* o1,
   NamedSet* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A NamedSet.
o2
A NamedSet.
Parameters [Visual Basic, C#, C++]
o1
A NamedSet.
o2
A NamedSet.
Return Value

true if o1 and o2 represent the same NamedSet; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSet Inequality Operator

Determines whether two specified instances of NamedSet are unequal.

[Visual Basic]
returnValue = NamedSet.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   NamedSet o1,
   NamedSet o2
);
[C++]
public: static bool op_Inequality(
   NamedSet* o1,
   NamedSet* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A NamedSet.
o2
A NamedSet.
Parameters [Visual Basic, C#, C++]
o1
A NamedSet.
o2
A NamedSet.
Return Value

true if o1 and o2 do not represent the same NamedSet; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSet Class | NamedSet Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection Class

Gets a read-only, on-demand collection of NamedSet objects contained by a CubeDef.

For a complete list of NamedSetCollection class members, see NamedSetCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.NamedSetCollection

[Visual Basic]
NotInheritable Public Class NamedSetCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class NamedSetCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class NamedSetCollection : public ICollection,
   IEnumerable
[JScript]
public class NamedSetCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a CubeDef, iterates through the NamedSetCollection collection and displays information for each named set.

Public Sub ListNamedSetCollection(ByRef CubeToCheck As CubeDef)

    ' Check the parameter before performing actions on it.
    If CubeToCheck Is Nothing Then
        Throw New System.ArgumentNullException("CubeToCheck")
    Else
        ' Iterate through the NamedSetCollection collection of the
        ' CubeDef object.

        Try
            Dim nsetToCheck As NamedSet

            Debug.WriteLine("Found " & CubeToCheck.NamedSets.Count & _
                " named set(s) in cube:")

            For Each nsetToCheck In CubeToCheck.NamedSets
                Debug.WriteLine("Named Set:  " & nsetToCheck.Name)
                Debug.WriteLine("    Description:  " & _
                    nsetToCheck.Description)
                Debug.WriteLine("    Expression:   " & _
                    nsetToCheck.Expression)
            Next
        Catch e As System.Exception
            Debug.WriteLine(e)
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection Members

For more information about the NamedSetCollection class, see NamedSetCollection Class.

Public Properties

public property Count | Gets the number of NamedSet objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified NamedSet from the collection. In C#, this property is the indexer for the NamedSetCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified Array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Gets the specified NamedSet from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

NamedSetCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection Properties

The properties of the NamedSetCollection class are listed here. For a complete list of NamedSetCollection class members, see NamedSetCollection Members.

Public Properties

public property Count | Gets the number of NamedSet objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified NamedSet from the collection. In C#, this property is the indexer for the NamedSetCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

NamedSetCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Count Property

Gets the number of NamedSet objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of NamedSet objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Item Property

Gets the specified NamedSet from the collection.

[C#] In C#, this property is the indexer for the NamedSetCollection class.

Overload List

Gets the specified NamedSet from the collection by its index.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.Int32) As NamedSet
[C#] public NamedSet this[System.Int32] {get;}
[C++] public: __property NamedSet* get_Item(System.Int32);
[JScript] NamedSetCollection.Item (System.Int32)

Gets the specified NamedSet from the collection by its name.

[Visual Basic] Public Overloads Default ReadOnly Property Item(System.String) As NamedSet
[C#] public NamedSet this[System.String] {get;}
[C++] public: __property NamedSet* get_Item(System.String);
[JScript] NamedSetCollection.Item (System.String)
See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Item Property (System.Int32)

Gets the specified NamedSet from the collection by its index.

[C#] In C#, this property is the indexer for the NamedSetCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As NamedSet
[C#]
public NamedSet this[
   int index
] {get;}
[C++]
public: __property NamedSet* get_Item(
   int index
);
[JScript]
returnValue = NamedSetCollectionObject.Item(index);
-or-
returnValue = NamedSetCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the NamedSet to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the NamedSet to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | NamedSetCollection.Item Overload List


NamedSetCollection.Item Property (System.String)

Gets the specified NamedSet from the collection by its name.

[C#] In C#, this property is the indexer for the NamedSetCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As NamedSet
[C#]
public NamedSet this[
   string index
] {get;}
[C++]
public: __property NamedSet* get_Item(
   String* index
);
[JScript]
returnValue = NamedSetCollectionObject.Item(index);
-or-
returnValue = NamedSetCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The name of the NamedSet to find.
Parameters [Visual Basic, C#, C++]
index
The name of the NamedSet to find.
Exceptions

Exception type | Condition
InvalidOperationException | The specified member did not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | NamedSetCollection.Item Overload List


NamedSetCollection.SyncRoot Property

Gets an Object hat can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An Object hat can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection Methods

The methods of the NamedSetCollection class are listed here. For a complete list of NamedSetCollection class members, see NamedSetCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified Array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Gets the specified NamedSet from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

NamedSetCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As NamedSet, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   NamedSet[] array,
   int index
);
[C++]
public: void CopyTo(
   NamedSet* array[],
   int index
);
[JScript]
public function CopyTo(
   array : NamedSet[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Find Method

Gets the specified NamedSet from the collection.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As NamedSet
[C#]
public NamedSet Find(
   string index
);
[C++]
public: NamedSet* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : NamedSet;
Parameters
index
The name of the NamedSet to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code

See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

NamedSetCollection Class | NamedSetCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator Structure

Supports iterating over a NamedSetCollection and reading its individual named sets.

For a list of all members of this type, see NamedSetCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.NamedSetCollection.Enumerator

[Visual Basic]
Public Structure NamedSetCollection.Enumerator
   Implements IEnumerator
[C#]
public struct NamedSetCollection.Enumerator : IEnumerator
[C++]
public __value struct NamedSetCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

NamedSetCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator Members

NamedSetCollection.Enumerator Structure

Public Properties

public property Current Gets the current named set in the NamedSetCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of an Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next named set in the NamedSetCollection.
public method Reset | Moves the enumerator to a position before the first named set in the NamedSetCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

NamedSetCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator Properties

The properties of the NamedSetCollection.Enumerator structure are listed here. For a complete list of NamedSetCollection.Enumerator structure members, see NamedSetCollection.Enumerator Members.

Public Properties

public property Current Gets the current named set in the NamedSetCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

NamedSetCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator.Current Property

Gets the current named set in the NamedSetCollection.

[Visual Basic]
Public ReadOnly Property Current As NamedSet
[C#]
public NamedSet Current {get;}
[C++]
public: __property NamedSet* get_Current();
[JScript]
public function get Current() : NamedSet;
Property Value

The named set in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last named set in the NamedSetCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection.Enumerator Structure | NamedSetCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator.System.Collections.IEnumerator.Current Property

Supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

NamedSetCollection.Enumerator Structure | NamedSetCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator Methods

The methods of the NamedSetCollection.Enumerator structure are listed here. For a complete list of NamedSetCollection.Enumerator structure members, see NamedSetCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of an Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next named set in the NamedSetCollection.
public method Reset | Moves the enumerator to a position before the first named set in the NamedSetCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

NamedSetCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator.MoveNext Method

Moves to the next named set of the NamedSetCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection.Enumerator Structure | NamedSetCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


NamedSetCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first named set in the NamedSetCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

NamedSetCollection.Enumerator Structure | NamedSetCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfo Class

Represents metadata associated with an instance of a CellSet.

For a list of all members of this type, see OlapInfo Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfo

[Visual Basic]
NotInheritable Public Class OlapInfo
[C#]
public sealed class OlapInfo
[C++]
public __gc __sealed class OlapInfo
[JScript]
public class OlapInfo
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfo Members

OlapInfo Class

Public Properties

public property AxesInfo | Gets an AxesInfo that represents metadata pertaining to the axes that are associated with a CellSet.
public property CellInfo | Gets a CellInfo that represents metadata pertaining to the cells that are associated a CellSet.
public property CubeInfo | Gets a CubeInfo that represents metadata pertaining to the cube that is associated with a CellSet.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of an Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfo Properties

The properties of the OlapInfo class are listed here. For a complete list of OlapInfo class members, see OlapInfo Members.

Public Properties

public property AxesInfo | Gets an AxesInfo that represents metadata pertaining to the axes that are associated with a CellSet.
public property CellInfo | Gets a CellInfo that represents metadata pertaining to the cells that are associated with a CellSet.
public property CubeInfo | Gets a CubeInfo that represents metadata pertaining to the cube that is associated with a CellSet.

See Also

OlapInfo Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfo.AxesInfo Property

Gets an AxesInfo that represents metadata pertaining to the axes that are associated with a CellSet.

[Visual Basic]
Public ReadOnly Property AxesInfo As AxesInfo
[C#]
public AxesInfo AxesInfo {get;}
[C++]
public: __property AxesInfo* get_AxesInfo();
[JScript]
public function get AxesInfo() : AxesInfo;
Property Value

An AxesInfo that represents metadata pertaining to the axes that are associated with a CellSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfo Class | OlapInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfo.CellInfo Property

Gets a CellInfo that represents metadata pertaining to the cells that are associated with a CellSet.

[Visual Basic]
Public ReadOnly Property CellInfo As CellInfo
[C#]
public CellInfo CellInfo {get;}
[C++]
public: __property CellInfo* get_CellInfo();
[JScript]
public function get CellInfo() : CellInfo;
Property Value

An CellInfo that represents metadata pertaining to the structure of the axes that are associated with a CellSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfo Class | OlapInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfo.CubeInfo Property

Gets a CubeInfo that represents metadata pertaining to the cube that is associated with a CellSet.

[Visual Basic]
Public ReadOnly Property CubeInfo As CubeInfo
[C#]
public CubeInfo CubeInfo {get;}
[C++]
public: __property CubeInfo* get_CubeInfo();
[JScript]
public function get CubeInfo() : CubeInfo;
Property Value

An CubeInfo that represents metadata pertaining to the structure of the axes that are associated with a CellSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfo Class | OlapInfo Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxis Class

Represents metadata pertaining to an axis that is associated with a CellSet.

For a list of all members of this type, see OlapInfoAxis Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoAxis

[Visual Basic]
NotInheritable Public Class OlapInfoAxis
[C#]
public sealed class OlapInfoAxis
[C++]
public __gc __sealed class OlapInfoAxis
[JScript]
public class OlapInfoAxis
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoAxis Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxis Members

OlapInfoAxis Class

Public Properties

public property Hierarchies | Gets an OlapInfoHierarchyCollection that represents metadata pertaining to the hierarchies that are associated with the OlapInfoAxis.
public property Name | Gets a String that represents the name of the OlapInfoAxis.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoAxis Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxis Properties

The properties of the OlapInfoAxis class are listed here. For a complete list of OlapInfoAxis class members, see OlapInfoAxis Members.

Public Properties

public property Hierarchies | Gets an OlapInfoHierarchyCollection that represents metadata pertaining to the hierarchies that are associated with the OlapInfoAxis.
public property Name | Gets a String that represents the name of the OlapInfoAxis.

See Also

OlapInfoAxis Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxis.Hierarchies Property

Gets an OlapInfoHierarchyCollection that represents metadata pertaining to the hierarchies that are associated with the OlapInfoAxis.

[Visual Basic]
Public ReadOnly Property Hierarchies As OlapInfoHierarchyCollection
[C#]
public OlapInfoHierarchyCollection Hierarchies {get;}
[C++]
public: __property OlapInfoHierarchyCollection* get_Hierarchies();
[JScript]
public function get Hierarchies() : OlapInfoHierarchyCollection;
Property Value

An OlapInfoHierarchyCollection that represents metadata pertaining to the hierarchies that are associated with the OlapInfoAxis.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxis Class | OlapInfoAxis Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxis.Name Property

Gets a String that represents the name of the object that the OlapInfoAxis represents.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that represents the name of the object that the OlapInfoAxis represents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxis Class | OlapInfoAxis Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection Class

Gets a read-only, on-demand collection of OlapInfoAxis objects.

For a list of all members of this type, see OlapInfoAxisCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoAxisCollection

[Visual Basic]
NotInheritable Public Class OlapInfoAxisCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class OlapInfoAxisCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class OlapInfoAxisCollection : public
   ICollection, IEnumerable
[JScript]
public class OlapInfoAxisCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection Members

OlapInfoAxisCollection Class

Public Properties

public property Count | Gets the number of OlapInfoAxis objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoAxis from the collection. In C#, this property is the indexer for the OlapInfoAxisCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoAxis from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoAxisCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection Properties

The properties of the OlapInfoAxisCollection class are listed here. For a complete list of OlapInfoAxisCollection class members, see OlapInfoAxisCollection Members.

Public Properties

public property Count | Gets the number of OlapInfoAxis objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
public property Item | Overloaded. Gets the specified OlapInfoAxis from the collection. In C#, this property is the indexer for the OlapInfoAxisCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OlapInfoAxisCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Count Property

Gets the number of OlapInfoAxis objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of OlapInfoAxis objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Item Property

Gets the specified OlapInfoAxis from the collection.

[C#] In C#, this property is the indexer for the OlapInfoAxisCollection class.

Overload List

Gets the specified OlapInfoAxis from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As OlapInfoAxis
[C#] public OlapInfoAxis this[System.Int32] {get;}
[C++] public: __property OlapInfoAxis* get_Item(System.Int32);
[JScript] OlapInfoAxisCollection.Item (System.Int32)

Gets the specified OlapInfoAxis from the collection by its name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As OlapInfoAxis
[C#] public OlapInfoAxis this[System.String] {get;}
[C++] public: __property OlapInfoAxis* get_Item(System.String);
[JScript] OlapInfoAxisCollection.Item (System.String)
See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Item Property (System.Int32)

Gets the specified OlapInfoAxis from the collection by its index.

[C#] In C#, this property is the indexer for the OlapInfoAxisCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As OlapInfoAxis
[C#]
public OlapInfoAxis this[
   int index
] {get;}
[C++]
public: __property OlapInfoAxis* get_Item(
   int index
);
[JScript]
returnValue = OlapInfoAxisCollectionObject.Item(index);
-or-
returnValue = OlapInfoAxisCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the OlapInfoAxis to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the OlapInfoAxis to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoAxisCollection.Item Overload List


OlapInfoAxisCollection.Item Property (System.String)

Gets the specified OlapInfoAxis from the collection by its name.

[C#] In C#, this property is the indexer for the OlapInfoAxisCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal name As String _
) As OlapInfoAxis
[C#]
public OlapInfoAxis this[
   string name
] {get;}
[C++]
public: __property OlapInfoAxis* get_Item(
   String* name
);
[JScript]
returnValue = OlapInfoAxisCollectionObject.Item(name);
-or-
returnValue = OlapInfoAxisCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
name
The name of the OlapInfoAxis to find.
Parameters [Visual Basic, C#, C++]
name
The name of the OlapInfoAxis to find.
Exceptions

Exception type | Condition
InvalidOperationException | The specified member does not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoAxisCollection.Item Overload List


OlapInfoAxisCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection Methods

The methods of the OlapInfoAxisCollection class are listed here. For a complete list of OlapInfoAxisCollection class members, see OlapInfoAxisCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoAxis from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoAxisCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OlapInfoAxis, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OlapInfoAxis[] array,
   int index
);
[C++]
public: void CopyTo(
   OlapInfoAxis* array[],
   int index
);
[JScript]
public function CopyTo(
   array : OlapInfoAxis[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Find Method

Gets the specified OlapInfoAxis from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As OlapInfoAxis
[C#]
public OlapInfoAxis Find(
   string name
);
[C++]
public: OlapInfoAxis* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : OlapInfoAxis;
Parameters
name
The name of the OlapInfoAxis to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.GetEnumerator Method

Gets an instance of the Enumerator class for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

OlapInfoAxisCollection Class | OlapInfoAxisCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator Structure

Supports iterating over an OlapInfoAxisCollection and reading its individual OlapInfoAxis objects.

For a list of all members of this type, see OlapInfoAxisCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.OlapInfoAxisCollection.Enumerator

[Visual Basic]
Public Structure OlapInfoAxisCollection.Enumerator
   Implements IEnumerator
[C#]
public struct OlapInfoAxisCollection.Enumerator : IEnumerator
[C++]
public __value struct OlapInfoAxisCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoAxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator Members

OlapInfoAxisCollection.Enumerator Structure

Public Properties

public property Current Gets the current OlapInfoAxis in the OlapInfoAxisCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoAxis in the OlapInfoAxisCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoAxis in the OlapInfoAxisCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoAxisCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator Properties

The properties of the OlapInfoAxisCollection.Enumerator structure are listed here. For a complete list of OlapInfoAxisCollection.Enumerator structure members, see OlapInfoAxisCollection.Enumerator Members.

Public Properties

public property Current Gets the current OlapInfoAxis in the OlapInfoAxisCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoAxisCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator.Current Property

Gets the current OlapInfoAxis in the OlapInfoAxisCollection.

[Visual Basic]
Public ReadOnly Property Current As OlapInfoAxis
[C#]
public OlapInfoAxis Current {get;}
[C++]
public: __property OlapInfoAxis* get_Current();
[JScript]
public function get Current() : OlapInfoAxis;
Property Value

The OlapInfoAxis in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last OlapInfoAxis in the OlapInfoAxisCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection.Enumerator Structure | OlapInfoAxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

OlapInfoAxisCollection.Enumerator Structure | OlapInfoAxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator Methods

The methods of the OlapInfoAxisCollection.Enumerator structure are listed here. For a complete list of OlapInfoAxisCollection.Enumerator structure members, see OlapInfoAxisCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoAxis in the OlapInfoAxisCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoAxis in the OlapInfoAxisCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoAxisCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator.MoveNext Method

Moves to the next OlapInfoAxis in the OlapInfoAxisCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection.Enumerator Structure | OlapInfoAxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoAxisCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first OlapInfoAxis in the OlapInfoAxisCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoAxisCollection.Enumerator Structure | OlapInfoAxisCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCube Class

Represents metadata pertaining to a cube that is associated with an instance of a CellSet class.

For a list of all members of this type, see OlapInfoCube Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoCube

[Visual Basic]
NotInheritable Public Class OlapInfoCube
[C#]
public sealed class OlapInfoCube
[C++]
public __gc __sealed class OlapInfoCube
[JScript]
public class OlapInfoCube
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoCube Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCube Members

OlapInfoCube Class

Public Properties

public property CubeName | Gets a String that represents the name of the cube that the OlapInfoCube represents.
public property LastDataUpdate | Gets a DateTime that represents the last updated date for the data contained in the cube that the OlapInfoCube represents.
public property LastSchemaUpdate | Gets a DateTime that represents the last updated date for the schema associated with the cube that the OlapInfoCube represents.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object instance is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoCube Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCube Properties

The properties of the OlapInfoCube class are listed here. For a complete list of OlapInfoCube class members, see OlapInfoCube Members.

Public Properties

public property CubeName | Gets a String that represents the name of the cube that the OlapInfoCube represents.
public property LastDataUpdate | Gets a DateTime that represents the last updated date for the data contained in the cube that the OlapInfoCube represents.
public property LastSchemaUpdate | Gets a DateTime that represents the last updated date for the schema associated with the cube that the OlapInfoCube represents.

See Also

OlapInfoCube Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCube.CubeName Property

Gets a String that represents the name of the cube that the OlapInfoCube represents.

[Visual Basic]
Public ReadOnly Property CubeName As String
[C#]
public string CubeName {get;}
[C++]
public: __property String* get_CubeName();
[JScript]
public function get CubeName() : String;
Property Value

A String that represents the name of the cube that the OlapInfoCube represents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCube Class | OlapInfoCube Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCube.LastDataUpdate Property

Gets a DateTime that represents the last updated date for the data contained in the cube that the OlapInfoCube represents.

[Visual Basic]
Public ReadOnly Property LastDataUpdate As DateTime
[C#]
public DateTime LastDataUpdate {get;}
[C++]
public: __property DateTime get_LastDataUpdate();
[JScript]
public function get LastDataUpdate() : DateTime;
Property Value

A DateTime that represents the last updated date for the data contained in the cube that the OlapInfoCube represents.

Remarks

This property may not be implemented by the provider, in which case a NotSupportedException exception is thrown when attempting to access this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCube Class | OlapInfoCube Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCube.LastSchemaUpdate Property

Gets a DateTime that represents the last updated date for the schema associated with the cube that the OlapInfoCube represents.

[Visual Basic]
Public ReadOnly Property LastSchemaUpdate As DateTime
[C#]
public DateTime LastSchemaUpdate {get;}
[C++]
public: __property DateTime get_LastSchemaUpdate();
[JScript]
public function get LastSchemaUpdate() : DateTime;
Property Value

A DateTime that represents the last updated date for the schema associated with the cube that the OlapInfoCube represents.

Remarks

This property may not be implemented by the provider, in which case a NotSupportedException exception is thrown when attempting to access this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCube Class | OlapInfoCube Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection Class

Gets a read-only, on-demand collection of OlapInfoCube objects.

For a list of all members of this type, see OlapInfoCubeCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoCubeCollection

[Visual Basic]
NotInheritable Public Class OlapInfoCubeCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class OlapInfoCubeCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class OlapInfoCubeCollection : public
   ICollection, IEnumerable
[JScript]
public class OlapInfoCubeCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection Members

OlapInfoCubeCollection Class

Public Properties

public property Count | Gets the number of OlapInfoCube objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoCube from the collection. In C#, this property is the indexer for the OlapInfoCubeCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoCube from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type for the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoCubeCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection Properties

The properties of the OlapInfoCubeCollection class are listed here. For a complete list of OlapInfoCubeCollection class members, see OlapInfoCubeCollection Members.

Public Properties

public property Count | Gets the number of OlapInfoCube objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoCube from the collection. In C#, this property is the indexer for the OlapInfoCubeCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OlapInfoCubeCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Count Property

Gets the number of OlapInfoCube objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of OlapInfoCube objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Item Property

Gets the specified OlapInfoCube from the collection.

[C#] In C#, this property is the indexer for the OlapInfoCubeCollection class.

Overload List

Gets the specified OlapInfoCube from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As OlapInfoCube
[C#] public OlapInfoCube this[System.Int32] {get;}
[C++] public: __property OlapInfoCube* get_Item(System.Int32);
[JScript] OlapInfoCubeCollection.Item (System.Int32)

Gets the specified OlapInfoCube from the collection by its name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As OlapInfoCube
[C#] public OlapInfoCube this[System.String] {get;}
[C++] public: __property OlapInfoCube* get_Item(System.String);
[JScript] OlapInfoCubeCollection.Item (System.String)
See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Item Property (System.Int32)

Gets the specified OlapInfoCube from the collection by its index.

[C#] In C#, this property is the indexer for the OlapInfoCubeCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As OlapInfoCube
[C#]
public OlapInfoCube this[
   int index
] {get;}
[C++]
public: __property OlapInfoCube* get_Item(
   int index
);
[JScript]
returnValue = OlapInfoCubeCollectionObject.Item(index);
-or-
returnValue = OlapInfoCubeCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the OlapInfoCube to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the OlapInfoCube to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoCubeCollection.Item Overload List


OlapInfoCubeCollection.Item Property (System.String)

Gets the specified OlapInfoCube from the collection by its name.

[C#] In C#, this property is the indexer for the OlapInfoCubeCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal name As String _
) As OlapInfoCube
[C#]
public OlapInfoCube this[
   string name
] {get;}
[C++]
public: __property OlapInfoCube* get_Item(
   String* name
);
[JScript]
returnValue = OlapInfoCubeCollectionObject.Item(name);
-or-
returnValue = OlapInfoCubeCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
name
The name of the OlapInfoCube to find.
Parameters [Visual Basic, C#, C++]
name
The name of the OlapInfoCube to find.
Exceptions

Exception type | Condition
InvalidOperati.onException | The specified member does not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoCubeCollection.Item Overload List


OlapInfoCubeCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection Methods

The methods of the OlapInfoCubeCollection class are listed here. For a complete list of OlapInfoCubeCollection class members, see OlapInfoCubeCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoCube from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoCubeCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OlapInfoCube, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OlapInfoCube[] array,
   int index
);
[C++]
public: void CopyTo(
   OlapInfoCube* array[],
   int index
);
[JScript]
public function CopyTo(
   array : OlapInfoCube[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Find Method

Gets the specified OlapInfoCube from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As OlapInfoCube
[C#]
public OlapInfoCube Find(
   string name
);
[C++]
public: OlapInfoCube* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : OlapInfoCube;
Parameters
name
The name of the OlapInfoCube to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.GetEnumerator Method

Gets an instance of the Enumerator class for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

OlapInfoCubeCollection Class | OlapInfoCubeCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator Structure

Supports iterating over an OlapInfoCubeCollection and reading its individual OlapInfoCube objects.

For a list of all members of this type, see OlapInfoCubeCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.OlapInfoCubeCollection.Enumerator

[Visual Basic]
Public Structure OlapInfoCubeCollection.Enumerator
   Implements IEnumerator
[C#]
public struct OlapInfoCubeCollection.Enumerator : IEnumerator
[C++]
public __value struct OlapInfoCubeCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoCubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator Members

OlapInfoCubeCollection.Enumerator Structure

Public Properties

public property Current Gets the current OlapInfoCube in the OlapInfoCubeCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoCube in the OlapInfoCubeCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoCube in the OlapInfoCubeCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object collection.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoCubeCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator Properties

The properties of the OlapInfoCubeCollection.Enumerator structure are listed here. For a complete list of OlapInfoCubeCollection.Enumerator structure members, see OlapInfoCubeCollection.Enumerator Members.

Public Properties

public property Current Gets the current OlapInfoCube in the OlapInfoCubeCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoCubeCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator.Current Property

Gets the current OlapInfoCube in the OlapInfoCubeCollection.

[Visual Basic]
Public ReadOnly Property Current As OlapInfoCube
[C#]
public OlapInfoCube Current {get;}
[C++]
public: __property OlapInfoCube* get_Current();
[JScript]
public function get Current() : OlapInfoCube;
Property Value

The OlapInfoCube in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last OlapInfoCube in the OlapInfoCubeCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection.Enumerator Structure | OlapInfoCubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

OlapInfoCubeCollection.Enumerator Structure | OlapInfoCubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator Methods

The methods of the OlapInfoCubeCollection.Enumerator structure are listed here. For a complete list of OlapInfoCubeCollection.Enumerator structure members, see OlapInfoCubeCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns a Type for the current instance.
public method MoveNext | Moves to the next OlapInfoCube in the OlapInfoCubeCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoCube in the OlapInfoCubeCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoCubeCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator.MoveNext Method

Moves to the next OlapInfoCube of the OlapInfoCubeCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection.Enumerator Structure | OlapInfoCubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoCubeCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first OlapInfoCube in the OlapInfoCubeCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoCubeCollection.Enumerator Structure | OlapInfoCubeCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchy Class

Represents metadata of a hierarchy that is contained in an instance of a CellSet class.

For a list of all members of this type, see OlapInfoHierarchy Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoHierarchy

[Visual Basic]
NotInheritable Public Class OlapInfoHierarchy
[C#]
public sealed class OlapInfoHierarchy
[C++]
public __gc __sealed class OlapInfoHierarchy
[JScript]
public class OlapInfoHierarchy
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoHierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchy Members

OlapInfoHierarchy Class

Public Properties

public property HierarchyProperties | Gets an OlapInfoPropertyCollection that represents metadata pertaining to the hierarchy properties that are associated with the OlapInfoHierarchy.
public property Name | Gets a String that represents the name of the OlapInfoHierarchy.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoHierarchy Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchy Properties

The properties of the OlapInfoHierarchy class are listed here. For a complete list of OlapInfoHierarchy class members, see OlapInfoHierarchy Members.

Public Properties

public property HierarchyProperties | Gets an OlapInfoPropertyCollection that represents metadata pertaining to the hierarchy properties that are associated with the OlapInfoHierarchy.
public property Name | Gets a String that represents the name of the OlapInfoHierarchy.

See Also

OlapInfoHierarchy Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchy.HierarchyProperties Property

Gets an OlapInfoPropertyCollection that represents metadata pertaining to the hierarchy properties that are associated with the OlapInfoHierarchy.

[Visual Basic]
Public ReadOnly Property HierarchyProperties As _
   OlapInfoPropertyCollection
[C#]
public OlapInfoPropertyCollection HierarchyProperties {get;}
[C++]
public: __property OlapInfoPropertyCollection*
   get_HierarchyProperties();
[JScript]
public function get HierarchyProperties() :
   OlapInfoPropertyCollection;
Property Value

An OlapInfoPropertyCollection that represents metadata pertaining to the hierarchy properties that are associated with the OlapInfoHierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchy Class | OlapInfoHierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchy.Name Property

Gets a String that represents the name of the hierarchy.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that represents the name of the hierarchy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchy Class | OlapInfoHierarchy Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection Class

Gets a read-only, on-demand collection of OlapInfoHierarchy objects.

For a list of all members of this type, see OlapInfoHierarchyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoHierarchyCollection

[Visual Basic]
NotInheritable Public Class OlapInfoHierarchyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class OlapInfoHierarchyCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class OlapInfoHierarchyCollection : public
   ICollection, IEnumerable
[JScript]
public class OlapInfoHierarchyCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection Members

OlapInfoHierarchyCollection Class

Public Properties

public property Count | Gets the number of OlapInfoHierarchy objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoHierarchy from the collection. In C#, this property is the indexer for the OlapInfoHierarchyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoHierarchy from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoHierarchyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection Properties

The properties of the OlapInfoHierarchyCollection class are listed here. For a complete list of OlapInfoHierarchyCollection class members, see OlapInfoHierarchyCollection Members.

Public Properties

public property Count | Gets the number of OlapInfoHierarchy objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoHierarchy from the collection. In C#, this property is the indexer for the OlapInfoHierarchyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OlapInfoHierarchyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Count Property

Gets the number of OlapInfoHierarchy objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

Gets the number of OlapInfoHierarchy objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Item Property

Gets the specified OlapInfoHierarchy from the collection.

[C#] In C#, this property is the indexer for the OlapInfoHierarchyCollection class.

Overload List

Gets the specified OlapInfoHierarchy from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As OlapInfoHierarchy
[C#] public OlapInfoHierarchy this[System.Int32] {get;}
[C++] public: __property OlapInfoHierarchy* get_Item(System.Int32);
[JScript] OlapInfoHierarchyCollection.Item (System.Int32)

Gets the specified OlapInfoHierarchy from the collection by its name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As OlapInfoHierarchy
[C#] public OlapInfoHierarchy this[System.String] {get;}
[C++] public: __property OlapInfoHierarchy* get_Item(System.String);
[JScript] OlapInfoHierarchyCollection.Item (System.String)
See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Item Property (System.Int32)

Gets the specified OlapInfoHierarchy from the collection by its index.

[C#] In C#, this property is the indexer for the OlapInfoHierarchyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As OlapInfoHierarchy
[C#]
public OlapInfoHierarchy this[
   int index
] {get;}
[C++]
public: __property OlapInfoHierarchy* get_Item(
   int index
);
[JScript]
returnValue = OlapInfoHierarchyCollectionObject.Item(index);
-or-
returnValue = OlapInfoHierarchyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the OlapInfoHierarchy to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the OlapInfoHierarchy to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoHierarchyCollection.Item Overload List


OlapInfoHierarchyCollection.Item Property (System.String)

Gets the specified OlapInfoHierarchy from the collection by its name.

[C#] In C#, this property is the indexer for the OlapInfoHierarchyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal name As String _
) As OlapInfoHierarchy
[C#]
public OlapInfoHierarchy this[
   string name
] {get;}
[C++]
public: __property OlapInfoHierarchy* get_Item(
   String* name
);
[JScript]
returnValue = OlapInfoHierarchyCollectionObject.Item(name);
-or-
returnValue = OlapInfoHierarchyCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
name
The name of the OlapInfoHierarchy to find.
Parameters [Visual Basic, C#, C++]
name
The name of the OlapInfoHierarchy to find.
Exceptions

Exception type | Condition
InvalidOperationException | The specified member does not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoHierarchyCollection.Item Overload List


OlapInfoHierarchyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection Methods

The methods of the OlapInfoHierarchyCollection class are listed here. For a complete list of OlapInfoHierarchyCollection class members, see OlapInfoHierarchyCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoHierarchy from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoHierarchyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OlapInfoHierarchy, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OlapInfoHierarchy[] array,
   int index
);
[C++]
public: void CopyTo(
   OlapInfoHierarchy* array[],
   int index
);
[JScript]
public function CopyTo(
   array : OlapInfoHierarchy[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Find Method

Gets the specified OlapInfoHierarchy from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As OlapInfoHierarchy
[C#]
public OlapInfoHierarchy Find(
   string name
);
[C++]
public: OlapInfoHierarchy* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : OlapInfoHierarchy;
Parameters
name
The name of the OlapInfoHierarchy to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.GetEnumerator Method

Gets an instance of the Enumerator class for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

OlapInfoHierarchyCollection Class | OlapInfoHierarchyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator Structure

Supports iterating over an OlapInfoHierarchyCollection and reading its individual OlapInfoHierarchy objects.

For a list of all members of this type, see OlapInfoHierarchyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.OlapInfoHierarchyCollection.Enumerator

[Visual Basic]
Public Structure OlapInfoHierarchyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct OlapInfoHierarchyCollection.Enumerator : IEnumerator
[C++]
public __value struct OlapInfoHierarchyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoHierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator Members

OlapInfoHierarchyCollection.Enumerator Structure

Public Properties

public property Current Gets the current OlapInfoHierarchy in the OlapInfoHierarchyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoHierarchy in the OlapInfoHierarchyCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoHierarchy in the OlapInfoHierarchyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoHierarchyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator Properties

The properties of the OlapInfoHierarchyCollection.Enumerator structure are listed here. For a complete list of OlapInfoHierarchyCollection.Enumerator structure members, see OlapInfoHierarchyCollection.Enumerator Members.

Public Properties

public property Current Gets the current OlapInfoHierarchy in the OlapInfoHierarchyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoHierarchyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator.Current Property

Gets the current OlapInfoHierarchy in the OlapInfoHierarchyCollection.

[Visual Basic]
Public ReadOnly Property Current As OlapInfoHierarchy
[C#]
public OlapInfoHierarchy Current {get;}
[C++]
public: __property OlapInfoHierarchy* get_Current();
[JScript]
public function get Current() : OlapInfoHierarchy;
Property Value

The OlapInfoHierarchy in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last OlapInfoHierarchy in the OlapInfoHierarchyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection.Enumerator Structure | OlapInfoHierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

OlapInfoHierarchyCollection.Enumerator Structure | OlapInfoHierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator Methods

The methods of the OlapInfoHierarchyCollection.Enumerator structure are listed here. For a complete list of OlapInfoHierarchyCollection.Enumerator structure members, see OlapInfoHierarchyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoHierarchy in the OlapInfoHierarchyCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoHierarchy in the OlapInfoHierarchyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoHierarchyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator.MoveNext Method

Moves to the next OlapInfoHierarchy in the OlapInfoHierarchyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection.Enumerator Structure | OlapInfoHierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoHierarchyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first OlapInfoHierarchy in the OlapInfoHierarchyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoHierarchyCollection.Enumerator Structure | OlapInfoHierarchyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoProperty Class

Represents metadata pertaining to hierarchy, cell, and cube objects that are contained in an OlapInfoProperty.

For a list of all members of this type, see OlapInfoProperty Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoProperty

[Visual Basic]
NotInheritable Public Class OlapInfoProperty
[C#]
public sealed class OlapInfoProperty
[C++]
public __gc __sealed class OlapInfoProperty
[JScript]
public class OlapInfoProperty
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoProperty Members

OlapInfoProperty Class

Public Properties

public property Name | Gets a String that represents the name of the object that the OlapInfoProperty represents.
public property Namespace | Gets a String that represents the namespace of the object that the OlapInfoProperty represents.
public property Type | Gets a Type that represents the type of the object that the OlapInfoProperty represents.

Public Methods

public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instances.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoProperty Properties

The properties of the OlapInfoProperty class are listed here. For a complete list of OlapInfoProperty class members, see OlapInfoProperty Members.

Public Properties

public property Name | Gets a String that represents the name of the object that the OlapInfoProperty represents.
public property Namespace | Gets a String that represents the namespace of the object that the OlapInfoProperty represents.
public property Type | Gets a Type that represents the type of the object that the OlapInfoProperty represents.

See Also

OlapInfoProperty Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoProperty.Name Property

Gets a String that represents the name of the property that the OlapInfoProperty represents.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String that represents the name of the property that the OlapInfoProperty represents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoProperty Class | OlapInfoProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoProperty.Namespace Property

Gets a String that represents the namespace of the property that the OlapInfoProperty represents.

[Visual Basic]
Public ReadOnly Property Namespace As String
[C#]
public string Namespace {get;}
[C++]
public: __property String* get_Namespace();
[JScript]
public function get Namespace() : String;
Property Value

A String that represents the namespace of the property that the OlapInfoProperty represents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoProperty Class | OlapInfoProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoProperty.Type Property

Gets a Type that represents the type of the property that the OlapInfoProperty represents.

[Visual Basic]
Public ReadOnly Property Type As Type
[C#]
public Type Type {get;}
[C++]
public: __property Type* get_Type();
[JScript]
public function get Type() : Type;
Property Value

A Type that represents the type of the property that the OlapInfoProperty represents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoProperty Class | OlapInfoProperty Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection Class

Gets a read-only, on-demand collection of OlapInfoProperty objects.

For a list of all members of this type, see OlapInfoPropertyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.OlapInfoPropertyCollection

[Visual Basic]
NotInheritable Public Class OlapInfoPropertyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class OlapInfoPropertyCollection : ICollection,
   IEnumerable
[C++]
public __gc __sealed class OlapInfoPropertyCollection : public
   ICollection, IEnumerable
[JScript]
public class OlapInfoPropertyCollection implements ICollection,
   IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection Members

OlapInfoPropertyCollection Class

Public Properties

public property Count | Gets the number of OlapInfoProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoProperty from the collection. In C#, this property is the indexer for the OlapInfoPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection Properties

The properties of the OlapInfoPropertyCollection class are listed here. For a complete list of OlapInfoPropertyCollection class members, see OlapInfoPropertyCollection Members.

Public Properties

public property Count | Gets the number of OlapInfoProperty objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified OlapInfoProperty from the collection. In C#, this property is the indexer for the OlapInfoPropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OlapInfoPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Count Property

Gets the number of OlapInfoProperty objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

Gets the number of OlapInfoProperty objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Item Property

Gets the specified OlapInfoProperty from the collection.

[C#] In C#, this property is the indexer for the OlapInfoPropertyCollection class.

Overload List

Gets the specified OlapInfoProperty from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As OlapInfoProperty
[C#] public OlapInfoProperty this[System.Int32] {get;}
[C++] public: __property OlapInfoProperty* get_Item(System.Int32);
[JScript] OlapInfoPropertyCollection.Item (System.Int32)

Gets the specified OlapInfoProperty from the collection by its name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As OlapInfoProperty
[C#] public OlapInfoProperty this[System.String] {get;}
[C++] public: __property OlapInfoProperty* get_Item(System.String);
[JScript] OlapInfoPropertyCollection.Item (System.String)
See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Item Property (System.Int32)

Gets the specified OlapInfoProperty from the collection by its index.

[C#] In C#, this property is the indexer for the OlapInfoPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As OlapInfoProperty
[C#]
public OlapInfoProperty this[
   int index
] {get;}
[C++]
public: __property OlapInfoProperty* get_Item(
   int index
);
[JScript]
returnValue = OlapInfoPropertyCollectionObject.Item(index);
-or-
returnValue = OlapInfoPropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the OlapInfoProperty to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the OlapInfoProperty to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoPropertyCollection.Item Overload List


OlapInfoPropertyCollection.Item Property (System.String)

Gets the specified OlapInfoProperty from the collection by its name.

Note If more than one property exists with the same name in the underlying schema, the first property with a matching name is returned.

[C#] In C#, this property is the indexer for the OlapInfoPropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal name As String _
) As OlapInfoProperty
[C#]
public OlapInfoProperty this[
   string name
] {get;}
[C++]
public: __property OlapInfoProperty* get_Item(
   String* name
);
[JScript]
returnValue = OlapInfoPropertyCollectionObject.Item(name);
-or-
returnValue = OlapInfoPropertyCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
name
The name of the OlapInfoProperty to find.
Parameters [Visual Basic, C#, C++]
name
The name of the OlapInfoProperty to find.
Exceptions

Exception type | Condition
InvalidOperationException | The specified member does not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | OlapInfoPropertyCollection.Item Overload List


OlapInfoPropertyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection Methods

The methods of the OlapInfoPropertyCollection class are listed here. For a complete list of OlapInfoPropertyCollection class members, see OlapInfoPropertyCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Returns the specified OlapInfoProperty from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoPropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OlapInfoHierarchy, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OlapInfoHierarchy[] array,
   int index
);
[C++]
public: void CopyTo(
   OlapInfoHierarchy* array[],
   int index
);
[JScript]
public function CopyTo(
   array : OlapInfoHierarchy[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Find Method

Gets the specified OlapInfoProperty from the collection by its name.

Note If more than one property exists with the same name in the underlying schema, the first property with a matching name is returned.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As OlapInfoProperty
[C#]
public OlapInfoProperty Find(
   string name
);
[C++]
public: OlapInfoProperty* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : OlapInfoProperty;
Parameters
name
The name of the OlapInfoProperty to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.GetEnumerator Method

Gets an instance of the Enumerator class for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

OlapInfoPropertyCollection Class | OlapInfoPropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator Structure

Supports iterating over an OlapInfoPropertyCollection and reading its individual OlapInfoProperty objects.

For a list of all members of this type, see OlapInfoPropertyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.OlapInfoPropertyCollection.Enumerator

[Visual Basic]
Public Structure OlapInfoPropertyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct OlapInfoPropertyCollection.Enumerator : IEnumerator
[C++]
public __value struct OlapInfoPropertyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

OlapInfoPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator Members

OlapInfoPropertyCollection.Enumerator Structure

Public Properties

public property Current Gets the current OlapInfoProperty in the OlapInfoPropertyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoProperty in the OlapInfoPropertyCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoProperty in the OlapInfoPropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator Properties

The properties of the OlapInfoPropertyCollection.Enumerator structure are listed here. For a complete list of OlapInfoPropertyCollection.Enumerator structure members, see OlapInfoPropertyCollection.Enumerator Members.

Public Properties

public property Current Gets the current OlapInfoProperty in the OlapInfoPropertyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

OlapInfoPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator.Current Property

Gets the current OlapInfoProperty in the OlapInfoPropertyCollection.

[Visual Basic]
Public ReadOnly Property Current As OlapInfoProperty
[C#]
public OlapInfoProperty Current {get;}
[C++]
public: __property OlapInfoProperty* get_Current();
[JScript]
public function get Current() : OlapInfoProperty;
Property Value

The OlapInfoProperty in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last OlapInfoProperty in the OlapInfoPropertyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection.Enumerator Structure | OlapInfoPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

OlapInfoPropertyCollection.Enumerator Structure | OlapInfoPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator Methods

The methods of the OlapInfoPropertyCollection.Enumerator structure are listed here. For a complete list of OlapInfoPropertyCollection.Enumerator structure members, see OlapInfoPropertyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next OlapInfoProperty in the OlapInfoPropertyCollection.
public method Reset | Moves the enumerator to a position before the first OlapInfoProperty in the OlapInfoPropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String value that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

OlapInfoPropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator.MoveNext Method

Moves to the next OlapInfoProperty in the OlapInfoPropertyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection.Enumerator Structure | OlapInfoPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


OlapInfoPropertyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first OlapInfoProperty in the OlapInfoPropertyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

OlapInfoPropertyCollection.Enumerator Structure | OlapInfoPropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position Class

Represents a tuple reference contained by an Axis.

For a complete list of Position class members, see Position Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Position

[Visual Basic]
NotInheritable Public Class Position
[C#]
public sealed class Position
[C++]
public __gc __sealed class Position
[JScript]
public class Position
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A Position encapsulates tuple references within the axis of a cellset. Use the Position to represent tuples for display purposes when displaying a cellset.

Note The Position is available primarily for backward compatibility. The Position represents a coordinate along the axis that contains it. Each Position on the axis has a corresponding Tuple in the Set contained by that axis. We recommend the Tuple instead of the Position, in most cases.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position Members

Position Class

Public Properties

public property Members | Gets a MemberCollection that contains the members of the Position.
public property Ordinal | Gets the ordinal position of the Position.

Public Methods

public method Equals | Determines whether two instances of Object are equal.
public method GetHashCode | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Position are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Position are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Position Class | Microsoft.AnalysisServices.AdomdClient Namespace


Position Properties

The properties of the Position class are listed here. For a complete list of Position class members, see Position Members.

Public Properties

public property Members | Gets a MemberCollection that contains the members of the Position.
public property Ordinal | Gets the ordinal position of the Position.

See Also

Position Class | Microsoft.AnalysisServices.AdomdClient Namespace


Position.Members Property

Gets an instance of the MemberCollection class that contains the members of the Position.

[Visual Basic]
Public ReadOnly Property Members As MemberCollection
[C#]
public MemberCollection Members {get;}
[C++]
public: __property MemberCollection* get_Members();
[JScript]
public function get Members() : MemberCollection;
Property Value

A MemberCollection that contains the members of the Position. The combination of members contained in the MemberCollection class define the tuple represented by the Position.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Position Class | Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position.Ordinal Property

Gets the ordinal position of the Position.

[Visual Basic]
Public ReadOnly Property Ordinal As Integer
[C#]
public int Ordinal {get;}
[C++]
public: __property int get_Ordinal();
[JScript]
public function get Ordinal() : int;
Property Value

An Integer that contains the ordinal position of the Position.

Remarks

This property returns the ordinal position of the Position within a PositionCollection, referenced from an Axis by using the Positions property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Position Class | Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position Methods

The methods of the Position class are listed here. For a complete list of Position class members, see the Position Members topic.

Public Methods

public method Equals | Determines whether two instances of Object are equal.
public method GetHashCode | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Position Class | Microsoft.AnalysisServices.AdomdClient Namespace


Position.Equals Method

Determines whether two instances of Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Position.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Position Class | Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Position Class | Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position Operators

The operators of the Position class are listed here. For a complete list of Position class members, see Position Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Position are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Position are unequal.

See Also

Position Class | Microsoft.AnalysisServices.AdomdClient Namespace


Position Equality Operator

Determines whether two specified instances of Position are equal.

[Visual Basic]
returnValue = Position.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Position o1,
   Position o2
);
[C++]
public: static bool op_Equality(
   Position* o1,
   Position* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A Position.
o2
A Position.
Parameters [C#, C++]
o1
A Position.
o2
A Position.
Return Value

true if o1 and o2 represent the same Position; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Position Class | Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


Position Inequality Operator

Determines whether two specified instances of Position are unequal.

[Visual Basic]
returnValue = Position.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Position o1,
   Position o2
);
[C++]
public: static bool op_Inequality(
   Position* o1,
   Position* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A Position.
o2
A Position.
Parameters [C#, C++]
o1
A Position.
o2
A Position.
Return Value

true if o1 and o2 do not represent the same Position; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Position Class | Position Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection Class

Gets a read-only collection of Position objects contained by an Axis object.

For a complete list of PositionCollection class members, see PositionCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.PositionCollection

[Visual Basic]
NotInheritable Public Class PositionCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class PositionCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class PositionCollection : public ICollection,
   IEnumerable
[JScript]
public class PositionCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection Members

PositionCollection Class

Public Properties

public property Count | Gets the number of Position objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Gets the specified Position from the collection. In C#, this property is the indexer for the PositionCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified Array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

PositionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection Properties

The properties of the PositionCollection class are listed here. For a complete list of PositionCollection class members, see PositionCollection Members.

Public Properties

public property Count | Gets the number of Position objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Gets the specified Position from the collection. In C#, this property is the indexer for the PositionCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

PositionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Count Property

Gets the number of Position objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of Position objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Item Property

Gets the specified Position from the collection by its index.

[C#] In C#, this property is the indexer for the PositionCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Position
[C#]
public Position this[
   int index
] {get;}
[C++]
public: __property Position* get_Item(
   int index
);
[JScript]
returnValue = PositionCollectionObject.Item(index);
-or-
returnValue = PositionCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Position to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Position to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.SyncRoot Property

Gets an Object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An Object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection Methods

The methods of the PositionCollection class are listed here. For a complete list of PositionCollection class members, see PositionCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified Array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

PositionCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.CopyTo Method

Copies the elements of the collection to the specified Array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Position, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Position[] array,
   int index
);
[C++]
public: void CopyTo(
   Position* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Position[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

PositionCollection Class | PositionCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator Structure

Supports iterating over a PositionCollection and reading its individual positions.

For a list of all members of this type, see PositionCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.PositionCollection.Enumerator

[Visual Basic]
Public Structure PositionCollection.Enumerator
   Implements IEnumerator
[C#]
public struct PositionCollection.Enumerator : IEnumerator
[C++]
public __value struct PositionCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

PositionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator Members

PositionCollection.Enumerator Structure

Public Properties

public property Current Gets the current position in the PositionCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next position of the PositionCollection.
public method Reset | Moves the enumerator to a position before the first position of the PositionCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

PositionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator Properties

The properties of the PositionCollection.Enumerator structure are listed here. For a complete list of PositionCollection.Enumerator structure members, see PositionCollection.Enumerator Members.

Public Properties

public property Current Gets the current position in the PositionCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

PositionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator.Current Property

Gets the current position in the PositionCollection.

[Visual Basic]
Public ReadOnly Property Current As Position
[C#]
public Position Current {get;}
[C++]
public: __property Position* get_Current();
[JScript]
public function get Current() : Position;
Property Value

The position in the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last position of the PositionCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection.Enumerator Structure | PositionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

PositionCollection.Enumerator Structure | PositionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator Methods

The methods of the PositionCollection.Enumerator structure are listed here. For a complete list of PositionCollection.Enumerator structure members, see PositionCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next position of the PositionCollection.
public method Reset | Moves the enumerator to a position before the first position of the PositionCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

PositionCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator.MoveNext Method

Moves to the next position of the PositionCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection.Enumerator Structure | PositionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PositionCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first position of the PositionCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PositionCollection.Enumerator Structure | PositionCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property Class

Represents a property of various ADOMD.NET objects.

For a list of all members of this type, see Property Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Property

[Visual Basic]
NotInheritable Public Class Property
[C#]
public sealed class Property
[C++]
public __gc __sealed class Property
[JScript]
public class Property
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property Members

Property Class

Public Properties

public property Name | Gets a String representing the name of the Property.
public property Type | Gets a Type representing the type of the Property.
public property Value | Gets an Object representing the value of the Property.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of the Property are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of the Property are not equal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Property Class | Microsoft.AnalysisServices.AdomdClient Namespace


Property Properties

The properties of the Property class are listed here. For a complete list of Property class members, see Property Members.

Public Properties

public property Name | Gets a String representing the name of the Property.
public property Type | Gets a Type representing the type of the Property.
public property Value | Gets an Object representing the value of the Property.

See Also

Property Class | Microsoft.AnalysisServices.AdomdClient Namespace


Property.Name Property

Gets a String representing the name of the Property.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;
Property Value

A String representing the name of the Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property.Type Property

Gets a Type representing the type of the Property.

[Visual Basic]
Public ReadOnly Property Type As Type
[C#]
public Type Type {get;}
[C++]
public: __property Type* get_Type();
[JScript]
public function get Type() : Type;
Property Value

A Type representing the type of the Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property.Value Property

Gets an Object representing the value of the Property.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;
Property Value

An Object representing the value of the Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property Methods

The methods of the Property class are listed here. For a complete list of Property class members, see Property Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString | Overridden. Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Property Class | Microsoft.AnalysisServices.AdomdClient Namespace


Property.Equals Method

Determines whether two instances of an Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Cell.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property.ToString Method

Returns a String that represents the current Property.

[Visual Basic]
Public Overrides Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString() : String;
Return Value

A String that represents the current Property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property Operators

The operators of the Property class are listed here. For a complete list of Property class members, see Property Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of the Property are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of the Property are not equal.

See Also

Property Class | Microsoft.AnalysisServices.AdomdClient Namespace


Property Equality Operator

Determines whether two specified instances of the Property are equal.

[Visual Basic]
returnValue = Property.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Property o1,
   Property o2
);
[C++]
public: static bool op_Equality(
   Property* o1,
   Property* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A Property.
o2
A Property.
Parameters [C#, C++]
o1
A Property.
o2
A Property.
Return Value

true if o1 and o2 represent the same Property; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


Property Inequality Operator

Determines whether two specified instances of the Property are not equal.

[Visual Basic]
returnValue = Property.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Property o1,
   Property o2
);
[C++]
public: static bool op_Inequality(
   Property* o1,
   Property* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A Property.
o2
A Property.
Parameters [C#, C++]
o1
A Property.
o2
A Property.
Return Value

true if o1 and o2 does not represent the same Property; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Property Class | Property Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection Class

Gets a read-only, on-demand collection of Property objects.

For a list of all members of this type, see PropertyCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.PropertyCollection

[Visual Basic]
NotInheritable Public Class PropertyCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class PropertyCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class PropertyCollection : public ICollection,
   IEnumerable
[JScript]
public class PropertyCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection Members

PropertyCollection Class

Public Properties

public property Count | Gets the number of Property objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Cell from the collection. In C#, this property is the indexer for the PropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two Object instances are equal.
public method Find | Returns the specified Property from the collection.
public method GetEnumerator | Gets an instance of the Enumerator class for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns a Type for the current Object.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

PropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection Properties

The properties of the PropertyCollection class are listed here. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Properties

public property Count | Gets the number of Property objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Cell from the collection. In C#, this property is the indexer for the PropertyCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

PropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Count Property

Gets the number of Property objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer  Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

The number of Property objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

true if access to the PropertyCollection is synchronized (thread safe), false otherwise.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Item Property

Gets the specified Property from the collection.

[C#] In C#, this property is the indexer for the PropertyCollection class.

Overload List

Gets the specified Property from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As Property
[C#] public Property this[System.Int32] {get;}
[C++] public: __property Property* get_Item(System.Int32);
[JScript] PropertyCollection.Item (System.Int32)

Gets the specified Property from the collection by its name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As Property
[C#] public Property this[System.String] {get;}
[C++] public: __property Property* get_Item(System.String);
[JScript] PropertyCollection.Item (System.String)
See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Item Property (System.Int32)

Gets the specified Dimension from the collection by its index.

[C#] In C#, this property is the indexer for the PropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Property
[C#]
public Property this[
   int index
] {get;}
[C++]
public: __property Property* get_Item(
   int index
);
[JScript]
returnValue = PropertyCollectionObject.Item(index);
-or-
returnValue = PropertyCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Property to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Property to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | PropertyCollection.Item Overload List


PropertyCollection.Item Property (System.String)

Gets the specified Property from the collection by its name.

[C#] In C#, this property is the indexer for the PropertyCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal name As String _
) As Property
[C#]
public Property this[
   string name
] {get;}
[C++]
public: __property Property* get_Item(
   String* name
);
[JScript]
returnValue = PropertyCollectionObject.Item(name);
-or-
returnValue = PropertyCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
name
The name of the Property to find.
Parameters [Visual Basic, C#, C++]
name
The name of the Property to find.
Exceptions

Exception type | Condition
InvalidOperationException | The specified member does not exist in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | PropertyCollection.Item Overload List


PropertyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object  Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection Methods

The methods of the PropertyCollection class are listed here. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two Object instances are equal.
public method Find | Returns the specified Property from the collection.
public method GetEnumerator | Gets an instance of the Enumerator class for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns a Type for the current Object.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

PropertyCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Property, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Property[] array,
   int index
);
[C++]
public: void CopyTo(
   Property* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Property[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Find Method

Gets the specified Property from the collection by its name.

[Visual Basic]
Public Function Find( _
   ByVal name As String _
) As Property
[C#]
public Property Find(
   string name
);
[C++]
public: Property* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : Property;
Parameters
name
The name of the Property to find.
Remarks

If the object is not found, the Find method returns null, whereas the Item property throws an exception.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.GetEnumerator Method

Gets an instance of the Enumerator class for iterating through the collection.

[Visual Basic]
Public Function GetEnumerator() As Enumerator
[C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

PropertyCollection Class | PropertyCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator Structure

Supports iterating over a PropertyCollection and reading its individual properties.

For a list of all members of this type, see PropertyCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.PropertyCollection.Enumerator

[Visual Basic]
Public Structure PropertyCollection.Enumerator
   Implements IEnumerator
[C#]
public struct PropertyCollection.Enumerator : IEnumerator
[C++]
public __value struct PropertyCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

PropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator Members

PropertyCollection.Enumerator Structure

Public Properties

public property Current Gets the current property in the PropertyCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next property of the PropertyCollection.
public method Reset | Moves the enumerator to a position before the first property of the PropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

PropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator Properties

The properties of the PropertyCollection.Enumerator structure are listed here. For a complete list of PropertyCollection.Enumerator structure members, see the PropertyCollection.Enumerator Members topic.

Public Properties

public property Current Gets the current property of the PropertyCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

PropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator.Current Property

Gets the current property of the PropertyCollection.

[Visual Basic]
Public ReadOnly Property Current As Property
[C#]
public Property Current {get;}
[C++]
public: __property Property* get_Current();
[JScript]
public function get Current() : Property;
Property Value

The property of the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last property of the PropertyCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection.Enumerator Structure | PropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

PropertyCollection.Enumerator Structure | PropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator Methods

The methods of the PropertyCollection.Enumerator structure are listed here. For a complete list of PropertyCollection.Enumerator structure members, see PropertyCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next property of the PropertyCollection.
public method Reset | Moves the enumerator to a position before the first property of the PropertyCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

PropertyCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator.MoveNext Method

Moves to the next property of the PropertyCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection.Enumerator Structure | PropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


PropertyCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first property of the PropertyCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

PropertyCollection.Enumerator Structure | PropertyCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


SchemaObjectType Enumeration

Represents the object type of an object retrieved by the GetSchemaObject method of the CubeDef.

[Visual Basic]
<Serializable>
Public Enum SchemaObjectType
[C#]
[Serializable]
public enum SchemaObjectType
[C++]
[Serializable]
__value public enum SchemaObjectType
[JScript]
public
   Serializable
enum SchemaObjectType
Remarks

This enumeration is used by the GetSchemaObject method of the CubeDef. For more information about using this enumeration, see GetSchemaObject Property.

Members

Member name | Description
ObjectTypeDimension | The object is a dimension.
ObjectTypeHierarchy | The object is a hierarchy.
ObjectTypeLevel | The object is a level.
ObjectTypeMeasure | The object is a measure.
ObjectTypeMember | The object is a member.
ObjectTypeNamedSet | The object is a named set.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Microsoft.AnalysisServices.AdomdClient Namespace


Set Class

Represents an ordered collection of zero or more tuples.

For a complete list of Set class members, see Set Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Set

[Visual Basic]
NotInheritable Public Class Set
[C#]
public sealed class Set
[C++]
public __gc __sealed class Set
[JScript]
public class Set
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A set is an ordered collection of zero or more tuples. A set is most commonly used to define axes in a multidimensional query. Like tuples, sets also have dimensionality. Because a set is composed of tuples, the dimensionality of a set is expressed by the dimensionality of each tuple within it. Therefore, tuples within a set must have the same dimensionality.

In ADOMD.NET, the Set class encapsulates the basic information used to define a set. The Set class is used primarily to represent an axis within the Axes collection of a CellSet. The dimensionality of a set is represented by the Hierarchies collection within the Set class, which identifies the nesting order of hierarchies within a given axis for a CellSet.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Set Members | Microsoft.AnalysisServices.AdomdClient Namespace


Set Members

Set Class

Public Properties

public property Hierarchies | Gets a reference to the HierarchyCollection that is referenced by the Set.
public property Tuples | Gets a reference to the TupleCollection that is referenced by the Set.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Set are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Set are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Set Class | Microsoft.AnalysisServices.AdomdClient Namespace


Set Properties

The properties of the Set class are listed here. For a complete list of Set class members, see Set Members.

Public Properties

public property Hierarchies | Gets a reference to the HierarchyCollection that is referenced by the Set.
public property Tuples | Gets a reference to the TupleCollection that is referenced by the Set.

See Also

Set Class | Microsoft.AnalysisServices.AdomdClient Namespace


Set.Hierarchies Property

Gets a reference to the HierarchyCollection collection referenced by the Set.

[Visual Basic]
Public ReadOnly Property Hierarchies As HierarchyCollection
[C#]
public HierarchyCollection Hierarchies {get;}
[C++]
public: __property HierarchyCollection* get_Hierarchies();
[JScript]
public function get Hierarchies() : HierarchyCollection;
Property Value

A HierarchyCollection.

Remarks

The Hierarchies property represents the hierarchies of the tuples included in the set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Set Class | Set Members | Hierarchies Class | Microsoft.AnalysisServices.AdomdClient Namespace


Set.Tuples Property

Gets a reference to the TupleCollection collection referenced by the Set.

[Visual Basic]
Public ReadOnly Property Tuples As TupleCollection
[C#]
public TupleCollection Tuples {get;}
[C++]
public: __property TupleCollection* get_Tuples();
[JScript]
public function get Tuples() : TupleCollection;
Property Value

A TupleCollection.

Remarks

The Tuples property represents the tuples the set contains.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Set Class | Set Members | TupleCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


Set Methods

The methods of the Set class are listed here. For a complete list of Set class members, see Set Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Set Class | Microsoft.AnalysisServices.AdomdClient Namespace


Set.Equals Method

Determines whether two instances of Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Cell.
Return Value

true if the two instances are equivalent; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Set Class | Set Members | Microsoft.AnalysisServices.AdomdClient Namespace


Set.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Set Class | Set Members | Microsoft.AnalysisServices.AdomdClient Namespace


Set Operators

The operators of the Set class are listed here. For a complete list of Set class members, see Set Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Set are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Set are unequal.

See Also

Set Class | Microsoft.AnalysisServices.AdomdClient Namespace


Set Equality Operator

Determines whether two specified instances of Set are equal.

[Visual Basic]
returnValue = Set.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Set o1,
   Set o2
);
[C++]
public: static bool op_Equality(
   Set* o1,
   Set* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A Set.
o2
A Set.
Parameters [C#, C++]
o1
A Set.
o2
A Set.
Return Value

true if o1 and o2 represent the same Set; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Set Class | Set Members | Microsoft.AnalysisServices.AdomdClient Namespace


Set Inequality Operator

Determines whether two specified instances of Set are unequal.

[Visual Basic]
returnValue = Set.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Set o1,
   Set o2
);
[C++]
public: static bool op_Inequality(
   Set* o1,
   Set* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [Visual Basic, JScript]
o1
A Set.
o2
A Set.
Parameters [C#, C++]
o1
A Set.
o2
A Set.
Return Value

true if o1 and o2 do not represent the same Set; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Set Class | Set Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Class

Represents an ordered collection of members from different hierarchies.

For a complete list of Tuple class members, see Tuple Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.Tuple

[Visual Basic]
NotInheritable Public Class Tuple
[C#]
public sealed class Tuple
[C++]
public __gc __sealed class Tuple
[JScript]
public class Tuple
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Remarks

A tuple consists of an ordered collection of members.

A tuple cannot contain more than one member from any single hierarchy.

In ADOMD.NET, a Tuple is used to represent a tuple by encapsulating the collection of Member objects that define the tuple. Tuple objects can be referenced only through the Tuples property of a Set.

Example
[Visual Basic]

The following function, given a Tuple, examines the object and returns a Multidimensional Expressions (MDX) string representation of the tuple:

Public Function GetTupleString(ByRef TupleToConvert As Tuple) As String
    If TupleToConvert Is Nothing Then
        Throw New System.ArgumentNullException("TupleToConvert")
    Else
        Dim tupleCount As Integer = TupleToConvert.Members.Count
        Dim tupleIndex As Integer = 0

        If tupleCount = 0 Then
            ' An empty tuple.
            Return "()"
        Else
            ' Iterate through each member in the Members collection,
            ' adding the value of the UniqueName property to a
            ' string.
            ' Because a tuple can represent many members, this
            ' example uses a StringBuilder object to improve
            ' string handling performance.
            Dim tupleString As New _
                System.Text.StringBuilder(15 * tupleCount)

            ' Tuples are framed with parentheses, with each member
            ' within a tuple separated by a comma.
            tupleString.Append("(")
            For tupleIndex = 0 To tupleCount - 1
                tupleString.Append( _
                TupleToConvert.Members(tupleIndex).UniqueName)
                If tupleIndex < (tupleCount - 1) Then
                    tupleString.Append(", ")
                End If
            Next
            tupleString.Append(")")

            Return tupleString.ToString
        End If
    End If
End Function
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Members

Tuple Class

Public Properties

public property Members | Gets a MemberCollection from the Tuple.
public property TupleOrdinal | Gets the ordinal position of the Tuple.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Tuple are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Tuple are unequal.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Tuple Class | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Properties

The properties of the Tuple class are listed here. For a complete list of Tuple class members, see Tuple Members.

Public Properties

public property Members | Gets a MemberCollection from the Tuple.
public property TupleOrdinal | Gets the ordinal position of the Tuple.

See Also

Tuple Class | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple.Members Property

Gets an instance of the MemberCollection class from the Tuple.

[Visual Basic]
Public ReadOnly Property Members As MemberCollection
[C#]
public MemberCollection Members {get;}
[C++]
public: __property MemberCollection* get_Members();
[JScript]
public function get Members() : MemberCollection;
Property Value

A MemberCollection that contains the members of the Tuple.

Remarks

A tuple represents a vector of members. A Tuple encapsulates the collection of Member objects that represent a particular tuple.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Tuple Class | Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple.TupleOrdinal Property

Gets the ordinal position of the Tuple.

[Visual Basic]
Public ReadOnly Property TupleOrdinal As Integer
[C#]
public int TupleOrdinal {get;}
[C++]
public: __property int get_TupleOrdinal();
[JScript]
public function get TupleOrdinal() : int;
Property Value

An Integer that contains the ordinal position of the Tuple.

Remarks

This property returns the ordinal position of the Tuple within a TupleCollection, referenced from a Set by using the Tuples property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Tuple Class | Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Methods

The methods of the Tuple class are listed here. For a complete list of Tuple class members, see Tuple Members.

Public Methods

public method Equals | Overridden. Determines whether two instances of Object are equal.
public method GetHashCode | Overridden. Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

Tuple Class | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple.Equals Method

Determines whether two instances of Object are equal.

[Visual Basic]
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;
Parameters
obj
An object of the same type as the Tuple.
Return Value

true if the two instances are equivalent; false otherwise.

Remarks

The Equals method, after verifying that obj is not null and that it is of the same type as the Tuple, compares the ordinal index (the value of the TupleOrdinal property) of obj with that of the Tuple. If the ordinal indexes are the same, the two instances are considered equivalent. This comparison is valid only within the scope of the parent Tuples property of a Set. Comparing two Tuple objects from different Tuples collections can yield unpredictable results.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Tuple Class | Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple.GetHashCode Method

Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.

[Visual Basic]
Public Overrides Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode();
[JScript]
public override function GetHashCode() : int;
Return Value

A 32-bit signed integer hash code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Tuple Class | Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Operators

The operators of the Tuple class are listed here. For a complete list of Tuple class members, see Tuple Members.

Public Operators

public operator static (Shared in Visual Basic) Equality Operator | Determines whether two specified instances of Tuple are equal.
public operator static (Shared in Visual Basic) Inequality Operator | Determines whether two specified instances of Tuple are unequal.

See Also

Tuple Class | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Equality Operator

Determines whether two specified instances of Tuple are equal.

[Visual Basic]
returnValue = Tuple.op_Equality(o1, o2)
[C#]
public static bool operator ==(
   Tuple o1,
   Tuple o2
);
[C++]
public: static bool op_Equality(
   Tuple* o1,
   Tuple* o2
);
[JScript]
returnValue = o1 == o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Tuple.
o2
A Tuple.
Parameters [Visual Basic, C#, C++]
o1
A Tuple.
o2
A Tuple.
Return Value

true if o1 and o2 represent the same Tuple; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Tuple Class | Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


Tuple Inequality Operator

Determines whether two specified instances of Tuple are not equal.

[Visual Basic]
returnValue = Tuple.op_Inequality(o1, o2)
[C#]
public static bool operator !=(
   Tuple o1,
   Tuple o2
);
[C++]
public: static bool op_Inequality(
   Tuple* o1,
   Tuple* o2
);
[JScript]
returnValue = o1 != o2;

[Visual Basic] In Visual Basic, you can use the operators defined by a type, but you cannot define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot define your own.

Arguments [JScript]
o1
A Tuple.
o2
A Tuple.
Parameters [Visual Basic, C#, C++]
o1
A Tuple.
o2
A Tuple.
Return Value

true if o1 and o2 do not represent the same Tuple; false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

Tuple Class | Tuple Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection Class

Gets a read-only collection of Tuple objects contained by a Set.

For a complete list of TupleCollection class members, see TupleCollection Members.

System.Object
Microsoft.AnalysisServices.AdomdClient.TupleCollection

[Visual Basic]
NotInheritable Public Class TupleCollection
   Implements ICollection, IEnumerable
[C#]
public sealed class TupleCollection : ICollection, IEnumerable
[C++]
public __gc __sealed class TupleCollection : public ICollection,
   IEnumerable
[JScript]
public class TupleCollection implements ICollection, IEnumerable
Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Example
[Visual Basic]

The following subroutine, given a CellSet and the total number of cells for which information should be displayed, iterates through the Cells collection and displays information for each cell:

Public Sub ListTupleCollection(ByRef AxisToCheck As Axis, _
    Optional ByVal Count As Integer = 10)

    ' Because a Set object can represent of thousands of tuples,
    ' the Count parameter limits the output to a
    ' specified number of cells.

    ' Check the parameter before performing actions on it.
    If AxisToCheck Is Nothing Then
        Throw New System.ArgumentNullException("AxisToCheck")
    Else
        ' Iterate through the Tuples collection of the
        ' Set object.
        Try
            Dim tupleToCheck As Tuple
            Dim tupleCount As Integer
            Dim tupleIndex As Integer

            tupleCount = AxisToCheck.Set.Tuples.Count

            Debug.WriteLine("Found " & tupleCount & _
                " tuple(s) in axis:")

            If tupleCount > Count Then tupleCount = Count
            If tupleCount > 0 Then
                For tupleIndex = 0 To tupleCount
                    tupleToCheck = AxisToCheck.Set.Tuples(tupleIndex)
                    Debug.WriteLine("Tuple: " & _
                        tupleToCheck.TupleOrdinal)
                    Debug.WriteLine("  No. of members:    " & _
                        tupleToCheck.Members.Count)
                Next
            End If
        Catch ex As AdomdConnectionException
            ' The connection could not be opened or was disconnected.
            ' This error can occur at any time, if the provider is
            ' disconnected from the server.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdErrorResponseException
            ' A response is received from a provider which indicates an error.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdUnknownResponseException
            ' A response has been returned from the provider that
            ' was not understood.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdCacheExpiredException
            ' A cached version of an ADOMD.NET object is no longer valid.
            ' This error is typically raised when reviewing meta data.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As AdomdException
            ' Any other error raised by ADOMD.NET.
            Debug.WriteLine(ex)
            Throw ex
        Catch ex As Exception
            ' Any other error.
            Debug.WriteLine(ex)
            Throw ex
        End Try
    End If
End Sub
Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection Members

TupleCollection Class

Public Properties

public property Count | Gets the number of Tuple objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Tuple from the collection. In C#, this property is the indexer for the TupleCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Gets the specified Tuple from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

TupleCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection Properties

The properties of the TupleCollection class are listed here. For a complete list of TupleCollection class members, see TupleCollection Members.

Public Properties

public property Count | Gets the number of Tuple objects in the collection.
public property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
public property Item | Overloaded. Gets the specified Tuple from the collection. In C#, this property is the indexer for the TupleCollection class.
public property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

TupleCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Count Property

Gets the number of Tuple objects in the collection.

[Visual Basic]
Public Overridable ReadOnly Property Count As Integer Implements _
   ICollection.Count
[C#]
public virtual int Count {get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;
Property Value

Gets the number of Tuple objects in the collection.

Implements

ICollection.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean  _
   Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;
Property Value

Always false.

Implements

ICollection.IsSynchronized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Item Property

Gets the specified Tuple from the collection.

[C#] In C#, this property is the indexer for the TupleCollection class.

Overload List

Gets the specified Tuple from the collection by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.Int32) As Tuple
[C#] public Tuple this[System.Int32] {get;}
[C++] public: __property Tuple* get_Item(System.Int32);
[JScript] TupleCollection.Item (System.Int32)

Gets the specified Tuple from the collection by its string index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(System.String) As Tuple
[C#] public Tuple this[System.String] {get;}
[C++] public: __property Tuple* get_Item(System.String);
[JScript] TupleCollection.Item (System.String)
See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Item Property

Gets the specified Tuple from the collection by its index.

[C#] In C#, this property is the indexer for the TupleCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Tuple

[C#]
public Tuple this[
   int index
] {get;}
[C++]
public: __property Tuple* get_Item(
   int index
);
[JScript]
returnValue = TupleCollectionObject.Item(index);
-or-
returnValue = TupleCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
The zero-based index of the Tuple to find.
Parameters [Visual Basic, C#, C++]
index
The zero-based index of the Tuple to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Item Property (System.String)

Gets the specified Tuple from the collection by its string index.

[C#] In C#, this property is the indexer for the TupleCollection class.

[Visual Basic]
Public Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Tuple
[C#]
public Tuple this[
   string index
] {get;}
[C++]
public: __property Tuple* get_Item(
   String* index
);
[JScript]
returnValue = TupleCollectionObject.Item(index);
-or-
returnValue = TupleCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

Arguments [JScript]
index
Name of the Tuple to find.
Parameters [Visual Basic, C#, C++]
index
Name of the Tuple to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace | TupleCollection.Item Overload List


TupleCollection.SyncRoot Property

Gets an Object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object Implements _
   _
   ICollection.SyncRoot
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;
Property Value

An Object that can be used to synchronize access to the collection.

Implements

ICollection.SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection Methods

The methods of the TupleCollection class are listed here. For a complete list of TupleCollection class members, see TupleCollection Members.

Public Methods

public method CopyTo | Copies the elements of the collection to the specified array.
public method Equals (inherited from System.Object) | Determines whether two instances of Object are equal.
public method Find | Gets the specified Tuple from the collection.
public method GetEnumerator | Gets an Enumerator for iterating through the collection.
public method GetHashCode (inherited from System.Object) | Serves as a hash function for a particular type, for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method ToString (inherited from System.Object) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

TupleCollection Class | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.CopyTo Method

Copies the elements of the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Tuple, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Tuple[] array,
   int index
);
[C++]
public: void CopyTo(
   Tuple* array[],
   int index
);
[JScript]
public function CopyTo(
   array : Tuple[],
   index : int
);
Parameters
array
An instance of a one-dimensional Array in which to copy the elements of the collection. The Array must have zero-based indexing.
index
The zero-based index at which to begin copying.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Find Method

Gets the specified Tuple from the collection.

[Visual Basic]
Public Function Find( _
   ByVal index As String _
) As Tuple
[C#]
public Tuple Find(
   string index
);
[C++]
public: Tuple* Find(
   String* index
);
[JScript]
public function Find(
   index : String
) : Tuple;
Parameters
index
The name of the Tuple to find.
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.GetEnumerator Method

Gets an Enumerator for iterating through the collection.

[Visual Basic]
Public Overrides Function GetEnumerator() As Enumerator
 [C#]
public Enumerator GetEnumerator();
[C++]
public: Enumerator GetEnumerator();
[JScript]
public function GetEnumerator() : Enumerator;
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code

See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.ICollection.CopyTo Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int index
);
[C++]
private: void ICollection::CopyTo(
   Array* array,
   int index
);
[JScript]
private function ICollection.CopyTo(
   array : Array,
   index : int
);
See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.IEnumerable.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private Function GetEnumerator() As IEnumerator Implements _
   IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();
[C++]
private: IEnumerator* IEnumerable::GetEnumerator();
[JScript]
private function IEnumerable.GetEnumerator() : IEnumerator;
See Also

TupleCollection Class | TupleCollection Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator Structure

Supports iterating over a TupleCollection and reading its individual tuples.

For a list of all members of this type, see TupleCollection.Enumerator Members.

System.Object
System.ValueType
Microsoft.AnalysisServices.AdomdClient.TupleCollection.Enumerator

[Visual Basic]
Public Structure TupleCollection.Enumerator
   Implements IEnumerator
[C#]
public struct TupleCollection.Enumerator : IEnumerator
[C++]
public __value struct TupleCollection.Enumerator : public
   IEnumerator

[JScript] In JScript, you can use the structures in the .NET Framework, but you cannot define your own.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe.

Requirements

Namespace: Microsoft.AnalysisServices.AdomdClient

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: Microsoft.Analysisservices.AdomdClient (in Microsoft.Analysisservices.AdomdClient.dll)

See Also

TupleCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator Members

TupleCollection.Enumerator Structure

Public Properties

public property Current Gets the current tuple of the TupleCollection.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two Object instances are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next tuple of the TupleCollection.
public method Reset | Moves the enumerator to a position before the first tuple of the TupleCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

TupleCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator Properties

The properties of the TupleCollection.Enumerator structure are listed here. For a complete list of TupleCollection.Enumerator structure members, see TupleCollection.Enumerator Members.

Public Properties

public property Current Gets the current tuple of the TupleCollection.

Explicit Interface Implementations

System.Collections.IEnumerator.Current Gets the current object in the collection.

See Also

TupleCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator.Current Property

Gets the current tuple of the TupleCollection.

[Visual Basic]
Public ReadOnly Property Current As Tuple
[C#]
public Tuple Current {get;}
[C++]
public: __property Tuple* get_Current();
[JScript]
public function get Current() : Tuple;
Property Value

The tuple of the collection, if the enumerator has not passed the end of the collection.

Exceptions

Exception type | Condition
InvalidOperationException | The enumerator is currently before the first or after the last tuple of the TupleCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection.Enumerator Structure | TupleCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator.System.Collections.IEnumerator.Current Property

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Private ReadOnly Property Current As Object Implements _
   IEnumerator.Current
[C#]
object IEnumerator.Current {get;}
[C++]
private: __property Object*
   System::Collections::IEnumerator::get_Current();
[JScript]
private function get IEnumerator.Current() : Object;
See Also

TupleCollection.Enumerator Structure | TupleCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator Methods

The methods of the TupleCollection.Enumerator structure are listed here. For a complete list of TupleCollection.Enumerator structure members, see TupleCollection.Enumerator Members.

Public Methods

public method Equals (inherited from System.ValueType) | Determines whether two instances of Object are equal.
public method GetHashCode (inherited from System.ValueType) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures such as hash tables.
public method GetType (inherited from System.Object) | Returns the Type of the current instance.
public method MoveNext | Moves to the next tuple of the TupleCollection object.
public method Reset | Moves the enumerator to a position before the first tuple of the TupleCollection.
public method ToString (inherited from System.ValueType) | Returns a String that represents the current Object.

Protected Methods

protected method Finalize (inherited from System.Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. In C# and C++, finalizers are expressed with destructor syntax.
protected method MemberwiseClone (inherited from System.Object) | Creates a shallow copy of the current Object.

See Also

TupleCollection.Enumerator Structure | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator.MoveNext Method

Moves to the next tuple of the TupleCollection.

[Visual Basic]
Public Overridable Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;
Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection.Enumerator Structure | TupleCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


TupleCollection.Enumerator.Reset Method

Moves the enumerator to a position before the first tuple of the TupleCollection.

[Visual Basic]
Public Overridable Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();
Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

.NET Framework Security: Full trust for the immediate caller. This member cannot be used by partially trusted code. For more information, see Using Libraries from Partially Trusted Code.

See Also

TupleCollection.Enumerator Structure | TupleCollection.Enumerator Members | Microsoft.AnalysisServices.AdomdClient Namespace


ADOMD.NET SDK Home Page

ADOMD.NET SDK

ADOMD.NET Home Page

ADOMD.NET SDK

Technical Support

  • Microsoft Product Support Services (PSS)
  • Microsoft SQL Server Support
  • Knowledge Base (KB) Search
  • Microsoft TechNet
  • Microsoft Windows Hardware Compatibility List

Microsoft Accessibility Website

White Papers

Web Links

  • Microsoft SQL Server Product Website
  • Microsoft SQL Server Developer Center
  • Professional Association for SQL Server
  • SQL Server Magazine
  • Microsoft Newsgroups
  • MSDN Online

Built on: 3/26/2004


ADMOD.NET SDK Topic Not Found

ADOMD.NET SDK

.NET Framework Reference

The link references a topic within the .NET Framework Reference. Please search for the topic in the .NET Framework Reference at http://msdn.microsoft.com/library/default.asp?url=/library/en-us/netstart/html/sdk_netstart.asp.

Click Back to return to the previous page.


ADMOD.NET SDK Topic Not Found

The link was unable to connect to a target page. Click Back to return to the previous page.