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Microsoft Excel version 2002 (included in Office XP)

Product Guide

Introduction

The Excel Product Guide is designed to assist in evaluating Microsoft Excel version 2002, included in the Office XP suite. It contains information on the new and improved capabilities of the application, examples of how you can access them, and in some instances screenshots of those new or improved capabilities.

For many people, Microsoft Excel continues to be the technology on which they rely on a daily basis. These users rely on Excel to access, process, analyze, share, and display the information with which they run their business. At the same time, Excel use is no longer relegated just to the accounting and finance departments. Everyday users need to access, analyze, create, and navigate through important data. With this in mind, Excel version 2002 was designed be an application that makes it even easier than before to access, connect, and analyze critical business data. At the same time, it gives everyday users the tools they need to get the most out of their data. 

Below is an overview of the key design goals for Excel version 202 and the new and improved functionality associated with those design goals. 

Key Design Goals and Overview of New Features 

Productivity and Efficiency

Working with spreadsheets is often a daunting task. If you’re a beginning user, it is often difficult to find the features you need to accomplish your task. If you’re an advanced user, there is often additional functionality that you would like to take advantage of that currently does not exist. A key design goal for Excel version 2002 was to provide both sets of users (and everyone in between) the tools they need to be more productive. Excel now gives novice and intermediate users more confidence in working with spreadsheets by making more of the existing functionality easier to discover as well as by providing more intelligence to help assure users that they are not making mistakes. For the advanced users, Excel focuses on making common tasks easier and more intuitive. 

	Feature
	Description
	How to Access

	Error Checking Smart Tag

[image: image2.png]NEW




	This feature alerts users via a Smart Tag of a possible error in a cell. Users can select a command to resolve the error, ignore it, or access further Error Checking options. 
	· Sum a column of cells, leaving out the last in the group.

· Hover over the cell containing the total and view error checking options.

	Function Argument Tooltips
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	Excel displays information about function arguments as users build a new formula. The Tooltips also provide a quick path to Help. Users simply click any function or argument name within the tooltip.
	· Example: Type in a formula in an Excel cell such as =npv(

· The tooltip appears. 
If you hover over a component of the formula, you can link to more help.

	Watch Window
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	Users can easily track results of multiple cells even when they are working on a different sheet or workbook. This prevents users from having to switch back and forth or scroll between sheets to keep track of important data. 
	· Select a cell to which you want to add a Watch.

· Right-click that cell and select Add Watch.


	Feature
	Description
	How to Access

	Speech
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	Users can easily dictate, navigate, and provide other commands using a microphone while working on their spreadsheets. Furthermore, Excel also supports text-to-speech, which enables Excel to read back values as part of checking a spreadsheet's contents. 

Note: Speech is currently available for U.S. English, Simplified Chinese, and Japanese.
	Speech Recognition:

· Ensure that Speech has been installed, and that you have trained the speech engine.

· From the Tools menu select Speech -> Speech Recognition.

· From the Speech toolbar select the mode you want and begin speaking.

Text To Speech:

· From the Tools menu select Speech -> Show Text To Speech Toolbar.

· Select the cells you would like spoken.

· Click the Speak Cells button on the Text To Speech toolbar.

	Formula Evaluator
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	Users can easily evaluate the calculations that make up their formula. This function allows users to step through each calculation to understand how Excel is calculating the result. 
	· Highlight the cell you want to evaluate.

· Open the Formula Auditing toolbar and click the Evaluate Formula button.

	Formula Auditing Toolbar
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	This toolbar provides users with a set of tools to link to auditing features such as the Formula Evaluator and the Watch Window. 
It also exposes other functionality such as toggling to display all formulas in the worksheet. 
	· Select View>Toolbars>
Formula Auditing Toolbar

	Excel Border Drawing
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	Using the border-drawing pencil, users can easily draw cell borders in their spreadsheet. Options include changing the line color, weight, and style or even adding a border grid to their sheet.
	· From the drop-down menu on the Border Drawing Button (Formatting toolbar), select Draw Borders.

· Use the pencil to draw the border you want.


	Feature
	Description
	How to Access

	Excel Alerts
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	Excel has improved the most common, frustrating, and confusing alerts. This includes rewording alerts to be more understandable, eliminating unnecessary alerts altogether, and adding functionality to make it easier to address the underlying problem. 
	· Alerts appear automatically. No action is required by the user

	Tab Colors
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	Users can keep their workbooks organized by color-coding their worksheet tabs. They can choose from a wide variety of colors with which to organize sections of a workbook. 
	· Right-click the Worksheet tab.

· Select the color you want to add.

	Link Management
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	Excel now provides richer feedback on links to other Excel workbooks. Users can check the status, fix, update, or even break the links easily and without having to sit through a lengthy updating process.


	· Select Links from the Edit menu.

· Update, fix, break, or check the status of your links.

	Range Finder
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	The Range Finder feature is enabled when a user creates a new formula or edits an existing formula. The Range Finder gives users better visual feedback for moving and resizing the Range Finder range. 
	· Sum a range of cells.

· Move the range finder (blue box surrounding range of cells) to another selection of cells.

	Extended AutoSum
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	The Extended AutoSum has more common functions added to the AutoSum tool. These include Average, Count, CountA, Max, and Min. It also has other enhancements such as providing a path to create any function from the AutoSum user interface (UI). 
	· On the Standard toolbar, drop down the AutoSum menu.

	Chart Data Labels
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	Improved Excel charting allows users more control over the content and formatting of their chart data labels. 
	· Highlight data in a spreadsheet and click the Charting icon.

· Choose to add data labels from step 3 of the Charting Wizard.

	Feature
	Description
	How to Access

	Function Wizard
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	Users can easily search for the function they need by choosing from the list of available functions. The Function Wizard also provides users with a way to access Help on any specific function. 
	· Select Function from the Insert menu or select the function button of the Standard toolbar.

	Narrow Column Tooltip
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	Excel now displays a tooltip that identifies the contents of a cell that contains "###" because the column is too narrow to display the number. 
	· Type in a large number in a narrow cell.

· Hover over the cell to see the value.

	Find and Replace
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	Users are provided with an enhanced user interface and functionality for the Find and Replace feature. Users can execute a single Find/Replace across all sheets in a workbook, reuse past searches, view a modeless UI, and find new elements such as formatting. 
	· Select Find from the Edit menu.

· Click the Replace tab to see additional options.

	Printing
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	Improved printing functionality automatically performs functions such as switching between Letter and A4 paper, autoscaling, and suppressing the printing of trailing blank pages and error values so that they don’t contain “#REF”. 
	· This functionality takes place automatically.

	Header/Footer
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	Pictures or drawings can now be inserted directly as headers or footers. 
	· Select Header and Footer from the View menu.

· Click Custom Footer.

	Cell Merging
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	With the Merge and Center button on the Formatting toolbar, users can unmerge a group of cells just as easily as they can merge a group of cells. It is possible to unmerge even if the Undo option is no longer available. 
	· Merge a group of cells together by highlighting those cells and clicking the Merge and Center button.

· Click the Merge and Center button again to undo the merge. 

	Sort Text as Numbers
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	This feature prevents unexpected sorting results by detecting mixed lists of numbers and text and enabling sorting text as numbers.
	· Sort a column that has both numbers and numbers formatted as text.

	Feature
	Description
	How to Access

	Prevent

Single-Column Sorting
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	This feature provides the same level of detection and feedback as the Sort tools on the toolbar to help prevent users from accidentally "breaking" a list by sorting a single column.
	· Sort a column that has data in the column next to it by selecting Sort from the Data menu.

· From the Sort dialog, select the option to sort columns simultaneously


Access to Important Information 

A second key goal for Excel version 2002 was to make working with data from the Web or from corporate databases simple. Today, accessing data from the Web or from corporate databases is often extremely difficult. In both cases, finding the information is often time consuming, and once it is found, it is often in a format that makes it difficult to use. Furthermore, while publishing data to the Web or to a corporate database is relatively simple, editing and republishing that data is often problematic. Excel version 2002 is designed to make it easy for anyone to share data with others, connect to important data on the Web or within an organization, and analyze that data to make better decisions.

	Feature
	Description
	How to Access

	Stock Quote Smart Tag
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	In previous versions, Excel recognized URLs and assigned links associated with these items. Users could activate the links by clicking them. Excel version 2002 extends this functionality by recognizing stock symbols as they are entered and providing users a Smart Tag icon. The Smart Tag allows users to access additional information on that stock from the Web or even insert into Excel a refreshable Web query of that stock information.
	· Make sure Smart Tags are turned on.

· Type in a stock symbol.

· Drop down the Smart Tag icon for available options.


	Feature
	Description
	How to Access

	Web Queries
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	Users can easily access, analyze, and refresh data from the Web right from within Excel. When information from the Web is copied into Excel, a Smart Tag appears, giving users the option to create a refreshable query. Once the data is brought into Excel from the Web, users can manually refresh the data or even identify how often Excel should automatically refresh the data. Users can also create these Web Queries by simply dragging and dropping a Web page into Excel.


	· Go up to any Web site and copy the information you want to analyze.

· Paste the information into Excel.

· Select Create Refreshable Web Query from the Smart Tag drop-down menu.

· Choose the table you want to import and click Import.

	Auto Republish
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	Saving Excel data to a Web page can occur automatically each time you save your Excel file. For example, if your file contains a range of data or a chart that you share with others on a Web page, each time you save your Excel file the Web page can be updated automatically. 
	· Save a spreadsheet (or entire workbook) as a Web Page (File> Save as Web Page).

· Click Publish.

· Check the AutoRepublish check box and choose Publish.

· Make a change to the spreadsheet and save.

· In the browser, click Refresh.

	Data Connection Wizard
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	The Data Connection Wizard takes the user through the process of connecting to an OLE DB data source and persisting the connection information in a Data Connection File. The Wizard can also edit the connection information in existing Data Connection files.
	· Select Open from the File menu.

· Open My Data Sources Folder.

· Double-click Connect to New Data Source.

	Office Data Connection Files
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	Data Connection Files, which are stored in a users My Data Sources folder, enable users to easily restore a connection to a data source without having to spend time searching for the connection.
	· Once you have connected to a new data source following the steps above, a Data Connection File is created.

· Open My Data Sources Folder and click the new data source.

	Feature
	Description
	How to Access

	Connection Directly to ActiveX Data Objects (ADO)

[image: image28.png]NEW




	The Spreadsheet Web Component can now directly connect to ActiveX® Data Objects (ADO), enabling users to analyze data from data sources such as SQL Server.
	

	Real-Time Data (RTD)
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	A new Real-Time Data function brings real-time data into Excel for analysis. 
	· Select the RTD function from the Insert Function dialog box.

· Insert the server name and real-time arguments you want to access.

	OLAP PivotTables
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	A variety of improvements have been made to OLAP PivotTable views, including the ability to create custom ad-hoc groups and get visual totals.
	· Select PivotTable and PivotChart Report from the Data menu.

· Select External Data Source and click Next.

· Select Get Data and then select your OLAP cube.

	Excel Web Editing
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	Regardless of whether users save their Excel files to the Web with or without interactivity, more Excel features can be brought back into Excel from the Web. For example, more formatting such as colors and fonts and more features such as filtering, protection, and data validation are functional when users edit a Web page in Excel. This means exporting data from Excel Web components to Excel gives users a richer experience.
	· Save an Excel spreadsheet (with multiple features and formatting) as HTML.
· Open up the HTML page and click Edit in the browser.


Reliability and Data Recovery 

Another key goal for Excel version 2002 was to allow users to spend time analyzing their data rather than worrying about their software. For example, in the past, if an error were to occur, it was likely that the user would have had to spend a significant amount of time recreating their work. With the reliability features in Excel version 2002, users can continue to work even in the unlikely event of an error. Furthermore, a variety of security enhancements have been included in Excel version 2002 to help users feel more secure when working with their spreadsheets. Note: See the Office XP Product Guide for additional functionality in this area that spans across the Office applications.

	Feature
	Description
	How to Access

	Document Recovery
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	Microsoft Excel gives users the option of saving their current files at the time an error occurs in an application. As a result, users spend less time recreating their spreadsheets. 
	· You can only access this if an error occurs.

· Choose to recover the document and click Close.

· Open the recovered document from the Document Recovery pane.

	Application Error Reporting
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	Excel allows users to automatically report any errors that occur directly to Microsoft or their corporate IT department. This gives Microsoft (or organizations) the data needed to further diagnose and correct these errors as well as to provide users with direct access to workarounds or other information on the error. 
	· You can only access this if an error occurs.

· Choose to report the error back to Microsoft from the error dialog box.

	Application and Document Recovery
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	This provides a safer method for shutting down Excel if it is not responding. Users can choose to shut it down while initiating recovery of the document. They can also report the problem to Microsoft or their corporate IT department at the same time.
	· If Excel is not responding, go to the Windows Start Menu.

· Under Programs, select Office Tools.

· Then select Microsoft Office Application Recovery.

· Choose to restart or end the application.

	Repair and Extract
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	Microsoft Excel has a corrupt document repair and recovery feature that is automatically invoked in the event of an error or a failure to load a file. Users can also invoke this functionality by choosing Open and Repair from the File Open dialog box (the drop-down menu to the right of Open).
	· In Excel, select Open from the File Menu.

· Highlight a file you want to open.

· Select the drop-down arrow from the Open button and choose Open and Repair.

	Feature
	Description
	How to Access

	Auto Recover
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	Automatic recovery has been added to Microsoft Excel. Users can choose how often files are automatically saved. If an error occurs, the recovered file is opened, and users have the option of discarding the file, saving it over the original, or saving it as a separate file.
	· Select Options from the Tools menu.

· Select the Save tab.

· Select Save AutoRecover Information and highlight how often it should take place.

	Worksheet Protection
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	Password protection is made available at a much more granular level by enabling users to protect specified ranges within a sheet. Password protection can also be applied to more features than ever before (Cell Formatting, for example). Users can now use domain-level security to map protection to a particular user or group of users.

	· Select Tools>Protection> Allow Users To Edit Ranges.

	Recalculation Improvements
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	Excel makes the calculation engine more reliable and robust with improvements such as globally recalculating (calculation order is no longer reliant on worksheet names) and allowing for uninterruptible recalculations.
	


Collaborative Spreadsheet Review

Working together on spreadsheets is extremely common today. The most prevalent way that users collaborate on spreadsheets is by attaching the spreadsheets to e-mail messages. Unfortunately, the problem with the current process is that it is often difficult to keep track of multiple versions of the spreadsheets, and tracking and merging changes from others is often too difficult or forgotten. The newest version of Excel gives users an easy way to review, compare, and merge documents with others via e-mail without changing anything about the way they do things today. 

	Feature
	Description
	How to Access

	Send for Review
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	Excel understands each user’s specific role in the review cycle and gives each user the tools needed to successfully collaborate on spreadsheets. When a spreadsheet is sent for review (from the File > Send To menu), the correct reviewing tools are automatically turned on for others to review. Furthermore, when the spreadsheet is sent back, users can merge the changes back into the original document. 
	· Select File>Send To>Mail Recipient for Review.

· Outlook automatically attaches the document to an outgoing e-mail message and sets the Send For Review process in place.

	Compare and Merge
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	Excel gives users the ability to merge together comments and revisions from multiple reviewers. The author (spreadsheet owner) can then accept and reject one or all revisions. 
	· Open a revised spreadsheet that you had originally sent to others for review.

· Click “yes” to merge and compare the spreadsheets from the reviewers.

	Reviewing Toolbar
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	As a part of the Send For Review functionality described above, the Reviewing Toolbar gives users the ability to reply to the owner of a document with their changes or end the review process.
	· From the View menu, select Toolbars and then Reviewing.

Note: This automatically appears when opening a document that was sent for review.

	Send This Selection
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	The Send To functionality in Excel has robust support for sending portions of a workbook to others. For example, users can send any range of data, chart, or PivotTable from their Excel file. They can also choose to add interactivity to what they are sending so that the recipient can use the appropriate Office Web Components within the e-mail message they receive. 
	· Open up a spreadsheet and highlight the cells you want to send.

· Click the Office E-mail icon.

· Select Send The Current Sheet As The Message Body.

· Click Send This Selection.


Integration with Microsoft SharePoint Team Services

Excel version 2002 is tightly integrated with Microsoft SharePoint Team Services, making it simple to capture cumulative team knowledge. This tight integration allows team members to publish, import, export, and even update their Excel spreadsheets via their Microsoft SharePoint Team Services Web Site. 
	Feature
	Description
	How to Access

	Exporting Team Lists to Excel
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	Team members can easily export a variety of lists from their Team Web Site back into Excel for further analysis. These lists include Contacts, Announcements, Events, Links, Tasks, and Surveys. 
	· Open a list (such as contacts) from Microsoft SharePoint Team Services.

· Click Export to Excel.

	Save/Open Spreadsheets to Microsoft SharePoint Team Services
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	Saving to and opening documents from Document Libraries is made simple by enabling users to navigate to their Microsoft SharePoint Team Services Web Site from the File Open/File Save dialog box. Office enhances the user experience by displaying document libraries via an HTML interface right in the File Open/File Save dialog boxes.
	· Open an Excel spreadsheet.

· Select Save As from the File menu.

· Type in the URL of your SharePoint Team Services Web Site (or access it via My Network Places).

· Choose the document library you want to save to.

	Uploading of Spreadsheets to Document Libraries
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	Team members can easily upload a spreadsheet or any other Office file directly into a document library. Once the spreadsheet is in the document library, users can filter through the various files and even subscribe to or have discussions on a spreadsheet.
	· Open up a document library on your SharePoint Team Services Web Site

· Select Upload Document.

· Select the spreadsheet you want to upload.

	Import Excel File as a List
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	Team members can import any Excel spreadsheet or range of cells as a list into their Microsoft SharePoint Team Services Web Site. 
	· Select Lists from the SharePoint Team Services Web Site.

· Select New List.

· Select Import a List From Microsoft Excel.


Rich Data Analysis Solutions

A final goal for Excel version 2002 was to provide organizations with the tools they need to create rich solutions in Excel and on the Web. With support for XML and improved Office Web Components, the newest version of Excel enables organizations to build rich solutions using the tools in Excel with which they are already familiar.

	Feature
	Description
	How to Access

	XML support
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	Excel now supports the loading and saving of XML data. Users can load and save generic, well formed, and spreadsheet XML into Excel. And because XML is an open format, others can easily access and extract that information. 
	· In Excel, choose Save As from the File menu.

· From the file-type drop-down menu, select XML spreadsheet.

	Office Web Components (Spreadsheet, Chart, and PivotTable)
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	The Office Web Components (the Spreadsheet, Charting, and PivotTable Web Components) now have customizable menus and toolbars in which buttons and menus can be added and removed. New buttons and menus can also be added using script. See below for new functionality and improvements in each of the individual Web Components. 


	· Save a spreadsheet, chart, or PivotTable as a Web Page.

· Select the Interactivity check box.

· Try the new features mentioned.

	Spreadsheet Web Component
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	The Spreadsheet Web Component has more support for Excel workbook features, including loading spreadsheet XML files, supporting named ranges, array formulas, multiple worksheets, wrapped text, and the ability to publish entire workbooks with interactivity to the Web. Furthermore, the Spreadsheet Web Component now supports all of the built-in functions in Excel. 
	· Save a spreadsheet as a Web Page.

· Select the Interactivity check box.

· Try the new features mentioned.

	Chart Web Component
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	The Chart Web Component now supports 3-D charts using the DirectX® application programming interface and Office Art Fill Effects. The Chart Web Component has also added full support of the Excel PivotChart® dynamic views features, plus new capabilities such as graphing multiple charts within the same Web Component, and data-driven conditional formatting. Finally, fully customizable drawing and layout controls enable users to create completely new chart types and custom annotations within their chart.


	· Save a chart as a Web Page.

· Select the Interactivity check box.

· Try the new features mentioned.

	PivotTable Web Component
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	The PivotTable Web Component now supports creating and displaying custom member properties and custom groups. It also provides improved filtering capabilities, allowing users to more effectively analyze their important data at a granular level. In addition, the PivotTable Web Component enables users to make edits directly to the data. The edits can be committed directly back to the database.


	· Save a PivotTable as a Web Page.

· Select the Interactivity check box.

· Try the new features mentioned.

	Extensibility of Office Web Components
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	The Web Component object model has been extended to expose the entire built-in keyboard and user interface commands through the programming model. Developers can now use script to create sophisticated macros within the Web Components using only built-in commands in Excel. 
	

	Excel PivotTables
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	An improved PivotTable user interface makes it easier for users to work with PivotTable fields, solving issues such as truncated field names and the inability to see both hierarchy and levels. Also, PivotTables now enable immediate view of PivotTable fields even before the data field is populated. 
	· Select PivotTable and PivotChart Report from the Data menu and select the data you want to analyze.

· Try the new features mentioned.
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