Microsoft Windows Keyboard Guide
This document presents basic keyboard navigation for Microsoft® Windows® 95 and Microsoft Windows NT® 4.0. For general Windows concepts and descriptions of the interface, consult online Help or the documentation supplied with your operating system. Developers may also find The Windows Interface Guidelines for Software Design by Microsoft Press to be useful.

This document describes conventions that are supported by most applications designed for Windows 95 or Windows NT. However, different applications and different contexts do vary slightly. Also, while we recommend that applications generate a warning sound when unsupported keystrokes are used, many do not. 

Windows 95 and Windows NT 4.0 provide Accessibility Options that can make typing easier for people who have difficulty using the keyboard or pressing more than one key at a time. Consult online Help for details.

1. General Windows Keys

The following keys work throughout Microsoft Windows.

	Keys:
	Action:

	f1
	Displays Help information for the active object or the window as a whole.

	Windows logo key or ctrl+esc
	Opens the Start menu located on the taskbar.

	ctrl+alt+delete 
	In Microsoft Windows 95, opens the Close Program dialog box that contains a list box of applications to be closed and command buttons for Ending Task, Shutting Down, and Cancel.

In Microsoft Windows NT, opens the Windows NT Security dialog box, with the following options: Lock Workstation, Logoff, Shut Down, Change Password, Task Manager, and Cancel. If you are not logged on, brings up the logon dialog box.

	delete
	Deletes the selected item(s). If the items are files, moves them to the Recycle Bin.

	delete+shift
	Delete the selected item(s). If the items are files, destroys them immediately without moving them to the Recycle Bin.

	ctrl+n
	Opens the New dialog box. (This can also be opened from the File menu.)

	ctrl+o
	Opens the Open dialog box. (This can also be opened from the File menu.)

	ctrl+p
	Opens the Print dialog box. (This can also be opened from the File menu.) 

	ctrl+s
	Opens the Save dialog box. (This can also be opened from the File menu.)

	ctrl+x
	Cuts the selected item(s) to the clipboard. (This can also be opened from the Edit menu.)

	ctrl+insert or ctrl+c
	Copies the selected item(s) to the clipboard. (This can also be opened from the Edit menu.)

	shift+insert or ctrl+v
	Pastes the copied items(s) from the clipboard. (This can also be opened from the Edit menu.)

	alt+backspace or ctrl+z
	Undoes the last action. Note that not all actions, such as shutting down, can be undone. (This can also be opened from the Edit menu.)

	alt+shift+backspace
	Redoes the previously undone action. (This can also be opened from the Edit menu.)

	Windows logo key+m
	Minimizes all open windows. The keyboard focus goes to the least recently selected icon on the desktop. Add shift to expand previously opened windows and return focus to the most recently used application. 

	Windows logo key+e
	Opens the Windows Explorer. (This can also be opened from the Program item in the Start menu.)

	Windows logo key+f 
	Opens the Find: All Files dialog box. (This can also be opened from the Find item in the Start menu.)

	Windows logo key+r
	Opens the Run dialog box. (This can also be opened from the Run item in the Start menu.)

	Windows logo key+break
	Opens the System Properties dialog box. (This can also be opened from the Systems item in Control Panel.)

	Windows logo key+ctrl+f
	Opens the Find Computer dialog box. (This can also be opened from the Find item in the Start menu.)

	Windows logo key+number
	Reserved for use by computer manufacturers.

	shift+f10 or Application key
(also the right mouse click)
	Opens the shortcut menu for the active item. This can be selected text, a toolbar button, a taskbar button, or other item. 

	shift
	Press down and hold the shift key while you insert a CD-ROM to bypass the AutoPlay feature. Hold down the shift key while Microsoft Word is loading to suppress the AutoExec macro.


2. Selecting Items by Access Key or by Name

Most dialog box controls, menu titles, and menu items have underlined access keys. You can press ALT along with the access key to activate the control or menu anywhere within the active window. If an item doesn't have an underlined character, its access key is the first character in its name.

Access keys can sometimes be used without the ALT key for choosing controls or menu items. Use access keys without ALT to select items from an open menu. You can choose a dialog box control by typing its access key alone, except when the focus is on an edit box, a list box, or another control that expects typed characters. Therefore, using the ALT is a more reliable method.

Choosing controls in this way normally activates them, except when more than one item has the same access key. In that case, it will navigate to the next item assigned that key, but will not activate it. You must then press enter to activate it. 

Within a list box, list view, tree view, or on the desktop, you can select an item by typing the first one or more characters in its name. You can begin typing a new name by pausing, and in some cases by pressing BACKSPACE. Pressing the same character more than once at the beginning of a name will select the next item beginning with that character. 

3. Desktop and Taskbar Navigation Keys

Depending on your setup, various items appear on your desktop when you start Microsoft Windows. For example, the My Computer icon provides access to a list of the drives and files on your computer. You can use the arrow keys to move from one icon to another, or you can select items by typing their names.

By default, the Start button and the taskbar are located at the bottom of your screen when you start Windows and are always visible when Windows is running. Every time you start a program or open a window, a button representing that window appears on the taskbar. When you close a window, its button disappears from the taskbar. The taskbar it has status indicators, including the time, shown at the rightmost end.

	Keys:
	Action:

	Windows logo key+m
	Minimizes all open windows. The keyboard focus goes to the most recently selected icon on the desktop. Add shift to expand previously opened windows and return focus to the most recently used application. 

	arrow key
	Selects the adjacent icon or taskbar button in the direction of the arrow.

	Any printing character
	Selects the next icon with the specified name or initial letter.

	Windows logo key or ctrl+esc
	Opens the Start menu from the taskbar. Press esc again to place the keyboard focus on the Start button.

	tab
	Moves between the last selected icon on the desktop, the Start button on the taskbar, and the taskbar as a whole. There is no visual indication of the focus on the taskbar, but you can use the arrow keys to move between the taskbar buttons. You can also use shift+f10 to bring up the shortcut menu for the taskbar.

	Windows logo key+tab
	Cycles through the taskbar buttons.

	f2
	Rename a selected item. A bold rectangle appears around the title creating a text box. Type the new name and press enter. Press esc to cancel. Some icons on the desktop cannot be renamed.

	f3
	Opens the Find: All files dialog box.


It is often easier to use the Windows Explorer to manipulate objects that are on the desktop and in My Computer. The desktop is treated as the highest level directory on your computer in Windows Explorer, above the My Computer icon. Using the real desktop is often inconvenient because you have to minimize all other windows to be able to see it, but you can easily switch between Windows Explorer displaying the desktop group and any other application windows.

Like the desktop, one normally doesn't need to use the task bar except for the Start menu which can be accessed at all times by ctrl+esc. The following section describes keystrokes for switching between windows that can be used in place of the taskbar buttons.

4. Window manipulation keys

Application windows contain running applications. At the top of the window is a title bar with the name of the application and the associated document. The title bar of the window you are currently using is usually a different color than those of the inactive windows. The application's menu bar is located directly below the title bar. Application windows can be positioned anywhere within the desktop borders. Since the active window always appears in the foreground it might overlap inactive windows, partially or completely obscuring them.

Windows can be arranged on the desktop through the taskbar shortcut menu. To reach this menu, use this sequence of keys: ctrl+esc, esc, tab, shift+f10. The following options are on the shortcut menu and may be reached using arrow keys or the underlined keys: Cascade, Tile Horizontally, Tile Vertically, Minimize all, Undo minimize all, Properties.

To move a window, choose the Move command from the leftmost icon on the title bar. Use arrow keys to move the window, followed by enter to accept or esc to cancel. To resize a window, choose the Size command then use an arrow key to choose which window border you want to move, then move it with the appropriate arrow keys, finally ending with enter to accept or esc to cancel

	Keys:
	Action:

	alt+f4
	Closes the active application window. (This can also be opened from the Program menu of the active application.)

	alt+space
	Opens the Program menu from the leftmost icon on the title bar of the active window. The Program menu typically contains the following commands: Restore, Move, Size, Minimize, Maximize and Close.

	alt+tab 
	Switches to the most recently used application window. To select an application from a list, continue to hold alt down and press tab more than once to move through the list. Add shift to reverse direction through the list.

	alt+esc
	Switches keyboard focus to next application window, including minimized windows on the taskbar. Press esc more than once to switch through successive windows and add shift to reverse the direction.

	alt+enter
	Switches a MS DOS-based application between full-screen and windowed modes.

	print screen
	Copies an image of the screen to the clipboard.

	alt+print screen
	Copies an image of the active window to the clipboard.


Applications can have multiple document windows. Document windows appear within the applications windows, and like application windows may tile or overlap. Document windows have their own title bars unless they are maximized. When maximized, they fill the application workspace and share the application window’s title bar and the document name is included with the name of the application on a shared title bar. The document window’s document icon is added to the application menu bar on the far left. For example, in Microsoft Word the title bar says "Microsoft Word - Name of Document" when the document window is maximized. Commands that affect the application window affect the document window as well.

	Keys:
	Action:

	ctrl+f4
	Closes the active document window. 

	ctrl+f6 
	Switches to next document window in the active application. Add shift to switch to the previous document window.

	alt+hyphen
	Opens the Document menu from the leftmost icon on the title bar of the active document window. The Document menu typically contains the following commands: Restore, Move, Size, Minimize, Maximize and Close.


For some applications, the application and document windows can be divided into two or more separate viewing areas called panes. This is useful when moving or copying information from one document to another or from one part of a document to another. Panes are also used when viewing both the body of the documents and the footnotes or annotations.

To split a window into two panes, open the Window menu and choose the Split command. The Split Bar appears in the middle of the window with the keyboard focus indicated by arrows. Move the split bar to the desired location using the arrow keys. Press enter to set the split bar in the desired location. Use f6 or tab to move between panes in a clockwise direction; add shift to reverse direction.

5. Menu commands

Applications frequently include commands that are listed in menus. Menus are represented by names on a menu bar at the top of each application window. In Microsoft Windows, you select a menu, and then choose a command from that menu. Choosing the command initiates the action. An ellipsis (...) after the menu indicates that a dialog box will appear after the command is chosen to ask for information that the application needs to carry out the command.

	Keys:
	Action:

	Windows logo key or ctrl+esc
	Opens the Start menu on the taskbar.

	f10 or alt
	Activates the menu bar of the active window. The leftmost menu name is selected. (When you have a maximized document window, the leftmost menu has an icon instead of a name and there is no visual indication that it is selected.) Press f10 or alt again to toggle the focus back to where it was previously.

	left arrow or right arrow
	Moves the focus between menus on the menu bar in the direction of the arrow. If the original menu was open, the target menu will be opened and the focus on the first item.

	up arrow or down arrow
	Opens the selected menu. down arrow selects the next command in the list. up arrow selects the previous command in the list.

	enter
	Opens the selected menu when focus is on the menu title, but it activates a menu item when focus is on a menu item. If the selected menu item is unavailable, enter closes the menu.

	alt+space
	Opens the Program menu from the leftmost icon on the title bar of the active window. The Program menu typically contains the following commands: Restore, Move, Size, Minimize, Maximize and Close.

	alt+hyphen
	Opens the Document menu from the leftmost icon on the title bar if the active document window. The Document menu typically contains the following commands: Restore, Move, Size, Minimize, Maximize and Close.

	esc
	Closes an open menu and moves the focus back to the parent menu if there is one. Otherwise it returns the focus to the menu title. If the focus was already on the menu title, focus moves back to wherever it was before activating the menu bar.

	alt+Any printing character
	Chooses the menu with the underlined character (access key) on the main menu bar. 

	Any printing character
	Chooses the command with the underlined character (access key) on an open menu.

	shift+f10 or Application key
(also the right mouse click)
	Opens the shortcut menu for the active item. This can be selected text, a toolbar button, a taskbar button, or other item. 


6. Windows Explorer keys

The Windows Explorer displays the contents of a computer, drive or directory. The Windows logo key+e opens the Windows Explorer at any time, and it can also be started from Programs on the Start menu. It normally has two panes, the left pane showing a tree view of your folders, and the right pane showing the contents of one folder. 

Windows Explorer can also show a single-pane, without the tree view. In this case it normally hides the toolbar unless you explicitly turn it on using the View menu. The same information is can be accessed using the My Computer icon from the desktop, and in the standard Open and Save As dialog boxes.

In the View menu offers a choice of icon displays. The Large Icons view displays the contents of a drive or directory as large icons in horizontal rows. The Small Icons view displays the same information in small icons in horizontal rows. The List menu item displays directories and files as small icons in vertical columns. The Details view displays files as a single column of icons with multiple columns of information about each file.

Files and folders can be moved or copied by using the Cut, Copy, and Paste commands from the Edit menu or by shortcut keys. Moving a program icon does not change the performance of the program. Deleting a program icon does not delete all the files associated with the program, so install or delete programs using the Add/Remove Programs option in Control Panel.

6.1 View Control Keys

	Keys:
	Action:

	arrow keys
	Select the next item in the indicated direction. Add shift to select or deselect additional items. Add ctrl to move to the item without selecting it. In Details View there is only one column so right and left arrow scrolls the window a small amount to the right or left. In List View the up and down arrow keys wrap between columns.

	page up or page down
	Moves to the bottom or top item on the screen. Use a second time to select the item one screen above or below. Add shift to select additional items. Add ctrl to move to the item without selecting it.

	home or end
	Selects the first or last item in the list. Add shift to select or deselect additional items. Add ctrl to move to the item without selecting it.

	Any printing character
	Selects the next icon with the specified name or initial letter. space behaves this way when it is typed as part of a name. 

	enter
	Opens the selected item. This may open a new window, depending on the options you have selected. (This can also be opened from the File menu.)

	backspace
	Displays the contents of the parent directory. This may open a new window, depending on the options you have selected.

	space
	When typed alone, selects the current item if it is not already selected. Use after moving with the ctrl key to select separate groups of items.

	ctrl+space
	Selects or deselects the current item. Use after moving with the ctrl key to select separate groups of items.

	shift+space
	Extends the selection to the current item. If you have already selected more than one item, it selects only the items from the first item you selected to the current item.

	ctrl+z
	Undoes the last action. Some actions cannot be undone. (This can also be opened from the Edit menu.)

	ctrl+x
	Cuts the selected item(s) to the clipboard. (This can also be opened from the Edit menu.)

	ctrl+c
	Copies the selected item(s) to clipboard. (This can also be opened from the Edit menu.)

	ctrl+v
	Pastes the copied item(s) from clipboard. (This can also be opened from the Edit menu.)

	ctrl+a
	Selects all the items in the current window. (This can also be opened from the Edit menu.)

	ctrl+g
	Opens Go To Folder dialogue. (This can also be opened from the Tools menu).

	ctrl+f or f3
	Opens Find: All Files dialog box. (This can also be opened from the Tools menu).

	delete
	Deletes the selected item(s) to the Recycle Bin. (This can also be opened from the File menu.)

	shift+delete
	Delete the selected item(s) immediately without moving the item(s) to the Recycle Bin.

	alt+enter
	Displays the properties of the selected item. (This can also be opened from the Files menu.)

	f2
	Renames a selected item. A bold rectangle appears around the item. Type the new name and press enter. Press esc to cancel. (This can also be opened from the File menu.)

	f4
	Opens the drop-down list box on the toolbar. Pressing f4 again moves the keyboard focus back to the previously used item..

	f5
	Refreshes the current window. (This can also be opened from the View menu.)

	f6 or tab
	Switches between panes and the toolbar.


6.2 Tree View Control Keys

Tree views display a set of objects as an indented outline based on their hierarchical relationships. For example, the All Folders pane in the Windows Explorer is a tree view. Files and folders can be moved or copied in tree view by using the Cut, Copy, and Paste commands. Tree view only supports single selection of items.

	Keys:
	Action:

	right arrow
	Opens a branch, or selects the first item in the branch.

	left arrow
	Closes a branch, or selects the parent of the current item.

	asterisk (on the numeric keypad)
	Expands everything under the current selection. 

	minus sign (on the numeric keypad)
	Closes everything under the current selection.

	plus sign (on the numeric keypad)
	Expands everything under the current selection back to a previously opened state, or opens only one level if it has not previously been opened.

	up arrow or down arrow
	Selects the next visible object above or below.

	page up or page down
	Moves to the top or bottom item on the screen. Use a second time to move up or down one screen.

	home or end
	Selects the first or last item on the tree.

	Any printing character
	Selects the next icon with the specified name or initial letter. Repeating the character selects successive items beginning with the same character.

	backspace
	Chooses the parent directory


7. Dialog Boxes

A dialog box is a window that appears temporarily on top of your application window to request information. Message boxes are simple dialog boxes that appear to display additional information, warnings, or to explain why a requested task could not be accomplished. Dialog boxes often contain groups of controls necessary to set options or settings for programs. A typical dialog box might contain some text, a set of radio buttons, and OK and Cancel push buttons. 

Controls that have an access key in their titles can be selected or chosen by typing alt+the underlined letter at any time when the dialog box is active. tab will move the keyboard focus between controls, but which items are visited by tab and their order may vary between applications. Typically, items that cannot be changed are not visited by the tab key. arrow keys are used to move within a list box, groups of option controls, or groups of page tabs. arrow keys can move the keyboard focus between other controls but this behavior is not reliable. Options that are unavailable appear dimmed and cannot be selected.

While the controls described here are typically found on dialog boxes, they can also occur in other contexts.

Command buttons (also known as push buttons) initiate an immediate action. One command button in each dialog box carries out the command you choose, using the information supplied in the dialog box. This is normally labeled "OK". Other command buttons let you cancel the command or choose from additional options.

Command buttons marked with an ellipsis (...) open another dialog box so you can provide more information or confirm an action. Command buttons marked with a pair of greater-than symbols (>>) expand the current dialog box to show more controls. Command buttons marked with an arrow display a menu.

The default button is initially indicated by a dark border. Press enter at any time to choose the button with a dark border. Use tab to move the keyboard focus to the next control, and add shift to reverse the direction. When you move the keyboard focus to a command button it temporarily takes the dark border, but when the keyboard focus is not on a command button the dark border returns to the default button. Press space to choose the command button you selected with tab. Use esc to immediately choose the Cancel button if there is one. Typing the access key for a push button will immediately carry out the command.

Check boxes may be selected or cleared to turn on or off an option. Check boxes may have two states (checked and unchecked) or three states (checked, unchecked, and indeterminate). Check boxes are often displayed in sets of related options, for example in setting Font Effects in Microsoft Word the check boxes offer Strikethrough, Superscript, Subscript, Hidden, Small caps, and All caps.

Use tab
to move between boxes and space
to change the check box to the next state. Typing the access key for a check box will also move the focus to the box and change its state.

Option controls (also known as radio buttons) are used to select only one option from a group of options. (Like check boxes, option buttons may represent two or three states.) Use the arrow keys to select the next or previous buttons within the group. In some applications, you can add ctrl to move to the button without selecting it, then use space to choose the currently selected option button. Typing the access key for an option control will also move the focus to the control and select it.

Tabbed pages are used to fit many options into a single dialog box. They appear visually similar to dividers from a notebook. Each page contains separate groups of controls such as check boxes or option controls. Use tab to move the focus to the tab for the currently visible page. Typing the access key for a page tab will also move the focus to the tab and display its page.

	Keys:
	Action:

	ctrl+page down or ctrl+tab
	Switches to the next tab and displays the page.

	ctrl+page up or ctrl+shift+tab 
	Switches to the previous tab and displays the page.

	right arrow or left arrow
	When the focus is on a tab selector, chooses the next or previous tab in the current row and displays the page.

	down arrow or up arrow
	Chooses the tab in the next or previous row and displays the page.


Sliders appear as an indicator on a vertical or horizontal gauge. The slider both displays and sets a value from a continuous range, such as speed, brightness, or volume. Use tab or the appropriate access key to move the focus to the slider. 

	Keys:
	Action:

	right arrow or down arrow
	Selects the next higher setting.

	left arrow or up arrow
	Selects the next lower setting.

	home or end
	Selects the lowest or highest setting.

	page down
	Selects a somewhat lower or higher setting depending on the application. (This is the equivalent of pressing an arrow key many times.)

	page up
	Moves in the reverse of the page down.


Spin boxes appear as a text box with up and down arrows used to select from a list of fixed values. Use tab to move the keyboard focus to the text box, then enter a valid value in the box or use the up arrow or down arrow keys to select the next higher or lower values.

List boxes display a column of available choices. If there are more choices than can fit in the open list box, moving the selection through the list will cause more choices to scroll into view. Use tab or type the appropriate access key to move the focus to the list box.

Single selection list boxes allow only one item to be selected from the list at a time. Items are selected when navigating to them, and moving to a second item will automatically deselect all other items. 

Drop-down list boxes show only the selected item. There is a small button to the right of the control that shows a downward-pointing arrow. This displays more items from the list box while you make your selection. You can also show or hide the list using alt+down arrow, alt+up arrow, or f4. In all other respects it behaves like a normal single-selection list box.

Extended selection list boxes support selecting single items, blocks of items, or combinations of the two. After selecting an item as in a single-selection list box, hold down shift+Navigation keys to select or deselect more items.

Multiple selection list boxes typically have comparatively long lists and more of these items are expected to be chosen individually (not in blocks). Navigating to items does not automatically select them nor does selecting an item change the status of other selections. Press space to select or deselect an item.

Combo-boxes and drop-down combo boxes are list boxes with attached edit boxes. You can make your selection by either typing in the edit box or using the standard commands to select from the list. 

	Keys:
	Action:

	up arrow or down arrow
	Selects the previous or next item. In an extended selection list box, add shift to select additional items and add ctrl to move to an item without selecting it. In an multiple selection list box, moves without changing the selection.

	page up or page down
	Selects the item up or down one screen. In an extended selection list box, add shift to select additional items and add ctrl to move to an item without selecting it. In an multiple selection list box, moves without changing the selection.

	home or end
	Selects the first or last item in the list box. In an extended selection list box, add shift to select additional items and add ctrl to move to an item without selecting it. In an multiple selection list box, moves without changing the selection.

	Any printing character
	Moves to the next item matching the characters being typed. Use backspace to change. In an multiple selection list box, moves to an item without selecting it. 

	space or ctrl+space
	Selects or deselects the current item in an extended-selection list box.

	shift+space
	Extends the selection from the last selected item to the current item in an extended selection list-box.

	shift+f8
	In extended selection list boxes, pressing shift+f8 allows you to move without changing the selection. You can then press ctrl+space or shift+space to select additional items. The list box returns to normal operation when you press shift+f8 a second time or switch to another window or control.


Edit controls are rectangular boxes used for displaying or editing text. See the following section for more information. Use tab or the appropriate access key to move the focus to the edit control and select the text.

8. Text Navigation and Editing Keys

When you open a document window in a word processing (or similar) program, a pointer appears in the upper-left corner of the window. The text you enter will appear at the pointer. In insertion mode, the new text is inserted into the existing text—the existing text is automatically pushed back to follow the new text. In overwrite mode, the new text overwrites the existing text. The following keys automatically scroll the window to keep the pointer in view when it is necessary. These keys also work in the text boxes of dialog boxes and list boxes.

	Keys:
	Action:

	insert
	Toggles between overtype and insertion modes. (Edit controls only support insert mode.)

	arrow key
	Moves the pointer one character in the direction of the arrow key. If there is selected text, moves the pointer to the end of the selection and deselects the text.

	home or end
	Moves the pointer to the beginning or end of the current line. 

	page up and page down
	Moves the pointer up or down one screen or to the first or last line.

	ctrl+right or ctrl+left
	Moves the pointer to the beginning of the next or previous word.

	ctrl+up or ctrl+down
	Moves the pointer to the beginning of the preceding or next paragraph. (Not supported in edit controls.)

	ctrl+home or ctrl+end
	Moves the pointer to the beginning or the end of the document. (Not supported in edit controls.)


Press shift with the above text navigation keys to select blocks of text for editing. For example, press shift+end to select text from the pointer to the end of the line. shift toggles, in other words you can also use shift+the above navigation keys to both select and deselect text.

	Keys:
	Action:

	delete
	Deletes the next character or the selected text.

	backspace
	Deletes the previous character or the selected text. 

	alt+backspace or ctrl+z
	Undoes the last action.

	ctrl+insert or ctrl+c
	Copies selected text to clipboard.

	shift+delete or ctrl+x
	Cuts the selected text to the clipboard.

	shift+insert or ctrl+v
	Pastes copied text from clipboard.


9. Accessibility Keys

Use the Control Panel to turn on these keys for both Microsoft Windows 95 and Microsoft Windows NT 4.0. Under previous versions of Windows, Windows NT and MS-DOS the Accessibility features were not on the system until the Access Pack has been installed. Once Access Pack is installed, the hot keys are on by default. These features are not available on Windows NT 3.1.

	Keys:
	Action:

	Five taps on shift
	Toggles the StickyKeys feature on and off. Use StickyKeys if you want to use the shift, control, or alt keys one key at a time in combination with other keys.

	Left alt+Left shift+num lock
	Toggles the MouseKeys feature on and off. Use MouseKeys if you want to control the mouse pointer with the numeric keypad.

	Hold num lock for 5 seconds
	Toggles the ToggleKeys feature on and off. Use ToggleKeys if you want to hear tones when pressing caps lock, num lock and scroll lock.

	Hold Right shift for 8 seconds
	Three beeps followed by a sliding beep signals eight seconds. Toggles the FilterKeys features (SlowKeys, BounceKeys and RepeatKeys) on and off. Use FilterKeys if you want Windows to ignore brief or repeated keystrokes or to slow the repeat rate. SlowKeys ignores keys that are pressed accidentally or for a short time. BounceKeys ignores keys that are pressed more than once too quickly. RepeatKeys adjusts or disables the keyboard repeat rate.

	Hold Right shift for 12 seconds
	Three beeps followed by a sliding beep followed by a double beep signals twelve seconds. Turns on the BounceKeys feature with the most conservative settings. 

	Hold Right shift for 16 seconds
	Three beeps followed by a sliding beep followed by a double beep followed by a triple beep signals sixteen seconds. Turns the SlowKeys feature on with the most conservative settings.

	Left alt+Left shift+print screen
	In Microsoft Windows 95, toggles the High Contrast Mode feature on and off. Use this option if you want Windows to display colors and fonts designed for easy reading.

In Microsoft Windows NT 4.0, use Control Panel to select from several High Contrast schemes in the Appearance page under the Display option.


10. Shortcut Keys for Applications or Documents

Shortcuts provide easy access to the documents and programs you use most often. You can put shortcuts to any program or document on your desktop or on your Start menu and give them shortcut keys. Typing a shortcut key at any time will switch to the application or document, or start it if it is not already running.

The items on your Start menu are shortcuts and you can assign them shortcut keys. The Start menu is also a convenient place to put shortcuts you create.

To create a shortcut and place it in the Start menu:

	Action:
	Result:

	1 Press ctrl+esc.
	The Start menu appears.

	2 Choose Programs from the Start menu.
	The Programs menu opens.

	3 Choose Windows Explorer from the Programs menu.
	The Windows Explorer opens with the contents of 'Start Menu' in the Contents pane on the right.

	4 Press f6 and arrow keys.
	Use f6 to switch panes and the arrow keys to navigate to the program or document to which you are assigning a shortcut.

	5 Press ctrl+c.
	Copies the selected item to the clipboard.

	6 Press ctrl+esc.
	The Start menu appears again.

	7 Press esc.
	The keyboard focus moves to the Start button on the taskbar.

	8 Press shift+f10.
	The shortcut menu for the Start button appears.

	9 Press e.
	Chooses the Explore command. A second copy of Windows Explorer opens with the contents of 'Start Menu' in the Contents pane on the right. The keyboard focus is on the first item in the pane.

	10 Press alt+e.
	The Edit menu opens.

	11 Press s.
	Chooses the Paste Shortcut command. The new shortcut icon appears at the end of the list of icons in the Contents of "Start Menu" pane.

	12 Choose Close from the File menu.
	Closes the second copy of the Windows Explorer. Repeat to close the first copy.


You can also place shortcuts on the desktop through the Windows Explorer.

To assign a shortcut key to a shortcut: 

	Action:
	Result:

	1 Select the shortcut on the desktop or in the Windows Explorer.
	You can assign shortcut keys only to shortcuts on the Desktop or in the Start menu. (To assign shortcut keys to shortcuts on he Start menu you will need to go through Explorer.)

	2 Press alt+enter.
	Displays the Properties tabbed page.

	3 Press ctrl+tab.
	Chooses the Shortcut page tab.

	4 Press alt+k or tab.
	Chooses the Shortcut Key edit box.

	5 Press any key combination. 
	Enter your shortcut and it will appear in the edit box. Shortcut keys must include ctrl or alt, or both, and one other key. For example, ctrl+shift+y. You cannot use esc, enter, tab, spacebar, print screen, or backspace. Be careful, because no other program will be able to use this key combination while it is defined as a shortcut key. Press backspace to delete an existing shortcut key or change your entry in the text box.

	6 Press enter. 
	Chooses the OK button. Press esc to cancel.
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