DLinq Designer for VB and C#

The DLinq Designer provides a visual design surface for creating DLinq entity classes and associations (relationships) based on tables in a database.
This document contains the following topics:

· DLinq Designer Walkthrough
· Creating Objects from the Toolbox
· Creating Relationships (Associations) between Objects
· Inheritance
DLinq Designer Walkthrough
Walkthrough: Creating and Binding to DLinq Objects using the DLinq Designer
Introduction
This walkthrough explains how to do the following:

· Create DLinq objects and add them to a project.
· Create a project data source to display the DLinq objects in the Data Sources window.

· Create controls bound to the DLinq objects on a Windows Form.

· Save data in a DLinq object back to the database.

· Bind data-bound controls to the results of a LINQ query.

Prerequisites
In order to complete this walkthrough, you need:
· A working data connection to the Northwind sample database in Server/Database Explorer.
Create a New Project
	To create the new Windows Application

	1. From the File menu, create a new project.
2. Select the LINQ project type.

3. Select the LINQ Windows Application Template.

4. Name the project DLinqWalkthrough.a03edf2a-cb24-4ce9-8ee5-2977b5e87e5c


Add a DLinq Object File to the Project
DLinq objects are stored in .dlinq files. Add .dlinq files to projects using the Add New Item dialog box.
	To add a .dlinq file to the project

	5. From the Project menu select Add New Item.
6. Select the DLinqObjects template and click Add.

The .dlinq file is added to the project and the Dlinq Designer opens.


Add a Customers DLinq Object to the Designer
Create DLinq objects based on database tables by dragging tables from Server Explorer (Database Explorer) onto the DLinq Designer.
	To add a DLinq object to the designer

	7. In Server/Database Explorer navigate to the Customers table in the Northwind sample database.
8. Drag the Customers node onto the DLinq Designer's design surface.
A DLinq object named Customer is created with properties that correspond to the columns in the Customers table. The DLinq object is named Customer because it represents a single customer from the Customers table.
9. Build the project to compile the Customer DLinq object (building is necessary for the next step).
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Create an Object Data Source using the Customers DLinq object

Add DLinq objects to the Data Sources window by running the Data Source Configuration Wizard.
	To create a DLinq object Data Source

	10. From the Data menu, select Add New Data Source.

11. Select Object on the Choose a Data Source Type page and click Next.

12. Expand the DLinqWalkthough node and navigate to the Customer object.

Note   If the Customer object is not available, cancel out of the wizard, build the project, and rerun the wizard.

13. Click Finish to create the data source.


Create Data-Bound Controls to Display the Data on a Windows Form
Create controls that are data bound to DLinq objects by dragging DLinq data source items from the Data Sources window onto a Windows Form.
	To add controls bound to the DLinq object

	14. From the Data Sources window drag the Customer node onto Form1 (onto the Form designer).

Note   To display the Data Sources window, select Show Data Sources from the Data menu.
15. For VB applications; add the following Imports statement to the top of the form code:

' VB Only

Imports System.Data.Dlinq.DataQueryExtensions
16. Add the following code to the form (global to the form, outside of any specific method):
' VB
Private NorthwindDataContext1 As New NorthwindDataContext
// C#

private NorthwindDataContext northwindDataContext1 = new NorthwindDataContext();

17. Create an event handler for the Form_Load event and add the following code withn the handler:

' VB

CustomerBindingSource.DataSource = NorthwindDataContext1.Customers.ToBindingList()
// C#

customersBindingSource.DataSource = northwindDataContext1.Customers.ToBindingList();



Test the Application
Run the application and verify the data from the Customers table is displayed on the form.

Add an Orders DLinq Object to the Designer

	To create an Orders DLinq object

	18. In Server/Database Explorer navigate to the Orders table.

19. Drag the Orders node onto the DLinq Designer's design surface.

A DLinq object named Order is created with properties that correspond to the columns in the Orders table.
20. Build the project to compile the updated DLinq objects (necessary for the next step).


When dropping the Orders table onto the DLinq Designer the designer detects the relationship and creates an 'Association' (relationships are called Associations in DLinq). This results in an Orders property in the Customers entity that contains a collection of Order objects.
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Create Controls Bound to the Orders Data
After adding the Orders table and building the project, the Data Sources window displays the related Orders as an additional node in the Customers table.
	To add bound controls to the related data

	21. In the Data Sources window expand the Customers node.
22. Select the Orders node and drag it onto the form below the existing CustomerDataGridView.


Test the Application

Once again, run the application and verify the data from the Customers and Orders tables are displayed on the form. Navigate to different customers and verify the order data is changing and staying in synch with the selected customer.
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Implementing Save Functionality

The save button is disabled by default and code is not automatically added to the form when data-bound controls are created. This section explains how to enable the Save button and implement save functionality for DLinq objects.
	To implement save functionality

	23. Select the Save button on the customersBindingNavigator and set the Enabled property to True (in the Properties window).

24. Double click the save button to create an event handler and switch to Code view.

25. Add the following code into the save button event handler:

' VB

NorthwindDataContext1.SubmitChanges()

// C#

northwindDataContext1.SubmitChanges();



Test the Application

Once again, run the application; this time edit one of the records and click the save button.

Your changes are saved to the database.

Close the application, and then run it again so it reloads the data from the database.

Notice the changes are still there.

Binding to LINQ Queries
In addition to binding the CustomersBindingSource to the DataContext you can also bind directly to LINQ queries.
Add a Button and TextBox to the Form
To demonstrate binding controls to LINQ queries lets add extra controls to the form where we can enter a query parameter and 
	To add controls to the form

	26. Add a TextBox to the form and set its Name property to CityTextBox.

27. Add a Button to the form and set the following properties:

· Name = RunQueryButton

· Text = Run Query
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	To bind to a LINQ query

	Double click the RunQueryButton and add the following code to the button click event handler:

' VB

Dim results = From customers in NorthwindDataContext1.Customers _
    Where customers.City = CityTextBox.Text _

    Select customers
CustomersBindingSource.DataSource = results.ToBindingList()
// C#

var results = from customers in northwindDataContext1.Customers

                      where customers.City == CityTextBox.Text
                      select customers;
customersBindingSource.DataSource = results.ToBindingList();


Test the Application

Once again, run the application.

· Type London in the text box and click the Run Query button.

· Notice only customers with a value of London in the City column appear in the grid.

· Now type Madrid in the text box and click the Run Query button.

· The results are replaced with customers from Madrid.
Creating Objects from the Toolbox
You can create DLinq objects by dragging items from the Toolbox onto the design surface. 
	To create DLinq Objects from the Toolbox

	28. Go to the DLinq Designer and drag a DLinq Class from the toolbox onto an empty area of the design surface.

29. In the Properties window set the TableName property to Order Details.

30. Set the Name property to Order Detail.

31. Right click the Order Detail object on the design surface and select Add DLinqProperty.

32. Set the Name property to OrderID.

33. Set the ColumnName property to OrderID.

34. Set the IsID property to True (for the OrderID column only)

35. Set the ServerType property to int.

36. Set the PropertyType property to System.Int32.

37. Repeat steps 4-9 using the following values to create the remainder of the Orders object:

Name and ColumnName

ServerType

PropertType

Nullable

ProductID
int
Int32
False
UnitPrice
money
Decimal
False
Quantity
smallint
Int16
False
Discount
real
Single
False



Creating Relationships (Associations) Between Objects

Relationships in DLinq objects are called Associations and created by defining a property of the 'parent' object which is a collection of items in the related 'child' object. The property is adorned with the Association attribute which signifies the relationship.

Note   Dragging related items from Server/Database Explorer onto the DLinq Designer automatically configures the Association between the related objects.

	To create a relationship (Association) between the Order and Order Detail objects

	38. From the DLinq Objects toolbox create an Association between the Order and Order Detail objects.

Note   Select the Association in the Toolbox and release the mouse button, then click the Order object, and then click the Order Detail object.

39. Select the Association on the design surface and set the following properties:

Property

Value

Description

Name

Order Details

The name of the association

OtherKey

OrderID
Equivalent to the primary key in the related table.

RelationName

FK_Order_Details_Orders

The name of the association in code.

ThisKey

OrderID
Equivalent to the foreign key in this table.

40. Build the project to save the changes.


Create Controls Bound to the Order Details Data

After adding the Order Detail object and building the project, the Data Sources window displays the related Order Details as a node in the Orders table.
	To add bound controls to the related data

	41. From the Data Sources window expand the Orders node.
42. Select the Order Details node and drag it onto the form along side the existing OrdersDataGridView.

IMPORTANT   There is a known bug that may throw an exception at this point. If this happens the workaround is to close Visual Studio and then reopen your project. After the project is reopened you should now be able to drag the Order Details node onto the form. For more information on this bug you can look in the Read Me file.


Test the Application

Once again, run the application and verify. Navigate to different Orders and verify the order details data is changing and staying in synch with the selected order.
Inheritance and the DLinq Designer
You can also use the DLinq Designer to visually create objects that inherit from existing objects.
Create a Table to Inherit From

To demonstrate inheritance we will create a small Person table and use that as a base class and create an Employee object that inherits from it.
	To create a base table to demonstrate inheritance

	43. In Server Explorer, right click the Tables node and select Add New Table.
44. Add the following columns to the table in the table designer:

Column Name

Data Type

Allow Nulls

Type

int

True

ID

int

False
FirstName

nvarchar(200)

False

LastName

nvarchar(200)

False

Manager

int

True
45. Set the ID as the primary key. 

46. Save the table and name it Person.


Add some Data to the Table

	To add data to the table

	47. Open the table in data view (Right click the Person table and select Show Table Data).

48. Copy the following data into the table. (You can cut and paste it in.)


	1
	1
	Maria
	Anders
	NULL

	1
	2
	Ana
	Trujillo
	NULL

	1
	3
	Thomas
	Hardy
	NULL

	2
	4
	Antonio
	Moreno
	1

	2
	5
	Christina
	Berglund
	1

	2
	6
	Hanna
	Moos
	1

	2
	7
	Elizabeth
	Lincoln
	2

	2
	8
	Victoria
	Ashworth
	2

	2
	9
	Patricio
	Simpson
	2

	2
	10
	Francisco
	Chang
	3

	2
	11
	Yang
	Wang
	3

	2
	12
	Pedro
	Afonso
	3


Create a New Project

	To create the new Windows Application

	49. From the File menu, create a new project.

50. Select the LINQ project type.

51. Select the LINQ Windows Application Template.

52. Name the project DLinqInheritance and click OK.a03edf2a-cb24-4ce9-8ee5-2977b5e87e5c


Add a DLinq Object File to the Project

	To add a .dlinq file to the project

	53. From the Project menu select Add New Item.

54. Select the DLinqObjects template and click Add.

The .dlinq file is added to the project and the Dlinq Designer opens.


Add the Objects to the Designer

	To add the base and inherited classes

	55. In Server/Database Explorer navigate to the Person table in the Northwind sample database.

56. Drag the Person table onto the DLinq Designer's design surface.

57. Drag a 2nd Person table onto the designer and change its name to Employee.
Note   If the second table appears directly on top of the first just drag it off to the side.

58. From the DLinq Objects toolbox create an Inheritance between the Person and Employee objects.

Note   Select the Inheritance item in the Toolbox and release the mouse button, then click the Employee object, and then click the Person object. The arrow on the inheritance line should be pointing to the Person object.

59. Delete the Manager property from the Person object.
60. Delete the Type, ID, FirstName, and LastName properties from the Employee object. (In other words, delete all properties except Manager.)

61. Select the Inheritance line on the design surface.

62. Set the DiscriminatorColumn property to Type.

63. Set the DiscriminatorValue property to 2.

64. Select the Person object and set the DiscriminatorValue to 1.
65. Build the project.


Query the Inherited Class and Display the Data on the Form
	To create a LINQ query and display the results on the form.

	66. Drag a ListBox onto Form1.
67. Double click the form to create a Form_Load event handler.

68. Add the following code to the Form_Load handler:

' VB

Dim dc As New NorthwindDataContext
Dim results = From emp In dc.Persons _

    Where TypeOf emp Is Employee _

    Select emp

For Each Emp As Employee In results

    ListBox1.Items.Add(Emp.LastName)

Next

// C#

NorthwindDataContext dc = new NorthwindDataContext();

var results = from emp in dc.Persons

              where emp is Employee

              select emp;

foreach(Employee Emp in results)
{

    listBox1.Items.Add(Emp.LastName)

}


Test the Application

Run the application and verify the records returned are only employees (records with a value of 2 in their Type column).
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