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Designing a Web
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Now that you are familiar with how FrontPage 2000 works, you can get started on your Web site. In this chapter you begin by designing your school Web site. When you have a blue print in place, managing the site is much easier in the long run. Although you can always return to a Web site and arrange pages after you have finished creating the site, you may find it easier to manage the Web site if you plan ahead.

You also want visitors to your site to be able to navigate easily between pages on your Web site without losing track of where they are. Good organization helps make browsing a Web site fun, helps guarantee return visits, and hinges on good planning and organization. 
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Before you begin

In order to create an outstanding Web site, you must first plan the types of content and the types of Web pages you want on your Web site. 

· Brainstorm about the types of content you want on your Web site. This can include information about student activities and services, sports, academic departments and advancement requirements, alumni activities, and more.

· Brainstorm about the types of links you want from your Web site. These can include links to research resources, professional educator organizations, and other educational sites.

· Begin an outline of your Web site.

This book shows you how to create a school home page with links to at least five other pages. The pages used for these activities are:

· Calendar of Events

· Departments and Faculty

· Academic Requirements

· Alumni Activities

· Educational Links

Organizing your Web’s structure

The home page serves as the gateway to a Web site, so you should organize your Web site around it. Using the Navigation view in FrontPage 2000 to set up a flowchart to group your pages, you can easily arrange your Web.

Determining a purpose

Just like any other task you may do, you need to know your Web site’s purpose before you begin. In the case of a school Web site, you may want to publicize school events, keep students up-to-date on deadlines and other activities, point patrons to educational resources, or portray a positive image of the school to your community. 

Defining your Web site’s purpose helps you decide what kind of theme you want to give the Web site, and what types of information to include on the pages.

Drawing an organization chart

On paper, draw a simple organizational sketch of how the pages of your Web should be placed in relation to one another. The home page is at the top, and the rest of the pages are connected on one or more levels below the home page. 

Understanding good Web design

FrontPage 2000 allows you to add numerous themes, fonts, animations, effects, sounds, graphics, and more. In order to create a well-designed Web site, you should have an idea about what design elements you want to use to enhance the look of your Web site. 

Good Web design consists of the following:

· A well-organized structure

· Focused information

· Consistency between pages

· Easy navigation

· Well-maintained information and links

Understanding basic Web page design

In a well-designed Web site, visitors should always know where they are, and how to get where they need to go. To make sure that people can find what they need in your site, your pages should feature consistent layout elements. Applying basic page design to your site helps make your site easier to navigate through and more pleasant for people to visit. 

The structure of a Web page includes a header, body or active page, and footer.

· The header, at the top of the Web page, can include a title, banner, shared borders, or navigation bars that provide links to other pages. 

· The body contains text stating the Web's purpose and provides information. It can also include navigation bars, images, sound, motion clips, and other links. 

· The footer, at the bottom of the printed page, may include an address, phone number, e-mail address, date of last update, hit counter, or links.

The header and footer usually look the same on most of the pages in a Web. The easiest way to have the same information on each page is to use the Shared Border feature in FrontPage 2000. Shared borders let you create the header and footer on one page, and have automatically copy them onto other pages with in your Web. For more information on shared borders, see the Getting Your Bearings chapter in this book. 

Opening an existing Web

If you saved and closed the Central High School Web site that you began in the previous chapter, you need to open the existing Web to continue working where you left off.

To open an existing Web

1. Open FrontPage 2000.

2. Click the arrow next to the Open button, and click Open Web. The Open Web dialog box opens to the Web you worked on most recently. 
[image: image1.png](=2
& open. 4o
& Open web.




3. If you have not worked on any other Webs, click Open.
-or-
If you have worked on other Webs, browse through the folders to find the Central High School Web, and then click Open.

The Web opens in Page view.

Adding a design theme to your Web

A FrontPage 2000 theme consists of unified design elements and color schemes for bullets, fonts, images, navigation bars, and other page elements. A theme gives the pages and navigation bars in your FrontPage Web an attractive and consistent appearance. After adding a theme, you can also modify the theme to represent your organization, club, or school.

To add a theme

4. Double-click central_high_school_home_page.htm to open the home page.

5. On the Format menu, click Theme.

6. In the Themes dialog box, select the All Pages option.

7. Select the Straight Edge theme. Straight Edge is a very simple theme. To explore the other themes, click the title and a preview appears in the Sample of Theme box.

8. Select the Active Graphics and Background Image check boxes. 

9. Click OK. The theme is applied to all pages in your Web.

Adding and deleting pages

After planning a Web site, you know what pages to include in your Web and where they should be. You can always add and delete pages later, but plan the Web site before you add pages. With a plan in place, you can more easily assign tasks and pages to people who are contributing to your Web’s production. If you are working alone, it is easier to organize tasks when the Web site is well planned.

To add a page to your Web

10. On the Views toolbar, click [image: image2.png]


 to go to the Navigation view.

11. Click the page to which you want to add a new page. 

12. Click [image: image3.png]


 to add the new page.

13. To name the page, right-click the new page and click Rename, and then type the new page name.

To delete a page from your Web

14. On the Views toolbar, click [image: image4.png]


 to go to the Navigation view.

15. Click the page you want to delete.

16. On the Edit menu, click Delete. The page no longer appears in the Navigation view.

Organizing and managing pages

FrontPage 2000 makes it easier than ever to manage the development of a complex Web site by allowing you to easily move Web pages, assign, track, and update tasks, and keep track of broken links, slow pages and old files.

Create tasks to track work that needs to be done in your Web. You can assign a task to a specific person or workgroup, prioritize the importance of the task, and associate the task with a specific file or the entire Web.

FrontPage 2000 monitors task status for you. When you save a page associated with a task in Page view, FrontPage 2000 asks if you want to change the task status to Completed. If you answer No, FrontPage 2000 changes the task status to In Progress. You can also mark tasks as completed in Tasks view.

To move a page within your Web

17. Click the page you want to move.

18. Drag the page to the preferred location by clicking and holding the mouse button down while moving the pointer to the new location.

To create a task

Use tasks to maintain and manage your Web. You can assign and prioritize tasks and link them to pages, pictures, sounds, other Office documents, or any other files in your Web.

19. In Page view, go to the Departments and Faculty page.

20. On the Standard toolbar, click the arrow next to the New button and then click Task. The New Task dialog box appears.
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21. In the New Task dialog box, in the Task name box, type Faculty Extensions.

22. In the Assigned to box, type or select the name of the person you want to assign the task to. 

23. In the Description box, type Gather faculty phone extensions for use on this page or other description of the task. 

24. In the Priority area, click a priority for the task and then click OK. 

To assign a task

You can more effectively manage the workflow of your Web site by assigning tasks to different students. You can assign a task to a person, a group, or anything else that you can type or select in the Assigned To list. 

· You can assign a task when you create it. Type or select a name in the Assigned to box of the New Task dialog box. 

· You can assign a task after you've created it. In Tasks view, click the cell in the Assigned to column of the task you want to assign, click the cell again, and then type or select a name. This overrides any assignment made when the task was created. 

· If a task has been marked as Completed, you can't reassign it.

Using check-out and check-in

When a group of students and educators work on a Web together, many people create and edit Web content. When working in groups, there is always a danger that two people could open and edit the same page, only to discover after the fact that a conflict has occurred. FrontPage 2000 helps alleviate this problem by adding page-level Check-In and Check-Out.

When you check out a file, only you can modify it. Other authors can open the last-saved version of the file to view it, but cannot save any changes to it. This means you no longer have to worry about one person over-writing another person’s changes. After you check in a file that you have edited, other authors can then check out the file and modify it.

Before you can check out a file

25. On the Tools menu, click Web Settings. 

26. Click the General tab.

27. Select the Use Document Check-In and Check-Out checkbox.

28. Click Yes when asked if you want to proceed.

To check out a file

29. In the Folder List in any view or in Folders view, right-click the file you want to check out.

30. Click Check Out on the shortcut menu. Files available for check-out have a green dot next to them. Files that are currently checked-out have a red check next to them.

To check in a file

31. In Page view, click Save [image: image6.png]


 to save your changes. 

32. In the Folder List in any view or in Folders view, right-click the file you want to check in, and then click Check In on the shortcut menu. 

Managing large Webs

In order to manage a large Web, you may want to control who can have access to different sections of the Web. To easily set access control for viewing, editing, and administrating permissions over any portion of a Web site, FrontPage 2000 introduces the ability to create Webs within Webs, called subwebs. You can also create a nested subweb below another subweb. Nested subwebs allow you to have control over site-wide management issues and allow groups of users to have access to specific content. For example, in your school’s Web site, the students could have a nested subweb they would own, then the newspaper staff could have a nested subweb within the student subweb. This allows sites to grow larger yet at the same time be more easily managed.

To create a nested subweb

33. On the Views toolbar, click [image: image7.png]


 to go to the Page view.

34. On the File menu, click New, and then Folder.

35. Name the new folder.

36. Click the folder you just created.

37.  In the Folder List, right-click the folder you want to convert to a web, and then click Convert to Web on the shortcut menu. 
To change permissions

In order to change the permissions on a subweb, you must have the FrontPage Server Extensions installed on the Web server.

38. Select the subweb on which you want to change permissions.

39. On the Tools menu, click Security, and then Permissions.

Selecting target browsers

Many of the exciting features discussed in the following chapters work only in the latest browsers. FrontPage 2000 includes a tool that allows you to target your Web for compatibility with specific browsers and technologies. 

If you are creating an intranet and know that everyone visiting your Web site in your school has the most current versions of Microsoft Internet Explorer, all of the FrontPage 2000 features are available. 

If you are creating a Web site for use on the internet, and you want visitors with older browsers to see the same features that viewers with new browsers see, you need to set the target browser for the older browsers. Commands not supported by those browser technologies or versions are unavailable (that is, they appear dimmed) on menus in FrontPage 2000 as you work. 

· The following table lists the default technologies and features supported for each browser compatibility combination. If you override the default and enable a technology or feature not supported by a specific browser or version, your pages might not be displayed properly, or they might contain errors. A check indicates that the technology or feature is supported

	Browser
	ActiveX
controls
	VB
Script
	JavaScript
and 
Java applets
	Dynamic
HTML
	Frames
	CSS
1.0
	CSS
2.0
	Active 
server 
pages

	 Internet Explorer
 4.0 and later
	√
	√
	√
	√
	√
	√
	√
	√

	 Internet Explorer
 3.0 and later
	√
	√
	√
	√
	√
	√
	
	√

	 Netscape Navigator
 4.0 and later
	
	
	√
	√
	√
	√
	√
	√

	 Netscape Navigator
 3.0 and later
	
	
	√
	
	√
	
	
	√

	 Internet Explorer 
 and Navigator
 4.0 and later
	
	
	√
	√
	√
	√
	√
	√

	 Internet Explorer 
 and Navigator
 3.0 and later
	
	
	
	
	
	
	
	√

	 Microsoft WebTV
	
	
	
	
	
	
	
	√


· If you choose Netscape Navigator only, Both Internet Explorer and Netscape Navigator, or Microsoft Web TV in the Browsers box, the following commands and settings are unavailable: 

· Marquee 

· Video 

· Table background picture 

· Cell borders and background 

· If you choose Microsoft Internet Explorer, Both Internet Explorer and Netscape Navigator, or Microsoft Web TV in the Browsers box, the Blink check box setting is unavailable: 

To target only selected browsers

40. On the Tools menu, point to Page Options, and then click the Compatibility tab. 

41. In the Browser box, select the specific browsers you want. 

42. In the Browser versions box, select the specific versions of browsers that you want. 

Tracking the progress of the Web site

You can create reports that: 

· Indicate which pages in your Web take too long to download. FrontPage 2000 calculates the size of all pictures, text, controls, and other elements linked to any page in your Web to show how long it takes for site visitors to download that page at different modem speeds. 

· Indicate which files in your Web aren't linked to any other files. You can use this information during regular Web maintenance to delete any outdated or duplicate files. 

· Show and print site summaries. FrontPage2000  calculates the number and sizes of pages, pictures, incomplete tasks, and other elements in your Web. You can see which files are oldest or newest, group them by the person or workgroup they're assigned to, sort them by size, and so on. 

In Reports view, the Site Summary report lists the total number of hyperlinks in your Web as well as the number of unverified links, broken links, external links, and internal links.

Hyperlinks view shows you a graphical representation of the hyperlinks to and from any file in your Web. FrontPage 2000 automatically tracks and repairs any internal hyperlinks in your Web whenever you move, rename, or delete a file. You can instantly check the status of any external hyperlinks using the Recalculate Hyperlinks command on the Tools menu.

Extending your knowledge
To give your site a professional look, you can choose from templates and themes to design a Web in FrontPage 2000. You can look at different Web site templates to see the types of pages included on the site. This may give you additional ideas about how to use FrontPage 2000 in your classroom.

Design an intranet for your Web site. Intranets enable groups to share information quickly and easily. An Intranet would be perfect for a school to share student work and staff information. The Microsoft Office 2000 60 Minute Intranet Kit provides a template that helps you set up an Intranet. To order the kit, go to the following Web site:

http://www.microsoft.com/office/intranet

Also, you can order the FrontPage 2000 45-day Trial CD for $6.95. This is a bonus pack CD with a FrontPage 2000 tutorial and hands-on exercises. The CD also has additional themes and clip art. To order the CD, go to the following Web site: 

http:www.microsoft.com/frontpage/trial

What you will do:





Create an outline for your Web site.�


View the design of a FrontPage Web.�


Add and customize a theme.�


Add and delete pages.�


Organize your pages.�


Decide which browsers you want visitors to be able to use to view your site.�


Learn to track the progress of the Web site design by assigning status, author, and categories.
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Click the arrow next to the Open button.








Then, click the Open Web button.
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If you create a task in Page view while editing a page, the new task is automatically associated with that page. To associate a task with a page or file in another view, select the file, and then create the task. 
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The Assigned To list is shared with Reports view for assigning files. In Reports view, you can assign a file to someone without creating a specific task.
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To see the checkout status of files, point to Reports on the View menu, and then click Checkout Status.
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To see the checkout status of files, point to Reports on the View menu, and then click Checkout Status. 








Click the arrow next to the New button.

















Then, click the New Task button
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To target specific technologies or features instead of browsers, click Custom, and then in the Technologies area, select or clear the check boxes of the specific technologies or features you want to enable or disable.
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On the File menu, click Import to import any site you like in order to get started quickly. Change the graphics and text to match your own.
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