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Adding Features 
to your Web

Now that you’ve finished creating your Web site, you’re ready to publish it. Before you do though, considering adding some extra flare and character to your Web. You can add animation effects, set up tables, forms, and frames, create buttons that change when you move your mouse pointer over them, insert video clips, and more. Adding these features to your Web without FrontPage 2000 would normally mean that you would need to know a lot of complex code, but FrontPage 2000 does all the work for you.

Before you begin

· Look over your Web pages and decide which headings could benefit from an animation effect. You can make your text slide, bounce, or spiral onto the page. You can also pick the timing for the effects: when the page finishes loading, when you mouse-over the text, and when you click text.

· Determine what types of information would be best placed in a table. Examples include faculty schedules, athletic schedules listed by sport, calling trees, and room assignments.

· Brainstorm about the information you may want to collect from alumni. This can include name, address, and job status.

Adding animation effects

With FrontPage 2000, it’s easy to add animation effects to create movement and interest to a Web page. Please note that because people use all kinds of browsers to access the World Wide Web, animation effects created with DHTML code cannot be seen by everyone who may visit your site. In order for the animation to work the way you expect it to, visitors must view the animation with Internet Explorer 4.0 or later or with Netscape 4.0 or later. When browsers don’t support DHTML, text appears just as it did before you added the effect. 

You may also want to look at FrontPage 2000’s new feature that lets you know whether or not an effect is compatible with a particular browser—especially if you want viewers with older browsers to see the effects included on your Web site. See the Selecting target browsers section in the Designing a Web Site chapter of this book for more information.

To add DHTML animation to a heading

1. On the Views toolbar, click Page.

2. Double-click central_high_school_home_page.htm.

3. On the Format menu, click Dynamic HTML effects. The DHTML Effects toolbar appears.

4. Select the heading “Welcome to the Central High School Home Page!”

5. In the On box, select Page load, so that visitors to your site see the effect as the page loads in their browser.

6. In the Apply box, select Elastic. The heading stretches like elastic as the page loads.

7. To see the effect, on the File menu click Preview in Browser. If you are prompted, save your work. You see the effect as your browser loads the page.

Creating a table

On Web pages, information often appears in tables with invisible borders. Tables help you control your page layout so that everything is easy to find and to read. Tables display information in a side-by-side format, in rows and columns. Each block of information is called a cell, which can contain text, images, lists, and even other tables. Choose from one of FrontPage 2000’s multiple templates for tables the table that suits your needs.

In FrontPage 2000, tables are simple to create. In fact, you can set up tables with FrontPage 2000 in much the same way you can in Microsoft Word. In the following procedure, you create a table to organize teacher phone extensions, room numbers, and classes taught.

To set up a table 

8. On the Views toolbar, click Page.

9. Double-click departments_and_faculty.htm.

10. Position the mouse pointer where you want to insert the table on the page.

11. Click the Table [image: image1.png]


 button.

12. Drag the cursor over the three columns and five rows. To expand the number of columns or rows available in the box, click and drag the cursor while highlighting the appropriate number of cells. The table appears in your Web page.

13. Enter the following information in the table.

	
Name
	Phone Extension #
	Room Number

	Browne, Kevin 
	2377
	102

	Cole, Sean
	2358
	120

	Martin, Nina
	2398
	110

	Wheeler, Wendy
	2367
	109


To create new table cells

14. On the View menu, click Table Toolbar.

15. On the Table toolbar, click the Draw Table [image: image2.png]


 button. The mouse pointer becomes a pencil.

16. With the pencil, in the top right cell, draw a vertical line from the right of Room Number down through the bottom cell, so that you "cut" the column in half.

17. On the Table toolbar, click the Draw Table button to de-select the pencil.

18. Place the mouse pointer on the line between the Phone Extension # and Room Number columns.

19. When the double-arrow appears, click and drag the column border to the left.

20. Using the double-arrow, resize all the columns to make them equal.

21. In the first cell of the new column, type Subject Taught.

22. In the cells beneath “Subject Taught”, type Chemistry, Computer Science, Science, and Math.

Adding interactivity to a Web with forms

With FrontPage 2000, you can use forms for visitors to you Web site to fill out. With the forms, you can gather all kinds of information. Set up forms for alumni polls, faculty surveys, and student research projects. Forms can contain text, tables, images, and fields that visitors fill out and send to you. You can also easily customize a form by adding bulleted lists, pop-up menus, buttons, check boxes, labels, and places for visitors to enter text. In the following lessons, you create a form that uses buttons and text areas. After collecting the information, you can then send it to a database and publish the database on another Web page.

To format a form title

23. On the Views toolbar, click Page.

24. Double-click alumni_activities.htm.

25. Type Alumni Information on the first line, and select it.

26. On the Format toolbar, click the Bold [image: image3.png]


 button.

27. Change the font size from Normal to 16 pt.

28. On the Format toolbar, click the Center [image: image4.png]


 button.

29. Click below Alumni Survey, and press ENTER. 

30. On the Format toolbar, click the Align Left [image: image5.png]


 button.

To create radio buttons

Radio buttons require you to select one option from the button choices.

31. On the Insert menu, click Forms, and then click Radio Button.

32. Click in front of the radio button you just inserted, and press ENTER to move the button down so you can type above the radio button.

33. Press the UP ARROW key, and type Did you graduate from Central High?
34. Click between the radio button and the Submit button, and press ENTER.

35. Click after the radio button, and type Yes.

36. Press TAB several times. Follow step 1 to insert another radio button.

37. Type No after the button, and press ENTER.

To create check boxes

Check boxes allow you to select several options.

38. Type If yes, what year(s) did you attend Central High School?, and press ENTER.

39. On the Insert menu, click Forms, and then click Check Box.

40. Place the cursor after the check box, type 1968, and press TAB.

41. Repeat steps 2 and 3 to insert check boxes for subsequent years.

42. Press ENTER.

To create one-line text boxes

A one-line text box limits the amount of text you can type in the box.

43. Place the cursor on a blank line below the check boxes. Type First Name.

44. On the Insert menu, click Forms, and then click One-Line Text Box.

45. Press TAB twice, type Last Name: and then repeat step 2 to add another one-line text box, press ENTER.

To create a scrolling text box

A scrolling text box does not limit the amount of text you can type in the box.

46. Place the cursor below the one-line text box, and type Comments:.

47. On the Insert menu, click Forms, and then click Scrolling Text Box.

48. Click the scrolling text box and drag the handles to resize the text box to the size you would like. Although the box is a particular size on screen, this does not limit the amount of text someone can type in the box.

49. Save your page and click the Preview tab to see what it looks like in a browser.

You must publish your Web site before data can be submitted from your form. To find out more about publishing your Web site, see the Publishing a Web Site chapter in this book.

Using form results with a database

After you collect information from the alumni, you can save the information on a database and publish the database information on your Web. In this section you learn to send the data from the form to a Microsoft Access database, and then show the contents of the database on a Web page. 

The database integration features require you to host your pages on a server with Active Server Pages (ASP) capabilities, such as Microsoft Internet Information Server. You can use these capabilities with any ODBC-compliant database. In this exercise, it is assumed that you have an ASP-capable server. If you are not, you can author on your hard drive or a network drive, and later publish to your ASP-capable Web server.

To save form results in a database

50. Return to Page view.

51. Right-click the radio button with yes next to it, and then click Form Properties.

52. Select the Send to Database option, and then click the Options button.

53. Click Create Database. FrontPage 2000 automatically creates the Access database file and places it in the newly created directory in your Web. Since the page is called Alumni.htm, the database connection will also be called Alumni.

54. In the dialog that appears, click OK to confirm that the database has been created. The Options for Saving Results to Database dialog box appears.

55. Click OK, and then click OK again in the Form Properties dialog box. Another dialog box appears warning you that the page should be saved as ASP.

56. Click OK again. 

To save the page

57. On the File menu, click Save As, and then click OK.

58. In the File Name box, type Alumni, and in the Save As Type box, select Active Server Pages, and then click Save.

To create a page the shows data from the database

59. Go to Page view and click the New Page [image: image6.png]


 button.

60. On the Insert menu, click Database, and then click Results.

61. Select the Use an Existing Database Connection option, select Alumni, and then click Next.

62. Continue to click Next in the following dialogs, and then click Finish.

63. Save the page as results.asp.

Adding hover buttons

Hover buttons are like other buttons that contain hyperlinks to other pages or files, making Webs more fun to visit. When you hover your mouse pointer over a hover button, it can glow, display a custom picture, or play a sound effect. 

To add a hover button 
64. In Page view, double-click on alumni_activities.htm. 
65. In the bottom-shared border, select the link text, Central High School Home Page.
66. Click the Insert Component [image: image7.png]


 button, and then click Hover Button. 
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67. In the Button text box, type Central High School Home Page as the label for the hover button. 

68. In the Link to box, type central_high_school_home_page.htm.

69. In the Button color box select a theme color.

70. In the Effect color box select a theme color that compliments the button color you have chosen.

71. In the Effect box, select Glow.

72. Click OK.

73. Resize the button by clicking and dragging the handles until it is the appropriate size.

74. To view this effect, save your file and click the Preview tab. 

Extending your knowledge

You can make your Web site even more useful and fun by adding discussion webs, frames, and hit counters. With discussion webs, you can allow people to participate in on-line discussions through your Web site. Use the discussion webs feature to promote online study groups, parenting forums, or parent/teacher communications. With frames, you can have greater control over how people navigate through your site. FrontPage 2000 provides you with several templates to make building frames simple. And if you’ve ever wondered just how many people visit or “hit” your site each day, FrontPage 2000 can help. You can add a hit counter anywhere on your.

Exploring discussion Webs 

Discussion webs are interactive webs that let site visitors discuss topics by reading articles or messages that have been posted, replying to articles, and posting new ones. For example, your Web site may have a discussion group for students to create an on-line study group, or there may be an area for teachers and parents to discuss class assignments and homework tips. Create a discussion web by using the Discussion Web Wizard. The wizard asks for the features you want to use, then creates a Web and sets up the pages for you. After you create the Web, you can open the pages and customize them. 

To create a discussion Web

75. On the File menu, point to New, and then click Web. 

76. On the Web Site tab, click Discussion Web Wizard. Check the Add to current Web check box, and then click OK. 

77. Once the Discussion Web Wizard opens, follow the on-screen directions to create a discussion group. Accept the wizard’s default settings, except for the following:

· In Enter a descriptive title for this discussion, type Parent and Faculty Discussion Group, and then click OK. 

· In the Do you want the Table of Contents for this discussion to be the home page for this web? box, select No.

· In the Frame options box, select the Dual interface option. This allows the server to adjust the discussion page based on whether or not the viewer’s browser can see frames. 

78. Click Finish to generate your discussion Web. This creates several new HTML pages in your folder. The main page of the discussion Web is named disc1_frm.htm, which is where you want to direct hyperlinks.

79. After the wizard has set up your Web pages, modify them as you would any other Web page. 

80. To preview the discussion web, double-click disc1_frm.htm. You must publish your Web site before you can have a fully functional discussion Web. To find out more about publishing your site, review the Publishing a Web Site chapter in this book.

Creating and adding a hit counter

A hit counter tallies and displays the number of times a page has been visited. To see how many people have visited your Web site, you can add a hit counter. For example, add a hit counter to your alumni page so that you and site visitors can see how many times the alumni page has been visited.

To install a hit counter

81. On the Views toolbar, click Page.

82. Double-click alumni_activities.htm and place the pointer at the bottom of the page above the shared border.

83. Click the Insert Components [image: image9.png]


 button, and then click Hit Counter.

84. In the Hit Counter Properties dialog box, select a counter.

85. Select Reset counter to, and type 0 in the text box.

86. Select Fixed number of digits, type 5 in the text box, and click OK.

87. Click the Save [image: image10.png]


 button. You must publish your Web site before you preview the hit counter. 

Working with frames

Frames determine how Web pages are displayed in the browser window. Frames, which divide the Web browser window into different areas, can retrieve and display a separate page in your Web. You control the display of the page in a frame by creating a hyperlink to the page and specifying the frame as the target of the hyperlink. 

FrontPage 2000 has a set of templates for creating Frames pages. These allow you to place many frames in a frame layout document. A simple frames page has two frames, one containing hyperlinks, and the other displaying the pages that the hyperlinks point to. In other words, when a visitor clicks a hyperlink in the first frame, the page the hyperlink points to is displayed in the second frame.

To add frames to a page

88. On the File menu, click New and then click Page. 

89. In the New dialog box, click the Frames Pages tab and select the template Contents. 

90. Click OK.

91. Click inside the left frame to select it, then click New Page.
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92. At the top of the left frame type Alumni Directory, highlight the text, and then select Heading 2 from the Style drop-down list.

93. Below the heading, type 1968 and press ENTER, 1969 and press ENTER, 1970 and press ENTER, 1971 and press ENTER, and type Alumni Survey.

94. Click inside the right frame to select it, then click New Page.

95. Type Welcome to Central High School's Alumni Directory, highlight the text, select Heading 2 from the Style drop-down list, and then Press ENTER.

96. Type, Former Central High School students have provided the information presented in the directory. If you would like to submit alumni information, please fill out the alumni survey.
To save a frames page

The page you just created actually consists of three individual HTML pages. When saving a new frames page, you are prompted to save all three.

97. Click the Save [image: image12.png]


 button.

98. In the File Name box, type alumni_directory.htm.
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99. Click Save. The Save dialog box remains on-screen and you are prompted to save the two remaining documents.

100. In the File Name box, type year_of_attendance.htm.
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101. Click Save.

102. In the File Name box, type directory_main_page.htm.
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103. Click Save.

To create a link on a frames page

104. In the left-hand frame, select the text “Alumni Survey.”

105. Click the Insert Hyperlink [image: image16.png]


 button.

106. In the Edit Hyperlink dialog box, select alumni_activities.htm.

107. Click OK.

108. Test the link by previewing this page. When you click on the hyperlink, the new page should load in the right frame, and the left frame should remain the same.

What you will do:





Add animation effects to your Web.�


Use a table to improve you display information.�


Add a survey to your Web.�


Create a hover button.�


Host interactive discussions on your Web. �


Create a hit counter.�


Learn about and create a frame for your page.��








�To highlight the text that will be animated, click the Highlight DHTML Effects � EMBED Word.Picture.8  ���button in the DHTML Effects toolbar. Place your cursor over the highlighted text to view a description of the effect.








�When you click a template, FrontPage 2000 displays a thumbnail showing that template's frames layout in the Preview area. 








�


Selecting the Dual interface option allows users with browsers that don’t see frames to view your pages. This is especially helpful for those people using browsers with screen reading capabilities.








Left Frame





Right Frame





This blue border indicates that you are saving the frame definition page.








This blue section indicates that you are saving the HTML page in the left frame.








This blue section indicates that you are saving the HTML page in the right frame.
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