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Connecting Pages
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Now that you have added the Web pages and content to your Web site, you can create hyperlinks between pages and to other Web sites on the World Wide Web. 

Like the term “World Wide Web” suggests, the Internet is made up of an enormous numbers of linked computers, Web sites, documents, images, and text. Hyperlinks are what make up the strands of the web. When you link your site to the World Wide Web, your site becomes part of a huge network of information and with FrontPage 2000, becoming a part of the World Wide Web is simple.

Before you begin

· Use your outline to determine which of your pages to link together.

· Decide on an e-mail address to use as a point of contact for people who wish to correspond with someone involved with the Web site.

· Make a list of sites outside of your own Web site that you want to create links to. Later in this chapter you learn how to create links to those site, so you may want to copy down the web address names. It is important to make sure that you record the exact web address, or links you create may not work.

Creating hyperlinks

Hyperlinks connect locations on the World Wide Web, such as Web pages, different sites, or just paragraphs located on the same page. Hyperlink destinations can be text, graphics, e-mail addresses, files (such as a multimedia file or Microsoft Office document), or programs. A hyperlink can be text or a picture.

Images containing hyperlinks are known as image maps. A well-designed image map gives users visual cues about where each hyperlink takes them. For example, an image map for a tourism bureau could be an actual map of a geographical region. Clicking on a city in the map could take you to tourist information about the city.

On your Web you can include links to other sites that visitors to your site might want to check out. On your Educational Links page, you could list your favorite links to the World Wide Web. This provides an easy way to get to your favorite and most often used Web sites on the World Wide Web.

When you type a hyperlink in Page view, FrontPage 2000 automatically formatts the link. The text and a line below it appear in blue and, with an active Internet connection, a link occurs when you click. 

Understanding the URL

The destination of a hyperlink is encoded as a URL, or Uniform Resource Locators. URLs, also known as web addresses, contain information about web servers or network location, path, and file name. 

	http://www.microsoft.com/frontpage/productinfo/default.htm

	Protocol
	Web server or network location
Also called a domain
	Path
	File name


Hyperlinks are made up of URLs that are either absolute or relative: 

· An absolute URL contains the full address and is generally used for linking different sites. 

· A relative URL has one or more missing parts and is generally used for linking within a particular site. If the protocol and domain are missing, the Web browser uses the protocol and domain of the current page. 

When you create hyperlinks in FrontPage 2000, you do not need to know the destination URL. You can browse to the page, or file whether on the World Wide Web or a system you and your site visitors can access, and FrontPage 2000 provides the correct URL. For hyperlinks to destinations in the Web you are working on, FrontPage 2000 creates relative URLs. If you rename or move a file in your Web, FrontPage 2000 updates all the URLs that point to the file. By generating relative URLs, FrontPage 2000 saves you time and ensures that your Web site is portable. 

Creating a hyperlink to a page or file in a Web
Creating hyperlinks with FrontPage 2000 is easy. You can use the Create Hyperlink dialog or drag and drop to create a hyperlink to a destination such as a page or file in a Web. You can create hyperlinks from your home page to the other pages in the Web or create a hyperlink to a GIF picture. In this activity, you create hyperlinks to favorite Web sites from the Educational Links page

To create a hyperlink within your Web site

1. If your Central High School Web site is not open, open it and go to Page view, and then double-click central_high_school_home_page.htm. Each of the bulleted items has the title of a Web page already in the text.

2. Select Calendar of Events in the first bulleted item to link to the Calendar of Events page in you Web site.

3. Click the Hyperlink [image: image1.png]


 button. 

4. Click calendar_of_events.htm in the Create Hyperlink dialog box and then click OK. The text changes color and now has an underline indicating that it is a hyperlink.

To create a hyperlink to the World Wide Web

5. In Page view, double-click educational_links.htm.

6. Type the text you want to use as a hyperlink and then select it. For example, type and select "Encarta Schoolhouse." 

7. Click the Hyperlink [image: image2.png]


 button. 

8. Type the URL in the URL area and click OK.
-Or-
Click the World Wide Web [image: image3.png]


 button. In your Web browser, browse to the page that you want, and then press ALT+TAB to switch back to FrontPage 2000. The location of the page you visited is displayed in the URL box. 

Creating a bookmark

A bookmark, also known as an anchor, is a location or text on a page marked as a destination for a hyperlink. If a Web page is long and divided into sections, a bookmark allows you to link to a section of the page rather than to the top of the page as with conventional hyperlinks. To display the section of a page to the site visitor, insert a bookmark at the beginning of the section, and then create a hyperlink with the bookmark as its destination. When the site visitor clicks the hyperlink, the relevant part of the page is displayed, rather than the top of the page. 

If a location is bookmarked, you see a blue flag [image: image4.jpg]


 when looking at your Web page in Page view with the Normal tab selected. The flag is simply a reminder to you of the bookmark’s location. It is not visible when viewing the Web page in the browser. If text is bookmarked, the text is displayed in Page view with a dashed underline when the Normal tab is selected. 

To create a bookmark

9. In Page view, position the insertion point where you want to create a bookmark, or select the text to which you want to assign the bookmark. 

10. On the Insert menu, click Bookmark. 

11. In the Bookmark name box, type the name of the bookmark (spaces are allowed). 

Create a hyperlink to a bookmark

12. In Page view, type the text you want to use as a hyperlink, and then select it.
-or-
If you want to use the name of a bookmark as the hyperlink text, position the insertion point where you want to insert the hyperlink.

13. Click the Hyperlink [image: image5.png]


 button.

14. Select the page that contains the bookmark.

15. In the Bookmark box, click the bookmark you want to use as the destination.

Adding linked graphics to a Web 

Just as you can use pictures and images to make your Web more visually appealing, you can also to create links using graphics rather than ordinary test. When you insert graphics, it is a good idea to also add ALT text, which creates a description of the graphic that visitors see when they hover a cursor over the graphic. ALT text is helpful when visitor with disabilities cannot see the graphic or it the graphic is not available for viewing.

To insert an image

16. On the Educational Links page, place the cursor to the left of the Encarta Schoolhouse link.

17. On the Insert menu, point to Picture, and then click Clipart. The Clip Art Gallery dialog box appears.

18. On the Pictures tab, scroll down and click Buttons & Icons.

19. Click the button graphic you prefer, and then click the Insert clip button.

To add ALT text to a graphic

20. Right-click the image you just inserted.

21. Click Picture Properties, and then click the General tab.

22. Under Alternative representations in the Text box, type the text that you want to appear in the event that the graphic is not available to the person viewing your Web page. For example, type This button is a link to Encarta on the Encarta link button.

23. Click OK.

To create a hyperlink from a graphic

24. Click the image you just inserted.

25. On the Standard toolbar, click the Hyperlink [image: image6.png]


 button. The Create Hyperlink dialog box appears.

26. In the Create Hyperlink dialog box, type the Encarta Schoolhouse URL in the URL box.

27. Click OK. The button is now a hyperlink.

Creating image maps

Image maps are graphics that contain multiple hyperlinks. FrontPage 2000 allows you to create image maps by inserting the image on the page and using the tools on the Image toolbar to create several hotspots that include hyperlinks. A hotspot is an area on a graphic that links to another page or Web site. Generally, hotspots are simply an area on a graphic, but you can also add text to the hotspot.

To insert an image

28. On the Educational Links page, place the cursor to the right of the Encarta Schoolhouse link and press ENTER.

29. On the Insert menu, point to Picture, and then click Clipart. The Clip Art Gallery dialog box appears.

30. In the Search for clips box, type world.

31. Click the globe graphic, and then click the Insert clip button.

32. Add ALT text to the graphic.

To create a hotspot

33. On the View menu, point to Toolbars, and then click Pictures.

34. On the Pictures toolbar, click the Rectangular Hotspot [image: image7.png]


 button. The mouse pointer becomes a pencil.

35. With the pencil, draw a rectangle around North America to create a hotspot. The Create Hyperlink dialog box appears.

36. In the URL box, type http://encarta.msn.com/evg/default.shtm, the URL for the Encarta Virtual Globe.

37. Click OK. The area is now a hyperlink.

To create a text hotspot

38. On the Pictures toolbar, click the Text [image: image8.png]


 button. 

39. In the text box that appears, type Xpeditions.

40. Move the text box to the location you want by clicking and dragging the text box border.

41. Double-click the border of the text box. The Create Hyperlink dialog box appears.

42. In the URL box, type http://www.nationalgeographic.com/xpeditions/
main.html?main=hall, the National Geographic Expeditions URL and then click OK. 

Adding an e-mail hyperlink

In addition to conventional hyperlinks, you can also add links to e-mail. You can create a hyperlink that opens and addresses an e-mail message to the address you specify. This allows visitors to your Web site to send you comments.

To add an e-mail link

43. Go to the Central High School Home Page in Page view.

44. Position the pointer after the fax number in the bottom shared border, and press ENTER.

45. On the Standard toolbar, click Hyperlink [image: image9.png]


.

46. In the Create Hyperlink dialog box, click Make a hyperlink that sends 
E-mail [image: image10.png]


. The Create E-mail Hyperlink dialog box appears.

47. In the Type an E-mail address text box, type the address you want comments to be sent to, and click OK.

48. In the Create Hyperlink dialog box, click OK.

Removing hyperlinks

At some point, you may decide you want to remove a link if your Web changes or if the link no longer works because someone else’s site has changed. Deleting a hyperlink from a page is simple. 

To remove a hyperlink from your Web

49. In Page view, select a hyperlink on one of the pages in your Web site. 

50. Do one of the following: 

· To delete the hyperlink completely, including the hyperlink text, press DELETE. 

· To preserve the hyperlink text but delete the hyperlink associated with it, select the hyperlink, and then click Hyperlink [image: image11.png]


 button. Select the contents of the URL box, and then press DELETE. 

Managing hyperlinks on your Web site

With FrontPage 2000, you can check your Web has incorrect or broken hyperlinks and quickly, repair them. A broken hyperlink is one that has an invalid destination URL and returns an error if the site visitor clicks the hyperlink. 

Verifying hyperlinks

A critical part of managing a Web site is verifying that the hyperlinks go to the correct external destinations (destinations that are outside of your Web). After hyperlinks have been verified, their status does not change until you verify the hyperlinks again, or close and reopen the Web. 

To verify your hyperlinks

51. In Reports view, click the Verify Hyperlinks [image: image12.png]


 button on the Reports toolbar. 

52. Select the Verify all hyperlinks option, and then click Start. The status of all hyperlinks in the current Web appears. 

Repairing broken hyperlinks

A hyperlink might have an invalid URL for various reasons; you may have mistyped it, or, if the destination page is on another World Wide Web site, the page might have been changed or removed. 

To repair a hyperlink

53. On the View menu, point to Reports, and then click Broken Hyperlinks. 

54. All broken hyperlinks in your Web are listed. If a hyperlink's destination is not in the current Web, the status of the hyperlink is Unknown.

55. Double-click a hyperlink with Broken status. 

56. To display the page to edit it, click Edit Page. 

57. If you know the correct URL of the destination, edit it in the Replace hyperlink with box. 
-or- 
Click Browse to browse to the page or file in a Web, file system, or World Wide Web. 

58. To repair other occurrences of this hyperlink in all pages in the current Web, click Change in all pages. 
-or-
To repair other occurrences of this hyperlink in selected pages, click Change in selected pages, and then select the pages. 

59. Click Replace. If the hyperlink's destination is not in the current Web, the status of the hyperlink changes to Unknown. If the destination is valid, the hyperlink no longer appears in the Broken Hyperlinks report.

Previewing your Web in the browser

After creating your hyperlinks, you should test each link. You can do this by previewing your Web with your browser. . (A browser is software that displays Web pages.) When your Web site is open in the browser, click each link to make sure it works properly. Use the Back button to return to your own Web site. FrontPage 2000 includes Microsoft Internet Explorer 5.0, a popular Web browser You can use Internet Explorer 5.0 to review pages you have created, to check hyperlinks, and to explore the World Wide Web.

To preview your Web using Internet Explorer 5.0

Simply click the Preview tab.

To preview your Web using other browsers

60. On the File menu, click Preview in Browser. 

61. In the Preview Browser dialog box, select the browser you wish to use, and click Preview. The browser opens to your Web site.

62. Click some of the links you made in this chapter and look at the work you have done.

63. On the File menu, click Close when you are finished previewing.

Extending your knowledge

In addition to adding hyperlinks to text, graphics, pages, and sites, FrontPage 2000 lets you create links to Microsoft Office documents. This is especially helpful if your Web site is on an intranet and you want other educators to have access to Microsoft Office documents. 

Creating hyperlinks on your Web for Office documents

With FrontPage 2000, you can quickly and easily create hyperlinks to Office documents, such as documents created in Word or Excel. When a visitor to your Web site clicks a hyperlink to an Office document, the document opens. Some Web browsers display the document inside the browser window; other browsers open a separate window.
To create a hyperlink to an Office document 

64. In Page view, type the text you want to use as a hyperlink and then select it. For example, type and select "Budget Spreadsheet." 

65. Click the Hyperlink [image: image13.png]


 button.

66. Do one of the following: 

· If the Office document is in the current Web, navigate to the Web in which the document is located, and then select the document. 

· If the Office document is on the local file system and you have access permission to the file, click the File button, browse to the document, and then select it. 

· Import the file into your Web site.

67. Click OK. The text you selected is now a link to the document.

What you will do:





Create hyperlinks within your Web site.�


Create text hyperlinks to sites on the World Wide Web. �


Create an image map.�


Use hyperlinks to receive e-mail.�


Remove  hyperlinks.�


Check the hyperlinks in the Hyperlinks view.�


Preview your Web in the browser.�


Create a hyperlink to an Office document.








�Not all Web browsers support hyperlinks to e-mail addresses. 








�If the destination page or file is in the current web, click the page or file in the Folder List, and then drag it to the open page where you want to place the hyperlink.








� If you want to have the URL on the page, you can create a hyperlink by simply typing the full URL and pressing RETURN. FrontPage 2000 automatically creates a hyperlink to the URL you typed. For example, for the Encarta Schoolhouse hyperlink, simply type http://encarta.msn.com/�schoolhouse/default.asp








�


In order to verify all of your hyperlinks, save all open pages. 
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If the Office document is in the current web, click it in the Folder List, and then drag it to the open page where you want to place the hyperlink.
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