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Analyzing Data Using Access

Databases are collections of data organized into forms and tables for easy access, management, and querying. Educators use databases every day to check accounting records, post student grades, access security systems, and register for seminars. Even your list of personal contacts and your computer financial program use databases.

Microsoft® Access enables you to harness the power of a database to enable more effective use of data. Whether you are recording grades for your students, tracking attendance, doing research, or evaluating survey data, you can make more sense of the information by analyzing it within a database application.

In this hands-on session, you will learn to create simple databases and Web interfaces to view the contents of a database. You will also learn to import data from a variety of sources, such as text files from Web-based surveys, and then analyze it. This session will prepare you to work with data you collect from quizzes, tests, and surveys that you can create in Microsoft FrontPage®.

Before You Begin

Access is a relational database management program. It enables users to create storage structures for data, to manipulate and analyze that data, and to format the data for output in printed reports or on the Web. It also integrates nicely with FrontPage to provide the data collection mechanism for data-enabled Web pages.

If you have not already done so, make sure that you download the sample data file that accompanies this tutorial titled survey.txt
The sample file can be found on the Microsoft in Education Web site at the following URL (type analyzing data in the Search field):

http://www.microsoft.com/education/ 

Touring Access

Before you start working with collected data, become familiar with the features of Access. The following illustration shows the Database Container: 




Using Databases

Imagine you have collected data in your Access database from a Web-based survey and now you want to tabulate the results. You have also given a quiz and you want to summarize the grades that are contained in a text file and then enter them into your grade book. You need to create a database that will import the students’ answers so that you can manipulate the data and create the reports.
To effectively use Access, it is important to understand the role of a database. A database is a collection of tables, queries, forms, reports, and program codes that make it easy to organize the interrelations of these objects. Tables are the containers for data arranged into rows (records) and columns (fields). Queries are questions that are asked of your data (for example, how many students failed the quiz). Forms are screens that are used to present or collect data in an organized manner (for example, the data entry screen that the registrar’s office completes for a new student). Reports format the output for printing (for example, a class schedule posted on a bulletin board). Macros and Modules are user programs that are written to automate functions or to create a complete database application. Access databases are relational databases, which mean that they contain several tables that are linked together by special matching fields called primary keys. Complex data structures can be stored and accessed in the most efficient way possible. The term relational is derived from the fact that the tables are related to each other. If you want to examine Access databases further than this workshop permits, Microsoft has a series of step-by-step books and other reference material available. Just go to http://mspress.microsoft.com and search for Access to find relevant titles and a brief synopsis of each.

Creating a Database

This section describes how to quickly create a database to store and analyze data. Databases can be very simple (like the one you will create) to very complex (like the one the IRS uses to keep track of tax records). Whole courses of study can be derived from the design and implementation of data stores. The files you will create are a foundation for your use of data and are meant to be a useful tool in your work. You will not be a database guru nor have a full-featured database when you complete this workshop, but you will have a good understanding of how to create a simple database and the extensibility of these tools.

The following illustration shows the dialog box that is presented to create a new database file:
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To create a new database

1. Start Access. In the Task Pane, click Blank Database.

2. The File New Database dialog box opens.
3. Choose a file name and location, and then click Create. Your new database will be opened in the Database Container. Note that Access 2002 will create a new database in Access 2000 file format for ease with individuals using Access 2000.
Importing Data

Data can exist in many different formats and repositories. Incorporating external data into a database is an essential time saving task. There is no need to rekey existing electronically stored data, you can just import it. Of course, Access can’t possibly read all of the different types of data formats that exist, but you can save data as a delimited text file in most applications. Delimited indicates that each section of data is separated or defined by some sort of special character. For example, the comma, the quote, and the space are very common delimiters. The data can then be interpreted from this file and imported into Access. This same method can be used to extract data from Access and into other database systems. You are going to import the results of a Web-based survey and then analyze the data to summarize the results.

To import a delimited text file

4. On the File menu, point to Get External Data, and then click Import.

5. In the Import dialog box, in the Files of type drop-down list, click Text Files, and then navigate to the file you want to import (Look for the sample file survey.txt you downloaded from the URL: ).

6. Double-click the file. 
-or-
Click the file, and then click Import.

7. The Import Text Wizard opens. Click Next to accept a delimited text file.

8. Select the First Row Contains Field Names check box. The data is shown in the main pane on this page of the wizard. Click Next.
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9. Click Next to indicate that you want to store your data in a new table.

10. Click Next to accept the field settings.

11. Click No primary key, and then click Next.

12. Change the name of the table if you want, and then click Finish. 

13. Click OK to respond to the information box that notifies you that the import completed successfully.

You now have a new table listed in the Database Container that is named by your selection in step 9. (Any additional imports will be similar to this one.)

Using Queries

Queries enable you to ask questions of your data. The answer is called a dynaset. Dynaset is a term that describes the set of records that the query returns in response to the question asked of the data. The questions allow the distillation of a large quantity of data into easy to understand statements. For example a query of student test scores can show the students who correctly answered questions 2 and 10, or the number of students with perfect attendance.

To create a simple query

14. In the Objects list, click Queries, and then click New on the Database Container toolbar.

15. In the New Query dialog box, click Simple Query Wizard, and then click OK. The Simple Query Wizard starts.
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16. Select the fields that you want to include in the query, and then click the > button. (Make sure that one of the fields that you select is the Age field.) Click Next.
17. Click Next to produce a detail query.

18. In the What title do you want for your query box, name your query to describe the question that you hope to answer by running the query. For example, type Students by enrolled major
19. Click Finish to display the completed query.

To get specific with criteria

20. After creating the previous query, change to Design view by clicking Design View on the View menu.
-or-
Click the Design View button on the toolbar.
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21. Click the criteria box in the age column, and then type >45
22. Change to Datasheet view by clicking Datasheet View on the View menu.
-or-
Click the Datasheet View button on the toolbar.

23. You will see the results of your query. Notice that all the ages of the survey respondents are greater than 45. To revise your query, change back to Design view.
24. On the File menu, click Save As, and then type a name in the space provided.

You can change the criteria in any of the columns of data by using the same steps. Think of the criteria as a statement that says “Where age (column) is equal to (operator) 50 (value).” In Structured Query Language (SQL) this is called the WHERE clause. Each criteria box you fill-in narrows down the list of records that will be returned by the query. Valid operators are In, 
Between, =, >, < or combinations of these commands.

To create a crosstab query

25. In the Database Container, in the Objects list, click Queries, and then click New on the Database Container toolbar.

26. Click Crosstab Query Wizard, and then click OK.

27. Click Next to indicate that you want to base your query on the results table.

28. Double-click major to select its contents as the row headings, and then click Next.

29. Double-click gender to select its contents as the column headings.

30. Click OwnPC as the values for your crosstab, and then click Next.

31. Click Modify the design, and then click Finish to accept the default name Survey_Crosstab.
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32. Change to Datasheet view by clicking Datasheet View on the View menu.
-or-
Click Datasheet View on the toolbar.

33. On the File menu, click Save.
-or-
Click Save on the toolbar.

When you view the output of a crosstab query, you can see that it creates a spreadsheet that contains the data you requested. Each unique item in the field chosen for row heading appears as a row heading and each unique item chosen for column heading appears as a column heading. The field chosen for the value is manipulated based on the total row setting and the values are displayed at each row/column intersection. This type of analysis is very useful for finding distributions. For example, if you have a table of student grades, a crosstab query of the data will show the grade distribution and the average for each student and each graded item.

Using Reports

Now that you have tables and queries, you can format them for output to a printer. Reports allow you to customize the look of the data contained in a table or query. The data can be grouped, sorted, and manipulated to present the data in the most useful way for those who will be reviewing it.

To create a report

34. In the Database Container, in the Objects list, click Reports, and then click New on the Database Container toolbar.

35. Click Report Wizard, and then, in the box at the bottom of the dialog box, select the table or query that will provide the data. (Select Survey for the lab.)

36. Click OK. The Report Wizard starts.
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37. Select all fields by clicking the >> button, and then click Next.

38. Double-click age, and then click Grouping Options.

39. In the Grouping Intervals dialog box, in the Grouping intervals drop-down list, click 10s, and then click OK.

40. Click Next.

41. Select a field to sort by. (For the lab, in the drop-down list, click name.) Click Next.
42. Choose the layout and orientation by clicking the appropriate options. (You can preview the affect of each by looking in the Preview pane on the left.) Click Next.
43. Select a style for your report, and then click Next.

44. Type a title, and then click Finish. Your report will open in Print Preview, so you can examine the proposed output before it is printed.

45. On the File menu, click Save As. Type the name you want, and then click OK.

You can create a report from any query or table. To create a crosstab report, select the appropriate crosstab query in step 2.

Using Web Pages

In addition to making your data available to others by printing out reports, you can create Web pages that display the contents of queries and reports. This will allow anyone with a browser to view your data in an organized manner.

To create data access pages

46. In the Database Container, in the Objects list, click Pages, and then click New on the Database Container toolbar.

47. Click Page Wizard, and then click OK.

48. In the Tables/Queries box, click the appropriate table or query. (Click Survey_Crosstab for the lab.)

49. Click the>> button to select all fields, and then click Next.

50. Click Next to continue past the screen that allows the grouping of records.

51. Click Next to continue past the sorting selection.

52. Type a name for your page, and then click Finish.
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53. On the View menu, click Page View to see the page as it will look in a browser.

Notice the navigation bar at the bottom of the data. It allows you to move quickly and easily through the records that are being displayed. You can also construct your own page from scratch but that requires knowledge of controls. Controls are the items that can be placed on a form to display contents of queries and tables, display graphics and text, and interact with the user. This is a more advanced topic outside the scope of this workshop, but there are plenty of reference materials on the subject. To begin with, search for “controls” in the Access help files. 
Getting Help

You can get help from the Access help system by typing your question in the box to the top right of your screen that says “Type a question for help”. Online Help may also be referenced at any time while you are using Access. 
Sample databases are available from Sample Databases on the Help menu. To open the online help, on the Help menu, click Microsoft Access Help. 
If you have an Internet connection, you can also point to Office on the Web on the Help menu and choose from several resources that may be of interest to you such as Product News, Frequently Asked Questions, and Online Support. You can also go to http://www.microsoft.com/access for all of the latest product information.
Information in this document, including URL and other Internet Web site references, is subject to change without notice. Companies, names and data used in examples herein are fictitious unless otherwise noted.
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What you will do:�


Use Web Templates


Import data from text files


Ask questions of your data using queries


Understand crosstab queries


Create a report 


Use Web forms





Words to know:�


Table. A storage structure for data that is composed of like columns of information (fields) and repeated in rows (records). Similar to a single worksheet in Microsoft Excel.�


Query. A question asked of the data contained in tables or other queries , for example,, “Which students passed the final?”�


Form. A screen used to format the output of a query or table for display or to allow for data entry.�


Report. Formatted output of data for printing; receives data from tables and queries.�


Field. A column of data in a table (for example, Last Name in a table of names and addresses).�


Primary Key. The field on which a table can be related to another table to join the two together (for example, your account number at your bank ties you to a table of transactions, loans, and personal data).�


Cross�tab Report. Rotation of data to allow a more organized view of the information. Creates a spreadsheet like view of data.�


Access 2002. The latest version of Microsoft’s desktop relational database management application. Allows simple database manipulation as well as full turnkey application creation. Seamless integration with the Microsoft Office family of applications.





Window Sizing Buttons





Toolbars





Database Container





Status Bar





Object Types





Menu Bar





Existing Objects





Create New Object shortcuts





�


The sample files that come with Access are excellent reference tools for developing more complex databases. Not only do you see the functionality that can be built into a database, but you are also given the features behind that functionality.





�


Some file formats can be linked into Access, which leaves the data in its native format. Dbase and Excel data can be accessed in this way.








�


Use wizards to create the basic queries, forms, and reports. Examine these to develop your knowledge of these objects as they are a great stepping stone to a full understanding of these major Access components.�
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