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Introduction

Welcome to the Microsoft® Office FrontPage® 2003 Product Guide. The purpose of this document is to assist your evaluation of FrontPage 2003, and give you a sense of the enhanced features and functionality that FrontPage 2003 offers. 

Web sites are becoming more and more sophisticated, and they require a sophisticated application that can keep pace with your Web development skills and abilities. Microsoft Office FrontPage 2003 is the Web site creation and management application with the tools, power, and features to help you produce professional sites that are dynamic and interactive. FrontPage 2003 empowers users with advances in three key areas:

1. Designing: New layout tools make it easier to design the site you want, giving you the precise layout control you need. Improved graphics support makes working with graphics from other applications much easier.
2. Coding: Use design tools to generate better code, or expand your code skills. Use built-in scripting tools for interactive results. With professional coding tools, write code faster, more efficiently, and with greater accuracy.
3. Extending: Build rich interactive Web sites using live data from a variety of sources. Easily develop dynamic XML data-driven Web sites in a WYSWYG (what you see is what you get) environment. And the enhanced publishing features help you get the Web sites you build on line in no time.
This Product Guide will walk you through the new features and benefits of using FrontPage 2003, and show you how you can build on your Web design and development skills to create engaging, dynamic Web sites.

Uses for FrontPage 2003
FrontPage 2003 provides Web designers and developers with a set of tools to enable the creation of dynamic Web sites quickly and easily. FrontPage 2003 centralizes all of the design, coding, and publishing functions to provide a total Web creation and management solution with the flexibility to match your design and coding skills, as well as push them to new levels. 

FrontPage 2003 takes advantage of the latest technologies such as XML and Microsoft SharePoint™ Products and Technologies to create powerful data-driven Web sites. FrontPage also provides easy-to-use layout and design tools to help you design great-looking sites.
For example, you could use the pre-made template and layout options and the scripting features in FrontPage 2003 to easily implement a quick site with simple interactivity. Or you can develop a more sophisticated site complete with pop-up menus.

With Microsoft Windows® SharePoint Services in Microsoft Windows Server™ 2003, FrontPage 2003 easily allows you to edit and present live data, such as Windows SharePoint Services data, XML, Web Services or OLE DB data sources, to build rich interactive data-driven Web sites that both lower your maintenance costs and allow your users to post to the Web using just the browser. 
Overview of FrontPage 2003 Features

Microsoft Office FrontPage 2003 offers new features that help you design, code, and extend your Web efforts.

Enhanced design power to produce better-looking Web sites. FrontPage 2003 provides a number of easy-to-use tools to create professional-looking Web sites that let you: 

Control the layout of your Web site quickly, easily and precisely.

Design with the graphics tools you prefer for best results.
Make your sites more accessible with tools to help ensure that people will be able to see your work.

Generate better code, faster. FrontPage 2003 helps you push your coding capabilities to new heights with powerful coding tools. With FrontPage 2003, you can:

Expand the power of your HTML.

Create interactive sites with built-in scripting tools.

Code faster and more accurately with professional coding tools.

Extend the power of your Web site into dynamic new directions. FrontPage 2003 takes the great code and Web design you create and helps you connect with people and information in exciting ways by allowing you to:

Choose from a range of publishing options.
Extend the power of your Web site to connect with people and information in new ways.
FrontPage 2003 in Action

Design Better Web Sites 

FrontPage 2003 helps Web designers create great-looking Web sites, giving you the freedom to create the Web sites you want, offering a host of layout and graphics features. And FrontPage layout and design tools help you realize your Web design vision, without requiring any knowledge of HTML.
	Feature
	Description
	Invocation

	Layout Tools
	
	

	Layout table tools

	Take pixel-precise control of your layout. FrontPage 2003 provides a special set of tools for creating and manipulating tables that are used for layout purposes. Tables that are created using these tools work equally well in different types of browsers, as well as in different browser versions. 

Use Autostretch to prevent columns and rows from being distorted when the Web page is viewed under conditions that vary, such as browser resolution or the size of the window. You can enhance the look of your page with rounded corners, shadows, borders, and other elements. 

Use the Layout Tables and Cells task pane to insert a layout table by selecting from a variety of layout styles. You can also draw or create any sort of layout table with the table pencil tool. 


	For the Layout Tables and Cells task pane: 

· In Design view, point to the Table menu, and select Table Layout Tables and Cells to open Layout Tables and Cells task pane.
To apply a layout table template:

· In the Layout Tables and Cells task pane, go to Table layout, and scroll through layout table templates.
· Click a template to apply it to the current document.
For the Draw Table tool: 
· In Design view, point to the Table menu, and select Draw Table to view the Tables toolbar. Alternately, click the View menu, point to Toolbars, and then click Tables.
· Click the Draw Table icon (the table pencil tool).

· Use the table pencil tool to “draw” another table within the page layout


	Layout Tools
	
	

	Dynamic Web Templates
	FrontPage 2003 has added support for much richer Web site templates than it has had in the past. You can create multiple templates, each containing multiple content regions, and apply these to pages in your Web site. When authoring a page linked to a template, the user is prevented from changing those parts of the page that come from the template. When you update the template file, those changes are automatically propagated to the pages linked to that template. If the editable regions have changed on the template, you simply use FrontPage 2003 to map the regions.

Further, Dynamic Web Templates are syntax compatible with templates from Macromedia Dreamweaver 4, so you can easily move your Dreamweaver Web site to FrontPage 2003 or work with Macromedia Dreamweaver users on a single site.


	To apply a Dynamic Web Template to a new page:

On the File menu, click New. 

On the New Page or Web Site task pane, under More Web Templates, select Web site templates.

In the Web Site Templates dialog box, click the appropriate template.

To apply a Dynamic Web Template to a new page:

On the Format menu, point to Dynamic Web Template, and click Attach Dynamic Web Template.

	Design-time layers
	FrontPage 2003 includes support for design-time layers, making it much easier to work with multiple pieces of content that all sit in the same space and are made visible with code at runtime. You have complete control over layer creation, placement, and visibility. It is simple to use Behaviors in FrontPage 2003 to write script to control the visibility of these images at runtime and to create sophisticated visual effects such as expanding menus.


	On the Insert menu, select Layer.


	Page rulers and layout grid
	Precision design and placement is a snap with helpful positioning guides such as page rulers and the background layout grid.
	On the View menu, click Ruler and Grid.
Select Show Grid or Show Ruler. 

	Layout detection
	Automatically identify layout tables with the Enable layout tool. You have complete control of the layout detection feature —you can turn the layout table tools on and off for a given table, or turn this feature off altogether to control the layout tools manually.
	Click (or select) the table.

In Design view, on the Table menu, point to Table Properties, and then select Table.

Check  Enable layout tools or Automatically enable layout tools based on table content.


	Layout Tools
	
	

	Tracing Images
	 Create a mock-up of a Web page image in a graphics program and then use it as a visual guide to re-create or trace the Web page design. After setting a tracing image, it appears in the background of the document window in Design view. Show or hide the image in FrontPage, set its opacity, and change its position. However, site visitors will not see the tracing image when viewing the site by using a Web browser.

	To configure and show a tracing image:

On the View menu, point to Tracing Image, and select Configure.

Type the file name in the File Name box, or click the Browse button.

Under Opacity, move the slider to adjust the image opacity to the desired level.

To toggle the tracing image on/off: 

On the View menu, point to Tracing Image, and select Show Image. 



	Improved themes
	Because FrontPage 2003 uses CSS (cascading style sheets) rather than HTML to apply themes, files are smaller, more transparent, and easier to control and modify. Pages with HTML themes applied in previous versions still work in FrontPage 2003.
	On the Format menu, select Theme.
In the Theme task pane, under Select a Theme, scroll through the list of available themes.

To select a theme, click on the thumbnail for the theme, and from its drop-down menu, choose Apply to selected page(s).

	Improved work environment and bigger design area 
	FrontPage 2003 centralizes all of the Web controls and gives you a panoramic view of your entire Web site to make creation and updates easier than ever. And, the bigger design area reduces scrolling.
	


	Graphics Tools
	
	

	Improved graphics support
	Working with graphics from other applications is easier than ever. New interfaces and default behaviors clearly explain what will happen when importing images into your Web site and what behavior to expect while editing imported images. This helps give you more control over how images are displayed and saved.
	Click the image to reveal image borders. 

Click on image border and drag to resize the image.

In the Picture Actions drop-down menu that appears, select Only Modify Size Attributes or Resample Picture to Match Size to complete the modification of the graphic.

	Multiple editor configuration
	Choose which editor to use for particular content when you edit it. For example, if you have a number of .gif files, some of which are photos and some diagrams, you can edit the photos using Adobe PhotoShop and the diagrams using Microsoft Visio® by automatically selecting that editor when you go to edit the file.
	On the Tools menu, click Options.

In the Options dialog box, click Configure Editors tab.

	Add Macromedia Flash-based content
	Including Macromedia Flash-based content in your Web site is as simple as dragging it into your work area. FrontPage 2003 provides a dialog box so you can set properties on a movie in Flash format by double-clicking it, and FrontPage 2003 supports scripting Flash objects using the script authoring functionality.
	On the Insert menu, point to Picture, and then click Movie in Flash Format.


	Compatibility Tools
	
	

	Browser and resolution reconciliation
	Target specific page size settings to see how your site will look in various combinations of browsers and resolutions —including simultaneous previewing of multiple browsers.
	To target a specific browser size:

On the View menu, point to Page Size and select target browser size.

Gray borders are added to the view if the target is smaller than the available space and a dotted line is displayed to show where the first screen ends.

To Preview in Browser:

On the File menu, point to Preview in Browser.

Select target browser, or choose multiple browsers in various screen sizes. Browser lists are fully customizable.

To customize browser compatibility:

On the Tools menu, point to Browser Compatibility.
Click Change.

In the Authoring dialog box, change desired settings to target specific browser(s).

Click OK to close Authoring dialog box.

Click Check to check browser compatibility.

	Accessibility checking
	Select guidelines (including US government section 508 guidelines) to discover issues that are identified as being in conflict with the World Wide Web Consortium (W3C) Web Content Accessibility Guidelines (WCAG) or the accessibility guidelines for Section 508 of the U.S. Rehabilitation Act. Accessibility suggestions are shown in a list and you can jump back and forth between that list and your site to address the issues.
	On the Tools menu, select Accessibility. 

Under Check Options, select desired options.

Click Check.


Generate Better Code
Along with better design tools, FrontPage 2003 has powerful coding tools to help you apply and increase your knowledge of various coding languages, as well as help you easily create interactive scripts. In addition, the design tools in FrontPage 2003 generate efficient and clean HTML and give you more control over the code.
	Feature
	Description
	Invocation

	Coding Tools
	
	

	Split view
	The new Split view helps you create and update sites more quickly by showing both the Code view and the Design view at the same time. When editing the Design view in split-screen, the code updates automatically as you work, so you can monitor the code and use this as a learning tool. When editing directly in the code, you manually update the Design view by pressing F5 to incorporate batches of your changes at once.
	In Page view, click Split to view both Code view and Design view at the same time. 



	Support for 
Multi-Monitor Configuration


	Take advantage of multi-monitor support by opening two instances of the same page, dragging the second instance over to your second monitor, and then keeping one in Design view and changing the other one to Code view.  Make a change in Design view on one monitor and see it instantly reflected in the Code view on the second monitor.  Likewise, enter new code into the Code view, save it, and then see it reflected in the Design view on the other monitor.
*Requires a 2nd video card and 2nd monitor.
	Start a new page or open an existing one.
Right-click on the page and choose the command Open Page in New Window.

Drag the new instance of the page over to your 2nd monitor.
Now you can switch one instance to Code view and leave the other one in Design view.

	Quick Tag Selector


	See the HTML tree structure below the insertion point in the user interface, and select or manipulate items in Design view. If you are working on a page with a number of nested tables, it can be difficult to select just the table or cells you want to work on. The Quick Tag Selector lets you select the exact element you need.
	In Design view, the Quick Tag Selector is located immediately below the page tab.

Click a tag to highlight associated elements in Design view. 

Switch to Code view to see highlighted code.

	Quick Tag Editor
	Create and alter tags easily with the Quick Tag Editor. Select text and edit tags that surround it, wrap it in a new tag, insert new HTML, or remove a tag.
	In Design view, click the element on the page you want to edit. 
On the Quick Tag Selector, open the drop-down menu associated with the highlighted tag.
In the tag drop-down menu, click Edit Tag. 
On the Quick Tag Editor toolbar, make desired changes.

Click the green checkmark to accept changes and close the Quick Tag Editor toolbar.


	HTML Tools
	
	

	Smart find and replace
	FrontPage 2003 provides basic find and replace functionality, as well as a rules engine for doing HTML searches. You can quickly search and replace on attributes or tags across your entire site or on specific pages. You can save your queries for later use or to share with other authors. This allows you to do fast updates across your Web site with great accuracy. For example, you could specify a rule to “find all pages in the site that lack a keyword meta tag and add the keyword tag before the </head> tag.”
	Press CTRL+F to open Find and Replace dialog box.

Click the Find tab to find text, attributes, or values. 

Click the Replace tab to quickly find and replace text, attributes, or values.

Click the HTML Tags tab to quickly find and replace tags. 


	Edit text files
	FrontPage 2003 allows you to edit text files, such as JavaScript/JScript, XML files, XSLT, etc. directly within the FrontPage editor, taking advantage of all the new code editing features without having to switch to a different editor.


	On the File menu, click Open.

In the Open File dialog box, in the Files of Type box, use the drop-down menu to display desired file types.

	Optimize HTML 
	FrontPage 2003 allows you to clean up the HTML in your pages in two different ways.
You can clean up your HTML at author time by simply going to the Tools menu and clicking Optimize HTML. Here, you are able to have FrontPage 2003 automatically clean up your code including removing “white space,” cleaning up HTML created in other programs, nonessential tags, comments, white space and VML code for vector-based graphics.
You can also clean up the remote version of your site when you publish, optimizing the files that you post online. This enables you to have full HTML editing capabilities on the local version of the site, while minimizing the size of the page that the user launches in a browser.

	To optimize local HTML:

On the Tools menu, click Optimize HTML.
In the Optimize HTML dialog box, check or uncheck the elements to be removed.
To optimize remote HTML:

In the Remote Web Site view, click Optimize Remote HTML.

In the Remote Web Site Properties box, under the Optimize HTML tab, check or uncheck the elements to be removed. 

Click Set as Default if you want to optimize your HTML using these settings every time the Web site is published.


	Scripting Tools
	
	

	Create and use script
	FrontPage 2003 provides IntelliSense® for authoring Jscript® and Microsoft Visual Basic® Scripting Edition (VBScript) in Code view.

	In Code view, insert cursor and type “<” to open Autocomplete drop-down menu. 

To open Autocomplete attributes drop-down menu, select any tag and press the spacebar.

	Interactive Buttons

	Include interactive buttons with rollover effects on your site. Choose from a selection of effects, define text and actions, and drop them into your site. Interactive buttons are built using standard script and images, so it is easy to modify them by hand if you wish.
	· On the Insert menu, select Interactive Button.
· In the Interactive Button dialog box, select desired button type from Buttons list.
· Type desired text in Text box.
· Type hyperlink text in Link box, or press Browse to find desired link page

	Behaviors

	Use Behaviors to author JScript without writing a single line of code. Just select desired functionality, and FrontPage 2003 takes care of the rest.
	On the Format menu, select Behaviors.

In the Behaviors task pane, click Insert to reveal script options. 

Use the associated script dialog box to tailor script.


	Professional Coder's Toolbox
	
	

	Microsoft IntelliSense
	The Code view now provides Microsoft IntelliSense® technology to reduce errors in code writing. IntelliSense includes statement completion and shows the parameters available for the code you’re writing (just as you would see in Microsoft Visual Studio®). Code IntelliSense is available for HTML, XSL (Extensible Stylesheet Language), Microsoft JScript®, VBScript, JavaScript, and ASP.NET.
	In Code view, insert cursor and type < to open Autocomplete drop-down menu. 

To open Autocomplete attribute drop-down menu, select any tag and press the spacebar

	Typing aids

	FrontPage 2003 offers a number of helpful tools to speed up the code writing process including:

· Word wrap

· Line numbers

· Auto indent
· Selection Margin

	· In Code view, right-click anywhere on the toolbar and select Code view. 

· On the Code view toolbar, click the Options drop-down menu.



	Code snippets

	Store blocks of code and insert them on pages from a library of code snippets. Code snippets can be anything you can insert in the Code view (HTML, CSS, etc.).
	On the Edit menu, point to IntelliSense, and then select List Code Snippets. 

	ASP.NET controls
	FrontPage 2003 supports the preview of ASP.NET controls, letting you work with Visual Studio. Preview, reposition, and resize these ASP.NET controls, and use IntelliSense support for scripting to ASP.NET intrinsic controls so you can easily hook up, tailor, or even instantiate new controls.
	
Open a page authored in Microsoft Visual Studio® with ASP.NET controls in it and begin editing


Extend the Power of Your Web Site 

In addition to great design and coding tools, FrontPage 2003 extends the power of your Web site to connect with people and information in new ways. Windows Server 2003 with Windows SharePoint Services connect to, edit and present live data from a range of data sources, including Windows SharePoint Services data, XML, Web Services or OLE DB data sources, to build rich interactive data-driven Web sites in a WYSIWYG editor. Create instant Web solutions that allow your users to post to the Web using just their browsers, thereby lowering your maintenance costs and allowing your users to post to the Web using just the browser. When it’s time to publish, choose from a broad range of publishing options.

	Feature
	Description
	Invocation

	Data-driven Webs Enabled by Windows SharePoint Services
	

	Data Source Catalog
	FrontPage 2003 lets you easily insert data views into your Web pages. The catalog contains data sources that are already part of your Web site (lists in Web sites based on Windows SharePoint Services, document libraries, and any XML files in the Web site, for example) and allow you to configure any external data sources that you want to work with in WYSWYG format. Supported data sources include:
· Windows SharePoint Services data

· XML files

· Web services or URLs that return XML

· OLE DB data sources


	On the Data menu, click Insert Data View. In the Data Source Catalog task pane, select a data source, and then click Properties.


	XML support
	FrontPage 2003 allows you to create and edit XSLTs for viewing XML data. It supports Microsoft Word or XML files, and URLs that return XML. FrontPage 2003 has all the tools necessary to handle and format XML data sources. Plus, you can save results from HTML forms in an XML file in your Web, and build views of that XML data file.
	To To open an XML file:

On the File menu, click Open.

In the Open File dialog box, in the Files of Type box, use the drop-down menu to select XML.

	Web Package Templates
	Set up Web Logs and news and reviews sites with just a couple of clicks with pre-built Web package templates that come with FrontPage 2003.
	On the File menu, select New. 

In the New Page or Web task pane, select Web package solutions. 

In the Web Site Templates dialog box, select a template.

Click OK.




	Data-driven Webs Enabled by Windows SharePoint Services
	

	Export and import Web packages
	Export and import collections of Web pages and content from Windows SharePoint Services Web sites. FrontPage 2003 makes sure that all dependent files are included when you import or export so the deployed package will work seamlessly on the new Web site.
	On the Tools menu, point to Packages, and then select Import or Export.

In the Import Web Packages or Export Web Packages dialog boxes, click Add or Remove buttons to add or remove files.

Click Hide Dependencies or Show Dependencies to hide or show dependencies.

	Customize data views
	FrontPage 2003 users can either manually format data, or apply a pre-built Data view, allowing you to quickly change the overall look of your data. Or, you can choose to customize the Data view to suit your own needs.
This part is transparent in both the Design and Code views — it looks just like regular FrontPage 2003 content, but you can manipulate the data directly from the user interface. Format data using standard formatting tools (like the Formatting command bar). This formatting is automatically applied to all of the data points at the same level of the XML tree (e.g. that column of the database). No special controls are required to format the data — you simply select the text and apply formatting just as you would format regular HTML text. When you format your data, FrontPage 2003 authors an XSLT transform to create and apply that formatting to your page. This transform is presented directly inline in the HTML file and is fully editable in the Code or Split views in FrontPage 2003.

	Open the Data Source Details task pane.

Under Work with Data, select Style to bring up the style selector.

Scroll and select format options.

Click OK.

	Data source details view
	The Data Source Details view in FrontPage 2003 allows you to see the data structure in the data source and even walk through individual records, allowing users unfamiliar with the data source to see its structure and contents before inserting a view into a page.
	On the Data menu, select Insert Data view. 

In the Data Source Catalog task pane, select a data source and choose Show Data to view the Data View Details task pane.
Alternately, select Insert Data View, drag and drop any data source from the catalog and the Data View Details task pane will automatically appear.  


	Data-driven Webs Enabled by Windows SharePoint Services
	

	Data View Web Part


	Authoring the data view is done on live data directly in the FrontPage 2003 Design view through the Data view Web Part. When you insert a data view, you are actually inserting a Data view Web Part into your page. This part is transparent in both the Design and Code views — it looks just like regular XSLT code, but you can manipulate the data in a new, rich, WYSIWYG way. You can format the data using the standard formatting tools (like the Formatting command bar). This formatting is automatically applied to all of the data points at the same level of the XML tree (e.g. that column of the database). No special controls are required to format the data — you simply select the text and apply formatting just as you would format regular HTML text.
When you format your data, FrontPage 2003 authors an XSLT transform to create and apply that formatting to your page. This transform is presented directly inline in the HTML file and is fully editable in the Code or Split views in FrontPage 2003.

	To change the font on live XML data:

Click in any cell in an XML table to select the content.

On the Format menu, select Font.

In the Font dialog box, under the Font tab, make desired modifications to the font and click OK.

After formatting your data, switch to Code view to examine the Extensible Stylesheet Language Transformations (XSLT). 

	Data View Styles


	In addition to manually formatting your data, you can also apply pre-built Data view styles. This allows you to quickly and easily change the overall look of your data. Applying a style preserves any applicable manual formatting you have already done, and you can apply additional manual formatting after the style.


	On the Data View Details task pane, under Manage view settings, click Style. Select the option you want, and then click OK.

	Web Part Pages and zones
	With the Microsoft Office Web Parts task pane, you can connect multiple Web Parts to change data or formatting in one Web Part when the contents or selection of the other Web Part changes. This allows you to create sophisticated master detail views on your data, where the reader selects categories from one Web Part and the details for that category are shown in another. Or, place them in Web Part zones that you define in your pages. Then, your users can put Web Parts into those zones in the browser without even starting FrontPage 2003.
	To open the Web Part catalog:
On the task pane drop-down menu, select Web Parts.

To insert a new Web Part:

Select a Web Part from the Web Part list and click Insert Selected Web Part.

To insert a new Web Part Zone on a Web Part Page:
At the bottom of the Web Parts task pane, select Insert New Web Part Zone. 




	Publishing Tools
	
	

	Remote Site view
	The new Remote Site view supports publishing in both directions and file synchronization between the sites, making it simple to work with other users on an FTP (File Transfer Protocol) or WebDAV (Web Distributed Authoring and Versioning) server. In addition, you can apply different filters in the Remote Site view that let you see which files are out of date on each server, whether any files have been marked to not publish, which files are in conflict, etc.
	To publish files in both directions (synchronize):

In the Remote Web Site view, click on a file or folder.

Use arrows to indicate the direction that you want to upload or download files or folders.

Under Publish all changed pages, click either Remote to local or Local to remote, and then click Publish Web site.

To synchronize files:

In Remote Web Site view, under Publish all changed pages, click Synchronize, and then click Publish Web site.

To apply publishing filters:

In the Remote Web Site view, click Remote Web Site Properties.

On the Publishing tab, select the options you want, and then click OK. 

	Connect to remote sites 
	The new Web import dialog box simplifies connection types and protocols, how to deal with SSL (Secure Sockets Layer) connections or use passive FTP, and other connection settings.
	 In the Remote Web Site view, view site status in Status window (below Local Web site and Remote Web site windows). 

	Publish to FTP and DAV servers
	Collaborate with others using the new site-building tools found in FrontPage 2003. File locking is provided on WebDAV servers using WebDAV file locking. On FTP servers, file locking is supported through the use of .lck files. These files are fully compatible with those used by Macromedia Dreamweaver, so you can work with Dreamweaver users on an FTP server without accidentally stepping on each other’s changes.
	In Remote Web Site view, click Remote Web Site Properties. 

Select desired Remote Web server type radio buttons.

In Remote Web site location box, type the Web site URL, or click Browse to select the destination folder.
Click OK.
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Achieve the design you want using the Cell Formatting Work Pane to manipulate columns, rows and cells.
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Dynamic Web Templates let you designate what sections of the site can be edited and who can edit them.
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Store blocks of code and insert them on pages from a library of Code Snippets.
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IntelliSense includes statement completion and shows the parameters available for the code you’re writing.
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Search HTML attributes or tags with smart find & replace based on rules you specify, to do fast, accurate updates across your Web site.
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Build custom Web Parts Pages, including Web part zones for SharePoint Products and Technologies.
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When using the Split View, edits made in the Design window automatically update Code window.
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okay, look.
by Cypher at 12:12 P | @
ilintend to write a nice big entry to fill you in on the details of my time off, but i have a little to do first.

i will return shortly... inks
Microsoft
ola! MSDN

by Nanster at 12:16 PM | @

Happy New Year! I feel like this is going to be my year of change and growth! And I'm ready for what's
next.

In-stalling

by Cypher at 12:14 P11 | @

I have just about reinstalled all my programs on the the new computer. This minor ordeal will teach me to
keep all the programs and installation disks in one location. The networking, which I thought I would need

help with, turned out easier with XP than I thought. Now if I can just figure out how to transfer YHS movies
to DD, I will be a happy camper.

E Wednesday, January 15, 2003

luna

by Cypher at 12:09 PM | @

Monday must submit introduction letter to department supervisor and I haven't printed it. Ran out of paper.
T always run out of paper at critical moments. Just like that last time when I needed to print the Java
source code for my project. Bummer.. Later go and buy.

Wine Lesson
by MCHamburger at 12:09 PM | @

Thank you, DZ. I think you ought to write a book on the subject of wine. It seems that you could rattle on
off in not time at all.
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Set up popular Web Logs and News and Reviews sites with just a couple of clicks.
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FrontPage 2003 tools for handling and formatting data from XML sources help you build powerful XML data-driven Web sites.

Glossary

	Conditional formatting
	Changing the appearance of a control, including its visibility, based on values entered into the form.

	Cascading Style Sheet (CSS)
	A document containing style information that can be referenced by multiple Web pages. Styles define appearance and formatting of content on Web pages and allow authors more control over how content is displayed in browsers.

	HTML
	Acronym for Hypertext Markup Language. The standard markup language used for documents on the World Wide Web. HTML uses tags to indicate how Web browsers should display page elements such as text and graphics and how to respond to user actions.

	JavaScript
	A cross-platform, World Wide Web scripting language. JavaScript code is inserted directly into an HTML page. JavaScript makes it possible to build Java programs. The script anchor represents a script written in JavaScript.

	JPEG
	A graphics file format (.jpg extension in Microsoft Windows) supported by many Web browsers that was developed for compressing and storing photographic images. It's best used for graphics with many colors, such as scanned photos.

	JScript
	An interpreted, object-based scripting language that borrows from C, C++, and Java. It is the Microsoft implementation of the ECMA 262 language specification.

	Layout table
	A collection of cells used to arrange content such as text or controls.

	Metadata
	Data that describes other data. For example, the words in a document are data; the word count is an example of metadata.

	Microsoft Script Editor (MSE)
	A programming environment used to create, edit, and debug Microsoft JScript or VBScript code on a Microsoft InfoPath™ form.

	Scripting language
	A simple programming language designed to perform special or limited tasks, sometimes associated with a particular application or function.

	Table
	One or more rows of cells commonly used to display numbers and other items for quick reference and analysis. Items in a table are organized into rows and columns.

	Task Pane
	The area of the workspace that contains the options you select for a given task. Task panes appear at certain times, such as when a document is opened, or when you click certain items on menus and toolbars. By default, task panes appear docked, but they can float, just like toolbars.

	VBScript
	An interpreted, object-based scripting language that is a subset of the Microsoft Visual Basic programming language. 

	Extensible Hypertext Markup Language (XHTML)
	A markup language that extends HTML and reformulates it as XML.

	XML (Extensible Markup Language)
	A condensed form of Standard Generalized Markup Language (SGML) that enables developers to create customized tags that offer flexibility in organizing and presenting information.

	XML data
	Data that is saved in an XML format. InfoPath forms are saved as XML data files.

	XML schema
	A formal specification, written in XML, that defines the structure of an XML document, including element names and rich data types, which elements can appear in combination, and which attributes are available for each element.

	XSL (Extensible Stylesheet Language)
	An XML vocabulary for specifying formatting semantics. An XSL style sheet specifies the presentation of a class of XML documents by describing how an instance of the class is transformed into an XML document that uses the formatting vocabulary.

	XSLT (Extensible Stylesheet Language for Transformations)
	A language that is used to transform XML documents into other types of documents, such as HTML or XML. It is designed for use as part of XSL.
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