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Managing Grades with Excel 2002
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Managing student progress has historically been a task met with many different approaches and has required a considerable amount of effort. Some educators use the traditional ledger format, some create a spreadsheet, and some search out a program. While all of these methods have merit, most miss the mark in one way or another. Typically, programs lack the ability to be customized, which forces the instructor to form their grading system to accommodate the vendor’s view of grading. Standard ledgers are cumbersome to use and provide no ability to analyze the data they contain. Spreadsheets are versatile, but require considerable thought and extensive setup to be useful. Microsoft® Excel 2002 offers a flexible, powerful tool with minimal initial setup. 

Excel in combination with the grade book can be an extremely useful combination. The grade book has the basics setup, so extensive worksheet design isn’t necessary. Because it’s built by using Excel, you have the ability to analyze your grade book data in very sophisticated ways and customize the sheet with a minimum of effort. 

This tutorial will show you how to use the grade book. Getting your existing data into Excel is discussed in the beginning. Then, we will examine and demonstrate customization of the grade book in addition to using it to record grades for several student activities. We will also analyze the grades to help you manage the student’s progress as graded activities are accomplished. Other attributes that will be discussed include weighting, dropping the lowest grade, and changing the grading scale. Finally we’ll communicate the results of our analysis to parents and administrators. By the end of this tutorial, you will have a functional grade book and an understanding of how Excel 2002 can enhance your grading technique.

Before You Begin

If you are new to Excel 2002, you might want to open Microsoft Excel Help from the Help menu, click the Contents tab and review the Getting Started Guide. More training on basic Excel operations are included in the Microsoft Office XP Step by Step Interactive Training that you received with your purchase of Microsoft Office XP. If you are using software that was licensed by your school, contact your network administrator to gain access to the Microsoft Step By Step Interactive Training. Advanced training materials are also available from Microsoft Press.

In addition to having Excel 2002 installed on your computer, some activities in this tutorial also require: 

· Network connection and modem

· Access to the Internet through a service provider

If you have not already done so, download the following sample data files that accompany this tutorial and save them to your computer in a location easy for you to access:

· gradebook.xls

· gradebook.mdb

· text_file.txt

These sample files can be found on the Microsoft Education Web site at the following URL:

 http://www.microsoft.com/education/?ID=TutorialPacks 
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Conventions

The directions given in this tutorial use the following conventions:

· To click is to use the mouse to point to an area on the screen and press the left (primary) mouse button. To double-click is to press the left mouse button twice quickly. To right-click is to press the right (secondary) mouse button. (If you are left-handed, you can customize the mouse so that the right button is primary and the left button is secondary.)

· Items such as menus or buttons that you click or select to carry out a command are bold. For example, "on the File menu, click Print" means you should click the Print command on the File menu.

· Information that you are to type exactly as shown is in italics. 

Help

When you have a question about Excel 2002, you can simply type your question into the box at the top right of the screen where it reads “Type a question for help.” You can also ask the Office Assistant, which is turned off by default in Office XP. To open the Office Assistant, on the Help menu, click Show the Office Assistant. Click the Office Assistant icon, and then type your question, such as How do I create a formula? in the text box provided.
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Using Excel

Before using Excel 2002, you will want to be familiar with its features. The following illustration shows a workbook.
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Worksheets

The basic Excel document is a worksheet. Several worksheets can be saved together as a workbook. When you start Excel, a blank worksheet opens. You can complete the following tasks:

· Add data manually. Type text and numbers in cells.

· Create formulas. Calculate results from the data by applying formulas to cells. Formulas can be up to 1,024 characters and can contain operators, cell references, values, text, and functions.

· Navigate. To change the active cell, use the arrow keys, Page Up or Page Down keys, or use the mouse to click a new cell or drag the scroll bars. 

· Select cells. Click a cell and drag the mouse pointer to select a range of cells. To select nonadjacent cells, hold down the CTRL key, and then click the cells that you want.

· Add a new worksheet to form a workbook. On the Insert menu, click Worksheet. Alternatively, right-click the tab of the active worksheet to open the context menu. Then, on the Insert menu, click Worksheet.

· Rename the worksheet. Double-click the Name tab; when the default name is selected, type the new name. Note in Office XP you can also set the color of the Worksheet tabs by right clicking on the tab and selecting a color. Setting different colors is helpful when you have a large number of worksheets in a workbook.
· Format the worksheet. Change or apply font styles, colors, patterns, borders, and cell alignment to make your worksheets more attractive and easier to read. Select the cells that you want to format. On the Format menu, click Cells.

· Embed charts and pictures. To create a new chart in Excel, on the Insert menu, click Chart. To insert another file, such as a clip art picture or a scanned image, on the Insert menu, point to Picture, and then click a command. 

Before getting started, it would be helpful for you to spend some time exploring Excel. One of the easiest ways to become familiar with a new program is to view the menus, become familiar with the buttons, and explore Help. 

To view Help

1. Open Excel on your computer.

2. In the top right hand corner of the Excel Screen type in the question How do I save a workbook?
You can view the topic that is displayed in the right pane, or select one of the additional topics for more information.

Now that you are familiar with some of the basic features of Excel 2002, you are ready to find out how you can use Excel to facilitate recording grades and analyzing those grades to manage student progress.

For your classes, you have recorded the results of graded activities throughout the quarter. You want to pull the data into your Excel grade book and analyze it to obtain the information for grade reporting. This data contains all the classes you teach, so it is important to keep it organized.
Importing Data

Before you can analyze data, you have to get it into a format that Excel can use. This usually means entering or importing data into a worksheet. There are several ways to do this, including:

· Enter data manually

· Generate data by using forms or macros

· Import data from another file, such as a text file

· Import data from a database 

· Import data from the Web

Importing data from text files

For this tutorial we will assume your class data is stored in a third party program. However, the information isn’t in an Excel file. Excel can’t read every type of file that exists, but most programs will allow you to save data as a delimited text file that can then be imported into Excel. Delimited means that each section of data is separated, or delimited, by a special character, typically a tab, comma, quote, or space.

You have exported the data from the program and saved it as a text file (grades.txt) and are now ready to import it into Excel.

To import a delimited text file

3. If you have not already done so, start Excel. 

4. On the File menu, click Open, and then select the folder where you downloaded the sample data files. Double-click gradebook.xls.

5. Click the Sheet1 tab.

6. On the Data menu, point to Import External Data, and then click Import Data.

7. Navigate to the folder where you downloaded the sample files and change the Files of type to Text Files.

8. Select the text file gradebook.txt, and then click Open. The Text Import Wizard opens.

9. Verify that Delimited is selected, and then click Next.

10. Verify that Tab is selected, and then click Next.

11. Verify that General is selected, and then click Finish.

12. Verify that Existing worksheet is selected, and then click OK.

13. On the File menu, click Save.

Later, if the data in the text file changes, you can update your Excel worksheet without importing the text file again. To do so, on the Data menu, click Refresh Data. Select the text file, and then click Import. Excel automatically updates the worksheet with any new data that is in the text file.

Importing data from a database

Another example of importing data could also be for a student project. The social science students also conducted their own survey of college freshman at their school. They used a Web-based form created in Microsoft FrontPage® 2002 and arranged for students from several English 102 classes to fill out the form online. They collected the results of their survey in a Microsoft Access 2002 database. To analyze and compare their survey with the national statistics, the group needs to import some of the survey data into Excel. They can query the database to isolate a subset of the data collected in the survey. Excel has a Query Wizard that makes it easy to retrieve data stored in an external database.

To query a database

14. If you have not already done so, open gradebook.xls. 

15. Click the Sheet2 tab.

16. Click Data, point to Import External Data, and then click New Database Query.

17. On the Databases tab, click MS Access Database, and then select Use the Query Wizard to create/edit queries. Click OK.

18. Locate the database gradebook.mdb (located in the sample_data folder that you downloaded with this tutorial) in the Select Database dialog box, and then click OK. The Query Wizard opens.

The Choose Columns dialog box prompts you to select the columns that you want to include in your query. The list on the left shows the tables and columns available from the database that you queried. The list on the right contains the columns that you want to include in your Excel worksheet.

19. From the list on the left, click Gradebook, and then click the right arrow. The columns from the database table are now listed on the right.

20. If you want to remove any columns from the list, select the appropriate heading, and then click the left arrow.

You can also preview the data in a column. Click Name from the list on the right, and then click Preview Now. You will see the names of several students listed in the Preview Data list. Click Next after you have completed these tasks. 
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21. The Filter Data dialog box allows you to filter the data that you are querying directly from the database. For example, if you wanted to include the records for only grade 5 students, you could do so here. You’ll need to have all the grade book data, so choose not to filter data at this point. Click Next.

22. The Sort Order dialog box allows you to sort the data that you are querying from the database by ascending or descending order. You might want to sort the data later, but choose not to do so here. Click Next.

23. Click Return Data to Microsoft Excel, and then click Finish.

24. Verify that Existing worksheet is selected, and then click OK. Notice that you can also create a PivotTable Report directly from a database query. PivotTables are discussed later in this tutorial. The data from the database opens in Sheet2. The External Data toolbar also appears.

Importing data from the Web

With Excel 2002, you can use data that you find on the Web. Conducting a Web query is very similar to conducting a database query. Excel 2002 remembers where the data came from so that you can refresh your query if the data changes. If you would like some real data to experiment with, historical statistics on college graduates and voluminous other amounts of data can be obtained from the United States Census Bureau. Census Bureau reports are located on the Web at http://www.census.gov/population/.

To create a Web query

25. If you have not already done so, open gradebook.xls.

26. On the Insert menu, click Worksheet. 

27. Right-click on the tab of the newly created worksheet, and then click Rename. Name the tab Web Query.
28. On the Data menu, point to Import External Data, and then click New Web Query.

29. Type the address http://www.census.gov/population/socdemo/school/ in the Address box, and then click Go. Scroll down and click tabA-6.txt. The page appears in the New Web Query dialog box.
30. Select the yellow boxes next to the areas of the page you would like in your query. They will turn green when selected. Click Import.
31. Verify that Existing worksheet is selected, and then click OK. The census data is imported into the Excel worksheet. 

Customizing the grade book

After you have some student data in Excel, you can get to work on customizing the operation of the grade book to suit your needs. Excel 2002 has many tools available that will allow you to view the grades in a detailed fashion even though all the activity data is recorded in one sheet. Formulas allow you to weight the types of activities and drop the lowest grades. You also have the ability to figure letter grades automatically from numerical scores and accommodate any grading scale you want.

A sample set of graded activities has been created for you as if you were a math instructor. In this section of the tutorial, we’ll be manipulating the data to view smaller subsets of information. Weighting activities and dropping the lowest grade are important aspects of calculating final class grades. Modification of formulas will be revealed in this regard. Assigning letter grades to the numerical scores can be a time consuming task as well. Automating the assignment of grading scales and the manipulation of these scales will also be covered to round out your grade book customization. 

Filtering a list

Filtering a list is a method of analysis in which you hide rows in the list that do not meet some specified criteria. For example, you could filter a grade book list to show only those students who had not taken a particular test, or just students who were in a particular class. You could then update the test data in the grade book or perform a mail merge with the results to mail notices only to those students and remind them of a make-up exam. 

In your grade book, each line represents a grade entry for a given activity. One line exists per activity per student, which means that all classes, students, and activities are represented in the Activity Data worksheet. You will want to view this in a more detailed way and explore the data by class or by student. Filtering will allow you to investigate many aspects of the student grades quickly while maintaining everything in one complete sheet. Keeping everything in the sheet is important to further analysis of student grades. By using filters, you can pare the listing down to view it in a simple format, but also analyze the data with the powerful tools of Excel 2002 that we’ll investigate later. 

To filter a list by using AutoFilter

32. If you have not already done so, open gradebook.xls and then click the Activity Data tab to switch to the appropriate worksheet.

33. Click anywhere in the worksheet to activate a cell.

34. On the Data menu, point to Filter, and then click AutoFilter. Drop-down arrows appear next to the field names in the header row.

35. You can filter the list by values in a single column or in multiple columns. For example, click the drop-down arrow on the Class field, and then click Algebra. The list of activities are reduced to just those that are recorded for the algebra class. Notice that the arrow is blue, indicating that the class is an active part of the filter.
36. In the Activity Type drop-down menu, click homework to view recorded homework grades. You can filter by any combination of columns. 

37. Select row 43 by clicking 43 in the row headings on the left side of the worksheet. 

38. On the Insert menu, click Rows to insert a new row above row 43.

39. Fill in a homework activity for Suzi Huang. Her student ID is 21. To fill in the remaining parts, select cells B23 to J23, click the fill handle at the lower right corner of cell J23 and drag to fill in row 43. Lastly, change Suzi’s grade for the activity to 88.

The number at the bottom of the grade column is the average of all the grades currently shown on the sheet, and the number at the bottom of the points column is the sum of the points currently displayed on the sheet. You can check a student’s progress by filtering down to a particular student, activity type, or activity—or by any combination of the three. 

To weight activities and drop the lowest grade

You might have noticed the weights and points columns in the Activity Data worksheet. These represent the percentage of the overall grade that the particular activity comprises and the number of points that the actual score the student received on the activity will add to the final grade.
40. Switch to the Pivot worksheet by clicking on the appropriate tab at the bottom of the screen. 

Here you see a table displaying each student in the algebra class and across the top, all the graded activities for the class. You want to calculate the student’s final grade in the class by weighting all the homework to be 30% of the total grade; but you’ll also need to drop the lowest homework grade before making that calculation.

41. Click in cell K7 and type ’=’ to indicate to Excel that you are entering a formula.

42. Type MIN( and select all the scores for homework (D7:F7) and close the parenthesis. The formula should read ‘=MIN(D7:F7)’. Notice the range you have typed is highlighted in blue in the sheet to the left. Press Enter. You have computed the lowest grade for homework.

Next you will figure out the overall homework grade after dropping the lowest one.

43. Click in cell L7 and type the formula to calculate the overall homework grade now that you’ve dropped the lowest one. The formula is ‘=(SUM(D7:F7)-K7)/2’. Press Enter. This gets a total homework score (SUM(D&:F7), subtracts the lowest score (-K7), and then divides by the number of homework grades that remain (/2).

Finally, we’ll compute the final grade by adding up the weighted points for everything, which will return the final score. 

44.  Click in cell M7, type ‘=SUM(G8:I8,C8)+L7*0.3’, and then press Enter. This represents the sum of all the weighted points for activities excluding the homework (SUM(G8:I8,C8), plus the calculated homework score (L7) multiplied by the weight for the overall homework grade (*0.3) of 30%. This gives you a final score for Rolfie of 87.94.

This logic can be applied to any grading system and number of activities and students. After the formulas have been typed in one row, they can be copied to successive rows by using the fill handle.

Assigning letter grades and modifying grading scales

After the proper numerical scores have been calculated for an individual activity or for an entire quarter, these scores need to be mapped to a grading scale. Some activities won’t have the standard grading scale of letter grades; they need modification to the scale or sometimes something as simple as pass/fail. We can accommodate for this easily in your Excel grade book. Let’s look at automatically assigning standard letter grades to the numerical scores and changing the divisions between those grading scales as well.

To Use Vlookup to assign letter grades to scores

Vlookup enables you to search a list for a value in the far left column and then return a corresponding value from another column in the sheet. We’ll be using this function to search a range for a particular score and then substitute that score for a letter grade.

45. Change to the Score worksheet by clicking on the tab at the bottom of the screen. You might have to scroll through the tabs to the right by using the worksheet tab navigation buttons in the lower left corner.
Note: You’ll notice that two columns exist, one for range and one for letter grade. The range column lists the lowest score that matches the letter grade in the second column. If you want to change the grading scale, simply modify the lowest scores that correspond to the appropriate letter grade or change the letter grades. Let’s get Rolfie’s final letter grade.
46. Switch to the Pivot worksheet by clicking on the appropriate tab at the bottom of the screen.

47. Click in cell N7, type ‘=VLOOKUP(M7,Score!$A$1:$B$6,2)’, and then press Enter. In this formula, we are finding the value of M7 exists in the scale provided on the score sheet. Because the value 87 is between 80 and 90, the function selects the next lower value (80). Then the corresponding value to 80 in the 2nd column is returned. The middle section of the formula that reads (Score!$A$1:$B$6) tells the function to look at the sheet named Score and always look to the range from A1 to B6 to find the values. If you expand the list in the Score sheet, you will need to modify this part to reflect the change.

48. The value now in N7 is B and if you look at the grading scale, a B would be correct for an 87.

Analyzing Data

You may have noticed the unique worksheet named Pivot that we used in the previous section. This sheet represents a Pivot Table. After your data is in Excel, you can perform many kinds of analyses, from simple filtering to advanced “what-if” analysis. With Excel's powerful PivotTable feature, we were able to do a great deal of analysis on the student grades without creating a single formula.

Because all your grade data is available in the Activity Data sheet, you are now ready to ask some questions about your classes and students. You will sum and average grades and weighted points, filter the data, reduce it to one class, and examine grade distributions by reviewing Pivot Charts.

Creating PivotTables

Like the Excel’s AutoFilter feature, a PivotTable enables you to select data that meets specific criteria while hiding the remainder. PivotTables make this especially easy when analyzing large quantities of data that contain both numerical data and non-numerical data, such as a class name, activity type, activity, and student name.

A PivotTable enables you to summarize data by comparing, or organizing, the data in various formats by using the row and column headings. For example, you might want to find out how many students received A’s on the exams for a specific class you teach, and then compare that number with the number of students that received A’s in another class. PivotTables enable you to organize these multiple sets of data at the same time.

One reason PivotTables are so useful is that they are flexible. After you have completed the collection of your data in a spreadsheet, you can manipulate the organization of the data by rearranging, or pivoting, the layout based on the row and column headings you choose. All you have to do to accomplish this is drag data to readdress the query. For example, you might want to explore your data further to see if more grade 5 students than grade 6 students received Ds on the 3rd quiz in math class, or if the same trend is present on a different activity. You can change the layout at any time by adding or removing headings to find these trends or exceptions while your original data set remains intact. Your data analysis can then be graphically expressed by using the PivotChart feature. 

To create a PivotTable

49. If you have not already done so, open gradebook.xls and then click the Activity Data tab to activate the Activity Data worksheet. To remove the Autofilter, on the Data menu, click Filter, and then click Autofilter if the filter is on.
50. Select cell J43 to cell A1.

51. On the Data menu, click PivotTable and PivotChart Report. The PivotTable and PivotChart Wizard open.

52. Click Microsoft Excel List or database as the location of the data to analyze, and then click PivotTable. Click Next.

Note:
If you want to create a PivotTable from external data, click External Data Source. Click Next, and then click Get Data. If Excel prompts you to install Microsoft Query, click Yes. Excel displays the Choose Data Source dialog box, which you can use to specify a data source such as a database or online analytical processing (OLAP) cube.

53. Because you have already selected the worksheet (step 2), the correct data range should be entered in the Range field. (The range is surrounded by a pulsing dashed line.) Click Next. If the data is not selected, click Cancel and return to step 2.

54. Click New Worksheet as the location for the data, and then click Layout to open the Layout dialog box.
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55. You can ask different questions of the data and look at it in different ways depending on which fields you decide to use for rows, columns, and data. For example, if you want to see the sheet as you might a page in a traditional paper grade book, drag the Name field to the Row box on the PivotTable diagram. Drag the Activity field to the Column box. Drag the Grade field to the Data box. (Note: you can use the same field in more than one place.) 

56. When you are finished, click OK, and then click Finish. The PivotTable opens and the PivotTable toolbar and Field List appear. 

57. Double-click Sum of Grade in the upper-left corner of the PivotTable, click Average, and then click OK. This way the grades are averaged instead of added.
To explore another question with the same data, you can drag the fields on and off the PivotTable. For example, if you want to see classes and the individuals in each class and count the number of graded activities for each student, you would drag the Name field to the Column box, and the Activity field off the Column box. In addition, you could drag Activity Type to the Column box to show and subtotal each type of activity (homework, exam, project, and so on).

Working with PivotTables

PivotTables are dynamic worksheets—you can change and rearrange them to ask different questions and to look at your data in different ways. The first thing you want to do is work with the PivotTable buttons to change the field parameters. For example, when analyzing student grades, you can change the page field data to display information about any of the individual classes. You can change the page field altogether to categorize the data differently, such as by class or activity type.

The following illustration shows a PivotTable report of the sample data. The shaded cells are PivotTable buttons. Drag buttons between rows and columns to change the way data is summarized. Click the arrow on a button to select which data to display for the field. In this example, only students in the algebra class are displayed, but it is easy to change this by selecting a new item from the Class drop-down list. To customize the way data is summarized, double-click a button.
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The following vocabulary will help you change the layout of your PivotTable report:

· Row fields. Fields from the underlying source data that are assigned a row orientation in a PivotTable report. In the above example, gender is the row field. A PivotTable report that has more than one row field has one inner row field, the one closest to the data area. Any other row fields are referred to as outer row fields. Inner and outer row fields have different attributes. Items in the outermost field are displayed only once, but items in the rest of the fields are repeated as needed.

· Column field. A field that is assigned a column orientation in a PivotTable report. In the above example, Activity is the column field. A PivotTable report can have multiple column fields, just as it can have multiple row fields. 

· Item. A subcategory, or member, of a PivotTable field. Items represent unique entries in the same field, or column, in the source data. Items appear as row or column labels or in the drop-down lists for page fields.

· Page field. A field that is assigned to a page, or filter, orientation. In the above example, ethnicity is the page field. When you click a different item in a page field, the entire PivotTable report changes to display only the summarized data associated with that item.

· Page field item. Each unique entry or value from the field, or column, in the source list or table becomes an item in the page field list. 

· Data field. A field from a source list or database that contains data to be summarized. A data field usually summarizes numeric data, such as statistics or sales figures, but the underlying data can also be text. By default, Excel summarizes text data in PivotTable reports by using the Count summary function, and summarizes numeric data by using Sum. 

· Data area. The part of a PivotTable report that contains summary data. The cells of the data area show summarized data for the items in the row and column fields. Each value in the data area represents a summary of data from the source records, or rows.

Using the PivotTable toolbar

The PivotTable toolbar allows you to work with your PivotTable easily without needing to access the PivotTable and PivotChart Wizard. The following illustration shows the toolbar created with the PivotTable in the previous procedure and its features. When you create the PivotTable, numerical data is summed by default and non-numerical data is counted. You can change the operation performed on data in a field of the PivotTable by clicking a cell in that field and then clicking the Field Settings button. Use the PivotTable Field dialog box that appears to specify the operation you want Excel to perform in that field. For example, you can use this button to sum up the total number of students per class in your PivotTable.

	Shortcut menu

	Start wizards
	  Show/hide detail

        Refresh data
	Field commands
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Formatting your PivotTable report

You can also format and customize the look of your PivotTable report. Try the following techniques:

· Add a field. Select any field in the PivotTable and then drag the field that you want to add from the PivotTable Field List to the PivotTable.

· Customize a field. Double-click a field button to change the field button name, the orientation of field items, and the type of subtotaling displayed. You can also hide items.

· Remove a field. Click the field button and drag it away from the PivotTable. When the pointer changes to a button with an X across it, release the mouse button. 

· Reformat the PivotTable. On the PivotTable toolbar, click Format Report to open the AutoFormat dialog box.

· Group similar items to hide details. Select the cells that you want to group together. Click Data, point to Group and Outline, and then click Group. For example, you could group the A’s together and then group the B’s together and so on. Excel names the groups Group1, Group2, and so on. You can rename the groups by selecting the name and typing a new one.

· View details. To see the records used to generate a summary value, double-click the appropriate summary cell. Excel opens a new worksheet containing the records used to create the summary.

Seeing your analysis with PivotCharts

A PivotChart is a chart linked to a PivotTable. You can create a PivotChart by using the PivotTable and PivotChart Wizard. You can drag fields to a PivotChart just as you can to a PivotTable. To create a PivotChart, click the Chart Wizard button [image: image6.jpg]


on the PivotTable toolbar. The PivotChart is created on a separate Chart worksheet. To embed the PivotChart in the PivotTable, activate the Chart worksheet, click Chart, and then click Location. Click As object in and then specify the PivotTable worksheet for the PivotChart.

Visual representation of data is a powerful analysis tool used by researchers and scientists. The social science students are developing a report of their analysis and would like to include a chart for maximum impact. The following illustration shows a PivotChart based on the previous PivotTable report that was created by the students.
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To create and customize a PivotChart

With the PivotTable still open, you can create a PivotChart from your existing PivotTable report.

58. Click the Chart Wizard button on the PivotTable toolbar. The default chart type will open on a separate Chart worksheet.

59. To change the chart type, click the Chart Wizard button on the PivotTable toolbar again. (Notice that the shortcut menu on the toolbar is now labeled PivotChart instead of PivotTable.) The Chart Wizard opens.

60. Select from one of the standard or custom chart types, and then click Next.

61. In the Chart Options dialog box, you can give the chart a title, show or hide gridlines, change the placement of the chart legend, change data labels, and show a data table with your chart.
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62. The Chart Location dialog box allows you to select a location for your PivotChart, as a separate worksheet or embedded in your PivotTable report.

63. Click Finish to display your PivotChart in a new sheet. Remember that as you drag field buttons, your PivotChart automatically updates.

Using Excel 2002 on the Web

Excel 2002 recognizes HTML as a native file format, allowing you to put your Excel files on the Web and then “round-trip” them back to Excel without losing any of your Excel formatting. This allows you to share your data analysis on the Web and even continue your data research through interactive worksheets, PivotTables, and PivotCharts.

Creating interactive Web pages

After you have analyzed the student grades, you may want to share that information with the students in your class. You can send it to the students in Excel format, type the information into a separate e-mail, or save the documents as a Web page that don’t require the student to have Excel to be able to review their grades and draw their own conclusions about their progress. Obviously the latter method reveals the easiest way to disseminate the information while not requiring students to purchase additional software. We’ll examine this method below.

To save an Excel worksheet in HTML format

64. On the File menu, click Save As Web Page. 

65. The Save As dialog box allows you to specify whether you want to save the entire workbook or only the active worksheet as a Web page. 

66. If you select the active worksheet and you want others to be able to manipulate your data, click Add Interactivity. 

67. Click Publish if you want to specify which items in the workbook you want to publish and which type of interactivity you want to add.
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The advantage of putting your data on the Web is that users can access and, if they have the required software installed, interact with your data without having Excel installed on their computers. All that users need is a Web browser and access to the Internet or an intranet. For example, with PivotTable interactivity added to a PivotTable worksheet, viewers can pivot and filter the data in a Web browser in the same way that they can in Excel. 
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If you save your data with interactive functionality, Microsoft Office XP users can work with the data and make changes to it by using Microsoft Internet Explorer version 4.01 or later, much as they would use Excel to work with the data. For example, they can rearrange cells and update cell values in a spreadsheet, or filter or change the layout of a PivotTable list. Spreadsheets, PivotTable lists, and charts can all be interactive. If you save your data in a non-interactive format, users can only view the data. 

Putting it together

With Excel 2002, you can analyze student grades and record their progress in detail. For more information on how to use Excel in combination with other Office XP programs in the classroom, please visit the Microsoft Education Web site at http://www.microsoft.com/education/ .

Information in this document is subject to change without notice. Companies, names, and data used in examples herein are fictitious unless otherwise noted.
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In a formula, cell references that are copied automatically updated to reflect the row or column that they are copied to. If you would like to have the formula reference the same range, just use the $ before the elements of the range that shouldn’t change.


For instance, $A2:C$7 would always refer to column A and then the number 2 would change and the second part of the range the column would change but the row would be fixed at 7. To have the entire range fixed just put $s beside each part like $A$2:$C$7. This is called an absolute reference.�
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Formulas can be created and the filled automatically into successive cells by highlighting the cell with the desired formula, clicking on the fill handle in the lower right corner of the cell, dragging over the cells that you wish to copy the formula into and releasing the mouse button. This will convert the formula to relative to the row in which it exists. �
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When working with text files, use a non-proportional font such as Courier New so that your fields of text line up.
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If you want more information about the Filter Data dialog box, click the help button in the lower left corner of the dialog box.�

















Words to know:





Cell reference. Identifies a cell or a range of cells on a worksheet and tells Microsoft Excel where to look for the values or data you want to use in a formula.





Function. A predefined calculation that may be included in a cell and does a specific manipulation of data.�


Operator. A symbol or other character that specifies the type of calculation you want to perform on the elements of a formula.�


PivotTable. A special type of worksheet used to summarize and analyze data.





Query. To search a database for records that meet specific criteria.�


Range. Two or more cells on a sheet. The cells in a range can be adjacent or nonadjacent.





Result set. Data that is returned by a query, usually a subset of the original database.�


Source data. The data used to create a PivotTable, or the data imported into Excel through a database or Web query.





Value. Converts a text string that represents a number into a number.





Vlookup. Function that returns a value from a column in a list based on finding a value in the leftmost column in the list.
























































































































































�


You can also import text files as Fixed Width files, in which the text fields are aligned in columns with spaces between each field. Typically data exported from a mainframe would be available in this format.�
















































































Worksheet tab
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If the file you want to import contains tables, convert the tables to text before saving the file as a text file. 





























































































































Task Pane
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What you will do:�


Use an Excel grade book


Customize the grade book


Assign weighting to graded elements


Translate numerical scores into letter grades


Use PivotTables and PivotCharts to analyze student data


Save your analysis as an interactive Web page�
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You can also open any of the Chart Wizard dialog boxes from the shortcut menus when you right click the appropriate place on your PivotChart.�
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You can also customize the way that you use the Office Assistant. For example, if you prefer to use the keyboard, you can have the Office Assistant display tips on shortcut keys. Because all Office programs share the Office Assistant, any options you change will apply to the Office Assistant in your other Office programs as well. To customize or turn off the Office Assistant, click it and then click Options.�
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Collecting real- world data is an important part of making learning relevant and engaging. To learn how students can collect their own data through Web surveys, see the Microsoft in Education tutorial Gathering Information Online. �





Row Headings�
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Learn more about using Web based forms in the tutorial Microsoft Gathering information Online available to download free from the Microsoft in Education Web site at � HYPERLINK "http://www.microsoft.com/education/" ��http://www.microsoft.com/education/default.asp?ID=TutorialPacks� 
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