Microsoft BizTalk Server 2000 の概要

Microsoft .NET Enterprise Servers 製品群の一製品の Microsoft BizTalk Server 2000 は、この 1 つの製品で、エンタープライズ アプリケーション インテグレーション (EAI) と Business-to-Business (B2B) インテグレーションを実現します。BizTalk Server 2000 により、開発者、IT プロフェッショナル、およびビジネス アナリストは、インターネット上のアプリケーション、プラットフォーム、およびビジネスに及ぶダイナミックなビジネス プロセスを簡単に構築することができます。

BizTalk Server 2000 に加え、Microsoft は業界パートナーとともに、プラットフォームに依存しない Extensible Markup Language である BizTalk Framework 2.0 を含む、インターネットに基づいたビジネス ソリューションに必要なその他のテクノロジの開発の先頭に立ってきました。BizTalk Framework 2.0 は標準ではなく、Simple Object Access Protocol (SOAP) などの既存の標準に基づいて構築されています。SOAP は、Microsoft Visual Studio 7.0 など、.NET 製品群のその他の製品におけるキー テクノロジでもあります。BizTalk Framework 2.0 は、信頼度の高いメッセージ通信機能のベースを BizTalk Server 2000 に提供します。

BizTalk Framework 2.0 の詳細、およびコミュニティ サービス、スキーマのライブラリ、およびホワイト ペーパーなどの BizTalk Server 2000 製品の参考情報については、Microsoft BizTalk Server 2000 の Web サイト (http://www.microsoft.com/japan/biztalkserver) を参照してください。

ここでは BizTalk Server 2000 の機能、サービス、アプリケーション モデル、および管理モデルを紹介します。オンライン ヘルプおよび Microsoft アクセシビリティについても説明します。また、BizTalk Server 2000 の用語集も含まれています。ここには次のトピックが含まれます。

  • Microsoft BizTalk Server 2000 について

  • BizTalk Server 用語集

  • ヘルプの使い方

  • 障害をお持ちの方のためのユーザー補助機能

  • Microsoft 製品サポート サービスへのお問い合わせ

Copyright © 1999–2000 Microsoft Corporation.
All rights reserved.


Microsoft BizTalkServer2000 について

BizTalk Server 見出し

Microsoft BizTalk Server 2000 について

Microsoft BizTalk Server 2000 は、企業内および企業間の疎結合、長時間ビジネス プロセスを統合する、強力な Web ベースの開発環境および実行環境を提供します。BizTalk Server では、数分や数時間ではなく、何週間も何ヶ月も続くようなトランザクションを処理できます。

BizTalk Server 2000 の機能としては、XLANG スケジュールの作成と活用、既存のアプリケーションの統合、ドキュメント仕様と仕様変換の定義、および実行時の利用状況の監視とログの記録があります。

サーバーは、インターネットを利用したドキュメントの送受信のための標準ゲートウェイを提供すると同時に、データの整合性、配信、および安全性を確保するサービスや、BizTalk フレームワークおよびその他の主要ドキュメント書式をサポートするサービスなど、さまざまなサービスを提供します。

ここには次のトピックが含まれます。

  • BizTalk Server の機能

  • BizTalk サービス

  • BizTalk Server のアプリケーション モデル

  • BizTalk Server の管理モデル

  • BizTalk Server 用語集


BizTalk Server の機能

次の表は、BizTalk Server の機能とその用途を示しています。

機能 用途
管理
  • サーバーの管理

  • プログラムによる管理
  • サーバーとサーバー グループを作成および管理します。

  • 共有キュー データベースおよび追跡データベースの場所などのグローバル サーバー グループのプロパティを構成します。

  • サーバーの設定を構成します。

  • 受信機能を構成および管理します。

  • ドキュメント キューを表示および管理します。

  • XLANG スケジューラ システム マネージャ、グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートにプログラムによってアクセスします。
ドキュメント トラッキング
  • ドキュメントの追跡
  • Microsoft BizTalk Server 2000 によって処理されるドキュメントの進行状況を追跡します。

  • BizTalk Server 2000 によって処理されるインターチェンジまたはドキュメントの完全なコピーを検索、表示、および保存します。

  • 追跡データベースから基本的な情報を見やすい形式で抽出するためのクエリを作成します。

  • ドキュメントから重要なユーザー定義データを抽出、保存、および解析します。
オーケストレーション デザイン
  • BizTalk オーケストレーションの設計
  • ビジネス プロセスを表すフローチャートを作成し、統合された設計環境でフローチャートをプログラムによって実装します。

  • XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルします。

  • ビジネス プロセスのメッセージ間のデータのフローを定義できます。
メッセージ
  • BizTalk メッセージ マネージャの使用

  • BizTalk メッセージ構成オブジェクト モデルへのアクセス
  • BizTalk メッセージ マネージャを使用して、データの交換をローカルおよびリモートで管理します。

  • BizTalk メッセージ構成オブジェクト モデルを使用して、データの交換をプログラムで管理します。

  • チャネル、メッセージ ポート、ドキュメント定義、エンベロープ、組織、および同報リストを作成および管理します。
XML ツール
  • 仕様の作成

  • データのマッピング
  • 仕様を作成および管理します。

  • レコードおよびフィールドを作成し、それらのプロパティを設定します。

  • 送信元仕様のレコードおよびフィールドを送信先仕様のレコードおよびフィールドにマップします。

  • Functoid を使用して、強力なデータ変換機能を実装します。


BizTalk サービス

Microsoft BizTalk Server 2000 には、ビジネス プロセスとデータ交換プロセスを自動化するためのメッセージ サービスおよびオーケストレーション サービスがあります。

BizTalk メッセージ サービス

BizTalk メッセージ サービス には、受信ドキュメントの受信、特定の書式を決定するためのドキュメントの解析、キー識別子の抽出と特定の処理規則の識別、送信先へのドキュメントの配信、およびドキュメントの追跡が含まれます。また、データ マッピング サービス、受信確認の生成と照合、およびデータ インテグリティとデータ セキュリティを確保するためのサービスも含まれます。

受信機能

BizTalk Server 2000 には、指定した場所にポストされたドキュメントをサーバーが監視できるようにする受信機能があります。BizTalk Server 2000 は次の受信機能をサポートします。受信機能は BizTalk Server 管理コンソールを使用して構成します。

  • ファイル

  • メッセージ キュー

BizTalk Server 2000 は次のプロトコルもサポートします。プロトコルは ASP ページまたは Microsoft Exchange スクリプトを使用して構成します。

  • HTTP (ASP ページを使用)

  • HTTPS (ASP ページを使用)

  • SMTP (Microsoft Exchange スクリプトを使用)

トランスポート サービス

BizTalk Server 2000 には、目的の場所へのドキュメントの送信を可能にするトランスポート サービスがあります。BizTalk Server 2000 は次のトランスポート サービスをサポートします。

  • HTTP

  • HTTPS

  • SMTP

  • ファイル

  • メッセージ キュー

  • アプリケーション統合コンポーネント

  • ループバック

データ パーサー

BizTalk Server 2000 は、ANSI X12、UN/EDIFACT、有効な整形式の Extensible Markup Language (XML) など、さまざまな種類の業界ドキュメント標準に対するデータ パーサーをサポートします。BizTalk Server 2000 は BizTalk Framework 2.0 もサポートします。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Server 2000 の Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。フラット ファイルに対するパーサー サポートも入手できます。また、ご利用の独自のカスタム パーサー コンポーネントを登録および使用することができます。

データ検証

BizTalk Server 2000 は、仕様に対するドキュメントの各インスタンスを確認することによってデータ検証を提供します。ドキュメントが仕様規則に従っていない場合、ドキュメントは、さらに分析するために、保留キューに配置されます。

信頼性の高いドキュメント配信

BizTalk Server 2000 は、構成可能な BizTalk メッセージ サービスのプロパティを使用して、信頼性の高いドキュメント配信を提供します。プロパティには、ドキュメントを送信するためのサービス時間帯の設定、受信確認の送受信、再試行回数の設定、および再試行間隔の設定が含まれます。BizTalk Server 2000 は、信頼性の高いメッセージ機能を提供する BizTalk フレームワーク準拠のエンベロープをサポートします。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Server 2000 の Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。また、BizTalk Server 2000 は、ある特定の場所に集中的にドキュメントをキューします。サーバーに障害が発生した場合、ロールオーバー機構により、新しいサーバーがドキュメントの制御を引き継ぎ、処理を続けることができます。

セキュリティ

BizTalk Server 2000 は、暗号化およびデジタル署名をサポートします。BizTalk Server 2000 トランスポート サービスを使用して送信されるすべてのドキュメントで、公開キー暗号化テクノロジがサポートされます。また、BizTalk Server 2000 は、受信するドキュメントの暗号解読および署名検証をサポートします。

BizTalk オーケストレーション サービス

BizTalk オーケストレーション サービスには、ビジネス プロセスを実行するアプリケーションでの長時間のビジネス プロセスの統合が含まれます。この統合により、XLANG スケジュールと呼ばれる実行可能なビジネス プロセス ファイルが提供されます。その他のサービスにより、実行されている XLANG スケジュールのインスタンスに対する制御が提供されます。

BizTalk オーケストレーション サービスの鍵となる機能は、数分や数時間ではなく、何週間も何ヶ月も続くような複雑なトランザクションを処理できる能力にあります。ほかの重要な機能としては、単一の XLANG スケジュール内で同時アクションを実装できる能力があります。

XLANG スケジュール

XLANG スケジュールは、プロセスの各ステップをそのステップを実行するテクノロジ コンポーネントまたはサービスに接続することによって実装されるビジネス プロセスです。そして、XLANG スケジュールは、XLANG スケジューラ エンジンと呼ばれるサービスによって実行されます。エンジンは、XLANG スケジュールのインスタンス作成、実行、ステータス退避、およびステータス復元、またはスケジュールの複数のインスタンスを制御します。

実装技術

BizTalk オーケストレーション サービスによってサポートされる実装テクノロジには、BizTalk メッセージ サービス、COM コンポーネント、メッセージ キュー サービス、および Windows スクリプト コンポーネントが含まれます。

XLANG 言語

XLANG は、さまざまなテクノロジ コンポーネントまたはサービスを使用したビジネス プロセスの実装と、ビジネス プロセスの論理シーケンスを記述する言語です。XLANG 言語は Extensible Markup Language (XML) で表現されます。


BizTalk Server のアプリケーション モデル

Microsoft BizTalk Server 2000 には、取引先と業務用アプリケーションとの間のビジネス プロセスおよびデータ交換を管理するための実行可能アプリケーションを作成できるツールおよびサービスがあります。BizTalk Server 2000 によって提供されるサービスの一覧については、「BizTalk のサービス」を参照してください。

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合することにより、取引先と複数のトランスポート サービスを使用する内部アプリケーションとの間のドキュメントおよびメッセージの交換を管理することができます。また、次の機能も提供します。

  • 複雑な長時間トランザクションとビジネス プロセスの制御

  • 信頼性の高いドキュメント配信およびメッセージ配信

  • 仕様に対する各ドキュメント インスタンスを確認することによるデータ検証

  • ドキュメントの構造および書式を変換するためのマップを使用したデータ マッピング

  • 暗号化証明書とデジタル署名証明書を使用したデータ セキュリティとデータ インテグリティ

  • 受信確認の生成と照合のサポート

受信確認を送信および受信するための BizTalk Server 2000 の構成については、「受信確認について」を参照してください。

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合する方法の詳細については、「BizTalk サービスの統合」を参照してください。


BizTalk Server の管理モデル

次の表は、Microsoft BizTalk Server 2000 における管理の主要な 4 つの領域と、各領域に関連する管理機能を示しています。

管理の領域 管理機能の概要
サーバー管理
  • サーバー グループとサーバーを構成および管理します。

  • 受信機能を構成し、管理する。

  • キューを管理します。
アプリケーション管理
  • XLANG スケジュールを提供する COM+ アプリケーションを構成および管理します。

  • 既定の XLANG スケジューラ アプリケーションを構成および管理します。
プログラムによる管理
  • XLANG システム マネージャ、XLANG グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートを構成します。
データベース管理
  • 次のデータベースを構成、管理、および保守します。
    • BizTalk メッセージ管理データベース

    • オーケストレーション データベース

    • 追跡データベース

    • 共有キュー データベース

サーバー管理

BizTalk Server 2000 では、サーバー管理には、サーバー グループの管理と構成、サーバーの追加/削除/構成、受信機能の追加と構成、各サーバー グループの共有キューの管理などの作業が含まれます。次の表は、一般的なサーバー管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
サーバーおよびサーバー グループの構成
  • 追跡データベースおよび共有キュー データベースへの接続を構成します。

  • トランスポート サービスおよびパーサーの順序を構成します。

  • サーバーの設定を構成します。
  • サーバー グループの追加、削除、および構成

  • グループ内のサーバーの追加、削除、および構成
キューの管理
  • インターチェンジとドキュメントを削除および再送信します。

  • データおよびエラー メッセージを表示します。
  • キューの管理
受信機能の管理
  • 受信機能を構成します。
  • サーバー グループの受信機能の管理
トラブルシューティング
  • 問題のあるサーバーおよびドキュメントをトラブルシューティングします。
  • イベント ビューアの管理

  • BizTalk Server 管理のトラブルシューティング

アプリケーション管理

アプリケーション管理には、XLANG スケジュールを提供する COM+ アプリケーション、既定の XLANG スケジューラ アプリケーション、および BizTalk Server 2000 をインストールしたときに作成されるオーケストレーション データベースの構成と管理が含まれます。次の表は、一般的なアプリケーション管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
既定の XLANG スケジューラ アプリケーションの管理
  • XLANG スケジューラ アプリケーションの既定の設定を変更します。
  • 既定の XLANG スケジューラ アプリケーションおよびデータベースの管理
COM+ アプリケーションの管理
  • 特定の XLANG スケジュールを実行するための COM+ アプリケーションを作成します。
  • XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理

プログラムによる管理

サーバーとアプリケーションの管理はプログラムによって行うことができます。次の表は、一般的なプログラム管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
キューの管理
  • インターチェンジおよびドキュメント データを表示します。

  • BizTalk メッセージ管理データベースを変更します。

  • 共有キュー データベースから読み取りを実行します。
  • Windows Management Instrumentation (WMI) および WMI アプリケーション プログラミングの詳細については、MSDN Online Library (msdn.microsoft.com/library/) で "WMI Application Programming" を検索してください。

  • WMI の概要

  • 保留キューへのアクセス
XLANG スケジューラ システム マネージャ、グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートの構成と管理
  • XLANG スケジューラ システム マネージャおよびグループ マネージャについての情報を開始、停止、および取得します。

  • グループに関連付けられているすべてのスケジュールについての情報を停止、中断、再開、および取得します。
  • XLANG スケジュールの管理

データベース管理

データ ファイルの圧縮やデータベースおよびトランザクション ファイル ログのバックアップなど、通常のデータベースのメンテナンスと管理に加え、BizTalk Server と Microsoft SQL Server の間の接続のメンテナンス、データベースの追加/削除/復元、新規データベースの構成など、データベースに関連するその他の作業も行う必要があります。次の表は、一般的なデータベース管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
データベースの管理
  • BizTalk メッセージ管理データベースを構成および変更します。

  • 新しい永続化データベースを作成および構成します。

  • 追跡データベースと共有キュー データベースを復元および手動削除します。
  • BizTalk メッセージ管理データベースの構成

  • サーバーの BizTalk メッセージ管理データベースの変更

  • 既定のオーケストレーション データベースの設定の変更

  • サーバー グループのデータベースの管理
データベースへのトラフィックの監視
  • サーバーの設定を構成します。
  • サーバーのプロパティについて

  • サーバーのプロパティの最適化


BizTalk Server 用語集

A

ANSI X12

米国の公的な標準化委員会 X12 によって設定された EDI 標準。その内容は米国規格協会 (American National Standards Institute) によって標準として認められています。

B

BizTalk Server 2000

企業内および企業間において、ビジネス プロセスの自動化およびアプリケーションの統合を実現するための新しい Microsoft 製品。BizTalk Server 2000 は、企業内および企業間の疎結合、長時間ビジネス プロセスを統合する、強力な Web ベースの開発環境および実行環境を提供します。

BizTalk Server 2000 の機能としては、新規の XLANG スケジュールと既存の XLANG スケジュールの合成、既存のアプリケーションの統合、ドキュメント仕様と仕様変換の定義、および実行時の利用状況の監視とログの記録があります。

サーバーは、インターネットを利用したドキュメントの送受信のための標準ゲートウェイを提供すると同時に、データの整合性、配信、および安全性を確保するサービスや、BizTalk フレームワークおよびその他の主要ドキュメント書式をサポートするサービスなど、さまざまなサービスを提供します。

BizTalk Server 管理コンソール

BizTalk Server 2000 のサーバー グループとそのプロパティの管理、受信機能の監視、およびサーバー グループによって使用される Microsoft SQL Server キュー内の作業項目を監視するために使用する Microsoft 管理コンソール (MMC) インターフェイス。

BizTalk エディタ

XML 仕様を作成、編集、および管理するためのツール。BizTalk エディタを使用すると、仕様のテンプレート、既存のスキーマ、特定の種類のドキュメント インスタンス、または空の仕様を基に、仕様を作成することができます。

BizTalk オーケストレーション サービス

XLANG スケジュールの設計、コンパイル、および実行を含むサービス。そのほかのサービスとして、特定の XLANG スケジュール インスタンスをホストするカスタム COM+ アプリケーションを作成する機能や XLANG スケジュールの永続化があります。

BizTalk オーケストレーション デザイナ

長時間、疎結合、コンピュータ処理可能なビジネス プロセスを記述するフローチャートを作成するための設計ツール。XLANG スケジュール フローチャートは、自動化されたビジネス プロセスを実行するために使用する XLANG スケジュールにコンパイルされます。

BizTalk ドキュメント トラッキング

BizTalk メッセージ サービスのすべての追跡情報にアクセスするために使用する Web ベースのユーザー インターフェイス (UI)。BizTalk オーケストレーション サービスの XLANG スケジュール ステータスを追跡することもできます。

BizTalk フレームワーク

Extensible Markup Language (XML) スキーマおよび業界標準に基づく、プラットフォームに依存しない電子商取引のフレームワーク。フレームワークにより、ハードウェア、オペレーティング システム、テクノロジに関係なく、業界間およびビジネス システム間を統合できます。具体的には、フレームワークは、スキーマ、製品、およびサービスから構成されます。BizTalk フレームワークの詳細については、BizTalk の Web サイト (http://www.microsoft.com/japan/biztalk/) を参照してください。

BizTalk マッパー

ある仕様のレコードおよびフィールドと、別の仕様のレコードおよびフィールドとの対応関係を定義するマップを作成するためのツール。マップには、マップに記述された変換を実行するために BizTalk Server が使用する Extensible Stylesheet Language (XSL) スタイル シートが含まれます。

BizTalk メッセージ サービス

ドキュメントの送信/受信/解析/追跡、受信確認の生成と照合、およびデータのマッピング/データ整合/セキュリティを含むサービス。

参照 : BizTalk メッセージ マネージャ

BizTalk メッセージ マネージャ

取引先とアプリケーションとの間でドキュメントを交換できるように BizTalk メッセージ サービスを構成するために使用するグラフィカル ユーザー インターフェイス (UI)。

参照 : BizTalk メッセージ サービス

BizTalk メッセージ管理データベース

すべてのサーバー構成に関連する情報を格納する Microsoft SQL Server データベース。サーバー構成には、グループおよびサーバー設定、受信機能、BizTalk メッセージ マネージャを使用して作成されるオブジェクのすべてのメッセージ構成情報、および BizTalk メッセージ構成オブジェクト モデルにアクセスして作成されるオブジェクトのすべてのメッセージ構成情報が含まれます。

E

Extensible Markup Language (XML)

World Wide Web Consortium (W3C) によって開発された仕様。これにより、システム設計者は標準 HTML にはない独自のタグを作成することができます。HTML はあらかじめ定義されたタグのみを使用してページ内の要素を記述しますが、XML ではページの開発者がタグを定義することができます。製品や支払総額など、事実上どのようなデータ項目のタグでもそれぞれのアプリケーションで使用することができます。これにより Web ページをデータベース レコードとして利用することができます。

参照 : コンパイル、マップ、データ変換、XML-Data Reduced (XDR)、XPath

Extensible Stylesheet Language (XSL)

Extensible Markup Language (XML) ドキュメントのスタイル シート書式。XSL は、Cascading Style Sheets (CSS) が Hypertext Markup Language (HTML) の表示を定義するために使用されるのと同じように、XML の表示を定義するために使用されます。BizTalk Server は、仕様間の変換言語として XSL を使用します。

F

Functoid

再利用可能な組み込み関数。これにより、送信元仕様の要素、送信先仕様の要素、およびほかの Functoid の間で複雑で構造的な処理ができます。

参照 : リンク

Functoid パレット

すべての Functoid を含むツール ボックス。送信元仕様の要素と送信先仕様の要素との間の関係を作成する場合に使用します。

U

UN/EDIFACT

国際連合で開発された、国際的な EDI 標準。この標準は、ヨーロッパで普及していて、日本を始めアジアの国や地域でも使用されています。正式名称は United Nations/Electronic Data Interchange For Administration, Commerce, and Transport です。

W

Web Distributed Authoring and Versioning (WebDAV)

HTTP 接続上のファイル システムなどの階層ファイル格納メディアを表示する HTTP 1.1 標準の拡張部分。WebDAV によって、ドキュメントはユーザーが誤って上書きしないようにロックされます。また、オーサリング ツール、プラットフォーム、ファイルが格納されている Web サーバーの種類にかかわらず、サーバー ベースのドキュメントを共有および作業できるようになります。

X

XLANG ID

XLANG スケジュール フローチャートのバージョンを識別するために使用される、グローバル一意識別子 (GUID)。 この ID は読み取り専用であり、変更することはできません。XLANG スケジュール フローチャートを更新すると、そのたびにこの ID も更新されます。XLANG ID は、ある XLANG スケジュールと、そのスケジュールのコンパイルに使用した特定のバージョンの XLANG スケジュール フローチャートとを関連付ける場合に利用できます。

XLANG 言語

ビジネス プロセス フローの論理的な順序を記述するための言語。さまざまなアプリケーション サービスを利用した、ビジネス プロセスの実装を記述するためにも使用されます。XLANG 言語は XML で表現されます。

XLANG スケジュール

ビジネス プロセスを、XLANG 言語で表現したもの。保存した XLANG スケジュールには、.skx というファイル拡張子が付いています。

参照 : XLANG スケジュール フローチャート、XLANG スケジュール インスタンス、XLANG スケジューラ エンジン

XLANG スケジュール インスタンス

実際に開始されたスケジュール。"XLANG スケジュール" は、ビジネス プロセスとそれに実装されるサービスのみを表します。XLANG スケジュールは XLANG スケジューラ エンジンによって実行され、1 つだけを実行することも、複数実行することもできます。同じ XLANG スケジュールからインスタンスを作成した場合は、すべてのインスタンスが同一のビジネス プロセスを実行しますが、含まれるメッセージはインスタンスごとに異なります。

参照 : XLANG スケジュール、XLANG スケジューラ エンジン

XLANG スケジュール ステータス

XLANG スケジュール インスタンスに含まれている情報。ステータスに含まれているのは、インスタンスが送受信したメッセージ、インスタンスが使用したすべての COM オブジェクト、およびビジネス プロセス内におけるインスタンスの進捗状況です。

参照 : ステータス

XLANG スケジュール フローチャート

ビジネス プロセスを表現したフローチャート。BizTalk オーケストレーション デザイナを使用して完成させたフローチャートをコンパイルすると、それをもとに XLANG スケジュールを作成し、実行できます。保存した XLANG スケジュール フローチャートには、.skv というファイル拡張子が付いています。

参照 : 通信シェイプ、フローチャート シェイプ、XLANG スケジュール、XLANG スケジューラ エンジン

XLANG スケジューラ

BizTalk Server 2000 と共にインストールされる既定の COM+ アプリケーション。実行中の XLANG スケジュール インスタンスをホストするために使用されます。

XLANG スケジューラ エンジン

XLANG スケジュール インスタンスを実行するサービス。XLANG スケジュールの開始、実行、ステータス退避、およびステータス復元を制御します。

参照 : ステータス退避、ステータス復元、XLANG スケジュール フローチャート、XLANG スケジュール インスタンス、XLANG スケジュール

XML-Data Reduced (XDR)

Microsoft が考案し、1998 年に World Wide Web Consortium (W3C) に提出された XML スキーマ方言。XML-Data と同様に、XML ドキュメントの構造を定義するための Extensible Markup Language (XML) スキーマ用の構文として使用します。XDR は XML-Data のサブセットです。

参照 : Extensible Markup Language (XML)

XPath

階層構造の XML ドキュメントを操作するために使用される、多機能な言語。XPath 式を使用すると、XML の要素と属性に関する情報を取得できるほか、特定の条件を満たすデータを選択したり、抽出したデータを比較したりできます。ノード パスと呼ばれることもあります。

参照 : Extensible Markup Language (XML)、ノード パス

あ

アクション

メッセージを送受信すること。送信アクションおよび受信アクションは、どのアプリケーション サービスが XLANG スケジュールに実装されているかによって、同期または非同期になります。

位置指定フラット ファイル

固定長フィールドおよび共通のレコード終端記号を持つレコードを含むファイル。

インスタンス キュー

XLANG スケジュールの各新規インスタンスで使用するために作成されたキュー。

参照 : 動的キュー、静的キュー

インターチェンジ

単一の送信を構成するドキュメント インスタンスの集合。組織内のアプリケーションとアプリケーション、または取引先との間で交換します。

内側のトランザクション

別のトランザクションの処理フロー内に含まれるトランザクション。

参照 : 長時間トランザクション、ネストしたトランザクション、トランザクション、外側のトランザクション

エンベロープ

1. エンベロープを定義する一連のプロパティ。エンベロープのプロパティにはエンベロープ書式が含まれ、エンベロープ仕様へのポインタを含むことができます。

2. ヘッダーとフッター情報、またはヘッダー情報のみ。トランスポートのためにドキュメント データをカプセル化し、必要な情報を提供します。

エンベロープ書式

XML や ANSI X12 など、エンベロープの中に含まれるドキュメントの書式。

オープン チャネル

送信元組織にオープンであると明示的に宣言されているチャネル。オープン チャネルの送信元指定データは、ドキュメント内またはドキュメントとともに送信されるパラメータのいずれかで BizTalk メッセージ サービスに渡されます。

参照 : チャネル、オープンネス、送信元組織

オープンなメッセージ ポート

送信先組織にオープンであると明示的に宣言されているメッセージ ポート。オープンなメッセージ ポートの送信先指定データは、ドキュメント内またはドキュメントとともに送信されるパラメータのいずれかで BizTalk メッセージ サービスに渡されます。

参照 : チャネル、オープンネス、送信元組織

オープンネス

チャネルの送信元またはメッセージ ポートの送信先についての明示的な情報を静的に設定しないこと。チャネルには送信元を識別する情報が含まれています。メッセージ ポートには送信先を識別する情報が含まれています。チャネルを "オープンな送信元" として設定したときは、チャネルには送信元情報を明示的に宣言せず、ほかの手段で指定します。この情報は、受信ドキュメントのインスタンスに含まれるか、Submit メソッドのパラメータとして指定します。同様に、メッセージ ポートを "オープンな送信先" として設定すると、メッセージ ポートには送信先情報を明示的に宣言せず、代わりに、送信ドキュメント インスタンスまたは Submit メソッドのパラメータで指定します。

参照 : 送信先組織、オープン チャネル、オープンなメッセージ ポート、送信元組織

か

基幹業務 (LOB) アプリケーション

組織の主要な業務用アプリケーション。BizTalk Server 2000 は多数の通信プロトコルをサポートします。これにより、基幹業務アプリケーションは確実に情報を送受信できます。

既定の組織

BizTalk メッセージ マネージャで自分の企業を表すオブジェクト。既定の組織は、BizTalk Server 2000 をインストールすると、自動的に作成されます。既定の組織だけがアプリケーションを持つことができます。

参照 : 送信先アプリケーション、同報リスト、組織、送信元アプリケーション、取引先

休止ステータス

非アクティブまたは休止している処理状態を表すステータス。またはプロセスがスタンバイ モードのときのステータス。

業界標準

情報の交換に使用される標準。標準は拡張可能で、明確な規則または構文が定められています。

共有キュー データベース

サーバー グループ内のすべてのサーバーで共有される Microsoft SQL Server データベース。共有キュー データベースには、BizTalk Server が処理するドキュメントに関連するすべてのチェックポイント情報が格納されます。サーバーに障害が発生しても、同じ共有キュー データベースを使用するほかのコンピュータは、作業キューからのメッセージの取得および作業キューへのメッセージの送信を続けることができます。これにより、冗長性と処理の負荷分散を実現します。共有キュー データベースは、BizTalk Server 管理コンソールに、一連の個別キューとしてグラフィカルに表示されます。

参照 : 再送信キュー、送信待キュー、保留キュー、作業キュー

区切りフラット ファイル

区切り文字で区切られたフィールドの集まりとして表されるレコードを含むファイル。レコードは、それ自体も区切り文字で区切られます。

グローバル追跡項目

BizTalk メッセージ サービスが処理したドキュメントのインスタンスごとに、追跡データベースに記録するドキュメント仕様フィールド。ドキュメント定義内で指定します。

参照 : ドキュメント インスタンス、ドキュメント定義

コード一覧

さまざまなテキスト情報の略語として使用されるコード値の一覧。たとえば、ST は "Ship To" に対するコード一覧の値で、一般的に住所を修飾するために使用されます。

コミット

保留中のトランザクションによって要求されているすべての変更を実行すること。このアクションは、トランザクション内のすべてのアクションが正常に完了した場合に発生します。

コンパイル

BizTalk Server が使用できる Extensible Stylesheet Language Transformations (XSLT) バージョンのマップを BizTalk マッパーで作成すること。マップは WebDAV リポジトリに格納され、あるドキュメント書式から別のドキュメント書式に変換するために BizTalk Server によって使用されます。

参照 : データ マッピング、データ変換、Extensible Markup Language (XML)、マップ

さ

サーバー グループ

集中的に管理、構成、監視される個々のサーバーの集合。

再送信

保留キューから BizTalk Server にインターチェンジまたはドキュメントを送信する処理手順。ドキュメントは障害が発生した時点から処理されます。

再送信キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。再送信キューは、最初の送信が試行された後に返信用にスケジュールされた作業項目を含むサーバー グループに関連付けられています。

参照 : 共有キュー データベース、トランスポート サービス、送信待キュー、保留キュー、作業キュー

作業キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。作業キューはサーバー グループに関連付けられています。現在 BizTalk Server 2000 が処理しているインターチェンジが含まれます。

参照 : 再送信キュー、送信待キュー、共有キュー データベース、保留キュー

実装シェイプ

XLANG スケジュール エンジンがサポートするテクノロジを表すシェイプ。このカテゴリのシェイプには、BizTalk メッセージ、COM コンポーネント、メッセージ キュー、およびスクリプト コンポーネントが含まれます。

参照 : 通信シェイプ、フローチャート シェイプ、実装ステンシル

実装ステンシル

BizTalk オーケストレーション デザイナが提供するステンシル。実装ステンシルには、実装テクノロジへポートをバインドするのに使用できるすべてのシェイプがあります。

参照 : フローチャート ステンシル、実装シェイプ

実装テクノロジ

XLANG スケジュールのポートを実装するために使用するテクノロジ。XLANG スケジューラ エンジンによってサポートされるテクノロジには、COM コンポーネント、Windows スクリプト コンポーネント、メッセージ キュー サービス、および BizTalk メッセージ サービスがあります。

受信確認チャネル

ドキュメントの送信者に返信する受信確認を処理するために必要な情報を含むチャネル。

参照 : チャネル

受信機能

BizTalk server がディレクトリを監視し、BizTalk Server にドキュメントを送信できるようにする機能。BizTalk Server 2000 では、ファイル受信機能とメッセージ キュー受信機能がサポートされます。

仕様

BizTalk Server 特有の XML スキーマ。仕様は BizTalk エディタで作成し、業界標準 (EDIFACT、ANSI X12、XML など) またはフラット ファイル (区切り、位置指定、または区切り位置指定) を基にして作成することができます。BizTalk マッパーは、送信元仕様および送信先仕様を開き、それらの仕様を使ってマップを作成します。

シリアライザ

XML ファイルを非 XML ファイル (ANSI X12、EDIFACT、フラット ファイルなど) に変換する BizTalk Server のコンポーネント。

信頼できるメッセージ

インターネット間の異種環境において、ドキュメントの確実に一度だけ配信される機能をサポートする BizTalk フレームワーク 2.0 プロトコルの機能。

スキーマ

XML ファイルの構造の定義。スキーマには構造内のレコードおよびフィールドに属するプロパティ情報が含まれます。

ステータス

コンピュータ処理のさまざまな要素のある時点での状態。

参照 : XLANG スケジュール ステータス

ステータス退避

ビジネス プロセスの次のアクションを実行する前、XLANG スケジューラ エンジンがメッセージの受信を待機している間に、XLANG スケジュール インスタンスのすべてのステータス情報を SQL Server データベースに格納すること。

参照 : XLANG スケジューラ エンジン

ステータス退避済みスケジュール

次のアクションに進む前、メッセージの受信を待機している間に、一時的にデータベースに格納されたスケジュール。スケジュールのすべてのステータス情報は、メッセージが受信されるまでデータベースに格納されます。スケジュールをステータス退避すると、スケジュールをホストしているコンピュータの負荷が減ります。

ステータス復元

メッセージが XLANG スケジュール エンジンによって受信された後、SQL Server データベースから XLANG スケジュール インスタンスのすべてのステータス情報を取得すること。

参照 : XLANG スケジューラ エンジン

ステータス保存データベース

XLANG スケジュールが退避されるときに、XLANG スケジュールのステータスを格納するために使用されるデータベース。BizTalk Server 2000 をインストールするとき、インストール中にオーケストレーション データベースという既定のデータベースが作成されます。

整形式の XML

単一のルートおよび完全にネストしているかまったくしていない要素を持つ、標準に適合した XML。

静的キュー

アドレスが静的に決まっているキュー。キューの場所が決まっていて不変な場合、メッセージ キューを使用するポートは静的キューを使用します。

参照 : 動的キュー、インスタンス キュー

静的ポート

XLANG スケジュールに必要なすべての情報を、設計時に設定するポート。XLANG スケジュールを作成するときに、メッセージの送信先や受信する場所、および通信アクションに使用する実装シェイプのテクノロジを設定します。

参照 : 動的ポート、ポート

セルフルーティング ドキュメント

ルーティング タグまたはドキュメント内に、送信元組織識別子、送信先組織識別子、ドキュメント定義などのすべての必要なルーティング情報を含んでいるドキュメント。

選択条件

ドキュメント定義に指定された、名前と値の組。名前と値の組は、ファンクショナル グループ ヘッダーにある値に基づいて、受信 EDI インターチェンジに対応するドキュメント定義を一意に識別するため、および送信 EDI インターチェンジのファンクショナル グループ ヘッダーに値を設定するために使用されます。

参照 : ドキュメント定義、電子データ交換 (EDI)

送信先アプリケーション

メッセージ ポートにドキュメントの送信先として指定されている既定の組織のアプリケーション。

参照 : 既定の組織

送信先仕様

送信ドキュメントを表す、マップ内の仕様。BizTalk マッパーを使用して、送信元仕様を送信先仕様にマップします。

参照 : 送信元仕様

送信先組織

メッセージ ポートにドキュメントの送信先として設定されている取引先の組織。

参照 : オープンネス、送信元組織、組織

送信待キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。送信待キューは、BizTalk Server が受信したがまだ処理していないインターチェンジを持つサーバー グループに関連付けられています。

参照 : 再送信キュー、共有キュー データベース、保留キュー、作業キュー

送信元アプリケーション

チャネルにドキュメントの送信元として指定されている既定の組織のアプリケーション。

参照 : チャネル, 既定の組織

送信元仕様

受信ドキュメントを表す、マップ内の仕様。BizTalk マッパーを使用して、送信元仕様を送信先仕様にマップします。

参照 : 送信先仕様

送信元組織

チャネルにドキュメントの送信元として設定している取引先の組織。

参照 : チャネル、送信先組織、オープン チャネル、オープンなメッセージ ポート、組織、取引先、オープンネス

組織

取引先または取引先の業務部門。既定の組織の場合、自分の企業。

参照 : 送信元組織、送信先組織、既定の組織、組織識別子、取引先

組織識別子

組織を一意に識別する一連のプロパティ。組織は複数の組織識別子をもつことができます。組織識別子は、名前、修飾子、値から構成されます。

参照 : 組織

外側のトランザクション

処理フローに 1 つ以上のトランザクションを含むトランザクション。

参照 : 内側のトランザクション、長時間トランザクション、ネストしたトランザクション、トランザクション

た

短時間トランザクション

作業の単独論理単位として実行するアクションの集合。

参照 : 長時間トランザクション、トランザクション

チェックポイント

作業項目の現在のステータスが格納されている、共有キュー データベース内の格納場所。サーバーに障害が発生した場合、そのサーバーのキューにあるドキュメントは、チェックポイントに記録されている情報を基に、共有キュー データベースから取り出され、サーバー グループ内の別のサーバーで処理されます。

チャネル

送信元のドキュメントを指定し、チャネルに関連付けられているメッセージ ポートまたは同報リストによって指定されている送信先にドキュメントが配信される前に BizTalk メッセージ マネージャが行う特定の処理手順を定義するプロパティ。

参照 : オープン チャネル、オープンなメッセージ ポート、受信確認チャネル、送信元アプリケーション、取引先、パススルー送信、送信元組織

チャネル フィルタ

ドキュメント インスタンス内のフィールドの値とチャネル内に指定された式の値を比較すること。この比較により、ドキュメントを処理するためにサーバーが呼び出すチャネルが決まります。

中断

進行中のトランザクションをキャンセルし、代わりに別のビジネス プロセスを実行すること。

長時間トランザクション

数日間、数ヶ月間などの長期に渡るメッセージを送受信するアクションの集合。通常、長時間トランザクションにはいくつかのネストした短時間トランザクションが含まれます。

参照 : 短時間トランザクション、内側のトランザクション、ネストしたトランザクション、外側のトランザクション、トランザクション

追跡データベース

個別またはバッチでサーバーが処理するドキュメントを追跡する、サーバー グループに関連付けられている Microsoft SQL Server データベース。XLANG スケジュール ステータスも追跡できます。

通信シェイプ

メッセージの内容そのもの、および XLANG スケジュール フローチャートに実装されるアプリケーション サービスの種類を表すためのシェイプ。この種類のシェイプには、定数 (Constants)、メッセージ (Message)、ポート (Port)、ポート参照 (Port References) が含まれます。

参照 : フローチャート シェイプ、実装シェイプ、XLANG スケジュール フローチャート

ディクショナリ

BizTalk Server によって処理される各作業単位に関連付けられるプロパティの集まり。これによって、メッセージ ポートを決定するのに使うドキュメント インスタンス内にあるプロパティの値の検索方法を、BizTalk Server に対して指示できます。ディクショナリは BizTalk エディタで設定します。

データ変換

データをある形式から別の形式に変換する処理。データ変換は、BizTalk Server が実行しているときに行われます。データを送信元仕様の形式から送信先仕様の形式に変換する際、データに必要な処理および計算を実行するのに、マップに指定された規則が使用されます。

参照 : コンパイル、データ マッピング、Extensible Markup Language (XML)、マップ

データ マッピング

送信元仕様のレコードおよびフィールドと、送信先仕様のレコードおよびフィールドとの対応関係を BizTalk マッパーで作成すること。

参照 : コンパイル、データ変換

電子データ交換 (EDI)

異なる企業間で、商取引のためのデータを、通信回線を介して標準的な規約 (可能な限り広く合意された各種規約) を用いて、コンピュータ (端末を含む) 間で交換すること。コンピュータ間の注文や請求書などのドキュメントの転送を制御するために使用する一連の標準。

参照 : 選択条件

同期通信

単一の通信アクション内で、メッセージ送信とそれに関連する受信を両方セットでする通信形態。

参照 : 非同期通信

同時実行

同時に実行される 2 つ以上のアクション。

動的キュー

アドレスが動的に決まるキュー。メッセージ キューを使用するポートは、キューの場所が動的な場合、動的キューを使用します。実行時にメッセージが、このキューのアドレスのポート参照を指定します。

参照 : 静的キュー、インスタンス キュー

動的ポート

実行時に、XLANG スケジュールに特定の場所情報を提供する必要があるポート。動的ポートの場所は、実行時にポートを参照する場所情報を持ったメッセージによって提供されます。

参照 : ポート、静的ポート

同報リスト

複数の異なる取引先または既定の組織のアプリケーションに、同じドキュメントを送信するためのメッセージ ポートのグループ。BizTalk メッセージ構成オブジェクト モデルでは、同報リストはポート グループとして参照されます。

参照 : 既定の組織、メッセージ ポート、取引先

ドキュメント インスタンス

BizTalk Server に送信される実際のデータの表現。ドキュメント インスタンスは、構造化されたデータの表現です。データ構造を定義する仕様とは別のものです。

参照 : グローバル追跡項目、パススルー送信

ドキュメント型

仕様が準拠しているドキュメント形式の名称。たとえば、仕様が ANSI X12 標準からの 850Schema.xml に準拠している場合、その仕様を BizTalk エディタで開くと、ルート ノードの [参照] タブの [ドキュメント型] フィールドに 850 と表示されます。

ドキュメント型定義 (DTD)

どの要素および属性がほかの要素および属性にあるかを指定する標準に基づいた定義、順序、繰り返し、および内容なども定義します。

ドキュメント定義

特定のドキュメントを表す一連のプロパティ。ドキュメント定義のプロパティにはドキュメント定義へのポインタが含まれ、グローバル追跡項目および選択条件も含みます。

参照 : グローバル追跡項目、選択条件

ドキュメント標準

ANSI X12 標準 850 (注文) などのトランザクション セットの構造のインプリメンテーション。実装ガイドライン (データ交換接続システム準備のための説明書) はドキュメント標準から作成することができます。

トランザクション

顧客からの注文入力や在庫の更新など、コンピュータ システム内の個々の処理。トランザクションは通常、データベース管理システム、注文入力システムなどのオンライン システムに関連付けられています。BizTalk オーケストレーション デザイナでは、トランザクションはトランザクション シェイプ内のグループ化されたアクションの集合として表されます。

参照 : 内側のトランザクション、長時間トランザクション、ネストしたトランザクション、外側のトランザクション、短時間トランザクション

トランザクション セット

ビジネス ドキュメントを表現する、EDI スキーマ。意味的に関連するフィールドの集まりであるセグメント複数で構成され、フィールドやセグメントの順序と意味が定義されています。トランザクション セットは、ANSI X12の用語で、EDIFACT では、メッセージという用語が使われます。

トランスポート サービス

ネットワーク プロトコルとアプリケーション統合コンポーネント (AIC) を含む一連のサービス。BizTalk Server 2000 は主要なトランスポート サービスをサポートします。これにより、アプリケーションが COM インターフェイスを使ってサーバーと直接通信できるかどうかに関係なく、サーバーは組織またはアプリケーションにドキュメントを送信できます。BizTalk Server 2000 は、ファイル、HTTP、HTTPS、および SMTP の各ネットワーク プロトコルと、メッセージ キューをサポートしています。トランスポート サービスは、トランスポート コンポーネントとも呼ばれます。

参照 : 再送信キュー、ループバック

取引先

既定の組織が電子データを交換する外部の組織。メッセージ ポート、同報リスト、チャネル、および XLANG スケジュールによって、取引先とのドキュメント交換を管理します。

参照 : チャネル、送信元組織、同報リスト、既定の組織、組織

な

ネストしたトランザクション

より大きなトランザクションの処理フロー内に含まれるトランザクション。

参照 : 内側のトランザクション、長時間トランザクション、トランザクション、外側のトランザクション

ノード パス

XML 要素および属性情報の取得、条件に一致するデータの選択、および取得したデータの比較の実行に使用する式。公式には、XPath として知られています。

参照 : XPath

は

パーサー

XML ファイルや、非 XML ファイル (ANSI X12、EDIFACT、フラット ファイルなど) を XML ファイルに変換する BizTalk Server のコンポーネント。

バージョン

BizTalk Server 2000 では、仕様のリリース番号、または作成した仕様の元となった業界標準のバージョン番号のいずれかのこと。

パイプライン コンポーネント

BizTalk Server 2000 でアプリケーションを統合するために作成されるコンポーネント。開発者は、IPipelineComponent または IPipelineComponentAdmin インターフェイスのいずれか、またはより負荷の少ない IBTSAppIntegration インターフェイスを使用して、これらのコンポーネントを開発できます。

バインド

ポートを実装すること。

参照 : ポート

パススルー送信

解析、デコード、暗号解読、変換、および署名検証の処理段階をバイパスする送信。ドキュメント インスタンスは、送信パラメータで指定されたチャネルに直接渡されます。この種類の送信は、データが破損しないようにバイナリ ファイルを送信するため、またはサーバー トランスポートとグローバル追跡機能のみを使用するために使用することができます。

参照 : チャネル、ドキュメント インスタンス

判断

条件式を順番に評価する処理。BizTalk オーケストレーション デザイナでは、判断は判断シェイプで表されます。条件は、Microsoft Visual Basic Scripting Edition (VBScript) 式で記述し、[判断] シェイプおよび [繰り返し] シェイプで使用します。

非セルフルーティング ドキュメント

送信元組織識別子、送信先組織識別子、ドキュメント定義などのルーティング情報のうち、1 つ以上が欠けているドキュメント。

非同期通信

単一の通信アクション内で、メッセージの送信または受信のどちらか片方だけを行う通信形態。

参照 : 同期通信

フローチャート シェイプ

XLANG スケジュール フローチャートのルーティング定義を表すシェイプ。このカテゴリのシェイプには、開始、アクション、判断、繰り返し、分岐、結合、トランザクション、終了、および中断が含まれます。

参照 : 通信シェイプ、実装シェイプ、フローチャート ステンシル、XLANG スケジュール フローチャート

フローチャート ステンシル

BizTalk オーケストレーション デザイナが提供するステンシル。フローチャート ステンシルには、LANG スケジュールで実行できるビジネス プロセスの処理フローを設計するのに使用できるすべてのシェイプがあります。

参照 : フローチャート シェイプ、実装ステンシル

ポート

特定の実装を行う名前を付けられた場所。BizTalk オーケストレーション デザイナでは、メッセージが送受信される場所、または通信アクションを実装する場所のこと。場所はポート名によって一意に識別されます。

参照 : 動的ポート、モニカ、ポートの場所、ポート参照、ポート実装、ポート名、バインド、静的ポート

ポート グループ

同じドキュメントをいくつかの異なる取引先の組織またはアプリケーションに送信するために使用することができるメッセージ ポートの集まり。BizTalk メッセージ マネージャでは、これを同報リストと呼びます。

ポート参照

XLANG スケジュール内の各ポートの場所を含む一意なメッセージ。ポート参照シェイプは [データ] ページに表示されます。このメッセージの内外のデータ フローには、ポートの場所が含まれます。

参照 : ポートの場所、ポート、ポート実装、ポート名

ポート実装

通信アクションを実装するためにポートが使用する特定のテクノロジ。

参照 : ポート、ポートの場所、ポート参照、ポート名

ポートの場所

特定のポートと関連付けられた場所。場所は使用されるポート実装に依存します。各実装によって、ポートに対して異なる種類の場所が提供されます。

参照 : ポート、ポート実装、ポート名、ポート参照

ポート名

ポートの一意な ID。この ID は、ポートの場所を特定のポートに関連付けるために使用されます。

参照 : ポート、ポート実装、ポートの場所、ポート参照

補正

完了したトランザクションに対する修復処理。たとえば、注文に対する支払いを済ませた後、結局その注文に応えられなかった場合、支払い額を購入者に返します。

保留キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。保留キューはサーバー グループに関連付けられています。キューには、処理中にエラーが発生した作業項目が含まれます。キューは、ドキュメントが修正および再処理されるか単純に削除されるまで、ドキュメントを格納します。

参照 : 再送信キュー、送信待キュー、共有キュー データベース、作業キュー

ま

マッピング

ある構造のデータを別の構造に変換する方法の指定に従ってする処理。

マップ

ある仕様のレコードおよびフィールドと、別の仕様のレコードおよびフィールドとの対応関係を定義する XML ファイル。マップには、マップに記述された変換を実行するために BizTalk Server が使用する Extensible Stylesheet Language (XSL) スタイル シートが含まれます。マップは BizTalk マッパーで作成します。

参照 : コンパイル、Extensible Markup Language (XML)、データ変換

メッセージ

1. XLANG スケジュールによって送受信されるデータ パケット。

2. BizTalk オーケストレーション デザイナの、XLANG スケジュールのメッセージに対応する、[データ] ページのシェイプ。メッセージ シェイプは一意に名前付けされたフィールドから構成され、各フィールドにはそれぞれのデータ型のデータが含まれています。

メッセージ ポート

ドキュメントにどのようにエンベロープを付け、どのようにセキュリティをかけ、どのように指定した送信先組織またはアプリケーションに送信するかを指示する一連のプロパティ。

参照 : 同報リスト

モニカ

オブジェクトを表す名前。オブジェクトの場所を識別する完全パスまたはアドレスを含むことができます。

参照 : ポート

ら

リンク

Microsoft BizTaｌk マッパーで、送信元仕様のフィールドから送信先のフィールドまたは Functoid への単純な値や名前のコピーを指定する操作。

参照 : Functoid

ルーティング ロジック

XLANG スケジュール内で実行する順序を決定する一連の規則。ルーティング ロジックは、BizTalk オーケストレーション デザイナの判断シェイプによって実装されます。

ループバック

現在のステータス データをステータス データの元となるアプリケーションに返すことを可能にする特別なトランスポート サービス。ループバックでは、ステータス データを元のアプリケーションに戻すために、SubmitSync メソッドを使います。

参照 : トランスポート サービス


ヘルプの使い方

ここでは Microsoft BizTalk Server 2000 ヘルプについて説明します。次のトピックが含まれます。

  • ヘルプの概要

  • ヘルプ トピックの検索

  • ヘルプ トピックへのブックマークの設定

  • ヘルプ トピックのコピー

  • ヘルプ トピックの印刷

  • フォント サイズの変更

  • 言語フィルタの使い方

  • ヘルプ ビューアのショートカット キー


ヘルプの概要

Microsoft BizTalk Server 2000 ヘルプは、情報の書式設定と表示に HTML を使用しています。ヘルプ ビューアには、総合目次、キーワード、および全文検索機能があり、これらを使用して情報を簡単に探し出せます。ブック アイコンを開くと、サブブックとトピックが表示されます。目次を展開し、ブック内のトピックを表示するには、ブック タイトルの横の展開記号 (+) をクリックします。折りたたみ記号 (-) をクリックすると、トピックが折りたたまれます。ヘルプ ビューアでは、ヘルプ トピックを表示したまま、目次、キーワード、または検索結果を表示できるという利点もあります。

ヘルプ ビューアには [お気に入り] タブもあり、これを使用してトピックにブックマークを設定することができます。これにより、頻繁に参照するトピックをすばやく表示できます。

BizTalk Server 2000 の詳細を確認するには、目次を使用してヘルプ全体の内容を参照できます。目次内のトピックをクリックすると、ヘルプ ウィンドウの内容ペインに情報が表示されます。

目次は、BizTalk Server 2000 の主な機能ごとに、ブック単位でまとめられています。それぞれのブックには、次の情報を含むサブブックがあります。

  • 操作方法

  • 概念

  • トラブルシューティング

  • 参考資料

手順とその作業に基づく情報については、「操作方法」を参照してください。BizTalk Server 2000 とその機能の全般的な情報とその他の情報については、「概念」と「参考資料」を参照してください。

「BizTalk Server 2000 Interface Reference」内のプログラミング情報については、言語フィルタ ツールを使用して、Microsoft Visual Basic と Visual C++ のどちらかまたは両方に固有の情報を参照できます。

関連項目

ヘルプ トピックへのブックマークの設定

ヘルプ トピックのコピー

フォント サイズの変更

ヘルプ トピックの検索

ヘルプ ビューアのショートカット キー

ヘルプ トピックの印刷

言語フィルタの使い方


ヘルプ トピックの検索

ヘルプ ビューアでは、次の表示オプションと検索オプションを使用できます。

  • [目次] タブ
    1. 目次を参照するには、[目次] タブをクリックします。ブック アイコンをダブルクリックして、トピック エントリおよびサブブックを表示します。

    2. 目次エントリをクリックして、対応するトピックを表示します。
  • [キーワード] タブ
    1. [キーワード] タブをクリックしてから、単語を入力するか、一覧をスクロールして、キーワード エントリの一覧を参照します。1 つのトピックが複数のエントリとして表されていることもあります。

    2. キーワード エントリをダブルクリックして、対応するトピックを表示します。
  • [検索] タブ
    1. [検索] タブをクリックしてから、検索する単語または句を入力し、[検索開始] をクリックして、単語または句が含まれるすべての場所を検索します。

      検索結果を絞り込むためには、AND、OR、NEAR、または NOT を使用して、単語または句をいくつか組み合わせます。

    2. 検索結果のエントリをダブルクリックして、対応するトピックを表示します。
  • [お気に入り] タブ
    1. トピックにブックマークを設定するには、[目次]、[キーワード]、[検索] のいずれかのタブを使用して、トピックを表示します。

    2. [お気に入り] タブをクリックし、[追加] をクリックして、トピック タイトルを [トピック] ボックスの一覧に追加します。

    3. [トピック] ボックスの一覧でブックマークをダブルクリックすると、目的のトピックをすばやく表示できます。

関連項目

ヘルプ ビューアのショートカット キー


ヘルプ トピックへのブックマークの設定

  1. [目次]、[キーワード]、[検索] のいずれかのタブを使用して、ブックマークを設定するトピックを表示します。

  2. [お気に入り] タブをクリックし、[追加] をクリックします。

トピック タイトルが [トピック] ボックスの一覧に追加されます。後でこの一覧からブックマークをダブルクリックすると、トピックをすばやく表示できます。

注

  • 頻繁に表示するお気に入りのヘルプ トピックの一覧を作成できます。

  • [トピック] ボックスの一覧からブックマークを削除するには、ブックマークをクリックし、[削除] をクリックします。

関連項目

ヘルプ トピックの検索

ヘルプ ビューアのショートカット キー


ヘルプ トピックのコピー

  1. ヘルプ ビューアのトピック ペインで、コピーするトピック内を右クリックし、[すべて選択] をクリックします。

  2. トピック内でもう一度右クリックし、[コピー] をクリックします。

    トピックがクリップボードにコピーされます。

  3. トピックのコピー先のドキュメントを開きます。

  4. 情報を挿入するドキュメント内の場所をクリックします。

  5. [編集] メニューの [貼り付け] をクリックします。

注

  • トピックの一部だけをコピーする場合は、コピーする部分を選択してから、選択部分を右クリックし、[コピー] をクリックします。

  • 手順番号はクリップボードへはコピーされません。

関連項目

ヘルプ トピックの検索

ヘルプ トピックの印刷


ヘルプ トピックの印刷

  • 印刷するトピックを右クリックし、[印刷] をクリックします。

重要

  • 単一のトピックを印刷するには、[目次] タブでトピックを選択します。ヘルプのツール バーにある [印刷] をクリックし、[選択されたトピックの印刷] をクリックします。ページの印刷の向きは [横] に設定することをお勧めします。ただし、コード例、大きな図、および改行できないテキストは完全に印刷されない場合があります。

  • ブック内のすべてのトピックを印刷するには、[目次] タブでブックを選択します。ヘルプのツール バーの [印刷] をクリックし、[選択された見出しおよびすべてのサブトピックを印刷] をクリックします。ページの印刷の向きは [横] に設定することをお勧めします。ただし、コード例、大きな図、および改行できないテキストは完全に印刷されない場合があります。

関連項目

ヘルプ トピックの検索

ヘルプ ビューアのショートカット キー


フォント サイズの変更

テキストのフォント サイズを拡大して表示を見やすくしたり、縮小してページ全体のレイアウトを確認したりできます。

  • テキストのサイズを拡大または縮小するには、ツール バーの [フォント] ( フォント ボタン) をクリックします。


言語フィルタの使い方

使用しているプログラミング環境に関連する情報だけを表示できるように、BizTalk Server 2000 ヘルプには言語フィルタ ツールが実装されています。「BizTalk Server 2000 Interface Reference」内のトピックのタイトル バーには、言語メニューを表示するフィルタ ( 言語フィルタ ツール) ボタンがあります。このメニューには、Visual C++ 用または Visual Basic 用のドキュメントを表示する選択項目があります。[すべて表示] を選択すると、両方の言語の情報が表示されます。両方の言語に関係する (一般的な概念などの) 情報は、どの言語を選択しているかに関係なく、常に表示されます。

  • 言語フィルタ オプションを表示するには、ツール バーのフィルタ ( 言語フィルタ ツール) ボタンをクリックし、次のいずれかのオプションをクリックします。
    • [C++]

    • [Visual Basic]

    • [すべて表示]

注

  • 言語フィルタ オプションを選択すると、オプションを再び変更するまで、表示されるすべてのページでその選択が有効になります。


ヘルプ ビューアのショートカット キー

BizTalk Server 2000 ヘルプ ビューアの操作は、ショートカット キーを使用しても実行できます。次の表は、ヘルプ ビューアで利用できるショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。または、Windows 2000 Professional ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。

ヘルプ ビューアのショートカット キー

ショートカット キー | 機能
Alt + Space | システム メニューを表示します。
Shift + F10 ヘルプ ビューアのショートカット メニューを表示します。

注

  • このショートカットは、トピック ペインにフォーカスがある場合に使用します。
Alt + Tab | ヘルプ ビューアと開いているほかのウィンドウとを切り替えます。
Alt + O | [オプション] メニューを表示します。
Alt + O、次に T | ナビゲーション ペインの表示と非表示を切り替えます。
↑ 目次、キーワード、または検索結果の一覧で、1 つ上のトピックに移動します。
↓ 目次、キーワード、または検索結果の一覧で、1 つ下のトピックに移動します。
PageUp | 目次、キーワード、または検索結果の一覧で、1 ページ上に移動します。
PageDown | 目次、キーワード、または検索結果の一覧で、1 ページ下に移動します。
F6 | ナビゲーション ペインとトピック ペインとの間でフォーカスを切り替えます。
Alt + O、次に R | トピック ペインに表示されるトピックを更新します。
↑または↓ トピックをスクロールします。
Ctrl + Home | トピックの先頭に移動します。
Ctrl + End | トピックの最後に移動します。
Ctrl + A | トピック ペインのすべてのテキストを強調表示します。
Alt + O、次に P | トピックを印刷します。
Alt + O、次に B | 前に表示したトピックに戻ります。
Alt + O、次に F | (前に表示した) 次のトピックに移動します。
Tab 関連するトピック間を移動します。

注

  • このショートカットは、トピック ペインにフォーカスがある場合に使用します。
Alt + F4 | ヘルプ ビューアを閉じます。

[目次] タブのショートカット キー

ショートカット キー | 機能
Alt + C | [目次] タブを表示します。
→ | ブックを開きます。
← | ブックを閉じます。
BackSpace | 前に開いたブックに戻ります。
↑または↓ | トピックを選択します。
Enter | 選択したトピックを表示します。

[キーワード] タブのショートカット キー

ショートカット キー | 機能
Alt + N | [キーワード] タブを表示します。
↑または↓ | 一覧内のキーワードを選択します。
Alt + D または Enter | 関連付けられたトピックを表示します。

[検索] タブのショートカット キー

ショートカット キー | 機能
Alt + S | [検索] タブを表示します。
Alt + L | 検索を開始します。
Alt + D または Enter | 選択したトピックを表示します。

[お気に入り] タブのショートカット キー

ショートカット キー | 機能
Alt + I | [お気に入り] タブを表示します。
Alt + A | [トピック] ボックスの一覧にトピックを追加します。
Alt + P [トピック] ボックスの一覧のトピックを選択します。

注

  • このショートカットは、トピック ペインにフォーカスがある場合に、[トピック] ボックスの一覧に移動するときに使用します。
Alt + R | [トピック] ボックスの一覧からトピックを削除します。
Alt + D | [トピック] ボックスの一覧のトピックを表示します。

関連項目

ヘルプの概要


障害をお持ちの方のためのユーザー補助機能

マイクロソフトでは、すべてのユーザーにとって使いやすい製品を提供するために努力しています。Microsoft BizTalk Server 2000 を使いやすくする機能については、次のトピックを参照してください。

  • ヘルプ ビューアのショートカット キー

  • BizTalk Server 管理コンソールのショートカット キー

  • BizTalk ドキュメント トラッキングのショートカット キー

  • BizTalk オーケストレーション デザイナのショートカット キー

  • BizTalk メッセージ マネージャのショートカット キー

  • BizTalk エディタのショートカット キー

  • BizTalk マッパーのショートカット キー

注

  • ユーザー補助機能のオプションの詳細については、Windows 2000 Server ヘルプの「Windows 2000 Server の紹介」ブックに含まれる「ユーザー補助機能」を参照してください。Windows 2000 Professional ヘルプの場合は、「特殊なニーズに合わせたユーザー補助の概要」を参照してください。


Microsoft 製品サポート サービス

製品名 : Microsoft BizTalk Server 2000

サポート オプション : サポート オプションに関する最新の情報を入手するには、Microsoft 製品サポート サービスの Web サイト (http://www.microsoft.com/japan/support/faq/) を参照して、製品一覧から BizTalk Server 2000 を選択してください。

条件 : Microsoft 製品サポート サービスに関連する費用、期間、および条件は、将来予告なしに変更することがあります。


BizTalk Server 2000 チュートリアル

Business-to-Business 自動調達

このチュートリアルでは、Microsoft BizTalk Server 2000 を構成し、Business-to-Business 自動調達のプロセスを設定し、実行する方法について学習します。

さらに、BizTalk Server のコンポーネントとサービスの連携機能を活用し、企業内および企業間における、疎結合、長時間ビジネス プロセスを統合する方法についても学習します。

注

BizTalk Server 2000 チュートリアルは、Microsoft Word 形式でも提供しています。チュートリアルを印刷する場合は、Word バージョンをご利用ください。Word をインストールしていない場合は、ワードパッドや Microsoft Word 97/2000 ビューアで閲覧することができます。Tutorial.doc ファイルは、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Documentation フォルダにあります。

要件

このチュートリアルを完了するには、BizTalk Server 2000 と、そのすべての付属コンポーネントをインストールする必要があります。BizTalk Server 2000 のハードウェア要件およびソフトウェア要件の一覧については、「BizTalk Server 2000 のインストール」を参照してください。

シナリオ

このシナリオでは、BizTalk Server 2000 の主要要素の概要について説明します。ProElectron, Inc. (購入側企業) では、BizTalk Server 2000 を使用して、Bits, Bytes, & Chips, Inc. (販売側企業) とのBusiness-to-Business 自動調達処理を実装しています。

ProElectron では、XLANG スケジュールを使用して、システムにおけるメッセージ フローを制御しています。注文要求が 1,000 ドル以下の場合は、注文が生成されて Bits, Bytes, & Chips に送信されます。1,000 ドルを超える場合、処理は終了します。

購入者のシステムには BizTalk メッセージ サービスが使用されています。BizTalk メッセージ サービスは、注文を受信してその経路を選定し、Bits, Bytes, & Chips の使用する書式に合わせて変換を行い、データを抽出します。

両者のシステムでは、BizTalk Server 2000 と連動する付属コンポーネントがこれ以外にも多数使用され、主要なデータ処理作業が実行されています。

次の図は、ProElectron および Bits, Bytes, & Chips で実装している Business-to-Business 自動調達システムの相互関係ダイアグラムを示しています。矢印は各ロールおよびエンティティ間のデータ フローを示します。

インターネット
注文用
アプリケーション
Invoice
Payment
Bits, Bytes,
& Chips, Inc
Purchase
order
PO request
approval
PO approval
ProElectron, Inc
Purchase request
ユーザー
PO 承認者
会計担当者
仕入先

重要

  • このシナリオの性質上、購入者と販売者の両方のシステムを単独の BizTalk Server 2000 に構成しています。

次の図は、購入者のシステムと販売者のシステムとの間におけるドキュメントの移動を示しています。またここには、XLANG スケジュール、BizTalk メッセージ サービス、および付属コンポーネント間のやりとりも示されています。この図を印刷して、確認しながらチュートリアルの各モジュールを進めていくと便利です。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい (拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

コンテンツ

モジュール 1 : ビジネス プロセスのモデル化

このモジュールでは、次のことについて学習します。

  • BizTalk オーケストレーション デザイナを使用して、ProElectron の調達プロセスをモデル化した XLANG スケジュール フローチャートを作成する。詳細については、「BizTalk オーケストレーションの設計」を参照してください。

  • XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルする。詳細については、「XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル」を参照してください。

  • XLANG スケジュールを実行し、購入者のシステムにおけるメッセージの移動状況を確認する。

モジュール 2 : 仕様とマップの作成

このモジュールでは、次のことについて学習します。

  • BizTalk エディタを使用して、ドキュメント仕様を作成する。詳細については、「仕様の作成と検証」を参照してください。

  • BizTalk マッパーを使用して、マップを作成する。詳細については、「新しいマップの作成」を参照してください。

モジュール 3 : BizTalk メッセージ サービスの構成

このモジュールでは、次のことについて学習します。

  • BizTalk メッセージ マネージャを使用して、Bits, Bytes, and Chips の BizTalk メッセージ サービスを構成する。詳細については、「BizTalk メッセージ マネージャの使用」を参照してください。

  • BizTalk Server 管理コンソールを使用して、Bits, Bytes, and Chips 向けのファイル受信機能を作成する。詳細については、「ファイル受信機能の追加」を参照してください。

モジュール 4 : XLANG スケジュールの完成

このモジュールでは、次のことについて学習します。

  • モジュール 2 において着手した BizTalk メッセージの実装によって、XLANG スケジュール フローチャートにポートを実装する。ポートとメッセージ ポートの違いについては、「ポート実装について」および「メッセージ ポートについて」を参照してください。

  • XLANG スケジュール フローチャートを完成させ、これを XLANG スケジュールにコンパイルする。

  • コンパイルした XLANG スケジュールを実行して、購入者と販売者の両システム間のメッセージのすべての動きを理解する。

ショートカット

ショートカットにより、既存の XLANG スケジュール、ドキュメント仕様、マップ、または構成スクリプトを利用して、時間と手間を省くことができます。ショートカットを使用すると、先の項目に進むことができます。

ショートカットを使用するには、コンポーネントが C ドライブにインストールされている必要があります。

「事前セットアップ」に進みます。


事前セットアップ

チュートリアルを開始する前に、次のものを作成する必要があります。

  • 4 つのサブフォルダを含むフォルダを 1 つ。

  • ASP ファイルを含むローカル Web サイト フォルダを 2 つ。

  • 購入者のシステム用のメッセージ キューを 2 つ。

「フォルダの作成」に進みます。


フォルダの作成

ここでは、4 つのサブフォルダを含むフォルダを 1 つ作成します。サブフォルダのうちの 2 つは購入者と販売者のシステム間で送受信されるメッセージの保存場所として使用し、残りの 2 つは購入者と販売者のそれぞれの Web サイト用のコンテンツ フォルダとして使用します。

フォルダを作成するには次の操作を行います。

  1. エクスプローラで C:\ ドライブのルート ディレクトリを参照します。

    注意

    • 以下に説明するフォルダは、BizTalk Server 2000 をセットアップしたドライブに関わらず、必ず、C:\ ドライブに作成してください。ほかのドライブに作成すると、チュートリアルが正常に動作しません。
  2. C:\ ドライブのルートに TutorialFiles というフォルダを新しく作成します。

  3. 新しく作成したフォルダ TutorialFiles をクリックします。サブフォルダを 4 つ作成し、それぞれに次の名前を付けます。
    • Buyer

    • Seller

    • SubmitPO

    • InvoiceToQueue

「ファイルのコピー」に進みます。


ファイルのコピー

ここでは、チュートリアルで使用するファイルをコピーします。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps に移動し、POReqtoPO.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft に貼り付けます。

  3. 次の表に従って、ほかのファイルをコピーし、TutorialFiles サブフォルダに貼り付けます。
    コピー元 | コピー先
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\SubmitPO\Solution\SubmitProElectronPO.asp | C:\TutorialFiles\SubmitPO
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\DropInvoicetoMSMQ.asp | C:\TutorialFiles\InvoiceToQueue
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\Global.asa | C:\TutorialFiles\InvoiceToQueue

「ローカル Web サイト フォルダの作成」に進みます。


ローカル Web サイト フォルダの作成

ここでは、2 つの仮想ディレクトリを作成します。1 つは請求書受信用の購入者の Web サイトをシミュレートするディレクトリ、もう一つは販売者のシステム上の注文受信用の Web サイトをシミュレートするディレクトリです。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  4. [コンピュータの管理] コンソール ツリーで [サービスとアプリケーション] を展開します。次に [インターネット インフォメーション サービス] を展開し、[既定の Web サイト] をクリックします。

  5. [操作] メニューの [新規作成] をポイントし、[仮想ディレクトリ] をクリックします。

    [仮想ディレクトリの作成ウィザード] が表示されます。

  6. [仮想ディレクトリの作成ウィザードへようこそ] ページで [次へ] をクリックします。

  7. [仮想ディレクトリのエイリアス] ページで、[エイリアス] ボックスに「SubmitPO」と入力し、[次へ] をクリックします。

  8. [Web サイトのコンテンツのディレクトリ パス] ページで [参照] をクリックします。

  9. C:\TutorialFiles\SubmitPO に移動し、[OK] をクリックします。それから [次へ] をクリックします。

  10. [アクセス許可] ページで [次へ] をクリックします。

  11. [完了] をクリックして [仮想ディレクトリの作成ウィザード] を終了します。

  12. [コンピュータの管理] コンソール ツリーで [既定の Web サイト] をクリックします。

  13. 購入者の Web サイトをシミュレートしたフォルダを作成するには、次の変更点に注意して手順 5. ～ 11. の操作を繰り返します。
    • 手順 7. では、[エイリアス] ボックスに「InvoiceToQueue」と入力します。

    • 手順 9. では、C:\TutorialFiles\InvoiceToQueue に移動します。

[コンピュータの管理] コンソールは、次のようになります。

図をクリックすると、拡大または縮小します。

  14. [コンピュータの管理] コンソールを閉じます。

「メッセージ キューの作成」に進みます。


メッセージ キューの作成

ここでは、2 つのメッセージ キューを作成して購入者のシステムでメッセージの送受信ができるようにします。

注

この操作を実行するには、メッセージ キューをインストールしておく必要があります。メッセージ キューのインストールについては、「メッセージ キューのインストール」を参照してください。

メッセージ キューを作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  4. [コンピュータの管理] コンソールで、[サービスとアプリケーション] を展開します。次に [メッセージ キュー] を展開し、[専用キュー] をクリックします。

  5. [操作] メニューの [新規作成] をポイントし、[専用キュー] をクリックします。

    [キューの名前] ダイアログ ボックスが表示されます。

  6. [名前] ボックスに「ReceivePOReq」と入力します。

  7. [トランザクション] チェック ボックスをオンにし、[OK] をクリックします。

  8. メッセージ キューをもう 1 つ作成するには、次の変更点に注意して手順 5. ～ 7. の操作を繰り返します。
    • 手順 6. では、[名前] ボックスに「ReceiveInvoice」と入力します。

[コンピュータの管理] コンソールは、次のようになります。

図をクリックすると、拡大または縮小します。

  9. [コンピュータの管理] コンソールを閉じます。

「付属コンポーネントのインストール」に進みます。


付属コンポーネントのインストール

ここでは、次の付属コンポーネントをインストールします。

  • Windows スクリプト コンポーネント (WSC)。購入者のシステムにインストールし、ポートを XLANG スケジュールにポートを実装するために使用します。注文要求に対する承認ステータスまたは拒否ステータスを XLANG スケジュールから受信します。

  • アプリケーション統合コンポーネント (AIC)。販売者のシステムにインストールし、購入者の注文データに基づいて請求書を生成するために使用します。

    注意

    • 上記のコンポーネントが既にコンピュータにインストールされている場合は、あらかじめアンインストールしておいてください。アンインストールの方法については、「付属コンポーネントのアンインストール」を参照してください。

付属コンポーネントをインストールするには次の操作を行います。

  1. BizTalk Server をインストールしたドライブで \Program Files\Microsoft BizTalk Server\Tutorial\Setup に移動します。

  2. Install_POtoInvoice.vbs をダブルクリックします。

    コンポーネントが正しくインストールされたことを示すメッセージ ボックスが表示されます。

  3. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution に移動し、PORequestApproval.wsc をクリックします。

  4. [ファイル] メニューの [登録] をクリックします。

    コンポーネントが正しく登録されたことを示すメッセージ ボックスが表示されます。

「モジュール 1 : ビジネス プロセスのモデル化」に進みます。


付属コンポーネントのアンインストール

注意

前にインストールしたコンポーネントを削除する場合以外は、この操作を行わないでください。

  1. POtoInvoice コンポーネントを削除するには、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Setup に移動します。

  2. Remove_POtoInvoice.vbs をダブルクリックします。

    コンポーネントが正しくアンインストールされたことを示すメッセージ ボックスが表示されます。

  3. Windows スクリプト コンポーネントを削除するには、\Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution に移動し、PORequestApproval.wsc をクリックします。

  4. [ファイル] メニューの [登録解除] をクリックします。

    コンポーネントが正しく登録解除されたことを示すメッセージ ボックスが表示されます。

付属コンポーネントの再インストールの方法については、「付属コンポーネントのインストール」を参照してください。


モジュール 1 : ビジネス プロセスのモデル化

ここでは、BizTalk オーケストレーション デザイナを使用して、自動調達プロセスを説明する XLANG スケジュール フローチャートを作成します。さらにその XLANG スケジュール フローチャートを、購入者のシステムのメッセージ フローを制御する実行可能な XLANG スケジュールとしてコンパイルします。

目的

  • 自動調達プロセスを説明する XLANG スケジュール フローチャートを作成する。詳細については、「XLANG スケジュール フローチャートの作成」を参照してください。

  • ビジネス プロセスを説明する論理シーケンスのそれぞれのアクションを接続する。詳細については、「シェイプの接続」を参照してください。

  • アクションをポートに接続してビジネス プロセスを実装する。詳細については、「アクションとポート間の通信フローの確立」を参照してください。

  • 条件式を書き込んで、ビジネス プロセスに条件を追加する。詳細については、「条件の設計」を参照してください。

  • メッセージのデータ フローを定義する。詳細については、「通信シェイプ」を参照してください。

  • XLANG スケジュール フローチャートを保存し、XLANG スケジュールにコンパイルする。詳細については、「XLANG スケジュールのコンパイル」を参照してください。

  • XLANG スケジュールを実行し、BizTalk Server でメッセージを処理する。詳細については、「XLANG スケジュールの実行」を参照してください。

「購入者の XLANG スケジュールの作成」に進みます。

関連項目

BizTalk オーケストレーションの設計


購入者の XLANG スケジュールの作成

ここでは、購入者のビジネス プロセスをモデル化し、XLANG スケジュールを作成します。

XLANG スケジュールを作成するには、「購入者のアクションの作成」に進みます。

ショートカット

既存の XLANG スケジュールを使用する場合は、直接「XLANG スケジュールの実行」に進みます。


購入者のアクションの作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. [ビジネス プロセス] ページで、[フローチャート] ステンシルの [アクション] シェイプを境界バーの左側にドラッグし、[開始] シェイプのすぐ下に配置します。

  3. [アクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [アクションのプロパティ] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに「Receive PO Request」と入力し、[OK] をクリックします。

    注意

    • このチュートリアルを正しく実行するために、名前はすべて示されているとおり正確に入力してください。チュートリアルのコンポーネントには、これらの名前が組み込まれています。
  5. [ビジネス プロセス] ページで [フローチャート] ステンシルの [判断] シェイプを境界バーの左側にドラッグし、[Receive PO Request] アクションのすぐ下に配置します。

  6. [判断] シェイプを右クリックし、[条件の作成] をクリックします。

    [条件のプロパティ] ダイアログ ボックスが表示されます。

  7. [条件名] ボックスに「Denied」と入力し、[OK] をクリックします。

    このモジュールでは、後に、メッセージおよびフィールド名を提供するスクリプト コンポーネントに [判断] シェイプをバインドし、判断規則を実装する条件式を追加します。

  8. 手順 2. ～ 4. の操作を繰り返して次の 3 つのアクションを作成します。
    • 2 つ目の [アクション] シェイプを [判断] シェイプの右側に配置します。このアクションには「Send Denial」という名前を付けます。

    • 3 つ目の [アクション] シェイプを [判断] シェイプの下に配置します。このアクションには「Send Approval」という名前を付けます。

    • 4 つ目の [アクション] シェイプを [Send Approval] アクションの下に配置します。このアクションには「Write PO Request to File」という名前を付けます。
  9. [ビジネス プロセス] ページで [フローチャート] ステンシルの [終了] シェイプを境界バーの左側にドラッグし、[Send Denial] アクションの下に配置します。

    注文要求が承認されない場合、XLANG スケジュールは拒否メッセージを表示して終了します。

  10. [ビジネス プロセス] ページで [フローチャート] ステンシルの [終了] シェイプを境界バーの左側にドラッグし、[Write PO Request to File] アクションの下に配置します。

    注文要求が承認された場合、XLANG スケジュールはその注文要求をファイル ディレクトリに書き込み、承認メッセージを表示して終了します。

「シーケンス内の購入者のアクションの接続」に進みます。


シーケンス内の購入者のアクションの接続

  1. [開始] シェイプをクリックして制御ハンドルを強調表示します。

    強調表示された [開始] シェイプ

    底部の制御ハンドルを [Receive PO Request] アクションの接続ポイントの上端までドラッグします。

    [Receive PO Request] アクションは、ビジネス プロセスの開始を表します。注文要求が受信されると、XLANG スケジュールは実行を開始します。

    注

    • 強調表示したシェイプ上の緑のボックスは制御ハンドルを表します。アクションに接続するには制御ハンドルをドラッグします。

    • シェイプ上の青い X は接続ポイントを表します。

    • [アクション] シェイプの側面にある接続ポイントは、ポートに接続する場合に限って使用します。ほかの [アクション] シェイプに接続する場合は使用しません。
  2. 手順 1. の操作を繰り返して次のアクションの接続を作成します。
    • [Receive PO Request] アクションを [判断] シェイプに接続します。
  3. [判断] シェイプの [Denied] 条件をクリックし、その右側の制御ハンドルを [Send Denial] アクションの接続ポイントの上端までドラッグします。

  4. [判断] シェイプの [Else] 条件をクリックし、その左側の制御ハンドルを [Send Approval] アクションの接続ポイントの上端までドラッグします。

    注

    • [判断] シェイプの条件は、左右どちら側の制御ハンドルを使用しても [Send Approval] アクションと [Send Denial] アクションに接続できます。
  5. [Send Approval] アクションを [Write PO Request to File] アクションに接続します。

  6. [Write PO Request to File] アクションを、その下に配置した [終了] シェイプに接続します。

  7. [Send Denial] アクションを、その下に配置した [終了] シェイプに接続します。

  8. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [XLANG スケジュール フローチャートに名前を付けて保存] ダイアログ ボックスが表示されます。

  9. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  10. [ファイル名] ボックスに「Buyer1」と入力し、[保存] をクリックします。

作成し、保存した XLANG スケジュール フローチャートは、次のようになります。

図をクリックすると、拡大または縮小します。

XLANG スケジュール フローチャート

「メッセージ キューでの注文要求の受信によるポートの実装」に進みます。


メッセージ キューでの注文要求の受信によるポートの実装

このサービスは、注文要求のメッセージ キューを監視するために構成します。このサービスを構成すると、XLANG スケジュールが処理を開始します。このチュートリアルでのポートおよびメッセージ ポートの使用方法の詳細については、「BizTalk サービスの統合」を参照してください。

ポートを実装するには次の操作を行います。

  1. [ビジネス プロセス] ページで [実装] ステンシルの [メッセージ キュー] シェイプを境界バーの右側にドラッグし、[Receive PO Request] アクションと平行になるように配置します。

    [メッセージ キュー バインド ウィザード] が表示されます。

  2. [メッセージ キュー バインド ウィザードへようこそ] ページで、[新しいポートの作成] が選択されていることを確認します。

  3. [新しいポートの作成] ボックスに「ReceivePORequest」と入力し、[次へ] をクリックします。

  4. [静的または動的キューの情報] ページで [静的キュー] が選択されていることを確認し、[次へ] をクリックします。

  5. [キュー情報] ページで [すべてのインスタンスに対して既存のキューを使用する] をクリックします。

  6. [キュー名を入力します。] というボックスに「.\private$\ReceivePOReq」と入力し、[次へ] をクリックします。

  7. [ポート プロパティの詳細設定] ページで [完了] をクリックします。

    [ビジネス プロセス] ページに [ReceivePORequest] ポートとそれに関連付けられた実装メッセージ キューが表示されます。

「Receive PO Request アクションの通信フローの作成」に進みます。


Receive PO Request アクションの通信フローの作成

  1. [Receive PO Request] アクションをクリックし、その右側の制御ハンドルを [ReceivePORequest] ポートの左側の接続ポイントまでドラッグします。

    [XML 通信ウィザード] が表示されます。

  2. [XML 通信ウィザードへようこそ] ページで [受信] をクリックし、[次へ] をクリックします。

  3. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認します。

  4. [メッセージ名] ボックスに「POReq」と入力し、[次へ] をクリックします。

  5. [XML 変換情報] ページで、[キューから XML メッセージを受信する] が選択されていることを確認し、[次へ] をクリックします。

  6. [メッセージの種類の情報] ページで、[メッセージの種類] ボックスに「POReq」と入力し、[次へ] をクリックします。

  7. [メッセージ仕様情報] ページで [参照] をクリックします。

    [仕様の参照] ダイアログ ボックスが表示されます。

  8. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps に移動します。

  9. PoReq.xml をクリックし、[開く] をクリックします。

  10. [追加] をクリックします。

    [フィールドの選択] ダイアログ ボックスが表示されます。

  11. [ノードを選択してください] で、[Total] を展開します。次に [POTtl] をクリックし、[OK] をクリックします。

    [メッセージ フィールド] のメッセージ フィールド一覧に、POTtl が表示されます。

  12. [完了] をクリックします。

ポートを実装し、通信フローを作成すると、XLANG スケジュール フローチャートは次のようになります。

図をクリックすると、拡大または縮小します。

XLANG スケジュール フローチャート

「スクリプト コンポーネントを使用したポートの実装」に進みます。


スクリプト コンポーネントを使用したポートの実装

XLANG スケジュールは、注文要求の合計フィールドの値を [判断] シェイプに渡します。判断規則の条件式は、注文要求の合計に基づいて、XLANG スケジュールのパスを分岐し、適切なメッセージを Windows スクリプト コンポーネントが使用されている実装ポートに送信します。

ポートを実装するには次の操作を行います。

  1. [実装] ステンシルの [スクリプト コンポーネント] シェイプを、フローチャートを 2 つに分割している境界バーの右側にドラッグし、[判断] シェイプと平行になるように配置します。

    [スクリプト コンポーネント バインド ウィザード] が表示されます。

  2. [スクリプト コンポーネント バインド ウィザードへようこそ] ページの [新しいポートの作成] ボックスに、「ApprovalComponent」と入力し、[次へ] をクリックします。

  3. [静的または動的な通信] ページで [静的] が選択されていることを確認し、[次へ] をクリックします。

  4. [スクリプト ファイルの指定] ページで [参照] をクリックします。

  5. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution に移動します。

  6. PORequestApproval.wsc をクリックし、[開く] をクリックします。それから [次へ] をクリックします。

  7. [コンポーネントのインスタンス作成情報] ページで、[Prog ID "BTSTutorial.PORequestApproval" を使用] が選択されていることを確認し、[次へ] をクリックします。

  8. [メソッド情報] ページで、[すべて選択] をクリックし、[次へ] をクリックします。

  9. [ポート プロパティの詳細設定] ページで [完了] をクリックします。

「スクリプト コンポーネントのメッセージのプロパティの定義」に進みます。


スクリプト コンポーネントのメッセージのプロパティの定義

  1. [Send Denial] アクションをクリックし、その右側の制御ハンドルを Windows スクリプト コンポーネントの [ApprovalComponent] ポートまでドラッグします。

    [メソッド通信ウィザード] が表示されます。

  2. [メソッド通信ウィザードへようこそ] ページで、[同期メソッド呼び出しを開始する] が選択されていることを確認し、[次へ] をクリックします。

  3. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認し、[次へ] をクリックします。

  4. [メッセージ仕様情報] ページの [メソッド] ボックスの一覧で、[SendDenial] をクリックし、[完了] をクリックします。

  5. [Send Approval] アクションをクリックし、その右側の制御ハンドルを [ApprovalComponent] ポートまでドラッグします。

    [メソッド通信ウィザード] が表示されます。

  6. [メソッド通信ウィザードへようこそ] ページで、[同期メソッド呼び出しを開始する] が選択されていることを確認し、[次へ] をクリックします。

  7. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認し、[次へ] をクリックします。

  8. [メッセージ仕様情報] ページの [メソッド] ボックスの一覧で、[SendApproval] をクリックし、[完了] をクリックします。

  9. [Write PO Request to File] アクションをクリックし、その右側の制御ハンドルを [ApprovalComponent] ポートにドラッグします。

    [メソッド通信ウィザード] が表示されます。

  10. [メソッド通信ウィザードへようこそ] ページで、[同期メソッド呼び出しを開始する] が選択されていることを確認し、[次へ] をクリックします。

  11. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認し、[次へ] をクリックします。

  12. [メッセージ仕様情報] ページの [メソッド] の一覧で、[WriteToFile] が選択されていることを確認し、[完了] をクリックします。

「判断規則の条件式の書き込み」に進みます。


判断規則の条件式の書き込み

拒否判断規則には、そのシェイプの動作を定義するプロパティが含まれています。条件式は、メッセージのデータを参照し、そのデータが TRUE と FALSE のいずれであるかを評価します。また、[判断] シェイプで使用する論理名および変数名も定義します。

注文要求の合計が 1,000 ドルを超える場合は次のような処理が行われます。

  • [判断] シェイプはポートに拒否メッセージを送信します。

  • 拒否されたことをユーザーに知らせるメッセージが表示されます。

  • XLANG スケジュールが終了します。

注文要求の合計が 1,000 ドル以下の場合は次のような処理が行われます。

  • [判断] シェイプはスクリプト コンポーネントに承認メッセージを送信します。

  • 承認されたことをユーザーに知らせるメッセージが表示されます。

  • スクリプト コンポーネントは、注文要求メッセージをローカル ファイル ディレクトリに書き込みます。

  • XLANG スケジュールが終了します。

条件式を書き込むには次の操作を行います。

  1. ページの下部にある [データ] タブをクリックします。

    [データ] ページが表示されます。

  2. POReq メッセージの中からフィールド名を探します。

    条件式を書き込むには、メッセージ名とフィールド名の両方が必要です。ここでは、メッセージ名を POReq、フィールド名を POTtl とします。

  3. ページの下部にある [ビジネス プロセス] タブをクリックします。

    [ビジネス プロセス] ページが表示されます。

  4. [判断] シェイプを右クリックし、[プロパティ] をクリックします。

    [判断のプロパティ] ダイアログ ボックスが表示されます。

  5. [Denied] が選択されていることを確認し、[編集] をクリックします。

    [条件のプロパティ] ダイアログ ボックスが表示されます。

  6. [条件式] ボックスに、「POReq.POTtl > 1000」と入力します。

    これは、注文要求の合計フィールドが 1,000 ドルを超えた場合、その要求が拒否されることを表す条件式です。

  7. [OK] をクリックして [条件のプロパティ] ダイアログ ボックスを閉じます。さらに [OK] をクリックして [判断のプロパティ] ダイアログ ボックスを閉じます。

XLANG スケジュール フローチャートは、次のようになります。

図をクリックすると、拡大または縮小します。

XLANG スケジュール フローチャート

「データ フローの定義」に進みます。


データ フローの定義

ビジネス プロセスのデータ フローを定義するには、[データ] ページで [メッセージ] シェイプの各フィールド間に接続を作成します。

データ フローを定義するには次の操作を行います。

  1. ページの下部にある [データ] タブをクリックします。

    [データ] ページが表示されます。

  2. [POReq] メッセージの [Document] フィールドをクリックし、その右側の制御ハンドルを [SendDenial_in] メッセージの [Document] フィールドの接続ポイントまでドラッグします。

  3. 手順 2. の操作を繰り返して、[POReq] メッセージの [Document] フィールドを次のフィールドに接続します。
    • [SendApproval_in] ボックスの [Document] フィールド

    • [WriteToFile_in] ボックスの [Document] フィールド

注

  • 制御ハンドルをほかのフィールドまでドラッグする場合は、先に [POReq] メッセージの [Document] フィールドをクリックしてください。

上記の操作が完了すると、[データ] ページは次のようになります。

図をクリックすると、拡大または縮小します。

「XLANG スケジュール フローチャートの保存」に進みます。


XLANG スケジュール フローチャートの保存

  • [ファイル] メニューの [Buyer1.skv を保存] をクリックします。

「XLANG スケジュールのコンパイル」に進みます。


XLANG スケジュールのコンパイル

  1. [ファイル] メニューの [XLANG Buyer1.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. XLANG スケジュールが BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab フォルダに保存されることを確認し、[保存] をクリックします。

  3. [ファイル] メニューの [終了] をクリックして BizTalk オーケストレーション デザイナを閉じます。

「XLANG スケジュールの実行」に進みます。


XLANG スケジュールの実行

ここでは、注文要求の承認と拒否のプロセスを確認するため XLANG スケジュールを 2 回実行します。

XLANG スケジュールを実行するには次の操作を行います。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動します。

  2. ExecuteTutorial.exe をダブルクリックします。このアプリケーションは、モニカで XLANG スケジュールを有効にする場合に使用します。

    ExecuteTutorial アプリケーションが起動します。

  3. [Browse for Schedule] をクリックします。

ショートカット

既存の XLANG スケジュールを使用している場合は、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動し、手順 2. に進みます。

  1. XLANG スケジュール Buyer1 を作成した場合は、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  2. XLANG スケジュール ファイル Buyer1.skx をクリックし、[開く] をクリックします。

  3. [Browse for Data File] をクリックし、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  4. POReqAccept.xml をクリックし、[開く] をクリックします。

  5. [Start XLANG Schedule] をクリックします。

    合計が 1,000 ドル以下であるため、注文要求が承認されます。XLANG スケジューラ エンジンにデータが渡されたことを示すメッセージが表示されます。この時点でアプリケーションは終了しています。次に、注文要求が承認されたことを示すメッセージが表示されます。[OK] をクリックしてダイアログ ボックスを閉じます。

  6. [End] をクリックし、ExecuteTutorial アプリケーションを閉じます。

    重要

    • このアプリケーションの実行時にオートメーション エラーが発生した場合は、専用キューが正しく構成されているか、専用キューの名前が正しいかどうかを確認してください。
  7. C:\TutorialFiles\Buyer に移動します。

    ファイル名は POReqXXXXX.xml で、XXXXX は一意な数値のセットを表します。このファイルをダブルクリックして Microsoft Internet Explorer で開きます。このファイルは、アプリケーションからメッセージ キューにポストされた注文要求のコピーです。確認後、削除してください。

  8. 手順 1. ～ 5. の操作を繰り返して、ExecuteTutorial アプリケーションを再実行します。

  9. [Browse for Data File] をクリックし、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  10. POReqDeny.xml をクリックし、[開く] をクリックします。

  11. [Start XLANG Schedule] をクリックします。

    合計が 1,000 ドルを超えているため、注文要求が拒否されます。アプリケーションが終了したことを示すメッセージが表示されます。次に、ドキュメント拒否を受信したことを示すメッセージが表示されます。[OK] をクリックしてダイアログ ボックスを閉じます。

  12. [End] をクリックし、ExecuteTutorial アプリケーションを閉じます。

次の図は、XLANG スケジュールを実行したときのデータのフローを示しています。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい (拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

「モジュール 1 の概要」に進みます。


モジュール 1 の概要

このモジュールでは、次のことについて学習しました。

  • 自動調達プロセスを説明する XLANG スケジュール フローチャートを作成する。詳細については、「XLANG スケジュール フローチャートの作成」を参照してください。

  • ビジネス プロセスを説明する論理シーケンスのそれぞれのアクションを接続する。詳細については、「シェイプの接続」を参照してください。

  • アクションをポートに接続してビジネス プロセスを実装する。詳細については、「アクションとポート間の通信フローの確立」を参照してください。

  • 条件式を書き込んで、ビジネス プロセスに条件を追加する。詳細については、「条件の設計」を参照してください。

  • メッセージのデータ フローを定義する。詳細については、「通信シェイプ」を参照してください。

  • XLANG スケジュール フローチャートを保存し、XLANG スケジュールにコンパイルする。詳細については、「XLANG スケジュールのコンパイル」を参照してください。

  • XLANG スケジュールを 2 回実行して BizTalk Server で注文要求を処理し、承認と拒否のプロセスを確認する。詳細については、「XLANG スケジュールの実行」を参照してください。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい(拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

「モジュール 2 : 仕様とマップの作成」に進みます。

関連項目

BizTalk オーケストレーションの設計


モジュール 2 : 仕様とマップの作成

ここでは、BizTalk エディタで仕様を、BizTalk マッパーでマップを作成します。

目的

  • 仕様を作成する。詳細については、「仕様の作成」を参照してください。

  • 新しいレコードとフィールドを仕様に追加する。詳細については、「レコードへの新しいフィールドの追加」を参照してください。

  • マップを作成する。詳細については、「データのマッピング」を参照してください。

  • マップ内の各フィールド間にリンクを作成する。詳細については、「リンクの作成」を参照してください。

  • Functoid を使用して、マップ内の値の数値処理を行う。詳細については、「Functoid について」を参照してください。

  • 仕様とマップを WebDAV リポジトリに保存する。詳細については、「仕様の格納」および「マップの格納」を参照してください。

「BizTalk エディタの使用」に進みます。

関連項目

仕様の作成とデータのマッピング


BizTalk エディタの使用

BizTalk エディタを使用すると仕様の作成、編集、および管理ができます。

BizTalk エディタで支払仕様を作成するには、「支払仕様の作成」に進みます。

ショートカット

既存の支払仕様を使用する場合は、直接「既存の支払仕様の使用」に進みます。


既存の支払仕様の使用

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps から PaymentSpec.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft に貼り付けます。

BizTalk エディタで注文要求仕様を作成するには、「注文要求仕様の作成」に進みます。

ショートカット

既存の注文要求仕様を使う場合は、「既存の注文要求仕様の使用」に進みます。


支払仕様の作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk Server エディタ] をクリックします。

  2. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  3. [空の仕様] をクリックし、[OK] をクリックします。

  4. ルート ノードの [空の仕様] をクリックします。

  5. [宣言] プロパティ ページの [名前] 行の "値" フィールドをダブルクリックします。「Payment」と入力して Enter キーを押します。

  6. [モデル] 行の "値" フィールドをダブルクリックし、[オープン] をクリックします。そして Enter キーを押します。

「支払仕様の Payment ルート ノードへの新しいレコードの追加」に進みます。


支払仕様の Payment ルート ノードへの新しいレコードの追加

  1. [Payment] ルート ノードを右クリックし、[新しいレコード] をクリックします。

  2. 新しいレコードに PaymentHeader という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、[Payment] ルート ノードの下にさらに 4 つのレコードを作成し、名前を付けます。この 4 つのレコードはいずれも [Payment] ルート ノードの子レコードです。それぞれに次の名前を付けます。
    • Seller

    • Buyer

    • Item

    • PaymentSummary

「支払仕様の既存のレコードへの新しいレコードの追加」に進みます。


支払仕様の既存のレコードへの新しいレコードの追加

  1. [Seller] レコードを右クリックし、[新しいレコード] をクリックします。

  2. 新しいレコードに Address という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、次の表に示すとおりに、親レコードに子レコードをそれぞれ作成します。
    親レコード | 子レコード
    Seller | ContactInfo
    Buyer | Address
    Buyer | ContactInfo

「支払仕様の既存のレコードへの新しいフィールドの追加」に進みます。


支払仕様の既存のレコードへの新しいフィールドの追加

  1. [PaymentHeader] レコードを右クリックし、[新しいフィールド] をクリックします。

  2. 新しいフィールドに PONumber という名前を付け、Enter キーを押します。

  3. [宣言] プロパティ ページの [データ型] 行の "値" フィールドをダブルクリックします。[String] をクリックして Enter キーを押します。

  4. [宣言] プロパティ ページの [最小値] 行の "値" フィールドをダブルクリックします。「1」と入力して Enter キーを押します。

  5. [宣言] プロパティ ページの [最大値] 行の "値" フィールドをダブルクリックします。「22」と入力して Enter キーを押します。

  6. 手順 1. ～ 5. の操作を繰り返して、次の表に示すとおりに、レコードまたは子レコードのフィールドを作成します。各レコードには複数のフィールドが含まれます。

    販売者と購入者のレコードは互いに対応しているので、購入者のフィールドを作成する必要はありません。同じ名前のレコードにはすべて、同じレコード情報およびフィールド情報が含まれています。あるフィールドを Seller レコードの Address レコード、または Seller レコードの ContactInfo レコードに追加すると、自動的に Buyer レコードの Address レコードまたは Buyer レコードの ContactInfo レコードにも、そのフィールド情報が反映されます。

    親レコード | フィールド名 | データ型 | 最小値 | 最大値
    PaymentHeader | Date | Date | なし | なし
    Seller/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Seller/ContactInfo | Name | String | 1 | 60
    Number | String | 1 | 60
    Item | Quantity | Real (r4) | なし | なし
    Price | Real (r4) | なし | なし
    Description | String | 1 | 80
    ExtendedPrice | Real (r4) | なし | なし
    PaymentSummary | Total | Real (r4) | なし | なし

「WebDAV への支払仕様の格納」に進みます。


WebDAV への支払仕様の格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [Microsoft] フォルダをダブルクリックします。

  3. [ファイル名] ボックスに「PaymentSpec」と入力し、[保存] をクリックします。

  4. [ツール] メニューの [インスタンスの検証] をクリックします。

    [ドキュメント インスタンスの検証] ダイアログ ボックスが表示されます。

  5. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動します。

  6. payment_valid.xml をクリックし、[開く] をクリックします。

    警告またはエラーは、存在する場合は [警告] ページに表示されます。

支払仕様は次のようになります。

図をクリックすると、拡大または縮小します。

BizTalk エディタで注文要求仕様を作成するには、「注文要求仕様の作成」に進みます。

ショートカット

既存の注文要求仕様を使う場合は、「既存の注文要求仕様の使用」に進みます。


既存の注文要求仕様の使用

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps から POReq.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft に貼り付けます。

「BizTalk マッパーの使用」に進みます。


注文要求仕様の作成

ここでは、注文要求仕様のルート ノードを作成します。

ルート ノードを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  2. [空の仕様] をクリックし、[OK] をクリックします。

  3. ルート ノードの [空の仕様] をクリックします。

  4. [宣言] プロパティ ページの [名前] 行の "値" フィールドをダブルクリックします。「POReq」と入力して Enter キーを押します。

  5. [モデル] 行の "値" フィールドをダブルクリックし、[オープン] をクリックします。そして Enter キーを押します。

「注文要求仕様のルート ノードへの新しいレコードの追加」に進みます。


注文要求仕様のルート ノードへの新しいレコードの追加

  1. [POReq] ルート ノードを右クリックし、[新しいレコード] をクリックします。

  2. 新しいレコードに Header という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、[POReq] ルート ノードの下にさらに 5 つのレコードを作成し、名前を付けます。この 5 つのレコードはいずれも [POReq] ルート ノードの子レコードです。それぞれに次の名前を付けます。
    • EmployeeInfo

    • BillTo

    • ShipTo

    • Item

    • Total

「注文要求仕様の既存のレコードへの新しいレコードの追加」に進みます。


注文要求仕様の既存のレコードへの新しいレコードの追加

  1. [BillTo] レコードを右クリックし、[新しいレコード] をクリックします。

  2. 新しいレコードに Address という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、親レコード [ShipTo] に子レコードを作成し、Address という名前を付けます。

「注文要求仕様の既存のレコードへの新しいフィールドの追加」に進みます。


注文要求仕様の既存のレコードへの新しいフィールドの追加

  1. [Header] レコードを右クリックし、[新しいフィールド] をクリックします。

  2. 新しいフィールドに Date という名前を付け、Enter キーを押します。

  3. [宣言] プロパティ ページの [データ型] 行の "値" フィールドをダブルクリックします。[Date] をクリックして Enter キーを押します。

  4. [EmployeeInfo] レコードを右クリックし、[新しいフィールド] をクリックします。

  5. 新しいフィールドに EmpID という名前を付け、Enter キーを押します。

  6. [宣言] プロパティ ページの [データ型] 行の "値" フィールドをダブルクリックします。[String] をクリックして Enter キーを押します。

  7. [宣言] プロパティ ページの [最小値] 行の "値" フィールドをダブルクリックします。「1」と入力して Enter キーを押します。

  8. [宣言] プロパティ ページの [最大値] 行の "値" フィールドをダブルクリックします。「60」と入力して Enter キーを押します。

  9. 手順 4. ～ 8. の操作を繰り返して、次の表に示すとおりに、レコードまたは子レコードのフィールドを作成します。各レコードには複数のフィールドが含まれます。

    BillTo と ShipTo のレコードは互いに対応しているので、ShipTo のフィールドを作成する必要はありません。同じ名前のレコードにはすべて、同じレコード情報およびフィールド情報が含まれています。あるフィールドを BillTo レコードの Address レコードに追加すると、自動的に ShipTo レコードの Address レコードにも、そのフィールド情報が反映されます。

    親レコード | フィールド名 | データ型 | 最小値 | 最大値
    EmployeeInfo | LastName | String | 1 | 30
    FirstName | String | 1 | 30
    BillTo/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Item | Quantity | Real (r4) | なし | なし
    Price | Real (r4) | なし | なし
    Description | String | 1 | 80
    UnitofMeasure | String | 2 | 2
    ExtendedPrice | Real (r4) | なし | なし
    Total | LineItemTtl | Real (r4) | なし | なし
    QtyTtl | Real (r4) | なし | なし
    POTtl | Real (r4) | なし | なし

「注文要求仕様の保存」に進みます。


注文要求仕様の保存

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [Microsoft] フォルダが開いていることを確認します。

  3. [ファイル名] ボックスに「POReq」と入力し、[保存] をクリックします。

  4. [ツール] メニューの [インスタンスの検証] をクリックします。

    [ドキュメント インスタンスの検証] ダイアログ ボックスが表示されます。

  5. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  6. POReqAccept.xml をクリックし、[開く] をクリックします。

    警告またはエラーは、存在する場合は [警告] ページに表示されます。

注文要求仕様は次のようになります。

図をクリックすると、拡大または縮小します。

  1. [ファイル] メニューの [終了] をクリックして BizTalk エディタ コンソールを閉じます。

「BizTalk マッパーの使用」に進みます。


BizTalk マッパーの使用

ここでは、BizTalk マッパーを使用して、CommonInvoice 仕様に適合したメッセージのデータを、PaymentSpec 仕様に適合したメッセージのデータに変換するマップを作成します。

BizTalk メッセージ サービスは、チャネル内のマップを使用して、ある書式のドキュメントのデータを別の書式のドキュメントに変換する方法を指定するものです。

BizTalk マッパーを使用してマップを作成するには、「InvoiceToPayment マップの作成」に進みます。

ショートカット

既存のマップを使用する場合は、直接「既存の InvoiceToPayment マップの使用」に進みます。


既存の InvoiceToPayment マップの使用

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps から InvoiceToPayment.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft に貼り付けます。

「モジュール 3 : BizTalk メッセージ サービスの構成」に進みます。


InvoiceToPayment マップの作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft BizTalk Server 2000] をポイントし、[BizTalk マッパー] をクリックします。

  2. [ファイル] メニューの [新規作成] をクリックします。

    [送信元仕様の種類の選択] ダイアログ ボックスが表示されます。

  3. [WebDAV ファイル] をクリックし、[OK] をクリックします。

    [送信元仕様の取得] ダイアログ ボックスが表示されます。

  4. [Microsoft] フォルダをダブルクリックします。

  5. CommonInvoice.xml をクリックし、[開く] をクリックします。

    [送信先仕様の種類の選択] ダイアログ ボックスが表示されます。

  6. [WebDAV ファイル] をクリックし、[OK] をクリックします。

  7. PaymentSpec.xml をクリックし、[開く] をクリックします。

「フィールド間のリンクの作成」に進みます。


フィールド間のリンクの作成

ここでは、送信元仕様のフィールドと送信先仕様のフィールドとの間にリンクを作成します。

フィールド間のリンクを作成するには次の操作を行います。

  1. [送信元仕様] ツリーで、[InvoiceHeader] レコードを展開して関連付けられているフィールドを表示します。

    詳細については、「ツリー項目の展開」を参照してください。

  2. [送信先仕様] ツリーで、[PaymentHeader] レコードを展開して関連付けられているフィールドを表示します。

  3. [送信元仕様] ツリーの [InvoiceHeader] レコードの [Date] フィールドを、[送信先仕様] ツリーの [PaymentHeader] レコードの [Date] フィールドまでドラッグします。手順 1. ～ 3. の操作を繰り返して、次の表に示すとおりに、フィールド間のリンクを作成します。
    送信元レコード/フィールド | 送信先レコード/フィールド
    InvoiceHeader/Number | PaymentHeader/PONumber

    Seller/Address/Name | Seller/Address/Name
    Seller/Address/Address1 | Seller/Address/Address1
    Seller/Address/Address2 | Seller/Address/Address2
    Seller/Address/City | Seller/Address/City
    Seller/Address/State | Seller/Address/State
    Seller/Address/PostalCode | Seller/Address/Zip
    Seller/Address/Country | Seller/Address/Country

    Seller/ContactInfo/ContactName | Seller/ContactInfo/Name
    Seller/ContactInfo/ContactNumber | Seller/ContactInfo/Number

    Buyer/Address/Name | Buyer/Address/Name
    Buyer/Address/Address1 | Buyer/Address/Address1
    Buyer/Address/Address2 | Buyer/Address/Address2
    Buyer/Address/City | Buyer/Address/City
    Buyer/Address/State | Buyer/Address/State
    Buyer/Address/PostalCode | Buyer/Address/Zip
    Buyer/Address/Country | Buyer/Address/Country

    Buyer/ContactInfo/ContactName | Buyer/ContactInfo/Name
    Buyer/ContactInfo/ContactNumber | Buyer/ContactInfo/Number

    Item/ItemHeader/Quantity | Item/Quantity
    Item/ItemHeader/Price | Item/Price

    Item/ItemDescription/Description Item/Description

    InvoiceSummary/InvoiceTotal/Amount PaymentSummary/Total

「Functoid を使用したリンクの作成」に進みます。


Functoid を使用したリンクの作成

ここでは、Functoid を使用して、送信元仕様内の [Quantity] フィールドを [Price] フィールドで乗算し、その値を送信先仕様の [ExtendedPrice] フィールドに配置します。

Functoid を使用してリンクを作成するには次の操作を行います。

  1. [表示] メニューの [Functoid パレット] をクリックします。

    [Functiod パレット] が表示されます。

  2. [数値演算] タブをクリックし、乗算 Functoid ( 乗算 Functoid) をマッピング グリッドにドラッグします。そして [Functoid パレット] を閉じます。

  3. 送信元仕様ツリーで、[Item] レコード下の [ItemHeader] レコードの [Quantity] フィールドを配置した Functoid までドラッグします。

  4. 送信元仕様ツリーで、[Item] レコード下の [ItemHeader] レコードの [Price] フィールドをその Functoid までドラッグします。

  5. [乗算] Functoid を、送信先仕様ツリーの [Item] レコードの [ExtendedPrice] フィールドまでドラッグします。

「マップのコンパイル」に進みます。


マップのコンパイル

  1. [ツール] メニューの [マップのコンパイル] をクリックします。

  2. 下部ウィンドウの [出力] タブをクリックします。

    [出力] ページに、XSL マップが作成されたことが示されています。警告またはエラーは、存在する場合は [警告] ページに表示されます。

「WebDAV へのマップの格納」に進みます。


WebDAV へのマップの格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [Microsoft] フォルダをダブルクリックします。

  3. [ファイル名] ボックスに「InvoiceToPayment」と入力し、[保存] をクリックします。

作成したマップは次のようになります。

図をクリックすると、拡大または縮小します。

  4. [ファイル] メニューの [終了] をクリックして BizTalk マッパー コンソールを閉じます。

「モジュール 2 の概要」に進みます。


モジュール 2 の概要

このモジュールでは、次のことについて学習しました。

  • 仕様を作成する。詳細については、「仕様について」を参照してください。

  • 新しいレコードとフィールドを仕様に追加する。詳細については、「レコードへの新しいフィールドの追加」を参照してください。

  • マップを作成する。詳細については、「データのマッピング」を参照してください。

  • マップ内の各フィールド間にリンクを作成する。詳細については、「リンクの作成」を参照してください。

  • Functoid を使用して、マップ内の値の数値処理を行う。詳細については、「Functoid について」を参照してください。

  • 仕様とマップを WebDAV リポジトリに保存する。詳細については、「仕様の格納」および「マップの格納」を参照してください。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい (拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

「モジュール 3 : BizTalk メッセージ サービスの構成」に進みます。

関連項目

仕様の作成とデータのマッピング


モジュール 3 : BizTalk メッセージ サービスの構成

ここでは、BizTalk メッセージ マネージャを使用して、販売者と購入者のシステムの組織、チャネル、およびメッセージ ポートを構成します。また、BizTalk Server 管理コンソールを使用して、ファイル受信機能を構成します。

目的

  • ドキュメント定義を作成する。詳細については、「ドキュメント定義の作成および管理」を参照してください。

  • 組織を作成する。詳細については、「組織の作成と管理」を参照してください。

  • メッセージ ポートを作成する。詳細については、「メッセージ ポートの作成および管理」および「BizTalk サービスの統合」を参照してください。

  • チャネルを作成する。詳細については、「チャネルの作成と管理」を参照してください。

  • チャネルのマップを使用して、ドキュメントを変換する。詳細については、「データのマッピング」を参照してください。

  • 受信機能を作成する。詳細については、「受信機能」を参照してください。

「購入者のシステムの構成」に進みます。

関連項目

BizTalk メッセージ マネージャの使用


購入者のシステムの構成

BizTalk メッセージ マネージャを使用して、取引先を表す組織を作成します。

BizTalk メッセージ マネージャを使用して購入者のシステムを構成するには、「購入者のシステムの組織の作成」に進みます。

ショートカット

スクリプトを使用して購入者のシステムを構成する場合は、直接「構成スクリプトを使用した購入者のシステムの構成」に進みます。


構成スクリプトを使用した購入者のシステムの構成

このスクリプトは、次のものを構成します。

  • 送信元組織 ProElectron on Buyer。購入者のシステムに構成します。

  • 送信先組織 Bits,Bytes,Chips on Buyer。購入者のシステムに構成します。

  • CommonPO、CommonInvoice、PaymentSpec、および POReq の仕様を参照する 4 つのドキュメント定義。

  • ASP ファイルへの HTTP トランスポート サービスを使用して、購入者のシステムから販売者のシステムへの注文要求の移動を定義するメッセージ ポートおよびチャネル。販売者のシステムに構成します。

  • 購入者に送付した請求書の動きを定義し、その請求書を支払ドキュメントに変換するメッセージ ポートおよびチャネル。販売者のシステムに構成します。

注意

  • BizTalk メッセージ マネージャおよび BizTalk Server 管理コンソールを使用して購入者のシステムを構成した場合は、構成スクリプトは実行しないでください。

購入者のシステムに BizTalk メッセージ サービスを構成するスクリプトを実行するには、次の操作を行います。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Setup\MessagingConfigurationScript に移動します。

  2. ConfigureBuyer.VBS をダブルクリックします。

    正常に実行されたことを知らせるメッセージ ボックスが表示されます。

「販売者のシステムの構成」に進みます。


購入者のシステムの組織の作成

注意

  • 構成スクリプトを使用した場合は、購入者のシステムを構成するのに BizTalk メッセージ マネージャおよび BizTalk Server 管理コンソールを使用しないでください。「販売者のシステムの構成」に進みます。
  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  3. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。

    [新しい組織] ダイアログ ボックスが表示されます。

  4. [組織名] ボックスに「Bits,Bytes,Chips on Buyer」 と入力し、[OK] をクリックします。

  5. 手順 3. および 4. の操作を繰り返して、新しい組織に ProElectron on Buyer という名前を付けます。

「購入者および販売者のシステムのドキュメント定義の作成」に進みます。


購入者および販売者のシステムのドキュメント定義の作成

ここでは、CommonInvoice、CommonPO、PaymentSpec、および POReq の各ドキュメント仕様を参照する 4 つのドキュメント定義を作成します。これらのドキュメント定義は、購入者のシステムと販売者のシステムで共有します。

ドキュメント定義を作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[ドキュメント定義] をクリックします。

    [新しいドキュメント定義] ダイアログ ボックスが表示されます。

  2. [ドキュメント定義名] ボックスに「Purchase Order」と入力します。

  3. [ドキュメント仕様] チェック ボックスをオンにし、[参照] をクリックします。

    [WebDAV リポジトリからのドキュメント仕様の選択] ダイアログ ボックスが表示されます。

  4. [Microsoft] フォルダをダブルクリックします。

  5. CommonPO.xml をクリックし、[開く] をクリックします。

  6. [OK] をクリックして [新しいドキュメント定義] ダイアログ ボックスを閉じます。

  7. 手順 1. ～ 6. の操作を繰り返し、次の変更点に注意して新しいドキュメント定義を作成します。
    • 新しいドキュメント定義の名前は Invoice とします。

    • WebDAV から選択するドキュメント仕様は CommonInvoice.xml にします。
  8. 手順 1. ～ 6. の操作を繰り返し、次の変更点に注意して新しいドキュメント定義を作成します。
    • 新しいドキュメント定義の名前は Purchase Order Request とします。

    • WebDAV から選択するドキュメント仕様は POReq.xml にします。
  9. 手順 1. ～ 6. の操作を繰り返し、次の変更点に注意して新しいドキュメント定義を作成します。
    • 新しいドキュメント定義の名前は Payment とします。

    • WebDAV から選択するドキュメント仕様は PaymentSpec.xml にします。

「購入者のシステムにおける Bits, Bytes, & Chips へのメッセージ ポートの作成」に進みます。


購入者のシステムにおける Bits, Bytes, & Chips へのメッセージ ポートの作成

ここでは、メッセージ ポート を購入者のシステムに作成します。メッセージ ポートはドキュメントの送信先を定義するものです。

作成したメッセージ ポートの送信先組織は "Bits,Bytes,Chips on Buyer" になります。このポートは、HTTP トランスポート サービスを使用してドキュメントを Bits, Bytes, & Chips に送付します。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [名前] ボックスに「Port to Bits,Bytes,Chips via HTTP」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [Bits,Bytes,Chips on Buyer] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で [HTTP] をクリックします。

  7. [アドレス] ボックスで、プレフィックス http:// の後に使用しているコンピュータの名前を入力し、続けて「/SubmitPO/SubmitProElectronPO.asp」と入力します。次に [OK] をクリックし、[次へ] をクリックします。

    例 : http://Computer1/SubmitPO/SubmitProElectronPO.asp

    使用しているコンピュータの名前を検索するには、次の操作を行います。

    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

    2. [管理ツール] をダブルクリックします。

    3. [コンピュータの管理] をダブルクリックします。

      [コンピュータの管理] コンソールが表示されます。

    4. [操作] メニューの [プロパティ] をクリックします。

      [コンピュータの管理 (ローカル) のプロパティ] ダイアログ ボックスが表示されます。

    5. [ネットワーク ID] タブをクリックします。

      使用しているコンピュータの名前が [コンピュータ名] フィールドに表示されます。

  8. [エンベロープ情報] ページで [次へ] をクリックします。

  9. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  10. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「購入者のシステムにおける ProElectron からのチャネルの作成」に進みます。


購入者のシステムにおける ProElectron からのチャネルの作成

ここでは、メッセージ ポートのチャネルを作成します。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for POReq to PO」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページで [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [ProElectron on Buyer] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Purchase Order Request] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Purchase Order] をクリックし、[OK] をクリックします。

  8. [受信ドキュメントを送信ドキュメントにマップする] チェック ボックスがオンになっていることを確認します。

  9. [マップ参照] ボックスの右側にある [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  10. [Microsoft] フォルダをダブルクリックします。

  11. POReqtoPO.xml をクリックし、[開く] をクリックします。そして [次へ] をクリックします。

  12. [ドキュメント ログ] ページで [次へ] をクリックします。

  13. [詳細構成] ページで [完了] をクリックします。

「購入者のシステム内で使用する Bits, Bytes & Chips へのメッセージ ポートの作成」に進みます。


購入者のシステム内で使用する Bits, Bytes, & Chips へのメッセージ ポートの作成

ここでは、ファイル トランスポート サービスを使用して購入者のシステムにあるドキュメントを送信するメッセージ ポートを作成します。ドキュメントは、送信先アドレスで指定したフォルダに送信されます。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [名前] ボックスに「Port to Bits,Bytes,Chips via Local File」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [ProElectron on Buyer] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で [ファイル] をクリックします。

  7. [アドレス] ボックスで、file:// の後に「C:\TutorialFiles\Seller\payment%tracking_id%.xml」と入力します。例 : file://c:\TutorialFiles\Seller\payment%tracking_id%.xml

    注

    • ファイル トランスポート サービスの場合、既定のトランスポート コンポーネント設定では、指定されたディレクトリの既存のファイルに新しいファイルが追加されます。各ドキュメントのインスタンスに一意な名前の新しいファイルを作成するには、次のファイル パス書式を使用します。
      file://C:\dir\file%tracking_id%.xml
  8. [OK] をクリックして [プライマリ トランスポート] ダイアログ ボックスを閉じ、[次へ] をクリックします。

  9. [エンベロープ情報] ページで [次へ] をクリックします。

  10. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  11. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「購入者のシステムにおける Bits, Bytes, & Chips からのチャネルの作成」に進みます。


購入者のシステムにおける Bits, Bytes, & Chips からのチャネルの作成

ここで作成するチャネルは、Bits, Bytes, & Chips から受信した請求書を処理し、マップを使用してその請求書を支払に変換します。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for Invoice To Payment」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [Bits,Bytes,Chips on Buyer] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Invoice] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Payment] をクリックし、[OK] をクリックします。

  8. [受信ドキュメントを送信ドキュメントにマップする] チェック ボックスがオンになっていることを確認します。

  9. [マップ参照] ボックスの右側にある [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  10. [Microsoft] フォルダをダブルクリックします。

  11. InvoicetoPayment.xml をクリックし、[開く] をクリックします。そして [次へ] をクリックします。

  12. [ドキュメント ログ] ページで [次へ] をクリックします。

  13. [詳細構成] ページで [完了] をクリックします。

  14. [ファイル] メニューの [終了] をクリックして BizTalk メッセージ マネージャを閉じます。

「購入者のシステムのファイル受信機能の作成」に進みます。


購入者のシステムのファイル受信機能の作成

ここでは、ローカル ファイル ディレクトリから購入者の注文要求を取得し、それを BizTalk メッセージ サービスに送信するファイル受信機能を作成します。

次の図は、送信側業務用アプリケーション、ファイル システム、および受信機能の相関関係を示しています。

送信側業務用アプリケーション
ファイル システム
BizTalk Server
ファイル受信機能
BizTalk
Server
送信

ファイル受信機能を作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  2. [Microsoft BizTalk Server 2000] を展開し、[BizTalk Server Group] を展開します。次に [受信機能] をクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[ファイル受信機能] をクリックします。

    [ファイル受信機能の追加] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに「PORequest Receive Function at ProElectron」と入力します。

  5. [受信機能を実行するサーバー] ボックスの一覧で、BizTalk Server Group 内のサーバー名をクリックします。

  6. [ポーリングするファイルの種類] ボックスに「*.xml」と入力します。

  7. [ポーリングの場所] ボックスに「C:\TutorialFiles\Buyer」と入力します。

  8. [詳細設定] ボタンをクリックします。

    [受信機能の拡張オプション] ダイアログ ボックスが表示されます。

  9. [チャネル名] ボックスの一覧で、[Channel for POReq to PO] をクリックし、[OK] をクリックします。

  10. [OK] をクリックして [ファイル受信機能の追加] ダイアログ ボックスを閉じます。

  11. BizTalk Server 管理コンソールを閉じます。

「販売者のシステムの構成」に進みます。


販売者のシステムの構成

BizTalk メッセージ マネージャを使用して、取引先を表す組織を作成します。

「販売者のシステムの組織の作成」に進みます。


販売者のシステムの組織の作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  3. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。

    [新しい組織] ダイアログ ボックスが表示されます。

  4. [全般] プロパティ ページの [組織名] ボックスに「Bits,Bytes,Chips on Seller」と入力し、[OK] をクリックします。

  5. 手順 3. および 4. の操作を繰り返して、新しい組織に ProElectron on Seller という名前を付けます。

「販売者のシステムにおける Bits, Bytes, & Chips へのメッセージ ポートの作成」に進みます。


販売者のシステムにおける Bits, Bytes, & Chips へのメッセージ ポートの作成

ここでは、ドキュメントの送信先を定義するメッセージ ポートを作成します。このメッセージ ポートは、トランスポート サービスにアプリケーション統合コンポーネント (AIC) を使用して、販売者のシステム内部でドキュメントを送信します。

通常、AIC は、BizTalk Server 2000 とバックエンド アプリケーションとの統合ポイントとして使用します。このシナリオでは、AIC をこの統合ポイントとして使用するほか、仮想のバックエンド アプリケーションとして使用します。メッセージ ポートは、注文を AIC に渡します。AIC は、注文を請求書に変換し、販売者のシステム上の BizTalk メッセージ サービスのチャネルに送信します。

注文は、チャネルのマップを使用して請求書に変換することもできます。ただしこのシナリオでは、わかりやすくするため AIC を使用してこの操作を行います。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [名前] ボックスに「Port to Bits,Bytes,Chips via AIC」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [Bits,Bytes,Chips on Seller] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で、[アプリケーション統合コンポーネント] が選択されていることを確認し、[参照] をクリックします。

    [コンポーネントの選択] ダイアログ ボックスが表示されます。

  7. [POToINVAIC ConvertPOToInvoice] をクリックし、[OK] をクリックします。

  8. [OK] をクリックして [プライマリ トランスポート] ダイアログ ボックスを閉じ、[次へ] をクリックします。

  9. [エンベロープ情報] ページで [次へ] をクリックします。

  10. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  11. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「販売者のシステムにおける ProElectron からのチャネルの作成」に進みます。


販売者のシステムにおける ProElectron からのチャネルの作成

ここでは、メッセージ ポートのチャネルを作成します。

作成したチャネルの送信元組織は "ProElectron on Seller" になります。これは販売者のシステム上の購入者を表します。このチャネルは、ProElectron から受信した注文を処理します。ドキュメント定義は受信、送信とも同じであるため、このチャネルではマップ参照は必要ありません。したがってドキュメント変換は行われません。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for PO」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [ProElectron on Seller] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Purchase Order] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Purchase Order] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  8. [ドキュメント ログ] ページで [次へ] をクリックします。

  9. [詳細構成] ページで [完了] をクリックします。

「販売者のシステムにおける ProElectron へのメッセージ ポートの作成」に進みます。


販売者のシステムにおける ProElectron へのメッセージ ポートの作成

メッセージ ポートに作成する送信先組織の名前は "ProElectron on Seller" で、これは販売者のシステム上の購入者を表します。このメッセージ ポートは、販売者のシステムから購入者のシステムにドキュメントを送信します。また、HTTP トランスポート サービスを使用して、指定された購入者のアドレスにドキュメントを配信します。

このポートを使用すると、請求書メッセージが販売者のシステムの ASP のページ経由で購入者のシステムのメッセージ キューに送信されます。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [全般情報] ページの [名前] ボックスに「Port to ProElectron via HTTP」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [ProElectron on Seller] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で [HTTP] をクリックします。

  7. [アドレス] ボックスで、プレフィックス http:// の後に使用しているコンピュータの名前を入力し、続けて「/InvoiceToQueue/DropInvoicetoMSMQ.asp」と入力します。次に [OK] をクリックし、[次へ] をクリックします。

    例 : http://Computer1/InvoiceToQueue/DropInvoicetoMSMQ.asp

    使用しているコンピュータの名前を検索するには、次の操作を行います。

    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

    2. [管理ツール] をダブルクリックします。

    3. [コンピュータの管理] をダブルクリックします。

      [コンピュータの管理] コンソールが表示されます。

    4. [操作] メニューの [プロパティ] をクリックします。

      [コンピュータの管理 (ローカル) のプロパティ] ダイアログ ボックスが表示されます。

    5. [ネットワーク ID] タブをクリックします。

      使用しているコンピュータの名前が [コンピュータ名] フィールドに表示されます。

  8. [エンベロープ情報] ページで [次へ] をクリックします。

  9. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  10. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「販売者のシステムにおける Bits, Bytes, & Chips からのチャネルの作成」に進みます。


販売者のシステムにおける Bits, Bytes, & Chips からのチャネルの作成

ここで作成したチャネルの送信元組織は "Bits,Bytes,Chips on Seller" になります。このチャネルは、メッセージ ポート Port to ProElectron via HTTP の規則に従って、販売者のシステムの ProElectron に送信される請求書を処理します。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for Invoice」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [Bits,Bytes,Chips on Seller] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Invoice] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Invoice] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  8. [ドキュメント ログ] ページで [次へ] をクリックします。

  9. [詳細構成] ページで [完了] をクリックします。

  10. [ファイル] メニューの [終了] をクリックして BizTalk メッセージ マネージャを閉じます。

「モジュール 3 の概要」に進みます。


モジュール 3 の概要

このモジュールでは、次のことについて学習しました。

  • ドキュメント定義を作成する。詳細については、「ドキュメント定義の作成および管理」を参照してください。

  • 組織を作成する。詳細については、「組織の作成と管理」を参照してください。

  • メッセージ ポートを作成する。詳細については、「メッセージ ポートの作成および管理」を参照してください。

  • チャネルを作成する。詳細については、「チャネルの作成と管理」を参照してください。

  • チャネルのマップを使用して、ドキュメントを変換する。詳細については、「データのマッピング」を参照してください。

  • ファイル受信機能を作成する。詳細については、「受信機能」を参照してください。

このモジュールで作成したドキュメント定義、組織、メッセージ ポート、チャネル、およびマップを表示するには、BizTalk メッセージ マネージャの [検索] ボタンを使用します。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい (拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

「モジュール 4 : XLANG スケジュールの完成」に進みます。

関連項目

BizTalk メッセージ マネージャの使用


モジュール 4 : XLANG スケジュールの完成

ここでは、BizTalk メッセージ サービスを使用して、BizTalk オーケストレーション デザイナでポートを実装します。次に、完成した XLANG スケジュールをコンパイルし、実行します。

目的

  • 請求のアクションおよび支払のアクションを追加する。詳細については、「シェイプの追加」を参照してください。

  • BizTalk メッセージ サービスを使用して、ポートを実装する。詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

  • 完成した XLANG スケジュールをコンパイルし、実行する。詳細については、「XLANG スケジュールのコンパイル」および「XLANG スケジュールの実行」を参照してください。

XLANG スケジュールを完成させるには、「請求のアクションおよび支払のアクションの追加」に進みます。

ショートカット

既存の XLANG スケジュールを使用する場合は、直接「完成した XLANG スケジュールの実行」に進みます。

関連項目

BizTalk オーケストレーションの設計


請求のアクションおよび支払のアクションの追加

ここでは、購入者から請求書を受信するアクションと、支払メッセージを販売者に送信するアクションを追加します。

アクションを作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. [ファイル] メニューの [開く] をクリックします。

    [XLANG スケジュール フローチャートを開く] ダイアログ ボックスが表示されます。

  3. 既存の Buyer1.skv ファイルを使用している場合は、[XLANG スケジュール フローチャートを開く] ダイアログ ボックスで、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動し、Buyer1.skv をクリックします。次に [開く] をクリックします。

    モジュール 1 で Buyer1.skv ファイルを作成した場合は、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動し、Buyer1.skv をクリックします。次に [開く] をクリックします。

    注

    空白のフローチャートが表示されます。このフローチャートは BizTalk オーケストレーション デザイナで閉じることができます。

  4. [Write PO Request to File] アクションと [終了] アクションの間の接続をクリックして強調表示し、Delete キーを押します。

  5. [終了] アクションを下方に移動し、新しいアクション シェイプ 2 つ分の空間を確保します。

  6. [ビジネス プロセス] ページで [フローチャート] ステンシルの [アクション] シェイプを境界バーの左側にドラッグし、[Receive Invoice] アクションのすぐ下に配置します。

  7. [アクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [アクションのプロパティ] ダイアログ ボックスが表示されます。

  8. [名前] ボックスに「Receive Invoice」と入力し、[OK] をクリックします。

  9. [ビジネス プロセス] ページで [フローチャート] ステンシルの [アクション] シェイプを境界バーの左側にドラッグし、[Receive Invoice] アクションのすぐ下に配置します。

  10. [アクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [アクションのプロパティ] ダイアログ ボックスが表示されます。

  11. [名前] ボックスに「Send Payment」と入力し、[OK] をクリックします。

  12. [Write PO Request to File] アクションを [Receive Invoice] アクションに接続します。

  13. [Receive Invoice] アクションを [Send Payment] アクションに接続します。

  14. [Send Payment] アクションを [終了] シェイプに接続します。

「メッセージ キューのバインドおよび請求書の受信」に進みます。


メッセージ キューのバインドおよび請求書の受信

[Receive Invoice] アクションはメッセージ キュー サービスにバインドされています。このサービスで定義した請求メッセージ キューに請求書が送信されると、[Receive Invoice] アクションが有効になります。

メッセージ キュー サービスをバインドするには次の操作を行います。

  1. [ビジネス プロセス] ページで、[実装] ステンシルの [メッセージ キュー] シェイプを、フローチャートを 2 つに分割している境界バーの右側にドラッグし、[Receive Invoice] アクションと平行になるように配置します。

    [メッセージ キュー バインド ウィザード] が表示されます。

  2. [メッセージ キュー バインド ウィザードへようこそ] ページで、[新しいポートの作成] が選択されていることを確認します。

  3. [新しいポートの作成] ボックスに「ReceiveInvoice」と入力し、[次へ] をクリックします。

  4. [静的または動的キューの情報] ページで [静的キュー] が選択されていることを確認し、[次へ] をクリックします。

  5. [キュー情報] ページで [すべてのインスタンスに対して既存のキューを使用する] をクリックします。

  6. [キュー名を入力します。] というボックスに「.\private$\ReceiveInvoice」と入力し、[次へ] をクリックします。

  7. [ポート プロパティの詳細設定] ページで [完了] をクリックします。

「Receive Invoice サービスのメッセージのプロパティの定義」に進みます。


Receive Invoice サービスのメッセージのプロパティの定義

  1. [Receive Invoice] アクションをクリックし、その右側の制御ハンドルを [ReceiveInvoice] ポートまでドラッグします。

    [XML 通信ウィザード] が表示されます。

  2. [XML 通信ウィザードへようこそ] ページで [受信] をクリックし、[次へ] をクリックします。

  3. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認します。

  4. [メッセージ名] ボックスに「CommonInvoice」と入力し、[次へ] をクリックします。

  5. [XML 変換情報] ページで、[キューから XML メッセージを受信する] が選択されていることを確認し、[次へ] をクリックします。

  6. [メッセージの種類の情報] ページで、[メッセージの種類] ボックスに「CommonInvoice」と入力し、[次へ] をクリックします。

  7. [メッセージ仕様情報] ページで、[完了] をクリックします。

「BizTalk メッセージ サービスのバインド」に進みます。


BizTalk メッセージ サービスのバインド

ここでは、BizTalk メッセージ サービスを XLANG スケジュール フローチャートにバインドし、使用中のチャネルに名前を付けます。

BizTalk メッセージ サービスをバインドするには次の操作を行います。

  1. [ビジネス プロセス] ページで、[実装ステンシル] の [BizTalk メッセージ] シェイプを、フローチャートを 2 つに分割している境界バーの右側にドラッグし、[Send Payment] アクションと平行になるように配置します。

    [BizTalk メッセージ バインド ウィザード] が表示されます。

  2. [BizTalk メッセージ バインド ウィザードへようこそ] ページで、[新しいポートの作成] が選択されていることを確認します。

  3. [新しいポートの作成] ボックスに「SendPayment」と入力し、[次へ] をクリックします。

  4. [通信の方向] ページで [送信] が選択されていることを確認し、[次へ] をクリックします。

  5. [静的または動的チャネルの情報] ページで、[静的チャネル] が選択されていることを確認します。

  6. [既存のチャネル名を入力してください] ボックスに「Channel for Invoice To Payment」と入力し、[完了] をクリックします。

    [Channel for Invoice To Payment] は、モジュール 3 で作成したものです。

「BizTalk メッセージ サービスのメッセージのプロパティの定義」に進みます。


BizTalk メッセージ サービスのメッセージのプロパティの定義

  1. [Send Payment] アクションの右側の制御ハンドルを [SendPayment] ポートまでドラッグします。

    [XML 通信ウィザード] が表示されます。

  2. [XML 通信ウィザードへようこそ] ページで [次へ] をクリックします。

  3. [メッセージ情報] ページで [既存のメッセージに参照を追加] をクリックし、[CommonInvoice] をクリックします。そして [次へ] をクリックします。

  4. [XML 変換情報] ページで、[XML メッセージをキューに送信する] が選択されていることを確認し、[次へ] をクリックします。

  5. [メッセージの種類の情報] ページで [次へ] をクリックします。

  6. [メッセージ仕様情報] ページで、[完了] をクリックします。

「完成した XLANG スケジュール フローチャートの保存」に進みます。


完成した XLANG スケジュール フローチャートの保存

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [XLANG スケジュール フローチャートに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  3. [ファイル名] ボックスに「Buyer2」と入力し、[保存] をクリックします。

「完成した XLANG スケジュールのコンパイル」に進みます。


完成した XLANG スケジュールのコンパイル

  1. [ファイル] メニューの [XLANG Buyer2.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  3. [ファイル名] ボックスに「Buyer2」と入力し、[保存] をクリックします。

完成した XLANG スケジュール フローチャートは、次のようになります。

図をクリックすると、拡大または縮小します。

XLANG スケジュール フローチャート

  4. [ファイル] メニューの [終了] をクリックします。

「完成した XLANG スケジュールの実行」に進みます。


完成した XLANG スケジュールの実行

Business-to-Business 自動調達ソリューションの構成が完了しました。次に、XLANG スケジュールを有効にするアプリケーションを実行します。

ここでは、XLANG スケジュールを有効にし、そのスケジュールによって監視されるメッセージ キューに注文要求を配信するアプリケーションを使用します。

XLANG スケジュールを実行するには次の操作を行います。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動します。

  2. ExecuteTutorial.exe をダブルクリックします。このアプリケーションは、モニカで XLANG スケジュールを有効にする場合に使用します。

    ExecuteTutorial アプリケーションが起動します。

  3. [Browse for Schedule] をクリックします。

ショートカット

既存の XLANG スケジュールを使用している場合は、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動し、手順 2. に進みます。

  1. XLANG スケジュール Buyer2 を作成した場合は、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  2. XLANG スケジュール Buyer2.skx をクリックし、[開く] をクリックします。

  3. [Browse for Data File] をクリックし、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  4. POReqAccept.xml をクリックし、[開く] をクリックします。

  5. [Start XLANG Schedule] をクリックします。

    合計が 1,000 ドル以下であるため、注文要求が承認されます。XLANG スケジューラ エンジンにデータが渡されたことを示すメッセージが表示されます。この時点でアプリケーションは終了しています。次に、注文要求が承認されたことを示すメッセージが表示されます。[OK] をクリックしてダイアログ ボックスを閉じます。

  6. [End] をクリックし、ExecuteTutorial アプリケーションを閉じます。

  7. C:\TutorialFiles\Seller に移動します。

    支払ファイルが表示されます。ファイル名は PaymentXXXX.xml で、XXXX は一意な数値のセットを表します。このファイルをダブルクリックして Microsoft Internet Explorer で開きます。

注文要求の送信が完了しました。注文要求は承認され、支払メッセージとして販売者のシステムに送信されます。

「モジュール 4 の概要」に進みます。


モジュール 4 の概要

このモジュールでは、次のことについて学習しました。

  • 請求のアクションおよび支払のアクションを追加する。詳細については、「シェイプの接続」を参照してください。

  • BizTalk メッセージ サービスを使用してメッセージ ポートを実装する。BizTalk メッセージ サービスによるメッセージ ポートの実装の詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

  • 完成した XLANG スケジュールをコンパイルし、実行する。詳細については、「XLANG スケジュールのコンパイル」および「XLANG スケジュールの実行」を参照してください。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい (拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

「チュートリアルの概要」に進みます。

関連項目

BizTalk オーケストレーションの設計


チュートリアルの概要

このチュートリアルでは、Microsoft BizTalk Server 2000 を構成し、Business-to-Business 自動調達のプロセスを設定し、実行しました。

次の図は、モジュール 4 の最後で XLANG スケジュール Buyer2 を実行したときの、BizTalk Server におけるデータ フローを示しています。

Send Payment
Receive Invoice
判断
PO Req>$1000
終了
Receive PO Req
XLANG スケジュール
ファイル受信機能
Buyer ファイル ディレクトリ
WSC コンポーネント
ASP ファイル
メッセージ キュー
はい (拒否)
いいえ
(承認)
スクリプト コンポーネント
メッセージ ポート
メッセージ ポート
Channel for Invoice
Channel for PO
チャネル
Port to ProElectron
via HTTP
Port to Bits, Bytes,
& Chips via AIC
Port to Bits, Bytes, & Chips via Local File
POtoINVAIC
SubmitProElectronPO
Port to Bits, Bytes,
& Chips via HTTP
Channel for
Invoice to Payment
Channel for
POReq to PO
チャネル
BizTalk メッセージ
メッセージ キュー
アクション
ポート
データ
データ
ExecuteTutorial
PO Request Receive
Function at ProElectron
DropInvoicetoMSMQ
ReceiveInvoice
PORequestApproval
ReceivePOReq
メッセージ キュー
メッセージ キュー
アプリケーション
PO Req
PO Req
開始
Buyer システム
BizTalk メッセージ サービス
終了
AIC
PO to Invoice
Seller ファイル
ディレクトリ
Payment
Seller
Buyer
Payment
Invoice
注 : 矢印はデータ フローを表す。
Invoice
Invoice
マップ
マップ
PO
PO
PO
PO
ASP ファイル
Seller システム
BizTalk オーケストレーション

BizTalk Server のコンポーネントとサービスの連携機能を活用し、企業内および企業間における、疎結合、長時間ビジネス プロセスを統合する方法を学習しました。

さらに次の方法についても学習しました。

  • BizTalk オーケストレーション デザイナを使用し、XLANG スケジュール フローチャートを作成してビジネス プロセスをモデル化する。

  • BizTalk メッセージ マネージャを使用して、組織、チャネル、メッセージ ポート、およびドキュメント定義を作成する。

  • BizTalk エディタを使用して、仕様を作成する。

  • BizTalk マッパーを使用して、マップを作成する。

  • XLANG スケジュールをコンパイルし、実行する。

これでチュートリアルが完了しました。このチュートリアルで使用する付属コンポーネントの作成の詳細については、「付録 : 付属コンポーネントの作成」を参照してください。


付録 : 付属コンポーネントの作成

ここでは、データを処理するために Microsoft BizTalk Server 2000 と共に使用する付属コンポーネントの作成方法について説明します。コンポーネントの種類とそれぞれの役割および処理時の相関関係について、詳細に説明します。

作成するコンポーネントは次のものです。

  • XLANG スケジュールを有効にするアプリケーション。購入者のシステムに作成します。このアプリケーションは、購入者のシステムにおけるメッセージ フローを制御する XLANG スケジュールにバインドされているメッセージ キューに、注文要求を送信します。

  • Windows スクリプト コンポーネント (WSC)。購入者のシステムに作成します。注文要求に対する XLANG スケジュールからの承認ステータスまたは拒否ステータスを確定します。承認された場合、WSC は承認メッセージを表示し、注文要求をローカル ファイル ディレクトリに書き込みます。このローカル ディレクトリは、購入者の BizTalk メッセージ サービスで取得します。拒否された場合は、WSC は拒否メッセージを表示し、スケジュールを終了します。

  • アプリケーション統合コンポーネント (AIC)。販売者のシステムに作成します。購入者の注文データに基づいて請求書を生成します。

  • 購入者のシステムに作成する ASP ファイル。BizTalk Server に注文を送信します。

  • 販売者のシステムに作成する ASP ファイル。請求書をメッセージ キューに配信します。

「アプリケーションの作成」に進みます。


アプリケーションの作成

ここでは、XLANG スケジュールを有効にし、注文要求をキューに送信するアプリケーションを作成します。このアプリケーションを使用して、XLANG スケジュールの実装のテストおよび BizTalk メッセージ マネージャの構成のテストを行います。

このテストを実行するには、サンプル プロジェクトのコードを変更します。対象となるコードは、XLANG スケジュールを有効にし、メッセージをキューに送信するコードです。補助コードが提供されています。

各手順は、それぞれコードのセグメントに対応しています。次の例のようなコメント ブロックを参照してください。

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do: Step A
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

これに続くコードは、プレース ホルダーを示す疑問符 (?) がある行で、ここに変更を加える必要があります。テストを実行するには、この疑問符を適切なコードに置き換えてください。たとえば、次のようなコードがあるとします。

Private g_MSMTxDisp As ?

この場合は次のように変更します。

Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser

注

  • これらのコード行はコメント アウトされています。変更対象の行の先頭にあるコメント マークは削除してください。ここでの手順は、コード ウィンドウどおりの順序になっているとは限りません。

「アプリケーションを開く」に進みます。


アプリケーションを開く

BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

ExecuteTutorial.vbp をダブルクリックします。

「アプリケーションへの必要な参照の追加」に進みます。


アプリケーションへの必要な参照の追加

ここでは、メッセージ キュー、XML、およびスクリプト ラン タイムを使用するために必要な多くのダイナミック リンク ライブラリ (DLL) をアプリケーションに実装します。

  1. [プロジェクト] メニューの [参照設定] をクリックします。

  2. [Microsoft Message Queue 2.0 Object Library] を選択します。

    このタイプ ライブラリの完全なパスは、\WINNT\System32\MQOA.dll です。

  3. [Microsoft Scripting Runtime] を選択します。

    この DLL の完全なパスは、\WINNT\System32\Scrun.dll です。

  4. [Microsoft XML, v 3.0] を選択します。

    この DLL の完全なパスは、\WINNT\System32\msxml3.dll です。

  5. [OK] をクリックします。

「メッセージ キュー オブジェクトの定義および初期化」に進みます。


メッセージ キュー オブジェクトの定義および初期化

ここでは、指定された種類のライブラリを使用するコードを追加します。ここでの手順は、コードの手順に対応しています。

  1. プロジェクト ウィンドウで [フォーム] を展開し、[Form1 (ExecuteTutorial.frm)] をクリックします。

  2. [表示] メニューの [コード] をクリックします。

  3. コードの Step A の一般宣言部で、メッセージ キュー オブジェクトを作成します。次の例を参照してください。
    Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser
Private g_MSMQQueue As MSMQ.MSMQQueue
Private g_MSMQInfo As MSMQ.MSMQQueueInfo
  4. コードの Step B の Form_Load イベント部で、メッセージ キュー オブジェクトを初期化します。次の例を参照してください。
    Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")
Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")

「データをキューに配置するコードの追加」に進みます。


データをキューに配置するコードの追加

ここでは、ExecuteMSMQ という新しいサブルーチンを追加します。これは cmdRunSked_Click イベントによって呼び出されるルーチンです。次の手順に従って、このサブルーチンを呼び出すコードを追加します。

  • Step C で、プロジェクトのコード ウィンドウの最後に次のコードを配置します。
    Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)
    Dim QueueMsg As New MSMQMessage

    Dim strData As String
    Dim fSend As Boolean
    Dim txt As TextStream
    Dim mybyte() As Byte

    g_MSMQInfo.FormatName = strQueuePath
    Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)
    mybyte = StrConv(DataToQueue, vbFromUnicode)
    QueueMsg.Body = DataToQueue

    Set MSMQTx = g_MSMTxDisp.BeginTransaction
    QueueMsg.send g_MSMQQueue, MSMQTx
    MSMQTx.Commit

    Set QueueMsg = Nothing
    Set MSMQTx = Nothing

End Sub

「XLANG スケジュールをアクティブにし、ExecuteMSMQ を呼び出すコードの追加」に進みます。


XLANG スケジュールをアクティブにし、ExecuteMSMQ を呼び出すコードの追加

ここでは、XLANG スケジュールをアクティブにし、メッセージをキューに送信するコードを呼び出すコードを cmdRunSked_Click イベントに追加します。

  1. コードの Step D の cmdRunSked_Click イベント部で、ExecuteMSMQ を呼び出します。次のコードを参照してください。
    ExecuteMSMQ "DIRECT=OS:.\private$\ReceivePoReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAll
  2. コードの Step E の cmdRunSked_Click イベント部で、GetObject を呼び出して、モニカで XLANG スケジュールのインスタンスを作成します。次のコードを参照してください。
    Set SendPAQ = GetObject(txtSked.Text)

「アプリケーションの保存およびコンパイル」に進みます。


アプリケーションの保存およびコンパイル

ここでは、アプリケーションを保存し、コンパイルします。

  1. [ファイル] メニューの [プロジェクトの上書き保存] をクリックします。

  2. [ファイル] メニューの [ExecuteTutorial.exe の作成] をクリックします。

  3. [実行可能ファイルの作成] ダイアログ ボックスで、BizTalk Server をインストールしたドライブのフォルダ \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動し、[OK] をクリックします。

これでアプリケーションを実行して、モジュール 1 および 4 の購入者のスケジュールを実行できるようになりました。

「Windows スクリプト コンポーネント (WSC) の作成」に進みます。


Windows スクリプト コンポーネントの作成

ここでは、XLANG スケジュールにバインドする Windows スクリプト コンポーネント (WSC) を作成します。WSC は、注文要求の承認ステータスまたは拒否ステータスを示すメッセージ ボックスを表示するためのものです。承認された場合は、必要に応じて、注文をローカル ファイルに書き込むこともできます。

「コンポーネントを登録するスクリプトの追加」に進みます。


コンポーネントを登録するスクリプトの追加

ここでは、コンポーネントをファイルに登録するためのスクリプトを追加します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [アクセサリ] をポイントし、[メモ帳] をクリックします。

  2. 次のスクリプトを追加します。
    <?xml version="1.0"?>
<component>
<?component error="true" debug="true"?>
<registration
     description="PORequestApproval"
     progid="BTSTutorial.PORequestApproval"
     version="1.00"
     classid="{2938621b-40fc-48e2-827c-bed74e21a538}"
>
</registration>

    あらかじめ構成されているコンポーネントと同じクラス ID を使用しているため、古いコンポーネントはレジストリで上書きされます。

「メソッドを実装するスクリプトの追加」に進みます。


メソッドを実装するスクリプトの追加

このコンポーネントには 3 つのメソッドがあります。1 つ目は、ユーザーに表示するメッセージ ボックスの形式で承認ステータスを送信するメソッドです。2 つ目は、同じくユーザーに表示するメッセージ ボックスの形式で、拒否ステータスを送信するメソッドです。どちらのメソッドを呼び出すかの判断は、XLANG スケジュール フローチャートの判断規則に従って行われます。3 つ目は、注文要求が承認された場合に、その注文をローカル ファイルに書き込むメソッドです。

  1. 3 つのメソッドの署名をファイルの最後に追加します。
    <public>
     <method name="SendApproval">
          <PARAMETER name="Document"/>
     </method>
     <method name="SendDenial">
          <PARAMETER name="Document"/>
     </method>
     <method name="WriteToFile">
          <PARAMETER name="Document"/>
          <PARAMETER name="FileName"/>
     </method>
</public>
  2. メソッドを実装するスクリプトをファイルの最後に追加します。
    <implements type="Behavior" id="Behavior"/>

<script language="VBScript">
<![CDATA[

function SendApproval(Document)
     MsgBox "Scheduler Engine Accepted document :" + vbcrlf + + vbcrlf + Document, 0, "Document Approval Received"
end function

function SendDenial(Document)
     MsgBox "Scheduler Engine Denied document :" + vbcrlf + + vbcrlf + Document, 0, "Document Denied"
end function

function WriteToFile(Document, FileName)
     dim objFileSys, strTimeNow

     if FileName = "" then
            FileName = "c:\TutorialFiles\Buyer\POReq*.xml"
     end if

'Generate a Unique Number used to generate unique files using a mask
   strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)

'Create File System Object
     Set objFileSys = CreateObject("Scripting.FileSystemObject")

'Create the Specified file, write the document data and close
     Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)
     filestream.writeline Document
      filestream.close
end function

]]>
</script>

</component>
  3. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [名前を付けて保存] ダイアログ ボックスが表示されます。

  4. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab に移動します。

  5. [ファイル名] ボックスに「PoRequestApproval.wsc」と入力します。

  6. [ファイルの種類] ボックスの一覧で [すべてのファイル] をクリックし、[保存] をクリックします。

  7. [メモ帳] を閉じます。

  8. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab に移動します。

  9. [PoRequestApproval.wsc] を右クリックし、[登録] をクリックします。

このコンポーネントは、モジュール 1 で使用された、構成済みの WSC と置き換えることができます。このコンポーネントを使用するには、スケジュールから既存の WSC バインドを削除し、このコンポーネントをポイントする新しい WSC バインドを作成します。

「WSC コンポーネントの削除」に進みます。


WSC コンポーネントの削除

ここでは、XLANG スケジュール フローチャート Buyer2 から WSC コンポーネントを削除します。前に作成したコンポーネントは再度バインドできます。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. モジュール 4 で作成したフローチャートを使用する場合は、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に保存した Buyer2.skv を開きます。

    作成済みの Buyer2 フローチャートを使用する場合は、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution にある Buyer2.skv を開きます。

  3. スクリプト コンポーネント シェイプをクリックし、Delete キーを押します。

  4. [データ] タブをクリックします。

  5. [SendApproval]、[SendDenial]、および [WritetoFile] メッセージをそれぞれ削除します。

これで、スケジュールに WSC コンポーネントを使用する準備ができました。次の操作を行います。

  1. WSC コンポーネントを使用して、Buyer2.skv にポートを実装します。詳細については、「スクリプト コンポーネントを使用したポートの実装」を参照してください。ただし、この手順のコンポーネントではなく、自分で作成したコンポーネントを使用します。

  2. ポート実装のメソッド通信を定義します。詳細については、「スクリプト コンポーネントのメッセージのプロパティの定義」を参照してください。

  3. ポートのデータ フローを定義します。詳細については、「データ フローの定義」を参照してください。

  4. XLANG ファイルを保存します。詳細については、「XLANG スケジュール フローチャートの保存」を参照してください。

  5. コンポーネントのテストをするには、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution にある ExecuteTutorial アプリケーションを実行します。

「アプリケーション統合コンポーネント (AIC) の作成」に進みます。


アプリケーション統合コンポーネント (AIC) の作成

ここでは、MSXML DOM を使用して注文ドキュメントを請求ドキュメントに変換するアプリケーション統合コンポーネント POtoINVAIC を新規に作成します。

「AIC の ActiveX DLL プロジェクトの作成」に進みます。


AIC の ActiveX DLL プロジェクトの作成

  1. Microsoft Visual Basic 6.0 を起動します。

  2. [新しいプロジェクト] ダイアログ ボックスで [新規作成] タブをクリックし、[ActiveX DLL] をクリックします。次に [開く] をクリックします。

    使用しているコンポーネントのプロジェクト Project 1 が作成されます。

  3. プロジェクトおよびコントロールの名前をより理解しやすいものに変更するには、プロジェクト ツリー ウィンドウで [Project1] をクリックします。プロパティのダイアログ ボックスで "(オブジェクト名)" プロパティを [POtoInvAIC] に変更します。

  4. プロジェクト ツリー ウィンドウで [Class1(Class1)] をクリックします。プロパティのダイアログ ボックスで "(オブジェクト名)" プロパティを [ConvertPOtoInvoice] に変更します。

「AIC に必要な参照の追加」に進みます。


AIC に必要な参照の追加

ここでは、BizTalk Server 2000 に必要な多くのインターフェイスをコンポーネントに実装します。

  1. [プロジェクト] メニューの [参照設定] をクリックします。

  2. [Microsoft BizTalk Server Application Interface Components 1.0 Type Library] を選択します。

    このタイプ ライブラリの完全なパスは、\Program Files\Microsoft BizTalk Server\btscomplib.tlb です。

  3. [Microsoft BizTalk Server Interchange 1.0 Type Library] を選択します。

    このタイプ ライブラリの完全なパスは、\Program Files\Microsoft BizTalk Server\cisapi.tlb です。

  4. [Microsoft Scripting Runtime] を選択します。

    この DLL の完全なパスは、\WINNT\System32\Scrun.dll です。このライブラリを使用して、ファイル システム オブジェクトを作成し、注文をディスクに書き込むために使用するテキスト ストリームを開きます。

  5. [Microsoft XML, v 3.0] を選択します。

    この DLL の完全なパスは、\WINNT\System32\msxml3.dll です。

  6. [OK] をクリックします。

「必要なインターフェイスの実装」に進みます。


必要なインターフェイスの実装

BizTalk Server にコンポーネントを AIC として認識させるには、2 つのインターフェイスのいずれか 1 つを実装します。このチュートリアルでの目標を達成するには、IBTSAppIntegration インターフェイスを実装します。

  1. プロジェクト ウィンドウで、[ConvertPOtoInvoice] クラス モジュールをクリックします。

  2. [表示] メニューの [コード] をクリックします。

  3. 次のコード行をコードの先頭に追加して、すべての変数に対して、明示的な宣言を強制するようにします。
    Option Explicit
  4. Option Explicit 文の後に次のコード行を追加して、必要なインターフェイスを実装します。
    Implements IBTSAppIntegration

「クラス オブジェクトの定義および初期化」に進みます。


クラス オブジェクトの定義および初期化

ここでは、コードを追加して、DOM を使用して XML ファイルを作成する MSXML クラス オブジェクトを定義します。注文を請求書に変換するプロジェクト スタイル シートをポイントする文字列変数を作成します。

  1. 次のコードを Implements IBTSAppIntegration 文の下に配置します。
    'Class Object Defines
Private m_DOMCommonPO As MSXML2.DOMDocument
Private m_DOMStylesheet As MSXML2.DOMDocument
Private m_objSubmit As BTSInterchangeLib.Interchange

'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice
Private m_strStylesheet As String
  2. 次のコードを追加します。このコードは、注文を請求書に変換する XML DOM オブジェクトと、BizTalk Server に最終請求ドキュメントを送信する Interchange オブジェクトを初期化します。
    Private Sub Class_Initialize()
'Create DOM/Interchange Objects
    Set m_DOMCommonPO = New MSXML2.DOMDocument
    Set m_DOMStylesheet = New MSXML2.DOMDocument
    Set m_objSubmit = New BTSInterchangeLib.Interchange

'Configure DOM Objects to be Synchronous
    m_DOMCommonPO.async = False
    m_DOMStylesheet.async = False

'Fill Stylesheet Embedded String
    m_strStylesheet = m_strStylesheet + ""

End Sub

「インターフェイス メソッドの実装」に進みます。


インターフェイス メソッドの実装

IBTSAppIntegration インターフェイスの ProcessMessage メソッドは、BizTalk Server から送信された受信 XML 共通注文ドキュメントのデータを、XML 共通請求ドキュメントに変換します。この共通請求ドキュメントは、BizTalk Server に返送されます。この目的は、注文を受信するバック エンド システムをシミュレートし、最終的にその注文の請求書を戻すことです。

  1. 関数定義および次元変数を追加します。次のコードを参照してください。
    Private Function IBTSAppIntegration_ProcessMessage( _
                                ByVal bstrDocument As String) As String
    Dim bstrInvoiceDocument As String
    Dim objScripting As New Scripting.FileSystemObject
'Initialize ProcessMessage to null
    IBTSAppIntegration_ProcessMessage = ""
  2. 受信したデータを DOM オブジェクトに読み込み、そのデータの書式が正しいかどうかを検証するコードを追加します。これを行うには、IBTSAppIntegration_ProcessMessage の下に次のコードを追加します。
        m_DOMCommonPO.loadXML bstrDocument

    If m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XML
'Raised errors are not caught in the component, and will be sent back to 'BizTalk Server
        Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _
            "The provided document was not valid XML and could not be processed because:" + _
            vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line: " + _
            CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position: " + _
            CStr(m_DOMCommonPO.parseError.linepos)
    End If
  3. 注文を請求書に変換する XSL コードが含まれるリソース ファイルを使用するコードを追加します。これを行うには、End If 文の下に次のコードを追加します。
        If m_strStylesheet = "" Then
        m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)

    End If
    m_DOMStylesheet.loadXML m_strStylesheet
    bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)

    If bstrInvoiceDocument = "" Then ' Mapping Failed Raise an Error
        Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _
            "The provided CommonPO document could not be translated into a Common Invoice " + _
            "as the map produced blank output."
    End If
  4. 請求ドキュメントを BizTalk メッセージ サービスに送信するコードを追加します。これを行うには、End If 文の下に次のコードを追加します。
    IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Bits,Bytes,Chips on Seller", , "ProElectron on Seller")

End Function

    送信呼び出しによって送信 ID が返されます。ただし、この場合、送信 ID は使用されません。

「クラス オブジェクトの終了」に進みます。


クラス オブジェクトの終了

クラスが終了したときにすべてのオブジェクトがメモリから解放されるようにするには、次のコードをプロジェクトの最後に追加します。

Private Sub Class_Terminate()
    Set m_DOMCommonPO = Nothing
    Set m_DOMStylesheet = Nothing
    Set m_objSubmit = Nothing
End Sub

「リソース ファイルの作成」に進みます。


リソース ファイルの作成

ここでは、注文を請求書に変換するための XSL を含むリソース ファイルを追加します。

  1. [アドイン] メニューをクリックし、[アドイン マネージャ] をクリックします。

    [アドイン マネージャ] ダイアログ ボックスが表示されます。

  2. [VB6 リソース エディタ] をクリックします。

  3. [ロード方法] で、[ロード/アンロード] をクリックしてリソース エディタをロードし、[起動時にロード] をクリックします。次に [OK] をクリックします。

  4. [ツール] メニューの [リソース エディタ] をクリックします。

  5. ツール バーの [カスタム リソースの追加] をクリックします。

    [カスタム リソースを開く] ダイアログ ボックスが表示されます。

  6. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動し、POtoINVAIC.txt をクリックします。次に [開く] をクリックします。

注意

  • リソースの ID は 101 です。既定では、作成した最初のリソースの ID が 101 になります。ただし、この番号は、リソースを変更すると 1 ずつ増加します。リソース ID を 101 に変更するには、リソース ID を右クリックし、[プロパティ] をクリックします。[ID] ボックスに「101」と入力します。次に [OK] をクリックします。
  7. ツール バーの [上書き保存] をクリックします。

    [リソース ファイルを名前を付けて保存] ダイアログ ボックスが表示されます。

  8. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動します。

  9. [ファイル名] ボックスに「POtoInvAICLab.RES」と入力し、[保存] をクリックします。

  10. リソース エディタを閉じます。

「コンポーネントの組み込みおよびバイナリ互換性の設定」に進みます。


コンポーネントの組み込みおよびバイナリ互換性の設定

新しいコンポーネントの作成中であるため、この時点でこのコンポーネントを組み込み、さらに新しく作成した DLL とのバイナリ互換性が得られるようにプロジェクトのプロパティを設定する必要があります。バイナリ互換性があると、DLL をコンパイルするたびに、新しいグローバル一意識別子 (GUID) を生成する必要がなくなります。

  1. [ファイル] メニューの [名前を付けてプロジェクトの保存] をクリックします。

    [名前を付けてファイルの保存] ダイアログ ボックスが表示されます。

  2. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab に移動します。

  3. [ファイル名] ボックスに「ConvertPOtoInvoice.cls」と入力し、[保存] をクリックします。

    [名前を付けてプロジェクトの保存] ダイアログ ボックスが表示されます。

  4. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab に移動します。

  5. [ファイル名] ボックスに「POToInvAICLab」と入力し、[保存] をクリックします。

  6. [ファイル] メニューの [POToInvAICLab.dll の作成] をクリックします。

    [実行可能ファイルの作成] ダイアログ ボックスが表示されます。

  7. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動し、[OK] をクリックします。

  8. [プロジェクト] メニューの [POToInvAICLab のプロパティ] をクリックします。

  9. [コンポーネント] タブをクリックします。

  10. [バイナリ互換] をクリックします。

  11. 参照ボタン ([...]) をクリックし、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動します。

  12. POToInvAICLab.dll をクリックし、[開く] をクリックします。

  13. [OK] をクリックします。

「AIC の登録」に進みます。


AIC の登録

ここでは、AIC を登録して、BizTalk Server が認識できるようにします。BizTalk Server は、登録された COM コンポーネントの一覧を参照し、これらのコンポーネントに対してクエリを実行して、IBTSAppIntegration インターフェイスまたは IPipelineComponent インターフェイスのいずれかを実装するコンポーネントを決定します。この基準を満たすコンポーネントはすべて BizTalk メッセージ マネージャのコンポーネントの一覧に表示されます。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [コンポーネント サービス] をダブルクリックします。

    [コンポーネント サービス] コンソールが表示されます。

  4. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] をクリックします。

  5. [COM+ アプリケーション] を右クリックして [新規作成] をポイントし、[アプリケーション] をクリックします。

    [COM アプリケーション インストール ウィザード] が表示されます。

  6. [COM アプリケーション インストール ウィザードへようこそ] ページで、[次へ] をクリックします。

  7. [新しいアプリケーションのインストールまたは作成] ページで、[空のアプリケーションを作成する] をクリックします。

  8. [新しいアプリケーション名の入力] ボックスに「POToInvAICLab」と入力します。

  9. [アクティブ化の種類]で [サーバー アプリケーション] をクリックし、[次へ] をクリックします。

  10. [アカウント] で [対話ユーザー - 現在ログオンしているユーザー] をクリックし、[次へ] をクリックします。

    注

    • 現在のログオン ユーザーは、BizTalk Server Administrators グループのメンバである必要があります。また、このシナリオの実行中はログオンしたままでいてください。
  11. [完了] をクリックします。

  12. コンソール ツリーで [COM+ アプリケーション] を展開し、作成済みの新しいパッケージ POToInvAICLab を展開します。

  13. [コンポーネント] をクリックします。

  14. エクスプローラで BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab を参照します。

  15. POToInvAICLab.dll を [コンポーネント サービス] の [コンポーネント] フォルダにドラッグします。

  16. [コンポーネント サービス] を閉じます。

これで、新しい AIC を使用するポートを再構成する準備ができました。次の手順に従って構成します。

  1. BizTalk メッセージ マネージャを開きます。

  2. [検索] 領域で [メッセージ ポート] をクリックし、[検索] をクリックします。

  3. [メッセージ ポート名] ボックスの一覧で、[Port to Bits,Bytes,Chips via AIC] をダブルクリックします。

  4. [全般情報] ページで、[次へ] をクリックします。

  5. [送信先組織] ページの [プライマリ トランスポート] で、[参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [参照] をクリックします。

  7. [利用可能なコンポーネント] ボックスの一覧で [POToInvAICLab ConvertPOtoInvoice] をクリックし、[OK] をクリックします。

  8. [OK] をクリックして [プライマリ トランスポート] ダイアログ ボックスを閉じ、[完了] をクリックします。

  9. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に保存された ExcecuteTutorial アプリケーションを実行して、コンポーネントのテストをします。


BizTalk Server 2000 の管理

BizTalk Server 2000 の管理は、次のように分割されています。

BizTalk Server 2000 のインストール

ここでは Microsoft BizTalk Server 2000 のインストールについて説明します。ハードウェア要件とソフトウェア要件のガイドライン、およびサーバー、クライアント、カスタムの各インストールに関する指示が含まれています。Microsoft BizTalk Server 2000 のインストールの詳細については、「BizTalk Server 2000 のインストール」を参照してください。

セキュリティについて

ここでは、BizTalk Server 2000 を使用する場合に、企業がどのようにしてデータを安全に交換するかを説明します。BizTalk Server は Microsoft Windows 2000 と Microsoft SQL Server に含まれるセキュリティ機能を利用します。セキュリティと BizTalk Server 2000 の詳細については、「セキュリティについて」を参照してください。

パフォーマンスとスケーラビリティの強化

ここでは BizTalk Server のパフォーマンス強化とスケーラブルなソリューション構築について説明します。ここで取り扱う問題およびガイドラインには、潜在的な障害の認識、待ち時間、およびデータベース管理が含まれます。スケーラブルでハイパフォーマンスなソリューション構築の詳細については、「パフォーマンスとスケーラビリティの強化」を参照してください。

サーバーおよびアプリケーションの管理

ここではサーバーおよび XLANG に関連するアプリケーションの管理方法について説明します。ここで取り扱う内容には、複数のグループにあるサーバーを集中的に構成および管理する方法、受信機能の構成と管理、共有キューの管理、および XLANG スケジュールを提供する COM+ アプリケーションの管理が含まれます。サーバーおよびアプリケーションの管理の詳細については、「サーバーおよびアプリケーションの管理」を参照してください。

ドキュメントの追跡

ここでは BizTalk Server 2000 によって処理されるインターチェンジおよびドキュメントの追跡方法について説明します。ここで取り扱う内容には、クエリと高度なクエリの作成方法、インターチェンジ、ドキュメント、およびカスタム検索データの保存方法、インターチェンジ レコード、ドキュメント レコード、および受信確認の結果の概要が含まれます。ドキュメントの追跡の詳細については、「ドキュメントの追跡」を参照してください。

注

  • コンポーネント サービスや管理ツールなどのさまざまな Microsoft Windows 2000 サービスおよびツールを開くファイル パスは、Windows 2000 Server か Windows 2000 Professional のどちらを使用しているかによって異なります。詳細については、「コンピュータの管理を開く」を参照してください。

    Microsoft BizTalk Server 2000 ヘルプでは、これらのサービスおよびツールへのパスは Windows 2000 Server に基づいています。Windows 2000 Professional を使用している場合、利用するサービスおよびツールの開き方については、Windows 2000 Professional ヘルプを参照してください。

関連項目

BizTalk Server の管理モデル


BizTalk Server 2000 のインストール

『Microsoft® BizTalk™ Server 2000 インストール ガイド』へようこそ。ここでは、ハードウェアとソフトウェアの要件のガイドラインを示すと共に、次のインストール オプションについて詳細に説明します。

  • サーバー インストール : BizTalk Server 2000 のすべてのサービスとツールを完全にインストールできます。

  • クライアント インストール : BizTalk Server 2000 のツールである BizTalk オーケストレーション デザイナ、BizTalk ドキュメント トラッキング、BizTalk エディタ、および BizTalk マッパーを完全にインストールできます。BizTalk Server 2000 のパーサー、シリアライザ、関連付けコンポーネント、およびランタイム コンポーネントはインストールされません。

  • カスタム インストール : BizTalk Server 2000 のツールとサービスそれぞれを任意に組み合わせたカスタム インストールを実行できます。

ここには次のトピックが含まれます。

  • ハードウェアとソフトウェアの要件

  • インストールに関する説明


ハードウェアとソフトウェアの要件

ここでは、Microsoft BizTalk Server 2000 をインストールする場合のハードウェアの最小要件と構成のオプションについて説明します。また、BizTalk Server 2000 に必要なソフトウェアをインストールする方法も説明します。

ここには次のトピックが含まれます。

  • ハードウェアの最小要件

  • ドキュメント メッセージ処理のパフォーマンス最大化のための推奨構成

  • 必要なソフトウェア

  • Windows 2000 の前提条件

  • SQL Server 7.0 または SQL Server 2000 のインストール

  • Visio 2000 SR-1 のインストール


ハードウェアの最小要件

Microsoft BizTalk Server 2000 の基本インストールのハードウェア最小要件は次のとおりです。

  • Intel® Pentium 300 MHz プロセッサ

  • 128 MB の RAM

  • 6 GB のハードディスク空き容量

  • CD-ROM ドライブ

  • ネットワーク アダプタ カード

  • VGA モニタまたは Super VGA モニタ

  • Microsoft マウス、または互換性のあるポインティング デバイス


ドキュメント メッセージ処理のパフォーマンス最大化のための推奨構成

ここでは、BizTalk Server 2000 の最大のパフォーマンスを得るために役立つガイドラインを示します。

  • 3 台のコンピュータで構成します。3 台コンピュータによる構成では、1 台目のコンピュータに BizTalk Server 2000、2 台目のコンピュータに追跡データベース、3 台目のコンピュータに BizTalk メッセージ管理データベースと共有キュー データベースをインストールします。

  • 1 台のサーバーがすべての送信機能と受信機能を持つ構成でより高いパフォーマンスを求めるときには、2 台のコンピュータを使って BizTalk Server 2000 サーバーを 2 つ構成し、一方を送信機能専用、もう一方を受信機能専用のサーバーにします。

  • 物理的にハード ディスクを複数搭載しているコンピュータに追跡データベースをインストールします。最適な構成は、4 台の SCSI II ハード ディスクと 1 台の SCSI II コントローラからなるものです。1 台目のハード ディスクは、ドキュメント トラッキング専用にします。2 台目のハード ディスクは、Microsoft Windows® 2000 システム ページ ファイル専用にします。3 台目のハード ディスクは、追跡トランザクション ログ専用にします。4 台目のハード ディスクは、分散トランザクション コーディネータ (DTC) ログ専用にします。

  • 受信機能のインスタンスを複数作成し、処理対象ドキュメントの複数の受信場所を監視します。ドキュメントの負荷を複数のサーバーに分散させるには、各コンピュータに受信機能を配置します。それぞれの監視場所は一意で、また独立した受信機能を持っている必要があります。特定の受信機能に過負荷がかかるのを回避するには、ドキュメントを送信する業務用アプリケーションがすべての監視場所にドキュメントを均等に分配します。

重要

  • BizTalk Server のパフォーマンス向上の詳細については、「パフォーマンスとスケーラビリティの強化」を参照してください。


必要なソフトウェア

次の表は、Microsoft BizTalk Server 2000 の実行のためにインストールする必要があるソフトウェアの一覧を示しています。

サーバー インストール | クライアント インストール | カスタム インストール
Microsoft Windows 2000 Server、Microsoft Windows 2000 Advanced Server、または Microsoft Windows 2000 Professional (ただし、NTFS ファイル システムでインストールし、Service Pack 1 を含むもの) | Microsoft Windows 2000 Server、Microsoft Windows 2000 Advanced Server、または Microsoft Windows 2000 Professional (ただし、NTFS ファイル システムでインストールし、Service Pack 1 を含むもの) | Microsoft Windows 2000 Server、Microsoft Windows 2000 Advanced Server、または Microsoft Windows 2000 Professional (ただし、NTFS ファイル システムでインストールし、Service Pack 1 を含むもの)
Microsoft Internet Explorer 5 以降 | Microsoft Internet Explorer 5 以降 | Microsoft Internet Explorer 5 以降
Microsoft Visioｮ 2000 SR-1 以降 (BizTalk オーケストレーション デザイナを使用するために必要) | Microsoft Visio 2000 SR-1 以降 (BizTalk オーケストレーション デザイナを使用するために必要) | Microsoft Visio 2000 SR-1 以降 (BizTalk オーケストレーション デザイナを使用するために必要)
Microsoft SQL Server™ 7.0 Service Pack 2 (SP2) または SQL Server 2000 | Microsoft SQL Server™ 7.0 Service Pack 2 (SP2) または SQL Server 2000
注
  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service が実行していないと使用できません。
 注
  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service が実行していないと使用できません。
 注
  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service が実行していないと使用できません。

* カスタム インストールに Microsoft SQL Server が必要になるのは、BizTalk のコア サービスをインストールする場合だけです。クライアント インストールには Microsoft SQL Server は必要ありません。

** SQL Server 2000 Personal Edition、SQL Server 2000 Desktop Engine (MSDE)、および SQL Server 2000 Win CE Edition は、サポートされません。SQL Server 2000 Enterprise Edition 評価版は、評価用にのみサポートされます。SQL Server 2000 Enterprise Developer Edition は、開発用にのみサポートされます。

*** Microsoft Windows 2000、 Microsoft Internet Explorer、 Microsoft Visio 2000、 Microsoft SQL Server は、日本語版のみに対応しています。


Windows 2000 の前提条件

Microsoft Windows 2000 Server Service Pack 1、Microsoft Windows 2000 Advanced Server Service Pack 1、および Microsoft Windows 2000 Professional Service Pack 1 は、Microsoft BizTalk Server 2000 のすべてのインストール オプションに推奨されているプラットフォームです。BizTalk Server 2000 は Service Pack 1 を含む Windows 2000 上で徹底してテストされています。このインストール ガイドでは、BizTalk Server を使用する場合に Windows 2000 Server、Windows 2000 Advanced Server、および Windows 2000 Professional で必要な構成について詳細に説明します。Windows 2000 Server Service Pack 1、Windows 2000 Advanced Server Service Pack 1、または Windows 2000 Professional Service Pack 1 をインストールした後、ソフトウェアのインストールを行う前に、Windows 2000 のユーザー アカウントを Administrators グループに追加する必要があります。詳細については、「Administrators グループへのユーザー アカウントの追加」を参照してください。また、メッセージ キューもインストールする必要があります。詳細については、「メッセージ キューのインストール」を参照してください。使用環境に Service Pack 1 が含まれていない場合は、Service Pack 1 をインストールする必要があります。詳細については、「Windows 2000 Service Pack 1 のインストール」を参照してください。

ここには次のトピックが含まれます。

  • Windows 2000 Server SP1、Windows 2000 Advanced Server SP1、またはWindows 2000 Professional SP1 のインストール

  • Windows 2000 Service Pack 1 のインストール

  • メッセージ キューのインストール

  • インターネット インフォメーション サービス (IIS) のインストール

  • BizTalk Server 2000 用の IIS 設定の構成

  • ユーザー アカウントのセットアップ


Windows 2000 Server SP1、Windows 2000 Advanced Server SP1、または Windows 2000 Professional SP1 のインストール

Windows 2000 Server、Windows 2000 Advanced Server、または Windows 2000 Professional をコンピュータにインストールする場合は、下の手順 2. に示す要件を満たすように注意してください。

  1. Windows 2000 Server Service Pack 1、Windows 2000 Advanced Server Service Pack 1、またはWindows 2000 Professional Service Pack 1 の CD を所定のドライブに挿入します。

    Service Pack 1 を含む Windows 2000 のバージョンを持っていない場合は、Windows 2000 と Service Pack 1 を個別にインストールします。

  2. Windows 2000 Server Service Pack 1、Windows 2000 Advanced Server Service Pack 1、または Windows 2000 Professional Service Pack 1 のセットアップ プログラムを実行し、インストールの説明に従います。

    次の条件を満たすようにしてください。

    • コンピュータ名には英数字だけを使用します。Microsoft SQL Server でサーバー コンピュータ名に使用できる文字セットには制限があるためです。

    • Windows NT ファイル システム (NTFS) でパーティションをフォーマットします。

    • [Windows 2000 コンポーネント] ページの [コンポーネント] ボックスの一覧で [メッセージ キュー サービス] をオンにします。Windows 2000 Professional をインストールする場合は、[インターネット インフォメーション サービス (IIS)] をクリックし、[次へ] をクリックします。[メッセージ キューの種類] ページで [次へ] をクリックします。

    • [ネットワークの設定] ページで [標準設定] をクリックします。

注

  • Windows 2000 Server Service Pack 1、Windows 2000 Advanced Server Service Pack 1、または Windows 2000 Professional Service Pack 1 をインストールした後、ソフトウェアのインストールを行う前に、Windows 2000 のユーザー アカウントを Administrators グループに追加する必要があります。詳細については、「Administrators グループへのユーザー アカウントの追加」を参照してください。

  • セットアップ時に [Windows 2000 コンポーネント] ページの [メッセージ キュー サービス] をオンにしなかった場合は、メッセージ キュー サービスをインストールする必要があります。詳細については、「メッセージ キューのインストール」を参照してください。

  • Windows 2000 Professional のセットアップ時に [Windows 2000 コンポーネント] ページの [インターネット インフォメーション サービス (IIS)] をクリックしなかった場合は、インターネット インフォメーション サービスをインストールする必要があります。詳細については、「インターネット インフォメーション サービス (IIS) のインストール」を参照してください。

  • 使用環境に Service Pack 1 が含まれていない場合は、Service Pack 1 をインストールする必要があります。詳細については、「Windows 2000 Service Pack 1 のインストール」を参照してください。

  • Windows 2000 Server、Windows 2000 Advanced Server、または Windows 2000 Professional のパーティションを、NTFS の最新バージョンに変換する必要があります。現在のファイル システムが NTFS の古いバージョンである場合は、セットアップ時にこの更新が自動的に行われます。現在のパーティションが FAT または FAT32 である場合は、NTFS への変換を行うかどうかの選択を求めるメッセージが表示されます。メッセージが表示されたら、NTFS を選択してください。


Windows 2000 Service Pack 1 のインストール

  1. Windows 2000 Service Pack 1 の CD を所定のドライブに挿入します。

    また、Microsoft Windows 2000 Web サイト (www.microsoft.com/japan/windows2000/) のダウンロード エリアにアクセスして Windows 2000 Service Pack 1 をダウンロードするか、またはその CD を注文することができます。

  2. Windows 2000 Service Pack 1 セットアップ プログラムを実行し、インストールの説明に従います。


メッセージ キューのインストール

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Windows コンポーネントの追加と削除] をクリックします。

    [Windows コンポーネント ウィザード] が開きます。

  4. [コンポーネント] ボックスの一覧で [メッセージ キュー サービス] チェック ボックスをオンにし、[次へ] をクリックします。

  5. [メッセージ キューの種類] ページで [Active Directory へのアクセス モードを手動で選択する] チェック ボックスをオンにし、[次へ] をクリックします。

  6. [メッセージ キュー サーバー] ページで [メッセージ キューでディレクトリ サービスにアクセスしない] をクリックし、[次へ] をクリックします。

  7. [完了] をクリックしてウィザードを閉じます。

注

  • メッセージ キュー サービス コンポーネントをインストールするときは、既定の設定をそのまま使用します。


インターネット インフォメーション サービス (IIS) のインストール

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Windows コンポーネントの追加と削除] をクリックします。

    [Windows コンポーネント ウィザード] が開きます。

  4. [コンポーネント] ボックスの一覧で [インターネット インフォメーション サービス (IIS)] チェック ボックスをオンにし、[次へ] をクリックします。

  5. [完了] をクリックしてウィザードを閉じます。


BizTalk Server 2000 用の IIS 設定の構成

BizTalk Server 2000 リポジトリへのアクセスや仕様の保存に関連する問題を回避するには、インターネット インフォメーション サービス (IIS) の [作成を有効にする] チェック ボックスをオフにする必要があります。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[インターネット サービス マネージャ] をダブルクリックします。

  2. ローカル IIS サーバーの展開記号 (+) をクリックします。

  3. [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [既定の Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  4. [Server Extensions] タブをクリックし、[作成を有効にする] チェック ボックスをオフにします。


ユーザー アカウントのセットアップ

開発だけを目的として BizTalk Server 2000 をインストールする場合は、通常のユーザー アカウントを作成すれば十分です。詳細については、「Administrators グループへのユーザー アカウントの追加」を参照してください。運用目的で BizTalk Server 2000 をインストールする場合は、サービス アカウントを作成してください。詳細については、「サービス アカウントの作成」を参照してください。サービス アカウント (特定のプロパティを持った通常のユーザー アカウント) を作成しない場合、BizTalk Server 2000 は、自動的に、対話ユーザー (セットアップ処理中にログオンしているユーザー) を対象に構成されます。対話ユーザーによって BizTalk Server 2000 をセットアップした場合、このユーザーがサーバーからログオフするとエラーが発生します。

ここには次のトピックが含まれます。

  • Administrators グループへのユーザー アカウントの追加

  • サービス アカウントの作成


Administrators グループへのユーザー アカウントの追加

  1. Administrator としてログオンします。

    [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. コンソール ツリーで [ローカル ユーザーとグループ] の展開記号 (+) をクリックします。

  3. [グループ] をクリックし、詳細ウィンドウで [Administrators] をダブルクリックします。

    [Administrators のプロパティ] ダイアログ ボックスが表示されます。

  4. [追加] をクリックします。

  5. [場所] ボックスの一覧で、使用しているコンピュータ名をクリックします。

  6. "名前をセミコロンで区切って入力するか、または一覧から選びます" というテキストが表示されているテキスト ボックスで、そのテキストを削除してから、ドメインおよびユーザー名を次の書式で入力します。

    <ドメイン>\<ユーザー名>

  7. [OK] をクリックします。

  8. 必要に応じて、[ネットワーク パスワードの入力] ページで次の操作を行います。
    • [ユーザー名] ボックスに、ユーザーのドメインとユーザー名を次の書式で入力します。

      <ドメイン>\<ユーザー名>

    • [パスワード] ボックスに、ユーザー名に関連付けられているパスワードを入力し、[OK] をクリックします。

    • [OK] をクリックして [Administrators のプロパティ] ダイアログ ボックスを閉じます。
  9. 必要に応じてコンピュータを再起動し、入力したドメイン ユーザー アカウントを使用してログオンします。


サービス アカウントの作成

  1. Administrator としてログオンします。

  2. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  3. コンソール ツリーで [システム ツール] の展開記号 (+) をクリックし、[ローカル ユーザーとグループ] をクリックします。

  4. [ユーザー] をクリックし、詳細ウィンドウ内の任意の位置を右クリックして [新しいユーザー] をクリックします。

    [新しいユーザー] ダイアログ ボックスが表示されます。

  5. [ユーザー名] ボックスにサービス アカウントの名前を入力し、[パスワード] ボックスにパスワードを入力し、[パスワードの確認入力] ボックスに同じパスワードを入力します。

  6. [ユーザーは次回ログオン時にパスワードの変更が必要] チェック ボックスをオフにし、[作成] をクリックして [閉じる] をクリックします。

  7. [コンピュータの管理] ウィンドウを閉じます。

  8. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[ローカル セキュリティ ポリシー] をダブルクリックします。

    [ローカル セキュリティ設定] ダイアログ ボックスが表示されます。

  9. コンソール ツリーで [ローカル ポリシー] の展開記号 (+) をクリックし、[ユーザー権利の割り当て] をクリックします。

  10. 詳細ウィンドウで、[オペレーティング システムの一部として機能] をダブルクリックし、[追加] をクリックします。一覧で、作成したアカウント名をクリックし、[追加] をクリックして [OK] をクリックします。

  11. [サービスとしてログオン] ポリシーに対しても手順 8. ～ 10. の操作を行います。
  12. 作成したサービス アカウントを Administrators グループへ追加します。

BizTalk Server 2000 がインストール済みで、対話ユーザー アカウントを使用している場合は、サービス アカウントを作成してから、次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[サービス] をダブルクリックします。

  2. 詳細ウィンドウで [BizTalk Messaging Service] をダブルクリックします。

    [(ローカル コンピュータ) BizTalk Messaging Service のプロパティ] ダイアログ ボックスが表示されます。

  3. [ログオン] タブをクリックし、[アカウント] をクリックします。

  4. [参照] をクリックし、作成したユーザー アカウントをダブルクリックします。

  5. [パスワード] ボックスに、ユーザー アカウント名に関連付けたパスワードを入力し、[パスワードの確認入力] ボックスにそのパスワードをもう一度入力して [OK] をクリックします。

  6. メッセージ ボックスが表示されます。[OK] をクリックします。

  7. コンピュータを再起動します。


SQL Server 7.0 または SQL Server 2000 のインストール

Microsoft BizTalk Server 2000 をインストールする前に、Microsoft SQL Server 7.0 Service Pack 2 (SP2) または Microsoft SQL Server 2000 をインストールする必要があります。BizTalk Server 2000 をインストールすると、インストール プロシージャは、SQL Server に 4 つの BizTalk Server 2000 データベース (BizTalk メッセージ管理データベース、共有キュー データベース、追跡データベース、およびオーケストレーション データベース) を作成します。

重要

  • Microsoft Windows 2000 Professional Service Pack 1 がインストールされているコンピュータに BizTalk Server 2000 をインストールする場合は、別のコンピュータに SQL Server 7.0 Service Pack 2 (SP2) または SQL Server 2000 をインストールする必要があります。Windows 2000 Professional は、SQL Server 7.0 または SQL Server 2000 のインストールをサポートしていません。BizTalk Server 2000 のデータベースをインストールするときは、SQL Server 7.0 または SQL Server 2000 をインストールしたコンピュータの名前を指定する必要があります。

SQL Server をインストールする前に、自分のログオン アカウントが、SQL Server をインストールするコンピュータ上の Windows 2000 Administrators グループのメンバであることを確認してください。ログオン アカウントの追加の詳細については、「Administrators グループへのユーザー アカウントの追加」を参照してください。

SQL Server 2000 をインストールする場合は、混合認証を指定します。既定では、SQL Server 2000 をインストールすると、認証モードが Windows 2000 のみに設定されます。BizTalk Server 2000 は SQL 認証を使用して BizTalk メッセージ管理データベース、共有キュー データベース、および追跡データベースにアクセスするので、この設定は使用しません。BizTalk Server 2000 をインストールする前に、認証モードが混合に設定されていることを確認してください。詳細については、「SQL Server 2000 の SQL 認証モードの設定」を参照してください。

SQL Server をクラスタにインストールし、BizTalk Server 2000 を別のコンピュータにインストールする場合は、BizTalk Server 2000 がインストールされているコンピュータに SQL Server クライアント ツールをインストールする必要があります。クラスタは複数のサーバーの集合で、単一のサーバーとして動作します。詳細については、「SQL Server クライアント ツールのインストール」を参照してください。作業が終了したら、クライアント ネットワーク ユーティリティを使用して、既定のネットワーク ライブラリを名前付きパイプから TCP/IP に変更します。詳細については、「既定のネットワーク ライブラリの TCP/IP への変更」を参照してください。

SQL Server 7.0 または SQL Server 2000 をインストールするには、正確な照合順序設定を使用することが重要です。照合順序とは、データの格納および比較の方法を決定する一連の規則です。文字データは、文字の正しい順序を定義する規則に従って並べ替えられます。この規則には、文字の区別、アクセント記号、カナ文字の種類、および文字幅を指定するオプションがあります。たとえば、日本語の文字を格納するには、SQL Server をセットアップするときに文字を区別する並べ替え順序を選択すると、日本語のひらがなとカタカナが区別できます。照合順序の設定の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] または [Microsoft SQL Server 7.0] をポイントし、[Books Online] をクリックしてください。「SQL 照合順序の使用」と「Windows の照合順序並べ替えスタイル」を参照してください。

ここには次のトピックが含まれます。

  • SQL Server 7.0 または SQL Server 2000 のインストール

  • SQL Server 7.0 Service Pack 2 の確認

  • SQL Server 7.0 の SQL Service Pack 2 のインストール

  • SQL Server クライアント ツールのインストール

  • 既定のネットワーク ライブラリの TCP/IP への変更

  • SQL Server 2000 の SQL 認証モードの設定

  • SQL Server が実行中であることの確認

  • ディスク容量の不要な割り当ての回避

  • SQL Server と BizTalk Server 2000 データベース間の相互作用


SQL Server 7.0 または SQL Server 2000 のインストール

SQL Server 7.0 のインストール

  1. Microsoft SQL Server の CD を所定のドライブに挿入します。

  2. SQL Server セットアップ プログラムを実行し、インストールの説明に従います。

    セットアップ ウィザードの説明に従って SQL Server のインストールに必要な操作を行います。次の条件を満たすようにしてください。

    • [セットアップの種類] ページで [標準] をクリックします。

    • [サービス アカウント] ページで、ドメイン ユーザー アカウント (ネットワークに接続されている場合) を使用します。

重要

  • SQL Server 7.0 をインストールする場合は、SQL Service Pack 2 (SP2) をインストールする必要があります。SP2 がインストールされているかどうかは、クエリ アナライザを使用して確認できます。詳細については、「SQL Server 7.0 Service Pack 2 の確認」を参照してください。SQL SP2 のインストールの詳細については、「SQL Server 7.0 の SQL Service Pack 2 のインストール」を参照してください。

  • ひらがなとカタカナを区別するには、[セットアップの種類] ページで [カスタム] を選択し、[文字幅を区別しない] および [カタカナを区別しない] をオフにします。

SQL Server 2000 のインストール

  3. Microsoft SQL Server の CD を所定のドライブに挿入します。

  4. SQL Server セットアップ プログラムを実行し、インストールの説明に従います。

    セットアップ ウィザードの説明に従って SQL Server のインストールに必要な操作を行います。次の条件を満たすようにしてください。

    • [セットアップの種類] ページで [標準] をクリックします。

    • [サービス アカウント] ページで、ドメイン ユーザー アカウント (ネットワークに接続されている場合) を使用します。

    • [認証モード] ページで [混合モード] をクリックします。

重要

  • ひらがなとカタカナを区別するには、[セットアップの種類] ページで [カスタム] を選択し、[幅を区別する] および [かなを区別する] をオンにします。


SQL Server 7.0 Service Pack 2 の確認

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server7.0] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] ダイアログ ボックスが表示されます。

  2. [OK] をクリックします。

    使用しているサーバー名が [SQL Server] ボックスに表示されていない場合は、一覧でそのサーバー名をクリックするか、またはそのサーバー名を入力し、[OK] をクリックします。

  3. [クエリ] ボックスに「SELECT @@VERSION」と入力します。

  4. [クエリ] メニューの [実行] をクリックします。

    クエリの戻り値の最初の行に、実行中の SQL Server のバージョンが示されます。SP2 がすでにインストールされている場合は、バージョンは 7.00.842 です。


SQL Server 7.0 の SQL Service Pack 2 のインストール

  1. SQL Service Pack 2 の CD を所定のドライブに挿入します。

  2. SQL Service Pack 2 セットアップ プログラムを実行して、インストールの説明に従います。


SQL Server クライアント ツールのインストール

SQL Server をクラスタにインストールし、BizTalk Server 2000 を別のコンピュータにインストールする場合は、BizTalk Server 2000 がインストールされているコンピュータに SQL Server クライアント ツールをインストールします。

  1. Microsoft SQL Server の CD を所定のドライブに挿入します。

  2. SQL Server セットアップ プログラムを実行し、インストールの説明に従います。

    セットアップ ウィザードの説明に従って SQL Server のインストールに必要な操作を行います。次の条件を満たすようにしてください。

    • [インストールの選択] ページで [SQL Server の新規インスタンスの作成またはクライアント ツールのインストール] をクリックします。

    • [インストールの定義] ページで [クライアント ツールのみ] をクリックします。


既定のネットワーク ライブラリの TCP/IP への変更

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[クライアント ネットワーク ユーティリティ] をクリックします。

    [SQL クライアント設定ユーティリティ] ダイアログ ボックスが表示されます。

  2. Microsoft SQL Server 7.0 を使用している場合は、[全般] プロパティ ページの [無効なプロトコル] ボックスの一覧で [TCP/IP] をクリックします。

    または

    Microsoft SQL Server 2000 を使用している場合は、[ネットワーク ライブラリ] プロパティ ページの [ネットワーク ライブラリ] ボックスの一覧で [TCP/IP] をクリックします。

  3. [有効にする] をクリックします。


SQL Server 2000 の SQL 認証モードの設定

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、さらに [SQL Server グループ] を展開します。

  3. 使用しているサーバー名を右クリックし、[プロパティ] をクリックします。

    [SQL Server のプロパティ] ダイアログ ボックスが表示されます。

  4. [セキュリティ] プロパティ ページの [混合モード (Windows 認証と SQL Server 認証)] をクリックし、[OK] をクリックします。


SQL Server が実行中であることの確認

BizTalk Server 2000 をインストールする前に、使用しているサーバー上で SQL Server が実行中であることを確認します。この確認が必要なのは、BizTalk Server 2000 のインストール時に 4 つの SQL データベースが作成されるためです。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] (SQL Server 2000 をインストールした場合) または [Microsoft SQL Server 7.0] (SQL Server 7.0 をインストールした場合) をポイントし、[サービス マネージャ] をクリックします。

    [SQL Server サービス マネージャ] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスのサーバー名が、使用しているコンピュータ名になっていることを確認します。

    そうでない場合は、ドロップダウン リストの下矢印をクリックして、利用できるサーバーの一覧を参照し、使用しているサーバーが表示されるまでスクロールします。

  3. [サービス] ボックスの一覧で [MSSQLServer] (SQL Server 7.0 の場合) または [SQL Server] (SQL Server 2000 の場合) をクリックします。

  4. MSSQLServer または SQL Server のサービスが実行中であることを確認します。

    ダイアログ ボックスの [開始/再開] ボタンが使用できない状態になっていれば、このサービスは実行中です。また、このダイアログ ボックスの一番下に、このサービスが実行中であることを示すメッセージが表示されています。たとえば、SQL Server 2000 では、"実行中 - \\<servername> - MSSQLServer" というメッセージです。

  5. このサービスが実行中でない場合は、[開始/再開] ボタンが使用できる状態になっているので、そのボタンをクリックしてサービスを開始します。


ディスク容量の不要な割り当ての回避

この操作を行えるのは、BizTalk Server 2000 がインストールされている場合だけです。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server 7.0] または [Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、さらに [SQL Server グループ] を展開します。次に使用しているサーバーを展開し、[データベース] を展開します。

  3. メッセージ管理データベースを右クリックし、[プロパティ] をクリックします。

    [<メッセージ管理データベース> プロパティ] ダイアログ ボックスが表示されます。

  4. [オプション] タブをクリックします。

  5. SQL Server 7.0 の場合は [チェックポイント時のログ切り捨て] チェック ボックスと [自動圧縮] チェック ボックスをオンにし、[OK] をクリックします。SQL Server 2000 の場合は [設定] の [自動圧縮] チェック ボックスをオンにし、[OK] をクリックします。

    注

    • Microsoft SQL Server 2000 を使用している場合は、[自動圧縮] チェック ボックスのみ利用できます。
  6. 追跡データベースおよび共有キュー データベースに対しても、手順 3. ～ 5. の操作を繰り返します。

重要

  • この操作を行えるのは、BizTalk Server 2000 がインストールされている場合だけです。BizTalk Server 2000 のインストールの詳細については、「インストールに関する説明」を参照してください。

注

  • セットアップ時に、BizTalk メッセージ管理データベース オブジェクト名は既定で InterchangeBTM に、追跡データベース オブジェクト名は既定で InterchangeDTA に、共有キュー データベース オブジェクト名は既定で InterchangeSQ になります。既定のデータベース オブジェクト名は、セットアップ時に変更できます。


SQL Server と BizTalk Server 2000 データベース間の相互作用

ディスク容量の不要な割り当てを回避するには、Microsoft SQL Server 7.0 の場合は [チェックポイント時のログ切り捨て] チェック ボックス と [自動圧縮] チェックボックスをオンにします。Microsoft SQL Server 2000 の場合は [設定] の [自動圧縮] チェックボックスをオンにします。この機能を使用しないと、SQL Server ログに膨大なディスク容量が使用されることがあります。

関連項目

ディスク容量の不要な割り当ての回避


Visio 2000 SR-1 のインストール

BizTalk オーケストレーション デザイナは Microsoft Visio 2000 ベースのユーザー インターフェイスであるため、BizTalk オーケストレーション デザイナを使用するには、コンピュータに Visio 2000 Service Release 1 がインストールされている必要があります。BizTalk オーケストレーション デザイナは、Visio 2000 Standard Edition SR-1 でテストが行われたもので、そのほかのエディションや、それ以降のバージョンの Visio でも動作すると思われます。

ここには次のトピックが含まれます。

  • Visio 2000 Standard Edition SR-1 のインストール


Visio 2000 Standard Edition SR-1 のインストール

  1. Visio 2000 Standard Edition SR-1 (または、そのほかのエディションや、それ以降のバージョンの Visio 2000 Standard Edition) の CD を所定のドライブに挿入します。

  2. Visio 2000 Standard Edition SR-1 セットアップ プログラムを実行し、インストールの説明に従います。

注

  • 詳細については、Microsoft Visio 2000 Standard Edition SR-1 のドキュメントを参照してください。


インストールに関する説明

Microsoft BizTalk Server 2000 をインストールするには、インストール ウィザード (Microsoft BizTalk Server.msi) または Microsoft Windows インストーラ (Msiexec.exe) を使用します。インストール ウィザードを使用する場合は、順に操作を行って、操作ごとに特定のプロパティ値に対するオプションを選択します。Microsoft Windows インストーラを使用すると、コマンド ラインからプロパティ値を指定できます。この方法を使用すると、BizTalk Server 2000 をサイレントに (常に対話や入力を求められることなく) インストールを行うことができます。BizTalk Server 2000 のサイレント インストールは、テスト シナリオや、大規模なエンタープライズ環境への展開に使用するものとして理想的です。どの種類のインストールを実行する場合にも、後の使用のために、次の情報を記録しておいてください。

  • BizTalk Server グループ名

  • SQL Server 名

  • ユーザー名

  • パスワード

  • BizTalk メッセージ管理データベース名

  • 追跡データベース名

  • 共有キュー データベース名

  • WebDAV リポジトリの URL

重要

  • BizTalk Server 2000 では Microsoft XML Parser version 3.0 を使用します。このリリースの BizTalk Server 2000 では、Microsoft XML (MSXML) Parser version 3.0 を自動的にインストールします。MSXML パーサーのそのほかのバージョンをインストールする場合、BizTalk Server 2000 と一緒に使用すると予期しない結果が生じることがあります。

注

  • BizTalk Server 2000 のインストール時に、コンピュータ上のハードディスクの空き容量が確認されます。サーバー インストールには約 52 MB が必要です。ただし、これには BizTalk メッセージ管理データベース、追跡データベース、共有キュー データベース、およびオーケストレーション データベースに必要なハードディスク容量は含まれていません。クライアント インストールには約 30 MB のハードウェア容量が必要です。カスタム インストールには、インストールするサービスおよびツールに応じて、約 2 ～ 52 MB が必要です。ただし、これにはデータベースに必要なハードディスク容量は含まれていません。

セットアップを実行する前に、ログオン アカウントが、BizTalk Server 2000 をインストールするコンピュータの Windows 2000 Administrators グループのメンバであることを確認してください。Administrators グループへの加入の詳細については、「Administrators グループへのユーザー アカウントの追加」を参照してください。

注

  • 対話ユーザーによって BizTalk Server をインストールした場合は、ユーザーが BizTalk Server 2000 にログオンしていないと BizTalk Server が起動されません。すべての COM+ パッケージは ローカル システム アカウントではなく対話ユーザー アカウントによって実行されます。つまり、ユーザーが BizTalk Server 2000 にログオンしている場合にだけ、このサービスが開始されます。たとえば、クライアント アプリケーションがリモートで BizTalk Server 2000 にドキュメントを送信するときにユーザーが BizTalk Server 2000 にログオンしていない場合は、サービスは開始されません。このような事態を回避するには、サービス アカウントを作成するか、または、サービスを開始するユーザーにコンピュータをロックさせて、サービスが常にバックグラウンドで実行されるようにします。サービス アカウントの作成の詳細については、「サービス アカウントの作成」を参照してください。

ここには次のトピックが含まれます。

  • サーバー インストール

  • クライアント インストール

  • カスタム インストール

  • サイレント インストール

  • BizTalk Server 2000 の削除


サーバー インストール

ここでは、すべての BizTalk のサービス、ツール、およびサンプルを含めた BizTalk Server 2000 のサーバー インストールを行う方法を説明します。

ここには次のトピックが含まれます。

  • BizTalk Server 2000 のサーバー インストールの実行

  • World Wide Web Publishing Service の開始

  • BizTalk ドキュメント トラッキングのリモート インストール


BizTalk Server 2000 のサーバー インストールの実行

  1. Microsoft BizTalk Server 2000 セットアップの CD を所定のドライブに挿入します。

  2. Microsoft BizTalk Server 2000 セットアップ プログラムを実行して、インストールの説明に従います。

    重要

    • BizTalk Server 2000 セットアップ ウィザードの説明に従って BizTalk Server 2000 のインストールに必要な操作を行います。以下の各手順に示される条件を満たすようにしてください。

    • BizTalk Server 2000 では Microsoft XML Parser version 3.0 を使用します。このリリースの BizTalk Server 2000 では、Microsoft XML (MSXML) Parser version 3.0 を自動的にインストールします。MSXML パーサーのそのほかのバージョンをインストールする場合、BizTalk Server 2000 と一緒に使用すると予期しない結果が生じることがあります。
  3. [使用許諾契約書] ページで使用許諾証契約の内容を確認し、[同意します] をクリックして、[次へ] をクリックします。

    注

    • 使用許諾契約書に同意しないと、インストールを続けることはできません。
  4. [ユーザー情報] ページの [ユーザー名] ボックスにユーザーの名前を入力し、[組織] ボックスにユーザーの会社名を入力します。次に、[このコンピュータのすべての利用者 (全ユーザー)] をクリックするか、BizTalk Server 2000 へのアクセスを制限する場合は [自分のみ] をクリックし、[次へ] をクリックします。

  5. [インストール先フォルダ] ページで、ページ上に表示されているフォルダに BizTalk Server 2000 をインストールする場合は [次へ] をクリックし、それ以外の場所へインストールする場合は [変更] をクリックします。

  6. [セットアップのタイプ] ページの [サーバー] をクリックし、[次へ] をクリックします。

  7. [BizTalk Serve 管理者のアクセス権の構成] ページの [グループ名] ボックスに、使用するグループ名を入力します (既定のグループ名をそのまま使用する場合は [BizTalk Server Administrators] になります)。

    注

    • グループ名を作成するときは、次のグループ命名規則に従ってください。

    • グループ名は、コンピュータ上のほかのグループ名およびユーザー名とは異なるものにします。

    • グループ名に `、!、@、#、$、%、^、&、*、(、)、+、=、[、]、{、}、|、\\、;\"、'<、>、,、.、および ? の文字を含めることはできません。

    • グループ名をピリオド (..) またはスペースだけで構成することはできません。

    • このグループ名を変更するときは、HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups にある Windows レジストリの "AdminGroupName" の値も修正する必要があります。BizTalk Server 2000 は、このレジストリ キーに基づいてグループを検索します。
  8. [グループの説明] ボックスに、グループ名の新しい説明を入力するか、または既定の説明をそのまま使用して、[次へ] をクリックします。

  9. [BizTalk サービス ログオン プロパティ] ページで、既定の設定である [ローカル システム アカウント] をクリックするか、または [特定のアカウント] をクリックして BizTalk Server 2000 へのアクセスを特定のユーザーに限定します。

    [特定のアカウント] をクリックした場合は、[ユーザー名] ボックスに新しいユーザー名を入力するか、または既定のユーザー名をそのまま使用して、[パスワード] ボックスに有効なパスワードを入力します。

    セットアップ終了時に BizTalk サービスが自動的に開始しないようにするには、[セットアップ完了後にサービスを開始する] チェックボックスをオフにします。オーケストレーション サービス以外の BizTalk サービスが自動的に開始しないようになります。

    注

    • BizTalk Server セットアップでは、[サービスとしてログオン] の権利と [オペレーティング システムの一部として機能] の権利が、[BizTalk サービス ログオン プロパティ] ページで指定されているアカウントに付与されます。

    • [特定のアカウント] をクリックした場合は、Windows 2000 Administrators グループに属するアカウントを指定します。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。
  10. [次へ] をクリックします。

  11. [プログラムのインストールの開始] ページの [インストール] をクリックします。

    BizTalk Server 2000 のインストールには数分かかることがあります。

  12. [Microsoft BizTalk Server 2000 メッセージ データベース セットアップ ウィザードへようこそ] ページが表示されたら、[次へ] をクリックします。

    BizTalk Server 2000 データベースのセットアップで、BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースを構成するために、ログオン情報 (サーバー、データベース、ユーザー名、およびパスワード) の入力を要求するメッセージが表示されます。

    注意

    • BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースの、ストアド プロシージャやトリガなどのコードを変更しないでください。データベースに直接アクセスしたり、ストアド プロシージャを直接呼び出さないでください。データベースに対する変更は、必ず BizTalk メッセージ構成オブジェクト モデルのメソッドとプロパティを使用して行ってください。データベースの変更を直接行うと、BizTalk メッセージ構成オブジェクト モデルによる制約の多くが無視されることになり、サーバーの誤動作やデータベースの破損が発生します。
  13. [BizTalk メッセージ管理データベースを構成します] ページの [新しい BizTalk メッセージ管理データベースの作成] または [既存のデータベースの選択] をクリックし、次のテキスト ボックスにサーバー名とユーザー情報を入力します。
    • [サーバー 名]

    • [ユーザー名]

    • [パスワード]

    • [データベース]

    一意なサーバー名およびデータベース名を選択し、新しいユーザー情報を入力するか、または既定の情報をそのまま使用します。

    重要

    • Microsoft Windows 2000 Professional Service Pack 1 を実行しているコンピュータに BizTalk Server 2000 をインストールする場合は、Microsoft SQL Server 7.0 または Microsoft SQL Server 2000 をインストールした別のコンピュータの名前を [サーバー名] に入力する必要があります。

    • [新しい BizTalk メッセージ管理データベースの作成] をクリックし、既存のデータベースを選択する場合は、そのデータベースの内容を手動で削除してください。データベース内容の削除の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] または [Microsoft SQL Server 7.0] をポイントし、[Books Online] をクリックしてください。同じサーバー上の既存のデータベースと同じ名前で新しくデータベースを作成する場合は、そのデータベースの内容を手動で削除してください。BizTalk Server セットアップでは、データベースに必要なストアド プロシージャが存在するかどうかは確認されますが、データベースに必要なすべての変数が存在するかどうかは確認されません。ストアド プロシージャが存在する場合、BizTalk Server セットアップはそのデータベースを変更しません。ストアド プロシージャが存在しない場合は、そのデータベースは削除されます。次に、BizTalk メッセージ管理データベース テーブルが再初期化されます。これまでの説明は、共有キュー データベースと追跡データベースにも当てはまります。

    • BizTalk Server を 1 つ以上セットアップして、それらを BizTalk メッセージ管理データベースで集中的に管理する場合、BizTalk Server データベースの相互作用についての情報を理解しておくことを強くお勧めします。データベースの変更の詳細については、「BizTalk メッセージ管理データベースの変更」を参照してください。
  14. [次へ] をクリックします。

  15. [BizTalk Server グループの構成] ページで、BizTalk Server グループとして使用する名前を [グループ名] ボックスに入力するか、または既定のグループ名 (BizTalk Server グループ) をそのまま使用して、[次へ] をクリックします。

    [既存の BizTalk Server グループの選択] をクリックして、[グループ名] ボックスの一覧から名前を選択することもできます。

    注

    • グループ名に `、!、@、#、$、%、^、&、*、(、)、+、=、[、]、{、}、|、\\、;\"、'<、>、,、.、および ? の文字を含めることはできません。
  16. [追跡データベースの構成] ページで手順 13. の操作を繰り返して、[次へ] をクリックします。

    重要

    • [追跡データベースの構成] ページの [ユーザー名] で既定のユーザー名を変更する場合、指定するアカウントには SA レベルのアクセス許可が付与されている必要があります。このアカウントは、SQL Server ユーザー ログインを作成するために使用します。BizTalk Server をインストールしたら、BizTalk Server サービスが追跡データベースに SA レベルでアクセスするのを防ぐために、アカウントのユーザー名とパスワードを変更してください。詳細については、「サーバー グループの接続のプロパティの構成」を参照してください。または、セットアップ時に、アカウントに SA レベルのアクセス許可を設定します。SQL Server アカウントのアクセス許可変更の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックしてください。
  17. [共有キュー データベースの構成] ページで手順 13. の操作を繰り返して、[次へ] をクリックします。

  18. [BizTalk Server グループの確認] ページで、[BizTalk Server グループのプロパティ] ボックス内の情報が正確であることを確認して、[次へ] をクリックします。

  19. [Microsoft BizTalk Server 2000 メッセージ データベース セットアップ ウィザードの完了] ページで [完了] をクリックして、BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースの構成を完了します。

  20. [Microsoft BizTalk Server 2000 オーケストレーション データベース セットアップ ウィザードへようこそ] ページで、[次へ] をクリックしてオーケストレーション データベースをインストールします。

    注

    • [キャンセル] をクリックすると、BizTalk Server 2000 はインストールされますが、オーケストレーション データベースとデータ ソース名 (DSN) はインストールされません。データベースと DSN は後でインストールできます。詳細については、「新しいステータス保存データベースの作成」、「既定の XLANG スケジューラ アプリケーションの構成」、および「XLANG スケジュールをホストする COM+ アプリケーションの構成」を参照してください。
  21. [既定のオーケストレーション データベースの構成] ページの [既定のオーケストレーション データベースを新しく作成する] または [既存のデータベースの選択] をクリックします。次に、サーバー名を選択し、[データベース] テキスト ボックスにデータベース情報を入力するか、または既定の情報をそのまま使用します。

    重要

    • Windows 2000 Professional Service Pack 1 を実行しているコンピュータに BizTalk Server 2000 をインストールする場合は、SQL Server 7.0 または SQL Server 2000 をインストールした別のコンピュータの名前を [サーバー名] に入力する必要があります。

    注

    • オーケストレーション データベースは、現在のユーザーのログオン ID に基づいて作成されます。

    • SQL Server をリモートで使用するには、オーケストレーション データベースに対する適切なアクセス許可を付与されている必要があります。XLANG スケジューラ エンジンの ID を再構成していない場合は、対話ユーザー (BizTalk Server 2000 のインストール時にログオンしたユーザー) にアクセス許可が付与されます。自分で作成したサービス アカウント、またはほかの一意なユーザー アカウントに一致するように XLANG スケジューラ エンジンの ID を再構成した場合は、再構成した ID に対応するようにアクセス許可を設定する必要があります。
  22. [完了] をクリックします。

  23. Microsoft BizTalk Server 2000 セットアップ ウィザードの最終ページで、[リリース ノートの表示] をクリックして BizTalk Server 2000 についての重要な最新情報を参照してから、[完了] をクリックします。

注意

  • COM+ アプリケーションの偽装レベルは変更しないでください。既定では [偽装する] に設定されています。このセキュリティのプロパティを [匿名]、[識別する]、または [委任する] に変更すると、インストール時に問題が発生することがあります。

重要

  • BizTalk オーケストレーション サービスのパフォーマンスを大きく向上させるには、エクスプローラで Program Files\Common Files\System\ado に移動し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと ADO のスレッド モデルが "Apartment" から "Both" になります。ただし、ADO を利用するほかのアプリケーションに影響を及ぼす可能性があります。スレッドが安全でないプロバイダは使用できません。

注

  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service が実行していないと使用できません。World Wide Web Publishing Service の詳細については、「World Wide Web Publishing Service の開始」を参照してください。


World Wide Web Publishing Service の開始

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [サービス (ローカル)] をクリックします。

  3. 詳細ウィンドウで [World Wide Web Publishing Service] を右クリックし、[開始] をクリックします。


BizTalk ドキュメント トラッキングのリモート インストール

BizTalk ドキュメント トラッキングを BizTalk Server 2000 の CD からインストールすると、BizTalk ドキュメント トラッキングの Web アプリケーションにアクセスするショートカットが BizTalk Server 2000 のプログラム グループ内に作成されます。それに対して、BizTalk ドキュメント トラッキングをインターネット経由でインストールする場合は、後で Web アプリケーションへアクセスするためのショートカットまたはお気に入りを手動で作成する必要があります。また、セキュリティに関する警告のダイアログ ボックスが表示されないようにするには、Web アプリケーションを信頼するように、使用しているブラウザの設定を手動で構成します。

ここには次のトピックが含まれます。

  • Internet Explorer のセキュリティ設定の構成


Internet Explorer のセキュリティ設定の構成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Internet Explorer] をクリックします。

  2. [ツール] メニューの [インターネット オプション] をクリックします。

    [インターネット オプション] ダイアログ ボックスが表示されます。

  3. [セキュリティ] タブで [信頼済みサイト] をクリックし、[サイト] ボタンをクリックします。

    [信頼済みサイト] ダイアログ ボックスが表示されます。

  4. [次の Web サイトをゾーンに追加する] ボックスに、BizTalk ドキュメント トラッキング サーバーの場所を入力します。

    BizTalk ドキュメント トラッキング サーバーの場所を見つけるには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft BizTalk Server 2000] をポイントし、[BizTalk ドキュメント トラッキング] をクリックします。BizTalk ドキュメント トラッキング サーバーの場所が [アドレス] ボックスに表示されます。

  5. [このゾーンのサイトにはすべてサーバーの確認 (https:) を必要とする] チェック ボックスをオフにします。

  6. [追加] をクリックし、[OK] を 2 回クリックしてダイアログ ボックスを閉じます。


クライアント インストール

Microsoft BizTalk Server 2000 のクライアント インストール オプションを選択すると、BizTalk オーケストレーション デザイナ、BizTalk エディタ、BizTalk マッパー、および BizTalk Server 2000 ヘルプだけをインストールできます。

ここには次のトピックが含まれます。

  • BizTalk Server 2000 のクライアント インストールの実行


BizTalk Server 2000 のクライアント インストールの実行

  1. Microsoft BizTalk Server 2000 セットアップの CD を所定のドライブに挿入して、画面上の説明に従います。

    重要

    • セットアップ ウィザードの説明に従って BizTalk Server 2000 のインストールに必要な操作を行います。以下の各手順で示される条件を満たすようにしてください。
  2. [使用許諾契約書] ページで使用許諾証契約の内容を確認し、[同意します] をクリックして、[次へ] をクリックします。

    注

    • 使用許諾契約書に同意しないと、インストールを続けることはできません。
  3. [ユーザー情報] ページの [ユーザー名] ボックスにユーザーの名前を入力し、[組織] ボックスにユーザーの会社名を入力します。次に、[このコンピュータのすべての利用者 (全ユーザー)] をクリックするか、BizTalk Server 2000 へのアクセスを制限する場合は [自分のみ] をクリックし、[次へ] をクリックします。

  4. [インストール先フォルダ] ページで [次へ] をクリックします。

  5. [セットアップのタイプ] ページの [クライアント] をクリックし、[次へ] をクリックします。

  6. Microsoft BizTalk Server 2000 セットアップ ウィザードの [プログラムのインストールの開始] ページの [インストール] をクリックします。

  7. Microsoft BizTalk Server 2000 セットアップ ウィザードの最終ページで、[リリース ノートの表示] をクリックして BizTalk Server 2000 のこのリリースについての重要な最新情報を参照します。

  8. [完了] をクリックしてインストール処理を終了します。

重要

  • BizTalk オーケストレーション サービスのパフォーマンスを大きく向上させるには、エクスプローラで Program Files\Common Files\System\ado に移動し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと ADO のスレッド モデルが "Apartment" から "Both" になります。また、ADO を利用するほかのアプリケーションに影響を及ぼす可能性があります。

注

  • BizTalk Server 2000 インターチェンジ コンポーネントをリモート コンピュータにインストールするには、Windows 2000 COM アプリケーション エクスポート ウィザードを使用します。
    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

    2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。さらに [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

    3. [BizTalk Server Interchange Application] を右クリックし、[エクスポート] をクリックします。

      画面上の説明に従って、クライアント コンピュータ上で実行できる .msi ファイルを作成します。


カスタム インストール

Microsoft BizTalk Server 2000 のカスタム インストールのオプションを選択すると、BizTalk Server 2000 のすべての機能をインストールすることも、または必要な機能だけをインストールすることもできます。

注

  • BizTalk Server 2000 のサーバー コンポーネントをインストールする場合は、最初に Microsoft SQL Server をインストールする必要があります。詳細については、「SQL Server 7.0 または SQL Server 2000 のインストール」を参照してください。

ここには次のトピックが含まれます。

  • BizTalk Server 2000 のカスタム インストールの実行


BizTalk Server 2000 のカスタム インストールの実行

  1. Microsoft BizTalk Server 2000 セットアップの CD を所定のドライブに挿入して、画面上の説明に従います。

    重要

    • BizTalk Server 2000 セットアップ ウィザードの説明に従って BizTalk Server 2000 のインストールに必要な操作を行います。以下の各手順に示される条件を満たすようにしてください。
  2. [使用許諾契約書] ページで使用許諾証契約の内容を確認し、[同意します] をクリックして、[次へ] をクリックします。

    注

    • 使用許諾契約書に同意しないと、インストールを続けることはできません。
  3. [ユーザー情報] ページの [ユーザー名] ボックスにユーザーの名前を入力し、[組織] ボックスにユーザーの会社名を入力します。次に、[このコンピュータのすべての利用者 (全ユーザー)] をクリックするか、BizTalk Server 2000 へのアクセスを制限する場合は [自分のみ] をクリックし、[次へ] をクリックします。

  4. [インストール先フォルダ] ページで [次へ] をクリックします。

  5. [セットアップのタイプ] ページの [カスタム] をクリックし、[次へ] をクリックします。

  6. [カスタム セットアップ] ページで、画面上の説明に従って、インストールする BizTalk Server 2000 コンポーネントを選択します。

    ほかの種類のインストールを実行するには、[戻る] をクリックします。続行する場合は、[次へ] をクリックします。選択したインストール コンポーネントによっては、追加情報を入力するためのページが表示されることもあります。

  7. [プログラムのインストールの開始] ページの [インストール] をクリックします。

    BizTalk Server 2000 カスタム インストールには数分かかることがあります。

  8. Microsoft BizTalk Server 2000 セットアップ ウィザードの最終ページで、[リリース ノートの表示] をクリックして Microsoft BizTalk Server 2000 のこのリリースについての重要な最新情報を参照します。

  9. [完了] をクリックしてインストール処理を終了します。

重要

  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service が実行していないと使用できません。World Wide Web Publishing Service を開始するには、次の操作を行います。
    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

    2. コンソール ツリーで [サービス (ローカル)] をクリックします。

    3. 詳細ウィンドウで [World Wide Web Publishing Service] を右クリックし、[開始] をクリックします。
  • BizTalk オーケストレーション サービスのパフォーマンスを大きく向上させるには、エクスプローラで Program Files\Common Files\System\ado に移動し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと ADO のスレッド モデルが "Apartment" から "Both" になります。また、ADO を利用するほかのアプリケーションに影響を及ぼす可能性があります。


サイレント インストール

Microsoft Windows インストーラを使用すると、コマンド ラインからプロパティ値を指定できます。この方法を使用すると、Microsoft BizTalk Server 2000 をサイレントに (常に対話や入力を求められることなく) インストールを行うことができます。BizTalk Server 2000 のサイレント インストールは、テスト シナリオや、大規模なエンタープライズ環境への展開に使用するものとして理想的です。

ここには次のトピックが含まれます。

  • BizTalk Server 2000 のサイレント インストールの実行


BizTalk Server 2000 のサイレント インストールの実行

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに「cmd」と入力し、[OK] をクリックします。

  3. 次のように入力して BizTalk Server 2000 をサイレント インストールします。
    msiexec /I "\\server\folder\Microsoft BizTalk Server.msi"
/qb /Lv* "C:\Temp\install.log" INSTALLLEVEL=200
ALLUSERS=1
PIDKEY="your 25-character product key (without dashes)"
DSNCONFIG="C:\Temp\BizTalkInstall.ini"

重要

  • パラメータ ALLUSERS=1 を追加して、すべてのユーザーに対してインストールを実行する必要があります。また、このパラメータを追加すると、サービスからレジストリ設定を参照できるようになります。

注

  • 上のコードについて説明します。
    • /I は、製品をインストールまたは構成するコマンド ラインです。

    • /qb は、基本ユーザー インターフェイス (進行状況バーのみ) を提供するコマンド ラインです。

    • /Lv* はログ ファイルを作成します。

    • INSTALLLEVEL=200 は、サーバーをインストールします。INSTALLLEVEL を指定しないと、既定値として 100 が設定されます。この値は、BizTalk Server 2000 のクライアント インストールを指定するものです。

    • PIDKEY="your 25-character product key (without dashes)" は、プロダクト キーです。たとえば、PIDKEY=AB6CDEFGH7IJK8LMN45LLTT34 のようになります。

    • DSNCONFIG="C:\Temp\BizTalkInstall.ini" は、セットアップ ウィザードにインストール情報を提供します。

コマンド ラインでさまざまなオプションを指定して、BizTalk Server 2000 インストールのプロパティを設定することができます。値が指定されないプロパティには、既定値が適用されます。次の表は、BizTalk Server 2000 に固有のプロパティを示しています。

公開プロパティ | 値 | 説明
USERNAME (組み込みインストーラのプロパティ) | <名前> 既定 : {LogonUser} | インストールを実行するユーザーの名前です。[ユーザー情報] ダイアログ ボックスの [ユーザー名] ボックス
COMPANYNAME (組み込みインストーラのプロパティ) | <組織> 既定 : {LogonCompany} | インストールを実行するユーザーの所属先の名前です。[ユーザー情報] ダイアログ ボックスの [組織] ボックス
PIDKEY | <プロダクト ID> 既定 : "" | プロダクト キーで、形式は XXXXX-XXXXX-XXXXX-XXXXX-XXXXX です。[ユーザー情報] ダイアログ ボックスの [プロダクト キー] 編集ボックス
INSTALLLEVEL (組み込みインストーラのプロパティ) | <インストール レベル> 既定 : 100 | 機能インストール レベルです。BizTalk Server 2000 セットアップでは、100=クライアント セットアップ、200=サーバー セットアップ
INSTALLDIR (組み込みインストーラのプロパティ) | <インストール パス> 既定 : "{ProgramFiles} \Microsoft BizTalk Server" | インストール先フォルダを示します。
BTS_GROUP_NAME (サーバー インストールのみ) | <グループ名> 既定 : "BTSAdmin" | BizTalk Server 2000 Windows NT グループの名前です。[BizTalk Server 管理者のアクセス権の構成] ページの [グループ名] ボックス
BTS_GROUP_DESCRIPTION (サーバー インストールのみ) | <グループの説明> 既定 : "メンバは Microsoft BizTalk Server 2000 を完全に管理できます" | BizTalk Server 2000 NT グループの説明です。[BiｚTalk Server 管理者のアクセス権の構成] ページの [グループの説明] ボックス
BTS_USERNAME (サーバー インストールのみ) | <ユーザー名> 既定 : "" | BizTalk Server 2000 サービスのログオン ドメイン名です。[BizTalk Server サービス ログオン プロパティ] ページの [ユーザー名] ボックス
BTS_PASSWORD (サーバー インストールのみ) | <パスワード> 既定 : "" | BizTalk Server 2000 サービスのログオン パスワードです。[BiｚTalk Server サービス ログオン プロパティ] ページの [パスワード] ボックス
BTS_SERVER (サーバー インストールとクライアント インストール) | <サーバー名> 既定 : "localhost" | リモートで管理する BizTalk サーバーの名前です。[BizTalk メッセージ管理データベースを構成します] ダイアログ ボックスの [サーバー名] ボックス
BTS_SDK_SERVER (サーバー インストールとクライアント インストール) | <サーバー名> 既定 : ""localhost"" | DCOM 用に使用する BizTalk サーバーの名前です。[BizTalk Server SDK の DCOM の構成] ページの [サーバー名] ボックス
DSNCONFIG (初期化ファイル) | <パス名> 既定 : "" | 使用するデータベース セットアップ ウィザード BTSsetupDB.exe および XLANGsetupDB.exeの初期化ファイルのパスです。

注

  • DSNCONFIG プロパティは、BizTalk Server 2000 のサイレント インストールを実行するために必要です。コマンド ラインで指定した初期化パス ファイルは、BTSsetupDB.exe および XLANGsetupDB.exe データベース セットアップ ウィザードに渡されます。次のコマンド ライン値のいずれか 1 つを使用します。
    • DSNCONFIG="<BTSsetupDB.exe および XLANGsetupDB.exe の .ini ファイルへの完全なパス>"

      または

    • BTSSETUPDB.INI="<BTSsetupDB.exe の .ini ファイルへの完全なパス>" および XLANGSETUPDB.INI="<XLANGsetupDB.exe の .ini ファイルへの完全なパス>"
  • データベース セットアップ ウィザードは、次の規則を使用して初期化ファイルの内容を処理します。
    • [<セクション>] と keys= はすべてオプションです。キーが指定されない場合は、サンプルの初期化ファイルに示されている既定値が使用されます。

    • 指定した BizTalk メッセージ管理データベースに GroupName の値がある場合は、そのグループが [InterchangeDTA] セクションと [InterchangeSQ] セクションを定義するので、これらのセクションの値は無視されます。

    • 指定したデータベースが指定したサーバー上にまだ存在しない場合は、それらのデータベースが作成されます。
  • BizTalk メッセージ管理データベース セットアップとオーケストレーション データベース セットアップは相互に独立しています。

  • インストールする機能に応じて、セットアップは、次のデータベースの一方だけを構成する場合と、どちらも構成する場合と、どちらも構成しない場合があります。
    • BizTalk メッセージ管理データベース : BizTalk メッセージ サービスおよび関連するコンポーネントがインストールされている場合にだけ構成されます。

    • オーケストレーション データベース : オーケストレーション サービスがインストールされている場合にだけ構成されます。
  • コマンド ラインでは次のプロパティを使用します。
    • DSNCONFIG : BTSsetupDB.exe および XLANGsetupDB.exe によって使用される .ini ファイルの場所を指定します。

      または

      BTSSETUPDB.INI : BTSsetupDB.exe によって使用される .ini ファイルの場所を指定します。

    • XLANGSETUPDB.INI : XLANGsetupDB.exe によって使用される .ini ファイルの場所を指定します。

すべての [<セクション>]、keys=、および既定値が示されたサンプル初期化ファイル

次に、BizTalk Server 2000 のサイレント インストールに必要な .ini ファイルの書式の例を示します。これらのコマンド ライン プロパティは、Windows インストーラを使用して BizTalk Server 2000 の最初の初期化を行うときに必要になります。

SetupDB.ini の例

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Messaging Management database
; Required section used by BTSsetupDB.exe only.
; Specify new or existing database.
;
[InterchangeBTM]
Server=localhost
Username=sa
Password=
Database=InterchangeBTM

;----------------------------------------------------------------------
; Name for BizTalk Server Group
; Required section used by BTSsetupDB.exe only.
; Specify new or existing server group.
;
[Group]
GroupName=BizTalkGroup

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Tracking database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeDTA]
Server=localhost
Username=sa
Password=
Database=InterchangeDTA

;----------------------------------------------------------------------

;
[InterchangeSQ]
Server=localhost
Username=sa
Password=
Database=InterchangeSQ

;----------------------------------------------------------------------
; SQL Server connection parameters for Orchestration database
; Required section used by XLANGsetupDB.exe only.
; Specify new or existing Orchestration database.
;
[Orchestration]
Server=localhost
Database=XLANG

次の表は、サンプルの BizTalkDB.ini 初期化ファイルのプロパティ、値について説明しています。

プロパティ | 値 | 説明
[InterchangeBTM] Server=BIZTALK この第 1 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkBTM

サーバー上にこの BizTalk メッセージ管理データベースがまだ存在しない場合は、作成します。
[Group] | GroupName=BizTalkServerGroup | このグループがすでに存在している場合は、そのほかの値は無視されます。
[InterchangeDTA] Server=DTA-SERVER この第 2 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkDTA

サーバー上にこの追跡データベースがまだ存在しない場合は、作成します。
[InterchangeSQ] Server=SQ-SERVER この第 3 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkSQ

サーバー上にこの共有キュー データベースがまだ存在しない場合は、作成します。
[Orchestration] Server=localhost この第 4 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=Orchestration

サーバー上にこの XLANG データベースがまだ存在しない場合は、作成します。

Microsoft Windows インストーラのコマンド ライン オプション

Microsoft Windows インストーラ (Msiexec.exe) は、パッケージを解釈して製品をインストールするプログラムです。また、このプログラムは、戻り値として返す、Microsoft Win32® エラー コードに対応したエラー レベルも設定します。次の表は、前の表に示したプロパティおよび値に追加して使用できる、このプログラムのコマンド ライン オプションを示しています。

オプション | パラメータ | 説明
/I | <パッケージ>|<製品コード> | 製品をインストールまたは構成します。
/f | [p|o|e|d|c|a|u|m|s|v] <パッケージ>|<製品コード> | 製品を修復します。このオプションは、コマンド ラインで入力されたプロパティ値を無視します。このオプションの既定の引数一覧は pecms です。このオプションは、REINSTALLMODE プロパティと同じ引数一覧を共用します。 p : ファイルがない場合にだけ再インストールを行います。 o : ファイルがないか、または古いバージョンである場合に再インストールを行います。 e : ファイルがないか、現在と同じバージョンか、または古いバージョンである場合に再インストールを行います。 d : ファイルがないか、またはバージョンが異なる場合に再インストールを行います。 c : ファイルがないか、または格納されているチェックサムが計算値と一致しない場合に再インストールを行います。File テーブルの Attributes 列に msidbFileAttributesChecksum が設定されているファイルだけを修復します。 a : すべてのファイルを強制的に再インストールします。 u : 必要なすべてのユーザー固有レジストリ エントリを再書き込みします。 m : 必要なすべてのコンピュータ固有レジストリ エントリを再書き込みします。 s : 既存のすべてのショートカットを上書きします。 v : ソースから実行し、ローカル パッケージを再キャッシュします。
/a | <パッケージ> | 管理インストールのオプションです。ネットワーク上で製品をインストールします。
/x | <パッケージ>|<製品コード> | 製品をアンインストールします。
/j | [u|m]<パッケージ> または [u|m]<パッケージ> /t <変換一覧> または [u|m]<パッケージ> /g <言語 ID> | 製品を通知します。このオプションは、コマンド ラインで入力されたプロパティ値を無視します。 u : 現在のユーザーに通知します。 m : コンピュータのすべてのユーザーに通知します。 t : 通知されたパッケージに変換を適用します。 g : 言語 ID です。
/L | [i|w|e|a|r|u|c|m|o|p|v|+|!]<ログ ファイル> | ログ ファイルへのパスを指定します。フラグは、どの情報をログに記録するかを示します。 i : ステータス メッセージ w : 致命的ではない警告 e : すべてのエラー メッセージ a : アクションのスタートアップ r : アクション固有のレコード u : ユーザー要求 c : UI パラメータの初期値 m : メモリ不足または致命的な終了の情報 o : ディスク容量不足のメッセージ p : ターミナル プロパティ v : 詳細出力 + : 既存のファイルに追加 ! : 1 行ごとにログにフラッシュ "*" : ワイルドカード。v オプション以外のすべての情報をログに記録v オプションも含める場合は、"/l*v" と指定
/m | <ファイル名> | Systems Management Server (SMS) のステータス .mif ファイルを作成します。インストール (-i)、削除 (-x)、管理インストール (-a)、または再インストール (-f) の各オプションと一緒に使用する必要があります。Ismif32.dll は SMS の一部としてインストールされているので、パス上に存在している必要があります。 ステータス .mif ファイルの各フィールドには、次の情報が格納されています。 Manufacturer : 作成者 Product : 改訂番号 Version : 件名 Locale : テンプレート Serial Number : 設定されていません。 Installation : Ismif32.dll により "DateTime" に設定されます。 InstallStatus : "Success" または "Failed"。 Description : エラー メッセージが次の順序で格納されます。1) インストーラが生成したエラー メッセージ、2) インストールを開始できなかったか、ユーザーが終了した場合は、Msi.dll からのリソース、3) システム エラー メッセージ ファイル、4) 書式付きメッセージ。"Installer error %i"。%i は Msi.dll から返されたエラー。
/p | <修正プログラム> | 修正プログラムを適用します。インストールされている管理イメージに修正プログラムを適用するには、オプションを次のように組み合わせます。 /p <修正プログラム> /a <パッケージ>
/q | n|b|r|f | ユーザー インターフェイス レベルを設定します。 q、qn : UI なし qb : 基本 UI qr : インストールの最後にモーダル ダイアログ ボックスが表示される簡略 UI qf : 最後にモーダル ダイアログ ボックスが表示される完全 UI qn+ : 最後にモーダル ダイアログ ボックスが表示されることを除いて UI なし qb+ : 最後にモーダル ダイアログ ボックスが表示される基本 UIユーザーがインストールをキャンセルすると、モーダル ダイアログ ボックスは表示されません。 qb- : モーダル ダイアログ ボックスが表示されない基本 UI/qb+- は、サポートされている UI レベルではありません。
/? または /h |  | Windows インストーラの著作権情報を表示します。
/y | <モジュール> | システムの API DllRegisterServer を呼び出して、コマンド ラインで渡されたモジュールを自動登録します。たとえば、msiexec /y my_file.dll のように入力します。 このオプションは、.msi ファイルのレジストリ テーブルを使用して追加できないレジストリ情報に対してだけ使用します。
/z | <モジュール> | システムの API DllUnRegisterServer を呼び出して、コマンド ラインで渡されたモジュールの登録を解除します。たとえば、msiexec /z my_file.dll のように入力します。 このオプションは、.msi ファイルのレジストリ テーブルを使用して削除できないレジストリ情報に対してだけ使用します。

注

  • 上の表について説明します。
    • オプション /i、/x、/f[p|o|e|d|c|a|u|m|s|v]、/j[u|m]、/a、/p、/y、および /z は、一緒に使用しないでください。この規則の唯一の例外は管理インストールに修正プログラムを適用する場合で、/p と /a を一緒に使用します。

    • オプション /t および /g と一緒に使用できるのは、/j だけです。

    • オプション /l および /q は、/i、/x、/f[p|o|e|d|c|a|u|m|s|v]、/j[u|m]、/a、および /p と一緒に使用できます。

プロパティおよび値の構文規則

コマンド ラインを使用して変更できるのは、公開プロパティだけです。コマンド ラインで入力されるプロパティ名はすべて大文字として解釈されますが、値は大文字と小文字が区別されます。コマンド ラインに「MyProperty」と入力すると、インストーラは、Property テーブルの MyProperty という値ではなく MYPROPERTY という値を上書きします。PROPERTY を VALUE に設定して製品をインストールするには、コマンド ラインで次の構文を使用します。プロパティは、オプションとその引数との間を除いた任意の位置に入力できます。

正しい構文は次のようになります。

msiexec /i A:\Example.msi PROPERTY=VALUE

次の構文は正しくありません。

msiexec /i PROPERTY=VALUE A:\Example.msi

プロパティ値がリテラル文字列の場合は、引用符で囲む必要があります。引用符に囲まれた文字列には空白を含めることができます。

msiexec /i A:\Example.msi PROPERTY="Embedded White Space"

コマンド ラインを使用して公開プロパティを消去するには、その値を空の文字列に設定します。

msiexec /i A:\Example.msi PROPERTY=""

テキストの一部がリテラル引用符で囲まれている場合は、その部分をさらに引用符で囲んでください。

msiexec /i A:\Example.msi PROPERTY="Embedded ""Quotes"" White Space"

複雑なコマンド ラインの例を次に示します。

msiexec /i testdb.msi INSTALLLEVEL=3 /l* msi.log COMPANYNAME="Acme ""Widgets"" and ""Gizmos."""

通知オプションの例を次に示します。スイッチは大文字と小文字が区別されません。

msiexec /JM msisample.msi /T transform.mst /G langid /LIME logfile.txt

Microsoft Windows インストーラの詳細については、MSDN™ ダウンロードの Web サイト (msdn.microsoft.com/downloads/) を参照してください。


BizTalk Server 2000 の削除

Microsoft BizTalk Server 2000 を削除するには、Microsoft Windows 2000 の [アプリケーションの追加と削除] の機能を使用します。

ここには次のトピックが含まれます。

  • BizTalk Server 2000 の削除


BizTalk Server 2000 の削除

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

  3. [Microsoft BizTalk Server 2000] をクリックし、[削除] をクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  4. BizTalk Server 2000 の削除を確認するメッセージが表示されたら [はい] をクリックします。


セキュリティについて

Microsoft BizTalk Server 2000 を使用すると、企業は取引先とデータを安全に交換できます。BizTalk Server では、Microsoft Windows 2000 および Microsoft SQL Server のセキュリティ機能を活用しています。

Windows 2000 のセキュリティ機能は次のとおりです。

  • 公開キー基盤

  • Microsoft コンポーネント サービス

  • Microsoft CryptoAPI (暗号化アプリケーション プログラム インターフェイス)

  • スマート カード

  • Kerberos プロトコル

公開キー証明書の管理としては、証明書の要求、証明書の要求に対する応答での証明書の処理、取引先との証明書の交換などがあります。公開キー証明書は、デジタル署名および暗号化のいずれにも利用できます。証明書を交換することにより、取引先と交換するデータの安全性を確保できます。ただし、企業の拡大に伴い、証明書の管理にも時間がかかるようになります。

BizTalk Server では、Secure Sockets Layer (SSL) など、Windows 2000 のセキュリティ機能を利用しているので、取引先は Web ページを作成および使用して、インターネットでデータを安全に交換できます。SSL とは、インターネット インフォメーション サービス (IIS) で実装されたプロトコルで、Web クライアントと Web サーバーとの間で秘密を保持できるように設計されたものです。SSL は相互に使用できる暗号アルゴリズムから使用するものを決定するハンドシェイク フェーズから始まり、公開キーと秘密キーを確認し、サーバーからクライアントへの認証を行います。ハンドシェイクが完了し、アプリケーション データの転送が開始されると、ハンドシェイク中に決定したセッション キーを使ってデータをすべて暗号化します。公開キー基盤 (PKI) というオープンな標準、および IPSec、L2TP、SSL/TLS、S/MIME などのセキュリティで保護されたプロトコルのサポートにより、ネットワークを仕入先や取引先まで迅速に拡張でき、また、偽装、データの盗難、悪意のあるハッカーから防御することができます。

Windows 2000 の管理ツールの 1 つであるコンポーネント サービスでは、データの整合性を保護する自動トランザクション サポート、および簡潔で強力なロール ベースのセキュリティなど、総合的なコンポーネント機能を提供しています。

ここには次のトピックが含まれます。

  • BizTalk Server 2000 セットアップと構成

  • トランスポート サービス

  • XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

  • 証明書の概要

  • CryptoAPI (Microsoft 暗号化アプリケーション プログラム インターフェイス)

  • Collaborative Data Objects (CDO)

関連項目

管理者特権


BizTalk Server 2000 セットアップと構成

取引先とのトランザクションは、セキュリティで保護されたものである必要があります。Microsoft BizTalk Server 2000 では、Microsoft Windows 2000 のセキュリティ サービスを利用した認証と暗号化のコンポーネントをいくつか提供して、セキュリティに対応しています。さらに、Windows 2000 のセキュリティだけでなく、Microsoft SQL Server のセキュリティも利用しています。BizTalk メッセージ管理データベースのデータを保護するために、BizTalk Server では、主に SQL Server ログオン セキュリティを使用しています。ただし、BizTalk オーケストレーションのステータス保存データベースでは、既定では Windows 2000 の認証を使用しています。スケジュール インスタンス用のホストにする COM+ コンポーネントとそのステータス保存データベースを作成する場合は、SQL Server の認証と Windows 2000 の認証のどちらを使用するかを選択できます。また、管理コンソールでは、Windows 2000 のセキュリティで利用できる Windows Management Instrumentation (WMI) も使用されています。

ここには次のトピックが含まれます。

  • ログオンのプロパティ

  • ローカル ポリシー

  • サービス アカウントの使用

  • 作業項目の送信


ログオンのプロパティ

ログオンのプロパティは、BizTalk Server 2000 のセキュリティの第一層となります。このプロパティにより、特定のコンピュータへユーザーがログオンする権利が制御されます。ログオンのプロパティによって、ユーザーはファイル共有やメッセージ キューなどのリソースにアクセスする場合に、ユーザー名とパスワードを入力することを求められます。HTTP や SMTP で受信したメッセージでも、セキュリティにログオンのプロパティが使用されています。たとえば、HTTP で ASP ページにアクセスしたユーザーは、Web ページのコンテンツを表示する前にユーザー名とパスワードの入力を求められることがあります。

BizTalk Server では、受信機能にインターネット インフォメーション サービス (IIS) および ASP ページを使用しています。ASP ページ (実際はページの背後に隠されているコード) は、Secure Sockets Layer (SSL) からの署名を確認し、IIS を経由して証明書などの追加セキュリティを最大化することにより、BizTalk Server のセキュリティの層を提供しています。IIS セキュリティの詳細については、Windows 2000 のヘルプの「インターネット インフォメーション サービス」を参照してください。

関連項目

管理者特権


ローカル ポリシー

[ローカル セキュリティ設定] コンソールの [ローカル ポリシー] では、ユーザー アカウントまたはサービス アカウントのセキュリティ オプションを指定します。ローカル ポリシーは、ユーザーがログオンしているコンピュータと、そのコンピュータに対してユーザーが所有している権利を基にしています。ローカル ポリシーを設定するには、[スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。それから [ローカル セキュリティ ポリシー] をダブルクリックし、[ローカル ポリシー] フォルダを展開します。

ローカル ポリシーでは、BizTalk Server 2000 ユーザーの権限と権利を定義します。次のものを構成できます。

  • 監査ポリシー : コンピュータのセキュリティ ログに記録するセキュリティ イベント (試行の成功または失敗あるいはその両方) を指定します。セキュリティ ログは、イベント ビューアにあります。

  • ユーザーの権利の割り当て : コンピュータに対してログオン権限や操作権限を持つユーザーまたはグループを指定します。

  • セキュリティ オプション : データのデジタル署名、アカウント名 Administrator と Guest、フロッピー ドライブと CD-ROM へのアクセス、ドライバのインストール、ログオン時のメッセージなど、コンピュータの各種セキュリティ設定を有効または無効にします。

[ローカル セキュリティ設定] コンソールにあるほかのポリシーを構成して、データの整合性を維持できます。たとえば、アカウント ポリシーでは次のものを構成できます。

  • パスワードのポリシー : ローカル ユーザー アカウントに対して、パスワードの制限の強制や有効期間などを設定します。

  • アカウントのロックアウトのポリシー : ローカル ユーザー アカウントに対して、ロックアウトの期間やロックアウトの対象を設定します。

重要

  • ローカル ポリシーは、定義上は、コンピュータに対してローカルとなります。ローカル ポリシーの設定を Active Directory のグループ ポリシー オブジェクトにインポートすると、そのグループ ポリシー オブジェクトが適用されるコンピュータのアカウントのローカル セキュリティ設定が影響を受けます。したがって、セキュリティ ポリシーの優先順位に注意することが重要です。ローカル レベルで設定されたポリシーは、グループ ポリシー (組織単位) に関連付けられたセキュリティ ポリシーによって上書きされます。また、ドメインのポリシーによっても上書きされます。いずれの場合も、ユーザー アカウントの権利は、ローカル ポリシーの設定で上書きされると、適用されなくなります。Microsoft Windows 2000 での動作は Microsoft Windows NT のものとまったく異なるため、注意が必要です。たとえば、ドメイン グループ ポリシーに既定のままのパスワード ポリシーを構成すると、このドメインのすべてのコンピュータにこのパスワード ポリシーが適用されます。つまり、このドメイン内の各ワークステーションのローカル アカウント データベースのパスワード ポリシーは、ドメインのパスワード ポリシーと同じになります。

注

  • 公開キーのローカル ポリシーは設定しないでください。公開キーにより、BizTalk Server のセキュリティが保護されています。公開キーは、データの暗号化と暗号解読に使う証明書のコンポーネントです。公開キーにポリシーを追加すると、BizTalk Server では関連付けられた証明書を使用できなくなります。

関連項目

管理者特権


サービス アカウントの使用

サービス アカウントは、ユーザーがコンピュータやネットワーク リソースにアクセスできる点で、対話ユーザー アカウントと似ています。サービス アカウントとは、オペレーティング システムの一部として機能するための特定のプロパティを備えた通常のユーザー アカウントです。一方、対話ユーザー アカウントとは、BizTalk Server 2000 のセットアップ処理中にログオンしているユーザーのことです。

アカウントが対話ユーザーに設定されていると、アプリケーションが動作するのはユーザーがログインしているときだけとなります。このため、対話ユーザー アカウントによって BizTalk Server をセットアップした場合、このユーザーがサーバーからログオフすると、BizTalk Server の動作に障害が発生します。対話ユーザー アカウントを選択することには、セキュリティの危険が伴いますが、それは、ログオンしているユーザーの認識も同意もなく、そのアカウントでアプリケーションが実行されるからです。たとえば、管理者がログオン中のコンピュータでアプリケーションが実行されている場合、そのアプリケーションは管理者のアカウントで実行されることになり、クライアントの代わりに呼び出しを行うことがあります。

アカウントをサービス アカウントに設定すると、オペレーティング システムの一部として機能するため、コンピュータにログオンしていないユーザーでもサーバー上のアプリケーションにアクセスできます。

サービス アカウントの詳細については、「サービス アカウントの作成」を参照してください。

関連項目

サービス アカウントの作成


作業項目の送信

作業項目を BizTalk Server 2000 に送信するユーザーの権限を制御するには、BizTalk Server インターチェンジ アプリケーション COM+ コンポーネントを使用します。BizTalk Server インターチェンジ アプリケーション COM+ コンポーネントでは、次のセキュリティ構成プロパティを使用しています。

  • 認証レベル

  • 偽装レベル

  • アクセス許可

  • 起動アクセス許可

  • 構成アクセス許可

作業項目を送信するユーザーの権限を制御するには、まず、COM+ アプリケーションの 1 つである BizTalk Server インターチェンジ アプリケーションにロールを追加し、次に、このロールを Submit メソッドおよび SubmitSync メソッドに関連付けます。

ここには次のトピックが含まれます。

  • BizTalk Server インターチェンジ アプリケーションへのロールの追加

  • Submit メソッドおよび SubmitSync メソッドへの新しいロールの関連付け

関連項目

管理者特権


BizTalk Server インターチェンジ アプリケーションへのロールの追加

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

    [コンポーネント サービス] コンソールが表示されます。

  2. [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [BizTalk Server Interchange Application] を右クリックし、[プロパティ] をクリックします。

    [BizTalk Server Interchange Application のプロパティ] ダイアログ ボックスが表示されます。

  4. [詳細設定] タブをクリックして [許可] の [変更を許可しない] チェック ボックスをオフにし、[OK] をクリックします。次に、メッセージ ダイアログ ボックスで [はい] をクリックします。

  5. 手順 3. を繰り返します。

  6. [セキュリティ] タブをクリックし、[アクセス権限] の [このアプリケーションへのアクセス チェックを行う] チェック ボックスをオンにします。

  7. [セキュリティ レベル] で、[プロセスおよびコンポーネント レベルでのアクセス チェックを実行する。セキュリティのプロパティはオブジェクトのコンテキストに含まれます。COM+ セキュリティ呼び出しのコンテキストが利用できます]をクリックします。

  8. [OK] をクリックします。

  9. 確認ダイアログ ボックスで、[はい] をクリックします。

  10. [BizTalk Server Interchange Application] を展開します。

  11. [ロール] フォルダをダブルクリックし、このフォルダを右クリックします。次に、[新規作成] をポイントし、[ロール] をクリックします。

    [ロール] ダイアログ ボックスが表示されます。

  12. ロールに付ける名前を入力し、[OK] をクリックします。

  13. 確認ダイアログ ボックスで、[はい] をクリックします。

  14. 作成したロールを展開し、[ユーザー] フォルダをダブルクリックして、このフォルダを右クリックします。次に [新規作成] をポイントし、[ユーザー] をクリックします。

  15. [ユーザーまたはグループの選択] ボックスに、追加するユーザーのフル ネームを入力します。

  16. ユーザー アカウントをロールに追加したら、[OK] をクリックします。

注

  • ロールに割り当てられたユーザー アカウントまたはグループそれぞれのアイコンが [ユーザー] フォルダに表示されます。アプリケーションが起動すると、新しいロールのメンバシップは有効になります。

関連項目

BizTalk Server インターチェンジ アプリケーションのシャットダウン


Submit メソッドおよび SubmitSync メソッドへの新しいロールの関連付け

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

    [コンポーネント サービス] コンソールが表示されます。

  2. [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開し、[BizTalk Server Interchange Application] を展開します。さらに [コンポーネント] を展開し、[BizTalk.Interchange.1] を展開し、[インターフェイス] を展開します。[IInterchange] を展開し、[メソッド] を展開します。

  3. [Submit] を右クリックし、[プロパティ] をクリックします。

    [Submit のプロパティ] ダイアログ ボックスが表示されます。

  4. [セキュリティ] タブをクリックします。

  5. [選択された項目に明示的に設定されたロール] で、「BizTalk Server インターチェンジ アプリケーションへのロールの追加」の手順で作成したロールのチェック ボックスをオンにし、[OK] をクリックします。

  6. [SubmitSync] を右クリックし、[プロパティ] をクリックします。

    [SubmitSync のプロパティ] ダイアログ ボックスが表示されます。

  7. [セキュリティ] タブをクリックします。

  8. [選択された項目に明示的に設定されたロール] で、「BizTalk Server インターチェンジ アプリケーションへのロールの追加」の手順で作成したロールのチェック ボックスをオンにし、[OK] をクリックします。

注

  • BizTalk Server インターチェンジ アプリケーションの新しいロールを作成してから、そのロールを Submit メソッドと SubmitSync メソッドに関連付けてください。

関連項目

BizTalk Server インターチェンジ アプリケーションのシャットダウン


トランスポート サービス

Microsoft BizTalk Server 2000 では、コア セットのトランスポート サービスをサポートしています。このトランスポート サービスにより、アプリケーションが COM インターフェイスを使ってサーバーと直接通信できるかどうかに関係なく、サーバーは組織またはアプリケーションにドキュメントを送信できます。BizTalk Server は、HTTP、HTTPS、および SMTP の各ネットワーク プロトコルと、メッセージ キューをサポートしています。

ここには次のトピックが含まれます。

  • HTTP と HTTPS

  • SMTP

  • メッセージ キュー 2.0

  • ファイル

関連項目

トランスポートの種類の選択

トランスポートのプロパティの設定


HTTP と HTTPS

HTTPS は、HTTP で Web のコンテンツにアクセスする場合に、強力な認証機能を提供するために使用されます。HTTPS の最も一般的な用途は、認証された Web サーバーへの接続を暗号化することです。https:// で始まる URL の参照によって通常開始される HTTPS 接続をクライアントが確立しようとする場合、クライアントとサーバーは使用するセキュリティ プロトコルを共同でネゴシエートしてから、認証情報を交換します。

Microsoft Internet Explorer 5 以降では、HTTP トランザクション用に、セキュリティで保護された、次のような共通の通信プロトコルをサポートしています。

  • Transport Layer Security (TLS version 1.0)

  • Secure Sockets Layer (SSL version 2 と 3)

  • Private Communications Technology (PCT version 1.0)

上記の各プロトコルは、交換するデータの秘密保持用の暗号化サービスと、クライアントとサーバーの間の相互認証用の認証サービスを提供しています。組み込みの HTTPS トランスポート サービスで提供されている SSL のサポートによって、インターチェンジにはサーバー間の認証とトランスポート層の暗号化の機能が備えられています。

BizTalk Server と HTTPS を使用することにより、HTTP を介して組織内で、または取引先との間で、データを安全に交換できます。次に、HTTP と HTTPS を使用した BizTalk Server 2000 でのデータの送受信について、詳細に説明します。

送信

HTTP および HTTPS トランスポート サービスは、アプリケーションおよび取引先に送信されるデータを保護するために使用します。これらのトランスポート サービスのセキュリティは、証明書に依存します。

たとえば、HTTP でデータを送信する前に、BizTalk Server の管理者はクライアント証明書のコピーを取引先に送信します。取引先は、この証明書のコピーを BizTalk ストアで保持します。これ以降、この証明書はデータを送信する取引先を認証する場合に使用されます。取引先に証明書を送信またはエクスポートする場合は、一意な証明書マネージャを作成する必要があります。

受信

HTTP 上でデータを保護するために、BizTalk Server では Microsoft インターネット インフォメーション サービス (IIS) と ASP ページを使用しています。HTTPS を使用して IIS に接続する場合、クライアントとサーバーは、チャネルをセキュリティで保護するための共通のプロトコルをネゴシエートします。サーバーとクライアントに共通のプロトコルがいくつかある場合、IIS では、SSL などのサポートされているプロトコルを使用してチャネルをセキュリティで保護します。BizTalk Server が HTTP で受信したデータを保護する場合も、処理は同様です。ASP ページは、BizTalk Server にデータを送信する場合のゲートウェイとして機能します。データがセキュリティで保護されている場合、呼び出しのために ASP コードで Submit メソッドまたは SubmitSync メソッドが使用されていると、BizTalk Server はデータを受信します。

関連項目

トランスポートの種類の選択

トランスポートのプロパティの設定


SMTP

SMTP (Simple Mail Transfer Protocol) は、サーバー間で電子メール メッセージを送信するプロトコルです。インターネットでのメール送信によく使われているプロトコルです。電子メール クライアントでの電子メール メッセージの取得には、POP または IMAP が使用されています。また、SMTP は、メール クライアントからメール サーバーへのメッセージ送信にも使用されています。電子メール アプリケーションを構成する場合は、POP サーバーまたは IMAP サーバーと、SMTP サーバーの両方を指定する必要があります。

SMTP を使用することにより、組織内で、または取引先との間で、データを安全に交換できます。BizTalk Server 2000 では、SMTP を使用して次の方法でデータの送受信を行います。

送信

BizTalk Server では、SMTP でデータを送信するためのトランスポート プロトコルを実装しています。SMTP では、少なくともデータを MIME エンコードする必要があります。このエンコード処理により、BizTalk Server では、データ セットの終了と、次のデータ セットの開始を識別できます。ただし、MIME エンコードにはセキュリティ機能がありません。S/MIME は、セキュリティで保護された MIME のバージョンです。組み込みの S/MIME エンコード コンポーネントを使用してエンコードされたドキュメントでは、ドキュメントの整合性の確保、送信元の認証、およびペイロードの暗号化が行われます。BizTalk Server で作成される S/MIME ドキュメントでは、その本文が暗号化メッセージになります。このセキュリティ機能を利用できるようにするには、MIME エンコード メッセージに証明書を関連付けます。MIME エンコードを指定できるのは、BizTalk メッセージ マネージャでメッセージ ポートを作成する場合です。また、BizTalk メッセージ マネージャでは、証明書も指定できます。

受信

Microsoft Exchange Server を使用して SMTP の受信側にセキュリティを実装するには、管理者が BizTalk Server 用の受信アカウントを作成します。アカウントが設定されると、取引先は公開キーを Exchange Server に送信し、そこで送信者 (取引先) の認証が行われます。公開キーは、Exchange Server の証明書ストアに保存されます。

Exchange Server がメッセージを受信すると、Submit メソッドによりデータが BizTalk Server に送信されます。BizTalk Server では証明書を公開キーと比較して確認し、一致する場合はデータを暗号解読してドキュメントを処理します。

関連項目

メッセージ ポートの要素

トランスポートの種類の選択

暗号化証明書の選択

トランスポートのプロパティの設定


メッセージ キュー 2.0

メッセージ キュー 2.0 では、次のものを使用して秘密保持とセキュリティをサポートしています。

  • アクセス制御

  • 監査

  • 暗号化

  • 認証

さらにメッセージ キューでは、Windows 2000 で利用できる Kerberos V5 セキュリティ プロトコルも利用しています。また、40 ビット暗号化だけでなく 128 ビット暗号化もサポートしています。また、メッセージ キューを使用すると、アプリケーションを統合し、プッシュ型のビジネス イベント配信環境をアプリケーション間に実装し、信頼性は高くなくてもコスト効率のよいネットワーク上に、信頼性の高いアプリケーションを実装できます。

メッセージ キューを使用することにより、組織内で、また取引先との間で、データを安全に交換できます。BizTalk Server 2000 では、メッセージ キューを使用して次の方法でデータの送受信を行います。

送信

メッセージ キューに対するセキュリティの第一層となるのは、ユーザー名とパスワードです。メッセージ キューに対してデータの格納または取得をするユーザーは、ユーザー名とパスワードを要求されます。また、メッセージ キューには、証明書が関連付けられたデータを格納することもできます。ユーザーは、BizTalk メッセージ マネージャを使用して、メッセージ キューに格納されているデータに証明書を指定できます。

受信

管理者がメッセージ キュー用のログオンのプロパティを作成すると、データを取得するためにはユーザー名とパスワードが必要になります。ログオンのプロパティの作成で、セキュリティの基盤が構築されます。取引先がデータに証明書を付けた場合、BizTalk Server でこのパッケージを処理するには、まずデータの暗号解読用の秘密キーのコピーを受信する必要があります。

関連項目

メッセージ キュー受信機能の追加

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

メッセージ キュー受信機能の構成 : [全般] タブ

メッセージ キュー受信機能の構成 : [サービス] タブ

トランスポートの種類の選択

トランスポートのプロパティの設定


ファイル

Microsoft Windows 2000 では、任意のファイルのアクセス制御を定義することにより、データとシステムを保護できます。BizTalk Server 2000 で必須となっている Windows NTFS ファイル システムを使用すると、重要なシステム ファイルやアプリケーション ファイルの損傷を防止できます。さらに NTFS では、アプリケーションのサポート ファイル用のセキュリティも強化されています。

ファイル記憶域を使用することにより、組織内で、また取引先との間で、データを安全に交換できます。また、ファイル記憶域を使用して、次の方法でデータの送受信ができます。

送信

ファイル記憶域のセキュリティの第一層となるのは、ユーザー名とパスワードです。フォルダに対してデータの格納または取得をするユーザーは、ユーザー名とパスワードを要求されます。また、フォルダには、証明書が関連付けられたデータを格納することもできます。この強化されたセキュリティの機能を利用するには、BizTalk メッセージ マネージャを使用して、フォルダに格納するデータに証明書を作成します。

受信

フォルダにログオンのプロパティが適用されている場合は、データを取得するためにはユーザー名とパスワードが必要になります。管理者は、読み取りや削除などのアクセスレ ベルを特定ユーザー用のファイル ディレクトリに指定することもできます。取引先がデータに証明書を付けた場合、BizTalk Server でこのパッケージを処理するには、まずデータの暗号解読用の秘密キーのコピーを受信する必要があります。受信ドキュメントにデジタル署名も付けると、送信元はドキュメントを送信したことを否定できなくなります。

関連項目

ファイル受信機能の追加

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [全般] タブ

ファイル受信機能の構成 : [サービス] タブ

トランスポートの種類の選択

トランスポートのプロパティの設定


XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

BizTalk オーケストレーション サービスをインストールすると、次のことに対してセキュリティ レベルを設定できます。

  • 新しい XLANG スケジュール インスタンスの作成

  • 既存の XLANG スケジュール インスタンスの操作

  • XLANG スケジュール インスタンスに関連した管理機能

  • XLANG スケジュール インスタンスをホストするアプリケーション

XLANG スケジュール インスタンス用のホストであるアプリケーションでは、ロール ベースのセキュリティを使用します。このセキュリティは COM+ で提供される自動サービスです。ロール ベースのセキュリティを使用して、ユーザーは COM+ アプリケーションのアクセス制御ポリシーを作成および実施できます。ロール ベースのセキュリティは、柔軟性と拡張性に優れたセキュリティ構成モデルを採用しているため、コンポーネント内ですべてのセキュリティを実施場合と比較すると、多くの利点があります。既定の COM+ アプリケーションには、XLANG スケジューラと XLANG スケジューラ永続化ヘルパの 2 種類があります。この 2 つのアプリケーションは、BizTalk オーケストレーション サービスのインストール時に自動的に作成されます。XLANG スケジューラ COM+ アプリケーションには、4 つのロールがあります。これらのロールを使用して、スケジューラ インスタンスが実行される COM+ アプリケーションに関係なく、それらのスケジューラ インスタンスのセキュリティを確保できます。この 4 つのロールは次のとおりです。

  • XLANG スケジュール作成者 : このロールにより、指定されたユーザーは XLANG スケジュール インスタンスを作成できます。たとえば、XLANG スケジュール インスタンスを作成させるためには、管理者はユーザーをこのロールのメンバシップの一覧に追加します。このロールのメンバに登録されていないユーザーが XLANG スケジュール インスタンスを作成しようとすると、アクセスが拒否されたことを示すエラー メッセージが表示されます。また、アクセスが拒否されたことを示すエントリがイベント ログに記録されます。

  • XLANG スケジュール ユーザー : このロールにより、指定されたユーザーは XLANG スケジュール インスタンスを操作できます。たとえば、スケジュールのインスタンスをユーザーに操作させるためには、管理者はユーザーをこのロールのメンバシップの一覧に追加します。このロールのメンバに登録されていないユーザーがスケジュールのインスタンスを操作しようとすると、アクセスが拒否されたことを示すエラー メッセージが表示されます。また、アクセスが拒否されたことを示すエントリがイベント ログに記録されます。

  • XLANG スケジューラの管理者 : このロールは、次の作業の管理者権限を持つユーザーを指定するために使用します。
    • COM+ アプリケーションを XLANG スケジュール インスタンス用のホストとして機能できるようにするかどうかを指定する。

    • XLANG スケジュール インスタンス用のホストとする COM+ アプリケーションの DSN の種類、および COM+ アプリケーションでサポートする必要のある永続化レベルのステータス管理値を設定する。

    • すべての XLANG スケジュール インスタンスをシャットダウンする。

    • XLANG スケジュール インスタンスの中断、再開、終了を行う。
  • XLANG スケジューラ アプリケーション : このロールは、ユーザーが作成する COM+ アプリケーションを操作するために XLANG スケジューラで使用されます。したがって、このロールには、COM+ アプリケーションの実行に使用するのと同じ ID を指定する必要があります。

ここには次のトピックが含まれます。

  • COM+ アプリケーションをセキュリティで保護する方法

  • オーケストレーション データベースのセキュリティ保護

  • 送信元 ID の確認

関連項目

XLANG スケジュール


COM+ アプリケーションをセキュリティで保護する方法

ロールを使用することにより、管理者は管理を目的としてアプリケーションの認証ポリシーを作成し、どのリソースにどのユーザーがアクセスできるかを指定できます。この指定は、必要に応じてメソッド レベルで行うことができます。COM+ サーバー アプリケーションはすべての XLANG スケジュール用のホストであるため、インストールされている COM オブジェクトへのアクセスを制限するには、各ロールのセキュリティのプロパティを構成します。

重要

  • セキュリティのプロパティをコンポーネント レベルで追加すると、それぞれのレベルでのロールの設定に基づいたコンポーネント、インターフェイス、およびメソッドも制限されます。COM+ のセキュリティの詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) にある COM+ Security のページを参照してください。

COM+ アプリケーションのセキュリティに関する推奨事項

次の推奨事項は、主に導入済みアプリケーションをセキュリティで保護する場合に有効です。

  • 対話ユーザーとして COM+ アプリケーションを構成しない。対話ユーザーの ID を使用する COM+ アプリケーションは、アプリケーションが常駐するコンピュータにユーザーがログオンしている場合にだけ使用することができます。ログオンしているユーザーがいない場合は、COM+ アプリケーションを実行することはできません。また、ユーザーが対話ユーザーとして COM+ アプリケーションを作成すると、ステータス保存データベースとそのリソースへのアクセスを構成することが、より困難になります。サービス アカウントの詳細については、「サービス アカウントの使用」を参照してください。

  • XLANG スケジューラの ID を再構成する。セットアップ中に、XLANG スケジューラの ID は、対話ユーザーとして自動的に構成されます。この構成は、多くの開発者にとって便利です。運用システムでは、XLANG スケジューラが一意なユーザー ID で動作するようにスケジューラの ID のプロパティを変更してください。この ID は、XLANG スケジューラが送信するすべてのメッセージで使用されます。

    注

    • Microsoft Windows 2000 ターミナル サービス クライアントを使用して XLANG スケジュールを開始する場合、XLANG スケジューラ エンジン用のホストである COM+ アプリケーションの ID は、Windows 2000 の有効なユーザー名またはグループ名に対して設定する必要があります。COM+ アプリケーションの ID は、そのアプリケーションのプロパティのダイアログ ボックスの [ID] プロパティ ページで設定します。ターミナル サービスでホストされているセッションを通じて XLANG スケジューラ エンジンを使用している場合は、ID を対話的に設定することはできません。
  • 新しい COM+ アプリケーションを作成する場合は、XLANG スケジュール インスタンス用のホストにするアプリケーションごとに一意な ID を設定する。COM+ アプリケーションを作成する場合は、購買などのビジネス プロセスごとに一意なセキュリティ要件を設定します。これにより、アプリケーションごとにセキュリティ レベルを設定できるようになります。また、不安定なアプリケーション コードによって発生する大きな障害を防止でき、個々のアプリケーションの動作も監査しやすくなります。

  • アプリケーション固有のコンポーネントを関連ビジネス プロセスにインストールする。これにより、データは保護され、これらのコンポーネントへのアクセスが許可されていないアプリケーションは拒否されます。ただし、サーバー アプリケーションは適切に保護されます。

    注

    • 各 COM+ アプリケーションには、コンポーネントを少なくとも 1 つは組み込む必要があります。アプリケーション固有のコンポーネントがインストールされていない場合は、アプリケーションのプレースホルダ コンポーネントを作成し、インストールする必要があります。このようにしないとアプリケーションは利用できません。
  • XLANG スケジューラ ロールのメンバシップの一覧を既定の設定から変更して、セキュリティを強化する。BizTalk Server をインストールすると、XLANG スケジューラが作成され、次のような既定の設定を持つロールで構成されます。
    • XLANG スケジュール作成者 : メンバシップのロールは、既定では Everyone です。

    • XLANG スケジュール ユーザー : メンバシップのロールは、既定では Everyone です。

    • XLANG スケジューラの管理者 : メンバシップのロールは、既定では Administrators です。

    • XLANG スケジューラ アプリケーション : メンバシップのロールは、既定では Everyone です。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

XLANG スケジュールをホストする COM+ アプリケーションの作成

XLANG スケジュール


オーケストレーション データベースのセキュリティ保護

XLANG スケジュール インスタンス用のホストにする COM+ アプリケーションを作成したら、ステータス保存データベースをその COM+ アプリケーションに関連付ける必要があります。それには、まず Microsoft SQL Server にステータス保存データベースを作成します。データベースを作成する場合、セキュリティに SQL Server 認証と Microsoft Windows 2000 認証のどちらを使用するかを指定する必要があります。データベースを作成したら、後で XLANG スケジュール インスタンス用のホストとして作成する COM+ アプリケーションにアクセス許可を与えます。COM+ アプリケーションには、テーブルを作成するアクセス許可と、そのテーブルに関連付けられたステータス保存データベースにプロシージャを作成するアクセス許可の両方を割り当ててください。BizTalk オーケストレーション サービスと既定の BizTalk Server オーケストレーション データベースの間の対話は、SQL Server ではなく Windows 2000 のセキュリティ モデルに基づいています。

関連項目

既定の XLANG スケジューラ アプリケーションおよびデータベースの管理


送信元 ID の確認

スケジュールの作成時には、さまざまなシェイプを使用して、ビジネス プロセスのポートの実装に用いる実装テクノロジを記述できます。COM コンポーネント シェイプは、送受信される各メッセージへのメソッド呼び出しによってポートを実装する技術です。スクリプト コンポーネント シェイプは、送受信される各メッセージへのメソッド呼び出しによってポートを実装する技術です。メッセージ キュー シェイプは、ポートを実装するのに使用する技術です。メッセージ キュー トランスポート サービスは、メッセージの送受信に使用します。これらの 3 つの技術のうちの 1 つを適用すると、メッセージを受信する前に必ず送信者の ID を確認するように設定できます。

XLANG スケジュール用の COM コンポーネント、Windows スクリプト コンポーネント、およびメッセージ キューのセキュリティの詳細については、「COM コンポーネントを使用したポートの実装」、「Windows スクリプト コンポーネントを使用したポートの実装」、および「メッセージ キューを使用したポートの実装」を参照してください。

関連項目

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

スクリプト コンポーネント シェイプの使用


証明書の概要

デジタル証明書は、暗号化キーをユーザーの 1 つまたは複数の属性と結合します。証明機関が発行した証明書により、ネットワーク メッセージの信頼性が確保され、インターネットが保護されます。この技術、およびその基盤となるデジタル署名により、インターネットでの電子商取引の普及が進んでいます。

ここには次のトピックが含まれます。

  • 証明書について

  • BizTalk Server で必要な証明書

  • 証明書の名前の制限


証明書について

Microsoft BizTalk Server 2000 では、セキュリティの大部分を証明書に頼っています。データを暗号化する公開キーと、データを暗号解読する秘密キーを使用することにより、BizTalk Server では信頼できるデータを送信し、処理するデータを安全なものにすることができます。Microsoft 管理コンソールにある公開キーのポリシーを使用して、暗号化ファイル システム (EFS) 用の暗号化されたデータの回復エージェント、ドメイン全体のルート証明機関、信頼された証明機関などを構成できます。証明書にはデジタル署名も含まれます。この署名はドキュメントに適用され、また、BizTalk Server のデジタル署名のネイティブ サポートによって、受信ドキュメントで確認されます。

証明書は、インターネットなどのようにセキュリティで保護されていないネットワークでの情報交換を認証し、保護するために使用するものです。証明書は、ユーザー、コンピュータ、およびサービスごとに管理できます。Windows 2000 Server に組み込まれている X.509 ベースの公開キー証明書サーバーにより、組織では、商用の証明機関 (CA) のサービスに頼らずにユーザーに対し認証用の公開キー証明書を発行できます。

BizTalk Server では BizTalk メッセージ マネージャを使用して証明書をサポートしています。証明書により、データの暗号化、暗号解読、およびデジタル署名を容易に行うことができます。BizTalk Server トランスポート サービスを使用して送信されるすべてのドキュメントで、公開キー暗号化テクノロジがサポートされます。また、BizTalk Server は、受信するドキュメントの暗号解読と署名検証をサポートします。

MachineKey と UserKey

証明書を取得する場合、現在ログオンしているユーザーに関連付けられている UserKey より、コンピュータに関連付けられている MachineKey を使用することをお勧めします。現在サーバーにログオンしているユーザーが UserKey を使用して証明書を取得すると、証明書の UserKey にユーザーのログオン情報が含まれるため、そのユーザーしか証明書にアクセスできません。このため、BizTalk Server で UserKey を使用して証明書にアクセスする必要がある場合、そのユーザーで BizTalk Server を実行する必要があります。任意のユーザーが BizTalk Server にログオンしてキーにアクセスできるようにするには、証明書に MachineKey が必要です。

BizTalk Server が証明書 (ローカル コンピュータ) にアクセスするには、BizTalk Server は LocalSystem または Administrator として実行されている必要があります。また、UserKey を使用する場合は、そのユーザーで BizTalk Server を実行し、かつそのユーザーは管理者である必要があります。


BizTalk Server で必要な証明書

証明書サーバーは、ユーザー単位およびコンピュータ単位で証明書を格納します。各ユーザーには証明書ストアが 1 つ、各コンピュータには専用の証明書ストアが複数あります。Windows 2000 では、ユーザーが作成した証明書はユーザーのものと見なされます。組織は、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある個人ストアに証明書を格納する必要があります。ただし、セキュリティを適切に確保するには、BizTalk Server 2000 は、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある BizTalk ストアにすべての取引先証明書を格納する必要があります。

証明書の作成では、メッセージ ポートとチャネルを作成したら、証明書はすべてをユーザー自身ではなく、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある BizTalk ストアと関連付ける必要があります。BizTalk メッセージ マネージャで取引先に対して暗号化や署名検証などのセキュリティを指定する場合、表示される証明書は、BizTalk ストアに格納されている取引先証明書です。SSL クライアントに対して検証済み暗号の解読や検証済み署名などのセキュリティを指定すると、BizTalk メッセージ マネージャは、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある個人ストアに格納されている証明書を表示します。証明書が格納される場所が重要なのは、実行時にユーザーが BizTalk Server でドキュメントを処理しようとするときに、コンピュータがバックグラウンド サービスとして動作していて、証明書にアクセスするのはこのサービスであるからです。

証明書の格納先をどこにするかという問題には、次の 2 通りの解決方法があります。

  • ユーザーが既に証明書を作成している場合は、Windows 2000 では証明書はユーザー ストアに格納されます。それらの証明書をユーザー ストアから [証明書 (ローカル コンピュータ)] の下にある対応するストアに移動する必要があります。この処理は証明書マネージャによって行われます。

  • ユーザーがサービス アカウントを作成した場合は、証明書はすべて、ユーザーではなくコンピュータに関連付けられます。

Windows 2000 による証明書の管理

BizTalk Server では、Microsoft Windows 2000 によって証明書が管理されています。Windows 2000 セキュリティ モデルに密接に統合された IIS 5.0 には、証明書サーバーが組み込まれています。これにより、組織ではインターネット標準の X 509 デジタル証明書の発行と管理を行うことができます。IIS 5.0 では、主な管理サービス以外にも、Microsoft 証明書サーバーがデジタル証明書の発行と管理を行うカスタマイズ可能なサービスを提供しています。証明書サーバーは、インターネット、企業イントラネット、およびセキュリティで保護されていないネットワークでの通信を安全なものにするソフトウェア セキュリティ システムの管理において、中心的な役割を果たしています。

ここには次のトピックが含まれます。

  • 証明書マネージャの作成

関連項目

送信の署名証明書の選択

受信ドキュメントの暗号解読を確認する証明書の選択

受信ドキュメントの署名を確認する証明書の選択

暗号化証明書の選択


証明書マネージャの作成

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に「mmc」と入力し、[OK] をクリックします。

    [コンソール1] ダイアログ ボックスが表示されます。

  2. [コンソール] メニューの [スナップインの追加と削除] をクリックします。

    [スナップインの追加と削除] ダイアログ ボックスが表示されます。

  3. [追加] をクリックします。

    [スタンドアロン スナップインの追加] ダイアログ ボックスが表示されます。

  4. [証明書] をクリックし、[追加] をクリックします。

    [証明書スナップイン] ダイアログ ボックスが表示されます。

  5. [コンピュータ アカウント] をクリックし、[次へ] をクリックします。次に [完了] をクリックし、[閉じる] をクリックします。それから [OK] をクリックしてダイアログ ボックスを閉じます。

関連項目

証明書の概要


証明書の名前の制限

Microsoft BizTalk Server 2000 では、証明書の名前の重複は許可されていません。同じ名前の証明書が複数存在する場合、BizTalk メッセージ マネージャでは、そのうちの 1 つの証明書だけが選択されます。たとえば、組織に同じ名前と参照を持つ証明書が 2 つあっても、両方の証明書を使用できるわけではありません。一方の証明書を使う場合、もう一方の証明書は、[チャネル] ウィザードの中の利用可能な証明書の一覧に表示されなくなります。


CryptoAPI (Microsoft 暗号化アプリケーション プログラム インターフェイス)

Microsoft BizTalk Server 2000 では CryptoAPI を使用して、処理するデータをセキュリティで保護します。最近の暗号化テクノロジの発達により追加された用途として、ネットワーク上のユーザーの認証、送信した情報の整合性の確保、および送信元による送信メッセージの所有権否定の防止のための各種メカニズムがあります。

暗号化を使用し、また、証明書生成のために Microsoft Windows 2000 などの Microsoft 独自の暗号化を使用するアプリケーション、メッセージ、データなどでは、いずれも CryptoAPI が使用されています。BizTalk Server では、プリプロセス コンポーネントなど、独自に作成した COM+ コンポーネントを使用するときにユーザーが指定する受信機能に CryptoAPI を使用します。これによって BizTalk Server では独自の暗号化コンポーネントを扱えるようになります。


Collaborative Data Objects (CDO)

Microsoft BizTalk Server 2000 では、送信と受信のいずれの場合でも、すべてのデータを MIME エンコードする必要があります。Windows 2000 に組み込まれている Collaborative Data Objects (CDO) を使用すると、BizTalk Server でデータをエンコードして処理ができます。たとえば、BizTalk Server で、テキストとグラフィックスを含むカタログを送信する場合は、まずデータ (グラフィックス) をバイナリから文字列に変換する必要があります。CDO は、テキストとグラフィックスを文字列形式に変換し、BizTalk Server で処理できるようにします。


パフォーマンスとスケーラビリティの強化

BizTalk Server 2000 のさまざまなコンポーネントについて理解すると、スケーラブルでハイ パフォーマンスなソリューションを作成できるようになります。潜在的なボトルネックの発見、待ち時間の解消、データベースの管理など、BizTalk Server のパフォーマンスを向上させる方法はいくつかあります。ただし、最適なソリューションを得るための作業の量は、組織のシステム アーキテクチャの複雑さや、予算によって異なります。

BizTalk Server のパフォーマンスを最適化するうえで重要となるのは、BizTalk メッセージ管理データベース、共有キュー データベース、追跡データベース、およびオーケストレーション データベースを最適化することです。データベース最適化の詳細については、「データベースのスケール アップ」と「データベースのスケール アウト」を参照してください。

ここには次のトピックが含まれます。

  • BizTalk Server の拡張

  • パフォーマンスの最適化


BizTalk Server の拡張

パフォーマンスを最適化するには、主なコンポーネントを複数のサーバーに分散することが重要です。BizTalk Server 2000 の主要コンポーネントとしては、次のものが挙げられます。

  • BizTalk サービス : ここに含まれるサービスとしては、BizTalk メッセージ サービスやBizTalk オーケストレーション サービスなどがあります。詳細については、「BizTalk サービス」を参照してください。

  • データベース : このようなデータベースとしては、BizTalk メッセージ管理、追跡、共有キュー、およびオーケストレーションの各データベースがあります。

  • トランスポート サービス : トランスポート サービスには、HTTP、ファイル、SMTP、メッセージ キューなどがあります。拡張のための要件は、コンポーネントごとに異なります。

ここには次のトピックが含まれます。

  • BizTalk Server の垂直方向拡張

  • BizTalk Server の水平方向拡張

関連項目

BizTalk Server データベースの管理

BizTalk メッセージ管理データベースの管理

永続化

トランスポートのプロパティの設定

共有キュー データベース

追跡データベース


BizTalk Server の垂直方向拡張

複数のプロセッサと大量のメモリを使用すると、BizTalk Server 2000 を垂直方向に拡張 (スケール アップ) できます。BizTalk Server を垂直方向に拡張すると、サーバーの数を減らし、サイト管理を簡略化することができますが、システムを水平方向に拡張したり、ソフトウェア アーキテクチャを改良するよりもコストがかかります。また、既存のハードウェアの容量を限界まで高めたら、次はシステムの水平方向拡張が必要になります。

ここには次のトピックが含まれます。

  • BizTalk Server のスケール アップ

  • データベースのスケール アップ

  • トランスポート サービスのスケール アップ


BizTalk Server のスケール アップ

BizTalk Server 2000 を垂直方向に拡張するには、次のような方法があります。

  • プロセッサを、大容量の L2 キャッシュを備えた Pentium III や、その派生プロセッサの Xeon などにアップグレードします。

  • 最大で 8 個までの CPU を備えた Symmetric Multiple Processing (SMP) サーバーを使用します。

  • ファイルの入出力やネットワークに関するボトルネックを解決します。

  • Microsoft Windows 2000 Server を 4 個の CPU を備えた SMP サーバー上で実行します。

    注

    • Microsoft Windows 2000 Server を 1 個の CPU で実行している場合に CPU を 3 個増設すると、パフォーマンスは向上しますが、1 個の場合の 4 倍の処理速度になるわけではありません。

BizTalk Server の垂直方向拡張でお勧めする方法

BizTalk Server で最適なパフォーマンスを得るための推奨環境は、次のとおりです。

  • CPU を 8 個までアップグレードできる、Pentium III Xeon マルチプロセッサ システム。クロック周波数が高いほどパフォーマンスが向上します。

  • 1 ～ 2 MB の L2 プロセッサ キャッシュ。解析のパフォーマンスが向上します。

  • 512 MB の RAM。組織でメガバイト (MB) 規模のドキュメントを複数処理する場合は、より多くの RAMを実装してください。

  • 100 MB/s (メガバイト/秒) スイッチのポートに接続した、スループット 100 Mbps (メガビット/秒) 以上の複数のネットワーク カード。ネットワークの入出力スループットが向上します。

  • メッセージ キューと分散トランザクション コーディネータ (DTC) のファイルおよびログを扱うための、複数のディスクとディスク コントローラ。DTC のログを中央のリモート サーバーに書き込むことで、ローカルの BizTalk Server におけるファイル入出力の競合を削減します。

  • BizTalk Server でデュアル ホームのネットワーク インターフェイス カード (NIC) を使用。共有キュー データベースおよび BizTalk メッセージ管理データベースを処理する SQL Server プロセスと、HTTP プロセスとを分離します。

  • これらの推奨環境は、BizTalk Server のみがインストールされたサーバーで BizTalk Server を実行することを前提としています。BizTalk サービスが、ほかのアプリケーション サービスとサーバーを共有している場合は、ハードウェアをさらに強化することをお勧めします。


データベースのスケール アップ

データベースを垂直方向に拡張するには、ディスクの構成を決定する必要があります。ディスク構成を決定するには、スループット、フェールオーバー (障害復旧性)、およびコストについて考慮する必要があります。

次の表は、利用できる選択肢を示し、それらを互いに比較したものです。

RAID レベル | コスト | 実質的なディスク使用率 | 速度 | フォールト トレランス
0 (ストライピング) | 低 | 100 | 高速 | 低
1 (ミラーリング) | 高 | 50 | 中程度 | 高
5 (パリティ付きストライピング) | 中 | 実質的なディスク容量 : アレイを構成するディスクの台数から 1 台 (パリティ用) を引いた台数の、合計ディスク容量 | 低速 | 中 (ディスクに障害が発生しても、パフォーマンスが低下するのみ)

最高のパフォーマンスを得るには、高速な CPU と大容量の不揮発性 RAM を備えた、キャッシュ付き Redundant Array of Independent Disks (RAID) コントローラをインストールすることをお勧めします。また、複数の RAID レベルを組み合わせると、必要なだけのパフォーマンスを得ることができます。たとえば、RAID 0 では最高のパフォーマンスが得られますが、フォールト トレランスは利用できません。RAID 1 では最高レベルのフォールト トレランスが得られますが、複数のディスクに同時にデータを書き込むのではなく、1 つのディスクに書き込むため、パフォーマンスは高くありません。最高のパフォーマンスを得るには、RAID 1 と RAID 0 を組み合わせます。そのためには、ストライピングを適用したディスク セットをミラーリングします。

注

  • 速度とコストに関しては、RAID 5 よりもほかの RAID レベルの方が優れています。RAID 5 には大きな利点がありますが、データの書き込みは RAID 0 および RAID 1 よりも低速です。

  • どのような方式を採用する場合でも、使用可能なディスク コントローラの数が重要な意味を持ちます。ディスク 1 台ごとにコントローラを 1 基ずつ使用すると、全体のパフォーマンスが大幅に向上します。ディスクを構成する場合は、ディスク チャネルを効率的に使用することも重要です。ディスク チャネルとは、1 つのコントローラを共有するディスクのことです。このようなディスクは、単一のディスクとして構成されることも、ディスク アレイの一部として動作するように構成されることもあります。たとえば、サーバーに 10 台のディスクがあり、2 つのアレイに 5 台ずつ配置され、各アレイはそれぞれ専用のコントローラに接続されているとします。この場合は、ディスク チャネルは 2 つになります。

理想的なのは、BizTalk メッセージ管理、共有キュー、追跡、およびオーケストレーションの各データベースを、それぞれ別のディスク チャネルに接続することです。組織のシステム環境によっては、データベースをそれぞれ別のサーバーに配置しなければならない場合があります。配置を計画するには、各データベースの使用方法を理解しておくことが重要です。

  • BizTalk メッセージ管理データベースには、組織、サーバー グループ、サーバー、チャネル、メッセージ ポートなど、BizTalk Ssrver に関するすべての構成情報が格納されています。この情報は、読み取られると Microsoft SQL Server のメモリにキャッシュされます。このデータベースは 4 つのデータベースについて必要最小限の利用状況を受信するもので、必要に応じて、ほかの 3 つのデータベースのいずれか 1 つと同じディスク チャネルに配置できます。

  • 共有キュー データベースは、あらゆるキューのデータを管理します。非同期通信を使用するドキュメントは、すべて共有キュー データベースに送信され、格納されます。BizTalk Server でドキュメントを処理する準備が整うと、そのドキュメントは共有キュー データベースから削除され、処理されます。共有キュー データベースはあらゆるトランザクションを管理しているため、このデータベースに対しては、データの書き込みと読み取りが頻繁に行われます。

  • 追跡データベースは、サーバーをパススルーするドキュメントを個別の処理とバッチ処理の両方について追跡します。このデータベースには、データと、データのログ記録の両方が格納されます。このため、追跡データベースでは、データの書き込みは頻繁に発生しますが、読み取りはほとんど行われません。

  • オーケストレーション データベースには、XLANG スケジュールの構造とアクティブな XLANG スケジュール インスタンスの進行状況が格納されるほか、XLANG スケジュール インスタンスがトランザクションを開始または完了した場合や、システムがシャットダウンした場合、または XLANG スケジュール インスタンスがステータス退避を実行した場合に送受信されるメッセージも格納されます。

データベースの垂直方向拡張の最適化でお勧めする事項

BizTalk Server データベースで最高のパフォーマンスを得るためには、次のような環境を整えることを検討してください。

  • CPU を 8 個までアップグレードできる、Pentium III Xeon マルチプロセッサ システム。クロック周波数が高いほどパフォーマンスが向上します。

  • 512 MB の RAM。組織でメガバイト (MB) 規模のドキュメントを複数処理する場合は、より多くの RAMを実装してください。

  • 一般的なデータベース管理方法に基づいて、基礎となる Microsoft SQL Server のデータベースとログを最適化します。SQL Server の詳細については、[スタート] メニューの [プログラム] をポイントし、[Microsoft SQL Server] をポイントして、[Books Online] をクリックしてください。

  • 最初は少数のトランザクションしか処理しないという計画を立てている場合は、複数のデータベースを同一のディスク入出力チャネルにインストールしてもかまいません。処理するトランザクションの量が増えたら、サーバーにディスクやコントローラを増設し、データベースをその新しいディスク入出力チャネルに移動します。また、各データベースを新しいサーバーに移動することも可能です。データベースの水平方向拡張については、「データベースのスケール アウト」を参照してください。

BizTalk メッセージ管理データベースを最適化するには、次のような方法があります。

  • データベースを、共有キュー データベースまたは追跡データベースと同じディスク入出力チャネルにインストールします。BizTalk メッセージ管理データベースの内容は、読み取られると Microsoft SQL Server のメモリにキャッシュされます。

  • 組織内に、処理対象のデータが大量にある場合は、このデータベースを専用のディスク入出力チャネルに配置し、共有キュー データベースまたは追跡データベースのパフォーマンスの低下を防ぎます。

共有キュー データベースを最適化するには、次のような方法があります。

  • CPU の使用率が 80% を超える場合は、CPU を追加します。

  • ディスク キューの長さの平均が 1 を超える場合や、ディスク入出力使用率が 100% を超える場合は、ハード ディスクを追加します。

  • データベースを、専用のディスク入出力チャネルにインストールします。

  • アクセスが高速なディスク、およびスループットの高いコントローラを購入します。

  • フォールト トレランスを実装する場合は、RAID 0 およびミラーリングの導入を検討します。

追跡データベースを最適化するには、次のような方法があります。

  • ハード ディスクを増設し、共有キュー データベースで使用するディスク領域を現在よりも大きくします。

  • 単一のトランザクションにおける平均的なドキュメント サイズを見積もります。そのドキュメント サイズに、ドキュメントが追跡データベースのログに記録される回数を掛けます。この値は、1 つのドキュメントを追跡データベースに格納するために必要となる、ドキュメント格納領域の大きさを表します。ドキュメント格納領域の値に必要なスループットの値を掛けると、追跡データベースに必要な容量がわかります。追跡データベース用の領域として、平均的なサイズのドキュメントに関するログを格納できるだけの容量を確保してください。

  • このデータベースには大量のデータが書き込まれるため、専用のディスク入出力チャネルにインストールします。トランザクションの量が多い環境では、ディスクの入出力チャネルを分離することは特に重要です。

    注

    • インターチェンジとドキュメントの追跡にはサイズに制限があり、制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

オーケストレーション データベースを最適化するには、次のような方法があります。

  • このデータベースではデータの書き込みと読み取りが頻繁に行われるため、専用のディスク入出力チャネルが必要です。可能な場合には必ず、アクセスが高速なディスク、およびスループットの高いコントローラを購入します。フォールト トレランスを実装する場合は、RAID 0 およびミラーリングの導入を検討します。

  • CPU の使用率が 80% を超える場合は、CPU を追加します。

  • ディスク キューの長さの平均が 1 を超える場合や、ディスク入出力使用率が 100% を超える場合は、ハード ディスクを追加します。

関連項目

BizTalk Server の拡張


トランスポート サービスのスケール アップ

BizTalk Server 2000 では、4 つのトランスポート サービスをサポートしています。これらのトランスポート サービスは、垂直方向に拡張することが可能です。

  • HTTP

  • ファイル

  • SMTP

  • メッセージ キュー

ここには次のトピックが含まれます。

  • HTTP/HTTPS (スケール アップ)

  • ファイル (スケール アップ)

  • SMTP (スケール アップ)

  • メッセージ キュー (スケール アップ)


HTTP/HTTPS (スケール アップ)

受信

HTTP/HTTPS 受信機能は、BizTalk Server のインターチェンジ オブジェクトを呼び出すことで、BizTalk Server 2000 にドキュメントを送信します。BizTalk Server には、独自の HTTP/HTTPS 受信機能はありません。HTTP 受信機能はローカル オブジェクトを呼び出します。このため、パフォーマンスがネットワーク待ち時間の影響を受けることはありません。ただし、HTTP 受信機能と BizTalk Server が同じサーバーに存在しているため、HTTP 受信機能は、データ トランスポートとデータ処理という 2 つの処理を実行する必要があります。

データ量の多い環境では、HTTP 受信機能と BizTalk サービスを同じサーバーで実行すると、どちらのパフォーマンスも低下します。また、ドキュメントの受信では Secure Sockets Layer (SSL、HTTPS とも呼ばれる) が利用されるため、暗号の解読処理によってパフォーマンスがさらに低下します。組織のセキュリティ ニーズに応じて、HTTPS を使用してデータを暗号化しなければならない場合もあります。このように、セキュリティ レベルを上昇させると BizTalk Server のパフォーマンスが影響を受けます。

送信

BizTalk Server は、ネイティブの HTTP/HTTPS クライアントです。送信トランスポート サービスで HTTP/HTTPS を使用するようにチャネルを構成している場合、BizTalk Server は HTTP/HTTPS を使用して取引先の HTTP/HTTPS サーバーにデータを送信します。BizTalk メッセージ サービスを実行しているサーバーから、HTTP/HTTPS 送信トランスポート サービスを別のサーバーに移動することはできません。作業項目の処理に参加するように構成されているサーバーがあり、そのサーバーが HTTP/HTTPS トランスポート サービスを使用するドキュメントを処理する場合は、そのサーバーがドキュメントを送信します。作業項目の処理の詳細については、「BizTalk Server のスケール アップ」を参照してください。

BizTalk Server は HTTP クライアントとして機能するため、サーバーのドキュメント シリアライズ能力が影響を受けます。ポートが HTTPS を使用している場合は、HTTP トランスポート サービスのパフォーマンスが大幅に低下します。SSL アクセラレータ カードでは HTTPS サーバーのパフォーマンスしか向上しないため、HTTPS クライアントとして動作している場合は SSL アクセラレータ カードを使用できません。

HTTP/HTTPS の最適化でお勧めする方法

HTTP/HTTPS のパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • 受信用の HTTP/HTTPS 受信サービスを、BizTalk Server を実行するサーバー以外のサーバーに構成します。BizTalk Server を実行するサーバー以外のサーバーにインストールできない場合は、高速な CPU を使用するか、CPU を増設してください。

  • BizTalk Server での送信ドキュメントの増加に対応できるように、CPU をクロック周波数の高いものに交換し、CPU を増設して必要なレベルのパフォーマンスが得られるようにします。

  • HTTP/HTTPS サービスを利用した送受信で ASP ページを使用する場合は、最良の方法について検討してください。ASP ページとインターネット インフォメーション サービスを最適化する方法については、インターネット インフォメーション サービスのヘルプ (localhost/iisHelp) で、[Active Server Pages ガイド] をクリックしてください。


ファイル (スケール アップ)

受信

ファイル受信機能は、企業間のトランザクションで利用すると高いパフォーマンスを得ることができますが、インターネットをベースとしたトランザクションで利用するにはセキュリティ保護が不十分なため、あまり使用されません。ただし、社内のアプリケーション間トランザクションであればセキュリティ上の危険も少ないため、その優れたパフォーマンスを活用することができます。また、SMTP や HTTP などのほかの受信機能と組み合わせた場合には、外部の取引先との間で、セキュリティを低下させることなく使用できます。SMTP および HTTP 受信機能では、セキュリティ保護のために HTTPS または S/MIME を使用して取引先からドキュメントを受け取り、ファイルを内部のファイル システムのディレクトリに書き込みます。その後の BizTalk Server によるドキュメントの受信でファイル受信機能を使用することができます。このトランスポートの組み合わせでは、パフォーマンスは向上しませんが、柔軟性とセキュリティを高めることができます。

注

  • S/MIME を使用すると、BizTalk Server のパフォーマンスが大幅に低下します。

送信

ファイル受信機能で説明したセキュリティとパフォーマンスの関係は、ファイル トランスポート サービスを使用してドキュメントを送信する場合にも当てはまります。

ファイル受信機能およびファイル トランスポート サービスの最適化でお勧めする方法

ファイル受信機能とファイル トランスポート サービスのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • リモートのファイル ディレクトリではなくローカルのファイル ディレクトリを使用して、ネットワークの待ち時間を少なくします。

  • ディスク アレイを使用して、スループットを向上させます。ディスク アレイの速度と冗長性とのトレードオフについては、「データベースのスケール アップ」を参照してください。


SMTP (スケール アップ)

受信

SMTP 受信機能は、BizTalk Server にはネイティブの SMTP 受信機能が組み込まれていないという点で、受信トランザクション用の HTTP 受信機能に似ています。SMTP 受信機能は、イベント ベースのメカニズムによってドキュメントを受信し、そのドキュメントを BizTalk Server に送信します。SMTP 受信機能を使用すると、MIME/SMIME エンコードされたドキュメントを受信し、前処理を行うことができます。

送信

S/MIME を利用した受信と HTTP/HTTPSを利用した送信で説明したセキュリティとパフォーマンスの関係は、ここでも当てはまります。メッセージ ポートまたはポートのトランスポート サービスとして、チャネルで SMTP を使用している場合、処理サーバーはドキュメントを処理し、それを受信アプリケーションに送信します。

注

  • 送信ドキュメントを S/MIME エンコードするためにデジタル証明書が必要となる場合は、BizTalk Server のパフォーマンスが大幅に低下します。

SMTP の最適化でお勧めする方法

SMTP のパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • 必要なレベルのパフォーマンスが得られるかどうかは、ドキュメントの受信で使用する SMTP サービスに大きく左右されます。組織には、通常は SMTP サービス機能を実行する SMTP サーバーが用意されています。SMTP サーバーを使用しない環境で Microsoft Exchange Server またはサード パーティ製のメッセージ システムを使用することにした場合、BizTalk Server が十分なレベルのパフォーマンスを維持するためには、BizTalk Server を実行するサーバーにかなりパフォーマンスの高いハードウェアを実装する必要があります。SMTP サーバーは、イベント ベースのメカニズムを呼び出すことで BizTalk Server にドキュメントを送信できるようになっている必要があります。

  • SMTP サーバー上で BizTalk Server を実行すると、CPU の処理能力が低下します。パフォーマンスの低下を抑えるには、高速な CPU を使用してください。

  • S/MIME を使用すると、BizTalk Server のパフォーマンスが大幅に低下します。S/MIME による BizTalk Server の全体的なパフォーマンスへの影響を抑えるには、高速な CPU を使用してください。


メッセージ キュー (スケール アップ)

受信

一般に、メッセージ キューはメッセージの送受信で大量のディスク入出力を行います。メッセージ キューはトランザクションを利用しているため、フォールト トレランスの向上に非常に役立ちます。ただし、トランザクションを利用するのはローカル サーバーの場合だけです。フォールト トレランスを向上させるためにメッセージ キューを使用する場合は、増加したディスク入出力の処理用に、各 BizTalk Server コンピュータに十分な数のディスクを設置する必要があります。

送信

メッセージ キューを使用してドキュメントを送信する場合も、メッセージ キューを使用してドキュメントを受信する場合と同様のセキュリティおよびパフォーマンス上の問題が発生します。

メッセージ キューの最適化でお勧めする方法

メッセージ キューのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • トランザクション キューと高速なディスク入出力チャネルを使用します。受信用のトランザクション キューには、リモート キューではなく、BizTalk Server 上のローカル キューを使用する必要があります。ローカル キューなら Active Directory を照会する必要はありませんが、ネットワークを流れるメッセージ キューは Active Directory を照会する必要があります。したがって、ローカルのメッセージ キューでデータの読み取りと書き込みを行うとパフォーマンスが向上します。非トランザクション ローカル キューを使用すると、パフォーマンスがさらに向上します。ただし、非トランザクション ローカル キューは、トランザクション キューほど信頼性が高くありません。また、より多くのメモリを必要とします。

    注

    • メッセージ キューを使用するために必要なハードウェア環境については、Windows 2000 Server ヘルプの「メッセージ キュー サーバーのハードウェアを選択する」を参照してください。
  • メッセージ キューの最大サイズは 4 MB です。ドキュメントのサイズが 4 MB を超える場合は、メッセージ キュー トランスポート サービスを使用できません。オーケストレーションのステータス保存データベースでは、ドキュメントのサイズは 2 MB までという制限があります。

  • ジャーナルを使用すると、メッセージ キューによるデータベースへの負担が大きくなります。メッセージ キュー トランスポート サービスを設定する場合は、データベースを最適化する際の標準的な手順に従って、データベースを最適化しておいてください。

  • スループットを最大限まで高めるには、データとログを分離し、複数のディスクとコントローラを使用します。


BizTalk Server の水平方向拡張

BizTalk Server 2000 の実装では、理想的には垂直方向と水平方向 (スケール アウト) の両方の拡張を行います。垂直方向に拡張すると、必要なサーバーの数が減少します。水平方向に拡張すると、次のような利点があります。

  • パフォーマンスの向上 : 単一のサーバーによって得られるものを超えるパフォーマンスを、コスト効率よく得ることができます。

  • サーバーのフォールト トレランス

  • さまざまなコンポーネントの分離と最適化 : BizTalk サービス、データベース、およびトランスポート サービスのパフォーマンスが向上します。

ハードウェアを水平方向に拡張すると、コストを節約できます。ただし、サイトの管理が複雑になるため、最初は垂直方向拡張から始めてください。

ここには次のトピックが含まれます。

  • BizTalk メッセージ サービスのスケール アウト

  • データベースのスケール アウト

  • トランスポート サービスのスケール アウト

関連項目

BizTalk Server の拡張


BizTalk メッセージ サービスのスケール アウト

BizTalk メッセージ サービスを水平方向に拡張するには、サーバー グループを使用します。サーバー グループとは、集中的に管理、構成、および監視されるサーバーの集合です。サーバー グループの追加と構成の詳細については、「グループとサーバー」を参照してください。

同じサーバー グループのメンバであるサーバーは、次のものを共有しています。

  • BizTalk Server ステータス エンジンの利用状況を監視する、共有キュー データベース

  • ドキュメントの利用状況をログに記録し、レポートを生成する追跡データベース

  • 構成情報が格納されるBizTalk メッセージ管理データベース

  • 受信機能

  • トランスポート コンポーネントおよびアプリケーション統合コンポーネント (AIC)、データ変換、データ暗号化、署名など、実行時にサーバーが必要とするすべてのコンポーネント

BizTalk Server グループは、受信ドキュメントの受信および Distributed Component Object Model (DCOM) を使用したドキュメント送信における負荷分散メカニズムは提供しません。BizTalk Server グループが提供するのは、複数のサーバーによる分担処理です。ドキュメントが共有キュー データベースに送信されると、グループ内のどのサーバーでもそのドキュメントの処理、シリアライズ、および送信を行うことができます。この機能によって、グループ内のあるサーバーがドキュメントを処理し、それを別のサーバーが送信することが可能になります。

次の目的で、1 つの組織に複数のサーバー グループを作成することができます。

  • 類似したトランスポート サービス (HTTP またはファイル) のグループ化

  • セキュリティの強化

  • 取引先の分類

複数のサーバー グループを使用すると、組織、チャネル、およびメッセージ ポートの構成の重複を防ぐこともできます。サーバー グループ間では、データベースが共有されます。組織、グループ、チャネル、およびメッセージ ポートの構成情報は、BizTalk メッセージ管理データベースに格納されます。したがって、複数の BizTalk Server グループで 1 つの BizTalk メッセージ管理データベースを共有できます。

注

  • 複数の BizTalk Server グループで 1 つの BizTalk メッセージ管理データベースを共有する場合、グループのメンバが共有する共有キュー、追跡、およびオーケストレーションの各データベースは、そのグループ専用のものが必要です。

BizTalk Server の水平方向拡張でお勧めする方法

BizTalk Server のパフォーマンスを最適化するには、次のような方法があります。

トランスポート サービスと受信機能の分離

BizTalk Server グループ用のトランスポート サービスと受信機能を分離すると、パフォーマンスが向上します。得られるパフォーマンス レベルは、処理中のドキュメントの数と、データ変換の複雑さによって異なります。BizTalk Server は、データの受信および処理用にそれぞれ別のスレッド プールを提供します。トランスポート サービスと受信機能を分離すると、サーバーが送信処理と受信処理を切り替える必要がなくなるため、コンテキストの切り替えが減少します。

既定では、共有キュー データベースからの作業項目の取り出し、処理、チャネルで構成されているトランスポート サービスを使用した送信などの作業項目の処理は、すべてのサーバーで行うことができます。この処理ではコンテキスト切り替えが必要なため、CPU のパフォーマンスが全般にわたって低下します。複数のサーバーを使用する場合は、少なくとも 1 台のサーバーが受信サービスを実行するようにしておくと、このようなパフォーマンス低下を防止できます。受信サービスを実行するサーバーを構成するには、BizTalk Server 管理コンソールで [作業項目の処理に参加する] チェック ボックスをオフにし、そのサーバーに新しい受信機能を作成します。[作業項目の処理に参加する] 機能の詳細については、「グループ内のサーバーの構成」を参照してください。ファイル受信機能の設定の詳細については、「ファイル受信機能の追加」を参照してください。メッセージ キュー受信機能の設定については、「メッセージ キュー受信機能の追加」を参照してください。

注

  • メッセージ キューでは、ローカル キューからはトランザクションを利用した読み取りのみが可能なため、キューから読み取りを行えるサーバーは 1 台だけです。

次のいずれかに当てはまっている場合は、BizTalk Server によってドキュメントが受信されます。

  • BizTalk Server がインストールされているサーバーで、受信機能が構成されている。

  • BizTalk Server がインストールされているサーバーで、SMTP または HTTP プロセスが、Submit メソッドを呼び出すように構成されている。

パーサーの優先順位の設定

パーサーの優先順位を設定すると、BizTalk Server のパフォーマンスを最適化できます。BizTalk Server には、4 つのデータ パーサーがあります。

  • XML

  • EDIFACT

  • ANSI X12

  • フラット ファイル

BizTalk Server は、ドキュメントを受信すると前の一覧にある順序でドキュメントを解析します。利用頻度の最も高いパーサーをリストの先頭に移動すると、BizTalk Server のパフォーマンスが向上します。パーサー順序の構成の詳細については、「サーバー グループのパーサー順序の構成」を参照してください。

パーサーの順序設定機能はサーバー グループの設定であるため、処理されるデータ型 (XML、EDIFACT、ANSI X12、およびフラット ファイル) ごとに別のグループを作成することをお勧めします。その後、グループごとにパーサーの優先順位を指定します。

ここには次のトピックが含まれます。

  • コンポーネント負荷分散


コンポーネント負荷分散

コンポーネント負荷分散 (CLB) は Microsoft Application Center 2000 の機能です。CLB を使用するには、Microsoft BizTalk Server 2000 をインストールしたサーバーに Application Center 2000 をインストールする必要があります。CLB を使用すると、COM+ サービス マネージャで BizTalk.Interchange.1 コンポーネントの負荷を分散することが可能になります。CLB は COM コンポーネント用の負荷分散メカニズムです。BizTalk Server 環境で CLB を利用すると、HTTP トランスポートで Submit メソッドを使用することにより、単一のサーバーではなく BizTalk Server クラスタを呼び出せるようになります。送信するアプリケーションでは、Submit メソッドを使用したクラスタの呼び出しは、ノードへの送信として認識されます。クラスタは複数のサーバーの集合で、単一のサーバーとして動作します。たとえば、HTTP サーバーのクラスタを使用している場合に送信を 1 回行うと、3 台のサーバーのいずれかに送信されます。CLB を使用しない場合は、3 台のサーバーのいずれか 1 台に送信されるように、HTTP トランスポート サービスを構成する必要があります。後者の場合は、HTTP サービスを構成したサーバーが送信に失敗したとき、BizTalk Server グループの別のサーバーに送信するように HTTP トランスポート サービスを再構成する必要があります。

重要

  • XLANG スケジュールをホストする既定の XLANG スケジューラ アプリケーションや COM+ アプリケーションは、複製しないでください。コンポーネント負荷分散を使用する場合は、COM+ アプリケーションを各サーバーにインストールする必要があります。XLANG スケジュールにバインドされている COM コンポーネントは、複製することができます。


データベースのスケール アウト

データベースを水平方向に拡張するには、各データベースを専用のサーバーにインストールします。大量のトランザクションが発生する環境では、データベースを専用サーバーにインストールすると、サーバーの CPU、ディスク入出力、およびメモリ リソースの割り当てをデータベースごとに指定できるようになります。

データベースの水平方向拡張の最適化でお勧めする方法

BizTalk Server のデータベースのパフォーマンスを最適化するには、次のような方法があります。

  • データベースは、933 MHz 以上の CPU を備えたサーバー 1 台につき 1 つだけインストールします。BizTalk Server 2000 をインストールしたサーバーには、データベースをインストールしないようにします。

  • XLANG スケジュールをホストするすべての COM+ アプリケーションを、933 MHz 以上の CPU を持つ専用のサーバーにインストールします。

  • スループット 100 Mbps (メガビット/秒) 以上の複数のネットワーク カードを 100 MB/s (メガバイト/秒) スイッチのポートに接続し、ネットワークの入出力スループットを向上させます。

  • 処理するドキュメント数が少ない組織では、データベースのアップグレードは容易です。処理量が増えてきた場合は、共有キュー データベース、追跡データベース、およびオーケストレーション データベースを専用のサーバーに移動します。ただし、BizTalk メッセージ管理データベースを移動するのは多少困難です。BizTalk メッセージ管理データベースが格納されたサーバーには、ドキュメント処理量の増加に備えて、ディスク領域、および構成をキャッシュするためのメモリを十分に用意しておいてください。

  • 追跡データベースを配置するサーバーには、BizTalk Server とこのデータベースの間で交換される大量の非圧縮データに対処するために、高速なネットワーク ハードウェアをインストールしてください。

    注

    • インターチェンジとドキュメントの追跡にはサイズに制限があり、制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

関連項目

BizTalk Server の拡張


トランスポート サービスのスケール アウト

BizTalk Server は、4 種類のトランスポート サービスをサポートしています。これらのトランスポート サービスは、水平方向に拡張することが可能です。

  • HTTP

  • ファイル

  • SMTP

  • メッセージ キュー

ここには次のトピックが含まれます。

  • HTTP/HTTPS (スケール アウト)

  • ファイル (スケール アウト)

  • SMTP (スケール アウト)

  • メッセージ キュー (スケール アウト)


HTTP/HTTPS (スケール アウト)

受信

HTTP/HTTPS 受信機能を水平方向に拡張するには、Web クラスタを使用します。たとえば、取引先がドキュメントを 1 つのアドレスに送信するだけで、その送信内容がクラスタ内の任意のサーバーにルーティングされます。Web クラスタは、Microsoft Windows 2000 Advanced Server が備えているネットワーク負荷分散 (NLB) 機能です。NLB の構成の詳細については、Windows 2000 Advanced Server ヘルプを参照してください。BizTalk Server のパフォーマンスを向上させるには、Web クラスタを構成し、受信ドキュメントをファイル ディレクトリやメッセージ キューに格納するか、または次の 2 つの方法のどちらかによって、ドキュメントを BizTalk Server へ直接送信するようにします。

  • ドキュメントが BizTalk Server に送信されるように、各サーバーを静的に構成します。

  • BizTalk Server の Web クラスタ (同じグループに所属するサーバー) にドキュメントを送信する場合に、Microsoft Application Center 2000 のコンポーネント負荷分散 (CLB) 機能を利用するように各サーバーを構成します。

    重要

    • XLANG スケジュールをホストする既定の XLANG スケジューラ アプリケーションや COM+ アプリケーションは、複製しないでください。コンポーネント負荷分散を使用する場合は、COM+ アプリケーションを各サーバーにインストールする必要があります。XLANG スケジュールにバインドされている COM コンポーネントは、複製することができます。

送信

送信 HTTP/HTTPS トランスポート サービスの水平方向拡張は、作業項目の処理に参加するように構成されたグループ内で、複数のサーバーを使用することによって実現できます。HTTP/HTTPS 送信機能は、作業項目の処理に参加するように構成されたグループ内の全サーバーで使用されるため、ドキュメントを処理する BizTalk Server から送信機能を分離することはできません。

HTTP/HTTPS の最適化でお勧めする方法

HTTP/HTTPS のパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • 大量のトランザクションが発生する環境の場合は、受信 HTTP/HTTPS トランスポートを BizTalk サービスとは別の専用サーバーで実行します。さらに、ドキュメントをファイル受信機能またはメッセージ キュー受信機能に送信するように HTTP/HTTPS サーバーを構成します。または DCOM を使用し、BizTalk Server のインターチェンジ オブジェクトの Submit メソッドを呼び出すようにします。受信 HTTP/HTTPS トランスポート専用のサーバーを設置したり、ドキュメントを受信機能に送信するように HTTP/HTTPS サーバーを構成したりすると、ネットワークでの待ち時間が長くなります。しかし、HTTP/HTTPS トランスポート サーバーと BizTalk Server を別々に構成することで、それぞれのアーキテクチャに合わせて構成することが可能になり、それらを最適化できるようになります。また、これらのサーバーを分離すると、暗号化と暗号解読に SSL を使用することによる負荷の影響を受けなくなるため、BizTalk Server で良好なパフォーマンスを保つことができます。

  • HTTP/HTTPS トランスポート サーバーの負荷分散クラスタを作成します。これにより、水平方向拡張の冗長性が得られるため、受信 HTTP/HTTPS トランスポートのパフォーマンスがさらに向上します。ネットワーク負荷分散サービスを使用して Web クラスタを作成する方法の詳細については、Windows 2000 Advanced Server ヘルプを参照してください。

  • 作業項目の処理に参加するように構成されているグループのサーバーで、どの程度の数のドキュメントが処理されるかを把握します。次に、送信 HTTP/HTTPS トランスポートが必要なメッセージ ポートを使用するチャネルの数を特定します。その後、送信 HTTP/HTTPS トランスポートを使用するチャネルを 1 つのグループにまとめます。これにより、作業項目の処理に参加するように構成されているグループのサーバーで、トランスポートを使用するドキュメントをシリアライズできるようになります。

  • HTTP/HTTPS サービスを利用した送受信で ASP ページを使用する場合は、最良の方法について検討してください。ASP ページとインターネット インフォメーション サービスの最適化方法については、インターネット インフォメーション サービスのヘルプ (localhost/iisHelp) で、[Active Server Pages ガイド] をクリックしてください。

  • ドキュメントを BizTalk Server に送信する場合は、Submit メソッドを呼び出す代わりに、ローカル システムのメッセージ キューまたはファイル トランスポート サービスを受信機能と共に使用します。


ファイル (スケール アウト)

受信

ファイル受信機能は、サーバーから分離することも、サーバー上に配置することもできます。ファイル受信機能を別のサーバーに分離すると、ディスクの入出力パフォーマンスへの影響を抑えることができますが、ファイルを受信するときのネットワークでの待ち時間によって、パフォーマンスに影響が及びます。

送信

水平方向拡張は、複数のサーバーから構成されるグループでドキュメントを処理し、それらのドキュメントをファイル トランスポート サービスに送信することで実現できます。パフォーマンスは、BizTalk Server を受信機能として使用するかどうか、および BizTalk Server が受信機能用の独立したサーバーとして構成されているかどうかで異なります。

ファイル受信機能およびファイル トランスポート サービスの最適化でお勧めする方法

ファイル受信機能とファイル トランスポート サービスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • ファイル受信機能は、BizTalk Server を実行するサーバー以外のサーバーに配置します。ただし、この方法では、ファイル受信時に発生する、ネットワークでの待ち時間によるパフォーマンスへの影響を解消できません。ファイル受信機能を BizTalk Server を実行するサーバー以外のサーバーに配置すると、ディスク入出力による BizTalk Server のパフォーマンスへの影響も抑えることができます。また、サーバーをこのように分離すると、未知のアプリケーションが BizTalk Server コンピュータにファイルをコピーしたり、要求を出したりすることを防止できます。このような処理が行われると、サーバーのリソースが大量に消費され、パフォーマンスが低下する可能性があります。

  • 受信機能を構成する場合に、同じファイル受信機能をポーリングするグループ内の全サーバーで実行されるように構成し、グループ内のすべてのサーバーがドキュメントを取得して処理するようにします。既定では、ファイル受信サービスはグループ内の 1 台のサーバーで実行されるように構成されます。このため、グループに 5 台のサーバーがあり、ファイル受信機能が 1 台のサーバーで実行されるように構成した場合は、ファイル受信機能が \\receiveserver\receivelocation でポーリングされると、5 台のうち 1 台のサーバーでのみファイルが取得され、処理が行われます。この場合は、ドキュメントを処理するサーバーがグループ全体で 1 台しかないことになります。残りの 4 台のサーバーは、受信機能からファイルを取得して解析することができません。

  • ファイル受信機能は、BizTalk Server を実行するサーバー以外のサーバーに構成します。これにより、未知のアプリケーションは BizTalk Server からファイルを取得できなくなります。ファイルの送信と受信はそれぞれ別の処理であるため、作業項目の処理に参加するように構成されたグループでは、すべてのサーバーがファイルを送信します。水平方向の拡張性は、作業項目の処理に参加するように構成されたグループ内の、サーバーの数のみに基づきます。


SMTP (スケール アウト)

受信

SMTP を利用して BizTalk Server からドキュメントを受信することはできますが、BizTalk Server にファイルを送信することはできません。BizTalk Server にドキュメントを送信するには、SMTP がイベント ベースのメカニズムを呼び出して受信メッセージをポーリングし、それをファイル共有またはメッセージ キューに送信できるようになっているか、BizTalk Server のインターチェンジ オブジェクトを利用してドキュメントを送信できるようになっている必要があります。このようなイベント ベースのメカニズムを提供する機能を備えた SMTP サーバー (Microsoft Exchange Server やサード パーティ製のメッセージ サーバー) は、一般に、大量のハードウェア リソースを消費します。このため、サーバーにこの機能を追加すると、サーバーのドキュメント処理能力が低下します。

送信

SMTP を利用したドキュメントの送信には、イベント ベースのメカニズムを持たない軽量の SMTP トランスポート サービスを使用できます。ドキュメントを送信する SMTP トランスポート サーバーは、単なるリレー エージェントとして機能します。送信 SMTP サーバーは、サーバー レベルではなく、グループ レベルで構成されます。したがって、グループ内の 1 台のサーバーに SMTP トランスポートが存在していると、SMTP トランスポート サービスを実装しているサーバーは、そのトランスポートを使用して送信ドキュメントを送信します。グループ内にあるほかのサーバーもすべて、SMTP 送信では SMTP トランスポートが存在するサーバーを利用します。

SMTP の最適化でお勧めする方法

SMTP を最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • SMTP トランスポートは、送受信機能用の BizTalk サービスを実行するサーバーとは別のサーバーで実行するように構成します。組織のネットワークには多くの場合 SMTP サーバーが置かれているので、それを送受信機能用に利用することができます。


メッセージ キュー (スケール アウト)

受信

メッセージ キューの受信機能を BizTalk Server と同じサーバーで実行するか、または別のサーバーにインストールするかを決定する必要があります。トランザクション キューを使用している場合は、同じサーバー上でメッセージ キュー受信機能を実行する必要があります。トランザクション キューを使用していない場合は、メッセージ キュー受信機能を別のサーバーで実行することができます。また、ローカルの BizTalk Server によるディスク入出力と、複数のサーバーの通信によるネットワーク待ち時間のうち、どちらによるパフォーマンスへの影響を受けるかを決める必要があります。後者の場合は、ディスクに対する入出力は行われますが、ローカル サーバーではなくリモート サーバーで行われるだけです。メッセージ キュー サービスのハードウェア環境については、Windows 2000 Server ヘルプの「メッセージ キュー サーバーのハードウェアを選択する」を参照してください。

送信

メッセージ キューを使用してドキュメントを送信する場合も、メッセージ キューを使用してドキュメントを受信する場合と同様のセキュリティおよびパフォーマンス上の問題が発生します。

メッセージ キューの最適化でお勧めする方法

メッセージ キューのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • ジャーナルを使用すると、メッセージ キューによるデータベースへの負担が大きくなります。メッセージ キュー トランスポート サービスを設定する場合は、データベースを最適化する際の標準的な手順に従って、データベースを最適化しておいてください。たとえば、スループットを最大限まで高めるには、データとログを分離し、複数のディスクとコントローラを使用します。


パフォーマンスの最適化

トランザクションの要件を満たし、パフォーマンスを向上させるには、BizTalk Server 2000を最適化します。パフォーマンスを向上させるには、BizTalk Server だけでなく、Microsoft Windows 2000 とデータベース間の相互作用の最適化も必要です。システムを構成したら、テストを行って結果を評価し、初期構成がトランザクションの要件を満たしているかどうかを確認します。パフォーマンスを最適化するには、アーキテクチャの再構成が必要です。再構成のたびにテストを行い、結果を評価してください。目標の結果が得られたら、メンテナンス計画を開始します。サーバー パフォーマンスは時間とともに変化するため、組織が処理するトランザクションの量や種類に変化が生じる場合があるからです。

ここには次のトピックが含まれます。

  • 一般的なパフォーマンスの最適化でお勧めする事項

  • アーキテクチャの設計、検討、およびテスト

  • パフォーマンスの維持


一般的なパフォーマンスの最適化でお勧めする事項

ここでは、システム設定を最適化するための一般的な推奨事項について説明し、BizTalk Server 2000 の設定を最適化してパフォーマンスを向上させる方法についても説明します。たとえば、次のような項目です。

  • Microsoft Windows 2000 の設定を最適化します。不要なサービスやプロトコルを実行しないなど、Microsoft Windows 2000 のパフォーマンスを向上させるためのテクニックをすべて適用します。Windows 2000 を最適化するテクニックの多くは、BizTalk Server の最適化にも利用できます。Microsoft Windows 2000 設定の最適化の詳細については、Windows 2000 ヘルプの「ヒント集」を参照してください。

  • トランスポート サービス、BizTalk サービス (BizTalk オーケストレーション サービスと BizTalk メッセージ サービス)、およびデータベースの間で、高速で信頼性の高いネットワーク接続を維持します (100 Mbps 以上のイーサネット)。ネットワークのスループットを最適化するには、各サーバーで複数のアダプタを使用し、それぞれを専用のスイッチ ポートに接続します。また、受信および送信トランザクションで、それぞれ別のネットワーク インターフェイス カード (NIC) を使用します。Microsoft Windows 2000 のネットワーク負荷分散 (NLB) や Microsoft Application Center 2000 のコンポーネント負荷分散 (CLB) (IInterchange または IPipelineComponent) と組み合わせて使用すると、パフォーマンスが大幅に向上します。

    重要

    • XLANG スケジュールをホストする既定の XLANG スケジューラ アプリケーションや COM+ アプリケーションは、複製しないでください。CLB を使用する場合は、このような COM+ アプリケーションを各サーバーにインストールする必要があります。XLANG スケジュールにバインドされている COM コンポーネントは、複製することができます。

ここには次のトピックが含まれます。

  • BizTalk オーケストレーション サービスの最適化

  • BizTalk メッセージ サービスの最適化

関連項目

BizTalk Server の拡張


BizTalk オーケストレーション サービスの最適化

BizTalk オーケストレーション サービスを使用して、XLANG スケジュールとスケジュールのコンテンツを最適化できます。スケジュールでのメモリの使用方法、およびビジネス プロセス フローの構造がパフォーマンスに与える影響を理解すると、BizTalk オーケストレーション サービスのパフォーマンスを向上するスケジュールの作成が可能になります。BizTalk オーケストレーション サービスによってサポートされる実装テクノロジには、BizTalk メッセージ サービス、COM コンポーネント、メッセージ キュー サービス、および Windows スクリプト コンポーネントが含まれます。これらのコンポーネントやサービスを最適化すると、BizTalk オーケストレーション サービスのパフォーマンスがさらに向上します。

ここには次のトピックが含まれます。

  • XLANG スケジュールの最適化

  • XLANG スケジュールのコンテンツの最適化


XLANG スケジュールの最適化

XLANG スケジュールには、企業内部のビジネス プロセスを大量に格納することができます。ビジネス プロセスには、短時間トランザクションや長時間トランザクションが含まれています。BizTalk Server は、このようなプロセスのコンテンツを制御することはありませんが、XLANG スケジュール内のこれらプロセスを通じて、情報の流れを管理します。XLANG スケジュールを設計する場合は、それを短時間トランザクションと長時間トランザクションのどちらで構成するかにかかわらず、次の点を考慮する必要があります。

  • XLANG スケジュール インスタンスを起動すると、必ずメモリ上で実行されます。

  • 1 台のサーバーで複数の XLANG スケジュールが実行されることがあります。

  • 複数の異なる XLANG スケジュールが同時に実行され、複数の XLANG スケジュール インスタンスが実行されることがあります。

オーケストレーション データベースは、実行中の XLANG スケジュールによって使用されるメモリを制御するための、ステータス退避と呼ばれるメカニズムを提供します。ステータス退避は、XLANG スケジュール インスタンスがメッセージを待っている場合に、その XLANG スケジュールでほかの活動が何も実行されていないときに行われます。そのようなとき、XLANG スケジューラ エンジンによって XLANG スケジュール インスタンスのステータス退避が行われ、それによってパフォーマンスが向上します。XLANG スケジュール インスタンスのステータス退避では、インスタンス固有のステータスがすべてデータベースに保存され、インスタンスはメモリから削除されます。XLANG スケジューラ エンジンのメモリには、XLANG スケジュール インスタンスのほんの一部だけが残ります。その XLANG スケジュール インスタンス用のポートにメッセージが到着すると、インスタンスのステータス復元が行われます。XLANG スケジュール インスタンスのステータス復元では、データベースにあるインスタンスがメモリ上に復元されます。

XLANG スケジュール インスタンスは、ステータス復元が行われるか、管理者によって明示的に終了されるまで、ステータス退避された状態で保持されます。このような処理によって、長時間に渡って、ビジネス プロセスを高い信頼性を保ったまま実行することが可能になります。ステータス退避の構成の詳細については、「ステータス退避とステータス復元」を参照してください。ステータス退避とステータス復元によってメモリの消費は少なくなりますが、パフォーマンスは低下します。これは、ステータス退避とステータス復元ではオーケストレーション データベースにデータの読み書きを行う必要があり、ネットワークでの待ち時間の影響を受けるためです。

重要

  • BizTalk オーケストレーション サービスのパフォーマンスを大幅に向上させるには、エクスプローラで Program Files\Common Files\System\ADO を参照し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと ADO のスレッド モデルが "Apartment" から "Both" になります。また、ADO を利用するほかのアプリケーションに影響を及ぼす可能性があります。


XLANG スケジュールのコンテンツの最適化

XLANG スケジュールは、ビジネス プロセスとそのプロセスのバインドについての情報を実装テクノロジに提供するものです。XLANG スケジュールのパフォーマンスは、通常はそこに含まれるアクションのパフォーマンス レベルを反映したものになります。XLANG スケジュールのコンテンツの最適化には、多くの項目が関係しています。これらの項目には、XLANG スケジュールに固有のものもあれば、分散アプリケーションの作成に関係するものもあります。

  • ステータス退避の値を再設定し、XLANG スケジュール用のメモリを確保します。既定の待ち時間は 0 秒です。この時間は変更することができます。180 秒以下の値を指定すると、XLANG スケジュールはステータス退避を行わなくなります。180 秒よりも大きい値を指定すると、XLANG スケジュールは直ちにステータス退避を行います。待ち時間と XLANG スケジュールのステータス退避の詳細については、「ステータス退避とステータス復元」および「同期通信と非同期通信」を参照してください。

  • 永続化コンポーネントを使用します。IPersistStream や IpersistStreamInit などの永続化コンポーネントを使用すると、XLANG スケジューラ エンジンが XLANG スケジュールを柔軟にステータス退避できるようになります。

  • オーケストレーション データベースと同じサーバーで COM オブジェクトを実行します。このようにすると、XLANG スケジュールがネットワーク待ち時間の影響を受けなくなります。

  • COM+ パッケージをインプロセスで実行し、最大限のパフォーマンスを得ます。COM+ パッケージをインプロセスで実行すると、アプリケーションのコンポーネントで障害が発生した場合にアプリケーション全体で障害が発生するなど、COM+ アプリケーションの堅牢性に影響を与えますが、アプリケーションをアウトプロセスで実行する場合よりも処理速度が格段に速くなります。このような潜在的な不安定さを補うため、アプリケーションを運用環境に導入する前に、そのアプリケーションのコンポーネントの安定性を十分にテストしてください。

  • 作業を 1 つのトランザクションにまとめます。トランザクションの開始時と終了時に XLANG スケジュール インスタンスのステータスを保存するときは、コンピュータのリソースが大量に消費されます。作業項目を 1 つのトランザクションにまとめることで、このようなパフォーマンスへの影響は大幅に減少します。また、XLANG スケジュールは、Microsoft 分散トランザクション コーディネータ (MSDTC) のトランザクションの実行中はステータス退避を行えません。MSDTC トランザクションは高速に処理されますが、パフォーマンスを低下させます。短時間で完了するアクションが複数ある場合は、それらのアクションを 1 つの MSDTC トランザクションにまとめてください。

  • 長時間トランザクションは非同期で実行し、XLANG スケジュールは短時間で COM 呼び出しを完了するように設計します。非同期で実行した処理の結果は、メッセージ キューまたは COM 呼び出しを介して XLANG スケジュール インスタンスに戻されます。COM を利用すると、"応答" ポートの名前をモニカとして渡すことができます。モニカはコンピュータを再起動しても有効です。

関連項目

モニカの構文


BizTalk メッセージ サービスの最適化

BizTalk メッセージ サービスを最適化するには、次のような方法があります。

  • ドキュメントをサーバー グループに送信します。BizTalk Server グループによって、複数のサーバーに作業を分配します。BizTalk Serverにデータを送信するには、次の操作を行います。
    • メッセージ キュー受信機能やファイル受信機能などを構成します。

    • BizTalk Server のインターチェンジ オブジェクトの Submit メソッドを呼び出します。

    受信機能は BizTalk サービスの内部で実行され、オブジェクトの内部ステータスをキャッシュできるため、受信機能を使用すると、Submit メソッドを使用してインターチェンジ オブジェクトを呼び出す場合よりも高いパフォーマンスが得られます。Sumbit メソッドはアウトプロセスで実行され、呼び出しのたびに内部ステータスを再構築します。

    インターチェンジ オブジェクトは BizTalk Server プロセスの外部に作成する必要があるため、インターチェンジ オブジェクトを呼び出して送信を行うと、受信機能を使用する場合よりも多くのリソースが消費されます。ただし、インターチェンジ オブジェクトを使用する場合は、グループ内のサーバーにデータを送信するときに 2 種類の方法を利用できます。

    • 送信全体の中の各部分がそれぞれグループ内の特定のサーバーに送信されるように、静的に構成します。ただし、BizTalk Server に静的にマップされたトランスポート サービスを持つサーバーで障害が発生した場合は、この方法ではフォールト トレランスがあまり得られません。

    • Microsoft Application Center 2000 のコンポーネント負荷分散 (CLB) 機能を使用し、パフォーマンスを向上させます。BizTalk Server グループを利用しても、ドキュメントの送信には負荷分散が提供されません。CLB を使用すると、負荷分散に加えてフォールト トレランスも提供されます。CLB の詳細については、「コンポーネント負荷分散」を参照してください。

    重要

    • XLANG スケジュールをホストする既定の XLANG スケジューラ アプリケーションや COM+ アプリケーションは、複製しないでください。コンポーネント負荷分散を使用する場合は、COM+ アプリケーションを各サーバーにインストールする必要があります。XLANG スケジュールにバインドされている COM コンポーネントは、複製することができます。

ここには次のトピックが含まれます。

  • 仕様の作成と最適化

  • マップの作成と最適化

  • BizTalk Server グループのプロパティの最適化

  • サーバーのプロパティの最適化

  • レジストリ設定の最適化

  • 暗号化の最適化

  • 通信の最適化

  • ファイアウォールの構成


仕様の作成と最適化

既定のグローバル追跡設定を使用する場合、BizTalk Server 2000 では 20 MB までの XML Unicode 形式ドキュメントをサポートします。 フラット ファイルなど、XML 以外のファイルは XML に変換する必要があるため、20 MB のファイル サイズ はサポートされません。変換処理でデータに XML タグが追加されるため、BizTalk Server が処理するドキュメントのサイズが大きくなります。BizTalk Server のパフォーマンスを最高のレベルに維持するには、XML 以外の種類のファイルは 20 MB 未満にする必要があります。XML に変換されたドキュメントの処理で必要なメモリの量は、そのドキュメントの元の構造によって異なります。グローバル追跡が有効に設定されている場合は、BizTalk Server のパフォーマンスに大きな影響を与えることなく、20 MB を超える XML Unicode 形式のドキュメントを処理できます。

注

  • インターチェンジ追跡のサイズ制限を超えると、BizTalk Server のパフォーマンスが低下します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。パフォーマンスは、ドキュメントのログ機能からも影響を受けます。ドキュメントのログ機能の詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

仕様を設計するときは、仕様内に検証条件を構成できます。たとえば、あるフィールドに特定のデータ型 (文字列など) が格納されるように指定したり、さらに複雑な条件 (80 とおりの値一覧と比較して、フィールドを検証するなど) を指定したりできます。後者の場合は、データを 80 とおりの値と比較することを要求し、いずれとも一致しない場合は仕様の検証プロセスを通過できなかったことになります。BizTalk Server の仕様の検証は既定で有効になっており、パフォーマンスは低下しますが、送受信するデータの有効性が確認されます。検証を無効にするとパフォーマンスが向上します。BizTalk Server はデータ検証メカニズムをほかにもいくつか備えているため、無効にしてもデータの有効性にはそれほど影響しません。たとえば、特定のデータ型と値を必要とするマップがあって、仕様の検証が無効になっている場合、データは解析プロセスは通過できますが、シリアライズ プロセスでマップが適用されたときにエラーが発生します。ほかのメカニズム (有効なデータを前提にしたマップなど) を利用できる場合は、仕様の検証を無効にすることで、検証プロセスによるパフォーマンス低下の可能性を回避できます。また、取引先との間でデータ標準について合意が得られ、トランザクションの検証が行われている場合にも、仕様の検証を無効にすることができます。データの送信方法を完全に制御できている場合 (アプリケーション間トランザクションなど) も、仕様の検証を無効にできます。

検証を無効にするには、次のレジストリ設定を使用します。

  • NoValidation : 仕様の検証が必要ない場合、たとえば、最小値/最大値、データ型、必要な値などの設定が仕様に適合しているかどうかについてドキュメントを検証しない場合は、これを 0 以外の値に設定するとデータが検証されなくなります。これにより、パフォーマンスは向上しますが、無効なデータが送信される可能性があります。仕様の検証を 0 以外の値に変更する設定は、組織がドキュメントの構造を制御している場合に、そのようなドキュメントを受信するサーバーに適しています。

レジストリの設定は、各サーバーで行います。仕様の検証が有効になっていると、そのサーバーで処理されるすべてのドキュメントについて、仕様に適合しているかどうかが検証されます。このため、サーバーの処理速度は仕様の検証が行われない場合よりも遅くなります。

ドキュメント サイズおよび仕様の最適化でお勧めする方法

BizTalk Serverのパフォーマンスを最適化するには、次のような方法があります。

  • 仕様には、必要以上のフィールドや属性を含めないようにします。余分なフィールドや属性があると、BizTalk Server で必要なメモリの量が増加します。仕様のサイズが大きくなると、それに比例して必要なメモリも増加します。たとえば、BizTalk Server に含まれる EDI 仕様は、EDI 標準に準拠しています。通常、EDI 仕様を使用するほとんどの組織で必要となるのは、仕様内部の約 10% だけです。そのため、組織とその取引先が 1 つの仕様の 10% しか使用していない場合は、不要なレコードとフィールドを削除して、トランザクションには変更後の仕様を使うことができます。

  • 仕様の検証が有効になっている場合、有効なデータが含まれているフィールドに対しては、仕様内で仕様の検証条件を指定しないでください。たとえば、あるフィールドに数値が含まれている場合でも、文字列として処理されることがあるため (電話番号など)、数値であることを要求しないようにしてください。既定のデータ型は文字列であるため、この場合にはデータ型を指定する必要はありません。このため、データ型フィールドは空白のままにしておきます。フィールドで使用可能な値を指定すると、データ型だけを検証する場合に比べて、検証に時間がかかります。


マップの作成と最適化

トランザクションの中でデータを変換すると、BizTalk Server 2000 のパフォーマンスが低下する場合があります。仕様のマッピング は CPU の負担となり、BizTalk Server のトランザクション処理能力が全般にわたって低下します。BizTalk Server サーバーに及ぶ影響の大きさは、変換に使用するマップの複雑さでほぼ決まります。たとえば、送信元仕様の productID というフィールドを送信先仕様の itemID というフィールドにマップしても、変換するデータに対して複雑な算術演算を実行する場合ほどは負担になりません。

マップの設計でお勧めする方法

  • Functoid を使用するのは、必要な場合だけにします。Functoid はスクリプトを使用するため、BizTalk Server がスクリプト エンジンを読み込む必要があります。これにより、ネイティブ XML の変換に比べてパフォーマンスが低下します。

  • データベース検索 Functoid を使用するのは、必要な場合だけにします。この Functoid を使用すると、BizTalk Server はそのたびにデータベース接続を確立し、データを照会し、レコード セットを格納して接続を閉じます。このような処理によって、BizTalk Server のパフォーマンスが低下します。

  • Functoid スクリプト内の COM オブジェクトの呼び出しや、カスタム Functoid の使用は控えます。どちらのテクニックを使用した場合も、BizTalk Server によって COM オブジェクトのインスタンスが作成されます。その結果、動作のパフォーマンスが全般にわたって低下します。また、次の項目がどのようになっているかによって、COM オブジェクトのインスタンス作成のパフォーマンスが影響を受けます。
    • インプロセスか、アウトプロセスか?

    • プロジェクトはローカルか、リモートか?

    • オブジェクトの記述は適切か?

    • トランザクションを利用しているか?
  • マップを 1 つ 1 つ分析し、最大限のパフォーマンスを得る方法を特定します。たとえば、2 つの送信元フィールドを連結し、その結果得られた値を 2 つの異なる送信先フィールドに配置するときに使用できるテクニックは、2 種類あります。1 つ目の連結テクニックは、連結 Functoid を 1 つ使用し、その出力を 2 か所にマップするというものです。2 つ目は、2 つの Functoidを使用し、それぞれに送信先フィールドへの出力リンクを 1 つずつ作成します。最初のテクニックでは、Functoid の中で実行されるスクリプトが 1 回しか呼び出されないため、少し効率的です。両方をテストし、どちらのテクニックの方がパフォーマンスがより高いかを確認してください。


BizTalk Server グループのプロパティの最適化

BizTalk Server 管理コンソールの [BizTalk Server グループのプロパティ] ダイアログ ボックスでは、次のプロパティを指定できます。

  • [メッセージ管理オブジェクト キャッシュの更新間隔 (秒)] : このフィールドには、最大で 300 秒まで設定できます。BizTalk Server 2000 は、チャネル、メッセージ ポート、エンベロープ、ドキュメント定義などの構成をメモリ内にキャッシュすることで、データベースを毎回呼び出さないようにしています。これらのオブジェクトが定期的に変更されることがない場合は、値を 300 に設定すると、データベースでのデータの読み書き回数が減少します。BizTalk Server では管理オブジェクトを 5 分ごとに更新します。変更を直ちに反映するには、サービスを再起動する必要があります。

  • [ドキュメント トラッキングを有効にする] : [追跡] タブでは、ドキュメント トラッキングを有効にするか、無効にするかを指定できます。トラッキング機能を使用しない場合は、このチェック ボックスをオフにすると、1 回のトランザクションにおけるデータベースへの読み書き回数を最小限に抑えることができます。このチェック ボックスをオンにすると、BizTalk Server はデータベースに接続し、データをログに記録します。トラッキング機能が不要でない限り、このチェック ボックスはオフにしないでください。ドキュメント トラッキングは、有効のままにしておくことを強くお勧めします。トラッキング機能のプロパティ設定の詳細については、「サーバー グループの追跡のプロパティの構成」を参照してください。

    注

    • インターチェンジの追跡にはサイズ上の制限があります。サイズの制限を超えると、BizTalk Server のパフォーマンスが低下します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。パフォーマンスは、ドキュメントのログ機能からも影響を受けます。ドキュメントのログ機能の詳細については、「ドキュメント ログのプロパティの設定」を参照してください。
  • [サーバーの呼び出し順序の整列] : グループで特定の種類のドキュメントを受信することが多い場合は、BizTalk Server のパーサーに優先順位を設定できます。BizTalk Server には 4 つのパーサーがあり、XML、EDIFACT、ANSI X12、およびフラット ファイルのデータ解析に使用されます。BizTalk Server は、ドキュメントを受信すると、これらのパーサーを一覧の順序どおりに使用してドキュメントを解析します。組織がおもに受信するドキュメントの種類が決まっている場合は、パーサーの順序を変更し、頻繁に受信するドキュメントの種類に合ったパーサーが先頭になるようにします。

関連項目

BizTalk メッセージ サービスのスケール アウト


サーバーのプロパティの最適化

BizTalk Server 管理コンソールでは、[<サーバー> のプロパティ] ダイアログ ボックスで次のプロパティを設定できます。

  • [使用可能な受信機能スレッドの最大数] : 受信機能のための、プロセッサ 1 基あたりの作業スレッドの数を指定できます。BizTalk Server は入出力ポートを占有するため、この値を小さくしすぎると、処理速度が低下します。この値を非常に大きくすると、重大な影響はありませんが、パフォーマンスが低下します。この値を調整し、最適な値を見つけてください。[使用可能な受信機能スレッドの最大数] の推奨値は 4 です。

  • [プロセッサごとの使用可能な作業スレッドの最大数] : 処理側のプロセッサ 1 基あたりの作業スレッド数を指定できます。作業スレッド数を適切な値に調整すると、パフォーマンスを向上させることができます。BizTalk Server 管理コンソールで、コンソール ツリーのサーバーを右クリックし、[プロパティ] をクリックします。[プロセッサごとの使用可能な作業スレッドの最大数] ボックスの既定値を変更します。既定値は 4 で、推奨される値は環境によって異なりますが、10 ～ 16 です。


レジストリ設定の最適化

レジストリ設定を最適化すると、BizTalk Server のパフォーマンスを向上させることができます。キーは、すべて DWORD 値として HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl Set\Services\BTSSvc に追加します。パフォーマンスを向上させるには、次のようなレジストリ設定を適用します。

  • NoValidation : 仕様の検証を無効にするには、このレジストリ キーを使用します。仕様の検証が必要ない場合、たとえば、最小値/最大値、データ型、必要な値などの設定が仕様に適合しているかどうかについてドキュメントを検証しない場合は、これを 0 以外の値に設定するとデータが検証されなくなります。これにより、パフォーマンスは向上しますが、無効なデータが送信される可能性があります。仕様の検証を 0 以外の値に変更する設定は、組織が構造を制御しているドキュメントを受信するサーバーに適しています。

  • ParserRefreshInterval : 既定では、60,000 (60 秒) に設定されています。この値は、新しいパーサーが追加されたかどうかについて、BizTalk Server がデータベースを確認する頻度を表しています。サーバーの動作中に更新されるグループ レベルのプロパティは、これだけです。新しいパーサーを追加することがない場合は、この値を 0 に設定すると BizTalk Server はデータベースを確認しなくなります。また、この値を使用すると、追跡データベースのグループ設定に新しいパーサーが追加されたかどうか、および設定が変更されたかどうかも確認できます。

  • CacheSize : このレジストリ キーは、BizTalk Server 管理オブジェクト キャッシュの最大サイズを指定するために使用します。既定値は 20 です。BizTalk Server のオブジェクト キャッシュのチャネル、メッセージ ポート、エンベロープ、またはドキュメント定義の数が 20 を超えると、BizTalk Server はメモリから項目の一部を直ちに削除します。サーバーが大量のメモリを備えている場合は、この値を大きく設定すると (20 以上)、BizTalk Server はメモリにより多くの項目を保持できるようになります。これは、更新間隔には影響を与えません。BizTalk Server はキャッシュ オブジェクトを削除し、それらが期限切れになると再読み込みを行います。

  • BatchSize : この値は、メッセージ キューの受信機能だけで使用します。既定では、BatchSize は 20 に設定されています。パフォーマンスを向上させるため、BizTalk Server はキューから最大で 20 項目を同時に読み取り、その 20 項目をすべて 1 つのトランザクションで送信します。データベースへのデータ書き込み回数を減らすと、パフォーマンスが大幅に向上します。デッドロックが発生して BizTalk Server がトランザクションを終了した場合は、項目が再送信されます。BizTalk Server はドキュメントを紛失しません。20 を超える値については、テストが実施されていません。この値は 0 に設定しないでください。

ここには次のトピックが含まれます。

  • 処理パフォーマンスの向上


処理パフォーマンスの向上

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「regedit」と入力し、[OK] をクリックします。

  2. レジストリ エディタで、HKEY_LOCAL_MACHINE ノードの展開記号 (+) をクリックし、[SYSTEM]、[CurrentControlSet]、[Services] を順に展開します。次に、[BTSSvc] をクリックします。

  3. 詳細ペインを右クリックし、[新規] をポイントします。次に、[DWORD 値] をクリックします。

  4. 「NoValidation」と入力し、Enter キーを 2 回押します。

    [DWORD 値の編集] ダイアログ ボックスが表示されます。

  5. [値のデータ] ボックスに 0 以外の値 (1 など) を入力し、[OK] をクリックします。既定値は 0 (検証あり) です。

  6. 詳細ペインを右クリックし、[新規] をポイントします。次に、[DWORD 値] をクリックします。

  7. 「ParserRefreshInterval」と入力し、Enter キーを押します。

  8. 詳細ペインを右クリックし、[新規] をポイントします。次に、[DWORD 値] をクリックします。

  9. 「CacheSize」と入力し、Enter キーを 2 回押します。

    [DWORD 値の編集] ダイアログ ボックスが表示されます。

  10. [値のデータ] ボックスに、メモリ内に格納するチャネル、メッセージ ポート、エンベロープ、およびドキュメント定義の数を入力します。

  11. 詳細ペインを右クリックし、[新規] をポイントします。次に、[DWORD 値] をクリックします。

  12. 「BatchSize」と入力し、Enter キーを 2 回押します。

    [DWORD 値の編集] ダイアログ ボックスが表示されます。

  13. [値のデータ] ボックスに、バッチ処理する項目の数を入力します。


暗号化の最適化

暗号化などのセキュリティ メカニズムを使用すると、BizTalk Server のパフォーマンスが低下します。暗号化を利用する場合は、次のような環境を整えることをお勧めします。

  • CPU の数を増やし、合計のクロック周波数 (MHz) を高めます。プロセッサの数を増やすと、パフォーマンスが向上します。

  • サーバーの台数を増やします。

  • 高速な CPU を使用します。

  • BizTalk Server の機能を分離します。たとえば、送信機能と受信機能を別のサーバーに配置します。HTTPS トランスポート サービスも、別のサーバーに配置できます。

  • ファイルまたはメッセージ キューを使用する場合は、既存の仮想プライベート ネットワーク (VPN) を使用します。VPN を使用すると、データ転送がセキュリティで保護されます。取引先との間で行われるあらゆるデータ転送を VPN によってセキュリティで保護すると、BizTalk Server のトランザクションをセキュリティで保護する必要がなくなります。

  • 暗号化ハードウェア アクセラレータを購入します。アクセラレータ カードには専用のプロセッサが搭載されているため、サーバーの CPU に対する、暗号化と暗号解読によるパフォーマンスへの影響が軽減されます。アクセラレータ カードは、CPU を複数増設する場合に比べると安価です。


通信の最適化

BizTalk Server は、同期通信と非同期通信の両方を統合するメカニズムを提供します。BizTalk Server 2000 では、ドキュメントを受信する場合に COM 統合とサーバーの受信機能 (ファイル受信機能またはメッセージ キュー受信機能) のどちらでも使用できます。

ドキュメントを BizTalk Server に送信する場合、そのドキュメントは通常は共有キュー データベースに格納されます。BizTalk Server はデータベースをポーリングした後、ドキュメントを処理します。この処理は、非同期通信メカニズムです。このとき、処理前のドキュメントにチェック ポイント設定を行うためのキューとして、Microsoft SQL Server データベースが使用されます。この抽象レイヤが追加されることで、ドキュメントの配信にどのようなトランスポート メカニズムが使用されていても、トランスポート サービスはドキュメントを BizTalk Server に送信することが可能になっています。

同期通信インターチェンジは、すべてのキューをバイパスし、呼び出し元スレッドのメッセージ ポートから要求されたコンポーネントをすべて処理します。同期通信プロトコルでは、利用可能な場合には、オプションの応答ドキュメントが返されます。この方法が有効なのは、一致するチャネルが 1 つしかない場合と、メッセージ ポート (同報リストではない) が 1 つしかない場合だけです。設定されたパラメータを用いた場合に複数のチャネルと一致したときは、同期通信で送信を行うと、同期通信の送信では複数のチャネルの一致が許可されていないというエラーが返されます。この方法を利用できるのは、単一のドキュメント インターチェンジの場合に限られます。送信に複数のドキュメントが含まれている場合に同期送信を行うと、複数のドキュメントを送信することはできないというエラーが返されます。この方法では、グループはサポートされません。同期通信は拡張できません。同期通信は単一のスレッドを使用してトランザクションを処理します。このプロセスはドキュメントを送信したサーバー上で実行する必要があるため、グループ内のほかの BizTalk Server との間で負荷分散を行うことはできません。

同期通信では、ドキュメントを直ちに処理するために、BizTalk Server にドキュメントを直接送信します。BizTalk Server は、処理が完了するまで IInterchange::SubmitSync インターフェイス呼び出し元への返信を阻止します。このインターフェイスは、呼び出し元に応答ドキュメントを配信します。このメカニズムを利用できるのは、COM ベースの統合メソッドに限られます。

同期通信と非同期通信の最適化でお勧めする方法

BizTalk Serverのパフォーマンスを最適化するには、次のような方法があります。

  • 最大限のパフォーマンスとスケーラビリティを得るには、非同期通信を利用するようにします。非同期通信は非常にスケーラビリティが高く、良好なスループットを提供します。同期通信呼び出しでは、SubmitSync の呼び出しはそれぞれ別のスレッドで実行されます。このため、大量のトランザクションが発生する環境において、呼び出し元に対し、即時に近い応答を提供します。ただし、多数の呼び出しが同時に行われると、1 台のサーバーで多数のスレッドが実行されることになり、BizTalk Server のパフォーマンスが全般にわたって低下します。Microsoft Windows 2000 はスレッド間で必ずコンテキストを切り替えるように設計されているため、BizTalk Server のパフォーマンス全般が低下する原因となります。また、次の条件下では同期通信の送信が失敗しますが、非同期通信の送信は失敗しません。
    • トランザクション条件が、複数のチャネルと一致する。

    • インターチェンジに複数のドキュメントが含まれている。
  • セルフルーティング ドキュメントを使用すると、BizTalk Server のパフォーマンスが低下する場合があります。


ファイアウォールの構成

ファイアウォールは内部ネットワークのセキュリティの保護に役立ちますが、待ち時間を発生させるほか、そこに障害が発生しただけでネットワーク全体に影響が及ぶ、単一点での障害が発生する可能性があります。負荷分散メカニズムを使用すれば単一点での障害が発生する確率は減りますが、ファイアウォールはネットワークのパフォーマンスを低下させます。

ファイアウォールを備えた環境で BizTalk Server 2000 を構成する場合は、2 とおりの構成方法があります。

  • 構成 1 : サーバーを社内の内部ネットワークにインストールし、取引先と通信するいくつかのサーバーを社内の非武装セグメント (DMZ) にインストールします。社内ネットワークに対する不正アクセスの被害を受けることなく、独自のインターネット サービスをホストしたい企業は、DMZ を使用しています。DMZ は、インターネットと内部ネットワークの防衛線との間にある境界セグメントです。通常はファイアウォールと要塞ホストが組み合わせられており、内部ネットワークと外部ネットワークとのゲートウェイになっています。DMZ にあるサーバーは、HTTP、メッセージ キュー、SMTP などのローカル トランスポート サービスを使用します。この環境では、すべての送受信トランザクションがファイアウォールを通過します。DMZ 内のサーバーは、別のファイアウォールを通じて Microsoft SQL Server にドキュメントを送信します。この構成を採用すると、DMZ 内の BizTalk Server や HTTP などのサーバーは、内部ファイアウォールを通じて Microsoft SQL Server と通信できます。

  • 構成 2 : サーバーを社内ネットワークにインストールします。インターネットを通じてドキュメントを交換する取引先は、DMZ (保護用の第 1 ファイアウォール) 内の SMTP/HTTP サーバーを使用してデータを送信します。これらのサーバーは、第 2 のファイアウォールを通じて、データを社内ネットワークのサーバーに送信します。

構成 1 と構成 2 は、どちらもパフォーマンスに影響を与えます。パフォーマンスの大幅な低下を避けるには、ファイアウォールを構築するとき、組織と取引先との間でごく普通に行われる量のトランザクションを扱えるように構築します。


アーキテクチャの設計、検討、およびテスト

BizTalk Server 2000 の主要コンポーネントは、BizTalk サービス、BizTalk Server データベース、およびトランスポート サービスです。構成が適切でないコンポーネントがあると、システム全体のパフォーマンスが低下します。

ここでは、BizTalk Server のアーキテクチャを定義、テスト、および調整し、最大限のパフォーマンスを得るための方法について詳しく説明します。

ここには次のトピックが含まれます。

  • アーキテクチャの設計

  • アーキテクチャのテストと分析

関連項目

BizTalk Server の拡張


アーキテクチャの設計

BizTalk Server 2000 で処理されるドキュメントの数を正確に決めるには、まず、次の機能を使用するかどうかについて検討する必要があります。

  • 仕様の検証

  • アプリケーション統合コンポーネント

  • トランスポート サービス

  • 暗号化

  • BizTalk オーケストレーション サービス

  • ファイアウォール

  • マップ

また、処理するドキュメントのサイズと、現在のサーバー構成も考慮する必要があります。

パフォーマンス テストを成功させるには、プロセスの数を少なくしておきます。最初は変化する要素が少ない状態から始め、徐々に変化する要素を増やしていくことが大切です。このようにすると、パフォーマンスが低下し始めたときに、その原因を簡単に識別することができます。

ここには次のトピックが含まれます。

  • トランザクション コンポーネントの開発

  • トランスポートの識別

  • 初期アーキテクチャ

関連項目

サーバーとアプリケーションの管理

BizTalk オーケストレーション サービス

アプリケーション統合コンポーネントの作成

仕様の作成

データのマッピング

XLANG スケジュールの実行 (操作方法)

BizTalk オーケストレーション デザイナの使用


トランザクション コンポーネントの開発

トランザクション コンポーネントを作成するには、トランザクションを設計し、ビジネス プロセス用のトランザクション プロパティを設定する必要があります。トランザクションの設計とトランザクション プロパティの設定の詳細については、次のトピックを参照してください。

  • ビジネス プロセスの設計

  • トランザクションの設計

  • XLANG スケジュール フローチャートのトランザクションのプロパティ

最も効率的なトランザクションの構成を特定するのに役立つテクニックについては、「構成のパフォーマンスの評価」を参照してください。

トランザクション コンポーネントを作成するには、処理対象となるトランザクションの種類をあらかじめ特定しておく必要があります。アプリケーション間や企業間の環境では、トランザクションに関するニーズと、トランザクションのプロファイルを特定する必要があります。たとえば、あるトランザクションでカスタム XML 書式の注文書を受信し、それを標準 EDI 書式の注文書にマップして、後でカスタム社内アプリケーションで処理する、といったシナリオがあります。

このシナリオでは、XML 書式による注文書用の仕様と、EDI 書式による注文書用の仕様を作成する必要があります。これらの仕様を作成するには、XML および EDI によるテンプレートが用意されている BizTalk エディタを使用します。テンプレートには、使用される可能性のあるレコードとフィールドがすべて含まれています。そのため、不要なレコードとフィールドを削除してから、最終的な仕様としてテンプレートを保存してください。設計時には、検証が必要となるフィールドが仕様に含まれている場合、BizTalk Server 2000 のパフォーマンス低下の原因となることに注意してください。仕様の最適化の詳細については、「仕様の作成と最適化」を参照してください。

仕様を作成する以外に、データのマップも行う必要があります。データをマップ ファイルに変換する方法は、単純な XSLT 変換、Functoid、カスタム スクリプトの使用などいくつもありますが、すべてパフォーマンスに影響を及ぼすため、さまざまな変換方法をテストすることが重要です。データ変換方法をテストしてほかの方法と比較しておくと、マッピングによる BizTalk Server のパフォーマンスへの影響を軽減させることができます。詳細については、「マップの作成と最適化」を参照してください。

関連項目

ビジネス プロセスの設計

トランザクションの設計

トランスポートの識別

XLANG スケジュール フローチャートのトランザクションのプロパティ


トランスポートの識別

データの送信および受信方法を決定するには、次の機能を使用するかどうかについて検討する必要があります。

  • 企業間トランザクション

  • アプリケーション間トランザクション

  • トランスポート サービス (送信および受信)

  • 暗号化

  • HTTPS または S/MIME

処理するトランザクションの種類に合わせて異なるトランスポートを使用する必要があるかどうかについて、考慮してください。また、企業間トランザクションとアプリケーション間トランザクションに専用のトランスポートが必要かどうか、およびこの 2 種類のトランザクションに使用できるトランスポートがあるかどうかを把握しておきます。


初期アーキテクチャ

初期アーキテクチャを正しく計画するには、次の点を考慮に入れてください。

  • 処理するトランザクションの量が少ない場合は、Microsoft SQL Server と BizTalk Server がインストールされたサーバー 1 台だけで運用できます。

  • トランザクションの量が中程度の場合は、BizTalk Server と SQL Server を別のコンピュータにインストールして使用します。

  • データの送受信には、既存の SMTP トランスポート サービスを使用できます。この種類のトランスポートを実行するサーバーとして、別のサーバーを用意することをお勧めします 。

  • HTTP、メッセージ キュー、またはファイル トランスポート サービスを使用すると、ローカルの BizTalk Server とは別のサーバーのディスク装置にデータを書き込むことができるので、BizTalk Server のパフォーマンスが向上します。

初期アーキテクチャでは、サーバー機能をできる限り分散させてください。たとえば、社内である人が SMTP サーバーとメッセージ キューを管理し、別の人がセキュリティ ポリシーを担当していることがあるためです。初期アーキテクチャの目標は、必要なサーバーの数と、それらのサーバーが担当する処理に必要なハードウェアを決定することです。必要なサーバー数が決まったら、初期アーキテクチャをテストします。

関連項目

アーキテクチャのテストと分析


アーキテクチャのテストと分析

アーキテクチャのテストに先立って、アーキテクチャのコンポーネントを定義し、トランザクションに関するニーズとプロファイル、作成する必要のあるトランザクション コンポーネント、および必要なトランスポートを特定します。最初に基本的な部分を作成しますが、それには次の作業が必要です。

  • トランザクションの処理に必要な BizTalk メッセージ サービス、組織、ドキュメント定義、チャネル、およびメッセージ ポートを構成します。

  • BizTalk オーケストレーション サービスを構成します。

  • XLANG スケジュールに必要な COM+ アプリケーション、BizTalk Server のチャネル、データベース、またはメッセージ キューをインストールあるいは構成します。

基本的な部分の構築が終わったら、BizTalk Server を使用してトランザクションを処理します。このテストによって、パフォーマンスに影響を与える要因を見極めることができます。

ここには次のトピックが含まれます。

  • 構成のパフォーマンスの評価

  • アーキテクチャの改良

関連項目

アーキテクチャの設計

BizTalk Server の拡張


構成のパフォーマンスの評価

BizTalk メッセージ サービスのパフォーマンスは、Microsoft Windows 2000 に用意されているパフォーマンス ツールを使用してテストできます。

パフォーマンス ツールを使用するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[パフォーマンス] をクリックします。パフォーマンス ツールに含まれるシステム モニタには、カウンタ値の変化が常時グラフィカルに表示されます。さまざまなカウンタがあるため、監視対象のシステム コンポーネントに合わせて監視するカウンタを決める必要があります。Windows 2000、IIS、SQL Server、およびメッセージ キューのパフォーマンスを監視する方法を説明したホワイト ペーパーは数多くあります。次の表は、監視対象となる主なオブジェクトおよびカウンタの一覧です。この表では、監視対象のオブジェクトおよびカウンタに関連した、BizTalk メッセージ サービスのパフォーマンスを評価するための情報も示しています。

オブジェクト | カウンタ | 監視する内容 | 関係するコンポーネント
Active Server Pages | Requests Queued | ピーク時間帯を除いて、大量のキューが発生していないことを確認します。 | .asp ページを使用する HTTP トランスポート サービス
 | Requests/Sec | HTTP トランスポート サービスが ASP を使用している場合に、受信している ASP 要求の量を示しています。ファイルが HTTP ページにポストされる場合は、このカウンタは正確な情報を提供しなくなります。 | .asp ページを使用する HTTP トランスポート サービス
 | Request Wait Time | 0 に近いことを確認します。 | .asp ページを使用する HTTP トランスポート サービス
Network Interface | Bytes Received/sec、Bytes Sent/sec | この数値が接続の容量限度に近くなり、プロセッサとメモリの使用率が中程度になっている場合は、接続によるパフォーマンスへの影響が発生します。 | すべて
Process | Private Bytes | メモリ リークが発生していないかどうか、サイズが利用可能な RAM の最大値に近づいていないかどうかを、これで監視します。 | HTTP トランスポート サービス
Memory | Available Bytes | 利用可能なバイト数が、10 MB 未満にならないようにします。10 MB を下回った場合は、メモリ使用率が一時的に増加したときにディスクへのページングが行われます。 | すべて
 | Page Faults/sec、Pages Input/sec、および Page Reads/sec | この数値が小さい場合は、サーバーは短時間で要求に応答します。数値が大きい場合は、サーバーのメモリ量を増やす必要があります。 | すべて
PhysicalDisk | Disk Reads/sec、Disk Writes/sec | この 2 つのカウンタの合計が、ディスク デバイスの最大容量よりもはるかに小さい値になっている必要があります。このカウンタを有効にするには、[スタート] メニューの [プログラム] をポイントし、[アクセサリ] をポイントして、[コマンド プロンプト] をクリックします。次に、[コマンド プロンプト] で「diskperf -y」と入力し、コンピュータを再起動します。 | SQL Server、メッセージ キュー、およびファイル トランスポート サービス
 | % Disk time | このカウンタは、100% をかなり下回っている必要があります。この値が 100% を超える場合 (1000% まで上昇する可能性あり) は、物理ディスクを増設するか、またはデータベースの 1 つを別のサーバーに移動します。 | SQL Server、メッセージ キュー、およびファイル トランスポート サービス
 | Current Disk Queue Length | このカウンタは、パフォーマンス データの収集中に、ディスクに一時置かれた要求の数を示しています。この数値が平均で 2 未満であれば、パフォーマンスは良好です。 | [BizTalk Server] : SQL Server
SQL Server.Databases | Transactions/sec | SQL Server が実際に実行したトランザクションの量を示しています。 | SQL Server
BizTalk Server | Documents Processed/sec | BizTalk Server 2000 が、どれほどの速さで作業キューからドキュメントをポーリングし、送信したかを示しています。 | BizTalk メッセージ サービス
BizTalk Server | Documents Received/sec | BizTalk Server が、どれほどの速さでドキュメントを作業キューに送信したかを示しています。この数値は、BizTalk Server が受信したドキュメント数 (解析に失敗したドキュメントを含む) だけを表しており、BizTalk Server が作業キューにチェックポイントを設定したドキュメント数は含まれません。作業キューにチェックポイントを設定されたドキュメント数は、基本的に Documents Processed/sec カウンタと等しくなります。 | BizTalk メッセージ サービス
BizTalk Server | Synchronous Submissions/sec、Asynchronous Submissions/sec | Sumbit メソッドや SubmitSync メソッド呼び出しが、どれだけの速さで行われたかを示しています。インターチェンジに含まれるドキュメントの数は特に決まっていないため、このカウンタは処理されたドキュメント数の確認には役立ちません。パススルー送信 (インターチェンジを解析せずに処理する) のみが使用されている場合に受信パフォーマンスを確認するには、このカウンタを監視します。 | BizTalk メッセージ サービス
MSMQ Queue | Messages in queue | この数値があまり(50K 以上) 大きくならないようにします。大きくなりすぎると、メッセージ キュー サーバーのメモリが大量に消費され、システムのパフォーマンスが全般にわたって低下します。 | メッセージ キュー トランスポート サービス
System | Processor Queue Length | システム内のすべてのプロセッサが共有しているキューで、実行されるのを待機しているスレッドの数を示しています。このカウンタの値が常に 2 または 3 スレッド以上ある場合は、プロセッサの速度が原因で、システムのパフォーマンスが全般にわたって低下しています。 | すべて
 | Context Switches/sec | BizTalk Server コンピュータでこの数値が高くなっている場合は、同じサーバーで送信機能と受信機能を実行していることが原因です。その場合は、送信機能と受信機能を別のサーバーに分離することを検討してください。 | すべて
Processor | %Processor Time | ネットワーク アダプタ カードとディスク入出力容量に余裕がある場合にこのカウンタの値が大きいときは、プロセッサがパフォーマンス低下の原因になっています。マルチ プロセッサ システムの場合は、このカウンタがアンバランスになっていないかどうかを調べてください。また、ピーク時の使用率は 100% になってもかまいませんが、通常時の使用率は 100% 未満になっている必要があります。サーバー機能は、すべて水平方向に拡張することが可能です。 | すべて
Web Service | Get Requests/sec Post Requests/sec | HTTP の get および post メソッドによって受信されているファイルの量を示しています。 | HTTP トランスポート サービス

入手可能な SMTP トランスポート サービス製品は数多くあるため、SMTP トランスポート サービス専用のカウンタは一覧に示していません。使用中の SMTP トランスポート サービスが何であるかにかかわらず、BizTalk Server との間で送受信されるメッセージの量を監視するようにしてください。この表に示したカウンタを監視すると、パフォーマンスの低下を確認することができます。システムの正常な動作は、すべてのコンポーネントが連携して動作することで保たれています。そのため、1 種類のパフォーマンスが低いという理由で、システム構成に大幅な変更を加えないでください。

パフォーマンスの監視によって得られたデータは、問題に発展し得る兆候を把握するうえでも役立ちます。たとえば、ディスク入出力の値が高い場合は、SQL Server がディスクに大量のデータを書き込んでいるか、システムによるディスクへのページングが頻繁に発生している可能性があります。ディスクへのページングが頻繁に行われるのは、ほとんどの場合、メモリの量が少なすぎることが原因です。このケースでは、ディスク入出力自体には問題はありませんが、ほかの問題を発見するきっかけになります。

関連項目

BizTalk Server の拡張


アーキテクチャの改良

パフォーマンスに影響を与えている部分がわかったら、システムのアーキテクチャを調整して、最大限のパフォーマンスが得られるようにします。たとえば、ハードウェアをアップグレードしたり、BizTalk Server のコンポーネントを別のサーバーに移動したりします。また、BizTalk Server の設定も調整する必要があります。設定の調整については、「サーバーのプロパティの最適化」を参照してください。

変更は計画的に行ってください。CPU の増設、設定の変更、別のサーバーへの機能の分離などの変更を実施したら、変更内容を文書化し、新しい構成をテストして、パフォーマンスが向上したかどうかを確認します。新しい構成でパフォーマンスが向上した場合は、構成をさらに変更します。一方、新しい構成でパフォーマンスが低下した場合は、システムの構成を前の状態に戻し、データを分析して問題の原因を確認してください。

関連項目

構成のパフォーマンスの評価


パフォーマンスの維持

パフォーマンスを維持するには、BizTalk Server の動作を正常な状態に保ち、将来にわたってパフォーマンスを確保するための、実務的なメンテナンス計画を作成します。BizTalk Server が処理するドキュメントの数は、しだいに増加していくのが普通です。BizTalk Server の初期アーキテクチャが正常に機能していても、トランザクションの数が増加していくと、システムのアーキテクチャや構成を変更しない限り同じレベルのパフォーマンスは維持できなくなります。ハードウェアの故障やメモリ不足も、システムのパフォーマンスに影響を与えます。

ここには次のトピックが含まれます。

  • パフォーマンスのメンテナンス計画の作成

  • Application Center 2000 の使用


パフォーマンスのメンテナンス計画の作成

監視計画には、次の項目を含めてください。

  • どのカウンタを監視するかを詳細に計画します。Windows 2000 のシステム モニタのカウンタは数多くあり、監視すべきしきい値、およびしきい値から導き出される問題の解釈も多数存在します。また、SQL Server のクエリが有効なデータまたはハードウェアの問題を返しているかどうかなど、アプリケーション レベルの問題も監視できます。

  • パフォーマンスにおける問題を解決するための手順を明確にします。たとえば、Windows 2000 イベント ログにメッセージを書き込む、電子メールによる通知を有効にする、カスタム プログラムによって一連のイベントを開始するなどがあります。

  • パフォーマンスしきい値がどの値に達した時点で通知を生成するのかを決めます。たとえば、CPU 使用率が 90% に達した時点で Windows 2000 イベント ログにイベントを書き込むように監視ツールを構成します。また、CPU 使用率が 90% 以上のまま 5 分間経過したときに、電子メール メッセージが送信されるようにします。使用する監視ツールの操作方法に従って、問題の重大度レベルごとに別のアクションを定義してください。

  • Windows 2000 イベント ログにイベントが書き込まれた場合に、それに対処する一連のアクションを定義します。Windows 2000、BizTalk Server 2000、SQL Server、およびメッセージ キューや HTTP などの組み込み Microsoft トランスポート サービスは、Windows 2000 イベント ログにイベントを書き込みます。イベント ログには、BizTalk Server システムを構成するサーバーのいずれかで問題が発生しそうになっていることを示す、有用な情報が含まれています。早めに対処しておくと、システムのパフォーマンスが全般にわたって低下するようなシステム障害を回避できます。計画では、ログの監視とアーカイブを行う頻度を定め、作業の担当者も決めておきます。サード パーティ製ツールを利用して複数のサーバーからログを収集し、それらをデータベースに書き込んで総合的に分析する方法もあります。このようなツールを利用すると、サーバーからログを削除することもできます。

  • パフォーマンスの監視に必要なツールを決定します。Windows 2000 に組み込まれたシステム モニタ ツールは、パフォーマンス カウンタを監視し、あらかじめ定義しておいた条件が満たされた場合に特定のアクションを実行できます。システム モニタ警告の構成の詳細については、Windows 2000 ヘルプの「監視の構成を設定する」を参照してください。また、Microsoft Application Center 2000 や多くのサード パーティ製ツールを利用すると、アクションの実行に加えて、データベースへのログ記録やアプリケーション レベルのテストなどの機能も実行できます。


Application Center 2000 の使用

Microsoft Application Center 2000 には、ヘルス モニタというツールが含まれています。ヘルス モニタは、Windows 2000 イベント ログおよびシステム モニタ ツールの代替ツールとして利用できます。ヘルス モニタを使用すると、管理者が監視対象を設定できるようになります。監視対象としては、TCP/IP、パフォーマンス モニタのカウンタのしきい値、イベント ログのエラー、および WMI イベントのチェックなどがあります。監視対象に対して条件を構成することができ、CPU 使用率が 90% 以上に達するなど一定の条件を満たした場合に、サーバーをオフラインにする、管理者に電子メールを送信するなどのアクションを実行できます。これらのツールを使用すると、BizTalk Server 2000 のパフォーマンスを予防的に監視し、維持することができます。

重要

  • XLANG スケジュールをホストする既定の XLANG スケジューラ アプリケーションや COM+ アプリケーションは、複製しないでください。コンポーネント負荷分散 (CLB) を使用するときは、COM+ アプリケーションを必ずそれぞれのサーバーにインストールしてください。XLANG スケジュールにバインドされている COM コンポーネントは、複製することができます。


サーバーおよびアプリケーションの管理

Microsoft BizTalk Server 2000 の管理機能を使用すると、インストールされている BizTalk Server 2000 を効率的かつ効果的に管理できます。BizTalk Server 2000 の管理には、次の 4 つの領域があります。

  • サーバー管理

  • アプリケーション管理

  • プログラムによる管理

  • データベース管理

ここではサーバー管理とプログラムによる管理について説明します。アプリケーション管理およびデータベース管理の詳細については、「BizTalk Server の管理モデル」を参照してください。サーバー管理には、サーバー グループ、サーバー、受信機能、および各サーバー グループの共有キューの構成と管理が含まれます。アプリケーション管理には、XLANG スケジュールを提供する COM+ アプリケーション、既定の XLANG スケジューラ アプリケーション、およびオーケストレーション データベースの構成と管理が含まれます。

ここには次のトピックが含まれます。

  • サーバーの管理

  • プログラムによる管理

関連項目

BizTalk Server の管理モデル


サーバーの管理

BizTalk Server 管理コンソールは集中的なユーザー インターフェイス (UI) を提供します。これを使用して、次のことを行えます。

  • Microsoft BizTalk Server 2000 と共にインストールされたサーバーをサーバー グループに追加し、管理する。

  • 共有キュー データベースと追跡データベースの場所などのサーバー グループのプロパティを構成する。

  • 受信機能を構成および管理する。

  • キューを表示し、管理する。

特定の作業のヘルプについては、「操作方法」を参照してください。

一般的な情報については、「概念」を参照してください。

問題を解決するためのヒントについては、「BizTalk Server 管理のトラブルシューティング」を参照してください。

関連項目

BizTalk Server 管理コンソールの環境


操作方法

ここでは、BizTalk Server 管理コンソールの使用について、作業ごとに説明します。「概念」を参照し、BizTalk Server 管理コンソールのすべての機能について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk Server 管理コンソールを開く

  • コンポーネント サービスを開く

  • BizTalk Server Administrators グループへのユーザーの追加

  • BizTalk メッセージ管理データベースの構成

  • 管理コンソールの更新

  • BizTalk メッセージ サービスの開始

  • サーバー グループの追加、削除、および構成

  • グループ内のサーバーの追加、削除、および構成

  • グループ内のサーバーの実行

  • キューの管理

  • サーバー グループのデータベースの管理

  • サーバー グループの受信機能の管理

  • イベント ビューアの管理

  • XLANG アプリケーションとデータベースの管理


BizTalk Server 管理コンソールを開く

  • [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk Server 管理コンソール] をクリックします。


コンピュータの管理を開く

  • [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。


BizTalk Server Administrators グループへのユーザーの追加

BizTalk Server Administrators グループにユーザーを追加するには、Windows 2000 Administrators グループのメンバーである必要があります。Windows 2000 Administrators グループへのユーザーの追加の詳細については、「Administrators グループへのユーザー アカウントの追加」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. [システム ツール] を展開し、[ローカル ユーザーとグループ] を展開します。次に、[グループ] フォルダをクリックします。

    詳細ウィンドウにフォルダの内容が表示されます。

  3. 詳細ウィンドウで [BizTalk Server Administrators] をクリックします。

  4. [操作] メニューの [すべてのタスク] をポイントし、[グループに追加] をクリックします。

    [BizTalk Server Administrators のプロパティ] ダイアログ ボックスが表示されます。

  5. [追加] をクリックします。

  6. [場所] ボックスの一覧で、ドメイン名またはコンピュータ名をクリックします。

  7. 手順 6. で選択したドメインまたはコンピュータと関連付けられたユーザーまたはコンピュータを含む一覧で、追加するユーザー アカウントをクリックし、[追加] をクリックします。次に [OK] をクリックします。

  8. [OK] をクリックして、[BizTalk Server Administrators のプロパティ] ダイアログ ボックスを閉じます。

注

  • ここでは、BizTalk Server Administration グループの名前が BizTalk Server Administrators であると想定しています。

  • 必要に応じて、いったんログオフしてから、自分のユーザー アカウントを使用してログインしてください。

関連項目

管理者特権


BizTalk メッセージ管理データベースの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] をクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [Microsoft BizTalk Server 2000 のプロパティ] ダイアログ ボックスが表示されます。

  3. [全般] タブで、次のプロパティを変更することができます。
    • [SQL データベース名] : すべてのサーバー グループで使用する BizTalk メッセージ管理データベースの名前を入力します。

    • [SQL Server 名] : BizTalk メッセージ管理データベースが格納されている Microsoft SQL Server データベースがあるサーバーの名前を入力します。

    • [ユーザー名] : BizTalk メッセージ管理データベースが格納されているサーバーへの接続に使用する SQL Server のログオン ユーザー名を変更することができます。

    • [パスワード] : BizTalk メッセージ管理データベースが格納されているサーバーへの接続に使用する SQL Server のログオン パスワードを変更することができます。
  4. [OK] をクリックします。

注意

  • BizTalk メッセージ管理データベースをメンテナンスの目的でオフラインにする場合に、この操作を行います。ただし、ほかのサーバー グループと関連付けられている別の BizTalk メッセージ管理データベースではなく、複製されたデータベースを指定する必要があります。データベースの変更の詳細については、「BizTalk メッセージ管理データベースの変更」を参照してください。

注

  • BizTalk メッセージ管理データベースを変更するか、別の Microsoft SQL Server にサーバー グループを指定する場合は、次の操作を行う必要があります。
    1. Microsoft BizTalk Server 2000 ノードのすべてのサーバーを停止します。サーバーを停止する方法の詳細については、「グループ内のサーバーの停止」を参照してください。

    2. BizTalk Server インターチェンジ アプリケーションをシャットダウンします。BizTalk Server インターチェンジ アプリケーションをシャットダウンする方法の詳細については、「BizTalk Server インターチェンジ アプリケーションのシャットダウン」を参照してください。

    3. Microsoft BizTalk Server 2000 ノードのすべてのサーバーを再起動します。サーバーを再起動する方法の詳細については、「グループ内のサーバーの起動」を参照してください。

    BizTalk メッセージ管理データベースを変更したり、別の Microsoft SQL Server にサーバー グループを指定すると、中央 BizTalk メッセージ管理データベース内のすべての BizTalk Server は新しい情報で更新されます。

  • 既存のサーバーの BizTalk メッセージ管理データベースを変更した後で、新しいグループに既存のサーバーを追加すると、既存のサーバーへのドキュメントの送信に問題が生じることがあります。問題の発生を避けるには、Microsoft BizTalk Server 2000 ノードのすべてのサーバーを停止し、BizTalk Server インターチェンジ アプリケーションをシャットダウンしてから、そのノードのすべてのサーバーを再起動します。サーバーを停止する方法の詳細については、「グループ内のサーバーの停止」を参照してください。BizTalk Server インターチェンジ アプリケーションをシャットダウンする方法の詳細については、「BizTalk Server インターチェンジ アプリケーションのシャットダウン」を参照してください。サーバーを再起動する方法の詳細については、「グループ内のサーバーの起動」を参照してください。

関連項目

BizTalk メッセージ管理データベースの変更

BizTalk Server インターチェンジ アプリケーションのシャットダウン

グループ内のサーバーの起動

グループ内のサーバーの停止


管理コンソールの更新

  1. BizTalk Server 管理コンソールで、[Microsoft BizTalk Server 2000] を展開します。更新する項目が表示されるまでコンソール ツリーの項目を展開していきます。更新する項目を見つけるには、サーバー グループ、キュー、受信機能、およびサーバーを展開する必要が生じる場合もあります。

  2. 更新する項目をクリックします。

  3. [操作] メニューの [最新の情報に更新] をクリックします。

注

  • BizTalk Server 管理コンソールでは、次の項目の状態を更新することができます。
    • Microsoft BizTalk Server 2000 ノード

    • サーバー グループ

    • サーバー

    • キュー

    • 受信機能
  • この操作は、コンソール ツリーの任意の項目で実行することができます。ルートで管理コンソールを更新すると、管理コンソール内のすべての項目が更新されます。サーバー グループを更新すると、そのグループ内の項目だけが更新されます。

  • 管理コンソールには自動更新間隔はありません。サーバー グループ、サーバー、受信機能、キュー内の項目数などの現在の状態を表示するには、この操作を行ってください。

関連項目

グループとサーバー

受信機能

キューの使用


BizTalk メッセージ サービスの開始

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. [サービス (ローカル)] をクリックします。

  3. 詳細ウィンドウで [BizTalk Messaging Service] をクリックします。

  4. [操作] メニューの [開始] をクリックします。


サーバー グループの追加、削除、および構成

サーバー グループを追加、削除、および構成するには、次の操作を行います。

  • サーバー グループの追加

  • サーバー グループの全般プロパティの構成

  • サーバー グループの接続のプロパティの構成

  • サーバー グループの追跡のプロパティの構成

  • サーバー グループのパーサー順序の構成

  • サーバー グループの削除


サーバー グループの追加

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] をクリックします。

  2. [操作] メニューの [新規作成] をポイントし、[グループ] をクリックします。

    [新しいグループ] ダイアログ ボックスが表示されます。

  3. [グループ名] ボックスに新しいサーバー グループの名前を入力します。

  4. [追跡データベース] で次の操作を行います。
    • [追跡データベース名] ボックスに、このサーバー グループの追跡データベースの名前を入力します。

    • [追跡 SQL Server 名] ボックスに、このサーバー グループの追跡データベースが格納されているサーバーの名前を入力します。

    • [ユーザー名] ボックスと [パスワード] ボックスに、その追跡データベースが格納されているサーバーへの接続に使用する Microsoft SQL Server のログオン ユーザー名とログオン パスワードを入力します。

      [ユーザー名] は必須フィールドです。[パスワード] は省略可能なフィールドです。サーバーへの接続でパスワードが要求されない場合は、このフィールドは空白のままにしてください。

  5. [共有キュー データベース] で次の操作を行います。
    • [共有キュー データベース名] ボックスに、このサーバー グループの共有キュー データベースの名前を入力します。

    • [共有キュー SQL Server 名] ボックスに、このサーバー グループの共有キュー データベースが格納されているサーバーの名前を入力します。

    • [ユーザー名] ボックスと [パスワード] ボックスに、その共有キュー データベースが格納されているサーバーへの接続に使用する SQL Server のログオン ユーザー名とログオン パスワードを入力します。

      [ユーザー名] は必須フィールドです。[パスワード] は省略可能なフィールドです。サーバーへの接続でパスワードが要求されない場合は、このフィールドは空白のままにしてください。

  6. [OK] をクリックします。

重要

  • サーバー グループの名前に ` !、@、#、$、%、^、&、*、(、)、+、=、[、]、{、}、|、\\、;、\、"、'、<、>、,、.、および ? の文字を使用することはできません。無効な文字の詳細については、「WMI の概要」を参照してください。

注

  • これはサーバー グループを作成するための操作です。設定を追加してサーバー グループを構成するには、「サーバー グループの全般プロパティの構成」を参照してください。

関連項目

グループ内のサーバーの追加、削除、および構成

サーバー グループの全般プロパティの構成

グループとサーバー

BizTalk メッセージ管理データベースの管理

共有キュー データベース

追跡データベース

WMI の概要


サーバー グループの全般プロパティの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [SMTP ホスト] ボックスに、このサーバー グループで使用する Simple Mail Transfer Protocol (SMTP) ホスト名を入力します。

    このフィールドは省略できます。BizTalk Server で、SMTP を使用して取引先または内部アプリケーションにドキュメントを送信する場合は、この構成が必要です。

  4. [信頼できるメッセージの返信先 URL] ボックスに、ファイル、メッセージ キュー、HTTP、HTTP/S、または SMTP のいずれかのサポートされるプロトコルを使用して、このサーバー グループが信頼できるメッセージ配信受信確認を受信するために使用する URL を入力します。
    トランスポートの種類 | 使用するプレフィックス
    ファイル | file://
    メッセージ キュー | queue://Direct=OS:<servername>\<queuename>
    Hyper Text Transport Protocol (http) | http://
    Hyper Text Transport Protocol Secure (https) | https://
    SMTP | mailto:

    メッセージ キューを指定する場合は、書式名を使用します。また、書式名の前に "queue://" を付ける必要があります。書式名の詳細については、「利用可能な受信機能」を参照してください。

  5. [メッセージ管理オブジェクト キャッシュの更新間隔 (秒)] ボックスの一覧で、サーバー グループのキャッシュ更新間隔に設定する秒数をクリックします。

    既定では、サーバーは 50 秒ごとにこのキャッシュを更新します。

  6. プロキシ サーバーを経由してインターネットに接続するように BizTalk Server を構成する場合は、[プロキシ サーバー] で [プロキシ サーバーを使用] チェック ボックスをオンにします。

    使用するプロキシ サーバーのアドレスとポートを入力します。

  7. [OK] をクリックします。

  8. [プロキシ サーバー] に変更を加えた場合にのみ、次の操作を行います。
    • 一般プロパティを構成したグループ内の各サーバーを停止します。サーバーの停止の詳細については、「グループ内のサーバーの停止」を参照してください。

    • 一般プロパティを構成したグループ内の各サーバーを起動します。サーバーの起動の詳細については、「グループ内のサーバーの起動」を参照してください。

重要

  • [SMTP ホスト] フィールドは省略できます。ただし、BizTalk メッセージ マネージャでトランスポート サービスとして SMTP を使用する場合は、このフィールドを構成する必要があります。たとえば、ここで SMTP ホストを構成しないと、BizTalk メッセージ マネージャでプライマリ トランスポートまたはバックアップ トランスポートとして SMTP を選択することができません。

注

  • BizTalk Server で信頼できるメッセージ処理は、BizTalk Framework 2.0 に準拠しているものです。信頼できるメッセージ処理と BizTalk Framework 2.0 の詳細については、Microsoft の Web サイト (www.microsoft.com/japan/biztalkserver/) で "BizTalk Framework 2.0" を検索してください。

  • [信頼できるメッセージの返信先 URL] を構成する場合は、ASP を利用したページ、または受信機能によって監視されるメッセージ キューを使用します。最初に独自の ASP ページを構成しない場合は、BizTalk Server に含まれる ReceiveStandard.asp ファイルを使用します。このサンプル ASP ページは \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Receive Scripts にあります。このページはポストを取得し、BizTalk Server に送信するためのものです。セキュリティで保護されたサイトの実装の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) にアクセスして、"Implementing a Secure Site with ASP" を検索してください。

  • [信頼できるメッセージの返信先 URL] ボックスに localhost を含む URL を指定すると、受信機能は正しく動作しません。このフィールドにローカル ホストを指定することはできません。

  • HTTP ポストへの応答はテキストにする必要があります。応答がバイナリ データを要求する場合は、MIME または UUEncode を使用してバイナリ データをエンコードします。

関連項目

管理キャッシュ

利用可能な受信機能

グループ内のサーバーの起動

グループ内のサーバーの停止


サーバー グループの接続のプロパティの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [接続] タブをクリックします。

  4. [追跡データベース] で次の操作を行います。
    • [追跡データベース名] ボックスに、このサーバー グループで使用する追跡データベースの名前を入力します。

    • [追跡 SQL Server 名] ボックスに、このサーバー グループで使用する追跡データベースを格納している Microsoft SQL Server の名前を入力します。

    • [ユーザー名] ボックスと [パスワード] ボックスに、その追跡データベースが格納されているサーバーへの接続に使用する Microsoft SQL Server のログオン ユーザー名とログオン パスワードを入力します。
  5. [共有キュー データベース] で次の操作を行います。
    • [共有キュー データベース名] ボックスに、このサーバー グループで使用する共有キュー データベースの名前を入力します。

    • [共有キュー SQL Server 名] ボックスに、このサーバー グループで使用する共有キュー データベースを格納している Microsoft SQL Server の名前を入力します。

    • [ユーザー名] ボックスと [パスワード] ボックスに、その共有キュー データベースが格納されているサーバーへの接続に使用する SQL Server のログオン ユーザー名とログオン パスワードを入力します。
  6. [OK] をクリックします。

注

  • [追跡データベース] または [共有キュー データベース] の情報を変更した場合は、次の操作を行う必要があります。
    1. Microsoft BizTalk Server 2000 ノードのすべてのサーバーを停止します。サーバーを停止する方法の詳細については、「グループ内のサーバーの停止」を参照してください。

    2. BizTalk Server インターチェンジ アプリケーションをシャットダウンします。BizTalk Server インターチェンジ アプリケーションをシャットダウンする方法の詳細については、「BizTalk Server インターチェンジ アプリケーションのシャットダウン」を参照してください。

    3. Microsoft BizTalk Server 2000 ノードのすべてのサーバーを再起動します。サーバーを再起動する方法の詳細については、「グループ内のサーバーの起動」を参照してください。
  • [追跡データベース] の値を変更する場合は、Connection.vb ファイルの接続文字列を新しい追跡データベース情報で更新する必要があります。Connection.vb は、\Program Files\Microsoft BizTalk Server\BizTalkTracking\VBScripts フォルダにあります。接続文字列の Initial Catalog プロパティには、その追跡データベースの名前が含まれています。このプロパティを更新して、追跡データベース名を更新します。次に、Connection.vb ファイルの接続文字列を示します。
    Const g_ConnectionString = "Provider=SQLOLEDB.1;
Persist Security Info=False;User ID=dta_ui_login;
Password=;Initial Catalog=<databasename>;
Data Source=<servername>;Connect Timeout=15"

関連項目

利用可能な受信機能

グループとサーバー

BizTalk Server インターチェンジ アプリケーションのシャットダウン

グループ内のサーバーの起動

グループ内のサーバーの停止


サーバー グループの追跡のプロパティの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [追跡] タブをクリックします。

  4. [ドキュメント トラッキングを有効にする] チェック ボックスと、使用する次のいずれかのオプションのチェック ボックスをオンにします。
    • 受信インターチェンジをログに記録するには、[受信インターチェンジを記録する] チェック ボックスをオンにします。

    • 送信インターチェンジをログに記録するには、[送信インターチェンジを記録する] チェック ボックスをオンにします。

    • MIME エンコード メッセージをログに記録するには、[元の MIME エンコード メッセージを記録する] チェック ボックスをオンにします。
  5. [OK] をクリックします。

注意

  • [ドキュメント トラッキングを有効にする] チェック ボックスをオフにすると、追跡機能を無効にすることができます。ただし、ドキュメント トラッキングを無効にすると、BizTalk Server 2000 の重要な機能を失うことになります。追跡の詳細については、「サーバー グループの追跡設定について」を参照してください。

注

  • [ドキュメント トラッキングを有効にする] チェック ボックスがオフになっている場合は、[受信インターチェンジを記録する] チェック ボックス、[送信インターチェンジを記録する] チェック ボックス、および [元の MIME エンコード メッセージを記録する] チェック ボックスは利用できません。

関連項目

グループとサーバー

サーバー グループの追跡設定について


サーバー グループのパーサー順序の構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、パーサーの順序を構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [パーサー] タブをクリックします。

    パーサーは [サーバーの呼び出し順序の整列] ボックスに、次の順序で一覧表示されます。

    • BizTalk.ParserXML.1

    • BizTalk.ParserEdifact.1

    • BizTalk.ParserX12.1

    • BizTalk.ParserFFile.1

最もよく使用するパーサーを一覧の上の方に移動すると、BizTalk Server のパフォーマンスを向上させることができます。

  4. [サーバーの呼び出し順序の整列] ボックスで、移動するパーサーをクリックします。上矢印または下矢印をクリックして、選択したパーサーを上または下に移動します。

  5. パーサーを希望する順序に整列したら、[OK] をクリックします。

注

  • [最新の情報に更新] をクリックすると、ローカル レジストリに登録された新しいパーサーを取得できます。新しいパーサーを [サーバーの呼び出し順序の整列] ボックスに表示するには、そのパーサーが登録されているサーバーで [最新の情報に更新] をクリックします。

関連項目

IBizTalkParserComponent インターフェイスの使用


サーバー グループの削除

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、削除するサーバー グループを展開します。

  2. 削除するサーバー グループにあるサーバーをクリックします。

  3. [操作] メニューの [停止] をクリックします。

    グループ内のサーバーそれぞれに対して手順 2. ～ 3. の操作を繰り返し、グループ内のすべてのサーバーを停止します。

  4. サーバー グループをクリックします。

  5. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  6. [はい] をクリックします。

注

  • 1 つ以上の実行中のサーバーを含むサーバー グループを削除することはできません。サーバーを停止し、サーバー グループを削除するには、グループ内のすべてのサーバーに対する Windows 2000 管理者特権が必要です。

  • サーバー グループに関連付けられた追跡データベースと共有キュー データベースは、グループを削除した後も Microsoft SQL Server 内に残ります。この追跡データベースと共有キュー データベースを削除するには、手動で削除します。これらのデータベースを削除する方法の詳細については、「追跡データベースと共有キュー データベースの削除」を参照してください。

関連項目

グループとサーバー

追跡データベースと共有キュー データベースの削除

グループ内のサーバーの停止


グループ内のサーバーの追加、削除、および構成

グループ内のサーバーを追加、削除、および構成するには、次の操作を行います。

  • グループへのサーバーの追加

  • グループからのサーバーの削除

  • グループ内のサーバーの構成

  • サーバーの BizTalk メッセージ管理データベースの変更


グループへのサーバーの追加

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、サーバーを追加するサーバー グループをクリックします。

  2. [操作] メニューの [新規作成] をポイントし、[サーバー] をクリックします。

    [BizTalk Server の追加] ダイアログ ボックスが表示されます。

  3. [BizTalk Server 名] ボックスに、BizTalk Server 2000 のインストールを完了した既存のサーバーの名前を入力します。

  4. [OK] をクリックします。

注

  • サーバーを追加したサーバー グループのプロパティ全体を表示するには、そのグループを右クリックし、[プロパティ] をクリックします。

関連項目

グループとサーバー

グループ内のサーバーの実行

サーバーのプロパティについて


グループからのサーバーの削除

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、削除するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

    サーバーの現在のインターチェンジとドキュメントに対するすべての処理が終了します。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

注

  • ドキュメントを処理するために受信機能によってポイントされているサーバーは、サーバー グループから削除することができません。ほかのサーバーをポイントするようにその受信機能を編集するか、今後使用しない場合はその受信機能を削除します。

関連項目

サーバーからのインターチェンジの解放

グループとサーバー

サーバー グループの受信機能の管理

グループ内のサーバーの実行


グループ内のサーバーの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、構成するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

    サーバーが実行中のときは、構成を変更することはできません。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [使用可能な受信機能スレッドの最大数] ボックスに、1 から 128 までの範囲の数値を入力します。

    既定値は 4 です。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  5. サーバーで作業キュー内の項目を処理する場合は、[作業項目の処理に参加する] チェック ボックスをオンにします。

    このチェック ボックスがオンになっていると、サーバーは作業キュー内のドキュメントを処理します。サーバーで作業キュー内のドキュメントを処理しない場合は、このチェック ボックスをオフにします。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  6. [プロセッサごとの使用可能な作業スレッドの最大数] ボックスに 1 から 128 までの範囲の数値を入力します。

    既定値は 4 です。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  7. [BizTalk Server スケジューラ呼び出しの間隔 (ミリ秒)] ボックスに 1 から 4,294,967,295 までの範囲の数値を入力します。

    既定値は 200 です。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  8. [OK] をクリックします。

  9. 構成したサーバーを右クリックし、[開始] をクリックします。

注

  • [作業項目の処理に参加する] チェック ボックスがオフになっている場合は、[プロセッサごとの使用可能な作業スレッドの最大数] チェック ボックスと [BizTalk Server スケジューラ呼び出しの間隔 (ミリ秒)] チェック ボックスは利用できません。

関連項目

グループとサーバー

グループ内のサーバーの実行

サーバーのプロパティについて


サーバーの BizTalk メッセージ管理データベースの変更

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、BizTalk メッセージ管理データベースを変更するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

  5. BizTalk Server 管理コンソールを閉じます。

  6. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  7. \Program Files\Microsoft BizTalk Server\Setup に移動します。

  8. BTSsetupDB.exe をクリックします。

  9. [ファイル] メニューの [開く] をクリックします。

    [Microsoft BizTalk Server 2000 メッセージ データベース セットアップ ウィザード] が表示されます。

  10. [Microsoft BizTalk Server 2000 メッセージ データベース セットアップ ウィザードへようこそ] ページで、[次へ] をクリックします。

  11. [BizTalk メッセージ管理データベースを構成します] ページで、[新しい BizTalk メッセージ管理データベースの作成] をクリックします。

    または

    [既存のデータベースの選択] をクリックします。

  12. [サーバー名] ボックスで、新しい、または既存の BizTalk メッセージ管理データベースがあるサーバーの名前をクリックします。

  13. 必要に応じて、[ユーザー名] ボックスと [パスワード] ボックスに、SQL サーバーにアクセスするための有効なユーザー名とパスワードを入力します。

  14. [データベース] ボックスに、新しい、または既存の BizTalk メッセージ管理データベースの名前を入力します。

  15. [次へ] をクリックします。

  16. [BizTalk Server グループの構成] ページで、[新しい BizTalk Server グループの作成] をクリックします。[グループ名] ボックスに新しいグループの名前を入力し、[次へ] をクリックします。

    または

    [既存の BizTalk Server グループの選択] をクリックします。[グループ名] ボックスの一覧で既存のグループの名前をクリックし、[次へ」をクリックします。

    手順 11. で既存のデータベースを選択した場合は、選択できるのは既存の BizTalk Server グループだけです。

  17. 必要に応じて、[新しい追跡データベースの作成] をクリックし、[次へ] をクリックします。

    または

    [既存のデータベースの選択] をクリックします。[サーバー名] ボックスの一覧で、サーバーをクリックします。必要に応じて、[ユーザー名] ボックスと [パスワード] ボックスに、有効な Microsoft SQL Server のユーザー名とパスワードを入力します。[データベース] ボックスに、データベースの名前を入力します。[次へ] をクリックします。

  18. 必要に応じて、[新しい共有キュー データベースの作成] をクリックし、[次へ] をクリックします。

    または

    [既存のデータベースの選択] をクリックします。[サーバー名] ボックスの一覧で、サーバーをクリックします。必要に応じて、[ユーザー名] ボックスと [パスワード] ボックスに、有効な SQL Server のユーザー名とパスワードを入力します。[データベース] ボックスに、データベースの名前を入力します。[次へ] をクリックします。

  19. [BizTalk Server グループの確認] ページで、入力した情報を確認して [次へ] をクリックします。

  20. [Microsoft BizTalk Server 2000 データベース セットアップ ウィザードの完了] ページで [完了] をクリックします。

  21. BizTalk Server 管理コンソールを開きます。

  22. [Microsoft BizTalk Server 2000] を展開し、BizTalk メッセージ管理データベースを変更したサーバーを含むサーバー グループを展開して、対象のサーバーをクリックします。

  23. [操作] メニューの [開始] をクリックします。

重要

  • サーバーを異なる BizTalk メッセージ管理データベースと関連付ける場合に、この操作を行います。BizTalk メッセージ管理データベース間でのサーバーの移動の詳細については、「BizTalk メッセージ管理データベース間でのサーバーの移動」を参照してください。サーバー グループの BizTalk メッセージ管理データベースの変更の詳細については、「BizTalk メッセージ管理データベースの変更」を参照してください。

関連項目

BizTalk メッセージ管理データベースの変更

BizTalk Server データベースの管理

BizTalk メッセージ管理データベース間でのサーバーの移動


グループ内のサーバーの実行

グループ内のサーバーを実行するには、次の操作を行います。

  • グループ内のサーバーの起動

  • グループ内のサーバーの停止

  • サーバーからのインターチェンジの解放


グループ内のサーバーの起動

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、起動するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [開始] をクリックします。

注

  • サーバー グループ内のサーバーを起動すると、そのサーバーの BizTalk メッセージ サービスも起動します。BizTalk メッセージ サービスが起動した後に、サーバーは Microsoft SQL Server データベースのキューに格納されたドキュメントの受信、送信、処理、および追跡を行うことができます。

  • [開始] はサーバーが停止している場合にのみ利用可能です。サーバーが実行中は利用できません。

関連項目

グループ内のサーバーの追加、削除、および構成

管理キャッシュ

グループとサーバー

グループ内のサーバーの停止


グループ内のサーバーの停止

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、停止するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

注

  • サーバー グループ内のサーバーを停止すると、そのサーバーの BizTalk メッセージ サービスも停止します。BizTalk メッセージ サービスが停止した後は、サーバーは Microsoft SQL Server データベースのキューに格納されているドキュメントの受信、送信、処理、または追跡を行うことができません。

  • 停止したサーバーに関連付けられているインターチェンジを再配布する場合は、「サーバーからのインターチェンジの解放」を参照してください。

関連項目

グループ内のサーバーの追加、削除、および構成

管理キャッシュ

サーバーからのインターチェンジの解放

グループとサーバー


サーバーからのインターチェンジの解放

ここでは、元のサーバーが停止したり、オフラインになっている場合に、グループ内のほかのサーバーにインターチェンジを再配布できるように、サーバーからインターチェンジを解放する方法について説明します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、インターチェンジを解放するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

  3. [操作] メニューの [すべてのタスク] をポイントし、[インターチェンジの解放] をクリックします。

関連項目

グループ内のサーバーの追加、削除、および構成

グループとサーバー

グループ内のサーバーの停止


キューの管理

ここには次のトピックが含まれます。

  • 保留キューへのドキュメントの移動

  • エラーの説明の表示

  • インターチェンジの表示

  • ドキュメントの表示

  • ドキュメントの再送信

  • ドキュメントの削除


保留キューへのドキュメントの移動

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、移動するドキュメントを含むグループを展開します。次に、[キュー] を展開します。

  2. 移動するドキュメントを含むキューを展開し、対象のドキュメントをクリックします。

  3. [操作] メニューの [すべてのタスク] をポイントし、[保留キューに移動] をクリックします。

関連項目

保留キュー

キューの使用


エラーの説明の表示

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、表示するドキュメントを含むグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、表示するドキュメントをクリックします。

  3. [操作] メニューの [エラーの説明の表示] をクリックします。

関連項目

保留キュー

キューの使用

ドキュメントの表示

インターチェンジの表示


インターチェンジの表示

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、表示するインターチェンジを含むグループを展開します。次に [キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、表示するインターチェンジをクリックします。

  3. [操作] メニューの [インターチェンジの表示] をクリックします。

    [ドキュメントの内容] ダイアログ ボックスが表示されます。

注

  • 大きなインターチェンジを表示しようとすると、データが切り捨てられることがあります。[ドキュメントの内容] ダイアログ ボックスで表示できるデータのサイズの上限は 4MB です。

  • BizTalk Server がインターチェンジを解析できなかった場合に、[ドキュメントの内容] ダイアログ ボックスにバイナリ データが表示されることがあります。パーサー エラーの詳細については、「解析エラー」を参照してください。

  • 保留キューが次のステータスの場合、[インターチェンジの表示] を利用できます。
    • カスタム コンポーネント

    • 解析

    • エンコード

    • 署名

    • 暗号化

    • 送信
  • [操作] メニューに [インターチェンジの表示] と [ドキュメントの表示] が同時に表示されることはありません。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

保留キュー

キューの使用

ドキュメントの表示

エラーの説明の表示


ドキュメントの表示

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、表示するドキュメントを含むグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、表示するドキュメントをクリックします。

  3. [操作] メニューの [ドキュメントの表示] をクリックします。

    [ドキュメントの内容] ダイアログ ボックスが表示されます。

注

  • 大きなドキュメントを表示しようとすると、データが切り捨てられることがあります。[ドキュメントの内容] ダイアログ ボックスで表示できるデータのサイズの上限は 4MB です。

  • 保留キューが次のステータスの場合、[ドキュメントの表示] を利用できます。
    • ドキュメントの検証

    • チャネルの選択

    • マッピング

    • 関連付けています

    • シリアライズ
  • [操作] メニューに [インターチェンジの表示] と [ドキュメントの表示] が同時に表示されることはありません。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

保留キュー

キューの使用

エラーの説明の表示

インターチェンジの表示


ドキュメントの再送信

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、再送信するドキュメントを含むグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、再送信するドキュメントをクリックします。

  3. [操作] メニューの [すべてのタスク] をポイントし、[再送信] をクリックします。

注

  • この手順は、ドキュメントの再送信だけでなく、ドキュメントを再転送するためにも使用できます。

  • 保留キューにあるすべてのドキュメントが再送信されるわけではありません。場合によっては、ドキュメントを削除してから、元のアプリケーションまたは組織から送信し直す必要があります。保留キューにあるドキュメントの詳細については、「保留キュー」を参照してください。

関連項目

保留キュー

キューの使用


ドキュメントの削除

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、削除するドキュメントを含むグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、削除するドキュメントをクリックします。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

関連項目

保留キュー

キューの使用


サーバー グループのデータベースの管理

サーバー グループのデータベースを管理するには、次の操作を行います。

  • BizTalk Server インターチェンジ アプリケーションのシャットダウン

  • 追跡データベースと共有キュー データベースの削除

  • 追跡データベースの手動による復元

  • 共有キュー データベースの手動による復元


BizTalk Server インターチェンジ アプリケーションのシャットダウン

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [BizTalk Server Interchange Application] をクリックします。

  4. [操作] メニューの [シャットダウン] をクリックします。

注

  • リモート サーバーから BizTalk Server インターチェンジ アプリケーションをシャットダウンすることができます。それには、手順 1. で [マイ コンピュータ] の代わりにリモート コンピュータを展開します。

関連項目

管理キャッシュ

サーバー グループの接続のプロパティの構成

サーバー グループの追跡のプロパティの構成

グループとサーバー

コンポーネント サービスを開く

追跡データベース


追跡データベースと共有キュー データベースの削除

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、[SQL Server グループ] を展開します。次に削除するデータベースを含む個々のサーバーを展開します。

  3. [データベース] フォルダを展開して、削除するデータベースをクリックします。

  4. [操作] メニューの [削除] をクリックします。

    [データベースの削除] ダイアログ ボックスが表示されます。

  5. [はい] をクリックします。

注

  • 追跡データベースの既定の名前は、InterchangeDTA です。共有キュー データベースの既定の名前は、InterchangeSQ です。

関連項目

グループとサーバー

共有キュー データベース

グループ内のサーバーの停止

追跡データベース


追跡データベースの手動による復元

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、データベースを復元するサーバーを展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [新規データベース] をクリックします。

    [データベースのプロパティ] ダイアログ ボックスが表示されます。

  5. [全般] プロパティ ページの [名前] ボックスに追跡データベースの名前を入力し、[OK] をクリックします。

  6. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] ダイアログ ボックスが表示されます。

  7. [OK] をクリックします。

  8. Microsoft SQL Server 7.0 がインストールされている場合は、[クエリ] ウィンドウの [DB] のボックスの一覧で、新しい追跡データベースの名前をクリックします。

    または

    Microsoft SQL Server 2000 がインストールされている場合は、[オブジェクト] プロパティページで新しい追跡データベースの名前をクリックします。

  9. [SQL スクリプトの読み込み] ボタン ( [SQL スクリプトの読み込み] ボタン) をクリックします。

  10. \Program Files\Microsoft BizTalk Server\Setup に移動します。

  11. BTS_Tracking_Schema.sql をクリックし、[開く] をクリックします。

  12. [クエリ実行] ボタンをクリックします。

  13. [SQL スクリプトの読み込み] ボタンをクリックします。

  14. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  15. BTS_Reporting.sql をクリックし、[開く] をクリックします。

  16. [クエリ実行] ボタンをクリックします。

  17. [SQL スクリプトの読み込み] ボタンをクリックします。

  18. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  19. BTS_Tracking_Logic.sql をクリックし、[開く] をクリックします。

  20. [クエリ実行] ボタンをクリックします。

  21. [SQL スクリプトの読み込み] ボタンをクリックします。

  22. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  23. BTS_WorkflowEvents_Logic.sql をクリックし、[開く] をクリックします。

  24. [クエリ実行] ボタンをクリックします。

  25. [SQL スクリプトの読み込み] ボタンをクリックします。

  26. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  27. BTS_WorkflowEvents_Schema.sql をクリックし、[開く] をクリックします。

  28. [クエリ実行] ボタンをクリックします。

  29. SQL クエリ アナライザと SQL Server Enterprise Manager を閉じます。

注意

  • 追跡データベースを手動で復元すると、すべてのデータが失われます。データを保持するには、追跡データベースを復元する前に、そのデータをバックアップしてください。

注

  • 追跡データベースが破損した場合に、この操作を行います。

関連項目

共有キュー データベースの手動による復元


共有キュー データベースの手動による復元

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、データベースを復元するサーバーを展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [新規データベース] をクリックします。

    [データベースのプロパティ] ダイアログ ボックスが表示されます。

  5. [全般] プロパティ ページの [名前] ボックスに共有キュー データベースの名前を入力し、[OK] をクリックします。

  6. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] ダイアログ ボックスが表示されます。

  7. [OK] をクリックします。

  8. Microsoft SQL Server 7.0 がインストールされている場合は、[クエリ] ウィンドウの [DB] のボックスの一覧で、新しい共有キュー データベースの名前をクリックします。

    または

    Microsoft SQL Server 2000 がインストールされている場合は、[オブジェクト] プロパティ ページで新しい共有キュー データベースの名前をクリックします。

  9. [SQL スクリプトの読み込み] ボタン ( [SQL スクリプトの読み込み] ボタン) をクリックします。

  10. \Program Files\Microsoft BizTalk Server\Setup に移動します。

  11. BTS_Core_Schema.sql をクリックし、[開く] をクリックします。

  12. [クエリ実行] ボタンをクリックします。

  13. [SQL スクリプトの読み込み] ボタンをクリックします。

  14. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  15. BTS_Core_Logic.sql をクリックし、[開く] をクリックします。

  16. [クエリ実行] ボタンをクリックします。

  17. SQL クエリ アナライザと SQL Server Enterprise Manager を閉じます。

注意

  • 共有キュー データベースを手動で復元すると、すべてのデータが失われます。データを保持するには、共有キュー データベースを復元する前に、そのデータをバックアップしてください。

注

  • 追跡データベースが破損した場合に、この操作を行います。

関連項目

追跡データベースの手動による復元


サーバー グループの受信機能の管理

サーバー グループの受信機能を管理するには、次の操作を行います。

  • ファイル受信機能の追加

  • ファイル受信機能の構成 : [全般] タブ

  • ファイル受信機能の構成 : [サービス] タブ

  • メッセージ キュー受信機能の追加

  • メッセージ キュー受信機能の構成 : [全般] タブ

  • メッセージ キュー受信機能の構成 : [サービス] タブ

  • ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

  • 受信機能の削除


ファイル受信機能の追加

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、ファイル受信機能を追加するサーバーを含むサーバー グループを展開します。

  2. [受信機能] をクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[ファイル受信機能] をクリックします。

    [ファイル受信機能の追加] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに、ファイル受信機能の名前を入力します。

  5. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  6. [受信機能を実行するサーバー] ボックスの一覧で、そのグループ内のサーバーの名前をクリックします。

  7. [ポーリングするファイルの種類] ボックスに、BizTalk Server が受信するファイルの拡張子を入力します。

    ファイルの拡張子は、次の構文で記述する必要があります。

    *.ext

    例 : *.xml

  8. [ポーリングの場所] ボックスに、この受信機能がファイルの受信場所として使用するディレクトリへの論理パスまたは Universal Naming Convention (UNC) パスのいずれかを入力します。

  9. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサの名前をクリックします。

    カスタム プリプロセッサを使用しない場合は、空白のままにします。

  10. [ユーザー名] ボックスと [パスワード] ボックスに、ファイル受信場所に接続するための有効なユーザー名とパスワードを入力します (省略可)。

    これは、その受信場所が保護されており、サーバーに接続するために有効なユーザー名とパスワードが要求される場合にのみ必要です。

  11. 非セルフルーティング ドキュメント用に受信機能をカスタマイズしたり、オープンネスまたはパススルーのオプションを指定するには、[詳細設定] をクリックします。

    詳細設定オプションの詳細については、「ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成」を参照してください。

  12. [OK] をクリックします。

注

  • ここでは、既定の設定でファイル受信機能を作成します。ファイル受信機能に追加の設定を構成するには、「ファイル受信機能の構成 : [全般] タブ」を参照してください。

  • 複数の種類のファイルをポーリングする場合は、標準のワイルドカード書式を使用します。

    例 : *.* または *.x?l

  • 同じディレクトリを監視するために 1 つ以上のファイル受信機能を構成する場合は、3 文字のファイル拡張子を使用します。3 文字を超えるファイル拡張子を使用する場合は、最初の 3 文字が一意であることを確認します。

    例 : *.xml、*.1xml、*.12xml

  • ファイル受信機能は、読み取り専用ファイルを処理できません。

  • 作成する各受信機能に一意な名前が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

関連項目

利用可能な受信機能

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [全般] タブ

ファイル受信機能の構成 : [サービス] タブ

カスタム プリプロセッサ

受信機能


ファイル受信機能の構成 : [全般] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、ファイル受信機能を構成するサーバー グループを展開します。次に、[受信機能] を展開します。

  2. 構成するファイル受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  5. [セキュリティ] の [ユーザー名] ボックスと [パスワード] ボックスに、この受信機能に接続するための有効なユーザー名とパスワードを入力します。

    これは、その受信場所が保護されており、サーバーに接続するために有効なユーザー名とパスワードが要求される場合にのみ必要です。

  6. この受信機能を一時的にシャットダウンする場合は、[受信機能を無効にする] チェック ボックスをオンにして、確認のダイアログ ボックスで [はい] をクリックします。

  7. [OK] をクリックします。

注

  • ファイル受信機能は、読み取り専用ファイルを処理できません。

関連項目

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [サービス] タブ


ファイル受信機能の構成 : [サービス] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、ファイル受信機能を構成するサーバー グループを展開します。次に、[受信機能] を展開します。

  2. 構成するファイル受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [サービス] タブをクリックします。

  5. [受信機能を実行するサーバー] ボックスの一覧で、サーバー名をクリックします。

  6. [ポーリングの場所] ボックスに、この受信機能がファイルの受信場所として使用するディレクトリへの論理パスまたは Universal Naming Convention (UNC) パスのいずれかを入力します。

  7. [ポーリングするファイルの種類] ボックスに、BizTalk Server が受信するファイルの拡張子を入力します。

    ファイルの拡張子は、次の構文で記述する必要があります。

    *.ext

    例 : *.doc

  8. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサの名前をクリックします。

    カスタム プリプロセッサを使用しない場合は、空白のままにします。

  9. [OK] をクリックします。

注

  • 複数の種類のファイルを受信する場合は、標準のワイルドカード書式を使用します。

    例 : *.*

  • 同じディレクトリを監視するために 1 つ以上のファイル受信機能を構成する場合は、3 文字のファイル拡張子を使用します。3 文字を超えるファイル拡張子を使用する場合は、最初の 3 文字が一意であることを確認します。

    例 : *.xml、*.1xml、*.12xml

  • ファイル受信機能は、読み取り専用ファイルを処理できません。

関連項目

利用可能な受信機能

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

カスタム プリプロセッサ


メッセージ キュー受信機能の追加

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、メッセージ キュー受信機能を追加するサーバー グループを展開します。

  2. [受信機能] をクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[メッセージ キュー受信機能] をクリックします。

    [メッセージ キュー受信機能の追加] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに、メッセージ キュー受信機能の名前を入力します。

  5. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  6. [受信機能を実行するサーバー] ボックスの一覧で、そのグループ内のサーバーの名前をクリックします。

  7. [ポーリングの場所] ボックスに、この受信機能が受信場所として使用するサーバー名とメッセージ キュー名を入力します。

    たとえば、次のようになります。

    Direct=OS:<servername>\<queuename>

    キューが格納されている処理サーバーを選択します。トランザクション メッセージは、ローカル キューだけでサポートされます。

  8. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサをクリックします。

    カスタム プリプロセッサを使用しない場合は、空白のままにします。

  9. [ユーザー名] ボックスと [パスワード] ボックスに、メッセージ キューに接続するための有効なユーザー名とパスワードを入力します。

    これは、受信場所がインターチェンジとドキュメントを処理するサーバー上にない場合にのみ必要です。

  10. 非セルフルーティング ドキュメント用に受信機能をカスタマイズしたり、オープンネスまたはパススルーのオプションを指定するには、[詳細設定] をクリックします。

    詳細設定オプションの詳細については、「ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成」を参照してください。

  11. [OK] をクリックします。

重要

  • [ポーリングの場所] ボックスで、<servername>\<queuename> に "queue://" のプレフィックスを付けないでください。これは "queue://" を使用するサーバー グループの一般プロパティとは異なります。メッセージ キュー構文の詳細については、「利用可能な受信機能」を参照してください。サーバー グループのプロパティの詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

注

  • カスタム プリプロセッサの詳細については、「カスタム プリプロセッサ」を参照してください。

  • 実行中の BizTalk Server に提供されたユーザー名とパスワードがキューに対して読み取りアクセス許可を持っていない場合は、メッセージ キュー受信機能は動作しません。

  • 信頼性を確保するには、トランザクション キューを使用します。非トランザクション キューを使用すると、メッセージが失われることがあります。トランザクション キューの詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、"Message Queuing" を検索してください。

  • 作成する各受信機能に一意な名前が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

関連項目

利用可能な受信機能

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

メッセージ キュー受信機能の構成 : [全般] タブ

カスタム プリプロセッサ

受信機能


メッセージ キュー受信機能の構成 : [全般] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、メッセージ キュー受信機能を構成するサーバー グループを展開します。次に [受信機能] を展開します。

  2. 構成するメッセージ キュー受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  5. [セキュリティ] の [ユーザー名] ボックスと [パスワード] ボックスに、メッセージ キューに接続するための有効なユーザー名とパスワードを入力します。

    これは、その受信場所が処理サーバー上にない場合にのみ必要です。

  6. この受信機能を一時的にシャットダウンする場合は、[受信機能を無効にする] チェック ボックスをオンにして、確認のダイアログ ボックスで [はい] をクリックします。

  7. [OK] をクリックします。

関連項目

メッセージ キュー受信機能の構成 : [サービス] タブ

受信機能


メッセージ キュー受信機能の構成 : [サービス] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、メッセージ キュー受信機能を構成するサーバー グループを展開します。次に [受信機能] を展開します。

  2. 構成するメッセージ キュー受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [サービス] タブをクリックします。

  5. [受信機能を実行するサーバー] ボックスの一覧で、サーバー名をクリックします。

  6. [ポーリングの場所] ボックスに、この受信機能が受信場所として使用するサーバー名とメッセージ キュー名を入力します。

    たとえば、次のようになります。

    Direct=OS:<servername>\<queuename>

  7. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサをクリックします。

    カスタム プリプロセッサを使用しない場合は、このオプションを空白のままにします。

  8. [OK] をクリックします。

重要

  • [ポーリングの場所] ボックスで、<servername>\<queuename> に "queue://" のプレフィックスを付けないでください。これは "queue://" を使用するサーバー グループの一般プロパティとは異なります。メッセージ キュー構文の詳細については、「利用可能な受信機能」を参照してください。サーバー グループのプロパティの詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

注

  • カスタム プリプロセッサの詳細については、「カスタム プリプロセッサ」を参照してください。

関連項目

利用可能な受信機能

サーバー グループの全般プロパティの構成

カスタム プリプロセッサ


ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、受信機能を構成するサーバー グループを展開します。次に [受信機能] を展開し、構成する受信機能をクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  3. [詳細設定] タブをクリックします。

  4. [オープンネス] ボックスの一覧で、次のいずれかを選択できます。
    • [開いていません] : 送信元と送信先の両方が受信機能またはドキュメント インスタンスで明示的に宣言されている場合は、このオプションをクリックします。BizTalk Server は、送信元と送信先を決定するためにドキュメントを解析する必要がありません。

    • [オープンな送信先] : 送信先情報がメッセージ ポートで明示的に宣言されていない場合は、このオプションをクリックします。送信先はドキュメント インスタンスまたは送信パラメータで動的に指定します。

    • [オープンな送信元] : 送信元情報がチャネルで明示的に宣言されていない場合は、このオプションをクリックします。送信元はドキュメント インスタンスまたは送信パラメータで動的に指定します。
  5. デコード、暗号解読、署名検証、解析などのすべての処理を省略し、インターチェンジのトランスポートだけを行う場合は、[パススルー フラグを付けて送信する] チェック ボックスをオンにします。

    [パススルー フラグを付けて送信する] チェック ボックスをオンにする場合は、チャネルを選択する必要があります。

  6. [エンベロープ名] ボックスの一覧で、エンベロープ定義の名前をクリックします。

    フラット ファイルを受信する場合は、エンベロープを選択します。そうでない場合は、このオプションを空白のままにします。

  7. [チャネル名] ボックスの一覧で、チャネルの名前をクリックします。

  8. [ドキュメント定義名] ボックスの一覧で、ドキュメント定義の名前をクリックします。

  9. [送信元と送信先] の [選択した送信元] で、[参照] をクリックします。

    [送信元の選択] ダイアログ ボックスが表示されます。

  10. [組織の修飾子] ボックスの一覧で、送信元組織の修飾子の種類をクリックします。

  11. [組織の識別子値] ボックスの一覧で、送信元組織の識別子の値をクリックし、[OK] をクリックします。

  12. [送信元と送信先] の [選択した送信先] で、[参照] をクリックします。

    [送信先の選択] ダイアログ ボックスが表示されます。

  13. [組織の修飾子] ボックスの一覧で、送信先組織の修飾子の種類をクリックします。

    同報リストにドキュメントを送信する場合は、[組織の修飾子] ボックスの一覧で [GROUP] を選択する必要があります。

  14. [組織の識別子値] ボックスの一覧で、送信先組織の識別子の値をクリックし、[OK] をクリックします。

  15. [OK] をクリックします。

重要

  • 受信機能の詳細プロパティとして次の一覧のいずれかのオブジェクトを割り当てる前に、そのオブジェクトを作成する必要があります。これらのオブジェクトは、BizTalk メッセージ マネージャで作成するか、プログラムで作成され、BizTalk メッセージ管理データベースに格納されます。
    • エンベロープ

    • チャネル

    • ドキュメント定義

    • 送信元の修飾子

    • 送信元組織の識別子の値

    • 送信先の修飾子

    • 送信先組織の識別子の値

注

  • [オープンネス] ボックスの一覧で、[オープンな送信元] または [オープンな送信先] をクリックした場合は、[パススルー フラグを付けて送信する] チェック ボックスは利用できません。

  • 同報リストにドキュメントを送信する場合は、[送信先の選択] ダイアログ ボックスの [組織の修飾子] ボックスの一覧で [GROUP」を選択する必要があります。

  • 受信機能の詳細プロパティはすべて省略可能で、空白のままにすることができます。ドキュメントの送信の詳細については、「ルーティング」または「受信機能とドキュメント ルーティングについて」を参照してください。

  • [パススルー フラグを付けて送信する] チェック ボックスをオンにした場合、利用できるボックスの一覧は [チャネル] だけです。

  • パススルー送信は、BizTalk Server 2000 の解析、暗号解読、およびデコードの機能を省略します。パススルー フラグを付けてドキュメントを送信する方法の詳細については、「受信機能の詳細プロパティについて」を参照してください。送信の詳細については、「送信」を参照してください。

関連項目

受信機能

ルーティング

送信

受信機能の詳細プロパティについて

受信機能とドキュメント ルーティングについて


受信機能の削除

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、受信機能を削除するサーバー グループを展開します。次に [受信機能] を展開します。

  2. 削除する受信機能をクリックします。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

関連項目

受信機能


イベント ビューアの管理

BizTalk Server 管理コンソールに含まれるイベント ビューアを使用して、サーバーとドキュメント処理に関する問題をトラブルシューティングすることができます。イベント ビューアは、BizTalk Server 管理コンソールのコンソール ツリーに表示されます。BizTalk Server 2000 のアプリケーションに関連するエラーにはすべて、BizTalk Server エラーというラベルが付きます。XLANG スケジュールに関連するエラーにはすべて、XLANG スケジューラ エラーというラベルが付きます。

イベント ビューアを管理するには、次の操作を行います。

  • BizTalk Server エラーのためのイベント ビューアの構成

  • イベント ビューアでのアプリケーションに関連するエラーの表示


BizTalk Server エラーのためのイベント ビューアの構成

  1. BizTalk Server 管理コンソールで、[イベント ビューア] を展開します。

  2. [アプリケーション] をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    [アプリケーションのプロパティ] ダイアログ ボックスが表示されます。

  4. [フィルタ] タブをクリックします。

  5. [イベント ソース] ボックスの一覧で、次のいずれかをクリックします。
    • [BizTalk Server] : このオプションは BizTalk メッセージ サービスに関連するエラー メッセージのイベント ソースをフィルタ処理します。

    • [XLANG Scheduler] : このオプションは、BizTalk オーケストレーション サービスに関連するエラー メッセージのイベント ソースをフィルタ処理します。
  6. [OK] をクリックして、[アプリケーションのプロパティ] ダイアログ ボックスを閉じます。


イベント ビューアでのアプリケーションに関連するエラーの表示

  1. BizTalk Server 管理コンソールで、[イベント ビューア] を展開します。

  2. [アプリケーション] をクリックします。

    詳細ウィンドウに、アプリケーション エラー メッセージが一覧表示されます。

  3. 詳細ウィンドウでメッセージをクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

注

  • ここでは、BizTalk Server エラーと XLANG スケジューラ エラーだけを表示するために、イベント ビューアが構成されていると想定しています。BizTalk Server エラーと XLANG スケジューラ エラーを表示する方法の詳細については、「BizTalk Server エラーのためのイベント ビューアの構成」を参照してください。

関連項目

BizTalk Server エラーのためのイベント ビューアの構成


XLANG アプリケーションとデータベースの管理

ここでは、XLANG スケジュールをホストする COM+ アプリケーションを管理する方法について説明します。また、ここでは、BizTalk Server 2000 をインストールするときに作成される既定の XLANG スケジューラ アプリケーションとオーケストレーション データベースの管理についても説明します。

BizTalk Server 2000 は、XLANG 永続化ヘルパという COM+ アプリケーションを提供します。これは、XLANG スケジュール インスタンスをホストするすべての COM+ アプリケーションによって使用されます。セットアップが終了した後に、XLANG 永続化ヘルパの構成を変更しないでください。

ここには次のトピックが含まれます。

  • 既定の XLANG スケジューラ アプリケーションおよびデータベースの管理

  • XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理

  • 実行中の XLANG スケジュールの監視

注

  • Microsoft SQL Server の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)


既定の XLANG スケジューラ アプリケーションおよびデータベースの管理

既定の XLANG スケジューラ アプリケーションとオーケストレーション データベースは、BizTalk Server 2000 のインストール中に作成されます。本番運用システムまたは Microsoft Terminal Server を実行しているシステムでは、このアプリケーションとデータベースの既定の設定を変更する必要があります。XLANG スケジュール インスタンスをホストするための新しい COM+ アプリケーションと、XLANG スケジュール ステータス情報を格納するための新しいステータス保存データベースを作成することもできます。

XLANG スケジュール インスタンスをホストする新しい COM+ アプリケーションの作成については、「XLANG スケジュールをホストする COM+ アプリケーションの作成」を参照してください。

既定の XLANG スケジューラ アプリケーションの既定の設定を変更する上でのセキュリティとパフォーマンスに関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

ここには次のトピックが含まれます。

  • 既定の XLANG スケジューラ アプリケーションの構成

  • 既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

  • 既定のオーケストレーション データベースの設定の変更

  • すべての XLANG アプリケーションのシャットダウン

  • すべての XLANG アプリケーションの再起動

  • 注

  • Microsoft SQL Server の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)


既定の XLANG スケジューラ アプリケーションの構成

既定の XLANG スケジューラ アプリケーションとオーケストレーション データベースは、BizTalk Server 2000 のインストール中に作成されます。本番運用システムまたは Microsoft Terminal Server を実行しているシステムでは、このアプリケーションとデータベースの既定の設定を変更する必要があります。XLANG スケジュール インスタンスをホストするための新しい COM+ アプリケーションと、XLANG スケジュール ステータス情報を格納するための新しいステータス保存データベースを作成することもできます。

XLANG スケジュール インスタンスをホストする新しい COM+ アプリケーションの作成については、「XLANG スケジュールをホストする COM+ アプリケーションの作成」を参照してください。

既定の XLANG スケジューラ アプリケーションの既定の設定を変更する上でのセキュリティとパフォーマンスに関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. 運用システムまたは Microsoft Terminal Server を実行しているシステムでは、既定の XLANG スケジューラ アプリケーションのアプリケーション ID を変更してください。詳細については、「既定の XLANG スケジューラ アプリケーションのアプリケーション ID の変更」を参照してください。

  5. オーケストレーション データベースの既定のデータベース設定も変更してください。詳細については、「既定のオーケストレーション データベースの設定の変更」を参照してください。

注

  • データ ソース名 (DSN) と COM+ アプリケーションは、同じである必要があります。たとえば、XLANG スケジューラ エンジンをホストしている COM+ アプリケーションの名前が "XLANG Scheduler" である場合は、DSN の名前も "XLANG Scheduler" にします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

COM+ アプリケーションの DSN 設定の変更

既定のオーケストレーション データベースの設定の変更

新しいステータス保存データベースの作成

インスタンス作成アプリケーションの作成

すべての XLANG アプリケーションの再起動

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

すべての XLANG アプリケーションのシャットダウン


既定の XLANG スケジューラ アプリケーションのアプリケーション ID の変更

既定の XLANG スケジューラ アプリケーションの既定の対話型ユーザー アカウントを、サービス アカウントに変更してください。

既定の XLANG スケジューラ アプリケーションの既定の設定を変更する上でのセキュリティとパフォーマンスに関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. [詳細設定] プロパティ ページの [許可] で [変更を許可しない] チェック ボックスをオフにし、[OK] をクリックします。

    次のメッセージが表示されます : アプリケーションは 1 つ以上の外部プロダクトから作成されました。それらの外部プロダクトは、保存しようとしている変更内容をサポートしますか?

  5. [はい] をクリックします。

    [XLANG Scheduler のプロパティ] ダイアログ ボックスが閉じます。

  6. [XLANG Scheduler] をクリックします。[操作] メニューの [プロパティ] をクリックします。

  7. [ID] プロパティ ページの [アカウント] で [このユーザー] をクリックします。

  8. 使用するアカウントの情報を入力します。

  9. [OK] をクリックします。

    次のメッセージが表示されます : アプリケーションは 1 つ以上の外部プロダクトから作成されました。それらの外部プロダクトは、保存しようとしている変更内容をサポートしますか?

  10. [はい] をクリックします。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

既定のオーケストレーション データベースの設定の変更

既定の XLANG スケジューラ アプリケーションの構成

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


既定のオーケストレーション データベースの設定の変更

BizTalk Server 2000 をインストールすると、オーケストレーション データベースがセットアップされ、既定の設定で構成されます。既定の設定を変更して、実行中のシステムに適する構成にすることができます。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、[SQL Server グループ] を展開します。次に、既定のデータベースを含むサーバーを展開し、[データベース] を展開します。

  3. XLANG データベースをクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. 次の 6 つのタブがあり、データベースのさまざまなプロパティを設定できます。
    • [全般]

    • [データ ファイル] (SQL Server 7.0 にはありません。)

    • [トランザクション ログ]

    • [ファイル グループ] (SQL Server 7.0 にはありません。)

    • [オプション]

    • [権限]

Microsoft SQL Server でのデータベースの構成の詳細については、Microsoft SQL Server Books Online を参照してください。

重要

  • ここでは、XLANG という名前の既定のデータベースをセットアップすることを想定しています。

注

  • プライマリ データベースとトランザクション ログ ファイルは、データベース名をプレフィックスとして使用して作成されます。たとえば、XLANGdb_Data.mdf と XLANGdb_Log.ldf のようになります。プライマリ ファイルには、そのデータベースのシステム テーブルが含まれます。

  • データベースの最大サイズは、利用可能なディスク領域と、使用している Microsoft SQL Server のバージョンのライセンス上の制限によって決定されます。

  • 既定のオーケストレーション データベースのオブジェクト名は "XLANG" です。インストール処理中に、この名前を変更することができます。

  • SQL Server の詳細については、[スタート] メニューの [プログラム] をポイントし、[Microsoft SQL Server] をポイントして、[オンライン ブック] をクリックしてください。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

既定の XLANG スケジューラ アプリケーションの構成

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


すべての XLANG アプリケーションのシャットダウン

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. [XLANG] プロパティ ページの [シャットダウンの制御] で、[すべての XLANG アプリケーション] をクリックします。

注意

  • すべての COM+ アプリケーションに対して、制御されたシャットダウンを実行するには、この操作を行います。これを実行すると、すべての実行中の XLANG スケジュールのステータスが、ステータス保存データベースに保存されます。詳細については、「永続化」を参照してください。

    COM+ アプリケーションを右クリックして、[シャットダウン] をクリックしないでください。次のいずれかの問題が発生することがあります。

    • 実行中の XLANG スケジュールのすべてがトランザクションの場合は、制御されないシャットダウンによって、実行中のトランザクションが中断します。

    • 実行中の XLANG スケジュールのすべてがトランザクションではない場合は、スケジュール内で処理中のデータが失われます。

重要

  • データ ソース名 (DSN) を利用できない場合または構成が正しくない場合は、ステータス退避済みの XLANG スケジュールを再起動することはできません。既定の XLANG スケジューラ アプリケーションの DSN の構成の詳細については、「既定の XLANG スケジューラ アプリケーションの構成」を参照してください。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

既定の XLANG スケジューラ アプリケーションの構成

すべての XLANG アプリケーションの再起動

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン


すべての XLANG アプリケーションの再起動

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. [XLANG] プロパティ ページの [ステータス退避済み XLANG アプリケーションを再起動] で、[すべての XLANG アプリケーション] をクリックします。

重要

  • データ ソース名 (DSN) を利用できない場合または構成が正しくない場合は、ステータス退避済みの XLANG スケジュールを再起動することはできません。既定の XLANG スケジューラ アプリケーションの DSN の構成の詳細については、「既定の XLANG スケジューラ アプリケーションの構成」を参照してください。

  • ステータス退避済みアプリケーションを再起動すると、ステータス退避済みスケジュールのステータス復元が非同期的に開始されます。ステータス復元処理には時間がかかります。ステータス復元処理の完了時間を特定するには、XLANG Event Monitor を使用します。XLANG Event Monitor ツールの詳細については、ツールに付属のリリース ノートを参照してください。Microsoft BizTalk Server 2000 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、どちらもインストール ディレクトリ \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

既定の XLANG スケジューラ アプリケーションの構成

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン

すべての XLANG アプリケーションのシャットダウン


XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理

XLANG スケジュールをホストする COM+ アプリケーションのほとんどは、その XLANG スケジュールを開発するときに作成する必要があります。アプリケーションとスケジュールのセキュリティとパフォーマンス上の要件を考慮に入れる必要があります。また、特定のスケジュールを実行するために、固有な COM+ アプリケーションを作成する必要が生じることがあります。詳細については、「XLANG スケジュールの実行 (操作方法)」と「XLANG スケジュールの実行 (概念)」を参照してください。

ここには次のトピックが含まれます。

  • 新しいステータス保存データベースの作成

  • COM+ アプリケーションのアプリケーション ID の変更

  • COM+ アプリケーションの DSN 設定の変更

  • XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン

注

  • Microsoft SQL Server の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)


新しいステータス保存データベースの作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、新しいデータベースを追加するサーバーを展開し、[データベース] を展開します。

  3. [データベース] をクリックします。[操作] メニューの [新規データベース] をクリックします。

  4. [全般] プロパティ ページの [名前] ボックスに新しいデータベースの名前を入力し、[OK] をクリックします。

    この操作によって、既定値のセットで新しいデータベースが作成されます。これらの既定値は変更することができます。Microsoft SQL Server でのデータベースの構成の詳細については、Microsoft SQL Server Books Online を参照してください。

注

  • プライマリ データベースとトランザクション ログ ファイルは、データベース名をプレフィックスとして使用して作成されます。たとえば、XLANGdb_Data.mdf と XLANGdb_Log.ldf のようになります。プライマリ ファイルには、そのデータベースのシステム テーブルが含まれます。

  • データベースの最大サイズは、利用可能なディスク領域と、使用している Microsoft SQL Server のバージョンのライセンス上の制限によって決定されます。

  • SQL Server の詳細については、[スタート] メニューの [プログラム] をポイントし、[Microsoft SQL Server] をポイントして、[オンライン ブック] をクリックしてください。

関連項目

既定の XLANG スケジューラ アプリケーションの構成

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


COM+ アプリケーションのアプリケーション ID の変更

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. ID を変更する COM+ アプリケーションをクリックし、[操作] メニューの [プロパティ] をクリックします。

  4. [詳細設定] プロパティ ページの [許可] で、[変更を許可しない] チェック ボックスがオフになっていることを確認し、[OK] をクリックします。

    プロパティ ダイアログ ボックスが閉じます。

  5. COM+ アプリケーションを再び右クリックし、[プロパティ] をクリックします。

  6. [ID] プロパティ ページの [アカウント] で [このユーザー] をクリックします。

  7. 使用するアカウントの情報を入力します。

  8. [OK] をクリックします。

    次のメッセージが表示されます : アプリケーションは 1 つ以上の外部プロダクトから作成されました。それらの外部プロダクトは、保存しようとしている変更内容をサポートしますか?

  9. [はい] をクリックします。

注

  • XLANG スケジュールをホストする COM+ アプリケーションのアプリケーション ID の設定に関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

既定のオーケストレーション データベースの設定の変更

既定の XLANG スケジューラ アプリケーションの構成

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


COM+ アプリケーションの DSN 設定の変更

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. データ ソース名 (DSN) 設定を変更する COM+ アプリケーションをクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. [XLANG] プロパティ ページの [DSN の構成] をクリックします。

    [ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されます。

  5. 任意の設定を変更します。

注意

  • DSN 設定を変更した後に、[XLANG] プロパティ ページで [テーブルの初期化] をクリックしないでください。それを行うと、既存のデータベースにあるデータが破棄されます。

重要

  • DSN と COM+ アプリケーションは同じ名前を使用する必要があります。たとえば、COM+ アプリケーションの名前が "XLANG Scheduler" である場合は、DSN の名前も "XLANG Scheduler" にします。

  • DSN の構成とデータ ソース (ODBC) の使用の詳細については、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスの [ヘルプ] をクリックし、その内容を参照してください。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. シャットダウンする XLANG スケジュールをホストする COM+ アプリケーションをクリックします。[操作] メニューの [プロパティ] をクリックします。

  4. [XLANG] プロパティ ページの [シャットダウンの制御] で、[この XLANG アプリケーション] をクリックします。

注意

  • すべての COM+ アプリケーションに対して、制御されたシャットダウンを実行するには、この操作を行います。これを実行すると、すべての実行中の XLANG スケジュールのステータスが、ステータス保存データベースに保存されます。詳細については、「永続化」を参照してください。

    COM+ アプリケーションを右クリックして、[シャットダウン] をクリックしないでください。次のいずれかの問題が発生することがあります。

    • 実行中の XLANG スケジュールのすべてがトランザクションの場合は、制御されないシャットダウンによって、すべての失敗時エラー処理プロセスと補正エラー処理プロセスが発生します。

    • 実行中の XLANG スケジュールのすべてがトランザクションではない場合は、スケジュール内で処理中のデータが失われます。

重要

  • データ ソース名 (DSN) を利用できない場合または構成が正しくない場合は、ステータス退避済みの XLANG スケジュールを再起動することはできません。XLANG スケジュールをホストする COM+ アプリケーションの DSN の構成の詳細については、「XLANG スケジュールをホストする COM+ アプリケーションの構成」を参照してください。

注

  • XLANG スケジュールをホストする COM+ アプリケーションを作成する場合は、[ステータス退避済み XLANG アプリケーションを再起動] オプションは利用できません。ステータス退避済みアプリケーションを再起動する方法の詳細については、「すべての XLANG アプリケーションの再起動」を参照してください。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

XLANG スケジュールをホストする COM+ アプリケーションの構成

すべての XLANG アプリケーションの再起動

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行 (操作方法)

すべての XLANG アプリケーションのシャットダウン


実行中の XLANG スケジュールの監視

XLANG Event Monitor または Windows 2000 イベント ビューアのいずれかを使用して、実行中の XLANG スケジュールを監視することができます。

  • XLANG Event Monitor : XLANG スケジューラ エンジンは、XLANG スケジュールを実行するときにスケジュール インスタンスの進行状況を示すさまざまな種類のイベントを生成します。XLANG Event Monitor を使用して XLANG スケジュール イベントを監視し、スケジュール インスタンスの進行状況を確認できます。既定の XLANG スケジューラ アプリケーション、または XLANG スケジュールをホストするために作成したカスタム COM+ アプリケーションを監視することができます。XLANG Event Monitor は、任意の数のローカル コンピュータまたは分散コンピュータ上のホスト アプリケーションによって発行されたすべてのイベントに対して監視することができます。XLANG Event Monitor は、後の分析用に、これらのイベントをファイルに保存することもできます。

    XLANG Event Monitor の使用の詳細については、ツールに付属のリリース ノートを参照してください。Microsoft BizTalk Server 2000 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、どちらもインストール ディレクトリ \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

  • Windows 2000 イベント ビューア : Windows 2000 イベント ビューアは、XLANG スケジュールに関連するイベント メッセージを発行します。エラー メッセージを表示するためのイベント ビューアの使用の詳細については、次の関連項目を参照してください。
    • XLANG スケジュールのエラー メッセージをフィルタ処理するためのイベント ビューアの構成については、「BizTalk Server エラーのためのイベント ビューアの構成」を参照してください。

    • イベント ビューアの一般情報については、Windows 2000 Server ヘルプの「イベント ビューアを使う」を参照してください。

ここには次のトピックが含まれます。

  • XLANG スケジュールのエラー メッセージ

関連項目

BizTalk Server エラーのためのイベント ビューアの構成


XLANG スケジュールのエラー メッセージ

次の表は、実行中の XLANG スケジュールがエラーを生成したときに返されるエラー メッセージの一覧を示しています。これらのメッセージは Windows 2000 イベント ビューアで表示することができます。

メッセージ名 | 値 | 説明
ID_CAT_UNKNOWN | 0x1 | SVC%0
ID_CAT_NAMESVC | 0x2 | NameSvc%0
ID_CAT_ENGINE | 0x3 | Engine%0
ID_CAT_SYSMGR | 0x4 | SystemMgr%0
ID_CAT_GRPMGR | 0x5 | GroupMgr%0
ID_CAT_WFSVCMGR | 0x6 | WFSvcMgr%0
ID_CAT_OBJECTMODEL | 0x7 | WFObjectModel%0
ID_CAT_BINDING | 0x8 | WFBinding%0
ID_CAT_COM_LAST | 0x9 | <>%0
IDS_I_MTSTOCOM_LAUNCH_FINISHED | 0x1000 | 権限のないクライアントが XLANG スケジュールの新しいインスタンスを作成しようとしました。次のメッセージには、残りのモニカ文字列とクライアントの ID が表示されます。バイナリ データとして含まれるクライアントのセキュリティ識別子 (SID) : %1%0
ID_W_NOT_USER | 0x2001 | 権限のないクライアントが XLANG スケジュールの既存のインスタンスにアクセスしようとしました。次のメッセージに、モニカ文字列の関連語句とクライアント ID が表示されます。バイナリ データとして含まれるクライアントのセキュリティ識別子 (SID) : %1%0
IDS_E_COMSVCS_INTERNAL_ERROR | 0x3000 | XLANG スケジューラ エンジンの内部ステータスで矛盾を検出しました。Microsoft 製品サポート サービスに連絡して、このエラーの内容を報告してください。 %1%0
IDS_COMSVCS_RESOURCE_ERROR | 0x3001 | XLANG スケジューラ エンジンが重要なリソースがないことを検出したため、そのリソースをホストしている処理は終了しました。 %1%0
IDS_COMSVCS_INTERNAL_ERROR_ASSERT | 0x3002 | COM+ の内部エラーです。このエラーに関しては Microsoft 製品サポート サービスに問い合わせてください。アサーション エラー : %1%0
ID_E_USER_EXCEPTION | 0x3003 | システムから呼び出されたスケジュール済みのコンポーネントの実行に失敗したため例外が発生しました。スケジュール済みのコンポーネントに問題があることを示しています。コンポーネントの開発者にエラーの発生と次の情報を伝えてください。 %1%2%0
ID_INITIALIZE_FOR_DTC | 0x3004 | XLANG スケジューラ エンジンは、トランザクション コンポーネントのサポートに必要なトランザクションを初期化できませんでした。MS DTC が実行中であることを確認してください。 %1%0
ID_E_CANT_CREATE_COMPONENT | 0x3005 | XLANG スケジューラ エンジンは、スケジュールの実行に必要なユーザー コンポーネントを作成できませんでした。詳細情報は次のとおりです。 %1%0
ID_E_PROGID_NOT_FOUND | 0x3006 | XLANG スケジューラ エンジンは、次のメッセージのプログラム ID を COM クラス ID に変換できませんでした。 %1%0
ID_E_CANT_CREATE_INTERCEPTOR | 0x3007 | XLANG スケジューラ エンジンは、次のメッセージのインターフェイス ID に対応したインターセプタ オブジェクトを作成できませんでした。原因は次の理由が考えられます。1) インターフェイスが正しく登録されていない。2) インターフェイスのタイプ ライブラリが設定されていない。3) インターフェイスの種類の情報を含むファイルを読み取れない。このインターセプタに関連付けられたポート名 : %1%0
ID_E_INTF_NOT_SUPPORTED | 0x3008 | XLANG スケジューラ エンジンは、スケジュール バインドと参照先の COM コンポーネントとの矛盾を検出しました。バインドの一覧にあるコンポーネントでは正しいインターフェイスのサポートに失敗しました。次のメッセージに、コンポーネントのクラス ID およびサポートされていないインターフェイス ID が表示されます。このコンポーネントに関連付けられたポート名 : %1%0
ID_E_UNKNOWN_METHOD | 0x3009 | XLANG スケジューラ エンジンは、この XLANG スケジュールのポート実装に指定されていないメソッドの呼び出しを受け取りました。次のメッセージに、IID とメソッド番号が表示されます。呼び出しを受け取るポート名は、%1%0 です。
ID_E_UNKNOWN_IDISPATCH_METHOD | 0x300A | XLANG スケジューラ エンジンは、存在しないメソッドの呼び出しを IDispatch::Invoke() インターフェイスから受け取りました。次のメッセージに、メソッドのディスパッチ ID が表示されます。呼び出しを受け取るポート名は、%1%0 です。
ID_E_NAMED_PARAMS | 0x300B | XLANG スケジューラ エンジンは、名前付き引数を持ったメソッドの呼び出しを IDispatch::Invoke() インターフェイスから受け取りました。名前付き引数ではなく位置の引数を使用してください。次のメッセージに、メソッドのディスパッチ ID が表示されます。呼び出しを受け取るポート名は、%1%0 です。
ID_E_BAD_INVOKE_PARAMS | 0x300C | XLANG スケジューラ エンジンは、パラメータの数が正しくないメソッドの呼び出しを IDispatch::Invoke() インターフェイスから受け取りました。次のメッセージに、IID とメソッドのディスパッチ ID が表示されます。呼び出しを受け取るポート名は、%1%0 です。
ID_E_BAD_RETURN_POINTER | 0x300D | XLANG スケジューラ エンジンは、IDispatch::Invoke() インターフェイスから正しくないメソッドの出力パラメータを受け取りました。返された参照が無効 (NULL または正しくないポインタ) か、必要なインターフェイスをサポートしていません。次のメッセージに、必要なディスパッチ ID が表示されます。正しくないポート参照が含まれるメッセージ名 : %1%0
ID_E_ACCESS_CHECK_FAILURE | 0x300E | XLANG スケジューラ エンジンは、クライアントからのモニカ解決要求を承認できませんでした。アクセスは拒否されます。
ID_E_BAD_INVOKE | 0x300F | メソッドに対する IDispatch::Invoke() インターフェイスでメソッドの呼び出しに失敗しました。次のメッセージに、メソッドのディスパッチ ID が表示されます。呼び出しを受け取ろうとしたポート名 : %1%0
ID_E_INVOKED_METHOD | 0x3010 | 次のメッセージにあるディスパッチ ID を持つメソッドを呼び出すときにエラーが発生しました。呼び出しを受け取ろうとしたポート名 : %1%0
ID_E_CANT_GET_TYPEINFO | 0x3011 | 次のポート名と COM CLSID を持つコンポーネントは、XLANG スケジューラ エンジンに必要な情報を渡せませんでした。%1%0
ID_E_CANT_INVOKE_METHOD | 0x3012 | XLANG スケジューラ エンジンは、次のメッセージに表示されたポート名に関連付けられたオブジェクトにメソッド呼び出しを渡せませんでした。呼び出されるインターフェイス名とメソッド名は、次のとおりです。%1%0
ID_E_CANT_GET_CLASSINFO | 0x3013 | 次のポート名と COM CLSID を持つコンポーネントは、IProvideClassInfo::GetClassInfo インターフェイス経由で XLANG スケジューラ エンジンに必要な情報を渡せませんでした。%1%0
ID_E_SCRIPT_ERROR | 0x3014 | XLANG スケジュール インスタンスでスクリプト化された判断規則を実行できませんでした。スクリプト エンジンから返されたエラーは次のとおりです。また、スクリプトのソース コードと、エラーが発生したスケジュール インスタンスに関する情報も示しています。%1%0
ID_E_SCRIPT_ERROR_NOINFO | 0x3015 | XLANG スケジュール インスタンスでスクリプト化された判断規則は失敗しました。エラーに関する詳細情報は内部エラーのため取得できませんでした。エラー コードは次のとおりです。%1%0
ID_E_SCRIPT_BADCONV | 0x3016 | XLANG スケジュール インスタンスでスクリプト化された判断規則は、VBScript エンジンと互換性のない型のメッセージ フィールドを参照しました。XLANG スケジューラ エンジンは、フィールドを互換性のある型に変換しようとしましたができませんでした。次の情報は、スクリプト規則、メッセージ、および関係するフィールドと共に、フィールドの元のバリアント データ型と、変換しようとしたデータ型を示します。フィールドのバリアント型のデータ構造は、バイナリ データとしてログ エントリに記録されます。%1%0
ID_E_SCRIPT_BADARRAY | 0x3017 | XLANG スケジュール インスタンスでスクリプト化された判断規則は VB スクリプト エンジンと互換性のない配列型のメッセージ フィールドを参照しました。Visual Basic スクリプトは、バリアント型の配列のみサポートします。次の情報には、スクリプト規則、メッセージ、およびフィールドが含まれます。フィールドのバリアント型のデータ構造は、バイナリ データとしてログ エントリに記録されます。%1%0
ID_E_SCRIPT_BADEXPR | 0x3018 | XLANG スケジュール インスタンスでスクリプト化された判断規則に、ブール型の結果を返さない式がありました。次の情報には、スクリプト規則および式が含まれます。式が返すバリアント型のデータ構造はバイナリ データとしてログ エントリに記録されます。%1%0
ID_E_SCHEDULE_NOT_RUNNING | 0x3019 | XLANG スケジューラ エンジンは、実行されていない XLANG スケジュール インスタンスでポートに関連付けられたオブジェクトの呼び出しを受け取りました。呼び出しを受け取るポート名は、%1%0 です。
ID_E_INTERNAL_EXCEPTION | 0x301A | COM+ 内部例外が発生しました。このエラーに関しては Microsoft 製品サポート サービスに連絡し、次の情報を知らせてください。%1%2%0
ID_E_BAD_DATAFLOW_NOMESSAGE | 0x301B | データ フローの仕様に問題があります。この XLANG スケジュールは実行されていますが、データの送信元とされているメッセージが存在しません。詳細情報は次のとおりです。%1%0
ID_E_BAD_ARGUMENTVALUE | 0x301C | COM メソッド呼び出しのパラメータとして使用されているフィールドの 1 つに、値の種類が正しくないものがあります。データ フローが間違っているか、見つからないことが原因と考えられます。詳細情報は次のとおりです。%1%0
ID_E_DEEP_VARIANT_NESTING | 0x301D | COM メソッドの呼び出しのパラメータとして使用されているフィールドの 1 つにバリアント型が 1 レベル以上ネストされています。IID とメソッドのディスパッチ ID は次のとおりです。呼び出しを受け取るポート名は、%1%0 です。
ID_E_BAD_MAPPORTVALUE | 0x301E | マップされたポートを渡すフィールドが無効です。詳細情報は次のとおりです。%1%0
ID_E_BAD_CALLPARAMNUMBER | 0x301F | 呼び出しに渡されるパラメータの数が正しくありません。詳細情報は次のとおりです。%1%0
ID_E_EXECUTINGCALLEDSCHEDULE | 0x3020 | XLANG スケジュールをトップレベルのスケジュールとして実行できません。コンテキスト パラメータをスケジュールに渡す必要があります。詳細情報は次のとおりです。%1%0
ID_E_CANT_GET_SUPPORTERRORINFO | 0x3021 | 次のポート名と COM CLSID を持つコンポーネントは、サポートしているはずのインターフェイスから XLANG スケジューラ エンジンに、ISupportErrorInfo::InterfaceSupportsErrorInfo を使用して成功を返せませんでした。%1%0
ID_E_PERSIST_FAILURE | 0x3022 | スケジュール インスタンスのステータスをデータベースに保存できませんでした。詳細情報は次のとおりです。%1%0
ID_E_TRANSACTION_COMMIT_FAILURE | 0x3023 | システムはトランザクション コンテキストをコミットできませんでした。詳細情報は次のとおりです。%1%0
ID_E_TRANSACTION_ABORTED | 0x3024 | システムはトランザクション コンテキストを中断しました。詳細情報は次のとおりです。%1%0
ID_E_TRANSACTION_ABORT_FAILURE | 0x3025 | システムはトランザクション コンテキストを中断できませんでした。このトランザクションのステータスは不明です。詳細情報は次のとおりです。%1%0
ID_E_PENDINGREHYDRATIONERROR | 0x3026 | ステータス復元アプリケーションでエラーが発生したためシャットダウンしています。これによりステータス復元要求の一部は失敗します。XLANG スケジューラ エンジン サービスを再起動してください。詳細情報は次のとおりです。%1%0
ID_E_REHYDRATIONONSTARTUPERROR | 0x3027 | システム エラーのため、1 つまたは複数の XLANG スケジュールを復元できませんでした。データベースの読み取りまたは読み取ったデータに問題のある可能性があります。詳細情報は次のとおりです。%1%0
ID_E_REHYDRATIONERROR | 0x3028 | XLANG スケジュールのステータス復元中にエラーが発生しました。データベースの読み取りまたは格納されている情報に問題のある可能性があります。XLANG スケジュールのステータスが正しく退避されなかった可能性があります。詳細情報は次のとおりです。%1%0
ID_E_FOUNDINITIALIZEDTHREAD | 0x3029 | XLANG スケジュールの処理中に、XLANG スケジューラ エンジン サービスのスレッド管理で重大なエラーが発生しました。スケジュールの処理は失敗する可能性があります。テクニカル サポートに連絡してください。%1%0
ID_E_CALLONCOMPLETEDSCHEDULE | 0x302A | XLANG スケジューラ エンジン サービスは、完了した XLANG スケジュール インスタンスに対する呼び出しを受け取りました。このスケジュール インスタンスはメモリから既に削除されています。インターフェイスの IID は次のとおりです。%1%0
IDS_MSG_TIMEBOMB_EXPIRED | 0x302B | Microsoft Biztalk Server 2000 をご評価いただき、ありがとうございました。この評価版の評価期間は終了しました。Microsoft Biztalk Server 2000 のライセンスされたバージョンの入手に関しては、Microsoft にお問い合わせください。%0
ID_E_FIELDPORTPERSISTENCEERROR | 0x302C | XLANG スケジュール インスタンスを永続化しようとしたときにエラーが発生しました。詳細情報は次のとおりです。%1%0
ID_E_FIELDPORTREHYDRATIONERROR | 0x302D | XLANG スケジュール インスタンスの特定のサブコンポーネントをデータベースから復元しようとしてエラーが発生しました。詳細情報は次のとおりです。%1%0
ID_E_SCHEDULEDONE | 0x3030 | XLANG スケジュール インスタンスに完了のマークを付けるときに、XLANG スケジューラ エンジンでエラーが発生しました。データベースを更新できなかったか、最終段階でエラーが発生しました。詳細情報は次のとおりです。%1%0
ID_E_COMPONENT_INCOMPATIBLE_TXN | 0x3031 | コンポーネントのインスタンスを作成中に XLANG スケジューラ エンジンでエラーが発生しました。コンポーネントが別のトランザクションで既に登録されているか、コンポーネントがトランザクションに登録されていません。現在のインスタンスの作成にはトランザクションが必要です。詳細情報は次のとおりです。%1%0
ID_E_SUSPEND_FAILURE | 0x3032 | XLANG スケジュール インスタンスを中断できませんでした。詳細情報は次のとおりです。%1%0
ID_E_INITNEW | 0x3033 | XLANG スケジューラ エンジンは、IPersistStreamInit::InitNew の実行中にエラーを受け取りました。次のメッセージに、コンポーネントのクラス ID とエラー コードが表示されます。このコンポーネントに関連付けられたポート名 : %1%0
ID_E_POSSIBLEBYOTISSUE | 0x3034 | 要求されたコンポーネントを作成できませんでした。このマシンの COM+ アプリケーション内に BYOT コンポーネントを構成したことが原因と考えられます。この設定は XLANG スケジューラ サービスと互換性がありません。このコンポーネントに関連付けられたポート名 : %1%0
ID_E_FIELDPROCESSINGERROR | 0x3035 | 入力されたフィールドの値が無効です。詳細情報は次のとおりです。%1%0
ID_E_NO_OBJECT | 0x3036 | XLANG スケジュールのインスタンスを作成できませんでした。詳細情報は次のとおりです。%1%0
ID_E_STARTUP_FAILED | 0x3037 | 次のエラーが発生したため、1 つ以上の XLANG グループ マネージャが起動に失敗しました : %1%0
ID_E_NON_SCRIPT_BADEXPR | 0x3038 | XLANG スケジュール インスタンスに、許可されないデータ型を持つ条件比較フィールドが含まれています。詳細情報は次のとおりです。%1%0
E_BTW_PERSIST_REACHEDEOF | 0x3039 | ファイルの終端 (EOF) に到達したため、レコード セットはこの行を返すことができません。%1%0
ID_E_BAD_DATAFLOW_EMPTYFIELD | 0x3040 | データ フローの仕様に問題があります。データの送信元として示されているフィールドが空です。以前にフィールドを永続化できていなかった可能性があります。詳細情報は次のとおりです。%1%0
ID_E_CANT_OPEN_DEADLETTER_QUEUE | 0x3041 | XLANG スケジューラ エンジンは、ホスト COM+ アプリケーション用の XLANG 配信不能メッセージ キューを作成または開くことができませんでした。失敗する COM+ アプリケーションの名前 : %1%0
ID_E_CANT_XFER_TO_DEADLETTER_QUEUE | 0x3042 | XLANG スケジューラ エンジンは、無効なメッセージをホスト COM+ アプリケーション用の XLANG 配信不能メッセージ キューに送信することができませんでした。失敗する COM+ アプリケーションの名前 : %1%0
ID_E_CANT_LOADMODULE | 0x3043 | XLANG スケジューラ エンジンが必要なモジュールを読み込めませんでした。これは、モジュールとのコンパイル エラーまたはセマンティック エラーのために発生することがあります。詳細情報は次のとおりです : %1%0
ID_E_USER_DATA_EXCEPTION | 0x3044 | クライアントから受信した値が原因で、例外が発生しました。これは、データに対する不適切なメモリ割り当て、参照カウントの不一致、またはそのほかのデータ破損によって発生します。問題が発生するのはほとんどの場合、クライアントのコードに問題があることが原因です。詳細情報は次のとおりです : %1%2%0
E_BTW_INTERNAL_ERROR | 0x4001 | 内部エラーが発生しました。 %1%0
E_EXPORT_FAILED | 0x4002 | XLANG スケジュールは処理できませんでした。%0
E_BTW_UNKNOWN_SHAPE | 0x4003 | コンパイラはシェイプを認識できません。このシェイプは不明なシェイプです。%0
E_BTW_INCOMPLETE_FLOW | 0x4004 | コネクタがないため、フローが不完全です。%0
E_BTW_INCOMPLETE_FLOW_LEFT | 0x4005 | フローが不完全です。シェイプは左側のコネクタに接続されたフローが必要です。%0
E_BTW_INCOMPLETE_FLOW_RIGHT | 0x4006 | フローが不完全です。シェイプは右側のコネクタに接続されたフローが必要です。%0
E_BTW_INCOMPLETE_FLOW_LATERAL | 0x4007 | フローが不完全です。対象の側面にシェイプが付けられていません。%0
E_BTW_INCOMPLETE_FLOW_TOP | 0x4008 | フローが不完全です。シェイプは上部のコネクタに接続されたフローが必要です。%0
E_BTW_INCOMPLETE_FLOW_BOTTOM | 0x4009 | フローが不完全です。シェイプは下部のコネクタに接続されたフローが必要です。%0
E_BTW_INCOMPLETE_FLOW_ANYLINE | 0x400A | フローが不完全です。シェイプに接続されていません。%0
E_BTW_MIRRORLIST_INCONSISTENT | 0x400B | 失敗時ページまたは補正ページ内にミラー シェイプが見つかりません。シェイプを新しいものに置き換えて再試行してください。%0
E_BTW_BEGIN_INSIDE_TRANSACTION | 0x4010 | 開始シェイプはトランザクションの中に入れないでください。%0
E_BTW_END_MULTIPLE_LOOP | 0x4020 | 繰り返し分岐で使用できる終了シェイプは 1 つのみです。%0
E_BTW_END_IN_TRANSACTION | 0x4021 | コンテキスト内では終了シェイプを使用できません。%0
E_BTW_SYNCACTION_NO_PAIR | 0x4030 | COM ポートにバインドするには、アクションを組にしてください。%0
E_BTW_INCOMPLETE_FLOW_BINDING | 0x4031 | アクションまたはポートにバインドがありません。%0
E_BTW_FIELD_TYPE_NOT_SUPPORTED | 0x4040 | 型 (バリアント型 =%1) はサポートされていません。%0
E_BTW_ROLE_NOT_SUPPORTED | 0x4050 | コントラクト (ロールのある XLANG スケジュール) をコンパイルできません。%0
E_BTW_EMPTY_TRANSACTION | 0x4060 | トランザクションは有効なシェイプを含んでいません。%0
E_BTW_TRANSACTION_NOT_PERMITTED | 0x4061 | XLANG スケジュールを COM+ コンポーネントとして扱う場合、トランザクション シェイプは使用できません。トランザクションを削除するか、開始シェイプのプロパティを編集してトランザクション モデルを変更してください。%0
E_BTW_TRANSACTION_BOUNDARIES_CROSSED | 0x4062 | 最初にフローをトランザクションに接続しないと、外部のトランザクションからトランザクション内のシェイプにフローを接続できません。トランザクションの上部の接続ポイントにフローを記述してトランザクションに接続します。次に、トランザクションをクリックして強調表示します。トランザクションの接続ポイントからトランザクション内の最初のシェイプに別のフローを記述します。トランザクションを保持したままフローを記述するには、トランザクションの下部の接続ポイントに最初にフローを接続する必要があります。次に、トランザクションをクリックして強調表示します。下部の接続ポイントからビジネス プロセス内の次のシェイプに別のフローを記述します。%0
E_BTW_TRANSACTION_TERMINATED_PREMATURELY | 0x4063 | トランザクションに、トランザクションから出るためのパスを 1 つ以上設定してください。%0
E_BTW_NO_RULES_FOR_SWITCH | 0x4070 | 判断シェイプには条件を少なくとも 1 つ設定してください。%0
E_BTW_CANNOT_WAIT_ON_ALL_SWITCH_BRANCHES | 0x40A0 | 判断からの "すべての" 分岐を待てません。%0
E_BTW_NO_BRANCH_FOUND | 0x40A1 | 結合は、対応する分岐または判断を見つけられません。%0
E_BTW_JOIN_MISMATCH | 0x40A2 | この分岐または判断に使用できる結合は、1 つだけです。%0
E_BTW_JOIN_SHARED | 0x40A3 | 同じ結合は異なる分岐や判断から受信したフローに使用できません。%0
E_BTW_CANNOT_WAIT_ON_SOME_SWITCH_BRANCHES | 0x40A4 | 判断からのパスをすべて結合につなぐことはできません。%0
E_BTW_CANNOT_WAIT_ANY_ON_FORK_BRANCHES | 0x40A5 | "または" を待つことができません。分岐に、送信待スケジュールとならないと思われる処理書式が含まれています。%0
E_BTW_DATAFLOW_DISALLOWED_ON_BTM_PORT | 0x40C0 | このポートは、繰り返し内の複数の受信アクションまたは 1 つの受信アクションで使用できません。%0
E_BTW_MESSAGE_TECH_NOT_FOUND | 0x4110 | メッセージはどのポートにもバインドされていません。%0
E_BTW_MESSAGE_TYPE_MISMATCH | 0x4111 | メッセージが競合型 "%1" および "%2" で使用されました。%0
E_BTW_MISSING_TECHNOLOGY | 0x4120 | この通信フローで利用できるメソッドの一覧に、変更が加えられています。メソッド通信ウィザードをもう一度実行して別のメソッドを選択し、この通信フローを更新してください。%0
E_BTW_MISSING_PORT_DATAFLOW | 0x41A0 | このポート設定は、XLANG スケジューラ エンジン以外で作成されたことを示しています。適切なメッセージ フィールドから接続を記述して、このポート参照の送信元を指定してください。%0
E_BTW_CIRCULAR_DATAFLOW | 0x41A1 | この XLANG スケジュールのデータフロー パスは循環パスである可能性があります。%0
E_BTW_LOOP_NORULE | 0x41D0 | 条件が定義されていません。%0
E_BTW_LOOP_BODY_EXITS_TRANSACTION | 0x41D1 | 繰り返しの本体が、繰り返しを囲んでいるトランザクションから脱出できません。%0
E_BTW_LOOP_BODY_END_MISSING | 0x41D2 | 繰り返し本体の終了位置が見つかりません。%0
E_BTW_ABORT_NOT_IN_TXN | 0x41E0 | 中断シェイプは、これを囲むトランザクションに関連付けてください。%0
E_BTW_ABORT_CONTEXT_INVALID_SCOPE | 0x41E1 | 中断シェイプは、現在のコンテキストまたは親コンテキストのみを参照できます。%0
E_BTW_END_MULTIPLE_ABORT | 0x41E2 | 失敗時ページで複数の終了シェイプを使用することはできません。%0
E_BTW_COMPILER_FAILED | 0x5000 | "%1" でコンパイルに失敗しました。%0
E_BTW_PARSE_FAILED | 0x5001 | 解析に失敗しました。%0
E_BTW_FIXUP_FAILED | 0x5002 | 修正に失敗しました。%0
E_BTW_VALIDATION_FAILED | 0x5003 | 検証に失敗しました。%0
E_BTW_NODE_FAILURE | 0x5004 | 場所はノード "%1" (%2!d!、%3!d!) です。%0
E_BTW_STACK_TOO_MANY_ITEMS | 0x5005 | スタックにある項目が多すぎます。%0
E_BTW_STACK_UNEXPECTED_NODE | 0x5006 | 予期しないノードが見つかりました。%0
E_BTW_XMLQUERY_RETURNED_ZERO_NODES | 0x5007 | XML クエリからはノードが返されませんでした。%0
E_BTW_XMLQUERY_RETURNED_MULTIPLE_NODES | 0x5008 | XML クエリから複数のノードが返されました。%1%0
E_BTW_XMLQUERY_MISSING_ATTRIBUTE | 0x5009 | 必要な属性 "%1" がありません。%0
E_BTW_LOAD_MODULE_FAILED | 0x500A | モジュール "%1" の読み込みに失敗しました。%0
E_BTW_XML_LOAD_FAILED | 0x500B | XML-DOM が "%1!d!、%2!d!" にエラーを返しました。%0
E_BTW_ERROR_LOADING_PACKAGE | 0x500C | URL "%2" を読み込み中に "0x%1!X!" エラーが発生しました。%0
E_BTW_NAMED_LIST_HAS_DUPLICATE_ENTRIES | 0x500D | 一覧に "%1" という名前の重複エントリがあります。%0
E_BTW_REQUIRED_ELEMENT_MISSING | 0x500E | 必須の要素 "%1" がありません。%0
E_BTW_ELEMENT_MISSING_VALUE | 0x5100 | 要素の値がありません。%0
E_BTW_REFERENCE_RESOLVE_FAILED | 0x5110 | 位置の値 "%2" で "%1" を解決できません。%0
E_BTW_CONTEXTREF_INVALID_REFERENCE | 0x5120 | 独立した (何も囲んでいない) コンテキストに "戻る" またはそこから "開放する" ことはできません。%0
E_BTW_CONTEXTREF_SELF_REFERENCE | 0x5121 | 外側のコンテキストから内側のコンテキストに "戻る" または内側のコンテキストから "出る" ことはできません。%0
E_BTW_ASYNC_ACTION_COM_NOT_ALLOWED | 0x5400 | 同期アクションには、COM ポート以外のポートを参照させるようにしてください。%0
E_BTW_CONNECTION_PORT_HAS_TECH_BINDING | 0x5490 | 接続で使用されているポート "%1" にはテクノロジをバインドできません。%0
E_BTW_CONNECTION_PORT_REUSED | 0x5491 | 接続で使用されているポート "%1" は、XLANG スケジュールで既に使用されています。%0
E_BTW_TRANSACTIONS_NESTED | 0x54B0 | トランザクションをネストする場合は、外側のトランザクションの方がより長い間実行されるようにしてください。%0
E_BTW_TRANSACTIONS_NESTED_RETRY | 0x54B1 | トランザクションをネストする場合、外側のトランザクションには再試行回数を指定できません。%0
E_BTW_MESSAGE_HAS_NO_DECL | 0x5520 | メッセージ "%1" に関連付けられている宣言はありません。%0
E_BTW_MESSAGE_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5521 | メッセージ "%1" の "%2" に対するデータ依存関係は不完全です。依存関係は、フロー内で作成中ではありません。または依存関係が、"インスタンスを作成しない" オプションが選択されているポート上で要求されている可能性があります。%0
E_BTW_PORT_HAS_NO_BINDING | 0x5570 | ポート "%1" に関連付けられているバインドはありません。%0
E_BTW_PORT_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5571 | ポート "%1" のメッセージ "%2" に対するデータ依存関係は不完全です。依存関係は、フロー内で作成中ではありません。または依存関係が、"インスタンスを作成しない" オプションが選択されているポート上で要求されている可能性があります。%0
E_BTW_RULE_HAS_NO_BINDING | 0x55B0 | 条件 "%1" に関連付けられているバインドはありません。%0
E_BTW_SCHEDULE_SUSPENDED | 0x55E0 | XLANG スケジュールが中断されました。%0
E_BTW_SCHEDULE_STOPPED | 0x55E1 | XLANG スケジュールが停止されました。%0
E_BTW_PERSIST_FAILED | 0x55E2 | XLANG スケジュール インスタンスのステータスをデータベースに保存できませんでした。%0
E_BTW_SUSPEND_FAILED | 0x55E3 | XLANG スケジュールを中断できませんでした。%0
E_XLANG_SHUTTINGDOWN | 0x55E4 | XLANG アプリケーションをシャットダウンしています。%0
E_BTW_MISSING_MESSAGE_BINDING_ON_PORT | 0x5730 | アクションはポート "%1" を使用していますが、ポートのバインドではメッセージ "%2" へのバインドは定義されていません。%0
E_BTW_MISSING_INCOMING_PORTREF | 0x5731 | この受信アクションが使用するメッセージは、ポート参照 (%2) に接続されたフィールド (%1) を含んでいますが、このデータフロー接続は、受信する必要があるポート参照 (%2) を示しません。%0
E_BTW_SOURCE_PORT_HAS_NOINVOCATION | 0x5740 | この送信アクションは、"インスタンスを作成しない" オプションが選択されているポート "%1" を参照しています。%0
E_BTW_MISSING_OUTGOING_PORTREF | 0x5741 | この受信アクションが使用するメッセージは、ポート参照 (%2) に接続されたフィールド (%1) を含んでいますが、このデータフロー接続は、送信する必要があるポート参照を示しません。%0
E_BTW_TASK_LIMIT | 0x5750 | タスクに "%1!d!" 個のアクションがあります。現在の上限は "%2!d!" 個です。%0
E_BTW_SYNC_DIFFERENT_PORTS | 0x5760 | 同期アクションの組は別々のポート "%1" と "%2" を参照しています。%0
E_BTW_SYNC_SAME_MESSAGE | 0x5761 | 同期アクションの組は同じメッセージ "%1" を参照しています。%0
E_BTW_SYNC_ONLY_COM_ALLOWED | 0x5762 | 同期アクションの組には、COM ポートのみを参照させるようにしてください。%0
E_BTW_SYNC_SECOND_MESSAGE_MUST_BE_OUT_FOR_FIRST_MESSAGE | 0x5763 | 同期アクションの組では、2 番目のアクションにあるメッセージは 1 番目のアクションにあるメッセージの出力メッセージにしてください。%0
E_BTW_INVALID_DELAY_TIME | 0x5770 | 遅延時間 (%1!d!) が無効です。遅延時間はマイナスにできません。%0
E_BTW_CALL_MESSAGE_SCHEMA_NAME_MISMATCH | 0x5800 | XLANG スケジュールを呼び出しているメッセージ "%2" のメッセージ仕様名 "%1" が、XLANG スケジュールを呼び出した仕様名 "%3" と一致しません。%0
E_BTW_CALL_MESSAGE_SCHEMA_REPRESENTATION_MISMATCH | 0x5801 | XLANG スケジュールを呼び出しているメッセージ "%1" のメッセージ仕様表現が、XLANG スケジュールを呼び出した仕様表現と一致しません。%0
E_BTW_ASSIGNMENT_PORT_HAS_TECH_BINDING | 0x5830 | 切り取り書式の割り当てで使用されているポート "%1"には、テクノロジをバインドできません。%0
E_BTW_PARTITION_LIMIT | 0x5850 | パーティションに "%1!d!" 個のプロセスがあります。現在の上限は "%2!d!" 個です。%0
E_BTW_MESSAGE_USED_IN_PARALLEL | 0x5851 | 並列アクションまたは並列処理は同じメッセージ "%1" を使用します。%0
E_BTW_PORT_USED_IN_PARALLEL | 0x5852 | 並列アクションまたは並列処理は同じポート "%1" を使用します。%0
E_BTW_INVALID_RETRY_COUNT | 0x5A30 | 再試行回数 "%1!d!" が無効です。再試行回数はマイナスにできません。%0
E_BTW_INVALID_BACKOFF_VALUE | 0x5A31 | バックオフ値 "%1!d!" が無効です。バックオフ値はマイナスにできません。%0
E_BTW_INVALID_TIMEOUT_VALUE | 0x5A32 | タイムアウト値 "%1!d!" が無効です。タイムアウト値はマイナスにできません。%0
E_BTW_FIELD_RESERVED_NAME | 0x5A50 | %1 は予約済みフィールド名です。%0
E_BTW_ELEMENT_TYPE_NOT_DEFINED | 0x5A51 | 要素型 "%1" は定義されていません。%0
E_BTW_ELEMENT_TYPE_INCOMPLETE | 0x5A70 | 要素型の定義が不完全です。下位要素または dt:type を指定してください。%0
E_BTW_MULTIPLE_PORTS | 0x5A90 | 異なるポート "%1" と "%2" が同じフィールドで使用されています。%0
E_XLANG_INVALID_COMPARE_TYPE | 0x5A91 | このデータ型の比較は許可されません。%0
E_BTW_FIELD_NOT_MATCHING_SCHEMA_ELEMENT | 0x5A92 | "%1" の FieldBinding には、スキーマと一致する要素がありません。位置は "%2!d!" です。%0
E_BTW_FIELD_HAS_AMBIGUOUS_DATAFLOW | 0x5A93 | メッセージ フィールドは、別のメッセージ フィールドからと参照からのポートへのデータ フローを両方持つことができません。どちらか 1 つを削除してください。%0
E_BTW_PORT_TARGET_INVALID | 0x5A94 | このフィールドの種類は、ポート参照としての使用に適していません。COM にバインドされているポートがオブジェクト参照または文字列として通信できます。メッセージ キューにバインドされているポートは文字列としてのみ転送されます。内部ポートはオブジェクト参照としてのみ通信できます。%0
E_BTW_FIELD_TARGET_INVALID | 0x5A95 | バリアント型 "%2" の送信先フィールド "%1" は、バリアント型 "%4" の送信元フィールド "%3" からデータを取得できません。%0
E_BTW_INITIALIZED_MESSAGEFIELD_INVALID_OVERWRITE | 0x5A96 | 初期化したメッセージ "%2" のフィールド "%1" にあるデータは、バインド仕様の別のメッセージまたはポートのデータで上書きできません。%0
E_BTW_DATAFLOW_INCOMPLETE | 0x5AB1 | [in] パラメータを受け入れるソース アクションには、データ フローによって表示されるフィールド (from フィールド) を対応させてください。%0
E_BTW_DATAFLOW_FROM_SYSTEM_FIELD | 0x5AB2 | システム フィールドからポートを初期化できません。%0
E_BTW_DATAFLOW_FROM_CONSTANT_FIELD | 0x5AB3 | 定数メッセージ フィールドからはポートを初期化できません。%0
E_BTW_MISSING_SCRIPT_EXPRESSION | 0x5AC0 | 条件に対する条件式が入力されていません。%0
E_BTW_BAD_SCRIPT_EXPRESSION | 0x5AC1 | %1"%4" の文字位置 %3!d! にある %2。%0
E_BTW_MAP_INVALID_BINDING | 0x5AE0 | メッセージ "%1" のバインドに、マップ済みのポート "%2" への参照を含めてください。%0
E_BTW_MESSAGE_BINDING_SCHEMA_MISMATCH | 0x5AE1 | バインドと、メッセージ "%1" のスキーマが一致しません。%0
E_BTW_MESSAGEDECL_INIT_DATA_UNAVAILABLE | 0x5B00 | フィールド "%1" のための初期化データを取得できません。%0
E_BTW_LATENCY_INVALID_VALUE | 0x5B20 | 待ち時間のプロパティ値は、最大値 "%1!d!" より小さいマイナス以外の整数にしてください。%0
E_BTW_PORT_LATENCY_ON_INTERNAL | 0x5B21 | 内部ポートには待ち時間を指定できません。%0
E_BTW_MESSAGE_TECHNOLOGY_MISMATCH | 0x5BB0 | ポート "%1" テクノロジ "%2" とメッセージ "%3" テクノロジ "%4" が一致しません。%0
E_BTW_FIELD_TECHNOLOGY_MISMATCH | 0x5BC0 | メッセージ "%1" テクノロジ "%2" とフィールド "%3" テクノロジ "%4" が一致しません。%0
E_BTW_COM_PORT_NOT_CREATABLE | 0x5C10 | COM ポートを呼び出せる場合、COM ポートの CLSID、ProgID、またはモニカのいずれかが必要になります。%0
E_BTW_AUTORETURN_COM_PORT_MUST_BE_USED_INSIDE_CONTEXT | 0x5C11 | ポート "%1" は、失敗を示す HRESULT がメソッドから返されると、トランザクションを中断するように構成されています。このポートはトランザクション内でのみ使用できます。%0
E_BTW_COM_PORT_GENERAL_ACCESS_FAILURE | 0x5C12 | COM ポートを呼び出すことができます。Windows 2000 のドキュメントを参照してください。%1%0
E_BTW_COM_PARAMETERS_LIMIT | 0x5C20 | メソッドに "%1!d!" 個のパラメータがあります。現在の上限は "%2!d!" 個です。%0
E_BTW_COM_NO_MATCHING_RETURN | 0x5C21 | COM メソッドに対応する戻り値 がありません。%0
E_BTW_COM_NO_MATCHING_METHOD | 0x5C22 | COM 戻り値に対応するメソッドがありません。%0
E_BTW_INVALID_SLOT_NUMBER | 0x5C23 | スロットの数 "%1!d!" が無効です。スロットの数は、SLOT_NONE(-1) より小さくできません。%0
E_BTW_INVALID_INVOKE_KIND | 0x5C24 | invokeKind 値 "%1!d!" が無効です。使用可能な値は 1、2、3、4、および 8 です。%0
E_BTW_PROXY_DISCONNECTED | 0x5C25 | プロキシは切断されました。%0
E_BTW_COM_DISPATCH_SLOT_SPECIFIED | 0x5C26 | ディスパッチ インターフェイスに対してはスロットの数を指定できません。%0
E_BTW_COM_SPECIFY_DISPID_OR_SLOT | 0x5C27 | ディスパッチ ID またはスロットに、有効な値を指定してください。%0
E_BTW_COM_INVALID_BYREF_FOR_RETURN_MESSAGES | 0x5C30 | "%1" は <com:return> メッセージなので Byref を "1" にしてください。%0
E_BTW_COM_INVALID_NESTED_VARIANTS | 0x5C31 | 1 レベル以上ネストした変数は許可されていません。%0
E_BTW_COM_FIELD_INDEX_MUST_BE_NON_NEGATIVE | 0x5C32 | フィールドのインデックス "%1!d!" は、有効なインデックスではありません。インデックスは正の整数にしてください。%0
E_BTW_COM_FIELD_INDEX_REPEATED | 0x5C33 | フィールドのインデックス "%1!d!" は、メッセージ内にある別のフィールドで既に使用されています。%0
E_BTW_COM_FIELD_INDEX_NOT_CONTIGUOUS | 0x5C34 | 同期アクションの組のメッセージ "%1" と "%2" において、フィールドのインデックス "%3!d!" が無効です。これらのメッセージのフィールド インデックスは、0 から始まる連続した正の整数ブロックを形成している必要があります。%0
E_BTW_MSMQ_NO_MQRT_DLL | 0x5D00 | メッセージ キュー DLL と MQRT.DLL を読み込めませんでした。%0
E_BTW_MSMQ_CREATECHANNEL | 0x5D01 | MQBinder: %1 のチャネルの作成に失敗しました。%0
E_BTW_MSMQ_NOT_CONFIGERED_PROPERLY | 0x5D02 | メッセージ キュー サービスが正しく構成されていません。キュー オブジェクトを開けませんでした。%1%0
E_BTW_MSMQ_NO_CERTIFICATE_AVAILABLE | 0x5D03 | メッセージ キュー サービスは、証明書を取得できません。%1%0
E_BTW_MSMQ_NO_WELLKNOWN_QUEUE_NAME | 0x5D04 | XLANG スケジュールでキューが命名されていないため、メッセージを既存のキューに送信できません。XLANG スケジュールでキューの名前を指定してください。%1%0
E_BTW_MSMQ_INVALID_FIELD_TYPE | 0x5D05 | メッセージ "%1" のフィールド "%2" に指定されたフィールドの種類が無効です。%0
E_BTW_MSMQ_PORT_NOT_BOUND | 0x5D06 | メッセージ キュー ポートがバインドされていません。%1%0
E_BTW_MSMQ_QUEUE_NOT_TRANSACTIONAL | 0x5D10 | キューにはトランザクションの正しいプロパティがありません。%1%0
E_BTW_MSMQ_OPEN_ACCESSDENIED | 0x5D11 | キューを開いているときに、メッセージ キューへのアクセス拒否エラーが発生しました。XLANG スケジュールのキューについて指定した accessRole と、現在のユーザーに関連付けられている権利を比較してください。%1%0
E_BTW_MSMQ_OPEN_GENERALFAILURE | 0x5D12 | キューを開いているときに、メッセージ キューのエラーが発生しました。エラー コードについて調べ、適切な診断を行うには、Windows 2000 のメッセージ キュー サービスに関するドキュメントを参照してください。%1%0
E_BTW_MSMQ_PORT_NOT_CREATABLE | 0x5D13 | メッセージ キューを使用して実装されているポートには、キュー名が必要です。%0
E_BTW_MSMQ_GENERAL_QUEUE_ACCESS_FAILURE | 0x5D14 | キューへのアクセス中にメッセージ キューのエラーが発生しました。エラー コードについて調べ、適切な診断を行うには、Windows 2000 のメッセージ キュー サービスに関するドキュメントを参照してください。%1%0
E_BTW_MSMQ_INVALID_MESSAGE_VT_TYPE | 0x5D20 | メッセージ キューのメッセージの形式が不明です。%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGETYPE | 0x5D21 | メッセージ キューのメッセージの種類が不明です。メッセージの種類をメッセージから取得できませんでした。%1%0
E_BTW_MSMQ_MESSAGE_UNAUTHENTICATED | 0x5D22 | メッセージ キューのメッセージが認証されていませんが、ポートが受信できるのは認証されたメッセージのみです。%1%0
E_BTW_MSMQ_MESSAGE_INCORRECT_AUTHENTICATE_LEVEL | 0x5D23 | メッセージ キューのメッセージが要求されたレベルで認証されていません。%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGE | 0x5D24 | メッセージ キューのメッセージに無効な本文があります。%1%0
E_BTW_MSMQ_MESSAGE_NOT_SEND | 0x5D25 | メッセージ キューのメッセージを送信できませんでした。%1%0
E_BTW_MSMQ_MESSAGE_SCHEMAVALIDATION_FAILED | 0x5D26 | メッセージ キューのメッセージは、提供されたスキーマに対して正しく検証されませんでした。スキーマおよびスキーマのパスを確認してください。%1%0
E_BTW_MSMQ_COULD_NOT_CREATE_MQMESSAGE | 0x5D27 | メッセージのインスタンスをメッセージ キューのメッセージに変換できませんでした。%1%0
E_BTW_MSMQ_NO_TRUSTRELATIONSHIP_FOR_USER | 0x5D28 | 入力されたユーザーの信頼関係を確立できませんでした。%1%0
E_BTW_MSMQ_MESSAGE_EMPY_MESSAGE | 0x5D29 | メッセージ キューのメッセージで、メッセージ本体が空になっています。%1%0
E_BTW_MSMQ_MESSAGE_ONLY_ONE_EMPTY_XPATH_ALLOWED | 0x5D2A | メッセージ キューのメッセージには、空のノード パス (XPath) を持つフィールドは 1 つのみ含めることができます。%0
E_BTW_MSMQ_MESSAGE_ONE_EMPTY_XPATH_NEEDED | 0x5D2B | メッセージ キューのメッセージには、空のノード パス (XPath) を持つフィールドが 1 つ必要です。%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGEBODY | 0x5D2C | メッセージ キューのメッセージに無効な本文があります。%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGESTRING | 0x5D2D | メッセージ キューのメッセージの本文に無効な文字列があります。%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGE | 0x5D2E | メッセージ キューのメッセージが無効または不明なメッセージのため、配信不能メッセージ キューに移動されました。%1%0
E_BTW_MSMQ_MESSAGE_TYPE_CONFLICTING_SCHEMA | 0x5D2F | メッセージ キューのメッセージ "%1" と "%2" (ポート "%4" の種類 "%3") は仕様表現が競合しています。これは、名前、種類、または XPath クエリが 2 つの表示内のフィールドの 1 つと一致しないために発生することがあります。%0
E_BTW_MSMQ_DOCUMENT_FIELD_TYPE_NOT_STRING | 0x5D30 | メッセージ キューのメッセージにあるフィールド "%1" に、空のノード パス (XPath) が含まれています。フィールドのデータ型を文字列データ型にしてください。%0
E_BTW_MSMQ_DOCUMENT_FIELD_CANNOT_CONVERT_TO_STRING | 0x5D31 | メッセージ キューのメッセージのフィールドを文字列に変換できませんでした。%1%0
E_BTW_MSMQ_DOCUMENT_FIELD_CONVERTION_FAILURE | 0x5D32 | メッセージ キューのメッセージのフィールドを変換できませんでした。%1%0
E_BTW_CANT_DISPOSE_MESSAGE | 0x6001 | XLANG スケジュール インスタンスが、無効なメッセージを受信したキューにバインドされました。XLANG スケジューラ エンジンはこのメッセージを配信不能メッセージ キューに送信できませんでした。このため、スケジュール インスタンスは終了しました。%0

関連項目

BizTalk Server エラーのためのイベント ビューアの構成


概念

ここでは、BizTalk Server 管理コンソールを理解するうえで不可欠な概念について説明します。サーバー グループの作成、受信機能の定義、および Microsoft BizTalk Server 2000 でのドキュメントの利用状況を監視、表示、およびログに記録するためのデータベースの作成などの管理作業について説明します。

ここには次のトピックが含まれます。

  • WMI の概要

  • BizTalk Server 管理コンソールの環境

  • 管理キャッシュ

  • BizTalk Server データベースの管理

  • グループとサーバー

  • サーバー エラーの処理

  • 受信機能

  • キューの使用

  • 管理者特権


WMI の概要

Windows Management Instrumentation (WMI) は、Microsoft Windows 2000 に含まれるデータ管理レイヤです。Microsoft BizTalk Server 2000 は、WMI レイヤを使用して管理機能をカプセル化します。BizTalk Server 管理コンソールを使用して、グループ、サーバー、およびキューの設定を変更する場合、新しい値は、BizTalk Server WMI プロバイダを経由して BizTalk メッセージ管理データベースに格納されます。BizTalk Server 2000 では、この WMI プロバイダは Microsoft SQL Server データベースを使用して管理オブジェクトを格納します。WMI は、統一スクリプト アプリケーション プログラミング インターフェイス (API) をサポートします。この API は、ローカル コンピュータまたはリモート コンピュータ上の WMI プロバイダへのアクセスをアプリケーションとスクリプトに提供するものです。

注

  • WMI には、WMI オブジェクト パスに使用できる構文と有効な文字に制限があります。` ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ? は無効な文字です。

    サーバー グループ名を作成する場合、これらの文字を使用してはいけません。

  • すべてのタイムスタンプは、Microsoft SQL Server のローカル時刻を使用して作成されます。ただし、WMI プロバイダは世界標準時 (UTC) のタイムスタンプを参照します。その後、管理コンソールは、表示するためにタイムスタンプをローカル時刻に変換します。

  • プログラムによって WMI データベース レイヤにアクセスするには、\Program Files\Microsoft BizTalk Server\Setup フォルダにある InterchangeProvSchema.mof ファイルを使用します。このファイルには、管理オブジェクトに対応する WMI クラスが含まれています。WMI アプリケーション プログラミングの詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で "WMI Application Programming" を検索してください。


BizTalk Server 管理コンソールの環境

ここには次のトピックが含まれます。

  • BizTalk Server 管理コンソールのユーザー インターフェイス

  • BizTalk Server 管理コンソールのショートカット キー


BizTalk Server 管理コンソールのユーザー インターフェイス

BizTalk Server 管理コンソール (単に管理コンソールともいいます) は、システム管理者が管理できる BizTalk Server コンポーネントの視覚的な表現を提供する Microsoft 管理コンソール (MMC) スナップインです。管理コンソールの左側はコンソール ツリーといい、サーバー グループなどのさまざまな項目を表すフォルダとサブフォルダから構成されています。管理コンソールの右側は詳細ペインといい、コンソール ツリーで選択した項目に関する情報が表示されます。

画面上では、Microsoft BizTalk Server 2000 は管理コンソールの左側にコンソール ルートの下位項目として表示されます。BizTalk Server で構成される各サーバー グループは別々のサブフォルダに表示され、そのグループのキューおよび受信機能と、グループ内のサーバーの名前から構成されます。コンソール ツリーで項目を展開すると、その項目に関する詳細項目が表示されます。項目を右クリックすると、その項目を構成したり、新しい項目を作成することができます。

関連項目

BizTalk Server 管理コンソールを開く


BizTalk Server 管理コンソールのショートカット キー

BizTalk Server 管理コンソールのタスクは、ショートカット キーを使用しても実行できます。次の表は、Microsoft 管理コンソールのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional ヘルプでは、「マウス キーでマウス ポインタを動かすには」を参照してください。

ショートカット キー | 機能
F5 | BizTalk Server 管理コンソールを最新の情報に更新します。 このショートカット キーは、コンソール ツリーで強調表示されている現在の項目を更新します。
Alt + F4 | BizTalk Server 管理コンソールを閉じます。
Alt + マイナス記号 (-) | アクティブなコンソール ウィンドウのウィンドウ メニューを表示します。
Shift + F10 | 選択した項目の [操作] メニューを表示します。
Alt + A | 選択した項目の [操作] メニューを表示します。
Alt + V | [表示] メニューを表示します。
F1 | 選択した項目のオンライン ヘルプを表示します。
Alt + Enter | 選択した項目のプロパティがあれば、そのプロパティ ダイアログ ボックスを表示します。

関連項目

BizTalk Server 管理コンソールを開く


管理キャッシュ

BizTalk Server を起動すると、サーバー グループ、サーバー グループのプロパティ、受信機能、共有キュー データベースおよび追跡データベースへの接続など、BizTalk Server 管理コンソールのすべての項目が管理キャッシュに格納されます。キャッシュ内のすべての項目は、サーバー データベース接続とサーバーのプロパティを除いて、50 秒ごとに更新されます。つまり、SMTP ホストや信頼できるメッセージの返信先 URL などのサーバー グループの一般プロパティを変更すると、その変更は 50 秒ごとに反映されます。ただし、[プロセッサごとの使用可能な作業スプレッドの最大数] などのサーバーのプロパティを変更した場合は、構成を変更したサーバーを停止してから再起動して、その変更をキャッシュに格納する必要があります。また、BizTalk メッセージ管理データベース、追跡データベース、または共有キュー データベースへの接続を変更した場合は、そのグループ内のサーバーを停止してから再起動して、BizTalk Server インターチェンジ アプリケーションをシャットダウンする必要があります。

関連項目

サーバー グループの全般プロパティの構成

BizTalk Server インターチェンジ アプリケーションのシャットダウン

グループ内のサーバーの起動

グループ内のサーバーの停止


BizTalk Server データベースの管理

BizTalk メッセージ サービスには、次の 3 つのデータベースが関連付けられています。

  • BizTalk メッセージ管理データベース

  • 追跡データベース

  • 共有キュー データベース

BizTalk メッセージ管理データベースは、グループとサーバーの設定や受信機能を含むすべてのサーバー構成情報を格納します。これらの管理オブジェクトの構成は、BizTalk Server 管理コンソールまたはプログラムによって処理されます。BizTalk メッセージ管理データベースは、チャネル、メッセージ ポート、およびその他のメッセージ オブジェクトのすべてのメッセージ構成情報も格納します。メッセージ構成情報はこのデータベースに格納されますが、オブジェクトの構成は BizTalk メッセージ マネージャを使用して処理されるか、または BizTalk メッセージ構成オブジェクト モデルを使用してプログラムにより処理されます。チャネル、メッセージ ポートなどの構成の詳細については、「BizTalk メッセージ マネージャの使用」または「オブジェクト モデルに関するリファレンス」を参照してください。

追跡データベースは、BizTalk Server によって処理されるすべてのインターチェンジ、ドキュメント、および受信確認のログを保持します。追跡データベースの詳細については、「追跡データベース」を参照してください。追跡設定を構成するには、「サーバー グループの追跡のプロパティの構成」を参照してください。特定のフィールドまたはドキュメント インスタンス データを追跡するには、「チャネルのプロパティの設定」を参照してください。

共有キュー データベースは、処理中または処理を待機している間にドキュメントを保持します。ドキュメントは処理が終わると削除されます。共有キュー データベースの詳細については、「共有キュー データベース」を参照してください。

ここには次のトピックが含まれます。

  • BizTalk メッセージ管理データベースの管理

  • BizTalk サーバー グループ データベースの管理


BizTalk メッセージ管理データベースの管理

ほとんどの業務用の用途では、1 つの中央 BizTalk メッセージ管理データベースを使用して、複数のサーバー グループ、サーバー、チャネル、メッセージ ポートなどを構成します。このガイドラインの例外の 1 つに、サード パーティ ベンダがあります。サード パーティ ベンダでは、顧客に固有の業務上のニーズに基づいて、顧客ごとに BizTalk メッセージ管理データベースが必要になることがあります。ただし、その他すべての場合には、すべての BizTalk サーバー グループに対して 1 つの中央 BizTalk メッセージ管理データベースを使用することを強くお勧めします。

場合によっては、中央 BizTalk メッセージ管理データベースからサーバーを削除する必要が生じることがあります。たとえば、BizTalk メッセージ管理データベースが格納されているサーバーのメンテナンスが必要になる場合があります。この場合、すべてのサーバー グループが複製された BizTalk メッセージ管理データベースを参照するようにして、BizTalk Server が停止しないようにする必要があります。また、BizTalk メッセージ管理データベース間でサーバーを移動する必要が生じることもあります。たとえば、3 社の顧客、A、B、および C を持つサード パーティ ベンダで、顧客 A の業務が減少し、顧客 B と顧客 C からの業務が増加したとします。この場合、顧客 A の BizTalk メッセージ管理データベースと関連付けられたサーバーを顧客 B および顧客 C と関連付けられたデータベースに移動することができます。

ここには次のトピックが含まれます。

  • BizTalk メッセージ管理データベースの変更

  • BizTalk メッセージ管理データベースからのサーバーの削除

  • BizTalk メッセージ管理データベース間でのサーバーの移動

  • BizTalk メッセージ管理データベース間でのリモート サーバーの移動


BizTalk メッセージ管理データベースの変更

BizTalk メッセージ管理データベースを構成するには、2 つの方法があります。

  • インストール中に利用できる構成オプションを使用する。

  • Microsoft BizTalk Server 2000 ノードでサーバーを変更するための BizTalk Server 管理コンソールを使用する。

単一のサーバーからすべての BizTalk サーバーを集中的に管理するには、インストール時に中央 BizTalk メッセージ管理データベースを参照するようにすべてのサーバーを構成します。このように構成すると、任意の BizTalk サーバーで BizTalk Server 管理コンソールを開くたびに、Microsoft BizTalk Server 2000 ノードに一覧表示されているサーバーが同じ BizTalk メッセージ管理データベースを参照するため、集中的に管理することができます。サーバー グループが中央 BizTalk メッセージ管理データベースを参照していれば、通常、別の BizTalk メッセージ管理データベースを変更する必要はありません。この例外として、メンテナンスのためにそのデータベースをオフラインにする場合があります。この場合、BizTalk Server 管理コンソールを使用して、Microsoft BizTalk Server 2000 ノードのすべてのサーバー グループを中央データベースの複製を参照するようにします。ほかのサーバー グループと関連付けられている別の中央 BizTalk メッセージ管理データベースを一時的に参照するようにしてはいけません。そのようにすると、元の BizTalk メッセージ管理データベースの構成に戻せなくなることがあります。

関連項目

BizTalk サーバー グループ

サーバーの BizTalk メッセージ管理データベースの変更

BizTalk メッセージ管理データベースの構成

BizTalk メッセージ管理データベース間でのサーバーの移動


BizTalk メッセージ管理データベースからのサーバーの削除

中央 BizTalk メッセージ管理データベースからすべての BizTalk サーバーを削除しても、そのデータベースの内容は失われません。同様に、システムに複数の中央 BizTalk メッセージ管理データベースがあり、1 つの中央 BizTalk メッセージ管理データベースからすべての BizTalk サーバーを削除しても、そのデータベースの内容は失われません。BizTalk Server 2000 データベース セットアップ ウィザードを実行し、[BizTalk メッセージ管理データベースを構成します] ページで既存のデータベースを選択することによって、中央 BizTalk メッセージ管理データベースに新しい BizTalk サーバーを追加することができます。サーバーの BizTalk メッセージ管理データベースの追加または変更の詳細については、「サーバーの BizTalk メッセージ管理データベースの変更」を参照してください。

関連項目

サーバーの BizTalk メッセージ管理データベースの変更


BizTalk メッセージ管理データベース間でのサーバーの移動

BizTalk Server をある中央 BizTalk メッセージ管理データベースから別のメッセージ管理データベースに一時的に移動する場合、ほかの BizTalk Server を少なくとも 1 つ、元の中央データベース内のサーバー グループの 1 つに残す必要があります。これにより、その BizTalk Server を元の中央データベースに簡単に復元することができます。BizTalk Server を残さないと、中央データベースに新しい BizTalk Server を追加するには、BizTalk Server データベース セットアップ ウィザードを実行して、[BizTalk メッセージ管理データベースを構成します] ページで既存のデータベースを選択する必要があります。サーバーの BizTalk メッセージ管理データベースの追加または変更の詳細については、「サーバーの BizTalk メッセージ管理データベースの変更」を参照してください。

関連項目

サーバーの BizTalk メッセージ管理データベースの変更

グループとサーバー


BizTalk メッセージ管理データベース間でのリモート サーバーの移動

BizTalk メッセージ管理データベースにリモート サーバーを追加するとき、そのサーバーが既に別の中央 BizTalk メッセージ管理データベースに属していた場合、Windows イベント ログに次のエラー メッセージが表示されます。

WMI クラスの新しいインスタンス "MicrosoftBizTalkServer_Server" を BizTalk Server WMI プロバイダで作成できません :サーバー <サーバー名> が別の BizTalk Server インストールに属している可能性があります。

このエラーは、もともと別のデータベースに属していたリモート サーバーを追加しようとしたことを示します。BizTalk Server 管理コンソールでこの手順が実行された場合、管理コンソールはそのリモート サーバーがリモート データベースのグループにも属しているかどうかを判断しようとします。管理コンソールはリモート サーバーの Windows Management Instrumentation (WMI) プロバイダに問い合わせ、これを判断します。サーバーが別の中央データベースのサーバー グループに属している場合、既に別の中央データベースのグループに属しているリモート サーバーは追加できないことを示す管理コンソールからのエラー メッセージが表示されます。

関連項目

リモート サーバーを別の BizTalk メッセージ管理データベースに移動するとエラーが発生する

WMI の概要


BizTalk サーバー グループ データベースの管理

各サーバー グループは、共有キュー データベースと追跡データベースの 2 つのデータベースを使用します。共有キュー データベースは、処理と送信のために BizTalk Server 2000 に送信されるすべてのドキュメントとインターチェンジを保持します。追跡データベースは、監査、調整、および問題解決のために、受信インターチェンジと送信インターチェンジを追跡し、格納します。

サーバーとグループの論理構成を整理するために、各サーバー グループと関連付けられた共有キュー データベースと追跡データベースに一意な名前を付けることが重要です。たとえば、Group1 と Group2 という 2 つのサーバー グループがある場合は、最初のグループのデータベースに、SharedQueue1 と Tracking1 という名前を付け、2 番目のグループのデータベースに SharedQueue2 と Tracking2 という名前を付けます。

注

  • BizTalk メッセージ管理データベースは、共有キュー データベースおよび追跡データベースとは異なるデータベースです。このデータベースは、複数のグループおよびサーバーの構成に関する情報と BizTalk メッセージ サービスの構成に関する情報を格納するために使用します。ドキュメントとインターチェンジの送信を処理したり、ドキュメントとインターチェンジの利用状況を追跡することはありません。

ここには次のトピックが含まれます。

  • 共有キュー データベース

  • 追跡データベース


共有キュー データベース

  • サーバー グループ内のすべてのサーバーは、単一の共有キュー データベースを共有します。グループ内のサーバーに送信されるすべてのドキュメントとインターチェンジは、BizTalk Server によって処理されるまで共有キュー データベースに格納されます。

  • 共有キュー データベースは BizTalk Server 管理コンソールでは一連のキューとして視覚的に表示され、BizTalk Server でのインターチェンジまたはドキュメントの処理状況に関する情報を提供してます。インターチェンジとドキュメントは、BizTalk Server に処理されている間、次のいずれかのキューにあります。
    • 作業キュー : 現在 BizTalk Server に処理されているインターチェンジとドキュメントの一覧。

    • 送信待キュー : BizTalk Server によって処理され、サービス時間帯に従って送信を待機しているインターチェンジとドキュメントの一覧。サービス時間帯の詳細については、「ServiceWindowInfo」を参照してください。

    • 再送信キュー : 再送信されるインターチェンジおよびドキュメントと、受信確認を待機している信頼できるメッセージの一覧。

    • 保留キュー : 解析エラー、シリアライズ エラー、送信エラー、またはチャネル構成の間違いなど、さまざまな理由で処理が失敗したインターチェンジとドキュメントの一覧。

関連項目

サーバー グループの接続のプロパティの構成

グループとサーバー

ServiceWindowInfo

キューの管理

キューの使用


追跡データベース

サーバー グループ内のすべてのサーバーは単一の追跡データベースを共有します。追跡データベースは、BizTalk Server でのインターチェンジとドキュメントの利用状況に関連するすべての情報を格納します。追跡データベースは、サーバーを経由するインターチェンジまたはドキュメントのステータスを追跡するために使用します。たとえば、注文が取引先に送信されたかどうかを確認する場合、追跡データベースに対してクエリを実行します。このデータベースは、インターチェンジとドキュメントが BizTalk Server によって正しく送受信されたことを確認するために使用したり、送信時間または受信応答などのレポート情報を得るために使用することができます。

追跡データベースのドキュメント トラッキング パラメータとログ パラメータの定義

BizTalk Server 管理コンソールでは、インターチェンジおよびドキュメントを追跡するかどうかを選択することができます。サーバー グループの追跡設定を構成する方法の詳細については、「サーバー グループの追跡のプロパティの構成」を参照してください。追跡を有効にする場合、次のオプションを利用できます。

  • [受信インターチェンジを記録する] : この設定は、BizTalk Server によって受信されるドキュメントを追跡データベースに格納することを指定します。格納された受信ドキュメントは、問題解決のために利用状況の記録を提供します。このチェック ボックスは既定でオンになっています。

  • [送信インターチェンジを記録する] : この設定は、BizTalk Server によって送信されるドキュメントを追跡データベースに格納することを指定します。このチェック ボックスは既定でオンになっています。

  • [元の MIME エンコード メッセージを記録する] : この設定は、MIME エンコード ドキュメントをデコードされる前の元のメッセージ書式で追跡データベースに格納することを指定します。このチェック ボックスは既定でオフになっています。

関連項目

サーバー グループの接続のプロパティの構成

サーバー グループの追跡のプロパティの構成

グループ内のサーバーの起動

グループ内のサーバーの停止

BizTalk ドキュメント トラッキングの使用


グループとサーバー

多数のドキュメントの処理をサポートするデータ交換環境では、複数のサーバーおよびデータベースが必要になることがあります。企業には、ドキュメントの交換を集中化し、管理するための方法が必要です。

Microsoft BizTalk Server 2000 は、サーバーをグループに分け、BizTalk Server 管理コンソールを使用してこれらのサーバー グループを管理および構成することによって、ドキュメントの交換を集中化します。

ここには次のトピックが含まれます。

  • BizTalk サーバー グループ

  • グループとサーバーの関係

  • グループ ステータス

  • BizTalk サーバー


BizTalk サーバー グループ

サーバー グループは BizTalk Server 管理コンソールの主要な構成要素です。サーバー グループとは、集中的に管理、構成、および監視されるサーバーの集合です。

BizTalk サーバー グループ内のサーバーは、次のものを共有しています。

  • 正常に処理されるまですべてのドキュメントを保存する共有キュー データベース

  • ドキュメントとインターチェンジの利用状況をログに記録し、レポートを作成するために使用する追跡データベース

  • 受信機能

  • トランスポート コンポーネント、アプリケーション統合コンポーネント (AIC) など、サーバーがドキュメントとインターチェンジの処理時に要求するすべてのコンポーネント

中央 BizTalk メッセージ管理データベースは複数のグループおよびサーバーを管理します。このため、グループとサーバーは同じ構成情報を共有しています。この構成情報は、サーバーのドキュメント処理定義を指定します。管理コンソールから各サーバーとグループをリモートで管理できるように、各サーバー環境に対して同じ BizTalk メッセージ管理データベースを指定します。また、スケーラビリティとより良いパフォーマンスのために複数のサーバー グループを設定する場合は、中央 BizTalk メッセージ管理データベースを 1 つだけ使用します。複数のメッセージ管理データベースを使用すると、サーバーは同じ BizTalk メッセージ管理構成を共有することができません。

関連項目

サーバー グループの追加、削除、および構成

BizTalk サーバー

受信機能

グループとサーバーの関係

キューの使用


グループとサーバーの関係

BizTalk Server 2000 の各環境には、少なくとも 1 つのサーバー グループが必要です。グループとサーバーの関係を次に定義します。

  • 個々のサーバーは 1 つのサーバー グループにだけ属することができます。

  • グループ内のすべてのサーバーは、同じ共有キューと受信機能を使用します。

  • グループ内のすべてのサーバーは、トランスポート コンポーネントやアプリケーション統合コンポーネント (AIC) などのコンポーネントを共有して、インターチェンジとドキュメントを処理します。

次の図は、BizTalk Server 2000 のサーバー グループ間の関係を示しています。サーバー 1 ～ 6 には Microsoft BizTalk Server 2000 がインストールされています。サーバー A ～ D には Microsoft SQL Server がインストールされ、データベース管理専用に使用されます。サーバー A ～ D は追跡データベースまたは共有キュー データベースのいずれか専用に使用されますが、BizTalk メッセージ管理データベースは、比較的小さく、プロセッサにあまり負担をかけないため、いずれかのサーバーに格納することができます。共有キュー データベースと追跡データベースは別のデータベース管理専用サーバーに格納し、すべてのサーバー グループには単一の中央 BizTalk メッセージ管理データベースを使用することを強くお勧めします。

グループとサーバーの論理構成

グループ 2
グループ 1
追跡
データベース
サーバー C
追跡
データベース
サーバー A

共有キュー
データベース
サーバー D

共有キュー
データベース
サーバー B
BizTalk Server 3
BizTalk Server 2
BizTalk Server 6
BizTalk Server 5
BizTalk Server 4
BizTalk Server 1
BizTalk メッセージ管理データベース サーバー A

関連項目

BizTalk Server データベースの管理


グループ ステータス

BizTalk Server 管理コンソールは、サーバー グループを列挙し、各グループが追跡データベースと共有キュー データベースの両方またはどちらか一方に接続できるかどうかを指定します。[Microsoft BizTalk Server 2000] をクリックすると、詳細ペインにグループ ステータスが表示されます。グループ ステータスは次のいずれかになります。

  • [接続済み] : グループが追跡データベースと共有キュー データベースに接続されていることを示します。

  • [追跡への接続に失敗しました] : グループが追跡データベースに接続されていないことを示します。

  • [共有キューへの接続に失敗しました] : グループが共有キュー データベースに接続されていないことを示します。

  • [追跡と共有キューへの接続に失敗しました] : グループが追跡データベースと共有キュー データベースに接続されていないことを示します。


BizTalk サーバー

サーバー グループ内のサーバーは、データの変換、暗号化、デジタル署名、およびドキュメント トラッキングなどの適切な BizTalk メッセージ サービス機能を提供して、BizTalk サーバー グループの外部にあるほかのサーバーとアプリケーション間でのドキュメント交換を管理します。各サーバーは、ドキュメントを変換、シリアライズ、署名、暗号化、解読、およびトランスポートするために適切なコンポーネント オブジェクト モデル (COM) を呼び出して、共有キュー データベースに対して受信ドキュメントと送信ドキュメントをキューに入れたり、キューから取り出したりします。BizTalk Server COM インターフェイスを使用しないアプリケーションでは、BizTalk Server 2000 は受信機能を使用してデータを受信します。

必要に応じて、グループ内のすべてのサーバーをまったく同じに構成することができます。これにより、グループ内のサーバーを簡単に追加および削除することができます。また、グループ内の一部のサーバーをドキュメントの受信専用に構成することもできます。

ここには次のトピックが含まれます。

  • サーバーのプロパティについて

  • サーバー ステータス

関連項目

BizTalk サーバー グループ

グループとサーバーの関係


サーバーのプロパティについて

グループ内のサーバーを構成する場合、スループットとサーバー パフォーマンスを最大化できるよう調整する必要があります。サーバーのプロパティの構成に影響を与える要素には、業務上のニーズ、サーバーの容量、ネットワーク帯域幅などがあります。インストール環境に最も適する構成を決定するために、運用環境をシミュレートするテスト設定でさまざまな構成を試すことを強くお勧めします。

使用可能な受信機能スレッドの最大数

受信機能スレッドの最大数はプロセッサごとに設定します。このオプションの範囲は 1 から 128 です。この数値を調整して、サーバーで実行する受信機能のパフォーマンスを最適化します。ほとんどの場合、受信機能スレッドの数を増加させると、サーバーの受信機能のスループットが向上します。

作業項目の処理に参加する

[作業項目の処理に参加する] チェック ボックスがオンになっていると、サーバーは作業キュー内のドキュメントを処理します。このチェック ボックスをオフにすると、サーバーは作業キュー内のドキュメントを処理しません。このチェック ボックスをオフにする状況が 2 つあります。第 1 の状況は、メッセージ キューからメッセージを受信する場合です。現在、メッセージ キューはローカル トランザクションの読み取りだけをサポートしています。つまり、キューは Microsoft BizTalk Server 2000 がインストールされたサーバー上に存在している必要があり、これらのキューから読み取るためにグループ内の 1 つのサーバーだけを構成することができます。メッセージ キューがあるサーバーでできる限り早く受信できるようにするには、[作業項目の処理に参加する] チェック ボックスをオフにします。

このチェック ボックスをオフにする第 2 の状況は、BizTalk Server クラスタのパフォーマンスを最大にする場合です。たとえば、BizTalk Server グループ内の 1 つのサーバーを管理作業専用にする場合です。

プロセッサごとの使用可能な作業スレッドの最大数

作業スレッドの最大数はプロセッサごとに設定します。このオプションの範囲は 1 から 128 です。小さい値を設定すると、トラフィックの多い状況では、BizTalk Server に障害が発生することがあります。高い値を設定すると、有害な影響は生じませんが、パフォーマンスが低下することがあります。

[プロセッサごとの使用可能な作業スレッドの最大数] と [BizTalk Server スケジューラ呼び出し間隔] は、Microsoft SQL Server データベースへのトラフィック量に影響を与える要素です。[プロセッサごとの使用可能な作業スレッドの最大数] を小さい値に設定し、[BizTalk Server スケジューラ呼び出し間隔] を大きい値に設定することによって、SQL データベースへのトラフィックを制限することができます。同様に、作業スレッドの最大数を大きくして、スケジューラ呼び出し間隔の設定を小さくすることによって、データベースへのトラフィックを増加させることができます。

注

  • このサーバーで作業項目を処理しない場合は、[作業項目の処理に参加する] チェック ボックスをオフにします。[プロセッサごとの使用可能な作業スレッドの最大数] オプションを 0 に設定しないでください。

BizTalk Server スケジューラ呼び出し間隔 (ミリ秒)

[BizTalk Server スケジューラ呼び出し間隔] の範囲は、1 から 4,294,967,295 です。作業キュー内の利用可能な項目をポーリングするスレッドが存在します。[BizTalk Server スケジューラ呼び出し間隔] は、そのスレッドが作業キューをポーリングする頻度を制御します。大量のデータを受信しない場合は、この値を大きくします。大量のデータを受信する場合は、この値を小さくする必要が生じることがあります。

関連項目

グループ内のサーバーの構成


サーバー ステータス

BizTalk Server 管理コンソールは、サーバー グループ内のサーバーを列挙し、サーバーの一覧を返します。BizTalk Server 管理コンソールは、詳細ペインに次のサーバー ステータスを返します。

  • [実行中] : サーバーが実行中であることを示します。

  • [アクセスは拒否されました] : サーバーの Windows 2000 管理者特権がないことを示します。

  • [エラー] : サーバー グループに登録されたサーバーで BizTalk Server 2000 が削除されていることを示します。

  • [停止] : 管理者がサーバーを停止したことを示します。

  • [不明] : サーバー グループに登録されたサーバーが不明な理由で利用できないことを示します。この場合、サーバーとの接続が失われている可能性があります。

関連項目

管理者特権


サーバー エラーの処理

BizTalk Server 管理コンソールに含まれている Windows 2000 イベント ビューアを使用して、サーバー レベルで BizTalk Server 2000 のエラー処理を構成することができます。Windows 2000 イベント ビューアは、管理コンソールのコンソール ツリーに表示されます。

イベントのログ

Windows 2000 イベント ビューアは、ハードウェア、ソフトウェア、およびシステムの問題に関する情報を含むログを作成します。管理コンソールからイベント ビューアをカスタマイズして、BizTalk Server 2000 に固有なアプリケーションと XLANG スケジューラのエラーを表示することができます。これにより、BizTalk Server のトラブルシューティングを効率的に行えます。BizTalk Server エラーと XLANG スケジューラ エラー用にイベント ビューアをカスタマイズする方法の詳細については、「イベント ビューアの管理」を参照してください。

イベント ビューアの詳細については、Windows 2000 Server ヘルプの「イベント ビューアを使う」を参照してください。

注

  • BizTalk Server 2000 に関連するすべてのアプリケーション エラーは、BizTalk Server エラーまたは XLANG スケジューラ エラーとして定義されます。

関連項目

イベント ビューアの管理


受信機能

受信場所からドキュメントを受信し、BizTalk Server に送信する必要がある場合、プログラムによって送信呼び出しを構成することができます。送信呼び出しの詳細については、「送信」または「Submit」を参照してください。または、データを処理するために受信機能を構成することができます。たとえば、COM インターフェイスを経由して BizTalk Server と直接通信することができない組織またはアプリケーションからドキュメントを受信する必要がある場合、受信機能を使用してインターチェンジとドキュメントを BizTalk Server に送信することができます。または、メッセージ キューから受信する必要がある場合、受信機能を使用してドキュメントを BizTalk Server に送信することができます。BizTalk Server 2000 は、ファイルとメッセージ キューの 2 種類の受信機能をサポートしています。

管理コンソールで BizTalk Server 2000 の汎用受信機能を作成し、その受信機能の名前やドキュメント定義などを定義することができます。受信機能の構成の詳細については、「サーバー グループの受信機能の管理」を参照してください。受信機能の詳細プロパティの詳細については、「受信機能の詳細プロパティについて」を参照してください。

次の図は、送信側業務用アプリケーション、ファイル システム、および BizTalk Server の汎用受信機能間の相関関係を示しています。

送信側業務用アプリケーション
ファイル システム
BizTalk Server
ファイル受信機能
BizTalk
Server
送信

ここには次のトピックが含まれます。

  • 利用可能な受信機能

  • カスタム プリプロセッサ

  • 受信機能の複数のインスタンス

  • 受信機能とドキュメント ルーティングについて

  • 受信機能の詳細プロパティについて


利用可能な受信機能

BizTalk Server では、ファイルとメッセージ キューの 2 種類の受信機能を利用できます。業務の習慣によって、使用する受信機能の種類と時期を決定します。

ファイル受信機能

ファイル受信機能は、受信機能が監視するディレクトリに利用状況がある場合にアクティブになります。ファイル受信機能を使用するには、そのディレクトリを変更できる必要があります。ファイル受信機能は、そのディレクトリからファイルを削除し、BizTalk Server 2000 に送信します。

メッセージ キュー受信機能

メッセージ キュー受信機能は、メッセージ キュー内の利用状況に基づいてアクティブになります。この受信機能は、キューからインターチェンジまたはドキュメントを抽出し、BizTalk Server 2000 に送信します。

メッセージ キューのポーリング場所を定義する場合、パス名の代わりに書式名を使用します。BizTalk Server はストレートにメッセージ キュー アプリケーション プログラミング インターフェイス (API) と共に動作するよう設計されており、API 呼び出しは書式名でのみ動作します。メッセージ キュー受信機能を構成する場合、次の書式名を使用します。

  • Direct=OS:<サーバー名>\<キュー名>

注

  • メッセージ キューと書式名の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」、「Getting Started」、「Contents of the Platform SDK」を順に展開し、「Message Queuing Services (MSMQ)」を参照してください。


カスタム プリプロセッサ

BizTalk Server に送信する前に処理する必要があるドキュメントがある場合、カスタム プリプロセッサを作成し、受信機能を構成して、そのプリプロセッサを呼び出すことができます。たとえば、圧縮データを送信し、BizTalk Server に送信する前に圧縮解凍する必要がある場合、カスタム プリプロセッサを呼び出すよう受信機能を構成して、データを圧縮解凍します。

関連項目

プリプロセッサの一覧にクラス識別子が表示される

IBTSCustomProcess

受信機能でのドキュメントの前処理


受信機能の複数のインスタンス

受信機能の複数のインスタンスが存在することがあります。たとえば、BizTalk Server 2000 にドキュメントおよびインターチェンジを送信するために複数の業務用アプリケーションがファイル受信機能を使用する場合、ファイル受信機能の単一のインスタンスまたは複数のインスタンスのいずれかを構成することができます。

注

  • 作成する各受信機能に一意な名前が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

関連項目

サーバー グループの受信機能の管理


受信機能とドキュメント ルーティングについて

受信機能を構成する場合、その受信機能によって受信されるドキュメントがセルフルーティングまたは非セルフルーティングのいずれであるかを決定します。セルフルーティング ドキュメントには必要なすべてのルーティング情報が含まれ、非セルフルーティング ドキュメントには、ルーティング情報の一部またはすべてが不足しています。

セルフルーティング ドキュメント

セルフルーティング ドキュメントには、送信元組織の識別子、送信先組織の識別子、およびドキュメント定義などのすべてのルーティング情報が含まれます。ルーティング情報は、ANSI X12 と EDIFACT の場合と同様に、ドキュメント仕様よって定義されるルーティング タグ、またはドキュメント内にハードコードされるルーティング タグで定義されます。BizTalk エディタで仕様を作成できるすべてのドキュメントは、セルフルーティング ドキュメントとして構成することができます。セルフルーティング ドキュメントの一般的な種類は、XML、ANSI X12、および EDIFACT です。ドキュメントがセルフルーティングの場合、ドキュメントで提供されているデータを上書きする場合を除き、受信機能で詳細プロパティを構成する必要はありません。

送信元組織の修飾子、送信先組織の修飾子、またはドキュメント定義がドキュメントに含まれていない場合、そのドキュメントは保留キューに配置されます。また、送信元組織または送信先組織の修飾子を指定しない場合、BizTalk Server は組織の修飾子として組織名の既定値を使用し、BizTalk メッセージ管理データベースに格納されている組織の名前を参照します。

非セルフルーティング ドキュメント

非セルフルーティング ドキュメントには、必要なルーティング情報のすべてまたは一部が不足しています。受信機能を構成する場合、受信機能のプロパティ ダイアログ ボックスの [詳細設定] タブまたは受信機能に提供するドキュメントで、次の情報を定義する必要があります。

  • 送信元組織識別子、送信先組織識別子、およびドキュメント定義

または

  • チャネル

ドキュメントを送信するときに、BizTalk Server はドキュメントを処理するためのチャネルを検出します。これは、受信機能でチャネル名を指定するか、送信元組織識別子、送信先組織識別子、およびドキュメント定義を指定する、2 つの方法で行うことができます。これらの 3 つのプロパティは、BizTalk Server が正しいチャネルを検出するために使用されます。したがって、チャネルを選択する場合は、そのチャネルがドキュメントをルーティングするために必要なすべての情報を提供するため、ドキュメント定義、送信元の情報、および送信先の情報のオプションは利用できません。

非セルフルーティング ドキュメントの一般的な種類は、複数の送信元 (オープンな送信元) から受信するドキュメントまたは複数の送信先 (オープンな送信先) に送信するドキュメントです。

複数の送信元からのドキュメントを管理するための受信機能の構成

非セルフルーティング ドキュメントを処理する単一の受信機能を構成して、複数の送信元から特定の種類のドキュメントを受信することができます。これはオープンな送信元のシナリオです。送信元組織、送信先組織、およびドキュメント定義情報の場所は、ドキュメント内で指定するか、またはドキュメントと共に送信するパラメータで指定する必要があります。たとえば、複数の顧客から購入注文を受信する予定があり、すべてを同じ送信先アプリケーションに送信する場合、受信機能でドキュメント定義と送信先組織識別子のプロパティを設定します。BizTalk Server は、ドキュメントを解析する場合、サプライヤの組織識別子を検出し、この情報を受信機能のパラメータと組み合わせて、正しいチャネルを見つけてから、ドキュメントを処理します。

関連項目

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

サーバー グループの受信機能の管理

送信元組織のプロパティの設定


受信機能の詳細プロパティについて

詳細プロパティを使用して、業務の習慣に基づいて特別な種類の受信機能を構成することができます。

たとえば、次のドキュメントを送信する受信機能を定義することができます。

  • [オープンな送信元] プロパティまたは [オープンな送信先] プロパティが設定されているドキュメント

  • [パススルー] プロパティが設定されているドキュメント

  • チャネル名を指定するドキュメント

  • その他の種類の非セルフルーティング ドキュメント

ドキュメントでのオープンネス プロパティの定義

次のオプションはドキュメントのオープンネスを定義します。

  • [開いていません] : 送信元と送信先の両方が受信機能またはドキュメント インスタンスで明示的に宣言されていることを指定します。

  • [オープンな送信先] : 送信先情報がメッセージ ポートで明示的に宣言されていないことを指定します。送信先はドキュメント インスタンスまたは送信パラメータで動的に指定します。BizTalk Server が正しいチャネルを検出するためには、受信機能またはドキュメント インスタンスでドキュメント定義と送信元組織識別子のプロパティを構成する必要があります。

  • [オープンな送信元] : 送信元情報がチャネルで明示的に定義されていないことを指定します。送信元はドキュメント インスタンスで動的に指定します。BizTalk Server が正しいチャネルを検出するためには、受信機能またはドキュメント インスタンスでドキュメント定義と送信先組織識別子のプロパティを構成する必要があります。

パススルーを使用する受信機能の構成

パススルーを使用するよう構成された受信機能は、BizTalk Server の解析、暗号解読、署名検証、変換、およびデコードの機能をバイパスします。Binary Large Object データまたは解析、暗号解読、およびデコードを要求しないその他のインターチェンジを送信する場合は、このオプションを選択します。[パススルー フラグを付けて送信する] チェック ボックスをオンにして受信機能を構成する場合は、チャネルを指定する必要があります。チャネルを指定しなければ、BizTalk Server はドキュメントを処理できません。

エンベロープ名

フラット ファイルで受信インターチェンジを受信する場合、受信機能でエンベロープ書式を指定します。エンベロープは、インターチェンジを開き、解釈する方法を BizTalk Server に指示する仕様を示します。単一のインターチェンジで複数のフラット ファイルを受信する場合、個々のフラット ファイルを接尾辞または接頭辞である区切り記号で区切る必要があります。挿入辞はサポートされていません。これは、解析プロパティを構成するときに、エンベロープ仕様およびドキュメント仕様のルート ノードで設定する必要があります。フラット ファイルの解析のプロパティを設定する方法の詳細については、「解析のプロパティの設定」の表 "標準 : [カスタム]、"構造" プロパティ : [区切り記号]" を参照してください。

チャネル名

BizTalk Server に送信される各インターチェンジまたはドキュメントは、その処理方法に関する一連の規則を要求します。チャネルには、サーバーがインターチェンジまたはドキュメントを処理するために必要なすべての情報が含まれています。BizTalk Server によって処理されるすべてのインターチェンジとドキュメントは、チャネルを経由する必要があります。チャネルは次のいずれかの方法で検出されます。第 1 の方法では、インターチェンジまたはドキュメントを送信したときに、BizTalk Server はそのドキュメントを解析して、送信元識別子、送信先識別子、およびドキュメント定義を調べます。この情報がドキュメント インスタンスにない場合、BizTalk Server は受信機能を参照します。送信元識別子、送信先識別子、およびドキュメント定義が発見されると、BizTalk Server は受信ドキュメントと同じドキュメント定義、送信元識別子、および送信先識別子を持つチャネルを決定します。一致するチャネルが見つかると、そのドキュメント インスタンスが処理されます。

チャネルを検出する第 2 の方法では、受信機能でチャネルが指定されます。この場合、チャネルの検索がバイパスされ、受信ドキュメントの処理が早くなります。

ドキュメント定義、送信元組織識別子、および送信先組織識別子

非セルフルーティング ドキュメントを受信する場合、ドキュメント定義、送信元組織識別子、および送信先組織識別子のすべてまたは一部を構成することができます。受信したドキュメントに含まれているルーティング情報によって、どのプロパティを受信機能で定義するかが決まります。たとえば、同じ送信元組織から複数の種類のドキュメントを受信し、常にこれらのドキュメントを同じ送信先に送信する場合、受信機能で送信元組織識別子と送信先組織識別子を構成し、ドキュメント インスタンスでドキュメント定義を動的に定義することができます。

関連項目

エンベロープの作成

エンベロープ情報のプロパティの設定

解析のプロパティの設定

チャネルについて

ドキュメント定義について

エンベロープについて

組織について

受信機能とドキュメント ルーティングについて

受信処理のためのエンベロープの使用


キューの使用

Microsoft BizTalk Server 2000 は、BizTalk Server 管理コンソールで共有キュー管理機能を提供します。BizTalk Server Administrators は、任意のキューから保留キューにドキュメントを移動することができます。ドキュメントの処理状態によって、ドキュメントを保留キューから削除、再送信、または表示することができます。BizTalk Server Administrators は、保留キュー内のドキュメントのエラー メッセージを並べ替えて、表示することができます。

次のキューは、BizTalk Server でさまざまなルーティング段階と処理段階にある受信ドキュメントおよび送信ドキュメントを格納するために使用します。

  • 作業キュー

  • 送信待キュー

  • 再送信キュー

  • 保留キュー

注

  • インターチェンジとドキュメントは "先入れ先出し" の順序で BizTalk Server 管理コンソールに表示されます。つまり、キューの最も古い項目が先頭に表示され、最新の項目は最後に表示されます。また、一度に最大 15,000 のインターチェンジとドキュメントが表示されます。15,000 を超える実際の項目がキューにある場合、新しい項目を表示できるように、キューの現在の項目を削除または再送信する必要があります。コンソール ツリーのキュー数 (キューの横にあるかっこ内の数) は、キューに存在する実際の項目数を表します。ドキュメントを再送信または削除して、キューから項目を削除することができます。

関連項目

キューの管理


作業キュー

作業キューには、現在 BizTalk Server によって処理されているドキュメントが格納されます。作業キューのトランザクションは、到着時に処理されるため、長い間キューに残ることはありません。BizTalk Server Administrators は、このキューにあるドキュメントを選択し、それを保留キューに移動することができます。

関連項目

保留キューへのドキュメントの移動

キューの使用


送信待キュー

送信待キューには、BizTalk Server によって処理され、サービス時間帯に基づいて送信を待機している作業項目が含まれます。BizTalk Server Administrators は、このキューにあるドキュメントを選択し、それを保留キューに移動することができます。サービス時間帯の詳細については、「BizTalkServiceWindowInfo インターフェイス」を参照してください。

関連項目

保留キューへのドキュメントの移動

BizTalkServiceWindowInfo インターフェイス

キューの使用


再送信キュー

再送信キューには、配信のために再送信されるドキュメントと信頼できるメッセージの受信機能を待機しているドキュメントが含まれます。送信の種類を区別することはできません。既定では、失敗した送信は 5 分ごと最大 3 回再試行され、その後保留キューに移動されます。これらの数値は、BizTalk メッセージ マネージャまたはプログラムによって変更することができます。再試行回数の変更の詳細については、「詳細構成のプロパティの設定」、または「RetryCount」および「RetryInterval」を参照してください。

BizTalk Server Administrators は、このキューにあるドキュメントを選択し、それを保留キューに移動することができます。

関連項目

RetryCount

RetryInterval

保留キューへのドキュメントの移動

詳細構成のプロパティの設定

キューの使用


保留キュー

保留キューには、解析エラー、シリアライズ エラー、送信の失敗、またはチャネル構成を見つけられないことなど、さまざまな理由で処理が失敗した作業項目が含まれます。BizTalk Administrators は、このキューにあるドキュメントを右クリックして、次のいずれかのオプションを選択することができます。

  • [エラーの説明の表示] : BizTalk Administrators は、ドキュメントが保留キューに送信された理由を示すエラーの説明を表示することができます。

  • [インターチェンジの表示] : BizTalk Administrators は、解析エラーや送信の失敗などのさまざまな理由で処理が失敗したインターチェンジの内容を表示することができます。[インターチェンジの表示] には次のステータスが表示されます。
    • 初期

    • カスタム コンポーネント

    • 解析

    • エンコード

    • 署名

    • 暗号化

    • 送信
  • [ドキュメントの表示] : BizTalk Administrators は、シリアライズ エラーやチャネルを見つけられないなど、さまざまな理由で処理が失敗したドキュメントの内容を表示することができます。[ドキュメントの表示] には次のステータスが表示されます。
    • ドキュメントの検証

    • チャネルの選択

    • フィールドの追跡

    • マッピング

    • 関連付けています

    • シリアライズ
  • [削除] : BizTalk Administrators は、保留キューからエントリを完全に削除することができます。この操作は回復できません。ドキュメントを保留キューから削除した後に、そのドキュメントを取得することはできません。

  • [再送信] : BizTalk Administrators は、BizTalk Server にインターチェンジとドキュメントを再送信することができます。

保留キューのステータス

インターチェンジとドキュメントはさまざまな理由で保留キューに配置されます。次の表は、保留キューのステータス、それに関連するエラー メッセージ、および解決策として実行できる操作を示しています。

保留キューのステータス値 | エラー メッセージ | エラーの説明と操作例
[チャネルの選択] または [送信] | 予期しないエラー | 予期しない内部サーバー エラーが発生しました。 ドキュメントを再送信します。
[チャネルの選択] または [送信] | 不明 | そのインターチェンジまたはドキュメントは、アクティブでないサーバーのよる "処理中" であるとマークされました。サーバーの再起動時に、この項目は自動的に保留キューに移動されました。処理元のサーバーでエラーが発生した可能性があります。詳細については、システム管理者に問い合わせてください。 問題を修正してから、ドキュメントまたはインターチェンジを再送信します。
[チャネルの選択] または [送信] | メモリ不足 | BizTalk Server を実行しているコンピュータのメモリが不足しています。 サーバーを再起動し、保留キュー内のすべてのインターチェンジとドキュメントを再送信します。
[解析] | 解析の失敗 | BizTalk Server はデータを解析できませんでした。 インターチェンジの内容を表示して、BizTalk Server が解析できなかった理由を調べます。IInterchange または受信機能を使用して、そのインターチェンジを再送信します。詳細については、「インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される」または「解析エラー」を参照してください。
[解析] | データ不足 | 受信データから抽出した情報には、チャネルの場所を特定するための情報が十分に含まれていませんでした。 インターチェンジを表示し、不足しているデータを見つけます。IInterchange または受信機能を使用して、そのインターチェンジを再送信します。詳細については、「インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される」または「解析エラー」を参照してください。
[解析] | タイムスタンプの有効期限切れ | BizTalk フレームワーク タイムスタンプ "expiresAt" による有効期限が切れました。このドキュメントはもう有効ではありません。詳細については、「インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される」を参照してください。
[チャネルの選択] | チャネルが見つかりません | BizTalk Server は、このドキュメントに一致するチャネルを発見できませんでした。 そのドキュメント用のチャネルを作成するか、ドキュメントを修正してから再送信します。
[チャネルの選択] | チャネルは削除されました。 | このドキュメントに関連付けられているチャネルは、ドキュメントが作業キューに到達した後に削除されました。 チャネルを再構成するか、別のチャネル用にドキュメントを構成してから再送信します。 または ドキュメントを送信せず、保留キューからそのドキュメントを削除します。
[チャネルの選択] | チャネルが見つかりません | 受信機能または送信呼び出しによって指定されたチャネルが見つかりませんでした。チャネルを構成するか、ドキュメントを再構成してから、再送信します。
[チャネルの選択] | 無効なチャネル | 送信呼び出しによって指定されたチャネルは、オープン チャネルでした。オープン チャネルは、パススルー送信呼び出しには使用できません。 チャネルを変更して、ドキュメントを再送信します。
[マッピング] | マップの失敗 | チャネルが参照しているマップの形式が正しくありません。 保留キューからそのドキュメントを削除し、マップを修正して、新しいドキュメントとしてドキュメントを送信します。
[シリアライズ] | シリアライズの失敗 | BizTalk Server は、このドキュメントをネイティブ形式に変換できませんでした。ドキュメントを再送信します。
[エンコード] | エンコードの失敗 | BizTalk Server は、このインターチェンジをエンコードできませんでした。 インターチェンジを再送信します。
[署名] | 署名の失敗 | BizTalk Server は、このインターチェンジに署名できませんでした。 証明書の有効期限が切れている可能性があります。詳細については、Microsoft 管理コンソールの証明書スナップインを参照してください。証明書スナップインを表示する方法の詳細については、Windows 2000 ヘルプの「証明書を管理する」の下にある「証明書スナップインを MMC コンソールに追加する」を参照してください。
[暗号化] | 暗号化の失敗 | BizTalk Server は、このインターチェンジを暗号化できませんでした。 証明書の有効期限が切れている可能性があります。詳細については、Microsoft 管理コンソールの証明書スナップインを参照してください。証明書スナップインを表示する方法の詳細については、Windows 2000 ヘルプの「証明書を管理する」の下にある「証明書スナップインを MMC コンソールに追加する」を参照してください。
[送信] | 送信の失敗 | BizTalk Server は、このインターチェンジを配信できませんでした。 チャネルのトランスポート アドレスを確認します。問題を修正し、インターチェンジを再送信します。
[送信] | タイムアウトによる失敗 | BizTalk Server は、このインターチェンジの処理をタイムアウト前に完了できませんでした。送信に時間がかかりすぎたことが考えられます。 信頼性の低い送信手段を利用している場合は、再送信の前に、このインターチェンジの送信が完了していないかどうかを確認してください。
[送信] | ユーザーの移動 | BizTalk Server Administrator はこのドキュメントを保留キューに移動しました インターチェンジを再送信します。
[送信] | タイムスタンプの有効期限切れ | BizTalk フレーム タイムスタンプ "receiptRequiredBy" の有効期限が切れました。このドキュメントはもう有効ではありません。
[ドキュメントの検証] | 無効なドキュメント | 仕様に対するこのドキュメントの検証が失敗しました。 詳細については、イベント ログでそのエラーを参照してください。スキーマを修正し、ドキュメントを再送信します。
[フィールドの追跡] | フィールドの追跡の失敗 | BizTalk Server は、ドキュメント内にある要求されたフィールドを追跡できませんでした。 ドキュメントを表示して追跡するフィールドが存在していることを確認するか、フィールドの追跡に関するチャネルの構成を変更します。次に、ドキュメントを再送信します。
[カスタム コンポーネント] | カスタム コンポーネントの実行失敗 | カスタム コンポーネントの実行に失敗しました。 カスタム コンポーネントまたはカスタム プリプロセッサのトラブルシューティングを行って、インターチェンジを送信します。
[関連付けています] | 関連付けの失敗 | この受信確認の関連付けに失敗しました。

注

  • 保留キューのエラー メッセージの確認に加えて、イベント ログで詳細を確認することもできます。イベント ログの詳細については、「イベント ビューアの管理」を参照してください。

  • 保留キューにあるすべてのドキュメントが再送信されるわけではありません。場合によっては、ドキュメントを削除してから、元のアプリケーションまたは組織から送信し直す必要があります。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

イベント ビューアの管理

キューの管理

解析エラー

受信機能とドキュメント ルーティングについて

受信機能の詳細プロパティについて

キューの使用


管理者特権

BizTalk Server 管理コンソールを表示するには、BizTalk Server Administrators グループのメンバである必要があります。BizTalk Server Administrator 以外のユーザーとしてログオンした場合、Microsoft BizTalk Server 2000 フォルダ内の項目を表示することができません。BizTalk Server Administrators グループのメンバであり、Microsoft Windows 2000 Administrators グループのメンバではない場合は、次の作業だけ行うことができます。

  • サーバー グループの追加と削除

  • グループのプロパティの表示と変更

  • すべてのキューとそのエントリの管理

  • 受信機能の追加と削除

  • 受信機能のプロパティの表示と変更

また、たとえば Server_1、Server_2、および Server_3 の 3 つのサーバーを含むサーバー グループを管理している場合、3 つすべてのサーバーで Windows 2000 の管理者特権が必要です。Windows 2000 管理者特権が Server_1 で変更された場合、管理者特権が失われ、管理コンソールはグループと関連付けられた 3 つのサーバーすべての一覧を返し、各サーバーのステータスを一覧表示します。Server_1 については "アクセスは拒否されました" というステータスが返されます。

BizTalk Server Administrators グループと Windows 2000 Administrators グループの両方のメンバである場合は、さらに次の作業を行うことができます。

  • サーバー グループへのサーバーの追加とサーバー グループからのサーバーの削除

  • サーバーのプロパティの表示と変更

  • サーバーのステータスの表示

  • サーバー上のインターチェンジの解放

BizTalk Server のインストールを実行しているユーザーは、セットアップ中に BizTalk Server Administrators グループに追加されます。ほかのユーザーを BizTalk Server Administrators グループに追加することもできます。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。


BizTalk Server 管理のトラブルシューティング

ここでは、BizTalk Server 管理のトラブルシューティングについて説明します。操作中にエラー メッセージが表示された場合、まずここで解決策を探してください。

このドキュメントがリリースされた後で明らかになった問題については、Microsoft BizTalk Server フォルダの下にあるリリース ノート (\Program Files\Microsoft BizTalk Server\Documentation\Readme.htm) に補足説明が入ります。

ここでは、次の問題について説明します。

  • データベースからすべてのグループを取得できない

  • インターチェンジとドキュメントのサイズ制限

  • コンポーネント サービスと BizTalk Server 2000 とのトランザクション タイムアウトの不一致

  • BizTalk メッセージ サービスが開始しない

  • 保留キューから大量のドキュメントを削除するとパフォーマンスが低下する

  • 出力の検証に失敗する

  • サーバーがフラット ファイル インターチェンジ内のすべてのドキュメントを返さない

  • プリプロセッサの一覧にクラス識別子が表示される

  • インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

  • BizTalk Server がドキュメントの処理を停止した

  • 受信機能でドキュメントが削除されない

  • クラスタ コンピュータにインストールされた SQL Server に接続できない

  • 受信機能がドキュメントの処理を停止した

  • リモート サーバーを別の BizTalk メッセージ管理データベースに移動するとエラーが発生する

  • 解析エラー

注

  • 保留キュー内のエラー メッセージを確認すると、トラブルシューティングの詳細がわかります。保留キュー、エラー メッセージ、およびエラー処理の詳細については、「保留キュー」を参照してください。

  • エラー メッセージや警告メッセージなどの詳細をイベント ログで確認することもできます。イベント ログの詳細については、「イベント ビューアの管理」を参照してください。


データベースからすべてのグループを取得できない

原因 : 次のメッセージが表示された場合、BizTalk メッセージ管理データベースがオフラインになっています。

Microsoft BizTalkServer_Group のインスタンスを列挙できません : BizTalk メッセージ管理データベースに接続できませんでした。

解決策 : サーバーがオフラインになっている原因を究明し、サーバーがオンラインになったら接続を再試行します。たとえば、BizTalk メッセージ管理データベースを格納しているサーバーがメンテナンスのためにオフラインになっている場合、このメッセージが表示されます。


インターチェンジとドキュメントのサイズ制限

BizTalk Server に送信できるドキュメントの最大サイズは 20 MB です。BizTalk Server に送信できるインターチェンジの最大サイズは 20 MB です。

20 MB を超える XML UNICODE 形式のインターチェンジを受信する場合は、グローバル追跡の設定をオフにしておくことをお勧めします。7 ～ 10 MB を超える ANSI フラット ファイル インターチェンジを受信する場合は、グローバル追跡の設定をオフにしておくことをお勧めします。サーバー グループの追跡の設定を構成する方法の詳細については、「サーバー グループの追跡プロパティの設定」を参照してください。

20 MB を超える XML UNICODE 形式のドキュメント インスタンスを受信する場合は、BizTalk メッセージ マネージャのドキュメント ログの設定をオフにしておくことをお勧めします。7 ～ 10 MB を超える ANSI フラット ファイルを受信する場合は、BizTalk メッセージ マネージャのドキュメント ログの設定をオフにしておくことをお勧めします。特定のドキュメント インスタンスのコピーを格納する方法については、「ドキュメント ログのプロパティの設定」を参照してください。

関連項目

サーバー グループの追跡のプロパティの構成

ドキュメント ログのプロパティの設定


コンポーネント サービスと BizTalk Server 2000 とのトランザクション タイムアウトの不一致

コンポーネント サービスと BizTalk Server 2000 との間にはファイル タイム アウトの不一致があります。BizTalk Server 2000 を使用して既定のトランザクション タイム アウト値である 60 秒を超えるファイルを送信すると、BizTalk Server 2000 はそのトランザクションを送信済みとして記録し、受信側のサーバーはエラーが発生することなくファイルを受信します。コンポーネント サービスはトランザクションを中断したものとして記録します。トランザクションはロールバックできません。


BizTalk メッセージ サービスが開始しない

原因 : BizTalk メッセージ管理データベースが格納されている SQL サーバーに BizTalk Server が接続できない場合、BizTalk メッセージ サービスは開始されません。すべての COM+ パッケージは、ローカル システム アカウントではなく対話型ユーザー アカウントで実行されます。ユーザーが BizTalk Server にログオンした場合にだけ、サービスが開始されます。たとえば、クライアント アプリケーションによってドキュメントが BizTalk Server にリモート送信されたが、BizTalk Server 2000 が実行されているサーバーにユーザーがログオンしていない場合、サービスは開始されません。

解決策 : BizTalk Server が BizTalk メッセージ管理データベースに接続されているかを確認します。Microsoft SQL Server が正しく実行されているかを確認します。BizTalk Server を実行するためのサービス アカウントを作成する必要がある場合があります。サービス アカウント作成の詳細については、Windows 2000 ヘルプの「サービスがログオン時に使うユーザー アカウントを選択するには」を参照してください。


保留キューから大量のドキュメントを削除するとパフォーマンスが低下する

原因 : 保留キューから大量のドキュメントを削除すると、パフォーマンスが低下することがあります。

解決策 : 保留キューからすべてのドキュメントを削除する必要がある場合、この目的のために提供されている Microsoft Visual Basic サンプル スクリプト、PurgeBizTalkSuspendedQueue.vbs を使用することができます。BizTalk Server 2000 をインストールすると、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous フォルダにこのスクリプトが格納されます。

注意

  • 特定の BizTalk Server グループの保留キューに含まれるすべての内容を永久に削除する場合以外は、このサンプル スクリプトを使用しないでください。


出力の検証に失敗する

原因 1 : 送信元仕様のフィールドのデータ型がリンク先となる送信先仕様のフィールドのデータ型と一致していません。このエラーはイベント ビューアに記録されます。

解決策 : 送信元仕様または送信先仕様のいずれかのデータ型を修正します。送信元仕様と送信先仕様の詳細については、「仕様の作成と検証」を参照してください。

原因 2 : Functoid が送信先仕様のフィールドにリンクされていて、フィールドのデータ型のプロパティが文字列ではありません。

解決策 : 送信先仕様のフィールドのデータ型を String に変更します。それから、処理するドキュメントを BizTalk Server に送信します。データ型の詳細については、「宣言のプロパティの設定」を参照してください。

原因 3 : 送信先仕様のフィールドに、そのフィールドに既に割り当てられているデータ型以外のデータ型の定数値が割り当てられています。

解決策 : 送信先仕様のフィールドに関連付けられたデータ型を変更します。それから、処理するドキュメントを BizTalk Server に送信します。データ型の詳細については、「宣言のプロパティの設定」を参照してください。

原因 4 : EDIFACT データにリリース インジケータが含まれています。フィールドの物理的な最大文字制限を検証する場合、論理文字数にリリース文字が含まれます。このエラーはイベント ビューアに記録されます。

解決策 : EDIFACT データにリリース インジケータを使用しないようにします。BizTalk Server が、必要なときに自動的にリリース インジケータを送信データに挿入します。

関連項目

仕様の作成と検証

宣言のプロパティの設定


サーバーがフラット ファイル インターチェンジ内のすべてのドキュメントを返さない

原因 : インターチェンジ内のいずれかのドキュメントがドキュメント仕様を満たしていません。たとえば、ドキュメントに必須入力フィールドがありません。

解決策 : 仕様を満たしていないドキュメントを修正し、インターチェンジを再送信します。エラーが返されるのは仕様を満たしていないドキュメントについてですが、BizTalk Server はインターチェンジ内のすべてのドキュメントを処理できません。フラット ファイル構造はオープンな書式で、冗長検査を実装するようには設計されていません。


プリプロセッサの一覧にクラス識別子が表示される

原因 : カスタム プリプロセッサの登録が解除されています。

解決策 : イベント ログを調べて、カスタム プリプロセッサの登録が解除されていることを確認します。そして、カスタム プリプロセッサを再登録するか、一覧からほかのプリプロセッサを選択します。

関連項目

ファイル受信機能の構成 : [サービス] タブ

カスタム プリプロセッサ

受信機能でのドキュメントの前処理


インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

原因 1 : BizTalk Server がインターチェンジまたはドキュメントを解析できませんでした。

解決策 : 保留キューからドキュメントを削除します。受信インターチェンジまたはドキュメントが、BizTalk Server で処理できる書式 (XML、ANSI X12、EDIFACT、またはフラット ファイル) であることを確認します。それから、インターチェンジまたはドキュメントを送信元の組織またはアプリケーションから BizTalk Server に再送信します。

BizTalk Server がドキュメントを解析できない場合、BizTalk Server がそのドキュメントを正しく読み取り、処理するための十分な情報がないため、ドキュメントはバイナリ データとして保留キューに表示されます。解析エラーの詳細については、「解析エラー」を参照してください。

原因 2 : BizTalk Server がインターチェンジまたはドキュメントを解析できましたが、データ コンテンツが有効ではありませんでした。タイムスタンプ "expiresAt" の期限が切れ、ドキュメントが有効でなくなっています。このエラーは、"expiredAt" フィールドが使用されている BizTalk フレームワーク ドキュメントで発生します。

解決策 : 保留キューからドキュメントを削除します。このドキュメントはもう有効ではありません。ドキュメントが有効でない原因を調べます。

原因 3 : ドキュメントのスキーマが正しくないのため、BizTalk Server がドキュメントを解析できませんでした。受信したファイルがフラット ファイルで、ドキュメント仕様のコード ページが UTF-8 に設定されている場合、BizTalk Server は UTF-8 をサポートしないため、このドキュメントを解析できません。

解決策 : フラット ファイルを受信した場合、ドキュメント仕様が正しいかどうかを確認します。ドキュメント仕様のコード ページが UTF-8 に設定されている場合、BizTalk Server はドキュメントを処理できません。保留キューからドキュメントを削除します。詳細については、「参照のプロパティの設定」を参照してください。

関連項目

解析エラー

参照のプロパティの設定

保留キュー


BizTalk Server がドキュメントの処理を停止した

原因 1 : BizTalk メッセージ管理データベース、追跡データベース、または共有キュー データベースのいずれかへの接続が切断された場合、またはそのほかの理由でこれらのデータベースにアクセスできない場合、BizTalk Server はドキュメントの処理を続行できません。Microsoft SQL Server が Enterprise Manager からシャットダウンされるか一時停止された場合に、このような状況が発生することがあります。Microsoft BizTalk Server 2000 にこのエラーが発生した場合、BizTalk メッセージ サービスが正常にシャットダウンされ、エラー発生時の処理状態と整合性が正しく保存されます。サービスがシャットダウンされる原因になったエラーの詳細がイベント ビューアに記録されます。

解決策 : システム管理者は、ページャー通知または電子メールによるステータス配信を通じて、このエラーを BizTalk Server がオフラインであることの通知として使用することができます。このような通知を受信したら、管理者は Microsoft 管理コンソール スナップインのサービスを使用して、BizTalk メッセージ サービスを手動で再開し、再びイベント ログを調べてエラーが解消されているかどうかを確認します。エラーがまだ解消されていない場合は、管理者は BizTalk Server が Microsoft SQL Server サービスを利用できるかを確認します。BizTalk メッセージ サービスの開始方法については、「BizTalk メッセージ サービスの開始」を参照してください。

原因 2 : BizTalk Server 2000 がインストールされているサーバーにウィルス対策ソフトウェアが導入されている場合、メッセージ ポートの既定の設定では正しくない可能性があります。

解決策 : ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。メッセージ ポートで既定の設定になっているファイル トランスポートの種類を使用し、BizTalk Server 2000 がインストールされているサーバーでウィルス対策ソフトウェアを使用していて、正確に同じ名前の複数のファイルを同じファイル位置に同時に送信すると、BizTalk Server 2000 が応答しなくなることがあり、その場合再起動する必要があります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。この問題は、メッセージ ポートのファイル パス形式 (file://C:\dir\file%tracking_id%.xml) を使用して処理されるドキュメント インスタンスごとに一意なファイルを作成することで解決することもできます。詳細については、「トランスポート アドレスの指定」を参照してください。サーバーを再起動する必要がある場合は、「グループ内のサーバーの起動」を参照してください。

関連項目

トランスポート アドレスの指定

グループ内のサーバーの起動

BizTalk メッセージ サービスの開始


受信機能でドキュメントが削除されない

原因 : 再試行の間隔が、生成されたドキュメント数に対して必要な処理能力より低く設定されている可能性があります。

解決策 : 再試行の間隔を 2 倍にして、BizTalk Server にドキュメントを再送信します。再試行の間隔を構成する方法については、「詳細構成のプロパティの設定」を参照してください。

関連項目

詳細構成のプロパティの設定


クラスタ コンピュータにインストールされた SQL Server に接続できない

原因 : Microsoft SQL Server がクラスタ サーバーにインストールされている場合、SQL Server は TCP/IP を使用して接続するクライアントだけをサポートします。

解決策 : SQL Server クライアント ツールをインストールして、既定のネットワーク ライブラリを TCP/IP に変更します。SQL Server クライアント ツールのインストールの詳細については、「SQL Server クライアント ツールのインストール」を参照してください。既定のネットワーク ライブラリの変更については、「既定のネットワーク ライブラリの TCP/IP への変更」を参照してください。

関連項目

既定のネットワーク ライブラリの TCP/IP への変更

SQL Server クライアント ツールのインストール


受信機能がドキュメントの処理を停止した

原因 : 1 台のリモート サーバーが同時にサポートできる受信機能は 50 までです。

解決策 : 複数の受信機能のサポートの詳細については、 Microsoft 製品サポート サービスの Web サイトで、Knowledge Base の次の記事を検索してください。

  • 「IIS がリモートの UNC パスに接続すると RPC でエラーが発生する」(JP221790)

詳細については、Knowledge Base の次の記事を参照してください。

  • 「Windows NT における ローカル システムアカウントと Null セッション」(JP132679)

  • 「システム アカウントで実行されているサービスがネットワークにアクセスできない」(JP124184)

  • 「PRB : サービスから名前付きパイプを開こうとするとアクセス拒否」(JP126645)

  • 「[NT]FindFirstChangeNotification がすべてのプロセスには通知しない」(J045160)


リモート サーバーを別の BizTalk メッセージ管理データベースに移動するとエラーが発生する

原因 : サーバーが別の BizTalk メッセージ管理データベースに属している可能性があります。

解決策 : BizTalk メッセージ管理データベースにリモート サーバーを追加するとき、そのサーバーが既に別の中央 BizTalk メッセージ管理データベースに属していた場合、Windows イベント ログに次のエラー メッセージが表示されます。

WMI クラスの新しいインスタンス "MicrosoftBizTalkServer_Server" を BizTalk Server WMI プロバイダで作成できません :サーバー <サーバー名> が別の BizTalk Server インストールに属している可能性があります。

このエラーは、もともと別のデータベースに属していたリモート サーバーを追加しようとしたことを示します。BizTalk Server 管理コンソールでこの手順が実行された場合、管理コンソールはそのリモート サーバーがリモート データベースのグループにも属しているかどうかを判断しようとします。管理コンソールはリモート サーバーの Windows Management Instrumentation (WMI) プロバイダに問い合わせ、これを判断します。サーバーが別の中央データベースのグループに属している場合、既に別の中央データベースのグループに属しているリモート サーバーは追加できないことを示す管理コンソールからのエラー メッセージが表示されます。

関連項目

WMI の概要


解析エラー

原因 1 : 信頼できるメッセージを送信する場合、ポートの既定の設定では正しくない可能性があります。

解決策 : ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。既定の設定のファイル トランスポートの種類を選択し、メッセージ ポートで Reliable エンベロープ書式のエンベロープを選択して、複数のファイルを同時に同じファイル位置に送信すると、予期しない解析結果を生じることがあります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで 、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。ポートの既定の設定の変更については、「メッセージ ポート既定値の変更」を参照してください。

その他の原因 : さまざまな原因により BizTalk Server がドキュメントを解析できません。一般的な原因として次のものがあります。

  • BizTalk Server が解析不能な書式のインターチェンジまたはドキュメントが存在する。

  • ドキュメントのスキーマが正しくない。

  • フラット ファイル インターチェンジのスキーマが正しくないか無効である。

  • フラット ファイル インターチェンジに無効な文字が含まれている。

  • フラット ファイル インターチェンジに文字がない。

  • フラット ファイル インターチェンジに区切り記号がない。

  • BizTalk フレームワーク 2.0 ドキュメントに、ポートまたはチャネルに一覧表示される無効なエイリアスが含まれている。

  • カスタム XML ヘッダーにドキュメント コンテナ ノードがない。

  • カスタム XML ドキュメントに属性がない。

  • EDI ドキュメント仕様がエンベロープと一致しない。

解決策 : インターチェンジ データまたはドキュメント データを表示して、BizTalk Server がインターチェンジまたはドキュメントを解析できない原因を調べます。インターチェンジ データまたはドキュメント データを表示するには、次の方法を使用できます。

  • インターチェンジ データまたはドキュメント データの最初の 512 バイトを表示します。インターチェンジ データまたはドキュメント データの表示方法の詳細については、「インターチェンジの表示」または「ドキュメントの表示」を参照してください。

  • BizTalk ドキュメント トラッキングでインターチェンジ レコード内のインターチェンジ データを表示します。BizTalk ドキュメント トラッキングでのインターチェンジの表示方法の詳細については、「日付によるインターチェンジとドキュメントの情報の検索」、「組織によるインターチェンジとドキュメントの情報の検索」、「ドキュメント型によるインターチェンジとドキュメントの情報の検索」、または「クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索」を参照してください。

  • Windows Management Instrumentation (WMI) レイヤを使用してインターチェンジ データを表示します。WMI アプリケーション プログラミングの詳細については、MSDN Online Library の Web サイト msdn.microsoft.com/library/ で "WMI Application Programming" を検索してください。

BizTalk Server がドキュメントを解析できない原因が判明したら、原因となった問題を修正し、IInterchange または受信機能を使用してインターチェンジまたはドキュメントを再送信してください。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

保留キュー

ドキュメントの表示

インターチェンジの表示


プログラムによる管理

ここで説明するインターフェイスによって、XLANG スケジューラ システム マネージャ、XLANG グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートにアクセスできます。

XLANG スケジューラ システム マネージャは、モニカの解決とグループ マネージャの管理を行います。グループ マネージャは、XLANG スケジュール ホストに指定されている COM+ アプリケーションごとに実行され、XLANG スケジュール インスタンスを管理します。XLANG スケジュール インスタンスは、スケジュールの完了ステータスなどの情報を問い合わせることができる実行中の XLANG スケジュールを表します。XLANG スケジュールのポートが COM にバインドされている場合は、プロキシ オブジェクトを使用して、ポート バインドで指定されたインターフェイスへの参照を取得できます。

注

  • 1 台のコンピュータに存在できる XLANG スケジューラ システム マネージャは 1 つだけです。

次の図は、これらのインターフェイスの関係と、対応するモニカを示しています。

sked://[host]
システム管理者
IWFSystemAdmin
sked://[host][!group]
XLANG スケジュール
インスタンス
XLANG スケジュール
インスタンス
XLANG スケジュール
インスタンス
グループ管理者
グループ管理者
グループ管理者
WorkflowInstance
IWFProxy
IWFWorkflowInstance
IWFWorkflowInstance
IWFWorkflowInstance
IWFGroupAdmin
IWFGroupAdmin
IWFGroupAdmin
sked://[host][!group]/file.skx
sked://[host][!group]/file.skx/port
COM バインド XLANG ポートへのプロキシ

詳細については、「XLANG スケジュールの管理」を参照してください。

関連項目

モニカの構文

Copyright © 1999#0150;2000 Microsoft Corporation.


ドキュメントの追跡

BizTalk ドキュメント トラッキングは、Microsoft BizTalk Server 2000 のドキュメント処理状況を表示するスタンドアロンの Web アプリケーションです。クエリまたは高度なクエリを作成し、追跡データベースから重要な情報を、見やすい形式に抽出できます。BizTalk ドキュメント トラッキングを使って、ドキュメントの送信元と送信先、ドキュメント名とドキュメント型、および関連する日付と時刻のパラメータに関して記録された情報を表示できます。あるいは、標準検索フィールドおよびカスタム検索フィールドを表示するクエリを作成して、業務運用結果を分析できます。たとえば、仕入先に送信した注文ごとに注文金額合計フィールドを記録することができます。そしてこのデータを使用して、一定期間にわたる仕入金額の合計を分析し、仕入先に報告できます。

また、BizTalk ドキュメント トラッキングでは、インターチェンジとドキュメントのレコードを個々にまたは一括して表示するように構成することもできます。さらに、BizTalk ドキュメント トラッキングを使用して、受信ドキュメント インスタンスおよび送信ドキュメント インスタンスの完全なコピーを表示、閲覧、保存し、後で確認することもできます。

  • 特定の作業のヘルプについては、「操作方法」を参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk ドキュメント トラッキングのトラブルシューティング」を参照してください。

重要

  • BizTalk ドキュメント トラッキングへのアクセスは、Web アプリケーションと同様に Microsoft Internet Explorer で行うため、Microsoft BizTalk Server 2000 ヘルプへのアクセス方法も異なり、ヘルプで利用できる機能が一部制限されています。[目次]、[キーワード]、[検索]、および [お気に入り] の各タブは利用できません。すべてのトピックには、開始ページからのリンク、関連項目のリンクを通してアクセスすることができます。もちろん、ブラウザの [戻る] ボタンも使用できます。

    特定のヘルプ トピックを検索したり、BizTalk Server 2000 のほかの機能やサービスに関する情報にアクセスするには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk Server ドキュメント] をクリックします。[スタート] ボタンからヘルプを利用できるようにするには、ご使用のコンピュータに BizTalk Server 2000 をインストールしてください。

  • BizTalk ドキュメント トラッキングでは Microsoft ActiveX コントロールが使用されるため、選択時またはクエリ送信時に ActiveX コントロールのダウンロード ダイアログ ボックスが表示されることがあります。表示された場合は、[はい] をクリックして作業を続行してください。

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    * この表示は、お使いのソフトウェアのバージョンにより、表現が多少異なる場合があります。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。 [信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「Internet Explorer でのセキュリティ設定の構成」を参照してください。


操作方法

ここでは、インターチェンジとドキュメント インスタンスのレコード、および関連データの検索、表示、および検索結果の保存を行う方法を作業ごとに説明します。「概念」を参照し、検索機能とそのクエリ結果について十分に理解しておいてください。

BizTalk ドキュメント トラッキングには、2 種類の検索機能があります。クエリと高度なクエリです。送信元組織など、標準の検索条件を使用してドキュメントを検索する場合は、クエリを使用します。注文金額合計など、ドキュメントの特定のデータを検索する場合は、高度なクエリを使用します。

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングを初めて開く

  • BizTalk ドキュメント トラッキングを開く

  • BizTalk Server Report Users グループへのユーザーの追加

  • クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え

  • 高度なクエリの使用

  • インターチェンジ データ、ドキュメント データ、およびカスタム検索データの保存


BizTalk ドキュメント トラッキングを初めて開く

Windows コモン コントロールおよび BizTalk ドキュメント トラッキング コントロールがコンピュータにインストールされていない場合は、BizTalk ドキュメント トラッキングを初めて開いたときに、コンポーネントのインストールを求めるメッセージが表示されます。これらのコンポーネントがコンピュータにインストールされている場合は、「BizTalk ドキュメント トラッキングを開く」を参照してください。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk ドキュメント トラッキング] をクリックします。

    次のコンポーネントのインストールを求める [Web ページ ダイアログ] ダイアログ ボックスが表示されます。

    • Windows コモン コントロール

    • BizTalk ドキュメント トラッキング インストール コントロール
  2. [続行] をクリックして Windows コモン コントロールをインストールします。

    セキュリティに関する警告が表示されます。

  3. [はい] をクリックして BizTalk ドキュメント トラッキング インストール コントロールをインストールします。

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    * この表示は、お使いのソフトウェアのバージョンにより、表現が多少異なる場合があります。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。 [信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「Internet Explorer でのセキュリティ設定の構成」を参照してください。

関連項目

Internet Explorer のセキュリティ設定の構成

BizTalk ドキュメント トラッキングを開く


BizTalk ドキュメント トラッキングを開く

  • [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk ドキュメント トラッキング] をクリックします。

    または

    Microsoft Internet Explorer で BizTalk ドキュメント トラッキングをお気に入りに追加すると、Internet Explorer から BizTalk ドキュメント トラッキングを開くことができます。

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    * この表示は、お使いのソフトウェアのバージョンにより、表現が多少異なる場合があります。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。 [信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「Internet Explorer でのセキュリティ設定の構成」を参照してください。

関連項目

Internet Explorer のセキュリティ設定の構成

BizTalk ドキュメント トラッキングを初めて開く


BizTalk Server Report Users グループへのユーザーの追加

BizTalk ドキュメント トラッキングのユーザー インターフェイスを表示し、高度なクエリの式を保存するには、BizTalk Server Report Users グループのメンバになっている必要があります。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. [システム ツール] を展開し、[ローカル ユーザーとグループ] を展開します。次に、[グループ] フォルダをクリックします。

  3. .詳細ウィンドウで、[BizTalk Server Report Users] をクリックします。

  4. [操作] メニューの [すべてのタスク] をポイントし、[グループに追加] をクリックします。

    [BizTalk Server Report Users のプロパティ] ダイアログ ボックスが表示されます。

  5. [追加] をクリックします。

  6. [場所] ボックスの一覧で、ドメイン名またはコンピュータ名をクリックします。

  7. 手順 6. で選択したドメインまたはコンピュータと関連付けられたユーザーまたはコンピュータを含む一覧で、追加するユーザー アカウントをクリックし、[追加] をクリックします。次に [OK] をクリックします。

  8. [OK] をクリックして [BizTalk Server Report Users のプロパティ] ダイアログ ボックスを閉じます。


クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え

ドキュメント型や送信元組織などの標準検索条件でクエリを使用して、インターチェンジとドキュメント インスタンスのレコード、および関連データの検索、表示、保存を行うことができます。

ここには次のトピックが含まれます。

  • 日付によるインターチェンジとドキュメントの情報の検索

  • 組織によるインターチェンジとドキュメントの情報の検索

  • ドキュメント型によるインターチェンジとドキュメントの情報の検索

  • クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

  • 組織とドキュメント型の検索条件のクリア

  • [クエリ結果] ページのカスタマイズ

  • [クエリ結果] ページの検索パラメータの表示

注

  • クエリ パラメータを選択するときは、できるだけ具体的なものにしてください。そうすることにより、サーバーの負荷が減り、クエリ結果が返される時間が短縮されます。

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    * この表示は、お使いのソフトウェアのバージョンにより、表現が多少異なる場合があります。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。 [信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「Internet Explorer でのセキュリティ設定の構成」を参照してください。


日付によるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングの [日付の範囲] で、[日付の表示] ボックスの一覧の [ローカル時刻] または [世界標準時] をクリックして、表示日付のタイム ゾーンを指定します。

  2. [開始日] ボックスの一覧に追跡期間の開始日を入力するか、矢印をクリックしてカレンダーを表示し、日付を選択します。

    時刻を変更するには、[開始日] ボックスの一覧の隣にあるボックスに開始時刻を入力するか、上矢印または下矢印をクリックして指定します。

  3. [終了日] ボックスの一覧に追跡期間の終了日を入力するか、矢印をクリックしてカレンダーを表示し、日付を選択します。

    時刻を変更するには、[終了日] ボックスの一覧の隣にあるボックスに終了時刻を入力するか、上矢印または下矢印をクリックして指定します。

  4. [クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

  5. インターチェンジ データを表示するには、表示するデータが格納されているインターチェンジ レコードを検索して、データ列の [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  6. インターチェンジの XLANG スケジュール ステータスを表示するには、[スケジュール] 列の [スケジュール] アイコンをクリックします。

    [XLANG スケジュールの概要の表示] ページが表示されます。

  7. インターチェンジに関連付けられたドキュメント インスタンス レコードを表示するには、対象のドキュメント インスタンス レコードが格納されているインターチェンジの隣の [展開記号 (+)] アイコンをクリックします。

  8. ドキュメント インスタンスに関連付けられたデータを表示するには、[データ] 列の [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  9. データをネイティブ形式で表示するには [ネイティブ形式の表示] を、XML 形式で表示するには [XML 形式の表示] をクリックします。

  10. ドキュメント インスタンスに関連付けられた受信確認データを表示するには、[受信] 列の [受信確認] アイコンをクリックします。

    新しい [クエリ結果] ページが表示されます。

  11. インターチェンジの隣の [展開記号 (+)] アイコンをクリックし、データ フィールドの [データ] アイコンをクリックします。

  12. ドキュメント インスタンスのカスタム検索フィールド データを表示するには、データを表示するドキュメントを検索し、水平スクロール バーを使用してカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

注

  • [日付の表示] ボックスの一覧で選択する値によって、検索時刻と表示結果が異なります。たとえば、[日付の表示] ボックスの一覧で [世界標準時] を選択し、時刻フィールドで 8:00:00 を指定した場合、世界標準時 (UTC) の 8 時以後に処理されたすべてのデータが検索対象となります。これは、ローカル時刻の 8:00:00 とは異なります。

  • 既定の日付は、現在の日付の 7 日前に設定されています。

  • 表示日付は、BizTalk Server で生成されて、ドキュメント インスタンスとインターチェンジのメタデータに付けられるタイムスタンプです。実際のドキュメント内容の日付ではありません。実際のドキュメント日付を基にしてドキュメントを検索するには、[高度なクエリ] で式を作成してください。高度なクエリの詳細については、「高度なクエリの作成」を参照してください。

  • クエリで日付の範囲だけを指定すると、BizTalk ドキュメント トラッキングでは、すべての送信元組織と送信先組織、およびすべてのドキュメント型を検索します。このような単一検索パラメータは使用しないでください。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。

  • XLANG スケジュール ステータスには、最後に検出されたイベント、処理の開始時刻と終了時刻などがあります。

関連項目

高度なクエリの作成

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

クエリについて


組織によるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングの [送信元の選択] ボックスの一覧で、インターチェンジとドキュメントを表示する組織をクリックします。送信元組織に関連付けられているアプリケーションを選択するには、組織の隣の [展開記号 (+)] アイコンをクリックし、対象のアプリケーションをクリックします。すべての送信元組織を選択するには、[すべて選択] をクリックします。

    または

    BizTalk ドキュメント トラッキングの [送信先の選択] ボックスの一覧で、インターチェンジとドキュメントを表示する組織をクリックします。送信先組織に関連付けられているアプリケーションを選択するには、組織の隣の [展開記号 (+)] アイコンをクリックし、対象のアプリケーションをクリックします。すべての送信先組織を選択するには、[すべて選択] をクリックします。

    同じクエリに対して、[送信元の選択] および [送信先の選択] ボックスの一覧で、組織とアプリケーションを選択できます。

  2. [クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。クエリ条件と一致するインターチェンジの一覧がここに表示されます。

  3. インターチェンジ データを表示するには、表示するデータが格納されているインターチェンジ レコードを検索して、データ列の [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  4. インターチェンジの XLANG スケジュール ステータスを表示するには、[スケジュール] 列の [スケジュール] アイコンをクリックします。

    [XLANG スケジュールの概要の表示] ページが表示されます。

  5. インターチェンジに関連付けられたドキュメント インスタンス レコードを表示するには、対象のドキュメント インスタンス レコードが格納されているインターチェンジの隣の [展開記号 (+)] アイコンをクリックします。

  6. ドキュメント インスタンスに関連付けられたデータを表示するには、[データ] 列の [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  7. データをネイティブ形式で表示するには [ネイティブ形式の表示] を、XML 形式で表示するには [XML 形式の表示] をクリックします。

  8. ドキュメント インスタンスに関連付けられた受信確認データを表示するには、[受信] 列の [受信確認] アイコンをクリックします。

    新しい [クエリ結果] ページが表示されます。

  9. インターチェンジの隣の [展開記号 (+)] アイコンをクリックし、データ フィールドの [データ] アイコンをクリックします。

  10. ドキュメント インスタンスのカスタム検索フィールド データを表示するには、データを表示するドキュメントを検索し、水平スクロール バーを使用してカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールドの表示] ページが表示されます。

注

  • 送信元組織と送信先組織を特定しない場合は、すべての送信元組織と送信先組織のインターチェンジ レコードおよびドキュメント レコードが返されます。[すべてクリア] および [すべて選択] のどちらのオプションを使用しても、[クエリ結果] ページに同じ結果が返されます。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。

  • XLANG スケジュール ステータスには、最後に検出されたイベント、処理の開始時刻と終了時刻などがあります。

関連項目

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

クエリについて


ドキュメント型によるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングの [ドキュメント型の選択] で、[ドキュメントの表示] をクリックします。

  2. [ドキュメント型の選択] ボックスの一覧で、検索するドキュメント型をクリックします。すべてのドキュメント型を選択するには、[すべて選択] をクリックします。

  3. [クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

  4. インターチェンジ データを表示するには、表示するデータが格納されているインターチェンジ レコードを検索して、データ列の [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  5. インターチェンジの XLANG スケジュール ステータスを表示するには、[スケジュール] 列の [スケジュール] アイコンをクリックします。

    [XLANG スケジュールの概要の表示] ページが表示されます。

  6. インターチェンジに関連付けられたドキュメント インスタンス レコードを表示するには、対象のドキュメント インスタンス レコードが格納されているインターチェンジの隣の [展開記号 (+)] アイコンをクリックします。

  7. ドキュメント インスタンスに関連付けられたデータを表示するには、[データ] 列の [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  8. データをネイティブ形式で表示するには [ネイティブ形式の表示] を、XML 形式で表示するには [XML 形式の表示] をクリックします。

  9. ドキュメント インスタンスに関連付けられた受信確認データを表示するには、[受信] 列の [受信確認] アイコンをクリックします。

    新しい [クエリ結果] ページが表示されます。

  10. インターチェンジの隣の [展開記号 (+)] アイコンをクリックし、データ フィールドの [データ] アイコンをクリックします。

  11. ドキュメント インスタンスのカスタム検索フィールド データを表示するには、データを表示するドキュメントを検索し、水平スクロール バーを使用してカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

注

  • 1 つまたは複数のドキュメント型を指定せずに検索を絞り込まない場合は、クエリによって一覧のすべてのドキュメント型が返されます。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。

  • XLANG スケジュール ステータスには、最後に検出されたイベント、処理の開始時刻と終了時刻などがあります。

関連項目

日付によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

クエリについて


クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングでは、単一クエリ セッションで次のクエリ パラメータを組み合わせると、インターチェンジ レコードとドキュメント インスタンス レコード、および関連データの検索と表示を行うことができます。
    • 送信元の選択 : "送信元の選択" パラメータを使用したクエリの作成については、「組織によるインターチェンジとドキュメントの情報の検索」を参照してください。

    • 送信先の選択 : "送信先の選択" パラメータを使用したクエリの作成については、「組織によるインターチェンジとドキュメントの情報の検索」を参照してください。

    • ドキュメント型 : "ドキュメント型" パラメータを使用したクエリの作成については、「ドキュメント型によるインターチェンジとドキュメントの情報の検索」を参照してください。

    • 日時 : "日時" パラメータを使用したクエリの作成については、「日付によるインターチェンジとドキュメントの情報の検索」を参照してください。
  2. [クエリ] ボタンをクリックします。


組織とドキュメント型の検索条件のクリア

  • BizTalk ドキュメント トラッキングで、[送信元の選択]、[送信先の選択]、または [ドキュメント型の選択] ボックスの一覧の下の [すべてクリア] をクリックします。

注

  • [すべてクリア] をクリックすると、BizTalk ドキュメント トラッキングの検索対象は、すべての送信元組織と送信先組織、およびすべてのドキュメント型という既定の設定に戻ります。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。


[クエリ結果] ページのカスタマイズ

  1. BizTalk ドキュメント トラッキングの [並べ替えの指定] で、[関連するインターチェンジのグループ化] チェック ボックスをオンにします。

    この操作により、関連送信インターチェンジでグループ化された受信インターチェンジが [クエリ結果] ページに表示されるようになります。関連する送信インターチェンジと共に受信インターチェンジを表示しない場合は、このチェック ボックスをオフにします。

  2. [並べ替えの指定] の [並べ替え順 1] ボックスの一覧で、最初に使用する並べ替え順をクリックします。並べ替え順のボックスの一覧それぞれに対してこの操作を繰り返し、[クエリ結果] ページでのドキュメントの並べ替え順を構成します。

    [並べ替え順] ボックスの一覧には、次の選択肢があります。

    • [送信元組織名]

    • [送信元アプリケーション名]

    • [送信先組織名]

    • [送信先アプリケーション名]

    • [ドキュメント型]

    • [処理時間]


[クエリ結果] ページの検索パラメータの表示

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. [検索パラメータ] バーの [表示] アイコンをクリックします。

    次の検索パラメータと、その値が、[検索パラメータ] に一覧表示されます。

    • 日付の範囲

    • タイム ゾーン

    • クエリ式名

    • 並べ替え順

    • 送信元の選択

    • 送信先の選択

    • ドキュメント型の選択

関連項目

高度なクエリの作成

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


高度なクエリの使用

特定の注文番号が付いたドキュメント インスタンスなど、特定のデータを検索する必要がある場合に、情報の検索に高度なクエリを使用できます。

ここには次のトピックが含まれます。

  • 高度なクエリの作成

  • 既存の高度なクエリの選択

  • 既存の高度なクエリの編集

  • クエリからの既存の高度なクエリのクリア

  • 既存の高度なクエリの削除


高度なクエリの作成

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[新規] をクリックします。

    [高度なクエリ ビルダ] ページが表示されます。

  2. [送信元の選択] ボックスの一覧で、オプションをクリックして送信元の選択条件を指定します。

    これは、検索対象であるフィールドから取得された名前です。

  3. [演算子] ボックスの一覧で演算子をクリックします。

  4. [値] ボックスに、値を入力します。

  5. [AND/OR] ボックスの一覧で、使用する条件とほかの条件を結合するには [AND] を、比較するには [OR] をクリックします。この手順は省略できます。

  6. [作成] をクリックします。

  7. 必要な条件をすべて追加するまで、手順 2. ～ 6. の操作を繰り返します。

  8. 次のいずれかの操作を行います。
    • [OK] をクリックして、この式の適用対象を現在のクエリ セッションに限定します。

    • [保存] をクリックして、これ以降のクエリ セッションで使用するために式を保存します。[BizTalk ドキュメント トラッキング] ダイアログ ボックスで、[クエリ式名の入力] ボックスに 50 文字以内で式名を入力し、[OK] をクリックします。

注

  • 高度なクエリで作成した 1 つまたは複数の条件の集合をクエリ式と呼びます。

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

  • BizTalk メッセージ マネージャでは、カスタム フィールドを追跡するためにチャネルやドキュメント定義を構成すると、これらのフィールドが [送信元の選択] ボックスの一覧に表示されるようになります。フィールドの追跡を行うように BizTalk メッセージ マネージャを構成していない場合は、[送信元の選択] ボックスの一覧には "<カスタム検索>" だけが表示されます。特定フィールドの追跡の詳細については、「ドキュメント ログのプロパティの設定」および「チャネル内の仕様フィールドの選択」を参照してください。

関連項目

クエリからの既存の高度なクエリのクリア

既存の高度なクエリの削除

既存の高度なクエリの編集

既存の高度なクエリの選択


既存の高度なクエリの選択

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[参照] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  2. 既存のクエリを選択し、[OK] をクリックします。

注

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

関連項目

高度なクエリの作成

クエリからの既存の高度なクエリのクリア

既存の高度なクエリの削除

既存の高度なクエリの編集


既存の高度なクエリの編集

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[参照] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  2. 編集する既存のクエリを選択し、[編集] をクリックします。

    [高度なクエリ ビルダ] ダイアログ ボックスが表示されます。

  3. 次のうち、必要な操作を行います。
    • [新規] をクリックして条件を追加します。4 つのフィールドにそれぞれ条件を指定し、[作成] をクリックします。

    • 既存の条件をクリックし、[編集] をクリックします。次に、4 つのフィールドのうち任意のものを変更し、[作成] をクリックします。

    • 既存の条件を選択し、[削除] をクリックします。
  4. [保存] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  5. 編集したクエリを選択し、[OK] をクリックします。

注

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

関連項目

高度なクエリの作成

クエリからの既存の高度なクエリのクリア

既存の高度なクエリの削除

既存の高度なクエリの選択


クエリからの既存の高度なクエリのクリア

  • BizTalk ドキュメント トラッキングの [高度なクエリ] で、[クリア] をクリックして、[クエリ式名] ボックスから現在の式をクリアします。

注

  • Internet Explorer の [更新] ボタンをクリックしても、高度なクエリは [クエリ式名] ボックスからクリアされません。

関連項目

高度なクエリの作成

既存の高度なクエリの削除

既存の高度なクエリの編集

既存の高度なクエリの選択


既存の高度なクエリの削除

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[参照] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  2. クエリを選択し、[削除] をクリックします。

  3. 作業が完了したら、[高度なクエリ] ダイアログ ボックスを閉じます。

注

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

関連項目

高度なクエリの作成

クエリからの既存の高度なクエリのクリア

既存の高度なクエリの編集

既存の高度なクエリの選択


インターチェンジ データ、ドキュメント データ、およびカスタム検索データの保存

受信インターチェンジおよび送信インターチェンジとそのドキュメントを格納するように、BizTalk メッセージ マネージャ、BizTalk メッセージ構成オブジェクト モデル、および BizTalk Server 管理コンソールを構成すると、インターチェンジ、ドキュメント データ、およびカスタム フィールド検索データを保存して、オフラインで表示することができます。これにより、特定の状況のトラブルシューティングや業務遂行方法の分析を行うことができます。

ここには次のトピックが含まれます。

  • インターチェンジ データの保存

  • ドキュメント インスタンス データの保存

  • カスタム フィールド検索データの保存


インターチェンジ データの保存

  1. クエリのパラメータを選択して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. 保存するインターチェンジ データが格納されているインターチェンジ レコードを検索し、データ フィールドの [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  3. [名前を付けて保存] をクリックします。

  4. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

関連項目

高度なクエリの作成

カスタム フィールド検索データの保存

ドキュメント インスタンス データの保存

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


ドキュメント インスタンス データの保存

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. 保存するドキュメント インスタンス データが格納されているインターチェンジ レコードを検索し、このインターチェンジの左の [展開記号 (+)] アイコンをクリックします。

  3. データ フィールドの [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  4. [名前を付けて保存] をクリックします。

  5. [ファイル名] ボックスに、ファイルに付ける名前と拡張子 (.xml ファイル拡張子またはドキュメント本来のファイル拡張子) を入力し、[保存] をクリックします。

関連項目

高度なクエリの作成

カスタム フィールド検索データの保存

インターチェンジ データの保存

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


カスタム フィールド検索データの保存

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. 表示するドキュメントが格納されているインターチェンジ レコードの左の [展開記号 (+)] アイコンをクリックします。

  3. 水平スクロール バーを使用して、表示するドキュメントのカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

  4. [名前を付けて保存] をクリックします。

  5. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

関連項目

高度なクエリの作成

ドキュメント インスタンス データの保存

インターチェンジ データの保存

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


概念

ここでは、ドキュメントの追跡および利用状況の監視を理解するうえで不可欠な概念について説明します。

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングの環境

  • BizTalk ドキュメント トラッキングの使用

  • 追跡データベース スキーマについて

  • インターチェンジとその関連ドキュメントの検索方法について

  • クエリ結果について

  • インターチェンジ用の統合 XLANG スケジュール ステータスについて

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。 [信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「Internet Explorer でのセキュリティ設定の構成」を参照してください。


BizTalk ドキュメント トラッキングの環境

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングのユーザー インターフェイス

  • BizTalk ドキュメント トラッキングのショートカット キー


BizTalk ドキュメント トラッキングのユーザー インターフェイス

BizTalk ドキュメント トラッキングは、Microsoft BizTalk Server で追跡対象として構成したインターチェンジとドキュメントの表示に使用するスタンドアロンの Web アプリケーションです。メイン ページは、次の部分から構成されています。

  • [日付の範囲]

  • [送信元の選択]

  • [送信先の選択]

  • [高度なクエリ]

  • [並べ替えの指定]

  • [ドキュメント型の選択]

クエリ パラメータは、[日付の範囲]、[送信元の選択]、[送信先の選択]、および [ドキュメント型の選択] で構成できます。

このページの左下部には、[高度なクエリ] および [並べ替えの指定] の領域があります。特定の情報またはカスタム検索フィールドを検索するには、[高度なクエリ] でパラメータを構成します。[クエリ結果] ページの並べ替え順を指定するには、[並べ替えの指定] でオプションを構成します。

メイン ページの [クエリ] をクリックすると、[クエリ結果] ページが表示されます。追跡データベースのレコードがクエリ パラメータと一致すると、インターチェンジ レコードが一覧表示されます。次の表は、[クエリ結果] ページで利用できるアイコンとその説明の一覧です。

アイコン | 目的
[データ] アイコン | インターチェンジまたはドキュメント インスタンス データにアクセスします。インターチェンジ レコードの [データ] アイコンをクリックすると、インターチェンジ データが表示されます。ドキュメント インスタンス レコードの [データ] アイコンをクリックすると、ドキュメント データが表示されます。
[展開記号] アイコン | インターチェンジ レコードを展開し、ドキュメント インスタンス レコードを表示します。
[折りたたみ] アイコン | インターチェンジ レコードを折りたたみ、ドキュメント インスタンス レコードを非表示にします。
[XLANG スケジュール] アイコン | インターチェンジに関する XLANG スケジュール ステータスを表示します。
[受信確認] アイコン | 新しい [クエリ結果] ページで、受信確認の内容を表示します。受信確認の結果の詳細については、「受信確認の結果について」を参照してください。
[カスタム検索] アイコン | .カスタム検索データを表示します。


BizTalk ドキュメント トラッキングのショートカット キー

BizTalk ドキュメント トラッキングでは、ショートカット キーを使用して作業を行うことができます。次の表は、メイン ページで利用できるショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。または、Windows 2000 Professional ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Alt + N | [高度なクエリ ビルダ] ページを表示します。
Alt + B | [高度なクエリ] ページを表示します。
Alt + C | 現在のクエリ セッションから高度なクエリを消去します。
Alt + S | [送信元の選択] ボックスの一覧で、すべての組織およびアプリケーションを選択します。
Alt + R | [送信元の選択] ボックスの一覧を消去します。
Alt + E | [送信先の選択] ボックスの一覧で、すべての組織およびアプリケーションを選択します。
Alt + A | [送信先の選択] ボックスの一覧を消去します。
Alt + W | [ドキュメント型の選択] ボックスの一覧で、すべてのドキュメント型を表示します。
Alt + T | [ドキュメント型の選択] ボックスの一覧で、すべてのドキュメント型を選択します。
Alt + L | [ドキュメント型の選択] ボックスの一覧を消去します。
Alt + Q | [クエリ結果] ページを表示します。
Alt + O | BizTalk ドキュメント トラッキングを終了します。
Alt + H | オンライン ヘルプを表示します。
Alt + フィールド名の下線付き文字または数字 | 特定のフィールドにフォーカスを移動します。たとえば、Alt キーを押しながら 1 キーを押すと、[並べ替え順 1] にフォーカスが移動します。

次の表は、[クエリ結果] ページで利用できるショートカット キーの一覧です。[クエリ結果] ページを表示するには、Alt キーを押しながら Q キーを押します。

ショートカット キー | 機能
Alt + C | [クエリ結果] ページを閉じます。
Alt + H | オンライン ヘルプを表示します。
Space | アイコンを開く、または閉じます。開くまたは閉じるアイコンにフォーカスを移動する場合は、Tab キーを使用してください。たとえば、インターチェンジ レコードを展開する場合は、選択したインターチェンジ レコードの [展開] アイコンにフォーカスが移動するまで繰り返し Tab キーを押し続けます。次に、Space キーを押します。

次の表は、[高度なクエリ ビルダ] ページで利用できるショートカット キーの一覧です。[高度なクエリ ビルダ] ページを表示するには、メイン ページで、Alt キーを押しながら N キーを押します。

ショートカット キー | 機能
Alt + N | 高度なクエリ式に条件を追加します。
Alt + E | 条件を編集します。
Alt + R | 高度なクエリ式から条件を削除します。
Alt + S | クエリ式を保存します。
Alt + O | クエリ式の適用対象を現在のクエリ セッションに限定します。
Alt + C | [高度なクエリ ビルダ] ページを閉じます。
Alt + H | オンライン ヘルプを表示します。
Alt + フィールド名の下線付き文字 | 特定のフィールドにフォーカスを移動します。たとえば、Alt キーを押しながら V キーを押すと、"値" フィールドにフォーカスが移動します。

注

  • フォーカスを [クエリ] に移動する場合に、[クエリ] に条件が複数あるときは、↑キーまたは↓キーを使用して目的の条件を選択します。

次の表は、[高度なクエリ] ページで利用できるショートカット キーの一覧です。[高度なクエリ] ページを表示するには、メイン ページで、Alt キーを押しながら B キーを押します。

ショートカット キー | 機能
Alt + E | 既存のクエリ式を編集します。
Alt + N | [高度なクエリ ビルダ] ページを表示します。
Alt + D | クエリ式を削除します。
Alt + O | 現在のクエリにクエリ式を追加します。
Alt + C | 変更を保存しないで [高度なクエリ] ページを閉じます。
Alt + H | オンライン ヘルプを表示します。


BizTalk ドキュメント トラッキングの使用

BizTalk ドキュメント トラッキングを使用すると、次のことを行うことができます。

  • Microsoft BizTalk Server 2000 によって処理されるインターチェンジとその関連ドキュメントを追跡します。

  • 電子ビジネス トランザクションのすべてのコピーを保存するための法律または標準に関する条件を満たします。

  • 顧客からの問い合わせに迅速かつ簡単に回答する。たとえば、「取引先 A に請求書を送ったのはいつでしたか」という問い合わせがあると、日付、時刻、さらに受信確認が送られてきたかどうかを検索できます。

  • トラブルシューティングに役立てる。

  • 争議の解決に役立てる。

ドキュメントの追跡は、一括してまたは単一トランザクションとして行うことができます。BizTalk ドキュメント トラッキングでは、送信元と送信先の情報、ドキュメント型、日時パラメータなど、インターチェンジに関連付けられたメタデータを自動的に格納します。メタデータは自動的に格納されますが、注文日付または注文金額合計などの詳細なフィールドが取得されるのは、このような情報を BizTalk メッセージ構成オブジェクト モデルまたは BizTalk メッセージ マネージャで取得できるように構成した場合だけです。追跡対象として選択したフィールドの構成については、「チャネルのプロパティの設定」または「受信ドキュメントの追跡のプロパティの設定」を参照してください。

追跡対象として構成した追跡データは、メタデータまたはフィールドのいずれであっても、インストール時またはサーバー グループの構成時に構成した追跡データベースにすべて自動的に格納されます。BizTalk ドキュメント トラッキングのユーザー インターフェイス (UI) を使用すると、特定のサーバー グループに関連付けられた追跡データベースに格納されているデータにアクセスできます。追跡データベースに格納されているデータは、このユーザー インターフェイスからすべて利用できるわけではありませんが、追跡対象として構成したメタデータとフィールドは簡単に利用できます。たとえば、購買アプリケーション C が注文書を取引先 D に送ったのはいつか、またこの取引先 D から注文に対する返答があったかどうか、またあった場合にはいつあったかを追跡する必要がある場合に、BizTalk ドキュメント トラッキングを使用します。

ここには次のトピックが含まれます。

  • サーバー グループの追跡設定について

  • BizTalk メッセージ マネージャの追跡設定について

注

  • 「信頼できるメッセージ受信確認」は、BizTalk ドキュメント トラッキングのユーザー インターフェイスに表示されません。

関連項目

チャネルのプロパティの設定

受信ドキュメントの追跡のプロパティの設定

追跡データベース


サーバー グループの追跡設定について

サーバー グループの追跡設定では、インターチェンジの追跡を有効にするか無効にするかを指定します。このグローバル追跡設定は、BizTalk Server 管理コンソールで構成します。サーバー グループの追跡の設定を構成する方法の詳細については、「サーバー グループの追跡のプロパティの設定」を参照してください。[ドキュメント トラッキングを有効にする] チェック ボックスがオンの場合は、受信インターチェンジ、送信インターチェンジ、または元の MIME エンコード メッセージ、あるいはこれらすべてをログに記録するように BizTalk Server を構成できます。

Microsoft BizTalk Server 2000 をインストールすると、ドキュメント トラッキングが自動的に有効になり、受信インターチェンジのログ記録および送信インターチェンジのログ記録のオプションが選択され、次のようなインターチェンジのメタデータが追跡されます。

  • 送信元組織の情報

  • 送信先組織の情報

  • ドキュメント型

  • インターチェンジが BizTalk Server で処理された日時

  • ドキュメント数

  • エラー情報

  • コントロール ID

インターチェンジの追跡だけでなく、注文金額合計や請求金額合計など特定のフィールドを BizTalk Server で追跡できるように構成することもできます。特定フィールドの追跡の詳細については、「BizTalk メッセージ マネージャの追跡設定について」を参照してください。否認防止および商法上の問題に備えて、インターチェンジのコピーを元の書式で保存する必要がある場合は、グローバル追跡設定を使用します。社内用の監査記録を作成する、またはドキュメント単位でデータに簡単にアクセスできるようにする場合は、BizTalk メッセージ構成オブジェクト モデルまたは BizTalk メッセージ マネージャで追跡設定を構成します。追跡設定は BizTalk メッセージ構成オブジェクト モデルや BizTalk 管理コンソールで構成できますが、これにより、追跡データベースのサイズが短期間に肥大化する場合があり、同時に重複してデータを格納することになります。

BizTalk ドキュメント トラッキングの設定を無効にする

ドキュメントを追跡する必要がない場合は、BizTalk ドキュメント トラッキングを無効にすることができます。ただし、ドキュメント トラッキングを無効にすると、重要な機能が使用できなくなります。たとえば、ドキュメント トラッキングを無効にすると、次のことができなくなります。

  • BizTalk Server 2000 で処理されているインターチェンジとその関連ドキュメントを追跡する。

  • 電子ビジネス トランザクションのすべてのコピーを保存するための法律または標準に関する要件を満たす。

  • 顧客からの問い合わせに迅速かつ簡単に回答する。たとえば、「取引先 A に請求書を送ったのはいつでしたか」という問い合わせがあったとき、日付、時刻、さらに受信確認が送られてきたかどうかを検索する。

  • トラブルシューティングに役立てる。

  • 争議の解決に役立てる。

ドキュメント トラッキングを有効または無効にする、あるいはグローバル追跡設定を変更するには、BizTalk Server 管理コンソールを使用します。サーバー グループの追跡の設定を構成する方法の詳細については、「サーバー グループの追跡プロパティの設定」を参照してください。

注

  • BizTalk Server 管理コンソールを開くには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  • インターチェンジとドキュメントの追跡には、サイズの制限があります。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

関連項目

サーバー グループの追跡のプロパティの構成

インターチェンジとドキュメントのサイズ制限

BizTalk Server 管理コンソールを開く

BizTalk メッセージ マネージャの追跡設定について


BizTalk メッセージ マネージャの追跡設定について

次のことを行う必要がある場合は、BizTalk メッセージ マネージャで追跡設定を構成してください。

  • 受信ドキュメント インスタンスと送信ドキュメント インスタンスの完全なコピーを格納する。

  • 注文金額合計や注文日など、特定のフィールドを取得対象として構成する。

サーバー グループの追跡のプロパティとは異なり、特定のフィールドの追跡またはドキュメント インスタンスのコピーの格納の機能が自動的に有効になることはありません。これらのオプションは、BizTalk メッセージ マネージャで適切なチャネルやドキュメント定義を構成する場合に必要です。

受信ドキュメント インスタンスまたは送信ドキュメント インスタンスのコピーを格納する方法の詳細については、「ドキュメント ログのプロパティの設定」を参照してください。特定フィールドの追跡の詳細については、「チャネル内の仕様フィールドの選択」を参照してください。

注

  • BizTalk メッセージ マネージャを開くには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  • ドキュメントの追跡と格納にはサイズの制限があります。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

関連項目

インターチェンジとドキュメントのサイズ制限

チャネルでの仕様フィールドの選択

ドキュメント ログのプロパティの設定

サーバー グループの追跡設定について


追跡データベース スキーマについて

サーバー グループ内のすべてのサーバーは単一の追跡データベースを共有します。追跡データベースは、BizTalk Server でのインターチェンジとドキュメントの処理状況に関連するすべての情報を格納します。追跡データベースは、サーバーを通過するインターチェンジまたはドキュメントのステータスを追跡するために使用します。追跡データベースには、次の 3 つの主要なテーブルがあります。

  • dta_interchange_details

  • dta_outdoc_details

  • dta_indoc_details

これらをサポートするテーブルには次のものがあります。

  • dta_group_details

  • dta_interchange_data

  • dta_document_data

  • dta_debugdoc_data

  • dta_routing_details

  • dta_custom_field_names

  • dta_MIME_data

次の図は、追跡データベースのデータベース スキーマ全体を示しています。わかりやすいように、この図ではテーブル名だけを表示します。テーブル間をつなぐ線は、外部キー フィールドでテーブルがどのように接続しているかを示しています。これらのキー フィールド、およびそれらとほかのテーブルとの関係については、「メタデータ コア テーブルの構造」および「セカンダリ テーブルの構造」を参照してください。

追跡データベース スキーマ

dta_group_details
dta_indoc_details
(コア テーブル)
dta_document_data
dta_routing_details
dta_custom_field_names
dta_outdoc_details
(コア テーブル)
dta_interchange_details
(コア テーブル)
dta_interchange_data
dta_debugdoc_data

ここには次のトピックが含まれます。

  • メタデータ コア テーブル

  • セカンダリ テーブル

  • メタデータ コア テーブルの構造

  • セカンダリ テーブルの構造

  • 関連テーブル

  • インターチェンジとドキュメントをログに記録する方法

  • 受信確認をログに記録する方法

  • ルーティング情報をログに記録する方法

  • 追跡データベースでの XLANG スケジュール イベントの追跡


メタデータ コア テーブル

コア テーブルには、BizTalk Server で処理されるインターチェンジのメタデータが格納されます。メタデータには、送信元組織および送信先組織の情報、ドキュメント型、インターチェンジの処理日時、ドキュメント数、エラー情報、コントロール ID などが含まれます。

追跡データベースのメタデータの核を形成するテーブルは、次の 3 つです。

  • dta_indoc_details

  • dta_outdoc_details

  • dta_interchange_details

次の表は、これらのコア テーブルそれぞれの機能を示しています。

テーブル名 | 説明
dta_indoc_details | BizTalk Server に送信されるドキュメントごとにレコードを 1 つ作成します。
dta_outdoc_details | BizTalk Server で生成されるドキュメントごとにレコードを 1 つ作成します。BizTalk Server に送信されるドキュメント 1 つから、1 つまたは複数のドキュメントが生成され、それぞれの送信先に配信されることもあります。複数のチャネルやメッセージ ポート グループに送り先が該当することがあるためです。受信ドキュメントと送信ドキュメントを 2 つのテーブルに区別することにより、この 1 対他の関係を物理的に表現することができます。
dta_interchange_details | BizTalk Server で処理されるインターチェンジごとにレコードを 1 つ作成します。このテーブルの方向フラグにより、送信の方向が区別されます。

関連項目

メタデータ コア テーブルの構造


セカンダリ テーブル

メタデータ コア テーブルをサポートするセカンダリ テーブルは、次の 7 つです。

  • dta_document_data

  • dta_debugdoc_data

  • dta_interchange_data

  • dta_routing_details

  • dta_group_details

  • dta_custom_field_names

  • dta_MIME_data

これらのテーブルには、ドキュメント データ、ルーティング情報、カスタム検索情報などのサポート情報が格納されます。次の表は、これらのテーブルそれぞれの機能を示しています。

テーブル名 | 説明
dta_document_data | BizTalk Server で送受信されるドキュメントごとにレコードを 1 つ作成します。
dta_debugdoc_data | 中間 XML 形式を記録するためにメッセージ チャネル オブジェクトに構成される受信ドキュメントまたは送信ドキュメントの項目ごとに、行を 1 つ作成します。
dta_interchange_data | BizTalk Server で送受信されるインターチェンジごとに行を 1 つ作成します。このテーブルにも、呼び出し側アプリケーション IInterchange::SubmitSync に返される応答ドキュメントが格納されます。
dta_routing_details | BizTalk メッセージ管理データベースにおけるデータベースの相互依存をなくすために、メッセージ ポートのミラーとして機能します。特に、処理するドキュメントに関連する送信元と送信先の情報を追跡するために必要です。BizTalk メッセージ管理データベースからのこの情報は、新しい置き換えが検出されるたびに、ここで繰り返し処理されます。
dta_group_details | インターチェンジ内で同じ型のドキュメント グループ (ANSI X12 や EDIFACTなど) を用いるドキュメント形式に、拡張コンポーネント (パーサー、シリアライザ、および受信確認関連付けコンポーネント) を提供します。このテーブルには、これらのコンポーネントによって解析またはシリアライズされたグループごとに、行を 1 つ作成します。
dta_custom_field_names | BizTalk Server で検出された、それぞれの追跡ログ対象フィールド ノード名とデータ型の組ごとに行を 1 つ作成します。このテーブルは dta_outdoc_details テーブルのための、外部キーに対するフィールド名取得用クロス リファレンスです。dta_indoc_details テーブルへは、dta_outdoc_details テーブルを経由し、dta_outdoc_details テーブルに対応する、dta_indoc_details テーブル内の親レコードをポイントする外部キーによって、このテーブル (data_custom_field_names) のフィールド名が間接的に関連付けられています。
dta_MIME_data | BizTalk Server に送信される MIME エンコード インターチェンジごとに行を 1 つ作成します。このテーブルは、添付ドキュメントを含む MIME データを追跡する方法を提供するものです。

関連項目

セカンダリ テーブルの構造


メタデータ コア テーブルの構造

メタデータ コア テーブルは相互にリンクし、追跡設定が構成されている場合、BizTalk Server で処理するすべてのインターチェンジのメタデータを格納します。サーバー グループの追跡設定を構成する方法については、「サーバー グループの追跡設定について」を参照してください。

dta_indoc_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_outdoc_details

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_group_details

  • dta_interchange_details

  • dta_error_message

  • dta_validity_values

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_debugdoc_data

  • dta_document_data

  • dta_error_message

dta_indoc_details テーブルには、BizTalk Server に送信されたドキュメントごとに、行が 1 つ作成されます。次の表は、dta_indoc_details テーブルのフィールドを示しています。

フィールド名 | 説明
nInDocKey | プライマリ キー、一意なレコード識別子です。
nDocumentDataKey | dta_document_data への外部キーです。
nDebugDocDataKey | 受信ドキュメントの XML 形式の dta_debugdoc_data への外部キーです。受信ドキュメントが XML である場合も例外ではありません。
nGroupKey | dta_group_details への外部キーです。
nInterchangeKey | dta_interchange_details への外部キーです。
uidTrackingGUID | グローバル一意識別子 (GUID) に基づいたマスタ トラッキング キーです。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 構文のバージョンです。
nvcRelease | バージョンのリリースです。
nvcDocType | ドキュメント型またはトランザクション セット識別子です。
nvcControlID | 電子データ交換 (EDI) ドキュメントとファンクショナル グループの一意な制御番号です。
nlsValid | 検証結果を示すコードです。値は、0 (無効)、1 (有効)、または 2 (パススルー) のいずれかです。
nError | エラーの発生を示すコードです。これは dta_error_message テーブルへの外部キーで、このテーブルにエラー メッセージの説明が含まれます。

dta_outdoc_details

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_indoc_details

  • dta_interchange_details

  • dta_group_details

  • dta_debugdoc_data

  • dta_routing_details

  • dta_error_message

  • dta_ack_status

  • dta_data_level_values

  • dta_validity_values

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_document_data

  • dta_error_message

このテーブルは、次のテーブルと多対多の関係を持っています。

  • dta_custom_field_names

  • dta_ack_status_values

dta_outdoc_details テーブルには、BizTalk Server によって送信されたドキュメントごとに、行が 1 つ作成されます。次の表は、dta_outdoc_details テーブルのフィールドを示しています。

フィールド名 | 説明
nOutDocKey | プライマリ キー、一意なレコード識別子です。
nInDocKey | dta_indoc_details 親レコードへの外部キーです。
nDocumentDataKey | dta_document_data テーブルへの外部キーです。
nDebugDocDataKey | 送信ドキュメントの XML 形式の dta_debugdoc_data への外部キーです。送信ドキュメントが XML である場合も例外ではありません。送信ドキュメントがメッセージ ポート グループに送信される場合は、dta_debugdoc_data レコードのコピーが 1 つだけ格納されます。結果として得られる dta_outdoc_details レコードはすべて、それをポイントします。
nGroupKey | dta_group_details テーブルへの外部キーです。
nInterchangeKey | dta_interchange_details テーブルへの外部キーです。
uidTrackingGUID | グローバル一意識別子 (GUID) に基づいたマスタ トラッキング キーです。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 構文のバージョンです。
nvcRelease | バージョンのリリースです。
nvcDocType | ドキュメント型またはトランザクション セット識別子です。
nvcControlID | EDI ドキュメントおよびファンクショナル グループの一意な制御番号です。
nlsValid | 検証結果を示すコードです。値は、0 (無効)、1 (有効)、または 2 (パススルー) のいずれかです。
nError | エラーの発生を示すコードです。これは dta_error_message テーブルへの外部キーで、このテーブルにエラー メッセージの説明が含まれます。
nAckStatus | 受信確認状況のコードです。これは dta_ack_status_values テーブルへの外部キーで、このテーブルに受信確認状況の説明が含まれます。
nRoutingKey | dta_routing_details への外部キーです。
nReceiptFlag | どのテーブルに受信確認が関連付けられているかを示すフラグです。値は、1 (インターチェンジ)、2 (グループ)、4 (受信ドキュメント)、8 (送信ドキュメント) のいずれかです。受信確認の詳細については、「受信確認をログに記録する方法」を参照してください。
nReceiptKey | 受信確認を示す一意な番号です。受信確認の詳細については、「受信確認をログに記録する方法」を参照してください。
ntReceiptDueBy | 受信確認の最終期限のタイムスタンプで、処理タイムスタンプとして算出されます。
nRealName1 | dta_custom_field_names への外部キーです。
rlRealValue1 | 実数の追跡ログ対象フィールド 1 です。このフィールドの値は 8 バイトの実数である必要があります。
nRealName2 | dta_custom_field_names への外部キーです。
rlRealValue2 | 実数の追跡ログ対象フィールド 2 です。このフィールドの値は 8 バイトの実数である必要があります。
nIntName1 | dta_custom_field_names への外部キーです。
nIntValue1 | 整数の追跡ログ対象フィールド 1 です。
nIntName2 | dta_custom_field_names への外部キーです。
nIntValue2 | 整数の追跡ログ対象フィールド 2 です。
nDateName1 | dta_custom_field_names への外部キーです。
dtDateValue1 | 日付型の追跡ログ対象フィールド 1 です。
nDateName2 | dta_custom_field_names への外部キーです。
dtDateValue2 | 日付型の追跡ログ対象フィールド 2 です。
nStrName1 | dta_custom_field_names への外部キーです。
nvcStrValue1 | 文字列型の追跡ログ対象フィールド 1 です。
nStrName2 | dta_custom_field_names への外部キーです。
nvcStrValue2 | 文字列型の追跡ログ対象フィールド 2 です。
nvcCustomSearch | XML としての連結文字列型の取得対象の Binary Large Object です。

dta_interchange_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_indoc_details

  • dta_outdoc_details

  • dta_group_details

  • dta_interchange_data

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_direction_values

  • dta_error_message

  • dta_transport_type_values

dta_interchange_details テーブルには、BizTalk Server で処理されたインターチェンジごとに、行が 1 つ作成されます。次の表は、dta_interchange_details テーブルのフィールドを示しています。

フィールド名 | 説明
nInterchangeKey | プライマリ キー、一意なレコード識別子です。
nInterchangeDataKey | dta_interchange_data への外部キーです。
nResponseDocDataKey | 送信トランスポートの受信者によって返される応答ドキュメントの dta_document_data への外部キーです。
uidInterchangeGUID | インターチェンジのグローバル一意識別子 (GUID) です。
uidSubmissionGUID | 親送信のグローバル一意識別子 (GUID) です。ここでは、BizTalk オーケストレーション サービスによって提供される、またはそれに対して付与される関連付け識別子 (correlationID) が保持されます。レコードが BizTalk オーケストレーション サービスによらない受信インターチェンジのものである場合は、このフィールドは空です。受信インターチェンジに対して、このフィールドには、BizTalk オーケストレーション サービスからインターチェンジが送信される場合のみ、値が格納されます。送信インターチェンジに対しては、このフィールドには常に値が格納されます。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 構文のバージョンです。
nvcControlID | 電子データ交換 (EDI) インターチェンジの一意な制御番号、または BizTalk の信頼できるメッセージの識別子です。
nDirection | インターチェンジが受信か送信かを示すフラグです。値は 0 (送信) または 1 (受信) のいずれかです。これは dta_direction_values テーブルへの外部キーで、このテーブルに方向を表す値が含まれます。
dtTimeSent | 正常に行われた送信のタイムスタンプです。
nError | エラーの発生を示すコードです。これは dta_error_message テーブルへの外部キーで、このテーブルにエラー メッセージの説明が含まれます。
nTestMode | テストか本番運用かを示します。このフィールドは予備で、使用されていません。
nvcSrcAliasQualifer | 送信インターチェンジから抽出される送信者修飾子の値です。
nvcSrcAliasId | 送信インターチェンジから抽出される送信者識別子の値です。
nvcSrcAppName | 送信インターチェンジから抽出される送信元アプリケーション用のインターチェンジ レベル識別子です。
nvcDestAliasQualifier | 送信インターチェンジから抽出される受信者修飾子です。
nvcDestAliasID | 送信インターチェンジから抽出される受信者識別子の値です。
nvcDestAppName | 送信インターチェンジから抽出される送信先アプリケーション用のインターチェンジ レベル識別子です。
nAckStatus | 受信確認状況のコードです。これは dta_ack_status_values テーブルへの外部キーで、このテーブルに受信確認状況の説明が含まれます。
nvcSMTPMessageID | SMTP トランスポート メッセージ識別子 (EDIINT 用) です。このフィールドは予備で、使用されていません。
nDocumentsAccepted | インターチェンジが受けたドキュメントの数です。
nDocumentsRejected | インターチェンジが拒絶したドキュメントの数です。
nTransportType | 転送プロトコル識別コードです。これは dta_transport_type_values への外部キーです。
nvcTransportAddress | トランスポート先のアドレスです。
nvcServerName | インターチェンジを処理したサーバーです。
nNumberOfBytes | バイト単位で表したインターチェンジのサイズです。このフィールドでは、関連する dta_interchange_data レコードでの追跡対象を表します。実際に送信されるものと異なる場合があります。サイズは、送信中に行われる追加のエンベロープ処理や書式変換により、増える場合があります。
nNumOfTransmitAttempts | 送信の試行回数カウンタです。

関連項目

サーバー グループの追跡設定について


セカンダリ テーブルの構造

セカンダリ テーブルは、追跡データベースのコア テーブルのサポート データを格納します。セカンダリ テーブルで格納する情報には、次のようなものがあります。

  • カスタム フィールド検索データ

  • ルーティング情報

  • インターチェンジ データ

  • ドキュメント データ

dta_document_data

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_indoc_details

  • dta_outdoc_details

dta_document_data テーブルは、ドキュメント格納領域のための中心的なリポジトリです。次の表は、dta_document_data テーブルのフィールドを示しています。

フィールド名 | 説明
nDocumentDataKey | プライマリ キー、一意なレコード識別子です。
nCodePage | 文字コードにエンコードされた格納データのシステム コード ページ (1200-Unicode、65001-UTF-8 など) です。データに関するコード ページ情報が BizTalk Server にない場合は、このフィールドの値は -1 になります。この場合、nBLOBType フィールドの値によって、データの解釈方法に関する情報を得られることがあります。
nBLOBType | imgDocumentData フィールドに格納されているデータ型を示すフラグです。値は 0 (不明) または 1 (XMLDOM 読み込み可能) のいずれかです。XMLDOM 読み込み可能である場合、MSXML DOMDocument オブジェクトへの読み込み、それによる操作が可能なデータであることを示します。このフィールドは、dta_blobtype_values への外部キーです。
imgDocumentData | ドキュメントの格納領域で、Binary Large Object です。
nNumberOfBytes | バイト単位で表したドキュメントのサイズです。
nNumberOfRecords | ドキュメントに含まれるレコードまたはセグメントです。

dta_debugdoc_data

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_indoc_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_outdoc_details

このテーブルは、デバッグ ドキュメント格納領域のための中心的なリポジトリです。次の表は、dta_debugdoc_data テーブルのフィールドを示しています。

フィールド名 | 説明
nDebugDocDataKey | プライマリ キー、一意なレコード識別子です。
ntxtDocumentData | ドキュメントの格納領域で、Binary Large Object です。常に Unicode です。
nNumberOfBytes | バイト単位で表したドキュメントのサイズです。
dtProcessedTimeStamp | レコードが作成された時刻です。BizTalk Server をインストールしたディレクトリの \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SQLServerAgentJobs\DTA_SampleJobs.sql にある削除ジョブ サンプル (dtaJob_purge_database) の中で使用されています。

dta_interchange_data

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_interchange_details

dta_interchange_data テーブルは、インターチェンジ格納領域のための中心的なリポジトリで、ここには、システムで処理されたインターチェンジごとに、レコードが 1 つ作成されます。BizTalk Server に送信されるインターチェンジについてのみ、nlsFile フィールドでは、格納されているデータがもともとファイル システムから受信したものかどうかを示します。フラグが設定されている場合、nvcOriginalFileName フィールドには、データがもともと存在していたファイル システムの場所への Universal Naming Convention (UNC) パスが格納されます。imgInterchangeData フィールドには、その元の場所に関係なく、送信されたデータが保持されます。

フィールド名 | 説明
nInterchangeDataKey | プライマリ キー、一意なレコード識別子です。
nCodePage | 文字コードにエンコードされた格納データのシステム コード ページ (1200-Unicode、65001-UTF-8 など) です。データに関するコード ページ情報が BizTalk Server にない場合、またはデータがパススルー送信の結果として追跡される場合は、このフィールドの値は -1 になります。この場合、nBLOBType フィールドの値によって、データの解釈方法に関する情報を得られることがあります。
nlsFile | ファイルをベースとしたデータ送信を示すフラグです。値は 0 (非ファイル ベース) または 1 (ファイル ベース) のいずれかです。
nvcOriginalFileName | nlsFile フィールドの値が 1 である場合は、ファイルへの Universal naming convention (UNC) パスです。
nBLOBType | imgDocumentData フィールドに格納されているデータ型を示すフラグです。値は 0 (不明) または 1 (XMLDOM 読み込み可能) のいずれかです。XMLDOM 読み込み可能である場合、MSXML DOMDocument オブジェクトへの読み込み、それによる操作が可能なデータであることを示します。このフィールドは、dta_blobtype_values への外部キーです。
imgInterchangeData | インターチェンジの格納領域で、Binary Large Object です。

dta_group_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_indoc_details

  • dta_outdoc_details

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_interchange_details

  • dta_direction_values

dta_groug_details テーブルには、電子データ交換 (EDI) 用の拡張コンポーネントで処理されたグループごとに、行が 1 つ作成されます。次の表は、dta_group_details テーブルのフィールドを示しています。

フィールド名 | 説明
nGroupKey | プライマリ キー、一意なレコード識別子です。
nInterchangeKey | dta_interchange_details への外部キーです。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 標準のバージョンです。
nvcRelease | バージョンのリリースです。
nvcFunctionalGroupID | グループのドキュメント型のコードです。
nvcControlID | 電子データ交換 (EDI) ドキュメントとファンクショナル グループの一意な制御番号です。
nvcSrcAppName | 送信元アプリケーションのグループ レベル識別子です。
nvcDestAppName | 送信先アプリケーションのグループ レベル識別子です。
nAckStatus | 受信確認状況のコードです。これは dta_ack_status_values テーブルへの外部キーで、このテーブルに受信確認状況の説明が含まれます。
nDirection | グループが受信か送信かを示すフラグです。値は 0 (送信) または 1 (受信) のいずれかです。これは dta_direction_values への外部キーです。
nDocumentsAccepted | グループが受けたトランザクションの数です。
nDocumentsRejected | グループが拒絶したトランザクションの数です。
nNumberOfBytes | バイト単位で表したインターチェンジのサイズです。

dta_routing_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_outdoc_details

dta_routing_details テーブルには、異なる送信元または送信先の情報の組ごとに、行が 1 つ作成されます。組織またはアプリケーションのレベルで、2 つのドキュメントのルーティング フィールドに同じ値が含まれている場合があります。この場合、これらのドキュメントは、ドキュメント型またはより下位のレベルのフィルタによって区別されます。このような場合、dta_routing_details テーブルに含まれる行は、それぞれの親メッセージ ポート以外は同じ値を持っています。この親メッセージ ポートへのリンクは、BizTalk メッセージ マネージャのユーザー インターフェイス機能と追跡機能との接続のために使用されます。次の表は、dta_routing_details テーブルのフィールドを示しています。

フィールド名 | 説明
nRoutingKey | プライマリ キー、一意なレコード識別子です。
nvcSrcOrgName | 送信元組織の名前です。親チャネル オブジェクトで指定されています。
nvcSrcAppName | 送信元アプリケーションの名前です。親チャネル オブジェクトで指定されています。
nvcDestOrgName | 送信先組織の名前です。親メッセージ ポート オブジェクトで指定されています。
nvcDestAppName | 送信先アプリケーションの名前です。親メッセージ ポート オブジェクトで指定されています。
nvcDistributionName | 同報リストの名前です。
uidChannelGUID | グローバル一意識別子 (GUID) に基づいた親チャネルの一意なキーです。BizTalk メッセージ管理データベースに対するチャネル関連付けキーとして使用されます。
uidPortGUID | グローバル一意識別子 (GUID) に基づいた親メッセージ ポートの一意なキーです。BizTalk メッセージ管理データベースに対するメッセージ ポート関連付けキーです。

dta_custom_field_names

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_outdoc_details

dta_custom_field_names テーブルには、取得されたノード名とデータ型の異なる組ごとに、行が 1 つ作成されます。次の表は、dta_custom_field_names テーブルのフィールドを示しています。

フィールド名 | 説明
nNameKey | プライマリ キー、一意なレコード識別子です。
nvcName | ノード名のテキストです。たとえば、/CommonPO/Total/@POTotal です。
nDataType | ノード名に含まれるデータ型です。

dta_MIME_data

dta_MIME_data テーブルには、BizTalk Server で処理された受信 MIME データが格納されます。このテーブルは、添付ドキュメントを含む MIME データを追跡する方法を提供するものです。次の表は、dta_MIME_data テーブルのフィールドを示しています。

フィールド名 | 説明
nMIMEDataKey | プライマリ キー、一意なレコード識別子です。
uidSubmissionGUID | 親送信のグローバル一意識別子 (GUID) です。
nCodePage | imgMIMEData フィールド内の、文字コードにエンコードされた格納データのシステム コード ページです。MIME データの場合、値は 1252 (ASCII) または 1200 (Unicode) のいずれかです。
imgMIMEData | ドキュメントの格納領域で、Binary Large Object です。


関連テーブル

追跡データベースには、さらに 13 のテーブルがあり、コア テーブルやセカンダリ テーブルをサポートしています。これらのテーブルには、グループやインターチェンジの関連付けキー、受信確認状況の値、データ レベルの値などの情報が格納されます。次の表は、それぞれのテーブルとその機能を示しています。

テーブル名 | 用途
dta_ack_status_values | 受信確認状況の値を格納します。値は、"なし"、"待ち"、"返信期限切れ"、"受信済"、"受信済 (エラー)"、"受信拒否" のいずれかです。
dta_blobtype_values | Binary Large Object の種類を格納します。値は 0 (不明) または 1 (読み込み可能 XMLDOM) のいずれかです。
dta_data_level_values | BizTalk Server で使用されるデータ レベルの値を格納します。値は、"インターチェンジ"、"グループ"、"受信ドキュメント"、"送信ドキュメント" のいずれかです。
dta_direction_values | インターチェンジの方向の情報を格納します。値は、"受信" または "送信" のいずれかです。
dta_error_message | BizTalk ドキュメント トラッキングで使用されるエラー メッセージを格納します。値は、"エラーなし"、"カスタム コンポーネントを呼び出すことができませんでした。"、"インターチェンジを解析できませんでした。"、"指定されたチャネルは存在しません。"、"インターチェンジをシリアライズできませんでした。"、"インターチェンジをエンコードできませんでした。"、"インターチェンジに署名できませんでした。"、"インターチェンジを暗号化できませんでした。"、"送信の試行に失敗しました (再試行は待ち状態)。"、"前回の送信試行は失敗しました。"、"ドキュメントを解析できませんでした。"、"ドキュメントを検証できませんでした。"、"有効なチャネルが見つかりませんでした。"、"ドキュメントをマッピングできませんでした。"、"有効なメッセージ ポートが見つかりませんでした。"、"ドキュメントをシリアライズできませんでした。" のいずれかです。
dta_group_correlation_keys | グループの関連付けキーを格納します。受信確認の関連付けのときに、対象のグループを示す値が動的に生成されます。
dta_interchange_correlation_keys | インターチェンジの関連付けキーを格納します。受信確認の関連付けのときに、対象のグループを示す一意な値が動的に生成されます。
dta_transport_type_values | トランスポートの種類の値を格納します。値は、"なし"、"HTTP"、"SMTP"、"DCOM"、"アプリケーション統合"、"メッセージ キュー"、"ファイル"、"HTTPS"、"オープンな送信先"、"ループバック"、"オーケストレーション アクティベーション" のいずれかです。
dta_ui_codepage_charset | 文字コードにエンコードされたデータのシステム コード ページを格納します。
dta_ui_user_queries | 個々のユーザーが作成して保存した高度なクエリを格納します。
dta_validity_values | 検証結果の値を格納します。値は、"無効"、"有効"、"パススルー" のいずれかです。 パススルーの値が返された場合は、ドキュメントが解析されず、検証が行われなかったことを示します。パススルーの詳細については、「受信機能の詳細プロパティについて」を参照してください。
dta_wf_EventData | XLANG スケジュールによって発生する監視対象の COM+ イベントに関連してログに記録されるプロパティごとに、レコードを 1 つ格納します。このテーブルの複数の行のセットで、dta_wf_WorkFlowEvent テーブル中の共通の親を共有しています。
dta_wf_WorkFlowEvent | XLANG スケジュールによって発生する監視対象の COM+ イベントごとに、レコードを 1 つ格納します。


インターチェンジとドキュメントをログに記録する方法

オープンな送信元、オープンな送信先、パススルーなど、処理シナリオが違うと、追跡データベースのログに記録される方法はそれぞれ異なります。共通の処理シナリオは、"非オープン"、"オープンな送信元"、"オープンな送信先"、"ループバック"、"パススルー" および "受信確認を要求し、受信確認を生成する" の 6 つです ("受信確認を要求する" と "受信確認を生成する" は 1 つのシナリオと見なされています)。"受信確認を要求する" と "受信確認を生成する" のシナリオについては、「受信確認をログに記録する方法」を参照してください。次の表は、そのほかの処理シナリオについて説明しています。

処理シナリオ | 説明
非オープン | 送信元と送信先の両方が受信機能、ドキュメント インスタンス、Submit メソッド、または SubmitSync メソッドで明示的に宣言されている場合に発生します。
オープンな送信元 | 送信元情報がチャネルで明示的に定義されていない場合に発生します。チャネルはオープンな送信元として設定されている必要があります。また、送信呼び出しや受信機能で、送信元のオープンネスを指定する必要があります。
オープンな送信先 | 送信先情報がメッセージ ポートで明示的に定義されていない場合に発生します。送信先はドキュメント インスタンス、Submit メソッド、または SubmitSync メソッドで動的に指定されます。メッセージ ポートはオープンな送信先として設定されている必要があります。また、送信呼び出しや受信機能で、送信先のオープンネスを示す必要があります。
ループバック | メッセージ ポートで指定されているトランスポートがループバックである場合に発生します。ループバックは、SubmitSync メソッドを使用して受信ドキュメントを送信したビジネス アプリケーション、コンポーネント、または XLANG スケジュールに、チャネルの送信ドキュメントを返します。このトランスポートは、アプリケーションに接続されているメッセージ ポートで、SubmitSync メソッドを用いる場合にのみ使用できます。
パススルー | 受信機能で [パススルー フラグを付けて送信する] オプションを選択するか、Submit メソッドや SubmitSync メソッドでパススルーのプロパティを構成する場合に発生します。BizTalk Server はドキュメントを処理しません。たとえば、ドキュメントの解析、署名、解読、検証は行われません。ドキュメントは BizTalk Server で伝送のみ行われます。

次の表は、追跡データベースのログに記録される送信レコードを示しています。

処理シナリオ | dta_interchange_details (送信) | dta_outdoc_details | 応答ドキュメント
非オープン | ○ | ○ | ○
オープンな送信元 | ○ | ○ | ○
オープンな送信先 | ○ | ○ | ○
ループバック | ○ | ○ |
パススルー | ○ | ○ | ○

注

  • 応答ドキュメントが生成されるのは、HTTP、HTTPS、AIC のトランスポートを使用したときのみです。また、受信者には、返信されたデータを送信する必要があります。

  • パススルー シナリオの場合、dta_outdoc_details テーブルのログに記録されるレコードは、空のレコードです。nlsValid フィールドの値は 2 で、このレコードはパススルー ドキュメントに関連付けられています。nSyntax フィールドの値は "UNKNOWN" です。BizTalk Server ではドキュメントを処理しないため、このテーブルのフィールドのほとんどに、関連するデータを格納できません。

次の表は、追跡データベースのログに記録される受信レコードを示しています。

処理シナリオ | dta_interchange_details (受信) | dta_indoc_details | 応答ドキュメント
非オープン | ○ | ○ | ○
オープンな送信元 | ○ | ○ | ○
オープンな送信先 | ○ | ○ | ○
ループバック | ○ | ○ |
パススルー | ○ | ○ | ○

注

  • 応答ドキュメントが生成されるのは、HTTP、HTTPS、AIC のトランスポートを使用したときのみです。また、受信者には、返信されたデータを送信する必要があります。

  • パススルー シナリオの場合、dta_indoc_details テーブルのログに記録されるレコードは、空のレコードです。nlsValid フィールドの値は 2 で、このレコードはパススルー ドキュメントに関連付けられています。nSyntax フィールドの値は "UNKNOWN" です。BizTalk Server ではドキュメントを処理しないため、このテーブルのフィールドのほとんどに、関連するデータを格納できません。

関連項目

受信確認をログに記録する方法


受信確認をログに記録する方法

次の図は、BizTalk Server での受信確認フローを示しています。

受信確認の生成と送信
受信確認の受信と照合
インターチェンジの受信と処理
送信先のシステム
送信元のシステム
送信先のシステムへの
メッセージ ポート
注文書
パーサー
送信元の
システムへの
メッセージ
ポート
送信
ドキュメント定義
受信確認
ドキュメント仕様
ドキュメント仕様
受信
ドキュメント定義
マップ
受信確認チャネル
既定受信
アプリケーションへの
メッセージ ポート
送信元のシステムからの
チャネル
ドキュメント
仕様
受信確認の
ドキュメント定義
注文書のチャネル
インターチェンジの生成と送信

このシナリオの状況は次のとおりです。

  • 送信元システムおよび送信先システムでは、Microsoft BizTalk Server 2000 を使用しています。

  • 送信元システムは、送信先システムに注文を送信し、その注文に対する受信確認が返されます。

  • どちらのシステムも、受信確認を要求し、生成するように構成されています。

注文が送信元システムで処理され、送信先システムに送信されると、1 つのレコードが dta_outdoc_details テーブルのログに記録されます。次の表は、そのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 1 | レコードを示す一意な番号です。
nAckStatus | 1 | ドキュメントの受信確認が待ち状態であることを示します。
nReceiptFlag |  | 現時点では値が格納されていません。
nReceiptKey |  | 現時点では値が格納されていません。

送信先システムが注文を受信し、処理すると、1 つのレコードが dta_indoc_details テーブルのログに記録され、2 つのレコードが dta_outdoc_details テーブルのログに記録されます。dta_indoc_details テーブルのレコードは注文に関連する情報を記録します。dta_outdoc_details テーブルの 1 番目のレコードは注文に関連する情報を記録し、2 番目のレコードは注文に対する受信確認に関連する情報を記録します。

次の表は、dta_indoc_details テーブルのレコードの注文に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nInDocKey | 1 | レコードを示す一意な番号です。
nDocType | CommonPO | 受信ドキュメントの型を示します。

dta_outdoc_details テーブルのログに記録される 1 番目のレコードは、BizTalk Server で処理される注文に関連するものです。次の表は、そのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 10 | レコードを示す一意な番号です。
nInDocKey | 1 | レコードを dta_indoc_details テーブルの親レコードにリンクします。

dta_outdoc_details テーブルのログに記録される 2 番目のレコードは、注文によって生成される受信確認に関連するものです。次の表は、そのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 2 | レコードを示す一意な番号です。
nInDocKey | 1 | レコードを dta_indoc_details テーブルの親レコードにリンクします。
nAckStatus | 0 | 受信確認が返されることは要求されていません。
nReceiptFlag | 4 | 受信確認が dta_indoc_details テーブルのレコードに関連付けられていることを示します。
nReceiptKey | 1 | 受信確認レコードを示す一意な番号です。

送信元システムが、送信先システムによって生成された受信確認を受信し、レコードが dta_indoc_details テーブルのログに記録されると、dta_outdoc_details テーブルのログに記録された元のレコードが更新されます。次の表は、dta_indoc_details テーブルのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nInDocKey | 9 | レコードを示す一意な番号です。
nDocType | 997 | 受信ドキュメントの型を示します。

次の表は、dta_outdoc_details テーブルの更新されたレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 1 | レコードを示す一意な番号です。
nAckStatus | 3 | 受信確認が受信されたことを示します。
nReceiptFlag | 4 | 受信確認が dta_indoc_details テーブルのレコードに関連付けられていることを示します。
nReceiptKey | 9 | 受信確認レコードを示す一意な番号です。

関連項目

インターチェンジとドキュメントをログに記録する方法


ルーティング情報をログに記録する方法

追跡データベースのログに記録されるルーティング情報の内容は、ドキュメントが受信と送信のどちらであるか、または BizTalk Server でデータをどのように処理するかによって異なります。受信インターチェンジの場合、BizTalk Server はドキュメントを受信すると、ドキュメント インスタンスの中でルーティング情報を探します。次に BizTalk Server は、受信機能または IInterchange::Submit で指定されたルーティング パラメータを確認します。ルーティング情報が受信機能または IInterchange::Submit で検出された場合、これらのパラメータはドキュメント インスタンスをルーティングするために使用されます。ドキュメント インスタンスに格納されているルーティング情報は、追跡データベースの dta_routing_details テーブルのログに記録されます。

送信インターチェンジの場合、送信元と送信先のルーティング情報は常にチャネルから得て、dta_routing_details テーブルのログに記録されます。

これにより、BizTalk ドキュメント トラッキングのユーザー インターフェイスに、エイリアスに関するどんな情報が表示されるかが変わってきます。これは、どのように BizTalk Server で送信される複数のインターチェンジが単一データ フロー インスタンスとして相互に関連しているかには影響を与えません。


追跡データベースでの XLANG スケジュール イベントの追跡

BizTalk メッセージ サービスと BizTalk オーケストレーション サービスとの間で交換され、XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースのテーブルで追跡できます。このアクション イベントは、BizTalk ドキュメント トラッキングを使用して表示できます。ただし、XLANG スケジュールによって処理されるメッセージに関連するアクション イベントの追跡と表示の機能は、BizTalk Server 2000 をインストールしたときに自動的に有効になりません。この機能を有効にするには、次の操作を行います。

  1. サンプルのダイナミック リンク ライブラリ (.DLL) ファイル WorkFlowAudit.dll を登録します。

    このサンプル ファイルは \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\bin にあります。

  2. WorkFlowAuditClient.exe を実行し、WorkFlowAudit.dll をアクティブにします。

    このサンプル アプリケーションは \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient にあります。

    補足情報としてのドキュメント (Readme.txt) は、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\Docs にあります。

  3. WorkFlowAuditClient アプリケーションの [Start] ボタンをクリックして、追跡データベースの XLANG スケジュールに関連するアクション イベントのログを開始します。

重要

  • レコードが dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルのログに記録されるのは、WorkFlowAuditClient アプリケーションが起動している場合のみです。WorkFlowAuditClient アプリケーションを起動するには、ここで説明した 3 つの操作を完了している必要があります。WorkFlowAuditClient が停止している場合は、レコードは dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルのログに記録されません。

これらの操作を行うと、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスとの間で交換されるメッセージに対し、レコードが dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルのログに記録されます。dta_wf_EventData テーブルの nvcName フィールドのログに記録される値は、dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルと、追跡データベースのコア テーブルである dta_interchange_details テーブルとの間のリンクとして機能します。コア テーブルの詳細については、「メタデータ コア テーブルの構造」を参照してください。

BizTalk オーケストレーション サービスから BizTalk メッセージ サービスに送信されるメッセージ

BizTalk オーケストレーション デザイナでの BizTalk メッセージのポート実装を使用して BizTalk オーケストレーション サービスから BizTalk メッセージ サービスに送信されるメッセージはすべて、関連付け識別子 (correlationID) と呼ばれるグローバル一意識別子 (GUID) によって識別されます。メッセージが BizTalk オーケストレーション サービスから BizTalk メッセージ サービスに送信される場合、correlationID が dta_interchange_details テーブルの uidSubmissionGUID フィールドのログに記録されます。さらに、レコードが dta_wf_EventData テーブルと dta_wf_WorkFlowEvent テーブルのログに記録されます。これにより、BizTalk ドキュメント トラッキングを使用して、XLANG スケジュールで処理されるメッセージに関連するアクション イベントを表示することができます。

BizTalk メッセージ サービスから BizTalk オーケストレーション サービスに送信されるドキュメント

BizTalk メッセージ サービスに送信されるドキュメントはすべて、送信ハンドル (SubmissionHandle) と呼ばれるグローバル一意識別子によって識別されます。送信ハンドルの詳細については、「Submit メソッド」を参照してください。ドキュメントが BizTalk メッセージ サービスから BizTalk オーケストレーション サービスに送信される場合、dta_interchange_details テーブルの uidSubmissionGUID フィールドに送信ハンドルが記録されます。さらに、ドキュメントが BizTalk メッセージ サービスから BizTalk オーケストレーション サービスに送信されると、次の 2 つのイベントが発生します。

  • BizTalk オーケストレーション サービスに送信されるドキュメントの correlationID プロパティに、送信ハンドルが挿入されます。

  • レコードが、dta_wf_EventData テーブルと dta_wf_WorkFlowEvent テーブルのログに記録されます。ドキュメントが BizTalk メッセージ サービスから送信されるため、送信ハンドルは、dta_wf_EventData テーブルの nvcName フィールドの correlationID としてログに記録されます。

アクション イベントの表示

BizTalk ドキュメント トラッキングを使用して、XLANG スケジュールによって処理されるメッセージに関連するアクション イベントを表示するには、BizTalk ドキュメント トラッキングでクエリを作成してクエリ結果ページを表示します。そして、そのページ内にある XLANG スケジュールのアイコンをクリックします。クエリの作成方法と XLANG スケジュール イベントの表示方法の詳細については、「クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え」を参照してください。

dta_wf_EventData テーブル

次に示すテーブルには、XLANG スケジュールによって生成される監視対象の COM+ イベントに関連してログに記録されるプロパティごとに、レコードが 1 つ作成されます。このテーブルの複数の行のセットで、dta_wf_WorkFlowEvent テーブル中の共通の親を共有しています。

フィールド名 | 説明
nEventDataId | 自動的に加算される整数キー フィールドです。
nWorkFlowEventId | dta_wf_EventData テーブルの親イベント レコードへの外部キーです。
nvcName | 関連付け識別子 (correlationID) です。
nvcValue | 任意の値です。通常は、グローバル一意識別子 (GUID) に基づいています。

dta_wf_WorkFlowEvent テーブル

次のテーブルは dta_wf_EventData テーブルの親になっていて、このテーブルには、XLANG スケジュールによって生成される監査対象の COM+ イベントごとにレコードが 1 つ作成されます。

フィールド名 | 説明
nWorkFlowEventId | 自動的に加算される整数キー フィールドです。
nvcEventId | イベントの種類です。
nvcEventName | イベントの名前です。
nProcessId | 送信元イベントのプロセス識別子です。
nvcApplicationId | XLANG スケジュールの識別子です。
nvcInstanceId | スケジュールの特定のインスタンスの識別子です。
nEventTime | 1970 年 1 月 1 日の午前 0 時から経過した秒数で表した、イベントの世界標準時 (UTC) の時刻です。
nEventSubTime | ITime 引数に追加されるマイクロ秒単位の秒数です。時刻をマイクロ秒単位で算出するために使用します。
nEventTick | イベント発生時の高精度パフォーマンス カウンタの値です。
nvcServerName | イベントが検出されたサーバーです。
dtDateEntered | イベントの日付です。

関連項目

BizTalk サービスの統合

メタデータ コア テーブルの構造

Submit メソッド

インターチェンジ用の統合 XLANG スケジュール ステータスについて


インターチェンジとその関連ドキュメントの検索方法について

BizTalk ドキュメント トラッキングでは、クエリ パラメータを指定すると、すべてのインターチェンジとドキュメントを表示できます。検索結果を最大にし、サーバーの負荷を最小にするには、クエリとその使い方について理解することが重要です。パラメータをほとんど指定せずにクエリを作成した場合、返されるインターチェンジ レコードの数が大変多くなることがあります。この場合には、長い処理時間が必要となり、サーバーの処理能力にも負担がかかります。複数のユーザーが同時にデータベースにクエリを実行すると、状況は悪化します。

BizTalk Server には、2 レベルのクエリがあります。クエリと高度なクエリです。クエリには、クエリ結果の絞り込みに一般的に使用される条件を指定します。高度なクエリでは、特定データを検索するクエリ式を使用することにより、より詳細なクエリ結果を得ることができます。

ここには次のトピックが含まれます。

  • クエリについて

  • 高度なクエリについて


クエリについて

BizTalk ドキュメント トラッキングにある 3 つの標準クエリ パラメータは、日付の範囲とタイム ゾーン、送信元識別子と送信先識別子、およびドキュメント型です。この条件の 1 つまたは複数をクエリで指定して、インターチェンジとドキュメントのレコードを検索できます。たとえば、指定した日付の範囲にあるすべてのドキュメント型を検索することができます。または、特定のドキュメント型であり、かつ、選択した送信元組織および送信先組織と一致するインターチェンジとドキュメントを検索できます。

日付の範囲とタイム ゾーン

BizTalk ドキュメント トラッキングに一覧表示されている日時は、ドキュメントが BizTalk Server で処理されたときのものです。クエリに日付の範囲を指定しない場合、既定の日付の範囲は、現在の日付の 7 日前からとなります。[送信元の選択]、[送信先の選択]、および [ドキュメント型の選択] ボックスの一覧とは異なり、任意の日時のドキュメントを検索する場合に、日付の範囲を空白にすることはできません。BizTalk ドキュメント トラッキングでは、日時の範囲を必ず指定してください。

ローカル時刻と世界標準時 (UTC) のどちらで日時を表示するかを指定することもできます。インターチェンジとドキュメントは、ローカル時刻で表示する場合がほとんどです。ただし、取引先が異なるタイム ゾーンにある場合は、ドキュメントの送信または受信の日時を指定する共通の条件を作成するために、世界標準時を使用する必要があります。

送信元組織と送信先組織

インターチェンジとドキュメントは、送信元組織または送信先組織、あるいはその両方を基にして検索することができます。また、クエリを作成する場合、ドキュメントを 1 つまたは複数の組織、あるいはすべての組織でフィルタ処理をして取得することができます。組織に関連付けられているアプリケーションで作成されたインターチェンジとドキュメントを検索することもできます。たとえば、送信元組織 A の表計算アプリケーションが送信先組織 B のデータベース アプリケーションに対し、データを送信した場合、いつデータが送受信されたのかを特定することができます。

ドキュメント型

注文書または請求書など、特定のドキュメント型を持つインターチェンジやドキュメントを検索することができます。クエリでは、ドキュメント型の条件を送信元識別子や送信先識別子と組み合わせて、取引先との間で送受信したインターチェンジとドキュメントを検索できます。このようなクエリを使用すると、取引先との関係の分析に役立ちます。

並べ替えの指定

[クエリ結果] ページでの列の並べ替え順の指定方法には 6 通りあります。クエリの既定の並べ替え順は、次のとおりです。

  • 送信元組織名 : ドキュメントの送信元組織の名前です。

  • 送信元アプリケーション名 : ドキュメントが作成されたアプリケーションの名前です。

  • .送信先組織名 : ドキュメントの送信先組織の名前です。

  • 送信先アプリケーション名 : ドキュメントを送信する先のアプリケーションの名前です。

  • ドキュメント型 : ドキュメントの型です。

  • 処理時間 : BizTalk Server でドキュメントが処理された時刻です。

関連項目

高度なクエリについて


高度なクエリについて

クエリによって返されるインターチェンジとドキュメント レコードが多すぎる場合は、クエリ式を使用して検索を絞り込むことができます。[高度なクエリ] ダイアログ ボックスの [高度なクエリ ビルダ] で、新しいクエリ式の作成、または既に保存されているクエリ式の一覧の参照を行うことができます。このクエリ式は、クエリに追加した条件句の作成によって構成された SQL 文です。高度なクエリの作成に役立つオプションは、次のとおりです。

  • 送信元の選択 : 検索対象のフィールドの一覧です。BizTalk メッセージ マネージャでは、カスタム フィールドを追跡するためにチャネルやドキュメント定義を構成すると、これらのフィールドが [送信元の選択] ボックスの一覧に表示されるようになります。フィールドの追跡を行うように BizTalk メッセージ マネージャを構成していない場合は、[送信元の選択] ボックスの一覧には "<カスタム検索>" だけが表示されます。特定フィールドの追跡の詳細については、「ドキュメント ログのプロパティの設定」および「チャネル内の仕様フィールドの選択」を参照してください。

  • 演算子 : 利用可能な演算子の一覧です。たとえば、>、<、=、!=、[次のものが含まれています]、[次のものが含まれていません] があります。

  • 値 : このボックスに値を入力すると、高度なクエリの境界値を指定できます。

  • AND/OR : 検索条件の結合に使用するグループ化演算子 (AND と OR) を含む一覧です。

  • クエリ : 作成したクエリの一覧です。

  • 論理グループ : AND グループ演算子または OR グループ化演算子を使用して、作成済み検索条件を結合する場合の説明です。クエリに句を追加する場合、グループ化演算子に関する説明が、この [論理グループ] ボックスに表示されます。たとえば、[論理グループ] ボックスに、次のように表示される場合があります。

    1 AND 2 AND (3 OR 4)

    この例では、条件 1 および条件 2 が適用され、かつ、条件 3 または条件 4 が、条件 1 および条件 2 と結合されます。

注

  • 同じ名前のクエリを複数作成することができます。

関連項目

クエリについて


クエリ結果について

[クエリ結果] ページでは、クエリ結果はインターチェンジ レコードおよびドキュメント レコードの 2 つのレベルで構成されます。構成の最上位レベルにあるのがインターチェンジ レコードです。インターチェンジ レコードは、BizTalk Server 2000 で送受信したインターチェンジを表しています。インターチェンジ レコードは、ドキュメント インスタンス レコードの親レコードであり、ドキュメント インスタンス レコードを意味のある方法で構成するのに役立ちます。インターチェンジ レコードに含まれるフィールドの詳細については、「インターチェンジ レコードの結果について」を参照してください。インターチェンジ レコードはデータ フィールドの行の集合として表示され、各行の左には [展開記号 (+)] アイコンが表示されます。

[展開記号 (+)] アイコンをクリックすると、ドキュメント インスタンス レコードが表示されます。ドキュメント インスタンス レコードもまた、データ フィールドの行として表示されます。インターチェンジ レコードごとに、通常 1 つのドキュメント インスタンス レコードがあります。ただし、単一のインターチェンジで複数のドキュメント型が送信される場合は、インターチェンジで送信されたドキュメント型ごとに 1 つのドキュメント レコードがあります。ドキュメント インスタンス レコードに含まれるフィールドの詳細については、「ドキュメント インスタンス レコードの結果について」を参照してください。

ここには次のトピックが含まれます。

  • 追跡データベース スキーマの基本

  • インターチェンジ レコードの結果について

  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について

  • 送信の失敗の結果について


追跡データベース スキーマの基本

[クエリ結果] ページに表示される項目を理解するには、追跡データベース スキーマの基本を知っていることが重要です。追跡データベースには、BizTalk Server で処理されるインターチェンジおよびドキュメントごとに、メタデータ (送信元組織と送信先組織の識別子、日時、ドキュメント型など) を格納するコア テーブルが 3 つあります。このデータベース テーブルとは次の 3 つです。

  • dta_interchange_details

  • dta_indoc_details

  • dta_outdoc_details

dta_interchange_details

dta_interchange_details テーブルは、インターチェンジに関連したデータをすべて格納し、dta_indoc_details テーブルおよび dta_outdoc_details テーブルの親テーブルとなっています。BizTalk Server で処理されたインターチェンジごとに、テーブルに 1 つのレコードが格納されています。[クエリ結果] ページのインターチェンジ レコードのフィールドには、このテーブルのデータが表示されています。このテーブルのフィールドでは、インターチェンジが受信と送信のどちらであるかを示します。たとえば、インターチェンジを受信した場合、[クエリ結果] ページでは、受信インターチェンジ レコードとして表されます。インターチェンジを送信した場合は、[クエリ結果] ページには、送信インターチェンジ レコードとして表されます。dta_interchange_details テーブルの詳細については、「メタデータ コア テーブル」または「メタデータ コア テーブルの構造」を参照してください。

dta_indoc_details

dta_indoc_details テーブルには、BizTalk Server に送信された各ドキュメントのデータがすべて格納されています。このテーブルは、主キーによって dta_interchange_details テーブルにリンクされています。[クエリ結果] ページにある、受信インターチェンジ レコードに関連付けられているドキュメント インスタンス レコードのフィールドには、このテーブルのレコードが表示されています。たとえば、ドキュメントを送信する場合で、そのドキュメントの追跡情報を [クエリ結果] ページで表示するには、まず、該当する送信インターチェンジ レコードを検索します。次に、このレコードを展開すると、ドキュメント インスタンス レコードが表示されます。このドキュメント インスタンス レコードは dta_indoc_details テーブルに関連付けられており、追跡対象として構成したフィールドのデータがこのレコードに表示されます。dta_indoc_details テーブルの詳細については、「メタデータ コア テーブル」または「メタデータ コア テーブルの構造」を参照してください。

dta_outdoc_details

dta_outdoc_details テーブルには、BizTalk Server で生成された各ドキュメントのデータがすべて格納されています。dta_indoc_details テーブルの 1 つのレコードに対応する dta_outdoc_details テーブルのレコードが複数存在する場合があります。これは、単一の送信から複数のドキュメントの生成が可能なためです。たとえば、BizTalk Server に送信されたドキュメントが、10 メッセージ ポートで構成されている同報リストに送信されるような場合です。この場合、dta_indoc_details テーブルのログに 1 つのレコードが記録され、dta_outdoc_details テーブルのログには 10 個のレコードが記録されます。したがって、1 つの送信インターチェンジ レコードが、関連したドキュメント インスタンス レコードと共に [クエリ結果] ページに表示されます。ドキュメント インスタンス レコードのフィールドには、dta_outdoc_details テーブルのデータが表示されます。dta_outdoc_details テーブルの詳細については、「メタデータ コア テーブル」または「メタデータ コア テーブルの構造」を参照してください。

関連項目

インターチェンジとドキュメントをログに記録する方法

メタデータ コア テーブル

メタデータ コア テーブルの構造

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

受信確認の結果について

送信の失敗の結果について

追跡データベース スキーマについて


インターチェンジ レコードの結果について

指定したクエリ パラメータを基に、クエリ条件との一致が見つかると、1 つまたは複数のインターチェンジ レコードが返されます。1 つのインターチェンジ レコードでは、Microsoft BizTalk Server 2000 で送信または受信される 1 つのインターチェンジを表します。

次の表は、インターチェンジに格納されている情報の一覧です。

インターチェンジの列見出し | 説明
データ | インターチェンジ データをネイティブ形式で表示するためのリンクを示します。
スケジュール 利用できる場合は、個々のインターチェンジに対応する XLANG スケジュール ステータス情報へのリンクを示します。インターチェンジに関連付けられている XLANG スケジュール ステータス情報がない場合は、次のメッセージが表示されます。

このインターチェンジは、利用可能な XLANG スケジュール情報がありません。
方向 | インターチェンジを BizTalk Server に送られた (着信)、または BizTalk Server から送る (発信)、のどちらであるかを示します。
エラー ドキュメントに関連付けられたエラーがあるかどうかを示します。表示される可能性のあるメッセージは次のとおりです。
  • エラーなし

  • カスタム コンポーネントを呼び出すことができませんでした。

  • インターチェンジを解析できませんでした。

  • 指定されたチャネルは存在しません。

  • インターチェンジをシリアライズできませんでした。

  • インターチェンジをエンコードできませんでした。

  • インターチェンジに署名できませんでした。

  • インターチェンジを暗号化できませんでした。

  • 送信の試行に失敗しました (再試行は待ち状態)。

  • 前回の送信試行は失敗しました。

  • ドキュメントを解析できませんでした。

  • ドキュメントを検証できませんでした。

  • 有効なチャネルが見つかりませんでした。

  • ドキュメントをマッピングできませんでした。

  • 有効なメッセージ ポートが見つかりませんでした。

  • ドキュメントをシリアライズできませんでした。
送信元組織 | 送信元組織の名前を示します。
送信元アプリケーション | ドキュメントが作成されたアプリケーションの名前を示します。
送信先組織 | 送信先組織の名前を示します。
送信先アプリケーション | ドキュメントの送信先アプリケーションを示します。
ドキュメント型 | ドキュメントの型を示します。1 つのインターチェンジに複数のドキュメント型がある場合は、"<複数>" がこのフィールドに表示されます。
ドキュメント数 | インターチェンジ内のドキュメントの数を示します。
コントロール ID | 電子データ交換 (EDI) の一意な制御番号、または BizTalk の「信頼できるメッセージ」の識別子を示します。
受信確認状況 | 受信確認状況を示します。受信確認状況の値は、なし、待ち、返信期限切れ、受信済、受信済 (エラー)、または受信拒否のいずれかです。
処理時間 | インターチェンジが処理された時刻を示します。ドキュメント トラッキング レコードが作成されたときの時刻が設定されます。このフィールドは、いったん設定されると更新されません。
転送時間 | インターチェンジの送信が成功した場合に送信時刻を示します。送信が成功しなかった場合は、NULL になります。受信の場合は、このフィールドは常に NULL になります。
送信元 ID の修飾子 | 送信元組織の修飾子の種類を示します。BizTalk Server で内部的に使用される修飾子です。
送信元の識別子 | 送信元組織の識別子値を示します。データ内に示された識別子で、ドキュメントのルーティングに使用されます。送信元 ID の修飾子とは異なります。ルーティングの詳細については、「ルーティング情報をログに記録する方法」を参照してください。
送信先 ID の修飾子 | 送信先組織の修飾子の種類を示します。
送信元の識別子 | 送信先組織の識別子値を示します。ルーティングの詳細については、「ルーティング情報をログに記録する方法」を参照してください。

関連項目

追跡データベース スキーマの基本

ドキュメント インスタンス レコードの結果について

インターチェンジとその関連ドキュメントの検索方法について


ドキュメント インスタンス レコードの結果について

インターチェンジのドキュメント インスタンス レコードは、ドキュメント情報を示すフィールドの行として表示されます。

次の表は、ドキュメント インスタンス レコードの結果情報の一覧です。

ドキュメントの列見出し | 説明
データ | ドキュメント インスタンスにあるデータをネイティブ形式および XML 形式で表示するためのリンクを示します。
トラッキング ID | グローバル一意識別子 (GUID) に基づいたトラッキング キーを示します。
ドキュメント型 | ドキュメントの型を示します。1 つのインターチェンジに複数のドキュメントがある場合、このフィールドにドキュメント型が示されます。このフィールドに、複数のドキュメント型が示されることはありません。ほかにもドキュメント型がある場合は、別のドキュメント インスタンス レコードとして示されます。
コンプライアンス | ドキュメントが有効かどうかを示します。コンプライアンスの値は、有効か無効のいずれかです。
エラー ドキュメントに関連付けられたエラーがあるかどうかを示します。表示される可能性のあるメッセージは次のとおりです。
  • エラーなし

  • カスタム コンポーネントを呼び出すことができませんでした。

  • 指定されたチャネルは存在しません。

  • 送信の試行に失敗しました (再試行は待ち状態)。

  • 前回の送信試行は失敗しました。

  • ドキュメントを解析できませんでした。

  • ドキュメントを検証できませんでした。

  • 有効なチャネルが見つかりませんでした。

  • ドキュメントをマッピングできませんでした。

  • 有効なポートが見つかりませんでした。

  • ドキュメントをシリアライズできませんでした。
受信 | 受信確認情報へのリンクを示します。

次の表は、送信ドキュメントだけに適用されるフィールドの一覧です。

受信確認状況 | 受信確認状況を示します。受信確認状況の値は、なし、待ち、返信期限切れ、受信済、受信済 (エラー)、または受信拒否のいずれかです。
実数 1、実数 2 | ドキュメントの内容から実数として取得されたデータを示します。実数を示すフィールドは 2 つあります。
整数 1、整数 2 | ドキュメントの内容から整数値として取得されたデータを示します。整数を示すフィールドは 2 つあります。
日付 1、日付 2 | ドキュメントの内容から日付値として取得されたデータを示します。日付を示すフィールドは 2 つあります。
文字列 1、文字列 2 | ドキュメントの内容から文字列値として取得されたデータを示します。文字列を示すフィールドは 2 つあります。
カスタム検索 | 文字列値として取得された追加のデータを示します。このフィールドの制限値は 2 GB です。

注

  • 送信ドキュメントで追跡の対象とする情報を構成する方法については、「ドキュメント定義内の仕様フィールドの選択」または「チャネル内の仕様フィールドの選択」を参照してください。

  • ドキュメント定義で、整数、実数、文字列、日付、カスタム フィールドなどのフィールドをオプションとして構成し、これらのフィールドを追跡対象として構成しても、送信されたドキュメント インスタンスにこれらのフィールドがない場合は、これらのフィールドはクエリ結果に表示されません。BizTalk ドキュメント トラッキングでは、省略可能なフィールドにデータがないことを示すエラー メッセージや警告メッセージは表示されません。

  • ドキュメント インスタンスでは、次の条件が満たされる場合、1 は -1 として追跡されます。
    • BizTalk エディタで特定のフィールドの宣言のプロパティを設定するときに、データ型がブール型に設定されている。

    • BizTalk メッセージ構成オブジェクト モデルまたは BizTalk メッセージ マネージャで、追跡対象のフィールドが整数として選択されている。

関連項目

チャネルでの仕様フィールドの選択

ドキュメント定義内の仕様フィールドの選択

追跡データベース スキーマの基本

インターチェンジとその関連ドキュメントの検索方法について

インターチェンジ レコードの結果について


受信確認の結果について

次の図は、BizTalk ドキュメント トラッキングでの受信確認フローを示しています。図のドキュメント 1 は、BizTalk Server A で最初に処理され、受信確認を要求するフラグが設定されています (ドキュメント 1、受信確認要求フラグ設定)。次に、BizTalk Server B は受信機能を使用してこのドキュメントを受信し (ドキュメント 1、受信確認生成フラグ設定)、ドキュメントを処理して、受信確認を生成します [ドキュメント 1 の受信確認 (送信)]。次に、BizTalk Server A はこの受信確認を受信します [ドキュメント 1 の受信確認 (受信)]。

受信確認フロー

BizTalk
Server A
ドキュメント 1 の
受信確認
(受信)
ドキュメント 1 の
受信確認
(送信)
受信確認作成
フラグ設定
受信確認要求
フラグ設定
ドキュメント 1
ドキュメント 1
ドキュメント 1
BizTalk
Server B
受信機能

"ドキュメント 1、受信確認要求フラグ設定" の受信確認を表示する場合、まず、[クエリ結果] ページで、"ドキュメント 1、受信確認要求フラグ設定" に対応している適切なインターチェンジ レコードを探します。受信フィールドの [受信確認] アイコンをクリックします。これにより、新しい [クエリ結果] ページが表示され、BizTalk Server A が "ドキュメント 1、受信確認要求フラグ設定" を処理したときに生成したインターチェンジ レコードが示されます。データ列の [データ] アイコンをクリックします。表示されるデータは、受信確認の実際の内容です。上の図で、この最後の段階は、"ドキュメント 1 の受信確認 (受信)" に対応しています。

"ドキュメント 1、受信確認生成フラグ設定"の受信確認を表示する場合、まず、[クエリ結果] ページで "ドキュメント 1"受信確認生成フラグ設定"に対応している適切なインターチェンジ レコードを探します。受信フィールドの [受信確認] アイコンをクリックします。これにより、新しい [クエリ結果] ページが表示され、BizTalk Server B が "ドキュメント 1、受信確認生成フラグ設定" を処理したときに生成したインターチェンジ レコードが示されます。インターチェンジ レコードを展開してドキュメント インスタンスの詳細を表示し、データ フィールドの [データ] アイコンをクリックします。表示されるデータは、受信確認の実際の内容です。上の図で、この最後の段階は、"ドキュメント 1 の受信確認 (送信)" に対応しています。

注

  • 受信確認の送信と受信は、受信確認を処理できるパーサーでのみ行われます。受信確認の詳細については、「受信確認について」を参照してください。

  • 「信頼できるメッセージ受信確認」は、BizTalk ドキュメント トラッキングのユーザー インターフェイスに表示されません。

関連項目

受信確認をログに記録する方法

追跡データベース スキーマの基本


送信の失敗の結果について

送信に失敗すると、失敗は追跡データベースのログに記録されます。ただし、追跡データベースのログに記録されるエラーがすべて BizTalk ドキュメント トラッキングのユーザー インターフェイスに表示されるわけではありません。エラーがユーザー インターフェイスに表示されるのは、レコードが dta_outdoc_details テーブルのログに記録された場合だけです。コア テーブルの詳細については、「追跡データベース スキーマの基本」または「メタデータ コア テーブル」を参照してください。

次の表は、表示される可能性のあるエラー メッセージ、および追跡データベースのコア テーブルのログにレコードが記録されるかどうかの一覧です。

エラー メッセージ | ログに記録されるレコード | 説明
エラーなし | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | 該当するフィールドが 3 つのコア テーブルのログに記録されます。
カスタム コンポーネントを呼び出すことができませんでした。 |  | このエラー メッセージが表示されるのは、カスタム プリプロセッサが受信機能に関連付けられている場合だけです。レコードは、追跡データベースのログには記録されません。
インターチェンジを解析できませんでした。 | dta_interchange_details (受信) | 解析エラーが発生した場合は、インターチェンジとデータがログに記録されます。
指定されたチャネルは存在しません。 | dta_indoc_details dta_interchange_details (受信) |
インターチェンジをシリアライズできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | 空のレコードが、dta_interchange_details (送信) テーブルのログに記録されます。インターチェンジが再送信され、これが成功すると、レコードは更新されます。
インターチェンジをエンコードできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details |
インターチェンジに署名できませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details |
インターチェンジを暗号化できませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details |
送信の試行に失敗しました (再試行は待ち状態)。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details |
前回の送信試行は失敗しました。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details |
ドキュメントを解析できませんでした。 | dta_indoc_details dta_interchange_details (受信) |
ドキュメントを検証できませんでした。 | dta_indoc_details dta_interchange_details (受信) |
有効なチャネルが見つかりませんでした。 | dta_indoc_details dta_interchange_details (受信) |
ドキュメントをマッピングできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | ログ エラーは dta_outdoc_details テーブルのレコードのログに記録され、空のレコードが、dta_interchange_details (送信) テーブルのログに記録されます。
有効なメッセージ ポートが見つかりませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | ポートが見つからないエラーは dta_outdoc_details テーブルのレコードのログに記録され、空のレコードが、dta_interchange_details (送信) テーブルのログに記録されます。
ドキュメントをシリアライズできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | dta_indoc_details テーブルと dta_outdoc_details テーブルのレコードに、シリアライズ エラーが記録されます。

関連項目

サーバー グループの追跡のプロパティの構成

保留キュー

追跡データベース スキーマの基本

追跡データベース スキーマについて


インターチェンジの統合 XLANG スケジュール ステータスについて

BizTalk ドキュメント トラッキングでは、関連する XLANG スケジュールのステータスを追跡できます。サーバーにあるスケジュールのアクションは監視され、追跡データベース内の適切なテーブルに格納されます。このとき、これらのアクションと特定のメッセージ インスタンスとを関連付ける識別子が与えられます。追跡データベースの格納スキーマと関連付けは、Microsoft BizTalk Server 2000 の機能の一部ですが、BizTalk Server 2000 のインストール時にイベント サブスクリプション機能は実装されません。ただし、追跡インテグレーションを実行するためのサンプルが用意されています。BizTalk Server 2000 をインストールすると、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit フォルダにこのサンプルのソース コードが格納されます。また、bin サブフォルダにはダイナミックリンク ライブラリ (WorkFlowAudit.dll) が、Docs サブフォルダには、このサンプルのドキュメント (Readme.txt) が格納されています。サンプルのクライアント アプリケーションは、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient にあります。


BizTalk ドキュメント トラッキングのトラブルシューティング

ここでは、BizTalk ドキュメント トラッキングのトラブルシューティングについて、一般的な情報を提供します。

  • BizTalk ドキュメント トラッキングのユーザー インターフェイスの表示に関する問題

  • インターチェンジとドキュメントが格納されない

  • クエリ結果に何も表示されない

  • クエリ結果に追跡フィールドが表示されない

  • 検索引数が多すぎる


BizTalk ドキュメント トラッキングのユーザー インターフェイスの表示に関する問題

原因 : Microsoft Office Web コンポーネントがインストールされていません。

解決策 : Microsoft Office Web コンポーネントをインストールします。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Microsoft Office 2000 SR-1 Premium] をクリックします。

  4. [変更] をクリックします。

  5. [機能の追加/削除] をクリックします。

  6. [Office ツール] の隣の展開記号 (+) をクリックします。

  7. [Office Web コンポーネント] をクリックし、環境に適したオプションをクリックします。

  8. [完了] をクリックします。


インターチェンジとドキュメントが格納されない

原因 : BizTalk Server 管理コンソールで追跡機能が無効になっています。

解決策 : BizTalk Server 管理コンソールで追跡機能を有効にします。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  2. [Microsoft BizTalk Server 2000] を展開し、ドキュメントが格納されないサーバー グループをクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  4. [追跡] タブをクリックします。

  5. [ドキュメント トラッキングを有効にする] チェック ボックスをオンにします。

  6. 次の 1 つまたは複数のチェック ボックスをオンにします。
    • [受信インターチェンジを記録する]

    • [送信インターチェンジを記録する]

    • [元の MIME エンコード メッセージを記録する]
  7. [OK] をクリックします。

関連項目

サーバー グループの追跡のプロパティの構成


クエリ結果に何も表示されない

原因 1 : 日時の範囲が正しくありません。

解決策 : 日時の範囲が正しいことを確認します。たとえば、5 分前にドキュメントを送信したのに、10 分前より以前のドキュメントを検索するように時刻の範囲が設定されていると、追跡対象のドキュメントはクエリ結果に表示されません。

原因 2 : データベースからデータが削除された可能性があります。

解決策 : 詳細については、データベース管理者に問い合わせてください。

関連項目

日付によるインターチェンジとドキュメントの情報の検索


クエリ結果に追跡フィールドが表示されない

原因 : BizTalk Server でデータを変換できなかったか、演算オーバーフローのエラーが発生しています。

解決策 : イベント ログで、次のエラー メッセージを参照してください。

<<パスとファイル名>> : 送信用の <<グローバル一意識別子>> の追跡項目をログに記録できませんでした :

追跡フィールド : <<フィールド名>>

仕様フィールド名 : <<仕様フィールド名>>/DTADataTypeTest/String/@_String

実際の値 : <<フィールドの実際の値>>

ドキュメントまたはチャネルの構成で、追跡フィールドの設定の確認および修正を行います。

関連項目

チャネルでの仕様フィールドの選択

ドキュメント ログのプロパティの設定


検索引数が多すぎる

原因 : [送信元の選択] ボックスの一覧や [送信先の選択] ボックスの一覧で指定したオプションの数が多すぎます。

解決策 : クエリをできるだけ具体的なものにしてください。[送信元の選択] ボックスの一覧や [送信先の選択] ボックスの一覧で指定するオプションの数を減らし、[クエリ] をクリックします。

関連項目

クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え


BizTalk Server 2000 のアプリケーション開発

Microsoft BizTalk Server 2000 には、取引先と業務用アプリケーションとの間のビジネス プロセスおよびデータ交換を管理するための実行可能アプリケーションを作成できるツールおよびサービスがあります。

ここには次のトピックが含まれます。

  • BizTalk オーケストレーションの設計

  • BizTalk メッセージ サービスの構成

  • 仕様の作成とデータのマッピング

  • BizTalk サービスの統合


BizTalk オーケストレーションの設計

BizTalk オーケストレーション デザイナは Microsoft Visio 2000 を基にした設計ツールで、XLANG スケジュールとしてコンパイルおよび実行できるビジネス プロセス フローチャートを作成できます。XLANG は XML を基にした言語です。XLANG スケジュールには、ビジネス プロセスおよびそのプロセスのアプリケーション サービスへのバインドを記述します。

BizTalk オーケストレーション デザイナを使用すると、疎結合、長時間実行可能なビジネス プロセスを記述するフローチャートを作成することができます。一般的に、フローチャートには、注文要求などの特定のプロセスを完了する間に実行される対話や手順を記述します。通常、ビジネス プロセスには時間の制限がありません。また、ビジネス プロセス内のステップ間は疎結合されています。ビジネス プロセスの記述は、プロセスを実行するために使用される実装ロジックとシーケンスから切り離されています。

特定の作業のヘルプについては、「操作方法」を参照してください。

一般的な情報については、「概念」を参照してください。


操作方法

ここでは、BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを作成し、それをコンパイルして実行可能な XLANG スケジュールにする方法を作業ごとに説明します。また、XLANG スケジュールの実行方法についても説明します。「概念」を参照し、BizTalk オーケストレーション デザイナのすべての機能について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk オーケストレーション デザイナの使用

  • XLANG スケジュールの実行


BizTalk オーケストレーション デザイナの使用

ここでは、BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを設計し、それをコンパイルして XLANG スケジュールにする方法について説明します。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートを開く、および保存する

  • ページ、シェイプ、およびステンシルの表示

  • シェイプの追加、削除、および接続

  • 条件付きシェイプのプロパティの設定

  • 同時実行のプロパティの設定

  • トランザクション プロパティの設定

  • エラー処理プロパティの設定

  • ポートの実装

  • メッセージの送信と受信

  • メッセージ間のデータ フローの記述


XLANG スケジュール フローチャートを開く、および保存する

ここには次のトピックが含まれます。

  • 新しい XLANG スケジュール フローチャートの作成

  • 既存の XLANG スケジュール フローチャートを開く

  • XLANG スケジュール フローチャートの保存


新しい XLANG スケジュール フローチャートの作成

  • BizTalk オーケストレーション デザイナで、[ファイル] メニューの [新規作成] をクリックします。

注

  • この手順では、デザイナ ウィンドウ内に新しい XLANG スケジュール フローチャートが開きます。既定の設計開始ページは [ビジネス プロセス] ページです。また、新しいフローチャートを開始すると、[フローチャート ステンシル] および [実装ステンシル] も既定で開きます。

  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

関連項目

既存の XLANG スケジュール フローチャートを開く

XLANG スケジュール フローチャートの保存


既存の XLANG スケジュール フローチャートを開く

  1. BizTalk オーケストレーション デザイナで、[ファイル] メニューの [開く] をクリックします。

    [XLANG スケジュール フローチャートを開く] ダイアログ ボックスが表示されます。

  2. XLANG スケジュール フローチャートを参照し、目的のフローチャートをクリックします。次に、[開く] をクリックします。

注

  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

  • XLANG スケジュールのファイル拡張子は .skx です。BizTalk オーケストレーション デザイナでは、.skx ファイルを開くことはできません。.skx ファイルを変更または更新するには、ソースの .skv ファイルを開いて変更した後、その .skv ファイルを .skx ファイルに再コンパイルします。

関連項目

新しい XLANG スケジュール フローチャートの作成

XLANG スケジュール フローチャートの保存


XLANG スケジュール フローチャートの保存

  • BizTalk オーケストレーション デザイナで、[ファイル] メニューの [<ファイル> の保存] をクリックします。

注

  • ファイル名のパラメータ <ファイル> は、保存するファイル名に置き換えられます。

  • XLANG スケジュール フローチャートを保存する場合、フローチャートは既定で <図面 X>.skv という名前で保存されます。ここで、X はフローチャート名に付加された番号です。これ以外の名前に変更して保存することもできます。

  • [ファイル] メニューの [名前を付けて保存] をクリックする方法もあります。その場合、[XLANG スケジュール フローチャートに名前を付けて保存] ダイアログ ボックスが表示され、次のことを行うことができます。
    • ファイル名を別の名前に変更する。

    • ファイルを別の場所に保存する。
  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

  • XLANG スケジュールのファイル拡張子は .skx です。BizTalk オーケストレーション デザイナでは、.skx ファイルを開くことはできません。.skx ファイルを変更または更新するには、ソースの .skv ファイルを開いて変更した後、その .skv ファイルを .skx ファイルに再コンパイルします。

関連項目

新しい XLANG スケジュール フローチャートの作成

既存の XLANG スケジュール フローチャートを開く


ページ、シェイプ、およびステンシルの表示

BizTalk オーケストレーション デザイナには、フローチャート領域を最大化したり、特定のシェイプまたはデータの関係を表示するための、いくつかの表示オプションがあります。

ここには次のトピックが含まれます。

  • 設計ページの表示

  • シェイプの表示

  • ステンシルの表示

  • 複数のウィンドウの使用

  • コメントの使用

  • XLANG スケジュール フローチャートのプレビュー、印刷、およびサイズ変更


設計ページの表示

ここには次のトピックが含まれます。

  • ビジネス プロセス ページの表示

  • データ ページの表示

  • ビジネス プロセス ページとデータ ページの表示

  • トランザクションの補正ページの表示

  • トランザクションの失敗時ページの表示

  • ページの表示

関連項目

複数のウィンドウの使用

シェイプの表示

ステンシルの表示


ビジネス プロセス ページの表示

  • [表示] メニューの [ビジネス プロセス ページ] をクリックします。

注

  • 設計ページの下部にある [ビジネス プロセス] タブをクリックする方法もあります。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

データ ページの表示


データ ページの表示

  • [表示] メニューの [データ ページ] をクリックします。

注

  • 設計ページの下部にある [データ] タブをクリックする方法もあります。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示


ビジネス プロセス ページとデータ ページの表示

  • [表示] メニューの [ビジネス プロセス ページとデータ ページ] をクリックします。

注

  • この表示オプションを選択すると、1 つの XLANG スケジュールに対して、[ビジネス プロセス] ウィンドウと [データ] ウィンドウの 2 つのウィンドウが開きます。この機能は、[新しいウィンドウを開く] オプションの動作に似ています。複数のウィンドウを開く方法については、「複数のウィンドウの使用」を参照してください。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページの表示

データ ページの表示


トランザクションの補正ページの表示

  • 設計ページの下部で、表示するページの [<トランザクション> の補正] タブをクリックします。

注

  • ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • [<トランザクション> の補正] ページを XLANG スケジュール フローチャートに追加する方法については、「補正エラー処理の有効化」を参照してください。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示

データ ページの表示


トランザクションの失敗時ページの表示

  • 設計ページの下部で、表示するページの [<トランザクション> の失敗時] タブをクリックします。

注

  • ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • [<トランザクション> の失敗時] ページを XLANG スケジュール フローチャートに追加する方法については、「失敗時エラー処理の有効化」を参照してください。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示

データ ページの表示


ページの表示

  • 表示するページのタブをクリックします。

注

  • 各ページのタブは、設計ページの下部にあります。

関連項目

複数のウィンドウの使用

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示

データ ページの表示


シェイプの表示

ここには次のトピックが含まれます。

  • フローチャート シェイプの表示

  • フローチャート シェイプと通信シェイプの表示

  • フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

関連項目

ステンシルの表示

設計ページの表示


フローチャート シェイプの表示

  • [表示] メニューの [フローチャート シェイプ] をクリックします。

注

  • このオプションを使用した場合、設計ページには、フローチャート シェイプおよびその相互の接続だけが表示されます。すべてのポート、ポート メッセージ、実装、およびポートとアクションまたはポートと実装との間の接続は表示されません。

  • この表示オプションは、[データ] ページでは使用できません。

関連項目

フローチャート シェイプと通信シェイプの表示

フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

ステンシルの表示

設計ページの表示


フローチャート シェイプと通信シェイプの表示

  • [表示] メニューの [フローチャート シェイプと通信シェイプ] をクリックします。

注

  • このオプションを使用した場合、設計ページにフローチャート シェイプおよびその相互の接続が表示されます。ポート、ポート メッセージ、およびポートとアクションとの間の接続も表示されます。すべての実装、およびポートと実装との間の接続は表示されません。

  • この表示オプションは、[データ] ページでは使用できません。

関連項目

フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

フローチャート シェイプの表示

ステンシルの表示

設計ページの表示


フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

  • [表示] メニューの [フローチャート シェイプ、通信シェイプ、および実装シェイプ] をクリックします。

注

  • すべてのシェイプと、その相互の接続が表示されます。

  • この表示オプションは、[データ] ページでは使用できません。

関連項目

フローチャート シェイプと通信シェイプの表示

フローチャート シェイプの表示

ステンシルの表示

設計ページの表示


ステンシルの表示

ここには次のトピックが含まれます。

  • フローチャート ステンシルの表示

  • 実装ステンシルの表示

関連項目

シェイプの表示

設計ページの表示


フローチャート ステンシルの表示

  • [表示] メニューの [ステンシル] をポイントし、[フローチャート] をクリックすると、フローチャート ステンシルの表示と非表示が切り替わります。

関連項目

シェイプの表示

設計ページの表示

実装ステンシルの表示


実装ステンシルの表示

  • [表示] メニューの [ステンシル] をポイントし、[実装] をクリックすると、実装ステンシルの表示と非表示が切り替わります。

関連項目

シェイプの表示

設計ページの表示

フローチャート ステンシルの表示


複数のウィンドウの使用

ここには次のトピックが含まれます。

  • 新しいウィンドウを開く

  • ウィンドウを並べて表示

  • ウィンドウを重ねて表示

  • ウィンドウのフォーカスの切り替え

関連項目

設計ページの表示


新しいウィンドウを開く

  • [ウィンドウ] メニューの [新しいウィンドウを開く] をクリックします。

注

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウを重ねて表示

ウィンドウのフォーカスの切り替え

ウィンドウを並べて表示

設計ページの表示


ウィンドウを並べて表示

  • [ウィンドウ] メニューの [並べて表示] をクリックします。

注

  • ウィンドウを並べて表示すると、複数のウィンドウを同時に見ることができます。

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウを重ねて表示

ウィンドウのフォーカスの切り替え

新しいウィンドウを開く

設計ページの表示


ウィンドウを重ねて表示

  • [ウィンドウ] メニューの [重ねて表示] をクリックします。

注

  • ウィンドウを重ねて表示すると、1 つのウィンドウを画面の手前に表示できます。別のウィンドウのタイトル バーをクリックすると、そのウィンドウが画面の手前に表示されます。

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウのフォーカスの切り替え

新しいウィンドウを開く

ウィンドウを並べて表示

設計ページの表示


ウィンドウのフォーカスの切り替え

  • [ウィンドウ] メニューで、フォーカスを設定するウィンドウの名前をクリックします。

注

  • XLANG スケジュールの名前に設計ページの名前を追加したものが、ウィンドウの名前になります。たとえば、図面1.skv:ビジネス プロセスや図面1.skv:データのようになります。

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウを重ねて表示

新しいウィンドウを開く

ウィンドウを並べて表示

設計ページの表示


コメントの使用

ここには次のトピックが含まれます。

  • コメントの追加

  • コメントの編集

  • コメント内のテキストの書式設定

  • コメントの削除


コメントの追加

  1. BizTalk オーケストレーション デザイナで、ツール バーの [テキスト ツール] ( テキスト ツール) をクリックします。

  2. コメントを作成する領域を、マウス ポインタでドラッグします。

  3. コメントを入力します。

注

  • [テキスト ツール] をオフにするには、ツール バーの [オブジェクト選択ツール] ( オブジェクト選択ツール) ボタンをクリックします。

  • BizTalk オーケストレーション デザイナはカスタマイズされた Microsoft Visio インターフェイスを使用しているため、[テキスト ツール] ボタンには 2 つのオプションがあります。これらの 2 つのボタンの機能は同じです。
    • [テキスト ツール] ( テキスト ツール) ボタン

    • [テキストブロック ツール] ( テキストブロック ツール) ボタン

関連項目

コメントの削除

コメントの編集

コメント内のテキストの書式設定


コメントの編集

  1. BizTalk オーケストレーション デザイナで、ツール バーの [テキスト ツール] ( テキスト ツール) をクリックします。

  2. 編集するコメントをクリックします。

  3. コメントを編集します。

注

  • [テキスト ツール] をオフにするには、ツール バーの [オブジェクト選択ツール] ( オブジェクト選択ツール) ボタンをクリックします。

  • BizTalk オーケストレーション デザイナはカスタマイズされた Microsoft Visio インターフェイスを使用しているため、[テキスト ツール] ボタンには 2 つのオプションがあります。これらの 2 つのボタンの機能は同じです。
    • [テキスト ツール] ( テキスト ツール) ボタン

    • [テキストブロック ツール] ( テキストブロック ツール) ボタン

関連項目

コメントの追加

コメントの削除

コメント内のテキストの書式設定


コメント内のテキストの書式設定

  1. BizTalk オーケストレーション デザイナの設計ページで、書式設定するコメントを 1 つ以上選択します。

  2. [書式] メニューの [テキスト] をクリックします。

    [テキスト] ダイアログ ボックスが表示されます。このダイアログ ボックスには、テキストのサイズ、フォント、およびスタイルに関するオプションがいくつかあります。

  3. 使用するオプションを選択し、[OK] をクリックします。

注

  • これらのオプションは、XLANG スケジュール フローチャート内で強調表示しているコメント、およびこれから作成するすべての新しいコメントに適用されます。

  • コメントを選択するには、そのコメントをクリックします。複数のコメントを選択するには、Shift キーを押しながら、選択するコメントをクリックします。

関連項目

コメントの追加

コメントの削除

コメントの編集


コメントの削除

  • BizTalk オーケストレーション デザイナの設計ページで、削除するコメントをクリックし、Delete キーを押します。

注

  • XLANG スケジュール フローチャートからコメントを削除するには、[テキスト ツール] をオフにしておく必要があります。

関連項目

コメントの追加

コメント内のテキストの書式設定


XLANG スケジュール フローチャートのプレビュー、印刷、およびサイズ変更

ここには次のトピックが含まれます。

  • 印刷プレビューの使用

  • XLANG スケジュール フローチャートの印刷

  • XLANG スケジュール フローチャートのサイズ変更


印刷プレビューの使用

  • [ファイル] メニューの [印刷プレビュー] をクリックします。

注

  • [印刷の向き] オプションを [横] から [縦] に変更すると、次のメッセージが表示されます。

    1 つまたは複数の図面ページが印刷のページ設定とは異なる向きに設定されています。複数ページに渡って印刷するには [OK] をクリックします。向きを揃えるには、印刷ページの向きを変更します。

    [OK] をクリックして変更を適用すると、印刷プレビューは次のような表示になります。

    • [次の印刷面] をクリックして次のページへ進んでから、[前の印刷面] をクリックして前のページに戻ると、印刷プレビューには、一部のシェイプがそのページに存在しないかのように表示されます。この表示は問題ありません。実際の XLANG スケジュールでは、複数ページに渡って正しく印刷されます。

関連項目

XLANG スケジュール フローチャートの印刷

XLANG スケジュール フローチャートのサイズ変更


XLANG スケジュール フローチャートの印刷

  1. [ファイル] メニューの [印刷] をクリックします。

  2. [印刷] ダイアログ ボックスで必要なオプションを設定し、[印刷] をクリックします。

関連項目

XLANG スケジュール フローチャートのサイズ変更

印刷プレビューの使用


XLANG スケジュール フローチャートのサイズ変更

  1. BizTalk オーケストレーション デザイナで、[表示] メニューの [ページ全体を表示] をクリックします。

  2. Ctrl キーを押しながら、マウス ポインタをページ枠に移動します。

    ページ枠でマウス ポインタの形が双方向矢印に変わります。

  3. ページ枠をクリックしてドラッグすると、サイズを変更できます。

関連項目

XLANG スケジュール フローチャートの印刷

印刷プレビューの使用


シェイプの追加、削除、および接続

ここには次のトピックが含まれます。

  • シェイプの追加

  • シェイプの名前設定

  • シェイプの削除

  • 未使用のポートおよびメッセージの削除

  • シェイプの接続


シェイプの追加

  • BizTalk オーケストレーション デザイナの [フローチャート] ステンシルで、シェイプをクリックし、設計ページまでドラッグします。

注

  • フローチャート シェイプ を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

  • XLANG スケジュール フローチャートへの [実装] シェイプの追加方法については、「ポートの実装」を参照してください。

  • [データ] ページにはシェイプを追加できません。アクションをポートに接続するたびに、[データ] ページに新しいメッセージが自動的に作成されます。

関連項目

シェイプの接続

シェイプの削除

未使用のポートおよびメッセージの削除

シェイプの名前設定

フローチャート ステンシルの表示


シェイプの名前設定

  1. BizTalk オーケストレーション デザイナの設計ページで、シェイプを右クリックし、[プロパティ] をクリックします。

  2. [<シェイプ> のプロパティ] ダイアログ ボックスで、[名前] ボックスに名前を入力します。

注

  • 各シェイプの "名前" プロパティには、たとえば アクション 1 のように、そのシェイプの名前に番号を追加したものが、既定値として格納されています。この既定値は必要に応じて変更できます。

  • 開始、判断、繰り返し、分岐、結合、終了、および中断の各シェイプには、名前を付けることができません。

  • 名前を付けることができるのは、アクション、トランザクション、ポート、メッセージ、および条件の各シェイプです。

  • シェイプ名は一定の命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • 1 バイト文字セットによるトランザクション名の長さは、16 文字以内にします。2 バイト文字セットによるトランザクション名の長さは、8 文字以内にします。

  • アクションには、最大の長さが 32 文字という点を除いて、命名規則による制限がありません。

関連項目

シェイプの追加

シェイプの接続

シェイプの削除

未使用のポートおよびメッセージの削除


シェイプの削除

  • 削除するシェイプをクリックし、Delete キーを押します。

注

  • 接続をクリックし、Delete キーを押すと、2 つのシェイプ間の接続を削除できます。

  • 複数のシェイプと接続しているシェイプを削除すると、それらの接続もすべて削除されます。

  • トランザクションを削除すると、そのトランザクションに含まれているシェイプもすべて削除されます。

  • BizTalk メッセージ、またはメッセージ キューの実装を削除しても、その実装の接続先のポートは削除されません。

  • COM コンポーネント、または Windows スクリプト コンポーネントの実装を削除すると、その実装の接続先のポートも削除されます。

  • ポートに含まれたメッセージをクリックし、Delete キーを押すと、メッセージを削除できます。[データ] ページ上の、関連付けられたメッセージが削除されます。

    [データ] ページからメッセージを削除することもできます。詳細については、「メッセージの削除」を参照してください。

  • この削除の手順では、条件を削除できません。条件の削除については、次のトピックを参照してください。
    • 判断条件の削除

    • 繰り返しループ条件の削除

    • 未使用の条件の削除

関連項目

シェイプの追加

シェイプの接続

メッセージの削除

判断条件の削除

繰り返しループ条件の削除

未使用のポートおよびメッセージの削除

未使用の条件の削除

シェイプの名前設定


未使用のポートおよびメッセージの削除

  • BizTalk オーケストレーション デザイナで、[ツール] メニューの [未使用のポートとメッセージの削除] をクリックします。

注

  • この手順では、未使用のすべてのポート、およびそのポートに含まれるすべてのメッセージが、XLANG スケジュール フローチャートから削除されます。[データ] ページ上の、対応するメッセージも削除されます。

関連項目

シェイプの追加

シェイプの接続

シェイプの削除

シェイプの名前設定


シェイプの接続

ここには次のトピックが含まれます。

  • シェイプの選択

  • 2 つのシェイプの接続

  • コネクタ ツールの使用

  • シェイプの縦方向または横方向の整列

関連項目

シェイプの追加

シェイプの削除

未使用のポートおよびメッセージの削除

シェイプの名前設定


シェイプの選択

  • BizTalk オーケストレーション デザイナの設計ページで、選択するシェイプをクリックします。

    選択したシェイプは、緑の点線で囲まれます。また、そのシェイプで利用可能なすべての制御ハンドル ( 制御ハンドル) が有効になります。

注

  • シェイプを選択すると、制御ハンドル ( 制御ハンドル) をそのシェイプからほかのシェイプへドラッグできるようになります。

  • シェイプを選択すると、シェイプのプロパティを編集したり、そのシェイプの切り取り、コピー、貼り付け、消去、および複製を行うことができます。行うことができる操作は、シェイプによって異なります。

  • [ポート] シェイプに接続された [アクション] シェイプをコピーすると、そのコピーされたアクションも同じポートに接続されます。

関連項目

シェイプの追加

2 つのシェイプの接続

シェイプの削除

コネクタ ツールの使用


2 つのシェイプの接続

  1. 2 つのシェイプを接続するには、一方のシェイプを選択します。

    選択したシェイプは、緑の点線で囲まれます。また、そのシェイプで利用可能なすべての制御ハンドル ( 制御ハンドル) が有効になります。

  2. 接続する制御ハンドルを、もう一方のシェイプの接続ポイント ( 接続ポイント) までドラッグします。

    接続ポイントが赤い四角形 ( アクティブ接続ポイント) で強調表示されたら、マウス ボタンを離して接続を設定します。

注

  • 処理フローは、シェイプの上部と下部の接続ポイント、および制御ハンドルから接続されます。

  • 通信フローは、アクション シェイプの右側の制御ハンドルから、ポート シェイプの左側の接続ポイントへ接続されます。

  • シェイプの接続には、コネクタ ツールも使用できます。詳細については、「コネクタ ツールの使用」を参照してください。

関連項目

シェイプの追加

シェイプの削除

シェイプの選択

コネクタ ツールの使用


コネクタ ツールの使用

  1. ツール バーの [コネクタ ツール] ( コネクタ ツール)) ボタンをクリックします。

  2. 作成する接続の接続元となるシェイプの制御ハンドル ( 制御ハンドル) をポイントします。

    制御ハンドルが赤い四角形で囲まれ、ドラッグ可能になったことが示されます。

  3. マウス ボタンを押しながら、そのシェイプから作成する接続の接続先となるシェイプの接続ポイント ( 接続ポイント) まで、制御ハンドルをドラッグします。

    接続先シェイプの接続ポイントが赤い四角形 ( アクティブ接続ポイント) で囲まれたら、マウス ボタンを離して接続を確立します。

注

  • コネクタ ツールをオフするには、ツール バーの [オブジェクト選択ツール] ( オブジェクト選択ツール) ボタンをクリックします。

  • コネクタ ツールが有効になっているときは、ページにシェイプを追加したり、そのほかの操作を行うことができます。ただし、エラー メッセージが表示される場合があります。このエラー メッセージは無効なため、問題ありません。この誤ってエラーが表示される問題は、Microsoft Visio の今後のリリースで修正される予定です。このエラー メッセージが表示された場合は、[OK] をクリックして先に進んでください。メッセージの内容は次のとおりです。

    Visio 内部エラー #-1

    アクション 1246: ページへドロップ

    ファイルを一度閉じてから再度開いてみてください。症状が変わらない場合は Visio を再起動してみてください。

関連項目

シェイプの追加

2 つのシェイプの接続

シェイプの削除

シェイプの選択


シェイプの縦軸方向または横軸方向の整列

  1. BizTalk オーケストレーション デザイナの設計ページで、軸に揃えて整列させるシェイプの周囲をマウス ポインタでドラッグします。

  2. ツール バーの [シェイプの整列] ( シェイプの整列) ボタンをクリックします。

  3. [図形の整列] ダイアログ ボックスの次のいずれかの領域で、使用する整列方法をクリックします。
    • [上下の整列] の次のいずれかのボタンをリックします。

      水平上揃えボタン 水平上揃え

      水平中心線揃えボタン 水平中心線揃え

      水平下揃えボタン 水平下揃え

    • [左右の整列] の次のいずれかのボタンをクリックします。

      垂直左揃えボタン 垂直左揃え

      垂直中心線揃えボタン 垂直中心線揃え

      垂直右揃えボタン 垂直右揃え

注

  • 設計ページでシェイプを選択しないと、[シェイプの整列] ボタンが有効になりません。

  • シェイプは、1 つの軸だけに揃えて整列することを推奨します。両方の軸に揃えてシェイプを整列すると、シェイプが重なって表示される場合があります。誤って変更した場合は、Ctrl キーを押しながら Z キーを押すと元に戻ります。

  • [図形の整列] ダイアログ ボックスで、選択を解除するボタン ( 選択解除ボタン) をクリックすると、整列の選択が消去されます。

  • [新規ガイドを作成し、図形を揃える] チェック ボックスは、常に使用できません。

  • Shift キーを押しながらシェイプをクリックすると、複数のシェイプを選択できます。


条件付きシェイプのプロパティの設定

ここには次のトピックが含まれます。

  • 判断条件の設定

  • 繰り返しループの状態の設定

  • 条件の作成

関連項目

条件の設計


判断条件の設定

ここには次のトピックが含まれます。

  • 判断条件の追加

  • 判断条件の編集

  • 判断条件の削除

  • 条件の評価順序の決定

関連項目

条件の作成

条件の設計


判断条件の追加

  1. BizTalk オーケストレーション デザイナの設計ページで、条件を追加する [判断] シェイプを右クリックし、[条件の作成] をクリックします。

    [条件の作成] ダイアログ ボックスが表示されます。

  2. [条件の作成] ダイアログ ボックスで、次のオプションのいずれかをクリックします。
    • [新しい条件の作成]

      [OK] をクリックします。[条件のプロパティ] ダイアログ ボックスが表示されます。

      条件の作成の詳細については、「条件の作成」を参照してください。

    • [既存の条件の追加]

      [利用可能な条件] ボックスの一覧で、追加する条件をクリックし、[OK] をクリックします。

      [条件の作成] ダイアログ ボックスが閉じ、条件が判断に追加されます。

注

  • XLANG スケジュール フローチャートに初めて条件を追加するときは、[条件の作成] をクリックすると [条件のプロパティ] ダイアログ ボックスが表示されます。[条件の作成] ダイアログ ボックスが表示されるのは、判断に追加可能な条件が、既に 1 つまたは複数作成されている場合だけです。[条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

  • [判断] シェイプを右クリックし、[プロパティ] をクリックしてから [追加] をクリックしても、判断に条件を追加できます。

関連項目

条件の作成

判断条件の削除

条件の設計

条件の評価順序の決定

判断条件の編集


判断条件の編集

  1. BizTalk オーケストレーション デザイナの設計ページで、[判断] シェイプを右クリックし、[プロパティ] をクリックします。

  2. [判断のプロパティ] ダイアログ ボックスで、編集する条件をクリックし、[編集] をクリックします。

  3. [条件のプロパティ] ダイアログ ボックスで、変更を行い、[OK] をクリックします。

    [条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

  4. 別の条件を編集するには、その条件をクリックし、[編集] をクリックします。

    または

    [判断のプロパティ] ダイアログ ボックスを閉じるには、[OK] をクリックします。

注

  • [判断のプロパティ] ダイアログ ボックスでは、[追加] をクリックすると条件を追加できます。

  • [判断] シェイプに含まれる条件を右クリックし、[プロパティ] をクリックしても、条件を編集できます。この操作では、[条件のプロパティ] ダイアログ ボックスが表示されます。

関連項目

判断条件の追加

条件の作成

判断条件の削除

条件の設計

条件の評価順序の決定


判断条件の削除

  1. BizTalk オーケストレーション デザイナの設計ページで、条件を削除する [判断] シェイプを右クリックし、[プロパティ] をクリックします。

  2. 削除する条件をクリックし、[削除] をクリックします。

関連項目

判断条件の追加

条件の作成

条件の設計

条件の評価順序の決定

判断条件の編集


条件の評価順序の決定

  1. BizTalk オーケストレーション デザイナの設計ページで、[判断] シェイプを右クリックし、[プロパティ] をクリックします。

  2. [判断のプロパティ] ダイアログ ボックスで、評価順序を変更する条件をクリックします。

  3. [順序] で、上矢印または下矢印をクリックして条件を移動し、一覧に表示される順序を変更します。

注

  • 条件の順序は、優先順位の高いものから順に設定することをお勧めします。条件は条件の 1 つが TRUE と評価されるまで、順番に実行されます。次に、最初に TRUE と評価された条件に対する処理フローが実行されます。TRUE と評価される条件がない場合は、ELSE 処理フローが実行されます。

関連項目

判断条件の追加

条件の作成

判断条件の削除

条件の設計

判断条件の編集


繰り返しループの状態の設定

ここには次のトピックが含まれます。

  • 繰り返しループ条件の追加

  • 繰り返しループ条件の編集

  • 繰り返しループ条件の削除

  • 繰り返しループのステータスの保持

関連項目

条件の作成

条件の設計


繰り返しループ条件の追加

  1. BizTalk オーケストレーション デザイナの設計ページで、条件を追加する [繰り返し] シェイプを右クリックし、[条件の作成] をクリックします。

    [条件の作成] ダイアログ ボックスが表示されます。

  2. [条件の作成] ダイアログ ボックスで、次のオプションのいずれかをクリックします。
    • [新しい条件の作成]

      [OK] をクリックします。[条件のプロパティ] ダイアログ ボックスが表示されます。

      条件の作成の詳細については、「条件の作成」を参照してください。

    • [既存の条件の追加]

      [利用可能な条件] ボックスの一覧で、追加する条件をクリックし、[OK] をクリックします。

      [条件の作成] ダイアログ ボックスが閉じ、条件が繰り返しループに追加されます。

注

  • XLANG スケジュール フローチャートに初めて条件を追加するときは、[条件の作成] をクリックすると [条件のプロパティ] ダイアログ ボックスが表示されます。[条件の作成] ダイアログ ボックスが表示されるのは、繰り返しループに追加可能な条件が、既に 1 つまたは複数作成されている場合だけです。[条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

  • 繰り返しループに追加できる条件は 1 つだけです。

関連項目

条件の作成

繰り返しループ条件の削除

条件の設計

繰り返しループ条件の編集

繰り返しループのステータスの保持


繰り返しループ条件の編集

  1. BizTalk オーケストレーション デザイナの設計ページで、[繰り返し] シェイプに含まれた条件を右クリックし、[プロパティ] をクリックします。

  2. [条件のプロパティ] ダイアログ ボックスで、変更を行い、[OK] をクリックします。

    [条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

関連項目

繰り返しループ条件の追加

条件の作成

繰り返しループ条件の削除

条件の設計

繰り返しループのステータスの保持


繰り返しループ条件の削除

  • BizTalk オーケストレーション デザイナの設計ページで、条件を削除する [繰り返し] シェイプを右クリックし、[条件の削除] をクリックします。

関連項目

繰り返しループ条件の追加

条件の作成

条件の設計

繰り返しループ条件の編集

繰り返しループのステータスの保持


繰り返しループのステータスの保持

  1. BizTalk オーケストレーション デザイナの設計ページで、[繰り返し] シェイプを右クリックし、[プロパティ] をクリックします。

  2. [繰り返しのプロパティ] ダイアログ ボックスの [ステータスの永続化] で、次のオプションのいずれかをクリックします。
    • [はい]

      各ループで繰り返し使用されるメッセージが、XLANG スケジュール ステータスとして保存されます。そのループが失敗したトランザクションに含まれている場合、ループの繰り返しが完了するたびに、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが表示されます。

    • [いいえ]

      最後のループの繰り返しで使用されたメッセージだけが、XLANG スケジュール ステータスとして保存されます。そのループが失敗したトランザクションに含まれている場合、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが 1 回だけ表示されます。

関連項目

繰り返しループ条件の追加

条件の作成

繰り返しループ条件の削除

条件の設計

繰り返しループ条件の編集


条件の作成

ここには次のトピックが含まれます。

  • 条件の作成

  • 式アシスタントの使用

  • 条件への定数の追加

  • 未使用の条件の削除

関連項目

条件の設計

判断条件の設定

繰り返しループの状態の設定


条件の作成

ビジネス プロセスの条件を評価するような条件を作成することができます。条件は、XLANG スケジュールの判断および繰り返しループ内で使用されます。判断シェイプまたは繰り返しシェイプに条件を追加するときは、[条件のプロパティ] ダイアログ ボックスが表示されます。

  1. [条件のプロパティ] ダイアログ ボックスで、[条件名] ボックスに条件の名前を入力します。

    このフィールドは必須です。

  2. [条件の説明] ボックスに、その条件の詳しい説明を入力します。

    このフィールドは省略できます。

  3. [条件式] ボックス内にカーソルを置くと、式アシスタントが有効になります。

    使用する条件式を入力するか、式アシスタントを使用します。式アシスタントの使用方法および条件式の作成方法については、「式アシスタントの使用」を参照してください。

重要

  • XML では大文字と小文字が区別されるため、条件式ではメッセージおよびそのフィールドと同じように大文字と小文字を区別して使用する必要があります。

  • 式アシスタントを有効にするには、[条件式] ボックスにカーソルを置く必要があります。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。
  • 開始、終了、判断、繰り返し、分岐、結合、および中断の各シェイプには、名前を付けることができません。

  • その条件が使用されている判断シェイプおよび繰り返しシェイプの幅は、条件名の長さによって決まります。

  • 式を追加する場所にカーソルを置くと、[条件式] ボックスの任意の場所に条件式を追加できます。

  • ポート実装およびアクションとポート間のメッセージ通信を作成しない限り、条件式を作成できません。

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにする前に、そのスケジュール内のすべての条件の条件式を完成する必要があります。

関連項目

条件への定数の追加

条件の設計

判断条件の設定

繰り返しループの状態の設定

式アシスタントの使用


式アシスタントの使用

  1. [条件のプロパティ] ダイアログ ボックスで、[式アシスタント] の [メッセージ] ボックスの一覧からメッセージをクリックします。

  2. [式アシスタント] の [フィールド] ボックスの一覧からフィールドをクリックします。

  3. [挿入] をクリックします。

  4. [条件式] ボックスで、式を完成します。

    式アシスタントは、選択されたメッセージおよびフィールドだけを追加します。条件式を評価するには、その条件に論理式を定義する必要があります。たとえば、次のようにします。

    PORequest.Total < 500

    式を組み合わせて、さらに複雑な論理式を指定することもできます。たとえば、次のようにします。

    PORequest.Total < 500 AND PORequest.Quantity < 20

重要

  • XML では大文字と小文字が区別されるため、条件式ではメッセージおよびそのフィールドと同じように大文字と小文字を区別して使用する必要があります。

  • 式アシスタントを有効にするには、[条件式] ボックスにカーソルを置く必要があります。

  • [フィールド] ボックスの一覧で使用可能なフィールドは、[メッセージ] ボックスの一覧で選択したメッセージによって異なります。そのメッセージに含まれているフィールドだけが使用可能になります。

注

  • [メッセージ] ボックスの一覧には、[データ] ページで使用可能なすべてのメッセージ、および定数の一覧が含まれています。

  • 条件では、[データ] ページにあるシステム フィールドを使用できます。条件内で使用した場合、システム フィールドは必ずかっこで囲まれます。たとえば、次のようになります。

    Message1.[__Exists__]

    システム フィールドの詳細については、「データ処理」を参照してください。

  • 条件内では、Date や Time など、Microsoft Visual Basic の関数を使用できます。

  • 式を追加する場所にカーソルを置くと、[条件式] ボックスの任意の場所に条件式を追加できます。

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにする前に、そのスケジュール内のすべての条件の条件式を完成する必要があります。

関連項目

条件への定数の追加

条件の作成

条件の設計

判断条件の設定

繰り返しループの状態の設定


条件への定数の追加

条件内の条件式には、定数を追加できます。定数を使用するには、その前に定数を使用可能にしておく必要があります。

  1. 使用可能な定数がない場合は、[データ] ページで [定数] ボックスの一覧に定数を追加します。

    定数の使用方法と [定数] ボックスの一覧への追加方法については、「定数の使用」を参照してください。

  2. [条件のプロパティ] ダイアログ ボックスで、[メッセージ] ボックスの一覧から [定数] をクリックします。

  3. [フィールド] ボックスの一覧から使用する定数をクリックし、[挿入] をクリックします。

注

  • [データ] ページの [定数] ボックスの一覧にあるすべての定数が使用可能で、条件内でも使用できます。

関連項目

条件の作成

条件の設計

判断条件の設定

繰り返しループの状態の設定

式アシスタントの使用


未使用の条件の削除

  • [ツール] メニューの [未使用の条件の削除] をクリックします。

注

  • ここでは、XLANG スケジュール フローチャート内の判断および繰り返しループにある、未使用のすべての条件が削除されます。

  • XLANG スケジュール フローチャートから削除されるのは、繰り返しシェイプおよび判断シェイプ内で現在使用されていない条件だけです。繰り返しシェイプおよび判断シェイプ内で使用中の条件は、そのシェイプが現在ほかのシェイプに接続されていなくても削除されません。

関連項目

条件への定数の追加

条件の作成

式アシスタントの使用


同時実行のプロパティの設定

ここには次のトピックが含まれます。

  • 同時実行フローの作成

  • 結合の種類プロパティの設定

  • 同時実行フローの結合

  • 同時実行フローの終了

重要

  • 同時実行 プロセスの詳細については、「同時実行の設計」も必ずお読みください。


同時実行フローの作成

  1. BizTalk オーケストレーション デザイナの設計ページで、[分岐] シェイプをクリックします。

  2. 分岐シェイプ下部の制御ハンドル ( 制御ハンドル) を、ビジネス プロセスのフロー内にある後続のシェイプの、上部の接続ポイント ( 接続ポイント) に接続します。

  3. 手順 1. と 2. を繰り返し、同時実行フローをすべて作成します。

重要

  • 同時実行プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • 上部の接続ポイントから分岐シェイプに入力できるフローは 1 つだけです。

  • 同時実行プロセスを実行するために分岐シェイプから出力できるフローは、最大 64 個です。

  • フローを記述するたびに、[分岐] シェイプをクリックして選択し、制御ハンドルをアクティブにする必要があります。

    または

    複数の同時実行フローを作成する場合は、コネクタ ツールを使用するとフローを簡単に追加できます。コネクタ ツールの詳細については、「コネクタ ツールの使用」を参照してください。

  • フローチャート シェイプ を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

同時実行フローの終了

同時実行フローの結合

シェイプの選択

結合の種類プロパティの設定

コネクタ ツールの使用


結合の種類プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[結合] シェイプを右クリックし、[プロパティ] をクリックします。

  2. [結合の種類] で、次のオプションのいずれかをクリックします。
    • [AND]

    • [OR]

重要

  • 同時実行 プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • 結合オプションとして [OR] を選択した場合、その結合に入力されるすべてのフローが持つアクションは、そのフローに関連付けられたアクション 1 つだけになります。

関連項目

同時実行フローの作成

同時実行フローの終了

同時実行フローの結合


同時実行フローの結合

  1. BizTalk オーケストレーション デザイナの設計ページで、同時実行プロセスを実行しているビジネス プロセス内のシェイプをクリックします。

  2. シェイプの下部の制御ハンドル ( 制御ハンドル) を、結合シェイプの上部の接続ポイント ( 接続ポイント) に接続します。

  3. この結合を再結合するすべての同時実行フローに対して、手順 1. と 2. を繰り返します。

重要

  • 同時実行 プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • 結合オプションとして [OR] を選択した場合、その結合に入力されるすべてのフローが持つアクションは、そのフローに関連付けられたアクション 1 つだけになります。

  • 上部の接続ポイントから結合シェイプに入力できるフローは、最大 64 個です。

  • 結合シェイプの下部の接続ポイントから出力できるフローは 1 つだけです。

  • 複数の同時実行フローを結合する場合は、コネクタ ツールを使用するとフローを簡単に結合できます。コネクタ ツールの詳細については、「コネクタ ツールの使用」を参照してください。

  • フローチャート シェイプ を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

同時実行フローの作成

同時実行フローの終了

シェイプの選択

結合の種類プロパティの設定

コネクタ ツールの使用


同時実行フローの終了

  1. BizTalk オーケストレーション デザイナの設計ページで、同時実行プロセスを実行しているビジネス プロセス内のシェイプをクリックします。

  2. シェイプの下部の制御ハンドル ( 制御ハンドル) を、終了シェイプの上部の接続ポイント ( 接続ポイント) に接続します。

    この同時実行プロセスが終了します。XLANG スケジュール内のほかのフローは再結合されません。

重要

  • 同時実行プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • フローチャート シェイプ を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

同時実行フローの作成

同時実行フローの結合

シェイプの選択

結合の種類プロパティの設定

コネクタ ツールの使用


トランザクション プロパティの設定

ここには次のトピックが含まれます。

  • XLANG スケジュールに対するトランザクション プロパティの設定

  • トランザクション プロパティの個別設定

  • コンポーネントおよびメッセージ キュー トランザクションのサポートについて

関連項目

トランザクションの設計


XLANG スケジュールに対するトランザクション プロパティの設定

ここには次のトピックが含まれます。

  • トランザクション モデルの設定

  • トランザクションのアクティブ化プロパティの設定

関連項目

トランザクションの設計


トランザクション モデルの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[開始] シェイプを右クリックし、[プロパティ] をクリックします。

    [開始のプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクション モデル] で、次のオプションのいずれかをクリックします。
    • [XLANG スケジュールにトランザクションを含める]

      このオプションを選択すると、XLANG スケジュールでトランザクションを使用できるようになります。

    • [XLANG スケジュールを COM+ コンポーネント として扱う]

      このオプションを選択すると、XLANG スケジュールに対するトランザクション サポートが無効になります。そして、COM+ トランザクションのコンテキスト内で、COM コンポーネントが XLANG スケジュールをアクティブにできるようになります。

注

  • "トランザクション モデル" プロパティを [XLANG スケジュールを COM+ コンポーネントとして扱う] に設定すると、[トランザクションのアクティブ化] ボックスの一覧が有効になります。

  • "トランザクション モデル" プロパティを [XLANG スケジュールを COM+ コンポーネント として扱う] に設定した場合は、XLANG スケジュール フローチャートにトランザクションを追加しないでください。XLANG スケジュール フローチャートがコンパイルできなくなり、エラー メッセージが表示されます。

  • XLANG ID のプロパティは、XLANG スケジュール フローチャート インスタンスのバージョンを識別するために使用される一意な ID です。この ID は読み取り専用であり、変更することはできません。XLANG スケジュール フローチャートを更新すると、そのたびに ID も更新されます。

    XLANG ID プロパティを使用すると、XLANG スケジュール フローチャート (.skv) と、それをコンパイルした XLANG スケジュール (.skx) とを対応付けられます。

  • 開始シェイプが使用できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは開始シェイプを使用できません。

関連項目

コンポーネントおよびメッセージ キュー トランザクションのサポートについて

トランザクションの設計

トランザクションのアクティブ化プロパティの設定


トランザクションのアクティブ化プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[開始] シェイプを右クリックし、[プロパティ] をクリックします。

    [開始のプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクション モデル] ボックスの一覧で、[XLANG スケジュールを COM+ コンポーネントとして扱う] をクリックします。

    このオプションを有効にすると、コンポーネント サービスが XLANG スケジュールを COM+ コンポーネントとして扱うようになります。このオプションを選択すると、XLANG スケジュールに対するトランザクション サポートが無効になります。そして、COM+ トランザクションのコンテキスト内で、COM コンポーネントが XLANG スケジュールをアクティブにできるようになります。

  3. [トランザクションのアクティブ化] ボックスの一覧で、次のオプションのいずれかをクリックします。
    • [サポートしない]

      スケジュール作成者の COM+ オブジェクト コンテキストにトランザクションがあっても、XLANG スケジュールはそのトランザクションを無視します。そのトランザクションの範囲内にあるスケジュールのアクションは、まったく実行されません。

    • [サポートする]

      スケジュール作成者の COM+ オブジェクト コンテキストにトランザクションが存在する場合、XLANG スケジュールは COM+ トランザクションに参加します。

    • [必要]

      XLANG スケジュールは、トランザクションの範囲内で実行する必要があります。スケジュール作成者の COM+ オブジェクト コンテキストにトランザクションが存在しない場合、トランザクションが自動的に作成され、XLANG スケジューラ エンジンによって使用されます。

    • [新しいトランザクションを要求する]

      XLANG スケジュールは、新しいトランザクションの範囲内で実行する必要があります。XLANG スケジューラ エンジンは、作成者の COM+ オブジェクト コンテキストに存在するすべてのトランザクションと異なる新しいトランザクションを、スケジュールに対して自動的に作成します。

注

  • XLANG ID のプロパティは、XLANG スケジュール フローチャート インスタンスのバージョンを識別するために使用される一意な ID です。この ID は読み取り専用であり、変更することはできません。XLANG スケジュール フローチャートを更新すると、そのたびに ID も更新されます。

    XLANG ID プロパティを使用すると、XLANG スケジュール フローチャート (.skv) と、それをコンパイルした XLANG スケジュール (.skx) とを対応付けられます。

  • 開始シェイプが使用できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは開始シェイプを使用できません。

関連項目

コンポーネントおよびメッセージ キュー トランザクションのサポートについて

トランザクションの設計

トランザクション モデルの設定


トランザクション プロパティの個別設定

ここには次のトピックが含まれます。

  • トランザクション内のグループ アクションとフロー

  • ネストしたトランザクションの設計

  • トランザクションに入出力されるフローの作成

  • トランザクションの名前設定

  • トランザクションの種類プロパティの設定

  • タイムアウト プロパティの設定

  • 再試行回数プロパティの設定

  • バックオフの時間プロパティの設定

  • 分離レベル プロパティの設定

関連項目

トランザクションの設計


トランザクション内のグループ アクションとフロー

  1. BizTalk オーケストレーション デザイナの設計ページで、[フローチャート] ステンシルの [トランザクション] シェイプを境界バーの左側にドラッグします。

  2. [トランザクション] シェイプのサイズを変更して、シェイプがトランザクションで囲まれるようにします。

注

  • トランザクションの境界内にあるシェイプおよびフローは、すべてそのトランザクションに含まれていると見なされます。

  • トランザクション内のシェイプを選択するには、そのシェイプをクリックします。

  • 境界内にシェイプを含むトランザクションを削除すると、そこに含まれているすべてのシェイプも削除されます。

  • トランザクションの種類は、次の色で示されます。
    • 青 : この色は、定刻トランザクションを示します。

    • ベージュ : この色は、長時間トランザクションを示します。

    • 灰色 : この色は、短時間の DTC スタイルのトランザクションを示します。
  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

トランザクションに入出力されるフローの作成

トランザクションの設計

ネストしたトランザクションの設計

トランザクションの名前設定


ネストしたトランザクションの設計

  1. BizTalk オーケストレーション デザイナの設計ページで、[フローチャート] ステンシルの [トランザクション] シェイプをドラッグし、現在のトランザクションの境界内に配置します。

  2. [トランザクション] シェイプのサイズを変更して、シェイプがトランザクションで囲まれるようにします。

重要

  • ネストしたトランザクションを作成すると、外側のトランザクションの一部のプロパティが無効になります。
    • [短時間の DTC スタイル] のトランザクションは使用できなくなります。

    • [トランザクションのオプション] にあるすべてのオプションが使用できなくなります。

    • [タイムアウト] プロパティはアクティブですが、ネストしたトランザクションを作成すると、トランザクションの種類を [定刻トランザクション] に変えるまで変更できなくなります。

注

  • トランザクションの境界内にあるシェイプおよびフローは、すべてそのトランザクションに含まれていると見なされます。

  • トランザクション内のシェイプを選択するには、そのシェイプをクリックします。

  • 境界内にシェイプを含むトランザクションを削除すると、そこに含まれているすべてのシェイプも削除されます。

  • トランザクションの種類は、次の色で示されます。
    • 青 : この色は、定刻トランザクションを示します。

    • ベージュ : この色は、長時間トランザクションを示します。

    • 灰色 : この色は、短時間の DTC スタイルのトランザクションを示します。
  • 内側のトランザクションに完全に含まれていないフローチャート シェイプは、外側のトランザクションに含まれていると見なされます。

  • 外側のトランザクションに含まれているフローチャート シェイプは、内側のトランザクションと部分的に重複し、内側のトランザクションに完全に含まれていない場合、部分的に表示されないことがあります。この場合は、シェイプを選択し、移動して、重複しないようにしてください。

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

トランザクションに入出力されるフローの作成

トランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定


トランザクションに入出力されるフローの作成

  1. BizTalk オーケストレーション デザイナの設計ページで、ビジネス プロセスのフローにあるトランザクションの前のシェイプをクリックします。

  2. そのシェイプの下部の制御ハンドル ( 制御ハンドル) を、トランザクション シェイプの上部の接続ポイント ( 接続ポイント) に接続します。

  3. [トランザクション] シェイプをクリックし、選択します。

  4. その [トランザクション] シェイプの上部の制御ハンドルを、トランザクション フローの開始を示す、トランザクション内にある最初のシェイプの上部の接続ポイントに接続します。

  5. そのシェイプから、トランザクション内の次のシェイプにフローを接続します。

  6. トランザクション内のすべてのフローを接続し、すべてのアクションを、通信フローを作成するポートに接続します。

  7. トランザクション内にある最後のシェイプの下部の制御ハンドルから、[トランザクション] シェイプの下部の接続ポイントへフローを接続します。

  8. [トランザクション] シェイプをクリックし、選択します。

  9. [トランザクション] シェイプの下部の制御ハンドルを、そのトランザクションの外側にあるビジネス プロセスのフロー内の、次のシェイプの上部の接続ポイントに接続します。

注

  • トランザクション内のシェイプを選択するには、そのシェイプをクリックします。

  • フローチャート シェイプ を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

コネクタ ツールの使用


トランザクションの名前設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [名前] ボックスに、そのトランザクションの名前を入力します。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。
  • 1 バイト文字セットによるトランザクション名の長さは、16 文字以内にします。2 バイト文字セットによるトランザクション名の長さは、8 文字以内にします。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

バックオフの時間プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


トランザクションの種類プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [種類] で、次のオプションのいずれかをクリックします。
    • [定刻トランザクション]

    • [短時間の DTC スタイル]

    • [長時間]

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定


タイムアウト プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [タイムアウト] ボックスに、時間を秒単位で入力します。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

トランザクションの種類プロパティの設定


再試行回数プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [再試行の回数] ボックスに、トランザクションが失敗と見なされるまでに再試行できる回数を入力します。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


バックオフの時間プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [バックオフの時間] に、時間を秒単位で入力します。

注

  • バックオフの時間プロパティによって、トランザクションの再試行の間隔が決まります。このオプションを使用できるのは、短時間の DTC スタイルのトランザクションだけです。バックオフの時間は再試行の回数値と共に使用され、次にトランザクションが再試行を行うまでの待機時間が決定されます。バックオフ値は指数になっています。バックオフ値が 2 秒の場合、再試行の間隔は 2 秒、4 秒、8 秒、16 秒のようになります。計算式は B**R (B の R 乗) です。ここで、B はバックオフの時間、R は現在の再試行の回数を示します。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

分離レベル プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


分離レベル プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [分離レベル] ボックスの一覧から、次のオプションのいずれかをクリックします。
    • [Serializable]

    • [Read Uncommitted]

    • [Read Committed]

    • [Repeatable Read]

注

  • このプロパティを設定できるのは、短時間の DTC スタイルのトランザクションだけです。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

バックオフの時間プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


コンポーネントおよびメッセージ キュー トランザクションのサポートについて

ここには次のトピックが含まれます。

  • COM コンポーネント内でのトランザクションのサポート レベルについて

  • Windows スクリプト コンポーネント内でのトランザクションのサポート レベルについて

  • メッセージ キューが提供するトランザクションのサポートについて

関連項目

トランザクションの設計

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


COM コンポーネント内でのトランザクションのサポート レベルについて

COM コンポーネントに対するトランザクションのサポートは、[COM コンポーネント バインド ウィザード] で設定します。

  1. [COM コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「COM コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対するトランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必要]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

関連項目

XLANG スケジュール フローチャートへのバインド済みポートの追加

トランザクションの設計

COM コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


Windows スクリプト コンポーネント内でのトランザクションのサポート レベルについて

Windows スクリプト コンポーネントに対するトランザクションのサポートは、[スクリプト コンポーネント バインド ウィザード] で設定します。

  1. [スクリプト コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「Windows スクリプト コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対するトランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必要]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

関連項目

XLANG スケジュール フローチャートへのバインド済みポートの追加

トランザクションの設計

Windows スクリプト コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


メッセージ キューが提供するトランザクションのサポートについて

メッセージ キューに対するトランザクションのサポートは、[メッセージ キュー バインド ウィザード] で設定します。

  1. [メッセージ キュー バインド ウィザード] を開きます。

    このウィザードの詳細については、「メッセージ キューを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、[このキューはトランザクションを必要とする] チェックボックスをオンまたはオフにします。

関連項目

XLANG スケジュール フローチャートへのバインド済みポートの追加

トランザクションの設計

メッセージ キューを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


エラー処理プロパティの設定

ここには次のトピックが含まれます。

  • 処理フローの中断

  • トランザクション エラー処理の有効化

  • コンポーネント エラー処理の有効化

関連項目

例外処理


処理フローの中断

  1. BizTalk オーケストレーション デザイナの [フローチャート] ステンシルで、[中断] シェイプをクリックし、設計ページまでドラッグします。

  2. [判断] シェイプから出力される論理分岐から [中断] シェイプの接続ポイント ( 接続ポイント) まで、処理フローを接続します。

重要

  • 中断シェイプは、論理分岐内のビジネス プロセスの中断に使用されます。判断シェイプと組み合わせて使用されます。

    中断シェイプを使用するかどうかは、ビジネス プロセスの必要性によって決まります。判断内に含まれた条件が TRUE と評価されるまで、順番に評価されます。条件が TRUE と評価されると、処理フローは次のアクションに進みます。TRUE と評価される条件がない場合は、処理フローを中断します。

    次の図は、条件が TRUE と評価されると処理フローはアクション 3 へ進むという、判断条件を示しています。TRUE と評価される条件がない場合、処理フローは中断されます。

    図をクリックすると、拡大または縮小します。

関連項目

コンポーネント エラー処理の有効化

トランザクション エラー処理の有効化

例外処理

論理分岐


トランザクション エラー処理の有効化

ここには次のトピックが含まれます。

  • 失敗時エラー処理の有効化

  • 補正エラー処理の有効化

関連項目

処理フローの中断

例外処理


失敗時エラー処理の有効化

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [失敗時] の [コードの追加] をクリックします。

  3. [失敗時] の [有効にする] チェック ボックスをオンにします。

注

  • [コードの追加] をクリックすると、このトランザクションに関連付けられたトランザクションの [<トランザクション> の失敗時] ページが作成されます。ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • [有効にする] チェック ボックスをオンにすると、XLANG スケジュールがこのトランザクションに対して失敗時に実行されるコードを実行するようになります。このチェック ボックスをオンにしなかった場合、失敗時のプロセスを設計することはできますが、XLANG スケジュールの実行中に実行することはできません。

関連項目

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

例外処理


補正エラー処理の有効化

  1. BizTalk オーケストレーション デザイナの設計ページで、ネストしたトランザクション グループの内側にある [トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [補正] の [コードの追加] をクリックします。

  3. [補正] の [有効にする] チェック ボックスをオンにします。

注

  • [コードの追加] をクリックすると、このトランザクションに関連付けられた [<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが作成されます。

  • [有効にする] チェック ボックスをオンにすると、XLANG スケジュールがこのトランザクションに対して失敗時に実行されるコードまたは補正コードを実行するようになります。このチェック ボックスをオンにしなかった場合、失敗時および補正のプロセスを設計することはできますが、XLANG スケジュールの実行中に実行することはできません。

  • ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • トランザクションの種類は、次の色で示されます。
    • 青 : この色は、定刻トランザクションを示します。

    • ベージュ : この色は、長時間トランザクションを示します。

    • 灰色 : この色は、短時間の DTC スタイルのトランザクションを示します。

関連項目

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

例外処理


コンポーネント エラー処理の有効化

ここには次のトピックが含まれます。

  • COM コンポーネントが失敗を返した場合のトランザクションの中断

  • Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断

関連項目

処理フローの中断

例外処理


COM コンポーネントが失敗を返した場合のトランザクションの中断

COM コンポーネントに対するトランザクションのサポートは、[COM コンポーネント バインド ウィザード] で設定します。

  1. [COM コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「COM コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。

重要

  • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

    このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

関連項目

Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断

XLANG スケジュール フローチャートへのバインド済みポートの追加

例外処理

COM コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断

Windows スクリプト コンポーネントに対するトランザクションのサポートは、[スクリプト コンポーネント バインド ウィザード] で設定します。

  1. [スクリプト コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「Windows スクリプト コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。

重要

  • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

    このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

関連項目

COM コンポーネントが失敗を返した場合のトランザクションの中断

XLANG スケジュール フローチャートへのバインド済みポートの追加

例外処理

Windows スクリプト コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


ポートの実装

BizTalk オーケストレーション デザイナには、ポート通信の実装に使用可能な技術を表す、4 種類の実装シェイプが用意されています。これらのシェイプについて、次の表に示します。

シェイプ名 | 説明
COM コンポーネント | [COM コンポーネント] シェイプは、送受信されるメッセージごとにメソッド呼び出しを使用してポートを実装するテクノロジを表します。このシェイプを境界バーの右側までドラッグすると、COM コンポーネント バインド ウィザードが表示されます。
スクリプト コンポーネント | [スクリプト コンポーネント] シェイプは、送受信されるメッセージごとにメソッド呼び出しを使用してポートを実装するテクノロジを表します。このシェイプを境界バーの右側までドラッグすると、スクリプト コンポーネント バインド ウィザードが表示されます。
メッセージ キュー | [メッセージ キュー] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、メッセージ キュー サービスが使用されます。このシェイプを境界バーの右側までドラッグすると、メッセージ キュー バインド ウィザードが表示されます。
BizTalk メッセージ | [BizTalk メッセージ] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、BizTalk メッセージ サービスが使用されます。ポートの実装には、BizTalk Server メッセージ ポートまたはメッセージ チャネルを使用できます。このシェイプを境界バーの右側までドラッグすると、BizTalk メッセージ バインド ウィザードが表示されます。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートへの未バインド ポートの追加

  • XLANG スケジュール フローチャートへのバインド済みポートの追加

  • COM コンポーネントを使用したポートの実装

  • Windows スクリプト コンポーネントを使用したポートの実装

  • メッセージ キューを使用したポートの実装

  • BizTalk メッセージを使用したポートの実装

  • ポート実装のプロパティの変更

関連項目

通信シェイプ

フローチャート シェイプ

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

メッセージの送信と受信

ポート実装について

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


XLANG スケジュール フローチャートへの未バインド ポートの追加

  • BizTalk オーケストレーション デザイナの設計ページで、境界バーを右クリックし、[新しいポートの追加] をクリックします。

注

  • ポートを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポートを使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 未バインド ポートは、メッセージ キューまたは BizTalk メッセージを使用して実装できます。このような実装をページに追加する場合、使用可能な未バインド ポートを実装ウィザードで選択できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

メッセージの送信と受信


XLANG スケジュール フローチャートへのバインド済みポートの追加

  • BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [実装] シェイプを境界バーの右側にドラッグし、ウィザードの手順に従って実装を行います。

注

  • ポートを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポートを使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

メッセージの送信と受信


COM コンポーネントを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [COM コンポーネント] シェイプを境界バーの右側にドラッグします。

    [COM コンポーネント バインド ウィザード] が表示されます。

  2. [COM コンポーネント バインド ウィザードへようこそ] ページで、作成するポートの名前を入力します。

    BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

    [次へ] をクリックします。

  3. [静的または動的な通信] ページで、次のオプションのいずれかをクリックします。
    • [静的]

      XLANG スケジューラ エンジンが、このコンポーネントのインスタンスを作成します。

      [静的] をクリックすると、XLANG スケジュール インスタンスが終了したときに、このコンポーネントが自動的に破棄されます。

      [次へ] をクリックします。手順 4. に進みます。

    • [動的]

      このオプションを選択すると、別のアプリケーションがコンポーネントのインスタンスを作成します。オブジェクト インスタンスへのモニカまたはポインタを、メッセージ内のフィールドとして XLANG スケジュールに返す必要があります。[データ] ページでは、そのメッセージ フィールドと、この実装を使用するポートのポート参照との間に、接続を描画する必要があります。メッセージを特定のポートへ送信する方法については、「メッセージとポートの対応付け」を参照してください。

      [次へ] をクリックします。手順 5. に進みます。

    • [インスタンスを作成しない]

      データの受信だけが目的の場合、このオプションを選択します。このオプションでは、メソッドを使用してデータを XLANG スケジュールに渡しますが、そのメソッド呼び出しに関連するコードは実行しないことが指定されます。詳細については、「データ処理」を参照してください。

      [次へ] をクリックします。手順 5. に進みます。

    静的な通信および動的な通信の詳細については、次のトピックを参照してください。

    • 静的ポートと動的ポート

    • インスタンス管理

    • スクリプト コンポーネント シェイプの使用
  4. [クラス情報] ページで、次のオプションのいずれかをクリックします。
    • [登録されたコンポーネントから]

      ツリー制御には、コンピュータに登録されているすべてのコンポーネントが表示されます。使用するクラスのフォルダを展開し、クラスをクリックします。

      [次へ] をクリックします。手順 5. に進みます。

    • [モニカから]

      標準の COM モニカの名前を入力し、インスタンスを作成する COM コンポーネントの場所を指定します。このオプションを使用すると、XLANG スケジュールのトランザクション内で実行される通信に、COM コンポーネントを使用できなくなります。

      [次へ] をクリックします。手順 5. に進みます。

  5. [インターフェイス情報] ページで、使用するインターフェイスをクリックします。

    [次へ] をクリックします。手順 6. に進みます。

    注

    • COM コンポーネントにインターフェイスが 1 つしかない場合、このページは表示されません。

    • Microsoft Visual Basic で作成された COM コンポーネントの場合、そのコンポーネントに含まれるクラスごとに、そのクラスと同じ名前のインターフェイスが 1 つあります。各インターフェイス名の前には、アンダースコア (_) が付きます。
  6. [メソッド情報] ページで、使用するメソッドを選択します。

    [次へ] をクリックします。手順 7. に進みます。

    注

    • COM コンポーネントにメソッドが 1 つしかない場合、このページは表示されません。

    • 最低 1 つのメソッドを選択する必要があります。

    • 複数のメソッドを選択したり、すべてのメソッドを選択することもできます。[すべて選択] または [すべて取り消し] を使用すると、すべてのメソッドを選択したり、選択解除することができます。
  7. [ポート プロパティの詳細設定] ページの [セキュリティ] で、次のオプションのいずれかをクリックします。
    • [必要なし]

      送信者の ID は確認されません。

    • [オプション]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。ID が利用可能かどうかにかかわらず、XLANG スケジュールは継続して実行されます。

    • [必要]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。送信者 ID は必須です。ID が利用できない場合、XLANG スケジュールはメッセージを無視します。

    注

    • ID が必要にもかかわらず利用できないため、XLANG スケジュールが受信メソッド呼び出しを拒否した場合、エラー コード「E_ACCESSDENIED」が呼び出し元に返されます。
  8. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対する、トランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必要]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

  9. [ポート プロパティの詳細設定] ページの [ステータス管理のサポート] で、次のオプションのいずれかをクリックします。
    • [ステータスを保持しない]

      このポート実装で使用されるコンポーネントは、メソッド呼び出し間でステータスを保持しません。

    • [ステータスを保持し、永続的にサポートしない]

      このポート実装で使用されるコンポーネントは、そのコンポーネントの存続期間の間ステータスを保持しますが、そのコンポーネントは永続的ではありません。

    • [ステータスを保持し、永続的にサポートする]

      このポート実装で使用されるコンポーネントは、IPersistStream インターフェイスまたは IPersistStreamInit インターフェイスのいずれかを使用して保存できるステータスを保持します。これらのインターフェイスを使用すると、その後のインスタンス作成に備えてコンポーネントのステータスを保存し、その保存されたステータスを使用してコンポーネントを再作成できます。

  10. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンまたはオフにします。

    重要

    • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

      このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

  11. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • COM コンポーネントの実装で使用するための新しいポートが必ず作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

ポート実装について

COM コンポーネント シェイプの使用

メソッド通信ウィザードの使用


Windows スクリプト コンポーネントを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [スクリプト コンポーネント] シェイプを境界バーの右側にドラッグします。

    [スクリプト コンポーネント バインド ウィザード] が表示されます。

  2. [スクリプト コンポーネント バインド ウィザードへようこそ] ページで、作成するポートの名前を入力します。

    BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

    [次へ] をクリックします。手順 3. に進みます。

  3. [静的または動的な通信] ページで、次のオプションのいずれかをクリックします。
    • [静的]

      XLANG スケジューラ エンジンが、このコンポーネントのインスタンスを作成します。

      [静的] をクリックすると、XLANG スケジュール インスタンスが終了したときに、このコンポーネントが自動的に破棄されます。

      [次へ] をクリックします。手順 4. に進みます。

    • [動的]

      このオプションを選択すると、別のアプリケーションがコンポーネントのインスタンスを作成します。オブジェクト インスタンスへのモニカまたはポインタを、メッセージ内のフィールドとして XLANG スケジュールに返す必要があります。[データ] ページでは、そのメッセージ フィールドと、この実装を使用するポートのポート参照との間に、接続を描画する必要があります。メッセージを特定のポートへ送信する方法については、「メッセージとポートの対応付け」を参照してください。

      [次へ] をクリックします。手順 4. に進みます。

    • [インスタンスを作成しない]

      データの受信だけが目的の場合、このオプションを選択します。このオプションでは、メソッドを使用してデータを XLANG スケジュールに渡しますが、そのメソッド呼び出しに関連するコードは実行しないことが指定されます。

      [次へ] をクリックします。手順 4. に進みます。

    静的な通信および動的な通信の詳細については、次のトピックを参照してください。

    • 静的ポートと動的ポート

    • インスタンス管理

    • スクリプト コンポーネント シェイプの使用
  4. [スクリプト ファイルの指定] ページで [参照] をクリックします。

  5. [スクリプト ファイルの選択] ダイアログ ボックスで、使用する .wsc ファイルの場所を参照し、ファイルをクリックします。次に、[開く] をクリックします。

    [次へ] をクリックし、次のいずれかに従って進みます。

    • 手順 3. で [静的] を選択した場合は、手順 6. に進みます。

    • 手順 3. で [動的] または [インスタンスを作成しない] を選択した場合は、手順 7. に進みます。
  6. [コンポーネントのインスタンス作成情報] ページで、次のいずれかをクリックします。
    • [スクリプト ファイルのモニカを使用]

      スクリプト ファイルのパスと名前が、モニカとして自動的に与えられます。

      [次へ] をクリックします。手順 7. に進みます。

    • [ProgID <ProgID> を使用]

      ProgID が自動的に与えられ、Windows スクリプト コンポーネント ファイルの XML から抽出されます。スクリプト ファイルのパスはハード コーディングされていないため、これを推奨します。

      [次へ] をクリックします。手順 7. に進みます。

  7. [メソッド情報] ページで、使用するメソッドを選択します。

    [次へ] をクリックします。手順 8. に進みます。

    注

    • Windows スクリプト コンポーネントにメソッドが 1 つしかない場合、このページは表示されません。

    • 最低 1 つのメソッドを選択する必要があります。

    • 複数のメソッドを選択したり、すべてのメソッドを選択することもできます。[すべて選択] または [すべて取り消し] を使用すると、すべてのメソッドを選択したり、選択解除することができます。
  8. [ポート プロパティの詳細設定] ページの [セキュリティ] で、次のオプションのいずれかをクリックします。
    • [必要なし]

      送信者の ID は確認されません。

    • [オプション]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。ID が利用可能かどうかにかかわらず、XLANG スケジュールは継続して実行されます。

    • [必要]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。送信者 ID は必須です。ID が利用できない場合、XLANG スケジュールはメッセージを無視します。

    注

    • ID が必要にもかかわらず利用できないため、XLANG スケジュールが受信メソッド呼び出しを拒否した場合、エラー コード「E_ACCESSDENIED」が呼び出し元に返されます。
  9. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対する、トランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必要]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

  10. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンまたはオフにします。

    重要

    • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

      このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

  11. [完了] をクリックします。

重要

  • Windows スクリプト コンポーネントを使用する場合、そのコンポーネントは次の規則に従っている必要があります。
    • 引数宣言は、値ではなく参照で行う必要があります。

    • Microsoft Visual Basic スクリプトのサブルーチンはサポートされていません。関数だけがサポートされています。

    • 1 つの .wsc ファイル内で複数のコンポーネントは使用できません。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • Windows スクリプト コンポーネントの実装で使用するための新しいポートが必ず作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

  • Windows スクリプト コンポーネント ファイルで使用されるファイル拡張子は .wsc です。Windows スクリプト コンポーネントの詳細については、Windows Scripting Technologies の Web サイト (www.microsoft.com/japan/developer/scripting/) にある Windows スクリプト コンポーネントのページを参照してください。

  • XLANG スケジューラ エンジンで実行されている Windows スクリプト コンポーネントは、XLANG スケジューラ エンジンと Windows スクリプト ホストの両方がシャットダウンされるまで変更できません。

関連項目

COM コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

ポート実装について

スクリプト コンポーネント シェイプの使用

メソッド通信ウィザードの使用


メッセージ キューを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [メッセージ キュー] シェイプを境界バーの右側にドラッグします。

    [メッセージ キュー バインド ウィザード] が表示されます。

  2. [メッセージ キュー バインド ウィザードへようこそ] ページで、次のオプションのいずれかをクリックします。
    • [新しいポートの作成]

      BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

      [次へ] をクリックします。手順 3. に進みます。

    • [既存の未バインド ポート]

      [既存の未バインド ポート] ボックスの一覧で、使用するポートをクリックします。

      [既存の未バインド ポート] ボックスの一覧には、未バインド ポートの名前だけが表示されます。未バインド ポートには、定義済みの実装がありません。

      [次へ] をクリックします。手順 3. に進みます。

  3. [静的または動的キューの情報] ページで、次のオプションのいずれかをクリックします。
    • [静的キュー]

      静的キューとは、既存のキューです。このキューは、設計時に存在している必要があります。

      [次へ] をクリックします。手順 4. に進みます。

    • [動的キュー]

      このオプションを選択する場合、メッセージ フィールドからこのポートのポート参照へのリンクを、[データ] ページで作成する必要があります。

      このポート実装を使用して通信アクションが実行される前に、メッセージ キューの名前を別のメッセージで指定する必要があります。特定のメッセージとポートの対応付けについては、「メッセージとポートの対応付け」を参照してください。

      [次へ] をクリックします。手順 5. に進みます。

    静的キューと動的キューの詳細については、「静的ポートと動的ポート」を参照してください。

  4. [キュー情報] ページで、次のオプションのいずれかをクリックします。
    • [すべてのインスタンスごとに新しいキューを作成する]

      キューにはプレフィックスを付ける必要があります。例 : ".\Private$\PrivateQueuePrefix"、".\PublicQueuePrefix" など。作成する新しいキューごとに、一意な ID がプレフィックスに追加されます。

      キューのプレフィックスは既定で割り当てられます。この既定のプレフィックスは変更できます。

      ほかからこのポートに返信できるようにするには、このポートへの参照をメッセージに含めて送信する必要があります。それには、[すべてのインスタンスごとに新しいキューを作成する] をオンにし、ルート キュー名を入力します。実行時には、各インスタンスに対してこのルート名を持った新しいキューが XLANG スケジューラ エンジンによって作成され、作成された各キューのルート名にインスタンスの GUID が追加されます。インスタンスが終了すると、このキューは削除されます。

      このポートへの参照を送信しない場合は、インスタンスごとにキューを作成する必要がありません。すべてのインスタンスで使用されるキューを 1 つ作成するだけでかまいません。

      [次へ] をクリックします。手順 5. に進みます。

    • [すべてのインスタンスに対して既存のキューを使用する]

      既存のキュー名を入力します。例 : ".\private$\queuename"

      [次へ] をクリックします。手順 5. に進みます。

  5. [ポート プロパティの詳細設定] ページの [セキュリティ] で、次のオプションのいずれかをクリックします。
    • [必要なし]

      送信者の ID は確認されません。XLANG スケジュールは、メッセージが認証されたかどうかにかかわらず、空の __Sender__ フィールドを持ったメッセージを必ず受信します。

    • [オプション]

      XLANG スケジューラ エンジンによって、送信者の ID の確認要求が送信されます。メッセージが認証されたかどうかにかかわらず、XLANG スケジュールはメッセージを受信します。メッセージが認証された場合は、__Sender__ フィールドにメッセージ キューのメッセージの SenderID プロパティが格納されます。

    • [必要]

      XLANG スケジューラ エンジンによって、送信者の ID の確認要求が送信されます。送信者 ID の確認は必須です。メッセージが認証された場合、XLANG スケジュールはメッセージを受信し、__Sender__ フィールドにメッセージ キュー メッセージの SenderID プロパティが格納されます。

      メッセージが認証されなかった場合、アプリケーションのイベント ログが作成され、.\private$\<アプリケーション名>.DeadLetter という名前で作成された新しいキューにメッセージが移動されます。

  6. [ポート プロパティの詳細設定] ページの [セキュリティ] で、[Windows のグループ名またはユーザー名を使用して、キューを制御する] チェック ボックスをオンまたはオフにします。

    このチェックボックスをオンにした場合は、キューへのメッセージの書き込みを許可するユーザーまたはグループの名前を入力します。このオプションを使用できるのは、静的キューを使用している場合だけです。

  7. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、[このキューはトランザクションを必要とする] チェックボックスをオンまたはオフにします。

  8. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

ポート実装について

メッセージ キュー シェイプの使用

XML 通信ウィザードの使用


BizTalk メッセージを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [BizTalk メッセージ] シェイプを境界バーの右側にドラッグします。.

    [BizTalk メッセージ バインド ウィザード] が表示されます。

  2. [BizTalk メッセージ バインド ウィザードへようこそ] ページで、次のオプションのいずれかをクリックします。
    • [新しいポートの作成]

      BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

      [次へ] をクリックします。手順 3. に進みます。

    • [既存の未バインド ポート]

      [既存の未バインド ポート] ボックスの一覧で、使用するポートをクリックします。

      [既存の未バインド ポート] ボックスの一覧には、未バインド ポートの名前だけが表示されます。未バインド ポートには、定義済みの実装がありません。

      [次へ] をクリックします。手順 3. に進みます。

  3. [通信の方向] ページで、次のオプションのいずれかをクリックします。
    • [送信]

      [次へ] をクリックします。手順 4. に進みます。

    • [受信]

      [次へ] をクリックします。手順 5. に進みます。

    注

    • [受信] を選択した場合、HTTP URL 送信先を使用するか、XLANG スケジュールからメッセージを受信するように BizTalk メッセージ マネージャを使ってメッセージ ポートを構成して XLANG スケジュールをインスタンス化するようにし、そのスケジュール内の特定のポートにメッセージを送信させることで、メッセージを受信できます。HTTP URL によるメッセージ受信の詳細については、「BizTalk サービスの統合」を参照してください。BizTalk メッセージ マネージャによるメッセージ ポートの構成の詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  4. [静的または動的チャネルの情報] ページで、次のオプションのいずれかをクリックします。
    • [静的チャネル]

      既存のチャネルの名前を入力します。[完了] をクリックします。

    • [動的チャネル]

      このオプションを選択した場合は、BizTalk メッセージ サービスで実行時に必要になるデータを提供するためのポートを構成する必要があります。このデータによって、メッセージを処理するための適切なチャネルを特定します。

      以前に受信したメッセージ フィールドからこのポートのポート参照へのリンクを、[データ] ページで作成する必要があります。メッセージ フィールドは送信先アドレスを含んでいなければなりません。このアドレスは、そのチャネルに関連付けられているオープンなメッセージ ポート用の送信先アドレスとして BizTalk メッセージ サービスが使用します。詳細については、「BizTalk サービスの統合」を参照してください。

      アクションからこのポートへの通信フローを確立するには、XML 通信ウィザードを使用します。[メッセージの種類の情報] ページの [メッセージの種類] ボックスに、チャネルの受信ドキュメント定義の名前を入力します。BizTalk メッセージ サービスは、このデータを使用して、メッセージを処理するためのチャネルを識別します。詳細については、「識別」を参照してください。

      [完了] をクリックします。

    重要

    • 指定した受信ドキュメント定義を使うチャネルが、少なくとも 1 つ BizTalk メッセージ サービスで構成されている必要があります。アクションが BizTalk メッセージにバインドされているポートと通信し、バインドの指定されたチャネルがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

    • 指定した受信ドキュメント定義を使用するチャネルは、BizTalk メッセージ サービスで 1 つだけ構成し、XLANG スケジュールを送信元として構成してください。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。そのチャネルは、オープンなメッセージ ポートと関連付ける必要もあります。アクションが BizTalk メッセージにバインドされているポートと通信した場合に、バインド用のチャネルが複数存在していたときには、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。
  5. [XLANG スケジュールのアクティブ化情報] ページで、次のオプションのいずれかをクリックします。
    • [はい]

      このポートは、ループ内の複数の受信アクションまたは 1 つの受信アクションで使用できません。

      [完了] をクリックします。

    • [いいえ]

      [次へ] をクリックします。手順 6. に進みます。

  6. [チャネル情報] ページの [チャネル名] ボックスに、使用するチャネルの名前を入力します。チャネルの詳細については、「チャネルについて」および「チャネルの検索」を参照してください。

  7. [チャネル情報] ページの [BizTalk メッセージ サービスがドキュメントを受信する http URL アドレス] ボックスに、BizTalk Server がこのチャネルのドキュメントを受信する、受信側の URL アドレスを入力します。

  8. [完了] をクリックします。

重要

  • メッセージを受信したときに新しい XLANG スケジュールがアクティブになるようにポートを構成する場合、次の制限を考慮する必要があります。
    • メッセージを受信したときにスケジュールをアクティブにするために使用できるポートは、1 つのスケジュール内で 1 つだけです。

    • このポートで受信できるアクションは 1 つだけです。

    • この 1 つのアクションは、ループ本体に含められません。

    • このポートのポート参照からスケジュール内のほかのメッセージへのデータ フローの接続は、描画できません。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

BizTalk サービスの統合

メッセージとポートの対応付け

ポート実装のプロパティの変更

チャネルの検索

チャネルについて

ポート実装について

BizTalk メッセージ シェイプの使用

XML 通信ウィザードの使用


ポート実装のプロパティの変更

  1. BizTalk オーケストレーション デザイナの設計ページで、変更する [実装] シェイプを右クリックします。

  2. [プロパティ] をクリックします。

    その実装シェイプのウィザードが表示されます。

  3. ウィザードの手順に従って、目的のプロパティを変更します。

注

  • ポート実装を変更できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 実装のウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装


メッセージの送信と受信

BizTalk オーケストレーション デザイナには 2 つの形式の通信が用意されており、XLANG スケジュールはそれを使用することで、メッセージの送信と受信を行うことができます。

  • 同期通信 : メソッド呼び出しを使用して、同期メッセージの組が送信および受信されます。

  • 非同期通信 : XML メッセージを使用して、非同期メッセージが送信および受信されます。

詳細については、「同期通信と非同期通信」を参照してください。

ここには次のトピックが含まれます。

  • アクションとポート間の通信フローの確立

  • 同期メッセージの送信と受信

  • 非同期メッセージの送信と受信

  • アクションとポート間の通信フローの変更

関連項目

同期通信と非同期通信

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


アクションとポート間の通信フローの確立

  1. BizTalk オーケストレーション デザイナの設計ページで、[アクション] シェイプをクリックし、選択します。

  2. [アクション] シェイプの右側の制御ハンドル ( 制御ハンドル) を、[ポート] シェイプの接続ポイント ( 接続ポイント) にドラッグします。

    通信ウィザードが表示されます。

  3. 作成する通信フローの種類に応じて、次のいずれかの手順に進みます。
    • COM コンポーネントまたはスクリプト コンポーネント実装を使用するポートへの同期通信フローを作成する場合は、[メソッド通信ウィザード] を使用します。「同期メッセージの送信と受信」へ進んでください。

    • メッセージ キューまたは BizTalk メッセージの実装を使用するポートへの非同期通信フローを作成する場合、および未バインド ポートへの非同期通信フローを作成する場合は、XML 通信ウィザードを使用する必要があります。「非同期メッセージの送信と受信」へ進んでください。

注

  • シェイプの接続には、コネクタ ツールも使用できます。詳細については、「コネクタ ツールの使用」を参照してください。

  • アクションとポート間の通信フローを確立できるのは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは、アクションおよびポートを使用できません。

  • [データ] ページにはシェイプを追加できません。アクションをポートに接続するたびに、[データ] ページに新しいメッセージが自動的に作成されます。


同期メッセージの送信と受信

BizTalk オーケストレーション デザイナで、アクションとポートとの間に同期通信用の通信フローを作成すると、[メソッド通信ウィザード] が表示されます。通信フロー作成の詳細については、「アクションとポート間の通信フローの確立」を参照してください。

  1. [メソッド通信ウィザードへようこそ] ページで、次のオプションのいずれかをクリックします。
    • [同期メソッド呼び出しを開始する]

      XLANG スケジューラ エンジンによって、同期メソッド呼び出しが開始されます。

      この場合、XLANG スケジューラ エンジンがコンポーネントへメソッド呼び出しを送信し、コンポーネントからの応答を待って、応答を受信します。

      [次へ] をクリックします。手順 3. に進みます。

    • [同期メソッド呼び出しを待つ]

      XLANG スケジューラ エンジンは、ほかのアプリケーションによって開始されたメソッド呼び出しの受信を待ちます。

      この場合、XLANG スケジューラ エンジンは、ほかのアプリケーションがメソッド呼び出しを開始するのを待ちます。そのアプリケーションがメソッド呼び出しをコンポーネントに送信し、XLANG スケジューラ エンジンはそのコンポーネントからの応答を待って、アプリケーションに応答を返します。XLANG スケジュールは、メソッド要求とメソッド応答の両方をインターセプトします。

      手順 2. に進みます。

  2. XLANG スケジュールの実行を最適化するには、[メソッド通信ウィザードへようこそ] ページで、XLANG スケジューラ エンジンがメッセージの受信を待つ時間を秒単位で入力します。

    既定の待ち時間は 0 秒です。この時間は変更することができます。180 秒以下の値を指定すると、XLANG スケジュールはステータス退避を行わなくなります。180 秒よりも大きい値を指定すると、XLANG スケジュールは直ちにステータス退避を行います。待ち時間と XLANG スケジュールのステータス退避の詳細については、「ステータス退避とステータス復元」および「メソッド通信ウィザードの使用」を参照してください。

    [次へ] をクリックします。手順 3. に進みます。

  3. [メッセージ情報] ページで、次のオプションのいずれかをクリックします。
    • [新しいメッセージの作成]

      このメッセージの名前は、このウィザードの次のページで選択するメソッドによって自動的に決定されます。新しいメッセージのデータ フローは、[データ] ページのほかのメッセージに接続されている必要があります。

      [次へ] をクリックします。手順 4. に進みます。

    • [既存の同期メッセージ ペアに参照を追加]

      既に構成済みのメッセージの組への参照が、この通信フローに追加されます。このようなメッセージの組は、同じ内に限って再利用できます。ほかのポート実装では使用できません。

      [完了] をクリックします。

  4. [メッセージ仕様情報] ページの [メソッド] ボックスの一覧で、使用するメソッドをクリックします。この一覧から選択できるメソッドは 1 つだけです。

    メソッドを選択することで、この通信フローに対するメッセージが定義されます。<入力> および <出力> パラメータは、選択したメソッドのパラメータ条件から自動的に決まります。どちらのパラメータ一覧にも、パラメータの名前とデータ型が含まれています。

    通信フローで使用されるメッセージの定義については、「同期通信」を参照してください。

  5. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • [同期メソッド呼び出しを待つ] をクリックしない限り、待ち時間プロパティは有効になりません。

  • 同期通信の使用中に利用できるメソッドは、ポート実装に対して選択されたものだけです。ほかのポート実装のメソッドは使用できません。また、非同期通信フローの XML メッセージも使用できません。利用可能なメソッドを変更するには、ポート実装のウィザードをもう一度起動し、ほかのメソッドを選択します。

  • 同期通信を作成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで使用されるメソッドとパラメータに対応しています。メッセージには、そのメソッドに対するすべての <入力> パラメータと、そのメソッドに対するすべての <出力> パラメータが含まれています。

    メソッドにパラメータを含めないことは可能ですが、メッセージには入力必須のシステム フィールドが必ず含まれます。同期通信で使用されるメッセージの定義については、「同期通信」を参照してください。

関連項目

ステータス退避とステータス復元

アクションとポート間の通信フローの確立

ポートの実装

非同期メッセージの送信と受信

同期通信

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


非同期メッセージの送信と受信

  1. [XML 通信ウィザードへようこそ] ページで、次のオプションのいずれかをクリックします。
    • [送信]

      メッセージが非同期で送信されます。

      [次へ] をクリックします。手順 3. に進みます。

    • [受信]

      XLANG スケジューラ エンジンは、メッセージの受信を待ってから XLANG スケジュールを続行します。

      手順 2. に進みます。

  2. XLANG スケジュールの実行を最適化するには、[XML 通信ウィザードへようこそ] ページで、XLANG スケジューラ エンジンがメッセージの受信を待つ時間を秒単位で入力します。

    既定の待ち時間は 0 秒です。この時間は変更することができます。180 秒以下の値を指定すると、XLANG スケジュールはステータス退避を行わなくなります。180 秒よりも大きい値を指定すると、XLANG スケジュールは直ちにステータス退避を行います。待ち時間と XLANG スケジュールのステータス退避の詳細については、「ステータス退避とステータス復元」および「XML 通信ウィザードの使用」を参照してください。

    [次へ] をクリックします。手順 3. に進みます。

  3. [メッセージ情報] ページで、次のオプションのいずれかをクリックします。
    • [新しいメッセージの作成]

      [メッセージ名] ボックスに、メッセージの名前を入力します。既定のメッセージ名はメッセージに数字を追加した名前です。この名前は変更できます。

      新しいメッセージのデータ フローは、[データ] ページのほかのメッセージに接続されている必要があります。

    • [既存のメッセージに参照を追加]

      既に構成済みのメッセージへの参照が、この通信フローに追加されます。

    [次へ] をクリックし、次のいずれかの手順に進みます。

    • [XML 通信ウィザードへようこそ] ページで [送信] をクリックした場合は、手順 4. へ進みます。

    • [XML 通信ウィザードへようこそ] ページで [受信] をクリックした場合は、手順 6. へ進みます。
  4. [XML 変換情報] ページで、次のオプションのいずれかをクリックします。
    • [XML メッセージをキューに送信します]

    • [メッセージをキューに文字列として送信します]

      XLANG スケジューラ エンジンは、この文字列から標準 XML ラッパーを削除する必要があります。

    XLANG スケジューラ エンジン内のデータ フローは、XML を使用して処理されます。スケジューラ エンジンは標準で、XML メッセージをメッセージ キューに送信します。スケジューラ エンジンは、メッセージから標準 XML ラッパーを削除し、文字列として送信することもできます。データ フローでは、このアクションに対する正しい仕様書式でメッセージが配信される必要があります。

    XML メッセージを文字列として送信または受信する場合は、このメッセージの [データ] ページに作成された [メッセージ] シェイプに、StringData という名前のフィールドが含まれている必要があります。また、このメッセージには仕様フィールドを追加できません。

    [次へ] をクリックします。手順 5. に進みます。

  5. [メッセージの種類の情報] ページの [メッセージの種類] ボックスで、メッセージのラベル指定を入力します。

    入力したテキストは、メッセージがキューに送信されるときにメッセージのラベルとして使用されます。

    次のいずれかの手順に進みます。

    • [XML 変換情報] ページで [XML メッセージをキューに送信します] をクリックした場合は、[次へ] をクリックします。手順 8. に進みます。

    • [XML 変換情報] ページで [メッセージをキューに文字列として送信します] をクリックした場合は、[完了] をクリックします。
  6. [XML 変換情報] ページで、次のオプションのいずれかをクリックします。
    • [キューから XML メッセージを受信する]

    • [キューから文字列メッセージを受信する]

      XLANG スケジューラ エンジンは、エンジンの標準 XML ラッパーの文字列をラップする必要があります。

    XLANG スケジューラ エンジン内のデータ フローは、XML を使用して処理されます。スケジューラ エンジンは標準で、XML メッセージをメッセージ キューから受信します。スケジューラ エンジンは、メッセージを文字列として受信し、それを XML でラップすることもできます。

    [次へ] をクリックします。手順 7. に進みます。

  7. [メッセージの種類の情報] ページの [メッセージの種類] ボックスで、メッセージのラベル指定を入力します。

    入力したテキストは、メッセージ キューから受信するメッセージを正しく識別するために使用されます。

    最初に、XLANG スケジューラ エンジンはメッセージの種類の情報をキュー内にあるメッセージ ラベルと照合し、一致するものを探します。

    次に、キュー内にあるメッセージが XML 形式である場合、XLANG スケジューラ エンジンはメッセージの種類の情報をキュー内にあるメッセージの XML ルートの要素と照合し、一致するものを探します。

    次のいずれかの手順に進みます。

    • [XML 変換情報] ページで [キューから XML メッセージを受信する] をクリックした場合は、[次へ] をクリックします。手順 8. に進みます。

    • [XML 変換情報] ページで [キューから文字列メッセージを受信する] をクリックした場合は、[完了] をクリックします。
  8. [メッセージ仕様情報] ページで [参照] をクリックします。

  9. [仕様の参照] ダイアログ ボックスで、使用する仕様を参照し、[開く] をクリックします。

    選択した仕様のファイル パスとファイル名が、[メッセージ仕様情報] ページの [メッセージ仕様] ボックスに入力されます。

    注

    • 既存の仕様を参照しない場合は、[作成] をクリックします。この操作によって BizTalk エディタが起動し、このメッセージで使用する仕様を選択したり、必要に応じて変更することができます。新しい仕様を作成することもできます。

    • 仕様を参照して選択した場合は、[作成] ボタンが [編集] という名前になります。[編集] をクリックすると、選択した仕様を変更できます。
  10. 仕様に対してメッセージを検証する場合は、[メッセージ仕様情報] ページの [仕様に対してメッセージを検証] チェック ボックスをオンにします。

    注

    • 検証する仕様を選択しないと、このチェック ボックスは有効になりません。
  11. [メッセージ仕様情報] ページの [メッセージ フィールド] ボックスの一覧にフィールドを追加する場合は、[追加] をクリックします。

    重要

    • このメッセージ仕様の追加フィールドを選択する場合は、BizTalk エディタを使用して作成した仕様を使用する必要があります。標準またはスキーマを BizTalk エディタにインポートしてから BizTalk 仕様として保存すると、それらを適合させることができます。詳細については、「仕様の作成と検証」を参照してください。
  12. [フィールドの選択] ダイアログ ボックスの [ノードを選択してください] ツリーで必要なノードを展開し、追加するフィールドをクリックして、[OK] をクリックします。

    注

    • [ノードを選択してください] ツリーのフィールドをクリックすると、[フィールド名] ボックスにフィールド名が自動的に追加されます。

    • [ノードを選択してください] ツリーのフィールドをクリックすると、[ノード パス] ボックスにノード パスが自動的に追加されます。このパスは、手動で編集できます。詳細については、「ノード パス フィールド」を参照してください。

    • レコード ノードを選択して、[メッセージ フィールド] の一覧に追加することはできません。選択できるのはフィールドだけです。詳細については、「ノード パス フィールド」を参照してください。

    • [メッセージ フィールド] ボックスの一覧に複数のフィールドを追加したい場合は、[フィールドの選択] ダイアログ ボックスでフィールドを選択し、[OK] をクリックします。[メッセージ仕様情報] ページで [追加] をクリックし、この手順を繰り返してほかのフィールドを追加します。
  13. [メッセージ フィールド] ボックスの一覧からフィールドを削除する場合は、[メッセージ仕様情報] ページで一覧のフィールドをクリックし、[削除] をクリックします。

    注

    • 入力必須フィールドは削除できません。入力必須フィールドは、[メッセージ フィールド] ボックスの一覧で背景が黄色に表示されます。
  14. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • [受信] をクリックしないと、待ち時間プロパティは有効になりません。

  • 非同期通信で使用可能なメッセージは、XML メッセージだけです。すべての XML メッセージが使用可能で、複数のポートに対して指定できます。[メソッド通信ウィザード] を使用して作成した同期メッセージの組は、すべて使用できません。

  • この通信フローを、BizTalk メッセージを使用して実装したポートに接続する場合、通信の方向 (送信または受信) はポート実装によって決まります。[XML 通信ウィザード] では設定できません。ウィザードの最初のページの [送信] および [受信] オプションは自動的に選択され、利用できません。通信フローの構成を終了するには、[次へ] をクリックして次のページに進む必要があります。

  • 非同期通信を構成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで送信または受信される情報に対応しています。メッセージには、入力必須のシステムフィールドと、必要な追加仕様フィールドが含まれます。非同期メッセージ通信で使用されるメッセージの定義については、「非同期通信」を参照してください。

関連項目

非同期通信

仕様の作成と検証

仕様の作成とデータのマッピング

ステータス退避とステータス復元

アクションとポート間の通信フローの確立

ノード パス フィールド

同期メッセージの送信と受信

XML 通信ウィザードの使用


アクションとポート間の通信フローの変更

  1. BizTalk オーケストレーション デザイナの設計ページで、アクションとポート間の通信フローを右クリックします。

    通信ウィザードが表示されます。

  2. ウィザードの手順に従って、目的のプロパティを変更します。

    作成する通信フローの種類に応じて、次のいずれかの手順に進みます。

    • COM コンポーネントまたはスクリプト コンポーネントの実装を使用するポートへの同期通信フローを作成する場合は、メソッド通信ウィザードを使用する必要があります。「同期メッセージの送信と受信」へ進んでください。

    • メッセージ キューまたは BizTalk メッセージの実装を使用するポートへの非同期通信フローを作成する場合、および未バインド ポートへの非同期通信フローを作成する場合は、XML 通信ウィザードを使用する必要があります。「非同期メッセージの送信と受信」へ進んでください。

注

  • アクションとポート間の通信フローを確立できるのは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは、アクションおよびポートを使用できません。

  • [データ] ページにはシェイプを追加できません。アクションをポートに接続するたびに、[データ] ページに新しいメッセージが自動的に作成されます。

関連項目

アクションとポート間の通信フローの確立

非同期メッセージの送信と受信

同期メッセージの送信と受信

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


メッセージ間のデータ フローの記述

ここには次のトピックが含まれます。

  • メッセージの選択

  • メッセージ内のフィールドの選択

  • メッセージ間のフローの記述

  • メッセージの削除

  • メッセージとポートの対応付け

  • 定数の使用

関連項目

シェイプの追加、削除、および接続

データ処理


メッセージの選択

  • BizTalk オーケストレーション デザイナの [データ] ページで、選択するメッセージのグレーのヘッダ フィールドをクリックします。

    選択したメッセージ全体が、緑の点線で囲まれます。

注

  • [定数] ボックスの一覧、[ポート参照] ボックスの一覧、または [メッセージ] を選択できます。

  • メッセージ全体を選択すると、ドラッグすることでページ上を移動できます。メッセージを移動すると、メッセージ間に記述されたデータ フローを明確にすることができます。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージの削除

メッセージ間のフローの記述

メッセージとポートの対応付け

メッセージ内のフィールドの選択

定数の使用


メッセージ内のフィールドの選択

  • BizTalk オーケストレーション デザイナの [データ] ページで、メッセージ内の選択するフィールドをクリックします。

    選択したフィールドは、緑の点線で囲まれます。そのフィールドで使用可能なすべての制御ハンドル ( 制御ハンドル) が有効になります。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージの削除

メッセージ間のフローの記述

メッセージとポートの対応付け

メッセージの選択

定数の使用


メッセージ間のフローの記述

  1. BizTalk オーケストレーション デザイナの [データ] ページで、メッセージ内のフィールドをクリックし、制御ハンドル ( 制御ハンドル) を有効にします。

  2. 制御ハンドルを、接続先となる別のメッセージにあるフィールドの接続ポイント ( 接続ポイント) までドラッグします。

    接続ポイントが赤い四角形 ( アクティブ接続ポイント) で強調表示されたら、マウス ボタンを離して接続を設定します。

注

  • 複数のデータ フローを作成する場合は、コネクタ ツールを使用するとフローを簡単に追加できます。コネクタ ツールの詳細については、「コネクタ ツールの使用」を参照してください。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージの削除

メッセージとポートの対応付け

メッセージ内のフィールドの選択

メッセージの選択

定数の使用


メッセージの削除

  • BizTalk オーケストレーション デザイナの [データ] ページで、削除するメッセージのグレーのヘッダ フィールドをクリックし、Delete キーを押します。

注

  • [ポート参照] ボックスの一覧は削除できません。

  • [定数] ボックスの一覧は削除できません。

  • メッセージ内のフィールドを 1 つだけ選択し、Delete キーを押すと、そのフィールドだけではなくメッセージ全体が削除されます。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージ間のフローの記述

メッセージ内のフィールドの選択

メッセージの選択


メッセージとポートの対応付け

  1. [ポート参照] ボックスの一覧で、参照先のポートの名前を含んだフィールドをクリックします。

  2. 制御ハンドル ( 制御ハンドル) を、そのフィールドから、ポートへの参照を渡すメッセージ内のフィールドの接続ポイント ( 接続ポイント) までドラッグします。

重要

  • メッセージとポート参照の関連付けの詳細については、次のトピックを参照してください。
    • インスタンス管理

    • データ処理

    • ポート実装について

関連項目

データ処理

メッセージの削除

メッセージ間のフローの記述

ポートの実装

インスタンス管理

メッセージ内のフィールドの選択

メッセージの選択

ポート実装について

定数の使用


定数の使用

ここには次のトピックが含まれます。

  • 定数の追加

  • 定数の編集

  • 定数の削除

関連項目

データ処理

フィールド データ型

データ型とデータ型値の概要


定数の追加

  1. BizTalk オーケストレーション デザイナの [データ] ページで、[定数] の一覧を右クリックし、[プロパティ] をクリックします。

    [定数メッセージのプロパティ] ダイアログ ボックスが表示されます。

  2. [追加] をクリックします。

    [定数のプロパティ] ダイアログ ボックスが表示されます。

  3. [名前] ボックスに、定数の名前を入力します。

  4. [データ型] ボックスの一覧で、その定数のデータ型をクリックします。

  5. [値] ボックスに、その定数の値を入力します。

  6. [OK] をクリックし、もう一度 [OK] をクリックします。

注

  • 既定では、作成した定数に数字を追加した名前が与えられます。この名前は変更できます。

  • [データ型の説明] には、選択したデータ型に関する情報が読み取り専用で表示されます。場合によっては、そのデータ型の書式の例や、有効な値の範囲なども表示されます。

関連項目

データ処理

定数の削除

定数の編集

フィールド データ型

データ型とデータ型値の概要


定数の編集

  1. BizTalk オーケストレーション デザイナの [データ] ページで、[定数] の一覧を右クリックし、[プロパティ] をクリックします。

    [定数メッセージのプロパティ] ダイアログ ボックスが表示されます。

  2. [定数] ボックスの一覧で、編集する定数をクリックします。

  3. [編集] をクリックします。

    [定数のプロパティ] ダイアログ ボックスが表示されます。

  4. 変更が必要な定数のプロパティを編集し、[OK] をクリックします。

注

  • [定数のプロパティ] ダイアログ ボックスで利用可能なプロパティの詳細については、「定数の追加」を参照してください。

  • 既定では、作成した定数に数字を追加した名前が与えられます。この名前は変更できます。

  • [データ型の説明] には、選択したデータ型に関する情報が読み取り専用で表示されます。場合によっては、そのデータ型の書式の例や、有効な値の範囲なども表示されます。

関連項目

定数の追加

データ処理

定数の削除

フィールド データ型

データ型とデータ型値の概要


定数の削除

  1. BizTalk オーケストレーション デザイナの [データ] ページで、[定数] の一覧を右クリックし、[プロパティ] をクリックします。

    [定数メッセージのプロパティ] ダイアログ ボックスが表示されます。

  2. [定数] ボックスの一覧で、削除する定数をクリックします。

  3. [削除] をクリックします。

関連項目

定数の追加

データ処理

定数の編集

フィールド データ型

データ型とデータ型値の概要


XLANG スケジュールの実行

ここでは、XLANG スケジュールのコンパイルおよびデバッグの方法、および XLANG スケジュールを有効にし、実行する方法について説明します。XLANG スケジュールを実行するには、専用のスケジュール インスタンスをホストする COM+ アプリケーションも作成するとよいでしょう。

ここには次のトピックが含まれます。

  • XLANG スケジュールのコンパイルとデバッグ

  • XLANG スケジュール ホスト アプリケーションの作成と構成

関連項目

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールのコンパイルとデバッグ

XLANG スケジュールを作成したら、そのスケジュールをコンパイル、実行、テスト、およびデバッグします。BizTalk オーケストレーション デザイナには、XLANG スケジュールのコンパイル、実行、テスト、およびデバッグに役立つ機能が用意されています。

BizTalk オーケストレーション デザイナで利用可能なオプションは、次のとおりです。

  • コンパイル

  • メソッドの署名の更新

  • 実行中の XLANG スケジュール インスタンスのシャットダウン

これらのオプション以外に、XLANG スケジュールのテストとデバッグに役立つツールが 2 つあります。

  • XLANG Event Monitor : このツールを使用すると、実行中の XLANG スケジュール インスタンスを監視できます。このツールの使用方法の詳細については、付属のリリース ノートを参照してください。Microsoft BizTalk Server 2000 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノート (Readme.htm) は、どちらもインストール ディレクトリ \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

  • Windows 2000 イベント ビューア : Windows 2000 イベント ビューアを使用すると、XLANG スケジュールのエラーを確認できます。詳細については、次のトピックを参照してください。
    • イベント ビューアの管理

    • 実行中の XLANG スケジュールの監視

    • イベント ビューアの詳細については、Windows 2000 Server ヘルプの「イベント ビューアを使う」を参照してください。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

  • XLANG スケジュールの実行

  • コンパイルされた Visual Basic コンポーネントのデバッグ

  • メソッド署名の更新

  • 実行中のすべての XLANG スケジュールのシャットダウン

関連項目

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

  1. BizTalk オーケストレーション デザイナで、[ファイル] メニューの [XLANG <フローチャート X>.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. [XLANG スケジュールに名前を付けて保存] ボックスの一覧で、XLANG スケジュールを保存する場所を参照します。

  3. [ファイル名] ボックスの一覧で、ファイル名を変更することもできます。

  4. [保存] をクリックします。

注

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにするときに、コンパイル エラーが発生する場合があります。エラー メッセージにはフローチャート内の問題が示され、影響を受けたシェイプは緑の点線で囲まれて強調表示されます。

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにする場合、フローチャートは既定の <フローチャートX>.skx という名前でコンパイルされます。ここで、X はスケジュール名に付加された番号です。このファイル名は、フローチャートのコンパイル時に変更できます。

  • XLANG スケジュールのファイル拡張子は .skx です。.skx ファイルは、XLANG 言語で記述された XML ファイルです。BizTalk オーケストレーション デザイナでは、.skx ファイルを開くことはできません。.skx ファイルを変更または更新するには、ソースの .skv ファイルを開いて変更した後、その .skv ファイルを .skx ファイルに再コンパイルします。

  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

関連項目

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

XLANG スケジュール フローチャートを開く、および保存する

メソッド署名の更新

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

実行中のすべての XLANG スケジュールのシャットダウン


XLANG スケジュールの実行

XLANG スケジュールを実行するには、XLANG スケジュールを有効にするための手段を作成する必要があります。

そのためのおもな方法は 2 つあります。

  • XLANG スケジュールを有効化および実行するように、BizTalk オーケストレーション サービスおよび BizTalk メッセージ サービスを構成します。

    詳細については、次のトピックを参照してください。

    • BizTalk サービスの統合

    • 送信先アプリケーションのプロパティの設定
  • ASP ページなどのインスタンス作成アプリケーションを作成し、プログラム上で XLANG スケジュールをアクティブにします。

    詳細については、次のトピックを参照してください。

    • XLANG スケジュールの実行 (概念)

    • インスタンス作成アプリケーションの作成

    • モニカの構文

関連項目

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

モニカの構文

メソッド署名の更新

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

実行中のすべての XLANG スケジュールのシャットダウン


コンパイルされた Visual Basic コンポーネントのデバッグ

Microsoft Visual Basic で作成されたコンポーネントを、コンパイル後にデバッグしなければならない場合があります。

  1. Visual Basic 6.0 で、デバッグする Visual Basic プロジェクトを開きます。

  2. [ファイル] メニューの [<プロジェクト>.dll の作成] をクリックします。

  3. [実行可能ファイルの作成] ダイアログ ボックスの [オプション] をクリックします。

  4. [プロジェクト プロパティ] ダイアログ ボックスの [コンパイル] タブで、[ネイティブ コード コンパイル] と [最適化なし] をクリックし、[シンボリック デバッグ情報を作成] チェック ボックスをオンにします。

  5. [OK] をクリックし、もう一度 [OK] をクリックして、プロジェクトをコンパイルします。

  6. Visual Basic の .dll プロジェクトを開きます。

  7. 使用するブレークポイントを設定します。

  8. [実行] メニューの [開始] をクリックします。

次回、XLANG スケジュールが Visual Basic コンポーネントを呼び出すと、Visual Basic デバッガがブレークポイントで停止します。

重要

  • Visual Basic の .dll は、[シンボリック デバッグ情報を作成] チェック ボックスがオンになった状態で作成する必要があります。

  • XLANG スケジューラ エンジンが、まだ .dll を読み込んでいないことを確認してください。既に .dll が読み込まれている場合は、XLANG スケジューラ エンジンをシャットダウンしてからやり直してください。

注

  • コンポーネントのデバッグや、コンポーネント サービス、および COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。


メソッドの署名の更新

  • BizTalk オーケストレーション デザイナで、[ツール] メニューの [メソッドの署名を更新] をクリックします。

注

  • XLANG スケジュールの作成と同時に COM+ コンポーネントを作成し、使用可能な任意のメソッド呼び出しのメソッド パラメータのいずれかを変更する場合に、このオプションを使用します。このオプションによって、XLANG スケジュールで使用可能なメソッド パラメータが、最新の状態に更新されます。

  • XLANG スケジュールをコンパイルするときは、[メソッドの署名を更新] が自動的に実行されます。

関連項目

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

実行中のすべての XLANG スケジュールのシャットダウン


実行中のすべての XLANG スケジュールのシャットダウン

  • BizTalk オーケストレーション デザイナで、[ツール] メニューの [すべての実行中の XLANG スケジュール インスタンスのシャットダウン] をクリックします。

注

  • XLANG スケジュール インスタンスの実行中は、その XLANG スケジュールで使用されている COM コンポーネントを変更できません。このオプションによって、そのスケジュールで実行中のすべてのインスタンスがシャットダウンされ、コンポーネントが格納されたファイルがロック解除されるため、変更できるようになります。

関連項目

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

メソッド署名の更新

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュール ホスト アプリケーションの作成と構成

ここでは、XLANG スケジュールをアクティブにし、実行する方法について説明します。既定の XLANG スケジューラ アプリケーションを使用して XLANG スケジュールを実行することもできますが、通常は、新しい COM+ アプリケーションを作成してスケジュール インスタンスを実行した方が便利です。

セキュリティ、配置、および構成という問題があるため、XLANG スケジュールをホストするほとんどの COM+ アプリケーションは、XLANG スケジュールを開発するときに作成する必要があります。アプリケーションとスケジュールに対するセキュリティとパフォーマンスの必要性も考慮する必要があります。スケジュール実行の専用のインスタンスをホストする新しい COM+ アプリケーションを作成したり、あるスケジュール インスタンスを実行するアプリケーションを、別のアプリケーションを使用するほかの XLANG スケジュールから分離する場合もあります。

XLANG スケジュール、およびスケジュールをホストする COM+ アプリケーションの作成に関する、セキュリティおよびパフォーマンスの問題の詳細については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

COM+ アプリケーションを作成後に管理する方法については、「XLANG アプリケーションとデータベースの管理」を参照してください。

ここには次のトピックが含まれます。

  • XLANG スケジュールをホストする COM+ アプリケーションの作成

  • XLANG スケジュールをホストする COM+ アプリケーションの構成

重要

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールをホストする COM+ アプリケーションの作成

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーの [コンポーネント サービス]、[コンピュータ]、[マイ コンピュータ] を順に展開し、[COM+ アプリケーション] をクリックして選択します。

    最初に、[COM+ アプリケーション] を選択して右クリックする必要があります。これを最初に選択しないと、[新規作成] オプションを使用できません。

  3. [COM+ アプリケーション] を右クリックして [新規作成] をポイントし、[アプリケーション] をクリックします。

    [COM アプリケーション インストール ウィザード] が表示されます。

  4. [COM アプリケーション インストール ウィザードへようこそ] ページで、[次へ] をクリックします。

  5. [新しいアプリケーションのインストールまたは作成] ページで、[空のアプリケーションを作成する] をクリックします。

  6. [空のアプリケーションを作成] ページで、アプリケーションの名前を入力し、[サーバー アプリケーション] が選択されていることを確認して、[次へ] をクリックします。

  7. [アプリケーション ID の設定] ページで、適切なアカウントにアプリケーション ID を設定します。

    XLANG スケジュールをホストする COM+ アプリケーションに対して、サービス アカウントを作成するようにしてください。

    アプリケーション ID の作成に関するセキュリティとパフォーマンスの問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

  8. [次へ] をクリックし、[完了] をクリックします。

  9. 新しく作成した COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

  10. [XLANG] タブで、[このアプリケーションを XLANG スケジュール インスタンスのホストにする] チェック ボックスをオンにします。

  11. COM+ アプリケーションを構成するには、「XLANG スケジュールをホストする COM+ アプリケーションの構成」に進んでください。

重要

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

注

  • XLANG スケジュールをホストする COM+ アプリケーションを作成する場合は、[ステータス退避済み XLANG アプリケーションを再起動] オプションは利用できません。ステータス退避済みアプリケーションを再起動する方法の詳細については、「すべての XLANG アプリケーションの再起動」を参照してください。

関連項目

XLANG スケジュールをホストする COM+ アプリケーションの構成

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールをホストする COM+ アプリケーションの構成

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. 構成する COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

  4. XLANG スケジュールをホストする COM+ アプリケーションを管理するための、サービス アカウントを必ず作成するようにしてください。COM+ アプリケーションを作成するときに、[COM アプリケーション インストール ウィザード] で既定の設定を変更しなかった場合は、ここで設定を変更できます。詳細については、「COM+ アプリケーションのアプリケーション ID の変更」を参照してください。

  5. COM+ アプリケーションの DSN 設定を構成します。詳細については、「COM+ アプリケーションの DSN 設定の変更」を参照してください。

  6. COM+ アプリケーションで使用するデータベースを構成します。次の構成が可能です。
    • 既存のデータベースの指定。詳細については、「COM+ アプリケーションの DSN 設定の変更」を参照してください。

      または

    • 新しいデータベースの作成と構成。詳細については、「新しいステータス保存データベースの作成」および「COM+ アプリケーションの DSN 設定の変更」を参照してください。

注意

  • COM+ アプリケーションで使用する新しいデータベースを作成および構成する場合、COM+ アプリケーションの DSN 設定の構成後に、データベース テーブルを初期化する必要があります。

    DSN の構成方法、およびデータ ソース (ODBC) の使用方法の詳細については、[ODBC データ ソースの管理者] ダイアログ ボックスの [ヘルプ] をクリックしてください。

    構成した COM+ ホスト アプリケーション用に新しいデータベース テーブルを初期化する方法は、次のとおりです。

    1. COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

    2. [XLANG] タブをクリックします。

    3. [XLANG] タブの [テーブルの初期化] をクリックします。
  • 既存のデータベース用に COM+ ホスト アプリケーションと DSN を構成しているときは、[テーブルの初期化] をクリックしないでください。それを行うと、既存のデータベースにあるデータが破棄されます。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

関連項目

COM+ アプリケーションのアプリケーション ID の変更

COM+ アプリケーションの DSN 設定の変更

XLANG スケジュールをホストする COM+ アプリケーションの作成

新しいステータス保存データベースの作成

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


概念

ここでは、BizTalk オーケストレーション デザイナを理解するうえで不可欠な概念について説明します。ここには次のトピックが含まれます。

  • BizTalk オーケストレーション サービス

  • XLANG スケジュール フローチャートの作成

  • XLANG スケジュールのコンパイル

  • XLANG スケジュールのデバッグ

  • XLANG スケジュールの実行

  • セッション ステータスの管理

  • XLANG スケジュールの更新

注

  • 「操作方法」を参照し、BizTalk オーケストレーション デザイナの作業ごとの使用方法について十分に理解しておいてください。


BizTalk オーケストレーション サービス

BizTalk オーケストレーション サービスは、確立された情報交換テクノロジの機能をさらに拡張します。これによって、ビジネス プロセスを詳細な表現で作成し、統合された設計環境でソフトウェア的な実装をすることができます。

ビジネス プロセスの設計と実装は、これまで、図式を利用した設計フェーズとコーディング フェーズの 2 つの異なるフェーズで実行されていました。一般的に、図式を利用した設計フェーズでは、既存のビジネス プロセス (調達など) を分析し、プロセスを記述するワークフロー ダイアグラムまたは相互関係ダイアグラムを作成します。通常、コーディング フェーズは別に進められます。ここでは、図式を利用した抽象的なビジネス プロセスのモデルを構築し、そのモデルを実装フレームワークにマップします。

BizTalk オーケストレーションの重要な機能の 1 つに、今まで異なっていたこれらのフェーズを 1 つの設計環境に統合する機能があります。この設計環境では、柔軟性の高いフローチャート作成機能と、多機能な実装ツールのセットを提供します。BizTalk オーケストレーションで、次のことができます。

  • ビジネス プロセスを実現する XLANG スケジュール フローチャートを作成できます。

  • フローチャートの特定のアクションを、メッセージを送受信する場所を表すポートに接続することによって、ビジネス プロセスを実装できます。ポートとは、名前付きの場所です。メッセージとは、アクションとポートの間で送受信されるデータを表します。

  • ビジネス プロセスのメッセージ間のデータのフローを定義できます。

  • XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルできます。XLANG スケジュールとは、フローチャートに含まれる情報を実行可能な Extensible Markup Language (XML) で表現したものです。

設計と実装を統合する機能のほかに、BizTalk オーケストレーションは重要な追加機能を提供します。この機能により、複数の組織、プラットフォーム、およびアプリケーションにまたがって、堅固な、疎結合、長時間ビジネス プロセスを作成できます。非同期で疎結合、長時間ビジネス プロセスでは、たとえば、インターネットで注文された製品を在庫部品から組み立てる必要があるとして、これらの部品は、たまたま在庫切れになっている可能性もあり、ビジネス プロセス全体が完了するまでに、数週間から数か月かかることもあります。これに対して、密結合ビジネス プロセスでは、メッセージの交換が同期されます。たとえば、銀行口座から現金を引き出すと、口座の借方に記入された直後に現金が支払われます。

BizTalk オーケストレーションで、次の操作ができます。

  • 図式を利用した表現で長時間ビジネス プロセスを作成できます。

  • 図式を利用して表現したアクションを特定のテクノロジで実装したポートに接続することにより、メッセージの交換を容易にします。

  • 完了したフローチャートを実行可能な XML 表現のフローチャートにコンパイルできます。

  • 完了までに数週間から数か月を要する可能性があるビジネス プロセスを確実に実行できます。

ここには次のトピックが含まれます。

  • ビジネス プロセスについて

  • BizTalk オーケストレーション デザイナの環境

  • XLANG スケジュール

関連項目

XLANG スケジュール フローチャートの作成

ビジネス プロセスについて


ビジネス プロセスについて

製造業にとって組み立てラインが重要であるように、ビジネス プロセスはビジネス管理にとって重要です。明確な一定形式のプロセスのセットに従うことによって、あらゆるビジネスで生産性を向上させ、コストを軽減することができます。ビジネス プロセスでは、各業務のすべての担当者間でメッセージ交換のプロトコルを定義します。ビジネス プロセスを定義するには、アクションの論理的な順序と、それに対応するメッセージのフローを決定する必要があります。ビジネス プロセスでは、これらのアクションを実行する各業務の担当者は定義しません。

一般的に、長時間ビジネス プロセスの一連の手順は非同期です。各手順は、独立した 1 人または複数の担当者が実行できるアクションです。これらのアクション間では、関連する作業を実行している、していないに関わらず、担当者間でメッセージを送受信することになります。各業務の担当者は、入力に対して応答する自動化されたプロセスであったり、完全に別のビジネス プロセスであったりします。ビジネス プロセスを理解するには、複雑で多様な相関関係や依存関係を図式を利用して目に見えるようにする必要があります。このような関係を目に見えるよう記述するために、ワークフロー ダイアグラムや相互関係ダイアグラムなどのビジネス プロセスをモデル化するツールが開発されています。

ここには次のトピックが含まれます。

  • ワークフロー ダイアグラム

  • 相互関係ダイアグラム


ワークフロー ダイアグラム

ワークフローは、組織内の手順を自動化し、向上させるビジネス プロセスの設計テクノロジです。これは、プロジェクトの完了に必要な手順、強固な依存関係、取らなければならない承認を描画するときに役立つテクノロジです。ワークフロー アプリケーションを使用して、作業を担当者に割り当て、個々の責任を定義し、担当者間の関係を表すことができます。また、ワークフロー アプリケーションを使用して、プロジェクトの完了や目標達成の期限を設定することもできます。しかし一般的に、ワークフロー テクノロジは高度に集中化されています。担当者には作業が割り当てられ、期限が指定されますが、ワークフロー エンジンは、ある担当者から次の担当者へと完了した作業項目の経路を選定し、スケジュールを進める責任があります。これに対して、BizTalk オーケストレーションの裁量範囲はもっと広く、担当者には自主性があり、ある担当者から別の担当者に作業項目の経路を選定する責任は、集中化されたアプリケーションではなく各担当者が決定します。

関連項目

相互関係ダイアグラム

ビジネス プロセスについて


相互関係ダイアグラム

相互関係ダイアグラムは、ビジネス プロセス内のデータ フローと、交換されるメッセージを表します。BizTalk オーケストレーションは、相互関係ダイアグラムに含めることができない、判断、同時実行アクション、トランザクション、補助的なアクションに対する定義と制御を提供することで、相互関係ダイアグラムの概念を拡張します。BizTalk オーケストレーションを使用してビジネス プロセスを設計すると、コンパイルされ、実行可能なビジネス プロセス (XLANG スケジュール) ができます。これに対して、相互関係ダイアグラムはビジネス プロセスの静的な表現です。

次の図は、一般的な自動化された調達システムの相互関係ダイアグラムを示しています。

インターネット
注文用
アプリケーション
Invoice
Payment
Bits, Bytes,
& Chips, Inc
Purchase
order
PO request
approval
PO approval
ProElectron, Inc
Purchase request
ユーザー
PO 承認者
会計担当者
仕入先

関連項目

ビジネス プロセスについて

ワークフロー ダイアグラム


BizTalk オーケストレーション デザイナの環境

BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを作成できます。XLANG スケジュール フローチャートとは、ビジネス プロセスを表現したものです。XLANG スケジュール フローチャートは、Microsoft Visio 2000 のファイル形式をカスタマイズした .skv ファイルとして保存されます。その後で、XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルできます。XLANG スケジュールは、XLANG スケジューラ エンジンが理解できる XML 構造の .skx テキスト ファイルです。BizTalk オーケストレーション デザイナでは、次の特徴を含む XLANG スケジュール フローチャートを作成できます。

  • 視覚的なビジネス プロセスの記述。この XLANG スケジュール フローチャートの一面は、ワークフロー ダイアグラムまたは相互関係ダイアグラムに似ています。

  • 視覚的な構成可能ポートの表現。これは、XLANG スケジュール フローチャートの実装面です。

  • 視覚的なシェイプ間の接続の表現。ビジネス プロセスのプロセス フローを表現するために、フローチャート シェイプを接続できます。ビジネス プロセスの通信のフローを表現するために、アクションをポートに接続できます。

  • 指定したメッセージ フィールド間の視覚的なフローの表現。このXLANG スケジュール フローチャートの特徴により、あるメッセージのメッセージ フィールドと別のメッセージのメッセージ フィールドとの関係を決めることができます。これらの関係を関連付けることにより、データ依存のルーティングを実行できます。

XLANG スケジュール フローチャートは、ビジネス プロセスで実行される手順を表現したものです。XLANG スケジュール フローチャートでは、次の項目を定義できます。

  • 取引先が使用することに同意したメッセージ交換プロトコル

  • アクション発生の論理的な順序が記述された、メッセージの送受信時に使用されるアクション

  • ポートの実装、およびリンクされるアクション

  • メッセージ フィールド間のデータ フロー

ここには次のトピックが含まれます。

  • 設計ページ

  • フローチャート シェイプ

  • 実装シェイプ

  • 通信シェイプ

  • BizTalk オーケストレーション デザイナのショートカット キー


設計ページ

BizTalk オーケストレーション デザイナには、アクセス可能な 4 つの設計ページがあります。これらの設計ページを使用して、XLANG スケジュール フローチャートをいろいろな角度から作成できます。

  • [ビジネス プロセス] ページ。このページでは、[フローチャート] シェイプと [実装] シェイプを使用して、ビジネス プロセスを定義できます。これらのシェイプの使用方法については、「フローチャート シェイプ」と「実装シェイプ」を参照してください。

  • [データ] ページ。このページでは、[通信] シェイプを使用して、メッセージ フィールド間のデータ フローを制御できます。これらのシェイプは、BizTalk オーケストレーション デザイナが自動的に作成します。これらのシェイプの使用方法については、「通信シェイプ」を参照してください。

  • [<トランザクション> の失敗時] ページ。このページでは、[フローチャート] シェイプと [実装] シェイプを使用して、障害が発生したトランザクションに対して代わりのビジネス プロセスを設計できます。

  • [<トランザクション> の補正] ページ。このページでは、[フローチャート] シェイプと [実装] シェイプを使用して、コミットされたネストしたトランザクションを元に戻すプロセスを設計できます。トランザクションの詳細については、「トランザクションの設計」を参照してください。

関連項目

例外処理


フローチャート シェイプ

BizTalk オーケストレーション デザイナには、[フローチャート] ステンシルに、8 つのフローチャート シェイプがあります。これらのシェイプを使用して、ビジネス プロセスを表現します。[フローチャート] ステンシルの 8 つのシェイプを使用して、XLANG スケジュールの構造と意味を表現できます。XLANG は、ビジネス プロセスの操作を表現する XML ベースの言語です。

次の表は、フローチャート シェイプの一覧と説明を示しています。

シェイプ名 説明
開始

[開始] シェイプは、[フローチャート] ステンシルにはありません。削除することも、別の [開始] シェイプを作成することもできません。[開始] シェイプは、XLANG スケジュール フローチャートの開始を表します。[開始] シェイプは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページで自動的に作成されます。[ビジネス プロセス] ページに表示される [開始] シェイプには、設定可能なプロパティがあります。[<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページに表示される [開始] シェイプには、設定可能なプロパティはありません。[開始] シェイプをトランザクションで囲むことはできません。ビジネス プロセスは、フローチャートの中で、[開始] シェイプから最初の [フローチャート] シェイプに向かって流れる必要があります。
アクション

[アクション] シェイプは、メッセージをポートから受信する、またはメッセージをポートに送信するプロセスを表します。送信アクションまたは受信アクションは、同期のことも非同期のこともあります。どちらになるかは、ポートがバインドされるコンポーネントまたは実装によって決まります。
判断

[判断] シェイプは、1 つ以上の条件を順番に評価するプロセスを表します。

このシェイプには、1 つの受信フローと 1 つ以上の送信フローがあります。各送信フローは、TRUE または FALSE と評価される条件に関連付けられています。最初に TRUE と評価された条件によって、ビジネス プロセスで使用される送信フローが決まります。ビジネス プロセスでは、最初に TRUE と評価された条件からのフローが実行されます。TRUE と評価される条件がない場合は、ELSE フローが実行されます。

[判断] シェイプには、条件を少なくとも 1 つ設定します。各条件には、1 つの条件式を設定します。
繰り返し

[繰り返し] シェイプは、1 つの条件が含まれていて、繰り返すプロセスを表します。条件が TRUE と評価された場合は、条件からのフローが実行され、繰り返されます。条件が FALSE と評価された場合は、Continue フローが実行されます。ビジネス プロセス フローが [繰り返し] シェイプの条件から出たときには、単一の [終了] シェイプで完結する必要があります。

繰り返しループのステータスを保存するように構成することもできます。[繰り返し] シェイプを右クリックし、[プロパティ] をクリックすると、[繰り返しのプロパティ] ダイアログ ボックスが表示されます。[ステータスの永続化] で [はい] を選択すると、各ループの繰り返しで使用されたメッセージを XLANG スケジュール ステータスとして保存できます。繰り返しループが失敗したトランザクションに含まれている場合、ループの繰り返しが完了するたびに、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが呼び出されます。[いいえ] を選択すると、最後のループの繰り返しで使用されたメッセージだけが、XLANG スケジュール ステータスとして保存されます。繰り返しループが失敗したトランザクションに含まれている場合、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが 1 回だけ呼び出されます。

障害が発生したネストしたトランザクション内にある [繰り返し] シェイプに一連のビジネス プロセスが流れると、そのネストしたトランザクションの [<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページで作成されたメッセージとポートは、外側のトランザクションの [<トランザクション> の失敗時] ページで利用できなくなります。収集したメッセージをネストしたトランザクションの外に正常に流すには、失敗時に実行されるコードまたは補正コードをそのように設計します。
分岐

[分岐] シェイプを使用すると、ビジネス プロセスで同時実行ができます。分岐に入ることができるフローは 1 つで、最大で 64 個までのフローに分岐させることができます。分岐から出たフローは、同時に実行されます。1 つの [分岐] シェイプから流れ出たすべての一連のビジネス プロセスは、1 つの [結合] シェイプに接続するか、[終了] シェイプで終了する必要があります。
結合

[結合] シェイプは、ビジネス プロセスで同時実行されているフローを同期させます。[結合] シェイプには、最大で 64 個のフローが入ることができ、1 つのフローが出ることができます。フローの同期方法を指定するには、論理演算子の AND と OR を使用します。次の [結合] のプロパティを設定できます。
  • OR : 最初に到着したフローは続行します。その他のフローも実行を続けます。

  • AND : 出力フローを始める前に、すべての入力フローの同期をとります。
トランザクション

[トランザクション] シェイプは、すべてが実行されるアクション、またはまったく実行されないアクションのどちらかの集合を表します。トランザクションには次の 3 種類があります。
  • 短時間トランザクション

  • 長時間トランザクション

  • 長時間実行する定刻トランザクション

トランザクションを使用すると、アプリケーションの信頼性が向上し、大規模アプリケーションのエラー処理が単純化されます。

[トランザクション] シェイプの入力は 1 つのパスに制限され、出力も 1 つのパスだけです。[トランザクション] シェイプに [終了] シェイプを含めることはできません。長時間トランザクションにネストしたトランザクションを含めることはできますが、短時間トランザクションにネストしたトランザクションを含めることはできません。トランザクションの再試行ができるのは、短時間トランザクションだけです。ビジネス プロセスの一部を短時間 [トランザクション] シェイプで囲むと、トランザクションの "再試行回数" プロパティを設定できます。短時間トランザクションに障害が発生すると、指定した回数再試行されます。

トランザクション プロパティを定義すると、[<トランザクション> の補正] ページ (ネストしたトランザクション用) または [<トランザクション> の失敗時] ページを利用可能にできます。どちらのページでも、特定のトランザクションのエラー処理プロセスをモデル化できます。

注

  • 内側の [トランザクション] シェイプの境界線が外側の [トランザクション] シェイプの境界線と重複していると、内側のトランザクションはネストされません。内側のトランザクションの境界線が外側のトランザクションの境界線と重複しないようにしてください。
終了

[終了] シェイプは、1 つの処理フローの完了を表します。フローチャートに [判断]、[繰り返し]、または [分岐] シェイプが含まれている場合は、1 つのフローチャートで複数の [終了] シェイプを使用できます。
中断

[中断] シェイプは、トランザクション グループの実行を強制終了します。これによって、[<トランザクション> の失敗時] エラー処理ページまたは [<トランザクション> の補正] エラー処理ページを有効にしたり、トランザクションを再試行します。

注

  • [<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページのパラメータ <トランザクション> は、[ビジネス プロセス] ページの関連したトランザクションの名前に置き換えられます。

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション シェイプ、ポート シェイプ、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • コンスタント名およびメッセージ名を数字で始めることはできません。
  • 1 バイト文字セットによるトランザクション名の長さは、16 文字以内にします。2 バイト文字セットによるトランザクション名の長さは、8 文字以内にします。

  • アクションには、最大の長さが 32 文字という点を除いて、命名規則による制限がありません。

  • 中断、開始、判断、終了、分岐、結合、および繰り返しの各シェイプには、名前を付けることができません。

関連項目

通信シェイプ

トランザクションの設計

実装シェイプ


実装シェイプ

BizTalk オーケストレーション デザイナには、[実装] ステンシルに 4 つの実装シェイプがあります。これらのシェイプを使用して、ビジネス プロセスでポートを実装するために使用される実装テクノロジを記述します。

次の表は、実装シェイプの一覧と説明を示しています。

シェイプ名 | 説明
COM コンポーネント | [COM コンポーネント] シェイプは、送受信されたメッセージごとにメソッドを使用してポートを実装するためのテクノロジを表します。このシェイプを境界バーの右側までドラッグすると、COM コンポーネント バインド ウィザードが表示されます。COM コンポーネント実装の詳細については、「COM コンポーネント シェイプの使用」を参照してください。
スクリプト コンポーネント | [スクリプト コンポーネント] シェイプは、送受信されるメッセージごとにメソッドを使用してポートを実装するためのテクノロジを表します。このシェイプを境界バーの右側までドラッグすると、スクリプト コンポーネント バインド ウィザードが表示されます。スクリプト コンポーネント実装の詳細については、「スクリプト コンポーネント シェイプの使用」を参照してください。
メッセージ キュー | [メッセージ キュー] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、メッセージ キュー サービスが使用されます。このシェイプを境界バーの右側までドラッグすると、メッセージ キュー バインド ウィザードが表示されます。メッセージ キュー実装の詳細については、「メッセージ キュー シェイプの使用」を参照してください。
BizTalk メッセージ | [BizTalk メッセージ] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、BizTalk メッセージ サービスが使用されます。このシェイプを境界バーの右側までドラッグすると、BizTalk メッセージ バインド ウィザードが表示されます。BizTalk メッセージ実装の詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • コンスタント名およびメッセージ名を数字で始めることはできません。

関連項目

通信シェイプ

フローチャート シェイプ


通信シェイプ

BizTalk オーケストレーション デザイナには、メッセージにデータが流れる方向を示す [通信] シェイプがいくつかあります。[通信] シェイプは、BizTalk オーケストレーション デザイナが自動的に作成します。

[ポート参照] シェイプ、[定数] シェイプ、および [メッセージ] シェイプは、[データ] ページにあります。[データ] ページは、インスタンスが実行しているときに XLANG スケジュール インスタンスが使用するメッセージ間のデータのフローを表します。データのフローを設計するには、[データ] ページでシェイプのフィールドを接続します。

次の表は、通信シェイプの一覧と説明を示しています。

シェイプ名 | 説明
ポート | ポートは、メッセージが送受信される名前付きの場所です。境界バーを右クリックし、[新しいポートの追加] をクリックして未バインド ポートを追加します。または、実装シェイプを境界バーの右側にドラッグしてバインド済みポートを追加します。 各ポートには、[データ] ページに表示される [メッセージ] に対応するメッセージが含まれています。メッセージは、アクションで送受信されるデータを表します。メッセージのデータは、[データ] ページでフィールドの一覧に分かれて表示されます。
ポート参照 | [ポート参照] メッセージには、[ビジネス プロセス] ページで作成されたすべてのポートの一覧が含まれています。[ビジネス プロセス] ページで新しいポートが追加されるたびに、新しい参照がこの一覧に追加されます。[ポート参照] メッセージで、ポートの元の場所を指定できます。[ポート参照] メッセージには、ビジネス プロセスのポートごとに 1 つのポート フィールドが含まれています。
定数 | [定数] メッセージによって、XLANG スケジュールに初期データをセットできます。[定数] メッセージに定数を追加するには、[定数] メッセージをダブルクリックするか、[定数] メッセージのフィールドをダブルクリックして [定数メッセージのプロパティ] ダイアログ ボックスを開きます。
メッセージ | [メッセージ] には、メッセージで送受信されるデータに関する情報のフィールド一覧が含まれています。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • コンスタント名およびメッセージ名を数字で始めることはできません。

[データ] ページで定義される各メッセージには、XLANG スケジューラ エンジンがメッセージごとに自動的に作成し、管理する追加のシステム フィールドがあります。これらのフィールドで、メッセージに関する説明を参照できます。また、条件に対する条件式で使用することもできます。次の表は、自動的に作成されるシステム フィールドを要約しています。

システム フィールド 説明
__Exists__ このフィールドを使用して、メッセージが存在するかどうかをテストできます。メッセージが存在するかどうかは、メッセージが XLANG スケジューラ エンジンで受信または送信されたかどうかで決まります。

このフィールドは、[データ] ページのメッセージには表示されません。 [判断] シェイプと [繰り返し] シェイプでのみ使用されます。
__Sender__ このフィールドには、メッセージの送信者 ID がわかっている場合に、その ID が格納されます。

このフィールドは、[データ] ページのメッセージに表示されます。
__Status__ このフィールドには、COM コンポーネントにバインドされたポートでの COM メソッド呼び出しから返されたステータスが含まれています。このフィールドは、[データ] ページのメッセージに表示されます。

注

  • このシステム フィールドは、COM コンポーネントとスクリプト コンポーネントの実装でのみ使用されます。

  • 返されるステータスは、常に HRESULT です。
ドキュメント このフィールドには、送受信されたメッセージ本体を含む文字列が含まれています。常に、XML メッセージを参照します。

注

  • このシステム フィールドは、メッセージ キューと BizTalk メッセージの実装でのみ使用されます。

重要

  • XLANG スケジュール インスタンスから送信されるメッセージには、定義されたデータのフィールドごとに送信元が必要です。データのフィールドの送信元を定義するには、別のメッセージの別のフィールドからそのフィールドをポイントする接続が必要です。

注

  • XLANG スケジュールを作成するために使用されるコンパイル エンジンは、メッセージのすべての入力専用フィールドが定義されているかどうかを検証します。入力専用フィールドの一部が定義されていない場合、スケジュールはコンパイルされません。メソッドの引数は、入力、出力、入出力のどれでもかまいません。コンパイル エンジンは、入力と出力の両方に定義された引数の定義要件を無視します。入出力フィールドへの受信接続が定義されていない場合、メッセージのデータの定義がなくてもスケジュールはコンパイルされます。

関連項目

データ処理

フローチャート シェイプ

実装シェイプ


BizTalk オーケストレーション デザイナのショートカット キー

BizTalk オーケストレーション デザイナでは、ショートカット キーを使用して作業を実行できます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。Windows 2000 Professional ヘルプでは、「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Alt または F10 | メニュー バーをアクティブにします。
Alt + F4 | アクティブな項目を閉じます。または、プログラムを終了します。
Alt + F7 | ウィンドウを重ねて表示します。
Alt + Space | アクティブな項目のシステム メニューを表示します。
Alt + メニュー名の下線付き文字 | 対応するメニューを表示します。
方向キー | 選択したシェイプを方向キーの方向に移動します。
Ctrl キーを押しながら項目をドラッグ | 選択した項目をコピーします。
Ctrl + A | すべてを選択します。
Ctrl + C | 設計ページで選択した項目をコピーします。
Ctrl + F4 | アクティブなフローチャートを閉じます。
Ctrl + I | ウィンドウを原寸大に戻します。
Ctrl + N | 新しいフローチャートを作成します。
Ctrl + O | 既存のフローチャートを開きます。
Ctrl + P | [印刷] ダイアログ ボックスを開きます。
Ctrl + Q | プログラムを終了します。
Ctrl + Shift + 方向キー | スクロールします。
Ctrl + Shift + マウス左クリック | 拡大します。
Ctrl + Shift + マウス右クリック | 縮小します。
Ctrl + V | 選択した項目を設計ページに貼り付けます。
Ctrl + X | 設計ページで選択した項目を切り取ります。
Ctrl + Y | 操作を繰り返します。
Ctrl + Z | 操作を元に戻します。
Del | 設計ページで選択した項目を削除します。
Esc | 現在の作業を取り消します。
F1 | オンライン ヘルプを表示します。
F11 | テキスト プロパティ ダイアログ ボックスを開きます。
F8 | 選択したシェイプを整列します。
← | ダイアログ ボックスのタブにフォーカスがある場合、フォーカスを左に移動します。
→ | ダイアログ ボックスのタブにフォーカスがある場合、フォーカスを右に移動します。
Shift キーを押しながら項目をドラッグ | 項目を水平または垂直にまっすぐドラッグします。
Space | チェック ボックスのオン/オフを切り替えます。
開いたメニューのコマンド名の下線付き文字 | 対応するコマンドを実行します。


XLANG スケジュール

XLANG スケジュール フローチャートのコンパイルされたバージョンが、XLANG スケジュールです。XLANG スケジューラ エンジンは、このスケジュールを実行します。XLANG スケジューラ エンジンは、XLANG スケジュールに記述されているビジネス プロセスを、XLANG スケジュールに定義されているアクション、条件、およびエラー処理プロセスに基づいて監視し、制御します。

ここには次のトピックが含まれます。

  • XLANG の概要

  • インスタンス管理

  • 永続化

  • ステータス退避とステータス復元

  • データ処理


XLANG の概要

XLANG は、ビジネス プロセスの動作を記述する XML ベースの言語です。BizTalk オーケストレーション デザイナは、XLANG スケジュール フローチャートを XML 構造の XLANG スケジュール ファイルにコンパイルします。XLANG は XML ベースなので、XLANG スケジュールは整形式ドキュメントの XML 条件に従い、仕様または標準スキーマに準拠している必要があります。


インスタンス管理

XLANG スケジューラ エンジンがインスタンス管理を実行する方法を理解するには、ビジネス プロセスの抽象定義とビジネス プロセス定義の複数実行インスタンスの違いに注意する必要があります。BizTalk オーケストレーション デザイナでは、ビジネス プロセス定義を設計し、XLANG スケジュール フローチャート (.skv ファイル) として保存します。XLANG スケジュール フローチャートを作成した後、XLANG スケジュール (.skx ファイル) にコンパイルします。XLANG スケジュールを展開した後、多くの場合、スケジュールの複数のインスタンスが同時に実行しています。各 XLANG スケジュール インスタンスには、ほかのインスタンスの有効期間とは別に、独立した有効期間を設定できます。複数の XLANG スケジュール インスタンスをサポートするアプリケーションを設計するときは、次の事項に注意してください。

  • メッセージを受信するときは、XLANG スケジュールの新しいインスタンスをアクティブにします。新しい XLANG スケジュール インスタンスをアクティブにするアプリケーションを設計するには、メッセージを受信するたびに COM 関数 GetObject を使用します。たとえば、Active Server Page (ASP) を使用して発注要求または顧客サポートの要求が含まれているメッセージを受信する場合は、ASP で COM 関数 GetObject を使用して、XLANG スケジュールをアクティブにする必要があります。

BizTalk メッセージ バインド ウィザードを使用して、メッセージが送信される先の名前付きの場所として機能するポート バインドを作成することもできます。BizTalk Server 2000 には、BizTalk メッセージにバインドされたポートがメッセージを受信したときに XLANG スケジュールのインスタンスをアクティブにする自動メカニズムが用意されています。BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページでは、XLANG スケジュールの新しいインスタンスをアクティブにしてから、このポートにメッセージを送信するように BizTalk メッセージ サービスでチャネルが構成されていることを確認するように求めるメッセージが表示されます。この処理を完了するには、BizTalk メッセージ マネージャで新しいメッセージ ポート ウィザードを実行する必要があります。新しいメッセージ ポート ウィザードの [送信先アプリケーション] ページで、ポート名、および XLANG スケジュールの名前と場所を指定します。

  • メッセージの交換を XLANG スケジュール インスタンスに関連付けます。XLANG スケジュールの各インスタンスには、XLANG スケジューラ エンジンによってグローバル一意識別子 (GUID) が割り当てられます。そのため、XLANG スケジュールの各実行インスタンスの各ポートには、一意なアドレスを指定できます。これによって、特定の XLANG スケジュール インスタンスの特定のポートと直接通信できます。一意なアドレスを指定できるポートの場所を使用して直接通信できるため、単一の場所を使用してメッセージをインスタンスに配布する必要がなくなります。スケジュール インスタンスから送信される最初のメッセージは、多くの場合、静的ポート (名前付きの場所) へのメッセージです。XLANG スケジュールがアクティブになると、このインスタンスは動的ポート (インスタンスごとの一意な場所) の場所を受信者に送信します。受信者は、そのポートに通信を戻す必要があります。これは、一意な返信先アドレス付きで送信された電子メール メッセージに対応します。次の一覧は、BizTalk Server バインド テクノロジごとの動的バインドのサポートの説明です。
    • COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの [静的または動的な通信] ページで [静的] を選択した場合、XLANG スケジューラ エンジンはコンポーネントの XLANG スケジュール インスタンスを作成します。[動的] を選択した場合は、コンポーネントのインスタンスを作成する前に、別のアプリケーションでインターフェイス ポインタまたはモニカを (メッセージのフィールドとして) 送信する必要があります。

      [インスタンスを作成しない] を選択することもできます。コンポーネント インスタンスの作成の詳細については、「静的ポートと動的ポート」を参照してください。

    • メッセージ キュー バインド ウィザードの [静的または動的な通信] ページで [静的キュー] を選択し、[次へ] をクリックすると、[キュー情報] ページが表示されます。[キュー情報] ページで、各 XLANG スケジュール インスタンスに対して個別にインスタンスごとのキューを作成するように指定することも、すべての実行インスタンスに対してキューを 1 つだけ使用するように指定することもできます。関連付けを有効にするには、各 XLANG スケジュール インスタンスに対して個別にインスタンスごとのキューを作成するように指定する必要があります。

    • メッセージ キュー バインド ウィザードの [静的または動的な通信] ページで [動的キュー] を選択した場合は、ポートを通じてメッセージを送受信する前に、別のアプリケーションでキュー名を (メッセージのフィールドとして) 送信する必要があります。

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで、チャネル情報を指定するか、チャネル情報が XLANG スケジュールで既に受信したメッセージ フィールドによって提供されていることを示すことができます。メッセージ交換の詳細については、「BizTalk サービスの統合」を参照してください。

    重要

    • メッセージは、取引先との通信で既に使用している XLANG スケジュール インスタンスと同じものに関連付けてください。
  • アプリケーションの拡張。メモリ上に置く必要がない XLANG スケジュール インスタンスは、ステータス退避してください。メッセージの到着を待つ間、XLANG スケジュール インスタンスを必ずしもメモリ上に置く必要はありません。

注

  • すべての実装テクノロジでは、動的にバインドされ、実行時に定義される場所を示すシェイプの下にシャドウが表示されます。

関連項目

データ処理

ステータス退避とステータス復元

セッション ステータスの管理

永続化


永続化

XLANG スケジューラ エンジンは、ステータス保存データベースに次の情報を格納します。

  • XLANG スケジュールの構造

  • アクティブな XLANG スケジュール インスタンスの進行状況

  • XLANG スケジュール インスタンスを実行している間に送受信されたメッセージ

XLANG スケジューラ エンジンが情報を永続化することによって、次のことができます。

  • 長時間のスケジュールのステータス退避とステータス復元ができます。長時間トランザクションの途中で、システムに障害が発生することがあります。システムが再起動されたときに、XLANG スケジューラ エンジンはステータス保存データベースを参照して、スケジュールのどこから再開するかを判断します。

  • トランザクションに障害が発生したときに、スケジュール インスタンスのステータスを復元します。トランザクションの途中でシステムに障害が発生し、トランザクションが中断されることがあります。XLANG スケジューラ エンジンはステータス保存データベースを参照して、スケジュールのどこから再開するかを判断します。

  • 実行中のスケジュールのデバッグと監視をサポートします。デバッグ ツールと監視ツールを使用してステータス保存データベースに照会し、スケジュール インスタンスの進行状況に関する情報を表示できます。

トランザクションの開始前と完了後に XLANG スケジュールのステータスの永続化をサポートすることによって永続性が提供され、コミットされたすべての変更が恒久的にシステムに反映されます。また、障害が発生した場合にトランザクションを再試行することもできます。次の条件を満たしている場合に、実行中のスケジュール インスタンスのステータスは永続化されます。

  • トランザクションの開始時。ビジネス プロセスがトランザクションの開始に入るときに、ステータス保存データベースのトランザクション再試行回数を更新する必要があります。これによって、トランザクションの途中でシステムに障害が発生した場合に、XLANG スケジューラ エンジンが再試行回数を追跡できます。

  • トランザクションの終了時。ビジネス プロセスがトランザクションの外に出る場合、必要に応じて、ロールバックできるようにスケジュール ステータスを更新する必要があります。この更新は、データベースの永続性の原子性を保証するために、トランザクションのコンテキストで行われます。

関連項目

ステータス退避とステータス復元

インスタンス管理

セッション ステータスの管理


ステータス退避とステータス復元

XLANG スケジュールの複数のインスタンスを同時に長時間実行している場合、すべてのインスタンスをメモリ上に残しておくと非効率的になることがあります。この問題に対処するために、XLANG スケジューラ エンジンにはステータス退避とステータス復元の基盤が用意されています。

XLANG スケジュール インスタンスがメッセージを長時間待つことが予測される場合、そのスケジュールでほかの活動が何も実行されていなければ、XLANG スケジューラ エンジンは XLANG スケジュール インスタンスのステータスを退避できます。XLANG スケジュール インスタンスのステータス退避は、インスタンスに固有のすべてのステータスをステータス保存データベースに保存して永続化し、インスタンスをメモリから削除します。ステータス退避済み XLANG スケジュール インスタンス用のポート アドレスにメッセージが到着すると、インスタンスのステータス復元が行われます。XLANG スケジュール インスタンスのステータス復元では、データベースにあるインスタンスがメモリ上に復元されます。

XLANG スケジュール インスタンスは、ステータス復元が行われるか、管理者によって明示的に終了されるまで、ステータス退避された状態で保持されます。このような処理によって、長時間に渡って、ビジネス プロセスを高い信頼性を保ったまま実行することが可能になります。

XLANG スケジューラ エンジンの待ち時間の設定を使用して、アクションが非アクティブになってから XLANG スケジュール インスタンスをステータス保存データベースにステータス退避するまでの時間を決定できます。XLANG スケジューラ エンジンは、この待ち時間の設定を使用して、XLANG スケジュール インスタンスをステータス保存データベースにステータス退避し、メッセージが到着したときにステータス復元します。ただし、次のように、待ち時間の設定にかかわらず、スケジュールがステータス退避されない場合があります。

  • スケジュール インスタンスが休止ステータスではない場合。これは、XLANG スケジュール インスタンスの現在の処理 フローの 1 つでアクションの実行中に発生することがあります。XLANG スケジューラ エンジンが XLANG スケジュール インスタンスをステータス退避するには、スケジュール インスタンスのすべての処理 フローが同じステータスである必要があります。ステータス退避を実行するには、すべての保留中アクションの待ち時間が、指定されたしきい値を超える必要があります。

  • 保留中の DTC スタイル トランザクションがある場合。DTC スタイルのトランザクションは一般的に短時間なので、DTC スタイルのトランザクションが実行中の場合、XLANG スケジューラ エンジンはスケジュールのステータス退避を行いません。

  • 永続化できない実行中ポートがある場合。実行中ポートとは、実装済みで、後でスケジュール インスタンスで使用される可能性があるポート オブジェクトまたはポートです。ポートの有効期間は、スケジュール インスタンスの実行にとって重要な問題です。ポートは COM インターフェイスなどの実装テクノロジにバインドされます。ポートがバインドされている実装テクノロジが永続化されずに、後で再使用されるステータス情報を保持している場合、インスタンスのステータス退避とステータス復元は行われません。ステータス保存データベースに障害が発生し、後で再実行した場合、ステータス情報は失われ、最後にステータス退避されたときのステータスからスケジュール インスタンスの実行を再開することはできません。

XLANG スケジューラ エンジンは、シャットダウンされるときに、トランザクション コンテキストにないすべての情報も含めて、可能な限り多くの情報をステータス保存データベースに保存します。

関連項目

インスタンス管理

セッション ステータスの管理

永続化

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


データ処理

XLANG では、すべてのデータは一意な名前のメッセージのセットに格納されています。アクションがメッセージを受信すると、新しいデータが XLANG スケジュール インスタンスに入力されます。

XLANG スケジュール フローチャートごとに、1 つの [データ] ページがあります。[データ] ページでは XLANG スケジュールのデータ フローを記述できます。あるメッセージ フィールドから別のメッセージ フィールドにデータが流れることを示すには、送信元メッセージ フィールドから送信先メッセージ フィールドに矢印を描画します。

[定数] メッセージを除いて、[データ] ページのメッセージのどのメッセージ フィールドにも、最初は値が含まれていません。[定数] メッセージは、[データ] ページで指定された値で初期化されます。これは、新しい XLANG スケジュール インスタンスごとに自動的に初期化されます。定数の使用方法については、「定数メッセージ」を参照してください。表示されているほかのメッセージの値は、XLANG スケジュール インスタンスで各メッセージが送受信されたときに設定されます。1 つのメッセージを複数のアクションで受信することができます。メッセージが受信されるたびに、そのメッセージの値は上書きされます。メッセージが XLANG スケジュールの別のポイントで送信される場合でも、受信したメッセージへのデータのフローを使用して別の受信メッセージの値が設定されることはありません。排他的に送信されるメッセージは、そのメッセージのメッセージ フィールドに値を設定するように [データ] ページに表示されているデータ フローを使用します。送信されたすべてのメッセージのすべてのフィールドが指定されるまで、スケジュールはコンパイルされません。

[データ] ページのフィールドが、XML スキーマ内でオプションのノードをポイントしている XPath を参照する場合は、次のガイドラインを使用します。

  • オプションのノードが存在するときの受信メッセージ。このメッセージを受信したときに XML ドキュメントにオプションのノードが存在する場合、XPath フィールドはノードの値を格納します。

  • オプションのノードが存在しないときの受信メッセージ。このメッセージを受信したときにオプションのノードが存在しない場合、XPath フィールドは NULL 値を格納します。このフィールドで判断規則と VBScript 式 IsNull (Message.Field) を使用して、受信メッセージにオプションのノードが含まれているかどうかを判断する必要があります。このフィールドが別の送信メッセージへのデータ フローを提供する場合、値が存在するかどうかをテストしないと、XLANG スケジューラ エンジンが送信メッセージを作成しようとしたときにエラーが発生します。

  • オプションのノードが存在するときの送信メッセージ。このメッセージが (オプションの XML ノードをポイントする XPath ノードを使用して) 送信される場合、XLANG スケジューラ エンジンはデータ フローを使用してメッセージを作成します。ノードがメッセージのドキュメント フィールドに存在する場合、XLANG スケジューラ エンジンはこの値を XPath の値で上書きします。

  • オプションのノードが存在しないときの送信メッセージ。このメッセージが (オプションの XML ノードをポイントする XPath ノードを使用して) 送信される場合、XLANG スケジューラ エンジンはデータ フローを使用してメッセージを作成します。ノードが指定されたドキュメント フィールドに存在しない場合、XLANG スケジューラ エンジンは上書きするノードを作成しません。これが原因でエラーが発生することがあります。

メッセージ キューとの間で送受信されるメッセージの場合は、次のガイドラインを使用します。

  • 受信メッセージ。アクションが非 XML メッセージをメッセージ キューから受信する場合は、XML 通信ウィザードの [XML 変換情報] ページの [キューから文字列メッセージを受信する] を選択する必要があります。このように構成すると、[データ] ページの [メッセージ] シェイプに、新しい StringData フィールドが表示されます。この StringData フィールドに、キューから受信した非 XML メッセージが格納されます。メッセージのドキュメント フィールドには、XLANG スケジューラ エンジンの標準 XML ラッパーで囲まれた StringData フィールドが格納されます。

  • 送信メッセージ。アクションが非 XML メッセージをメッセージ キューに送信する場合は、XML 通信ウィザードの [XML 変換情報] ページの [メッセージをキューに文字列として送信します] を選択する必要があります。このように構成すると、[データ] ページの [メッセージ] シェイプに、新しい StringData フィールドが表示されます。この構成を完了するには、[データ] ページの [定数] メッセージで、XLANG スケジューラ エンジンの標準 XML ラッパーを含む新しい定数を作成する必要があります。この定数名は任意ですが、データ型は string である必要があり、定数の値は、<?xml version="1.0" ?> <StringData> </StringData> にする必要があります。この新しい定数を作成した後で、[定数] メッセージの新しい定数から [メッセージ] シェイプのドキュメント フィールドへのデータ フロー接続を描画する必要があります。非 XML 文字列を含むフィールドから [メッセージ] シェイプの新しい StringData フィールドへのデータ フロー接続も描画する必要があります。

注

  • データ フローの方向とメッセージ フローの方向は、互いに独立しています。メッセージ フローは、メッセージの送信または受信を示します。

  • コンポーネントのインスタンスを作成しないで、メソッド呼び出しを使用して XLANG スケジュールでデータを受信できるようにするには、COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの [静的または動的な通信] ページの [インスタンスを作成しない] を選択します。[インスタンスを作成しない] を選択すると、コンポーネントはインスタンスを作成せず、メソッド呼び出しのコードも実行されません。代わりに、XLANG スケジュールがメソッド要求の情報をインターセプトすると、この情報をメソッド応答として返します。メソッド呼び出しが回避されます。

  • メッセージが繰り返しループの本体でのみ使用される場合、ループの各繰り返しではメッセージの値は初期化されません。メッセージが繰り返しループの本体の内側と外側の両方で使用される場合、メッセージの値はループの各繰り返しを通じて保持されます。メッセージの値は、一連のビジネス プロセスが [繰り返し] シェイプに流れる前と流れた後を通じて保持されていることもあります。

  • 繰り返しループの中の [<トランザクション> の補正] または [<トランザクション> の失敗時] でメッセージが初期化された場合、そのメッセージの値はループの外側では利用できません。

  • データ型が char の XML メッセージのフィールド (定数メッセージを含む) がメソッド メッセージ フィールドにデータ フローを提供する場合、フィールドはメソッド用に integer に変換されます。メソッド メッセージ フィールドのデータ型が string の場合、文字列には整数値が格納されます。文字は格納されません。この問題が発生した場合、送信元フィールドが定数メッセージの一部であれば、定数フィールドのデータ型を string に変更してください。送信元フィールドが XML メッセージの一部である場合は、char データ型を string に型変換するコンポーネントを使用する必要があります。

ここには次のトピックが含まれます。

  • データ ページ

  • 定数メッセージ

  • ポート参照メッセージ

  • フィールド データ型

  • システム フィールド

  • ノード パス フィールド


データ ページ

XLANG スケジュール フローチャートごとに、1 つの [データ] ページがあります。[データ] ページには、次の情報が表示されます。

  • XLANG スケジュールのメッセージごとに 1 つのメッセージ シェイプ

  • 1 つの [定数] メッセージ

  • XLANG スケジュール フローチャートのポートごとに、ポート フィールドを含む 1 つの [ポート参照] メッセージ

  • メッセージ フィールド間のデータのフローを示す接続図

メッセージは、一意な名前のフィールドのセットで構成されています。各フィールドには、特定のデータ型のデータ項目が 1 つ含まれています。XLANG スケジュールの各メッセージは、[データ] ページに表形式で表示されます。各表には、メッセージの名前、およびフィールド名とそれに対応するデータ型の一覧が表示されます。データ フローを必要としないシステム フィールドは、黄色の背景色で表示されます。ユーザー フィールドとデータ フローが必要なシステム フィールドは、白の背景色で表示されます。

[データ] ページの接続は、送信元メッセージ フィールドの右側から送信先メッセージ フィールドの左側をポイントします。この接続は、送信元メッセージ フィールドが送信先メッセージ フィールドにデータを提供することを示します。実行時に送信先メッセージが作成されると、XLANG スケジューラ エンジンが送信元メッセージ フィールドから送信先メッセージ フィールドにデータをコピーします。送信元メッセージがまだ到着していない場合、実行時エラーが発生します。

注

  • [データ] ページでは、次のデータ型はサポートされていません。
    • BinHex

    • BinBase64

    • I8

    • UI8

データ型が BinHex、BinBase64、I8、または UI8 の XML ドキュメントにノードがあり、[データ] ページでこのノードへの XPath を使用して、ノードを XLANG スケジューラ エンジンの範囲に入るように指定した場合、ノードは文字列に変換されます。

  • XLANG スケジュールでは、すべてのフィールドの名前は 100 文字以内にする必要があります。

関連項目

定数メッセージ

データ処理

フィールド データ型

ノード パス フィールド

ポート参照メッセージ

システム フィールド


定数メッセージ

[定数] メッセージを使用して、XLANG スケジュール インスタンスをデータで初期化することができます。XLANG スケジューラ エンジンの中で、[定数] メッセージは特異な機能を実行します。このメッセージは、送信も受信もされません。新しい XLANG スケジュール インスタンスごとに、自動的に初期化されます。[定数] メッセージに定数を追加するには、[定数] メッセージをダブルクリックするか、[定数] メッセージのフィールドをダブルクリックして [定数メッセージのプロパティ] ダイアログ ボックスを開きます。次に、[定数メッセージのプロパティ] ダイアログ ボックスの [追加] をクリックして、[定数のプロパティ] ダイアログ ボックスを開きます。[定数のプロパティ] ダイアログ ボックスで、定数に名前を付けたり、定数のデータ型を選択したり、定数に値を割り当てることができます。

注

  • XML は、日付の書式設定をする Windows ロケールの設定を処理しません。ローカライズされた書式の日付を定数に割り当てるには、定数のデータ型を string に設定します。この定数が date データ型のフィールドにデータを提供すると、XLANG スケジューラ エンジンは、文字列をローカライズされた書式に準拠した日付であると解釈します。

関連項目

データ処理

データ ページ

フィールド データ型

ノード パス フィールド

ポート参照メッセージ

システム フィールド


ポート参照メッセージ

[ポート参照] メッセージには、[ビジネス プロセス] ページで作成されたすべてのポートの一覧が含まれています。[ビジネス プロセス] ページで新しいポートが追加されるたびに、新しい参照がこの一覧に追加されます。[ポート参照] メッセージで、ポートの元の場所を指定できます。[ポート参照] メッセージには、XLANG スケジュール フローチャートのポートごとに 1 つのポート フィールドが含まれています。

XLANG スケジュールのポートが、設計時にはわからないことがあります。このような状況は、メッセージの送信先または作成元がほかのメッセージのコンテンツで決まる場合に発生します。たとえば、メッセージを作成した取引先に対して、受信確認を使用してメッセージに応答する必要があるアクションの状況を記述するビジネス プロセスがあるとします。この例で受信するメッセージには、通常、メッセージ作成元のアドレスが含まれている返信先アドレス フィールドがあります。XLANG スケジュールは、返信先アドレス フィールドのコンテンツを受信確認メッセージの送信先アドレスに関連付ける必要があります。[ポート参照] メッセージと受信確認メッセージを使用して、[データ] ページでこのシナリオを実装できます。メッセージ交換の詳細については、「BizTalk サービスの統合」を参照してください。

重要

  • 1 つの分岐シェイプの異なる分岐のアクションは、互いに通信できません。たとえば、ある分岐のアクションがキューからのメッセージの受信を待機しているときに、別の分岐のアクションがこのキューにメッセージを送信することはできません。異なる分岐のアクション間のあらゆる通信を適切にサポートするように XLANG スケジュール フローチャートが設計されていない場合、エラーは表示されませんが、実行時に XLANG スケジュール インスタンスの障害が発生することがあります。

関連項目

定数メッセージ

データ処理

フィールド データ型

ノード パス フィールド

システム フィールド


フィールド データ型

BizTalk オーケストレーション デザイナでは、XML データ型名と共にすべてのデータ型が表示されます。次の表は、表示される XML データ型名と等価な OLE Automation、Visual Basic、および C プログラムの型の一覧です。

XML UI 表示 | OLE Automation | Visual Basic | C
単純型 |  |  |
boolean | VT_BOOL | Boolean | VARIANT_BOOL
string | VT_BSTR | String | BSTR
cy | VT_CY | Currency | CURRENCY
date | VT_DATE | Date | DATE
dispatch | VT_DISPATCH | Object | IDispatch
error | VT_ERROR |  | SCODE
i1 | VT_I1 |  | signed char
i2 | VT_I2 | Integer | SHORT
i4 | VT_I4 | Long | LONG
int | VT_INT |  | INT
r4 | VT_R4 | Single | FLOAT
r8 | VT_R8 | Double | DOUBLE
ui1 | VT_UI1 | Byte | BYTE
ui2 | VT_UI2 |  | USHORT
ui4 | VT_UI4 |  | ULONG
uint | VT_UINT |  | UINT
unknown | VT_UNKNOWN | Object | IUnknown
variant | VT_VARIANT | Variant | VARIANT

関連項目

定数メッセージ

データ処理

データ ページ

ノード パス フィールド

ポート参照メッセージ

システム フィールド


システム フィールド

各メッセージには、XLANG スケジューラ エンジンが自動的に作成したシステム フィールドのセットが含まれていることもあります。

システム フィールド名 | このシステム フィールドが表示されるタイミング | 説明
__Status__ | COM またはスクリプト バインドにバインドされているポートからメッセージを受信したとき。 | メソッド呼び出しの HRESULT。
__Sender__ | 任意のポートとの間でメッセージを送受信したとき。 | メッセージを受信した場合、メッセージ キューまたは COM が提供する SenderID。メッセージが送信された場合、値は NULL。
ドキュメント | メッセージ キューまたは BizTalk メッセージにバインドされているポートとの間でメッセージを送受信したとき。 | 送受信されたメッセージ本体が含まれている文字列。

関連項目

定数メッセージ

データ処理

フィールド データ型

ノード パス フィールド

ポート参照メッセージ


ノード パス フィールド

メッセージ キューまたは BizTalk メッセージにバインドされているポートが XML ドキュメントを受信したとき、特定のドキュメント ノードを XLANG スケジューラ エンジンのデータ範囲に入れることができます。特定のノードが選択されていない場合、XLANG スケジューラ エンジンは XML ドキュメントをドキュメント システム フィールドに入力される不定形の文字列として扱います。

ドキュメント ノードを XLANG スケジューラ エンジンのデータ範囲に入れるには、XML 通信ウィザードの [メッセージ仕様] ページを使用します。XML 仕様を指定すると、[追加] と [削除] が有効になります。

関連項目

定数メッセージ

データ処理

フィールド データ型

ポート参照メッセージ

システム フィールド

XML 通信ウィザードの使用


XLANG スケジュール フローチャートの作成

XLANG スケジュールを設計するときに実行する必要がある作業は、次の 5 つです。

  • XLANG スケジュールが実行するビジネス プロセスの表現を描画します。[フローチャート] シェイプを使用して、ビジネス プロセスのフローを設計ページの左側に記述します。主となるビジネス プロセスは、[ビジネス プロセス] ページで描画します。代替のビジネス プロセスは、[<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページで描画します。

  • 判断の分岐条件と、ビジネス プロセスで繰り返し発生するプロセスを定義します。次に、同時に実行されるプロセスを定義し、ビジネス プロセスに必要なトランザクションと下位トランザクションを設計します。

  • ビジネス プロセスに必要なポート実装を作成します。4 つの実装テクノロジが利用できます。利用できる技術は、COM コンポーネント、Windows スクリプティング コンポーネント、メッセージ キュー サービス、および BizTalk メッセージ サービスです。

  • データとメッセージの間のフローを定義します。データとメッセージの間のすべてのフローを [データ] ページで描画します。

  • トランザクションに障害が発生した場合に必要になるビジネス プロセスを描画します。代替のビジネス プロセスを [<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページで描画します。

注

  • [フローチャート] シェイプと [実装] シェイプは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページに追加できます。これらのシェイプは、[データ] ページでは利用できません。

ここには次のトピックが含まれます。

  • ビジネス プロセスの設計

  • 例外処理

  • ビジネス プロセスの実装


ビジネス プロセスの設計

BizTalk オーケストレーション デザイナの [ビジネス プロセス] ページの左側は、ビジネス プロセスを設計するための領域です。境界バーによって、[ビジネス プロセス] ページは左側のビジネス プロセス設計領域と右側の実装領域に分割されます。

ここには次のトピックが含まれます。

  • アクションの設計

  • 条件の設計

  • 同時実行の設計

  • トランザクションの設計


アクションの設計

ビジネス プロセスは、XLANG スケジュール フローチャートの [開始] シェイプから最初の [フローチャート] シェイプに向かって流れる必要があります。一般的に、XLANG スケジュール フローチャートの最初の [フローチャート] シェイプは [アクション] シェイプになります。

[開始] シェイプには、2 つの構成可能プロパティがあります。[開始のプロパティ] ダイアログ ボックスで "トランザクション モデル" プロパティを構成して、XLANG スケジュール インスタンスで [トランザクション] シェイプをサポートするか、XLANG スケジュールをトランザクションの COM コンポーネントの中からアクティブにするかを決定できます。最初のオプションは、[トランザクション] シェイプのサポートを有効にします。2 番目のオプションは、[トランザクション] シェイプのサポートを無効にします。

[開始のプロパティ] ダイアログ ボックスで "トランザクションのアクティブ化" プロパティと "XLANG ID" プロパティを構成することもできます。トランザクションのアクティブ化の詳細については、「トランザクションの設計」を参照してください。

XLANG ID は、読み取り専用プロパティです。このプロパティには、XLANG スケジュール フローチャートのバージョンを、生成された XLANG スケジュールに関連付けるために使用されるグローバル一意識別子 (GUID) が含まれています。新しいフローチャートが作成されると自動的に GUID が生成され、XLANG スケジュール フローチャートが変更されるたびに新しい GUID が生成されます。

[アクション] シェイプで唯一の構成可能なプロパティは、アクションの名前です。アクションの名前は最大 32 文字です。アクション名は XLANG スケジュールの動作に影響を与えません。

関連項目

同時実行の設計

条件の設計

トランザクションの設計

フローチャート シェイプ


条件の設計

条件は、Microsoft Visual Basic Scripting Edition (VBScript) 式で記述し、[判断] シェイプおよび [繰り返し] シェイプで使用します。条件には、次の項目を含めることができます。

  • Date や Time などの組み込み VBScript 式

  • メッセージ フィールドのデータを評価する式

  • メッセージが存在するかどうかを判断できる式

条件には、シェイプの動作を定義する次のプロパティが含まれています。

  • [条件名] : XLANG スケジュール フローチャートでその条件を使用するシェイプの中に表示される必須プロパティです。条件名によって、条件は一意に識別されます。一意な名前を付けた単一の条件を、複数の [判断] シェイプと [繰り返し] シェイプで使用できます。条件を使用する [判断] シェイプまたは [繰り返し] シェイプの幅は、そのシェイプに含まれている最も名前の長い条件によって決まります。

  • [条件の説明] : 省略できるプロパティです。条件を説明します。

  • [条件式] : メッセージに含まれているデータを参照する必須の VBScript 式です。式は、TRUE または FALSE に評価される必要があります。

XLANG スケジュール フローチャートを設計するときに条件を作成し、条件名と条件の説明を指定します。[実装] シェイプをフローチャートに追加するときに、条件式を追加します。

注

  • "条件式" プロパティは、XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルするときにだけ必要になります。

  • [データ] ページのメッセージには表示されませんが、__Exists__ フィールドというメッセージ フィールドがあります。このフィールドを使用して、メッセージが存在するかどうかをテストできます。メッセージが存在するかどうかは、メッセージが XLANG スケジューラ エンジンで受信または定義されたかどうかで決まります。

関連項目

条件の作成

アクションの設計

同時実行の設計

トランザクションの設計

フローチャート シェイプ

判断条件の設定


同時実行の設計

BizTalk オーケストレーション デザイナは、同時に実行されるアクションをサポートします。[分岐] シェイプと [結合] シェイプを使用して、XLANG スケジュールで同時に実行される処理フローを実装します。[分岐] シェイプを使用して、同時に実行される処理フローを作成します。[結合] シェイプを使用して、同時に実行される処理フローのうち [終了] シェイプで終了しないフローを同期させます。

結合のプロパティ

[結合] シェイプには、設定可能な 2 つのプロパティがあります。これらのプロパティは、次の論理演算子で表されます。

  • [AND] : XLANG スケジュールは、すべての処理フローが結合に到着するまで待機してから、ビジネス プロセスの次のアクションを続行します。

  • [OR] : XLANG スケジュールは、最初の処理フローが結合に到着するまで待機してから、ビジネス プロセスの次のアクションを続行します。

    同じ分岐シェイプのほかの分岐のアクションはプロセスを完了しますが、OR 結合は完了するまで待機しません。OR 結合から出る処理フローに、その OR 結合に入る分岐からのデータ フローを必要とするアクションが含まれている場合、結合の外のアクションが実行されるときまでに分岐のアクションが完了していないと、エラーが発生します。

有効な分岐および結合処理フロー

ビジネス プロセスで同時に実行されるフローを設計するときは、次のガイドラインに従います。

  • 分岐したすべてのフローは、[終了] シェイプで終了するか、[結合] シェイプで同期をとって 1 つのフローにする必要があります。

  • 分岐したフローのアクションは、互いに通信できません。たとえば、ある分岐のアクションがキューからのメッセージの受信を待機しているときに、別の分岐のアクションがこのキューにメッセージを送信することはできません。

    注意

    • 異なる分岐のアクション間の通信を適切にサポートするように XLANG スケジュール フローチャートが設計されていない場合、エラー メッセージは表示されませんが、実行時に XLANG スケジュール インスタンスの障害が発生することがあります。
  • 1 つの結合を使用して複数の分岐からのフローの同期をとることはできません。[結合] シェイプを使用して同期をとれるのは、対応する分岐からのフローだけです。[分岐] シェイプと [結合] シェイプの使用には、1 対 1 の対応があります。

    次の図は、2 つの分岐を使用して同時実行フローを作成し、1 つの結合を使用してこれらのフローの同期をとろうとする例です。この接続は無効です。このような接続をしようとすると、XLANG スケジュールをコンパイルするときにエラー メッセージが表示されます。

    図をクリックすると、拡大または縮小します。

    図 1. 無効な結合を使用している同時実行フロー

    次の 2 つの図は、有効な結合の例です。

    図 2 の例では、2 つの分岐が 2 つの結合に対応しています。2 番目の分岐と結合の組が、最初の分岐と結合の組の中にネストされています。

    図をクリックすると、拡大または縮小します。

    図 2. 分岐と結合の 1 対 1 の対応と、ネストした分岐と結合の組を使用している同時実行フロー

    図 3 の例では、2 つの分岐が 2 つの結合に対応しています。2 番目の分岐と結合の組が、最初の分岐と結合の組の中にネストされています。2 番目の分岐と結合の組の間にある同時実行フローの 1 つが [終了] シェイプで終了する場合も、もう 1 つの同時実行フローの同期を対応する結合でとってから、最初の分岐と結合の組からの同時実行フローと同期をとる必要があることに注意してください。

    図をクリックすると、拡大または縮小します。

    図 3. 分岐と結合の 1 対 1 の対応、ネストした分岐と結合の組、および 1 つのフローを終了する [終了] シェイプを使用している同時実行フロー

  • 複数の同時実行フローの同期を OR 結合でとる場合、結合に入る各処理フローにはアクションを 1 つだけ含めることができます。複数のアクションが含まれているフローは無効です。

    次の図は、複数の同時実行フローの同期をとる OR 結合です。各フローには、アクションが 1 つだけ含まれています。

    図をクリックすると、拡大または縮小します。

関連項目

アクションの設計

条件の設計

トランザクションの設計

フローチャート シェイプ

同時実行のプロパティの設定


トランザクションの設計

BizTalk オーケストレーション デザイナは、エラー処理や障害が発生したトランザクションからの回復など、トランザクション指向のプログラミング モデルを提供します。BizTalk オーケストレーション デザイナで、[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページの2 種類の追加ページを作成するように [トランザクション] シェイプを構成できます。これら 2 つのページを使用して、ビジネス プロセスが失敗したトランザクションから回復できるようにします。[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページには、追加の [<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページを参照する [トランザクション] シェイプを含めることができます。[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページは、[ビジネス プロセス] ページに表示される同じ [ポート] シェイプと [実装] シェイプを使用できます。

BizTalk オーケストレーション デザイナで設計される短時間トランザクションには、4 つの ACID 属性があります。ACID とは、次のプロパティで構成される略語です。

  • Atomicity (原子性)。トランザクションは、作業の最も小さな単位を表します。トランザクションのすべての変更が実行されるか、またはまったく実行されないかのどちらかです。

  • Consistency (一貫性)。コミットされるときに、トランザクションはシステム内のデータの一貫性を保つ必要があります。トランザクションの開始前に内部の一貫性がとれていたデータベースのデータを変更する場合は、そのトランザクションがコミットされるときにも、データベースの内部の一貫性がとれている必要があります。このプロパティを保証することは、主にアプリケーション開発者の責任です。

  • Isolation (独立性)。同時に実行されるトランザクションによる変更は、ほかの同時に実行されるトランザクションによる変更から独立している必要があります。同時に実行される独立したトランザクションは、これらのトランザクションが連続して実行された場合と同じく、内部データベースの一貫性を保つように変更を実行します。

  • Durability (持続性)。トランザクションがコミットされると、すべての変更は恒久的にシステムに反映されます。システム障害が発生した場合にも、変更は永続化します。

これに対して、長時間トランザクションでは、完了までに長時間を必要とする操作を処理できるように独立性が犠牲になっています。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートのトランザクションのプロパティ

  • 特定のトランザクション シェイプのトランザクション プロパティ

  • ポート実装のトランザクション プロパティ

  • 長時間トランザクション

  • 短時間トランザクション

関連項目

アクションの設計

同時実行の設計

条件の設計

フローチャート シェイプ

トランザクション プロパティの設定


XLANG スケジュール フローチャートのトランザクションのプロパティ

[ビジネス プロセス] ページの [開始] シェイプを右クリックし、[プロパティ] をクリックすると、[開始のプロパティ] ダイアログ ボックスが表示されます。[開始のプロパティ] ダイアログ ボックスで、次のプロパティを構成できます。

  • [トランザクション モデル] : このプロパティの既定の設定は、[XLANG スケジュールにトランザクションを含める] です。
    • XLANG スケジュール フローチャートで、グループ化したアクションの集合を [トランザクション] シェイプで囲む場合は、[XLANG スケジュールにトランザクションを含める] を選択します。このオプションを選択すると、"トランザクションのアクティブ化" プロパティは無効になります。

    • COM+ コンポーネントによって XLANG スケジュールを COM+ トランザクション コンテキストの中でアクティブにするには、[XLANG スケジュールを COM+ コンポーネントとして扱う] を選択します。このオプションを選択すると、トランザクションを XLANG スケジュール フローチャートに含めることができなくなり、[分岐] シェイプを使用した同時実行の実装が制限されます。[分岐] シェイプを使用する場合は、COM+ コンポーネント呼び出しが含まれているすべてのアクションを、単一の送信分岐に入れる必要があります。この制限は、XLANG スケジュール フローチャートのアクションに COM コンポーネント呼び出しが含まれている場合には適用されません。また、すべてのトランザクションの変更を、単一の送信分岐で実行する必要があります。

      このオプションを選択すると、"トランザクションのアクティブ化" プロパティが有効になります。

  • [トランザクションのアクティブ化] : このプロパティの既定の設定は、[サポートしない] です。
    • [サポートしない] : XLANG スケジュールがトランザクションをサポートしない場合は、これを選択します。

    • [サポートする] : XLANG スケジュールが COM+ トランザクションに参加する可能性がある場合は、これを選択します。

    • [必要] : XLANG スケジュールに COM+ トランザクションが必要な場合は、これを選択します。

    • [新しいトランザクションを要求する] : XLANG スケジュールが新しいトランザクションに参加する必要がある場合は、これを選択します。この設定が有効な場合、XLANG スケジューラ エンジンは呼び出し元のトランザクションと異なる新しいトランザクションを自動的に開始します。
  • [XLANG ID] : "XLANG ID" プロパティの詳細については、「フローチャート シェイプ」を参照してください。

関連項目

トランザクションの設計

長時間トランザクション

短時間トランザクション

ポート実装のトランザクション プロパティ

特定のトランザクション シェイプのトランザクション プロパティ


特定のトランザクション シェイプのトランザクション プロパティ

[ビジネス プロセス] ページの [トランザクション] シェイプを右クリックし、[プロパティ] をクリックすると、[トランザクションのプロパティ] ダイアログ ボックスが表示されます。[トランザクションのプロパティ] ダイアログ ボックスで、次のプロパティを構成できます。

  • [種類] : このプロパティは、選択した [トランザクション] シェイプで使用されるトランザクションの種類を決定します。このプロパティの既定の設定は、[短時間の DTC スタイル] です。
    • ACID トランザクションの 4 つのプロパティを持つ作業の単一論理単位として実行されるアクションの集合をトランザクションでグループ化する場合は、[短時間の DTC スタイル] を選択します。ACID トランザクションの詳細については、「トランザクションの設計」を参照してください。[短時間の DTC スタイル] トランザクションは、設計ページに灰色の影付きで表示されます。このオプションは、ネストしたトランザクションとスタンドアロン トランザクションで利用できます。ネストしたトランザクションが含まれている外側のトランザクションでこのオプションを選択することはできません。

    • 無期限にメッセージを送受信するアクションの集合をトランザクションでグループ化する場合は、[長時間] を選択します。[長時間] トランザクションを構成してネストしたトランザクションの集合をグループ化することもできますが、トランザクションのネストのレベルは 2 段階に制限されます。[長時間] トランザクションは、設計ページに黄色の影付きで表示されます。このオプションは、すべてのトランザクションで利用できます。

    • 指定した時間内に完了しない場合に [長時間] トランザクションを中断するには、[定刻トランザクション] を選択します。[定刻トランザクション] は、設計ページに青色の影付きで表示されます。このオプションは、すべてのトランザクションで利用できます。
  • [タイムアウト] : このプロパティは、トランザクションを中断するまでの実行時間を秒単位で決定します。このオプションは、[定刻トランザクション] と [短時間の DTC スタイル] のトランザクションで利用できます。

  • [再試行回数] : このプロパティは、[短時間の DTC スタイル] トランザクションのプロセスが完了しなかった場合に、トランザクションのプロセスを実行する回数を決定します。再試行するたびに、アプリケーションのステータスはトランザクションのプロセスの開始ポイントにリセットされます。

  • [バックオフの時間] : このプロパティは、トランザクションを再試行する間隔を決定します。バックオフの時間は再試行の回数値と共に使用され、次にトランザクションが再試行を行うまでの待機時間が決定されます。バックオフ値は指数になっています。バックオフ値が 2 秒の場合、再試行の間隔は 2 秒、4 秒、8 秒、16 秒のようになります。計算式は B**R (B の R 乗) です。ここで、B はバックオフの時間、R は現在の再試行の回数を示します。あるトランザクション再試行のバックオフの時間が 180 秒よりも大きい場合、その XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。

  • [分離レベル] : 分離レベルは、同時に実行されるトランザクションのデータが、どの程度互いにアクセスできるかを決定します。このオプションは、[短時間の DTC スタイル] トランザクションでのみ利用できます。次の中から選択します。
    • [Serializable] を選択すると、選択したトランザクションが完了するまで同時に実行されるトランザクションはデータを変更できなくなります。これは、4 つの分離レベルの中で最も制限されたレベルです。

    • [Read Uncommitted] を選択すると、選択したトランザクションが完了する前に、同時に実行されるトランザクションがデータを変更できるようになります。これは、4 つの分離レベルの中で最も制限されないレベルです。

    • [Read Committed] を選択すると、同時に実行されるトランザクションのデータ変更がコミットされるまで、選択したトランザクションはこのデータにアクセスできなくなります。このオプションは Microsoft SQL Server の既定の設定です。

    • [Repeatable Read] を選択すると、選択したトランザクションが完了するまで読み取りがロックされます。
  • [失敗時] : [<トランザクション> の失敗時] ページを有効にするには、[コードの追加] をクリックし、[有効にする] チェック ボックスをオンにして [OK] をクリックします。これによって、[<トランザクション> の失敗時] ページを使用して、選択したトランザクションの障害を処理する代替のビジネス プロセスを設計できます。このオプションは、すべてのトランザクションで利用できます。

  • [補正] : [<トランザクション> の補正] ページを有効にするには、[コードの追加] をクリックし、[有効にする] チェック ボックスをオンにして [OK] をクリックします。これによって、[<トランザクション> の補正] ページを使用して、既にコミットされたネストしたトランザクションで実行された作業の論理単位を元に戻す代替のビジネス プロセスを設計できます。このオプションは、ネストしたトランザクションでのみ利用できます。

注

  • ネストしたトランザクションを中断しても、外側のトランザクションが自動的に中断されることはありません。これによって、ネストしたトランザクションの障害から回復できるように外側のトランザクションを設計できます。しかし、ネストしたトランザクションの [<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが外側のトランザクションを中断するように設計されていると、ネストしたトランザクションの障害によって外側のトランザクションの障害が発生します。

関連項目

トランザクションの設計

長時間トランザクション

短時間トランザクション

XLANG スケジュール フローチャートのトランザクションプロパティ

ポート実装のトランザクション プロパティ


ポート実装のトランザクション プロパティ

COM コンポーネント バインド ウィザードとスクリプト コンポーネント バインド ウィザードの [ポート プロパティの詳細設定] ページで、COM コンポーネントと Windows スクリプト コンポーネントのトランザクション プロパティを構成できます。[ポート プロパティの詳細設定] ページは、コンポーネントのメソッドからエラーが返されたときに現在のトランザクションを中断するオプションを提供します。[ポート プロパティの詳細設定] ページで、次のトランザクションのプロパティを構成できます。

  • [トランザクションのサポート] : "トランザクションのサポート" プロパティは、コンポーネントがトランザクションを必要とするか、サポートするか、または無視するかどうかを指定します。
    • [無効] : このオプションを選択すると、コンポーネントは COM トランザクション管理を無視します。

    • [サポートしない] : このオプションを選択すると、コンポーネントはトランザクションに参加せず、ほかのコンポーネントのトランザクションを伝達しません。

    • [サポートする] : このオプションを選択すると、コンポーネントがバインドされているポートに接続するアクションが、トランザクションに含まれている場合に、そのコンポーネントがトランザクションに含まれます。そうでない場合は、コンポーネントにはトランザクションがありません。

    • [必要] : このオプションを選択すると、コンポーネントがバインドされているポートに接続するアクションが、トランザクションに含まれている場合に、そのコンポーネントがトランザクションに含まれます。コンポーネントがバインドされているポートに接続するアクションが、トランザクションに含まれていない場合は、コンポーネント用に新しいトランザクションが作成されます。

    • [新しいトランザクションを要求する] : このオプションを選択すると、コンポーネント用に新しいトランザクションが常に作成されます。

重要

  • BizTalk オーケストレーション デザイナは、XLANG スケジュール フローチャートで使用されている実装テクノロジのトランザクションの動作に依存します。XLANG スケジュール フローチャートに [トランザクション] シェイプが含まれている場合は、ビジネス プロセスのトランザクションの動作を提供したり強制することはありません。COM コンポーネント、メッセージ キュー、またはスクリプトがトランザクションでない場合は、XLANG スケジュール フローチャートで操作されたデータがトランザクションの場合のように変更されることはありません。

注

  • "トランザクション モデル" プロパティを設定して、XLANG スケジュールを COM コンポーネントとして扱う場合は、XLANG スケジュール フローチャートで [トランザクション] シェイプを使用しないでください。[トランザクション] シェイプを使用して、XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルしようとすると、コンパイル処理が動作しなくなります。コンパイルする前に、XLANG スケジュール フローチャートからすべての [トランザクション] シェイプを削除する必要があります。

  • 複数のトランザクションで COM コンポーネントを使用する場合は、COM コンポーネントでステータスを保持しないようにするか、ステータスを保持して永続的にサポートする必要があります。

  • 複数のアクションが COM コンポーネントまたはスクリプト コンポーネントにバインドされているポートと通信する場合、これらのアクションが互いにネストしていない複数のトランザクション内にあると、コンポーネント インスタンスは新しいトランザクション コンテキストに入る前に破棄されてから再びインスタンス化されます。コンポーネントがステータスを保持し、永続的にサポートしている場合は、再アクティブ化されたときにステータスが復元されます。コンポーネントがステータスを保持し、永続的にサポートしていない場合は、ステータスが失われます。コンポーネントが別のアプリケーションでインスタンス化された場合に XLANG スケジューラ エンジンがコンポーネントを再アクティブ化できるのは、そのコンポーネントが永続化できるときだけです。永続化できないコンポーネントが別のアプリケーションでインスタンス化された場合、XLANG スケジューラ エンジンでコンポーネントを再びインスタンス化することはできません。XLANG スケジュールでエラーが発生します。

関連項目

トランザクションの設計

長時間トランザクション

短時間トランザクション

XLANG スケジュール フローチャートのトランザクションプロパティ

特定のトランザクション シェイプのトランザクション プロパティ


長時間トランザクション

長時間トランザクションは、「トランザクションの設計」で説明した 4 つの ACID 属性の 1 つである独立をサポートしません。長時間トランザクションのデータはロックされないので、ほかのプロセスまたはアプリケーションでデータを変更できます。データの一貫性を保つ必要がある場合は、ACID トランザクションを排他的に使用する必要があります。しかし、待ち時間が長い環境で ACID トランザクションを使用すると重大なスケーラビリティの問題が発生するため、XLANG スケジュール フローチャートでは長時間トランザクションをサポートしています。長時間トランザクションによって、データベースを長時間ロックする必要がなくなります。長時間トランザクションの間、メッセージは無期限に送受信されます。XLANG スケジュール フローチャートで記述されたビジネス プロセスの要件によっては、ビジネス プロセス全体 ([開始] シェイプと [終了] シェイプ以外) を長時間トランザクションで囲むことができます。

通常、長時間トランザクションには複数のネストした短時間トランザクションが含まれます。たとえば、単純な電信送金の場合、長時間トランザクションにネストした短時間トランザクションが含まれ、その中に次のアクションが含まれます。

  • 銀行口座からの現金引き出し

  • 電信送金処理の開始

次の図は、Wire transfer という長時間トランザクションの中でネストしている Send money という短時間トランザクションです。ネストしたトランザクションには単純な電信送金の 2 つのアクションが含まれています。Initiate the wire transfer アクションが完了すると、一連のビジネス プロセスはネストしたトランザクションの外に流れます。このときに、ネストしたトランザクションはコミットされ、銀行口座から現金が引き出されて送信先に送金されます。この時点で、一連のビジネス プロセスは外側のトランザクションの Wait for acknowledgement アクションに流れます。

図をクリックすると、拡大または縮小します。

このシナリオで、Wire transfer トランザクションは [定刻トランザクション] として構成されています。指定された時間内に送信者が現金受領の受信確認を受信しなければ、外側のトランザクションは中断されます。このとき、一連のビジネス プロセスはネストしたトランザクションの [Send money の補正] ページに流れます。ネストしたトランザクションは既にコミットされているので、送信者の口座に振り込めるアクションを代替のビジネス プロセスで記述する必要があります。[Send money の補正] ページに記述されたビジネス プロセスが実行されると、ビジネス プロセスは外側のトランザクションの [Wire transfer の失敗時] ページに流れます。このページには、外側のトランザクションの例外処理を記述するビジネス プロセスを含める必要があります。この例の場合、電子メールを担当者に送信して送金のステータスを通知するビジネス プロセスが考えられます。

関連項目

トランザクションの設計

フローチャート シェイプ

短時間トランザクション


短時間トランザクション

短時間トランザクションは、作業の単一論理単位として実行されるグループ化されたアクションの集合です。この作業の論理単位には、ACID トランザクションの 4 つのプロパティがあります。ACID トランザクションの詳細については、「トランザクションの設計」を参照してください。

関連項目

トランザクションの設計

フローチャート シェイプ

長時間トランザクション


例外処理

XLANG スケジューラ エンジンは、システム エラーをトラップできます。BizTalk オーケストレーション デザイナで、実行時の XLANG スケジュール エラーに対応する XLANG スケジュールを設計できます。ビジネス プロセスの一部を [トランザクション] シェイプで囲むと、エラーが発生した場合または要件を満たさない場合に実行される代替のビジネス プロセスを設計できます。

ここには次のトピックが含まれます。

  • システム エラー

  • アプリケーション エラー

関連項目

エラー処理プロパティの設定


システム エラー

XLANG スケジューラ エンジンの実行中に発生する可能性があるシステム エラーは、重要度のレベルによって 3 段階に分けられます。3 段階のレベルを重要度の低い順に示します。

  • XLANG スケジュールでトラップできるエラー

  • XLANG スケジュール インスタンスを終了させるエラー

  • XLANG スケジューラ エンジンの障害を発生させるエラー

ここには次のトピックが含まれます。

  • XLANG スケジュールでトラップできるエラー

  • XLANG スケジュール インスタンスを終了させるエラー

  • XLANG スケジューラ エンジンの障害を発生させるエラー


XLANG スケジュールでトラップできるエラー

XLANG スケジューラ エンジンは、次のシステム エラーをトラップできます。

  • 失敗を示す HRESULT を発生させる COM エラー。たとえば、アクセス許可が適切でない場合に XLANG スケジュールからメソッドが呼び出されると、COM はアクセス拒否のメッセージを返します。これは、COM バインドまたはスクリプト バインドに適用されます。

  • 登録されているサービスによるトランザクションの中断。たとえば、データベースへの接続が失われたときに、分散トランザクション コーディネータ (DTC) はトランザクションを中断します。また、メッセージ キュー サービスがメッセージをキューに入れることができないときに、メッセージ キュー サービスはトランザクションを中断します。

論理分岐を使用して失敗を示す HRESULT を処理するには、メソッド呼び出しから送信される _out メッセージを判断規則でテストする必要があります。HRESULT 値は _out メッセージの __Status__ フィールドに格納されています。

トランザクション障害プロセスを使用して失敗を示す HRESULT を処理するには、COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの最後のページで [メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにする必要があります。このプロパティは、アクションがトランザクションの中にある場合にだけ設定できます。

重要

  • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

メッセージ キューまたはBizTalk メッセージにおける実装テクノロジのエラー処理は、トランザクションの障害プロセスだけで実行できます。実行するには、メッセージ キュー バインド ウィザードの最後のページで [このキューはトランザクションを必要とする] チェック ボックスをオンにする必要があります。

注

  • メッセージ キューが正常な戻り値を返すアクションを送信した場合、メッセージが正常にキューに配置されたことを示します。メッセージが配信されたことを示すものではありません。

関連項目

アプリケーション エラー

XLANG スケジューラ エンジンの障害を発生させるエラー

XLANG スケジュール インスタンスを終了させるエラー

例外処理

システム エラー


XLANG スケジュール インスタンスを終了させるエラー

XLANG スケジュール インスタンスの障害を発生させるシステム エラーのうち、XLANG スケジュールでトラップできないエラーには、次のものがあります。

  • スケジュールされたメソッドと呼び出されたコンポーネントの同期がとれていない。

  • 送信待キューが存在しない。

  • スケジュールされたチャネルが存在しない。

  • メッセージからのデータ フローが、まだ到着していない。

関連項目

アプリケーション エラー

XLANG スケジュールでトラップできるエラー

XLANG スケジューラ エンジンの障害を発生させるエラー

例外処理

システム エラー


XLANG スケジューラ エンジンの障害を発生させるエラー

XLANG スケジューラ エンジンでトラップできないシステム エラーは、XLANG スケジューラ エンジンの障害を発生させ、同じ COM+ アプリケーションで実行されているすべての XLANG スケジュール インスタンスを巻き込むことがあります。これらのシステム エラーには、XLANG スケジューラ エンジンのプロセス領域で実行されているコンポーネントによるアクセス違反があります。XLANG スケジューラ エンジンはこれらのエラーをトラップしようとしますが、多くの場合、トラップできません。

関連項目

アプリケーション エラー

XLANG スケジュールでトラップできるエラー

XLANG スケジュール インスタンスを終了させるエラー

例外処理

システム エラー


アプリケーション エラー

XLANG スケジュール エラーの原因になるエラーを処理するには、次の 3 つの方法があります。

  • 論理分岐を使用する

  • トランザクション中断プロセス

  • タイムアウトを使用する


論理分岐

判断と条件を使用して、あらゆるプロセス ページ ([ビジネス プロセス] ページ、[<トランザクション> の失敗時] ページ、または [<トランザクション> の補正] ページ) の処理フローを分岐させることができます。次の図は、メソッド実行の単純なテストです。

図をクリックすると、拡大または縮小します。

この例では、Clear_out メッセージに __Status__ というシステム フィールドがあります。条件 HRESULT Success の条件式は Clear_out.[__Status__] >= 0 です。負の HRESULT は失敗を示し、0 または正の HRESULT は成功を示します。このように判断と条件を使用して、任意のメッセージの任意のデータ フィールドの例外を、任意の条件の VB Script 式でテストできます。テストの対象は、HRESULT に限りません。

関連項目

例外処理

タイムアウト

トランザクション中断プロセス


トランザクション中断プロセス

BizTalk オーケストレーション デザイナでは、トランザクションを使用して、作業の単一論理単位として実行されるアクションの集合をグループ化できます。これによって、グループの中のすべてのアクションを完了させるか、どのアクションも完了させないようにします。ビジネス プロセスをトランザクションにグループ化することによって、BizTalk オーケストレーション デザイナは最高レベルの構造化と信頼性を提供します。

トランザクションの処理フローは、トランザクションが完了するか、中断イベントが発生するまで、通常どおりに実行されます。中断イベントは、次のような場合に発生する可能性があります。

  • 処理フローに [中断] シェイプが出現した場合。

  • ポート バインドで中断を発生させるように指定されている失敗を示す HRESULT が返される場合。

  • あらゆるバインド テクノロジで、トランザクションを中断する障害イベントがシステム レベルで発生する可能性があります。たとえば、メッセージ キューがメッセージをキューに入れることができない場合があります。

  • XLANG スケジューラ エンジンにエラーが発生し、指定されたインスタンスのトランザクションが中断されることがあります。たとえば、DTC エラーがあります。

  • スケジュールを一時停止するときに、場合によっては、そのスケジュールのすべてのトランザクションを中断する必要があります。

  • トランザクション プロパティのタイムアウトが経過した場合。

中断が発生した場合、トランザクション グループの "再試行回数" プロパティに設定された値に応じて、トランザクションを最初から再試行できます。指定された回数、トランザクションを再試行しても障害が回復しなければ、[<トランザクション> の失敗時] ビジネス プロセスが呼び出されます。この [<トランザクション> の失敗時] コードは、トランザクションの障害を処理するための構造化された場所を提供します。

[<トランザクション> の失敗時] コードでトランザクションの作業を元に戻す必要はありません。ポートがトランザクションのリソースにバインドされている場合は、分散トランザクション コーディネータがトランザクションに登録されているすべてのアクションをロールバックします。非トランザクションのリソースは、ロールバックされません。トランザクションが外側のトランザクションの中にネストされていて、このネストしたトランザクションが既にコミットされている場合、一連のビジネス プロセスはネストしたトランザクションの [<トランザクション> の補正] ビジネス プロセスに流れます。[<トランザクション> の補正] ビジネス プロセスは、[<トランザクション> の補正] ページに記述します。この代替のビジネス プロセスには、ネストしたトランザクションの作業を元に戻すアクションを含める必要があります。

[<トランザクション> の補正] コードまたは [<トランザクション> の失敗時] コードが完了すると、一連のビジネス プロセスは [ビジネス プロセス] ページの [トランザクション] シェイプの一番下から外に流れます。トランザクションの後で発生する一連のビジネス プロセスのアクションは、トランザクションが完了、または中断されたかどうかを明示的に示すものを受信しません。明示的に示すには、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページのメッセージ フィールドでフラグを設定します。

関連項目

例外処理

論理分岐

タイムアウト


タイムアウト

トランザクションのアクションが、予測されるメッセージを取引先から受信しない場合、この障害はアプリケーション エラーとして処理されます。このエラーをテストするには、定刻トランザクションを使用します。

たとえば、単純な電信送金の場合、定刻トランザクションにネストしたトランザクションが含まれ、その中に次のアクションが含まれます。

  • 銀行口座からの現金引き出し

  • 電信送金処理の開始

次の図は、Wire transfer という時間制限付きのトランザクションの中でネストしている Send money というトランザクションです。ネストしたトランザクションには単純な電信送金の 2 つのアクションが含まれています。Initiate the wire transfer アクションが完了すると、ビジネス プロセスはネストしたトランザクションの外に流れます。このときに、ネストしたトランザクションはコミットされ、銀行口座から現金が引き出されて送信先に送金されます。この時点で、ビジネス プロセスは外側のトランザクションの Wait for acknowledgement アクションに流れます。

図をクリックすると、拡大または縮小します。

このシナリオで、Wire transfer トランザクションは時間制限付きのトランザクションとして構成されています。指定された時間内に送信者が現金受領の受信確認を受信しなければ、外側のトランザクションは中断されます。このとき、ビジネス プロセスはネストしたトランザクションの [Send money の補正] ページに流れます。ネストしたトランザクションは既にコミットされているので、送信者の口座に振り込めるアクションを代替のビジネス プロセスで記述する必要があります。[Send money の補正] ページに記述されたビジネス プロセスが実行されると、ビジネス プロセスは外側のトランザクションの [Wire transfer の失敗時] ページに流れます。このページには、外側のトランザクションの例外処理を記述するビジネス プロセスを含める必要があります。この例の場合、電子メールを担当者に送信して送金のステータスを通知するビジネス プロセスが考えられます。

関連項目

例外処理

論理分岐

トランザクション中断プロセス


ビジネス プロセスの実装

[実装] ステンシルには、ビジネス プロセスにポートを実装するために使用できるテクノロジに対応する 4 つのシェイプが含まれています。各アクションはメッセージをポートに送信するか、メッセージをポートから受信するので、メッセージ送受信のセマンティックな意味は特定の実装テクノロジによって異なります。

[実装] シェイプの使用には、2 つの異なるプロセスが含まれます。最初のプロセスで、ポートを実装テクノロジにバインドします。概念的には、ポートはメッセージが送受信される抽象的な場所です。ポートを実装にバインドすることによって、ポートがバインドされる場所の種類が定義されます。2 番目のプロセスで、アクションをポートに接続します。このプロセスで、ポートとの間で送受信されるメッセージのスキーマが定義されます。

BizTalk オーケストレーション デザイナは、4 つの実装テクノロジをサポートします。

  • COM コンポーネント。このテクノロジを使用すると、同期通信ができます。

  • Windows スクリプト コンポーネント。このテクノロジを使用すると、同期通信ができます。

  • メッセージ キュー サービス。このテクノロジを使用すると、非同期通信ができます。

  • BizTalk メッセージ サービス。このテクノロジを使用すると、非同期通信ができます。

境界バーによって、BizTalk オーケストレーション デザイナの設計ページは左側のビジネス プロセス設計領域と右側の実装領域に分割されます。ポート バインド ウィザードを開くには、[実装] シェイプの 1 つを設計ページの境界バーの右側にドラッグします。この作業は、[ビジネス プロセス] ページ、[<トランザクション> の失敗時] ページ、および [<トランザクション> の補正] ページで実行できます。

注

  • BizTalk オーケストレーション デザイナではエンベロープを構成できません。そのため、フラット ファイルを BizTalk オーケストレーションに送信するには、BizTalk エディタを使用してフラット ファイルのコンテンツを XML に変換します。次に、この XML ファイルを BizTalk オーケストレーションに送信します。

ここには次のトピックが含まれます。

  • ポート実装について

  • 同期通信と非同期通信


ポート実装について

ポートとは、特定の実装を使用する名前付きの場所です。XLANG スケジュールでは、ポートは、同期通信と非同期通信をサポートし、XLANG スケジュールから、またはXLANG スケジュールへ、メッセージを渡すのに使用されます。

BizTalk オーケストレーション デザイナでは、メッセージが送信される場所またはメッセージが受信される場所、および通信アクションを実装するために使用されるテクノロジによって、ポートが定義されます。ポートは、XLANG スケジュールのビジネス プロセス フローのアクションの左側にあるアクションにバインドされ、必要なアクションを容易にするために使用される右側の実装テクノロジにバインドされます。場所はポートの名前によって一意に識別されます。

ポートの場所は、ポートを実装するために使用されるテクノロジによって多少異なります。次の表は、利用できるポート実装と、それぞれのポート実装に関連付けられている場所です。

ポート実装 | ポートの場所
COM コンポーネント | アクティブ化されたオブジェクトのインスタンスへのポインタ
Windows スクリプト コンポーネント | アクティブ化されたオブジェクトのインスタンスへのポインタ
メッセージ キュー | メッセージ キューへのキュー パス名
BizTalk メッセージ | 特定の BizTalk メッセージ チャネルのチャネル名

ポートは、次の 2 つの方法で記述できます。

  • 静的ポート : 静的ポートは、設計時にポートの場所と実装に関するすべての情報を XLANG スケジュールに提供する必要があります。XLANG スケジュールを作成するデザイナは、メッセージの送信先や受信側だけでなく、通信アクションを実装するためのテクノロジも知っておく必要があります。

  • 動的ポート : 動的ポートは、実行時に特定の場所の情報を XLANG スケジュールに提供する必要があります。動的ポート用の実装は設計時に選択しますが、このポートの場所は XLANG スケジュールが実行されるまでわかりません。動的ポートの場所は、ポートを参照する場所情報に渡されるメッセージによって提供されます。このメッセージは、このポート実装を使用する通信が使用される前に、XLANG スケジュールの処理フローのポイントに到着している必要があります。

    動的ポートを通信に使用する場合、XLANG スケジュールがそのアクションを完了しようとする前にポートへの参照が含まれているメッセージを受信しないと、エラーが生成されます。

静的ポートと動的ポートは両方とも同期通信と非同期通信のオプションを提供しますが、これらの通信のポート実装はポートを実装するために使用するテクノロジによって異なります。

どのポートも、静的ポートまたは動的ポートのどちらにもなりますが、すべてのポートが同期通信と非同期通信の両方を実装できるわけではありません。同期通信アクションを作成するには、COM コンポーネント ポート実装またはスクリプト コンポーネント ポート実装を使用する必要があります。非同期通信アクションを作成するには、メッセージ キュー ポート実装または BizTalk メッセージ ポート実装を使用する必要があります。

ここには次のトピックが含まれます。

  • 静的ポートと動的ポート

  • COM コンポーネント シェイプの使用

  • スクリプト コンポーネント シェイプの使用

  • メッセージ キュー シェイプの使用

  • BizTalk メッセージ シェイプの使用

関連項目

同期通信と非同期通信


静的ポートと動的ポート

静的ポートと動的ポートの動作は、使用する実装の種類によって異なります。

COM コンポーネントまたは スクリプト コンポーネントを使用するポート実装

COM コンポーネントまたはスクリプト コンポーネントを使用するポート実装の場合、静的プロパティと動的プロパティは、コンポーネントのインスタンスを作成する方法を表します。

  • [静的] : 静的ポートを使用する XLANG スケジュールでは、XLANG スケジューラ エンジンがこのポート実装用に定義されているコンポーネントのインスタンスを作成します。

  • [動的] : 動的ポートを使用する XLANG スケジュールでは、XLANG スケジューラ エンジンはコンポーネントのインスタンスを作成しません。XLANG スケジュールは、別のアプリケーションがコンポーネントのインスタンスを作成するまで待機します。オブジェクト インスタンスは、メッセージ内のフィールドとして XLANG スケジュールに送信される必要があります。[データ] ページでは、そのメッセージ フィールドと、この実装を使用するポートのポート参照との間に、接続を描画する必要があります。XLANG スケジュールは、コンポーネントからのメソッド要求とメソッド応答の両方をインターセプトします。

[静的] と [動的] のほかに、3 番目の選択肢があります。

  • [インスタンスを作成しない] : インスタンスの作成をしないポートを使用する XLANG スケジュールでは、コンポーネントのインスタンスは作成されず、メソッド呼び出しのコードも実行されません。代わりに、XLANG スケジュールがメソッド要求の情報をインターセプトすると、この情報をメソッド応答として返します。メソッド呼び出しが回避されます。

メッセージ キューを使用するポート実装

メッセージ キューを使用するポート実装の場合、静的プロパティと動的プロパティは、静的キューと動的キューを表します。

  • [静的キュー] : 静的ポートは、既存のキューである静的キューを使用します。このキューは設計時に割り当てることができます。

    静的キューを使用する場合は、決して変更されない既存のキューを使用するか、XLANG スケジュールを実行するたびに同じキューの新しいインスタンスを作成するかのいずれかを選択できます。インスタンスごとのキューは、キューの名前に追加される一意な ID によって識別されます。

  • [動的キュー] : 動的ポートは、設計時にはわからない動的キューを使用します。動的キューの情報は、実行時にメッセージ フィールドで提供する必要があります。[データ] ページで、メッセージ フィールドからこのポートのポート参照へのリンクを作成する必要があります。キュー名を含むメッセージが到着すると、XLANG スケジュールは割り当てられたキューを使用できるようになります。キュー名を含むメッセージは、このポート実装を使用する通信が使用される前に到着する必要があります。

BizTalk メッセージを使用するポート実装

BizTalk メッセージを使用するポート実装の場合、静的プロパティと動的プロパティは、静的チャネルと動的チャネルを表します。動的チャネルは、メッセージを送信するときにだけ使用できます。動的チャネルを使用してメッセージを受信することはできません。

  • [静的チャネル] : 静的ポートは、既存のチャネルである静的チャネルを使用します。このチャネルは設計時に割り当てることができ、変更できません。

  • [動的チャネル] : 動的ポートは、設計時にはわからない動的チャネルを使用します。動的チャネルの情報は、実行時にメッセージ フィールドで提供する必要があります。[データ] ページで、メッセージ フィールドからこのポートのポート参照へのリンクを作成する必要があります。チャネル名を含むメッセージが到着すると、XLANG スケジュールは割り当てられたチャネルを使用できるようになります。チャネル名を含むメッセージは、このポート実装を使用する通信が使用される前に到着する必要があります。

動的チャネルを使用するポートによって、XLANG スケジュールは使用するチャネルを実行時に決定できるため、設計時に定義した既存のチャネルが不要になります。このプロパティは、XLANG スケジュールがメッセージを BizTalk メッセージ サービスに渡すときに使用するチャネルを定義します。

動的チャネルと、BizTalk メッセージ マネージャで構成するオープン チャネルを混同しないでください。オープン チャネルを使用すると、ドキュメントの情報またはドキュメントで送信されるパラメータで送信元組織を実行時に決定できます。このプロパティは、ドキュメントの送信元を定義します。オープン チャネルの詳細については、「チャネルについて」を参照してください。

動的チャネルを使用するポートに渡されるメッセージは、チャネル情報を BizTalk メッセージ サービスに渡すときに、オープン チャネルとオープンでないチャネルのどちらでも指定できます。

関連項目

ポートの実装

同期通信と非同期通信

チャネルについて

BizTalk メッセージ シェイプの使用

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

スクリプト コンポーネント シェイプの使用


COM コンポーネント シェイプの使用

[COM コンポーネント] シェイプを使用すると、既存のコンポーネントまたはアプリケーションで XLANG スケジュールのアクションを実行できます。COM テクノロジは同期をとるため、アクションが実行されるときは、常に双方向のメッセージのフローがあります。これに対して、非同期テクノロジのメッセージのフローは、一方向です。

XLANG スケジューラ エンジンは、[アクション] シェイプを使用してメッセージの送受信をサポートします。BizTalk オーケストレーション デザイナでポートを COM コンポーネントにバインドするときに、ポートはシステムに登録されている COM コンポーネントで実装されたインターフェイスにバインドされます。

ポートに接続された送信アクションは、XLANG スケジューラ エンジンによる特定のメソッド呼び出しの起動を表します。<入力> パラメータと <入出力> パラメータがポートに送信されます。戻り値として、メソッド呼び出しの <入出力> パラメータと <出力> パラメータで定義されたスキーマのメッセージをポートから受信します。メソッド呼び出しは、ポートにバインドされたインターフェイスでサポートされます。

ポートに接続された受信アクションは、外部アプリケーションがポートに対するメソッド呼び出しを作成するまで待機します。<入力> パラメータと <入出力> パラメータでポートが受信するメッセージのスキーマを定義し、<入出力> パラメータと <出力> パラメータでポートから送信するメッセージのスキーマを定義します。

ポートに接続されて COM コンポーネントにバインドされたアクションごとに、2 つのメッセージが交換されます。メッセージによって、起動されたインターフェイスのメソッドが識別されます。メッセージのスキーマは、メソッドの署名の <入力> パラメータと <入出力> パラメータ (および、<入出力> パラメータと <出力> パラメータ) に対応します。コンポーネントのタイプ ライブラリにアクセスできるので、BizTalk オーケストレーション デザイナは、ユーザーに情報を問い合わせずに、自動的にこれらのメッセージのスキーマを構築できます。

重要

  • 長時間のビジネス プロセスを実装するときは、COM コンポーネントの使用に注意が必要です。ステータスを保持するコンポーネントを XLANG スケジュールで使用する場合は、IPersistStream インターフェイスまたは IPersistStreamInit インターフェイスのいずれかを使用して保存できるコンポーネントを使用することをお勧めします。これによって、XLANG スケジュールはスケジュールのステータスと共にコンポーネントのステータスも格納できます。XLANG スケジュールは、ステータスを保持し、信頼性の高い状態で長時間実行できる必要があります。ステータスを保持しないコンポーネントを使用する場合は、XLANG スケジュールがステータス復元されるたびに、コンポーネントの新しいインスタンスが作成されます。ただし、ステータスを保持しないコンポーネントを使用する場合は、スケジュールの出力に影響を与えないようにする必要があります。

バインドは、ポートを実装するテクノロジを指定する処理です。COM コンポーネント バインド ウィザードは、次の 5 つのページで構成されています。

[COM コンポーネント バインド ウィザードへようこそ]

[COM コンポーネント バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。

[静的または動的な通信]

[静的または動的な通信] ページで、コンポーネントのインスタンスを作成する方法を定義できます。次の表は、静的通信と動的通信の設定の一覧と説明を示しています。

[静的または動的な通信] | 説明
[静的] | XLANG スケジューラ エンジンに対して、実装を完了させるために必要なすべての情報を設計時に指定できる場合は、このオプションを選択します。
[動的] | 実行時に実装を完了するための追加の情報が必要な場合は、このオプションを選択します。
[インスタンスを作成しない] | コンポーネントをアクティブにしないで、メソッド呼び出しを使用して XLANG スケジュールがデータを受信できるようにするには、このオプションを選択します。[インスタンスを作成しない] を選択すると、このコンポーネントへのメソッド呼び出しはインターセプトされ、XLANG スケジューラ エンジンは引数を格納し、呼び出しは呼び出し元に戻ります。コンポーネントはインスタンスを作成しません。

[クラス情報]

[クラス情報] ページで、登録済みコンポーネントの一覧またはモニカからクラスを選択できます。

[インターフェイス情報]

[インターフェイス情報] ページで、使用するインターフェイスを選択できます。このページは、選択したクラスに複数のインターフェイスが含まれている場合にだけ表示されます。Visual Basic コンポーネントのインターフェイスは、常に 1 つです。

[メソッド情報]

[メソッド情報] ページで、使用するメソッドを選択できます。このページは、選択したクラスに複数のメソッドが含まれている場合にだけ表示されます。

[ポート プロパティの詳細設定]

[ポート プロパティの詳細設定] ページで、セキュリティ、トランザクションのサポート、ステータス管理のサポート、およびエラー処理を構成できます。

[COM コンポーネント] シェイプのステータス管理のサポート プロパティによって、次のことができます。

  • トランザクションが開始する前とトランザクションが完了した後に、XLANG スケジュールのステータスを永続化します。これによって永続性が提供され、コミットされたすべての変更が恒久的にシステムに反映されます。また、障害が発生した場合にトランザクションを再試行することもできます。

  • メッセージの到着を待機している間、XLANG スケジューラ エンジンは XLANG スケジュールのステータス退避を実行し、その後ステータス復元を実行することができるので、インスタンス管理が最適化されます。

[COM コンポーネント] シェイプを使用して、受信したメッセージの認証済みユーザー情報を要求できます。

[セキュリティ]

次の表は、送信者 ID の確認設定の一覧と説明を示しています。

送信者 ID の確認 | 説明
[必要なし] | XLANG スケジュールが送信者の ID を確認せずにメッセージを受信できるようにする場合は、このオプションを選択します。
[オプション] | コンポーネントがメッセージを受信したときに、XLANG スケジューラ エンジンが送信者を識別するようにする場合は、このオプションを選択します (情報が利用可能な場合)。
[必要] | XLANG スケジューラ エンジンが送信者を識別できないメッセージを受信しないようにする場合は、このオプションを選択します。

[トランザクションのサポート]

次の表は、トランザクションのサポート設定の一覧と説明を示しています。

[トランザクションのサポート] | 説明
[無効] | すべての非 COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントは COM トランザクション管理を無視します。
[サポートしない] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントはトランザクションに参加せず、ほかのコンポーネントのトランザクションを伝達しません。
[サポートする] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。そうでない場合は、コンポーネントにはトランザクションがありません。
[必要] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。コンポーネントがバインドされているポートに関連付けられているトランザクションがない場合は、コンポーネント用に新しいトランザクションが作成されます。
[新しいトランザクションを要求する] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネント用に新しいトランザクションが常に作成されます。

[ステータス管理のサポート]

次の表は、ステータス管理のサポート設定の一覧と説明を示しています。

[ステータス管理のサポート] | 説明
[ステータスを保持しない] | XLANG スケジューラ エンジンは、コンポーネント インスタンスがステータス退避されると、そのコンポーネント インスタンスを終了します。この設定を選択した場合は、スケジュールがステータス復元されるときに、XLANG スケジューラ エンジンは必要に応じて新しいコンポーネント インスタンスを作成します。
[ステータスを保持し、永続的にサポートしない] | XLANG スケジューラ エンジンに対し、コンポーネント インスタンスの実行を継続するように要求します。アプリケーションがステータス退避されている間にシステムに障害が発生すると、このコンポーネントに保持されていたステータスはすべて失われます。
[ステータスを保持し、永続的にサポートする] | XLANG スケジューラ エンジンは、コンポーネント インスタンスをメモリから削除し、ステータス退避中にコンポーネントの IPersistStream または IPersistStreamInit のいずれかを呼び出すことでメモリに復元します。ステータス復元中に、もう一度メモリに復元します。

[エラー処理]

コンポーネントのメソッドからエラーが返されたときに、XLANG スケジューラ エンジンでトランザクションを中断する場合は、[エラー処理] の [メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。

注

  • アクションが COM コンポーネントにバインドされているポートと通信し、指定されたメソッドがコンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • BizTalk オーケストレーション デザイナは、IDispatch から派生したパラメータを含む COM コンポーネント メソッドへのバインドをサポートしません。しかし、BizTalk オーケストレーション デザイナは、IDispatch 型のパラメータを含む COM コンポーネントメソッドへのバインドはサポートします。

  • アプリケーションに、IUnknown インターフェイスを使用した XLANG スケジュールの COM コンポーネントへの参照がある場合、XLANG スケジュール インスタンスがステータス退避およびステータス復元されると、その参照は無効になります。永続化できるすべての COM コンポーネントは、ステータス退避されたときと同じステータスに正しくステータス復元されます。しかし、インターフェイスは新しいアドレスに割り当てられます。これは、正常な動作です。1 つの XLANG スケジュール インスタンスの複数のメッセージ フィールドに、同じ COM コンポーネントへのポインタが含まれていて、そのスケジュールがステータス退避される場合は、ステータス復元された後、これらのメッセージ フィールドには 1 つの COM コンポーネントへのポインタが含まれます。しかし、この COM コンポーネントは、ステータス退避の前のコンポーネントと同じではありません。ステータス退避の前に存在していた COM コンポーネントに似た、新しい COM コンポーネントが作成されます。元の COM コンポーネントが永続化できる場合は、新しい COM コンポーネントのステータスは、ステータス退避の前の元の COM コンポーネントのステータスと同じです。

  • コンポーネントの一意性は、繰り返しループを超えると維持されません。繰り返しループの中のあるメッセージに COM コンポーネントへのポインタを持つフィールドが含まれていて、その繰り返しループの外の別のメッセージに同じ COM コンポーネントへのポインタを持つフィールドが含まれている場合、ステータス退避とステータス復元の後でこれら 2 つのメッセージ フィールドに格納されるポインタは 1 つの COM コンポーネントへのポインタではなくなります。2 つのメッセージ フィールドに格納されるポインタは、元の COM コンポーネントに似た別の 2 つの COM コンポーネントへのポインタです。元の COM コンポーネントが永続化できる場合は、2 つの新しい COM コンポーネントは、ステータス退避の前の元の COM コンポーネントのステータスと同じステータスを保持します。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

BizTalk メッセージ シェイプの使用

メッセージ キュー シェイプの使用

メソッド通信ウィザードの使用

スクリプト コンポーネント シェイプの使用


スクリプト コンポーネント シェイプの使用

[スクリプト コンポーネント] シェイプを使用すると、既存の Windows スクリプト コンポーネントで XLANG スケジュールのアクションを実行できます。[スクリプト コンポーネント] は同期をとるため、アクションが実行されるときは、常に双方向のメッセージのフローがあります。これに対して、非同期テクノロジのメッセージのフローは、一方向です。

ポートに接続された送信アクションは、XLANG スケジューラ エンジンによる特定のメソッド呼び出しの起動を表します。<入力> パラメータと <入出力> パラメータがポートに送信されます。戻り値として、メソッド呼び出しの <入出力> パラメータと <出力> パラメータで定義されたスキーマのメッセージをポートから受信します。メソッド呼び出しは、ポートにバインドされたインターフェイスでサポートされます。

ポートに接続された受信アクションは、外部アプリケーションがポートに対するメソッド呼び出しを作成するまで待機します。<入力> パラメータと <入出力> パラメータでポートが受信するメッセージのスキーマを定義し、<入出力> パラメータと <出力> パラメータでポートから送信するメッセージのスキーマを定義します。

ポートに接続されてスクリプト コンポーネントにバインドされたアクションごとに、2 つのメッセージが交換されます。メッセージによって、起動されたインターフェイスのメソッドが識別されます。メッセージのスキーマは、メソッドの署名の <入力> パラメータと <入出力> パラメータ (および、<入出力> パラメータと <出力> パラメータ) に対応します。コンポーネントのタイプ ライブラリにアクセスできるので、BizTalk オーケストレーション デザイナは、ユーザーに情報を問い合わせずに、自動的にこれらのメッセージのスキーマを構築できます。

XLANG スケジューラ エンジンは、メソッドが戻るまで待機してからビジネス プロセスを続行します。メッセージを送信するために、XLANG スケジューラ エンジンは指定された Windows スクリプト コンポーネントのメソッドを起動します。

新しいスクリプト コンポーネント バインドを作成するには、BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [スクリプト コンポーネント] シェイプを境界バーの右側にドラッグします。既存のスクリプト コンポーネントを編集するには、[スクリプト コンポーネント] シェイプを右クリックし、[プロパティ] をクリックします。どちらの操作でも、スクリプト コンポーネント バインド ウィザードが起動します。バインドは、ポートを実装するテクノロジを指定する処理です。スクリプト コンポーネント バインド ウィザードは、次の 6 つのページで構成されています。

[スクリプト コンポーネント バインド ウィザードへようこそ]

[スクリプト コンポーネント バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。

[静的または動的な通信]

[静的または動的な通信] ページで、コンポーネントのインスタンスを作成する方法を定義できます。次の表は、静的通信と動的通信の設定の一覧と説明を示しています。

[静的または動的な通信] | 説明
[静的] | XLANG スケジューラ エンジンに対して、実装を完了させるために必要なすべての情報を設計時に指定できる場合は、このオプションを選択します。
[動的] | 実行時に実装を完了するための追加の情報が必要な場合は、このオプションを選択します。
[インスタンスを作成しない] | コンポーネントをアクティブにしないで、メソッド呼び出しを使用して XLANG スケジュールがデータを受信できるようにするには、このオプションを選択します。[インスタンスを作成しない] を選択すると、このコンポーネントへのメソッド呼び出しはインターセプトされ、XLANG スケジューラ エンジンは引数を格納し、呼び出しは呼び出し元に戻ります。コンポーネントはインスタンスを作成しません。

[スクリプト ファイルの指定]

[スクリプト ファイルの指定] ページで、使用する Windows スクリプト コンポーネント (.wsc) ファイルへのパスを入力できます。

[コンポーネントのインスタンス作成情報]

[コンポーネントのインスタンス作成情報] ページで、XLANG スケジューラ エンジンがモニカまたは Prog ID のどちらかを使用してスクリプト コンポーネントのインスタンスを作成することを指定できます。

[メソッド情報]

[メソッド情報] ページで、選択したクラスに属するメソッドを選択できます。

[ポート プロパティの詳細設定]

[ポート プロパティの詳細設定] ページで、セキュリティ、トランザクションのサポート、およびエラー処理を構成できます。[スクリプト コンポーネント] シェイプを使用して、受信したメッセージの認証済みユーザー情報を要求できます。

[セキュリティ]

次の表は、送信者 ID の確認設定の一覧と説明を示しています。

送信者 ID の確認 | 説明
[必要なし] | XLANG スケジュールが送信者の ID を確認せずにメッセージを受信できるようにする場合は、このオプションを選択します。
[オプション] | コンポーネントがメッセージを受信したときに、XLANG スケジューラ エンジンが送信者を識別するようにする場合は、このオプションを選択します (情報が利用可能な場合)。
[必要] | XLANG スケジューラ エンジンが送信者を識別できないメッセージを受信しないようにする場合は、このオプションを選択します。

[トランザクションのサポート]

次の表は、トランザクションのサポート設定の一覧と説明を示しています。

[トランザクションのサポート] | 説明
[無効] | すべての非 COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントは COM トランザクション管理を無視します。
[サポートしない] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネントはトランザクションに参加せず、ほかのコンポーネントのトランザクションを伝達しません。
[サポートする] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。そうでない場合は、コンポーネントにはトランザクションがありません。
[必要] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。コンポーネントがバインドされているポートに関連付けられているトランザクションがない場合は、コンポーネント用に新しいトランザクションが作成されます。
[新しいトランザクションを要求する] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネント用に新しいトランザクションが常に作成されます。

[エラー処理]

コンポーネントのメソッドからエラーが返されたときに、XLANG スケジューラ エンジンで中断プロセスを起動する場合は、[エラー処理] の [メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページを使用するには、XLANG スケジューラ エンジンのこのオプションをオンにする必要があります。このオプションがオフの場合は、どちらのページで定義されたエラー回復プロセスも実行されません。

重要

  • Windows スクリプト コンポーネントを使用する場合、そのコンポーネントは次の規則に従っている必要があります。
    • 引数宣言は、値ではなく参照で行う必要があります。

    • Visual Basic スクリプトのサブルーチンはサポートされていません。関数だけがサポートされています。

    • 1 つの .wsc ファイル内で複数のコンポーネントは使用できません。

注

  • アクションがスクリプト コンポーネントにバインドされているポートと通信し、指定されたメソッドがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • XLANG スケジューラ エンジンで実行されているスクリプト コンポーネントは、XLANG スケジューラ エンジンと Windows スクリプティング ホストの両方がシャットダウンされるまで変更できません。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

BizTalk メッセージ シェイプの使用

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

メソッド通信ウィザードの使用


メッセージ キュー シェイプの使用

[メッセージ キュー] シェイプを使用すると、XLANG スケジュールは、キューを使用して疎結合されている別の XLANG スケジュール (またはアプリケーション) と通信できます。XLANG スケジュールとアプリケーションの間で通信できるようにするには、メッセージをキューに送信してから読み出します。1 つの XLANG スケジュールでは、[メッセージ キュー] シェイプにバインドされた複数のポートを使用できます。

ポートは [メッセージ キュー] シェイプにバインドされるときに、メッセージ キューにもバインドされます。ポートは、名前付きキューまたはインスタンスごとのキューにバインドできます。ポートがインスタンスごとのキューにバインドされた場合は、この XLANG スケジュールのインスタンスごとに一意なキューが作成され、使用されます。インスタンスごとのキューは、XLANG スケジュールが XLANG スケジュール インスタンスごとに別のキューを使用するための便宜的な方法です。

メッセージ キューにバインドされたポートにアクションが接続されるときに、次の情報を使用して、スケジュールでメッセージを表現する方法が定義されます。

アクションで送受信するメッセージを定義する必要があります。キューには複数の種類のメッセージを格納できるので、メッセージの種類はアクションが受信するメッセージの種類を識別するときに役立ちます。[送信] アクションの間に、メッセージがキューに書き込まれると、メッセージのラベル プロパティにメッセージの種類のマークが付けられます。

[メッセージ キュー] シェイプは、メッセージを送受信するために使用するメッセージ キュー サービスを表します。メッセージを受信するために、XLANG スケジューラ エンジンは、使用するキューの名前とそのメッセージに含まれる XML スキーマのルート要素名を必要とします。メッセージを送信するには、メッセージの送信に使用するキューの名前が必要です。

メッセージ キューを使用してメッセージを受信するように XLANG スケジュール インスタンスを構成した場合は、XML 通信ウィザードを使用して送信先書式を XML または文字列として指定できます。

新しいメッセージ キュー バインドを作成するには、BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [メッセージ キュー] シェイプを境界バーの右側にドラッグします。既存のメッセージ キュー実装を編集するには、[メッセージ キュー] シェイプを右クリックし、[プロパティ] をクリックします。どちらの操作でも、メッセージ キュー バインド ウィザードが起動します。バインドは、ポートを実装するテクノロジを指定する処理です。メッセージ キュー バインド ウィザードは、次の 4 つのページで構成されています。

[メッセージ キュー バインド ウィザードへようこそ]

[メッセージ キュー バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。または、既存の未バインド ポートを選択することができます。

[静的または動的キューの情報]

[静的または動的キューの情報] ページで、メッセージ キューを設計時または実行時に定義するように指定できます。次のオプションのいずれかを選択します。

  • 設計時にキュー情報を指定できる場合は、[静的キュー] を選択します。

  • XLANG スケジューラ エンジンが外部の送信元から実行時に情報を取得してキュー名を決定する場合は、[動的キュー] を選択します。

[キュー情報]

[キュー情報] ページで、新しいキューを作成するか、既存のキューを指定することができます。次のオプションのいずれかを選択します。

  • XLANG スケジューラ エンジンで、XLANG スケジュール インスタンスごとにインスタンスごとのキューを作成する場合は、[すべてのインスタンスごとに新しいキューを作成する] を選択します。

  • XLANG スケジューラ エンジンで既存のキューを使用する場合は、[すべてのインスタンスに対して既存のキューを使用する] を選択します。

[ポート プロパティの詳細設定]

[ポート プロパティの詳細設定] ページで、セキュリティを構成し、トランザクションのサポートを有効にするかどうかを選択できます。[メッセージ キュー] シェイプを使用して、受信したメッセージの認証済みユーザー情報を要求できます。

[セキュリティ]

次の表は、送信者 ID の確認設定の一覧と説明を示しています。

送信者 ID の確認 | 説明
[必要なし] | XLANG スケジュールが送信者の ID を確認せずにメッセージを受信できるようにする場合は、このオプションを選択します。
[オプション] | コンポーネントがメッセージを受信したときに、XLANG スケジューラ エンジンが送信者を識別するようにする場合は、このオプションを選択します (情報が利用可能な場合)。
[必要] | XLANG スケジューラ エンジンが送信者を識別できないメッセージを受信しないようにする場合は、このオプションを選択します。

[Windows のグループ名またはユーザー名を使用して、キューを制御する] チェック ボックスのオンとオフを切り替えることもできます。このチェックボックスをオンにした場合は、キューへのメッセージの書き込みを許可するユーザーまたはグループの名前を入力します。このオプションを使用できるのは、静的キューを使用している場合だけです。

[トランザクションのサポート]

[トランザクションのサポート] の [このキューはトランザクションを必要とする] チェック ボックスをオンにすると、トランザクションのサポートが有効になります。

注

  • 現在サポートされているキューの名前形式では、別のコンピュータ上のキューにリモート アクセスできません。XLANG スケジュールが別のコンピュータ上のアプリケーションと通信する場合、プライベート キューの代わりにパブリック キューを使用してください。

  • アクションがメッセージ キューにバインドされているポートと通信し、バインドに指定されたキューがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • XLANG スケジューラ エンジンが、キューがトランザクション用かどうかを判断できることは重要です。トランザクション コンテキストのキューにメッセージが送信される場合、XLANG スケジューラ エンジンはトランザクションを使用してキューと通信するかどうかを認識する必要があります。[このキューはトランザクションを必要とする] チェック ボックスをオンにしてポート バインドを構成した場合、実行時にキューがトランザクション用でないと判断されると、XLANG スケジューラ エンジンは終了します。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

BizTalk メッセージ シェイプの使用

COM コンポーネント シェイプの使用

スクリプト コンポーネント シェイプの使用

XML 通信ウィザードの使用


BizTalk メッセージ シェイプの使用

[BizTalk メッセージ] シェイプは、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスとの間でメッセージを交換するために使用する BizTalk メッセージ サービスを表します。メッセージを受信するために、XLANG スケジューラ エンジンは、BizTalk メッセージ サービスがドキュメントを受信するために使用する HTTP URL アドレス、チャネルの名前、および送信ドキュメント定義のメッセージの種類を必要とします。ドキュメントを受信して XLANG スケジュールをアクティブにするには、ドキュメント定義のメッセージの種類だけが必要です。メッセージを送信するには、チャネルの名前と、受信ドキュメント定義のメッセージの種類が必要です。BizTalk オーケストレーション サービスと BizTalk メッセージ サービス間のメッセージ交換の詳細については、「BizTalk サービスの統合」を参照してください。

重要

  • メッセージを受信したときに新しい XLANG スケジュールがアクティブになるようにポートを構成する場合、次の制限を考慮する必要があります。
    • メッセージを受信したときに XLANG スケジュールをアクティブにするために使用できるポートは、1 つのスケジュール内で 1 つだけです。

    • このポートで受信できるアクションは 1 つだけです。

    • この 1 つのアクションは、ループ本体に含められません。

    • このポートのポート参照からスケジュール内のほかのメッセージへのデータ フローの接続は、描画できません。

新しい BizTalk メッセージ バインドを作成するには、BizTalk オーケストレーション設計ページで、[実装] ステンシルの [BizTalk メッセージ] シェイプを境界バーの右側にドラッグします。既存の BizTalk メッセージ実装を編集するには、[BizTalk メッセージ] シェイプを右クリックし、[プロパティ] をクリックします。どちらの操作でも、BizTalk メッセージ バインド ウィザードが起動します。バインドは、ポートを実装するテクノロジを指定する処理です。BizTalk メッセージ バインド ウィザードは、次のページで構成されています。

[BizTalk メッセージ バインド ウィザードへようこそ]

[BizTalk メッセージ バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。または、既存の未バインド ポートを選択することができます。

[通信の方向]

[通信の方向] ページで、ポートをメッセージを送信または受信するように構成することを指定できます。

[静的または動的な通信]

[静的または動的な通信] ページは、[BizTalk メッセージ バインド ウィザードへようこそ] ページで [送信] を選択した場合にだけ表示されます。[静的または動的な通信] ページで、XLANG スケジューラ エンジンが設計時に定義される [静的チャネル]、または実行時に定義される [動的チャネル] を使用することを指定できます。

[XLANG スケジュールのアクティブ化情報]

[XLANG スケジュールのアクティブ化情報] ページで、この受信アクションで XLANG スケジュール インスタンスがアクティブになるかどうかを指定します。[はい] を選択すると、BizTalk メッセージ バインド ウィザードは終了します。[いいえ] を選択すると、[チャネル情報] ページが表示されます。

[チャネル情報]

[チャネル情報] ページで、チャネルの名前と、BizTalk メッセージ サービスがドキュメントを受信するために使用する HTTP URL アドレスを指定できます。

注

  • アクションが BizTalk メッセージにバインドされているポートと通信し、バインドの指定されたチャネルがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • 単一のトランザクションに送信受信別々の BizTalk メッセージ バインドを含めると、デッドロック状態になりトランザクションが失敗する場合があります。

  • BizTalk メッセージ サービスで送受信される XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースで追跡できます。詳細については、「追跡データベースでの XLANG スケジュール イベントの追跡」を参照してください。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

スクリプト コンポーネント シェイプの使用

XML 通信ウィザードの使用


同期通信と非同期通信

COM コンポーネント実装またはスクリプト コンポーネント実装へのすべての通信は同期です。COM コンポーネントまたはスクリプト コンポーネントの実装を使用するポートへの通信フローを作成する場合は、メソッド通信ウィザードを使用する必要があります。

未バインド ポート、メッセージ キュー実装、または BizTalk メッセージ実装へのすべての通信は、非同期です。メッセージ キューまたは BizTalk メッセージの実装を使用するポートへの通信フローを作成する場合、および未バインド ポートへの通信フローを作成する場合は、XML 通信ウィザードを使用する必要があります。

次の図と文字は、発生する可能性がある 4 つの通信アクションに対する XLANG スケジュールの動作を説明しています。

待機しない
待機する
待機する
待機する
2
非同期送信アクション
同期送信アクション
非同期受信アクション
同期受信アクション
1
3
4
4
3
2
1
待機する
別の
アプリケーション
XLANG
スケジュール
Com または
スクリプト
コンポーネント
メッセージ キューまたは BizTalk
メッセージ

  1. 同期受信アクション
    1. XLANG スケジュールは、別のアプリケーションがメソッド要求を送信し、コンポーネントのインスタンスを作成するまで待機します。

    2. メソッド要求をインターセプトします。

    3. コンポーネントがメソッド応答を返すまで待機します。

    4. メソッド応答をインターセプトします。

    5. ビジネス プロセス フローの次のアクションを続行します。
  2. 同期送信アクション
    1. XLANG スケジュールは、メソッド要求を開始し、コンポーネントのインスタンスを作成します。

    2. コンポーネントがメソッド応答を返すまで待機します。

    3. メソッド応答を受信します。

    4. ビジネス プロセス フローの次のアクションを続行します。
  3. 非同期受信アクション
    1. XLANG スケジュールは、別のアプリケーションがメッセージ キューまたは BizTalk メッセージ チャネルにメッセージを送信するまで待機します。

    2. メッセージ キューまたはチャネルからメッセージを受信します。

    3. ビジネス プロセス フローの次のアクションを続行します。
  4. 非同期送信アクション
    1. XLANG スケジュールは、メッセージ キューまたは BizTalk メッセージ チャネルにメッセージを送信します。

    2. ビジネス プロセス フローの次のアクションを続行します。

    3. 別のアプリケーションが、メッセージ キューまたは BizTalk メッセージ チャネルからメッセージを受信します。

注

  • 同期受信アクションには、特別な事例があります。COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの [インスタンスを作成しない] を選択すると、コンポーネントのインスタンスは作成されず、メソッド呼び出しのコードも実行されません。代わりに、XLANG スケジュールがメソッド要求の情報をインターセプトすると、この情報をメソッド応答として返します。メソッド呼び出しが回避されます。静的ポートと動的ポート、および COM コンポーネント バインド ウィザードとスクリプト コンポーネント バインド ウィザードの詳細については、次のトピックを参照してください。
    • 静的ポートと動的ポート

    • ポートの実装

    • COM コンポーネント シェイプの使用

    • スクリプト コンポーネント シェイプの使用
  • BizTalk メッセージ サービスで送受信される XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースで追跡できます。詳細については、「追跡データベースでの XLANG スケジュール イベントの追跡」を参照してください。

ここには次のトピックが含まれます。

  • メソッド通信ウィザードの使用

  • 同期通信

  • XML 通信ウィザードの使用

  • 非同期通信

関連項目

ポートの実装

静的ポートと動的ポート

COM コンポーネント シェイプの使用

スクリプト コンポーネント シェイプの使用


メソッド通信ウィザードの使用

[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページでは、メソッド通信ウィザードを使用して、[アクション] シェイプと [COM コンポーネント] シェイプまたは [スクリプト コンポーネント] シェイプの間のメッセージのフローを定義できます。メッセージを送信する場合、XLANG スケジュールは _in メッセージでメソッドを呼び出し、コンポーネントから _out メッセージを受信するまで待機します。メッセージを受信する場合、XLANG スケジュールは、一方のアプリケーションがポートのメソッドを呼び出して _in メッセージをメソッドに送信するまで待機し、コンポーネントからの _out メッセージがもう一方のアプリケーションに送信されるまで待機します。

注

  • Visual Basic プログラムの場合、ByVal パラメータを使用できるのは _in メッセージだけです。ほかのすべてのパラメータは、_in メッセージと _out メッセージの両方で使用できます。

  • C 言語プログラムの場合、in パラメータは _in メッセージでのみ、out パラメータは _out メッセージでのみ使用できます。in,out パラメータは、両方のメッセージで使用できます。

  • Visual Basic プログラムと C 言語プログラムで、同じパラメータが _in メッセージと _out メッセージの両方にある場合、_in メッセージにはメソッドに送信されたコンテンツが含まれ、_out メッセージにはメソッドから返されたコンテンツが含まれます。

メソッド通信ウィザードを起動するには、[アクション] シェイプの右の制御ハンドル ( 制御ハンドル) を [COM コンポーネント] シェイプまたは [スクリプト コンポーネント] シェイプにバインドされているポートの接続ポイント ( 接続ポイント) までドラッグします。メソッド通信ウィザードは、次の 3 つのページで構成されています。

[メソッド通信ウィザードへようこそ]

[メソッド通信ウィザードへようこそ] ページで、XLANG スケジューラ エンジンがメソッドを呼び出す、またはメソッド呼び出しを待機するように指定できます。XLANG スケジューラ エンジンがメソッド呼び出しを待機するように指定した場合は、メッセージが到着するまで待機する必要があると予測される時間を秒単位で指定し、待ち時間の値を設定できます。この値が 180 秒以下の場合、XLANG スケジュール インスタンスはステータス保存データベースにステータス退避されません。この値が 180 秒を超えている場合は、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。既定では、待ち時間の値は 0 に設定されています。これは、メッセージがすぐに到着すると予測されていることを示します。

XLANG スケジュール インスタンスが、アクションが待機しているメッセージの到着以外の理由でステータス復元された場合 (および、XLANG スケジュール インスタンスが休止ステータスに入った場合)、指定された待ち時間の値を使用して、XLANG スケジュール インスタンスをすぐにステータス退避するかどうかが決定されます。これは、同時に実行される分岐が待機していたメッセージを受信したときや、コンピュータが再起動してすべての XLANG スケジュール インスタンスがステータス復元されたときなどに発生します。このとき、待ち時間の値は、XLANG スケジュール インスタンスが休止ステータスに入ったポイントから評価されます。XLANG スケジューラ エンジンの元の待機時間の開始から経過した時間が (待ち時間の値と合わせて)、XLANG スケジューラ エンジンがステータス復元の後で休止ステータスに入ったときから 180 秒を超えている場合、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。XLANG スケジュール インスタンスのこのポイントは、XLANG スケジューラ エンジンがメッセージの到達の監視を開始してから長時間経過した後で発生することがあります。

[メッセージ情報]

[メッセージ情報] ページで、新しいメッセージと既存のメッセージへの参照のどちらを作成するかを指定できます。既存のメッセージへの参照を作成するように指定した場合は、メソッドとの間で送受信されたり、[メッセージ] シェイプと関連付けられている、以前に作成されたメッセージの一覧から選択できます。使用したいメッセージが一覧にない場合は、新しいメッセージを作成するように指定し、新しいメッセージのデータ フローを定義する必要があります。

[メッセージ仕様情報]

[メッセージ仕様情報] ページでは、[メッセージ情報] ページで作成または参照したメッセージのメッセージ仕様を選択できます。

関連項目

非同期通信

ステータス退避とステータス復元

永続化

同期通信と非同期通信

同期通信

XML 通信ウィザードの使用


同期通信

同期通信で使用できるメソッドは、ポート実装用に選択したメソッドに限られます。ほかのポート実装のメソッドは使用できません。また、非同期通信フローの XML メッセージも使用できません。利用可能なメソッドを変更するには、適切なバインド ウィザードをもう一度起動し、ほかのメソッドを選択します。

<入力> および <出力> パラメータは、選択したメソッドのパラメータ条件から自動的に決まります。どちらのパラメータ一覧にも、パラメータの名前とデータ型が含まれています。メッセージには、メソッドに関連付けられているパラメータのほかに、必要なシステム フィールドも含まれています。同期メッセージには、次のシステム フィールドが常に含まれています。

  • __Sender__

    このシステム フィールドは、同期メッセージで使用されるメソッドの必須 <入力> パラメータです。

  • __Status__

    このシステム フィールドは、同期メッセージで使用されるメソッドの必須 <出力> パラメータです。

同期メッセージ

同期通信を作成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで使用されるメソッドとパラメータに対応しています。メッセージには、そのメソッドに対するすべての <入力> パラメータと、そのメソッドに対するすべての <出力> パラメータが含まれています。

メソッドにパラメータを含めないことは可能ですが、メッセージには入力必須のシステム フィールドが必ず含まれます。次に [メッセージ] スキーマの例を示します。

Method name_in
__Sender__   string
   parameter 1   Data type 1
   parameter 2   Data type 2
   parameter n   Data type n
Method name_out
__Status__   string
   Parameter 1   Data type 1
   Parameter 2   Data type 2
   Parameter n   Data type n

次の図は、システム フィールド __Sender__ と __Status__、およびメソッド呼び出しの <入力> パラメータと <出力> パラメータが含まれている同期メッセージの組を示しています。

Method_out
データ型 3
データ型 2
データ型 1
String
パラメータ 2
パラメータ 1
データ型 2
データ型 1
Int
_Status_
パラメータ 3
パラメータ 2
パラメータ 1
_Sender_
Method_in

関連項目

ステータス退避とステータス復元

永続化

同期通信と非同期通信

メソッド通信ウィザードの使用


XML 通信ウィザードの使用

[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページでは、XML 通信ウィザードを使用して、[アクション] シェイプと [メッセージ キュー] シェイプ、 [BizTalk メッセージ] シェイプ、または未バインド ポートの間のメッセージのフローを定義できます。XML 通信ウィザードを起動するには、[アクション] シェイプの右の制御ハンドル ( 制御ハンドル) を未バインド ポートまたは [メッセージ キュー] シェイプか [BizTalk メッセージ] シェイプにバインドされているポートの接続ポイント ( 接続ポイント) までドラッグします。XML 通信ウィザードは、次の 5 つのページで構成されています。

[XML 通信ウィザードへようこそ]

[XML 通信ウィザードへようこそ] ページで、ポートがアクションにメッセージを送信するか、アクションからメッセージを受信するかを指定できます。[BizTalk メッセージ] シェイプを使用して実装されたポートとアクションの間の通信を作成する場合、通信方向は既に構成されています。この構成は、BizTalk メッセージ バインド ウィザードを使用してポート バインドを作成したときに行われます。

メッセージを受信するようにポートが構成されている場合は、メッセージが到達するまで XLANG スケジューラ エンジンが待機する時間を秒単位で指定できます。この値が 180 秒以下の場合、XLANG スケジュール インスタンスはステータス保存データベースにステータス退避されません。この値が 180 秒を超えている場合は、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。既定では、待ち時間は 0 秒に設定されています。これは、メッセージがすぐに到達すると予測されていることを示します。

XLANG スケジュール インスタンスが、アクションが待機しているメッセージの到達以外の理由でステータス復元された場合 (および、XLANG スケジュール インスタンスが休止ステータスに入った場合)、指定された待ち時間の値を使用して、XLANG スケジュール インスタンスをすぐにステータス退避するかどうかが決定されます。これは、同時に実行される分岐が待機していたメッセージを受信したときや、コンピュータが再起動してすべての XLANG スケジュール インスタンスがステータス復元されたときなどに発生します。このとき、待ち時間の値は、XLANG スケジュール インスタンスが休止ステータスに入ったポイントから評価されます。XLANG スケジューラ エンジンの元の待機時間の開始から経過した時間が (待ち時間の値と合わせて)、XLANG スケジューラ エンジンがステータス復元の後で休止ステータスに入ったときから 180 秒を超えている場合、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。XLANG スケジュール インスタンスのこのポイントは、XLANG スケジューラ エンジンがメッセージの到達の監視を開始してから長時間経過した後で発生することがあります。

[メッセージ情報]

[メッセージ情報] ページで、新しいメッセージと既存のメッセージへの参照のどちらを作成するかを指定できます。新しいメッセージを作成するように指定した場合は、新しいメッセージのデータ フローを定義します。データ フローの詳細については「データ処理」を参照してください。メッセージ名の "ラベル" プロパティを使用して、次の方法でスケジュールのパフォーマンスを最適化します。

  • メッセージの "ラベル" プロパティが、新しい [メッセージ] シェイプを作成したときに指定した [XML ルートの要素] と同一である場合、XLANG スケジューラ エンジンはメッセージを取得します。

  • "ラベル" プロパティが [XML ルートの要素] で指定した値と一致しない場合、XLANG スケジューラ エンジンはメッセージのコンテンツを調べます。新しい [メッセージ] シェイプを作成したときに指定した XML ルートの要素の値が実際の XML ルートの要素と一致する場合、XLANG スケジューラ エンジンはメッセージを取得します。一致しない場合は、XLANG スケジューラ エンジンはメッセージをキューに残し、次のメッセージを確認します。

[XML 変換情報]

[XML 変換情報] ページで、XML 形式のデータとテキスト文字列のうち、どちらのメッセージをキューとの間で送受信するかを指定できます。メッセージをテキスト文字列として送信するように選択した場合、XLANG スケジューラ エンジンの標準 XML ラッパーがメッセージから削除されます。

[メッセージの種類の情報]

[メッセージの種類の情報] ページで、定義した種類のメッセージを識別するために XLANG スケジューラ エンジンで使用するラベルを指定できます。入力したテキストは、メッセージ キューから受信するメッセージを正しく識別するために使用されます。2 つの異なるメッセージに対して同じメッセージの種類を選択する場合は、フィールド名、フィールドの種類、および XPath の問い合わせが正確に一致することを確認してください。同じポートの同じメッセージの種類のメッセージの間に矛盾があると、XLANG スケジューラ エンジンはエラーを報告します。[メッセージの種類の情報] ページの [メッセージの種類] ボックスで、メッセージのラベル指定を入力します。XLANG スケジューラ エンジンは、指定した情報に基づいて次の操作を行います。

  • XLANG スケジューラ エンジンは、メッセージの種類の情報をキュー内にあるメッセージ ラベルと照合し、一致するものを探します。メッセージの種類が一致しないと、メッセージは無視され、XLANG スケジューラ エンジンは一致する次の受信メッセージを見つけるために検索を続行します。これによって、複数のアクションが 1 つのメッセージ キューから複数の種類のメッセージを受信できます。

  • キュー内にあるメッセージが XML 形式である場合、XLANG スケジューラ エンジンはメッセージの種類の情報をキュー内にあるメッセージの XML ルートの要素と照合し、一致するものを探します。

[メッセージ仕様情報]

[メッセージ仕様情報] ページで、使用するメッセージ仕様 (.xml) ファイルへのパスを入力するか、参照することができます。選択したメッセージ仕様が、BizTalk エディタを使用して作成したものである場合は、XLANG スケジューラ エンジンのデータ範囲にフィールドを追加できます。[仕様に対してメッセージを検証] チェック ボックスをオンにすると、仕様に対してメッセージを検証できます。[メッセージ仕様情報] ページの [参照] をクリックすると、[仕様の参照] ダイアログ ボックスが表示されます。[仕様の参照] ダイアログ ボックスで、使う仕様を検索できます。

仕様を選択していない場合、[メッセージ仕様情報] ページの [作成] をクリックすると、BizTalk エディタを開くことができます。既に仕様を選択している場合は、[メッセージ仕様情報] ページの [編集] をクリックすると、選択した仕様で BizTalk エディタを開くことができます。

[メッセージ仕様情報] ページの [追加] をクリックすると、[フィールドの選択] ダイアログ ボックスが表示されます。[フィールドの選択] ダイアログ ボックスの [ノードを選択してください] ツリーで使用するノードを展開し、追加するフィールドをクリックします。[フィールドの選択] ダイアログ ボックスで、選択したポートのメッセージ シェイプに追加するフィールドの名前とノード パスを編集できます。データ型フィールドは、表示されますが編集はできません。

注

  • 検証ができるのは、メッセージを受信するときに限られます。メッセージを送信する場合、検証チェック ボックスは無視されます。

  • [ノードを選択してください] ツリーのフィールドをクリックすると、[フィールド名] ボックスにフィールド名が自動的に追加されます。

  • [ノードを選択してください] ツリーのフィールドをクリックすると、[ノード パス] ボックスにそのフィールドへのノード パスが自動的に追加されます。

  • フィールドの中から特定のデータを抽出するときは、ノード パスを手動で編集すると便利です。たとえば、フィールドに配列が含まれている場合は、配列全体ではなく配列の項目を 1 つだけ取得する必要があります。ただし、メッセージ仕様のノード パスは手動で編集しないでください。

  • ノードを選択して [メッセージ フィールド] ボックスの一覧に追加することはできません。選択できるのはフィールドだけです。フィールドは、リーフ ノードとも呼ばれます。たとえば、[Seller] ノードまたは [Address] ノードにはリーフ ノードが含まれているため、選択できません。[Name] フィールドと [Address] フィールドにはほかのノードが含まれていないので、選択できます。

  • メッセージ キューからのメッセージ受信を待機している間に、無効な XML メッセージや不十分な認証などの問題が発生すると、配信不能メッセージ キューが動的に作成されます。配信不能メッセージ キューは、COM+ アプリケーションごとに固有です。配信不能メッセージ キューには、.\private$\ApplicationName.DeadLetter という名前が付けられます。たとえば、無効な XML を含むメッセージがキューに到達した場合、XLANG スケジューラ エンジンが XML メッセージをキューから受信するように XML 通信ウィザードの [XML 変換情報] ページで指定されていると、無効な XML メッセージは .\private$\ApplicationName.DeadLetter に移動されます。

  • 同じメッセージ キューから別々にメッセージを受け取るように 2 つの XLNAG スケジュールを設計すると、メッセージが間違った XLANG スケジュール インスタンスによって処理される可能性があります。この問題を回避するには、XLANG スケジュール インスタンスによって受信されるメッセージの各種類に対して 1 つのメッセージ キューを使用します。

関連項目

非同期通信

同期通信と非同期通信

同期通信

メソッド通信ウィザードの使用


非同期通信

非同期メッセージはメッセージ キューまたは BizTalk メッセージ チャネルに配置され、XLANG スケジュールは処理を続行します。応答を待機することはありません。

非同期通信で使用可能なメッセージは、XML メッセージだけです。すべての XML メッセージが使用可能で、複数のポートに対して指定できます。[メソッド通信ウィザード] を使用して作成した同期メッセージの組は、すべて使用できません。

非同期メッセージ

非同期通信を構成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで送信または受信される情報に対応しています。メッセージには、入力必須のシステム フィールドと、必要な追加仕様フィールドが含まれます。

次に [メッセージ] スキーマの例を示します。

Message name
__Sender__   string
Document   string
   Field 1   Data type 1
   Field 2   Data type 2
   Field n   Data type n

次の図は、Message_1 というメッセージを示しています。システム フィールド __Sender__ と Document は自動的に提供されるもので、すべての非同期メッセージに存在します。このメッセージには、ユーザーが選択した 2 つの仕様フィールドも含まれています。

システムが追加したフィールド 2 つとユーザーが選択した仕様フィールド 2 つを持つメッセージ
フィールド 2
フィールド 1
Document
データ型 1
string
データ型 2
string
_Sender_
Message_1

XML 通信ウィザードの [フィールドの選択] ダイアログ ボックスを使用して、仕様フィールドを追加できます。[フィールドの選択] ダイアログ ボックスの [ノードを選択してください] ツリーのノードをクリックすると、仕様フィールドを選択できます。ノードをクリックすると、ノード パスが [ノード パス] ボックスの一覧に追加されます。リーフ ノードを選択する必要があります。リーフ ノードは子を持たないノードです。次の図で、ノード Name はリーフ ノードですが、ノード Address はリーフ ノードではありません。

ノード パスは、XPath とも呼ばれます。選択したノード パスをそのまま使用することも、パスに対する追加の基準を入力することもできます。たとえば、配列が含まれているノードを選択する場合、配列全体を取得するのではなく、配列内の特定のインデックスを指定して取得することができます。

注

  • XML メッセージを文字列として送信または受信する場合は、このメッセージの [データ] ページに作成された [メッセージ] シェイプに、StringData という名前のフィールドが含まれている必要があります。また、このメッセージには仕様フィールドを追加できません。

次の図は、[フィールドの選択] ダイアログ ボックスを示しています。

図をクリックすると、拡大または縮小します。

[フィールドの選択] ダイアログ ボックス

仕様フィールドの選択とノード パスの使用の詳細については、次のトピックを参照してください。

  • ノード パス フィールド

  • XML 通信ウィザードの使用

  • 非同期メッセージの送信と受信

  • 仕様の作成

関連項目

仕様の作成

ステータス退避とステータス復元

ノード パス フィールド

永続化

非同期メッセージの送信と受信

同期通信と非同期通信

XML 通信ウィザードの使用


XLANG スケジュールのコンパイル

XLANG スケジュール フローチャートが完成したら、フローチャートを実行可能な XLANG スケジュールにコンパイルできます。フローチャートをコンパイルする前に、[データ] ページで定義したメッセージ間のデータのフローを確認します。XLANG スケジュールは、ビジネス プロセスと、そのプロセスのバインドについての情報を実装テクノロジに提供するものです。

BizTalk オーケストレーション デザイナは、コンパイルのプロセスで XLANG スケジュールの問題が発見されたときに、できるだけ多くの役立つ情報を提供するように設計されています。BizTalk オーケストレーション デザイナは、エラーを検出すると、エラーが含まれているシェイプを強調表示し、エラー メッセージを表示し、XLANG スケジュールのコンパイルを取り消します。

コンパイル中に、BizTalk オーケストレーション デザイナは、各シェイプが完了していて正しいかどうかを確認します。XLANG スケジューラ エンジンは、[ビジネス プロセス] ページの [開始] シェイプを最初に処理します。次に、再帰的にフローチャート全体を下方向に処理します。XLANG スケジューラ エンジンがエラーを検出した場合、そのエラーは一般的に、ビジネス プロセスが深くネストした位置のシェイプに流れるときに発生します。エラーを報告するために、XLANG スケジューラ エンジンは適切なエラー メッセージを構築します。そして、XLANG スケジューラ エンジンが上方向にスタックを戻るときに、各メソッドは元のエラー メッセージにメソッド自体のエラー メッセージを結合します。元のエラー メッセージにエラー メッセージを結合したメソッドがない場合は、最上位のコンパイル メソッドが次の一般エラー メッセージを追加します。XLANG スケジュールは処理できませんでした。

コンパイルされた XLANG スケジュールには、[開始] シェイプの XLANG ID プロパティと一致するグローバル一意識別子 (GUID) が含まれます。この ID を使用して、XLANG スケジュール フローチャートのバージョンと、そのフローチャートを生成した XLANG スケジュールを関連付けることができます。

注

  • 「操作方法」を参照し、BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを作成し、実行可能な XLANG スケジュールにコンパイルする方法について、作業ごとに十分に理解しておいてください。

関連項目

XLANG スケジュールのコンパイルとデバッグ

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュールのデバッグ


XLANG スケジュールのデバッグ

XLANG Event Monitor は、実行中の XLANG スケジュール インスタンスを監視するために使用するツールです。XLANG Event Monitor の使用方法の詳細については、付属のリリース ノートを参照してください。Microsoft BizTalk Server 2000 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、どちらもインストール ディレクトリ \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

XLANG Event Monitor には、次の機能があります。

  • XLANG Event Monitor は、XLANG スケジューラ エンジンの動作をリアル タイムに表示します。

  • 実行中のスケジュールを最初に列挙した後、XLANG Event Monitor はイベントを監視します。XLANG Event Monitor を使用して、実行中のインスタンスを中断したり停止できます。

  • XLANG Event Monitor のユーザー インターフェイスはマルチドキュメント インターフェイス (MDI) に似ていて、同時に複数のインスタンス トレースを表示できます。

  • 選択したアプリケーションを複数のコンピュータで同時に監視できます。

  • XLANG Event Monitor では、記録と表示で別のフィルタを使用できます。

関連項目

XLANG スケジュールのコンパイルとデバッグ

XLANG スケジュールのコンパイル

実行中の XLANG スケジュールの監視

XLANG スケジュールのエラー メッセージ


XLANG スケジュールの実行

BizTalk オーケストレーション デザイナをインストールすると、XLANG スケジューラ COM+ アプリケーションなど、いくつかの COM+ アプリケーションがインストールされ、Microsoft Windows 2000 コンポーネント サービス内に構成されます。このアプリケーションは、XLANG スケジューラ エンジンの既定のインスタンスをホストするものです。コンポーネント サービスに作成された新しい COM+ アプリケーションのプロパティを表示するダイアログ ボックスには、[XLANG] プロパティ ページが表示されます。ここでは、新しい COM+ アプリケーションが XLANG スケジューラ エンジンをホストするように設定できます。新しい XLANG スケジュールを実行する COM+ アプリケーションは、XLANG スケジュールのインスタンスをアクティブにするために使われる、モニカ構文で決定することもできます。

XLANG スケジューラ エンジンは、実行中の XLANG スケジュール インスタンスのアクティブ化、実行、ステータス退避、およびステータス復元を制御します。XLANG スケジュールをアクティブにするには、XLANG スケジュールのモニカを XLANG スケジューラ エンジンに渡す小さなアプリケーションを作成します。XLANG スケジューラ エンジンは、XLANG スケジュール内のアクションを実行し、XLANG スケジュールのステータス退避が必要になるまでビジネス プロセスを順序どおり続行していきます。XLANG スケジュールのステータス退避は、XLANG スケジューラ エンジンがメッセージを受信するまでの待機時間が、3 分を超えると予測される場合に発生します。メッセージが到着すると、XLANG スケジューラ エンジンによって XLANG スケジュール インスタンスのステータスが復元され、スケジュールが完了するまで、または XLANG スケジューラ エンジンが別のメッセージを待機する必要が生じるまで、ビジネス プロセスのアクションの実行が続けられます。ステータス退避をサポートするには、ステータス保存データベースを構成する必要があります。推奨されるネットワーク ライブラリは TCP/IP です。

Microsoft Windows 2000 コンポーネント サービスの情報を表示するには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

XLANG スケジューラ アプリケーションのプロパティ ダイアログ ボックスの [XLANG] プロパティ ページには、次のオプションが表示されます。

  • [このアプリケーションを XLANG スケジュール インスタンスのホストにする] : このチェック ボックスをオンにすると、この COM+ アプリケーションが XLANG スケジュールのインスタンスをアクティブにできるようになります。特定の COM+ アプリケーションにスケジュール インスタンスのアクティブ化を指示するには、アプリケーション名が含まれているモニカ書式を使用します。このチェック ボックスは、このアプリケーションを XLANG スケジューラ エンジンのホストとして使用する場合にオンにします。

  • [永続性] : このグループ ボックスでは、長時間にわたるビジネス プロセスのステータス退避とステータス復元をサポートするための、Microsoft SQL Server の構成を行うことができます。
    • [DSN の作成] は、XLANG スケジューラ エンジンをホストする COM+ アプリケーションの ODBC データ ソース名 (DSN) を作成します。ファイル DSN は、データベース接続に関する情報をファイルに格納するものです。ファイルの拡張子は .dsn で、既定では $\Program Files\Common Files\ODBC\Data Sources ディレクトリに格納されます。[DSN の作成] をクリックすると DSN ウィザードが起動します。

    • [DSN の構成] をクリックすると、ODBC データ ソース アドミニストレータが起動します。この COM+ アプリケーションにおける XLANG スケジュールのデータ送信元を管理できます。

    • [テーブルの初期化] は、定義した SQL Server データベース内に、永続性をサポートするために必要なテーブルを作成します。

    重要

    • [XLANG Scheduler のプロパティ] ダイアログ ボックスで構成するデータ ソース名は、COM+ アプリケーションの名前と同じものにする必要があります。
  • [シャットダウンの制御] : このグループ ボックスにあるボタンで、XLANG スケジュール インスタンスをホストしている COM+ アプリケーションをシャットダウンできます。
    • [すべての XLANG アプリケーション] をクリックすると、実行中の XLANG スケジュール インスタンスをホストしているすべての COM+ アプリケーションがシャットダウンされます。

    注

    • 既定のアプリケーション以外のアプリケーションを選択した場合は、[この XLANG アプリケーション] というボタンが表示されます。
  • [ステータス退避済み XLANG アプリケーションを再起動] : このグループ ボックスにあるボタンで、ステータス退避済み XLANG アプリケーションを管理できます。
    • [すべての XLANG アプリケーション] をクリックすると、XLANG スケジュール インスタンスをホストしているすべての COM+ アプリケーションのステータスが退避され、可能であれば実行が続けられます。

重要

  • COM+ アプリケーションを右クリックして実行中の XLANG スケジュール インスタンスをシャットダウンすることはやめてください。COM コンポーネントがメモリに読み込まれたまま残り、正しくアンロードされません。その方法ではなく、[XLANG Scheduler] COM+ アプリケーションのプロパティを表示するダイアログ ボックスで、[XLANG] タブの [シャットダウンの制御] ボックスにあるボタンを使用してください。

注

  • Microsoft Windows 2000 ターミナル サービスのクライアントを使用して XLANG スケジュールを開始する場合は、XLANG スケジューラ エンジンをホストする COM+ アプリケーションの ID を、有効な Windows 2000 ユーザー名またはグループ名に設定する必要があります。COM+ アプリケーションの ID は、そのアプリケーションのプロパティを表示するダイアログ ボックスの [ID] プロパティ ページで設定します。ターミナル サービスでホストされているセッションを通じて XLANG スケジューラ エンジンを使用している場合は、ID を対話的に設定することはできません。

  • XLANG スケジュールを実行する作業ごとの詳細については、「XLANG スケジュールの実行 (操作方法)」を参照してください。

ここには次のトピックが含まれます。

  • モニカの構文

  • インスタンス作成アプリケーションの作成


モニカの構文

モニカは、新しい XLANG スケジュール インスタンスを作成したり、既存の XLANG スケジュール インスタンスを参照したりするために使用します。どちらの場合にも、スケジュール インスタンスの特定のポートを参照できます。モニカによって、XLANG スケジューラ エンジンをホストする COM+ アプリケーションが決定されます。

XLANG スケジュールの新しいインスタンスを作成するには、XLANG スケジュールのモニカを COM+ アプリケーションに渡す必要があります。COM+ アプリケーションは、モニカを XLANG ネーム サービスに渡すことで、名前を解決すると共に XLANG スケジューラ エンジンのインスタンスを使って XLANG スケジュール インスタンスをアクティブにします。次のコード サンプルは、モニカの一般的な構文です。

sked://[HostName][!GroupManager][/FilePath][/PortName]

モニカの構文にある各セグメントは、インスタンス化するオブジェクトの種類によっては省略できます。次の表は、モニカの構文セグメントの一覧と説明を示しています。

モニカの構文セグメント | 説明 | 構文の例
<HostName> | XLANG スケジューラ エンジンを実行しているコンピュータのホスト名です。XLANG システム マネージャとも呼ばれます。省略した場合は、既定値として localhost が使用されます。この名前では、大文字と小文字は区別されません。 | sked:// sked://MyServer
<GroupManager> | XLANG スケジュール インスタンスを管理するために使用される XLANG スケジューラ エンジン グループ マネージャです。グループ マネージャの名前は、XLANG ホストとして指定した COM+ アプリケーションと同じものです。省略すると、既定値として XLANG Scheduler が使用されます。この名前では大文字と小文字が区別され、名前に空白を含めることができます。 | sked:/// sked://AnotherServer!/ sked://AnotherServer!MyGroup/
<FilePath> | アクティブにする XLANG スケジュール ファイル (.skx) へのパスです。この値では、大文字と小文字は区別されません。 | sked://host1!MyGrp/C:\basic.skx sked:///C:\basic.skx
<PortName> | XLANG スケジュールの COM コンポーネントまたは Windows スクリプト コンポーネントにバインドする、ポートの名前です。この名前では、大文字と小文字が区別されます。 | sked:///C:\basiccom.skx/portA

モニカの構文を使用すると、既存の XLANG スケジュール インスタンスを参照したり、XLANG スケジュールを起動したりできるほか、新しい XLANG スケジュール インスタンスの特定のポートとの通信チャネルを確立できます。

XLANG スケジュール インスタンスを参照するモニカは、XLANG スケジューラ エンジンで作成します。その後、[ポート参照] シェイプと、XLANG スケジュールで送信されるメッセージとの間に接続を作成すると、利用できるようになります。ポート参照の正確な形式は、ポートがバインドされている実装テクノロジと、対象のメッセージ フィールドのデータ型によって異なります。メッセージ キューまたは BizTalk メッセージ サービスにバインドされているポートは、データ型が String のフィールドにのみ接続できます。対象のフィールドには、キューの名前、または現在の XLANG スケジュール インスタンスでポートにバインドされているメッセージ エンドポイントの名前が含まれます。

COM コンポーネントにバインドされているポートは、データ型が String、Object、または Unknown のフィールドにのみ接続できます。対象のフィールドのデータ型が String の場合は、現在の XLANG スケジュール インスタンスのポートを参照するモニカが作成されます。このモニカは永続的です。このモニカは GetObject 関数を使用して解決することができ、システムを再起動した後も有効です。対象のフィールドのデータ型が Object または Unknown の場合は、ポート インスタンスへの COM 参照がメッセージ シェイプに渡されます。この種類の参照が外部コンポーネントに渡された場合、システムが再起動した後は無効になります。

実行中の XLANG スケジュール インスタンスを参照するためのモニカは、次の Microsoft Visual Basic コードで示すように、XLANG スケジュール インスタンス オブジェクトから取得できます。

Dim oSchedule as IWFWorkflowInstance
Set oSchedule = GetObject("sked:///C:\temp\myschedule.skx")
dim sMoniker as string
sMoniker = oSchedule.FullyQualifiedName

関連項目

インスタンス作成アプリケーションの作成

XLANG スケジュールの実行 (概念)


インスタンス作成アプリケーションの作成

インスタンス作成アプリケーションは、COM 関数 GetObject を使用して、完了した XLANG スケジュール ファイルのモニカを XLANG スケジューラ エンジンに渡します。次の Microsoft Visual Basic コードは、その方法を示しています。

Dim objExecute As object
Dim strURL as string

strURL = "sked:///c:\temp\myschedule.skx"

' This enables the XLANG Scheduler Engine to execute the XLANG schedule.
Set objExecute = GetObject(strURL)

モニカでポートを指定しなかった場合は、GetObject 関数で返されるオブジェクトの Port プロパティによって、COM コンポーネントにバインドされているポートへの参照を取得できます。同様に、FullPortName プロパティによって、実装テクノロジにバインドされたポートの完全で永続的な名前を取得できます。

次のコードは、COM ポートまたはスクリプト ポートへのプロキシを取得する方法を示しています。このコード例は、前のコード例からの続きです。

Dim oPort as Object
Set oPort = objExecute.Port("SchedulePortName")
Call oPort.ComponentMethodName(arg1,arg2,...argN)

注

  • ポートが、デュアル インターフェイスをサポートしない COM オブジェクトにバインドされている場合は、<oPort> 変数を適切なクラスと共に宣言する必要があります。

関連項目

モニカの構文

XLANG スケジュールの実行 (概念)


セッション ステータスの管理

COM コンポーネント バインド ウィザードの [ポート プロパティの詳細設定] ページで、COM コンポーネントがサポートする永続性レベルに対して、ステータス管理のための値を選択できます。[ステータス管理のサポート] ボックスで、次のオプションのいずれか 1 つを選択します。

  • [ステータスを保持しない] : XLANG スケジューラ エンジンは、コンポーネント インスタンスがステータス退避されると、そのコンポーネント インスタンスを終了します。この設定を選択した場合は、スケジュールがステータス復元されるときに、XLANG スケジューラ エンジンは必要に応じて新しいコンポーネント インスタンスを作成します。

  • [ステータスを保持し、永続的にサポートしない] : XLANG スケジューラ エンジンに対し、コンポーネント インスタンスの実行を継続するように要求します。アプリケーションがステータス退避されている間にシステムに障害が発生すると、このコンポーネントに保持されていたステータスはすべて失われます。

  • [ステータスを保持し、永続的にサポートする] : XLANG スケジューラ エンジンは、コンポーネント インスタンスをメモリから削除し、ステータス退避中にコンポーネントの IPersistStream または IPersistStreamInit のいずれかを呼び出すことでメモリに復元します。ステータス復元中に、もう一度メモリに復元します。

関連項目

インスタンス管理


XLANG スケジュールの更新

XLANG スケジュールを更新する方法は、2 とおりあります。元の XLANG スケジュールに上書きすることも、元の XLANG スケジュールと同時に実行される新しい XLANG スケジュールを追加することもできます。

元の XLANG スケジュールに上書きするには、BizTalk オーケストレーション デザイナを使用して新しい XLANG スケジュール フローチャートを作成し、元の XLANG スケジュールと同じ名前の XLANG スケジュールとして XLANG スケジュール フローチャートをコンパイルします。XLANG スケジュール フローチャートは、Microsoft Visio 2000 ファイル形式のカスタム バージョンである .skv ファイルとして保存されます。その後は、XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにすることができます。XLANG スケジュールは、XLANG スケジューラ エンジンが認識できる、.skx という拡張子を持つ XML 構造のテキスト ファイルです。元の XLANG スケジュールを更新するには、新しい .skx ファイルを元の .skx ファイルにコピーします。

元の XLANG スケジュールと同時に実行される新しい XLANG スケジュールを追加するには、BizTalk オーケストレーション デザイナを使用して新しい XLANG スケジュール フローチャートを作成し、新しい名前の XLANG スケジュールとして XLANG スケジュール フローチャートをコンパイルします。新しい XLANG スケジュールを正しくアクティブにするには、XLANG スケジュール インスタンスをアクティブにするメカニズムに変更を加え、古い .skx ファイルではなく新しい .skx ファイルをポイントするようにする必要があります。この作業を完了すると、XLANG スケジュールに新しい要求が出されたときは、新しい XLANG スケジュール インスタンスが作成されるようになります。

XLANG スケジュールとそのコンポーネントは、通常はすべてインスタンス単位で動作するので、実行中の元のスケジュールを処理する XLANG スケジュール インスタンスは、完了するまで実行されます。永続化されている XLANG スケジュール インスタンスも、元のスケジュールのソース コードが保存されているので、完了するまで実行されます。この場合、実行パスは元のビジネス プロセスに従います。XLANG スケジュールに新しい要求が出されると、新しい XLANG スケジュール インスタンスが作成されます。

注

  • XLANG スケジュールが使用しているオブジェクトのインターフェイスが変更された場合は、BizTalk オーケストレーション デザイナで XLANG スケジュール フローチャート (.skv ファイル) を読み込み、新しい .skx ファイルをコンパイルする必要があります。これによって .skx ファイルのバインド情報が更新され、コンポーネントのタイプ ライブラリとの同期がとれるようになります。


BizTalk メッセージ サービスの構成

Microsoft BizTalk Server 2000 で取引先とのドキュメント交換や企業内でのアプリケーション統合を処理するために BizTalk メッセージ サービスを構成する方法には、2 とおりあります。グラフィカル ユーザー インターフェイス (GUI) である BizTalk メッセージ マネージャを使用するか、または BizTalk メッセージ構成オブジェクト モデルに直接アクセスします。

BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデルを使用すると、データ交換を処理するためのメッセージ ポートとチャネルを作成することができます。また、メッセージ ポートとチャネルの作成に使用する、ドキュメント定義、エンベロープ、および組織を作成できます。さらに、メッセージ ポートのグループである同報リストを作成することもできます。

注

  • BizTalk メッセージ マネージャや BizTalk メッセージ構成オブジェクト モデルを使用してオブジェクトへのアクセスとオブジェクトの作成を行ったり、オブジェクトにアクセスしたりオブジェクトを作成するスクリプトやアプリケーションを実行するには、BizTalk Server Administrators グループのユーザー アカウントに属している必要があります。BizTalk Server Administrators グループは、BizTalk Server 2000 がインストールされると作成されます。このグループには、必要に応じてユーザーを追加することができます。ユーザー アカウントの追加の詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの使用

  • BizTalk メッセージ構成オブジェクト モデルへのアクセス


BizTalk メッセージ マネージャの使用

BizTalk メッセージ マネージャはグラフィカル ユーザー インターフェイス (UI) の 1 つで、BizTalk メッセージ サービスを構成することによりドキュメントの交換を管理できます。BizTalk メッセージ サービスは、プログラムに基づいて構成することもできます。詳細については、「BizTalk メッセージ構成オブジェクト モデルへのアクセス」を参照してください。

注意

  • ドキュメントを処理する場合は、あらかじめ BizTalk メッセージ マネージャを使用して BizTalk メッセージ サービスを構成しておく必要があります。BizTalk Server 2000 でドキュメントを処理している最中に、使用中のオブジェクトへのアクセスおよび変更を行うと、予期しない結果を招く場合があります。

ドキュメントは取引先とご使用の業務用アプリケーションとの間で交換できます。BizTalk メッセージ マネージャは、BizTalk Server 2000 をインストールしたコンピュータからローカルで使用することも、クライアント アプリケーションとしてリモートで使用することもできます。これによりシステム管理者は、セキュリティを確保し、サーバーを一元管理すると同時に、リモート ユーザーに BizTalk メッセージ マネージャへのアクセスを許可できます。

Microsoft BizTalk Server 2000 ヘルプには、チャネル、メッセージ ポート、ドキュメント定義、エンベロープ、および 組織の作成方法と管理方法のほか、同報リストの使用方法が説明されています。

BizTalk メッセージ マネージャ オブジェクト

次の図は、BizTalk メッセージ マネージャで作成できるオブジェクト間の関係を示しています。

BizTalk メッセージ マネージャの概要
アプリケーション (既定の組織)
ドキュメント定義
(受信)
メッセージ ポート
(送信先)
チャネル
(送信元)
チャネル
エンベロープ
同報リスト
メッセージ ポート
ドキュメント定義
(送信)
組織 (取引先)
受信
ドキュメント
送信
ドキュメント

次に、BizTalk メッセージ マネージャで作成できるオブジェクトの概要について説明します。オブジェクト間の関係についても説明します。各オブジェクトの詳細については、それぞれの説明の最後にあるリンクをクリックして、該当するオブジェクトのヘルプ トピックを参照してください。

チャネル

チャネルは BizTalk メッセージ マネージャの主要オブジェクトです。BizTalk メッセージ マネージャのその他すべてのオブジェクトの目的は、チャネルを作成するかチャネルの動作をサポートすることです。チャネルは、ドキュメントの送信元が組織、業務で使用するアプリケーション、XLANG スケジュールのいずれであるかを識別します。ドキュメント定義を使用することにより、受信ドキュメントと送信ドキュメントも識別します。詳細については、「チャネルについて」を参照してください。

メッセージ ポート

メッセージ ポートは、チャネルが処理するドキュメントの送信先を識別します。送信先は、組織、業務で使用するアプリケーション、XLANG スケジュールのいずれかです。メッセージ ポートは、ドキュメントの送信先アドレス、そのアドレスへのトランスポート方法、およびセキュリティによる保護とエンベロープ化が行われているかどうかを指定し、行われている場合はその方法を指定します。詳細については、「メッセージ ポートについて」を参照してください。

組織

組織は、ドキュメントを交換する取引先を表します。既定の組織という特殊な組織は、自分の会社を表します。既定の組織用にアプリケーションを作成でき、それは自分の会社で使用する内部アプリケーションを表します。組織およびアプリケーションは、チャネルの送信元またはメッセージ ポートの送信先として機能します。詳細については、「組織について」を参照してください。

ドキュメント定義

ドキュメント定義は、BizTalk Server 2000 で処理する特定の種類のドキュメントを表し、仕様へのポインタになります。仕様は、ドキュメントの構造、種類、およびバージョンを定義します。チャネルは受信および送信ドキュメント定義を指定し、サーバーで処理されるドキュメントを示します。ドキュメント定義は任意の数のチャネルで使用できます。詳細については、「ドキュメント定義について」を参照してください。

エンベロープ

エンベロープは、オープンな受信インターチェンジまたは送信インターチェンジを作成するために必要な情報を BizTalk Server 2000 に提供します。エンベロープはメッセージ ポート内で選択でき、サーバーに送信インターチェンジの作成を指示します。エンベロープはメッセージ ポートに関係なく、BizTalk Server 2000 によってオープンな受信インターチェンジにも使用できます。詳細については、「エンベロープについて」を参照してください。

同報リスト

同報リストとはメッセージ ポートの集まりで、これを使用するとさまざまな取引先組織または内部アプリケーションのグループに同じドキュメントを送信できます。個々のメッセージ ポートにチャネルを作成する場合と同様に、同報リストには最低 1 つのチャネルを作成する必要があります。詳細については、「同報リストについて」を参照してください。

注

  • BizTalk メッセージ マネージャを使用して作成できるオブジェクトは、BizTalk メッセージ構成オブジェクト モデルを使用してプログラムに基づいて作成することもできます。詳細については、「BizTalk メッセージ構成オブジェクト モデルへのアクセス」を参照してください。

  • BizTalk メッセージ マネージャを使用して作成できるオブジェクトは、BizTalk メッセージ サービスのほかのユーザー インターフェイスを使用して作成できるオブジェクトも使用します。チャネルで使用されるマップは、BizTalk マッパーで作成します。ドキュメント定義ではドキュメント仕様が、エンベロープではエンベロープ仕様が使用されます。仕様は BizTalk エディタで作成します。

  • 特定の作業のヘルプについては、「操作方法」を参照してください。

  • 一般的な情報については、「概念」を参照してください。


操作方法

ここでは、BizTalk メッセージ マネージャを使用する方法を作業ごとに説明します。「概念」を参照し、BizTalk メッセージ マネージャを使用して作成する各オブジェクト間の関係について、十分に理解しておいてください。

ここには次のトピックが含まれます。

  • チャネルの作成と管理

  • メッセージ ポートの作成および管理

  • 組織の作成と管理

  • ドキュメント定義の作成および管理

  • エンベロープの作成および管理

  • 同報リストの使用


チャネルの作成と管理

ここでは、チャネルを作成し、管理する方法を作業ごとに説明します。「概念」の「チャネルについて」を参照し、チャネルについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • チャネルの作成

  • チャネルの検索

  • チャネルの編集

  • チャネルの削除

  • チャネルのプロパティの設定


チャネルの作成

チャネルを作成する前に、メッセージ ポートまたは同報リストを作成する必要があります。詳細については、「メッセージ ポートの作成」または「同報リストの作成」を参照してください。

  1. BizTalk メッセージ マネージャで、[その他の項目を検索] の [メッセージ ポート] または [同報リスト] をクリックし、[検索] をクリックします。

  2. [メッセージ ポート名] で、チャネルを作成するメッセージ ポートをクリックします。

    – または –

    [同報リスト名] で、チャネルを作成する同報リストをクリックします。

  3. BizTalk メッセージ マネージャで、[ファイル] メニューの [新規作成] をポイントし、[チャネル] をポイントしてから、次のどちらかの手順を実行します。
    • 組織からチャネルを作成するには、[組織から] をクリックします。

    • アプリケーションからチャネルを作成するには、[アプリケーションから] をクリックします。

    [新しいチャネル ウィザード] が表示されます。

  4. [全般情報] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「チャネル情報の全般的なプロパティの設定」を参照してください。

  5. 次の手順のいずれかを行ってください。
    • 組織からチャネルを作成する場合は、[送信元組織] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信元組織のプロパティの設定」を参照してください。

    • アプリケーションからチャネルを作成する場合は、[送信元アプリケーション] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。
  6. [受信ドキュメント] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「受信ドキュメントのプロパティの設定」を参照してください。

  7. [送信ドキュメント] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「送信ドキュメントのプロパティの設定」を参照してください。

  8. [ドキュメント ログ] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

  9. [詳細構成] ページでプロパティを設定します。

    詳細については、「詳細構成のプロパティの設定」を参照してください。

  10. チャネルのすべてのプロパティを設定したら、[詳細構成] ページの [完了] をクリックして、チャネル ウィザードを閉じます。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認チャネル] を使用してチャネルに名前を付けることはできません。

  • この手順で作成できるのは、標準チャネルか受信確認チャネルのいずれかです。ここでの手順には、受信確認チャネルを作成する場合には使用できないチャネルのプロパティについての注意事項が示してあります。

  • データのパススルー送信に使用するメッセージ ポートとチャネルを作成する場合、使用できるのは、サービス時間帯、チャネルの再試行回数機能と再試行の間隔の機能、およびチャネルに関連付けられたメッセージ ポートのトランスポート機能だけです。デコードまたは暗号解読の検証、フィルタ、ドキュメント トラッキング、およびマッピングの各チャネルの機能は使用できません。

  • ローカル ドメイン以外にあるマップを参照するチャネルを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

チャネルの削除

チャネルの編集

チャネルの検索

チャネルのプロパティの設定

チャネルについて


チャネルの検索

  1. BizTalk メッセージ マネージャで、[その他の項目を検索] の [チャネル] をクリックします。

  2. すべてのチャネルを検索するには、検索条件をすべて消去し、[検索] をクリックします。

  3. 次の操作を 1 つ以上行ってください。
    • 特定の名前のチャネルを検索するには、[チャネルの検索] でそのチャネルの名前を [チャネル名] ボックスに入力し、[検索] をクリックします。不完全な名前を入力すると、検索はその不完全な名前と一致しているすべての名前を返します。

    • 特定の種類の送信元からのチャネルを検索するには、[送信元] ボックスの一覧で送信元の種類をクリックし、[検索] をクリックします。

    • 特定のメッセージ ポートまたは同報リストに関連付けられたチャネルを検索するには、[メッセージ ポートまたは同報リストに関連] ボックスにメッセージ ポート名または同報リスト名を入力し、[検索] をクリックします。不完全な名前を入力すると、検索はその不完全な名前と一致しているすべての名前を返します。

    • 特定のドキュメント定義を使用するチャネルを検索するには、[ドキュメント定義の使用] ボックスにドキュメント定義名を入力し、[検索] をクリックします。不完全な名前を入力すると、検索はその不完全な名前と一致しているすべての名前を返します。

注

  • [検索] をクリックする前に、複数の検索条件を設定することができます。

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 特定のメッセージ ポートまたは同報リストに関連付けられたチャネルを検索する場合、メッセージ ポートまたは同報リストを右クリックし、[チャネルの検索] をクリックしても検索できます。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件には、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

チャネルの削除

チャネルの編集

チャネルのプロパティの設定

チャネルについて


チャネルの編集

  1. BizTalk メッセージ マネージャの [チャネル名] ボックスの一覧で、編集するチャネルをクリックします。

    チャネルの検索については、「チャネルの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    チャネルのプロパティ ウィザードが表示されます。

  3. [全般情報] ページで、適切なプロパティを編集します。

    詳細については、「チャネル情報の全般的なプロパティの設定」を参照してください。

    プロパティの編集を終了したら、[完了] をクリックしてチャネルのプロパティ ウィザードを閉じるか、[次へ] をクリックして別のチャネルのプロパティを編集します。

  4. 次の手順のいずれかを行ってください。
    • 組織からのチャネルを編集する場合は、[送信元組織] ページで適切なプロパティを編集します。詳細については、「送信元組織のプロパティの設定」を参照してください。

    • アプリケーションからのチャネルを編集する場合は、[送信元アプリケーション] ページで適切なプロパティを編集します。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。
  5. [受信ドキュメント] ページで、適切なプロパティを編集します。

    詳細については、「受信ドキュメントのプロパティの設定」を参照してください。

  6. [送信ドキュメント] ページで、適切なプロパティを編集します。

    詳細については、「送信ドキュメントのプロパティの設定」を参照してください。

  7. [ドキュメント ログ] ページで、適切なプロパティを編集します。

    詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

  8. [詳細構成] ページで、適切なプロパティを編集します。

    詳細については、「詳細構成のプロパティの設定」を参照してください。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認チャネル] を使用してチャネルに名前を付けることはできません。

  • ローカル ドメイン以外にあるマップを参照するチャネルを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

チャネルの作成

チャネルの削除

チャネルの検索

チャネルのプロパティの設定

チャネルについて


チャネルの削除

  1. BizTalk メッセージ マネージャの [チャネル名] ボックスの一覧で、削除するチャネルをクリックします。

    チャネルの検索については、「チャネルの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • 受信確認チャネルは、その受信確認チャネルを参照しているすべてのチャネルを削除してからでなければ削除できません。

関連項目

チャネルの作成

チャネルの編集

チャネルの検索

チャネルのプロパティの設定

チャネルについて


チャネルのプロパティの設定

ここでは、チャネルのプロパティを構成する方法を作業ごとに説明します。ここには次のトピックが含まれます。

  • チャネル情報の全般的なプロパティの設定

  • 送信元組織のプロパティの設定

  • 送信元アプリケーションのプロパティの設定

  • 受信ドキュメントのプロパティの設定

  • 送信ドキュメントのプロパティの設定

  • ドキュメント ログのプロパティの設定

  • 詳細構成のプロパティの設定

  • 送信元組織の選択

  • 受信確認チャネルの選択

  • 受信ドキュメント定義の選択

  • 受信ドキュメントの暗号解読を確認する証明書の選択

  • 受信ドキュメントの署名を確認する証明書の選択

  • 送信ドキュメント定義の選択

  • マップの選択

  • 送信の署名証明書の選択

  • メッセージ ポート既定値の変更

  • 同報リスト既定値の変更

  • 受信ドキュメントの追跡のプロパティの設定

  • チャネル フィルタのプロパティの設定


チャネル情報の全般的なプロパティの設定

  1. チャネル ウィザードの [全般情報] ページで、[名前] ボックスにチャネル名を入力します。

  2. [コメント] ボックスに、チャネルに関するコメントを入力します。

  3. 受信確認チャネルを作成する場合は、[受信確認チャネルとして使用する] チェック ボックスをオンにします。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

注

  • 受信確認チャネルは特別な種類のチャネルで、BizTalk Server 2000 で受信したドキュメントの送信元に受信確認を返すのに使用されます。受信確認の詳細については、「受信確認について」を参照してください。

  • オープンなメッセージ ポートまたは同報リストの受信確認チャネルは作成できません。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定


送信元組織のプロパティの設定

  1. チャネル ウィザードの [送信元組織] ページで、次のいずれかの手順を実行します。
    • オープン チャネルを作成するには、[オープンな送信元] をクリックし、[次へ] をクリックします。オープン チャネルは、ドキュメント内のデータ、またはドキュメントとともに送信されたパラメータによって送信元が指定されることを示します。

      ドキュメントの送信の詳細については、「送信」を参照してください。

    • 取引先の組織を送信元として指定するには、[組織] をクリックし、手順 2. へ進みます。
  2. [組織] の [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. 組織をクリックし、[OK] をクリックします。

    詳細については、「送信元組織の選択」を参照してください。

  4. 送信元組織の既定の組織識別子を上書きする場合は、[組織の識別子] ボックスの一覧で別の識別子をクリックします。

  5. メッセージ ポートに指定した送信先からの受信確認が必要な場合は、[受信確認を要求する] チェック ボックスをオンにして、[受信間隔 (分)] ボックスに値を入力するか、上矢印または下矢印をクリックして値を増減します。

    既定値は 120 分です。受信確認の詳細については、「受信確認について」を参照してください。

  6. 送信元への受信確認を生成する場合は、[受信確認を生成する] チェック ボックスをオンにして、[参照] をクリックし、受信確認チャネルを選択します。

    詳細については、「受信確認チャネルの選択」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

注

  • X12 エンベロープで使用する送信元組織の識別子を選択する場合、"既定の組織" という組織識別子、3 文字以上の修飾子を持つ識別子、または 16 文字以上の値を持つ識別子は選択しないでください。

  • EDIFACT エンベロープで使用する送信元組織の識別子を選択する場合、"既定の組織" という組織識別子、5 文字以上の修飾子を持つ識別子、または 36 文字以上の値を持つ識別子は選択しないでください。

  • 特定の組織からのチャネルを編集する場合、[オープンな送信元] オプションは使用できず、送信元組織は変更できません。オープン チャネルを編集する場合、[組織] オプションは使用できません。

  • 受信確認チャネルを編集または作成する場合、[受信確認を要求する] チェック ボックスおよび [受信確認を生成する] チェック ボックスは使用できません。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信確認について


送信元アプリケーションのプロパティの設定

  1. チャネル ウィザードの [送信元アプリケーション] ページで、次のいずれかの手順を実行します。
    • 送信元が XLANG スケジュールであることを指定するには、[XLANG スケジュール] をクリックし、[次へ] をクリックします。

      オープンなメッセージ ポートのためのチャネルを作成する場合は、この操作を行わないでください。BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合の詳細については、「BizTalk サービスの統合」を参照してください。

    • 既定の組織のアプリケーションを送信元として指定するには、[アプリケーション] をクリックし、手順 2. へ進みます。
  2. [名前] ボックスの一覧でアプリケーションをクリックします。

  3. 既定の組織の既定の組織識別子を上書きする場合は、[組織の識別子] ボックスの一覧で別の識別子をクリックします。

  4. 送信先からの受信確認が必要な場合は、[受信確認を要求する] チェック ボックスをオンにして、[受信間隔 (分)] ボックスに値を入力するか、上矢印または下矢印をクリックして値を増減します。

    既定値は 120 分です。受信確認の詳細については、「受信確認について」を参照してください。

  5. 送信元への受信確認を生成する場合は、[受信確認を生成する] チェック ボックスをオンにして、[参照] をクリックし、受信確認チャネルを選択します。

    詳細については、「受信確認チャネルの選択」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

注

  • BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。

  • 受信確認チャネル、または XLANG スケジュールが送信元として指定されているチャネルを作成および編集する場合、[受信確認を要求する] チェック ボックスおよび [受信確認を生成する] チェック ボックスは使用できません。

関連項目

チャネルの作成

チャネルの編集

BizTalk サービスの統合

チャネルのプロパティの設定

受信確認について


受信ドキュメントのプロパティの設定

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. ドキュメント定義をクリックし、[OK] をクリックします。

    詳細については、「受信ドキュメント定義の選択」を参照してください。

  3. 受信ドキュメントの暗号解読を確認する場合は、[受信ドキュメントの暗号解読証明書の確認] チェック ボックスをオンにします。次に、[暗号解読確認の証明書] ボックスの右側の [参照] をクリックします。

    [暗号解読を確認する証明書の選択] ダイアログ ボックスが表示されます。

  4. 証明書を選択します。

    詳細については、「受信ドキュメントの暗号解読を確認する証明書の選択」を参照してください。

  5. 受信ドキュメントのデジタル署名を確認する場合は、[受信ドキュメントの署名証明書の確認] チェック ボックスをオンにします。次に、[署名確認の証明書] ボックスの右側の [参照] をクリックします。

    [署名を確認する証明書の選択] ダイアログ ボックスが表示されます。

  6. 署名証明書を選択します。

    詳細については、「受信ドキュメントの署名を確認する証明書の選択」を参照してください。

  7. 受信ドキュメントのフィールドを追跡する場合は、[受信ドキュメントの追跡] チェック ボックスをオンにし、[追跡] をクリックします。

    [受信ドキュメントの追跡] ダイアログ ボックスが表示されます。

  8. 追跡のプロパティを設定します。

    詳細については、「受信ドキュメントの追跡のプロパティの設定」を参照してください。

  9. 受信ドキュメントのチャネル フィルタ式を作成する場合は、[受信ドキュメントのフィルタ] チェック ボックスをオンにし、[フィルタ] をクリックします。

    [チャネル フィルタ式] ダイアログ ボックスが表示されます。

  10. フィルタのプロパティを設定します。

    詳細については、「チャネル フィルタのプロパティの設定」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

注

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認を別の書式に変換するには、WebDAV リポジトリ内の既定受信仕様を参照する受信ドキュメント定義を受信確認チャネルで作成し、選択します。さらに、送信の受信確認に必要な書式の仕様を参照する送信ドキュメント定義を受信確認チャネルで作成および選択することと、書式を変換するための受信確認チャネル内のマップを指定することも必要です。詳細については、「受信確認について」を参照してください。

  • 既定の "BizTalk 既定受信" を受信ドキュメント定義として使用する受信確認チャネルを作成する場合、[追跡] と [フィルタ] の各チェック ボックスは使用できません。

  • オープンなメッセージ ポートのチャネルを作成し、送信先の情報がドキュメントで提供される場合、そのチャネルの受信ドキュメント定義は適切に構成された仕様を参照する必要があります。オープンなメッセージ ポートのドキュメントを処理するためのドキュメント仕様を構成する方法については、「ディクショナリ プロパティの設定」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定


送信ドキュメントのプロパティの設定

  1. チャネル ウィザードの [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. ドキュメント定義をクリックし、[OK] をクリックします。

    詳細については、「送信ドキュメント定義の選択」を参照してください。

  3. マップを指定する場合は、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスをオンにします。次に、[マップ参照] ボックスの右側の [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  4. マップの仕様を選択します。

    詳細については、「マップの選択」を参照してください。

  5. 送信ドキュメントにデジタル署名を付ける場合は、[送信ドキュメントに署名] チェック ボックスをオンにします。次に、[署名証明書] ボックスの右側の [参照] をクリックします。

    [セキュリティ情報] ページの [署名] が [S/MIME] に設定されているメッセージ ポートのためのチャネルを作成している場合、[送信ドキュメントに署名] チェック ボックスは自動的にオンになります。

    [署名証明書の選択] ダイアログ ボックスが表示されます。

  6. 署名証明書を選択します。

    詳細については、「送信の署名証明書の選択」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

重要

  • メッセージ ポートに指定するエンベロープの書式は、エンベロープが格納されるドキュメントの書式と一致する必要があります。ドキュメント形式は、関連付けられたチャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。

  • オープンなメッセージ ポートであることを宣言する場合は、X12 または EDIFACT 仕様の送信ドキュメント定義を持つポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元組織識別子と送信先組織識別子がサーバーに必要です。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報が含まれません。

  • WebDAV リポジトリのダイアログ ボックスを最初に開いたときは、BizTalk メッセージ マネージャがリモート サーバーのデータベースに接続されていても、ローカル サーバーの WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最新のサーバーです。

注

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認に別の形式を使用するには、WebDAV リポジトリ内の既定受信仕様を参照する受信ドキュメント定義を作成し、選択します。送信の受信確認のために必要な書式の仕様を参照する送信ドキュメント定義と、受信確認の書式を変換するマップも作成する必要があります。受信確認の詳細については、「受信確認について」を参照してください。

  • マップは受信ドキュメントの書式を送信ドキュメントの書式に変換するのに使用します。受信ドキュメントの仕様参照が送信ドキュメントの仕様参照と一致する場合、マップは必要ありません。既定では、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスはオンになりません。マップは BizTalk マッパーで作成できます。マップの詳細については、「データのマッピング」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信確認について


ドキュメント ログのプロパティの設定

  1. チャネル ウィザードの [ドキュメント ログ] ページの [受信ドキュメントの記録] で、適切なチェック ボックスをオンにします。
    • [ネイティブ形式]: チャネルの受信ドキュメントを元の形式で保存します。これは既定の設定です。

    • [XML 形式]: チャネルの受信ドキュメントを XML 形式で保存します。
  2. [送信ドキュメントの記録] で適切なチェック ボックスをオンにします。
    • [ネイティブ形式]: チャネルの送信ドキュメントを元の形式で保存します。

    • [XML 形式]: チャネルの送信ドキュメントを XML 形式で保存します。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

注

  • ログ機能を使用するドキュメントにはサイズに制限があり、制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

  • BizTalk Server 2000 では、非 XML 受信ドキュメントは元のネイティブ形式から処理用に XML 形式に変換され、送信ドキュメントは XML 形式から送信先で必要なネイティブ形式に変換されます。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定


詳細構成のプロパティの設定

  1. X12 または EDIFACT のエンベロープ書式を指定するメッセージ ポートのチャネルを作成している場合は、チャネル ウィザードの [詳細構成] ページで [グループ制御番号] ボックスにゼロ以外の値を入力します。

  2. [再試行のオプション] の [再試行の回数] ボックスに、受信確認が受信されなかった場合にサーバーがドキュメントを再送信する回数を入力し、[間隔 (分)] ボックスに、再試行の間隔を入力します。

    受信確認の詳細については、「受信確認について」を参照してください。

  3. メッセージ ポートまたは同報リストのトランスポートまたはエンベロープ コンポーネントの設定を上書きする場合は、[詳細設定] をクリックします。
    • メッセージ ポートのチャネルを作成または編集している場合は、[メッセージ ポート既定値の変更] ダイアログ ボックスが表示されます。詳細については、「メッセージ ポート既定値の変更」を参照してください。

    • 同報リストのチャネルを作成または編集している場合は、[同報リスト既定値の変更] ダイアログ ボックスが表示されます。詳細については、「同報リスト既定値の変更」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。変更が完了したら、[完了] をクリックします。

関連項目

チャネルの作成

チャネルの編集

再送信キュー

チャネルのプロパティの設定

受信確認について


送信元組織の選択

  1. チャネル ウィザードの [送信元組織] ページで、[名前] ボックスの右側の [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  2. [利用可能な組織] ボックスの一覧で組織をクリックし、[OK] をクリックします。

送信元組織のプロパティの設定を続けるには、「送信元組織のプロパティの設定」に進んでください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

送信元組織のプロパティの設定


受信確認チャネルの選択

  1. チャネル ウィザードの [送信元アプリケーション] ページまたは [送信元組織] ページで、[受信確認を生成する] チェック ボックスをオンにし、[参照] をクリックします。

    [受信確認チャネルの選択] ダイアログ ボックスが表示されます。

  2. [利用可能な受信確認チャネル] ボックスの一覧で受信確認チャネルをクリックし、[OK] をクリックします。

送信元組織のプロパティの設定を続けるには、「送信元組織のプロパティの設定」に進んでください。

送信元アプリケーションのプロパティの設定を続けるには、「送信元アプリケーションのプロパティの設定」に進んでください。

注

  • [利用可能な受信確認チャネル] ボックスの一覧には、作成しているチャネルの送信元と送信先が一致するメッセージ ポートに関連付けられた受信確認チャネルだけが表示されます。受信確認チャネルが指定されているチャネルを BizTalk Server 2000 が呼び出す場合、サーバーは指定された受信確認チャネルを使用して、そのドキュメントの元の送信元に受信確認を返します。受信確認の詳細については、「受信確認について」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

送信元アプリケーションのプロパティの設定

送信元組織のプロパティの設定

受信確認について


受信ドキュメント定義の選択

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. [利用可能なドキュメント定義] ボックスの一覧でドキュメント定義をクリックし、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認に別の書式を使用するには、WebDAV リポジトリ内の既定受信仕様を参照する送信ドキュメント定義を作成し、選択します。送信の受信確認のために必要な書式の仕様を参照する送信ドキュメント定義と、受信確認の書式を変換するマップも作成する必要があります。受信確認の詳細については、「受信確認について」を参照してください。

関連項目

チャネルの作成

ドキュメント定義の作成

チャネルの編集

チャネルのプロパティの設定

受信ドキュメントのプロパティの設定

受信確認について


受信ドキュメントの暗号解読を確認する証明書の選択

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメントの暗号解読証明書の確認] チェック ボックスをオンにします。

  2. [暗号解読確認の証明書] ボックスの右側の [参照] をクリックします。

    [暗号解読を確認する証明書の選択] ダイアログ ボックスが表示されます。

  3. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。

  • 適切なチャネルを識別するのに必要なデータをサーバーが取得できるように、ドキュメントは BizTalk Server 2000 に受信された時点で暗号解読されます。暗号解読が正しく実行されたかどうかは、チャネルに指定する証明書によって確認されます。

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信ドキュメントのプロパティの設定


受信ドキュメントの署名を確認する証明書の選択

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメントの署名証明書の確認] チェック ボックスをオンにします。

  2. [署名確認の証明書] ボックスの右側の [参照] をクリックします。

    [署名を確認する証明書の選択] ダイアログ ボックスが表示されます。

  3. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信ドキュメントのプロパティの設定


送信ドキュメント定義の選択

  1. チャネル ウィザードの [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. [利用可能なドキュメント定義] ボックスの一覧でドキュメント定義をクリックし、[OK] をクリックします。

送信ドキュメントのプロパティの設定を続けるには、「送信ドキュメントのプロパティの設定」に進んでください。

注

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認に別の書式を使用するには、WebDAV リポジトリ内の既定受信仕様を参照する送信ドキュメント定義を作成し、選択します。送信の受信確認のために必要な書式の仕様を参照する送信ドキュメント定義と、受信確認の書式を変換するマップも作成する必要があります。受信確認の詳細については、「受信確認について」を参照してください。

関連項目

チャネルの作成

ドキュメント定義の作成

チャネルの編集

チャネルのプロパティの設定

送信ドキュメントのプロパティの設定

受信確認について


マップの選択

  1. チャネル ウィザードの [送信ドキュメント] ページで、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスをオンにし、[マップ参照] ボックスの右側の [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  2. サーバーを変更する場合は、[サーバー] ボックスで次のどちらかの操作を行います。
    • 一覧に表示されているサーバーをクリックします。

    • サーバーの名前を入力し、Enter キーを押します。
  3. 使用するマップが格納されているフォルダをダブルクリックし、マップをクリックして、[開く] をクリックします。

送信ドキュメントのプロパティの設定を続けるには、「送信ドキュメントのプロパティの設定」に進んでください。

重要

  • WebDAV リポジトリのダイアログ ボックスを最初に開いたときは、BizTalk メッセージ マネージャがリモート サーバーのデータベースに接続されていても、ローカル サーバーの WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • サーバーとして http://localhost を選択すると、BizTalk メッセージ マネージャはそれを自動的にローカル コンピュータ名に変換します。

  • ローカル ドメイン以外にあるマップを参照するチャネルを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

チャネルの作成

チャネルの編集

データのマッピング

チャネルのプロパティの設定

送信ドキュメントのプロパティの設定


送信の署名証明書の選択

  1. チャネル ウィザードの [送信ドキュメント] ページで、[送信ドキュメントに署名] チェック ボックスをオンにし、[署名証明書] ボックスの右側の [参照] をクリックします。

    [署名証明書の選択] ダイアログ ボックスが表示されます。

  2. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

送信ドキュメントのプロパティの設定を続けるには、「送信ドキュメントのプロパティの設定」に進んでください。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

送信ドキュメントのプロパティの設定


メッセージ ポート既定値の変更

  1. チャネル ウィザードの [詳細構成] ページで [詳細設定] をクリックします。

    メッセージ ポートのチャネルを作成または編集している場合は、[メッセージ ポート既定値の変更] ダイアログ ボックスが表示されます。

  2. [プライマリ トランスポート] タブの [プロパティ] をクリックします。

    該当する BizTalk コンポーネントのプロパティのダイアログ ボックスが表示されます。

  3. 上書きするトランスポート コンポーネントのプロパティを変更し、[OK] をクリックします。

  4. メッセージ ポートにエンベロープがあり、そのエンベロープの設定を変更する場合は、[エンベロープ] タブをクリックし、[プロパティ] をクリックします。

    該当する BizTalk コンポーネントのプロパティのダイアログ ボックスが表示されます。

  5. 上書きするエンベロープ コンポーネントのプロパティを変更し、[OK] をクリックします。

詳細なプロパティの設定を続けるには、「詳細構成のプロパティの設定」に進んでください。

重要

  • メッセージ ポートのトランスポートとエンベロープのプロパティの変更は、高度な機能です。これらのダイアログ ボックスにあるトランスポート コンポーネントとエンベロープ コンポーネントのプロパティを十分に理解していない場合は、変更しないでください。

  • メッセージ ポートでカスタム書式のエンベロープを指定した場合は、詳細構成のプロパティを使用して、カスタム シリアライザ コンポーネントを構成する必要があります。

注

  • チャネルのメッセージ ポートのプロパティを変更する場合、変更はそのチャネルにだけ適用されます。

  • メッセージ ポートに設定されたトランスポート アドレスは変更できません。

  • HTTP トランスポート コンポーネントの既定の設定は、HTTP プロキシ サーバーを使用するようになっています。これは、企業のファイアウォールの外部にある Web サイトにデータをトランスポートするのに適した設定です。企業のファイアウォールの内部にある (つまり、イントラネット内の) Web サイトにデータをトランスポートするには、この手順で既定の設定を変更します。

  • HTTPS トランスポート コンポーネントの場合は、クライアント認証用に指定されている証明書だけを使用します。汎用として指定されている証明書は、この一覧には表示されません。

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。メッセージ ポートで既定の設定になっているファイル トランスポートの種類を使用し、BizTalk Server 2000 がインストールされているサーバーでウィルス対策ソフトウェアを使用していて、正確に同じ名前の複数のファイルを同じファイル位置に同時に送信すると、BizTalk Server 2000 が応答しなくなることがあり、その場合再起動する必要があります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。この問題は、メッセージ ポートのファイル パス形式 (file://C:\dir\file%tracking_id%.xml) を使用して処理されるドキュメント インスタンスごとに一意なファイルを作成することで解決することもできます。詳細については、「トランスポート アドレスの指定」を参照してください。

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。既定の設定のファイル トランスポートの種類を選択し、メッセージ ポートで Reliable エンベロープ書式のエンベロープを選択して、複数のファイルを同時に同じファイル位置に送信すると、予期しない解析結果を生じることがあります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで 、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。

  • メッセージ ポートに指定したエンベロープがカスタム書式で、カスタム シリアライザ コンポーネントを作成および登録してある場合は、この手順でカスタム シリアライザ コンポーネントのプロパティを構成できます。

  • EDIFACT エンベロープの既定の構文識別子は UNOA (大文字のラテン文字) です。データに別の構文が必要な場合は、この手順で異なる構文識別子を選択します。

  • EDIFACT リリース インジケータ (解除記号 : UNA04 RELEASE CHARACTER) を使用する場合、データにリリース インジケータ文字を含めないでください。リリース インジケータ文字を含めると、データがフィールドに設定された文字物理サイズを超過することがあります。

関連項目

チャネルの作成

チャネルの編集

詳細構成のプロパティの設定

チャネルのプロパティの設定


同報リスト既定値の変更

  1. チャネル ウィザードの [詳細構成] ページで [詳細設定] をクリックします。

    同報リストのチャネルを作成または編集している場合は、[同報リスト既定値の変更] ダイアログ ボックスが表示されます。

  2. [メッセージ ポートの選択] ボックスの一覧で上書きするメッセージ ポートを選択し、[上書き] をクリックします。

    [メッセージ ポート既定値の変更] ダイアログ ボックスが表示されます。

  3. 選択したメッセージ ポートのトランスポート コンポーネントとエンベロープ コンポーネントのプロパティを変更します。

    詳細については、「メッセージ ポート既定値の変更」を参照してください。

  4. 上書きするメッセージ ポートを変更したら、[閉じる] をクリックします。

詳細なプロパティの設定を続けるには、「詳細構成のプロパティの設定」に進んでください。

関連項目

チャネルの作成

チャネルの編集

メッセージ ポート既定値の変更

詳細構成のプロパティの設定

チャネルのプロパティの設定


受信ドキュメントの追跡のプロパティの設定

[受信ドキュメントの追跡] ダイアログ ボックスには、受信ドキュメントの仕様フィールドと、ドキュメント定義で選択されているグローバル追跡項目の一覧が表示されます。

このダイアログ ボックスを使用して仕様フィールドを選択すると、このチャネルにおいてのみ、グローバル追跡項目がそれらの仕様フィールドによって上書きされます。チャネルで選択するフィールドは、処理されるドキュメント インスタンスごとに、グローバル追跡項目ではなく追跡データベースに記録されます。

ここでは、チャネルで受信ドキュメントの仕様フィールドを選択または削除する方法について説明します。

ここには次のトピックが含まれます。

  • チャネルでの仕様フィールドの選択

  • チャネルでの仕様フィールドの削除

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

グローバル追跡プロパティの設定

受信ドキュメントのプロパティの設定


チャネルでの仕様フィールドの選択

  1. チャネル ウィザードの [受信ドキュメント] ページで [受信ドキュメントの追跡] チェック ボックスをオンにし、[追跡] をクリックします。

    [受信ドキュメントの追跡] ダイアログ ボックスが表示されます。

  2. [仕様フィールド] ボックスの一覧にあるツリーで、項目をダブルクリックして展開します。

  3. [追跡するフィールド] ボックスの一覧で追加する仕様フィールドをクリックし、次の手順のいずれかを実行します。
    追加するフィールドのデータ型 | 手順
    整数 | [整数] をクリックします。整数型のフィールドを 2 つ追加できます。
    実数 | [実数] をクリックします。実数型のフィールドを 2 つ追加できます。
    日付 | [日付] をクリックします。日付型のフィールドを 2 つ追加できます。
    テキスト | [テキスト] をクリックします。テキスト型のフィールドを 2 つ追加できます。
    カスタム | [カスタム] をクリックします。カスタム データ型のフィールドをいくつでも追加できます。これらのフィールドは、フィールドごとにタグの付いた XML 連結文字列として格納されます。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

重要

  • このダイアログ ボックスを使用して仕様フィールドを選択すると、このチャネルにおいてのみ、グローバル追跡項目がそれらの仕様フィールドによって上書きされます。チャネルで選択するフィールドは、処理されるドキュメント インスタンスごとに、グローバル追跡項目ではなく追跡データベースに記録されます。

注

  • 整数、実数、日付のいずれかのデータ型として追跡する仕様フィールドを選択するには、仕様の中でそのデータ型がフィールドに割り当てられている必要があります。仕様フィールドへのデータ型の割り当ての詳細については、「宣言のプロパティの設定」を参照してください。

  • 仕様フィールドのデータ型が、仕様内で割り当てられているデータ型でない場合は、そのフィールドはテキスト型またはカスタム データ型としてのみ追跡できます。

  • 追跡する仕様フィールドが文字データ型である場合は、そのフィールドはカスタム データ型としてのみ追跡できます。

  • 特定のデータ型の仕様フィールドは 2 つだけ選択できます。カスタム データ型として選択できるフィールド数には、制限はありません。

関連項目

チャネルの作成

チャネルの編集

チャネルでの仕様フィールドの削除

チャネルのプロパティの設定

グローバル追跡プロパティの設定

受信ドキュメントの追跡のプロパティの設定

ドキュメント データ フィールドの追跡


チャネルでの仕様フィールドの削除

  1. チャネル ウィザードの [受信ドキュメント] ページで [受信ドキュメントの追跡] チェック ボックスをオンにし、[追跡] をクリックします。

    [受信ドキュメントの追跡] ダイアログ ボックスが表示されます。

  2. [追跡するフィールド] ボックスの一覧で、削除する仕様フィールドをクリックし、[削除] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 追跡するフィールドの一覧からフィールドを削除しても、そのフィールドはこのチャネルの一覧から削除されるだけで、仕様からは削除されません。

関連項目

チャネルの作成

チャネルの編集

チャネルでの仕様フィールドの選択

チャネルのプロパティの設定

グローバル追跡プロパティの設定

受信ドキュメントの追跡のプロパティの設定

ドキュメント データ フィールドの追跡


チャネル フィルタのプロパティの設定

チャネル フィルタ式は XPath 式であり、ドキュメント内で指定されたフィールドの値に基づいてチャネルが呼び出されるかどうかを判定するのに使用できます。BizTalk Server 2000 がドキュメントを処理する場合、各ドキュメント内で指定されたフィールドの値がチャネル フィルタ式に対して評価されます。式が真であると、チャネルが呼び出されます。式が偽であると、チャネルは呼び出されません。

ここには次のトピックが含まれます。

  • チャネル フィルタ式の追加

  • チャネル フィルタ式の編集

  • チャネル フィルタ式の削除

関連項目

受信ドキュメントのプロパティの設定


チャネル フィルタ式の追加

  1. チャネル ウィザードの [受信ドキュメント] で [受信ドキュメントのフィルタ] チェック ボックスをオンにし、[フィルタ] をクリックします。

    [チャネル フィルタ式] ダイアログ ボックスが表示されます。

  2. [フィールドの選択] ボックスの一覧にあるツリーで、ノードをダブルクリックして展開します。

  3. フィルタ式の作成に使用する仕様フィールドをクリックし、[追加] をクリックします。

    [式のプロパティ] ダイアログ ボックスが表示されます。

  4. [演算子] ボックスの一覧で演算子をクリックします。
    演算子 記号
    等しい (既定) =
    等しくない !=
    より小さい <
    以下 <=
    より大きい >
    以上 >=

  5. [値] ボックスに式の値を入力し、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

重要

  • チャネル フィルタ式は有効な XPath 式でなければなりません。[追加] ボタンを使用すると、仕様フィールドを含む句を作成して、その句を式に挿入できますが、有効な XPath 式に必要な正しい構文は生成されません。XPath 式の詳細については、「チャネル フィルタ」を参照し、Microsoft の Web サイト (msdn.microsoft.com/library/) で XPath という語を検索対象にして検索してください。

注

  • 式は [式] ボックスの一覧に直接入力できます。

  • チャネル フィルタ式の仕様フィールドを選択するには、そのフィールドのデータ型は仕様で割り当てられているデータ型でなければなりません。フィールドへのデータ型の割り当ての詳細については、「宣言のプロパティの設定」を参照してください。

  • 式の作成に使用する仕様フィールドがブール型である場合、式の値に "true" または "false" のテキスト文字列を使用することはできません。代わりに、真の場合は "-1"、偽の場合は "0" の数値を使用します。

  • 式の作成に使用する仕様フィールドが日付型である場合、ハイフンも含めて YYYY-MM-DD の形式で値を入力します。

関連項目

チャネルの作成

チャネル フィルタ式の編集

チャネルの編集

チャネル フィルタ式の削除

チャネル フィルタのプロパティの設定

チャネルのプロパティの設定


チャネル フィルタ式の編集

  1. チャネル ウィザードの [受信ドキュメント] で [受信ドキュメントのフィルタ] チェック ボックスをオンにし、[フィルタ] をクリックします。

    [チャネル フィルタ式] ダイアログ ボックスが表示されます。

  2. [式] ボックスの一覧で式を編集し、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

重要

  • チャネル フィルタ式は有効な XPath 式でなければなりません。XPath 式の詳細については、「チャネル フィルタ」を参照し、Microsoft の Web サイト (msdn.microsoft.com/library/) で XPath という語を検索対象にして検索してください。

関連項目

チャネル フィルタ式の追加

チャネル フィルタ式の削除

チャネル フィルタのプロパティの設定


チャネル フィルタ式の削除

  • チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメントのフィルタ] チェック ボックスをオフにします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

関連項目

チャネル フィルタ式の追加

チャネルの作成

チャネル フィルタ式の編集

チャネルの編集

チャネル フィルタのプロパティの設定

チャネルのプロパティの設定


メッセージ ポートの作成および管理

ここでは、メッセージ ポートを作成し、管理する方法を作業ごとに説明します。「概念」の「メッセージ ポートについて」を参照し、メッセージ ポートについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • メッセージ ポートの作成

  • メッセージ ポートの検索

  • メッセージ ポートの編集

  • メッセージ ポートの削除

  • メッセージ ポートのプロパティの設定


メッセージ ポートの作成

  1. BizTalk メッセージ マネージャの [ファイル] メニューで、[新規作成] をポイントし、[メッセージ ポート] をポイントします。次に、次の手順のいずれかを実行します。
    • 取引先組織へのメッセージ ポートを作成する場合は、[組織へ] をクリックします。

    • 内部アプリケーションへのメッセージ ポートを作成する場合は、[アプリケーションへ] をクリックします。

    [新しいメッセージ ポート ウィザード] が開きます。

  2. [全般情報] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「メッセージ ポート情報の全般的なプロパティの設定」を参照してください。

  3. 次の手順のいずれかを行ってください。
    • 特定の組織へのメッセージ ポートを作成する場合は、[送信先組織] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

    • オープンなメッセージ ポートを作成する場合は、[オープンな送信先] をクリックし、[次へ] をクリックします。

      オープンなメッセージ ポートの場合は、ドキュメントまたはドキュメントで送信するパラメータにトランスポート情報および送信先情報を指定する必要があります。詳細については、「送信」を参照してください。

    • 特定のアプリケーションへのメッセージ ポートを作成する場合は、[送信先アプリケーション] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  4. [エンベロープ情報] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「エンベロープ情報のプロパティの設定」を参照してください。

  5. [セキュリティ情報] ページでプロパティを設定します。

    詳細については、「セキュリティ情報のプロパティの設定」を参照してください。

  6. チャネル ウィザードに直接進まずにチャネルを作成する場合は、[このメッセージ ポート用のチャネルの作成] チェック ボックスをオフにします。チャネル ウィザードに直接進む場合は、[チャネルの種類] ボックスの一覧から次のいずれかのチャネルの種類を選択します。
    • [組織から]

    • [アプリケーションから]
  7. すべてのメッセージ ポートのプロパティを設定し終わったら、[セキュリティ情報] ページの [完了] をクリックしてメッセージ ポート ウィザードを閉じます。

重要

  • オープンなメッセージ ポートであることを宣言する場合は、X12 または EDIFACT 仕様の送信ドキュメント定義を持つポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元および送信先の組織識別子を指定する必要があります。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報は含まれません。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認ポート] を使用してメッセージ ポートに名前を付けることはできません。

  • データのパススルー送信に使用するメッセージ ポートとチャネルを作成する場合、使用できるのは、サービス時間帯、チャネルの再試行回数機能と再試行の間隔の機能、およびチャネルに関連付けられたメッセージ ポートのトランスポート機能だけです。デコードまたは暗号解読の検証、フィルタ、ドキュメント トラッキング、およびマッピングの各チャネルの機能は使用できません。

関連項目

チャネルの作成と管理

メッセージ ポートの削除

メッセージ ポートの編集

メッセージ ポートの検索

メッセージ ポートのプロパティの設定

メッセージ ポートについて


メッセージ ポートの検索

  1. BizTalk メッセージ マネージャで、[その他の項目を検索] の [メッセージ ポート] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべてのメッセージ ポートを検索するには、検索条件をすべて消去し、[検索] をクリックします。

    • 特定の名前のメッセージ ポートを検索するには、そのメッセージ ポートの名前を [メッセージ ポート名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定の種類の送信先へのメッセージ ポートを検索するには、[送信先] ボックスの一覧から送信先の種類をクリックし、[検索] をクリックします。

注

  • [検索] をクリックする前に、複数の検索条件を設定することができます。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索条件には、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

メッセージ ポートの削除

メッセージ ポートの編集

メッセージ ポートについて


メッセージ ポートの編集

  1. BizTalk メッセージ マネージャの [メッセージ ポート名] ボックスの一覧で、編集するメッセージ ポートをクリックします。

    メッセージ ポートの検索については、「メッセージ ポートの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    メッセージ ポートのプロパティ ウィザードが表示されます。

  3. [全般情報] ページで、適切なプロパティを編集します。

    詳細については、「メッセージ ポート情報の全般的なプロパティの設定」を参照してください。

    プロパティを編集し終わったら、[完了] をクリックしてメッセージ ポートのプロパティ ウィザードを閉じるか、[次へ] をクリックして別のメッセージ ポートのプロパティを編集します。

  4. 次の手順のいずれかを行ってください。
    • 組織へのメッセージ ポートを編集する場合は、[送信先組織] ページで必要なプロパティを編集し、[次へ] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

    • アプリケーションへのメッセージ ポートを編集する場合は、[送信先アプリケーション] ページで必要なプロパティを編集し、[次へ] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  5. [エンベロープ情報] ページで必要なプロパティを編集し、[次へ] をクリックします。

    詳細については、「エンベロープ情報のプロパティの設定」を参照してください。

  6. [セキュリティ情報] ページで、必要なプロパティを編集します。

    詳細については、「セキュリティ情報のプロパティの設定」を参照してください。

  7. チャネル ウィザードに直接進まずにチャネルを作成する場合は、[このメッセージ ポート用のチャネルの作成] チェック ボックスをオフにします。チャネル ウィザードに直接進む場合は、[チャネルの種類] ボックスの一覧から次のいずれかのチャネルの種類を選択します。
    • [組織から]

    • [アプリケーションから]
  8. すべてのメッセージ ポートのプロパティを設定し終わったら、[完了] をクリックしてメッセージ ポート ウィザードを閉じます。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認ポート] を使用してメッセージ ポートに名前を付けることはできません。

関連項目

チャネルの作成と管理

メッセージ ポートの作成

メッセージ ポートの削除

メッセージ ポートのプロパティの設定

メッセージ ポートについて


メッセージ ポートの削除

  1. BizTalk メッセージ マネージャの [メッセージ ポート名] ボックスの一覧で、削除するメッセージ ポートをクリックします。

    メッセージ ポートの検索については、「メッセージ ポートの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • チャネルが作成されているメッセージ ポートは、そのチャネルを削除しない限り削除できません。

  • メッセージ ポートに関連付けられているチャネルを検索するには、そのメッセージ ポートを右クリックし、[チャネルの検索] をクリックします。

関連項目

チャネルの作成と管理

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートについて


メッセージ ポートのプロパティの設定

ここでは、メッセージ ポートのプロパティを構成する方法を作業ごとに説明します。ここには次のトピックが含まれます。

  • メッセージ ポートの全般的なプロパティの設定

  • 送信先組織のプロパティの設定

  • 送信先アプリケーションのプロパティの設定

  • エンベロープ情報のプロパティの設定

  • セキュリティ情報のプロパティの設定

  • 送信先組織の選択

  • 暗号化証明書の選択

  • トランスポートのプロパティの設定

  • エンベロープの区切り記号の設定


メッセージ ポート情報の全般的なプロパティの設定

  1. メッセージ ポート ウィザードの [全般情報] ページで、[名前] ボックスにメッセージ ポート名を入力します。

  2. [コメント] ボックスに、メッセージ ポートに関するコメントを入力し、[次へ] をクリックします。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。変更が完了したら、[完了] をクリックします。

関連項目

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


送信先組織のプロパティの設定

  1. メッセージ ポート ウィザードの [送信先組織] ページで、次のいずれかの手順を実行します。
    • オープンなメッセージ ポートを作成する場合は、[オープンな送信先] をクリックし、[次へ] をクリックします。

      オープンなメッセージ ポートの場合は、ドキュメントまたはドキュメントで送信するパラメータにトランスポート情報および送信先情報を指定する必要があります。詳細については、「送信」を参照してください。

    • 特定の取引先組織を送信先に指定する場合は、手順 2. に進みます。
  2. [組織] の [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. 組織をクリックし、[OK] をクリックします。

    詳細については、「送信先組織の選択」を参照してください。

  4. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  5. プライマリ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

  6. ドキュメントのトランスポート可能時間を限定するには、[プライマリ トランスポート] の [サービス時間帯] チェック ボックスをオンにします。

    [開始] および [終了] ボックスで時間をクリックして値を入力するか、上矢印または下矢印で値を増減します。

  7. セカンダリ トランスポートを指定する場合は、[バックアップ トランスポート] の [参照] をクリックします。

    [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  8. バックアップ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。変更が完了したら、[完了] をクリックします。

重要

  • オープンなメッセージ ポートであることを宣言する場合は、X12 または EDIFACT 仕様の送信ドキュメント定義を持つメッセージ ポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元および送信先の組織識別子を指定する必要があります。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報は含まれません。

注

  • サービス時間帯の時間は、サーバー上の時間を表しており、世界標準時 (UTC) 形式で示されます。

関連項目

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


送信先アプリケーションのプロパティの設定

  1. メッセージ ポート ウィザードの [送信先アプリケーション] ページで、次のいずれかの手順を実行します。
    • 特定の XLANG スケジュールの新しいインスタンスのポートを送信先に指定する場合は、[新しい XLANG スケジュール] をクリックします。[スケジュール モニカ] ボックスに、指定されたスケジュールのモニカを入力するか、[参照] をクリックしてそのパスを設定します。[ポート名] ボックスに、このスケジュールにあるドキュメントに関する特定の送信先ポートの名前を入力します。

      スケジュール モニカの構文は次のとおりです。

      sked://[localhost][!GroupManager][/FilePath][/PortName]

      XLANG スケジュールは、ローカル コンピュータでのみアクティブにできます。

      モニカの詳細については、「モニカの構文」を参照してください。

    • アクティブな XLANG スケジュール インスタンスを送信先に指定する場合は、[実行中の XLANG スケジュール] をクリックします。この方法は、取引先がメッセージを HTTP トランスポートを用いる特別に構成された ASP ページに返信する場合に、アクティブな XLANG スケジュールにメッセージをトランスポートするためにのみ利用します。詳細については、「BizTalk サービスの統合」を参照してください。

    • 既定の組織のアプリケーションを送信先に指定する場合は、[名前] ボックスの一覧にあるアプリケーションをクリックします。
  2. アプリケーションを送信先として選択した場合は、手順 3. ～ 5. を実行します。アプリケーション以外を送信先として選択した場合は、[次へ] をクリックします。

  3. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  4. プライマリ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

  5. ドキュメントのトランスポート可能時間を限定するには、[プライマリ トランスポート] の [サービス時間帯] チェック ボックスをオンにします。

    [開始] および [終了] ボックスで時間をクリックして値を入力するか、上矢印または下矢印で値を増減します。

  6. セカンダリ トランスポートを指定する場合は、[バックアップ トランスポート] の [参照] をクリックします。

    [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  7. バックアップ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。変更が完了したら、[完了] をクリックします。

重要

  • [新しい XLANG スケジュール] オプションを選択した場合は次の点に注意してください。
    • ポートに名前を付ける場合は、指定されたスケジュールの BizTalk メッセージにポートをバインドする必要があります。その際、メッセージが受信されると新しいスケジュールのインスタンスがアクティブになるようにバインドを構成する必要があります。

    • メッセージが受信されると新しいスケジュールのインスタンスがアクティブになる構成のポートは、1 スケジュールにつき 1 つとし、この動作がスケジュールの最初のアクションになるようにします。詳細については、「BizTalk メッセージを使用したポートの実装」を参照してください。

注

  • XLANG スケジュールをポートの送信先に選択した場合、そのポートで処理できるドキュメントの大きさの限度は 2 MB になります。

  • XLANG スケジュールの作成には BizTalk オーケストレーション デザイナを使用します。

  • サービス時間帯の時間は、サーバー上の時間を表しており、世界標準時 (UTC) 形式で示されます。

関連項目

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


エンベロープ情報のプロパティの設定

  1. メッセージ ポート ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] にある一覧からエンベロープを選択します。

    X12 書式または EDIFACT 書式のエンベロープを選択した場合は、次の手順を実行する必要があります。カスタム書式のエンベロープを選択した場合は、次の手順を省略できます。

    1. [区切り記号] をクリックし、区切り記号のプロパティを設定します。

      詳細については、「エンベロープの区切り記号の設定」を参照してください。

    2. [インターチェンジ制御番号] ボックスに、インターチェンジ制御番号を入力します。
  2. 送信先組織の既定の組織識別子を上書きする場合は、[組織の識別子] ボックスの一覧で別の識別子をクリックします。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。変更が完了したら、[完了] をクリックします。

重要

  • Reliable 書式のエンベロープを選択した場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスの [信頼できるメッセージの返信先 URL] アドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  • メッセージ ポートに指定するエンベロープの書式は、エンベロープが格納されるドキュメントの書式と一致する必要があります。ドキュメント形式は、関連付けられたチャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。

注

  • BizTalk Framework 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2000 はエンドポイントと考えてください。アプリケーションまたは取引先から、BizTalk Framework 2.0 に準拠したドキュメントが BizTalk Server 2000 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

  • アプリケーションへのメッセージ ポートの場合、[組織の識別子] ボックスの一覧から選択できる組織識別子は既定の組織の場合と同じです。

  • ループバック トランスポートを使用した場合、Reliable 書式のエンベロープは選択できません。

  • X12 エンベロープで使用する送信先組織識別子を選択する場合、"組織" という名前の組織識別子、3 文字以上の修飾子を持つ識別子、または 16 文字以上の値を持つ識別子は選択しないでください。

  • EDIFACT エンベロープで使用する送信先組織識別子を選択する場合、"組織" という名前の組織識別子、5 文字以上の修飾子を持つ識別子、および 36 文字以上の値を持つ識別子は選択しないでください。

  • EDIFACT 書式のエンベロープを選択した場合、既定の構文識別子は UNOA (大文字のラテン文字) です。別の構文を使用する場合は、チャネル ウィザードでメッセージ ポートの既定値を上書きして別の構文識別子を選択します。詳細については、「メッセージ ポート既定値の変更」を参照してください。

関連項目

エンベロープの作成

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定

エンベロープについて


セキュリティ情報のプロパティの設定

  1. メッセージ ポート ウィザードの [セキュリティ情報] ページで、[エンコード] の [種類] ボックスの一覧から、次のいずれかをクリックします。
    • [(なし)] : エンコードは指定されません。これは既定の設定です。

    • [MIME] : MIME (Multipurpose Internet Mail Extensions) を使用するエンコードが指定されます。

    • [カスタム] : カスタム エンコード コンポーネントを使用するエンコードが指定されます。

    注

    • カスタム エンコード コンポーネントを指定し、クラス識別子 (CLSID) を構成する場合は、BizTalk メッセージ構成オブジェクト モデルを使用します。

    • 添付ドキュメントがない場合に、Reliable 書式のエンベロープやエンベロープ仕様が指定されていないカスタム XML 書式のエンベロープを指定すると、MIME エンコードを指定したときでも出力は MIME エンコードされません。
  2. [暗号化] の [種類] ボックスの一覧から、次のいずれかをクリックします。
    • [(なし)] : 暗号化は指定されません。これは既定の設定です。

    • [S/MIME] : S/MIME (Secure Multipurpose Internet Mail Extensions) を使用するエンコードが指定されます。

    • [カスタム] : カスタム暗号化コンポーネントを使用するエンコードが指定されます。

    注

    • カスタム暗号化コンポーネントを指定し、クラス識別子 (CSLID) を構成する場合は、BizTalk メッセージ構成オブジェクト モデルを使用します。
  3. S/MIME 暗号化を選択した場合は、[暗号化] の [参照] をクリックします。

    [暗号化証明書の選択] ダイアログ ボックスが表示されます。

  4. 暗号化証明書を選択します。

    詳細については、「暗号化証明書の選択」を参照してください。

  5. [署名] の [種類] ボックスの一覧から、次のいずれかをクリックします。
    • [(なし)] : 署名は指定されません。これは既定の設定です。

    • [S/MIME] : S/MIME (Secure Multipurpose Internet Mail Extensions) を使用する署名が指定されます。

    • [カスタム] : カスタム署名コンポーネントを使用するエンコードが指定されます。

    注

    • カスタム署名コンポーネントを指定し、クラス識別子 (CSLID) を構成する場合は、BizTalk メッセージ構成オブジェクト モデルを使用します。
  6. チャネル ウィザードに直接進まずにチャネルを作成する場合は、[このメッセージ ポート用のチャネルの作成] チェック ボックスをオフにします。チャネル ウィザードに直接進む場合は、[チャネルの種類] ボックスの一覧から次のいずれかのチャネルの種類を選択します。
    • [組織から]

    • [アプリケーションから]

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。変更が完了したら、[完了] をクリックします。

関連項目

チャネルの作成

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


送信先組織の選択

  1. メッセージ ポート ウィザードの [送信先組織] ページで、[組織] をクリックし、[参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  2. [利用可能な組織] ボックスの一覧で組織をクリックし、[OK] をクリックします。

送信先組織のプロパティの設定を続けるには、「送信先組織のプロパティの設定」に進んでください。

関連項目

メッセージ ポートの作成

送信先組織のプロパティの設定

メッセージ ポートのプロパティの設定


暗号化証明書の選択

  1. メッセージ ポート ウィザードの [セキュリティ情報] ページで、[暗号化] の [種類] ボックスの一覧から [S/MIME] をクリックし、[参照] をクリックします。

    [暗号化証明書の選択] ダイアログ ボックスが表示されます。

  2. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

セキュリティのプロパティの設定を続けるには、「セキュリティ情報のプロパティの設定」に進んでください。

注

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

メッセージ ポートの作成

メッセージ ポートのプロパティの設定

セキュリティ情報のプロパティの設定


トランスポートのプロパティの設定

トランスポートのプロパティにはトランスポートの種類が含まれます。トランスポートの種類では、メッセージ ポートに指定された送信先に Microsoft BizTalk Server 2000 でドキュメントを送信する際に使用するトランスポート サービスを指定します。トランスポートのプロパティには、データの送信先アドレスを含めることもできます。このアドレスのプロパティは、選択したトランスポートの種類によって異なります。

ここでは、メッセージ ポートのプライマリ トランスポートとバックアップ トランスポートを設定する方法を説明します。ここには次のトピックが含まれます。

  • トランスポートの種類の選択

  • トランスポート アドレスの指定

  • アプリケーション統合コンポーネントの選択


トランスポートの種類の選択

  1. メッセージ ポート ウィザードの [送信先アプリケーション] または [送信先組織] のページで、[プライマリ トランスポート] または [バックアップ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスまたは [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  2. [トランスポートの種類] ボックスの一覧から、次のトランスポートのいずれかをクリックします。
    • [アプリケーション統合コンポーネント] : BizTalk Server 2000 に登録したアプリケーション統合コンポーネントを使用するトランスポートが指定されます。

    • [ファイル] : SendLocalFile コンポーネントを使用するトランスポートが指定されます。

    • [HTTP] : Hypertext Transfer Protocol を使用するトランスポートが指定されます。

    • [HTTPS] : Secure Hypertext Transfer Protocol を使用するトランスポートが指定されます。

    • [ループバック] : 送信同期呼び出しで受信ドキュメントを送信する業務用アプリケーション、コンポーネント、または XLANG スケジュールに、チャネルの送信ドキュメントを戻すトランスポートが指定されます。このトランスポートが使用できるのは、アプリケーションにドキュメントを送信するメッセージ ポートのみです。

    • [メッセージ キュー] : メッセージ キュー サービスを使用するトランスポートが指定されます。

    • [SMTP] : Simple Mail Transfer Protocol を使用するトランスポートが指定されます。
  3. 次の手順のいずれかを行ってください。
    • トランスポートの種類にアプリケーション統合コンポーネントを選択する場合は、「アプリケーション統合コンポーネントの選択」を参照してください。

    • トランスポートの種類にループバックを選択する場合、トランスポートのアドレスは必要ありません。

    • アプリケーション統合コンポーネントおよびループバック以外のトランスポートの種類を選択する場合は、「トランスポート アドレスの指定」を参照してください。

注

  • トランスポートの種類としてメッセージ キューを選択し、かつエンベロープを使用しない場合、そのメッセージ ポートで処理できるドキュメントの大きさの限度は 2 MB になります。

  • トランスポートの種類としてメッセージ キューを選択し、かつエンベロープを使用する場合、そのメッセージ ポートで処理できるドキュメントの大きさの限度は 4 MB になります。

  • SMTP トランスポートを選択する場合は、あらかじめ BizTalk 管理コンソールで SMTP ホストを構成しておく必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  • HTTP トランスポート コンポーネントの既定の設定は、HTTP プロキシ サーバーを使用するようになっています。これは、企業のファイアウォールの外部にある Web サイトにデータをトランスポートするのに適した設定です。会社のファイアウォールの内部にある (つまりイントラネット内の) Web サイトにデータをトランスポートするには、チャネルの既定の設定を変更します。詳細については、「メッセージ ポート既定値の変更」を参照してください。

  • ループバック トランスポートは、受信ドキュメントを別の書式にマップした上で、セキュリティ (エンコード、暗号化、デジタル署名) をエンベロープ化または適用し、呼び出し元に同時に送信ドキュメントが戻されるようにする場合に使用します。

  • ループバック トランスポートを選択した場合、Reliable 書式のエンベロープは使用できません。.

関連項目

メッセージ ポートの作成

アプリケーション統合コンポーネントの選択

メッセージ ポートのプロパティの設定

トランスポートのプロパティの設定

トランスポート アドレスの指定


トランスポート アドレスの指定

  1. メッセージ ポート ウィザードの [送信先アプリケーション] または [送信先組織] のページで、[プライマリ トランスポート] または [バックアップ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスまたは [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  2. [トランスポートの種類] ボックスの一覧で、ループバックおよびアプリケーション統合コンポーネント以外のトランスポートの種類をクリックします。

  3. [アドレス] ボックスに、送信先のアドレスを入力します。

  4. SMTP トランスポートを選択した場合は、[差出人電子メール アドレス] にアドレスを入力します。

    送信ヘッダーの送信元アドレスと、差出人電子メールの送信先にはここで入力したアドレスが使用されます。

送信先組織のプロパティの設定を続けるには、「送信先組織のプロパティの設定」に進んでください。

重要

  • ファイル トランスポートの場合、既定のトランスポート コンポーネントの設定では、指定されたディレクトリの既存のファイルに新しいファイルが追加されます。

  • ファイル トランスポートで同一名の複数のファイルを同じディレクトリに送信する場合、ファイルのドキュメント書式やコード ページが異なっていると内部のデータが破損します。

  • 各ドキュメントのインスタンスに新しいファイルを作成する場合は、次のファイル パス書式を使用する必要があります。

    file://C:\dir\file%tracking_id%.xml

注

  • メッセージ キュー以外のトランスポートでは、アドレスのプレフィックスが自動的に作成されます。このプレフィックスは必須であり削除できません。

  • メッセージ キュー トランスポートの場合、アドレスを有効にするには次の条件を満たす必要があります。
    • アドレスにプレフィックス queue:// は使用しないでください。

    • パスではなく書式名を使用します。有効な書式名を次に示します。

      DIRECT=Protocol:<ServerName>\<QueueName>

      PUBLIC=QueueGUID

      PRIVATE=MachineGUID\QueueNumber

      メッセージ キューの詳細については、Microsoft の Web サイト (msdn.microsoft.com/library/) で、"Message Queuing" を検索してください。

  • ファイル トランスポートの場合、アドレスを有効にするには次の条件を満たす必要があります。
    • 存在するファイル パスを指定する必要があります。ファイル パスは自動的に作成されないため、ファイル パスが存在しないことを知らせる警告を受け取りません。

    • ファイル名は拡張子付きで指定する必要があります。

      有効なファイル パスの例を示します。

      file://C:\dir\file.xml

  • ファイル トランスポートの場合、文字や記号を組み込んで動的にファイル名を変更できます。サーバーで作成されたファイル名には、[アドレス] ボックスに入力した静的な文字のほか、記号の値が含まれています。たとえば、[アドレス] ボックスに「file://C:\Orders\Invoice_%tracking_id%.xml」と入力すると、ファイル名は C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF} と表示されます。

    ファイル トランスポートで使用できる記号を次の表に示します。
    記号 | 説明 | 一意なファイル名
    %datetime% | ファイル作成の日時 (ミリ秒単位)。ローカル時間ではなくグリニッジ標準時 (GMT) が使用されます。 | なし
    %document_name% | BizTalk Server で処理されたドキュメントの名前。 | なし
    %server% | ドキュメントを処理したサーバーの名前。 | なし
    %tracking_id% | 一意なグローバル追跡番号。 | あり
    %uid% | 時間の経過に従って増加するカウンタ (ミリ秒単位)。この数値はサーバーを再起動するとリセットされます。 | なし

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。メッセージ ポートで既定の設定になっているファイル トランスポートの種類を使用し、BizTalk Server 2000 がインストールされているサーバーでウィルス対策ソフトウェアを使用していて、正確に同じ名前の複数のファイルを同じファイル位置に同時に送信すると、BizTalk Server 2000 が応答しなくなることがあり、その場合再起動する必要があります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで 、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。この問題は、メッセージ ポートのファイル パス形式 (file://C:\dir\file%tracking_id%.xml) を使用して処理されるドキュメント インスタンスごとに一意なファイルを作成することで解決することもできます。チャネルの詳細なプロパティでファイル トランスポート コンポーネントの追加設定を変更する方法の詳細については、「メッセージ ポート既定値の変更」を参照してください。

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。既定の設定のファイル トランスポートの種類を選択し、メッセージ ポートで Reliable エンベロープ書式のエンベロープを選択して、複数のファイルを同時に同じファイル位置に送信すると、予期しない解析結果を生じることがあります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。チャネルの詳細なプロパティでファイル トランスポート コンポーネントの追加設定を変更する方法の詳細については、「メッセージ ポート既定値の変更」を参照してください。

関連項目

メッセージ ポートの作成

アプリケーション統合コンポーネントの選択

トランスポートの種類の選択

メッセージ ポートのプロパティの設定

トランスポートのプロパティの設定


アプリケーション統合コンポーネントの選択

  1. メッセージ ポート ウィザードの [送信先アプリケーション] または [送信先組織] のページで、[プライマリ トランスポート] または [バックアップ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスまたは [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  2. [トランスポートの種類] ボックスの一覧で、[アプリケーション統合コンポーネント] をクリックします。

  3. [コンポーネント名] ボックスの右側にある [参照] をクリックします。

    [コンポーネントの選択] ダイアログ ボックスが表示されます。

  4. [利用可能なコンポーネント] ボックスの一覧で、コンポーネントをクリックし、[OK] をクリックします。

送信先組織のプロパティの設定を続けるには、「送信先組織のプロパティの設定」に進んでください。

注

  • アプリケーション統合コンポーネントが [利用可能なコンポーネント] ボックスの一覧に表示されるようにするには、BizTalk Server 2000 に登録する必要があります。詳細については、「アプリケーション統合コンポーネントの登録」を参照してください。

関連項目

メッセージ ポートの作成

トランスポートの種類の選択

メッセージ ポートのプロパティの設定

トランスポートのプロパティの設定

トランスポート アドレスの指定


エンベロープの区切り記号の設定

区切り記号のプロパティには、エンベロープ内のデータやインターチェンジのドキュメントを区切る際に使用する文字を指定します。区切り記号が必要になるのは、X12 書式および EDIFACT 書式のエンベロープのみです。カスタム書式のエンベロープの場合は、区切り記号を省略できます。

エンベロープの区切り記号は、メッセージ ポートにエンベロープを選択した場合に設定されます。 あるメッセージ ポート用に設定された区切り記号は、そのメッセージ ポートにのみ適用されます。同じエンベロープでも使用されるメッセージ ポートが異なる場合は、それぞれに異なる区切り記号が設定できます。ここでは、区切り記号のプロパティを設定する方法について説明します。ここには次のトピックが含まれます。

  • X12 区切り記号の設定

  • EDIFACT 区切り記号の設定

  • Custom 区切り記号の設定


X12 区切り記号の設定

  1. メッセージ ポート ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] から X12 書式のエンベロープを選択し、[区切り記号] をクリックします。

    [X12 区切り記号] ダイアログ ボックスが表示されます。

  2. [文字] ボックスまたは [16 進変換] ボックスのいずれかに区切り記号値を入力し、[OK] をクリックします。

X12 区切り記号の説明を次の表に示します。

区切り記号 (デリミタ) | 説明
コンポーネント要素 (エレメント) の区切り記号 (セパレーター) | 複合 (コンポジット) データ フィールドのデータのコンポーネントを区切る際に使用する文字を指定します。複合データ フィールドは、複数のサブフィールドで構成されるフィールドです。
要素 (エレメント) 区切り記号 (セパレーター) | レコードのデータ フィールドを区切る際に使用する文字を指定します。
セグメント終端記号 (ターミネーター) | レコードの終わりを示す際に使用する文字を指定します。

送信先組織のプロパティの設定を続けるには、「エンベロープ情報のプロパティの設定」に進んでください。

注

  • 各区切り記号には、 [文字] ボックスに 1 つの文字または [16 進変換] ボックスに 2 つの文字のいずれかを入力できます。[16 進変換] ボックスは、Enter キーなどの非印刷文字の区切り記号を入力するのに使用できます。

関連項目

メッセージ ポートの作成

Custom 区切り記号の設定

EDIFACT 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定


EDIFACT 区切り記号の設定

  1. メッセージ ポート ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] から EDIFACT 書式のエンベロープを選択し、[区切り記号] をクリックします。

    [EDIFACT 区切り記号] ダイアログ ボックスが表示されます。

  2. [文字] ボックスまたは [16 進変換] ボックスのいずれかに区切り記号値を入力し、[OK] をクリックします。

EDIFACT 区切り記号の説明を次の表に示します。

区切り記号 (サービス ストリング) | 説明
コンポーネント要素 (エレメント) の区切り記号 (セパレーター) | 複合データ フィールドのデータのコンポーネントを区切る際に使用する文字を指定します。複合データ フィールドは、複数のサブフィールドで構成されるフィールドです。
要素 (エレメント) 区切り記号 (セパレーター) | レコードのデータ フィールドを区切る際に使用する文字を指定します。
リリース インジケータ (リソース キャラクター) | 次に続く文字を区切り記号として評価しないことを示す際に使用する文字を指定します。
セグメント終端記号 (ターミネーター) | レコードの終わりを示す際に使用する文字を指定します。

注

  • EDIFACT リリース インジケータを使用する場合、データ内にリリース インジケータ文字を含めないでください。リリース インジケータ文字を含めると、データがフィールドに設定された文字物理サイズを超過することがあります。

  • 各区切り記号には、 [文字] ボックスに 1 つの文字または [16 進変換] ボックスに 2 つの文字のいずれかを入力できます。[16 進変換] ボックスは、Enter キーなどの非印刷文字の区切り記号を入力するのに使用できます。

  • EDIFACT の小数点記号 (デシマル マーク） は使用できません。

送信先組織のプロパティの設定を続けるには、「エンベロープ情報のプロパティの設定」に進んでください。

関連項目

メッセージ ポートの作成

Custom 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定

X12 区切り記号の設定


Custom 区切り記号の設定

  1. メッセージ ポート ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] からカスタム書式のエンベロープを選択し、[区切り記号] をクリックします。

    [Custom 区切り記号] ダイアログ ボックスが表示されます。

  2. [文字] ボックスまたは [16 進変換] ボックスのいずれかに区切り記号値を入力し、[OK] をクリックします。

Custom 区切り記号の説明を次の表に示します。

区切り記号 | 説明
サブフィールド | マルチパート データ フィールドのデータのコンポーネントを区切る際に使用する文字を指定します。
フィールド | レコードのデータ フィールドを区切る際に使用する文字を指定します。
エスケープ文字 | 次に続く文字を区切り記号として評価しないことを示す際に使用する文字を指定します。
レコード | レコードの終わりを示す際に使用する文字を指定します。

注

  • 各区切り記号には、 [文字] ボックスに 1 つの文字または [16 進変換] ボックスに 2 つの文字のいずれかを入力できます。[16 進変換] ボックスは、Enter キーなどの非印刷文字の区切り記号を入力するのに使用できます。

送信先組織のプロパティの設定を続けるには、「エンベロープ情報のプロパティの設定」に進んでください。

関連項目

メッセージ ポートの作成

EDIFACT 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定

X12 区切り記号の設定


組織の作成と管理

ここでは、組織を作成し、管理する方法を作業ごとに説明します。「概念」の「組織について」を参照し、組織について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • 既定の組織の構成

  • 組織の作成

  • 組織の検索

  • 組織の編集

  • 組織の削除

  • 組織のプロパティの設定


既定の組織の構成

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [全般] タブで、組織の全般的なプロパティを設定します。

    詳細については、「組織の全般的なプロパティの設定」を参照してください。

  5. [識別子] タブをクリックし、組織識別子のプロパティを設定します。

    詳細については、「組織識別子のプロパティの設定」を参照してください。

  6. [アプリケーション] タブをクリックし、アプリケーションのプロパティを設定します。

    詳細については、「アプリケーションのプロパティの設定」を参照してください。

  7. 既定の組織の必要なプロパティをすべて設定し終わったら、[OK] をクリックして [組織のプロパティ] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子に指定された値が送信元アドレスとして使用されます。信頼できるメッセージ受信確認の詳細については信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「オープンネス」を参照してください。

注

  • 既定の組織の名前は、いつでも任意の名前に変更できます。

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションを追加できます。

関連項目

組織の編集

組織の検索

アプリケーションのプロパティの設定

組織のプロパティの設定

組織について


組織の作成

  1. BizTalk メッセージ マネージャで、[ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。

    [新しい組織] ダイアログ ボックスが表示されます。

  2. [全般] タブで、組織の全般的なプロパティを設定します。

    詳細については、「組織の全般的なプロパティの設定」を参照してください。

  3. [識別子] タブをクリックし、組織識別子のプロパティを設定します。

    詳細については、「組織識別子のプロパティの設定」を参照してください。

  4. 必要なプロパティをすべて設定し終わったら、[OK] をクリックして [新しい組織] ダイアログ ボックスを閉じます。

関連項目

既定の組織の構成

組織の削除

組織の編集

組織の検索

組織のプロパティの設定

組織について


組織の検索

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべての組織を検索するには、検索条件をすべて消去し、[検索] をクリックします。

    • 特定の名前の組織を検索するには、[組織の検索] でその組織の名前を [組織名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 既定の組織のみを検索するには、[既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

注

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件には、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

組織の削除

組織の編集

組織について


組織の編集

  1. BizTalk メッセージ マネージャの [組織名] ボックスの一覧で、編集する組織をクリックします。

    組織の検索については、「組織の検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  3. [全般] タブで、変更が必要なプロパティを編集します。

    詳細については、「組織の全般的なプロパティの設定」を参照してください。

  4. [識別子] タブをクリックし、変更が必要な組織識別子のプロパティを編集します。

    詳細については、「組織識別子のプロパティの設定」を参照してください。

  5. 既定の組織を編集する場合は、[アプリケーション] タブをクリックし、変更が必要なアプリケーション プロパティを編集します。

    詳細については、「アプリケーションのプロパティの設定」を参照してください。

  6. 変更が必要なプロパティを編集し終わったら、[OK] をクリックして [組織のプロパティ] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子に指定された値が送信元アドレスとして使用されます。信頼できるメッセージ受信確認の詳細については信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「オープンネス」を参照してください。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションを追加できます。

関連項目

組織の作成

組織の削除

組織の検索

組織について


組織の削除

  1. BizTalk メッセージ マネージャの [組織名] ボックスの一覧で、削除する組織をクリックします。

    組織の検索の詳細については、「組織の検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • メッセージ ポートまたはチャネルで使用されている組織は削除できません。あらかじめ、その組織が使用されているチャネルおよびメッセージ ポートをすべて削除しておく必要があります。

  • 既定の組織は削除できません。

関連項目

組織の作成

組織の編集

組織の検索

組織について


組織のプロパティの設定

ここでは、組織のプロパティを構成する方法を作業ごとに説明します。ここには次のトピックが含まれます。

  • 組織の全般的なプロパティの設定

  • 組織識別子のプロパティの設定

  • アプリケーションのプロパティの設定


組織の全般的なプロパティの設定

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [全般] タブの [組織名] ボックスに、組織の一意な名前を入力します。

  3. [コメント] ボックスに、組織に関するコメントを入力します。

関連項目

既定の組織の構成

組織の作成

組織の編集

組織のプロパティの設定


組織識別子のプロパティの設定

組織識別子は組織を一意に識別するために使用されます。組織には複数の組織識別子を設定できますが、各識別子はその組織に固有のものにする必要があります。

新しい組織を作成すると、"組織" という名前の組織識別子が自動的に作成されます。この識別子の修飾子は OrganizationName で、値は組織に付けた名前になります。追加の識別子を作成し、そのうちの 1 つを既定の識別子に指定しない限り、"組織" が既定の識別子として使用されます。

ここには次のトピックが含まれます。

  • 組織識別子の追加

  • 組織識別子の編集

  • 組織識別子の削除

関連項目

既定の組織の構成

組織の作成

組織の編集

組織識別子

組織のプロパティの設定


組織識別子の追加

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [識別子] タブをクリックし、[追加] をクリックします。

    [新しい識別子] ダイアログ ボックスが表示されます。

  3. [名前] で次のいずれかの操作を行います。
    • [標準] をクリックし、一覧にある名前を 1 つクリックします。

    • [カスタム] をクリックし、ボックスに一意な名前を入力します。名前を入力したら、[修飾子] ボックスに識別子の修飾子を入力します。
  4. [値] ボックスに識別子の値を入力します。

  5. この識別子を組織の既定の識別子に設定する場合は、[既定値として設定] チェック ボックスをオンにします。既定の識別子に設定しない場合、このチェック ボックスはオフにしてください。

  6. [OK] をクリックして [新しい識別子] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子に指定された値が送信元アドレスとして使用されます。詳細については、「信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「オープンネス」を参照してください。

注

  • 組織の既定の識別子は 1 つしか指定できません。チャネルまたはメッセージ ポートに別の組織識別子を指定しない限り、組織の識別では既定の識別子が使用されます。

  • 新しい組織を作成すると、"組織" という名前の組織識別子が自動的に作成されます。この識別子の修飾子は OrganizationName で、値は組織の名前になります。追加の識別子を作成することはできますが、この識別子は変更も削除もできません。

  • サーバーで EDIFACT 以外の形式の受信ドキュメントを処理する場合に、空の修飾子と空でない値が検出されたときは、空の修飾子が OrganizationName に変換されます。

  • サーバーで EDIFACT 形式の受信ドキュメントを処理する場合に、空の修飾子と空でない値が検出されたときは、空の修飾子がダッシュ (-) に変換されます。空の修飾子を持つ EDIFACT 形式の受信ドキュメント、または空の修飾子を持つ送信エンベロープを処理する場合は、1 個のダッシュ (-) を修飾子にしたカスタム組織識別子を作成する必要があります。EDIFACT 送信ドキュメントの場合は、このダッシュが空の修飾子に変換されます。

  • EDIFACT エンベロープで使用する組織識別子を作成する場合、修飾子は 4 文字以下、値は 35 文字以下にする必要があります。

  • ANSI X12 エンベロープで使用する組織識別子を作成する場合、修飾子は 2 文字以下、値は 15 文字以下にする必要があります。

関連項目

既定の組織の構成

組織の作成

組織識別子の編集

組織の編集

組織識別子

組織識別子の削除

組織識別子のプロパティの設定


組織識別子の編集

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [識別子] タブをクリックします。

  3. [組織の識別子] ボックスの一覧で、編集する組織識別子をクリックし、[編集] をクリックします。

    [識別子のプロパティ] ダイアログ ボックスが表示されます。

  4. [名前] で次のいずれかの操作を行います。
    • [標準] をクリックし、一覧にある名前を 1 つクリックします。

    • [カスタム] をクリックし、ボックスに一意な名前を入力します。名前を入力したら、[修飾子] ボックスに識別子の修飾子を入力します。
  5. [値] ボックスに識別子の値を入力します。

  6. この識別子を組織の既定の識別子に設定する場合は、[既定値として設定] チェック ボックスをオンにします。既定の識別子に設定しない場合、このチェック ボックスはオフにしてください。

  7. [OK] をクリックして [識別子のプロパティ] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子の名前または修飾子は変更できませんが、値は変更することができます。この識別子は削除できません。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子の値が送信元アドレスとして使用されます。詳細については、「信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「オープンネス」を参照してください。

注

  • 組織の既定の識別子は 1 つしか指定できません。チャネルまたはメッセージ ポートに別の組織識別子を指定しない限り、組織の識別では既定の識別子が使用されます。

  • 新しい組織を作成すると、"組織" という名前の組織識別子が自動的に作成されます。この識別子の修飾子は OrganizationName で、値は組織の名前になります。追加の識別子を作成することはできますが、この識別子は変更も削除もできません。

  • サーバーで EDIFACT 以外の形式の受信ドキュメントを処理する場合に、空の修飾子と空でない値が検出されたときは、空の修飾子が OrganizationName に変換されます。

  • サーバーで EDIFACT 形式の受信ドキュメントを処理する場合に、空の修飾子と空でない値が検出されたときは、空の修飾子がダッシュ (-) に変換されます。空の修飾子を持つ EDIFACT 形式の受信ドキュメント、または空の修飾子を持つ送信エンベロープを処理する場合は、1 個のダッシュ (-) を修飾子にしたカスタム組織識別子を作成する必要があります。EDIFACT 送信ドキュメントの場合は、このダッシュが空の修飾子に変換されます。

  • EDIFACT エンベロープで使用する組織識別子を作成する場合、修飾子は 4 文字以下、値は 35 文字以下にする必要があります。

  • ANSI X12 エンベロープで使用する組織識別子を作成する場合、修飾子は 2 文字以下、値は 15 文字以下にする必要があります。

関連項目

組織識別子の追加

既定の組織の構成

組織の作成

組織の編集

組織識別子

組織識別子の削除

組織識別子のプロパティの設定


組織識別子の削除

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [識別子] タブをクリックします。

  3. [組織の識別子] ボックスの一覧で、削除する組織識別子をクリックし、[削除] をクリックします。

注

  • 既定として指定した組織識別子は、別の識別子を既定に指定しない限り削除できません。

  • 新しい組織を作成すると、"組織" という組織識別子が自動的に作成されます。この組織識別子は削除できません。

関連項目

組織識別子の追加

既定の組織の構成

組織の作成

組織識別子の編集

組織の編集

組織識別子

組織識別子のプロパティの設定


アプリケーションのプロパティの設定

BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションを追加できます。作成したアプリケーションを利用して、BizTalk Server 2000 と業務で使用する既存の内部アプリケーションとの間で交換されるドキュメントの流れを把握し、追跡することができます。既定の組織のアプリケーションはチャネルに送信元アプリケーションとして、またはメッセージ ポートに送信先アプリケーションとして指定できます。

既定の組織には任意の数のアプリケーションを割り当てることができます。各アプリケーションの名前は、一意なものにする必要があります。ここには次のトピックが含まれます。

  • アプリケーションの追加

  • アプリケーションの編集

  • アプリケーションの削除

関連項目

既定の組織の構成

組織の編集

組織のプロパティの設定


アプリケーションの追加

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [アプリケーション] タブの [追加] をクリックします。

    [新しいアプリケーション] ダイアログ ボックスが表示されます。

  5. [アプリケーション名] ボックスにアプリケーションの一意な名前を入力し、[OK] をクリックします。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションの追加、編集、および削除ができます。

関連項目

既定の組織の構成

アプリケーションの編集

組織の編集

アプリケーションの削除

アプリケーションのプロパティの設定


アプリケーションの編集

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [アプリケーション] タブの [アプリケーション] のボックスの一覧で、編集するアプリケーションをクリックし、[編集] をクリックします。

    [アプリケーションのプロパティ] ダイアログ ボックスが表示されます。

  5. [アプリケーション名] ボックスにアプリケーションの一意な名前を入力し、[OK] をクリックします。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションの追加、編集、および削除ができます。

関連項目

アプリケーションの追加

既定の組織の構成

組織の編集

アプリケーションの削除

アプリケーションのプロパティの設定


アプリケーションの削除

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [アプリケーション] プロパティ ページの [アプリケーション] ボックスの一覧で、削除するアプリケーションをクリックし、[削除] をクリックします。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションの追加、編集、および削除ができます。

関連項目

アプリケーションの追加

既定の組織の構成

組織の編集

アプリケーションのプロパティの設定


ドキュメント定義の作成および管理

ここでは、ドキュメント定義を作成し、管理する方法を作業ごとに説明します。「概念」の「ドキュメント定義について」を参照し、ドキュメント定義について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • ドキュメント定義の作成

  • ドキュメント定義の検索

  • ドキュメント定義の編集

  • ドキュメント定義の削除

  • ドキュメント定義のプロパティの設定


ドキュメント定義の作成

  1. BizTalk メッセージ マネージャの [ファイル] メニューの [新規作成] をポイントし、[ドキュメント定義] をクリックします。

    [新しいドキュメント定義] ダイアログ ボックスが表示されます。

  2. [全般] タブで全般プロパティを設定します。

    詳細については、「ドキュメント定義の全般プロパティの設定」を参照してください。

  3. [グローバル追跡] タブをクリックし、追跡プロパティを設定します。

    詳細については、「グローバル追跡プロパティの設定」を参照してください。

  4. [選択条件] タブをクリックし、選択条件プロパティを設定します。

    詳細については、「選択条件プロパティの設定」を参照してください。

  5. 必要なプロパティをすべて設定してから、[OK] をクリックして [新しいドキュメント定義] ダイアログ ボックスを閉じます。

注

  • ドキュメント定義の [信頼できるメッセージ受信確認チャネル] と [BizTalk 既定受信] はどちらも予約システム名なので指定できません。

  • 仕様を選択しないと、ドキュメントに対するグローバル追跡項目を指定できません。

  • チャネル内のドキュメント定義を選択する場合は、追跡する仕様フィールドとして、そのチャネルに対するグローバル追跡項目とは異なるフィールドを選択することにより、そのグローバル追跡項目を無効にできます。詳細については、「チャネル内の仕様フィールドの選択」を参照してください。

  • ローカル ドメイン以外の仕様を参照するドキュメント定義を保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

ドキュメント定義の削除

ドキュメント定義の編集

ドキュメント定義の検索

ドキュメント定義について


ドキュメント定義の検索

  1. BizTalk メッセージ マネージャの [その他の項目を検索] で [ドキュメント定義] をクリックします。

  2. すべてのドキュメント定義を検索するには、検索条件をすべて消去し、[検索] をクリックします。

    または

    特定の名前のドキュメント定義を検索するには、検索するドキュメント定義の名前を [ドキュメント定義の検索] の [ドキュメント定義名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

注

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件では、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

ドキュメント定義の削除

ドキュメント定義の編集

ドキュメント定義について


ドキュメント定義の編集

  1. BizTalk メッセージ マネージャの [ドキュメント定義名] ボックスの一覧で、編集するドキュメント定義をクリックします。

    ドキュメント定義の検索の詳細については、「ドキュメント定義の検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [ドキュメント定義のプロパティ] ダイアログ ボックスが表示されます。

  3. [全般] タグで全般プロパティを編集します。

    詳細については、「ドキュメント定義の全般プロパティの設定」を参照してください。

  4. [グローバル追跡] タブをクリックし、追跡プロパティを編集します。

    詳細については、「グローバル追跡プロパティの設定」を参照してください。

  5. [選択条件] タブをクリックし、選択条件プロパティを設定します

    詳細については、「選択条件プロパティの設定」を参照してください。

  6. 変更が必要なプロパティを編集し終わったら、[OK] をクリックして [ドキュメント定義のプロパティ] ダイアログ ボックスを閉じます。

注

  • ドキュメント定義の [信頼できるメッセージ受信確認チャネル] と [BizTalk 既定受信] はどちらも予約システム名なので指定できません。

  • 仕様を選択しないと、ドキュメントに対するグローバル追跡項目を指定できません。

  • ローカル ドメインの外部にある仕様を参照するドキュメント定義を保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

ドキュメント定義の作成

ドキュメント定義の削除

ドキュメント定義の検索

ドキュメント定義について


ドキュメント定義の削除

  1. BizTalk メッセージ マネージャの [ドキュメント定義名] ボックスの一覧で、削除するドキュメント定義をクリックします。

    ドキュメント定義の検索の詳細については、「ドキュメント定義の検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • チャネル内でドキュメント定義を使用する場合は、そのドキュメント定義を削除できません。ドキュメント定義を使用するすべてのチャネルを最初に削除する必要があります。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義の検索

ドキュメント定義について


ドキュメント定義のプロパティの設定

ここでは、ドキュメント定義のプロパティを構成する方法を作業ごとに説明します。ここには次のトピックが含まれます。

  • ドキュメント定義の全般プロパティの設定

  • ドキュメント仕様の選択

  • グローバル追跡プロパティの設定

  • 選択条件プロパティの設定


ドキュメント定義の全般プロパティの設定

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [全般] タブをクリックします。

  2. [ドキュメント定義名] ボックスに一意なドキュメント定義名を入力します。

  3. [ドキュメント仕様] チェック ボックスをオンにします。

  4. [参照] をクリックし、ドキュメント仕様を選択します。

    詳細については、「ドキュメント仕様の選択」を参照してください。

注

  • ドキュメントに対して、ドキュメント仕様を選択することも、選択しないこともできます。ただし、仕様を選択しない場合は、グローバル追跡項目は設定できず、また、ドキュメント定義を使用して処理したデータは次の制約を受けます。
    • ネイティブ形式から XML への変換はされません。

    • 仕様に照らした検証は行われません。

    • マップを使用して別の構成または書式に変換できません。
  • バイナリ ファイルのような、上記の変換や検証を行うことが適切でないデータを処理する場合は、ドキュメント仕様を選択しないことをお勧めします。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義のプロパティの設定

ドキュメント定義について


ドキュメント仕様の選択

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [全般] タブをクリックします。

  2. [ドキュメント仕様] チェック ボックスをオンにし、[参照] をクリックします。

    [WebDAV リポジトリからのドキュメント仕様の選択] ダイアログ ボックスが表示されます。

  3. サーバーを変更する場合は、[サーバー] ボックスで次のどちらかの操作を行います。
    • 一覧に表示されているサーバーをクリックします。

    • サーバーの名前を入力し、Enter キーを押します。
  4. 目的の仕様が格納されているフォルダをダブルクリックし、その仕様のファイルをダブルクリックします。

重要

  • [WebDAV リポジトリ] ダイアログ ボックスを初めて開くときには、BizTalk メッセージ マネージャがリモート サーバー上のデータベースに接続されている場合でも、ローカル サーバー上の WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • サーバーとして http://localhost を選択すると、BizTalk メッセージ マネージャはそれを自動的にローカル コンピュータ名に変換します。

  • ドキュメント定義がオープンなメッセージ ポートに対するチャネル内の受信ドキュメント定義として使用され、そのドキュメント内で送信先情報が指定される場合は、そのドキュメント定義の参照先の仕様が適切に構成されている必要があります。オープンなメッセージ ポートのドキュメントを処理するためのドキュメント仕様を構成する方法については、「ディクショナリ プロパティの設定」を参照してください。

  • ドキュメント仕様は選択することも、選択しないこともできますが、ほとんどの場合は仕様を選択することをお勧めします。仕様を選択しない場合は、処理するデータが以下の制約を受けます。
    • データは、受信側で XML に変換されないか、または送信側で XML から変換されません。

    • データに誤りがないことを確認するための検証が行われません。

    • チャネル内でマップを使用してデータの構成または書式を変換することはできません。

    • ドキュメント定義に対するグローバル追跡項目を指定できません。
  • パススルー送信でドキュメント定義を使用する場合は、ドキュメント仕様は必要ありません。

  • リモート サーバー上の WebDAV に初めて接続するときには、多少の遅延が生じることがあります。

  • ローカル ドメインの外部にある仕様を参照するドキュメント定義を保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義のプロパティの設定

ドキュメント定義について


グローバル追跡プロパティの設定

[グローバル追跡項目] タブの [仕様フィールド] ボックスの一覧には、ドキュメント定義に対して選択した仕様のツリーが表示されます。この一覧を展開して仕様内のフィールドを表示することと、ログに記録するフィールド数の制限値を追跡データベースに指定することができます。

ドキュメント定義をチャネルに対する受信ドキュメント定義として選択すると、そのチャネルが処理するインスタンスごとに、これらのフィールドが追跡されます。これらのフィールドは、グローバル追跡項目と呼ばれます。チャネル内のドキュメント定義を選択する場合は、そのチャネルだけが処理するドキュメント インスタンスごとに、追跡する仕様フィールドとして、グローバル追跡項目とは異なるフィールドを選択することにより、そのグローバル追跡項目を無効にできます。

ここでは、ドキュメント定義の仕様フィールドを選択する方法を説明します。

ここには次のトピックが含まれます。

  • ドキュメント定義内の仕様フィールドの選択

  • ドキュメント定義内の仕様フィールドの削除

関連項目

ドキュメント データ フィールドの追跡

ドキュメント定義について


ドキュメント定義内の仕様フィールドの選択

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [グローバル追跡] タブをクリックします。

  2. [仕様フィールド] ボックスの一覧で、レコードの隣にある拡大インジケータ (+) をクリックするか、レコードをダブルクリックして、表示を拡大します。

  3. [追跡するフィールド] ボックスの一覧で追加する仕様フィールドをクリックし、次の手順のいずれかを実行します。
    追加するフィールドのデータ型 | 実行する手順
    整数 | [整数] をクリックします。整数型のフィールドを 2 つ追加できます。
    実数 | [実数] をクリックします。実数型のフィールドを 2 つ追加できます。
    日付 | [日付] をクリックします。日付型のフィールドを 2 つ追加できます。
    テキスト | [テキスト] をクリックします。テキスト型のフィールドを 2 つ追加できます。
    カスタム | [カスタム] をクリックします。カスタム データ型のフィールドをいくつでも追加できます。これらのフィールドは、フィールドごとにタグの付いた XML 連結文字列として格納されます。

注

  • 整数、実数、日付のいずれかのデータ型として追跡する仕様フィールドを選択するには、仕様の中でそのデータ型がフィールドに割り当てられている必要があります。仕様フィールドへのデータ型の割り当ての詳細については、「宣言のプロパティの設定」を参照してください。

  • 仕様フィールドのデータ型が、仕様内で割り当てられているデータ型でない場合は、そのフィールドはテキスト型またはカスタム データ型としてのみ追跡できます。

  • 追跡する仕様フィールドが文字データ型である場合は、そのフィールドはカスタム データ型としてのみ追跡できます。

  • チャネル内のドキュメント定義を選択する場合は、追跡する仕様フィールドとして、そのチャネルに対するグローバル追跡項目とは異なるフィールドを選択することにより、そのグローバル追跡項目を無効にできます。詳細については、「チャネル内の仕様フィールドの選択」を参照してください。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義内の仕様フィールドの削除

ドキュメント定義のプロパティの設定

グローバル追跡プロパティの設定

ドキュメント データ フィールドの追跡

ドキュメント定義について


ドキュメント定義内の仕様フィールドの削除

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [グローバル追跡] タブをクリックします。

  2. [追跡するフィールド] ボックスの一覧で、削除する仕様フィールドをクリックし、[削除] をクリックします。

注

  • 追跡するフィールドの一覧からフィールドを削除しても、そのフィールドはこのドキュメント定義の一覧から削除されるだけで、仕様からは削除されません。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義内の仕様フィールドの選択

ドキュメント定義のプロパティの設定

グローバル追跡プロパティの設定

ドキュメント データ フィールドの追跡

ドキュメント定義について


選択条件プロパティの設定

選択条件とは、BizTalk Server 2000 が EDI ドキュメントを処理するためにだけ使用する、名前と値の一意な組み合わせです。受信 X12 または EDIFACT ドキュメントに対して、サーバーは選択条件を使用して、ドキュメント定義を一意に識別するか、または選択します。それは、個々の EDI ドキュメント内ではドキュメント定義名を使用できないからです。

送信 X12 ドキュメントまたは送信 EDIFACT ドキュメントでは、グループ ヘッダー情報を作成するために選択条件を使用します。

ここには次のトピックが含まれます。

  • 選択条件の追加

  • 選択条件の編集

  • 選択条件の削除

関連項目

ドキュメント定義について

選択条件について


選択条件の追加

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [選択条件] タブをクリックし、[追加] をクリックします。

    [新しい名前と値] ダイアログ ボックスが表示されます。

  2. [名前] ボックスに選択条件の名前を入力します。

  3. [値] ボックスに選択条件の値を入力し、[OK] をクリックします。

重要

  • BizTalk Server 2000 が選択条件の値を受信インターチェンジの対応するヘッダー要素 (エレメント) と照合し、それらの値を送信インターチェンジのヘッダー要素 (エレメント) に正確に挿入するには、次の表に示されるとおりに選択条件を入力する必要があります。

    X12 ヘッダー要素 (エレメント)
    名前 | 要件 | GS 要素 (エレメント)
    functional_identifier | 必須 | GS01
    application_sender_code | 必須 | GS02
    application_receiver_code | 必須 | GS03
    standards_version | 必須 | GS08

    EDIFACT ヘッダー要素 (エレメント)
    名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
    functional_identifier | 必須 | S009、0065 | 0038
    application_sender_code | 省略可 | 未使用 | S006、0040
    application_receiver_code | 省略可 | 未使用 | S007、0044
    standards_version_type | 必須 | S009、0052 | S008、0052
    standards_version_value | 必須 | S009、0054 | S008、0054

  • 送信 EDIFACT インターチェンジに対して、メッセージ ヘッダー (UNH) が必ず作成されます。application_sender_code と application_receiver_code を指定する場合は、グループ ヘッダー (UNG) も作成されます。

  • 各ドキュメント定義に対して使用する選択条件の名前と値の組み合わせは、ドキュメント定義全体にわたって一意である必要があります。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

選択条件の編集

選択条件の削除

ドキュメント定義のプロパティの設定

選択条件プロパティの設定

ドキュメント定義について

選択条件について


選択条件の編集

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [選択条件] タブをクリックします。

  2. [選択条件] ボックスの一覧で、編集する選択基準をクリックし、[編集] をクリックします。

    [新しい名前と値のプロパティ] ダイアログ ボックスが表示されます。

  3. [名前] ボックスに選択条件の名前を入力します。

  4. [値] ボックスに選択条件の値を入力し、[OK] をクリックします。

重要

  • BizTalk Server 2000 が選択条件の値を受信インターチェンジの対応するヘッダー要素 (エレメント) と照合し、それらの値を送信インターチェンジのヘッダー要素 (エレメント) に正確に挿入するには、次の表に示されるとおりに選択条件を入力する必要があります。

    X12 ヘッダー要素 (エレメント)
    名前 | 要件 | GS 要素 (エレメント)
    functional_identifier | 必須 | GS01
    application_sender_code | 必須 | GS02
    application_receiver_code | 必須 | GS03
    standards_version | 必須 | GS08

    EDIFACT ヘッダー要素 (エレメント)
    名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
    functional_identifier | 必須 | S009, 0065 | 0038
    application_sender_code | 省略可 | 未使用 | S006、0040
    application_receiver_code | 省略可 | 未使用 | S007、0044
    standards_version_type | 必須 | S009、0052 | S008、0052
    standards_version_value | 必須 | S009、0054 | S008、0054

  • 送信 EDIFACT インターチェンジに対して、メッセージ ヘッダー (UNH) が必ず作成されます。application_sender_code と application_receiver_code を指定する場合は、グループ ヘッダー (UNG) も作成されます。

  • 各ドキュメント定義に対して使用する選択条件の名前と値の組み合わせは、ドキュメント定義全体にわたって一意である必要があります。

関連項目

選択条件の追加

選択条件の削除

選択条件プロパティの設定

ドキュメント定義について

選択条件について


選択条件の削除

  1. [ドキュメント定義のプロパティ] ダイアログ ボックスの [選択条件] タブをクリックします。

  2. [選択条件] ボックスの一覧で、削除する選択基準をクリックし、[削除] をクリックします。

関連項目

選択条件の追加

選択条件の編集

選択条件プロパティの設定

ドキュメント定義について

選択条件について


エンベロープの作成および管理

ここでは、エンベロープを作成し、管理する方法を作業ごとに説明します。「概念」の「エンベロープについて」を参照し、エンベロープについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • エンベロープの作成

  • エンベロープの検索

  • エンベロープの編集

  • エンベロープの削除

  • エンベロープ仕様の選択


エンベロープの作成

  1. BizTalk メッセージ マネージャで、[ファイル] メニューの [新規作成] をポイントし、[エンベロープ] をクリックします。

    [新しいエンベロープ] ダイアログ ボックスが表示されます。

  2. [エンベロープ名] ボックスに一意なエンベロープ名を入力します。

  3. [エンベロープ書式] ボックスの一覧で、次のいずれかのエンベロープ書式をクリックします。
    • CUSTOM XML

      カスタム XML 形式の受信インターチェンジを Microsoft BizTalk Server 2000 で処理できるようにするには、カスタム XML 形式と仕様参照を持つエンベロープを作成します。ただし、カスタム XML インターチェンジを送信する場合は、Submit 関数のパラメータにそのエンベロープ名を指定する必要はありません。BizTalk Server 2000 では、名前の指定がなくても適切なエンベロープを見つけることができます。

    • X12

      X12 書式のエンベロープを作成しなくても、X12 書式の受信インターチェンジを BizTalk Server 2000 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • EDIFACT

      EDIFACT 書式のエンベロープを作成しなくても、EDIFACT 書式の受信インターチェンジを BizTalk Server 2000 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • FLATFILE

      フラット ファイル書式の受信インターチェンジを BizTalk Server 2000 で処理できるようにするには、フラット ファイル書式のエンベロープを作成します。フラット ファイルの受信ドキュメントを送信する場合は、Submit 関数のパラメータにエンベロープ名を指定する必要があります。詳細については、「送信」を参照してください。

    • CUSTOM

      カスタム書式 (BizTalk Server 2000 で直接にはサポートされない書式) の受信インターチェンジを BizTalk Server 2000 で処理できるようにするには、カスタム パーサー コンポーネントを作成します。エンベロープを作成する必要があるのは、カスタム パーサーにエンベロープが必要な場合だけです。詳細については、「IBizTalkParserComponent インターフェイスの使用」を参照してください。

      カスタム書式の送信インターチェンジを BizTalk Server 2000 で処理できるようにするには、カスタム書式のエンベロープを作成し、メッセージ ポートでそのエンベロープを選択します。カスタム シリアライザ コンポーネントも作成し、登録する必要があります。詳細については、「IBizTalkSerializerComponent インターフェイスの使用」を参照してください。チャネルのカスタム シリアライザは、チャネル ウィザードの [詳細構成] ページで構成できます。詳細については、「詳細構成のプロパティの設定」を参照してください。

    • RELIABLE

      Reliable 書式のエンベロープを作成しなくても、Reliable 書式の受信インターチェンジを BizTalk Server 2000 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

      Reliable 書式では、BizTalk Framework 2.0 に準拠するエンベロープが処理されます。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

      Reliable 書式を選択する場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスで [信頼できるメッセージの返信先 URL] のアドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  4. カスタム XML、フラット ファイル、またはカスタムのいずれかの書式を選択する場合は、エンベロープの仕様を選択できます。詳細については、「エンベロープ仕様の選択」を参照してください。

注

  • すべての書式の送信インターチェンジを BizTalk Server 2000 で処理できるようにするには、エンベロープを作成します。

  • カスタム XML 書式を選択し、仕様を選択しない場合、エンベロープの書式は既定で Reliable 書式になります。

  • BizTalk Framework 2.0 に準拠するエンベロープを処理する時には、BizTalk Server 2000 は、エンドポイントと有効期限時刻 (expiration time) を考慮する必要があります。アプリケーションまたは取引先から、BizTalk Framework 2.0 に準拠したドキュメントが BizTalk Server 2000 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

  • エンベロープの書式を変更する場合、既にその仕様が選択されているときは、エンベロープの書式を変更後、もう一度選択し直さなければならないことがあります。

  • ローカル ドメイン以外にある仕様を参照するエンベロープを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

エンベロープの削除

エンベロープの編集

エンベロープの検索

エンベロープについて


エンベロープの検索

  1. BizTalk メッセージ マネージャで、[その他の項目を検索] の [エンベロープ] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべてのエンベロープを検索するには、すべての検索条件を消去し、[検索] をクリックします。

    • 特定の名前のエンベロープを検索するには、[エンベロープの検索] でそのエンベロープの名前を [エンベロープ名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定の書式のエンベロープを検索するには、[書式] ボックスの一覧で書式をクリックし、[検索] をクリックします。

注

  • [検索] をクリックする前に、複数の検索条件を設定することができます。

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件では、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

エンベロープの削除

エンベロープの編集

エンベロープについて


エンベロープの編集

  1. BizTalk メッセージ マネージャの [エンベロープ名] ボックスの一覧で、編集するエンベロープをクリックします。

    エンベロープの検索の詳細については、「エンベロープの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [エンベロープのプロパティ] ダイアログ ボックスが表示されます。

  3. [エンベロープ名] ボックスに一意なエンベロープ名を入力します。

  4. [エンベロープ書式] ボックスの一覧で、次のいずれかのエンベロープ書式をクリックします。
    • CUSTOM XML

      カスタム XML 形式の受信インターチェンジを BizTalk Server 2000 で処理できるようにするには、カスタム XML 形式と仕様参照を持つエンベロープを作成します。ただし、カスタム XML インターチェンジを送信する場合は、Submit 関数のパラメータにそのエンベロープ名を指定する必要はありません。BizTalk Server 2000 では、名前の指定がなくても適切なエンベロープを見つけることができます。

    • X12

      X12 書式のエンベロープを作成しなくても、X12 書式の受信インターチェンジを BizTalk Server 2000 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • EDIFACT

      EDIFACT 書式のエンベロープを作成しなくても、EDIFACT 書式の受信インターチェンジを BizTalk Server 2000 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • FLATFILE

      フラット ファイル書式の受信インターチェンジを BizTalk Server 2000 で処理できるようにするには、フラット ファイル書式のエンベロープを作成します。フラット ファイルの受信ドキュメントを送信する場合は、Submit 関数のパラメータにエンベロープ名を指定する必要があります。詳細については、「送信」を参照してください。

    • CUSTOM

      カスタム書式 (BizTalk Server 2000 で直接にはサポートされない書式) の受信インターチェンジを BizTalk Server 2000 で処理できるようにするには、エンベロープを作成しなければならない場合があります。これらのインターチェンジを処理するためには、カスタム パーサー コンポーネントを作成する必要があり、このカスタム パーサー コンポーネントにエンベロープが必要な場合があります。詳細については、「IBizTalkParserComponent インターフェイスの使用」を参照してください。

      カスタム書式の送信インターチェンジを BizTalk Server 2000 で処理できるようにするには、カスタム書式のエンベロープを作成し、メッセージ ポートでそのエンベロープを選択します。カスタム シリアライザ コンポーネントも作成し、登録する必要があります。詳細については、「IBizTalkSerializerComponent インターフェイスの使用」を参照してください。チャネル のカスタム シリアライザは、チャネル ウィザードの [詳細構成] ページで構成できます。詳細については、「詳細構成のプロパティの設定」を参照してください。

    • RELIABLE

      Reliable 書式のエンベロープを作成しなくても、Reliable 書式の受信インターチェンジを BizTalk Server 2000 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

      Reliable 書式では、BizTalk Framework 2.0 に準拠するエンベロープが処理されます。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

      Reliable 書式を選択する場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスで [信頼できるメッセージの返信先 URL] のアドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  5. カスタム XML、フラット ファイル、またはカスタムのいずれかの書式を選択する場合は、エンベロープの仕様を選択できます。詳細については、「エンベロープ仕様の選択」を参照してください。

重要

  • Reliable 書式のエンベロープを作成し、ポートでそのエンベロープを選択する場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスで [信頼できるメッセージの返信先 URL] のアドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

注

  • すべての書式の送信インターチェンジを BizTalk Server 2000 で処理できるようにするには、エンベロープを作成します。

  • カスタム XML 書式を選択し、仕様を選択しない場合、エンベロープの書式は既定で Reliable 書式になります。

  • BizTalk Framework 2.0 に準拠するエンベロープを処理する時には、BizTalk Server 2000 は、エンドポイントと有効期限時刻 (expiration time) を考慮する必要があります。アプリケーションまたは取引先から、BizTalk Framework 2.0 に準拠したドキュメントが BizTalk Server 2000 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

  • エンベロープの書式を変更する場合、既にその仕様が選択されているときは、エンベロープの書式を変更後、もう一度選択し直さなければならないことがあります。

  • ローカル ドメイン以外にある仕様を参照するエンベロープを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

エンベロープの作成

エンベロープの削除

エンベロープの検索

エンベロープについて


エンベロープの削除

  1. BizTalk メッセージ マネージャの [エンベロープ名] ボックスの一覧で、削除するエンベロープをクリックします。

    エンベロープの検索の詳細については、「エンベロープの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • エンベロープが メッセージ ポートで使用されている場合は、そのエンベロープは削除できません。そのエンベロープを使用しているすべてのメッセージ ポートを先に削除する必要があります。

関連項目

エンベロープの作成

エンベロープの編集

エンベロープの検索

エンベロープについて


エンベロープ仕様の選択

  1. [新しいエンベロープ] ダイアログ ボックスまたは [エンベロープのプロパティ] ダイアログ ボックスで、[エンベロープ仕様] チェック ボックスをオンにして、[参照] をクリックします。

    [WebDAV リポジトリからのエンベロープ仕様の選択] ダイアログ ボックスが表示されます。

  2. サーバーを変更する場合は、[サーバー] ボックスで次のどちらかの操作を行います。
    • 一覧に表示されているサーバーをクリックします。

    • サーバーの名前を入力し、Enter キーを押します。
  3. 目的の仕様が格納されているフォルダをダブルクリックし、仕様をクリックします。次に [開く] をクリックします。

重要

  • WebDAV リポジトリのダイアログ ボックスを最初に開いたときは、BizTalk メッセージ マネージャがリモート サーバーのデータベースに接続されていても、ローカル サーバーの WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • サーバーとして http://localhost を選択すると、BizTalk メッセージ マネージャはそれを自動的にローカル コンピュータ名に変換します。

  • カスタム XML 書式を選択する場合は、エンベロープの仕様を選択できます。仕様を選択しなかった場合は、BizTalk Framework 2.0 に準拠する Reliable 書式が、既定でそのエンベロープの書式になります。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

  • フラット ファイル書式を選択する場合は、エンベロープの仕様を選択できます。受信インターチェンジを開くためにエンベロープが使用される場合は、仕様を選択する必要があります。送信インターチェンジの作成にエンベロープが使用される場合は、仕様は必要ありません。

  • カスタム書式を選択する場合は、エンベロープの仕様を選択できます。仕様が必要かどうかは、作成するカスタム パーサーまたはカスタム シリアライザによって決まります。

    カスタム書式を使用するには、さらに次の操作を行う必要があります。

    • そのカスタム書式の受信インターチェンジを開くためのカスタム パーサー コンポーネントを作成する。詳細については、「IBizTalkParserComponent インターフェイスの使用」を参照してください。

    • そのカスタム書式の送信インターチェンジを作成するためのカスタム シリアライザ コンポーネントを作成および構成する。詳細については、「IBizTalkSerializerComponent インターフェイスの使用」を参照してください。

    • メッセージ ポート上書きプロパティを使用するカスタム シリアライザ コンポーネントをチャネル ウィザードで構成する。詳細については、「メッセージ ポート既定値の変更」を参照してください。
  • ローカル ドメイン以外にある仕様を参照するエンベロープを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

エンベロープの作成

エンベロープの編集

エンベロープの検索

エンベロープについて


同報リストの使用

ここでは、同報リストを使用する方法を作業ごとに説明します。「概念」の「同報リストについて」を参照し、同報リストについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • 同報リストの作成

  • 同報リストの検索

  • 同報リストの編集

  • 同報リストの削除


同報リストの作成

  1. BizTalk メッセージ マネージャの [ファイル] メニューの [新規作成] をポイントし、[同報リスト] をクリックします。

    [新しい同報リスト] ダイアログ ボックスが表示されます。

  2. [同報リスト名] ボックスに一意な同報リスト名を入力します。

  3. [利用可能なメッセージ ポート] ボックスの一覧で選択するメッセージ ポートをクリックし、[追加] をクリックします。

    選択したメッセージ ポートが [選択されたメッセージ ポート] ボックスの一覧に追加されます。

  4. [選択されたメッセージ ポート] ボックスの一覧に不要なメッセージ ポートがある場合は、そのメッセージ ポートをクリックし、[削除] をクリックします。

  5. 必要なプロパティをすべて設定してから、[OK] をクリックして [新しい同報リスト] ダイアログ ボックスを閉じます。

注

  • 同報リストからメッセージ ポートを削除しても、そのポートは同報リストから削除されるだけで、データベースからは削除されません。

  • 同報リストには少なくとも 1 つのメッセージ ポートが含まれている必要があります。

  • オープンなメッセージ ポートは、同報リストに追加できません。

  • 同報リストが機能するには、少なくとも 1 つのチャネルが必要です。チャネルの詳細については、「チャネルの作成と管理」を参照してください。

関連項目

同報リストの削除

同報リストの編集

同報リストの検索

同報リストについて


同報リストの検索

  1. BizTalk メッセージ マネージャの [その他の項目を検索] で [同報リスト] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべての同報リストを検索するには、検索条件をすべて消去し、[検索] をクリックします。

    • 特定の名前の同報リストを検索するには、[同報リストの検索] でその同報リストの名前を [同報リスト名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定のメッセージ ポートを含む同報リストを検索するには、そのメッセージ ポートの名前を [含まれるメッセージ ポート] ボックスに入力し、[検索] をクリックします。

注

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果の既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件では、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

同報リストの作成

同報リストの削除

同報リストの編集

同報リストについて


同報リストの編集

  1. BizTalk メッセージ マネージャの [同報リスト名] ボックスの一覧で、編集する同報リストをクリックします。

    同報リストの検索については、「同報リストの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [同報リストのプロパティ] ダイアログ ボックスが表示されます。

  3. [同報リスト名] ボックスに一意な同報リスト名を入力します。

  4. [利用可能なメッセージ ポート] ボックスの一覧で選択するメッセージ ポートをクリックし、[追加] をクリックして、それらのポートを [選択されたメッセージ ポート] ボックスの一覧に追加します。

  5. [選択されたメッセージ ポート] ボックスの一覧に不要なメッセージ ポートがある場合は、そのメッセージ ポートをクリックし、[削除] をクリックします。

  6. 必要なプロパティをすべて設定してから、[OK] をクリックして [同報リストのプロパティ] ダイアログ ボックスを閉じます。

注

  • 同報リストからメッセージ ポートを削除しても、そのポートは同報リストから削除されるだけで、データベースからは削除されません。

  • 同報リストには少なくとも 1 つのメッセージ ポートが含まれている必要があります。

  • オープンなメッセージ ポートは、同報リストに追加できません。

関連項目

同報リストの作成

同報リストの削除

同報リストの検索

同報リストについて


同報リストの削除

  1. BizTalk メッセージ マネージャの [同報リスト名] ボックスの一覧で、削除する同報リストをクリックします。

    同報リストの検索の詳細については、「同報リストの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • 同報リストに関連付けられているすべてのチャネルを削除するまで、その同報リストは削除できません。

  • 同報リストを右クリックし、[チャネルの検索] をクリックすることにより、その同報リストに関連付けられているチャネルを検索できます。

関連項目

同報リストの作成

同報リストの検索

同報リストについて


概念

ここでは、BizTalk メッセージ マネージャを理解するうえで不可欠な概念について説明します。ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの環境

  • チャネルについて

  • メッセージ ポートについて

  • 組織について

  • ドキュメント定義について

  • エンベロープについて

  • 受信確認について

  • 同報リストについて


BizTalk メッセージ マネージャの環境

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャのオプションの構成

  • BizTalk メッセージ マネージャのユーザー インターフェイス

  • BizTalk メッセージ マネージャのショートカット キー

  • セキュリティ

注意

  • ドキュメントを処理する場合は、あらかじめ BizTalk メッセージ マネージャを使用してBizTalk メッセージ サービスを構成しておく必要があります。Microsoft BizTalk Server 2000 でドキュメントを処理している最中に、使用中のオブジェクトへのアクセスおよび変更を行うと、予期しない結果を招く場合があります。


BizTalk メッセージ マネージャのオプションの構成

ここでは、BizTalk メッセージ マネージャのオプションを変更する方法について説明します。次のオプションがあります。

  • 新しいメッセージ ポートまたはチャネルを構成する。

  • 以前に構成したメッセージ ポートまたはチャネルを管理する。

  • 検索の戻り値を設定する。

  • サーバー接続を設定する。

  • サーバーのタイムアウト値を設定する。

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの構成オプションの選択

  • サーバー接続のオプションの設定

注

  • BizTalk メッセージ マネージャのツール バーの位置は変更できます。ただし、アプリケーションを再起動すると、ツール バーの位置は元に戻ります。


BizTalk メッセージ マネージャの構成オプションの選択

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

    [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示されます。

  2. [構成オプション] で、次のオプションのいずれかを選択します。
    • 組織への新しいメッセージ ポートを作成および構成する場合は、[組織への新しいメッセージ ポートの構成] をクリックし、[OK] をクリックします。

      組織への新しいメッセージ ポートの作成および構成の詳細については、「メッセージ ポートの作成」を参照してください。

    • アプリケーションへの新しいメッセージ ポートを作成および構成する場合は、[アプリケーションへの新しいメッセージ ポートの構成] をクリックし、[OK] をクリックします。

      アプリケーションへの新しいメッセージ ポートの作成および構成の詳細については、「メッセージ ポートの作成」を参照してください。

    • 既存のメッセージ ポートを管理する場合は、[以前に構成したメッセージ ポートの管理] をクリックし、[OK] をクリックします。

      既存のメッセージ ポートの管理の詳細については、「メッセージ ポートの編集」を参照してください。

    • 既存のチャネルを管理する場合は、[以前に構成したチャネルの管理] をクリックし、[OK] をクリックします。

      既存のチャネルの管理の詳細については、「チャネルの編集」を参照してください。

注

  • BizTalk メッセージ マネージャを開いたときにこのダイアログ ボックスが表示されないようにするには、[次回からこのダイアログ ボックスを表示しない] チェック ボックスをオンにします。再び表示されるよう設定するには、[ツール] メニューの [オプション] をクリックし、[スタートアップ ダイアログ ボックスの表示] チェック ボックスをオンにします。

関連項目

メッセージ ポートの作成

チャネルの編集

メッセージ ポートの編集


サーバー接続のオプションの設定

  1. BizTalk メッセージ マネージャで [ツール] メニューの [オプション] をクリックします。

    [オプション] ダイアログ ボックスが表示されます。

  2. [検索結果の最大件数] ボックスで次の手順のいずれかを実行します。
    • 検索結果の最大件数を入力します。

    • 上矢印または下矢印をクリックして、値を増減します。
  3. [接続する BizTalk Server 名] ボックスに、BizTalk Server 2000 がインストールされているサーバーの名前を入力します。

  4. [サーバー タイムアウト (秒)] ボックスで次の手順のいずれかを実行します。
    • サーバー接続がタイムアウトするまでの秒数を入力します。

    • 上矢印または下矢印をクリックして、値を増減します。
  5. BizTalk メッセージ マネージャを起動したときのダイアログ ボックスの表示/非表示を切り替えるには、[スタートアップ ダイアログ ボックスの表示] チェック ボックスをオンまたはオフにします。

  6. すべてのプロパティを設定したら、[OK] をクリックします。

注

  • 接続するサーバーによって、BizTalk メッセージ マネージャを使用して新しいオブジェクトを検索、編集、または作成する BizTalk メッセージ管理データベースが決定されます。既定の接続先サーバーは、最後に接続したサーバーです。ドキュメント、マップ、およびエンベロープなどの仕様を格納し、取得するための WebDAV リポジトリをホストするサーバーは、ここでの設定とは別に、仕様を選択するために使用するエディタやマッパーなどのダイアログ ボックスから個別に設定します。既定の接続先 WebDAV は、最後に接続した WebDAV です。

  • 検索結果の既定の最大件数は 500 です。

  • サーバー接続がタイムアウトするまでの既定の秒数は 20 です。

  • 接続中のサーバーは、BizTalk メッセージ マネージャの左側にある検索ペインの上に表示されます。


BizTalk メッセージ マネージャのユーザー インターフェイス

BizTalk メッセージ マネージャのユーザー インターフェイスには、左右 2 つのメイン ペインがあります。

左側のペインには次の項目が表示されます。

  • BizTalk メッセージ マネージャが接続しているサーバーの名前

  • 検索可能なオブジェクトの一覧

  • 検索対象を絞り込むための検索条件

BizTalk メッセージ マネージャを使用して作成したあらゆるオブジェクトを検索できます。検索するオブジェクトの種類を選択するには、[その他の項目を検索] にある名前をクリックします。検索条件は選択するオブジェクトの種類によって異なります。

右側のペインには次の項目が表示されます。

  • 検索で返された項目の詳細。

項目の詳細は検索するオブジェクトの種類によって異なります。

検索結果ペインの項目を昇順または降順に並べ替えるには、列のヘッダーをクリックします。並べ替えは、一度に 1 つの列に基づいてのみ実行できます。

注

  • 検索する特定の種類のオブジェクトが多い場合は、すべての件数が返るまでに数分かかる場合があります。検索条件を指定することにより、検索結果の件数を減らすことができます。

  • 検索結果の既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

関連項目

BizTalk メッセージ マネージャのショートカット キー

チャネルの検索

同報リストの検索

ドキュメント定義の検索

エンベロープの検索

メッセージ ポートの検索

組織の検索


BizTalk メッセージ マネージャのショートカット キー

BizTalk メッセージ マネージャでは、ショートカット キーを使用して作業を実行できます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional ヘルプでは、「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Ctrl + A | すべてを選択します。
Ctrl + C | テキストをコピーします。
Ctrl + X | テキストを切り取ります。
Ctrl + V | テキストを貼り付けます。
Ctrl + Z | テキストの操作を取り消します。
Ctrl + R | 組織への新しいメッセージ ポートを作成します。
Ctrl + Shift + R | アプリケーションへの新しいメッセージ ポートを作成します。
Ctrl + L | 組織から新しいチャネルを作成します。
Ctrl + Shift + L | アプリケーションから新しいチャネルを作成します。
Ctrl + T | 新しい同報リストを作成します。
Ctrl + D | 新しいドキュメント定義を作成します。
Ctrl + G | 新しい組織を作成します。
Del | 選択した項目またはテキストを削除します。
Shift + F10 | 選択した項目のショートカット メニューを表示します。
Shift + 任意の方向キー | ウィンドウ内の複数の項目を選択、またはテキストを選択します。
Tab | ボタンやフィールド間でフォーカスが移動します。
Shift + Tab | ボタンやフィールド間でフォーカスが移動します。
Space | チェック ボックスをオンまたはオフにします。ボタンにフォーカスがある場合、マウスのクリックと同様な動作になります。
Alt + Space | アクティブなウィンドウのシステム メニューを表示します。
Alt + メニュー名の下線付き文字 | 対応するメニューを表示します。
開いたメニューのコマンド名の下線付き文字 | 対応するコマンドを実行します。
Alt + ↓ | アクティブになっているリスト ボックスのドロップダウン リストを表示します。
Enter | アクティブなオプションまたはボタンのコマンドを実行します。
Esc | 現在の作業を取り消します。
F1 | オンライン ヘルプを表示します。
Alt + F4 | アクティブなウィンドウを閉じるかアクティブなプログラムを終了します。
← | タブのフォーカスを左に移動します。
→ | タブのフォーカスを右に移動します。
任意の方向キー | ダイアログ ボックスのメイン ウィンドウにあるフォルダまたはファイルを強調表示します。この機能は、[WebDAV リポジトリからのドキュメント仕様の選択]、[WebDAV リポジトリからのエンベロープ仕様の選択]、および [WebDAV リポジトリからのマップの選択] ダイアログ ボックスで実行されます。詳細については、「ドキュメント仕様の選択」、「エンベロープ仕様の選択」、および「マップの選択」を参照してください。

関連項目

BizTalk メッセージ マネージャのユーザー インターフェイス


セキュリティ

BizTalk メッセージ マネージャを使用してオブジェクトにアクセスしたり、オブジェクトを作成するには、BizTalk Server Administrators グループのユーザー アカウントが必要です。BizTalk Server Administrators グループは、BizTalk Server 2000 がインストールされると作成されます。このグループには、必要に応じてユーザーを追加することができます。ユーザー アカウントの追加の詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。


チャネルについて

チャネルとは、BizTalk メッセージ サービスを構成して、受信したドキュメントを処理するために使用するプロパティのセットです。チャネルはメッセージ ポートまたは同報リスト用に作成することができます。チャネルがドキュメントを処理すると、そのドキュメントは関連付けられたメッセージ ポートまたは関連付けられた同報リスト内のメッセージ ポートで指定された送信先にトランスポートされます。1 つのメッセージ ポートまたは同報リスト用に 1 つ以上のチャネルを作成することができます。

チャネルでは、ドキュメントの送信元を指定します。これは、送信元組織または送信元アプリケーションにすることができます。チャネルの送信元としてアプリケーションを指定するには、既定の組織のアプリケーションを作成する必要があります。これは、自分の会社での実際の内部アプリケーションを表します。また、チャネルの送信元として XLANG スケジュールを指定することもできます。BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。詳細については、「BizTalk オーケストレーションの設計」を参照してください。BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合の詳細については、「BizTalk サービスの統合」を参照してください。

チャネルでオープンな送信元を明示的に宣言することもできます。この場合は、ドキュメントを送信するときに、ドキュメント内またはパラメータのいずれかで送信元を指定する必要があります。これは、オープン チャネルといいます。詳細については、「送信」を参照してください。

内部アプリケーションまたは取引先組織からの受信ドキュメントを表す、受信ドキュメント定義も指定します。また、指定した送信先に配信するドキュメントを表す、送信ドキュメント定義も指定します。ドキュメント定義の詳細については、「ドキュメント定義について」を参照してください。

送信ドキュメントの書式または構造が受信ドキュメントの書式または構造と異なる場合は、チャネルのマップを指定する必要があります。マップは元の受信ドキュメントの書式または構造を送信先の組織またはアプリケーションによって要求される送信ドキュメントの書式または構造に変換します。たとえば、会計アプリケーションが区切りフラット ファイル書式で発注書を生成し、取引先が X12 書式の発注書を要求する場合は、マップを使用してドキュメントの書式を変換することができます。マップの詳細については、「データのマッピング」を参照してください。

メッセージ ポートまたは同報リスト用に、それぞれに異なる構成で 1 つ以上のチャネルを作成することができます。たとえば、異なる書式で発注書を生成する 2 つの内部会計アプリケーションがあり、別の書式で発注書を受け取ることを希望している取引先があるとします。この場合は、その取引先用に単一のメッセージ ポートを作成してから、そのポート用に各アプリケーションからチャネルを作成することができます。両方のチャネルの送信ドキュメント定義は同じになり、取引先の書式と一致します。ただし、各チャネルにはアプリケーションからの受信ドキュメントの書式を変換するための異なるマップがあります。単一のメッセージ ポートに接続される異なるチャネルを作成できるため、すべての発注書を同じ書式で送信することができます。

また、次の目的のためにチャネルで他のプロパティを設定することができます。

  • 受信ドキュメント定義で追跡する仕様フィールドを指定します。指定するフィールドは、ドキュメント定義で指定されるグローバル追跡項目の代わりに、この特定のチャネルを使用して処理される各ドキュメント インスタンス用の追跡データベースに記録されます。グローバル追跡項目の詳細については、「ドキュメント データ フィールドの追跡」を参照してください。

  • 処理中のドキュメント内の 1 つ以上のフィールドの値に基づいて、BizTalk Server 2000 がチャネルを呼び出すかどうかを決定するチャネル フィルタ式を作成します。

  • 受信確認を構成します。送信したドキュメントの送信先から受信確認を要求し、受信したドキュメントの送信元のために受信確認を生成することができます。受信確認の処理の詳細については、「受信確認について」を参照してください。

  • セキュリティ プロパティを構成します。サーバーが受信ドキュメントの暗号と署名を確認したり、送信ドキュメントにデジタル署名を行うことを指定できます。

  • ドキュメントのログ オプションを指定します。受信ドキュメントと送信ドキュメントの両方をそれぞれのネイティブ形式、中間 XML 形式、または両方で格納することができます。

  • 詳細なプロパティを構成します。EDI 書式でドキュメントのグループ制御番号を指定し、サーバーがドキュメントを再送信するために使用する回数と間隔を設定して、メッセージ ポートまたは同報リストのトランスポート コンポーネント プロパティとエンベロープ プロパティを上書きすることができます。

BizTalk メッセージ マネージャを使用して、受信確認チャネルを作成することもできます。受信確認チャネルは特別な種類のチャネルで、BizTalk メッセージ サービスで受信したドキュメントの送信元に受信確認を返すのに使用されます。受信確認を要求する受信ドキュメントを処理するためのチャネルを作成する場合は、受信確認を処理するサーバーが使う受信確認チャネルを指定できます。このため、受信確認を要求するドキュメントを処理するために、メッセージ ポートとチャネルを作成する前に、メッセージ ポートと関連付けた受信確認チャネルを作成してください。受信確認の処理の詳細については、「受信確認について」を参照してください。

BizTalk Server 2000 は、ドキュメントを受信すると、そのドキュメントの処理方法をサーバーに指示する適切なチャネルを検出します。次に、サーバーはそのチャネルと関連付けられているメッセージ ポートまたは同報リストを検出します。メッセージ ポートは、指定された送信先にドキュメントをトランスポートするために必要な一連の手順をサーバーに指示します。チャネルが同報リストと関連付けられている場合は、サーバーは同報リストの各メッセージ ポートのプロパティを使用して、指定された送信先にドキュメントをトランスポートします。

ここには次のトピックが含まれます。

  • チャネルの要素

  • 有効なチャネルとメッセージ ポートの組み合わせ


チャネルの要素

チャネルは次の要素から構成されます。

送信元組織または送信元アプリケーション

チャネルを作成する場合は、ドキュメントの送信元としてアプリケーションまたは組織のいずれかを指定します。送信元アプリケーションは、常に既定の組織の業務用アプリケーションを表します。これには会計アプリケーション、注文入力システム、または基幹業務アプリケーションなどがあります。ドキュメントの送信元として、XLANG スケジュールを指定することもできます。BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。送信元組織は、常に外部の取引先を表します。

チャネルは、メッセージ ポートまたは同報リストのどちらかで使用するために作成するものです。チャネルの送信元から受信するドキュメントの送信先は、そのチャネルが作成されたメッセージ ポートまたは同報リストのメッセージ ポートで指定します。

受信ドキュメント定義と送信ドキュメント定義

チャネルのドキュメント定義は、BizTalk Server 2000 によって処理される受信ドキュメントと送信ドキュメントを表し、そのドキュメントを定義する仕様へのポインタになります。仕様は、ドキュメントの構造、種類、およびバージョンを定義します。詳細については、「ドキュメント定義について」を参照してください。

BizTalk Server 2000 は、ドキュメントを受信したときに、そのドキュメントを処理するために適切なチャネルを検出します。サーバーは受信ドキュメント定義の仕様を使って、受信ドキュメントを中間 XML 形式に変換します。サーバーは、必要があれば、受信ドキュメントの書式または構造を、送信ドキュメントの書式または構造にマップします。次に、サーバーは送信ドキュメントの仕様を使って、送信ドキュメントを送信先アプリケーションまたは送信先組織が認識し、使用することができる書式または構造に変換します。

マップ

受信ドキュメントの書式または構造は、送信ドキュメントに要求される書式または構造とは異なる場合があります。この場合は、受信ドキュメントの書式を送信ドキュメントの書式に変換するために、マップを使用することができます。

たとえば、カンマ区切りフラット ファイル書式で請求書を生成する会計アプリケーションがあり、取引先が X12 書式で請求書を受信する必要がある場合は、チャネルのマップを使用して、書式を変換することができます。

マップは、同じ書式を使用しているドキュメントの内容と構造を変換することもできます。詳細については、「データのマッピング」を参照してください。

追跡プロパティとフィルタ プロパティ

チャネルの受信ドキュメント定義のために、追跡データベースのログに記録する仕様フィールドを指定することができます。チャネルで指定する仕様フィールドは、このチャネルを使用して処理される各ドキュメント インスタンス用の追跡データベースのログに記録されます。指定したフィールドは、受信ドキュメント定義で指定するグローバル追跡項目の代わりにログに記録されます。送信ドキュメント定義で指定したグローバル追跡項目は無視されます。詳細については、「ドキュメント データ フィールドの追跡」を参照してください。

チャネル フィルタ式は、BizTalk Server 2000 がドキュメントを受信したときに呼び出すチャネルを決定するためのもう 1 つの方法です。チャネル フィルタ式の場合、ドキュメント インスタンス内の指定された 1 つ以上のフィールドの値に基づいて、チャネルが決定されます。

サーバーがドキュメントを処理する場合、指定された各フィールドの値は、チャネル フィルタ式の値で評価されます。式が真であると、チャネルが呼び出されます。式が偽であると、チャネルは呼び出されません。たとえば、1000 を超える発注書の総数を確認するためにチャネル フィルタ式を作成し、ドキュメントの PO Total フィールドが 1500 の場合、そのチャネルは呼び出されます。

ドキュメントのログ プロパティ

BizTalk Server 2000 は、非 XML 受信ドキュメントを処理するために、元のネイティブ形式から中間 Unicode XML 形式に変換します。BizTalk Server 2000 は、送信ドキュメントを中間 Unicode XML 形式から指定された送信先で要求される書式に変換します。各受信ドキュメントと送信ドキュメントのデータをいずれかの書式または両方の書式で格納することを選択できます。

関連項目

チャネルの作成と管理

チャネルについて

有効なチャネルとメッセージ ポートの組み合わせ


有効なチャネルとメッセージ ポートの組み合わせ

Microsoft BizTalk Server 2000 で有効に使用できる特定のチャネル (送信元) とメッセージ ポート (送信先) の組み合わせだけを作成することができます。

次の有効なビジネス シナリオは、データを正しくルーティングするために、正しい送信先でメッセージ ポートを構成し、正しい送信元でチャネルを構成する方法を示しています。

シナリオ 1 : 取引先から内部アプリケーションへ

このシナリオでは、既定の組織のアプリケーションを送信先としてメッセージ ポートを作成します。次に、取引先組織を送信元ととして、このメッセージ ポートのチャネルを作成します。

シナリオ 2 : 内部アプリケーションから取引先へ

このシナリオでは、取引先組織を送信先としてメッセージ ポートを作成します。次に、既定の組織のアプリケーションを送信元として、このメッセージ ポートのチャネルを作成します。

シナリオ 3 : 内部アプリケーションから内部アプリケーションへ

このシナリオでは、既定の組織のアプリケーションを送信先としてメッセージ ポートを作成します。次に、既定の組織の別のアプリケーションを送信元として、このメッセージ ポートのチャネルを作成します。

シナリオ 4 : 内部アプリケーションから同報リストへ

このシナリオでは、組織またはアプリケーションへの既存のメッセージ ポートのグループを含む同報リストを作成します。次に、既定の組織のアプリケーションを送信元として同報リストのチャネルを作成します。

シナリオ 5 : 内部アプリケーションからオープンな送信先へ

このシナリオでは、オープンなメッセージ ポートとして指定するメッセージ ポートを作成します。次に、既定の組織のアプリケーションを送信元として、このメッセージ ポートのチャネルを作成します。

シナリオ 6 : オープンな送信元から内部アプリケーションへ

このシナリオでは、既定の組織のアプリケーションを送信先としてメッセージ ポートを作成します。次に、オープン チャネルとして指定するこのメッセージ ポートのチャネルを作成します。

注

  • オープン チャネルとして指定するチャネルは、オープンなメッセージ ポートとして指定したメッセージ ポート用に作成することはできません。

シナリオ 7 : 取引先から中間送信先を経由して取引先へ

このシナリオでは、中間送信先として自分の会社にある BizTalk Server 2000 を経由して、ある取引先が別の取引先にドキュメントを送信します。一方の取引先組織を送信先としてメッセージ ポートを作成します。次に、別の取引先を送信元として、このメッセージ ポート用のチャネルを作成します。

関連項目

チャネルの要素

チャネルについて


メッセージ ポートについて

メッセージ ポートとは、指定したトランスポート サービスを使用して、BizTalk メッセージ サービスを構成し、指定した送信先にドキュメントをトランスポートするために使用できる一連のプロパティです。メッセージ ポートがトランスポートするドキュメントは、関連付けられたチャネルで指定した送信元から送信されます。多数の送信元から同じ送信先にドキュメントを送信するために、単一のメッセージ ポートに対して複数のチャネルを作成することができます。

メッセージ ポートは、指定された送信先組織、XLANG スケジュール、または送信先アプリケーションにドキュメントを送信するように構成することができます。

組織へのメッセージ ポートでは、送信先として特定の取引先を指定するか、オープンな送信先を宣言することができます。これはオープンなメッセージ ポートといいます。オープンなメッセージ ポートは、取引先組織だけにドキュメントをトランスポートするために使用することができます。オープンなメッセージ ポートの送信先組織情報は、そのドキュメント内に指定するか、そのドキュメントを BizTalk Server 2000 に送信するときにパラメータで指定する必要があります。ドキュメントの送信の詳細については、「送信」を参照してください。オープンなメッセージ ポートの詳細については、「オープンネス」を参照してください。

オープンなメッセージ ポートに対して指定されたアドレスが SMTP アドレスの場合は、サーバーには既定の組織の From アドレスが必要です。このアドレスを取得するには、サーバーは "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の、既定の組織の特別な組織識別子に指定された値を使用します。この組織識別子を構成する方法の詳細については、「既定の組織の構成」を参照してください。

アプリケーションへのメッセージ ポートでは、送信先として XLANG スケジュールまたは既定の組織のアプリケーションのいずれかを指定できます。既定の組織の詳細については、「組織について」を参照してください。

XLANG スケジュールへのメッセージ ポートは、指定された XLANG スケジュールの新しいインスタンスをアクティブにしてから、そのスケジュールの指定されたメッセージ ポートにドキュメントを配信するように構成できます。この場合、指定されたスケジュールには、BizTalk メッセージにバインドされたメッセージ ポートが含まれている必要があります。スケジュールを指定する場合は、メッセージ ポートの名前も指定します。XLANG スケジュールの実行インスタンスにドキュメントを配信するようにメッセージ ポートを構成することもできます。この場合、ドキュメントには、そのドキュメントを配信し、配信先スケジュールによって監視されるキュー名を含む必要があります。BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合の詳細については、「BizTalk サービスの統合」を参照してください。

さらに、メッセージ ポートのプロパティを使用して、ドキュメントを送信する特定のアドレス、ドキュメントをその場所に配信するためのトランスポートの種類、およびトランスポートの前にドキュメントをエンベロープに格納してセキュリティで保護する方法を指定します。

BizTalk Server 2000 は、ドキュメントを受信したときに、そのドキュメントを処理するために適切なチャネルを検出します。チャネルは、そのドキュメントを処理した後に、関連付けられたメッセージ ポートまたは同報リストをサーバーに示します。これらは、ドキュメントをエンベロープに格納してセキュリティで保護し、指定された送信先にトランスポートするために必要な一連の手順をサーバーに指示します。

ここには次のトピックが含まれます。

  • メッセージ ポートの要素

  • オープンなメッセージ ポート


メッセージ ポートの要素

メッセージ ポートは次の要素から構成されます。

送信先

メッセージ ポートの送信先は、取引先組織、XLANG スケジュール、または既定の組織のアプリケーションにすることができます。

組織へのメッセージ ポートは、送信先組織を明示的に指定するか、オープンなメッセージ ポートとして宣言することができます。オープンなメッセージ ポートでは、送信先組織はメッセージ ポートがドキュメントを処理するときに決定されます。送信先組織の情報はドキュメント内に指定するか、そのドキュメントを送信するときにパラメータで指定する必要があります。詳細については、「送信」を参照してください。

XLANG スケジュールへのメッセージ ポートは、2 つの方法で構成できます。第 1 に、XLANG スケジュールへのパスを指定して、XLANG の新しいインスタンスをアクティブにするようにメッセージ ポートを構成することができます。メッセージ ポートは、ドキュメントを処理するときに、このスケジュールをアクティブにしてから、メッセージ ポート プロパティで指定したスケジュール内のメッセージ ポートにドキュメントを配信します。または、アクティブな XLANG スケジュールにドキュメントを配信するようにメッセージ ポートを構成することもできます。この方法は、取引先にメッセージを送信し、取引先が専用に構成された ASP ページにメッセージを HTTP トランスポートを使って返信するときにだけ使用します。詳細については、「BizTalk サービスの統合」を参照してください。BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。詳細については、「BizTalk オーケストレーションの設計」を参照してください。

メッセージ ポートは、既定の組織の送信先アプリケーションにドキュメントをトランスポートすることもできます。メッセージ ポートの送信先としてアプリケーションを指定する前に、既定の組織にそのアプリケーションを追加する必要があります。詳細については、「アプリケーションの追加」を参照してください。

トランスポート プロパティ

メッセージ ポートで指定するトランスポート プロパティは、ドキュメントを送信先組織または送信先アプリケーションに転送するために使用するトランスポート サービスと、ドキュメントを送信する特定のアドレスを決定します。

メッセージ ポートで設定したトランスポート プロパティは、そのメッセージ ポートと関連付けられたすべてのチャネルに適用されます。BizTalk Server 2000 がドキュメントを処理するためにチャネルを呼び出した後に、サーバーはそのチャネルと関連付けられたメッセージ ポートのプロパティを参照します。サーバーはメッセージ ポートで指定されたトランスポートの種類を使用して、メッセージ ポートで指定されたアドレスにドキュメントを送信します。

ドキュメントをトランスポートできる特定の時間の範囲を指定するサービス時間帯を指定することもできます。

エンベロープ情報

エンベロープとは、トランスポートするドキュメントにプレフィックスを付けたり、カプセル化するために使用するヘッダー (場合によってはフッター) です。エンベロープのヘッダーには、そのエンベロープに格納される 1 つ以上のドキュメントに関する情報と、そのドキュメントをルーティングする方法に関する情報が含まれます。その内容は、送信元の組織識別子、送信先の組織識別子、および格納される 1 つ以上のドキュメントの種類に関する情報です。

BizTalk Server 2000 は、複数のドキュメントとドキュメントのグループを含むインターチェンジを受信し、処理することができます。エンベロープを使用しているドキュメントをトランスポートする場合に、BizTalk Server 2000 は各ドキュメントを別のインターチェンジに格納します。

エンベロープは省略できます。ただし、エンベロープを使用することを選択した場合、メッセージ ポートで指定するエンベロープの書式は、格納される 1 つ以上のドキュメントの書式と一致している必要があります。ドキュメントの書式は、関連付けられたチャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。反対に、チャネルの送信ドキュメント定義を選択する場合は、そのチャネルと関連付けられたメッセージ ポートには、対応する書式のエンベロープが必要です。たとえば、X12 書式の仕様を持つ送信ドキュメント定義を選択する場合は、メッセージ ポートで X12 エンベロープを指定してください。

セキュリティ プロパティ

メッセージ ポートで指定するセキュリティ プロパティは、そのメッセージ ポートと関連付けられたすべてのチャネルに適用されます。たとえば、メッセージ ポートで S/MIME (Secure Multipurpose Internet Mail Extensions) 暗号を指定する場合、そのメッセージ ポートと関連付けられたチャネルによって処理されるすべてのドキュメントは、指定した暗号を使用して暗号化されます。

異なる暗号を使用してセキュリティで保護する必要があるドキュメント、または暗号化する必要がないドキュメントがある場合は、別のメッセージ ポートを作成して、これらのドキュメントに適切なセキュリティ プロパティを指定する必要があります。

BizTalk Server 2000 は、MIME (Multipurpose Internet Mail Extensions) エンコードをサポートします。

MIME メッセージ書式規格は、クライアント プログラムがリッチ テキスト、複数の文字セット、および画像、音声、スプレッドシートなどのバイナリ添付ドキュメントを含むことがある複雑なメッセージ本体をデコードし、表示することができるように、メッセージを書式設定する方法を指定します。MIME は Uuencode よりも優れた柔軟なテクノロジであり、メッセージ内のコンテンツに一般的で柔軟なメカニズムを提供します。MIME 書式では、次のことを実行できます。

  • 各本体部分に対して、代替コンテンツのエンコード メカニズムを指定します。

  • 複数のコンテンツ部分のグループをメッセージ内に関連付けます。

  • 本体部分とメッセージ ヘッダー フィールドに US-ASCII 文字セット以外の文字セットを使用します。

  • コンテンツ部分 (たとえば、インラインまたは添付ドキュメント) の処理方法を指定します。

BizTalk Server 2000 は、S/MIME (Secure Multipurpose Internet Mail Extensions) 証明書に基づく公開キー暗号化をサポートしています。

暗号化は取引先に送信するビジネス データに適用することができます。データをセキュリティで保護するために暗号化証明書を使用することによって、意図された受信者だけが情報にアクセスできるようにすることができます。

ビジネス データを暗号化するには、送信元組織には、送信先組織の暗号化証明書の公開キーのコピーが必要です。送信元組織はこの公開キー証明書を使用してビジネス データを暗号化してから、その暗号化データを送信先組織に転送します。送信先組織は、その暗号化証明書の秘密キーを使用して、そのビジネス データを解読することができます。

オープンなメッセージ ポートでは、送信先組織が不明なため、暗号化セキュリティ プロパティは無効になっています。

BizTalk Server 2000 は S/MIME (Secure Multipurpose Internet Mail Extensions) 証明書に基づく公開キー デジタル署名をサポートしています。証明書の詳細については、「証明書について」を参照してください。

デジタル署名は、データの送信元の信頼性とデータが変更されていないことを確認し、データの送信元によるメッセージの否認を防止するために使用することができます。

署名証明書は、データを認証するデジタル署名を作成するために使用します。データの署名によってデータは変更されませんが、データとバンドルされるか、別に送信されるデジタル署名文字列が生成されます。

ドキュメントにデジタル署名するには、データを処理してメッセージ ダイジェストを作成します。次に、送信元組織の秘密キーを使用して、メッセージ ダイジェストを暗号化し、デジタル署名を生成します。このデータは、デジタル署名と共に受信者に送信されます。

デジタル署名を確認するには、受信者には送信者の署名証明書からの公開キーのコピーが必要です。受信者は、公開キーを使用してダイジェストを生成してから、メッセージ ダイジェストを単独に計算することによって、デジタル署名を解読します。2 つのダイジェストの結果を比較し、両者が同じ場合はその情報は改ざんされていません。

注

  • 証明書の詳細については、「証明書の概要」を参照してください。

関連項目

メッセージ ポートの作成および管理

オープンなメッセージ ポート

メッセージ ポートについて


オープンなメッセージ ポート

オープンなメッセージ ポートとは、特定の送信先組織を明示的に宣言していない組織へのメッセージ ポートです。オープンなメッセージ ポートでは、その送信先をアプリケーションにすることはできません。

オープンなメッセージ ポートでは、送信先情報とトランスポート情報は、そのドキュメント内に指定するか、そのドキュメントを Microsoft BizTalk Server 2000 に送信するときにパラメータで指定する必要があります。送信パラメータを使用する場合は、ドキュメントに含まれる送信先情報とトランスポート情報が上書きされます。ドキュメントの送信の詳細については、「送信」を参照してください。

オープンなメッセージ ポートのチャネルを作成し、送信先の情報がドキュメントで提供される場合、そのチャネルの受信ドキュメント定義は適切に構成された仕様を参照する必要があります。オープンなメッセージ ポートのドキュメントを処理するようにドキュメント仕様を構成する方法については、「ディクショナリのプロパティの設定」を参照してください。

オープンなメッセージ ポートでは、送信先組織が不明なため、暗号化セキュリティ プロパティは無効になっています。暗号化プロパティを設定するには、特定の既知の送信先組織からの証明書を指定する必要があります。暗号化証明書は、特定の送信先組織にトランスポートするドキュメントを暗号化するために使用します。

オープンなメッセージ ポートを使用すると、送信先ごとにメッセージ ポートを作成せずに、現在または将来のさまざまな取引先組織に 1 つ以上の標準化されたドキュメントを送信することができます。すべてのドキュメントは、そのメッセージ ポートで設定された同じエンベロープ、セキュリティ、およびトランスポート プロパティを共有します。

オープンなメッセージ ポートは、次の点で同報リストとは異なります。

  • オープンなメッセージ ポートでは、チャネルからの各ドキュメントは 1 つの送信先だけに配信されます。同報リストでは、チャネルからの各ドキュメントは複数の送信先に配信することができます。

  • オープンなメッセージ ポートでは、異なる取引先組織に情報を送信するためにメッセージ ポートのプロパティを変更する必要はありません。同報リストでは、異なる取引先組織に対して情報を送信するために、メッセージ ポートを追加する必要があります。

重要

  • メッセージ ポートをオープンなメッセージ ポートとして宣言する場合は、X12 仕様または EDIFACT 仕様の送信ドキュメント定義を持つメッセージ ポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元の組織識別子と送信先の組織識別子がサーバーに必要です。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報が含まれません。

関連項目

メッセージ ポートの作成および管理

メッセージ ポートの要素

メッセージ ポートについて


組織について

BizTalk メッセージ マネージャを使用して作成する組織は、ドキュメントを交換する取引先を表します。既定の組織という特殊な組織は、自分の会社を表します。

既定の組織

BizTalk メッセージ マネージャは、自動的に既定の組織を作成します。既定の組織を構成するときに、自分の会社として識別しやすいように、その名前を変更することができます。既定の組織は 1 つだけ存在し、削除することはできません。

メッセージ ポートまたはチャネルで、ドキュメントの送信元または送信先として既定の組織を指定することはできません。既定の組織のアプリケーションだけは、自分の会社内のドキュメントの送信元または送信先として指定することができます。たとえば、自分の会社が送信するドキュメントの送信先として取引先組織を指定するメッセージ ポートを作成するとします。次に、そのメッセージ ポート用のチャネルを作成する場合に、送信元として既定の組織を指定する代わりに、そのドキュメントが生成された自分の会社にある特定の内部アプリケーションを指定します。また、チャネルでドキュメントの送信元として既定の組織の 1 つのアプリケーションを指定し、メッセージ ポートで送信先として別のアプリケーションを指定することもできます。

既定の組織のアプリケーション

既定の組織にアプリケーションを追加すると、Microsoft BizTalk Server 2000 と自分の会社にある実際の内部アプリケーション間でドキュメントの流れを識別し、追跡することができます。ただし、アプリケーションを作成して、BizTalk メッセージ マネージャで送信元または送信先として指定するだけでは、実際の内部アプリケーションとの間でドキュメントの流れを制御したり、有効にすることはできません。内部アプリケーションを BizTalk Server 2000 と統合し、そのアプリケーションとの間でドキュメントの流れを指示するには、さらにサーバーを構成する必要があります。

送信元アプリケーションから BizTalk Server 2000 にドキュメントをトランスポートするには、いくつかの方法があります。アプリケーションを統合してサーバーにドキュメントをトランスポートするために必要な構成は、すべて BizTalk メッセージ マネージャの外部で実行されます。詳細については、「送信」を参照してください。

BizTalk Server 2000 から内部アプリケーションにドキュメントを配信するには、BizTalk メッセージ マネージャの内部と外部の両方で構成が必要になることがあります。メッセージ ポートで指定するトランスポートの種類とアドレスによって、ドキュメントを配信する特定の場所を決定することができます。次に、送信先アプリケーションの場所で受信されたドキュメントを取得するように、アプリケーションまたは別のコンポーネントを構成する必要があります。または、メッセージ ポートのトランスポート プロパティで、アプリケーションにドキュメントを直接に配信することができるアプリケーション統合コンポーネントを指定することができます。詳細については、「メッセージ ポートについて」を参照してください。

取引先組織

BizTalk メッセージ マネージャで作成するすべてのほかの組織は、外部の取引先または取引先の組織単位を表します。任意の数の組織を作成することができます。チャネルでドキュメントの送信元として、またはメッセージ ポートでドキュメントの送信先として取引先組織を指定することができます。

1 つの取引先をチャネルでドキュメントの送信元として指定し、別の取引先をメッセージ ポートでドキュメントの送信先として指定することもできます。この場合、自分の会社は 2 つの取引先間でサード パーティの中間送信先としての役割を果たします。

アプリケーションの場合と同様に、組織を作成して、BizTalk メッセージ マネージャで送信元または送信先として指定するだけでは、組織間でのドキュメントの流れは有効になりません。取引先組織と BizTalk Server 2000 との間でドキュメントの流れを制御し、指示するには、さらにサーバーを構成する必要があります。

外部取引先が送信元組織として BizTalk Server 2000 にドキュメントをトランスポートするにはいくつかの方法があります。このために必要な構成は、サーバーにドキュメントをトランスポートするためにアプリケーションを統合する方法に似ています。これはすべて BizTalk メッセージ マネージャの外部で行います。詳細については、「送信」を参照してください。

BizTalk Server 2000 から送信先組織として外部の取引先にドキュメントを配信するには、BizTalk メッセージ マネージャの内部と外部の両方で構成が必要になることがあります。メッセージ ポートで指定するトランスポートの種類とアドレスによって、ドキュメントを配信する特定の場所を決定することができます。次に、この場所にアクセスできる送信先組織は、その場所で受信されたドキュメントを処理するように、自分の会社の BizTalk Server、内部アプリケーションの 1 つ、または別のコンポーネントを構成することができます。メッセージ ポートの構成の詳細については、「メッセージ ポートについて」を参照してください。

ここには次のトピックが含まれます。

  • 組織識別子


組織識別子

Microsoft BizTalk Server 2000 とほかの取引先は、組織識別子を使用して、組織を一意に識別します。組織は複数の組織識別子を持つことができますが、各識別子はその組織に一意なものにする必要があります。たとえば、電話番号、URL、または DUNS 番号は、それぞれ組織を一意に識別することができますが、2 つの組織が組織識別子として同じ電話番号を使用することはできません。

組織識別子は、名前、修飾子、および値の 3 つの別個の要素から構成されます。たとえば、ある会社は自社を一意に識別するために電話番号を使用することがあります。この例では、識別子の名前は "電話番号"、その識別子を電話番号として識別する修飾子は番号 12、実際の電話番号の値は (801-555-1079) になります。各組織の識別子の名前は、その識別子の種類を示すために名前の代わりに使用される一意な修飾子を持ちます。たとえば、電話番号識別子の標準修飾子は 12 です。BizTalk Server 2000 は、ドキュメントを処理するときに、組織を識別するために修飾子と値だけを使用します。

各組織には少なくとも 1 つの識別子が必要です。組織を作成するときに、BizTalk メッセージ マネージャは "組織" という名前で識別子を作成します。この識別子の修飾子は OrganizationName で、その値は組織に付けた名前になります。この識別子は既定の識別子としても設定されます。つまり、ほかの識別子が指定されていない場合には、この識別子が使用されます。追加の識別子を作成して、任意の識別子を既定の識別子として指定することができます。OrganizationName の識別子、または指定した既定の識別子を削除することはできません。既定の識別子は、メッセージ ポートまたはチャネルで異なる識別子を選択して上書きしない限り、組織を識別するために使用されます。

BizTalk Server 2000 はドキュメントを処理し、トランスポートするときに、エンベロープ ヘッダーに送信先組織と送信元組織の組織識別子を挿入します。BizTalk Server 2000 は、ドキュメントを受信したときに、送信元組織と送信先組織の識別子のデータを検索します。次に、サーバーはその識別子とドキュメント定義名を使用して、そのドキュメントを処理するために使用するチャネルを決定します。

EDI 書式のインターチェンジには、組織識別子に対する制限があります。X12 エンベロープで組織識別子を使用する場合は、"既定の組織" という名前の組織識別子、3 文字以上の修飾子を持つ識別子、または 16 文字以上の値を持つ識別子は使用しないでください。EDIFACT エンベロープで組織識別子を使用する場合は、"既定の組織" という名前の組織識別子、5 文字以上の修飾子を持つ識別子、または 36 文字以上の値を持つ識別子は使用しないでください。

関連項目

組織の作成と管理

組織について


ドキュメント定義について

ドキュメント定義は、Microsoft BizTalk Server 2000 によって処理される特定の種類のドキュメントを表します。ドキュメント定義は、チャネルの受信ドキュメントまたは送信ドキュメントの種類を表し、ドキュメント仕様へのポインタになります。ドキュメント仕様は、ドキュメントの構造、種類、およびバージョンを定義します。任意の数のドキュメント定義で同じドキュメント仕様を使ったり、同じドキュメント定義を任意の数のチャネルで使用することができます。

チャネルの受信ドキュメントと送信ドキュメントの書式と構造が同じ場合は、両方に対して同じ仕様を使うことができます。同じではない場合は、受信ドキュメントの書式または構造を送信ドキュメントの書式または構造に変換するためにサーバーが使用するマップを指定する必要があります。

BizTalk Server 2000 は、ドキュメントを受信したときに、受信ドキュメント定義と一致する適切なチャネルを 1 つ以上識別します。各チャネルの受信ドキュメント定義は、仕様を示します。サーバーはその仕様を使って、非 XML 受信ドキュメントを元の書式から中間 XML 形式に変換し、そのドキュメントの構造を検証します。そのチャネルの送信ドキュメント定義も、仕様を示します。サーバーは、その送信ドキュメント仕様を使って、送信ドキュメントのデータ構造を検証します。必要があれば、サーバーはその仕様を使って、送信ドキュメントを XML 形式から、送信先組織または送信先アプリケーションが認識し、使用することができる書式に変換することもできます。送信先は、チャネルと関連付けられたメッセージ ポートで指定します。

ドキュメント定義のドキュメント仕様は省略できますが、ほとんどの場合は選択する必要があります。仕様を選択しない場合は、処理するデータが以下の制約を受けます。

  • データは、受信側で XML に変換されないか、または送信側で XML から変換されません。

  • データに誤りがないことを確認するための検証が行われません。

  • チャネル内でマップを使用してデータの構成または書式を変換することはできません。

  • グローバル追跡項目または選択条件を指定することができません。

Unicode XML 形式ではないデータのパススルー送信でドキュメント定義を使用する場合は、ドキュメント仕様は必要ありません。たとえば、データをまったく変換せずに、BizTalk Server 2000 を経由して送信先にバイナリ データを送信する場合があります。この場合、パススルー送信で使用するチャネルの受信ドキュメント定義または送信ドキュメント定義のいずれに対しても、ドキュメント仕様を選択しないでください。

ここには次のトピックが含まれます。

  • ドキュメント データ フィールドの追跡

  • 選択条件について

関連項目

ドキュメント定義の作成および管理

仕様の作成

マッピング仕様

チャネルについて


ドキュメント データ フィールドの追跡

ドキュメント定義では追跡データベースのログに記録する仕様のフィールドを指定することができます。ドキュメント定義で指定するフィールドは、受信ドキュメント定義としてそのドキュメント定義を使用するチャネルによって処理されるすべてのドキュメント インスタンスで追跡されます。これらのフィールドはすべてのチャネルで追跡されるため、グローバル追跡項目と呼ばれます。

チャネルの受信ドキュメント定義を選択するときに、追跡するチャネルの仕様フィールドを指定することができます。チャネルで指定した仕様フィールドは、特定のチャネルによって処理されるドキュメントで、グローバル追跡項目の代わりに追跡されます。

ドキュメント定義またはチャネルで追跡のために指定したフィールドは、そのチャネルの受信ドキュメント定義専用の追跡データベースのログに記録されます。チャネルの送信ドキュメント定義で追跡のために指定されたフィールドは追跡されません。

処理されているドキュメントの追跡データで、操作に関する情報を分析することができます。たとえば、取引先に送信するすべての請求書について、請求書の合計フィールドを追跡することができます。次に、特定の期間にすべての取引先に送信された請求書の総額を決定したり、個々の取引先に対する請求書の総額を決定することができます。

関連項目

ドキュメント定義の作成および管理

BizTalk ドキュメント トラッキングの使用


選択条件について

選択条件とは、Microsoft BizTalk Server 2000 が EDI ドキュメントを処理するためだけに使用する、名前と値の一意な組です。受信 ANSI X12 ドキュメントまたは受信 EDIFACT ドキュメントでは、個々の EDI ドキュメントで利用できるドキュメント定義名がないため、サーバーは選択条件を使用してドキュメント定義を一意に識別し、選択します。

送信 X12 ドキュメントまたは送信 EDIFACT ドキュメントでは、エンベロープにファンクショナル グループ ヘッダー情報を作成するために選択条件を使用します。

ここには次のトピックが含まれます。

  • 受信ドキュメントでの選択条件の使用

  • 送信ドキュメントでの選択条件の使用


受信ドキュメントでの選択条件の使用

受信ドキュメントを処理するために、BizTalk Server 2000 は受信ドキュメント定義の名前を要求します。サーバーは、通常受信ドキュメントのフィールドまたはドキュメントと共に送信されるパラメータのいずれかから受信ドキュメント定義の名前を取得します。詳細については、「送信」を参照してください。

X12 と EDIFACT の受信インターチェンジでは、ドキュメントはファンクショナル グループ ヘッダーまたはインターチェンジ ヘッダーに格納されることがあります。BizTalk Server 2000 は、これらのグループとインターチェンジに格納されているドキュメントを個々に処理します。各ドキュメントのドキュメント関連情報は、ファンクショナル グループ ヘッダーまたはインターチェンジ ヘッダーに格納されているため、サーバーは個々のドキュメントからドキュメント定義名を取得することはできません。また、インターチェンジには異なる種類のドキュメントの複数のグループが含まれることがあるため、ドキュメント定義を識別するために、サーバーへの送信パラメータとして単一のドキュメント定義名を提供することはできません。

このような場合、BizTalk Server 2000 はファンクショナル グループ ヘッダー (X12 インターチェンジの GS ヘッダーと EDIFACT インターチェンジの UNG ヘッダー) から関連データを抽出することができます。ファンクショナル グループのない EDIFACT インターチェンジでは、インターチェンジ ヘッダーからドキュメント関連データを抽出することができます。このデータの値をドキュメント定義で指定される選択条件の値と一致させることによって、サーバーは適切なドキュメント定義を一意に識別することができます。

BizTalk Server 2000 で選択基準の値を受信インターチェンジの対応するヘッダー要素 (エレメント) と一致させるためには、次の表に示されるとおりに選択条件を入力する必要があります。

X12 ヘッダー要素 (エレメント)

名前 | 要件 | GS 要素 (エレメント)
functional_identifier | 必須 | GS01
application_sender_code | 必須 | GS02
application_receiver_code | 必須 | GS03
standards_version | 必須 | GS08

EDIFACT ヘッダー要素 (エレメント)

名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
functional_identifier | 必須 | S009、0065 | 0038
application_sender_code | 省略可 | 未使用 | S006、0040
application_receiver_code | 省略可 | 未使用 | S007、0044
standards_version_type | 必須 | S009、0052 | S008、0052
standards_version_value | 必須 | S009、0054 | S008、0054

関連項目

ドキュメント定義の作成および管理

選択条件について

送信ドキュメントでの選択条件の使用


送信ドキュメントでの選択条件の使用

送信 X12 ドキュメントまたは送信 EDIFACT ドキュメントを処理するために、BizTalk Server 2000 は適切な書式の有効なエンベロープに各ドキュメントを配置します。エンベロープを作成するために、サーバーは選択条件の値データをグループ ヘッダーとメッセージ ヘッダーの対応するフィールドに挿入します。ヘッダーを構築するために、サーバーはチャネルの送信ドキュメント定義に含まれる選択条件の値を使用します。

たとえば、選択条件の 1 つとして functional_identifier/ORDERS という名前と値の組を持つドキュメント定義を作成するとします。次に、これをチャネルの送信ドキュメント定義として使用した場合は、functional_identifier という名前の選択条件に対応するグループ ヘッダー フィールドの値が、エンベロープ ヘッダーで ORDERS に設定されます。

BizTalk Server 2000 で対応するヘッダー要素 (エレメント) に選択条件の値を挿入するには、次の表に示されるとおりに選択条件を入力する必要があります。

X12 ヘッダー要素 (エレメント)

名前 | 要件 | GS 要素 (エレメント)
functional_identifier | 必須 | GS01
application_sender_code | 必須 | GS02
application_receiver_code | 必須 | GS03
standards_version | 必須 | GS08

EDIFACT ヘッダー要素 (エレメント)

名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
functional_identifier | 必須 | S009、0065 | 0038
application_sender_code | 省略可 | 未使用 | S006、0040
application_receiver_code | 省略可 | 未使用 | S007、0044
standards_version_type | 必須 | S009、0052 | S008、0052
standards_version_value | 必須 | S009、0054 | S008、0054

関連項目

ドキュメント定義の作成および管理

選択条件について

受信ドキュメントでの選択条件の使用


エンベロープについて

エンベロープはトランスポートのために電子ビジネス データをカプセル化します。エンベロープは、通常ヘッダー情報とフッター情報、またはヘッダー情報だけから構成されます。指定するエンベロープ プロパティは、受信インターチェンジを開いたり、送信インターチェンジを作成するために必要な情報を Microsoft BizTalk Server 2000 に提供します。エンベロープを作成する場合は、エンベロープ書式を指定します。特定の種類の書式では、エンベロープ仕様を選択することもできます。

BizTalk Server 2000 によってサポートされているエンベロープ書式は、カスタム XML、ANSI X12、UN/EDIFACT、(可変長 (区切り文字) および固定長) フラット ファイル、カスタム、および Reliable 書式があります。Reliable 書式では、BizTalk Framework 2.0 に準拠するエンベロープが処理されます。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。カスタム エンベロープ書式を指定する場合は、受信エンベロープ処理用のカスタム パーサー コンポーネントと、送信エンベロープ処理用のカスタム シリアライザ コンポーネントを作成し、登録する必要があります。詳細については、「IBizTalkParserComponent インターフェイスの使用」と「IBizTalkSerializerComponent インターフェイスの使用」を参照してください。

BizTalk Server 2000 でカスタム XML 形式またはフラット ファイル書式の受信インターチェンジを処理できるようにするには、対応する書式でエンベロープを作成する必要があります。BizTalk Server 2000 でカスタム書式の受信インターチェンジを処理できるようにするには、カスタム パーサー コンポーネントを作成し、登録します。BizTalk Server 2000 は、BizTalk メッセージ マネージャで作成したエンベロープを使用しなくても、ANSI X12 書式、UN/EDIFACT 書式、または Reliable 書式で受信インターチェンジを処理することができます。

任意の書式で送信ドキュメントを処理するには、エンベロープを作成して、メッセージ ポートでそのエンベロープを選択し、必要なエンベロープ書式とヘッダー情報でインターチェンジを作成する必要があります。BizTalk Server 2000 は、各送信インターチェンジにドキュメントを 1 つだけ配置します。

メッセージ ポートで X12 書式または EDIFACT 書式のエンベロープを選択した場合は、区切り記号とインターチェンジ制御番号も指定する必要があります。これらの EDI プロパティは、そのメッセージ ポートで使用するために選択されたエンベロープだけに適用されます。カスタム書式のエンベロープを選択する場合は、区切り記号とインターチェンジ制御番号は省略することができ、カスタム パーサーまたはカスタム シリアライザ コンポーネントの要件に依存します。X12、EDIFACT、またはカスタム エンベロープを使用するメッセージ ポート用にチャネルを作成する場合は、そのチャネルとメッセージ ポートの組み合わせによって処理されるドキュメントだけに適用するファンクショナル グループ制御番号を指定することができます。

メッセージ ポートで選択するエンベロープの書式は、そのエンベロープに含まれる送信ドキュメントの書式と一致する必要があります。送信ドキュメントの書式は、チャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに対して X12 書式のエンベロープを選択した場合は、そのメッセージ ポート用にチャネルを作成するときに、X12 書式を持つ仕様をポイントする送信ドキュメント定義を選択する必要があります。

メッセージ ポートを作成するときにエンベロープを指定しない場合は、データはヘッダーのない XML 形式で送信されます。

注

  • BizTalk Framework 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2000 はエンドポイントと考えてください。アプリケーションまたは取引先から、BizTalk Framework 2.0 に準拠したドキュメントが BizTalk Server 2000 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

ここには次のトピックが含まれます。

  • 受信処理のためのエンベロープの使用

  • 送信処理のためのエンベロープの使用

関連項目

エンベロープの作成および管理

メッセージ ポートについて


受信処理のためのエンベロープの使用

Microsoft BizTalk Server 2000 は、BizTalk メッセージ マネージャを使用して作成されるエンベロープを使用しなくても、X12 書式または EDIFACT 書式で、受信インターチェンジを処理することができます。

BizTalk Server 2000 でフラット ファイル書式の受信インターチェンジを処理するには、BizTalk メッセージ マネージャを使用して、エンベロープを作成する必要があります。そのエンベロープは、サーバーが使用できる仕様を示し、インターチェンジを解釈して開く必要があります。エンベロープの名前は、処理のためにインターチェンジが送信されるときにサーバーに提供する必要があります。詳細については、「送信」を参照してください。

BizTalk Server 2000 でカスタム XML 形式の受信インターチェンジを処理するには、BizTalk メッセージ マネージャを使用して、エンベロープを作成する必要があります。ただし、サーバーは送信時に提供されるエンベロープの名前がなくても、インターチェンジを解釈して開く必要があるカスタム XML エンベロープを検出することができます。送信時にエンベロープの名前をサーバーに提供することはできますが、これは必須ではありません。詳細については、「送信」を参照してください。

BizTalk Server 2000 でカスタム書式の受信インターチェンジを処理するには、インターチェンジを開くためにカスタム パーサーを作成する必要があります。詳細については、「IBizTalkParserComponent インターフェイスの使用」を参照してください。

受信インターチェンジを処理するために作成するエンベロープは、サーバーによって使用されるメッセージ ポートで選択する必要はありません。送信インターチェンジを処理するために使用するエンベロープだけをメッセージ ポートで選択する必要があります。

関連項目

エンベロープの作成および管理

エンベロープについて

送信処理のためのエンベロープの使用


送信処理のためのエンベロープの使用

メッセージ ポートは、Microsoft BizTalk Server 2000 から指定された送信先へのデータの送信フローを規定します。メッセージ ポートを作成するときに、そのメッセージ ポートによって処理されるドキュメントのエンベロープを選択することができます。エンベロープを選択する場合は、エンベロープ書式はそのエンベロープに含まれるドキュメントの書式と一致する必要があります。ドキュメントの書式は、チャネルの送信ドキュメント定義で参照される仕様によって決定されます。BizTalk メッセージ マネージャを使用してエンベロープを作成したら、任意の数のメッセージ ポートでそのエンベロープを使用することができます。

BizTalk Server 2000 が送信ドキュメントを処理する場合に、サーバーはメッセージ ポートで選択されたエンベロープのプロパティを使用して、ドキュメントをカプセル化したり、プレフィックスを付けることによって、インターチェンジを作成します。メッセージ ポートにエンベロープを指定しない場合は、データはヘッダーまたはフッターのない XML 形式で送信されます。カスタム XML 形式を指定し、エンベロープ仕様を選択しなかった場合、データは既定では Reliable 書式で送信されます。Reliable 書式では、BizTalk Framework 2.0 に準拠するエンベロープが処理されます。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

BizTalk Server 2000 でカスタム書式の送信インターチェンジを処理するには、インターチェンジを作成するために、カスタム シリアライザを作成する必要があります。詳細については、「IBizTalkSerializerComponent インターフェイスの使用」を参照してください。

X12 書式または EDIFACT 書式でエンベロープを選択する場合は、インターチェンジ制御番号と区切り記号を指定する必要があります。インターチェンジ制御番号は、メッセージ ポートを使用して処理されるドキュメントを識別し、追跡するために使用します。インターチェンジ制御番号は、エンベロープとメッセージ ポートが使用されるたびに、1 つずつ増加します。区切り記号は、エンベロープとエンベロープに含まれるドキュメントのレコードとフィールドを分けるために使用します。カスタム書式のエンベロープでは、インターチェンジ制御番号と区切り記号は省略できます。

重要

  • メッセージ ポートのエンベロープ書式は、関連付けられたチャネルの送信ドキュメント定義によって参照される仕様のドキュメント型の書式と一致させる必要があります。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。

関連項目

エンベロープの作成および管理

エンベロープについて

受信処理のためのエンベロープの使用


受信確認について

取引先とドキュメントを交換する場合に、送信するドキュメントに対して受信確認を受け取ること、または取引先が自分の会社に送信するドキュメントに対して受信確認を生成することが、ビジネス プロセスで要求される場合があります。

BizTalk メッセージ サービスには、インターチェンジのために受信確認を処理する 2 つの方法があります。X12 パーサーまたは EDIFACT パーサー、受信確認を要求するカスタム パーサーを使用するインターチェンジでは、チャネル プロパティを使用するように BizTalk メッセージ マネージャを構成して、受信確認を処理することができます。XML パーサーを使用するインターチェンジでは、データの信頼できる配信を保証するために、受信確認を自動的に処理する、信頼できるメッセージを使用するオプションがあります。

ここには次のトピックが含まれます。

  • チャネルを使用した受信確認処理

  • 信頼できるメッセージを使用した受信確認処理


チャネルを使用した受信確認処理

ここでは、チャネル プロパティを使用して受信確認の処理を制御するように、BizTalk メッセージ サービスを構成する方法について説明します。送信先のシステムは、送信元のシステムに受信確認を生成 (送信) するように構成されています。送信元のシステムは送信先システムに受信確認を要求し、受信確認を受け取ります。その後、受け取った受信確認を元のインターチェンジと照合します。この構成は、X12 パーサー、EDIFACT パーサー、または受信確認を要求するカスタム パーサーを使用するインターチェンジを処理する場合にのみ適用されます。カスタム パーサーの作成の詳細については、「IBizTalkParserComponent インターフェイスの使用」を参照してください。XML パーサーを使用するインターチェンジを処理する場合は、「信頼できるメッセージを使用した受信確認処理」を参照してください。

カスタム パーサーを使用し、元のインターチェンジと受信確認を照合する場合は、カスタム関連付けコンポーネントを作成する必要があります。

送信元のシステムが受信確認を受信するには、送信先のシステムも、受信確認を送信するように構成する必要があります。受信確認を要求するように送信元システムのチャネルを構成するだけでは、受信確認を受信するために十分ではありません。

次の図は、受信確認を処理するためのチャネル プロパティを使用した、送信元システムおよび送信先システムの構成を示しています。

受信確認の生成と送信
受信確認の受信と照合
インターチェンジの受信と処理
送信先のシステム
送信元のシステム
送信先のシステムへの
メッセージ ポート
注文書
パーサー
送信元の
システムへの
メッセージ
ポート
送信
ドキュメント定義
受信確認
ドキュメント仕様
ドキュメント仕様
受信
ドキュメント定義
マップ
受信確認チャネル
既定受信
アプリケーションへの
メッセージ ポート
送信元のシステムからの
チャネル
ドキュメント
仕様
受信確認の
ドキュメント定義
注文書のチャネル
インターチェンジの生成と送信

ここには次のトピックが含まれます。

  • チャネル受信確認のための送信元システムの構成

  • チャネル受信確認のための送信先システムの構成


チャネル受信確認のための送信元システムの構成

ここでは、インターチェンジ を 取引先に送信し、チャネル プロパティを使用して受信確認を処理するように BizTalk メッセージ サービスを構成する方法について説明します。

インターチェンジを処理し、送信先システムにトランスポートするには、チャネルとメッセージ ポートを作成する必要があります。送信先システムが返す受信確認を処理するためにチャネルとメッセージ ポートを作成する必要はありません。ただし、返されたときに受信確認を検証するためにサーバーが使用するドキュメント定義を作成する必要があります。

送信先システムにインターチェンジを送信し、チャネル プロパティを使用して受信確認を処理するように BizTalk メッセージ サービスを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • インターチェンジのために元のドキュメントの受信ドキュメント定義と送信ドキュメント定義の仕様を作成します。受信したときに受信確認を検証するためにサーバーが使用する、ドキュメント定義の仕様も作成する必要があります。
  • 仕様の作成と検証

    注

    • チャネルの送信ドキュメント定義では、X12 などの送信先システムによって要求される書式を使う仕様を作成する必要があります。

    送信先システムの BizTalk メッセージ サービスがインターチェンジを処理する場合に、パーサーは受信確認を要求したとき、次の処理を行います。

  • インターチェンジからヘッダー要素 (エレメント) を抽出します。

  • 既定受信を生成します。

  • ヘッダー要素 (エレメント) を既定受信に挿入します。

    インターチェンジの処理に使われる、チャネルの送信ドキュメント定義用の仕様は、送信元システムにおける処理のために、次のフィールドを含んでいる必要があります。このフィールドは、受信確認を検証するためのドキュメント定義用の仕様にも含まれていなければなりません。送信元システムはこれらの要素 (エレメント) を使用して、受信確認と元のインターチェンジとを照合します。

    次に X12 ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version

    次に EDIFACT ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version_type

    • standards_version_value
BizTalk メッセージ マネージャ
  • 受信確認のチャネルとドキュメント定義を作成するために、受信ドキュメント定義と送信ドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • ドキュメント定義では、上で作成した仕様を選択する必要があります。詳細については、「ドキュメント仕様の選択」を参照してください。

    • 受信確認のドキュメント定義も作成する必要があります。
  • 送信元システムに受信確認をトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • はじめに受信確認を処理するために、メッセージ ポートおよび関連付けられた受信確認チャネルを作成する必要があります。元のインターチェンジを処理するためにチャネルを作成するときに、受信確認チャネルを指定する必要があります。
  • 送信先システムにインターチェンジをトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成
  • 取引先からの元のインターチェンジを処理するためにチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページまたは [送信元組織] ページで、[受信確認を要求する] チェック ボックスをオンにします。

    • [受信確認を要求する] の [受信間隔 (分)] ボックスで、元のインターチェンジを再送信する前に、受信確認を受信するために待機する時間を設定します。詳細については、「送信元アプリケーションのプロパティの設定」または「送信元組織のプロパティの設定」を参照してください。
BizTalk ドキュメント トラッキング
  • 元のインターチェンジは追跡データベースのログに記録され、受信状況 (nACKStatus) フィールドは "Pending" に設定されます。追跡データベースの受信状態は、後に受信確認処理の状態を反映して変更されます。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について

送信元システムでの受信確認の送信

受信確認は、ほかのドキュメントと同じ方法で BizTalk メッセージ サービスに送信されます。受信確認が送信されると、X12 パーサーと EDIFACT パーサーは、ほかのドキュメントから受信確認を区別し、受信確認を元のインターチェンジと照合することをサーバーに指示します。

重要

  • 受信確認は、送信パラメータを使用せずに、BizTalk メッセージ サービスに送信する必要があります。


チャネル受信確認のための送信先システムの構成

ここでは、取引先から受信したインターチェンジを処理する方法、およびBizTalk メッセージ サービスを、チャネル プロパティを使用して、受信確認を生成するように構成する方法について説明します。まず、送信インターチェンジを処理し、それを送信先システムにトランスポートするためのチャネルとメッセージ ポートを作成する必要があります。送信先システムが返す受信確認を処理するためにチャネルまたはメッセージ ポートを作成する必要はありません。パーサーは、ドキュメント定義のみを使用して受信確認を処理します。

送信元システムからのインターチェンジを処理し、チャネル プロパティを使用して受信確認を送信するように BizTalk メッセージ サービスを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 受信確認チャネルを作成するために使用する受信ドキュメント定義と送信ドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • 受信確認チャネルの受信ドキュメント定義では、既定受信仕様を使います。この仕様は WebDAV リポジトリにあります。

    • 受信確認チャネルの送信ドキュメント定義では、ビジネス プロセスによって要求される書式を使う仕様を作成する必要があります。

    送信先システムの BizTalk メッセージ サービスが受信インターチェンジを処理する場合に、パーサーは受信確認を要求したとき、次の処理を行います。

    • グループのヘッダー要素 (エレメント) を抽出します。

    • 既定受信を生成します。

    • ヘッダー要素 (エレメント) を既定受信に挿入します。

    受信確認チャネル用の送信ドキュメント仕様には、これらのヘッダー要素 (エレメント) のためのフィールドが含まれている必要があります。送信元システムは、ヘッダー要素 (エレメント) を使用して受信確認と元のインターチェンジとを照合します。

    次に X12 ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version

    次に EDIFACT ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version_type

    • standards_version_value
  • チャネルを作成して、送信元システムからの元のインターチェンジを処理するために使用する受信ドキュメント定義と送信ドキュメント定義の仕様を作成します。
  • 仕様の作成と検証
BizTalk マッパー
  • 受信確認チャネルのマップを作成します。
  • 新しいマップの作成

    注

    • 受信確認チャネルを作成する場合は、マップを指定する必要があります。マップは、既定受信を送信ドキュメント用の適切なドキュメント型に変換するために使用されます。

    • 使用するビジネス プロセスで必要なドキュメント型と一致している場合は、BizTalk Server 2000 に用意されているマップを使用できます。これらのマップは WebDAV リポジトリから取得することができます。

      – または –

    • 既定受信仕様とビジネス プロセスで要求されるドキュメント型と一致する仕様を使って、独自のマップを作成することができます。
BizTalk メッセージ マネージャ
  • 受信確認チャネルと元のインターチェンジを処理するために使用するチャネルのドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • ドキュメント定義では、上で作成した仕様を選択する必要があります。詳細については、「ドキュメント仕様の選択」を参照してください。

    • 元のインターチェンジの処理に使われるチャネルのためのドキュメント定義も作成する必要があります。これらの仕様の構成は、ビジネス プロセスによって異なります。
  • 送信元システムに受信確認をトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • 元のインターチェンジのために使用されるメッセージ ポートと受信確認チャネルを作成する前に、受信確認を処理するためのメッセージ ポートと、それに関連付けられた受信確認チャネルを作成してください。元のインターチェンジを処理するためにチャネルを作成するときに、受信確認チャネルを指定する必要があります。
  • 受信確認を処理するために、アプリケーションからの受信確認チャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [全般情報] ページで、[受信確認チャネルとして使用する] チェック ボックスをオンにします。

    • チャネル ウィザードの [送信元アプリケーション] ページで、[名前] ボックスの一覧からアプリケーションを選択します。

      既定の組織用のアプリケーションを作成して、パーサーによって生成される受信確認を指定するために使うこともできます。

    • チャネル ウィザードの [受信ドキュメント] ページで、[参照] をクリックし、以前に作成した、既定受信仕様を使うドキュメント定義を参照します。

    • チャネル ウィザードの [送信ドキュメント] ページで、[参照] をクリックし、以前に作成した、ビジネス プロセスに必要なドキュメント型で仕様を使っているドキュメント定義を参照します。
  • 元のインターチェンジに含まれるドキュメントを意図される送信先にトランスポートするために、メッセージ ポートを作成します。
 メッセージ ポートの作成

注

  • このメッセージ ポートは、受信確認を処理するために特別な構成を要求しません。

  • 取引先からの元のインターチェンジを処理するためにチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元組織] ページで、[受信確認を生成する] チェック ボックスをオンにします。

    • [受信確認を生成する] で [参照] をクリックし、その受信確認を処理するために作成した受信確認チャネルを選択します。詳細については、「送信元組織のプロパティの設定」を参照してください。

    • チャネル ウィザードの [詳細構成] ページの [再試行のオプション] ボックスで、再試行の回数と間隔を設定することができます。詳細については、「詳細構成のプロパティの設定」を参照してください。
BizTalk ドキュメント トラッキング
  • 元のインターチェンジと受信確認は、追跡データベースのログに記録されます。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について


信頼できるメッセージを使用した受信確認処理

ここでは、BizTalk Framework 2.0 に準拠するインターチェンジを作成する信頼できるメッセージ エンベロープを使用して、受信確認を送受信するように BizTalk メッセージ サービスを構成する方法について説明します。信頼できるメッセージを使用すると、データの信頼できる配信を確保するために、受信確認を自動的に処理することができます。BizTalk Framework 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。X12、EDIFACT、またはカスタム パーサーを使用するインターチェンジを送受信する場合は、「チャネルを使用した受信確認処理」を参照してください。

BizTalk メッセージ マネージャを使用して、送信インターチェンジで Reliable エンベロープ書式を使用するようにメッセージ ポートを構成することができます。信頼できるメッセージ書式を使用するエンベロープのヘッダーには、常に返信先 URL アドレスを含む必要があります。返信先アドレスは、送信先システムによって使用され、受信確認をインターチェンジ送信者システムに送信します。

ここには次のトピックが含まれます。

  • 信頼できるメッセージ受信確認のための送信元システムの構成

  • 信頼できるメッセージ受信確認のための送信先システムの構成


信頼できるメッセージ受信確認のための送信元システムの構成

送信先システムにインターチェンジを送信し、信頼できるメッセージを使用して受信確認を処理するように BizTalk メッセージ サービスを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk Server 管理コンソール
  • [信頼できるメッセージの返信先 URL] ボックスに入力します。
  • サーバー グループの全般プロパティの構成

    注

    • BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2000] を展開し、構成するサーバー グループをクリックします。

    • [操作] メニューの [プロパティ] をクリックします。

    • [BizTalk Server グループのプロパティ] ダイアログ ボックスの [信頼できるメッセージの返信先 URL] ボックスに、信頼できるメッセージ配信の受信確認を受信するためにこのサーバー グループが使用する URL を入力します。

      信頼できるメッセージ エンベロープを使用する送信インターチェンジを作成する場合は、サーバーはこの [信頼できるメッセージ返信先 URL] の内容をその送信インターチェンジのヘッダーに自動的に挿入します。また、サーバーは再送信キューに元のインターチェンジを配置します。サーバーはチャネルで指定された再試行のオプションを使用して、受信確認が受信されるまで元のインターチェンジを再送信する回数を決定します。
BizTalk メッセージ マネージャ
  • Reliable エンベロープ書式を使用するエンベロープを作成します。
  • エンベロープの作成

    注

    • [新しいエンベロープ] ダイアログ ボックスの [エンベロープ書式] ボックスの一覧で、[RELIABLE] をクリックします。

    • カスタム XML 形式を選択し、仕様を選択しない場合、エンベロープの書式は既定で Reliable 書式になります。
  • 送信先システムに元のインターチェンジをトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

  • 新しいメッセージ ポート ウィザードの [エンベロープ情報] ページで、先ほど作成したエンベロープを選択します。詳細については、「エンベロープ情報のプロパティの設定」を参照してください。
  • 元のインターチェンジを処理するためのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページまたは [送信元組織] ページでは、受信確認に関するチェック ボックスは何もオンにしないでください。

    • チャネル ウィザードの [詳細構成] ページの [再試行のオプション] ボックスで、再試行の回数と間隔を設定することができます。詳細については、「詳細構成のプロパティの設定」を参照してください。
BizTalk ドキュメント トラッキング
  • 送信元システムで、元の送信インターチェンジは追跡データベースのログに記録されます。ただし、返される受信確認は記録されません。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について


信頼できるメッセージ受信確認のための送信先システムの構成

送信先システムのためのBizTalk メッセージ サービスが、信頼できるメッセージ書式のインターチェンジを受信した場合、BizTalk メッセージ サービスは特別なドキュメント定義、チャネル、およびメッセージ ポートを使用して、受信確認の処理および送信元システムへのトランスポートを行います。これらの特別なシステム オブジェクトは、BizTalk メッセージ マネージャでは表示されず、予約済みシステム名を使用して類似のオブジェクトを作成することはできません。

サーバーは、受信確認の送信先アドレスとして、受信インターチェンジのヘッダーに含まれる返信先アドレスを使用します。

送信元システムで信頼できるメッセージ返信先 URL として SMTP アドレスを指定している場合を除いて、送信先の BizTalk メッセージ サービスを、信頼できるメッセージ エンベロープで送信されたインターチェンジに対して受信確認を返すようにさらに構成する必要はありません。SMTP アドレスに受信確認を送信するには、その受信確認のヘッダーに From アドレスを挿入するようにサーバーを構成する必要があります。

BizTalk Server 2000 をインストールしたときに、既定の組織用に特別な組織識別子が作成されます。この識別子の名前は "信頼できるメッセージ受信確認 SMTP 送信元アドレス" です。この識別子を削除することはできません。SMTP アドレスに信頼できるメッセージ受信確認を送信する場合は、サーバーはこの組織識別子に対して指定した値を From アドレスとしてインターチェンジ ヘッダーに挿入します。

BizTalk メッセージ サービスを、SMTP の信頼できるメッセージ返信先 URL を使用して送信元システムへ受信確認を送信するように構成するには、次の表に示した手順に従ってください。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk メッセージ マネージャ
  • 既定の組織の、信頼できるメッセージ受信確認 SMTP 送信元アドレスの組織識別子を構成します。
  • 既定の組織の構成

    注

    • 既定の組織を開きます。

    • [組織のプロパティ] ダイアログ ボックスの [識別子] タブをクリックします。

    • [組織の識別子] ボックスの一覧で、[信頼できるメッセージ受信確認 SMTP 送信元アドレス] をクリックし、[編集] をクリックします。

    • [組織のプロパティ] ダイアログ ボックスで、[値] ボックスに識別子の値を入力します。詳細については、「組織識別子の編集」を参照してください。

    重要

    • この識別子の名前と修飾子は変更せず、値のみ変更してください。
  • 送信先システムに元のインターチェンジをトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートに特別な構成は必要ありません。
  • 元のインターチェンジを処理するためのチャネルを作成します。
  • チャネルの作成

    注

    • このメッセージ ポートに特別な構成は必要ありません。
BizTalk ドキュメント トラッキング
  • 送信先システムでは、受信インターチェンジは追跡データベースのログに記録されますが、受信確認は記録されません。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について


同報リストについて

同報リストとは、複数の異なる取引先組織または内部アプリケーションに同じドキュメントを送信することができるメッセージ ポートのグループです。

同報リストを使用すると、複数の取引先組織または既定の組織の内部アプリケーションに同時に同じデータを送信することができます。たとえば、Microsoft BizTalk Server 2000 に情報を 1 回だけ送信することによって、複数の取引先組織に同じカタログ、価格リスト、またはニュースレターを送信することができます。

はじめに、データを受信する取引先組織または内部アプリケーションごとにメッセージ ポートを作成してから、そのメッセージ ポートを同報リストに追加する必要があります。オープンなメッセージ ポートは、同報リストに追加できません。追加の取引先組織または内部アプリケーション用に新しいメッセージ ポートを作成してから、そのメッセージ ポートを既存の同報リストに追加することができます。詳細については、「メッセージ ポートの作成」を参照してください。

同報リストごとに少なくとも 1 つのチャネルを作成しなければ、その同報リストは動作しません。詳細については、「チャネルの作成」を参照してください。

BizTalk Server 2000 は、同報リストに関連するチャネルを呼び出す場合、データを処理するために同報リストと関連付けられたチャネルだけを呼び出します。同報リストの個々のメッセージ ポートと関連付けられたチャネルは呼び出されません。サーバーは、各メッセージ ポートのプロパティを連続的に使用して、メッセージ ポートで指定された送信先にデータをトランスポートします。

同報リストは、次の点でオープンなメッセージ ポートとは異なります。

  • 同報リストでは、チャネルからの各ドキュメントは複数の送信先に配信することができます。オープンなメッセージ ポートでは、チャネルからの各ドキュメントは 1 つの送信先だけに配信されます。

  • 同報リストでは、異なる取引先組織に対して情報を送信するために、メッセージ ポートを追加する必要があります。オープンなメッセージ ポートでは、異なる取引先組織に情報を送信するためにメッセージ ポートのプロパティを変更する必要はありません。

関連項目

同報リストの使用


BizTalk メッセージ構成オブジェクト モデルへのアクセス

ここでは、プログラムから BizTalk メッセージ構成オブジェクト モデルにアクセスする方法について説明します。Microsoft BizTalk Server 2000 を使用して、取引先の関係を管理して、データを交換するためのメッセージ ポートとチャネルを設定する方法を説明します。また、ドキュメント定義とエンベロープの作成方法、組織のプロパティの設定方法も説明します。詳細については、次のトピックを参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • COM インターフェイス、列挙、エラー メッセージの詳細については、「オブジェクト モデルに関するリファレンス」を参照してください。

  • コード例については、「BizTalk メッセージ サービスのコード サンプル」を参照してください。

BizTalk メッセージ構成オブジェクト モデルは、グラフィカル ユーザー インターフェイスの BizTalk メッセージ マネージャを使用して構成することもできます。詳細については、「BizTalk メッセージ マネージャの使用」を参照してください。


概念

ここでは、BizTalk メッセージ構成オブジェクト モデルにアクセスする方法を理解するうえで重要な概念について説明します。次のトピックが含まれます。

  • BizTalk メッセージ構成オブジェクト モデル

  • チャネル

  • メッセージ ポート

  • オープンネス

  • 組織

  • ドキュメント定義

  • エンベロープ

BizTalk メッセージ構成オブジェクト モデルを使用するコード例については、「BizTalk メッセージ サービスのコード サンプル」を参照してください。


BizTalk メッセージ構成オブジェクト モデル

BizTalk メッセージ構成オブジェクト モデルを使用すると、アプリケーションはメッセージ ポートとチャネルを簡単に設定、メンテナンス、および取得でき、取引先との関係の確立およびアプリケーションとアプリケーションの統合を実現できます。BizTalk メッセージ構成オブジェクト モデルを使用して、エンベロープおよびドキュメント定義を作成したり、組織のプロパティを設定することもできます。

BizTalk メッセージ構成オブジェクト モデルは、構造化照会言語 (SQL) データベースを使用してポート構成および他の関連データを格納します。オブジェクト インスタンス (メッセージ ポートや組織など) の一覧を問い合わせると、ActiveX Data Objects (ADO) レコード セットが返されます。

BizTalk メッセージ構成オブジェクト モデルは、Microsoft BizTalk Server 2000 がアプリケーションと取引先の間の構造化ドキュメントのインターチェンジを構成するために必要な構成データを公開するコンポーネント オブジェクト モデル (COM) オブジェクトで構成されています。COM オブジェクトは、データベースに格納できるメモリ上のデータのインスタンスを表します。

特に注記がない限り、すべてのオブジェクト プロパティは読み取り/書き込みです。

関連項目

BizTalk メッセージ構成オブジェクト

参照整合性

セキュリティ


BizTalk メッセージ構成オブジェクト

次の表は、BizTalk メッセージ構成オブジェクト モデルのオブジェクトの一覧です。

オブジェクト | 説明
BizTalkChannel | 送信元エンティティと、BizTalkPort オブジェクトとのバインドに関する構成が含まれています。
BizTalkConfig | チャネル、ドキュメント仕様、メッセージ ポートなどのその他の BizTalk オブジェクトを作成および取得します。
BizTalkDocument | ドキュメントの仕様を識別および記述します。
BizTalkEnvelope | ドキュメントに使用されているエンベロープ書式やエンベロープ スキーマを識別します。エンベロープは、ANSI X12 書式または EDIFACT 書式のドキュメントに必要です。
BizTalkOrganization | 電子データを交換する送信元または送信先を識別します。組織は、外部の取引先、自社、取引先または自社の事業単位を表します。組織には、チャネルの送信元アプリケーションまたはポートの送信先アプリケーションを指定できます。
BizTalkPort | ドキュメント送信の送信先に関連する属性を定義します。
BizTalkPortGroup | ポート グループを構成します。これは、カタログ、価格表、ニュースレターなど、同じドキュメントを取引先グループに送信するすべての BizTalkPort オブジェクトの集まりです。

注意

  • データベースに直接アクセスしないでください。ストアド プロシージャを直接呼び出さないでください。データベースを変更するときは、必ず BizTalk メッセージ構成オブジェクト モデルのメソッドおよびプロパティを使用してください。データベースを直接変更すると、BizTalk メッセージ構成オブジェクト モデルによって適用される多くの制約がバイパスされ、サーバーが正しく動作しなくなったり、データベースが破損したりします。

  • BizTalk メッセージ構成オブジェクト モデルには、設計時にだけアクセスします。BizTalk Server でドキュメントを処理している最中に、使用中のオブジェクトにアクセスすると、予期しない結果を招く場合があります。

  • BizTalk Server 2000 は、BSTR データ型のすべての変数を、NULL で終了する文字列として扱います。BSTR に含まれている NULL 文字の後ろのデータはすべて無視されます。埋め込み NULL 文字が含まれているドキュメントは、パススルー モードを使用して BizTalk Server に送信する必要があります。

関連項目

チャネル

ドキュメント定義

エンベロープ

メッセージ ポート

組織


参照整合性

BizTalk Server 2000 でオブジェクトのインスタンスを作成する場合、参照の依存関係を考慮する必要があります。参照の依存関係は、あるオブジェクトが別のオブジェクトを参照していたり、別のオブジェクトによって依存されていることを示します。たとえば、BizTalkChannel オブジェクトは BizTalkPort オブジェクトを参照しています。

参照整合性を維持するために、別のオブジェクト インスタンスから参照されているオブジェクト インスタンスは削除できません。参照されているオブジェクトがデータベースに存在しているときに、参照整合性が維持されます。

オブジェクトは、作成したときと逆の順序で削除します。別のオブジェクトのインスタンスから参照されているオブジェクトのインスタンスが削除されると、制約エラーが返されます。上の例では、BizTalkChannel オブジェクトによって使用されている BizTalkPort オブジェクトが削除されると、制約エラーが返されます。

次の順序は、オブジェクトの参照整合性を維持するために推奨されるオブジェクトの作成順序です。

  1. BizTalkOrganization

  2. BizTalkDocument

  3. BizTalkEnvelope (必要な場合)

  4. BizTalkPort
    • BizTalkPort オブジェクトには BizTalkOrganization オブジェクトが必要です。

    • BizTalkPort オブジェクトは BizTalkEnvelope オブジェクトを使用することがあります。
  5. BizTalkChannel
    • BizTalkChannel オブジェクトには BizTalkPort オブジェクトが必要です。

    • BizTalkChannel オブジェクトには BizTalkDocument オブジェクトが必要です。

    • BizTalkChannel オブジェクトには BizTalkOrganization オブジェクトが必要です。

    • チャネルがポート グループ用に作成された場合、BizTalkChannel オブジェクトは BizTalkPortGroup オブジェクトを使用することがあります。
  6. BizTalkPortGroup (使用する場合)
    • BizTalkPortGroup オブジェクトには BizTalkPort オブジェクトが必要です。


セキュリティ

BizTalk メッセージ構成オブジェクト モデルのオブジェクトにアクセスする場合、またはオブジェクトを作成する場合、スクリプトまたはアプリケーションは BizTalk Server Administrators グループのユーザー アカウントで実行する必要があります。BizTalk Server Administrators グループは、BizTalk Server 2000 がインストールされると作成されます。このグループには、必要に応じてユーザーを追加することができます。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。


チャネル

BizTalkChannel オブジェクトには、送信元エンティティに関連する構成情報と、BizTalkPort オブジェクトとのバインドに関連する構成情報が含まれています。BizTalk Server 2000 がドキュメントを受信する場合、そのドキュメントを処理するために必要なステップを通じて、特定の BizTalkChannel オブジェクトと、関連付けられた BizTalkPort オブジェクトまたは BizTalkPortGroup の中で関連付けられた BizTalkPort オブジェクトで構成されたプロパティが、サーバーに指示します。複数のチャネルが同じ BizTalkPort オブジェクトにバインドされていることもあります。これは、同じ送信先とドキュメントを交換する複数の送信元エンティティを表します。

入力 BizTalkDocument オブジェクトの種類が出力 BizTalkDocument オブジェクトの種類と異なる場合、BizTalkChannel オブジェクトはドキュメントの変換に使用するマップを識別します。また、ドキュメント トラッキング用のフィールドが含まれている仕様を示し、要求されているログ機能の種類を選択します。

関連項目

チャネル フィルタ

構成

ドキュメント処理

ドキュメント格納

ドキュメント トラッキング

識別


識別

BizTalk Server 2000 は、次のメソッドのうち 1 つを使用して適切な BizTalkChannel オブジェクトを判断して、入力ドキュメントを処理します。

  • 送信元組織の識別子/修飾子/値、送信先組織の識別子/修飾子/値、および BizTalkDocument オブジェクトの名前が、Interchange オブジェクトの Submit メソッドまたは SubmitSync メソッドのパラメータになります。

  • 送信元組織と送信先組織の識別子/修飾子/値、および BizTalkDocument オブジェクトの名前が、ドキュメント インスタンスのヘッダー フィールドに指定されます。

  • BizTalkChannel オブジェクトの名前が、Submit メソッド呼び出しまたは SubmitSync メソッド呼び出しのパラメータになります。

BizTalk Server 2000 は、ドキュメントを受信すると、まず、指定された BizTalkDocument オブジェクトをサポートするすべての BizTalkChannel オブジェクトを識別します。次にサーバーは、各 BizTalkPort オブジェクトを調べて、ドキュメントが送信されたときにドキュメントまたは Submit のパラメータの組織識別子で指定された送信元と送信先の BizTalkOrganization オブジェクトを、SourceOrganization プロパティと DestinationOrganization プロパティが識別しているかどうかを判断します。これには、指定された送信元組織または送信先組織と一致するすべてのオープンなメッセージ ポートが含まれます。

この識別処理は、Submit または SubmitSync のパラメータとして BizTalkChannel オブジェクトの名前を指定することによりバイパスできます。

関連項目

送信


ドキュメント処理

BizTalk Server 2000 が BizTalkChannel オブジェクトを識別すると、サーバーはこのオブジェクトを処理します。オブジェクトは、ドキュメントを処理する段階で、サーバーに指示します。サーバーに指示をするために、BizTalkChannel オブジェクトは独自の規則と、オブジェクトに関連付けられた BizTalkPort オブジェクトの規則に従います。

入力 BizTalkDocument オブジェクトは BizTalkChannel オブジェクトによって出力 BizTalkDocument オブジェクトに関連付けられます。BizTalkPort オブジェクトは、関連付けられる BizTalkChannel オブジェクトを作成する前に作成する必要があります。

BizTalk Server 2000 が BizTalkChannel オブジェクトを処理するときに、サーバーは関連付けられた各 BizTalkPort オブジェクトを呼び出し、サーバーが必要とするドキュメント処理の規則を取得します。BizTalkChannel オブジェクトのプロパティで設定された規則が、ドキュメント処理の初期段階でサーバーに指示して、使用する入力および出力 BizTalkDocument オブジェクト、使用するマップ ファイル、追跡するフィールドなどを決定します。ドキュメントが最終的な出力形式になると、送信元組織と送信先組織で合意した規則に従ってドキュメントを準備およびトランスポートする段階で、BizTalkPort オブジェクトのプロパティがサーバーに指示します。

サーバーは、ドキュメントを送信するときに、送信元組織、送信先組織、および指定された BizTalkDocument オブジェクトに一致する複数の BizTalkPort オブジェクトと BizTalkChannel オブジェクトを識別できます。このため、1 つの入力ドキュメントで複数の出力ドキュメントを生成できます。また、一致する BizTalkPort オブジェクトの異なるトランスポート プロパティを使用することにより、各出力ドキュメントを異なる場所に送信することができます。異なるマップ ファイルを使用して、出力ドキュメント インスタンスごとに元の入力ドキュメントからの異なるデータのサブセットを含めることもできます。


構成

BizTalkChannel オブジェクトは、指定された入力および出力 BizTalkDocument オブジェクトの内部的なドキュメント処理データで構成されています。完全に構成するには、Port プロパティで識別された完全な BizTalkPort オブジェクトが 1 つ、BizTalkChannel オブジェクトに必要です。入力および出力 BizTalkDocument オブジェクトを指定する必要があります。この BizTalkChannel オブジェクトで使用する InputDocument プロパティと OutputDocument プロパティを選択した後、BizTalkPort オブジェクトまたは BizTalkPortGroup オブジェクトを選択する必要があります。

BizTalkChannel オブジェクトの名前は、データベースに存在するその種類のすべてのオブジェクトの中で一意である必要があります。

BizTalkChannel オブジェクトを保存するには、次のプロパティが必要です。

  • InputDocument

  • Port (または PortGroup)

  • OutputDocument

  • Name

BizTalkChannel オブジェクトを作成または保存した後で変更できるのは、次のプロパティだけです。

  • Comments

  • ControlNumberValue

  • MapReference

  • Name

  • TrackFields


チャネル フィルタ

チャネル フィルタを使用すると、フィルタ式を構築して、ドキュメント インスタンスを処理する BizTalkChannel オブジェクトを選択することができます。サーバーはこれらの式を使用して、正しい BizTalkChannel オブジェクトを選択します。Expression プロパティには、ブール値に評価される XPath 式が含まれます。式が true に評価された場合、そのチャネルを使用してドキュメントが処理されます。そうでない場合、ドキュメントを処理するためにチャネルは呼び出されません。

XPath 式を使用して、XML ドキュメントの特定の要素、属性、またはこれらの項目の集合値を取得できます。次の XML ドキュメントがあるとします。

<INVOICE>
    <DATE>12/31/2000</DATE>
    <BILLTO>Vigor Airlines</BILLTO>
    <SUMMARY>
        <ITEM PARTNUMBER="10001" QUANTITY="10"/>
        <ITEM PARTNUMBER="20002" QUANTITY="20"/>
        <TOTAL VALUE="550"/>
    </SUMMARY>
</INVOICE>

このドキュメントに基づいて次の XPath 式を作成すると、このチャネルでは $500 を超える請求書だけを処理できます。

myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"

この例では合計が $500 を超えているので、チャネルで XML ドキュメント インスタンスが処理されます。XPath 式の詳細については、Microsoft の Web サイト (http://www.microsoft.com/japan/developer/library) で "XPath" を検索してください。

注

  • XPath チャネル フィルタ式の生成は、BizTalk メッセージ マネージャを使用してできます。詳細については、「チャネル フィルタ式の追加」を参照してください。


ドキュメント格納

BizTalkLoggingInfo オブジェクトを使用して、ドキュメント インスタンスの利用状況のログを記録する方法を選択できます。既定では、ドキュメントはネイティブ形式でログに記録されます。

次の表は、ドキュメントの格納に使用できるオプションの一覧です。

プロパティ | 説明
すべてのプロパティが空 | ドキュメントのコピーは格納されません。
LogNativeInputDocument | 入力をネイティブ形式で格納します (既定の設定)。
LogNativeOutputDocument | 出力をネイティブ形式で格納します。
LogXMLInputDocument | 入力を XML 形式で格納します。
LogXMLOutputDocument | 出力を中間 (XML) 形式で格納します。
これらの任意の組み合わせ | 上で説明したように格納されます。

注

  • ログ機能を使用するインターチェンジとドキュメントにはサイズに制限があり、制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。


ドキュメント トラッキング

BizTalkChannel オブジェクトは、ドキュメントのインスタンスを追跡するフィールドを含む仕様を示します。指定されたフィールドは、処理されるドキュメントのインスタンスごとに、追跡データベースにログが記録されます。BizTalkChannel オブジェクトの入力 BizTalkDocument オブジェクトを割り当てる場合、このチャネルで追跡するドキュメントのフィールドを指定できます。

BizTalk Server 2000 は、BizTalkChannel オブジェクトを実行するとき、入力 BizTalkDocument オブジェクトを使用して入力ドキュメントを処理します。追跡するように指定したフィールドは、ドキュメントのインスタンスごとに捕捉され、ログに記録されます。関連付けられた BizTalkChannel オブジェクトの出力 BizTalkDocument オブジェクトで追跡するように指定したフィールドは無視されます。ドキュメントの処理中に追跡された情報を取得するには、BTSDocTracking オブジェクトのメソッドを使用します。

処理されている入力ドキュメントの重要なデータをログに記録することによって、稼動中の詳細情報を追跡および分析できます。たとえば、取引先に送信されるすべての請求書について、請求書の合計フィールドをログに記録することができます。これによって、特定の期間にすべての取引先に送信された請求書の総額を確認したり、個々の取引先に対する請求書の総額を確認することができます。

ドキュメント トラッキングの詳細については、「追跡データベース スキーマについて」を参照してください。


メッセージ ポート

概念的には、メッセージ ポートは、取引先組織がドキュメントの送信を互いに受け入れる一連の規則です。送信先、トランスポートの種類、セキュリティ、およびエンベロープに関する情報が含まれます。送信元および送信先 BizTalkOrganization オブジェクトと送信元および送信先エイリアスを識別します。また、必要に応じて、組織に関連付けられたアプリケーションも識別します。

BizTalkPort オブジェクトは、オープンなメッセージ ポートとして指定されていなければ、特定の送信先組織を識別します。オープンなメッセージ ポートに指定されている場合、送信先組織は指定されていません。オープンなメッセージ ポートの場合、関連付けられたドキュメント、または Interchange オブジェクトの Submit メソッドか SubmitSync メソッドのパラメータに送信先トランスポートとアドレス情報が含まれている場合にだけ、BizTalkPort オブジェクトは有効です。

BizTalkPort オブジェクトは、区切り記号定義と EDI インターチェンジ制御番号も識別します。区切り記号は、エンベロープとエンベロープに含まれるドキュメントのレコードとフィールドを分けるために使用します。インターチェンジ制御番号は、エンベロープを使用して送信されるドキュメントを識別し、追跡するために使用します。インターチェンジ制御番号は、実行時にエンベロープが使用されるたびに、1 つずつ増加します。

BizTalkPort オブジェクトは、必要に応じて、エンコード、暗号化、および署名の種類も識別します。

注

  • BizTalkPort オブジェクトを作成および保存した後に、エンドポイントに関連付けられた送信先組織およびオープンネスを変更することはできません。

関連項目

オープンネス

ポート グループ


ポート グループ

BizTalkPortGroup オブジェクトは、同じドキュメントを取引先のグループに送信するためのすべての BizTalkPort オブジェクトの集まりを構成します。たとえば、カタログ、価格表、ニュースレターなど、同じデータが含まれているドキュメントを取引先グループに送信するときに使用できます。Interchange オブジェクトの Submit メソッドを 1 回呼び出すことによって、1 つのドキュメントが複数の取引先に送信されます。

BizTalkPortGroup オブジェクトには、少なくとも 1 つの BizTalkPort オブジェクトが含まれている必要があります。AddPort メソッドまたは RemovePort メソッドを呼び出すことにより、BizTalkPortGroup の BizTalkPort オブジェクトを追加または削除することができます。

BizTalkPortGroup オブジェクトは、少なくとも 1 つの BizTalkChannel オブジェクトに関連付ける必要があります。ポート グループを作成した後、BizTalkChannel オブジェクトで利用できる PortGroup プロパティを使用して、チャネルをポート グループに関連付けます。BizTalk Server 2000 は、ポート グループに関連するチャネルを呼び出す場合、データを処理するためにポート グループと関連付けられたチャネルだけを呼び出します。ポート グループの個々のポートと関連付けられたチャネルは呼び出されません。サーバーは、各ポートのプロパティを連続的に使用して、ポートで指定された送信先にデータをトランスポートします。

注

  • オープンなメッセージ ポートは、ポート グループに追加できません。

  • BizTalk メッセージ マネージャでは、ポート グループを同報リストと呼びます。

関連項目

送信


オープンネス

BizTalkEndPoint オブジェクトの Openness プロパティで、メッセージ ポートまたはチャネルがオープンかどうかが判断されます。オープンな BizTalkPort オブジェクトは、送信先が指定されていないメッセージ ポートです。オープンな BizTalkChannel オブジェクトは、送信元が指定されていないチャネルです。オープンなメッセージ ポートまたはチャネルに不足している情報は、関連付けられたドキュメント、または Interchange オブジェクトの Submit メソッドか SubmitSync メソッドのパラメータで指定する必要があります。

BIZTALK_OPENNESS_TYPE_EX_SOURCE を使用してオープン チャネルを指定する場合、または BIZTALK_OPENNESS_TYPE_EX_DESTINATION を使用してオープンなメッセージ ポートを指定する場合、BizTalkEndPoint オブジェクトの Type、Reference プロパティ、および Store プロパティは指定できません。

注

  • SMTP トランスポートとともにオープンなメッセージ ポートを使用する場合、BizTalkOrganization 識別子の [信頼できるメッセージ受信確認 SMTP 送信元アドレス] に指定されている値を [差出人] アドレスとして使用します。

関連項目

送信


組織

BizTalkOrganization オブジェクトは、電子データを交換する送信元または送信先として機能します。組織は、外部の取引先、自社、取引先または自社の部門を表します。既定の組織には、チャネルの送信元アプリケーションまたはメッセージ ポートの送信先アプリケーションを指定できます。

アプリケーションは、既定の組織のプロパティです。アプリケーションは、BizTalkChannel オブジェクトの送信元アプリケーションとして、または BizTalkPort オブジェクトの送信先アプリケーションとして指定できます。

エイリアス

エイリアスは、BizTalkOrganization オブジェクトの組織識別子です。BizTalkOrganization オブジェクトには既定のエイリアスを 1 つだけ設定する必要があります。ただし、複数のエイリアスを設定することはできます。エイリアスは BizTalkOrganization オブジェクトごとに自動生成されます。既定のエイリアスおよび自動生成されたエイリアスは削除できません。

詳細については、「組織の作成と管理」を参照してください。


ドキュメント定義

BizTalkDocument オブジェクトは、送受信されるドキュメントを記述するために使用されるドキュメント仕様を記述および識別します。ドキュメント仕様は、ドキュメントの構造、検証規則、およびドキュメント仕様の各要素の記述を定義します。BizTalkDocument オブジェクトには、仕様のバージョンと種類が含まれます。仕様の Web Distributed Authoring and Versioning (WebDAV) の場所への参照が含まれることもあります。ドキュメント仕様の詳細については、「仕様の作成と検証」を参照してください。

注

  • Reference プロパティを設定しなければ、ドキュメントの Content プロパティと Namespace プロパティは無効です。

  • BizTalk Server で既に登録されている名前空間を使用する新しい BizTalkDocument オブジェクトを作成すると、新しいドキュメントはその名前空間の Reference プロパティを継承します。名前空間は、作成される新しい Reference に対して一意である必要があります (大文字と小文字は区別されません)。

BizTalkDocument オブジェクトには、BizTalkDocument オブジェクトの名前を利用できないときに、BizTalk Server 2000 がドキュメントのファンクショナル グループ ヘッダーからこのオブジェクトを識別する情報を抽出するための電子データ交換 (EDI) 選択条件も含まれます。

BizTalkDocument オブジェクトは、ドキュメントのインスタンスを追跡するフィールドを含む仕様を示します。指定されたフィールドは、処理されるドキュメントごとに、追跡データベースにログが記録されます。

選択条件

いくつかの EDI 入力インターチェンジでは、ドキュメントはファンクショナル グループ エンベロープに含まれます。BizTalk Server 2000 は、このようなドキュメントを処理する場合、各ドキュメントのフィールドから BizTalkDocument オブジェクトの名前を取得することができません。また、含まれるドキュメントの種類は複数あるので、Interchange オブジェクトの Submit メソッドのパラメータとして単一の名前を指定することもできません。この場合、サーバーはドキュメントに関連するデータをファンクショナル グループ ヘッダー (たとえば、ANSI X12 インターチェンジの GS ヘッダー) 内で検出することができます。BizTalkDocument オブジェクトの PropertySet プロパティで指定された対応する選択条件とこのデータを比較することによって、サーバーは BizTalkDocument オブジェクトを一意に識別することができます。BizTalkDocument オブジェクトが識別されると、サーバーは名前を取得し、適切な BizTalkChannel オブジェクトを識別およびインスタンス化することができます。

選択条件は、BizTalk Server 2000 で EDI ドキュメントのヘッダーを作成し、出力するときにも役に立ちます。

グローバル追跡

BizTalkDocument オブジェクトは、追跡する項目を選択できる仕様を示します。入力ドキュメント仕様内の指定された項目は、その仕様を使って処理されるドキュメントごとに追跡されます。追跡するように指定されたすべての項目は、出力ドキュメント仕様では無視されます。追跡項目を指定する BizTalkChannel オブジェクトが、追跡するように指定された項目が含まれる入力ドキュメント仕様とともに使用された場合、チャネルで指定された項目だけが追跡に使用されます。

処理されている入力ドキュメントの重要なデータをログに記録することによって、稼動中の詳細情報を追跡および分析できます。たとえば、取引先に送信されるすべての請求書について、請求書の合計フィールドをログに記録することができます。これによって、特定の期間にすべての取引先に送信された請求書の総額を確認したり、個々の取引先に対する請求書の総額を確認することができます。

関連項目

ドキュメント格納

ドキュメント トラッキング


エンベロープ

BizTalkEnvelope オブジェクトは、2 つの情報で構成されています。

  • エンベロープの種類は Format プロパティで指定されます。ドキュメント型が "flatfile"、"custom xml"、"ANSI X12"、"edifact"、および "reliable" の場合、ドキュメントの Type とエンベロープの Format は一致している必要があります。

  • 使用する実際のエンベロープ ファイルは Reference プロパティで指定されます。

入力ドキュメント エンベロープ

入力ドキュメントの Type が "flatfile" の場合、エンベロープが必要です。これは、ドキュメントを XML に解析する方法と、ドキュメントを処理するパーサーについての情報がエンベロープに含まれるためです。エンベロープのない入力 "flatfile" ドキュメントは、処理に失敗します。その他のすべての入力ドキュメント型では、エンベロープは省略できます。

出力ドキュメント エンベロープ

エンベロープは、ネイティブ形式に変換された出力ドキュメント インスタンスをラップするために使用されます。出力ドキュメントで使用されるエンベロープは、BizTalkPort オブジェクトで指定されます。出力ドキュメントの Type が "ANSI X12" または "edifact" の場合、エンベロープが必要です。ただし、ドキュメントが ANSI X12 または EDIFACT であることが示されていればドキュメントをシリアライズできるので、これらの種類の書式では Reference プロパティは無視されます。出力ドキュメントの Type が "custom xml" の場合、Reference プロパティが指定されていればこれが使用されます。Reference プロパティが指定されていなければ、"custom xml" ドキュメントは変換された XML 形式に処理するために送信されます。

注

  • 複数の BizTalkPort オブジェクトで 1 つのエンベロープを参照することができます。

  • Reference プロパティを設定しなければ、エンベロープの Content プロパティと Namespace プロパティは無効です。

  • BizTalk Server で既に登録されている名前空間を使用する新しい BizTalkEnvelope オブジェクトを作成すると、新しいドキュメントはその名前空間の Reference プロパティを継承します。名前空間は、作成される新しい Reference に対して一意である必要があります (大文字と小文字は区別されません)。


仕様の作成とデータのマッピング

Microsoft BizTalk Server 2000 では、ドキュメントの構造を定義し、異なる書式間でデータをマップするために使用できるツールが提供されています。これらのツールを使用して、アプリケーション統合サーバーに必要な基本的なデータ交換情報を作成できます。これらのツールは Extensible Markup Language (XML) などの各種標準に基づいています。

BizTalk エディタを使用すると、業界標準や共通のスキーマに基づいた仕様を作成することも、企業独自の仕様を作成することもできます。

BizTalk マッパーを使用すると、2 つの異なる仕様のレコードやフィールドの間にマップを作成することができます。サーバーはこのマップを使用してデータを処理し、社内で、または取引先との間で共有できる書式にデータを変換します。

ここには次のトピックが含まれます。

  • 仕様の作成

  • データのマッピング

  • BizTalk エディタと BizTalk マッパーのトラブルシューティング


仕様の作成

BizTalk エディタは、仕様を作成、編集、および管理することができるツールです。BizTalk エディタは Extensible Markup Language (XML) を使用します。この言語は、構文、データベース、および概念のスキーマ間で共有する部分を処理するための共通の語彙を提供します。

BizTalk エディタは、ファイルに含まれているレコードとフィールドのプロパティを解釈することによって仕様を作成します。仕様は、オリジナル フォーマットに関わらず、あらゆる構造化データを XML で表したものです。また、BizTalk エディタで作成または修正する仕様は、BizTalk マッパーでデータを別の書式に変換するときに使えるように、共通のデータ記述で提供されます。仕様は、ビジネス プロセスにまたがるデータの移植性を提供します。BizTalk エディタでは、次の形式に基づいた仕様を作成できます。

  • 整形式の XML。

  • XML ベースのドキュメント テンプレート。

  • XML-Data Reduced (XDR) スキーマ。

  • ドキュメント定義型 (DTD)。

  • XML として格納された ActiveX データ オブジェクト (ADO) レコード セット。

  • 電子データ交換 (EDI) (ANSI X12 および EDIFACT)。

  • 区切りフラット ファイルおよび位置指定フラット ファイルなどのフラット ファイル (たとえば、SAP IDOC)。フラット ファイルは、区切られており、かつ位置が指定されているファイルでもかまいません。

  • 構造化ドキュメント書式。

BizTalk エディタでは、構造が何も含まれていない空の仕様から作成することも、既存のスキーマまたは仕様をインポートすることもできます。たとえば、DTD をインポートできます。DTD は、要素と属性が記述された構造化ファイルで、要素と属性の順序、頻度、および内容に関する制約も含まれています。新しい仕様の作成には、XML、ANSI X12、または EDIFACT などの標準仕様も使用できます。

ドキュメントのインスタンスがインポートされると、BizTalk エディタはドキュメントの構造を解釈し、ドキュメントの XML で表現した仕様を作成します。BizTalk エディタの仕様ツリーに表示されたレコードとフィールドを必要に応じて編集し、その構造を仕様として保存することができます。インポートできるファイルの種類は、次のとおりです。

  • XDR スキーマ

  • 整形式の XML

  • DTD

各仕様では、特定のタグ セットを利用して、ファイルの構造が記述されます。BizTalk エディタは、注文書、請求書、および事前出荷通知などの一般的なドキュメントの仕様を作成する場合に、ひな形として利用できるテンプレートもいくつか提供しています。

BizTalk Server によるドキュメント処理では、BizTalk マッパーで作成されたマップを使用して、送信データおよび受信データの仕様書式を別の仕様書式に変換します。

  • 特定の作業のヘルプについては、「操作方法」を参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • このほかの資料については、「参考資料」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk エディタと BizTalk マッパーのトラブルシューティング」を参照してください。


操作方法

ここでは、仕様を作成する方法を作業ごとに説明します。「概念」を参照し、レコードとフィールドの関係、および作成する仕様の種類に応じたプロパティの指定方法について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk エディタのオプションの変更

  • 仕様の作成と検証

  • 仕様を開く

  • 仕様を保存する、エクスポートする、変換する、閉じる

  • レコードとフィールドの管理

  • レコードとフィールドのプロパティの指定

  • メモと構文規則の編集

  • ドキュメント インスタンスの管理

  • 無効な文字コード表の管理

  • 表示の管理


BizTalk エディタのオプションの変更

  1. [BizTalk エディタのオプション] ダイアログ ボックスでオプションを表示または変更するには、[ツール] メニューの [オプション] をクリックします。

  2. [全般] プロパティ ページの [新しいフィールドを要素として作成] チェック ボックスをオンにします。このオプションの詳細については、「新しいフィールドを要素として作成」を参照してください。

関連項目

新しいフィールドを要素として作成


仕様の作成と検証

ここには次のトピックが含まれます。

  • 標準に基づいた仕様の作成

  • フラット ファイルに基づいた仕様の作成

  • 空のテンプレートに基づいた仕様の作成

  • 既存の仕様に基づいた仕様の作成

  • インポート ファイルに基づいた仕様の作成

  • 仕様の検証


標準に基づいた仕様の作成

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新しいドキュメント仕様] ダイアログ ボックスの [XML]、[X12]、または [EDIFACT] をクリックし、[OK] をクリックします。

    EDIFACT または ANSI X12 を選択する場合は、バージョンも選択する必要があります。作成するバージョンのフォルダをクリックし、[OK] をクリックします。

  3. 仕様の種類をクリックし、[OK] をクリックします。

  4. 必要に応じて、レコードの削除をします。

  5. 必要に応じて、フィールドの削除をします。

  6. 必要に応じて、コードの消去をします。

  7. 新しい仕様の保存をします。

関連項目

レコードとフィールドの管理

レコードとフィールドのプロパティの指定

仕様について


フラット ファイルに基づいた仕様の作成

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新しいドキュメント仕様] ダイアログ ボックスの [空の仕様] をクリックし、[OK] をクリックします。

  3. ルート ノードを強調表示し、[参照] タブをクリックします。

  4. [標準] 行の "値" フィールドをダブルクリックします。

  5. [標準] ボックスの一覧の [Custom] をクリックします。

  6. Enter キーを押します。

  7. [はい] をクリックして変更を確認します。

  8. ルート ノードへの新しいレコードの追加をします。

  9. 既存のレコードへの新しいレコードの追加をします。

  10. ルート ノードへの新しいフィールドの追加をします。

  11. レコードへの新しいフィールドの追加をします。

  12. レコードとフィールドのプロパティの指定をします。

  13. 新しい仕様の保存をします。

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。必要に応じて、追加のレコード プロパティを [区切り記号] または [位置指定] に設定します。

  • UTF8 コード ページに基づいたフラット ファイルは、BizTalk エディタではサポートされていません。

関連項目

レコードとフィールドの管理

レコードとフィールドのプロパティの指定

仕様について


空のテンプレートに基づいた仕様の作成

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新しいドキュメント仕様] ダイアログ ボックスの [空の仕様] をクリックし、[OK] をクリックします。

  3. ルート ノードへの新しいレコードの追加をします。

  4. 既存のレコードへの新しいレコードの追加をします。

  5. ルート ノードへの新しいフィールドの追加をします。

  6. レコードへの新しいフィールドの追加をします。

  7. レコードとフィールドのプロパティの指定をします。

  8. 新しい仕様の保存をします。

関連項目

レコードとフィールドの管理

レコードとフィールドのプロパティの指定

仕様について


既存の仕様に基づいた仕様の作成

  1. [ファイル] メニューの [開く] をクリックします。

  2. [ドキュメント仕様を開く] ダイアログ ボックスで、既存の仕様が含まれているフォルダを参照します。

  3. 一覧でファイルをクリックし、[開く] をクリックします。

  4. 必要に応じて、仕様を変更します。

  5. [ファイル] メニューの [名前を付けて保存] をクリックします。

  6. [ドキュメント仕様に名前を付けて保存] ダイアログ ボックスの [ファイル名] ボックスに、仕様の名前を入力します。

  7. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字に関連付けられた仕様を作成する場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。2 バイト文字に関連付けられた仕様を格納する場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

  8. レコードとフィールドの管理をします。

  9. 新しい仕様の保存をします。

関連項目

コード一覧の値と説明

レコードとフィールドの管理


インポート ファイルに基づいた仕様の作成

  1. [ツール] メニューの [インポート] をクリックします。

  2. [インポート モジュールの選択] ダイアログ ボックスの [整形式 XML インスタンス]、[ドキュメント型定義 (DTD)]、または [XDR スキーマ] をクリックし、[OK] をクリックします。

    XML-Data Reduced (XDR) ファイルをインポートする場合は、[XDR スキーマ] をクリックします。

  3. [インポート] ダイアログ ボックスで、インポートするファイルが含まれているフォルダを参照します。

  4. インポートするファイルをクリックし、[開く] をクリックします。

    BizTalk エディタは、インポート ファイルの構造に基づいた仕様を作成します。すべてのレコードとフィールドのプロパティ値を割り当てる必要があります。

  5. ルート ノードへの新しいレコードの追加をします。

  6. 既存のレコードへの新しいレコードの追加をします。

  7. ルート ノードへの新しいフィールドの追加をします。

  8. レコードへの新しいフィールドの追加をします。

  9. レコードとフィールドのプロパティの指定をします。

  10. 新しい仕様の保存をします。

重要

  • BizTalk エディタでは、要素にコメントが含まれているドキュメント型定義 (DTD) のインポートをサポートしていません。これらの DTD を正常にインポートするには、当該ファイルを編集して、要素内のすべてのコメントを削除します。

  • インポートするファイルに含まれている要素が、「コンテンツが含まれている」、「インスタンス データで繰り返されている」、「子がない」という 3 つの条件を満たしている場合は、BizTalk エディタは構造をインポートするときに、この要素をレコードではなくフィールドとして作成します。

  • ルート ノードにする要素の特定が自動的に行われない場合は、[ルート要素の選択] ダイアログ ボックスが表示されます。ルート ノードにする要素を選択し、[OK] をクリックします。

  • BizTalk エディタでは、ルート ノードを持つ循環参照が含まれている DTD や XDR スキーマをインポートすることはできません。ルート ノードを持つ循環参照が含まれている整形式 XML ドキュメントをインポートすることはできますが、循環参照にドキュメントのルート ノードを含めることはできないという警告が表示されます。循環参照の詳細については、「循環参照」を参照してください。

  • ルート ノードの名前空間を含む整形式 XML ファイルをインポートすると、名前空間は対象の名前空間になり、仕様のほかの部分では無視されます。対象の名前空間の詳細については、「参照のプロパティの設定」を参照してください。

  • 混在したコンテンツ (テキスト情報と下位要素) を持つ要素を含むファイルをインポートすると、その要素のテキスト情報は、インポートのときに無視されます。

  • 次の表は、XDR ファイルまたは DTD をインポートして得られる結果を、含まれるデータ型の種類ごとに示しています。列にデータ型を示します。
    "entity" および "entities" | "nmtoken" および "nmtokens" | "notation"
    XDR | ファイルをインポートできません。 | ファイルをインポートできます。データ型が削除されます。 | ファイルをインポートできません。
    DTD | ファイルをインポートできます。データ型が削除されます。 | ファイルをインポートできます。データ型が削除されます。 | ファイルをインポートできます。データ型は列挙型としてインポートされます。

関連項目

ファイルのインポート

レコードとフィールドの管理

レコードとフィールドのプロパティの指定


仕様の検証

  1. 仕様を開くか、スキーマをインポートします。

    詳細については、「仕様を開く」または「インポート ファイルに基づいた仕様の作成」を参照してください。

  2. [ツール] メニューの [仕様の検証] をクリックします。

[警告] プロパティ ページに、仕様の構造に問題がある可能性を示す警告が表示されます。警告をダブルクリックすると、レコードまたはフィールド、および関連付けられたプロパティが上のペインに赤く表示されます。

関連項目

インポート ファイルに基づいた仕様の作成

仕様を開く


仕様を開く

ここには次のトピックが含まれます。

  • ローカル ドライブの既存の仕様を開く

  • WebDAV から既存の仕様を開く


ローカル ドライブの既存の仕様を開く

  1. [ファイル] メニューの [開く] をクリックします。

  2. [ドキュメント仕様を開く] ダイアログ ボックスで、開く仕様が含まれているフォルダを参照します。

  3. 一覧でファイルをクリックし、[開く] をクリックします。

関連項目

WebDAV から既存の仕様を開く


WebDAV から既存の仕様を開く

  1. [ファイル] メニューの [WebDAV から取得] をクリックします。

  2. [WebDAV から取得] ダイアログ ボックスの [サーバー] ボックスにサーバー名を入力し、Enter キーを押します。

    ボックスの一覧でサーバー名を選択することもできます。

  3. 開く仕様が含まれているフォルダを参照し、仕様をクリックします。次に、[開く] をクリックします。

注

  • セッション中に初めてリモート WebDAV サーバーに接続するとき、遅延が発生することがあります。

関連項目

ローカル ドライブの既存の仕様を開く

BizTalk エディタと BizTalk マッパーのトラブルシューティング


仕様を保存する、エクスポートする、変換する、閉じる

ここには次のトピックが含まれます。

  • 新しい仕様の保存

  • 既存の仕様の保存

  • 仕様の格納

  • XDR スキーマのエクスポート

  • XDR スキーマから XSD スキーマへの変換

  • 仕様を閉じる


新しい仕様の保存

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。

  2. [ドキュメント仕様に名前を付けて保存] ダイアログ ボックスの [ファイル名] ボックスにファイルの名前を入力します。

  3. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字に関連付けられた仕様を保存する場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。2 バイト文字に関連付けられた仕様を保存する場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。


既存の仕様の保存

  • [ファイル] メニューの [保存] をクリックします。

注

  • ファイルを保存すると、ファイルはハード ディスクに格納されます。ファイルを WebDAV に保存するには、サーバーにファイルを格納するためのアクセス許可が必要です。

関連項目

仕様の格納


仕様の格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

  2. [WebDAV に格納] ダイアログ ボックスの [サーバー] ボックスにサーバー名を入力し、Enter キーを押します。

    ボックスの一覧でサーバー名を選択することもできます。

  3. 仕様を格納するフォルダを参照します。

  4. [ファイル名] ボックスにファイルの名前を入力します。

  5. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字に関連付けられた仕様を格納する場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。2 バイト文字に関連付けられた仕様を格納する場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

重要

  • ロケール設定が正しくない場合は、2 バイト文字セットのファイル名でファイルを格納できません。この問題を解決するには、「???.xml が WebDAV ダイアログ ボックスに表示される」を参照してください。

注

  • リモート WebDAV サーバーに初めて接続する場合は、時間がかかることがあります。

  • ファイルを WebDAV に格納すると、ファイルはサーバーに格納されます。ファイルをハード ディスクに保存するには、[ファイル] メニューの [名前を付けて保存] をクリックします。

関連項目

既存の仕様の保存

新しい仕様の保存

BizTalk エディタと BizTalk マッパーのトラブルシューティング


XDR スキーマのエクスポート

  1. [ツール] メニューの [XDR スキーマのエクスポート] をクリックします。

  2. [次の形式で XDR スキーマをエクスポートします] ダイアログ ボックスで、XML-Data Reduced (XDR) ファイルをエクスポートする場所を参照します。

  3. [ファイル名] ボックスにファイルの名前を入力します。

  4. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字に関連付けられた仕様をエクスポートする場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。2 バイト文字に関連付けられた仕様をエクスポートする場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

注

  • 新しい仕様と既存の仕様は、BizTalk エディタで開いているときにだけエクスポートできます。

  • 仕様をエクスポートすると、構造から一意な仕様情報が削除され、残った構造は、ほかのアプリケーションで使用できる一般的なスキーマとして保存されます。

関連項目

仕様を開く

XDR スキーマから XSD スキーマへの変換


XDR スキーマから XSD スキーマへの変換

  1. ローカル ドライブに Convert というフォルダを作成します。

  2. \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\XSDConverter の内容を Convert にコピーします。

  3. 変換する XDR スキーマを Convert にコピーします。

  4. コマンド プロンプトを開きます。

  5. Convert ディレクトリに移動します。

  6. コマンド プロンプトで次のように入力します。
    wscript convert.js xdrfilename.xml xsdfilename.xsd

xsdfilename.xsd という名前の変換された XSD スキーマが、Convert フォルダに作成されます。

注

  • XSD スキーマのファイル名を入力しないと、XSD スキーマの名前は元の XDR スキーマ名に .xsd を付加したものになります。たとえば、XDR スキーマの名前が xdrfilename.xml の場合は、変換された XSD スキーマの名前は xdrfilename.xml.xsd になります。

関連項目

XDR スキーマのエクスポート


仕様を閉じる

  • [ファイル] メニューの [閉じる] をクリックします。


レコードとフィールドの管理

ここには次のトピックが含まれます。

  • ルート ノードへの新しいレコードの追加

  • ルート ノードへの新しいフィールドの追加

  • 既存のレコードへの新しいレコードの追加

  • レコードへの新しいフィールドの追加

  • レコードの挿入

  • フィールドの挿入

  • 新しいフィールドを要素として作成

  • フィールドを属性から要素に変更

  • フィールドを要素から属性に変更

  • 仕様の中でのレコードの移動

  • 仕様の中でのフィールドの移動

  • 別の仕様へのレコードの移動

  • 別の仕様へのフィールドの移動

  • 仕様の中でのレコードのコピー

  • 仕様の中でのフィールドのコピー

  • 別の仕様へのレコードのコピー

  • 別の仕様へのフィールドのコピー

  • 単一レコードの名前の変更

  • 単一フィールドの名前の変更

  • 同じ名前を持つすべてのレコードの名前の変更

  • レコードの削除

  • フィールドの削除

  • 循環参照の作成

  • 既存のレコードの新しいインスタンスの作成

  • 既存の要素フィールドの新しいインスタンスの作成


ルート ノードへの新しいレコードの追加

  1. ルート ノードをクリックします。

  2. [編集] メニューの [新しいレコード] をクリックします。

    仕様ツリーの最後のノードの後ろに子レコードが挿入されます。

  3. レコードの名前を入力し、Enter キーを押します。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティに値を入力して非 XML ソース ファイルのタグを識別することができます。

  • 兄弟のレコードを同じ名前にすることはできません。

関連項目

レコードとフィールドのプロパティの指定


ルート ノードへの新しいフィールドの追加

  1. ルート ノードをクリックします。

  2. [編集] メニューの [新しいフィールド] をクリックします。

    仕様ツリーの最後のノードの後ろに子フィールドが挿入されます。

  3. フィールドの名前を入力し、Enter キーを押します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成

レコードとフィールドのプロパティの指定


既存のレコードへの新しいレコードの追加

  1. レコードをクリックします。

  2. [編集] メニューの [新しいレコード] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、子レコードが挿入されます。

  3. レコードの名前を入力し、Enter キーを押します。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して非 XML ソース ファイルのタグを識別することができます。

  • 兄弟のレコードを同じ名前にすることはできません。

関連項目

レコードとフィールドのプロパティの指定


レコードへの新しいフィールドの追加

  1. レコードをクリックします。

  2. [編集] メニューの [新しいフィールド] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、子フィールドが挿入されます。

  3. フィールドの名前を入力し、Enter キーを押します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成

レコードとフィールドのプロパティの指定


レコードの挿入

  1. レコードをクリックします。

  2. [編集] メニューの [レコードの挿入] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、兄弟レコードが挿入されます。

  3. レコードの名前を入力し、Enter キーを押します。

注

  • 兄弟のレコードを同じ名前にすることはできません。

関連項目

レコードとフィールドのプロパティの指定


フィールドの挿入

  1. フィールドを挿入する位置の前にあるレコードまたはフィールドをクリックします。

  2. [編集] メニューの [フィールドの挿入] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、兄弟フィールドが挿入されます。

  3. フィールドの名前を入力し、Enter キーを押します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成

レコードとフィールドのプロパティの指定


新しいフィールドを要素として作成

  1. [ツール] メニューの [オプション] をクリックします。

  2. [BizTalk エディタのオプション] ダイアログ ボックスの [新しいフィールドを要素として作成] チェック ボックスをオンにし、[OK] をクリックします。

注

  • このチェック ボックスがオフの場合は、フィールドは属性として作成されます。[新しいフィールドを要素として作成] チェック ボックスをオンにすると、すべての新しいフィールドは要素として作成されます。

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更


フィールドを属性から要素に変更

  1. 仕様ツリーのフィールドをクリックします。

  2. [宣言] プロパティ ページの [種類] 行の "値" フィールドをダブルクリックします。現在の設定は [属性] です。

  3. [種類] ボックスの一覧の [要素] をクリックし、Enter キーを押します。

  4. [はい] をクリックして変更を確認します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成


フィールドを要素から属性に変更

  1. 仕様ツリーのフィールドをクリックします。

  2. [宣言] プロパティ ページの [種類] 行の "値" フィールドをダブルクリックします。現在の設定は [要素] です。

  3. [種類] ボックスの一覧の [属性] をクリックし、Enter キーを押します。

  4. [はい] をクリックして変更を確認します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを属性から要素に変更


仕様の中でのレコードの移動

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するレコードをクリックし、ツリーの中の別のノードにドラッグします。

    マウスのボタンを離したときに、マウス ポインタが強調表示されたノード テキストの中心より上の位置にあると、レコードはそのノードの上に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの中心より下の位置にあると、レコードはそのノードの下に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの右にあると、レコードは強調表示されたレコードの下に子として挿入されます。

関連項目

別の仕様へのレコードのコピー

仕様の中でのレコードのコピー

別の仕様へのレコードの移動


仕様の中でのフィールドの移動

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するフィールドをクリックし、ツリーの中の別のノードにドラッグします。

    マウスのボタンを離したときに、マウス ポインタが強調表示されたノード テキストの中心より上の位置にあると、フィールドはそのノードの上に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの中心より下の位置にあると、フィールドはそのノードの下に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの右にあると、フィールドはそのレコードの下に子として挿入されます。

関連項目

別の仕様へのフィールドのコピー

仕様の中でのフィールドのコピー

別の仕様へのフィールドの移動


別の仕様へのレコードの移動

  1. 移動するレコードが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するレコードをクリックし、[編集] メニューの [切り取り] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

  6. [ドキュメント仕様を開く] ダイアログ ボックスで、レコードの移動先である仕様が含まれているフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. 仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. レコードを挿入する位置の前にあるルート ノード、レコード、またはフィールドをクリックします。

  11. [編集] メニューの [貼り付け] をクリックします。

注

  • 既存のレコードと同じ名前のレコードを移動すると、レコード名の末尾に数値が自動的に追加されます。

関連項目

別の仕様へのレコードのコピー

仕様の中でのレコードのコピー

仕様の中でのレコードの移動


別の仕様へのフィールドの移動

  1. 移動するフィールドが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するフィールドをクリックし、[編集] メニューの [切り取り] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

  6. [ドキュメント仕様を開く] ダイアログ ボックスで、レコードの移動先である仕様が含まれているフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. フィールドの移動先である仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. フィールドを挿入する位置の前にあるルート ノード、レコード、またはフィールドをクリックします。

  11. [編集] メニューの [貼り付け] をクリックします。

注

  • 既存のフィールドと同じ名前のフィールドを移動すると、フィールド名の末尾に数値が自動的に追加されます。

関連項目

別の仕様へのフィールドのコピー

仕様の中でのフィールドのコピー

仕様の中でのフィールドの移動


仕様の中でのレコードのコピー

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするレコードをクリックし、[編集] メニューの [コピー] をクリックします。

  4. レコードを挿入する位置の前にあるノードをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子レコードが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟レコードが挿入されます。

関連項目

別の仕様へのレコードのコピー

別の仕様へのレコードの移動

仕様の中でのレコードの移動


仕様の中でのフィールドのコピー

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするフィールドをクリックし、[編集] メニューの [コピー] をクリックします。

  4. フィールドを挿入する位置の前にあるノードをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子フィールドが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟フィールドが挿入されます。

関連項目

別の仕様へのフィールドのコピー

別の仕様へのフィールドの移動

仕様の中でのフィールドの移動


別の仕様へのレコードのコピー

  1. コピーするレコードが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするレコードをクリックし、[編集] メニューの [コピー] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

  6. [ドキュメント仕様を開く] ダイアログ ボックスで、レコードのコピー先である仕様が含まれているフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. レコードのコピー先である仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. レコードを挿入する位置の前にあるルート ノード、レコード、またはフィールドをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子レコードが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟レコードが挿入されます。

注

  • 既存のレコードと同じ名前のレコードをコピーすると、レコード名の末尾に数値が自動的に追加されます。

関連項目

仕様の中でのレコードのコピー

別の仕様へのレコードの移動

仕様の中でのレコードの移動


別の仕様へのフィールドのコピー

  1. コピーするフィールドが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするフィールドをクリックし、[編集] メニューの [コピー] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2000] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

  6. [ドキュメント仕様を開く] ダイアログ ボックスで、フィールドの移動先である仕様が含まれているフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. フィールドのコピー先である仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. レコードを挿入する位置の前にあるルート ノード、レコードまたはフィールドをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子フィールドが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟フィールドが挿入されます。

注

  • 既存のフィールドと同じ名前のフィールドをコピーすると、フィールド名の末尾に数値が自動的に追加されます。

関連項目

仕様の中でのフィールドのコピー

別の仕様へのフィールドの移動

仕様の中でのフィールドの移動


単一レコードの名前の変更

  1. 名前を変更するレコードをクリックします。

  2. [編集] メニューの [名前の変更] をクリックします。

  3. レコードの新しい名前を入力し、Enter キーを押します。

関連項目

同じ名前を持つすべてのレコードの名前の変更

単一フィールドの名前の変更


単一フィールドの名前の変更

  1. 名前を変更するフィールドをクリックします。

  2. [編集] メニューの [名前の変更] をクリックします。

  3. フィールドの新しい名前を入力し、Enter キーを押します。

注

  • 要素であるフィールドに、既存のレコードと同じ名前を付けることはできません。

関連項目

同じ名前を持つすべてのレコードの名前の変更

単一レコードの名前の変更


同じ名前を持つすべてのレコードの名前の変更

  1. 変更する名前を持つレコードのうちの 1 つをクリックします。

  2. [編集] メニューの [すべての record name の名前の変更] をクリックします。

  3. レコードの新しい名前を入力します。

    同じ名前を持つすべてのレコードの名前が変更されます。

注

  • このコマンドが [編集] メニューで利用できるのは、同じ名前のレコードが 2 個以上ある場合だけです。

関連項目

単一フィールドの名前の変更

単一レコードの名前の変更


レコードの削除

  1. 削除するレコードをクリックします。

  2. [編集] メニューの [削除] をクリックします。

  3. 確認ダイアログ ボックスで [はい] をクリックします。

注意

  • レコードを削除すると、すべての子レコードと子フィールドも削除されます。

関連項目

フィールドの削除


フィールドの削除

  1. 削除するフィールドをクリックします。

  2. [編集] メニューの [削除] をクリックします。

  3. 確認ダイアログ ボックスで [はい] をクリックします。

関連項目

レコードの削除


循環参照の作成

  1. 循環参照を作成する位置の前にあるレコードを選択します。

    これが基本のレコードです。

  2. [編集] メニューの [新しいレコード] をクリックします。

  3. 新しいレコードに基本のレコードと同じ名前を付け、Enter キーを押します。

    循環参照 循環参照アイコン が作成されます。

  4. [宣言] プロパティ ページの [循環回数] 行の "値" フィールドをダブルクリックします。

  5. 1 から 7 までの数字を入力し、Enter キーを押します。

重要

  • 循環参照ノードの [参照] プロパティ ページの "最小発生数" プロパティは、0 に設定する必要があります。1 に設定すると、無限ループが発生します。

注

  • 非 XML 仕様では、循環参照を使用できません。XMLの仕様を使用していることを確認してください。

関連項目

循環参照


既存のレコードの新しいインスタンスの作成

  1. 既存のレコードの新しいインスタンスを作成するノードをクリックします。

  2. [編集] メニューの [新しいレコード] または [レコードの挿入] をクリックします。

    注

    • 手順 1. でフィールドを選択した場合は、[編集] メニューの [新しいレコード] は利用できません。
  3. 新しいレコードに既存のレコードと同じ名前を付け、Enter キーを押します。

    同じレコードのインスタンスが 2 つ作成されます。

重要

  • 新しいレコード インスタンスに、兄弟レコードと同じ名前を付けることはできません。

  • 新しいレコードに祖先レコードと同じ名前を付けると、既存のレコードの新しいインスタンスではなく、循環参照が作成されます。循環参照の詳細については、「循環参照」を参照してください。

注

  • [新しいレコード] をクリックすると、新しいレコード インスタンスは選択したレコードの子孫として挿入されます。

  • [レコードの挿入] をクリックすると、新しいレコード インスタンスは選択したレコードまたはフィールドの兄弟として挿入されます。

  • 1 つのレコードが持つすべてのインスタンスで、下位のノード構造は同一です。レコードのあるインスタンスに対してノードを削除または追加すると、その変更はレコードのほかのすべてのインスタンスに自動的に反映されます。レコード インスタンスのプロパティには、同一のものと、インスタンスごとに個別に設定できるものがあります。すべてのレコード インスタンスで同一のプロパティと、異なるプロパティの詳細については、「プロパティの範囲」を参照してください。

  • 既存のレコードに、別の既存のレコードと同じ名前を付けることはできません。

  • 既存のレコードの新しいインスタンスを作成するには、新しいレコード インスタンスを挿入する位置の上にあるノードの右に、既存のレコードを Ctrl キーを押しながらドラッグする方法もあります。

関連項目

循環参照

プロパティの範囲


既存の要素フィールドの新しいインスタンスの作成

  1. 要素フィールドの新しいインスタンスを作成するノードを選択します。

    注

    • 複数のインスタンスを作成できるフィールドは、[宣言] プロパティ ページで種類が [要素] と指定されているフィールドだけです。種類が [属性] のフィールドには、複数のインスタンスを作成できません。同じ名前で 2 つ以上の属性フィールドを作成すると、それぞれのフィールドは完全に独立した状態で残ります。
  2. [編集] メニューの [新しいフィールド] または [フィールドの挿入] をクリックします。

    注

    • 手順 1. でフィールドを選択した場合は、[編集] メニューの [新しいフィールド] は利用できません。
  3. 新しいフィールドに既存のフィールドと同じ名前を付け、Enter キーを押します。

    同じフィールドのインスタンスが 2 つ作成されます。

重要

  • 新しい要素フィールド インスタンスに、兄弟要素フィールド インスタンスと同じ名前を付けることはできません。

注

  • [新しいフィールド] をクリックすると、新しいフィールド インスタンスは選択したレコードの子孫として挿入されます。

  • [フィールドの挿入] をクリックすると、新しいフィールド インスタンスは選択したレコードまたはフィールドの兄弟として挿入されます。

  • フィールド インスタンスのプロパティには、同一のものと、インスタンスごとに個別に設定できるものがあります。すべてのフィールド インスタンスで同一のプロパティと、異なるプロパティの詳細については、「プロパティの範囲」を参照してください。

  • 既存のフィールドに、別の既存のフィールドと同じ名前を付けることはできません。ただし、一方のフィールドの "種類" プロパティが [属性] に、もう一方のフィールドの "種類" プロパティが [要素] に設定されている場合は、それらに同じ名前を付けることができます。

  • 既存の要素フィールドの新しいインスタンスを作成するには、新しいフィールド インスタンスを挿入する位置の上にあるノードの右に、既存の要素フィールドを Ctrl キーを押しながらドラッグする方法もあります。

関連項目

循環参照

プロパティの範囲


レコードとフィールドのプロパティの指定

ここでは、次の内容について説明します。

  • 宣言のプロパティの設定

  • 参照のプロパティの設定

  • 解析のプロパティの設定

  • 名前空間の宣言

  • カスタム コメントの追加

  • カスタム コメントの編集

  • カスタム コメントの削除

  • ディクショナリ プロパティの設定

  • カスタム ディクショナリ プロパティの追加

  • カスタム ディクショナリ プロパティの名前の変更

  • ディクショナリ プロパティの消去

  • カスタム ディクショナリ プロパティの削除

  • コードの選択

  • コードの消去

  • [値] 列のフィールドのプロパティの消去

  • フィールド位置の自動計算


宣言のプロパティの設定

  1. 仕様ツリーで、プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[宣言] タブをクリックします。

  2. 設定するプロパティと関連付けられている [値] 列のフィールドをダブルクリックします。

  3. フィールドにデータを入力するか、下向き矢印をクリックして、一覧から利用可能なオプションを選択します。

  4. Enter キーを押して変更を適用します。

次の表は、[宣言] プロパティ ページに含まれているプロパティを一覧表示しています。選択するプロパティは、ルート ノード、レコード、またはフィールドのうち、選択したノードに対して設定されます。

[宣言] プロパティ ページ : ルート ノードのプロパティ

プロパティ | 値
名前 ルート ノードの名前です。

注

[宣言] プロパティ ページの [名前] の値を変更すると、これと一致するように、仕様ツリーのルート ノードの名前が自動的に変更されます。新しく作成された仕様では、[宣言] プロパティ ページの [名前] の値を変更すると、[参照] プロパティ ページの [仕様名] の値も変更されます。ただし、仕様名はルート ノードの名前と異なる可能性があるので、[仕様名] の値を変更しても [名前] の値または仕様ツリーのルート ノードの名前は変更されません。いったん [仕様名] の値を編集すると、[名前] の値またはルート ノードの名前を変更しても [仕様名] の値は変更されなくなります。
説明 | 仕様の説明です。
種類 | レコードの種類です。
モデル [クローズド] : ドキュメント インスタンスに含まれているデータと仕様構造が一致していることを示します。

[オープン] : ドキュメント インスタンスのデータが、仕様構造と完全には一致していないことを示します。

  • このプロパティ値が空白の場合、既定値は [オープン] です。
コンテンツ [要素のみ] : ルート ノードに含められるのは要素だけであることを示します。ルートに子レコードが含まれている場合の既定値です。

[なし] : ルート ノードに下位要素を含められないことを示します。

[テキストのみ] : ルート ノードに含められるのはテキストだけで、下位要素は含められないことを示します。

注

  • BizTalk エディタでは、テキスト情報と下位要素が混在したコンテンツを含む要素はサポートされていません。
順序 次の値のいずれかを選択します。
  • [単数] : 使用できる構成要素が 1 つだけで、省略できないことを示します。

  • [連続] : 指定された順序で構成要素を使用する必要があることを示します。

  • [複数] : 0 個以上の構成要素を任意の順序または組み合わせで使用できることを示します。

[宣言] プロパティ ページ : レコードのプロパティ

プロパティ | 値
名前 | レコードの名前です。
説明 | レコードの説明です。
種類 | レコードの種類です。
モデル [クローズド] : ドキュメント インスタンスに含まれているデータと仕様構造が一致していることを示します。

[オープン] : ドキュメント インスタンスに含まれているデータが、仕様構造と一致していないことを示します。

  • このプロパティ値が空白の場合、既定値は [オープン] です。
コンテンツ [要素のみ] : レコードに含められるのは要素だけであることを示します。レコードに子レコードが含まれている場合の既定値です。

[なし] : レコードに下位要素を含められないことを示します。

[テキストのみ] : レコードに含められるのはテキストだけで、下位要素は含められないことを示します。

注

BizTalk エディタでは、テキスト情報と下位要素が混在したコンテンツを含む要素はサポートされていません。
順序 次の値のいずれかを選択します。
  • [単数] : 使用できる構成要素が 1 つだけで、省略できないことを示します。

  • [連続] : 指定された順序で構成要素を使用する必要があることを示します。

  • [複数] : 0 個以上の構成要素を任意の順序または組み合わせで使用できることを示します。
循環回数 基本のレコードの下で利用する循環回数を入力します。循環参照の詳細については、「循環参照」を参照してください。

注

  • このプロパティ フィールドは、循環参照を作成したときにだけ表示されます。

[宣言] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
名前 | フィールドの名前です。
説明 | フィールドの説明です。
種類 次の値のいずれかを選択します。
  • [要素]

  • [属性]
モデル [クローズド] : ドキュメント インスタンスに含まれているデータと仕様構造が一致していることを示します。

[オープン] : ドキュメント インスタンスに含まれているデータが、仕様構造と一致していないことを示します。

注

  • このプロパティ値が空白の場合、既定値は [オープン] です。

  • "モデル" プロパティは、"種類" フィールドが "要素" に設定されている場合のみ構成できます。
コンテンツ [テキストのみ] : レコードに含められるのはテキストだけで、下位要素は含められないことを示します。

注

  • "コンテンツ" プロパティは、"種類" フィールドが "要素" に設定されている場合のみ構成できます。

  • "テキストのみ" は、フィールドの "コンテンツ" プロパティに対してのみ設定できる値です。
データ型 有効なデータ型です。すべての有効なデータ型の一覧と説明については、「データ型とデータ型値の概要」を参照してください。

重要

  • [参照] プロパティ ページの "標準" プロパティの値が [X12]、[EDIFACT]、または [Custom] に設定されている場合は、[解析] プロパティ ページで [カスタム データ型] の値を割り当てることができます。[カスタム データ型] の値を指定すると、"データ型" フィールドの値は [カスタム データ型] で選択した値と一致するように自動的に変更されます。既に "カスタム データ型" フィールドで値を指定している場合、[宣言] プロパティ ページの "データ型" フィールドで値を指定すると、"カスタム データ型" フィールドで指定した値が消去されます。

  • "データ型" プロパティを [識別子参照属性値 [IDREF]] または [複数識別子参照属性値 [IDREFS]] に設定したフィールドを仕様で作成する場合は、[データ型] を [識別子 [ID]] に設定した別のフィールドをその仕様で作成する必要があります。

  • BizTalk メッセージ マネージャのチャネル フィルタ式で追跡または使用するフィールドを選択するには、仕様でそのフィールドにデータ型を割り当てる必要があります。
データ型値 [データ型] ボックスの一覧で [列挙 [Enumeration]] をクリックした場合は、既定でデータ型値 "a b c" が [データ型値] ボックスに表示されます。既定値は、スペースで区切られたカスタム値で置き換えることができます。

ANSI X12 ドキュメントまたは EDIFACT ドキュメントの場合、特定のフィールドに関連付けられたコードを含めると、これらのコードが [データ型値] ボックスに自動的に表示され、[データ型] ボックスに自動的に [列挙 [Enumeration]] が表示されます。
最小値 フィールドに含めることができる最小文字数です。

注

  • "最小値" プロパティを設定できるのは、[データ型] の値が [文字列 [String]]、[数値 [Number]]、[バイナリ (base64) [Binary (base64)]]、および [バイナリ (hex) [Binary (hex)]] のフィールドだけです。
最大値 フィールドに含めることができる最大文字数です。

注

  • "最大値" プロパティを設定できるのは、[データ型] の値が [文字列 [String]]、[数値 [Number]]、[バイナリ (base64) [Binary (base64)]]、および [バイナリ (hex) [Binary (hex)]] のフィールドだけです。
既定値 受信ドキュメント インスタンスにフィールドが含まれていない場合に渡される値です。詳細については、「既定値の統合」を参照してください。

注

  • "既定値" プロパティが仕様に表示されるのは、ルート ノードの [参照] プロパティ ページの "標準" プロパティが [XML] に設定され、フィールドの [宣言] プロパティ ページの "種類" プロパティが [属性] に設定されている場合だけです。

関連項目

チャネル フィルタ式の追加

循環参照

既定値の統合

チャネルでの仕様フィールドの選択

ドキュメント定義内の仕様フィールドの選択

データ型とデータ型値の概要


参照のプロパティの設定

  1. 仕様ツリーで、プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[参照] タブをクリックします。

  2. 設定するプロパティと関連付けられている [値] 列のフィールドをダブルクリックします。

  3. [値] 列のフィールドにデータを入力するか、下向き矢印をクリックして、一覧から利用可能なオプションを選択します。

次の表は、[参照] プロパティ ページに含まれているプロパティを一覧表示しています。選択するプロパティは、ルート ノード、レコード、またはフィールドのうち、選択したノードに対して設定されます。

[参照] プロパティ ページ : ルート ノードのプロパティ

プロパティ | 値
仕様名 | 仕様の名前です。この名前は、仕様の <Schema> タグの値に対応します。
標準 次の値のいずれかを選択します。
  • [XML] : Extensible Markup Language (XML) に基づいた仕様を作成する場合に選択します。

  • [X12] : ANSI X12 に基づいた仕様を作成する場合に選択します。

  • [EDIFACT] : EDIFACT に基づいた仕様を作成する場合に選択します。

  • [Custom] : フラット ファイルに基づいた仕様を作成する場合、またはカスタム パーサーで解析するカスタム仕様を作成する場合に選択します。
標準バージョン | ANSI X12 バージョン 4010 など、仕様が基づく標準のバージョンです。
ドキュメント型 | 850 など、仕様が基づくドキュメント型です。
バージョン | 仕様が基づくドキュメント標準のバージョン番号です。
既定のレコード区切り記号 [解析] プロパティ ページの [区切り記号の種類] が [既定のレコード区切り記号] に設定されているすべてのノードで区切り記号として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
既定のフィールド区切り記号 [解析] プロパティ ページの [区切り記号の種類] が [既定のフィールド区切り記号] に設定されているすべてのノードで区切り記号として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
既定のサブフィールド区切り記号 [解析] プロパティ ページの [区切り記号の種類] が [既定のサブフィールド区切り記号] に設定されているすべてのノードで区切り記号として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
既定のエスケープ文字 [解析] プロパティ ページの [エスケープの種類] が [既定のエスケープ文字] に設定されているすべてのノードでエスケープ文字として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
コード ページ 次の値のいずれかを選択します。
  • アラビア語 (1256)

  • バルト語 (1257)

  • 中央ヨーロッパ言語 (1250)

  • キリル文字 (1251)

  • ギリシャ語 (1253)

  • ヘブライ語 (1255)

  • 日本語 (Shift-JIS) (932)

  • 韓国語 (949)

  • Little-Endian-UTF16 (1200)

  • 簡体字中国語 (936)

  • タイ語 (874)

  • 範体字中国語 (950)

  • トルコ語 (1254)

  • ベトナム語 (1258)

  • 西ヨーロッパ言語 (1252)

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。

  • UTF7 (65000) と UTF8 (65001) は、BizTalk Server ではサポートされていません。

  • [コード ページ] 値が空白の場合、既定値は [西ヨーロッパ言語 (1252)] です。
受信確認 次のオプションのいずれかを選択します。
  • [はい] : 仕様を、受信される受信確認ドキュメントとして使用することを示します。関連付けコンポーネント ([X12]、[EDIFACT]、または [Custom]) は、受信ドキュメントと受信確認対象の送信ドキュメント (既に受信ドキュメントの送信者に送信済みのドキュメント) を関連付けます

  • [いいえ] : 仕様を、受信される受信確認ドキュメントとして使用しないことを示します。

注

  • 受信の値が空白の場合、既定値は [いいえ] です。

  • CanonicalReceipt に基づいた仕様の場合、および CanonicalReceipt がマップ済みの仕様の場合は、"受信" プロパティを [いいえ] に設定する必要があります (どちらも、送信される受信確認ドキュメントを生成する場合に使用されます)。
エンベロープ 次のオプションのいずれかを選択します。
  • [はい] : 仕様をインターチェンジ仕様として使うことを示します。

  • [いいえ] : 仕様をインターチェンジ仕様として使わないことを示します。
対象の名前空間 BizTalk フレームワーク インスタンスを使用していて、インスタンスで名前空間を指定した場合は、インスタンスで使用される対応する名前空間を入力する必要があります。

注

  • インスタンスの対象の名前空間の値に "x-schema" を使用すると、BizTalk マッパーでそのインスタンスをテストするときにエラーが発生することがあります。

[参照] プロパティ ページ : レコードのプロパティ

プロパティ 値
最小発生数 ノード階層の所定の位置にレコードが出現できる最小回数です。指定できる値は 0 または 1 です。

注

  • このプロパティ値が空白の場合、既定値は 1 です。
最大発生数 ノード階層の所定の位置にレコードが出現できる最大回数です。指定できる値は 1 と * です。

注

  • アスタリスク (*) を入力すると、レコードはループ レコードと見なされます。この仕様を BizTalk マッパーで使用すると、このレコードはループとしてコンパイルされます。1 を入力すると、BizTalk マッパーはこのレコードをループ レコードと見なしません。

  • このプロパティ値が空白の場合、既定値は 1 です。

[参照] プロパティ ページ : フィールドのプロパティ

プロパティ 値
[必須] 次のオプションのいずれかを選択します。
  • [はい] : 必須フィールドであることを示します。

  • [いいえ] : 必須フィールドではないことを示します。

  • このプロパティ値が空白の場合、既定値は [いいえ] です。
開始位置 レコードでのフィールドの開始位置を示す数値です。

注

  • このプロパティ フィールドは、親レコードの構造が位置指定の場合にだけ表示されます。
終了位置 レコードでのフィールドの終了位置を示す数値です。

注

  • このプロパティ フィールドは、親レコードの構造が位置指定の場合にだけ表示されます。

関連項目

フィールド位置の計算

受信確認について


解析のプロパティの設定

  1. 仕様ツリーで、プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[解析] タブをクリックします。

  2. 設定するプロパティと関連付けられている [値] 列のフィールドをダブルクリックします。

  3. フィールドにデータを入力するか、下向き矢印をクリックして、一覧から利用可能なオプションを選択します。

次の表は、[解析] プロパティ ページに含まれているプロパティを一覧表示しています。利用できるプロパティは、使用する標準 (ANSI X12、EDIFACT、または Custom) と構造のプロパティによって異なります。既定では、空の仕様に基づいた新しい仕様は、Extensible Markup Language (XML) の標準のプロパティを持っています。必要に応じて、各プロパティに値を入力します。選択するプロパティは、ルート ノード、レコード、またはフィールドのうち、選択したノードに対して設定されます。

標準 : XML

[解析] プロパティ ページ : ルート ノード、レコード、およびフィールドのプロパティ

これらのプロパティは表示されません。

標準 : X12 または EDIFACT

重要

  • レコードとその子フィールドの [囲み文字]、[埋め込み文字]、[エスケープ文字]、および [区切り記号] の値は、互いに排他である必要があります。

  • 囲み文字とエスケープ文字には必ず異なる値を指定してください。

[解析] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ 値
構造 この値の既定値は、自動的にルート ノードの [区切り記号] になります。

注

  • 仕様のルート ノードの [参照] プロパティ ページの "標準" プロパティの値が [X12] または [EDIFACT] に設定されている場合は、ルート ノードとすべてのレコードの [解析] プロパティ ページで "構造" プロパティの値を編集できません。"構造" プロパティの値を編集するには、標準を [Custom] に変更します。
送信元のタグ識別子 送信元のタグ識別子の名前です。これは、データを持つレコードと一致させるために使用されるタグ名です。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して元のファイルに存在するタグを識別することができます。

  • "送信元のタグ識別子" プロパティでは、大文字と小文字が区別されます。
フィールド順 次のオプションのいずれかを選択します。
  • [接頭辞] : 接頭辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの前に付けます。たとえば、* が区切り記号である場合、*a*a*b*c になります。

  • [接尾辞] : 接尾辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの後ろに付けます。たとえば、* が区切り記号である場合、a*a*b*c* になります。

  • [挿入辞] : 挿入辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの間に付けます。たとえば、* が区切り記号である場合、a*a*b*c になります。これが、すべての EDI ドキュメントの本来のフィールド順です。

注

  • [フィールド順] の値が空白の場合、既定値は [接頭辞] です。
区切り記号の種類 次のオプションのいずれかを選択して、現在のノードの直下の子ノードの区切り記号を選択します。
  • [既定のレコード区切り記号] : 区切り記号が、ドキュメント インスタンスで定義されている "既定のレコード区切り記号" プロパティの値であることを示します。

  • [既定のフィールド区切り記号] : 区切り記号が、ドキュメント インスタンスで定義されている "既定のフィールド区切り記号" プロパティの値であることを示します。

  • [既定のサブフィールド区切り記号] : 区切り記号が、ドキュメント インスタンスで定義されている "既定のサブフィールド区切り記号" プロパティの値であることを示します。
エスケープの種類

(リリース文字とも呼ばれます)

 次のオプションのいずれかを選択して、現在のノードの直下の子ノードのエスケープ文字を選択します。
  • [既定のエスケープ文字] : エスケープ文字が、ドキュメント インスタンスで定義されている値であることを示します。

エスケープ文字は、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号文字としても使用されている場合に役立ちます。たとえば、次のようなフィールド データがあるとします。

Browne,Peter,1231,yes

このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。この問題を解決するには、フィールド データに含める区切り記号文字の直前にエスケープ文字を置きます。たとえば、エスケープ文字として円記号を指定した場合は、次の例のように区切り記号文字の直前に円記号を置きます。

Browne\,Peter,1231,yes

円記号の後ろのカンマは、区切り記号文字ではなく、フィールド データとして解釈されます。

注

  • [エスケープの種類] は、X12 仕様では利用できません。
改行の追加 次のオプションのいずれかを選択します。
  • [はい] : シリアライザがレコード区切り記号に達したときに、改行 (LF、0x0A) を自動的に追加することを示します。

  • [いいえ] : シリアライザがレコード区切り記号に達したときに、次のレコードの処理を同じ行で継続することを示します。

注

  • [改行の追加] の値が空白の場合、既定値は [いいえ] です。
復帰文字のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の復帰文字 (CR) の値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の CR 値をスキップしないようにパーサーに通知します。

注

  • [復帰文字のスキップ] の値が空白の場合、既定値は [はい] です。
改行のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の改行 (LF) 値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の LF 値をスキップしないようにパーサーに通知します。

注

  • [改行のスキップ] の値が空白の場合、既定値は [はい] です。
レコード数の無視 次のオプションのいずれかを選択します。
  • [はい] : 仕様のレコード総数をカウントするときに、このレコードをカウントしないよう、パーサーまたはシリアライザに通知します。

  • [いいえ] : 仕様のレコード総数をカウントするときに、このレコードをカウントするよう、パーサーまたはシリアライザに通知します。

注

  • ドキュメント インスタンスが BizTalk Server に送信されたときに、ドキュメント インスタンスのレコード数が仕様で算出されたレコード数と一致しない場合、解析は失敗します。詳細については、「解析エラー」を参照してください。

  • [レコード数の無視] の値が空白の場合、既定値は [はい] です。

[解析] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
カスタム データ型 次のオプションのいずれかを選択します。
  • String (AN) [文字列] : AN は英数字フィールドを示します。

  • Binary Hexadecimal (B) [バイナリ 16 進数] : B はバイナリ フィールドを示します。

  • Date (CY) [日付] : CY は 4 桁の日付フィールドを示します。

  • Number (D0-4) [数値] : D0 から D4 は 10 進数フィールドです。1 桁の数字は、小数点以下の桁数を表します。

  • Date (DT) [日付] : DT は日付フィールドを示します。

  • String (ID) [文字列] : ID は識別フィールドを示します。

  • Number (N) [数値] : N は整数フィールドを示します。

  • Number (N0-9) [数値] : N0 から N9 は 10 進数フィールドとして暗黙的に使用されます。10 進数字はデータに表示されません。1 桁の数字は、小数点以下の桁数を表します。

  • Number (R) [数値] : R は数値フィールドを示します。

  • Number (R0-R9) [数値] : R0 から R9 は実数フィールドを示します。1 桁の数字は、小数点以下の桁数を表します。

  • Time (TM) [時刻] : TM は時刻フィールドを示します。

重要

  • [カスタム データ型] の値を指定すると、その値と一致するように、[宣言] プロパティ ページの "データ型" フィールドの値が自動的に変更されます。たとえば、[解析] プロパティ ページの [カスタム データ型] を [Date (CY)] に変更すると、[宣言] プロパティ ページの [データ型] 値は自動的に [Date (CY)] に変更されます。[宣言] プロパティ ページの "データ型" フィールドの値を指定すると、"カスタム データ型" フィールドで指定した値が消去されます。

注

  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。

  • "標準" プロパティが [X12] に設定されている仕様では、これらのすべてのカスタム データ型の値がサポートされます。"標準" プロパティが [EDIFACT] に設定されている仕様でサポートされるカスタム データ型の値は、[String (AN)] と [Number (N)] です。
カスタム日付/時刻書式 "カスタム データ型" プロパティとして [Date (DT)]、[Date (CY)]、または [Time (TM)] を設定した場合は、一覧のオプションをクリックします。

注

  • このプロパティ フィールドは、[カスタム データ型] を [Date (DT)]、[Date (CY)]、または [Time (TM)] に設定した場合にだけ利用できます。
位置揃え 次のオプションのいずれかを選択します。
  • [左] : 位置指定ファイルの場合、データが最大フィールド長より小さいときに、そのデータを左側に揃えます。区切りファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

  • [右] : 位置指定ファイルで、データを右側に揃えます。

注

  • [位置揃え] の値が空白の場合、既定値は [左] です。
埋め込み文字 | フィールドに埋め込む文字を入力または選択します。埋め込み文字には、スペースまたは 0 を含むすべての文字を選択できます。詳細については、「埋め込み文字」を参照してください。
囲み文字 フィールド データを囲む文字を入力します。このプロパティは、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号値としても使用されている場合に役立ちます。たとえば、次のようなフィールド データがあるとします。

Browne,Peter,1231,yes

このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。この問題を解決するには、"囲み文字" プロパティの値を定義してから、フィールド データを囲み文字で囲むようにします。たとえば、最初のフィールドの "囲み文字" プロパティを二重引用符に設定し、次の例のようにフィールド データを入力します。

"Browne,Peter",1231,yes

二重引用符の間のカンマは、区切り記号値ではなく、フィールド データとして解釈されます。

注

  • 囲み文字としても使用される文字がフィールド データに含まれている場合は、この文字を別の囲み文字のセットで囲む必要があります。

    たとえば、囲み文字の値が二重引用符に設定されているとします。

    "Browne,Peter ""Pete"""

    これは、次のように解析されます。

    Browne,Peter "Pete"

  • 入力ドキュメント インスタンスのフィールド データに改行文字と復帰文字が連続して含まれている場合は、両方が囲み文字のセットに囲まれていても、出力ドキュメント インスタンスの対応するフィールド データには改行文字だけが含まれます。
埋め込み文字を含めた最小値 出力ドキュメント インスタンスのフィールドの、埋め込み文字を含めた最小値です。埋め込み文字の詳細については、「埋め込み文字」を参照してください。

注

  • このプロパティは、フィールドに埋め込み文字が設定されている場合にだけ利用できます。

  • フィールドの [宣言] プロパティ ページで "最小値" プロパティを設定した場合は、"埋め込み文字を含めた最小値" プロパティを "最小値" プロパティの値以上にする必要があります。"最小値" プロパティを設定していない場合は、"埋め込み文字を含めた最小値" プロパティを 1 以上にします。

標準 : [Custom]
"構造" プロパティ: [区切り記号] :

重要

  • レコードとその子フィールドの [囲み文字]、[埋め込み文字]、[エスケープ文字]、および [区切り記号] の値は、互いに排他である必要があります。

  • 囲み文字とエスケープ文字には必ず異なる値を指定してください。

[解析] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ | 値
構造 ルート ノードのプロパティで次のオプションを選択します。
  • [区切り記号] : ルート ノードが区切りファイル構造に基づいていることを示します。レコードは、個別に区切りファイル構造または位置指定ファイル構造に基づくことができます。

レコードのプロパティで次のオプションのいずれかを選択します。

  • [区切り記号] : レコードが区切りファイル構造に基づいていることを示します。子孫レコードは、個別に区切りファイル構造または位置指定ファイル構造に基づくことができます。

  • [位置指定] : レコードが位置指定ファイル構造に基づいていることを示します。位置指定レコードは子レコードを持つことができません。

注

  • 区切り記号と位置指定の両方の構造を含むドキュメントの場合は、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。レコードの "構造" プロパティは、必要に応じて個別に [位置指定] または [区切り記号] に設定できます。

  • 一方の構造からもう一方の構造に変更すると、メッセージ ボックスが表示されます。 [はい] をクリックして構造の変更を確認します。新しいプロパティが表示されたり、既存のプロパティの一部が削除される可能性があります。

  • 位置指定レコードの "構造" プロパティの "値" フィールドを右クリックし、[プロパティのクリア] をクリックすると、レコードの構造は区切り記号と解釈されます。新しいプロパティが表示されたり、既存のプロパティの一部が削除される可能性があります。

  • ドキュメントの "標準" プロパティが [Custom] に設定されている場合、ルート ノードとすべてのレコードの "構造" プロパティの既定値は空白です。"構造" プロパティを空白のままにしておくと、値は [区切り記号] になります。
送信元のタグ識別子 送信元のタグ識別子の名前です。これは、データを持つレコードと一致させるために使用されるタグ名です。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して元のファイルに存在するタグを識別することができます。

  • "送信元のタグ識別子" プロパティでは、大文字と小文字が区別されます。
フィールド順 次のオプションのいずれかを選択します。
  • [接頭辞] : 接頭辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの前に付けます。たとえば、* が区切り記号である場合、*a*a*b*c になります。

  • [接尾辞] : 接尾辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの後ろに付けます。たとえば、* が区切り記号である場合、a*a*b*c* になります。

  • [挿入辞] : 挿入辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの間に付けます。たとえば、* が区切り記号である場合、a*a*b*c になります。これが、すべての電子データ交換 (EDI) ドキュメントの本来のフィールド順です。

注

  • [フィールド順] の値が空白の場合、既定値は [接頭辞] です。
区切り記号の種類 次のオプションのいずれかを選択して、現在のノードの直下の子ノードの区切り記号を選択します。
  • [文字] : [解析] プロパティ ページで区切り記号の値を指定できるようにします。[文字] を選択した場合は、区切り記号値を指定する必要があります。

  • [既定のレコード区切り記号] : 区切り記号は、ルート ノードの [参照] プロパティ ページの "既定のレコード区切り記号" プロパティの値であることを示します。

  • [既定のフィールド区切り記号] : 区切り記号は、ルート ノードの [参照] プロパティ ページの "既定のフィールド区切り記号" プロパティの値であることを示します。

  • [既定のサブフィールド区切り記号] : 区切り記号は、ルート ノードの [参照] プロパティ ページの "既定のサブフィールド区切り記号" プロパティの値であることを示します。
区切り記号値 | 区切り記号に使用する文字の値を入力または選択します。区切り記号値を指定するには、まず [解析] プロパティ ページの [区切り記号の種類] を [文字] に設定します。
エスケープの種類

(リリース文字とも呼ばれます)

 次のオプションのいずれかを選択して、現在のノードの直下の子ノードのエスケープ文字を選択します。
  • [文字] : [解析] プロパティ ページでエスケープ文字の値を指定できるようにします。[文字] を選択した場合は、エスケープ文字の値を指定する必要があります。

  • [既定のエスケープ文字] : エスケープ文字は、ルート ノードの [参照] プロパティ ページの "既定のエスケープ文字" プロパティの値であることを示します。

エスケープ文字は、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号文字としても使用されている場合に役立ちます。たとえば、次のようなフィールド データがあるとします。

Browne,Peter,1231,yes

このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。この問題を解決するには、フィールド データに含める区切り記号文字の直前にエスケープ文字を置きます。たとえば、エスケープ文字として円記号を指定した場合は、次の例のように区切り記号文字の直前に円記号を置きます。

Browne\,Peter,1231,yes

円記号の後ろのカンマは、区切り記号文字ではなく、フィールド データとして解釈されます。
エスケープの値 | エスケープ文字に使用する文字の値を入力または選択します。エスケープ文字の値を指定するには、まず [解析] プロパティ ページの [エスケープの種類] を [文字] に設定します。
改行の追加 次のオプションのいずれかを選択します。
  • [はい] : パーサーがレコード区切り記号に達したときに、次の行に移動し、その行で次のレコードの処理を開始することを示します。

  • [いいえ] : パーサーがレコード区切り記号に達したときに、次のレコードの処理を同じ行で継続することを示します。

注

  • [改行の追加] の値が空白の場合、既定値は [いいえ] です。
復帰文字のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の復帰文字 (CR) の値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の CR 値をスキップしないようにパーサーに通知します。

注

  • [復帰文字のスキップ] の値が空白の場合、既定値は [はい] です。
改行のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の改行 (LF) 値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の LF 値をスキップしないようにパーサーに通知します。

注

  • [改行のスキップ] の値が空白の場合、既定値は [はい] です。
レコード数の無視 次のオプションのいずれかを選択します。
  • [はい] : 仕様のレコード総数をカウントするときに、このレコードをカウントしないよう、パーサーまたはシリアライザに通知します。

  • [いいえ] : 仕様のレコード総数をカウントするときに、このレコードをカウントするよう、パーサーまたはシリアライザに通知します。

注

  • ドキュメント インスタンスが BizTalk Server に送信されたときに、ドキュメント インスタンスのレコード数が仕様で算出されたレコード数と一致しない場合、解析は失敗します。詳細については、「解析エラー」を参照してください。

  • [レコード数の無視] の値が空白の場合、既定値は [はい] です。

[解析] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
カスタム データ型 次のオプションのいずれかを選択します。
  • String (AN) [文字列] : AN は英数字フィールドを示します。

  • Binary Hexadecimal (B) [バイナリ 16 進数] : B はバイナリ フィールドを示します。

  • Date (CY) [日付] : CY は 4 桁の日付フィールドを示します。

  • Number (D0-4) [数値] : D0 から D4 は 10 進数フィールドです。1 桁の数字は、小数点以下の桁数を表します。

  • Date (DT) [日付] : DT は日付フィールドを示します。

  • String (ID) [文字列] : ID は識別フィールドを示します。

  • Number (N) [数値] : N は整数フィールドを示します。

  • Number (N0-9) [数値] : N0 から N9 は 10 進数フィールドとして暗黙的に使用されます。10 進数字はデータに表示されません。1 桁の数字は、小数点以下の桁数を表します。

  • Number (R) [数値] : R は数値フィールドを示します。

  • Number (R0-R9) [数値] : R0 から R9 は実数フィールドを示します。1 桁の数字は、小数点以下の桁数を表します。

  • Time (TM) [時刻] : TM は時刻フィールドを示します。

重要

  • [カスタム データ型] の値を指定すると、その値と一致するように、[宣言] プロパティ ページの "データ型" フィールドの値が自動的に変更されます。たとえば、[解析] プロパティ ページの [カスタム データ型] を [Date (CY)] に変更すると、[宣言] プロパティ ページの [データ型] 値は自動的に [Date (CY)] に変更されます。[宣言] プロパティ ページの "データ型" フィールドの値を指定すると、"カスタム データ型" フィールドで指定した値が消去されます。

注

  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。
カスタム日付/時刻書式 "カスタム データ型" プロパティとして [Date (DT)]、[Date (CY)]、または [Time (TM)] を設定した場合は、一覧のオプションをクリックします。

注

  • このプロパティ フィールドは、[カスタム データ型] を [Date (DT)]、[Date (CY)]、または [Time (TM)] に設定した場合にだけ利用できます。
位置揃え 次のオプションのいずれかを選択します。
  • [左] : 位置指定ファイルの場合、データが最大フィールド長より小さいときに、そのデータを左側に揃えます。区切りファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

  • [右] : 位置指定ファイルで、データを右側に揃えます。

注

  • "位置揃え" プロパティの値が選択されていない場合は、既定でデータは左に揃えられます。

  • [位置揃え] の値が空白の場合、既定値は [左] です。
埋め込み文字 | フィールドに埋め込む文字を入力または選択します。埋め込み文字には、スペースまたは 0 を含むすべての文字を選択できます。詳細については、「埋め込み文字」を参照してください。
囲み文字 フィールド データを囲む文字を入力します。このプロパティは、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号値としても使用されている場合に役立ちます。たとえば、次のようなフィールド データがあるとします。

Browne,Peter,1231,yes

このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。この問題を解決するには、"囲み文字" プロパティの値を定義してから、フィールド データを囲み文字で囲むようにします。たとえば、最初のフィールドの "囲み文字" プロパティを二重引用符に設定し、次の例のようにフィールド データを入力します。

"Browne,Peter",1231,yes

二重引用符の間のカンマは、区切り記号値ではなく、フィールド データとして解釈されます。

注

  • 囲み文字としても使用される文字がフィールド データに含まれている場合は、この文字を別の囲み文字のセットで囲む必要があります。

    たとえば、囲み文字の値が二重引用符に設定されているとします。

    "Browne,Peter ""Pete"""

    これは、次のように解析されます。

    Browne,Peter "Pete"

  • 入力ドキュメント インスタンスのフィールド データに改行文字と復帰文字が連続して含まれている場合は、両方が囲み文字のセットに囲まれていても、出力ドキュメント インスタンスの対応するフィールド データには改行文字だけが含まれます。
埋め込み文字を含めた最小値 出力ドキュメント インスタンスのフィールドの、埋め込み文字を含めた最小値です。詳細については、「埋め込み文字」を参照してください。

注

  • このプロパティは、フィールドに埋め込み文字が設定されている場合にだけ設定できます。

  • フィールドの [宣言] プロパティ ページで "最小値" プロパティを設定した場合は、"埋め込み文字を含めた最小値" プロパティを "最小値" プロパティの値以上にする必要があります。"最小値" プロパティを設定していない場合は、"埋め込み文字を含めた最小値" プロパティを 1 以上にします。

標準 : [Custom]
"構造" プロパティ: [位置指定]

[解析] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ | 値
構造 ルート ノードのプロパティで次のオプションを選択します。
  • [位置指定] : ルート ノードが位置指定ファイル構造に基づいていることを示します。

注

  • 位置指定ルート ノードのドキュメントにはレコードを含めることはできません。

  • 位置指定ルート ノードの "構造" プロパティの "値" フィールドを右クリックし、[プロパティのクリア] をクリックすると、ルート ノードの構造は区切り記号と解釈されます。新しいプロパティが表示されたり、既存のプロパティの一部が削除される可能性があります。

  • ドキュメントの "標準" プロパティが [Custom] に設定されている場合、ルート ノードとすべてのレコードの "構造" プロパティの既定値は空白です。"構造" プロパティを空白のままにしておくと、値は [区切り記号] になります。
送信元のタグ識別子 送信元のタグ識別子の名前です。これは、データを持つレコードと一致させるために使用されるタグ名です。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して元のファイルに存在するタグを識別することができます。

  • "送信元のタグ識別子" プロパティでは、大文字と小文字が区別されます。
送信元のタグ位置 | 位置指定レコードの中でタグが始まる位置を表す数値です。
改行の追加 次のオプションのいずれかを選択します。
  • [はい] : パーサーがレコード区切り記号に達したときに、次の行に移動し、その行で次のレコードの処理を開始することを示します。

  • [いいえ] : パーサーがレコード区切り記号に達したときに、次のレコードの処理を同じ行で継続することを示します。

注

  • [改行の追加] の値が空白の場合、既定値は [いいえ] です。
復帰文字のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の復帰文字 (CR) の値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の CR 値をスキップしないようにパーサーに通知します。

注

  • [復帰文字のスキップ] の値が空白の場合、既定値は [はい] です。
改行のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の改行 (LF) 値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の LF 値をスキップしないようにパーサーに通知します。

注

  • [改行のスキップ] の値が空白の場合、既定値は [はい] です。
レコード数の無視 次のオプションのいずれかを選択します。
  • [はい] : 仕様のレコード総数をカウントするときに、このレコードをカウントしないよう、パーサーまたはシリアライザに通知します。

  • [いいえ] : 仕様のレコード総数をカウントするときに、このレコードをカウントするよう、パーサーまたはシリアライザに通知します。

注

  • ドキュメント インスタンスが BizTalk Server に送信されたときに、ドキュメント インスタンスのレコード数が仕様で算出されたレコード数と一致しない場合、解析は失敗します。詳細については、「解析エラー」を参照してください。

  • [レコード数の無視] の値が空白の場合、既定値は [はい] です。

[解析] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
カスタム データ型 次のオプションのいずれかを選択します。
  • String (AN) [文字列] : AN は英数字フィールドを示します。

  • Binary Hexadecimal (B) [バイナリ 16 進数] : B はバイナリ フィールドを示します。

  • Date (CY) [日付] : CY は 4 桁の日付フィールドを示します。

  • Number (D0-4) [数値] : D0 から D4 は 10 進数フィールドです。1 桁の数字は、小数点以下の桁数を表します。

  • Date (DT) [日付] : DT は日付フィールドを示します。

  • String (ID) [文字列] : ID は識別フィールドを示します。

  • Number (N) [数値] : N は整数フィールドを示します。

  • Number (N0-9) [数値] : N0 から N9 は 10 進数フィールドとして暗黙的に使用されます。10 進数字はデータに表示されません。1 桁の数字は、小数点以下の桁数を表します。

  • Number (R) [数値] : R は数値フィールドを示します。

  • Number (R0-R9) [数値] : R0 から R9 は実数フィールドを示します。1 桁の数字は、小数点以下の桁数を表します。

  • Time (TM) [時刻] : TM は時刻フィールドを示します。

重要

  • [カスタム データ型] の値を指定すると、その値と一致するように、[宣言] プロパティ ページの "データ型" フィールドの値が自動的に変更されます。たとえば、[解析] プロパティ ページの [カスタム データ型] を [Date (CY)] に変更すると、[宣言] プロパティ ページの [データ型] 値は自動的に [Date (CY)] に変更されます。[宣言] プロパティ ページの "データ型" フィールドの値を指定すると、"カスタム データ型" フィールドで指定した値が消去されます。

注

  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。
  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。
 "カスタム データ型" プロパティとして [Date (DT)]、[Date (CY)]、または [Time (TM)] を設定した場合は、一覧のオプションをクリックします。

注

  • このプロパティ フィールドは、[カスタム データ型] を [日付 (DT)]、[日付 (CY)]、または [時刻 (TM)] に設定した場合にだけ利用できます。
位置揃え 次のオプションのいずれかを選択します。
  • [左] : 位置指定ファイルの場合、データが最大フィールド長より小さいときに、そのデータを左側に揃えます。区切りファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

  • [右] : 位置指定ファイルで、データを右側に揃えます。

注

  • [位置揃え] の値が空白の場合、既定値は [左] です。
埋め込み文字 | フィールドに埋め込むために使用する文字を入力します。埋め込み文字には、スペースまたは 0 を含むすべての文字を選択できます。詳細については、「埋め込み文字」を参照してください。

関連項目

埋め込み文字


名前空間の宣言

  1. 仕様ツリーで、任意のノードをクリックします。

  2. [名前空間] タブをクリックします。

  3. [プレフィックス] 列の最初の空白フィールドを右クリックし、[追加] をクリックします。

  4. 名前空間プレフィックスを入力し、Enter キーを押します。

  5. 右隣の [統一リソース名 (URN)] 列のフィールドをダブルクリックします。

  6. 統一リソース名 (URN) を入力し、Enter キーを押します。

重要

  • [統一リソース名 (URN)] に入力した名前空間は BizTalk エディタによって検証されません。

名前空間の詳細については、「名前空間宣言」を参照してください。

関連項目

カスタム コメントの追加

カスタム コメントの削除

カスタム コメントの編集

名前空間宣言


カスタム コメントの追加

  1. 仕様ツリーで、カスタム コメントを追加するルート ノード、レコード、またはフィールドをクリックします。

    注

    • ルート ノードの [参照] プロパティ ページにカスタム コメントを追加することはできません。
  2. カスタム コメントを追加するプロパティ ページに応じて、[宣言] タブまたは [参照] タブをクリックします。

  3. [プロパティ] 列の最初の空白フィールドを右クリックし、[追加] をクリックします。

    [プロパティ] ボックスの編集モードがアクティブになります。

  4. プレフィックス名の組をコロンで区切って入力し、Enter キーを押します。

    または

    一覧のカスタム コメントを 1 つクリックし、Enter キーを押します。

  5. 右隣の [値] 列の空白フィールドをダブルクリックします。

  6. カスタム コメントの値を入力し、Enter キーを押します。

重要

  • 仕様を正常にコンパイルするには、手順 4. で使用される名前空間プレフィックスを仕様で宣言しておく必要があります。詳細については、「名前空間の宣言」を参照してください。

関連項目

SQL コメントの追加

名前空間の宣言

カスタム コメントの削除

カスタム コメントの編集

名前空間宣言


カスタム コメントの編集

  1. 仕様ツリーで、編集するカスタム コメントが含まれているノードをクリックします。

  2. 編集するカスタム コメントを参照するタブ ([宣言] または [参照]) をクリックします。

  3. カスタム コメントの "プロパティ" フィールドをダブルクリックしてフィールドを編集し、Enter キーを押します。

  4. カスタム コメントの "値" フィールドをダブルクリックしてフィールドを編集し、Enter キーを押します。

関連項目

SQL コメントの追加

名前空間の宣言

名前空間宣言


カスタム コメントの削除

  1. 仕様ツリーで、削除するカスタム コメントが含まれているノードをクリックします。

  2. 削除するカスタム コメントを参照するタブ ([宣言] または [参照]) をクリックします。

  3. カスタム コメントを右クリックし、[削除] をクリックします。

  4. [はい] をクリックして変更を確認します。

関連項目

カスタム コメントの追加

SQL コメントの追加

名前空間の宣言.

カスタム コメントの編集

名前空間宣言


ディクショナリ プロパティの設定

  1. 仕様ツリーで、プロパティを指定するルート ノード、レコード、またはフィールドをクリックし、[ディクショナリ] タブをクリックします。

  2. [プロパティ] 列で、フィールドと関連付ける値のチェック ボックスをオンにします。

[ディクショナリ] プロパティ ページには、次の表に示すプロパティがあります。ディクショナリ プロパティを設定できる仕様は、[参照] プロパティ ページの "標準" プロパティが [XML] または [Custom] に設定されている仕様だけです。

[ディクショナリ] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ | ノード パス
ドキュメントのコンテナ ノード | エンベロープ スキーマで、ドキュメント ノードはドキュメントが含まれているレコードを示します。

注

  • BizTalk Server のフラット ファイル パーサーで解析され、[参照] プロパティ ページの "標準" プロパティが [Custom] に設定されているフラット ファイル仕様では、[ディクショナリ] プロパティ ページの [ドキュメントのコンテナ ノード] チェック ボックスをオンにしてもオフにしても影響はありません。このディクショナリ プロパティは利用可能ですが、利用するには、"ドキュメントのコンテナ ノード" ディクショナリ プロパティを使用するカスタム仕様とカスタム パーサーを作成する必要があります。

[ディクショナリ] プロパティ ページ : フィールドのプロパティ

プロパティ | ノード パス
ドキュメント名 | ドキュメント名が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信元の種類 | 送信元の種類が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信元の値 | 送信元の値が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信先の種類 | 送信先の種類が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信先の値 | 送信先の値が含まれているドキュメント インスタンスのフィールドのパスを表示します。

注

  • 仕様の解析では、チャネルの場所の特定には [ディクショナリ] プロパティ ページの情報が使用されます。チャネルは BizTalk メッセージ マネージャを使用して作成できます。チャネルと BizTalk メッセージ マネージャの詳細については、「チャネルについて」を参照してください。

  • オープンなメッセージ ポートに送信されるドキュメントを仕様を使って定義する場合は、送信先とトランスポートの情報を含むフィールドの [ディクショナリ] プロパティ ページで、送信先の値を選択する必要があります。送信パラメータを使用している場合は、ドキュメント内の送信先の情報は上書きされます。ドキュメントの送信の詳細については、「送信」を参照してください。

  • "ディクショナリ" プロパティを設定するには、[プロパティ] 列のフィールドを右クリックし、[ルーティング情報の設定] をクリックする方法もあります。

関連項目

カスタム ディクショナリ プロパティの追加

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの削除

カスタム ディクショナリ プロパティの名前の変更

送信

メッセージ ポートについて


カスタム ディクショナリ プロパティの追加

  1. 仕様ツリーで、カスタム ディクショナリ プロパティを追加するフィールドをクリックします。

  2. [ディクショナリ] タブをクリックします。

  3. [プロパティ] 列の最初の空白フィールドをダブルクリックします。

  4. プロパティの名前を入力し、Enter キーを押します。

注

  • 作成するカスタム プロパティごとに一意な名前を指定してください。

  • ルート ノードの "標準" プロパティが [X12] または [EDIFACT] に設定されていてはなりません。

関連項目

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの削除

カスタム ディクショナリ プロパティの名前の変更

ディクショナリ プロパティの設定


カスタム ディクショナリ プロパティの名前の変更

  1. [ディクショナリ] タブをクリックします。

  2. 名前を変更するカスタム プロパティを右クリックし、[名前の変更] をクリックします。

  3. プロパティの名前を入力し、Enter キーを押します。

注

  • 作成するカスタム プロパティごとに一意な名前を指定してください。

関連項目

カスタム ディクショナリ プロパティの追加

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの削除

ディクショナリ プロパティの設定


ディクショナリ プロパティの消去

  1. 仕様ツリーで、ディクショナリ プロパティを消去するノードをクリックし、[ディクショナリ] タブをクリックします。

  2. [プロパティ] 列で、フィールドとの関連付けを解除する値のチェック ボックスをオフにします。

注

  • "ディクショナリ" プロパティの値を消去するには、[プロパティ] 列のフィールドを右クリックし、[ルーティング情報のクリア] をクリックする方法もあります。

  • ノードのディクショナリ プロパティを消去すると、ルーティング情報が削除されます。

関連項目

カスタム ディクショナリ プロパティの追加

カスタム ディクショナリ プロパティの削除

カスタム ディクショナリ プロパティの名前の変更

宣言のプロパティの設定


カスタム ディクショナリ プロパティの削除

  1. [ディクショナリ] タブをクリックします。

  2. 削除するカスタム プロパティを右クリックし、[削除] をクリックします。

  3. [はい] をクリックして変更を確認します。

関連項目

カスタム ディクショナリ プロパティの追加

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの名前の変更

ディクショナリ プロパティの設定


コードの選択

  1. 仕様ツリーのフィールドをクリックします。

  2. [コード一覧] タブをクリックします。

  3. [値] 列で、使用するコードのチェック ボックスをオンにします。

注

  • コード一覧は ANSI X12 または EDIFACT に基づく仕様に対してのみ利用可能です。ただし、ANSI X12 または EDIFACT に基づいた仕様のすべてのフィールドに対してコードが関連付けられているわけではありません。特定のフィールドで利用できるコードの完全な一覧は、[コード一覧] プロパティ ページに表示されます。コードの横の [値] フィールドのチェック ボックスがオンになっている場合は、そのフィールドに対してコードが関連付けられています。"説明" フィールドに、コードに関する説明が表示されます。

  • [コード一覧] プロパティ ページのフィールドにコードを関連付けると、その関連付けは [宣言] プロパティ ページにも表示されます。[宣言] プロパティ ページの "データ型" フィールドが自動的に [Enumeration [列挙]] になり、[コード一覧] プロパティ ページで選択したコード一覧の番号が "データ型値" フィールドに表示されます。[宣言] プロパティ ページの "データ型" フィールドを消去すると、[コード一覧] プロパティ ページではコードが何も選択されていない状態になります。詳細については、「[値] 列のフィールドのプロパティの消去」を参照してください。

  • 一定範囲内のコードを選択するには、コードのチェック ボックスをオンにし、Shift キーを押しながら次のコードのチェック ボックスをオンにします。最初のコードと次のコードの間にあるすべてのコードが選択されます。

  • [コード一覧] プロパティ ページに表示されるコード値は、時折重複していることがあります。重複しているコード値の "説明" フィールドには、コード値と関連付るドキュメントの種類に応じて、さまざまな説明が入ります。ドキュメント インスタンスの検証では、コード値を複数選択する必要はありません。コード一覧で値が重複している場合に、偶然に複数の重複コード値を選択したときは、次のように扱われます。
    • 重複した一連のコード値の中で、一番上に表示されているコード値を選択した場合は、そのコード値だけが選択されます。

    • 選択した値が、重複した一連のコード値の中で一番上に表示されている値ではなかった場合は、選択したコード値と共に一番上のコード値も自動的に選択されます。

    • 重複している一連のコード値の中で一番上に表示されているコード値は、ほかの値が 1 つでも選択されている場合は消去できません。

関連項目

[値] 列のフィールドのプロパティの消去

コードの消去

コード一覧の値と説明


コードの消去

  1. 仕様ツリーのフィールドをクリックします。

  2. [コード一覧] タブをクリックします。

  3. [値] 列で、消去するコードのチェック ボックスをオフにします。

注

  • コード一覧は ANSI X12 または EDIFACT に基づく仕様に対してのみ利用可能です。ただし、ANSI X12 または EDIFACT に基づいた仕様のすべてのフィールドに対してコードが関連付けられているわけではありません。特定のフィールドで利用できるコードの完全な一覧は、[コード一覧] プロパティ ページに表示されます。コードの横の [値] フィールドのチェック ボックスがオンになっている場合は、そのフィールドに対してコードが関連付けられています。"説明" フィールドに、コードに関する説明が表示されます。

  • [コード一覧] プロパティ ページに表示されるコード値は、時折重複していることがあります。重複しているコード値の "説明" フィールドには、コード値と関連付るドキュメントの種類に応じて、さまざまな説明が入ります。ドキュメント インスタンスの検証では、コード値を複数選択する必要はありません。コード一覧で値が重複している場合に、偶然に複数の重複コード値を選択したときは、次のように扱われます。
    • 重複した一連のコード値の中で、一番上に表示されているコード値を選択した場合は、そのコード値だけが選択されます。

    • 選択した値が、重複した一連のコード値の中で一番上に表示されている値ではなかった場合は、選択したコード値と共に一番上のコード値も自動的に選択されます。

    • 重複している一連のコード値の中で一番上に表示されているコード値は、ほかの値が 1 つでも選択されている場合は消去できません。

関連項目

コード一覧の値と説明

コードの選択


[値] 列のフィールドのプロパティの消去

  1. 消去するプロパティが含まれているタブをクリックします。

  2. [値] 列のフィールドを右クリックし、[プロパティのクリア] をクリックします。


フィールド位置の自動計算

  1. 位置指定レコードのフィールドを選択します。

  2. [データ型] 行の "値" フィールドをダブルクリックします。

  3. [データ型] ボックスの一覧で値をクリックします。

    注

    • 手順 4. と 5. で [最大値] の値を指定するには、[データ型] で、[文字列 [String]]、[数値 [Number]]、[バイナリ (base64) [Binary (base64)]]、または [バイナリ (hex) [Binary (hex)]] のいずれかの値を選択する必要があります。
  4. [最大値] 行の "値" フィールドをダブルクリックします。

  5. "最大値" フィールドに数値を入力し、Enter キーを押します。

  6. レコードのフィールドごとに、手順 1. ～ 5. を繰り返します。

  7. レコードを右クリックし、[フィールド位置の計算] をクリックします。

    次の警告が表示されます。

    この操作を実行すると、選択したレコードにあるフィールドの開始位置プロパティと終了位置プロパティが変更されます。操作を続行しますか?

  8. [はい] をクリックします。

    レコードにあるフィールドの開始位置と終了位置が計算されます。詳細については、「フィールド位置の計算」を参照してください。

関連項目

フィールド位置の計算


メモと構文規則の編集

[ノードのプロパティ] ダイアログ ボックスでは、次の操作ができます。

  • フィールドとレコードのメモの読み取りと編集

  • レコードの構文規則の読み取り

[ノードのプロパティ] ダイアログ ボックスを表示するには、次の操作を行います。

  1. 仕様ツリーのレコードまたはフィールドを右クリックし、[プロパティ] をクリックします。

    既定では [メモ] プロパティ ページが表示されます。

  2. レコードの構文規則を表示するには、[構文規則] タブをクリックします。

注

  • 構文規則はレコードにだけ適用されます。

このダイアログ ボックスの使用方法については、次のトピックを参照してください。

  • レコード メモの入力

  • 構文規則の表示

  • フィールド メモの入力


レコード メモの入力

[ノードのプロパティ] ダイアログ ボックスを開く方法については、「メモと構文規則の編集」を参照してください。

レコードに関する情報を、そのレコードに関連付けられているメモを使用して記録できます。記録する情報の例としては、レコードの目的や作成された理由などがあります。

  • メモを記録するには、[ノードのプロパティ] ダイアログ ボックスにテキストを入力し、[OK] をクリックします。

注

  • ルート ノードにはメモを追加できません。

  • メモに印刷不能文字を入力することはできません。

関連項目

フィールド メモの入力

構文規則の表示


構文規則の表示

[ノードのプロパティ] ダイアログ ボックスを開く方法については、「メモと構文規則の編集」を参照してください。

構文規則は、仕様ツリーの構成方法に関する情報を提供するものです。構文規則が表示されるのは、ANSI X12 標準に基づいた仕様だけです。

注

  • 構文規則はレコードにだけ適用されます。

関連項目

フィールド メモの入力

レコード メモの入力


フィールド メモの入力

[ノードのプロパティ] ダイアログ ボックスを開く方法については、「メモと構文規則の編集」を参照してください。

フィールドに関する情報を、そのフィールドに関連付けられているメモを使用して記録できます。記録する情報の例としては、フィールドの目的や作成された理由などがあります。

  • メモを記録するには、[ノードのプロパティ] ダイアログ ボックスにテキストを入力し、[OK] をクリックします。

注

  • メモに印刷不能文字を入力することはできません。

関連項目

レコード メモの入力

構文規則の表示


ドキュメント インスタンスの管理

BizTalk エディタを使用して、仕様に基づいたドキュメント インスタンスの作成、および仕様に対するドキュメント インスタンスの検証ができます。

ここには次のトピックが含まれます。

  • ドキュメント インスタンスの作成

  • ドキュメント インスタンスの検証


ドキュメント インスタンスの作成

  1. ドキュメント インスタンスの基本として使う仕様を開きます。

  2. [ツール] メニューの [XML インスタンスの作成] をクリックします。

  3. [ドキュメント インスタンスの作成] ダイアログ ボックスで、ドキュメント インスタンスを作成するフォルダを指定します。

  4. [ファイル名] ボックスにドキュメント インスタンスの名前を入力し、[保存] をクリックします。

    新しいドキュメント インスタンスが [出力] プロパティ ページに表示されます。

注

  • ドキュメント インスタンスの作成で利用できる形式は、Unicode だけです。

関連項目

ドキュメント インスタンスの検証


ドキュメント インスタンスの検証

  1. ドキュメント インスタンスの検証で使う仕様を開きます。

    詳細については、「仕様を開く」を参照してください。

  2. [ツール] メニューの [インスタンスの検証] をクリックします。

  3. [ドキュメント インスタンスの検証] ダイアログ ボックスで、検証するドキュメント インスタンスを参照し、[開く] をクリックします。

    ANSI X12 標準または EDIFACT 標準に基づいた仕様に対してドキュメント インスタンスを検証する場合は、[ドキュメントの区切り記号] ダイアログ ボックスが表示されます。次のいずれかの操作を行います。

    • ANSI X12 に基づいた仕様の場合 : 検証するドキュメントに適した区切り記号を選択し、[OK] をクリックします。

    • EDIFACT に基づいた仕様の場合 : 検証するドキュメントに適した区切り記号とエスケープ文字を選択し、[OK] をクリックします。

仕様に対してドキュメント インスタンスが検証されると、[警告] プロパティ ページに "ドキュメント インスタンスの検証が正常に終了しました。" というメッセージが表示されます。仕様に対してドキュメント インスタンスが検証されないと、[警告] プロパティ ページに、検証されなかったことを示すメッセージと、その原因を示すエラーが表示されます。非 XML 仕様に対する非 XML ドキュメント インスタンスの検証を行った場合、ドキュメント インスタンスが検証されると、ドキュメントの Extensible Markup Language (XML) バージョンが [出力] プロパティ ページに表示されます。

重要

  • 本番運用環境でドキュメント インスタンスを使用する前に、送信元仕様に対してそのインスタンスを検証し、[警告] プロパティ ページに表示された問題を修正するようにしてください。

注

  • BizTalk エディタでは、複数のドキュメントを含むドキュメント インスタンスは検証されません。

  • 空白の属性値 ("") を持つフィールドが含まれているドキュメント インスタンスは、そのフィールドの "最小値" プロパティに値が設定されている仕様に対しても正常に検証されます。たとえば、"最小値" プロパティの値が 4 に設定されているフィールドがある仕様に対して、対応するフィールドの属性値が空白であるドキュメント インスタンスを検証しても、この不一致が原因で検証が失敗することはありません。これは、検証エンジンの基本となっている MSXML パーサーが、空白の値を持つ属性を、属性が指定されていないものとして扱うためです。この問題は、BizTalk Server の次のリリースで修正される予定です。

  • 電子データ交換 (EDI) インスタンス (ANSI X12 標準と EDIFACT 標準の両方) に対してインスタンスの検証を正常に実行するには、これらのインスタンスからインターチェンジ、グループ、およびドキュメント エンベロープ (ヘッダーとトレーラの両方) を削除しておく必要があります。ANSI X12 ドキュメントの場合は、ISA、GS、ST、SE、GE、および IEA の各セグメントを削除する必要があります。EDIFACT ドキュメントの場合は、UNA (存在する場合)、UNB、UNG、UNH、UNT、UNE、および UNZ の各セグメントを削除します。

  • XML-Data Reduced (XDR) データ型に型指定された要素が含まれている整形式 XML ドキュメント インスタンスは、対応する仕様に対して検証できないことがあります。このようなドキュメント インスタンスを対応する仕様に対して検証するには、XDR データ型に型指定されたすべての要素の "モデル" プロパティを [オープン] に設定します。"モデル" プロパティの詳細については、「宣言のプロパティの設定」を参照してください。

  • Unicode で保存された非 XML ドキュメント インスタンスを正常に検証するには、ファイルの先頭のバイト順序記号を削除する必要があります。

  • [標準] が [X12]、[EDIFACT]、または [Custom] に設定されている仕様に対してドキュメント インスタンスを検証する場合は、ドキュメント インスタンスのドキュメント構造が仕様の標準に準拠している必要があります。たとえば、ANSI X12 のドキュメント インスタンスは、ANSI X12 の仕様に対してだけ検証できます。

  • "x-schema" スキーマ参照が含まれているドキュメント インスタンスは、BizTalk エディタで読み込まれるスキーマに関係なく、常にそのスキーマ参照を使用して検証されます。

  • 無効な文字コード表はインスタンスの検証の基準になりません。たとえば、[無効な文字コード範囲] ダイアログ ボックスの開始文字コードと終了文字コードの間にあるデータがインスタンスに含まれていても、検証は正常に終了します。

関連項目

ドキュメント インスタンスの作成


無効な文字コード表の管理

ここには次のトピックが含まれます。

  • 無効文字範囲の追加

  • 無効文字範囲の編集

  • 無効文字範囲の削除


無効文字範囲の追加

  1. [表示] メニューの [無効な文字コード表] をクリックします。

  2. [無効な文字コード範囲] ダイアログ ボックスの [新しい文字範囲の作成] [新しい文字範囲の作成] ボタン をクリックします。

  3. [無効な文字コード範囲の入力] ダイアログ ボックスの [無効な開始文字コード] ボックスの一覧で値をクリックし、Tab キーを押します。

  4. [無効な終了文字コード] ボックスの一覧で値をクリックし、[OK] をクリックします。

  5. 手順 2. ～ 4. を繰り返して、そのほかの無効文字範囲を追加します。

重要

  • 無効な文字範囲を設定できるのは、非 XML ドキュメントに対してだけです。

  • 疑問符 (?) の正しい 16 進数は (0x3f) です。[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスの既定の設定は、? (0x0) です。疑問符を表すときに、こちらを使用しないでください。疑問符を指定するには、? (0x3f) を一覧で選択してください。

注

  • [無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスに表示される値は 16 進数です。Microsoft Internet Explorer 5 以降などのアプリケーションを使用して仕様を Extensible Markup Language (XML) ソース ファイルとして表示すると、値は 10 進数で表示されます。たとえば、[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスにセミコロン (;) を入力すると、表示される値は ; (0x3b) になります。ブラウザを使用して表示すると、この値は 59 と表示されます。

  • 無効文字範囲を入力するには、[無効な開始文字コード] および [無効な終了文字コード] ボックスの表示エリアをダブルクリックして、[無効な文字コード範囲の入力] ダイアログ ボックスを表示する方法もあります。

関連項目

無効文字範囲の削除

無効文字範囲の編集


無効文字範囲の編集

  1. [表示] メニューの [無効な文字コード表] をクリックします。

  2. [無効な文字コード範囲] ダイアログ ボックスで変更する文字範囲を選択し、[文字範囲の変更] [文字範囲の変更] ボタン をクリックします。

  3. [無効な文字コード範囲の入力] ダイアログ ボックスで、次の操作を行います。
    • [無効な開始文字コード] ボックスの一覧で値を選択します。

      – または –

    • [無効な終了文字コード] ボックスの一覧で値を選択します。
  4. [OK] をクリックします。

  5. 手順 2. ～ 4. を繰り返して、そのほかの無効文字範囲を変更します。

重要

  • 無効な文字範囲を設定できるのは、非 XML ドキュメントに対してだけです。

  • 疑問符 (?) の正しい 16 進数は (0x3f) です。[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスの既定の設定は、? (0x0) です。疑問符を表すときに、こちらを使用しないでください。疑問符を指定するには、? (0x3f) の値を一覧でクリックしてください。

注

  • [無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスに表示される値は 16 進数です。Microsoft Internet Explorer 5 以降などのアプリケーションを使用して仕様を XML ソース ファイルとして表示すると、値は 10 進数で表示されます。たとえば、[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスにセミコロン (;) を入力すると、表示される値は ; (0x3b) になります。ブラウザを使用して表示すると、この値は 59 と表示されます。

  • 無効文字範囲を入力するには、[無効な開始文字コード] および [無効な終了文字コード] ボックスの表示エリアをダブルクリックして、[無効な文字コード範囲の入力] ダイアログ ボックスを表示する方法もあります。

関連項目

無効文字範囲の追加

無効文字範囲の削除


無効文字範囲の削除

重要

  • 無効な文字範囲を設定できるのは、非 XML ドキュメントに対してだけです。
  1. [表示] メニューの [無効な文字コード表] をクリックします。

    [無効な文字コード範囲] ダイアログ ボックスで削除する文字範囲をクリックし、[文字範囲の削除] [文字範囲の削除] ボタン をクリックします。

  2. [はい] をクリックして変更を確認します。

関連項目

無効文字範囲の追加

無効文字範囲の編集


表示の管理

ここには次のトピックが含まれます。

  • ツリー項目の展開

  • ツリー項目の折りたたみ

  • プロパティ値の表示

  • テキストのサイズの変更


ツリー項目の展開

  • 展開するルート ノードまたはレコードをクリックし、[表示] メニューの [ツリー項目の展開] をクリックします。

注

  • ツリー全体を展開するには、ルート ノードをクリックします。レコードをクリックすると、そのレコードの子レコードとフィールドだけが展開されます。

関連項目

ツリー項目の折りたたみ


ツリー項目の折りたたみ

  • 折りたたむルート ノードまたはレコードをクリックし、[表示] メニューの [ツリー項目の折りたたみ] をクリックします。

注

  • ツリー全体を折りたたむには、ルート ノードをクリックします。レコードをクリックすると、そのレコードの子レコードとフィールドだけが折りたたまれます。

関連項目

ツリー項目の展開


プロパティ値の表示

  • [表示] メニューで、次のプロパティのいずれかをクリックします。
    • 宣言

    • 参照

    • 解析

    • 名前空間

    • ディクショナリ

    • コード一覧


テキストのサイズの変更

  • [表示] メニューの [テキストのサイズ] をポイントし、使用するサイズをクリックします。


概念

ここでは、BizTalk エディタを理解するうえで不可欠な概念について説明します。

ここには次のトピックが含まれます。

  • 仕様について

  • ファイルのインポート

  • BizTalk エディタの環境

  • レコード、フィールド、およびプロパティ

  • 名前空間のサポート

  • SQL コメントの追加


仕様について

仕様とは、BizTalk エディタによって作成される BizTalk Server 固有の Extensible Markup Language (XML) スキーマのことです。仕様は、業界標準 (XML、EDIFACT、ANSI X12) に基づいて作成することも、非業界標準 (区切りフラット ファイル、 位置指定フラット ファイル、区切りフラット ファイルと位置指定フラット ファイルを組み合わせたファイル、空の仕様、既存のファイル) に基づいて作成することもできます。

業界標準

業界標準によって、企業間でデータを電子的に交換するための共通のデータ交換方法が提供されます。共通のビジネス言語を使用することにより、組織内やほかの企業のコンピュータとの間で通信を行うことができます。業界標準には電子ビジネス トランザクションの形式とデータの内容が指定されています。業界標準に基づいた仕様は、標準のサブセットと見なされます。ユーザーのニーズを満たす仕様を作成するには、業界標準をベースラインにして仕様を作成し、その後で不要なレコードやフィールドを削除します。残したレコードやフィールドのプロパティを変更する場合もあります。

非業界標準

非業界標準に基づいた仕様では、BizTalk エディタを使用してドキュメントの構造を定義する必要があります。位置指定フラットファイル、区切りフラット ファイル、位置指定フラット ファイルと区切りフラット ファイルを組み合わせたファイルなど、各種の非業界標準に基づいた仕様の作成に BizTalk エディタを使用できます。

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。追加のレコード プロパティは、その属性によって [区切り記号] または [位置指定] のいずれかに設定されます。

空の仕様

空の仕様は、ルート ノード要素だけを含む仕様です。空の仕様を基にする場合は、仕様構造全体を構築する必要があります。ルート要素の名前を変更し、必要に応じて、ヘッダー情報に属する仕様のルート要素のプロパティ値を変更します。その後、ビジネス プロセスの必要に応じて、レコードやフィールド、それらのプロパティを追加します。

既存のファイル

既存のファイルを再使用することで、特定のビジネス ニーズに合わせて既に作成済みのドキュメントを有効活用できます。既存のファイルを再使用するには、まずそのファイルを BizTalk エディタにインポートし、仕様として保存します。その後、保存した仕様を BizTalk マッパーで開き、取引先から要求された書式にマップします。

ここには次のトピックが含まれます。

  • 仕様構造

  • 標準のサポート

  • ほかのファイル形式のサポート

  • XML 名に使用できない文字

  • 無効な文字の範囲

関連項目

フラット ファイルに基づいた仕様の作成

空のテンプレートに基づいた仕様の作成

既存の仕様に基づいた仕様の作成

標準に基づいた仕様の作成

レコード、フィールド、およびプロパティ


仕様構造

BizTalk エディタで作成する仕様は、整形式 XML です。仕様構造は、作成の基礎として選択したファイルの種類によって異なります。仕様の基本構造は、種類とは関係なくすべて同じです。たとえば、すべての仕様は <?xml version=""?> タグで始まり、ファイル名や名前空間データなどのヘッダー情報が続きます。残りの構造は、仕様内のレコードやフィールド、およびそのレコードやフィールドに関連付けられた属性に基づいています。仕様の基本コードを表示するには、Microsoft Internet Explorer 5 以降で仕様を開きます。

[ツール] メニューの [XDR スキーマのエクスポート] を使用すると、仕様から XML-Data Reduced (XDR) スキーマを作成できます。詳細については、「XDR スキーマのエクスポート」を参照してください。

XDR スキーマから XSD スキーマを作成できます。XDR スキーマから XSD スキーマへの変換の詳細については、「XDR スキーマから XSD スキーマへの変換」を参照してください。

関連項目

XDR スキーマのエクスポート

XDR スキーマから XSD スキーマへの変換


標準のサポート

EDIFACT、ANSI X12 などの電子データ交換 (EDI ) 標準には、ビジネス ドキュメントに必要なファイル構造を構成するときに使用できる多数のセグメントとエレメントが定義されています (EDI 標準では、データ フィールドのことを一般に、エレメントと表現しています。XML では、要素と表現します)。BizTalk エディタを使って仕様を作成するときは、これらの構造を基本としてまず仕様を作成し、その後で不要なセグメントやエレメントを削除します。最終構造は、取引先との間または社員同士でビジネス データを交換する方法として用いられる標準のサブセットです。

EDIFACT ドキュメントまたは ANSI X12 ドキュメントにノードを作成したり、ノードを移動する場合は、ドキュメント標準を [Custom] に設定してください。また、"区切り記号の種類" プロパティを、変更後の構造がドキュメントの残りの部分と互換性を持つように設定してください。ドキュメント標準の設定を [Custom] から [EDIFACT] または [X12] に戻すと、"区切り記号の種類" プロパティの設定がすべて消失します。"カスタム" プロパティの設定の詳細については、「参照のプロパティの設定」を参照してください。"区切り記号の種類" プロパティの設定の詳細については、「解析のプロパティの設定」を参照してください。

BizTalk エディタは X12 構文規則もサポートしています。X12 構文規則は、1 つのレコードについて 2 つ以上のデータ要素間に存在する関係条件です。仕様に構文規則が含まれる場合は、仕様を検証するときに、サーバー実行時プロセスで構文規則が適用されます。

構文規則には次の 5 種類があります。

  • すべて

    TXI08 が存在する場合は、次のノードはすべて存在する必要があります。

    • TXI03
  • グループ化

    次のノードのいずれかが存在する場合は、すべてが存在する必要があります。

    • TXI04

    • TXI05
  • 任意

    次のノードのうちの 1 つ以上が存在する必要があります。

    • TXI02

    • TXI03

    • TXI06
  • 1 つ

    次のノードのうちの 1 つだけ存在できます。

    • TXI02

    • TXI03

    • TXI06
  • 任意 (条件付き)

    PO413 が存在する場合は、次のノードのうちの 1 つ以上が存在する必要があります。

    • PO410

    • PO411

    • PO412

関連項目

参照のプロパティの設定

付属 EDI ベースのドキュメントの概要一覧


ほかのファイル形式のサポート

BizTalk エディタは、位置指定ファイル構造、区切りファイル構造、位置指定ファイルと区切りファイルを組み合わせたファイル構造の仕様を作成しやすいように設計されています。ここでは、これらのファイル構造について説明します。

位置指定フラット ファイル

位置指定フラット ファイルは、同じ固定長を持つ複数のフィールドと、共通のレコード終端記号を持つ複数のレコードで構成されます。受信ファイルの構造は送信元仕様で定義するレコードとフィールドから成り、フィールドの位置情報を設定する必要があります。したがって、送信元仕様のドキュメント構造を定義する前に、必要なレコードとフィールドのレイアウトを取得してください。

次の表は、固定形式の例を示しています。

名前 | 住所 | 市区町村 | 電話番号
Xxxxxxxxxx | Aaaaaaaaaa | Ccccccccccccccc | xxx-xxx-xxxx
Yyyyyyyyyy | Bbbbbbbbbb | Ddddddddddddd | xxx-xxx-xxxx

"名前" フィールドは 10 文字以下、"住所" フィールドは 10 文字以下、"市区町村" フィールドは 15 文字以下、"電話番号" フィールドは 12 文字以下に、それぞれ固定されています。レコード区切り記号は、復帰文字 CR または改行文字 LF、あるいはその両方 CRLF です。

BizTalk エディタを使用して、連続するレコードやフィールドを作成できます。複数の種類のレコードを作成し、親レコードにそれぞれ異なる区切り記号を割り当てることができます。複数の種類のレコードを含む構造の場合は、それらの種類とレコード区切り記号 の仕様も、ドキュメント内の出現順に指定する必要があります。フィールドについては、開始位置、長さ、およびデータ型を指定します。

重要

  • 位置指定レコードは、常に区切られたレコードの子になっている必要があります。親の区切られたレコードに指定された区切り記号は、子の位置指定レコードのデータに表示されることはありません。子の位置指定フィールドのデータで、親の区切られたレコードの区切り記号をエスケープすることはできません。区切り記号とエスケープ記号の詳細については、「解析のプロパティの設定」を参照してください。

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。追加のレコード プロパティは、その属性によって [区切り記号] または [位置指定] のいずれかに設定されます。

  • 仕様を位置指定ファイル構造から区切りファイル構造に変更した場合は、[参照] タブで指定した元の開始位置と終了位置が、コンパイル後の仕様に含まれます。ただし、BizTalk Server によって仕様が解析されるときは、この情報が無視され、仕様は区切りファイルとして処理されます。

区切りフラット ファイル

区切りフラット ファイルには、区切り記号で区切られた 1 つ以上のレコードが含まれます。BizTalk エディタでは区切り記号はデータとして読み取られません。ただし、区切り記号文字をデータとして使用する場合は、データと区切り記号が区別できるようにデータの書式を設定します。たとえば、区切り記号文字を含むフィールドを引用符で囲むことによって、その区切り記号文字を区切り記号としてではなくデータとして処理する必要があることを示すことができます。

BizTalk エディタでは、個々のフィールドと、それらのフィールドに関連付ける区切り記号を選択できます。レコード区切り記号を指定することもできます。区切りフラット ファイルを使用できるようにするため、BizTalk エディタでは次のものがサポートされています。

  • 複数のレコード グループから成る構造

  • レコードの種類タグで定義された複数のレコードの種類

  • レコード区切り記号

  • フィールド データと区切り記号値とを区別する、囲み文字とエスケープ文字

  • フィールドの開始位置、長さ、および種類の値

  • フィールドのコンテンツ タグと記述

  • フラット ファイルを、BizTalk マッパーで処理できる仕様に変換する機能

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。追加のレコード プロパティは、その属性によって [区切り記号] または [位置指定] のいずれかに設定されます。


XML 名に使用できない文字

xF900 ～ xFFFE の Unicode 文字は Extensible Markup Language (XML) 名に使用できません。XML 名に無効な Unicode 文字を使用した場合、仕様ツリーでその XML 名が表示されるとき、無効な文字はエスケープされた数値エンティティに変換されます。エスケープされた数値エンティティは _xHHHH_ のようにエンコードされます。HHHH は 4 桁の 16 進数 Unicode コードです。たとえば、注文書仕様の中の Ship To という名前にはスペース文字が使用されていますが、仕様ツリーでは Ship_x0020_To と表示されます。エンコードされた Unicode 文字が含まれるノードの上にマウス ポインタを移動すると、エンコードされていない Unicode 文字を含むノード名が ToolTip に表示されます。

注

  • これは、BizTalk エディタまたは BizTalk マッパーで仕様ツリーを表示したときに発生します。


無効な文字の範囲

BizTalk Server で特定の文字または文字範囲を出力しないようにすることができます。それには、BizTalk エディタで、出力仕様として使う仕様を開きます。［無効な文字コード範囲] ダイアログ ボックスを開き、出力しないようにする文字または文字範囲を入力します。出力仕様の [無効な文字コード範囲] ダイアログ ボックスで指定した文字を BizTalk Server が処理しようとすると、処理が停止し、エラー メッセージが表示されます。

注

  • 文字範囲の出力を抑止できるのは、非 XML ドキュメントに対してだけです。

関連項目

無効文字範囲の追加

無効文字範囲の削除

無効文字範囲の編集

データのマッピング


ファイルのインポート

BizTalk エディタにインポートできるファイルは、整形式 XML インスタンス、ドキュメント型定義 (DTD)、XML-Data Reduced (XDR) スキーマの 3 種類です。ここでは、BizTalk エディタでのファイルのインポートの詳細について説明します。

注

  • ルート ノードにする要素の特定が自動的に行われない場合は、[ルート要素の選択] ダイアログ ボックスが表示されます。ルート ノードとする要素を選択し、[OK] をクリックします。

BizTalk エディタが整形式 XML インスタンス、DTD、または XDR スキーマをインポートすると、インポートしたファイルに基づく構造が作成され、レコードとフィールドのセットが表示されます。BizTalk エディタでファイルを保存すると、そのファイルは仕様になります。この仕様は適切なヘッダー情報を持ち、指定された構造に従っています。

重要

  • 次の表は、特定のデータ型を含む XDR ファイルと DTD をインポートできるかどうか、およびそのデータ型をインポートできるかどうかを示しています。列にデータ型を示します。
    "entity" および "entities" | "nmtoken" および "nmtokens" | "notation"
    XDR | ファイルをインポートできません。 | ファイルをインポートできますが、データ型が削除されます。 | ファイルをインポートできません。
    DTD | ファイルをインポートできますが、データ型が削除されます。 | ファイルをインポートできますが、データ型が削除されます。 | ファイルをインポートできます。データ型は列挙型としてインポートされます。

  • DTD の最終行がエンティティ参照 ("%xx" など) になっている場合は、BizTalk エディタにインポートできません。行終端文字がある DTD の最後に新しい行を作成すると、BizTalk エディタにインポートできるようになります。

  • ほかのファイルへの外部参照を含むファイルをインポートしようとすると、インポートが失敗します。

  • 整形式 Extensible Markup Language (XML) ファイルをインポートした後で、循環参照に関する警告が表示された場合は、警告に従って処置を行い、仕様を保存してから処理を続行することを強くお勧めします。

  • 整形式 XML ファイルまたは DTD をインポートするとき、BizTalk エディタはデータ型パラメータとフィールド長パラメータを解釈できません。

関連項目

インポート ファイルに基づいた仕様の作成


BizTalk エディタの環境

ここには次のトピックが含まれます。

  • BizTalk エディタのユーザー インターフェイス

  • BizTalk エディタのメニュー

  • BizTalk エディタのツール バーのボタン

  • BizTalk エディタのショートカット キー


BizTalk エディタのユーザー インターフェイス

BizTalk エディタのユーザー インターフェイスには 3 つのメイン ウィンドウがあります。左側のウィンドウには、仕様をグラフィカルに表現した仕様ツリーが表示されます。仕様ツリー内のトップ ノードはルート ノードであり、緑色の横線のあるドキュメント アイコン ルート ノード アイコン で表されます。仕様階層のルート ノードの下にレコードとフィールドがあります。レコードはルート ノードと同じアイコンで表されます。フィールドは青色の縦線のあるドキュメント アイコン フィールド アイコン で表されます。仕様ツリー内のノードは、左側にあるプラス アイコンまたはマイナス アイコンをクリックすることにより、展開したり、折りたたむことができます。

右側のウィンドウには、[宣言]、[参照]、[解析]、[名前空間]、[ディクショナリ]、[コード一覧] という 6 つのタブが表示されます。これらのプロパティ ページを使用して、仕様内のノードのプロパティ値、名前空間、ディクショナリのプロパティ、コード一覧を設定できます。これらのプロパティ ページの詳細については、「レコードとフィールドのプロパティの指定」を参照してください。

下のウィンドウには、[出力] と [警告] というタブが表示されます。[出力] プロパティ ページには、BizTalk エディタの "XML インスタンスの作成" 機能を使用して作成された Extensible Markup Language (XML) ドキュメント インスタンスが表示されます。仕様から XML ドキュメント インスタンスを作成する方法の詳細については、「ドキュメント インスタンスの作成」を参照してください。[警告] タブには、仕様に対するドキュメント インスタンスの検証が成功したかどうかが表示され、失敗したドキュメント検証に関する警告が表示されます。詳細については、「ドキュメント インスタンスの検証」を参照してください。

関連項目

ドキュメント インスタンスの作成

レコードとフィールドのプロパティの指定

ドキュメント インスタンスの検証


BizTalk エディタのメニュー

BizTalk エディタのメニューは、コマンドを論理的にまとめることで、作業を簡単に実行できるようになっています。たとえば、[表示] メニューのコマンドを使用して、仕様ツリー内のすべてのレコードとフィールドを表示したり、折りたたむことができます。

BizTalk エディタのメニューは次のとおりです。

  • [ファイル] : 仕様を作成する、開く、保存する、および閉じることができます。

  • [編集] : 仕様内のレコードやフィールドの切り取り、コピー、貼り付け、挿入、名前の変更、および削除を行うことができます。

  • [表示] : ユーザー インターフェイスの右側のウィンドウのビューの選択、下のウィンドウのビューの選択、BizTalk エディタ画面に表示するテキスト サイズの選択、[無効な文字コード表] ダイアログ ボックスの表示、仕様ツリーの展開と折りたたみ、[警告] タブでの次の警告の強調表示を行うことができます。

  • [ツール] : 仕様の検証、仕様に対するドキュメント インスタンスの検証、仕様からの Extensible Markup Language (XML) ドキュメント インスタンスの作成、ファイルのインポート、XML-Data Reduced (XDR) スキーマのエクスポート、BizTalk エディタのオプションの表示を行うことができます。

  • [ヘルプ] : BizTalk エディタの使用に関する各種の方法や概念を参照できます。

関連項目

BizTalk マッパーのメニュー


BizTalk エディタのツール バーのボタン

BizTalk エディタには、メニュー バーを補うためのツール バーが用意されています。ツール バーのすべてのボタンは、それが実行する作業を表すグラフィックで表示されます。左から右へ、次の順序で並んでいます。

  • [新規作成]

  • [開く]

  • [保存]

  • [WebDAV から取得]

  • [WebDAV に格納]

  • [仕様ノードの切り取り]

  • [仕様ノードのコピー]

  • [仕様ノードの貼り付け]

  • [仕様ノードの削除]

  • [新しいレコード]

  • [新しいフィールド]

  • [レコードの挿入]

  • [フィールドの挿入]

  • [折りたたみ]

  • [展開]


BizTalk エディタのショートカット キー

BizTalk エディタでは、ショートカット キーを使用して作業を行うことができます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional ヘルプでは、「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Ctrl + N | 新しい仕様を開きます。
Ctrl + O | 既存の仕様を開きます。
Ctrl + S | 仕様を保存します。
Shift + R | レコードを挿入します。
Ctrl + R | レコードに新しいレコードを追加します。
Shift + F | フィールドを挿入します。
Ctrl + F | レコードに新しいフィールドを追加します。
Del | レコードまたはフィールドを削除します。
F4 | 次の警告を強調表示します。
F5 | スキーマを検証します。
Ctrl + C | オブジェクトをコピーします。
Ctrl + X | オブジェクトを切り取ります。
Ctrl + V | オブジェクトを貼り付けます。
F6 | ウィンドウのフォーカスを時計回りに切り替えます。
Shift + F6 | ウィンドウのフォーカスを反時計回りに切り替えます。
Tab | 右側のウィンドウ内で、タブからその下のデータ シートへフォーカスを切り替えます。ボタンやフィールド間でフォーカスが移動します。
Space | チェック ボックスをオンまたはオフにします。ボタンにフォーカスがある場合、マウスのクリックと同様な動作になります。
F2 | 仕様ツリー内の強調表示されたノードに対して、編集モードをアクティブにします。右側のウィンドウのデータ シート内の強調表示された行に対して、編集モードをアクティブにします。
Shift + F2 次のフィールドに対して、編集モードをアクティブにします。
  • [宣言] プロパティ ページまたは [参照] プロパティ ページで強調表示されたカスタム コメント行のプロパティ列

  • [名前空間] プロパティ ページで強調表示されたカスタム コメント行のプレフィックス列

  • [ディクショナリ] プロパティ ページで強調表示されたカスタム ディクショナリ行のプロパティ列
Alt + ↓ アクティブになっているリスト ボックスの一覧を表示します。
Shift + + | 右側のウィンドウ内の名前空間データ シートにフォーカスを置いた状態で、新しいカスタム コメントを追加します。
Enter | ノードと値に対して行った編集を確定します。
Esc | ノードと値に対して行った編集を取り消します。
F1 | オンライン ヘルプを表示します。
Alt + F4 | プログラムを終了します。
← 左のタブを選択します。
→ 右のタブを選択します。
任意の方向キー | ダイアログ ボックスのメイン ウィンドウ内のフォルダまたはファイルを強調表示します。フォーカスは切り替わりません。この機能を使用できるのは、[新しいドキュメント仕様]、[WebDAV に格納]、[WebDAV から取得] の各ダイアログ ボックスです。[新しいドキュメント仕様] ダイアログ ボックスの詳細については、「仕様の作成と検証」を参照してください。WebDAV の詳細については、「WebDAV から既存の仕様を開く」を参照してください。
アプリケーション キーを押しながらショートカット メニューの [追加] をクリック | 仕様にカスタム プロパティを挿入します。この機能を使用できるのは、[宣言]、[参照]、[名前空間]、[ディクショナリ] の各プロパティ シートで、プロパティが強調表示されている場合です。

関連項目

BizTalk エディタのユーザー インターフェイス


レコード、フィールド、およびプロパティ

BizTalk エディタでは、仕様のレコードとフィールドは、所定の順序でツリー形式で表示されます。この構造内で、レコードとフィールドを使用して親子関係を作成できます。レコードにはほかのレコードやフィールドを含めることができますが、フィールドにはほかのフィールドやレコードを含めることができません。レコードは常に要素ですが、フィールドは要素、属性のどちらでもかまいません。仕様ツリーはレコードとフィールドをノードとして表したものです。仕様ツリーを使用すると、仕様内のすべてのレコードとフィールドの表示、作成、編集、削除を容易に行うことができます。仕様ツリー内のノードはそれぞれ、プロパティ定義のセットを持っています。プロパティ定義は、BizTalk エディタのメイン ウィンドウの [宣言]、[参照]、[解析]、[名前空間]、[ディクショナリ]、[コード一覧] という 6 つのプロパティ ページに表示されます。これらのプロパティ ページに表示されるデータは、BizTalk エディタを使用してドキュメントを元の形式から XML に変換するために必要です。これらのプロパティで、ドキュメントの構造、ドキュメントが位置指定ファイルか区切りファイルか、データの順序と長さ、およびデータの形式を定義します。

ここには次のトピックが含まれます。

  • レコードとそのプロパティ

  • フィールドとそのプロパティ

  • フィールド位置の計算

  • 文字数の制限

  • コード一覧の値と説明

  • 埋め込み文字

  • プロパティの範囲

  • 循環参照

  • 既定値の統合


レコードとそのプロパティ

作成する仕様の種類によっては、レコードの追加や削除が必要になる場合があります。仕様にレコードを追加したら、プロパティの指定が必要です。レコードを削除すると、そのレコードのプロパティ、およびそのレコードの子レコードとフィールドもすべて削除されます。

X12 または EDIFACT に基づいた仕様を作成する場合は、追加できるのはその標準にある種類のレコードだけですが、どんな種類のレコードでも削除できます。空の仕様に基づいた仕様を作成する場合は、レコードを追加する必要があります。既存の仕様に基づいて新しい仕様を作成するときなど、場合によっては、レコードの追加や削除が必要なこともあります。

レコードを追加または挿入する場合は、その場でレコードの名前を変更できます。既存のレコードの名前とそのプロパティを編集するには、対象のレコードを選択し、編集します。

既存のレコードと同じ名前のレコードを仕様に貼り付けると、貼り付けたレコードの名前の終わりに数字が付加されます。

既存のレコードの新しいインスタンスを作成する方法の詳細については、「既存のレコードの新しいインスタンスの作成」を参照してください。循環参照を作成する方法の詳細については、「循環参照の作成」を参照してください。

関連項目

既存のレコードの新しいインスタンスの作成

循環参照の作成

プロパティの範囲

レコードとフィールドのプロパティの指定


フィールドとそのプロパティ

作成する仕様の種類によっては、レコードの追加や削除が必要になる場合があります。フィールドは、電子データ交換 (EDI) の要素に対応しています。EDI ドキュメントなどの仕様にフィールドを追加したら、プロパティ値の指定が必要です。

X12 または EDIFACT に基づいた仕様を作成する場合は、追加できるのはその標準にある種類のフィールドだけですが、どんな種類のフィールドでも削除できます。空の仕様に基づいた仕様を作成する場合は、フィールドを追加する必要があります。ドキュメント型に関係なく、すべてのフィールドのプロパティを変更できます。

仕様に新しいフィールドを追加または挿入すると、既定では、[宣言] プロパティ ページにある "種類" プロパティが [属性] に設定されます。すべてのフィールドに対して、この値を手動で [要素] に変更できます。新しいフィールドを作成し、"種類" プロパティを既定で [要素] に設定する方法の詳細については、「新しいフィールドを要素として作成」を参照してください。

フィールドを追加または挿入する場合は、その場でフィールドの名前を変更できます。既存のフィールドの名前とそのプロパティを編集するには、対象のフィールドを選択し、編集します。

既存の要素フィールドと同じ名前の要素フィールドを仕様に貼り付けると、貼り付けたフィールドの名前の終わりに数字が付加されます。既存の兄弟フィールドと名前も "種類" プロパティ値も同じフィールドを仕様に貼り付けると、貼り付けたフィールドの名前の終わりに数字が付加されます。"種類" プロパティ値の詳細については、「宣言のプロパティの設定」を参照してください。既存の要素フィールドの新しいインスタンスを作成する方法の詳細については、「既存の要素フィールドの新しいインスタンスの作成」を参照してください。

関連項目

新しいフィールドを要素として作成

既存の要素フィールドの新しいインスタンスの作成

プロパティの範囲

宣言のプロパティの設定

レコードとフィールドのプロパティの指定


フィールド位置の計算

BizTalk エディタでは、位置指定レコード (ルート ノードの [参照] プロパティ ページの "標準" プロパティが [Custom] で、[解析] プロパティ ページの "構造" プロパティが [位置指定] であるレコード、または、ルート ノードの [参照] プロパティ ページの "標準" プロパティが [Custom] で、[解析] プロパティ ページの "構造" プロパティが [区切り記号] で、レコードの [解析] プロパティ ページの "構造" プロパティが [位置指定] であるレコード) 内のすべてのフィールドの開始位置と終了位置が、自動的に計算されます。まず、位置指定レコード内の各フィールドについて、[宣言] プロパティ ページの [データ型] と [最大値] の値を設定します。次に、位置指定レコードを右クリックし、ショートカット メニューの [フィールド位置の計算] をクリックします。レコードにあるフィールドの開始位置と終了位置が自動的に計算されます。詳細については、「フィールド位置の自動計算」を参照してください。

次に、この機能について詳細に説明します。

  • 位置指定レコード内のフィールドの開始位置と終了位置が指定されている場合は、フィールド位置の計算を行うと、最初のフィールドの開始位置を除くすべての位置が上書きされます。

  • フィールド位置の計算を行うと、既に設定されている場合を除き、位置指定レコード内の最初のフィールドの [開始位置] は 1 に設定されます。位置指定レコード内の最初のフィールドの [開始位置] が既に設定されている場合は、その値から計算が開始されます。

  • フィールド位置の計算では、[送信元のタグ識別子] も考慮に入れられます。たとえば、位置指定レコードのプロパティが次のように設定されているとします。[送信元のタグ識別子] が "TAG"、[送信元のタグ位置] が 10、4 つフィールドがあり、各フィールドの [最大値] がそれぞれ 2、5、8、6 で、最初のフィールドの [開始位置] が設定されていません。4 つのフィールドの開始位置と終了位置は、次のようになります。Field 1 = 1, 2、Field 2 = 3, 7、未使用 = 8, 9、TAG = 10, 12、Field 3 = 13, 20、Field 4 = 21, 26。[送信元のタグ位置] が 10 ではなく 1 の場合は、TAG の開始位置と終了位置は 1 と 3 になり、フィールド カウントは位置 4 から開始されます。

  • レコードのフィールド位置は、レコード内の最初のフィールドから最後のフィールドまで順次計算されます。"最大値" プロパティの値が設定されていないフィールドが検出された場合は、そのフィールド、および同一レコード内のすべての後続フィールドの開始位置と終了位置は計算されません。

  • 兄弟レコードが検出された場合は、その兄弟レコードのすべての後続フィールドの開始位置と終了位置は計算されません。

  • [最大値] が 1 に設定されているフィールドの開始位置と終了位置は同じです。

  • 位置指定レコードのフィールド位置の計算では、すべての子孫レコードに含まれるフィールドの位置も計算されます。レコードの前の兄弟フィールドの位置は計算されますが、レコードの後ろの兄弟フィールドの位置は計算されません。

関連項目

フィールド位置の自動計算


文字数の制限

名前やプロパティ値に使用できる文字数には制限があります。次の表は、BizTalk エディタでの文字数の制限を示しています。

名前またはプロパティ値 | 最大文字数
ノード名 (ルート ノード名、レコード名、フィールド名) | 255
名前空間プレフィックス | 64
文字列プロパティ値 | 1024
LONG プロパティ値 | 11
ULONG プロパティ値 | 10
CHAR プロパティ値 | 1
電子データ交換 (EDI) 書式プロパティ値 (EDI 固有の書式プロパティの値。たとえば、EDI ベースの仕様内のフィールドの [解析] プロパティ ページの [カスタム日付/時刻書式]) | 15
対象の名前空間 + 仕様名 | 255


コード一覧の値と説明

[コード一覧] プロパティ ページに ANSI X12 または EDIFACT のコード値とその説明が表示されます。説明で各コードの意味を定義しています。たとえば、多くの標準ドキュメント仕様の住所修飾子フィールドに表示されているコード値 ST は、出荷先アドレスの情報です。一覧内のコードは変更も削除もできません。コードをフィールドに関連付けるかどうかだけを選択できます。

ANSI X12 標準または EDIFACT 標準に基づいた仕様だけがコード一覧を持っています。ただし、ANSI X12 または EDIFACT に基づいた仕様のすべてのフィールドに対してコードが関連付けられているわけではありません。フィールドがコード一覧参照を持っている場合は、そのフィールドで利用可能なコードの完全な一覧が [コード一覧] プロパティ ページに表示されます。コードの横の [値] 列のチェック ボックスがオンになっている場合は、そのフィールドに対してコードが有効です。[説明] 列に、コードに関する説明が表示されます。

フィールドに関連付けられたコードを有効にするには、[コード一覧] プロパティ ページのコードの横の [値] 列のチェック ボックスをオンにし、コードを無効にするにはチェック ボックスをオフにします。コードは数値または英字値、または数値と英字値の組み合わせで一覧表示されます。値は特定の説明を表しています。コード値を仕様ツリー内の任意のフィールドに関連付けることができます。たとえば、注文書 ANSI X12 850 の BEG02 フィールドでコード OS を選択すると、このフィールドに特定のオーダー情報が含まれることを示す属性が追加されます。

BizTalk Server で提供される EDI ベースの仕様テンプレートのコード一覧の値と説明は、Microsoft Access データベース ファイルにあります。ファイルの場所は、\Program Files\Microsoft BizTalk Server\XML Tools\Databases\CodeLists\CodeListsX12a.mdb です。このデータベースに、新しい仕様テンプレートで新しくテーブルを作成する場合、そのテーブル名は <標準>_<バージョン> の書式をとります。たとえば、仕様テンプレートが D99A EDIFACT である場合、対応するテーブル名は EDIFACT_D99A になります。

重要

  • CodeListsX12a.mdb データベースで新しいテーブルを作成する場合は、無効な Extensible Markup Language (XML) 文字 (F900 から FFFE の Unicode 文字) をテーブルの値列に使用しないでください。保存した仕様が、コード一覧のある値が選択されたフィールドを含んでいて、そのコード一覧の値が、無効な XML 文字を持つテーブルの値に関連付けられている場合、保存した仕様は開くことができません。

コードをフィールドに関連付ける場合は、[宣言] プロパティ ページの "種類" プロパティの値を [属性] に設定する必要があります。

注

  • コード一覧は ANSI X12 または EDIFACT に基づく仕様に対してのみ利用可能です。このため、ANSI X12 または EDIFACT に基づいた仕様の構造を [カスタム] に変更し、その後、再び ANSI X12 または EDIFACT に基づいた構造に戻した場合は、[コード一覧] プロパティ ページから特定のフィールドのコード一覧の表示が消失することがあります。このような場合は、仕様を保存して、再び開いてください。そのフィールドのコード一覧が [コード一覧] プロパティ ページに再び表示されます。

関連項目

レコードとフィールドのプロパティの指定


埋め込み文字

BizTalk エディタでは、必要な出力を得られるよう区切りドキュメントの埋め込み文字を管理できます。BizTalk Server で処理する区切りドキュメントは、マッピングの前に Extensible Markup Language (XML) に変換する必要があるので、ドキュメント仕様の中で、区切りドキュメント インスタンスの埋め込み文字の処理方法を指示する必要があります。たとえば、区切りドキュメント インスタンス内に次のようなフィールドがあるとします。

Green*****

フィールドのデータ コンテンツは Green、フィールドは左揃え、データ コンテンツの右側に埋め込み文字が 5 つあり、埋め込み文字はアスタリスクです。

ドキュメント インスタンス内のフィールドに対応する仕様内のフィールドに埋め込み文字を定義しなかった場合は、5 つのアスタリスクはフィールドのデータ コンテンツの一部であると解釈されます。このフィールドの埋め込み文字が正しく処理されるようにするには、[解析] プロパティ ページでこのフィールドのプロパティを次の表に示すとおりに設定します。

プロパティ | 値
位置揃え | [左揃え]
埋め込み文字 | *
埋め込み文字を含めた最小値 | 出力ドキュメント インスタンスのこのフィールドの長さを特定の長さ以上にする場合は、このプロパティ値を設定してください。フィールドに埋め込み文字が挿入され、出力ドキュメント インスタンスのフィールドの最小値が変更されます。

"埋め込み文字" プロパティを使用して、BizTalk Server に送信されたドキュメント インスタンスからフィールド内の埋め込み文字を削除できます。"埋め込み文字を含めた最小値" プロパティを設定すると、必要に応じて、出力ドキュメント インスタンス内のフィールドに埋め込み文字が挿入されます。"位置揃え" プロパティを使用して、フィールド データ コンテンツのどちら側で、埋め込み文字の削除 (入力ドキュメント インスタンスから) または挿入 (出力ドキュメント インスタンスへ) を行うかを指定できます。左揃えに設定したフィールドでは、末尾の埋め込み文字が追加または削除され、右揃えに設定したフィールドでは、先頭の埋め込み文字が追加または削除されます。フィールドの "埋め込み文字" プロパティが設定されていない場合は、そのフィールドに対して埋め込み文字の追加や削除は行われません。


プロパティの範囲

仕様内の 1 つのレコードに 2 つ以上のインスタンスがある場合、あるプロパティの値は、これらのどのインスタンスでも等しくなっている必要があります。つまり、これらのプロパティの範囲はグローバルです。フィールド プロパティも範囲をグローバルにできますが、グローバルにできるのは、そのフィールドの "種類" プロパティの値が [要素] に設定されている場合に限ります。

たとえば、[宣言] プロパティ ページと [解析] プロパティ ページに表示されるすべてのプロパティは、1 つのレコードまたはフィールドの複数のインスタンスで同じです。1 つのレコードまたはフィールドのインスタンスのうちの 1 つについて [宣言] プロパティ ページまたは [解析] プロパティ ページのプロパティを変更すると、そのレコードまたはフィールドのほかのすべてのインスタンスについてもプロパティが自動的に変更されます。ただし、[参照] プロパティ ページと [ディクショナリ] プロパティ ページに表示されるプロパティの範囲はグローバルではないので、これらのプロパティの値は、レコードまたはフィールドのインスタンスごとに個別に設定できます。コード一覧はフィールドだけに適用され、範囲はグローバルではありません。

注

  • フィールドの範囲は、"種類" プロパティの値が [要素] に設定されている場合に限り、グローバルです。

  • フィールドの "種類" プロパティの値が [属性] に設定されている場合は、そのフィールドの範囲は常にローカルです。

  • BizTalk エディタでは、[宣言] プロパティ ページの "種類" プロパティの値が [要素] に設定されている場合に限り、範囲がグローバルです。"種類" プロパティの値が [属性] に設定されたグローバル範囲の宣言が含まれるスキーマを BizTalk エディタにインポートし、仕様として保存した場合は、その宣言は、"種類" プロパティが [要素] に設定された宣言内では自動的に範囲がローカルになります。


循環参照

仕様内でレコードをそのレコードの子孫として作成すると、循環参照が発生します。循環参照が発生するのは、[参照] プロパティ ページの "標準" プロパティの値が [XML] に設定されている場合だけです。循環参照は、カーブした矢印が付いたレコードのアイコン 循環参照アイコン で表示されます。

次の図は、BizTalk エディタでの循環参照の表示を示しています。

図をクリックすると、拡大または縮小します。

[宣言] プロパティ ページに "循環回数" プロパティが表示されます。このプロパティは循環ノードだけに適用されます。既定値は 1、最大値は 7 です。循環回数は、基本レコードより下位のレベルで循環できる回数を示します。たとえば、前の図の Record1 には、循環回数 3 の 3 つと基本レコードの 1 つの合計 4 つのレベルがあります。BizTalk マッパーでこの仕様を開くと、Record1 の 4 つのレベルがすべて表示されます。各 Record1 について Record2 と Field1 も表示されます。どの循環レベルのノードにでもリンクを接続できます。

循環ノードから派生したフィールドにはディクショナリ プロパティ値を設定できません。たとえば、前の図の Root/Record1/Field1 にはディクショナリ プロパティ値を設定できますが、Root/Record1/Record1 より下位のレベルで循環する 3 つの Field1 参照には、ディクショナリ プロパティ値を設定できません。

循環参照には次の制限が適用されます。

  • 循環パス上のノード (循環参照内の最初のレコードと最後のレコードの間にあるノード) は、その仕様内のほかのどの場所にも出現できません。

  • 循環パス上の要素は、ドラッグ アンド ドロップ操作やカット アンド ペースト操作のソースとターゲットのどちらとしても使用できません。

  • 循環は重複できません。

  • 仕様のルート ノードを循環参照の基本レコードにすることはできません。

重要

  • 循環参照ノードの [参照] プロパティ ページの "最小発生数" プロパティは、0 に設定する必要があります。1 に設定すると、無限ループが発生します。

注

  • 循環参照が含まれるスキーマをインポートした場合は、循環参照が有効かどうかの確認は自動的に実行されません。

関連項目

循環参照の作成

プロパティの範囲


既定値の統合

送信元仕様 に "種類" プロパティの値が [属性] に設定されたフィールドが含まれ、その送信元仕様に基づいた受信ドキュメント インスタンスにそのフィールドが含まれない場合は、仕様でそのフィールドに既定値を適用する必要があります。フィールドの既定値を設定するには、仕様ツリー内でそのフィールドをシングルクリックし、[宣言] プロパティ ページの "既定値" プロパティの "値" フィールドに数値を入力します。"種類" プロパティの値が [属性] に設定されている場合だけ、"既定値" プロパティが表示されます。受信ドキュメント インスタンスにそのフィールドが含まれない場合は、そのフィールドの既定値が使用されます。受信ドキュメント インスタンスにそのフィールドが含まれる場合は、既定値が無視されます。


名前空間のサポート

ここには次のトピックが含まれます。

  • 名前空間宣言

  • インポートしたファイルの名前空間の保存


名前空間宣言

仕様内で宣言された名前空間は、BizTalk エディタの [名前空間] プロパティ ページに表示されます。次の表は、BizTalk エディタで仕様を開いたときに、既定で [名前空間] プロパティ ページに表示されるプレフィックスと名前空間を示しています。これらのプレフィックスと名前空間は編集できません。

プレフィックス | 名前空間
(既定) | urn:schemas-microsoft-com:xml-data
b | urn:schemas-microsoft-com:BizTalkServer
d | urn:schemas-microsoft-com:datatypes

注

  • BizTalk Server では次の名前空間はサポートされていません。

    SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"

仕様内でカスタム名前空間を宣言するには、[名前空間] プロパティ ページの [プレフィックス] 列に名前空間プレフィックスを入力し、[統一リソース名 (URN)] 列に名前空間を入力します。[統一リソース名 (URN)] に入力した名前空間は BizTalk エディタによって検証されません。

任意のレコードやフィールドに対してカスタム コメントを追加することもできます。カスタム コメントは、プレフィックスと名前の組および関連値で構成されます。次はプレフィックスと名前の組の構文の例です。

prefix:name

[宣言] プロパティ ページまたは [参照] プロパティ ページの [プロパティ] 列にプレフィックスと名前の組を入力し、[値] 列に値を入力します。[宣言] プロパティ ページに入力したプロパティの値の範囲はグローバルであり、[参照] プロパティ ページに入力したプロパティの値の範囲はローカルです。グローバル範囲とローカル範囲の詳細については、「プロパティの範囲」を参照してください。カスタム コメントの追加の詳細については、「カスタム コメントの追加」を参照してください。

関連項目

カスタム コメントの追加

名前空間の宣言

インポートしたファイルの名前空間の保存

プロパティの範囲


インポートしたファイルの名前空間の保存

BizTalk エディタにインポートできるファイルは、XML-Data Reduced (XDR) スキーマ、整形式 XML インスタンス、ドキュメント型定義 (DTD) の 3 種類です。BizTalk エディタでは、既存の名前空間およびプレフィックスと名前の組の処理方法は、ドキュメント型によって異なります。

XDR スキーマのインポート

XDR スキーマをインポートした場合は、既存の名前空間は次のように処理されます。

  • 名前空間宣言がカスタム名前空間として保存され、[名前空間] プロパティ ページの既定の名前空間の下に表示されます。

  • カスタム名前空間プレフィックス ("名前"プロパティと "種類" プロパティに関連付けられている名前空間プレフィックスを除く) は、関連付けられている名前空間が宣言されている場合だけ保存されます。

注

  • 名前空間プレフィックスが "名前"プロパティや "種類" プロパティに関連付けられている XDR スキーマはインポートできません。

整形式 XML インスタンスのインポート

整形式 XML ドキュメント インスタンスをインポートすると、ドキュメントから名前空間宣言が削除され、プレフィックスと名前を区切る区切り記号がコロン (:) からアンダースコア (_) に変わり、元の名前空間プレフィックスの意図が保持されます。たとえば、次のようになります。

prefix_name

重要

  • 名前空間プレフィックスと名前の組を持つ整形式 XML ドキュメント インスタンスをインポートして、インポートしたインスタンスを仕様として保存した場合、新しい仕様に対する元のドキュメント インスタンスの検証を行うと、そのインスタンスの検証は失敗します。新しい仕様で、プレフィックスと名前の組が含まれるノードを削除し、そのノードの親レコードに対して、[宣言] プロパティ ページの "モデル" プロパティで [オープン] をクリックします。仕様を保存します。この仕様に対するドキュメント インスタンスの検証を行います。

注

  • 関連付けられた名前空間がドキュメント内で宣言されていない場合は、名前空間プレフィックスが含まれるドキュメントをインポートできません。

DTD のインポート

プレフィックスと名前の組が含まれる DTD をインポートすると、区切り記号がコロン (:) からアンダースコア (_) に変わります。これは、プレフィックス表記そのものがサポートされなくなっても、構造全体の中の配置という点から元のプレフィックスの意図を保持するための処理です。たとえば、次のようになります。

prefix_name

関連項目

名前空間宣言


SQL コメントの追加

仕様内の任意のノードに SQL コメントを指定できます。[宣言] プロパティ ページで SQL コメントを指定すると、範囲がグローバルなコメントが作成されます。コメントは仕様内の "種類" プロパティの値が [要素] または [属性] に設定された宣言に保存されます。[参照] プロパティ ページで SQL コメントを指定すると、範囲がローカルなコメントが作成されます。コメントは仕様内の [要素] の参照または [属性] の参照に保存されます。

仕様内のノードの、[宣言] プロパティ ページまたは [参照] プロパティ ページのいずれかの [プロパティ] 列の空のフィールドをダブルクリックすると SQL コメント一覧が表示され、この一覧で SQL コメントを選択できます。[値] 列の対応するフィールドに SQL コメントの値を入力します。"sql:relationship" と "sql:xpath-query" を除き、すべての SQL コメントの値が普通の文字列データです。SQL コメントとそのほかのカスタム コメントの追加の詳細については、「カスタム コメントの追加」を参照してください。

次の一覧は、BizTalk エディタで使用できる SQL コメントを示しています。

  • sql:datatype

  • sql:field

  • sql:id

  • sql:id-prefix

  • sql:is-constant

  • sql:key-fields

  • sql:limit-field

  • sql:limit-value

  • sql:map-field

  • sql:is-mapping-schema

  • sql:overflow-field

  • sql:relation

  • sql:relationship

  • sql:target-namespace

  • sql:url-encode

  • sql:use-cdata

  • sql:xpath-query

値 "sql:relationship" は 1 つ以上の名前と値の組であり、名前と値の組の中の名前は、key、key-relation、foreign-key、foreign-relation の 4 つの名前のうちのいずれかである必要があります。値 "sql:xpath-query" は 2 つの部分から成ります。最初の部分は、属性を構成する 1 つ以上の名前と値の組、2 番目の部分は、"sql:xpath-query" のコンテンツを "content=..." で表したものです。これらの 2 つの部分はポンド記号 (#) で区切られています。

次の表は、SQL コメント "sql:relationship" と "sql:xpath-query" の有効な例を示しています。

SQL コメント | 例
sql:relationship | key="CustomerID"
sql:relationship | key-relation="Cust"
sql:relationship | foreign-key="CustomerID"
sql:relationship | foreign-relation="Orders"
sql:xpath-query | mapping-schema="Schema.xml" #content=Employees

注

  • BizTalk エディタでは、現在のコンテキストで適切な SQL コメントだけではなく、それ以外の SQL コメントも選択できます。たとえば、"sql:relationship" と "xpath-query" の使用は [参照] プロパティ ページに制限されていますが、[宣言] プロパティ ページにもこれらの SQL コメントは表示されます。

  • SQL コメントを指定すると、[名前空間] プロパティ ページでプレフィックス "sql" が付いた名前空間とそれに対応する URN 値が自動的に宣言されます。

  • [参照] プロパティ ページで SQL コメントが指定されているノードを仕様内のほかの場所にコピーしたり切り取って貼り付けると、コピー先の新しいノードでは SQL コメントが消失します。

関連項目

カスタム コメントの追加

名前空間宣言

プロパティの範囲


参考資料

ここでは、次の内容について説明します。

  • データ型とデータ型値の概要

  • 付属 EDI ベースのドキュメントの概要一覧


データ型とデータ型値の概要

次の一覧は、[宣言] プロパティ ページの "データ型" プロパティの値を指定するときに参考になる説明と例を示しています。[データ型] ボックスの一覧からデータ型を選択し、[データ型値] ボックスで値を指定する必要があります。

データ型

Character [文字]

1 文字分の長さの文字列を含みます。

String [文字列]

任意のテキストを含みます。

Number [数値]

複数の桁を含み、先頭符号、小数部、および指数を含むことができます。標準英語句読法に従います。たとえば、15、3.14、-123E+10 になります。

Integer (int) [整数]

数字を含み、符号 (省略可) を含むことができます。小数や指数を含むことはできません。たとえば、1、58502、-13 になります。

Float [浮動小数]

数字を含みます。桁数の制限はありません。先頭符号、小数部、指数を含むことができます。

Fixed Point (14.4) [固定小数]

Number [数値] と同じですが、小数点の左側の桁数は 14 桁以下、小数点の右側の桁数は 4 桁以下である必要があります。たとえば、12.0044 になります。このデータ型は通貨値に使用できます。

Boolean [ブール値 (Yes/No)]

TRUE (1) または FALSE (0) のどちらかに評価される式を含みます。

Date [日付]

時間情報のない ISO 8601 形式のサブセットのデータを含みます。たとえば、1988-04-07 になります。

Date Time [日時]

時間情報 (省略可) がありタイム ゾーン情報のない ISO 8601 形式のサブセットのデータを含みます。秒数の精度はナノ秒までです。たとえば、1988-04-07T18:39:09 になります。

Date Time.tz [日時 (タイム ゾーン指定可)]

時間情報 (省略可) とタイム ゾーン情報 (省略可) のある ISO 8601 形式のサブセットのデータを含みます。秒数の精度はナノ秒までです。たとえば、1988-04-07T18:39:09-08:00 になります。

Time [時刻]

日付情報とタイム ゾーン情報のない ISO 8601 形式のサブセットのデータを含みます。たとえば、08:15:27 になります。

Time.tz [時刻 (タイム ゾーン指定可)]

日付情報がなくタイム ゾーン情報 (省略可) のある ISO 8601 形式のサブセットのデータを含みます。たとえば、08:15:27-05:00 になります。

Byte (i1) [バイト]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、127、-128 になります。

Word (i2) [ワード]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、703、-32768 になります。

Integer (i4) [整数]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、703、-32768、148343、-1000000000 になります。

Double Integer (i8) [倍精度整数]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、703、-32768、148343、-1000000000 になります。

Unsigned Byte (ui1) [符号なしバイト]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、255 になります。

Unsigned Word (ui2) [符号なしワード]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、255、65535 になります。

Unsigned Integer (ui4) [符号なし整数]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、703、3000000000 になります。

Unsigned Double Integer (ui8) [倍精度符号なし整数]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、703、3000000000 になります。

Real (r4) [実数]

1.17549435E-38F ～ 3.40282347E+38F の範囲の数字を含みます。たとえば、3.14285718E+2 になります。

Double Real (r8) [倍精度実数]

2.2250738585072014E308 ～ 1.7976931348623157E+308 の範囲の数字を含みます。たとえば、314159265358979E+1 になります。

Universal Unique Identifier (uuid) [ユニバーサル固有識別子]

埋め込みハイフン (省略可で無視できる) 付きのオクテットを表す 16 進数を含みます。たとえば、333C7BC4-460F-11D0-BC04-0080C7055A83 になります。

Uniform Resource Identifier (uri) [統一リソース識別子]

統一リソース名 (URI) を含みます。

Binary (base64) [バイナリ]

バイナリ テキストをバイナリ エンコードした文字を含みます。たとえば、Graphic Interchange Format (GIF) 画像をテキスト表現に変換したものです。

Binary (hex) [バイナリ]

オクテットを表すバイナリ 16 進数を含みます。たとえば、0x0ffaa になります。

ID [識別子]

フィールドを ID として指定します。

IDREF [識別子参照属性値]

ID 値を含むフィールドがフィールドに参照されることを示します。

IDREFS [複数識別子参照属性値]

ID の一覧がフィールドにあることを示します。各 ID はスペースで区切られています。

Enumeration [列挙]

一連の値に順序を割り当てます。たとえば、Monday、Tuesday、Wednesday を 1 2 3 のように列挙できます。

注

  • Fixed Point (14.4) [固定小数] は通貨値に使用できます。

関連項目

宣言のプロパティの設定


付属 EDI ベースのドキュメントの概要一覧

BizTalk エディタは EDI ベースのドキュメントをサポートしています。次の表は、標準に基づいた新しい仕様を作成するとき使用できる EDI ベースのドキュメントの標準、バージョン、およびドキュメント標準を一覧表示しています。詳細については、「標準に基づいた仕様の作成」を参照してください。

標準 バージョン ドキュメント標準
ANSI X12
  • 2040

  • 3010

  • 3060

  • 4010
  • 810

  • 832

  • 846

  • 850

  • 852 (2040 以外のすべてのバージョンで利用可能)

  • 855

  • 856

  • 861

  • 864

  • 867

  • 940 (3060 と 4010 バージョンのみで利用可能)

  • 944 (3060 と 4010 バージョンのみで利用可能)

  • 997
EDIFACT
  • D93A

  • D95A

  • D95B

  • D97B

  • D98A

  • D98B
  • APERAK (D93A 以外のすべてのバージョンで利用可能)

  • CONTRL (D98A と D98B バージョンのみで利用可能)

  • DESADV

  • INVOIC

  • INVRPT

  • ORDERS

  • ORDRSP

  • PARTIN

  • PAYEXT

  • PRICAT

  • PRODAT (D97B、D98A、D98B バージョンのみで利用可能)

  • RECADV (D97B、D98A、D98B バージョンのみで利用可能)

  • SLSRPT
XML
  • なし
  • CommonAdvancedShipNotice

  • CommonInventoryAdvice

  • CommonInvoice

  • CommonPartnerProfile

  • CommonPO

  • CommonPOAcknowledgment

  • CommonPriceCatalog

  • CommonShippingAdvice

  • CommonShippingOrder

  • CanonicalReceipt

  • Simple SOAP Envelope

  • BTF1 Envelope

関連項目

標準に基づいた仕様の作成


データのマッピング

BizTalk マッパーは変換設計ツールです。これを使用して、書式の異なる 2 つの仕様間でレコードやフィールドを対応付けることができます。BizTalk マッパーはリンクと Functoid を使用して、この変換を行います。Functoid は単純な計算から複雑なスクリプト機能まで、さまざまな操作を行います。BizTalk マッパーを使用すると、送信元仕様のデータ要素と送信先仕様のデータ要素との間で行う構造変換の関係をグラフィカルに表現することができます。この相互参照とデータ処理機能によって、マップが作成されます。このマップが提供する一連の指示により、書式の異なる 2 つの仕様間の関係が定義されます。仕様の書式は BizTalk エディタを使用して定義します。

マップは、送信元仕様と送信先仕様との間のデータ変換を表現するものです。Microsoft BizTalk Server 2000 および Microsoft XML Parser Version 3.0 の Extensible Stylesheet Language (XSL) コンポーネントでは、マップが提供する実行時データ変換情報を使用しています。マップを作成すると、変換情報は BizTalk マッパーの [出力] タブに表示されます。

BizTalk マッパーを使用すると、Extensible Markup Language (XML) データ形式内の仕様を自由に変換できます。BizTalk マッパーで開くことができるのは、BizTalk エディタで保存された仕様だけです。一般的な XML ファイルや非 XML ファイルは開くことができません。一般的な XML ファイル間の変換作業を行う場合は、それらのファイルを BizTalk エディタにインポートし、仕様として保存します。

BizTalk マッパーでは、単純な親子ツリー間のマッピングから、レコードと階層のループなどの細かく複雑なマッピングまで、さまざまなシナリオをサポートしています。マッピング プロセスが完了すると、シリアライザ コンポーネントは仕様を使って、取引先や内部アプリケーションから認識できるファイル形式を作成します。また、BizTalk マッパーにはスタイルシート コンパイラ コンポーネントが用意されているので、それを使用してマップを視覚的に表現したり、XSL スタイル シートを作成することができます。

次の図は、送信元仕様から送信先仕様へのマッピング プロセスを示しています。送信元ファイルはEDI ドキュメントで、送信先ファイルはフラット ファイル ドキュメントです。この例では、電子データ交換 (EDI) ドキュメント構造は中間 XML 形式に変換され、その構造は XML-Data Reduced (XDR) 仕様で表現されます。データの最終形式はフラット ファイルです。データ ドリブン パーサーは XDR 仕様を使って、送信元 EDI 仕様の XML バージョンを作成します。次に XSL エンジンが、送信元 XMLを送信先ファイル形式の XMLに変換します。その後、送信先仕様はシリアライズされ、送信先ファイルのネイティブ形式 (この例ではフラット ファイル) になります。

EDI ドキュメントの Flat File ドキュメントへの変換
XDR
仕様
XDR
仕様
XSLT マップ
XSL エンジン
EDI から Flat File へ
シリアライザ
データ パーサー
XML ドキュメント
EDI ドキュメント
XML ドキュメント
Flat-file ドキュメント
  • 特定の作業のヘルプについては、「操作方法」を参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • このほかの資料については、「参考資料」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk エディタと BizTalk マッパーのトラブルシューティング」を参照してください。

関連項目

BizTalk マッパーのユーザー インターフェイス


操作方法

ここでは、ある仕様から別の仕様にデータをマップする方法を作業ごとに説明します。「概念」を参照し、リンクと Functoid、およびその他のマッピング プロパティと機能について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk マッパーのオプションの変更

  • 新しいマップの作成

  • マップを開く

  • マップを保存する、格納する、閉じる

  • 仕様の置換

  • Functoid の管理

  • リンクの管理

  • コンパイル済みマップの作成および管理

  • マップのテスト

  • 表示の管理

  • ユーザー インターフェイスのカスタマイズ


BizTalk マッパーのオプションの変更

[BizTalk マッパーのオプション] ダイアログ ボックスでは、全般にわたるオプションの設定や、マッピング グリッドの色を選択することができます。

  • [BizTalk マッパーのオプション] ダイアログ ボックスを表示するには、[ツール] メニューの [オプション] をクリックします。既定では [全般] タブが表示されます。

[BizTalk マッパーのオプション] ダイアログ ボックスの使用方法については、次の手順を参照してください。

  • BizTalk マッパーのオプション : [全般] タブ

  • BizTalk マッパーのオプション : [色] タブ


BizTalk マッパーのオプション : [全般] タブ

[BizTalk マッパーのオプション] ダイアログ ボックスを開く方法については、「BizTalk マッパーのオプションの変更」を参照してください。

[全般] タブには、BizTalk マッパーの動作をカスタマイズするための 6 つのチェック ボックスがあります。

  • [単純なリンク エラーを警告] (既定でオンになっています) : データ型が一致しないノード間にリンクを作成しようとすると、警告が表示されます。

  • [コンパイラ リンクを表示] (既定でオンになっています) : コンパイルした後、マップにコンパイラ リンクが表示されます。

  • [ユーザーの操作後にコンパイラ リンクを削除] (既定ではオフになっています) : BizTalk マッパーで何らかの操作を行うと、コンパイラ リンクが削除されます。

  • [レコード コンテンツのリンクを許可] (既定ではオフになっています) : レコードから Functoid までのコンテンツ リンクを作成できます。

    注

    • Functoid の中には、入力または出力、あるいはその両方でレコード コンテンツを使用していないものがあり、それらの入出力に対しては [レコード コンテンツのリンクを許可] チェック ボックスの効果はありません。そのような入出力を行うものとしては、論理演算を行う Functoid (出力)、レコード カウント Functoid (入力)、繰り返し Functoid (入力)、およびループ Functoid (入出力) があります。
  • [送信先ツリー ノードへ複数の入力を許可] (既定ではオフになっています) : 送信先仕様ツリーのノードに、2 つ以上のリンクを作成することができます。

  • [マップのテスト前に保存するかどうかを確認] (既定でオンになっています) : [ツール] メニューの [マップのテスト] をクリックすると、変更内容をマップ ファイルに保存するかどうかを尋ねるダイアログ ボックスが表示されます。

関連項目

BizTalk マッパーのオプション : [色] タブ


BizTalk マッパーのオプション : [色] タブ

[BizTalk マッパーのオプション] ダイアログ ボックスを開く方法については、「BizTalk マッパーのオプションの変更」を参照してください。

[色] タブには、マッピング グリッドの色をカスタマイズするためのオプションがあります。これらのオプションについては、次のトピックを参照してください。

  • マッピング グリッドの色の変更

  • リンクの色の変更

  • 選択したオブジェクトの色の変更

  • コンパイラの警告の色の変更

  • 既定の色への復元

関連項目

BizTalk マッパーのオプション : [全般] タブ


新しいマップの作成

  1. [ファイル] メニューの [新規作成] をクリックします。

    [送信元仕様の種類の選択] ダイアログ ボックスが表示されます。

  2. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 3. に進みます。

    • [テンプレート]: 手順 4. に進みます。

    • [WebDAV ファイル]: 手順 3. に進みます。
  3. 送信元仕様が格納されているフォルダを参照し、手順 5. に進みます。

  4. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または ANSI X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 5. に進みます。

  5. 送信元仕様を選択し、[開く] をクリックします。

    [送信先仕様の種類の選択] ダイアログ ボックスが表示されます。

  6. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 7. に進みます。

    • [テンプレート]: 手順 8. に進みます。

    • [WebDAV ファイル]: 手順 7. に進みます。
  7. 送信先仕様が格納されているフォルダを参照し、手順 9. に進みます。

  8. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または ANSI X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 9. に進みます。

  9. 送信先仕様を選択し、[開く] をクリックします。

注

  • マップを作成するには、送信元仕様と送信先仕様の両方を指定する必要があります。

関連項目

送信先仕様の置換

送信元仕様の置換


マップを開く

ここには次のトピックが含まれます。

  • ローカル ハード ドライブにあるマップを開く

  • WebDAV からのマップの取得


ローカル ハード ドライブにあるマップを開く

  1. [ファイル] メニューの [開く] をクリックします。

    [マップ送信元を開く] ダイアログ ボックスが表示されます。

  2. マップが格納されているフォルダを参照します。

  3. 一覧にあるマップを選択し、[開く] をクリックします。

関連項目

WebDAV からのマップの取得


WebDAV からのマップの取得

  1. [ファイル] メニューの [WebDAV から取得] をクリックします。

    [WebDAV から取得] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスの一覧にあるサーバー名をクリックします。

  3. 取得するマップが格納されているフォルダを参照し、マップを選択して、[開く] をクリックします。

注

  • リモート WebDAV サーバーに初めて接続する場合は、時間がかかることがあります。

  • WebDAV からマップを取得するには、サーバー上のファイルを取得するためのアクセス許可が必要です。

関連項目

ローカル ハード ドライブにあるマップを開く

BizTalk エディタと BizTalk マッパーのトラブルシューティング


マップを保存する、格納する、閉じる

ここには次のトピックが含まれます。

  • 新しいマップの保存

  • 既存のマップの保存

  • コンパイル済みのマップの保存

  • マップの格納

  • マップを閉じる


新しいマップの保存

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [マップ送信元に名前を付けて保存] ダイアログ ボックスが表示されます。

  2. [ファイル名] ボックスにマップの名前を入力します。

  3. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字セットが多い仕様では [UTF-8]、2 バイト文字セットが多い仕様では [Unicode] をお勧めしますが、どちらを使うことも可能です。

注

  • BizTalk マッパーでマップを保存すると、マップは自動的にコンパイルされます。コンパイル済みマップは [出力] タブで見ることができます。

  • BizTalk マッパーでマップを保存すると、マップはハード ドライブに保存されます。マップを WebDAV に格納するには、ファイルをサーバーに格納するためのアクセス許可が必要です。

関連項目

マップの格納


既存のマップの保存

  • [ファイル] メニューの [保存] をクリックします。

注

  • BizTalk マッパーでマップを保存すると、マップは自動的にコンパイルされます。コンパイル済みマップは [出力] タブで見ることができます。

  • BizTalk マッパーでマップを保存すると、マップはハード ドライブに保存されます。マップを WebDAV に格納するには、ファイルをサーバーに格納するためのアクセス許可が必要です。

関連項目

マップの格納


コンパイル済みマップの保存

  1. [ファイル] メニューの [コンパイル済みマップに名前を付けて保存] をクリックします。

    [コンパイル済みマップに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

関連項目

マップの格納


マップの格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスの一覧にあるサーバー名をクリックします。

  3. マップを格納するフォルダを参照し、[ファイル名] ボックスにファイルの名前を入力します。

  4. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字セットが多い仕様では [UTF-8]、2 バイト文字セットが多い仕様では [Unicode] をお勧めしますが、どちらを使うことも可能です。

重要

  • ロケールを正しく設定していない場合、2 バイト文字コード セット (DBCS) を使用したファイル名ではファイルを格納できません。詳細については、「???.xml が WebDAV ダイアログ ボックスに表示される」を参照してください。

注

  • リモート WebDAV サーバーに初めて接続する場合は、時間がかかることがあります。

  • WebDAV にマップを格納するには、ファイルをサーバーに格納するためのアクセス許可が必要です。

関連項目

BizTalk エディタと BizTalk マッパーのトラブルシューティング


マップを閉じる

  • [ファイル] メニューの [閉じる] をクリックします。


仕様の置換

ここには次のトピックが含まれます。

  • 送信元仕様の置換

  • 送信先仕様の置換


送信元仕様の置換

  1. [編集] メニューの [送信元仕様の置換] をクリックします。

    マップを保存していない場合は、マップ送信元の変更内容を保存するように求めるメッセージが表示されます。

    [送信元仕様の種類の選択] ダイアログ ボックスが表示されます。

  2. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 3. に進みます。

    • [テンプレート]: 手順 4. に進みます。

    • [WebDAV ファイル]: 手順 3. に進みます。
  3. 送信元仕様が格納されているフォルダを参照し、手順 5. に進みます。

  4. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または ANSI X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 5. に進みます。

  5. 送信元仕様を選択し、[OK] または [開く] をクリックします。

注

  • 新しい仕様に送信元テスト値と関連付けられたフィールドがある場合、送信元仕様を置換すると送信元テスト値が保存されます。送信元テスト値の詳細については、「リンクのテスト」を参照してください。

  • 送信元仕様を置換すると破損する可能性のあるリンクについては、[警告] タブに警告の一覧が表示されます。

  • 送信元仕様の置換は、送信元仕様ツリーのレコードまたはフィールドを右クリックし、[仕様の置換] をクリックしても実行できます。

関連項目

送信先仕様の置換

リンクのテスト


送信先仕様の置換

  1. [編集] メニューの [送信先仕様の置換] をクリックします。

    マップを保存していない場合は、マップ送信元の変更内容を保存するように求めるメッセージが表示されます。

    [送信先仕様の種類の選択] ダイアログ ボックスが表示されます。

  2. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 3. に進みます。

    • [テンプレート]: 手順 4. に進みます。

    • [WebDAV ファイル]: 手順 3. に進みます。
  3. 送信先仕様が格納されているフォルダを参照し、手順 5. に進みます。

  4. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または ANSI X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 5. に進みます。

  5. 送信先仕様を選択し、[OK] または [開く] をクリックします。

注

  • 新しい仕様に送信先定数値と関連付けられたフィールドがある場合、送信先仕様を置換すると送信先定数値が保存されます。送信先定数値の詳細については、「定数値の追加」を参照してください。

  • 送信先仕様を置換すると破損する可能性のあるリンクについては、[警告] タブに警告の一覧が表示されます。

  • 送信先仕様の置換は、送信先仕様ツリーのレコードまたはフィールドを右クリックし、[仕様の置換] をクリックしても実行できます。

関連項目

定数値の追加

送信元仕様の置換


Functoid の管理

ここには次のトピックが含まれます。

  • Functoid パレットでの操作

  • Functoid プロパティの編集


Functoid パレットでの操作

Functoid パレットには、BizTalk マッパーで使用可能なすべての Functoid が含まれています。Functoid パレットで、使用する Functoid をクリックしてマッピング グリッドにドラッグしてください。タブにはさまざまな Functoid が用意されています。表示範囲外にあるタブを表示するには、左矢印ボタンまたは右矢印ボタンをクリックしてください。

ここには次のトピックが含まれます。

  • 文字列処理を行う Functoid の追加

  • 数値演算を行う Functoid の追加

  • 論理演算を行う Functoid の追加

  • 日時処理を行う Functoid の追加

  • 変換を行う Functoid の追加

  • 関数演算を行う Functoid の追加

  • 累積演算を行う Functoid の追加

  • データベース操作を行う Functoid の追加

  • スクリプト Functoid の追加

  • レコード カウント Functoid の追加

  • インデックス Functoid の追加

  • 繰り返し Functoid の追加

  • 値のマッピング Functoid の追加

  • 値のマッピング (フラット化) Functoid の追加

  • ループ Functoid の追加

  • Functoid の削除

関連項目

BizTalk マッパーの Functoid パレット

Functoid について


文字列処理を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [文字列] タブをクリックします。

  3. 文字列処理を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の文字列処理 Functoid の詳細については、「文字列処理を行う Functoid」を参照してください。.

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

文字列処理を行う Functoid

Functoid について


数値演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [数値演算] タブをクリックします。

  3. 数値演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の数値演算 Functoid の詳細については、「数値演算を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

数値演算を行う Functoid

Functoid について


論理演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [論理] タブをクリックします。

  3. 論理演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の論理演算 Functoid の詳細については、「論理演算を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 論理演算を行う Functoid で 2 つの文字列を比較する場合は、大文字と小文字が区別されます。たとえば、"Abc" と "abc" は等しくないと評価されます。例外は、論理演算を行う Functoid を使用して、ブール値の TRUE および FALSE を表す文字列を比較する場合です。たとえば、"True" と "true" は等しいと評価されます。

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

論理演算を行う Functoid

Functoid について


日時処理を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [日付/時刻] タブをクリックします。

  3. 日時処理を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の日時処理 Functoid の詳細については、「日時処理を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 日付、時刻、または日時を処理する Functoid で必要なのは、送信先仕様ツリーのフィールドまたはレコードへのリンクのみです。

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

日時処理を行う Functoid

Functoid について


変換を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [変換] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 変換を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の変換 Functoid の詳細については、「変換を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

変換を行う Functoid

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


関数演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [関数] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 関数演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の関数演算 Functoid の詳細については、「関数演算を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

関数演算を行う Functoid

Functoid について


累積演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [累積] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 累積演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の累積演算 Functoid の詳細については、「累積演算を行う Functoid」を参照してください。

  4. ループした親レコードを持つフィールドを、送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、送信先仕様ツリーのレコードまたはフィールドに Functoid をドラッグします。

    ループ レコードの詳細については、「累積演算を行う Functoid の使用」を参照してください。

重要

  • この手順の詳細については、「累積演算を行う Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

累積演算を行う Functoid

Functoid について


データベース操作を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [データベース] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. データベース操作を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    データベース操作を行う Functoid の詳細については、「データベース操作を行う Functoid」を参照してくたさい。

重要

  • データベース操作を行う Functoid を使用してデータベースから情報を抽出する方法については、「データベース操作を行う Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

データベース操作を行う Functoid

Functoid について


スクリプト Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. マッピング グリッドにスクリプト Functoid スクリプト Functoid をドラッグします。

    スクリプト Functoid の詳細については、「高度 Functoid」を参照してください。

  4. スクリプト Functoid をダブルクリックします。

  5. [Functoid プロパティ] ダイアログ ボックスの [スクリプト] タブをクリックし、必要なスクリプトを入力して [OK] をクリックします。

  6. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドのスクリプト Functoid にドラッグし、次に、スクリプト Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • スクリプト Functoid に複数の関数がある場合は、1 番目の関数が、主要部分を構成する基本の関数になります。スクリプト Functoid へのリンクがある場合は、この関数にパラメータを設定する必要があります。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開 」を参照してください。

関連項目

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

表示の管理


レコード カウント Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. レコード カウント Functoid レコード カウント Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    レコード カウント Functoid の詳細については、「高度 Functoid」を参照してください。

  4. ループ レコードを送信元仕様ツリーからマッピング グリッドのレコード カウント Functoid にドラッグし、次に、レコード カウント Functoid を送信先仕様ツリーのレコードにドラッグします。

    ループ レコードの詳細については、「レコード カウント Functoid の使用」を参照してください。

重要

  • この手順の詳細については、「レコード カウント Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


インデックス Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. インデックス Functoid インデックス Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    インデックス Functoid の詳細については、「高度 Functoid」を参照してください。

  4. ループした親レコードを持つフィールドを、送信元仕様ツリーからマッピング グリッドのインデックス Functoid にドラッグし、次に、送信先仕様ツリーのフィールドにインデックス Functoid をドラッグします。

    ループ レコードの詳細については、「インデックス Functoid の使用」を参照してください。

  5. インデックス Functoid をダブルクリックし、プロパティ シートを表示します。

  6. [新しいパラメータの挿入] ボタン [新しいパラメータの挿入] ボタン をクリックし、インデックス値を入力して Enter キーを押します。

  7. 必要に応じて、手順 6. を繰り返します。

  8. [OK] をクリックします。

重要

  • この手順の詳細については、「インデックス Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


繰り返し Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 繰り返し Functoid 繰り返し Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    繰り返し Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 繰り返し Functoid の使用方法については、「繰り返し Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


値のマッピング Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 値のマッピング Functoid 値のマッピング Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    値のマッピング Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 値のマッピング Functoid の使用方法については、「値のマッピング Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

値のマッピング (フラット化) Functoid の追加

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


値のマッピング (フラット化) Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 値のマッピング (フラット化) Functoid 値のマッピング (フラット化) Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    値のマッピング (フラット化) Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 値のマッピング (フラット化) Functoid の使用方法については、「値のマッピング (フラット化) Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

値のマッピング Functoid の追加

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


ループ Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. ループ Functoid ループ Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    ループ Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • ループ Functoid の使用方法については、「ループ Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

高度 Functoid

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


Functoid の削除

  1. 削除する Functoid を右クリックし、[削除] をクリックします。

  2. 確認ダイアログ ボックスで [はい] をクリックします。


Functoid プロパティの編集

  • [Functoid プロパティ] ダイアログ ボックスを表示するには、マッピング グリッドの Functoid を右クリックし、[プロパティ] をクリックします。

注

  • プロパティは、Functoid をダブルクリックして表示することもできます。

  • [全般] タブに、入力パラメータについての情報が表示されます。[スクリプト] タブに、スクリプトの内容が表示されます。

このダイアログ ボックスの使用方法については、次のトピックを参照してください。

  • 入力パラメータ

  • Functoid スクリプト


入力パラメータ

[Functoid プロパティ] ダイアログ ボックスを開く方法については、「Functoid プロパティの編集」を参照してください。

ほとんどの Functoid の入力パラメータは、[Functoid プロパティ] ダイアログ ボックスの [全般] タブで追加、削除、および上下に移動することができます。詳細については、次の手順を参照してください。

  • 入力パラメータの挿入

  • 入力パラメータの削除

  • 入力パラメータの移動

  • 入力パラメータの名前の変更

注

  • 一部の Functoid では、指定できるパラメータ数に制限があります。特定の Functoid に対して指定できるパラメータの数は、その Functoid の [Functoid プロパティ] ダイアログ ボックスの [全般] タブにある [入力パラメータ] ボックスの下に表示されます。


入力パラメータの挿入

  1. マッピング グリッドの Functoid をダブルクリックします。

    [Functoid プロパティ] ダイアログ ボックスが表示されます。

  2. [全般] タブの [新しいパラメータの挿入] ボタン [新しいパラメータの挿入] ボタン をクリックし、新しいパラメータの情報を入力して Enter キーを押します。

    注

    • 手順 2. で [新しいパラメータの挿入] ボタンが利用できない場合、その Functoid は入力パラメータを受け付けないか、必要としない Functoid です。
  3. 追加のパラメータが必要な場合は、手順 2. を繰り返します。

  4. [OK] をクリックします。

重要

  • 入力パラメータの定数値では、二重引用符を使用することはできません。

関連項目

入力パラメータの削除

入力パラメータの移動

入力パラメータの名前の変更


入力パラメータの削除

  1. マッピング グリッドの Functoid をダブルクリックします。

  2. [全般] タブの [入力パラメータ] ボックスで、削除する入力パラメータをクリックします。

  3. [選択したパラメータの削除] ボタン [image] をクリックし、[OK] をクリックします。

関連項目

入力パラメータの挿入

入力パラメータの移動

入力パラメータの名前の変更


入力パラメータの移動

  1. マッピング グリッドの Functoid をダブルクリックします。

  2. [全般] タブの [入力パラメータ] エリアで、移動する入力パラメータをクリックします。

  3. パラメータを上へ移動するには [選択したパラメータを上へ移動] ボタン [image] をクリックします。パラメータを下へ移動するには [選択したパラメータを下へ移動] ボタン [選択したパラメータを下へ移動] ボタン をクリックします。移動し終わったら [OK] をクリックします。

関連項目

入力パラメータの削除

入力パラメータの挿入


入力パラメータの名前の変更

  1. マッピング グリッドの Functoid をダブルクリックします。

  2. [全般] タブの [入力パラメータ] ボックスで、名前を変更する入力パラメータを右クリックし、[値の変更] をクリックします。

  3. パラメータの新しい名前を入力し、[OK] をクリックします。

関連項目

入力パラメータの削除

入力パラメータの挿入

入力パラメータの移動


Functoid スクリプト

[Functoid プロパティ] ダイアログ ボックスを開く方法については、「Functoid プロパティの編集」を参照してください。

[Functoid プロパティ] ダイアログ ボックスの [スクリプト] タブで、スクリプトの内容を表示し、編集することができます。

注

  • どのFunctoid のスクリプトでも表示できますが、編集できるのはスクリプト Functoid のスクリプトのみです。

関連項目

入力パラメータ


リンクの管理

ここには次のトピックが含まれます。

  • フィールド間のリンクの作成

  • フィールドと Functoid の間のリンクの作成

  • レコードとフィールドの間のリンクの作成

  • レコードと Functoid の間のリンクの作成

  • Functoid 間のリンクの作成

  • レコード コンテンツのリンクの許可

  • リンクのリダイレクト

  • リンクの削除


フィールド間のリンクの作成

  • 送信元仕様ツリーにあるフィールドを、送信先仕様ツリーのフィールドにドラッグします。

重要

  • 送信元仕様のフィールドのデータ型は、リンク先となる送信先仕様のフィールドのデータ型と一致している必要があります。

注

  • 送信先仕様の定数値を持つノードには、リンクできません。

  • 送信先仕様の既定値を持つ必須フィールドには、リンクできません。必須フィールドの作成については、「参照のプロパティの設定」を参照してください。フィールドの既定値の設定については、「宣言のプロパティの設定」を参照してください。

  • マップするフィールドを表示するために、仕様ツリーを展開しなければならないことがあります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

定数値の追加

表示の管理

宣言のプロパティの設定

参照のプロパティの設定

データ型とデータ型値の概要


フィールドと Functoid の間のリンクの作成

  • 送信元仕様ツリーまたは送信先仕様ツリーにあるフィールドを、マッピング グリッドの Functoid にドラッグします。

    または

  • マッピング グリッドにある Functoid を、送信元仕様ツリーまたは送信先仕様ツリーのフィールドにドラッグします。

重要

  • 送信先仕様のフィールドに特定のデータ型プロパティを指定した場合は、そのフィールドを、ほかのデータ型で出力を行う Functoid にリンクすることはできません。

注

  • フィールドから Functoid へのリンクを設定する場合は、あらかじめマッピング グリッドに Functoid を配置しておく必要があります。マッピング グリッドへの Functoid の追加の詳細については、「Functoid パレットでの操作」を参照してください。

  • 送信先仕様の定数値を持つノードには、リンクできません。

  • 送信先仕様の既定値を持つ必須フィールドには、リンクできません。必須フィールドの作成については、「参照のプロパティの設定」を参照してください。フィールドの既定値の設定については、「宣言のプロパティの設定」を参照してください。

関連項目

定数値の追加

表示の管理

宣言のプロパティの設定

参照のプロパティの設定

Functoid パレットでの操作


レコードとフィールドの間のリンクの作成

  1. [ツール] メニューの [オプション] をクリックします。

  2. [BizTalk マッパーのオプション] ダイアログ ボックスで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

  3. 送信元仕様ツリーにあるレコードを、送信先仕様ツリーのフィールドにドラッグします。

    または

    送信先仕様ツリーにあるレコードを、送信元仕様ツリーのフィールドにドラッグします。

注

  • 送信先仕様の定数値を持つノードには、リンクできません。

  • 送信先仕様の既定値を持つ必須フィールドには、リンクできません。必須フィールドの作成については、「参照のプロパティの設定」を参照してください。フィールドの既定値の設定については、「宣言のプロパティの設定」を参照してください。

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

定数値の追加

表示の管理

宣言のプロパティの設定

参照のプロパティの設定


レコードと Functoid の間のリンクの作成

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [レコード コンテンツのリンクを許可] チェック ボックスをオンにし、[OK] をクリックします。

  3. 送信元仕様ツリーまたは送信先仕様ツリーにあるレコードを、マッピング グリッドの Functoid にドラッグします。

    または

    マッピング グリッドにある Functoid を、送信元仕様ツリーまたは送信先仕様ツリーのレコードにドラッグします。

注

  • レコードから Functoid へのリンクを設定する場合は、あらかじめマッピング グリッドに Functoid を配置しておく必要があります。

  • 送信先仕様の定数値を持つノードには、リンクできません。送信先定数値の詳細については、「BizTalk マッパーのユーザー インターフェイス」を参照してください。

関連項目

定数値の追加

表示の管理


Functoid 間のリンクの作成

  • Functoid をマッピング グリッドの別の Functoid にドラッグします。

注

  • リンクは、マッピング グリッドで左から右に処理されます。ある Functoid から、その真上または真下にある別の Functoid へのリンクを作成することはできません。

関連項目

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成


レコード コンテンツのリンクの許可

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [レコード コンテンツのリンクを許可] チェック ボックスをオンにし、[OK] をクリックします。

  3. 送信元仕様ツリーにあるレコードを、送信先仕様ツリーのレコードにドラッグします。


リンクのリダイレクト

  1. マッピング グリッドで、リンクをクリックして強調表示します。

    リンクのエンドポイントが小さな青色四角形になり、強調表示されます。

  2. エンドポイントのどちらかを、Functoid にドラッグするか、ノードを接続したい所へドラッグします。

    エンドポイントをドラッグすると、ポインタが十字形になります。リンクを作成できないオブジェクトへドラッグすると、ポインタは斜線の描かれた円になります。

重要

  • 2 つ以上の送信元リンクが Functoid に接続されている場合に、それらの送信元リンクを送信元仕様の別のノードに 1 つ以上リダイレクトすると、Functoid の入力パラメータの順序は維持されません。Functoid をダブルクリックして入力パラメータを表示し、パラメータの順序が正しいことを確認します。


リンクの削除

  1. 削除するリンクを右クリックし、[削除] をクリックします。

  2. 確認ダイアログ ボックスで [はい] をクリックします。


グリッドでのリンクと Functoid の表示

ここには次のトピックが含まれます。

  • マッピング グリッドでのリンクと Functoid の表示

  • グリッドのプレビューを利用したリンクと Functoid の表示


マッピング グリッドでのリンクと Functoid の表示

  1. マッピング グリッド上で、スクロールする方向の端にカーソルを移動します。

    カーソルが、ポインタまたはパイプ (|) から大きな矢印に変わります。

  2. 矢印の方向にスクロールするには、左マウス ボタンをクリックしたまま離さないようにします。

注

  • 上下左右 4 方向のいずれかにスクロールする場合は、マッピング グリッドの背景をクリックし、矢印キーを押してスクロールすることもできます。

関連項目

BizTalk マッパーのユーザー インターフェイス

グリッドのプレビューを利用したリンクと Functoid の表示


グリッドのプレビューを利用したリンクと Functoid の表示

  1. [表示] メニューの [グリッドのプレビュー] をクリックします。

    [グリッドのプレビュー] ダイアログ ボックスが開き、マッピング グリッド上の Functoid の配置を示す図が表示されます。

    [グリッドのプレビュー] ダイアログ ボックスにある緑色のロケータ バーを別の場所にドラッグすると、マッピング グリッドにあるリンクと Functoid も移動します。

注

グリッドのプレビューは、マッピング グリッドを広く使って多くの Functoid を配置した場合に、マッピング グリッド内を移動するときに便利です。

関連項目

BizTalk マッパーのユーザー インターフェイス

マッピング グリッドでのリンクと Functoid の表示


リンク プロパティの編集

  • [リンク プロパティ] ダイアログ ボックスを表示するには、マッピング グリッドにあるリンクを右クリックし、[プロパティ] をクリックします。

    [全般] タブが表示されます。

このダイアログ ボックスの使用方法については、次のトピックを参照してください。

  • リンク プロパティの表示: [全般] タブ

  • リンク プロパティの表示: [コンパイラ] タブ

注

  • プロパティは、リンクをダブルクリックして表示することもできます。

関連項目

マップのコンパイル

リンクの管理


リンク プロパティの表示 : [全般] タブ

[リンク プロパティ] ダイアログ ボックスを開く方法については、「リンク プロパティの編集」を参照してください。

[全般] タブには、リンクの送信元と送信先に関する情報が表示されます。[送信元] ボックスには、リンクの送信元がレコード、フィールド、または Functoid のいずれであるかによって、リンク送信元のレコード パス、フィールド パス、または Functoid 名が表示されます。[送信先] ボックスには、リンクの送信先がレコード、フィールド、または Functoid のいずれであるによって、リンク送信先のレコード パス、フィールド パス、または Functoid 名が表示されます。

関連項目

リンク プロパティの表示: [コンパイラ] タブ


リンク プロパティの表示 : [コンパイラ] タブ

[リンク プロパティ] ダイアログ ボックスを開く方法については、「リンク プロパティの編集」を参照してください。

[コンパイラ] タブは、送信元仕様リンクおよび送信先仕様リンクのコンパイラのプロパティを設定するためのタブです。これらの設定の変更については、次のトピックを参照してださい。

  • 送信元仕様リンクのコンパイラ プロパティの選択

  • 送信先仕様リンクのコンパイラ プロパティの選択

関連項目

リンク プロパティの表示: [全般] タブ


送信元仕様リンクのコンパイラ プロパティの選択

  1. 送信元仕様のノードに接続されているマッピング グリッドのリンクを右クリックし、[プロパティ] をクリックします。

  2. [コンパイラ] タブをクリックし、[送信元仕様リンク] ボックスにある次のオプションのいずれか 1 つをクリックします。
    • [値のコピー (既定)] : 受信ドキュメント インスタンスのノードの値をコピーします。

    • [名前のコピー] : 受信ドキュメント インスタンスのノードの名前をコピーします。
  3. [OK] をクリックします。

関連項目

送信先仕様リンクのコンパイラ プロパティの選択


送信先仕様リンクのコンパイラ プロパティの選択

  1. 送信先仕様のノードに接続されているマッピング グリッドのリンクを右クリックし、[プロパティ] をクリックします。

  2. [コンパイラ] タブをクリックし、[送信先仕様リンク] ボックスにある次のオプションのいずれか 1 つをクリックします。
    • [リンクをフラット化 (既定)] : このモードでは、送信元仕様と送信先仕様のレコードおよびフィールドが 1 対 1 で対応するリンクが作成されます。

    • [リンクを上から順に一致] : このモードでは、上から順にレベルとレベルが一致されます。

    • [リンクを下から順に一致] : このモードでは、下から順にレベルとレベルが一致されます。
  3. [OK] をクリックします。

注

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つの [リンクをフラット化 (既定)] と、
    1 つの [リンクを上から順に一致] と、
    1 つの [リンクを下から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに [リンクをフラット化 (既定)] が指定されたように扱います。

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つ以上の [リンクをフラット化 (既定)] と、
    1 つの [リンクを上から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに [リンクを上から順に一致] が指定されたように扱います。

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つ以上の [リンクをフラット化 (既定)] と、
    1 つの [リンクを下から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに [リンクを下から順に一致] が指定されたように扱います。

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つ以上の [リンクを上から順に一致] と、
    1 つ以上の [リンクを下から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに [リンクをフラット化 (既定)] が指定されたように扱います。

関連項目

ノードと階層レベルの対応

送信元仕様リンクのコンパイラ プロパティの選択


コンパイル済みマップの作成および管理

ここには次のトピックが含まれます。

  • マップのコンパイル

  • マップのコンパイル後の警告とエラーの解決

  • 定数値の追加


マップのコンパイル

  • [ツール] メニューの [マップのコンパイル] をクリックします。

注意

  • 適切な結果が得られないような設定をコンパイラが検出した場合は、[警告] タブに警告が表示されます。本番運用環境で使用できるマップを準備する場合は、警告が表示されなくなるまで修正してください。

関連項目

マップのコンパイル後の警告とエラーの解決


マップのコンパイル後の警告とエラーの解決

  1. [警告] タブの警告をダブルクリックします。

    警告またはエラーに関連したリンクあるいは Functoid が、マッピング グリッドで強調表示されます。

  2. 必要に応じて、リンクまたは Functoid を修正します。

  3. 警告ごとに、手順 1. と 2. を繰り返します。

  4. [ツール] メニューの [マップのコンパイル] をクリックします。

関連項目

マップのコンパイル


定数値の追加

  1. 送信先仕様ツリーのレコードまたはフィールドをクリックし、[値] タブをクリックします。

  2. [送信先定数値] ボックスに、レコードまたはフィールドと関連付ける値を入力します。

注

  • 定数値が関連付けられているレコードまたはフィールドへは、リンクを作成できません。

  • 定数値を関連付けることができるのは、"コンテンツ" プロパティが "テキストのみ" に設定されているレコードだけです。"コンテンツ" プロパティの詳細については、「宣言プロパティの設定」を参照してください。

関連項目

宣言のプロパティの設定


マップのテスト

ここには次のトピックが含まれます。

  • リンクのあるレコードまたはフィールドのプロパティのテスト

  • リンクのテスト

  • Functoid のテスト


リンクのあるレコードまたはフィールドのプロパティのテスト

重要

  • テストを行う前に、常にマップをコンパイルすると、警告やエラーを解決することができます。詳細については、「マップのコンパイル」を参照してください。
  1. リンクで接続されている送信元仕様ツリーのフィールドをクリックします。

  2. [値] タブをクリックします。

  3. [送信元テスト値] ボックスに値を入力します。

  4. [ツール] メニューの [マップのテスト] をクリックします。

    重要

    • テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。マップに問題が発生したときに備えて、テストを行う前にファイルを保存しておきます。
  5. [はい] をクリックし、マップを保存します。

  6. [出力] タブの結果を確認します。

注

  • レコードの "最大発生数" プロパティがアスタリスク (*) の場合は、ループ レコードであることを示します。マップをテストするために BizTalk マッパーが生成する受信ドキュメント インスタンスには、レコードが 2 件発生します。

関連項目

マップのコンパイル

マップのテスト


リンクのテスト

重要

  • テストを行う前に、常にマップをコンパイルすると、警告やエラーを解決することができます。詳細については、「マップのコンパイル」を参照してください。
  1. リンクで接続されている送信元仕様ツリーのフィールドをクリックします。

  2. [値] タブをクリックします。

  3. [送信元テスト値] ボックスに値を入力します。

  4. [ツール] メニューの [マップのテスト] をクリックします。

    重要

    • テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。マップに問題が発生したときに備えて、テストを行う前にファイルを保存しておきます。
  5. [はい] をクリックし、マップを保存します。

  6. [出力] タブの結果を確認します。

関連項目

マップのコンパイル

マップのテスト


Functoid のテスト

重要

  • テストを行う前に、常にマップをコンパイルすると、警告やエラーを解決することができます。詳細については、「マップのコンパイル」を参照してください。
  1. [ツール] メニューの [マップのテスト] をクリックします。

    重要

    • テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。マップに問題が発生したときに備えて、テストを行う前にファイルを保存しておきます。
  2. [はい] をクリックし、マップを保存します。

  3. [出力] タブの結果を確認します。

関連項目

マップのコンパイル

マップのテスト


表示の管理

ここには次のトピックが含まれます。

  • ツリー項目の展開

  • ツリー項目の折りたたみ

  • レコード プロパティとフィールド プロパティの表示

  • 名前空間の表示

  • 送信元仕様ツリー ペインのサイズ調整

  • 送信先仕様ツリー ペインのサイズ調整

  • 下部ウィンドウのサイズ調整


ツリー項目の展開

  • 展開するルート ノードまたは仕様ツリーのレコードをクリックし、[表示] メニューの [ツリー項目の展開] をクリックします。

    または

    ルート ノードまたはツリーのレコードを右クリックし、[ツリー項目の展開] をクリックします。

関連項目

ツリー項目の折りたたみ


ツリー項目の折りたたみ

  • 折りたたむルート ノードまたは仕様ツリーのレコードをクリックし、[表示] メニューの [ツリー項目の折りたたみ] をクリックします。

注

  • ツリー項目の折りたたみは、ルート ノードまたはツリーのレコードを右クリックし、[ツリー項目の折りたたみ] をクリックしても実行できます。

関連項目

ツリー項目の展開


レコード プロパティとフィールド プロパティの表示

  • 送信元仕様ツリーまたは送信先仕様ツリーのレコードまたはフィールドをクリックし、[表示] メニューの [プロパティ] をクリックします。

    または

    どちらかのツリーのレコードまたはフィールドをクリックし、[プロパティ] タブをクリックします。

注

  • 特定のプロパティおよびそれに関連する値を表示する場合に、[プロパティ] タブのスクロール バーをドラッグしなければならないことがあります。


名前空間の表示

Microsoft Internet Explorer 5 以降でマップを表示すると、マップの名前空間を参照することができます。

  1. Internet Explorer を起動し、開くマップ ファイルを参照します。

  2. 送信元仕様の名前空間情報を表示するには、<srctree> タグの直後にある最初の <schema> タグまでスクロールします。

  3. 送信先仕様の名前空間情報を表示するには、<sinktree> タグの直後にある 2 番目の <schema> タグまでスクロールします。

関連項目

名前空間のサポート


送信元仕様ツリー ペインのサイズ調整

  1. 送信元仕様ツリー ペインの右境界線をポイントし、カーソルを両方向矢印にします。

  2. 境界線を右にドラッグするとペインのサイズは大きくなり、左にドラッグすると小さくなります。

注

  • 境界線をダブルクリックし、既定の位置に復元します。

関連項目

送信先仕様ツリー ペインのサイズ調整

下部ウィンドウのサイズ調整


送信先仕様ツリー ペインのサイズ調整

  1. 送信先仕様ツリー ペインの左境界線をポイントし、カーソルを両方向矢印にします。

  2. 境界線を左にドラッグするとペインのサイズは大きくなり、右にドラッグすると小さくなります。

注

  • 境界線をダブルクリックし、既定の位置に復元します。

関連項目

送信元仕様ツリー ペインのサイズ調整

下部ウィンドウのサイズ調整


下部ウィンドウのサイズ調整

  1. 下部ウィンドウの上境界線をポイントし、カーソルを両方向矢印にします。

  2. ペインを上方にドラッグするとペインのサイズは大きくなり、下方にドラッグすると小さくなります。

注

  • 境界線をダブルクリックし、既定の位置に復元します。

関連項目

送信先仕様ツリー ペインのサイズ調整

送信元仕様ツリー ペインのサイズ調整


ユーザー インターフェイスのカスタマイズ

ここには次のトピックが含まれます。

  • マッピング グリッドの色の変更

  • リンクの色の変更

  • 選択したオブジェクトの色の変更

  • コンパイラの警告の色の変更

  • 既定の色への復元

  • テキストのサイズの変更


マッピング グリッドの色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. マッピング グリッドの破線を表す [グリッドの前景色] の隣のボックスをクリックし、色パレットで新しい色を選択します。

    または

    マッピング グリッドの背景色を表す [グリッドの背景色] の隣のボックスをクリックし、色パレットで新しい色を選択します。

  4. [OK] をクリックします。

関連項目

コンパイラの警告の色の変更

リンクの色の変更

選択したオブジェクトの色の変更

既定の色への復元


リンクの色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. 次のいずれかの隣にあるボックスをクリックします。
    • [固定リンク] : 固定リンクは、マッピング グリッド内にある単純な値コピー リンクです。

    • [柔軟なリンク] : 柔軟なリンクは、単純な値コピー リンクを送信元仕様ツリーから送信先仕様ツリーにドラッグしているときのリンクです。リンクが作成されると、リンクの色は固定リンクの色に変わります。

    • [部分的なリンク] : 部分的なリンクは、フィールドまたはレコードの親レコードが折りたたまれている場合に存在するリンクです。

    • [コンパイラ リンク] : コンパイラ リンクは、コンパイラ ディレクティブ リンクです。コンパイラ リンクは、送信元仕様ツリーと送信先仕様ツリーの階層が一致していない場合に、送信元仕様ツリーのフィールドから送信先仕様ツリーのフィールドまでリンクを設定すると自動的に作成されるリンクです。
  4. 色パレットで新しい色を選択します。

  5. そのほかの色を変更する必要がある場合は、手順 3. を繰り返します。

  6. [OK] をクリックします。

関連項目

マッピング グリッドの色の変更

コンパイラの警告の色の変更

選択したオブジェクトの色の変更

既定の色への復元


選択したオブジェクトの色の変更

  1. [ツール] メニューの [オプション] をクリックします。

  2. [BizTalk マッパーのオプション] ダイアログ ボックスの [色] タブをクリックします。

  3. [選択したオブジェクト] の隣のボックスをクリックし、色パレットで新しい色を選択します。

  4. [OK] をクリックします。

関連項目

マッピング グリッドの色の変更

コンパイラの警告の色の変更

リンクの色の変更

既定の色への復元


コンパイラの警告の色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. [コンパイラの警告] の隣のボックスをクリックし、色パレットで新しい色を選択します。

  4. [OK] をクリックします。

関連項目

マッピング グリッドの色の変更

リンクの色の変更

選択したオブジェクトの色の変更

既定の色への復元


既定の色への復元

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. [既定の色に戻す] をクリックし、[OK] をクリックします。

関連項目

マッピング グリッドの色の変更

コンパイラの警告の色の変更

リンクの色の変更

選択したオブジェクトの色の変更


概念

ここでは、BizTalk マッパーを使用するうえで不可欠な概念について説明します。

ここには次のトピックが含まれます。

  • マッピング仕様

  • マッピングの使用環境

  • BizTalk マッパーの環境

  • リンクの作成

  • ノードと階層レベルの対応

  • レコード、フィールド、リンク、および Functoid プロパティの参照

  • Functoid について

  • マップのコンパイル

  • マップのテスト


マッピング仕様

ある形式のデータを別の形式に変換するための情報は、マップで規定されます。マップには、送信元と送信先という 2 つの仕様が必要です。データのマッピングとは、送信元仕様のレコードおよびフィールドと、送信先仕様のレコードおよびフィールドとの対応関係を定義するデータ変換処理のことです。

マップには 2 つの種類があります。1 つは、ある取引先に特有のニーズに適合するよう設計された専用のマップ、もう 1 つは、複数の取引先のニーズに適合するよう設計された汎用のマップです。ある取引先に特有のレコードおよびフィールド要件に合わせてマッピングを行う場合は、その取引先専用のマップを作成します。汎用のマップを作成する場合は、複数の取引先の条件を 1 つのマップにまとめます。複数の組織が相互に接続されている場合もあるため、複数の取引先に対して同一のマップを使用できるようにしておくと、リソースと時間を節約できます。

BizTalk マッパーは、リンクと呼ばれる単純な値のコピーや変換、および Functoid と呼ばれる複雑な構造的操作を含んだマップを、グラフィカルに表示します。これらの要素を組み合わせると、送信元仕様と送信先仕様との間でデータを簡単にマッピングできます。


マッピングの使用環境

ここには次のトピックが含まれます。

  • ループ パス

  • レコードとフィールドの順序


ループ パス

BizTalk エディタの [参照] タブで "最大発生数" プロパティが "*" に設定されていると、仕様内のレコードがループします。"最大発生数" プロパティの詳細については、「参照のプロパティの設定」を参照してください。

送信元仕様内にあるループしたレコードに含まれるフィールドが、送信先仕様内にあるループしたレコードに含まれるフィールドにリンクしていると、マップ内でループ パスが発生します。次の図は、Root\Record1\Field1 から Root\RecordA\Field1、および Root\Record2\Field2 から \Root\RecordB\Field3 という、2 つのループ パスを示しています。

図をクリックすると、拡大または縮小します。

この [プロパティ] タブでは、Record1 と RecordA がループしています。Record2 と RecordB もループしています。

次のコードは、入力ドキュメントのサンプルです。

<Root>
<Record1 Field1=Red>
<Record1 Field1=Green>
<Record1 Field1=Blue>
<Record2 Field2=50>
<Record2 Field2=100>
</Root>

上のマップを使用すると、この入力ドキュメントは次の出力ドキュメントにマップされます。

<Root>
<RecordA Field1=Red>
<RecordA Field1=Green>
<RecordA Field1=Blue>
<RecordB Field3=50>
<RecordB Field3=100>
</Root>

送信元仕様内にある複数のループしたレコードに含まれるフィールドが、送信先仕様にある 1 つのループしたレコードに含まれるフィールドにリンクしていると、マップ内で複数のループ パスが発生します。

次の図は、複数のループ パスの例を示しています。

図をクリックすると、拡大または縮小します。

BizTalk マッパーでは、複数のループ パスをサポートしていません。複数のループ パスが含まれるマップをコンパイルしようとすると、[警告] タブに、送信先ノードに複数の送信元ループ パスがありますというメッセージが表示されます。

関連項目

参照のプロパティの設定


レコードとフィールドの順序

Extensible Stylesheet Language (XSL) 内での出力レコードおよびフィールドの順序は、暗黙的に決まるわけではありません。BizTalk マッパーは、送信先仕様の構造を参照してからマッピング グリッドを通って送信元に戻り、送信元仕様ツリーから値を抽出することで XSL を生成するからです。たとえば、先頭が BillTo Address レコードで、その次が ShipTo Address レコードという出力ファイルを作成するには、送信先仕様内で ShipTo Address レコードの前に BillTo Address レコードを配置する必要があります。

次の図は、この構造を示しています。

図をクリックすると、拡大または縮小します。

ContactType フィールドには有効なコードが 2 つ (BT と ST) 格納されていて、Address が BillTo と ShipTo のどちらであるかは、このコードによって識別されます。期待したとおりの出力を作成するため、マッピング グリッドに等号 Functoid が追加され、送信元仕様内のフィールドが送信先仕様内のレコードにリンクされています。

このマップでは、1 番目の Functoid によって、次の条件を満たしているかどうかをチェックしています。

ContactType が BT と一致しているか?

この条件が満たされている場合は、出力レコード BillTo の Address 関連のフィールドが作成され、必要なフィールドが BillTo の Address 関連のフィールドにマップされます。条件が満たされていない場合、BizTalk マッパーはすべての入力 Address レコードを順に処理していきます。

重要

  • 出力ドキュメント インスタンス内でのレコードおよびフィールドの出現順序は、対応する出力仕様でのレコードおよびフィールドの順序によって決まります。


BizTalk マッパーの環境

ここには次のトピックが含まれます。

  • BizTalk マッパーのユーザー インターフェイス

  • BizTalk マッパーのメニュー

  • BizTalk マッパーのツール バー ボタン

  • BizTalk マッパーの Functoid パレット

  • BizTalk マッパーのショートカット キー


BizTalk マッパーのユーザー インターフェイス

BizTalk マッパーのメイン ウィンドウのツリーには、マップの作成に使用する 2 つの仕様が表示されます。左側はデータのマッピング元となる送信元仕様、右側はデータのマッピング先となる送信先仕様です。2 つの仕様の間にあるマッピング グリッドには、2 つの仕様間での構造的なデータ変換がグラフィカルに表示されます。リンクおよび Functoid はマッピング グリッド内に表示されます。ポインタをマッピング グリッドの端に移動させると、マッピング グリッド内を上下左右に簡単に移動できます。

[グリッドのプレビュー] ダイアログ ボックスを使用すると、マッピング グリッド内のある場所から別の場所へすばやく移動できます。緑のロケータ バーをドラッグすると、上下左右に移動できます。マッピング グリッドにある Functoid は、プレビュー グリッドでは黒い枠付きの赤いボックスで表示されます。マッピング グリッドに 2 つ以上の Functoid がある場合は、2 つの赤いボックスが連結され、黒い枠で囲まれて表示されます。

ツリー表示とマッピング グリッドの下には、下部ウィンドウが表示されます。ここには 4 つのタブがあります。

  • [プロパティ] : 送信元仕様ツリーまたは送信先仕様ツリー内のノードを選択すると、そのノードのプロパティおよびプロパティ値が [プロパティ] タブに表示されます。

  • [値] : このタブには、[送信元テスト値] および [送信先定数値] という 2 つのテキスト ボックスがあります。 [送信元テスト値] ボックスでは、フィールドを選択し、値を入力できます。これにより、フィールドに入るべき実際の値を使用して、マップをテストできます。[送信先定数値] ボックスでは、フィールドに入れる値を指定できます。Functoid または送信先仕様内のノードから、定数値が割り当てられたフィールドへのリンクは作成できません。

  • [出力] : マップをコンパイルすると、コンパイルされた Extensible Stylesheet Language (XSL) 形式シートがこのタブに表示されます。マップのテスト時は、テスト マップ出力が表示されます。

  • [警告] : このタブには、マップのコンパイル後にコンパイラからの警告が表示されます。

関連項目

マップのコンパイル

マップのテスト

グリッドのプレビューを利用したリンクと Functoid の表示


BizTalk マッパーのメニュー

BizTalk マッパーのメニューは、コマンドを論理的にまとめることで、作業を簡単に実行できるようになっています。たとえば、[表示] メニューのコマンドを使用すると、送信元仕様ツリーのすべてのレコードおよびフィールドを展開したり、送信先仕様ツリーのすべてのレコードおよびフィールドを折りたたんだりできます。

BizTalk マッパーのメニューは次のとおりです。

  • [ファイル] : このメニューを使用すると、マップを作成する、開く、保存する、および閉じるという操作を行えます。

  • [編集] : このメニューを使用すると、送信元仕様および送信先仕様の置換、およびマッピング グリッド内のオブジェクトの削除を行えます。

  • [表示] : このメニューを使用すると、Functoid パレット、Functoid のプロパティ、およびグリッドのプレビューを表示できます。また、BizTalk マッパーの表示テキスト サイズの選択、下部ウィンドウのタブの選択、仕様ツリーの展開と折りたたみ、および [警告] タブの次の警告の強調表示も行えます。

  • [ツール] : このメニューを使用すると、マップのコンパイルとテスト、および BizTalk マッパーのオプションの表示を行えます。

  • [ヘルプ] : このメニューを使用すると、BizTalk マッパーの使用に関する各種の方法や概念を参照できます。

関連項目

BizTalk エディタのメニュー


BizTalk マッパーのツール バー ボタン

BizTalk マッパーには、メニュー バーを補うためのツール バーが用意されています。ツール バーのすべてのボタンは、それが実行する作業を表すグラフィックで表示されます。左から右へ、次の順序で並んでいます。

  • [新規作成]

  • [開く]

  • [保存]

  • [WebDAV から取得]

  • [WebDAV に格納]

  • [削除]

  • [折りたたみ]

  • [展開]

  • [Functoid パレットの表示]

  • [マップのコンパイル]

  • [マップのテスト]


BizTalk マッパーの Functoid パレット

Functoid パレットには、BizTalk マッパーで使用可能なすべての Functoid が含まれています。Functoid には、送信元仕様のレコードまたはフィールド、または別の Functoid (日付 Functoid など) からデータを取得し、データを個別に処理して、送信先仕様のレコードまたはフィールドにセットする新しい値を返すためのプログラムが含まれています。Functoid パレットの詳細については、「Functoid について」を参照してください。

関連項目

Functoid について

Functoid パレットでの操作


BizTalk マッパーのショートカット キー

BizTalk マッパーでは、ショートカット キーを使用して作業を行うことができます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional ヘルプでは、「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Ctrl + N | 新しい仕様を開きます。
Ctrl + O | 既存のマップを開きます。
Ctrl + S | マップを保存します。
Cｔｒｌ + F5 | マップをテストします。
F4 | 次の警告を強調表示します。
F5 | マップをコンパイルします。
Del | マッピング グリッド内のオブジェクトを削除します。
F6 | ウィンドウのフォーカスを時計回りに切り替えます。
Shift + F6 | ウィンドウのフォーカスを反時計回りに切り替えます。Functoid パレットが開いた状態で Shift キーを押しながら F6 キーを押すと、フォーカスが [文字列] タブへ切り替わり、左右の方向キーを使用してタブを切り替えられます。
Tab | 下部ウィンドウで、フォーカスをタブからその下のウィンドウまたはフィールドへ、時計回りに切り替えます。ボタンやフィールド間でフォーカスが移動します。
Shift + Tab | 下部ウィンドウで、フォーカスをタブからその下のウィンドウまたはフィールドへ、反時計回りに切り替えます。
Space | チェック ボックスをオンまたはオフにします。ボタンにフォーカスがある場合、マウスのクリックと同様な動作になります。
F1 | オンライン ヘルプを表示します。
Alt + F4 | プログラムを終了します。
← | 左のタブを選択します。
→ | 右のタブを選択します。
任意の方向キー | ダイアログ ボックスのメイン ウィンドウ内のフォルダまたはファイルを強調表示します。フォーカスは切り替わりません。この機能を使用できるのは、[WebDAV から取得] ダイアログ ボックス、および [WebDAV に格納] ダイアログ ボックスです。詳細については、「WebDAV からのマップの取得」を参照してください。


リンクの作成

送信元仕様ツリーのレコードおよびフィールドから、送信先仕様ツリーのレコードおよびフィールドへのデータ コピーの基本機能は、リンクによって実行されます。BizTalk マッパーは、1 対 1 リンクおよび 1 対多 リンクをサポートしています。たとえば、送信元仕様ツリーの 1 つのレコードまたはフィールドと、送信先仕様ツリーの 1 つのレコードまたはフィールドを、リンクによって結合できます。送信元仕様ツリーの 1 つのレコードまたはフィールドと、送信先仕様ツリーの複数のレコードまたはフィールドを、リンクで結合することも可能です。また、送信元仕様ツリーの複数のレコードまたはフィールドを 1 つの Functoid とリンクで結合し、それを送信先仕様ツリーの 1 つのレコードまたはフィールドとリンクで結合することもできます。送信元仕様ツリーの複数のレコードまたはフィールドを、送信先仕様ツリーの 1 つのレコードまたはフィールドと結合することも可能です。

関連項目

リンクの管理


ノードと階層レベルの対応

BizTalk マッパーには、コンパイラ ディレクティブが含まれています。このディレクティブを使用すると、送信元仕様ツリーの階層と、送信先仕様ツリーの階層の対応レベルを設定できます。送信元仕様ツリーのフィールドから、送信先仕様ツリーのフィールドへのリンクを作成すると、BizTalk マッパーは [リンク プロパティ] ダイアログ ボックスの [コンパイラ] タブにある [送信先仕様リンク] ボックスの設定に基づいて、自動的にコンパイラ リンクを追加します。詳細については、「送信先仕様リンクのコンパイラ プロパティの選択」を参照してください。次の図は、ノードと階層レベルの対応の例を示しています。

  • [リンクをフラット化 (既定)] : このモードでは、リンクの親レコードが、別のツリーの各レコードと 1 対 1 のリンクを持ちます。第 1 のケースでは、送信元仕様は送信先仕様よりも複雑です。第 2 のケースでは、送信先仕様の方が複雑です。
F2
R5
R4
ルート 2
F1
R3
R2
R1
ルート 1
ユーザー作成のリンク
コンパイラ リンク

R5
R4
R3
ルート 2
F2
F1
R2
R1
ルート 1
ユーザー作成のリンク
コンパイラ リンク

  • [リンクを上から順に一致] : このモードでは、レベルとレベルが上から順に対応付けられます。第 1 のケースでは、送信元仕様は送信先仕様よりも複雑です。第 2 のケースでは、送信先仕様の方が複雑です。
F2
R5
R4
ルート 2
F1
R3
R2
R1
ルート 1
ユーザー作成のリンク
コンパイラ リンク

R5
R4
R3
ルート 2
F2
F1
R2
R1
ルート 1
ユーザー作成のリンク
コンパイラ リンク

  • [リンクを下から順に一致] : このモードでは、レベルとレベルが下から順に対応付けられます。第 1 のケースでは、送信元仕様は送信先仕様よりも複雑です。第 2 のケースでは、送信先仕様の方が複雑です。
F2
R5
R4
ルート 2
F1
R3
R2
R1
ルート 1
ユーザー作成のリンク
コンパイラ リンク

R5
R4
R3
ルート 2
F2
F1
R2
R1
ルート 1
ユーザー作成のリンク
コンパイラ リンク

注

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つの [リンクをフラット化 (既定)] と、
    1 つの [リンクを上から順に一致] と、
    1 つの [リンクを下から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに、[リンクをフラット化 (既定)] が指定されたように扱います。

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つ以上の [リンクをフラット化 (既定)] と
    1 つの [リンクを上から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに、[リンクを上から順に一致] が指定されたように扱います。

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つ以上の [リンクをフラット化 (既定)] と
    1 つの [リンクを下から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに、[リンクを下から順に一致] が指定されたように扱います。

  • 送信元仕様のフィールドと送信先仕様のフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、
    1 つ以上の [リンクを上から順に一致] と
    1 つ以上の [リンクを下から順に一致] を使用すると、
    BizTalk マッパーは、すべてのリンクに、[リンクをフラット化 (既定)] が指定されたように扱います。

関連項目

マップのコンパイル


レコード、フィールド、リンク、および Functoid プロパティの参照

送信元仕様および送信先仕様には、仕様に定義されたレコードおよびフィールドが表示されます。これらの仕様は、BizTalk エディタを使用して作成するか、整形式 XML として BizTalk エディタにインポートします。送信元仕様はマッピング グリッドの左側に表示され、送信先仕様は右側に表示されます。

レコードおよびフィールドのプロパティと値

レコードおよびフィールドのプロパティと値は、メイン ウィンドウの下にある [プロパティ] タブに表示されます。レコードまたはフィールドを選択すると、BizTalk エディタのプロパティ タブの主要プロパティと値が表示されます。

リンクおよび Functoid のプロパティ

BizTalk マッパーのマッピング グリッドには、データ変換の構造がグラフィカルに表示されます。リンクは、送信元仕様ツリーのレコードまたはフィールドと、送信先仕様ツリーのレコードまたはフィールドとを接続する 1 本の線で表示されます。リンクは、レコードまたはフィールドと Functoid の接続にも使用されます。Functoid はアイコンで表示されます。リンクのプロパティには、送信元と送信先のデータおよびコンパイラ ディレクティブ情報が含まれています。Functoid のプロパティには、入力パラメータおよびスクリプト情報が含まれています。

関連項目

レコード、フィールド、およびプロパティ

Functoid について


Functoid について

BizTalk マッパーは、送信元仕様ツリーのレコードおよびフィールドから、送信先仕様ツリーのレコードおよびフィールドへの、複雑な構造変換をサポートしています。Functoid は、定義済みの式と引数と呼ばれる値を使用して、計算を実行します。この計算は、指定されたレコードおよびフィールドの順序に基づいて実行されます。Functoid パレットで Functoid を選択してマッピング グリッドへドラッグし、それを送信元仕様ツリーおよび送信先仕様ツリーの要素とリンクすることで、データの加算、日付と時間の情報の変更、データの連結、そのほかの操作などが行われます。たとえば、加算 Functoid は値を加算します。

[Functoid パレット] には、次のタブがあります。

  • [文字列] : この Functoid は、文字列関数を使用してデータ文字列を処理します。たとえば、文字列位置検出 Functoid は、あるテキスト文字列を別のテキスト文字列内から検索し、発見した文字列の最初の文字の位置を返します。

  • [数値演算] : この Functoid は、引数と呼ばれる値を使用して、特定の順序または構造で計算します。たとえば、加算 Functoid は指定されたフィールドまたレコードに値を加算します。

  • [論理] : この Functoid では、論理テストが実行されます。論理演算を行う Functoid が送信先仕様のレコードに接続されていて、Functoid が TRUE (真) を返した場合、対応するレコードが出力ドキュメント内に生成されます。論理演算を行う Functoid が送信先仕様のレコードに接続されていて、Functoid が FALSE (偽) を返した場合、対応するレコードは出力ドキュメント内に生成されません。論理演算を行う Functoid の出力結果は、マップ内のほかの Functoid への入力としても使用できます。

  • [日付/時刻] : この Functoid では、日付と時間のデータの操作、または送信先仕様のレコードまたはフィールドへの、現在の日付、時刻、または日付と時間のデータの加算をします。

  • [変換] : この Functoid は DEC2HEX などのエンジニアリング関数とほぼ等しく、与えられた 10 進数に対応する 16 進数を返します。また、文字を ASCII コード値に変換したり、ASCII コード値を対応する文字に変換するときも使用されます。

  • [関数] : この Functoid は、数値を科学値に変換します。たとえば、コサイン Functoid はフィールドまたはレコードから値を取得し、コサインがその値となる角度をラジアンで返します。

  • [累積] : この Functoid は、ループ レコードの合計、平均、最小、または最大入力を返します。

  • [データベース] : この Functoid では、データベースからデータを抽出します。

  • [高度] : このタブには、カスタム Microsoft Visual Basic スクリプトを使用可能な Functoid、値のマッピング用の Functoid、およびレコード ループの情報の管理と抽出用の Functoid があります。

独自のカスタム Functoid を作成することもできます。カスタム Functoid のサンプルは、BizTalk Server をサーバー インストールしたコンピュータ、または BizTalk Server のカスタム インストールでメッセージ処理のサンプルもインストールしたコンピュータの、Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid フォルダにあります。

ここには次のトピックが含まれます。

  • Functoid をカスケードしての使用

  • 累積演算を行う Functoid の使用

  • データベース操作を行う Functoid の使用

  • レコード カウント Functoid の使用

  • インデックス Functoid の使用

  • 繰り返し Functoid の使用

  • 値のマッピング Functoid の使用

  • 値のマッピング (フラット化) Functoid の使用

  • ループ Functoid の使用


Functoid をカスケードしての使用

Functoid をカスケードすると、送信先仕様のフィールドやレコードに必要な出力をするために、フィールドやレコードを複数の Functoid にリンクしなければならないマップを作成できるようになります。Functoid をカスケードすると、複数の連続変換をマッピング グリッドに簡単に作成できます。ある Functoid を別の Functoid にリンクしてから、送信先仕様のレコードまたはフィールドにリンクすると、Functoid がカスケードされます。たとえば、連結された 2 つの文字列を使用して第 3 の文字列を生成し、それを送信先仕様のフィールドに格納するように、Functoid をカスケードすることができます。マッピング グリッド内でカスケードできる Functoid の数に制限はありませんが、複雑なカスケードを行うとパフォーマンスが低下します。


累積演算を行う Functoid の使用

累積演算を行う Functoid は、送信元仕様のレコード レベルのコンテキスト内で実行されます。通常、特定のレコードが 1 つの入力ファイルに何回も発生します。たとえば、注文時には、製品、説明、単価、残量などを含んだ明細が何回も発生します。次のコードは、注文の例を示しています。

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Bits, Bytes, & Chips</To>
<LineItems>
  <Item>
    <Product>TravelLight 400</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>TravelTuff Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>ScreenClean</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

次の図は、この注文が BizTalk エディタに表示された様子を示しています。

図をクリックすると、拡大または縮小します。

Item レコードの [参照] タブで、"最大発生数" プロパティが "*" に設定されていることに注目してください。これは、この Item レコードがループしていることを示しており、BizTalk マッパーはこのレコードをループとしてコンパイルします。

注文のすべての明細の合計を調べ、累計を出力ドキュメントのフィールドにマップするとします。それには、最初に注文の各明細レコードの金額 (単価 x 数量) を計算し、次に注文のすべての明細レコードのマッピングを行いながら、各明細レコードの合計を集計します。

次の図は、乗算 Functoid および累積合計 Functoid を使用して、入力された注文の明細レコードを集計し、その結果を TotalsDocument ドキュメントの POTotal フィールドに出力する様子を示しています。

図をクリックすると、拡大または縮小します。

累積演算を行う Functoid によるマップ

この例では、入力された注文 PurchaseOrder の LineItems レコードにあるすべての Item レコードが、累積操作の対象となります。Price および Quantity フィールドは、乗算 Functoid に渡されます。乗算 Functoid の出力が、累積合計 Functoid の入力になります。入力された注文 PurchaseOrder 内で、Item レコードが次々に累積されるため、累積合計 Functoid の出力は累積された値になります。この値は TotalsDocument ドキュメントの POTotal フィールドに送られ、次のように各製品の単価と数量を累積合計したものになります。(2000x1)+(50x2)+(2x100)=2300

注

  • ある入力の累積集計は、入力リンクの元となった親レコードに対して実行されます。これは、累積演算を行う Functoid の入力データを出力する Functoid でも同じです。

  • 累積演算を行う Functoid は数値以外の入力を無視します。たとえば、"Three" という入力値は無視されます。

累積平均 Functoid、累積最小値 Functoid、および累積最大値 Functoid の動作は、累積合計 Functoid とほぼ同じです。累積文字列 Functoid の動作はほかの累積演算を行う Functoid とは異なり、数値を集計するのではなく、文字列を連結します。

関連項目

累積演算を行う Functoid の追加

累積演算を行う Functoid


データベース操作を行う Functoid の使用

データベース操作を行う Functoid は、データベースからデータを抽出します。データベース操作を行う Functoid の使用方法を理解するため、広い地域に多数の店舗を持つ消費財メーカーを例に考えてみましょう。各店舗には数字コードが割り当てられ、すべての取引先に住所一覧が配布されています。住所一覧は次のような構造になっています。

StoreID: 123

Name:A. Datum Corporation

Address:1234 Main Street

City:Denver, Colorado

PostalCode: 97402

PhoneNumber: 801-555-0179

StoreManager:Anthony Chor

トランザクションで注文に含めて送信されるのは、店舗を表す数字コードだけです。BizTalk マッパーはそのコードを使用して、データベースから住所情報を抽出します。次の図は、その様子を示しています。

図をクリックすると、拡大または縮小します。

データベース操作を行う Functoid によるマップ

この図で、送信元仕様は入力された注文を表し、送信先仕様は請求書を表しています。データベース検索 Functoid データベース検索 Functoid によってデータベース検索が実行され、テーブルからレコードが検索されます。データベース検索 Functoid の出力の接続先にできるのは、値抽出 Functoid 値抽出 Functoid だけです。値抽出 Functoid によって、検索レコードから適切な列名が抽出されます。実行時にエラー （接続失敗など） が発生した場合は、エラー通知 Functoid エラー通知 Functoid からエラー情報が含まれた文字列が出力されます。

データベース検索 Functoid には、次の順序で 4 個の入力パラメータが必要です。

  • 検索する値

  • データベース接続文字列

  • テーブル名

  • 値を検索する列名

入力パラメータの挿入、削除、および移動方法については、「入力パラメータ」を参照してください。

前の例では、第 1 入力パラメータは入力された注文の StoreID フィールドから取得され、残り 3 個の入力パラメータにはデータベース検索 Functoid の [Functoid プロパティ] ダイアログ ボックスの [全般] タブの定数が使用されます。送信元仕様ツリーからリンクを作成し、4 個の入力パラメータに値を指定することも可能です。入力パラメータの挿入、削除、および移動方法については、「入力パラメータ」を参照してください。

値抽出 Functoid には、次の順序で 2 個の入力パラメータが必要です。

  • データベース検索 Functoid へのリンク

  • 列名

エラー通知 Functoid には、データベース検索 Functoid へのリンクが、入力パラメータとして 1 個だけ必要です。

注

  • SQL Server のデータ型には、text、ntext、image などのように、データベース検索 Functoid の検索値として使用できないものがあります。

  • データベース検索 Functoid の入力パラメータと一致するレコードが複数ある場合、値抽出 Functoid はテーブル内で最初に一致したレコードだけを抽出します。

関連項目

データベース操作を行う Functoid

入力パラメータ


レコード カウント Functoid の使用

レコード カウント Functoid は、送信元仕様のレコード レベルのコンテキスト内で実行されます。通常、特定のレコードが 1 つの入力ファイルに何回も発生します。たとえば、注文時には、製品、説明、単価、数量などを含んだ明細が何回も発生します。次のコードは、注文の例を示しています。

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Bits, Bytes, & Chips</To>
<LineItems>
  <Item>
    <Product>TravelLight 400</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>TravelTuff Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>ScreenClean</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

次の図は、この注文が BizTalk エディタに表示された様子を示しています。

図をクリックすると、拡大または縮小します。

Item レコードの [参照] タブで、"最大発生数" プロパティが "*" に設定されていることに注目してください。これは、この Item レコードがループしていることを示しており、BizTalk マッパーはこのレコードをループとしてコンパイルします。

注文の明細の合計数を調べ、その値を出力ドキュメントのフィールドにマップするとします。この環境は、送信元ドキュメントの内容を出力ドキュメントにマップするという、通常のマッピングの環境とは異なっています。その場合、出力ドキュメントにマップする値は、レコード カウント Functoid で生成されます。

レコード カウント Functoid には入力と出力が 1 つずつあります。入力は、送信元仕様のループ レコードからのリンクです。このレコードは、元の入力ドキュメント内に何回も出現します。レコード カウント Functoid の出力は、送信先仕様のフィールドへのリンクです。

次の図は、入力された注文に含まれる明細数をレコード カウント Functoid でカウントし、その値を POReport ドキュメントの Number_Of_Items フィールドに出力する様子を示しています。

図をクリックすると、拡大または縮小します。

レコード カウント Functoid によるマップ

この例では、入力された注文に 3 つの明細があるため、Number_Of_Items フィールドの値は 3 になります。

関連項目

高度 Functoid


インデックス Functoid の使用

インデックス Functoid は、送信元仕様のレコード レベルのコンテキスト内で実行されます。通常、特定のレコードが 1 つの入力ファイルに何回も発生します。たとえば、天気予報では DailySummary セクションが何回も発生します。DailySummary セクションには、気温、気圧、風速などが含まれています。次のコードは、天気予報の例を示しています。

<WeatherReport>
  <DailySummary>
    <Temperature>20</Temperature>
    <Pressure>80</Pressure>
    <WindSpeed>10</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>23</Temperature>
    <Pressure>78</Pressure>
    <WindSpeed>20</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>24</Temperature>
    <Pressure>77</Pressure>
    <WindSpeed>16</WindSpeed>
  </DailySummary>
</WeatherReport>

次の図は、この天気予報が BizTalk エディタに表示された様子を示しています。

図をクリックすると、拡大または縮小します。

DailySummary レコードの [参照] タブで、"最大発生数" プロパティが "*" に設定されていることに注目してください。これは、この DailySummary レコードがループしていることを示しており、BizTalk マッパーはこのレコードをループとしてコンパイルします。

天気予報の中で、最初の 2 つの DailySummary レコードにある情報を集める場合があります。BizTalk マッパーでは、入力された送信元仕様の DailySummary レコードの各フィールドをインデックス Functoid に接続し、第 1 と第 2 のどちらの DailySummary レコードから情報を取り出すかを、各インデックス Functoid で指定できます。そして、送信先仕様の適切なフィールドに、インデックス Functoid を接続します。インデックス Functoid は、送信元仕様の 1 つの親の下にあるフィールドと、送信先仕様の 1 つの親の下にあるフィールドとの間でしか動作しないことに注意してください。

次の図は、このようなインデックス Functoid の使用方法を示しています。

図をクリックすると、拡大または縮小します。

インデックス Functoid のマップ

1 日目の日別情報を取得するには、上の 3 つのインデックス Functoid のインデックス値が 1 になっている必要があります。2 日目の日別情報を取得するには、下の 3 つのインデックス Functoid のインデックス値が 2 になっている必要があります。

インデックス シーケンス入力は、インデックス Functoid のプロパティ シートにある [全般] タブで、入力パラメータとして設定されます。インデックス Functoid をダブルクリックすると、そのプロパティ シートが表示されます。最初の入力パラメータを見ると、このインデックス Functoid にリンクされた送信元仕様のフィールドがわかります。それ以降の入力パラメータは、インデックス値を示しています。

次の図は、前のマップの一番上のインデックス Functoid のプロパティ シートを示しています。

図をクリックすると、拡大または縮小します。

インデックス Functoid のプロパティ

注

  • インデックス Functoid の入力パラメータに数値定数以外の値が割り当てられていると、BizTalk マッパーは値が 1 として解釈します。たとえば上の図で、第 2 入力パラメータを "anystring" という値に置き換えても、マッピング結果は変化しません。

  • 通常、[Functoid プロパティ] ダイアログ ボックスの [全般] タブにあるインデックス シーケンス入力は定数値ですが、入力シーケンス値として送信元仕様のノードからのリンクを使用することも可能です。このリンクが、第 1 入力パラメータの親ではないループしたレコードからのものだった場合、インデックス シーケンス入力値は、入力ドキュメントのノードの第 1 インスタンスから取得されます。

  • インデックス シーケンス入力の値は、送信元ドキュメントの現在のコンテキストに必ず関係しています。.

1 つの入力ファイルに複数の天気予報が含まれていて、各天気予報には複数の日別情報が含まれていた場合、複数のインデックス値を指定する必要があります。次のコードは、複数の天気予報が含まれた入力ファイルの例です。

<WeatherReports>
  <WeatherReport1>
    <DailySummary>
      <Temperature>20</Temperature>
      <Pressure>80</Pressure>
      <WindSpeed>10</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>23</Temperature>
      <Pressure>78</Pressure>
      <WindSpeed>20</WindSpeed>
    </DailySummary>
  </WeatherReport1>
  <WeatherReport2>
    <DailySummary>
      <Temperature>24</Temperature>
      <Pressure>77</Pressure>
      <WindSpeed>16</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>22</Temperature>
      <Pressure>79</Pressure>
      <WindSpeed>21</WindSpeed>
    </DailySummary>
  </WeatherReport2>
</WeatherReports>

2 つのインデックス値を持ち、第 1 インデックスが 1、第 2インデックスが 2 に設定されたインデックス Functoid は、第 2 の天気予報の第 1 の日別情報からフィールド値を取得します。

重要

  • インデックス Functoid は、フィールド レベルからルート ノードの下の第 1 レベルにある親ノードと、同じ数のインデックス値を持つ必要があります。たとえば、複数の天気予報があるサンプル ドキュメントでは、2 つのインデックス値が必要です。天気予報が 1 つのサンプル ドキュメントで必要なインデックス値は、1 つだけです。設定したインデックス Functoid のインデックス値が必要な個数に達していない場合は、インデックス Functoid の最初の入力パラメータと一致する、送信元ドキュメントの最初のノードに基づいて出力が生成されます。

関連項目

高度 Functoid


繰り返し Functoid の使用

繰り返し Functoid は、ある時間にマップされる予定のループ レコードのシーケンス番号を識別します。次の図は、等号 Functoid と組み合わせて使用した繰り返し Functoid を示しています。

図をクリックすると、拡大または縮小します。

繰り返し Functoid のマップ

送信先仕様の 2 つのレコードそれぞれに対して、Functoid の組 (繰り返し Functoid 繰り返し Functoid と等号 Functoid 等号 Functoid) があります。次の図は、一番上の等号 Functoid のプロパティ シートを示しています。

図をクリックすると、拡大または縮小します。

一番上の等号 Functoid のプロパティ シート

次のコードは、送信先仕様の構造を確認する入力ドキュメント インスタンスの例です。

<Root>
<Record1 Field1="A"/>
<Record1 Field1="B"/>
</Root>

入力ドキュメント インスタンスの中で、送信元仕様がループしていって、第 1 レコードがマップされているときに、繰り返し Functoid は "1" を返し、第 2 レコードがマップされているときは、"2" を返します。等号 Functoid は、2 つの入力パラメータが等しい場合、値 "true" を返します。その結果、入力ドキュメント インスタンスの第 1 レコードがマップされているときは、一番上の Functoid のペアは値 "true" を返します。そして、送信先仕様の Record2 に "true" が渡され、Record2 が出力ドキュメントに書き込まれます。一番下の等号 Functoid の第 2 入力パラメータの値が 2 の場合、一番下の Functoid ペアは一番上の Functoid ペアと同様の動作をします。つまり、入力ドキュメント インスタンスの第 2 レコードがマップされると、送信先仕様の Record3 が出力ドキュメント インスタンスに書き込まれます。次のコードは、出力ドキュメント インスタンスを示しています。

<Root2>
<Record2 Field2="A"/>
<Record3 Field3="B"/>
</Root2>

関連項目

高度 Functoid


値のマッピング Functoid の使用

[値のマッピング] Functoid 値のマッピング Functoid には 2 個の入力パラメータが必要で、第 1 パラメータが "true" の場合は、第 2 入力パラメータの値を返します。次の図は、[値のマッピング] Functoid を使用したマップを示しています。

図をクリックすると、拡大または縮小します。

マップを完成させるには、各 Functoid の入力パラメータを設定する必要があります。次の図は、3 つの [値のマッピング] Functoid のプロパティ シートを示しています。

図をクリックすると、拡大または縮小します。

値のマッピング Functoid のプロパティ シート

次の図は、一番上の等号 Functoid のプロパティ シートを示しています。

図をクリックすると、拡大または縮小します。

等号 Functoid のプロパティ シート

中央の等号 Functoid のプロパティ シートは似ていますが、第 2 入力パラメータの値が定数値 "Y" になっています。一番下の等号 Functoid のプロパティ シートも似ていますが、第 2 入力パラメータの値が定数値 "Z" になっています。

次の要素が含まれた送信元ドキュメント インスタンスがあるとします。

<Field Name="X" Value="1"/>

Name の値 "X" によって、このマップの一番上の等号 Functoid は値 "true" を返します。また、等号 Functoid から値 "true" が返されることによって、リンクされた属性値 Functoid は値 1 を返します。

次のコードは、このマップの送信元仕様に対応するドキュメント インスタンスの例です。

<Root>
  <Record>
    <Field Name="X" Value="1"/>
    <Field Name="Y" Value="2"/>
    <Field Name="Z" Value="3"/>
  </Record>
  <Record>
    <Field Name="X" Value="4"/>
    <Field Name="Y" Value="5"/>
    <Field Name="Z" Value="6"/>
  </Record>
  <Record>
    <Field Name="X" Value="7"/>
    <Field Name="Y" Value="8"/>
    <Field Name="Z" Value="9"/>
  </Record>
</Root>

このマップおよびこの送信元ドキュメント インスタンスを使用することで、BizTalk Server は次のドキュメント インスタンスを出力します。

<Root>
<Record X="1"/>
<Record Y="2"/>
<Record Z="3"/>
<Record X="4"/>
<Record Y="5"/>
<Record Z="6"/>
<Record X="7"/>
<Record Y="8"/>
<Record Z="9"/>
</Root>

重要

  • [値のマッピング] Functoid で入力として使用できるのは、小文字の文字列 "true" および "false" という形式のブール型入力だけです。たとえば、入力ドキュメント インスタンスのフィールドが "True" という値を持ち、それが [値のマッピング] Functoid の第 1 入力パラメータに直接リンクされている場合、[値のマッピング] Functoid の第 2 入力パラメータは出力ドキュメントに渡されません。

関連項目

高度 Functoid

値のマッピング (フラット化) Functoid の使用


値のマッピング (フラット化) Functoid の使用

Microsoft Commerce Server では、Commerce Server カタログからフラット スキーマへマップすることがよくあります。[値のマッピング (フラット化)] Functoid を使用すると、この種類のマッピングが可能になります。次のコードは、Commerce Server カタログの例です。

<Root>
  <Record>
    <Field Name="X" Value="1"/>
    <Field Name="Y" Value="2"/>
    <Field Name="Z" Value="3"/>
  </Record>
  <Record>
    <Field Name="X" Value="4"/>
    <Field Name="Y" Value="5"/>
    <Field Name="Z" Value="6"/>
  </Record>
  <Record>
    <Field Name="X" Value="7"/>
    <Field Name="Y" Value="8"/>
    <Field Name="Z" Value="9"/>
  </Record>
</Root>

次のコードは、フラット スキーマの例です。

<Root>
  <Record X="1" Y="2" Z="3"/>
  <Record X="4" Y="5" Z="6"/>
  <Record X="7" Y="8" Z="9"/>
</Root>

このマッピングのシナリオでは、カタログ内の 3 つのレコードとフラット スキーマ内の 3 つのレコードとの間の、1 対 1 の対応関係を維持することが重要です。次の図は、この対応関係を維持するマップを示しています。

図をクリックすると、拡大または縮小します。

値のマッピング (フラット化) Functoid

このマップで、送信元仕様は入力するカタログの構造を表し、送信先仕様は出力するフラット スキーマの構造を表しています。3 つのレコードそれぞれに対して、Functoid のペア (等号 Functoid 等号 Functoid と [値のマッピング (フラット化)] Functoid 値のマッピング (フラット化) Functoid) が存在しています。次の図は、3 つの [値のマッピング (フラット化)] Functoid ごとのプロパティ シートを示しています。

図をクリックすると、拡大または縮小します。

値のマッピング (フラット化) Functoid のプロパティ シート

次の図は、一番上の等号 Functoid のプロパティ シートを示しています。

図をクリックすると、拡大または縮小します。

等号 Functoid のプロパティ シート

中央の等号 Functoid のプロパティ シートは似ていますが、第 2 入力パラメータの値が定数値 "Y" になっています。一番下の等号 Functoid のプロパティ シートも似ていますが、第 2 入力パラメータの値が定数値 "Z" になっています。

一番上の Functoid ペアが連携して動作することで、カタログ内の 3 つのレコードそれぞれからフラット スキーマ内の 3 つのレコードそれぞれに対して、値 X が渡されます。[値のマッピング (フラット化)] Functoid が、自分のプロパティ シートの第 2 パラメータの値を返すのは、第 1 パラメータの値が "true" の場合だけです。.そのため、一番上の [値のマッピング (フラット化)] Functoid が /Root/Record/Field/@Value の値を返すのは、リンク先の等号 Functoid が値 "true" を返す場合だけです。リンク先の等号 Functoid は、入力されたカタログの中で Name 値が X になっているフィールドだけに対して、値 "true" を返します。

中央の Functoid ペアの等号 Functoid は、入力されたカタログの中で Name 値が Y になっているフィールドだけに対して、値 "true" を返します。そのため、カタログ内の 3 つのレコードそれぞれからフラット スキーマ内の 3 つのレコードそれぞれに値 Y が渡されることが、この Functoid ペアによって保証されます。一番下の Functoid ペアは、同様の方法で値 Z を処理します。

重要

  • [値のマッピング (フラット化)] Functoid で入力として使用できるのは、小文字の文字列 "true" および "false" という形式のブール型入力だけです。たとえば、入力ドキュメント インスタンスのフィールドが "True" という値を持ち、それが [値のマッピング (フラット化)] Functoid の第 1 入力パラメータに直接リンクされている場合、[値のマッピング (フラット化)] Functoid の第 2 入力パラメータは出力ドキュメントに渡されません。

注

  • 入力ドキュメント インスタンス内のレコードに、このマッピング環境の等号 Functoid のどれか 1 つの第 2 入力パラメータと一致する属性を持つ、複数のフィールドがある場合、一致したものの中で最後のレコードだけが出力ドキュメントにマップされます。たとえば、この Commerce Server カタログの例で、第 1 Record に 3 つの Field があって、それらの Name 属性が X という値を持っている場合、最後の Field だけがマップされます。

フラット スキーマから Commerce Server カタログへのマッピング (このマッピングのシナリオとは逆方向のマッピング) の詳細については、「ループ Functoid の使用」を参照してください。

関連項目

高度 Functoid

ループ Functoid の使用

値のマッピング Functoid の使用


ループ Functoid の使用

ループ Functoid ループ Functoid は、送信元仕様内の複数のレコードやフィールドを結合し、送信先仕様内の 1 つのレコードにするために使用されます。次の図は、このようなループ Functoid の使用方法を示しています。

図をクリックすると、拡大または縮小します。

ループ Functoid によるマップ

[プロパティ] タブの [送信元の属性] および [送信先の属性] で、"最大発生数" が "*" に表示されていることからわかるとおり、送信元仕様の BillTo レコードおよび送信先仕様の Addresses レコードはループしています。この例では、送信元仕様の ShipTo および Header レコードもループしています。入力ドキュメント インスタンスに 3 つの BillTo レコードと 2 つの ShipTo レコードがある場合、ループ Functoid はそれらを結合し、出力ドキュメント内に 5 つの Addresses レコードを作成します。

次のコードは、入力ドキュメント インスタンスのサンプルです。

<Root>
<BillTo Name="Kim Yoshida" Address="345 North 63rd Street"
City="Boston" PostalCode="07458"></BillTo>
<BillTo Name="Michelle Votava" Address="7890 Broadway"
City="Columbus" PostalCode="46290"></BillTo>
<BillTo Name="Tanya Van Dam" Address="1234 Main Street"
City="Denver" PostalCode="97402"></BillTo>
<ShipTo Name="Patricia Esack" Address="456 First Avenue"
City="Miami" PostalCode="81406"></ShipTo>
<ShipTo Name="Peter Kress" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103"></ShipTo>
<Header ID="01"></Header>
<Header ID="02"></Header>
<Header ID="03"></Header>
</Root>

入力ドキュメント インスタンスの前に、上の図に示したマップが記述されていると、この入力ドキュメント インスタンスによって、次の出力ドキュメント インスタンスが生成されます。

<Root>
<Addresses Name="Kim Yoshida" Address="345 North 63rd Street"
City="Boston" PostalCode="07458" ID="01" />
<Addresses Name="Michelle Votava" Address="7890 Broadway"
City="Columbus" PostalCode="46290" ID="01" />
<Addresses Name="Tanya Van Dam" Address="1234 Main Street"
City="Denver" PostalCode="97402" ID="01" />
<Addresses Name="Patricia Esack" Address="456 First Avenue"
City="Miami" PostalCode="81406" ID="01" />
<Addresses Name="Peter Kress" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103" ID="01" />
</Root>

出力ドキュメント インスタンス内に作成された各 Addresses レコードは、ID フィールドの値が "01" になります。それは、Header レコードがループ Functoid に接続されていないからです。入力ドキュメント インスタンスの最初の ID フィールド値は、出力ドキュメント インスタンスに作成された各レコードに渡されます。

重要

  • 条件によっては、ループ Functoid を持つマップ内で使用された、一部の Functoid が期待どおりに動作しないことがあります。Functoid が次の条件に該当している場合、その Functoid からは期待どおりの結果が得られません。
    • Functoid に、複数の送信元仕様リンクがある。

    • Functoid の送信元仕様リンクの中で、ループ Functoid の入力レコードの子フィールドにリンクされているものが 2 つ以上ある。その子フィールドどうしは親が異なる。

    • Functoid に、ループ Functoid の出力レコードの子フィールドにリンクされた送信先仕様リンクがある。

    これらの条件に適合する Functoid を前のマップに追加した場合、その Functoid は、BillTo レコードの Name フィールドに接続された送信元仕様リンク、ShipTo レコードの Name フィールドに接続されたもう 1 つの送信元仕様リンク、および Addresses レコードの Name フィールドに接続された送信先仕様リンクを持つことになります。

フラット スキーマから Commerce Server カタログへのマッピング

ループ Functoid を使用すると、フラット スキーマを Microsoft Commerce Server カタログへマッピングできます。フラット スキーマおよび Commerce Server カタログの詳細については、「値のマッピング (フラット化) Functoid の使用」を参照してください。

次の図は、フラット スキーマから Commerce Server カタログへのマップを示しています。

図をクリックすると、拡大または縮小します。

重要

  • このマップが正常に動作するためには、次のことを行う必要があります。
    • 送信先仕様の Name フィールドに接続された各リンクでは、名前をコピーするように送信元仕様リンク プロパティを設定します。詳細については、「送信元仕様リンクのコンパイラ プロパティの選択」を参照してください。

    • 送信先仕様の Value フィールドに接続された各リンクでは、値をコピーするように送信元仕様リンク プロパティを設定します。詳細については、「送信元仕様リンクのコンパイラ プロパティの選択」を参照してください。

    • ループ Functoid を送信先仕様の Field という名前のレコードに接続するリンクでは、トップダウン型リンク対応を行うように送信先仕様リンク プロパティを設定します。詳細については、「送信先仕様リンクのコンパイラ プロパティの選択」を参照してください。

    • [BizTalk マッパーのオプション] ダイアログ ボックスの [送信先ツリー ノードへ複数の入力を許可] を必ずオンにします。詳細については、「BizTalk マッパーのオプション : [全般] タブ」を参照してください。

関連項目

BizTalk マッパーのオプション: [全般] タブ

送信先仕様リンクのコンパイラ プロパティの選択

送信元仕様リンクのコンパイラ プロパティの選択

値のマッピング (フラット化) Functoid の使用


マップのコンパイル

マップをコンパイルする場合、変換のグラフィカルな表現は BizTalk マッパーのコンパイラ コンポーネントによって作成されます。このコンポーネントは、実行時の Extensible Stylesheet Language (XSL) スタイル シートも生成します。このプロセスでマップが作成されます。マップをコンパイルすることで、マッピング グリッド内で指定された構造化ルールおよび変換が使えるようになります。リンクなどの変換は、送信元構造のインスタンス内にレコードおよびフィールドが出現している順序と、同じ順序で処理されます。たとえば、BizTalk マッパーは関連付けられたリンクを持つ送信元レコードまたはフィールドを発見すると、そのリンクのプロパティを集めます。その動作は、送信先仕様のレコードやフィールドに値を代入するだけの単純なコピーである可能性も、または送信元のいくつかのレコードやフィールドから、送信先のいくつかのレコードやフィールドへの、Functoid のプロパティを使用しての値の計算である可能性もあります。各リンクの実行は、ほかのリンクの実行とは無関係に行われます。

コンパイラで不正な出力が生成されるような状態が発生すると、BizTalk マッパーは [警告] タブに警告を表示します。たとえば、入力パラメータが 1 個必要な Functoid にパラメータが入力されなかった場合、BizTalk マッパーはマップのコンパイル時に [警告] タブに警告を表示します。実務環境で使用するマップは、警告が発生しない状態になっている必要があります。

コンパイル処理では、リンクおよびオブジェクトのすべての内容と機能など、送信元仕様と送信先仕様に関するすべての情報が保存されます。コンパイルされたマップは BizTalk Server で使用され、入力インスタンスから出力インスタンスへの、実際のトランザクションが実行されます。

関連項目

ノードと階層レベルの対応


マップのテスト

マップを作成した場合、自分が設計したマップが正しい出力を生成するかどうかを、BizTalk マッパーを使用して確認できます。[マップのテスト] 機能を使用すると、送信元ドキュメントのテスト インスタンスが、仕様から自動的に生成されます。この機能では、レコードの発生数、フィールドのデータの種類などの情報が仕様から確認され、テスト インスタンスが生成されます。[値] タブの [送信元テスト値] ボックスで、任意のレコードまたはフィールドに対してさまざまな値を指定すると、そのデータの結果をテストできます。

マップをテストするとき、BizTalk マッパーは自動的にそのマップをコンパイルします。しかし、先にマップをコンパイルし、警告やエラーを解消してからテストするようにしてください。テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。テスト前にファイルを保存しておくと、万一マップに問題が起きても、データを元に戻せます。

マップのテストが終わると、[出力] タブに結果が表示されます。テスト データは、送信先仕様に対応しています。

注

  • BizTalk マッパーのマップ テスト機能が備えているのは、自動生成されたテスト用ドキュメント インスタンスに対してマップをテストする機能のみです。テスト用のドキュメント インスタンスは、送信先仕様に基づいて BizTalk マッパーが生成します。このため、BizTalk マッパーでは、ビジネス ドキュメントを選択し、そのドキュメントのインスタンスを使用してマップをテストすることはできません。ただし、BizTalk Server と共に提供されているサンプルのマップ テスト用スクリプトを利用すれば、選択したドキュメント インスタンスを使用してマップをテストできます。詳細については、リリース ノート (\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\MapTest\Readme.txt) を参照してください。

関連項目

Functoid のテスト

リンクのテスト

リンクのあるレコードまたはフィールドのプロパティのテスト


参考資料

ここには次のトピックが含まれます。

  • 表示のカスタマイズ

  • 文字列処理を行う Functoid

  • 数値演算を行う Functoid

  • 論理演算を行う Functoid

  • 日時処理を行う Functoid

  • 変換を行う Functoid

  • 関数演算を行う Functoid

  • 累積演算を行う Functoid

  • データベース操作を行う Functoid

  • 高度 Functoid

  • BizTalk サービスの統合に使用するマップ


表示のカスタマイズ

BizTalk マッパーの外観は、いくつかの方法でカスタマイズできます。たとえば、マッピング グリッドの背景色を変更したり、リンクや選択したオブジェクトに対して新しい色を指定したり、コンパイラの警告の色を変更したり、文字サイズを変更するなどが可能です。カスタマイズできる項目は次のとおりです。

  • [グリッドの前景色] : マッピング グリッドの点線

  • [グリッドの背景色] : マッピング グリッドの背景色

  • [固定リンク] : マッピング グリッドの値コピー リンク

  • [柔軟なリンク] : 送信元仕様ツリーから送信先仕様ツリーへドラッグされた値コピー リンク

  • [部分的なリンク] : 親レコード ノードが折りたたまれたフィールドまたはレコードへのリンク

  • [コンパイラ リンク] : 送信元仕様ツリーのフィールドから送信先仕様ツリーのフィールドへリンクが設定されたときに、自動的に作成されるコンパイラ ディレクティブ リンク

  • [選択したオブジェクト] : 選択したオブジェクトとそのリンク

これらは、[ツール] メニューの [オプション] ダイアログ ボックスで変更できます。文字サイズの変更は、[表示] メニューでも行えます。

関連項目

BizTalk マッパーのオプション : [色] タブ


文字列処理を行う Functoid

Functoid パラメータ
文字列位置検出 Functoid 文字列位置検出

指定された別の文字列が始まる文字列位置を返します。

 この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクする 1 番目の文字列から 2 番目の文字列のある位置を探します。
左文字列抽出 Functoid 左文字列抽出

テキスト項目の一番左の文字から順に、指定された文字数だけ返します。

 この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクする 1 番目のフィールドは出力する文字列を指定します。この Functoid にリンクする 2 番目のフィールドは出力する文字数を指定します。出力結果は、Functoid にリンクした最初のフィールドの文字列のサブセットです。
小文字変換 Functoid 小文字変換

テキスト項目を小文字に変換します。

 この Functoid には 1 個の入力パラメータが必要です。
右文字列抽出 Functoid 右文字列抽出

テキスト項目の一番右の文字から順に、指定された文字数だけ抽出します。

 この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクする 1 番目のフィールドは出力する文字列を指定します。この Functoid にリンクする 2 番目のフィールドは出力する文字数を指定します。出力結果は、Functoid にリンクした最初のフィールドの文字列のサブセットです。
文字列長算出 Functoid 文字列長算出

文字列の長さを整数値で返します。

 この Functoid には 1 個の入力パラメータが必要です。出力結果は入力フィールドに含まれるデータの文字数を表したものです。
文字列抽出 Functoid 文字列抽出

上位文字列の開始位置と終了位置を指定し、文字列を抽出します。

 この Functoid には 3 個の入力パラメータが必要で、そのうちの 1 個は文字列でなければなりません。

この Functoid へのフィールドのリンク付けは、次の順序で行う必要があります。

  1. 文字列フィールド

  2. 開始位置フィールド

  3. 終了位置フィールド
連結 Functoid 連結

連続する入力文字列を連結します。

 この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限がありません。
文字列左スペース削除 Functoid 文字列左スペース削除

テキスト項目から先頭のスペースを削除します。

 この Functoid には 1 個の入力パラメータが必要です。
文字列右スペース削除 Functoid 文字列右スペース削除

テキスト項目から末尾のスペースを削除します。

 この Functoid には 1 個の入力パラメータが必要です。
大文字変換 Functoid 大文字変換

テキスト項目を大文字に変換します。

 この Functoid には 1 個の入力パラメータが必要です。


数値演算を行う Functoid

Functoid | パラメータ
絶対値算出 Functoid 絶対値算出 数値の絶対値を返します。 | この Functoid には 1 個の入力パラメータが必要です。 実際の入力値に関係なく、最終値は常に正です。
整数部抽出 Functoid 整数部抽出 数値の整数部を返します。 | この Functoid には 1 個の入力パラメータが必要です。 この Functoid は、数値の小数点以下を切り捨てます。
最大値算出 Functoid 最大値算出 一連の数値の中で最大値を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
最小値算出 Functoid 最小値算出 一連の数値の中で最小値を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
剰余 Functoid 剰余 整数で数値を除算した後の剰余を返します。 | この Functoid には 2 個の入力パラメータが必要です。この Functoid は、整数除算の剰余を返します。この Functoid は、出荷数量などについて、規定積載量に満たない値を計算するときに役に立ちます。
四捨五入 Functoid 四捨五入 指定された小数点以下の桁数に数値を四捨五入します。小数点以下の桁数が指定されない場合は、整数に四捨五入します。 | この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクしている 1 番目のパラメータは値を表し、2 番目のパラメータは四捨五入する小数点以下の桁数を表します。この Functoid は、標準の計算規則に基づいて、四捨五入を行います。
平方根算出 Functoid 平方根算出 数値の平方根を返します。 | この Functoid には 1 個の入力パラメータが必要です。
加算 Functoid 加算 一連の数値の合計を計算します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
減算 Functoid 減算 1 つの数値をほかの数値から引き算します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
乗算 Functoid 乗算 1 つの数値をほかの数値で乗算します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
除算 Functoid 除算 1 つの数値をほかの数値で除算します。 | この Functoid には 2 個の入力パラメータが必要です。この Functoid は、実数や整数に使用できます。


論理演算を行う Functoid

Functoid | パラメータ
より大きい Functoid より大きい 1 つ目のパラメータが 2 つ目のパラメータより大きいときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
以上 Functoid 以上 1 つ目のパラメータが 2 つ目のパラメータ以上のときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
より小さい Functoid より小さい 1 つ目のパラメータが 2 つ目のパラメータより小さいときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
以下 Functoid 以下 1 つ目のパラメータが 2 つ目のパラメータ以下のときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
等号 Functoid 等号 1 つ目のパラメータが 2 つ目のパラメータと等しいときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
不等号 Functoid 不等号 1 つ目のパラメータが 2 つ目のパラメータと等しくないときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
文字列検査 Functoid 文字列検査 パラメータが文字列値のときに TRUE を返します。 | この Functoid には 1 個の入力パラメータが必要です。
日付検査 Functoid 日付検査 パラメータが日付値のときに TRUE を返します。 | この Functoid には 1 個の入力パラメータが必要です。
数値検査 Functoid 数値検査 パラメータが数値のときに TRUE を返します。 | この Functoid には 1 個の入力パラメータが必要です。
論理和 Functoid 論理和 パラメータの論理和を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
論理積 Functoid 論理積 パラメータの論理積を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。


日時処理を行う Functoid

Functoid | パラメータ
日数加算 Functoid 日数加算 指定した日数を日付に加えます。 | この Functoid には 2 個の入力パラメータが必要です。1 番目のリンクには、入力値として日付情報が必要です。2 番目のリンクで、日付に加える日数を決定します。
日付 Functoid 日付 現在の日付を返します。 | この Functoid には入力パラメータは必要ありません。 出力書式は YYYY-MM-DD です。
時刻 Functoid 時刻 現在の時刻を返します。 | この Functoid には入力パラメータは必要ありません。 出力書式は HH:MM:SS です。
日時 Functoid 日時 現在の日付と時刻を返します。 | この Functoid には入力パラメータは必要ありません。 出力書式は YYYY-MM-DDTHH:MM:SS です。


変換を行う Functoid

Functoid | パラメータ
文字の ASCII 値算出 Functoid 文字の ASCII 値算出 文字の ASCII コード値を返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、基本 ANSI コード値に変換します。例 : a=97
値の ASCII 文字化 Functoid 値の ASCII 文字化 指定した ASCII コード値に対応する文字を返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、値を ANSI コード値に対応する文字に変換します。例 : 98=b
16 進変換 Functoid 16 進変換 10 進数の値を 16 進数にして返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は 10 進数を 16 進数に変換します。例 : 10=A
8 進変換 Functoid 8 進変換 10 進数の値を 8 進数にして返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、10 進数を 8 進数に変換します。例 : (8 進数 0-7)、8=10、および 10=12


関数演算を行う Functoid

Functoid | パラメータ
アーク タンジェント Functoid アーク タンジェント 数値のアーク タンジェントを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
コサイン Functoid コサイン 数値のコサインを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
サイン Functoid サイン 数値のサインを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
タンジェント Functoid タンジェント 数値のタンジェントを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
自然指数関数 Functoid 自然指数関数 e を指定した回数だけべき乗して返します。 | この Functoid には 1 個の入力パラメータが必要です。
自然対数 Functoid 自然対数 値の対数 (底 e) を返します。 | この Functoid には 1 個の入力パラメータが必要です。
10^X 10 を指定した回数だけべき乗して返します。 | この Functoid には 1 個の入力パラメータが必要です。
常用対数 Functoid 常用対数 値の対数 (底 10) を返します。 | この Functoid には 1 個の入力パラメータが必要です。
X^Y 値を指定した回数だけべき乗して返します。 | この Functoid には 2 個の入力パラメータが必要です。
底指定対数 Functoid 底指定対数 値の対数 (指定した底) を返します。 | この Functoid には 2 個の入力パラメータが必要です。


累積演算を行う Functoid

Functoid | パラメータ
累積合計 Functoid 累積合計 親レコードを反復することで、接続されているフィールドのすべての値を合計します。 | この Functoid には 1 個の入力パラメータが必要です。
累積平均 Functoid 累積平均 親レコードを反復することで、接続されているフィールドのすべての値の平均値を計算します。 | この Functoid には 1 個の入力パラメータが必要です。
累積最小値 Functoid 累積最小値 親レコードにまたがる入力の最小値を返します。 | この Functoid には 1 個の入力パラメータが必要です。
累積最大値 Functoid 累積最大値 親レコードにまたがる入力の最大値を返します。 | この Functoid には 1 個の入力パラメータが必要です。
累積文字列 Functoid 累積文字列 親レコードを反復することで、接続されているフィールドの文字列値を結合した文字列を返します。 | この Functoid には 1 個の入力パラメータが必要です。


データベース操作を行う Functoid

Functoid | パラメータ
データベース検索 Functoid データベース検索 指定された値を求めてデータベース検索を実行し、その値を含むレコードを取得して ADO レコード セットとして格納します。 | この Functoid には 4 個の入力パラメータが必要です。
値抽出 Functoid 値抽出 データベース検索 Functoid により取得された ADO レコード セットの特定の列から値を返します。 | この Functoid には 2 個の入力パラメータが必要です。
エラー通知 Functoid エラー通知 データベース検索 Functoid を使用したときに ODBC から返されたエラー文字列を返します。 | この Functoid には 1 個の入力パラメータが必要です。


高度 Functoid

Functoid | パラメータ
スクリプト Functoid スクリプト 独自に作成したスクリプトによる、カスタム機能を使用できます。 | この Functoid に対する入力パラメータ数は、カスタム スクリプトを記述することで構成可能です。
レコード カウント Functoid レコード カウント インスタンス内で発見されたレコードの総数を返します。 | この Functoid には 1 個の入力パラメータが必要です。
インデックス Functoid インデックス 指定したインデックスにある、レコードまたはフィールドの値を返します。 | この Functoid には少なくとも 2 個の入力パラメータが必要です。入力パラメータの最大数は、仕様階層におけるレベルの個数によって制限されます。
繰り返し Functoid 繰り返し ソース レコードの (ループ内の) 繰り返し回数を返します。 | この Functoid には 1 個の入力パラメータが必要です。
値のマッピング Functoid 値のマッピング 1 つ目のパラメータの値が true のとき、2 つ目のパラメータの値を返します。 | この Functoid には 2 個の入力パラメータが必要です。
値のマッピング (フラット化) Functoid 値のマッピング (フラット化) 1 つ目のパラメータの値が true のときに 2 つ目のパラメータの値を返し、送信元のドキュメント階層をフラット化します。 | この Functoid には 2 個の入力パラメータが必要です。
ループ Functoid ループ 各入力レコードを反復することで、複数の出力レコードを作成します。 | この Functoid には入力パラメータが少なくとも 1 個必要です。入力パラメータの最大数には制限がありません。


BizTalk サービスの統合に使用するマップ

非 HTTP トランスポートを使用して BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合する場合、マップ を作成して、パス名を書式名に変換する必要があることがあります。詳細については、「BizTalk サービスの統合」を参照してください。

パス名の書式名への変換

次のコードは、メッセージ キューのパス名の例を示しています。

private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

このパス名を書式名に変換するには、次の文字列をパス名の先頭に追加します。

queue://Direct=OS:

連結 Functoid を使用すると、この処理を簡単にできます。

次の図は、連結 Functoid を使用して 2 つ以上の文字列を連結するマップを示しています。連結 Functoid の詳細については、「文字列処理を行う Functoid」を参照してください。

図をクリックすると、拡大または縮小します。

連結 Functoid をダブルクリックすると、そのプロパティが表示されます。次の図は、パス名 private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73} の前に queue://Direct=OS: を追加するマップ内の連結 Functoid のプロパティがどのようになるかを示しています。

詳細については、「Functoid のプロパティの編集」を参照してください。

図をクリックすると、拡大または縮小します。

連結 Functoid のプロパティ


BizTalk エディタと BizTalk マッパーのトラブルシューティング

ここでは、次の内容について説明します。

  • リモート WebDAV サーバーに接続する際にパスワードが要求される

  • WebDAV への接続またはファイルの格納ができない

  • ???.xml が WebDAV ダイアログ ボックスに表示される

  • [WebDAV から取得] ダイアログ ボックスに BizTalkServerRepositoryMaps フォルダが表示される

  • [WebDAV から取得] または [WebDAV に格納] ダイアログ ボックスが空になっている

  • http://localhost に接続できない

  • BizTalk Server に送信したフラット ファイルが完全には解析されない

  • BizTalk Server にフラット ファイルを送信すると空白が削除される

  • マップのテストが失敗する

  • DTD のインポートが失敗する

  • [日付] または [時刻] フィールドを使用するとインスタンスの検証が失敗する


リモート WebDAV サーバーに接続する際にパスワードが要求される

原因 : ユーザーが BizTalkServerRepository フォルダへのアクセス権を持っていない可能性があります。

解決策 : ユーザーに BizTalkServerRepository フォルダへのアクセス権を付与します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット サービス マネージャ] をクリックします。

  2. コンソール ツリーでコンピュータの名前を展開します。

  3. [既定の Web サイト] を展開します。

  4. [BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

  5. [ディレクトリ セキュリティ] タブをクリックします。

  6. [匿名アクセスおよび認証コントロール] の [編集] をクリックします。

  7. [匿名アクセス] チェック ボックスをオンにし、[OK] を 2 回クリックします。


WebDAV への接続またはファイルの格納ができない

原因 1 :WebDAV からマップや仕様を取得したり、WebDAV にこれらを格納する際に、次のいずれかのメッセージが表示されることがあります。

WebDAV リポジトリにファイルを格納できません。この時点ではサーバーを利用できない可能性があります。

現在の範囲には、指定された特性に一致するキーがありません。

このメッセージは、Web サーバーのユーザー アカウントの匿名設定で、リポジトリを提供する Microsoft Windows 2000 のディレクトリに書き込み権限が設定されていない場合に表示されます。

解決策 : ユーザーにリポジトリへのアクセス権を付与します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  2. Microsoft BizTalk Server 2000 をインストールした場所に移動します。

  3. [Microsoft BizTalk Server] ディレクトリを展開します。[BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

  4. [セキュリティ] タブをクリックします。

  5. [追加] をクリックし、リポジトリへのアクセス許可を付与するユーザーのドメイン名とユーザー名を domain name\user name の形式で入力します。

  6. [OK] を 2 回クリックします。

原因 2 :WebDAV からマップや仕様を取得したり、WebDAV にこれらを格納する際に、次のメッセージが表示されることがあります。

BizTalk Server リポジトリが http://localhost/BizTalkServerRepository/DocSpecs に見つかりませんでした。別のサーバー名を入力して WebDAV 接続を再試行してください。

このメッセージは、Web サーバーで FrontPage Server Extensions が有効になっている場合に表示されます。

解決策 : FrontPage Server Extensions を無効にします。World Wide Web Publishing Service を実行している場合は、サービスをいったん停止し再起動します。

注

  • この問題は、WebDAV リポジトリを提供するコンピュータで World Wide Web Publishing Service を実行していなくても発生する場合があります。

FrontPage Server Extensions を無効にするには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット サービス マネージャ] をクリックします。

  2. 詳細ペインでご使用のコンピュータ名をダブルクリックします。次に [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [既定の Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [Server Extensions] タブの [作成を有効にする] チェック ボックスをオフにし、[OK] をクリックします。

World Wide Web Publishing Service を停止し再起動するには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[コンポーネント サービス] をクリックします。

  2. コンソール ツリーで [サービス (ローカル)] をクリックします。

  3. 詳細ペインで [World Wide Web Publishing Service] を右クリックし、[停止] をクリックします。

  4. [World Wide Web Publishing Service] を右クリックし、[開始] をクリックします。


???.xml が WebDAV ダイアログ ボックスに表示される

原因 : コンピュータが表示する文字は、BizTalk Server で指定したロケール設定に依存します。

解決策 : BizTalk Server で指定したロケール設定と同じ文字セットを使用中のコンピュータに指定します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックします。

  2. [地域のオプション] をダブルクリックします。

  3. [全般] タブの [システムの言語設定] で必要な言語のチェック ボックスをオンにし、[既定値に設定] をクリックします。

    [システム ロケールの選択] ダイアログ ボックスが表示されます。

  4. 一覧から適切なロケールを選択し、[OK] を 2 回クリックします。

    [地域のオプションの変更] ダイアログ ボックスが表示されます。

  5. [はい] をクリックして変更を確定し、コンピュータを再起動します。

注

  • コンピュータを再起動すると、[地域のオプション] ダイアログ ボックスで選択した言語に "(既定)" という情報が表示されます。

関連項目

マップの格納

仕様の格納


[WebDAV から取得] ダイアログ ボックスに BizTalkServerRepositoryMaps フォルダが表示される

原因 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスの [ローカル パス] ボックスの末尾に円記号があります。

解決策 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスの [ローカル パス] ボックスで、末尾の円記号を削除します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[コンピュータの管理] をクリックします。

  2. [コンピュータの管理] コンソールで [サービスとアプリケーション] を展開します。次に、[インターネット インフォメーション サービス] を展開し、[既定の Web サイト] を展開します。

  3. [BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

  4. [BizTalkServerRepository のプロパティ] ダイアログ ボックスの [ローカル パス] ボックスで、末尾の円記号を削除し、[OK] をクリックします。

この手順を完了すると、[WebDAV から取得] ダイアログ ボックスから BizTalkServerRepositoryMaps フォルダが削除されます。BizTalkServerRepositoryMaps フォルダは使用できないため、削除することをお勧めします。


[WebDAV から取得] または [WebDAV に格納] ダイアログ ボックスが空になっている

原因 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスでディレクトリの参照が無効になっています。

解決策 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスでディレクトリの参照を有効にします。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット サービス マネージャ] をクリックします。

  2. トラブルシューティングの対象となるコンピュータを展開します。

  3. [既定の Web サイト] を展開します。

  4. [BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

  5. [仮想ディレクトリ] タブで [ディレクトリの参照] チェック ボックスをオンにします。

  6. [読み取り] および [書き込み] チェック ボックスもオンになっていることを確認し、[OK] をクリックします。


http://localhost に接続できない

原因 : [プロキシ サーバーを使用する] チェック ボックスはオンになっていますが、[ローカル アドレスにはプロキシ サーバーを使用しない] チェック ボックスがオンになっていません。

解決策 : [プロキシ サーバーを使用する] チェック ボックスはオンにしたまま、[ローカル アドレスにはプロキシ サーバーを使用しない] チェック ボックスをオンにします。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Internet Explorer] をクリックします。

  2. [ツール] メニューの [インターネット オプション] をクリックします。

  3. [接続] タブをクリックし、[LAN の設定] をクリックします。

  4. [ローカル エリア ネットワーク (LAN) の設定] ダイアログ ボックスの [プロキシ サーバー] で [ローカル アドレスにはプロキシ サーバーを使用しない] チェック ボックスをオンにします。

  5. [OK] を 2 回クリックします。

注

  • このエラーは、http://<コンピュータの名前> に接続する場合は発生しません。


BizTalk サーバーに送信したフラット ファイルが完全には解析されない

原因 : 次のような区切りフラット ファイルを BizTalk Server に送信すると、解析エラーが発生する場合があります。

  • ルート ノードの [フィールド順] プロパティが、[接頭辞] または [接尾辞] に設定されている。

  • ルート ノードの名前が、ファイルに存在する別のノード名の部分文字列になっている。

解決策 : 仕様に存在するノード名の部分文字列とならないようにルート ノードの名前を変更します。


BizTalk Server にフラット ファイルを送信すると空白が削除される

原因 : フラット ファイルを BizTalk Server に送信すると、フィールドの空白が削除される場合があります。これは、基本となる MSXML パーサーでは、[宣言] タブの [種類] が [要素] に設定されたフィールド内の空白は既定で削除されるためです。

解決策 : フラット ファイル内のフィールドに空白を残す必要がある場合は、BizTalk エディタで送信元仕様のフィールドの [宣言] タブにある [種類] を [属性] に設定します。

関連項目

宣言のプロパティの設定


マップのテストが失敗する

原因 : マップをテストする場合、その前に BizTalk マッパーによってマップがコンパイルされます。コンパイル中に警告があった場合、マップのテストが失敗する可能性があります。その場合、次のエラー メッセージが表示されます。

テスト インスタンス ドキュメントを使用した、送信元仕様への XSL 変換に失敗しました。

解決策 : コンパイラのすべての警告を解決した後、マップを再コンパイルします。コンパイラの警告を解決するには、次の手順に従います。

  1. [警告] タブをクリックします。問題を解決する [警告] の行をダブルクリックします。警告メッセージに関連付けられたリンクまたは Functoid が強調表示されます。

  2. 必要に応じて、警告を解決します。

マップを再コンパイルするには

  • [ツール] メニューの [マップのコンパイル] をクリックします。

関連項目

マップのテスト


DTD のインポートが失敗する

原因 : 別のファイルへの外部参照を含むドキュメント型定義 (DTD) をインポートしようとすると、次のメッセージが表示される場合があります。

無効な文字が DTD に見つかりました。

解決策 : DTD をインポートする前に、その内部のすべての外部参照を削除します。


[日付] または [時刻] フィールドを使用するとインスタンスの検証が失敗する

原因 : BizTalk Server で受信ドキュメントのインスタンスの処理中に、[データ型] が [Date [日付]]、[Date Time [日時]]、[Date Time.tx [日時 (タイム ゾーン指定可)]]、[Time [時刻]]、[Time.tz [時刻 (タイム ゾーン指定可)]] のいずれかに設定されている Functoid または送信元フィールドから送信先ノードへのリンクがあり、その送信先ノードに送信されるデータが ISO 8601 以外の形式であった場合、インスタンスの検証が失敗します。

解決策 : [データ型] が [Date [日付]]、[Date Time [日時]]、[Date Time.tz [日時 (タイム ゾーン指定可)]]、[Time [時刻]]、[Time.tz [時刻 (タイム ゾーン指定可)]] のいずれかに設定されている送信先仕様のフィールドにリンクする場合、そのフィールドに Functoid または受信ドキュメントのインスタンスのノードからリンクするデータが ISO 8601 形式であることを確認してください。[データ型] プロパティの各値の正しい ISO 8601 形式を次の表に示します。

[データ型] プロパティ | ISO 8601 形式
Date [日付] | YYYY-MM-DD (1988-04-07)
Date Time [日時] | YYYY-MM-DDTHH:MM:SS (1988-04-07T18:39:09)
Date Time.tz [日時 (タイム ゾーン指定可)] | YYYY-MM-DDTHH:MM:SS-TZH:TZM (1988-04-07T18:39:09-08:00)
Time [時刻] | HH:MM:SS (08:15:27)
Time.tz [時刻 (タイム ゾーン指定可)] | HH:MM:SS-TZH:TZM (08:15:27-05:00)


BizTalk サービスの統合

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合することにより、取引先と複数のトランスポート サービスを使用する内部アプリケーションとの間のドキュメントおよびメッセージの交換を管理することができます。また、次の機能も提供します。

  • 複雑な長時間トランザクションとビジネス プロセスの制御

  • 信頼性の高いドキュメント配信およびメッセージ配信

  • 仕様に対する各ドキュメント インスタンスを確認することによるデータ検証

  • ドキュメントの構造および書式を変換するためのマップを使用したデータ マッピング

  • 暗号化証明書とデジタル署名証明書を使用したデータ セキュリティとデータ インテグリティ

  • 受信確認の生成と照合のサポート

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合する方法はたくさんありますが、ここでは一般的なシナリオを示します。

このシナリオでは、メッセージを生成して取引先の送信先システムに送信するように送信元システムの XLANG スケジュール インスタンスを構成し、取引先からの応答メッセージの受信を待ってから、初期メッセージを送信した XLANG スケジュール インスタンスにその応答メッセージを配信します。この構成を利用する一般的なビジネス プロセスの一例として、注文書を送信し、注文書の請け書を受信してから、処理を続行することなどがあります。

ここでは、HTTP トランスポートと非 HTTP トランスポートを使用して自分の会社と取引先との間でメッセージを交換するのに必要な構成手順について説明します。ただし、同様の構成を使用すると、自分の会社内のアプリケーション間でのメッセージ交換を制御できます。

BizTalk Server 2000 は、初期メッセージを送信する送信元システムと、応答メッセージを送信する発信元システムのどちらとしても機能できるので、ここでは、この両方に必要な構成手順を示します。これにより、必要な構成全体を確認することもできます。

これらの構成を反映する XLANG スケジュールのサンプルとその他の関連ファイルは、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services フォルダにあります。

注

  • BizTalk メッセージ サービスの "メッセージ ポート" と、BizTalk オーケストレーション サービスの "ポート" は、意味が異なります。
    • メッセージ ポートとは、指定したトランスポート サービスを使用して、指定した送信先へドキュメントをトランスポートすることを BizTalk メッセージ サービスに指示する一連のプロパティです。

    • ポートとは、特定の実装を使用する名前付きの場所です。XLANG スケジュールでは、ポートは、同期通信と非同期通信をサポートし、XLANG スケジュールから、または XLANG スケジュールへ、メッセージを渡すのに使用されます。
  • BizTalk メッセージ サービスで送受信される XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースで追跡できます。詳細については、「追跡データベースでの XLANG スケジュール イベントの追跡」を参照してください。

ここには次のトピックが含まれます。

  • HTTP トランスポートの使用

  • 非 HTTP トランスポートの使用

関連項目

BizTalk サービス

インスタンス管理


HTTP トランスポートの使用

ここでは、送信元システムと送信先システムの両方について、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合し、構成する方法について説明します。目的は次のとおりです。

  • 送信元システムが特定の XLANG スケジュール インスタンスを使用して、メッセージを生成し、それを取引先の送信先システムに送信するようにします。

  • 送信先システムが HTTP トランスポートを使用して応答メッセージを送信するようにします。

  • 送信元システムが応答メッセージを受信し、初期メッセージを生成して送信した XLANG スケジュール インスタンスへその応答メッセージを配信するようにします。

送信先システムが非 HTTP トランスポートを使用して応答メッセージを送信できるように両方のシステムを構成する方法については、「非 HTTP トランスポートの使用」を参照してください。

ここには次のトピックが含まれます。

  • HTTP トランスポートを使用するための送信元システムの構成

  • HTTP トランスポートを使用するための送信先システムの構成


HTTP トランスポートを使用するための送信元システムの構成

ここでは、HTTP URL の返信先アドレスを含むメッセージを生成し、送信するように送信元システムを構成する方法について説明します。取引先の送信先システムは、HTTP トランスポートを使用することで、初期メッセージに含まれた返信先アドレスを使用して、送信元システムの Web サイトにある ASP ページに応答メッセージを送信します。送信先システムが非 HTTP トランスポートを使用して応答メッセージを送信できるように送信元システムを構成する場合は、「非 HTTP トランスポートを使用するための送信元システムの構成」を参照してください。セキュリティで保護された HTTPS トランスポートを使用するのに必要な構成手順については、後で説明します。

この構成で返信先アドレスとして使用される HTTP URL は、ポートのプロパティのデータに基づいて、XLANG スケジュールによって生成されます。HTTP URL は次の要素から構成されます。

  • 応答メッセージの送信先である送信元システムの Web サイト上の ASP ページのアドレス

  • 応答メッセージの処理に使用される送信元システムの BizTalk メッセージ サービス内のチャネルの名前を含むクエリ文字列、および XLANG スケジュール インスタンスによって作成される、応答メッセージの配信先であるインスタンスごとのキューの完全修飾パス

HTTP URL の返信先アドレスの例を次に示します。

http://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\sendingchannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

送信元システムの ASP ページが応答メッセージを受信する場合、その応答メッセージには、次の手順を実行するスクリプトが含まれます。

  • クエリ文字列からチャネル名とキュー パス情報を抽出します。

  • キュー パスをパス名から形式名に変換し、BizTalk メッセージ サービスに必要な queue:// のプレフィックスを挿入します。

  • チャネル名とキュー パス情報を送信パラメータとして使用して、送信元システムの BizTalk メッセージ サービスへ応答メッセージを送信します。ドキュメントの送信の詳細については、「送信」を参照してください。

送信元システムの BizTalk メッセージ サービスは、指定されたチャネルを使用して応答メッセージを処理し、関連付けられたメッセージ ポートを使用します。メッセージ ポートはキュー パスを使用して、初期メッセージを生成した、実行中の同じ XLANG スケジュール インスタンスに応答メッセージをトランスポートします。

この送信元システムの構成を正しく機能させるには、取引先の送信先システムも正しく構成されている必要があります。送信先システムの構成については、「HTTP トランスポートを使用するための送信先システムの構成」を参照してください。

HTTP トランスポートを使用するように送信元システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージを処理するチャネルの受信と送信のドキュメント定義に必要な仕様を作成します。
  • 仕様の作成と検証

    注

    • 返信先アドレス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信先システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージを処理するチャネルの受信と送信のドキュメント定義に必要な仕様を作成します。
  • 仕様の作成と検証

    注

    • これらの仕様に特別な構成は必要ありません。
BizTalk メッセージ マネージャ
  • 取引先と送信先システムを表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージの処理に使用するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 返信先フィールドを持つ仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 応答メッセージの処理に使用するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • これらのドキュメント定義に特別な構成は必要ありません。
  • 初期メッセージを送信先システムへトランスポートするための、組織へのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートをオープンなメッセージ ポートにすることはできません。
  • XLANG スケジュールからの送信メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。

    • チャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 送信メッセージを生成したアクティブな XLANG スケジュール インスタンスへ応答メッセージをトランスポートするための、アプリケーションへのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先アプリケーション] ページで [実行中の XLANG スケジュール] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  • 送信先システムからの応答メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • 使用するチャネル名と送信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [静的チャネル] をクリックし、[既存のチャネル名を入力してください] ボックスに初期メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。
  • アクション シェイプと、初期メッセージを送信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

    • [メッセージ仕様情報] ページの [参照] をクリックし、仕様を参照します。この仕様は、初期メッセージの処理で使用されるチャネルの受信ドキュメント定義で使用されます。

    • [メッセージ仕様情報] ページで、[メッセージ フィールド] の [追加] をクリックし、初期メッセージに返信先アドレスを格納するために作成した仕様のフィールドを追加します。
  • BizTalk メッセージ シェイプを使用して、応答メッセージを受信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページで [いいえ] をクリックします。

    • [チャネル情報] ページの [チャネル名] ボックスに、応答メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。

      BizTalk オーケストレーション デザイナはチャネル名と GUID を使用して、応答メッセージが配信されるインスタンスごとのキューを作成し、名前を付けます。

    • [チャネル情報] ページの [BizTalk メッセージ サービスがドキュメントを受信する http URL アドレス] ボックスに、取引先が応答メッセージを送信できる ASP ページのアドレスを入力します。

      BizTalk オーケストレーション デザイナは、以前に入力されたアドレスとチャネル名を使用して、チャネル名とインスタンスごとのキューのキュー パスを含むクエリ文字列を持つ HTTP URL アドレスを作成します。
  • アクション シェイプと、応答メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、受信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージ サービスから XLANG スケジュール インスタンスに配信されるすべてのメッセージは、メッセージ キューに送信されます。これらのメッセージに付けられるメッセージ ラベルは、チャネルの送信ドキュメント定義の名前です。
  • 返信先アドレス フィールドにポート参照データを渡すためのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページのポート参照メッセージで、応答メッセージを受信するポートのポート参照をクリックします。次に、その制御ハンドルを、初期メッセージ内の返信先アドレス フィールドの接続ポイントまでドラッグします。

      これにより、ポート参照データが送信初期メッセージの返信先アドレス フィールドに渡されます。ポート参照は ASP ページの HTTP URL アドレスであり、チャネル名と、ポートのインスタンスごとのキューのキュー パスを持つクエリ文字列を含みます。
ASP ページ
  • BizTalk Server 2000 に用意されているサンプル ASP ページを使用するか、同じスクリプトをサンプル ページとして使用する ASP ページを構成できます。
 注
  • サンプル ASP ページを使用するには、インストール ドライブの \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts を参照し、ReceiveResponse.asp サンプルを見つけます。次に、このファイルを送信元システムの Web サイトの適切なディレクトリに置きます。

  • サンプル ASP ページが応答メッセージを受信すると、そのページのスクリプトによって、HTTP ヘッダーのアドレス内のクエリ文字列からチャネル名とキュー パスが抽出されます。キュー パスもパス名から書式名に変換され、queue:// のプレフィックスも挿入されます。次に、このデータがパラメータとして使用され、送信元システムの BizTalk メッセージ サービスに応答メッセージが送信されます。ドキュメントの送信の詳細については、「送信」を参照してください。

セキュリティで保護された HTTPS トランスポートの使用

取引先とのメッセージの交換時に、セキュリティで保護されたトランスポートがビジネス プロセスで必要な場合は、HTTPS トランスポートを使用します。

HTTPS トランスポートを使用するには、送信元システムの構成のうち、応答メッセージを受信するポートの URL アドレスを変更するだけで済みます。

応答メッセージを受信するポートを実装するときに、返信先アドレスとして入力する URL に、HTTP ではなく HTTPS のプレフィックスを使用します。

次に、HTTPS を使用する返信先アドレスの例を示します。

https://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\sendingchannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

送信先システムの構成はほかに何も変更する必要はありません。

関連項目

非 HTTP トランスポートの使用

BizTalk サービスの統合


HTTP トランスポートを使用するための送信先システムの構成

ここでは、HTTP URL の返信先アドレスを含むメッセージを受信し、HTTP トランスポートを使用して送信元システムに応答メッセージを送信するように、送信先システムを構成する方法について説明します。応答メッセージの送信に非 HTTP トランスポートを使用するように送信先システムを構成する場合は、「非 HTTP トランスポートを使用するための送信先システムの構成」を参照してください。セキュリティで保護された HTTP/S トランスポートを使用する場合の構成の注意事項については、後で説明します。

送信先システムの BizTalk メッセージ サービスが初期メッセージを受信する場合は、指定された XLANG スケジュールの新しいインスタンスをアクティブにして、その XLANG スケジュール インスタンス内の指定されたポートにメッセージを送信するように、送信先システムを構成します。

初期メッセージのフィールドに格納されている返信先アドレス データを、応答メッセージの送信に使用されるポートのポート参照フィールドに渡すように、XLANG スケジュールを構成します。次に、XLANG スケジュールは、動的チャネル オプションを使用して BizTalk メッセージ サービスに応答メッセージを送信します。

動的チャネル オプションの場合、メッセージが BizTalk メッセージ サービスに送信されると、特定のポート データが送信パラメータとして渡されます。ポート参照データ (この場合は返信先アドレス) は送信先識別子パラメータとして渡され、ポートのメッセージの種類はドキュメント定義名パラメータとして渡されます。送信パラメータの詳細については、「送信」を参照してください。送信パラメータにより、BizTalk メッセージ サービスは、応答メッセージを処理する特定のチャネルを識別できるようになります。詳細については、「識別」を参照してください。

動的チャネル オプションを使用する場合は、BizTalk メッセージ サービス内のチャネルが、オープンなメッセージ ポートに関連付けられている必要があります。オープンなメッセージ ポートは、返信先アドレスを使用することで取引先の送信元システムに応答メッセージをトランスポートします。この返信先アドレスは送信先識別子パラメータとして渡されます。これは送信元システム上の ASP ページの HTTP URL なので、HTTP トランスポートが使用されます。オープンなメッセージ ポートの詳細については、「オープンなメッセージ ポート」を参照してください。

この送信先システムの構成を正しく機能させるには、取引先の送信元システムも正しく構成されている必要があります。送信元システムの構成については、「HTTP トランスポートを使用するための送信元システムの構成」を参照してください。

HTTP トランスポートを使用するように送信先システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • 返信先アドレス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージを処理するチャネルの受信と送信のドキュメント定義に必要な仕様を作成します。
  • 仕様の作成と検証

    注

    • これらの仕様に特別な構成は必要ありません。
BizTalk メッセージ マネージャ
  • 送信元システムのある取引先を表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージを処理するチャネルと、応答メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 新しい XLANG スケジュール インスタンスをアクティブにするための、アプリケーションへのメッセージ ポートを作成し、その XLANG スケジュール インスタンス内のポートへ初期メッセージをトランスポートします。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先アプリケーション] ページで [新しい XLANG スケジュール] をクリックします。

    • [スケジュール モニカ] ボックスに、指定されたスケジュールのモニカを 入力するか、[参照] をクリックしてそのパスを設定します。

    • [ポート名] ボックスに、このスケジュールにあるドキュメントの特定の送信先ポートの名前を入力します。

      詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。

  • 取引先からの初期メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • 使用するチャネル名と送信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 応答メッセージを送信元システムへトランスポートするための、組織へのオープンなメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先組織] ページで [オープンな送信先] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。

      オープンなメッセージ ポートでは、ドキュメントに送信先情報が含まれているか、送信パラメータで送信先情報が提供される必要があります。XLANG スケジュールが BizTalk メッセージ サービスに応答メッセージを送信する場合、XLANG スケジュールは、初期メッセージに含まれていた返信先アドレス データを送信先識別子送信パラメータとして渡します。
  • XLANG スケジュールからの応答メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを受信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [通信の方向] ページで [受信] をクリックします。

    • BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページで [はい] をクリックします。

      重要

    • [はい] を選択すると、メッセージの到着時に新しいスケジュール インスタンスをアクティブにするようにポートが構成されます。このオプションの使い方の詳細については、この手順の関連項目を参照してください。
  • アクション シェイプと、初期メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージから XLANG スケジュールに渡されるすべてのメッセージは、メッセージ キューを使用します。これらのメッセージのラベルは、チャネルの送信ドキュメント定義の名前です。
  • BizTalk メッセージ シェイプを使用し、動的チャネルを使用して応答メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [動的チャネル] をクリックします。

    • 動的チャネルを使用するポートを作成する場合、BizTalk メッセージ サービスがメッセージの処理に使用するチャネルは、送信パラメータとして渡されたポート データによって決まります。これについては、この表の後で説明します。
  • アクション シェイプと、応答メッセージの送信に使用するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

      受信ドキュメント定義データは送信パラメータとして BizTalk メッセージ サービスに渡されます。これについては、この表の後で説明します。
  • 応答メッセージを送信するポートのポート参照に返信先アドレス フィールドを渡すためのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページで、初期メッセージの返信先アドレス フィールドをクリックします。次に、そのフィールドの制御ハンドルを、応答メッセージの送信に使用されるポートのポート参照メッセージ内のポート参照の左の接続ポイントまでドラッグします。

    重要

    • 返信先アドレス フィールドを、ポート参照の左の接続ポイントに接続する必要があります。ポート参照の左の接続ポイントを使用できるのは、動的チャネルを使用してメッセージを送信するようにポートが構成されている場合だけです。

      動的チャネルを使用するポートの場合、以前に受信したメッセージ内のフィールドからポート参照のデータが渡される必要があります。

      このシナリオでは、初期メッセージからの返信先アドレス データは、応答メッセージの送信に使用されるポートのポート参照フィールドに渡されます。返信先アドレスは応答メッセージの送信先の HTTP URL です。

      動的チャネルを使用するポートが BizTalk メッセージ サービスにメッセージを渡す場合、ポート参照データは送信先識別子パラメータとして渡され、メッセージの種類のデータはドキュメント定義パラメータとして渡されます。パラメータにより、BizTalk メッセージ サービスは、メッセージを処理するために呼び出すチャネルを識別できるようになります。詳細については、「識別」および「送信」を参照してください。

      動的チャネルを使用するようにポートが構成されている場合、送信先の情報は、オープンな送信先送信内のパラメータとして渡されます。したがって、動的チャネルを使用するポートによって呼び出されるすべてのチャネルは、オープンなメッセージ ポートに関連付けられている必要があります。

セキュリティで保護された HTTPS トランスポートの使用

応答メッセージのトランスポートに使用するメッセージ ポートはオープンなメッセージ ポートなので、暗号化証明書を使用してドキュメントを暗号化することはできません。

取引先とのメッセージの交換時に、セキュリティで保護されたトランスポートがビジネス プロセスで必要な場合は、送信元システムが HTTP URL ではなく HTTPS URL を、送信される初期メッセージに返信先アドレスとして含める必要があります。

詳細については、「HTTP トランスポートを使用するための送信元システムの構成」を参照してください。


非 HTTP トランスポートの使用

ここでは、送信元システムと送信先システムの両方について、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合し、構成する方法について説明します。目的は次のとおりです。

  • 送信元システムが特定の XLANG スケジュール インスタンスを使用して、メッセージを生成し、それを取引先の送信先システムに送信するようにします。

  • 送信先システムが初期メッセージを受信し、応答メッセージを生成する XLANG スケジュール インスタンスをアクティブにしてから、非 HTTP トランスポートを使用して応答メッセージを送信元システムに送信するようにします。

送信先システムが HTTP トランスポートを使用して応答メッセージを送信できるように両方のシステムを構成する方法については、「HTTP トランスポートの使用」を参照してください。

ここには次のトピックが含まれます。

  • 非 HTTP トランスポートを使用するための送信元システムの構成

  • 非 HTTP トランスポートを使用するための送信先システムの構成


非 HTTP トランスポートを使用するための送信元システムの構成

ここでは、静的キューのパスを含むメッセージを生成し、送信するように送信元システムを構成する方法について説明します。メッセージ内のキュー パスを応答メッセージのフィールドに渡し、非 HTTP トランスポートを使用してその応答メッセージを送信元システムに送信するように、取引先の送信システムを構成します。送信先システムが HTTP トランスポートを使用して応答メッセージを送信できるように送信元システムを構成する場合は、「HTTP トランスポートを使用するための送信元システムの構成」を参照してください。

送信元システムは、応答メッセージを受信すると、BizTalk メッセージ サービスにメッセージを送信します。BizTalk メッセージ サービスは、ドキュメント フィールドに格納されたキュー パスに指定されたキューに応答メッセージをトランスポートします。このキューは初期メッセージを生成した XLANG スケジュール インスタンスによって監視され、XLANG スケジュールはそのキューから応答メッセージを取得します。

この送信元システムの構成を正しく機能させるには、取引先の送信先システムも正しく構成されている必要があります。送信先システムの構成については、「非 HTTP トランスポートを使用するための送信先システムの構成」を参照してください。

非 HTTP トランスポートを使用するように送信元システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • キュー パス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信先システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • 受信仕様にキュー パス フィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信先システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。

    • 受信仕様のキュー パス フィールドを、送信先の値としてディクショナリ プロパティに設定する必要があります。詳細については、「ディクショナリ プロパティの設定」を参照してください。

      応答メッセージが受信され、送信元システム上の BizTalk メッセージ サービスへ送信されると、キュー パス フィールドが認識され、送信先識別子パラメータとして扱われます。詳細については、「送信」を参照してください。メッセージ ポートは、このキュー パスに指定されたキューに応答メッセージをトランスポートします。XLANG スケジュールはこのキューを監視し、応答メッセージを取得します。

BizTalk マッパー
  • 初期メッセージを処理するチャネルで使用されるマップを作成します。
  • 新しいマップの作成

    重要

    • XLANG スケジュールが生成するキュー パス名の構文をパス名から書式名に変更し、queue:// のプレフィックスを追加する必要があります。HTTP トランスポートのシナリオでは、ASP ページ内のスクリプトがこの変更を実行します。非 HTTP トランスポートのシナリオでこの変更を行うには、マップ内の連結 Functoid を使用します。詳細については、「BizTalk サービスの統合に使用するマップ」を参照してください。
BizTalk メッセージ マネージャ
  • 送信先システムのある取引先を表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージを処理するチャネルと、応答メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 初期メッセージを送信先システムへトランスポートするための、組織へのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートに特別な構成は必要ありません。
  • XLANG スケジュールからの初期メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。

    • [送信ドキュメント] ページで、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスをオンにし、[マップ参照] ボックスの右側の [参照] をクリックします。次に、以前に作成したマップを参照し、[開く] をクリックします。

    • 使用するチャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 初期メッセージを生成したアクティブな XLANG スケジュール インスタンスへ応答メッセージをトランスポートするための、組織へのオープンなメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先組織] ページで [オープンな送信先] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

    • このシナリオでは、アプリケーション (XLANG スケジュール) へ応答メッセージを送信する場合でも、組織へのメッセージ ポートを作成します。

      これにより、キュー パス情報を送信パラメータとして使用し、オープンなメッセージ ポートを使用して応答メッセージを送信できます。詳細については、「送信」を参照してください。

      オープンなメッセージ ポートは、キュー パスに指定された静的キューに応答メッセージをトランスポートします。XLANG スケジュールはそのキュー パスから応答メッセージを取得するように構成されます。
  • 送信先システムからの応答メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • このチャネルの受信ドキュメント定義は、以前に作成した仕様を使用するドキュメント定義を使用する必要があります。この仕様は、キュー パス フィールドを送信先の値としてディクショナリ プロパティに指定した仕様です。

    • 使用するチャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [静的チャネル] をクリックし、[既存のチャネル名を入力してください] ボックスに初期メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。
  • アクション シェイプと、初期メッセージを送信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

    • [メッセージ仕様情報] ページの [参照] をクリックし、初期メッセージのチャネルの受信ドキュメント定義に使用する仕様を参照します。

    • [メッセージ仕様情報] ページで、[メッセージ フィールド] の [追加] をクリックし、キュー パスを格納するために作成した仕様のフィールドを追加します。
  • メッセージ キュー シェイプを使用して、応答メッセージを受信するポートを実装します。
  • メッセージ キューを使用したポートの実装

    注

    • このシナリオでは、BizTalk メッセージ サービスからメッセージを受信する場合でも、メッセージ キューのポート バインドを使用します。

    • メッセージ キュー バインド ウィザードの [静的または動的キューの情報] ページで [静的キュー] をクリックします。

    • [キュー情報] ページの [すべてのインスタンスに対して既存のキューを使用する] をクリックし、[キュー名を入力します] ボックスに、応答メッセージの処理に使用する静的キューの名前を入力します。
  • アクション シェイプと、応答メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [XML 通信ウィザードへようこそ] ページで [受信] をクリックします。

    • [メッセージ情報] ページの [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージ名を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、受信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージから XLANG スケジュールに渡されるすべてのメッセージは、メッセージ キューを使用します。これらのメッセージのラベルは、チャネルの送信ドキュメント定義の名前です。
  • 受信するポート参照からキュー パス フィールドへのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページのポート参照メッセージで、応答メッセージを受信するポートのフィールドをクリックします。次に、そのフィールドの制御ハンドルを、初期メッセージのキュー パス フィールドの接続ポイントまでドラッグします。

      これにより、初期メッセージのキュー パス フィールドにポート参照データが挿入されます。ポート参照は、応答メッセージの受信に使用するポートの、静的キューのキュー パスです。


非 HTTP トランスポートを使用するための送信先システムの構成

ここでは、送信先システムがキュー パスを含むメッセージを受信し、同じキュー パスを含む応答メッセージを非 HTTP トランスポートを使用して送信元システムに送信するように、送信先システムを構成する方法について説明します。HTTP トランスポートを使用して応答メッセージを送信するように送信先システムを構成する場合は、「HTTP トランスポートを使用するための送信先システムの構成」を参照してください。

送信先システムの BizTalk メッセージ サービスが初期メッセージを受信する場合は、指定された XLANG スケジュールの新しいインスタンスをアクティブにして、その XLANG スケジュール インスタンス内の指定されたポートにメッセージを渡すように BizTalk メッセージ サービスを構成します。

XLANG スケジュールは、初期メッセージのキュー パス フィールドに格納されていたデータを応答メッセージ内の対応するフィールドに渡してから、BizTalk メッセージ サービス内のチャネルに応答メッセージを送信するように構成されます。

BizTalk メッセージ サービスは、指定されたチャネルを使用して、応答メッセージを処理し、メッセージ ポートに渡します。このメッセージ ポートは、送信元システムのある取引先との間で同意されているアドレスに応答メッセージをトランスポートするように構成されます。このメッセージ ポートをオープンなメッセージ ポートにすることはできません。

この送信先システムの構成を正しく機能させるには、取引先の送信元システムも正しく構成されている必要があります。送信元システムの構成については、「非 HTTP トランスポートを使用するための送信元システムの構成」を参照してください。

非 HTTP トランスポートを使用するように送信先システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • キュー パス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • キュー パス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
BizTalk メッセージ マネージャ
  • 送信元システムのある取引先を表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 応答メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 新しい XLANG スケジュール インスタンスをアクティブにするための、アプリケーションへのメッセージ ポートを作成し、その XLANG スケジュール インスタンス内のポートへ初期メッセージをトランスポートします。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先アプリケーション] ページで [新しい XLANG スケジュール] をクリックします。

    • [スケジュール モニカ] ボックスに、指定されたスケジュールのモニカを 入力するか、[参照] をクリックしてそのパスを設定します。

    • [ポート名] ボックスに、このスケジュールにあるドキュメントの特定の送信先ポートの名前を入力します。

      詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。

      この手順を完了するには、XLANG スケジュールのパスと、初期メッセージが配信される XLANG スケジュール内のポートの名前が必要です。したがって、この表の後で説明するように、最初に XLANG スケジュールを作成し、そのポートを構成する必要があります。
  • 取引先からの初期メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • 使用するチャネル名と送信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 応答メッセージを送信元システムへトランスポートするための、組織へのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先組織] ページで [組織] をクリックします。[名前] ボックスの右側の [参照] をクリックします。

    • [組織の選択] ダイアログ ボックスで、送信元システムのある取引先を表す、以前に作成した組織を選択します。詳細については、「送信先組織の選択」を参照してください。

    • メッセージ ポート ウィザードの [送信先組織] ページで [プライマリ トランスポート] の [参照] をクリックします。

    • [プライマリ トランスポート] ダイアログ ボックスの [トランスポートの種類] ボックスの一覧でトランスポートの種類を選択し、[アドレス] ボックスにアドレスを入力します。

      トランスポートの種類とアドレスは、取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。

    • オープンなメッセージ ポートを使用して応答メッセージを送信することはできません。
  • XLANG スケジュールからの応答メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。

    • 使用するチャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを受信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [通信の方向] ページで [受信] をクリックします。

    • BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページで [はい] をクリックします。

    重要

    • [はい] を選択すると、メッセージの到着時に新しいスケジュール インスタンスをアクティブにするようにポートが構成されます。このオプションの使い方の詳細については、この手順の関連項目を参照してください。

      このポートに付ける名前と、コンパイルした XLANG スケジュールを保存する場所を記録します。この情報は、この表の後で説明するとおり、BizTalk メッセージ サービスのメッセージ ポートを構成するのに必要です。
  • アクション シェイプと、初期メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージから XLANG スケジュールに渡されるすべてのメッセージは、メッセージ キューを使用します。これらのメッセージのラベルは、チャネルの送信ドキュメント定義の名前です。

    • [メッセージ仕様情報] ページの [参照] をクリックし、初期メッセージのチャネルの送信ドキュメント定義に使用する仕様を参照します。

    • [メッセージ フィールド] の [追加] をクリックし、初期メッセージのキュー パス アドレスを格納するために作成した仕様のフィールドを追加します。
  • BizTalk メッセージ シェイプを使用して、返信メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [静的チャネル] をクリックし、[既存のチャネル名を入力してください] ボックスに応答メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。

    • このポートは静的チャネルを使用するので、BizTalk メッセージへのオープンな送信先への送信の呼び出しは行われません。したがって、指定されたチャネルをオープンなメッセージ ポートに関連付けることはできません。
  • アクション シェイプと、応答メッセージを送信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

    • [メッセージ仕様情報] ページの [参照] をクリックし、仕様を参照します。この仕様は、応答メッセージの処理で使用されるチャネルの受信ドキュメント定義で使用されます。

    • [メッセージ フィールド] の [追加] をクリックし、応答メッセージのキュー パス アドレスを格納するために作成した仕様のフィールドを追加します。
  • 初期メッセージ内のキュー パス フィールドから応答メッセージ内のキュー パス フィールドへのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページで、初期メッセージ内のキュー パス フィールドをクリックします。次に、そのフィールドの制御ハンドルを、応答メッセージ内のキュー パス フィールドの接続ポイントまでドラッグします。

      これにより、初期メッセージから応答メッセージへキュー パス データが渡されます。


BizTalk Server 2000 インターフェイスに関するリファレンス

アプリケーションと Microsoft BizTalk Server 2000 をプログラムによって統合するには、BizTalk メッセージ構成オブジェクト モデルを使用するか、またはユーザーの業務や情報交換のニーズに合わせてサーバーの機能を拡張し、カスタマイズします。このインターフェイスに関するリファレンスでは、Microsoft Visual Basic や Visual C++ というプログラミング言語のプログラマが、BizTalk Server 2000 を使用または拡張するのに必要なすべての情報を提供します。さらに、インターフェイス、オブジェクト、列挙、コード サンプル、およびエラー メッセージの完全な一覧も提供します。

BizTalk Server 2000 は、BizTalk メッセージ構成オブジェクト モデルにアクセスし、IInterchange インターフェイスのメソッドを呼び出してドキュメントを送信することにより、プログラムによるアプリケーション統合をサポートします。また、Microsoft Site Server, Commerce Edition 3.0 で使用できるライトウェイト統合モデルやパイプライン コンポーネント モデルなど、拡張可能なアプリケーション統合コンポーネント (AIC) の使用もサポートしています。

このインターフェイスに関するリファレンスは、次の各部分で構成されています。

BizTalk メッセージ構成オブジェクト モデルの使用

ここでは、サポートされるインターフェイスに関するすべてのリファレンス ページなど、BizTalk メッセージ構成オブジェクト モデルへのアクセス方法について説明します。これは、Microsoft Visual C++ の開発者と Visual Basic の開発者の両方を対象に提供する情報です。詳細については、「BizTalk メッセージ構成オブジェクト モデルの使用」を参照してください。

ドキュメントの送信

ここでは、IInterchange インターフェイスの同期メソッドおよび非同期メソッドを使用して、ドキュメントを BizTalk Server 2000 に送信する方法について説明します。具体的には、取引先との関係を確立した後のドキュメントの移動方法と、BizTalk Server 2000 を経由して移動するドキュメントの追跡方法について説明します。詳細については、「ドキュメントの送信」を参照してください。

カスタム コンポーネントの作成

ここでは、Microsoft Site Server, Commerce Edition 3.0 で使用できるライトウェイト統合モデルやパイプライン コンポーネント モデルなど、BizTalk Server 2000 でサポートしている拡張可能なアプリケーション統合コンポーネント (AIC) について説明します。

開発者は次のことができるようになります。

  • AIC を使用して、ビジネス アプリケーションでビジネス ドキュメントを受信する。

  • デジタル署名と検証、暗号化と暗号解読、解析、およびトランスポートを実行するコンポーネントを開発して、BizTalk Server 2000 の機能を拡張する。

詳細については、「カスタム コンポーネントの作成」を参照してください。

XLANG スケジュールの管理

ここでは、特定の XLANG スケジュールの実行中のインスタンスにアクセスするために使用するインターフェイスと、XLANG スケジューラ ランタイム環境でシステム全体の管理タスクを実行するために使用するインターフェイスについて説明します。これは、Microsoft Visual C++ の開発者と Visual Basic の開発者の両方を対象に提供する情報です。詳細については、「XLANG スケジュールの管理」を参照してください。


BizTalk メッセージ構成オブジェクト モデルの使用

ここでは、プログラムから BizTalk メッセージ構成オブジェクト モデルを使用する方法について説明します。詳細については、次のトピックを参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • COM インターフェイス、列挙、エラー メッセージの詳細については、「オブジェクト モデルに関するリファレンス」を参照してください。

  • コード例については、「BizTalk メッセージ サービスのコード サンプル」を参照してください。

BizTalk メッセージ構成オブジェクト モデルは、グラフィカル ユーザー インターフェイスの BizTalk メッセージ マネージャを使用して構成することもできます。詳細については、「BizTalk メッセージ マネージャの使用」を参照してください。


オブジェクト モデルに関するリファレンス

ここでは、Microsoft Visual C++ または Visual Basic を使用したプログラミングに対して、Microsoft BizTalk Server 2000 で使用するインターフェイスに関するリファレンスを紹介します。BizTalk メッセージ構成オブジェクト モデルにアクセスするためのすべてのインターフェイス、オブジェクト、メソッド、プロパティおよび列挙に関する参照情報を提供します。さらに、エラー メッセージの完全な一覧を提供します。

次の COM インターフェイスまたは列挙が、このリファレンスで説明されています。

  • IBizTalkBase

  • IBizTalkCertificateInfo

  • IBizTalkChannel

  • IBizTalkConfig

  • IBizTalkDocument

  • IBizTalkEndPoint

  • IBizTalkEnvelope

  • IBizTalkLoggingInfo

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

  • IBizTalkServiceWindowInfo

  • IBizTalkTransportInfo

  • IDictionary

  • ISimpleList

  • オブジェクト モデルの列挙


IBizTalkBase インターフェイス [C++]

IBizTalkBase オブジェクト [Visual Basic]

C++ では、IBizTalkBase インターフェイスは、次のオブジェクトによって継承される共通のメソッドおよびプロパティを定義します。Microsoft Visual Basic では、IBizTalkBase クラスは、次のオブジェクトによって実装される共通のメソッドおよびプロパティを定義します。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

注

このオブジェクトのメソッドおよびプロパティは、常に上記のオブジェクト上で呼び出されます。実際の BizTalkBase オブジェクトを作成することによって呼び出されることはありません。

次の表は、BizTalkBase オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは読み取り専用プロパティです。
Handle (ハンドル) | long | オブジェクトへのハンドルです。これは読み取り専用プロパティです。
Name (名前) | BSTR | オブジェクトの名前です。

次の表は、BizTalkBase オブジェクトのメソッドを示しています。

メソッド | 説明
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。
Create | 新しいオブジェクトをデータベースに作成します。
Load | 指定されたオブジェクトをメモリにロードします。
LoadByName | 名前で指定されたオブジェクトをメモリにロードします。
Remove | オブジェクトをデータベースから削除します。
Save | オブジェクトをデータベースに保存します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::Clear メソッド [C++]

IBizTalkBase.Clear メソッド [Visual Basic]

Clear メソッドは、メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。

構文

[C++]

HRESULT Clear();

[Visual Basic]

object.Clear()

パラメータ

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このメソッドは、次のオブジェクトでサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::Create メソッド [C++]

IBizTalkBase.Create メソッド [Visual Basic]

Create メソッドは、データベース内に新しいオブジェクトを作成します。

構文

[C++]

HRESULT Create(
long* plBiztalkObjectHandle
);

[Visual Basic]

object.Create()

パラメータ

[C++]

plBiztalkObjectHandle

[out, retval] オブジェクトへのハンドルを含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このメソッドは、次のオブジェクトでサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

このメソッドを呼び出す前に、Name プロパティを設定する必要があります。Name プロパティは、各オブジェクトの種類に対してデータベース内で一意である必要があります。Create は DateModified プロパティを更新します。

ローカル ドメインの外部にある XML ドキュメント仕様またはマップを参照するオブジェクトを作成すると、エラーが発生することがあります。エラーが発生する場合は、WinHTTP プロキシ ユーティリティをダウンロードし、構成してください。このユーティリティをダウンロードするには、Microsoft MSDN の Web サイト (msdn.microsoft.com/downloads/default.asp) にアクセスし、「Web Development」ブックの「XML」にある「WinHTTP Proxy Configuration Utility」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::DateModified プロパティ [C++]

IBizTalkBase.DateModified プロパティ [Visual Basic]

DateModified プロパティには、オブジェクトの情報が作成または最後に変更された日付と時刻が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_DateModified(
BSTR* pstrModified
);

[Visual Basic]

object.DateModified

パラメータ

[C++]

pstrModified

[out, retval] 変更日付を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、変更日付を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このプロパティは、次のオブジェクトによってサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

これは読み取り専用プロパティです。文字列 strModified の書式は、yyyy-mm-dd hh:mm:ss です。時刻は協定世界時 (UTC) です。オブジェクトに対して Create メソッドまたは Save メソッドが呼び出されると、サーバーはこのプロパティを設定します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::Handle プロパティ [C++]

IBizTalkBase.Handle プロパティ [Visual Basic]

Handle プロパティには、オブジェクトへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Handle(
long* plBiztalkObjectHandle
);

[Visual Basic]

object.Handle

パラメータ

[C++]

plBiztalkObjectHandle

[out, retval] オブジェクトへのハンドルを含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このプロパティは、次のオブジェクトによってサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::Load メソッド [C++]

IBizTalkBase.Load メソッド [Visual Basic]

Load メソッドは、オブジェクトをメモリにロードします。

構文

[C++]

HRESULT Load(
long lBiztalkObjectHandle
);

[Visual Basic]

object.Load(lBiztalkObjectHandle As Long)

パラメータ

[C++]

lBiztalkObjectHandle

[in] ロードするオブジェクトへのハンドルを含む Long です。

[Visual Basic]

lBiztalkObjectHandle

ロードするオブジェクトへのハンドルを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このメソッドは、次のオブジェクトでサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

Load は、オブジェクトをロードする前に、内部で Clear メソッドを呼び出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::LoadByName メソッド [C++]

IBizTalkBase.LoadByName メソッド [Visual Basic]

LoadByName メソッドは、名前で指定されたオブジェクトをメモリにロードします。

構文

[C++]

HRESULT LoadByName(
BSTR strName
);

[Visual Basic]

object.LoadByName(strName As String)

パラメータ

[C++]

strName

[in] 名前を含む BSTR です。

[Visual Basic]

strName

名前を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このメソッドは、次のオブジェクトでサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

LoadByName は、オブジェクトをロードする前に、内部で Clear メソッドを呼び出します。

名前の最大長は 64 文字です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::Name プロパティ [C++]

IBizTalkBase.Name プロパティ [Visual Basic]

Name プロパティには、オブジェクトの名前が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Name(
BSTR* pstrName
);

Put メソッド :

HRESULT put_Name(
BSTR strName
);

[Visual Basic]

object.Name

パラメータ

[C++]

Get メソッド :

pstrName

[out, retval] オブジェクトの名前を含む BSTR へのポインタです。

Put メソッド :

strName

[in] オブジェクトの名前を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、名前を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このプロパティは、次のオブジェクトによってサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

サーバーは Name プロパティを必要とします。このプロパティは、オブジェクトに対して Create メソッドまたは Save メソッドを呼び出す前に設定する必要があります。Name プロパティは、各オブジェクトの種類に対してデータベース内で一意であり、長さは 1 文字以上である必要があります。名前の最大長は 64 文字です。

次の表は、BizTalk Server が使用する予約名を示しています。

名前 | オブジェクトの種類
信頼できるメッセージ受信確認ポート | IBizTalkPort
信頼できるメッセージ受信確認チャネル | IBizTalkChannel
BizTalk 既定受信 | IBizTalkDocument
信頼できるメッセージ受信確認 | IBizTalkDocument
信頼できるメッセージ受信確認 SMTP 送信元アドレス | IBizTalkOrganization エイリアス
既定の組織 | IBizTalkOrganization

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkBase::Remove メソッド [C++]

IBizTalkBase.Remove メソッド [Visual Basic]

Remove メソッドは、データベースからオブジェクトを削除します。

構文

[C++]

HRESULT Remove();

[Visual Basic]

object.Remove()

パラメータ

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このメソッドは、次のオブジェクトでサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

ほかのオブジェクトから参照されている場合、そのオブジェクトは削除できません。

BizTalkOrganization オブジェクトが既定の組織である場合は、このオブジェクトは削除できません。削除するには、その組織の IsDefault プロパティを False に設定し、別の組織の IsDefault プロパティを True に設定します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

参照整合性


IBizTalkBase::Save メソッド [C++]

IBizTalkBase.Save メソッド [Visual Basic]

Save メソッドは、データベースにオブジェクトを保存します。

構文

[C++]

HRESULT Save();

[Visual Basic]

object.Save()

パラメータ

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

適用対象

このメソッドは、次のオブジェクトでサポートされています。

  • BizTalkChannel

  • BizTalkDocument

  • BizTalkEnvelope

  • BizTalkOrganization

  • BizTalkPort

  • BizTalkPortGroup

解説

Save メソッドは DateModified プロパティを更新します。

ローカル ドメインの外部にある XML ドキュメント仕様またはマップを参照するオブジェクトを保存すると、エラーが発生することがあります。エラーが発生する場合は、WinHTTP プロキシ ユーティリティをダウンロードし、構成してください。このユーティリティをダウンロードするには、Microsoft MSDN の Web サイト (msdn.microsoft.com/downloads/default.asp) にアクセスし、「Web Development」ブックの「XML」にある「WinHTTP Proxy Configuration Utility」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkCertificateInfo インターフェイス [C++]

BizTalkCertificateInfo オブジェクト [Visual Basic]

このオブジェクトを使用すると、BizTalkPort オブジェクトまたは BizTalkChannel オブジェクトに関連付けられている証明書を構成できます。

C++ では、IBizTalkCertificateInfo オブジェクトのメソッドにアクセスするには BizTalkCertificateInfo インターフェイスを使用します。

次の表は、BizTalkCertificateInfo オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Name (名前) | BSTR | 証明書の名前です。これは読み取り専用プロパティです。
Reference (参照) | BSTR | 証明書ストア内の証明書への参照です。
Store (ストアの種類) | BIZTALK_ STORE_ TYPE | 証明書のストアの種類です。
Usage (使用法) | BIZTALK_USAGE_ TYPE | 証明書の使用法の種類です。これは読み取り専用プロパティです。

解説

BizTalkConfig オブジェクトの CreatePort メソッドまたは CreateChannel メソッドを使用して BizTalkPort オブジェクトまたは BizTalkChannel オブジェクトのインスタンスを作成すると、このオブジェクトが自動的に作成されます。

出力ドキュメントの場合は、BizTalkPort オブジェクトの EncryptionCertificateInfo プロパティを使用して、BizTalkCertificateInfo オブジェクトにアクセスします。入力ドキュメントの場合は、BizTalkChannel オブジェクトの SignatureCertificateInfo プロパティ、VerifySignatureCertificateInfo プロパティ、または DecryptionCertificateInfo プロパティを使用して、BizTalkCertificateInfo オブジェクトにアクセスします。既存のすべての BizTalkCertificateInfo オブジェクトを取得するには、BizTalkConfig オブジェクトの Certificates プロパティを使用します。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。S/MIME コンポーネントの証明書を構成するには、オブジェクト モデルにアクセスするスクリプトまたはアプリケーションを、BizTalk Server Administrators グループのユーザー アカウントで実行する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkCertificateInfo::Name プロパティ [C++]

BizTalkCertificateInfo.Name プロパティ [Visual Basic]

Name プロパティには、証明書の名前が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Name(
BSTR* pstrName
);

[Visual Basic]

object.Name

パラメータ

[C++]

pstrName

[out, retval] 名前を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、名前を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkCertificateInfo::Reference プロパティ [C++]

BizTalkCertificateInfo.Reference プロパティ [Visual Basic]

Reference プロパティには、証明書ストア内の証明書への参照が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Reference(
BSTR* pstrReference
);

Put メソッド :

HRESULT put_Reference(
BSTR strReference
);

[Visual Basic]

object.Reference

パラメータ

[C++]

Get メソッド :

pstrReference

[out, retval] 証明書参照を含む BSTR へのポインタです。

Put メソッド :

strReference

[in] 証明書参照を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • Put メソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、CryptoAPI エラーも返します。CryptoAPI に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、証明書参照を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

証明書への参照は、BizTalkConfig オブジェクトの Certificates プロパティを使用して取得する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkCertificateInfo::Store プロパティ [C++]

BizTalkCertificateInfo.Store プロパティ [Visual Basic]

Store プロパティには、証明書ストアの種類が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Store(
BIZTALK_STORE_TYPE* pStoreType
);

Put メソッド :

HRESULT put_Store(
BIZTALK_STORE_TYPE eStoreType
);

[Visual Basic]

object.Store

パラメータ

[C++]

Get メソッド :

pStoreType

[out, retval] 証明書ストアの種類を含む列挙値へのポインタです。有効な値は、BIZTALK_STORE_TYPE 列挙からの値です。

Put メソッド :

eStoreType

[in] 証明書ストアの種類を含む列挙値です。有効な値は、BIZTALK_STORE_TYPE 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は、BIZTALK_STORE_TYPE 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

証明書を格納するストアは、証明書の用途に応じて、次のように決まります。

証明書の種類 | ストア
暗号解読 | MY
暗号化 | BIZTALK
署名 | MY
署名確認 | BIZTALK

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkCertificateInfo::Usage プロパティ [C++]

BizTalkCertificateInfo.Usage プロパティ [Visual Basic]

Usage プロパティには、証明書の使用法の種類が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Usage(
BIZTALK_USAGE_TYPE* pUsageType
);

[Visual Basic]

object.Usage

パラメータ

[C++]

pUsageType

[out, retval] 列挙値へのポインタです。有効な値は、BIZTALK_USAGE_TYPE 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は、BIZTALK_USAGE_TYPE 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel インターフェイス [C++]

BizTalkChannel オブジェクト [Visual Basic]

BizTalkChannel オブジェクトのメソッドとプロパティは、ドキュメントを処理するチャネルを構成するために使用します。

C++ では、BizTalkChannel オブジェクトのメソッドにアクセスするには IBizTalkChannel インターフェイスを使用します。

次の表は、BizTalkChannel オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Comments (コメント) | BSTR | オブジェクトに対するユーザー コメントです。
ControlNumberValue (制御番号の値) | BSTR | グループ制御番号の値です。
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
DecryptionCertificateInfo (暗号解読証明書情報) | IDispatch | 入力ドキュメントを解読する証明書に関する情報です。
ExpectReceiptTimeout (受信確認タイムアウト) | long | 現在のドキュメントを有効期限切れとして処理する前に、そのドキュメントの受信確認を要求する時間 (単位 : 分)
Expression (式) | BSTR | オブジェクトの選択をフィルタする数式の完全なセットです。
Handle (ハンドル) | long | オブジェクトの識別子です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
InputDocument (入力ドキュメント) | long | 入力 BizTalkDocument オブジェクトへのハンドルです。これは必須プロパティです。
IsReceiptChannel (受信確認チャネル) | VARIANT_BOOL | オブジェクトが受信確認チャネルであるかどうかを示すフラグです。
LoggingInfo (ログ情報) | IDispatch | ログに関する情報です。
MapContent (マップの内容) | BSTR | 送信元組織で使用されるドキュメント形式と送信先組織で使用されるドキュメント形式が異なる場合に、送信元組織の形式で記述された入力ドキュメントを送信先組織の形式で表示する方法を示すマップの内容です。これは読み取り専用プロパティです。
MapReference (マップ参照) | BSTR | 送信元組織で使用されるドキュメント形式と送信先組織で使用されるドキュメント形式が異なる場合に、送信元組織の形式で記述された入力ドキュメントを送信先組織の形式で表示する方法を示すマップの Web Distributed Authoring and Versioning (WebDAV) の完全 URL です。InputDocument プロパティが OutputDocument プロパティと異なる場合、このプロパティは必須です。
Name (名前) | BSTR | オブジェクトの名前です。これは BizTalkBase オブジェクトから取得される必須プロパティです。
OutputDocument (出力ドキュメント) | long | 出力 BizTalkDocument オブジェクトへのハンドルです。これは必須プロパティです。
Port (ポート) | long | 関連付けられている BizTalkPort オブジェクトです。Port プロパティか PortGroup プロパティのいずれかを指定する必要があります。
PortGroup (ポート グループ) | long | 関連付けられている BizTalkPortGroup オブジェクトです。Port プロパティか PortGroup プロパティのいずれかを指定する必要があります。
ReceiptChannel (受信チャネル) | long | このオブジェクトの受信確認チャネルへのハンドルです。
RetryCount (再試行回数) | long | 送信先への接続に失敗したときのドキュメント送信の再試行回数です。
RetryInterval (再試行間隔) | long | 送信先への接続に失敗したときのドキュメント送信の再試行の間隔です。この値は分単位で指定します。
SignatureCertificateInfo (署名証明書情報) | IDispatch | 出力ドキュメントに署名する証明書に関する情報です。
SourceEndpoint (送信元エンドポイント) | IDispatch | 送信元に関する情報です。
TrackFields (追跡項目) | IDispatch | 追加のカスタム追跡項目を格納する Dictionary オブジェクトで、この追跡項目は、関連付けられている BizTalkChannel オブジェクトに対する BizTalkDocument オブジェクトのインターチェンジ データを追跡するために使用します。
VerifySignatureCertificateInfo (署名確認証明書情報) | IDispatch | 入力ドキュメントの署名を確認する証明書に関する情報です。

次の表は、BizTalkChannel オブジェクトのメソッドを示しています。

メソッド | 説明
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。このメソッドは BizTalkBase オブジェクトから取得されます。
Create | 新しいオブジェクトをデータベースに作成します。このメソッドは BizTalkBase オブジェクトから取得されます。
GetConfigComponent | BizTalkPort オブジェクトに関連付けられているコンポーネントの CLSID を読み取ります。
GetConfigData | 特定の BizTalkPort オブジェクトに関連付けられている構成を取得します。
Load | オブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadByName | 名前によってオブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
Remove | オブジェクトを削除します。このメソッドは BizTalkBase オブジェクトから取得されます。
Save | オブジェクトをデータベースに保存します。このメソッドは BizTalkBase オブジェクトから取得されます。
SetConfigComponent | BizTalkPort オブジェクトに関連付けられているコンポーネントの CLSID を設定します。
SetConfigData | BizTalkPort オブジェクトに関連付けられている構成情報を設定します。

解説

各 BizTalkChannel オブジェクトは、関連付けられている完全な BizTalkPort オブジェクトを 1 つ必要とします。1 つまたは複数の BizTalkChannel オブジェクトを 1 つの BizTalkPort オブジェクトに関連付けることができます。BizTalkChannel オブジェクトは、入力 BizTalkDocument オブジェクトと出力 BizTalkDocument のそれぞれ 1 つずつのみ関連付けることができます。ただし、1 つの BizTalkDocument からは、複数の BizTalkChannel オブジェクトに対して関連付けを行うことができます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

チャネル

ドキュメント処理


IBizTalkChannel::Comments プロパティ [C++]

BizTalkChannel.Comments プロパティ [Visual Basic]

Comments プロパティには、オブジェクトに対するユーザー コメントが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Comments(
BSTR* pstrComments
);

Put メソッド :

HRESULT put_Comments(
BSTR strComments
);

[Visual Basic]

object.Comments

パラメータ

[C++]

Get メソッド :

pstrComments

[out, retval] コメントを含む BSTR へのポインタです。

Put メソッド :

strComments

[in] コメントを含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、コメントを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::ControlNumberValue プロパティ [C++]

BizTalkChannel.ControlNumberValue プロパティ [Visual Basic]

ControlNumberValue プロパティには、グループ制御番号の値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ControlNumberValue(
BSTR* pstrControlNumberValue
);

Put メソッド :

HRESULT put_ControlNumberValue(
BSTR strControlNumberValue
);

[Visual Basic]

object.ControlNumberValue

パラメータ

[C++]

Get メソッド :

pstrControlNumberValue

[out, retval] 制御番号を含む BSTR へのポインタです。

Put メソッド :

strControlNumberValue

[in] 制御番号を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、制御番号を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

ControlNumberValue プロパティに含まれる値は、1 から 999999999 の間である必要があります。

関連付けられている BizTalkPort オブジェクトに対する BizTalkEnvelope オブジェクトの Format プロパティが X12、EDIFACT、または Custom に設定されている場合、このプロパティは必須です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::DecryptionCertificateInfo プロパティ [C++]

BizTalkChannel.DecryptionCertificateInfo プロパティ [Visual Basic]

DecryptionCertificateInfo プロパティには、入力ドキュメントを解読する証明書に関する情報が含まれています。この情報には、Name、Reference、Store、および Usage の各プロパティが含まれ、BizTalkCertificateInfo オブジェクトのメモリ内に作成および格納されます。

構文

[C++]

Get メソッド :

HRESULT get_DecryptionCertificateInfo(
IDispatch** ppDecryptionCertificateInfoDisp
);

Putref メソッド :

HRESULT putref_DecryptionCertificateInfo(
IDispatch* pDecryptionCertificateInfoDisp
);

[Visual Basic]

object.DecryptionCertificateInfo

パラメータ

[C++]

Get メソッド :

ppDecryptionCertificateInfoDisp

[out, retval] 証明書情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pDecryptionCertificateInfoDisp

[in] 証明書情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、証明書情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::ExpectReceiptTimeout プロパティ [C++]

BizTalkChannel.ExpectReceiptTimeout プロパティ [Visual Basic]

ExpectReceiptTimeout プロパティには、現在のドキュメントを有効期限切れとして処理する前に、そのドキュメントの受信確認を要求する時間の値 (単位 : 分) が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ExpectReceiptTimeout(
long* plMinutes
);

Put メソッド :

HRESULT put_ExpectReceiptTimeout(
long lMinutes
);

[Visual Basic]

object.ExpectReceiptTimeout

パラメータ

[C++]

Get メソッド :

plMinutes

[out, retval] 分単位で表す値を含む long へのポインタです。

Put メソッド :

lMinutes

[in] 分単位で表す値を含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、分単位で表す値を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::Expression プロパティ [C++]

BizTalkChannel.Expression プロパティ [Visual Basic]

Expression プロパティには、BizTalkChannel オブジェクトの選択をフィルタする式が含まれます。式が true と評価される場合、サーバーはドキュメントを処理するチャネルを選択します。

構文

[C++]

Get メソッド :

HRESULT get_Expression(
BSTR* pstrExpression
);

Put メソッド :

HRESULT put_Expression(
BSTR strExpression
);

[Visual Basic]

object.Expression

パラメータ

[C++]

Get メソッド :

pstrExpression

[out, retval] XPath 式を含む BSTR へのポインタです。

Put メソッド :

strExpression

[in] XPath 式を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、式を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

XPath 式は、InputDocument プロパティで設定されている入力ドキュメント仕様に基づいている必要があります。

注

  • 式の作成に使用する仕様フィールドがブール型である場合、式の値に "true" または "false" のテキスト文字列を使用することはできません。代わりに、true に対しては数値 "-1"、false に対しては数値 "0" を使用する必要があります。たとえば、承認済みの発注だけを処理するようにチャネルをフィルタするには、次のような式を作成します。
    Channel1.Expression = "/PORequest/Total[IsApproved = -1]"

    この例では、入力ドキュメント仕様に、ブール型の IsApproved フィールドを伴う下位要素 Total が含まれていることが前提になっています。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

チャネル フィルタ


IBizTalkChannel::GetConfigComponent メソッド [C++]

BizTalkChannel.GetConfigComponent メソッド [Visual Basic]

GetConfigComponent メソッドは、BizTalkPort オブジェクトに関連付けられているコンポーネントの CLSID を取得します。

構文

[C++]

HRESULT GetConfigComponent(
BIZTALK_CONFIGDATA_TYPE eConfigType,
 long lPortHandle,
BSTR* pstrCLSID
);

[Visual Basic]

object.GetConfigComponent( _
eConfigType As BIZTALK_CONFIGDATA_TYPE, _
 lPortHandle As Long _
)

パラメータ

[C++]

eConfigType

[in] 列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。

lPortHandle

[in] BizTalkPort オブジェクトへのハンドルを含む Long です。

pstrCLSID

[out, retval] コンポーネントの CLSID を含む BSTR へのポインタです。

[Visual Basic]

eConfigType

列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。

lPortHandle

ハンドルを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

[Visual Basic]

このメソッドは、コンポーネントの CLSID を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

eConfigType パラメータが BIZTALK_CONFIGDATA_TYPE_SIGNATURE に設定され、関連付けられている BizTalkPort オブジェクトの EncryptionType プロパティと SignatureType プロパティがどちらも S/MIME に設定されている場合、このメソッドは空文字列 ("") を返します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::GetConfigData メソッド [C++]

BizTalkChannel.GetConfigData メソッド [Visual Basic]

GetConfigData メソッドは、指定された BizTalkPort オブジェクトに関連付けられている構成を取得します。

構文

[C++]

HRESULT GetConfigData(
 BIZTALK_CONFIGDATA_TYPE eConfigType,
 long lPortHandle,
VARIANT* pvarType,
VARIANT* pvarDictionary
);

[Visual Basic]

object.GetConfigData( _
 eConfigType As BIZTALK_CONFIGDATA_TYPE, _
 lPortHandle As Long, _
 pvarType As Variant _
)

パラメータ

[C++]

eConfigType

[in] 列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。

lPortHandle

[in] 関連付けられた BizTalkPort オブジェクトへのハンドルを識別する Long です。

pvarType

[in, out] トランスポートの種類を含む VARIANT へのポインタです。

pvarDictionary

[in, out] VARIANT へのポインタで、この VARIANT には、プライマリ トランスポート構成情報を含むオブジェクトの IDictionary インターフェイスへのポインタが含まれます。

[Visual Basic]

eConfigType

[in] 列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。

lPortHandle

関連付けられた BizTalkPort オブジェクトへのハンドルを識別する Long です。

pvarType

トランスポートの種類を含む Variant です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

[Visual Basic]

このメソッドは、プライマリ トランスポート構成情報を含む CDictionary オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドが返す Dictionary オブジェクトには、EDIFACT および X12 に使用される特定の文字列修飾子が含まれています。次の表は、それらの文字列を示しています。

EDIFACT

修飾子文字列 | 説明
SerializerEdifact_SenderIntID | インターチェンジ送信者内部 ID です。
SerializerEdifact_SenderIntSubID | インターチェンジ送信者内部サブ ID です。
SerializerEdifact_RecipientIntID | インターチェンジ受信内部 ID です。
SerializerEdifact_RecipientIntSubID | インターチェンジ受信内部サブ ID です。
SerializerEdifact_RecipientRefPwd | 受信者参照とパスワードです。
SerializerEdifact_RecipientRefPwdQual | 受信者参照とパスワードの修飾子です。
SerializerEdifact_ApplicationRef | アプリケーション参照です。
SerializerEdifact_ProcPriCode | 処理優先度コードです。
SerializerEdifact_AckRequest | 受信確認要求です。
SerializerEdifact_AgreementID | インターチェンジ契約識別子です。
SerializerEdifact_TestInd | テスト インジケータです。
SerializerEdifact_UNACtrl | "常に UNA 送信" または "要求時のみ UNA を送信" です。
SerializerEdifact_SyntaxID | 構文識別子です。

ANSI X12

修飾子文字列 | 説明
SerializerX12_AuthInfoQual | 認証情報の修飾子です。
SerializerX12_AuthInfo | 認証情報です。
SerializerX12_SecInfoQual | セキュリティ情報修飾子です。
SerializerX12_SecInfo | セキュリティ情報です。
SerializerX12_CtrlStdID | インターチェンジ制御識別子です。
SerializerX12_CtrlVerNum | インターチェンジ制御バージョン番号です。
SerializerX12_AckRequired | 要求された受信確認です。
SerializerX12_UseInd | 使用法インジケータです。

注

  • EDIFACT 標準の詳細については、国連欧州経済委員会の Web サイト (www.unece.org) を参照してください。

  • X12 標準の詳細については、Data Interchange Standards Association の Web サイト (www.disa.org) を参照してください。

このメソッドを使用して BizTalkPort オブジェクトのトランスポート プロパティを上書きした後で、その BizTalkPort オブジェクトのトランスポート プロパティを変更する場合は、このメソッドをもう 1 度呼び出す必要があります。

eConfigType パラメータが BIZTALK_CONFIGDATA_TYPE_SIGNATURE に設定され、関連付けられている BizTalkPort オブジェクトの EncryptionType プロパティと SignatureType プロパティがどちらも S/MIME に設定されている場合、このメソッドは空の Dictionary オブジェクトを返します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::InputDocument プロパティ [C++]

BizTalkChannel.InputDocument プロパティ [Visual Basic]

InputDocument プロパティには、入力ドキュメント仕様を記述する BizTalkDocument オブジェクトへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_InputDocument(
long* plInDocHandle
);

Put メソッド :

HRESULT put_InputDocument(
long lInDocHandle
);

[Visual Basic]

object.InputDocument

パラメータ

[C++]

Get メソッド :

plInDocHandle

[out, retval] 入力 BizTalkDocument オブジェクトへのハンドルを含む long へのポインタです。

Put メソッド :

lInDocHandle

[in] 入力 BizTalkDocument オブジェクトへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、入力 BizTalkDocument オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは必須プロパティです。

このプロパティは、Create メソッドまたは Save メソッドが呼び出された後には、変更できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

構成

ドキュメント定義

ドキュメント処理


IBizTalkChannel::IsReceiptChannel プロパティ [C++]

BizTalkChannel.IsReceiptChannel プロパティ [Visual Basic]

IsReceiptChannel プロパティには、オブジェクトが受信確認チャネルであるかどうかを示すフラグが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_IsReceiptChannel(
VARIANT_BOOL* pbIsReceiptChannel
);

Put メソッド :

HRESULT put_IsReceiptChannel(
VARIANT_BOOL bIsReceiptChannel
);

[Visual Basic]

object.IsReceiptChannel

パラメータ

[C++]

Get メソッド :

pbIsReceiptChannel

[out, retval] フラグを含む VARIANT_BOOL へのポインタです。VARIANT_TRUE の値は、このチャネルが受信確認チャネルとして使用されることを示します。VARIANT_FALSE の値は、このチャネルが受信確認チャネルとして使用されないことを示します。

Put メソッド :

bIsReceiptChannel

[in] フラグを含む VARIANT_BOOL です。VARIANT_TRUE の値は、このチャネルが受信確認チャネルとして使用されることを示します。VARIANT_FALSE の値は、このチャネルが受信確認チャネルとして使用されないことを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、チャネルが受信確認チャネルとして使用されているかどうかを示す Variant を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ReceiptChannel


IBizTalkChannel::LoggingInfo プロパティ [C++]

BizTalkChannel.LoggingInfo プロパティ [Visual Basic]

LoggingInfo プロパティには、ドキュメントのログに関する情報が含まれます。この情報には、LogNativeInputDocument、LogNativeOutputDocument、LogXMLInputDocument、および LogXMLOutputDocument の各プロパティが含まれています。この情報は、BizTalkLoggingInfo オブジェクト内のメモリで作成され、そこに格納されます。

構文

[C++]

Get メソッド :

HRESULT get_LoggingInfo(
IDispatch** ppLoggingInfoDisp
);

Putref メソッド :

HRESULT putref_LoggingInfo(
IDispatch* pLoggingInfoDisp
);

[Visual Basic]

object.LoggingInfo

パラメータ

[C++]

Get メソッド :

ppLoggingInfoDisp

[out, retval] ログ フィールドを含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pLoggingInfoDisp

[in] ログ フィールドを含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、ログ フィールドを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント格納


IBizTalkChannel::MapContent プロパティ [C++]

BizTalkChannel.MapContent プロパティ [Visual Basic]

MapContent プロパティには、送信元組織で使用されるドキュメント形式と送信先組織で使用されるドキュメント形式が異なる場合に、送信元組織の形式で記述された入力ドキュメントを送信先組織の形式で表示する方法を示すマップの内容が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_MapContent(
BSTR* pstrMapContent
);

[Visual Basic]

object.MapContent

パラメータ

[C++]

pstrMapContent

[in] マップの内容を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、マップの内容を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。Create メソッドと Save メソッドは、この文字列が空である場合、MapReference プロパティにより指定されるマップのテキストを文字列にコピーします。

MapReference がマップに設定された状態で BizTalkChannel オブジェクトを作成または保存すると、参照されるマップの内容を変更しても、その内容は、参照している BizTalkChannel オブジェクトでは自動的には更新されません。変更が加えられたマップを参照する BizTalkChannel オブジェクトを更新するには、まず、マップを保存し、BizTalkChannel オブジェクトの MapReference プロパティを現在の値に再設定します。その後、参照している BizTalkChannel オブジェクトで Save を呼び出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::MapReference プロパティ [C++]

BizTalkChannel.MapReference プロパティ [Visual Basic]

MapReference プロパティには、送信元組織で使用されるドキュメント形式と送信先組織で使用されるドキュメント形式が異なる場合に、送信元組織の形式で記述された入力ドキュメントを送信先組織の形式で表示する方法を示すマップの Web Distributed Authoring and Versioning (WebDAV) の完全 URL が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_MapReference(
BSTR* pstrReference
);

Put メソッド :

HRESULT put_MapReference(
BSTR strReference
);

[Visual Basic]

object.MapReference

パラメータ

[C++]

Get メソッド :

pstrReference

[out, retval] マップ名を含む BSTR へのポインタです。

Put メソッド :

strReference

[in] マップ名を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、マップ名を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

InputDocument プロパティが OutputDocument プロパティ以外のドキュメント仕様を参照している場合、このプロパティは必須です。

MapReference がマップに設定された状態で BizTalkChannel オブジェクトを作成または保存すると、参照されるマップの内容を変更しても、その内容は、参照している BizTalkChannel オブジェクトでは自動的には更新されません。変更が加えられたマップを参照する BizTalkChannel オブジェクトを更新するには、まず、マップを保存し、BizTalkChannel オブジェクトの MapReference プロパティを現在の値に再設定します。その後、参照している BizTalkChannel オブジェクトで Save を呼び出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::OutputDocument プロパティ [C++]

BizTalkChannel.OutputDocument プロパティ [Visual Basic]

OutputDocument プロパティには、出力ドキュメント仕様を記述する BizTalkDocument オブジェクトへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_OutputDocument(
long* plOutDocHandle
);

Put メソッド :

HRESULT put_OutputDocument(
long lOutDocHandle
);

[Visual Basic]

object.OutputDocument

パラメータ

[C++]

Get メソッド :

plOutDocHandle

[out, retval] 出力 BizTalkDocument オブジェクトへのハンドルを含む long へのポインタです。

Put メソッド :

lOutDocHandle

[in] 出力 BizTalkDocument オブジェクトへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、出力 BizTalkDocument オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは必須プロパティです。このプロパティは、Create メソッドまたは Save メソッドが呼び出された後には、変更できません。

関連付けられている BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_SOURCE に設定されている場合、InputDocument プロパティは、X12 仕様または EDIFACT 仕様を持つ入力 BizTalkDocument オブジェクトを識別することができます。ただし、その場合は、OutputDocument プロパティが、X12 仕様または EDIFACT 仕様を持つ BizTalkDocument オブジェクトを識別しないようにする必要があります。

関連付けられている BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合は、この BizTalkChannel オブジェクトの OutputDocument プロパティが、X12 仕様または EDIFACT 仕様を持つ出力の BizTalkDocument オブジェクトを識別しないことが必要です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント定義


IBizTalkChannel::Port プロパティ [C++]

BizTalkChannel.Port プロパティ [Visual Basic]

Port プロパティには、関連付けられた BizTalkPort オブジェクトへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Port(
long* plPortHandle
);

Put メソッド :

HRESULT put_Port(
long lPortHandle
);

[Visual Basic]

object.Port

パラメータ

[C++]

Get メソッド :

plPortHandle

[out, retval] BizTalkPort オブジェクトへのハンドルを含む long へのポインタです。

Put メソッド :

lPortHandle

[in] BizTalkPort オブジェクトへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、BizTalkPort オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

次の制約が適用されます。

  • Port プロパティか PortGroup プロパティのいずれかをチャネルに対して指定する必要があります。

  • このプロパティは、Create メソッドまたは Save メソッドが呼び出された後には、変更できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

メッセージ ポート


IBizTalkChannel::PortGroup プロパティ [C++]

BizTalkChannel.PortGroup プロパティ [Visual Basic]

PortGroup プロパティには、関連付けられた BizTalkPortGroup オブジェクトへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_PortGroup(
long* plPortGroupHandle
);

Put メソッド :

HRESULT put_PortGroup(
long lPortGroupHandle
);

[Visual Basic]

object.PortGroup

パラメータ

[C++]

Get メソッド :

plPortGroupHandle

[out, retval] 関連付けられた BizTalkPortGroup オブジェクトへのハンドルを含む long へのポインタです。

Put メソッド :

lPortGroupHandle

[in] 関連付けられた BizTalkPortGroup オブジェクトへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、関連付けられた BizTalkPortGroup オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

次の制約が適用されます。

  • Port プロパティか PortGroup プロパティのいずれかをチャネルに対して指定する必要があります。

  • このプロパティは、Create メソッドまたは Save メソッドが呼び出された後には、変更できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ポート グループ


IBizTalkChannel::ReceiptChannel プロパティ [C++]

BizTalkChannel.ReceiptChannel プロパティ [Visual Basic]

ReceiptChannel プロパティには、このオブジェクトの受信確認チャネルへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ReceiptChannel(
long* plReceiptChannelHandle
);

Put メソッド :

HRESULT put_ReceiptChannel(
long lReceiptChannelHandle
);

[Visual Basic]

object.ReceiptChannel

パラメータ

[C++]

Get メソッド :

plReceiptChannelHandle

[out, retval] ハンドルを含む long へのポインタです。

Put メソッド :

lReceiptChannelHandle

[in] ハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、受信確認チャネルへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalkChannel オブジェクトが受信確認チャネルを指定できるのは、それ自体が受信確認チャネルではない場合に限られます。受信確認チャネルとして指定されたチャネルは、IsReceiptChannel プロパティを TRUE に設定する必要があります。また、受信確認チャネルは、その受信確認チャネルを使用するチャネル上の SourceEndpoint と同じDestinationEndpoint が指定されているメッセージ ポートを使用する必要があります。それにより、その受信確認チャネルは、ドキュメントの最初の送信元に受信確認を送信することができます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::RetryCount プロパティ [C++]

BizTalkChannel.RetryCount プロパティ [Visual Basic]

RetryCount プロパティは、送信先への接続に失敗したときのドキュメント送信の再試行回数を指定します。

構文

[C++]

Get メソッド :

HRESULT get_RetryCount(
long* plCount
);

Put メソッド :

HRESULT put_RetryCount(
long lCount
);

[Visual Basic]

object.RetryCount

パラメータ

[C++]

Get メソッド :

plCount

[out, retval] 再試行回数を含む long へのポインタです。

Put メソッド :

lCount

[in] 再試行回数を含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、再試行回数を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

RetryCount プロパティで指定する値は 0 から 999 の範囲にする必要があります。既定の再試行回数は 3 回です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::RetryInterval プロパティ [C++]

BizTalkChannel.RetryInterval プロパティ [Visual Basic]

RetryInterval プロパティは、ドキュメント送信時に送信先への接続に失敗した場合のドキュメント送信の再試行の間隔を分単位で指定します。

構文

[C++]

Get メソッド :

HRESULT get_RetryInterval(
long* pInterval
);

Put メソッド :

HRESULT put_RetryInterval(
long lInterval
);

[Visual Basic]

object.RetryInterval

パラメータ

[C++]

Get メソッド :

pInterval

[out, retval] 再試行間隔 (単位 : 分) を含む long へのポインタです。

Put メソッド :

lInterval

[in] 再試行間隔 (単位 : 分) を含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、再試行間隔 (単位 : 分) を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

RetryInterval プロパティで指定する値は 1 から 63999 の範囲にする必要があります。既定の再試行間隔は 5 分です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::SetConfigComponent メソッド [C++]

BizTalkChannel.SetConfigComponent メソッド [Visual Basic]

SetConfigComponent メソッドは、BizTalkPort オブジェクトに関連付けられているコンポーネントの CLSID を設定します。

構文

[C++]

HRESULT SetConfigComponent(
BIZTALK_CONFIGDATA_TYPE eConfigType,
 long lPortHandle,
BSTR strCLSID
);

[Visual Basic]

object.SetConfigComponent( _
eConfigType As BIZTALK_CONFIGDATA_TYPE, _
 lPortHandle As Long, _
 strCLSID As String _
)

パラメータ

[C++]

eConfigType

[in] 列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT および BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT 列挙値は、このメソッドでは使用できません。

lPortHandle

[in] ハンドルを含む Long です。

strCLSID

[in] コンポーネントの CLSID を含む BSTR です。

[Visual Basic]

eConfigType

列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT および BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT 列挙値は、このメソッドでは使用できません。

lPortHandle

ハンドルを含む Long です。

strCLSID

コンポーネントの CLSID を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::SetConfigData メソッド [C++]

BizTalkChannel.SetConfigData メソッド [Visual Basic]

SetConfigData メソッドは、BizTalkPort オブジェクトの構成情報を設定します。

構文

[C++]

HRESULT SetConfigData(

BIZTALK_CONFIGDATA_TYPE eConfigType,
 long lConfigDataHandle,
IDispatch* pConfigDataDisp
);

[Visual Basic]

object.SetConfigData( _

eConfigType As BIZTALK_CONFIGDATA_TYPE, _
lConfigDataHandle As Long, _
pConfigDataDisp As Object _
)

パラメータ

[C++]

eConfigType

[in] 列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。

lConfigDataHandle

[in] 関連付けられた BizTalkPort オブジェクトへのハンドルを識別する Long です。

pConfigDataDisp

[in] eConfigType パラメータで指定されたコンポーネントに関する情報を含むオブジェクトの IDictionary インターフェイスへのポインタです。

[Visual Basic]

eConfigType

列挙値です。有効な値は、BIZTALK_CONFIGDATA_TYPE 列挙からの値です。

lConfigDataHandle

関連付けられた BizTalkPort オブジェクトへのハンドルを識別する Long です。

pConfigDataDisp

eConfigType パラメータで指定されたコンポーネントに関する情報を含む CDictionary オブジェクトです。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドに渡される Dictionary オブジェクトには、EDIFACT および X12 に使用される特定の文字列修飾子が含まれています。これらの修飾子の詳細については、「GetConfigData メソッド」を参照してください。

BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT 列挙値または BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT 列挙値を使用する場合、トランスポート ディクショナリの内容は、使用されるプロトコルに応じて異なります。次の表は、それぞれのプロトコルに対応するトランスポート ディクショナリ フィールドの一覧です。

HTTP と HTTPS

フィールド名 | データ型 | 必須か省略可能か | 説明
URL | 文字列型 | 必須 | ドキュメント送信先の URL です。
ContentType | 文字列型 | 省略可能 | 送信時に HTTP ヘッダー内に表示される HTTP や HTTPS の コンテンツの種類のプロパティを示す値です。既定値は空の文字列 ("") です。
ClientCert | 文字列型 | 省略可能 | HTTPS による SSL 接続で使用される証明書への参照です。既定値は空の文字列 ("") です。
ProxyName | 文字列型 | 省略可能 | ファイアウォールの外部にドキュメントを送信するときに使用するプロキシ サーバーの URL です。
ProxyPort | 整数型 | 省略可能 | プロキシ サーバーで使用するポート番号です。
UseProxy | ブール型 | 省略可能 | プロキシ サーバーを使用するかどうかを示す値です。既定値は True です。

ローカル ファイル

フィールド名 | データ型 | 必須か省略可能か | 説明
Filename | 文字列型 | 必須 | 作成するファイルの名前とパスです。
CopyMode | 整数型 | 省略可能 | ファイルへの書き込み方法を示す値です。上書きモードには値 0、追加モードには値 1、ファイルの新規作成には値 2 を指定します。既定値は追加モード (1) です。
UserName | 文字列型 | 省略可能 | ファイル共有へのアクセスに必要な Windows NT ユーザ名です。既定値は空の文字列 ("") です。
Password | 文字列型 | 省略可能 | ファイル共有へのアクセスに必要な Windows NT ユーザ名です。既定値は空の文字列 ("") です。

メッセージ キュー

フィールド名 | データ型 | 必須か省略可能か | 説明
QueueName | 文字列型 | 必須 | ドキュメントの送信先のメッセージ キューの名前です。
MessageLabel | 文字列型 | 必須 | キューのメッセージ ラベル フィールドで指定する値です。
Priority | 整数型 | 省略可能 | キューに格納されているメッセージの優先度です。この値は 0 から 7 の範囲で指定し、値が大きいほど優先度が高くなります。既定値は 3 です。
AuthLevel | 整数型 | 省略可能 | デジタル署名を使用してメッセージを認証する必要があるかどうかを示す値です。認証を行わない場合は値 0 を指定します。認証を行う場合は値 1 を指定します。既定値は 0 です。
Delivery | 整数型 | 省略可能 | キューへのメッセージの配信方法を示す値です。キューに配信するまでメッセージをバックアップする場合は値 1 を指定します。メッセージをメモリに置くだけの場合は値 0 を指定します。既定値は 0 です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::SignatureCertificateInfo プロパティ [C++]

BizTalkChannel.SignatureCertificateInfo プロパティ [Visual Basic]

SignatureCertificateInfo プロパティには、出力ドキュメントに署名する証明書に関する情報が含まれます。この情報には、Name、Reference、Store、および Usage の各プロパティが含まれ、BizTalkCertificateInfo オブジェクトのメモリ内に作成および格納されます。

構文

[C++]

Get メソッド :

HRESULT get_SignatureCertificateInfo(
IDispatch** ppSignatureCertificateInfoDisp
);

Putref メソッド :

HRESULT putref_SignatureCertificateInfo(
IDispatch* pSignatureCertificateInfoDisp
);

[Visual Basic]

object.SignatureCertificateInfo

パラメータ

[C++]

Get メソッド :

ppSignatureCertificateInfoDisp

[out, retval] 証明書情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pSignatureCertificateInfoDisp

[in] 証明書情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、証明書情報を含む BizTalkCertificateInfo オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::SourceEndpoint プロパティ [C++]

BizTalkChannel.SourceEndpoint プロパティ [Visual Basic]

SourceEndpoint プロパティには、送信元に関する情報が含まれます。この情報には、Alias、Application、および Organization の各プロパティが含まれ、BizTalkEndPoint オブジェクトのメモリ内に作成および格納されます。

構文

[C++]

Get メソッド :

HRESULT get_SourceEndpoint(
IDispatch** ppSrcEndpointDisp
);

Putref メソッド :

HRESULT putref_SourceEndpoint(
IDispatch* pSrcEndpointDisp
);

[Visual Basic]

object.SourceEndpoint

パラメータ

[C++]

Get メソッド :

ppSrcEndpointDisp

[out, retval] 送信元に関する情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pSrcEndpointDisp

[in] 送信元に関する情報を含む IDispatchインターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、送信元に関する情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkChannel::TrackFields プロパティ [C++]

BizTalkChannel.TrackFields プロパティ [Visual Basic]

TrackFields プロパティは、この BizTalkChannel オブジェクトの入力ドキュメントのインターチェンジ データを追跡するフィールドを含む仕様をポイントする Dictionary オブジェクトを識別します。これらの追跡項目は、BizTalkDocument オブジェクトの TrackFields プロパティに設定されているフィールドよりも優先されます。

構文

[C++]

Get メソッド :

HRESULT get_TrackFields(
IDispatch** ppTrackFieldsDisp
);

Putref メソッド :

HRESULT putref_TrackFields(
IDispatch* pTrackFieldsDisp
);

[Visual Basic]

object.TrackFields

パラメータ

[C++]

Get メソッド :

ppTrackFieldsDisp

[out, retval] カスタム追跡項目を含むオブジェクトの IDictionary インターフェイスへのポインタのアドレスです。

Putref メソッド :

pTrackFieldsDisp

[in] カスタム追跡項目を含むオブジェクトの IDictionary インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、カスタム追跡項目を含む CDictionary オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Dictionary オブジェクト内のフィールドには、ドキュメントで追跡されるフィールドを識別する XPath 値が含まれている必要があります。既定では、Dictionary オブジェクトには、ドキュメントのデータを追跡するためにあらかじめ定義された 8 つのフィールドがあります。これらのあらかじめ定義されたフィールドは、整数、実数、日付、および文字列データ型のそれぞれに対して、2 つのフィールドで構成されています。追跡のためのフィールドを追加する必要がある場合は、Dictionary オブジェクトの x_custom_search フィールドを使用して、SimpleList オブジェクトに値を設定することができます。SimpleList オブジェクトには、そのほかの追跡項目をポイントする XPath の一覧が含まれています。XPath の値は、Add メソッドを使用して一覧に追加、および Delete メソッドを使用して一覧から削除することができます。

次の表は、TrackFields に対する Dictionary オブジェクト内のフィールド名を示しています。

フィールド名 | フィールドのデータ型
i_value1 | 整数値
i_value2 | 整数値
r_value1 | 実数値
r_value2 | 実数値
d_value1 | 日付値
d_value2 | 日付値
s_value1 | 文字列値
s_value2 | 文字列値
x_custom_search | そのほかのデータ項目を返すための一覧です。

XPath 式の詳細については、Microsoft の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で "XPath" を検索してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント トラッキング


IBizTalkChannel::VerifySignatureCertificateInfo プロパティ [C++]

BizTalkChannel.VerifySignatureCertificateInfo プロパティ [Visual Basic]

VerifySignatureCertificateInfo プロパティには、入力ドキュメントの署名を確認する証明書に関する情報が含まれます。この情報には、Name、Reference、Store、および Usage の各プロパティが含まれ、BizTalkCertificateInfo オブジェクトのメモリ内に作成および格納されます。

構文

[C++]

Get メソッド :

HRESULT get_VerifySignatureCertificateInfo(
IDispatch** ppVerifySignatureCertificateInfoDisp
);

Putref メソッド :

HRESULT putref_VerifySignatureCertificateInfo(
IDispatch* pVerifySignatureCertificateInfoDisp
);

[Visual Basic]

object.VerifySignatureCertificateInfo

パラメータ

[C++]

Get メソッド :

ppVerifySignatureCertificateInfoDisp

[out, retval] 証明書情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Put メソッド :

pVerifySignatureCertificateInfoDisp

[in] 証明書情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、証明書情報を含む BizTalkCertificateInfo オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig インターフェイス [C++]

BizTalkConfig オブジェクト [Visual Basic]

BizTalkConfig オブジェクトは、チャネル、ドキュメント仕様、エンベロープ、組織、ポート、およびポート グループを作成するために使用します。

C++ では、BizTalkConfig オブジェクトのメソッドにアクセスするには IBizTalkConfig インターフェイスを使用します。

次の表は、BizTalkConfig オブジェクトのプロパティを示しています。

プロパティ | データ型 | 説明
Certificates (証明書) | Object | 指定された証明書すべてを含む ADO レコード セットを返します。これは読み取り専用プロパティです。
Channels (チャネル) | Object | BizTalkChannel オブジェクトすべてを含む ADO レコード セットを返します。これは読み取り専用プロパティです。
Documents (ドキュメント) | Object | BizTalkDocument オブジェクトすべてを含む ADO レコード セットを返します。これは読み取り専用プロパティです。
Envelopes (エンベロープ) | Object | BizTalkEnvelope オブジェクトすべてを含む ADO レコード セットを返します。
Organizations (組織) | Object | BizTalkOrganization オブジェクトすべてを含む ADO レコード セットを返します。これは読み取り専用プロパティです。
PortGroups (ポート グループ) | Object | BizTalkPortGroup オブジェクトすべてを含む ADO レコード セットを返します。これは読み取り専用プロパティです。
Ports (ポート) | Object | BizTalkPort オブジェクトすべてを含む ADO レコード セットを返します。これは読み取り専用プロパティです。

次の表は、BizTalkConfig オブジェクトのメソッドを示しています。

メソッド | 説明
CreateChannel | 新しい BizTalkChannel オブジェクトへのポインタのアドレスを返します。
CreateDocument | 新しい BizTalkDocument オブジェクトへのポインタのアドレスを返します。
CreateEnvelope | 新しい BizTalkEnvelope オブジェクトへのポインタのアドレスを返します。
CreateOrganization | 新しい BizTalkOrganization オブジェクトへのポインタのアドレスを返します。
CreatePort | 新しい BizTalkPort オブジェクトへのポインタのアドレスを返します。
CreatePortGroup | 新しい BizTalkPortGroup オブジェクトへのポインタのアドレスを返します。

解説

C++ では、このインターフェイスのメソッドの 1 つを使用して作成された各オブジェクトは、次に示す共通のメソッドを IBizTalkBase インターフェイスから継承します。Microsoft Visual Basic では、このクラスのメソッドを使用して作成された各オブジェクトは、次に示す共通のメソッドを IBizTalkBase クラスから実装します。

  • DateModified

  • Handle

  • Name

  • Clear

  • Create

  • Load

  • LoadByName

  • Remove

  • Save

BizTalkPort オブジェクトと BizTalkChannel オブジェクトを作成すると、BizTalk Server は、関連付けられた下位オブジェクトを自動的に作成します。その下位オブジェクトにアクセスするには、BizTalkPort オブジェクトと BizTalkChannel オブジェクトのプロパティを使用します。

次の表は、オブジェクト、下位オブジェクト、および下位オブジェクトを取得するために使用するプロパティの関係を示しています。

下位オブジェクト | 関連付けられたオブジェクト | 設定するプロパティ
BizTalkEndPoint | BizTalkPort | DestinationEndpoint (送信先エンドポイント)
BizTalkEndPoint | BizTalkChannel | SourceEndpoint (送信元エンドポイント)
BizTalkLoggingInfo | BizTalkChannel | LoggingInfo (ログ情報)
BizTalkTransportInfo | BizTalkPort | PrimaryTransport (プライマリ トランスポート)、SecondaryTransport (セカンダリ トランスポート)
BizTalkServiceWindowInfo | BizTalkPort | ServiceWindowInfo (サービス ウィンドウ情報)
BizTalkCertificateInfo | BizTalkPort | EncryptionCertificateInfo (暗号化証明書情報)
BizTalkCertificateInfo | BizTalkChannel | SignatureCertificateInfo (署名証明書情報)、VerifySignatureCertificateInfo (署名確認証明書情報)、または DecryptionCertificateInfo (暗号解読証明書情報)

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::Certificates プロパティ [C++]

BizTalkConfig.Certificates プロパティ [Visual Basic]

Certificates プロパティは、指定された証明書すべてを含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT get_Certificates(
BIZTALK_STORE_TYPE StoreType,
 BIZTALK_USAGE_TYPE UsageType,
BSTR NamePrefix,
 IDispatch** ppCertsDisp
);

[Visual Basic]

object.Certificates( _

StoreType As BIZTALK_STORE_TYPE, _
 UsageType As BIZTALK_USAGE_TYPE, _
 NamePrefix As String, _

)

パラメータ

[C++]

StoreType

[in] 列挙値です。有効な値は、BIZTALK_STORE_TYPE 列挙からの値です。

UsageType

[in] 列挙値です。有効な値は、BIZTALK_USAGE_TYPE 列挙からの値です。

NamePrefix

[in] 証明書名の選択条件として使用するプレフィックスを含む BSTR です。この値で始まる証明書の Name は、レコード セット内に返されます。この値は大文字小文字を区別します。

ppCertsDisp

[out, retval] 指定された証明書すべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

StoreType

列挙値です。有効な値は、BIZTALK_STORE_TYPE 列挙からの値です。

UsageType

列挙値です。有効な値は、BIZTALK_USAGE_TYPE 列挙からの値です。

NamePrefix

証明書名の選択条件として使用するプレフィックスを含む文字列です。この値で始まる証明書の Name は、レコード セット内に返されます。この値は大文字小文字を区別します。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

このプロパティは、指定された証明書すべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkCertificateInfo オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Name

  • Reference

  • Store

  • Usage

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::Channels プロパティ [C++]

BizTalkConfig.Channels プロパティ [Visual Basic]

Channels プロパティは、BizTalkChannel オブジェクトすべてを含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT Channels(
IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

パラメータ

[C++]

ppChannelsDisp

[out, retval] BizTalkChannel オブジェクトすべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、BizTalkChannel オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkChannel オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • DateModified

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::CreateChannel メソッド [C++]

BizTalkConfig.CreateChannel メソッド [Visual Basic]

[C++]

CreateChannel メソッドは、新しい BizTalkChannel オブジェクトへのポインタのアドレスを返します。

[Visual Basic]

CreateChannel メソッドは、新しい BizTalkChannel オブジェクトを返します。

構文

[C++]

HRESULT CreateChannel(
IDispatch** ppChannelDisp
);

[Visual Basic]

object.CreateChannel()

パラメータ

[C++]

ppChannelDisp

[out, retval] 新しい BizTalkChannel オブジェクトを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、新しい BizTalkChannel オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::CreateDocument メソッド [C++]

BizTalkConfig.CreateDocument メソッド [Visual Basic]

[C++]

CreateDocument メソッドは、新しい BizTalkDocument オブジェクトへのポインタのアドレスを返します。

[Visual Basic]

CreateDocument メソッドは、新しい BizTalkDocument オブジェクトを返します。

構文

[C++]

HRESULT CreateDocument(
IDispatch** ppDocumentDisp
);

[Visual Basic]

object.CreateDocument()

パラメータ

[C++]

ppDocumentDisp

[out, retval] 新しい BizTalkDocument オブジェクトを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、新しい BizTalkDocument オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::CreateEnvelope メソッド [C++]

BizTalkConfig.CreateEnvelope メソッド [Visual Basic]

[C++]

CreateEnvelope メソッドは、新しい BizTalkEnvelope オブジェクトへのポインタのアドレスを返します。

[Visual Basic]

CreateEnvelope メソッドは、新しい BizTalkEnvelope オブジェクトを返します。

構文

[C++]

HRESULT CreateEnvelope(
IDispatch** ppEnvelopeDisp
);

[Visual Basic]

object.CreateEnvelope()

パラメータ

[C++]

ppEnvelopeDisp

[out, retval] 新しい BizTalkEnvelope オブジェクトを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、新しい BizTalkEnvelope オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::CreateOrganization メソッド [C++]

BizTalkConfig.CreateOrganization メソッド [Visual Basic]

[C++]

CreateOrganization メソッドは、新しい BizTalkOrganization オブジェクトへのポインタのアドレスを返します。

[Visual Basic]

CreateOrganization メソッドは、新しい BizTalkOrganization オブジェクトを返します。

構文

[C++]

HRESULT CreateOrganization(
IDispatch** ppOrganizationDisp
);

[Visual Basic]

object.CreateOrganization()

パラメータ

[C++]

ppOrganizationDisp

[out, retval] 新しい BizTalkOrganization オブジェクトを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、新しい BizTalkOrganization オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::CreatePort メソッド [C++]

BizTalkConfig.CreatePort メソッド [Visual Basic]

[C++]

CreatePort メソッドは、新しい BizTalkPort オブジェクトへのポインタのアドレスを返します。

[Visual Basic]

CreatePort メソッドは、新しい BizTalkPort オブジェクトを返します。

構文

[C++]

HRESULT CreatePort(
IDispatch** ppPortDisp
);

[Visual Basic]

object.CreatePort()

パラメータ

[C++]

ppPortDisp

[out, retval] 新しい BizTalkPort オブジェクトを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、新しい BizTalkPort オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::CreatePortGroup メソッド [C++]

BizTalkConfig.CreatePortGroup メソッド [Visual Basic]

[C++]

CreatePortGroup メソッドは、新しい BizTalkPortGroup オブジェクトへのポインタのアドレスを返します。

[Visual Basic]

CreatePortGroup メソッドは、新しい BizTalkPortGroup オブジェクトを返します。

構文

[C++]

HRESULT CreatePortGroup(
IDispatch** ppPortGroupDisp
);

[Visual Basic]

object.CreatePortGroup()

パラメータ

[C++]

ppPortGroupDisp

[out, retval] 新しい BizTalkPortGroup オブジェクトを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、新しい BizTalkPortGroup オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::Documents プロパティ [C++]

BizTalkConfig.Documents プロパティ [Visual Basic]

Documents プロパティは、BizTalkDocument オブジェクトすべてを含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT Documents(
IDispatch** ppDocumentsDisp
);

[Visual Basic]

object.Documents

パラメータ

[C++]

ppDocumentsDisp

[out, retval] BizTalkDocument オブジェクトすべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、BizTalkDocument オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkDocument オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • DateModified

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::Envelopes プロパティ [C++]

BizTalkConfig.Envelopes プロパティ [Visual Basic]

Envelopes プロパティは、BizTalkEnvelope オブジェクトすべてを含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT Envelopes(
IDispatch** ppEnvelopesDisp
);

[Visual Basic]

object.Envelopes

パラメータ

[C++]

ppEnvelopesDisp

[out, retval] BizTalkEnvelope オブジェクトすべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、BizTalkEnvelope オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkEnvelope オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • DateModified

  • Format

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::Organizations プロパティ [C++]

BizTalkConfig.Organizations プロパティ [Visual Basic]

Organizations プロパティは、BizTalkOrganization オブジェクトすべてを含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT Organizations(
IDispatch** ppOrganizationsDisp
);

[Visual Basic]

object.Organizations

パラメータ

[C++]

ppOrganizationsDisp

[out, retval] BizTalkOrganization オブジェクトすべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、BizTalkOrganization オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkOrganization オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • DateModified

  • IsDefault

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::PortGroups プロパティ [C++]

BizTalkConfig.PortGroups プロパティ [Visual Basic]

PortGroups プロパティは、BizTalkPortGroup オブジェクトすべてを含む ADO レコード セットを返します。

構文

[C++]

HRESULT PortGroups(
IDispatch** ppPortGroupsDisp
);

[Visual Basic]

object.PortGroups

パラメータ

[C++]

ppPortGroupsDisp

[out, retval] BizTalkPortGroup オブジェクトすべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、BizTalkPortGroup オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkPortGroup オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • DateModified

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkConfig::Ports プロパティ [C++]

BizTalkConfig.Ports プロパティ [Visual Basic]

Ports プロパティは、BizTalkPort オブジェクトすべてを含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT Ports(
IDispatch** ppPortsDisp
);

[Visual Basic]

object.Ports

パラメータ

[C++]

ppPortsDisp

[out, retval] BizTalkPort オブジェクトすべてを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、BizTalkPort オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkPort オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • DateModified

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkDocument インターフェイス [C++]

BizTalkDocument オブジェクト [Visual Basic]

BizTalkDocument オブジェクトは、ドキュメントのドキュメント仕様を識別し、記述するために使用します。

C++ では、BizTalkDocument オブジェクトのメソッドにアクセスするには IBizTalkDocument インターフェイスを使用します。

次の表は、BizTalkDocument オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Content (コンテンツ) | BSTR | オブジェクトによって記述されたドキュメント仕様のコンテンツです。これは読み取り専用プロパティです。
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Handle (ハンドル) | long | オブジェクトへのハンドルです。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Name (名前) | BSTR | オブジェクトの名前です。これは BizTalkBase オブジェクトから取得される必須プロパティです。
NameSpace (名前空間) | BSTR | ドキュメント内の要素間の名前の競合を解決する文字列です。これは読み取り専用プロパティです。
PropertySet (プロパティ セット) | IDispatch | 電子データ交換 (EDI) の選択条件 (名前と値のペア) を含む Dictionary オブジェクトです。サーバーは、ドキュメントが入力されるときにオブジェクトを識別するための情報を、この選択条件に基づいて EDI ドキュメントの機能グループ ヘッダーから抽出します。出力の場合は、サーバーが EDI ドキュメントのヘッダーを作成する際に利用されます。ドキュメントが EDI ドキュメントの場合、このプロパティは必須です。
Reference (参照) | BSTR | この BizTalkDocument オブジェクトが参照するドキュメント仕様に対する Web Distributed Authoring and Versioning (WebDAV) の完全 URL です。TrackFields プロパティが設定されている場合、このプロパティは必須です。
TrackFields (追跡項目) | IDispatch | サーバーによって処理されるすべてのドキュメントを、このドキュメント インスタンスに基づいて追跡するためにトラッキングが使用するカスタム フィールドを格納する Dictionary オブジェクトです。このプロパティが設定されている場合は、Reference プロパティに WebDAV URL が含まれている必要があります。
Type (種類) | BSTR | ドキュメント仕様の種類です。これは読み取り専用プロパティです。
Version (バージョン) | BSTR | ドキュメント標準のバージョンです。これは読み取り専用プロパティです。

次の表は、BizTalkDocument オブジェクトのメソッドを示しています。

メソッド | 説明
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。このメソッドは BizTalkBase オブジェクトから取得されます。
Create | 新しいオブジェクトをデータベースに作成します。このメソッドは BizTalkBase オブジェクトから取得されます。
Load | オブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadByName | 名前によってオブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadByPropertySet | ドキュメント オブジェクトをその PropertySet オブジェクトによってロードします。
Remove | オブジェクトをデータベースから削除します。このメソッドは BizTalkBase オブジェクトから取得されます。
Save | オブジェクトをデータベースに保存します。このメソッドは BizTalkBase オブジェクトから取得されます。

解説

各 BizTalkDocument オブジェクトには、関連付けられた BizTalkChannel オブジェクトが少なくとも 1 つ必要です。複数の BizTalkDocument オブジェクトが同じドキュメント仕様を参照できます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント定義


IBizTalkDocument::Content プロパティ [C++]

BizTalkDocument.Content プロパティ [Visual Basic]

Content プロパティには、オブジェクトによって記述されるドキュメント仕様のコンテンツが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Content(
BSTR* pstrContent
);

[Visual Basic]

object.Content

パラメータ

[C++]

pstrContent

[out, retval] コンテンツを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、コンテンツを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

Create メソッドまたは Save メソッドが呼び出されると、Reference プロパティが確認されます。Create を呼び出したときにこの文字列が空でない場合、Content はドキュメント仕様のコンテンツに設定され、NameSpace プロパティはドキュメント仕様内で検出された値に変更されます。

Reference がドキュメント仕様に設定された状態でオブジェクトを作成または保存すると、参照されるドキュメント仕様の Content または NameSpace を変更しても、その内容は、参照しているオブジェクトでは自動的には更新されません。変更が加えられたドキュメント仕様を参照するオブジェクトを更新するには、まず、ドキュメント仕様を保存し、オブジェクトの Reference プロパティを現在の値に設定します。その後、参照しているオブジェクトで Save を呼び出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkDocument::LoadByPropertySet メソッド [C++]

BizTalkDocument.LoadByPropertySet メソッド [Visual Basic]

LoadByPropertySet メソッドは、ドキュメント仕様をその PropertySet によってロードします。

構文

[C++]

HRESULT LoadByPropertySet(
IDispatch** pPropSetDictionaryDisp
);

[Visual Basic]

object.LoadByPropertySet( _

pPropSetDictionaryDisp As Object _
)

パラメータ

[C++]

pPropSetDictionaryDisp

[in] PropertySet を含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

pPropSetDictionaryDisp

PropertySet を含むオブジェクトです。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkDocument::NameSpace プロパティ [C++]

BizTalkDocument.NameSpace プロパティ [Visual Basic]

NameSpace プロパティには、ドキュメント内の要素間の名前の競合を解決する文字列が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_NameSpace(
BSTR* pstrNameSpace
);

[Visual Basic]

object.NameSpace

パラメータ

[C++]

pstrNameSpace

[out, retval] 名前空間を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、名前空間を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。Create メソッドまたは Save メソッドが呼び出されると、Reference プロパティが確認されます。Create を呼び出したときにこの文字列が空でない場合、Content はドキュメント仕様のコンテンツに設定され、NameSpace はドキュメント仕様内で検出された値に変更されます。

Reference がドキュメント仕様に設定された状態でオブジェクトを作成または保存すると、参照されるドキュメント仕様の Content または NameSpace を変更しても、その内容は、参照しているオブジェクトでは自動的には更新されません。変更が加えられたドキュメント仕様を参照するオブジェクトを更新するには、まず、ドキュメント仕様を保存し、オブジェクトの Reference プロパティを現在の値に設定します。その後、参照しているオブジェクトで Save を呼び出します。

注

  • ドキュメントを作成する場合は、NameSpace 内の文字数と仕様名の文字数を足した数が 255 を超えてはなりません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkDocument::PropertySet プロパティ [C++]

BizTalkDocument.PropertySet プロパティ [Visual Basic]

PropertySet プロパティには、電子データ交換 (EDI) の選択条件 (名前と値のペア) を含む Dictionary オブジェクトが含まれます。サーバーは、ドキュメントが入力されるときにオブジェクトを識別するための情報を、この選択条件に基づいて EDI ドキュメントの機能グループ ヘッダーから抽出します。出力の場合は、サーバーが EDI ドキュメントのヘッダーを作成する際に利用されます。

構文

[C++]

Get メソッド :

HRESULT get_PropertySet(
IDispatch** ppPropSetDisp
);

Putref メソッド :

HRESULT putref_PropertySet(
IDispatch* pPropSetDisp
);

[Visual Basic]

object.PropertySet

パラメータ

[C++]

Get メソッド :

ppPropSetDisp

[out, retval] 選択条件を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pPropSetDisp

[in] 選択条件を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、選択条件を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

ドキュメントが EDI ドキュメントの場合、このプロパティは必須です。関連付けられた BizTalkPort オブジェクトの Delimiters プロパティも定義する必要があります。

次の表は、PropertySet に対する Dictionary オブジェクトで名前が必要かどうかを示しています。

選択条件 | ANSI X12 | EDIFACT
application_sender_code | 必要 | 必要
application_receiver_code | 必要 | 必要
functional_identifier | 必要 | 必要
standards_version | 必要 | 不要
standards_version_type | 不要 | 必要
standards_version_value | 不要 | 必要

注

  • Dictionary オブジェクトに含まれる名前と値のペアは、合計で 450 バイト以下にする必要があります。

PropertySet を設定できるのは、Reference プロパティが設定されている場合のみです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント定義


IBizTalkDocument::Reference プロパティ [C++]

BizTalkDocument.Reference プロパティ [Visual Basic]

Reference プロパティには、オブジェクトが参照するドキュメント仕様に対する Web Distributed Authoring and Versioning (WebDAV) の完全 URL が含まれています。

構文

[C++]

Get メソッド :

HRESULT get_Reference(
BSTR* pstrReference
);

Put メソッド :

HRESULT put_Reference(
BSTR strReference
);

[Visual Basic]

object.Reference

パラメータ

[C++]

Get メソッド :

pstrReference

[out, retval] 参照を含む BSTR へのポインタです。

Put メソッド :

strReference

[in] 参照を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、参照を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Create メソッドまたは Save メソッドが呼び出されると、Reference が確認されます。Create を呼び出したときにこの文字列が空でない場合、Content はドキュメント仕様のコンテンツに設定され、NameSpace プロパティはドキュメント仕様内で検出された値に変更されます。

Reference がドキュメント仕様に設定された状態でオブジェクトを作成または保存すると、参照されるドキュメント仕様の Content または NameSpace を変更しても、その内容は、参照しているオブジェクトでは自動的には更新されません。変更が加えられたドキュメント仕様を参照するオブジェクトを更新するには、まず、ドキュメント仕様を保存し、オブジェクトの Reference プロパティを現在の値に設定します。その後、参照しているオブジェクトで Save を呼び出します。

Reference が設定されていない場合は、PropertySet プロパティと TrackFields プロパティを設定することはできません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkDocument::TrackFields プロパティ [C++]

BizTalkDocument.TrackFields プロパティ [Visual Basic]

TrackFields プロパティは、ドキュメントを追跡するために使用されるカスタム フィールドを格納する Dictionary オブジェクトを識別します。BizTalkDocument オブジェクトは、ドキュメントを追跡するフィールドを含む仕様を示します。指定されたフィールドは、処理されるドキュメントのインスタンスごとに、追跡データベースにログが記録されます。BizTalkDocument オブジェクト上の追跡項目はグローバルです。BizTalkChannel オブジェクトの TrackFields プロパティは、このプロパティで指定された値よりも優先されます。

構文

[C++]

Get メソッド :

HRESULT get_TrackFields(
IDispatch** ppTrackFieldsDisp
);

Putref メソッド :

HRESULT putref_TrackFields(
IDispatch* pTrackFieldsDisp
);

[Visual Basic]

object.TrackFields

パラメータ

[C++]

Get メソッド :

ppTrackFieldsDisp

[out, retval] カスタム追跡項目を含むオブジェクトの IDictionary インターフェイスへのポインタのアドレスです。

Putref メソッド :

pTrackFieldsDisp

[in] カスタム追跡項目を含むオブジェクトの IDictionary インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、カスタム追跡項目を含む CDictionary オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

TrackFields を設定できるのは、Reference プロパティが設定されている場合のみです。出力 BizTalkDocument オブジェクトに対して指定された追跡項目は無視されます。

Dictionary オブジェクト内のフィールドには、ドキュメントで追跡されるフィールドを識別する XPath 値が含まれている必要があります。既定では、Dictionary オブジェクトには、ドキュメントのデータを追跡するためにあらかじめ定義された 8 つのフィールドがあります。これらのあらかじめ定義されたフィールドは、整数、実数、日付、および文字列データ型のそれぞれに対して、2 つのフィールドで構成されています。追跡のためのフィールドを追加する必要がある場合は、Dictionary オブジェクトの x_custom_search フィールドを使用して、SimpleList オブジェクトに値を設定することができます。SimpleList オブジェクトには、そのほかの追跡項目をポイントする XPath の一覧が含まれています。XPath の値は、Add メソッドを使用して一覧に追加、および Delete メソッドを使用して一覧から削除することができます。

次の表は、TrackFields に対する Dictionary オブジェクト内のフィールド名を示しています。

フィールド名 | フィールドのデータ型
i_value1 | 整数値
i_value2 | 整数値
r_value1 | 実数値
r_value2 | 実数値
d_value1 | 日付値
d_value2 | 日付値
s_value1 | 文字列値
s_value2 | 文字列値
x_custom_search | そのほかのデータ項目を返すための一覧です。

XPath 式の詳細については、Microsoft の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で "XPath" を検索してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント定義

ドキュメント トラッキング


IBizTalkDocument::Type プロパティ [C++]

BizTalkDocument.Type プロパティ [Visual Basic]

Type プロパティには、ドキュメント仕様の種類が含まれます。

構文

[C++]

HRESULT get_Type(
BSTR* pstrType
);

[Visual Basic]

object.Type

パラメータ

[C++]

pstrType

[out, retval] ドキュメントの種類を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、ドキュメントの種類を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。すべてのドキュメント インスタンスは、関連付けられたエンベロープと同じドキュメント型である必要があります。たとえば、BizTalkEnvelope オブジェクトの Format プロパティが X12 に設定されている場合は、Type も X12 にします。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkDocument::Version プロパティ [C++]

BizTalkDocument.Version プロパティ [Visual Basic]

Version プロパティには、ドキュメント標準のバージョンが含まれます。

構文

[C++]

HRESULT get_Version(
BSTR* pstrVersion
);

[Visual Basic]

object.Version

パラメータ

[C++]

pstrVersion

[out, retval] バージョンを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、バージョンを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEndPoint インターフェイス [C++]

BizTalkEndPoint オブジェクト [Visual Basic]

BizTalkEndPoint オブジェクトは、BizTalkChannel オブジェクトの送信元情報および BizTalkPort オブジェクトの送信先情報を構成するために使用します。

C++ では、BizTalkEndPoint オブジェクトのメソッドにアクセスするには IBizTalkEndPoint インターフェイスを使用します。

次の表は、BizTalkEndPoint オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Alias (エイリアス) | long | 関連付けられている BizTalkPort オブジェクトに対する送信先 BizTalkOrganization オブジェクトの組織識別子の種類と値のペアへのハンドルです。
Applications (アプリケーション) | long | この BizTalkPort オブジェクトに対する送信先 BizTalkOrganization オブジェクトの関連付けられたアプリケーションへのハンドルです。
Openness (オープンネス) | BIZTALK_OPENNESS_ TYPE_EX | オブジェクトがオープンであるかどうかを示す列挙値です。
Organizations (組織) | long | この BizTalkPort オブジェクトの送信先 BizTalkOrganization オブジェクトへのハンドルです。Openness プロパティが BIZTALK_OPENNESS_ TYPE_EX_DESTINATION に設定されていない場合、これはこのオブジェクトが完了するための必須プロパティです。

解説

BizTalkConfig オブジェクトの CreatePort メソッドまたは CreateChannel メソッドを使用して BizTalkPort オブジェクトまたは BizTalkChannel オブジェクトのインスタンスを作成すると、BizTalkEndPoint オブジェクトが自動的に作成されます。

送信先エンドポイントに対しては、BizTalkPort オブジェクトの DestinationEndpoint プロパティを使用して、BizTalkEndPoint オブジェクトにアクセスします。送信元エンドポイントに対しては、BizTalkChannel オブジェクトの SourceEndpoint プロパティを使用して、BizTalkEndPoint オブジェクトにアクセスします。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEndPoint::Alias プロパティ [C++]

BizTalkEndPoint.Alias プロパティ [Visual Basic]

Alias プロパティには、エイリアスへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Alias(
long* plAliasHandle
);

Put メソッド :

HRESULT put_Alias(
long lAliasHandle
);

[Visual Basic]

object.Alias

パラメータ

[C++]

Get メソッド :

plAliasHandle

[out, retval] エイリアスへのハンドルを含む long へのポインタです。

Put メソッド :

lAliasHandle

[in] エイリアスへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、エイリアスへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEndPoint::Application プロパティ [C++]

BizTalkEndPoint.Application プロパティ [Visual Basic]

Application プロパティには、アプリケーションへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Application(
long* plAppHandle
);

Put メソッド :

HRESULT put_Application(
long lAppHandle
);

[Visual Basic]

object.Application

パラメータ

[C++]

Get メソッド :

plAppHandle

[out, retval] アプリケーションへのハンドルを含む long へのポインタです。

Put メソッド :

lAppHandle

[in] アプリケーションへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、アプリケーションへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEndPoint::Openness プロパティ [C++]

BizTalkEndPoint.Openness プロパティ [Visual Basic]

Openness プロパティには、オブジェクトにオープンな送信先または送信元があるか、あるいはそのどちらもないかを示す列挙値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Openness(
BIZTALK_OPENNESS_TYPE_EX* pOpennessType
);

Put メソッド :

HRESULT put_Openness(
BIZTALK_OPENNESS_TYPE_EX OpennessType
);

[Visual Basic]

object.Openness

パラメータ

[C++]

Get メソッド :

pOpennessType

[out, retval] 列挙値へのポインタです。有効な値は BIZTALK_OPENNESS_TYPE_EX 列挙からの値です。

Put メソッド:

OpennessType

[in] 列挙値です。有効な値は BIZTALK_OPENNESS_TYPE_EX 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は BIZTALK_OPENNESS_TYPE_EX 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalkPort オブジェクトが有効になるのは、IInterchange インターフェイスの Submit メソッドまたは SubmitSync メソッドに関連付けられたドキュメントやパラメータの情報が不足していると識別している場合のみです。

Openness が、チャネルに関連付けられている BizTalkEndPoint オブジェクトの BIZTALK_OPENNESS_TYPE_EX_SOURCE に設定されている場合は、次の制約が適用されます。

  • SignatureType プロパティを設定することはできません。

  • BizTalkPort オブジェクトは、ポート グループに含むことができません。

Openness がチャネル上の BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW に設定されている場合は、関連付けられている BizTalkOrganization オブジェクトを既定の組織にする必要があります。

このオブジェクトの Openness が、メッセージ ポートに関連付けられている BizTalkEndPoint オブジェクトの BIZTALK_OPENNESS_TYPE_EX_DESTINATION に設定されている場合は、次の制約が適用されます。

  • PrimaryTransportType プロパティを BIZTALK_TRANSPORT_TYPE_OPENDESTINATION に設定する必要があります。

  • EncryptionType プロパティを設定することはできません。

  • Submit または SubmitSync 上のドキュメントまたはパラメータは、送信先、トランスポートの種類、およびアドレスを指定する必要があります。

  • BizTalkPort オブジェクトは、ポート グループに含むことができません。

注

  • 既存のポートでこのプロパティを変更することはできません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

オープンネス


IBizTalkEndPoint::Organization プロパティ [C++]

BizTalkEndPoint.Organization プロパティ [Visual Basic]

Organization プロパティには、組織へのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Organization(
long* plOrganizationHandle
);

Put メソッド :

HRESULT put_Organization(
long lOrganizationHandle
);

[Visual Basic]

object.Organization

パラメータ

[C++]

Get メソッド :

plOrganizationHandle

[out, retval] 組織へのハンドルを含む long へのポインタです。

Put メソッド :

lOrganizationHandle

[in] 組織へのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、組織へのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEnvelope インターフェイス [C++]

BizTalkEnvelope オブジェクト [Visual Basic]

BizTalk Server によって処理されるドキュメントに使用するエンベロープ書式を構成するには、BizTalkEnvelope オブジェクトを使用します。エンベロープは、インターチェンジのためのヘッダー情報です。

C++ では、BizTalkEnvelope オブジェクトのメソッドにアクセスするには IBizTalkEnvelope インターフェイスを使用します。

次の表は、BizTalkEnvelope オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Content (コンテンツ) | BSTR | 選択したエンベロープ書式仕様のコンテンツです。これは読み取り専用プロパティです。
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Format (書式) | BSTR | エンベロープの種類を識別する文字列です。
Handle (ハンドル) | long | オブジェクトへのハンドルです。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Name (名前) | BSTR | オブジェクトの名前です。これは BizTalkBase オブジェクトから取得される必須プロパティです。
NameSpace (名前空間) | BSTR | エンベロープ仕様の要素間の名前の競合を解決する文字列です。これは読み取り専用プロパティです。
Reference (参照) | BSTR | エンベロープ書式仕様ファイルの完全な Web Distributed Authoring and Versioning (WebDAV) URL 名です。Format プロパティが "custom" に設定されている場合は、このプロパティは必須プロパティです。
Version (バージョン) | BSTR | エンベロープ書式仕様のバージョンです。これは読み取り専用プロパティです。

次の表は、BizTalkEnvelope オブジェクトのメソッドを示しています。

メソッド | 説明
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。このメソッドは BizTalkBase オブジェクトから取得されます。
Create | 新しいオブジェクトをデータベースに作成します。このメソッドは BizTalkBase オブジェクトから取得されます。
Load | オブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadByName | 名前によってオブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
Remove | オブジェクトをデータベースから削除します。このメソッドは BizTalkBase オブジェクトから取得されます。
Save | オブジェクトをデータベースに保存します。このメソッドは BizTalkBase オブジェクトから取得されます。

解説

1 つの電子データ交換 (EDI) 機能グループ内のすべてのドキュメント インスタンスは、同じ書式である必要があります。すべてのドキュメント インスタンスは、関連付けられたエンベロープと同じドキュメント型である必要があります。たとえば、Format が X12 に設定されている場合、関連付けられた BizTalkPort オブジェクトに対する BizTalkDocument オブジェクトの Type プロパティも X12 である必要があります。

EDIFACT 形式のエンベロープを使用しているときに、送信元か送信先のヘッダー内の空の修飾子に NULL 値を使用する場合、ダッシュ (-) 1 つを修飾子にしたカスタム識別子を作成します。このようにするには、BizTalkOrganization オブジェクトで CreateAlias メソッドを使用します。入力 EDIFACT エンベロープで空の修飾子が見つかると、サーバーによって空の修飾子がダッシュに変換されます。出力 EDIFACT エンベロープの場合は、このダッシュが空の修飾子に変換されます。

BizTalkDocument オブジェクトの Type プロパティが "flatfile" か "custom xml" に設定されている場合、入力ドキュメントには BizTalkEnvelope オブジェクトが必要です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

エンベロープ


IBizTalkEnvelope::Content プロパティ [C++]

BizTalkEnvelope.Content プロパティ [Visual Basic]

Content プロパティには、選択したエンベロープ書式仕様のコンテンツが含まれます。

構文

[C++]

HRESULT get_Content(
BSTR* pstrContent
);

[Visual Basic]

object.Content

パラメータ

[C++]

pstrContent

[out, retval] コンテンツを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、コンテンツを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

Create メソッドまたは Save メソッドが呼び出されると、Reference プロパティが確認されます。 Create を呼び出したときにこの文字列が空でない場合、Content はエンベロープ仕様のコンテンツに設定され、NameSpace プロパティはエンベロープ仕様内で検出された値に変更されます。

Reference がエンベロープ仕様に設定されている状態でオブジェクトを作成または保存すると、参照されるエンベロープ仕様の Content または NameSpace を変更しても、その内容は、参照しているオブジェクトでは自動的には更新されません。変更が加えられたエンベロープ仕様を参照するオブジェクトを更新するには、まず、エンベロープ仕様を保存し、オブジェクトの Reference プロパティを現在の値に設定します。その後、参照しているオブジェクトで Save を呼び出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEnvelope::Format プロパティ [C++]

BizTalkEnvelope.Format プロパティ [Visual Basic]

Format プロパティには、エンベロープの種類を識別する文字列が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Format(
BSTR* pstrFormat
);

Put メソッド :

HRESULT put_Format(
BSTR Format
);

[Visual Basic]

object.Format

パラメータ

[C++]

Get メソッド :

pstrFormat

[out, retval] エンベロープ書式を含む BSTR へのポインタです。

Put メソッド :

Format

[in] エンベロープ書式を含む BSTR です。BSTR は、以下の「解説」に一覧表示されている値のいずれかである必要があります。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、エンベロープ書式を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

書式の値は、次の文字列のいずれかである必要があります。

  • x12

  • edifact

  • custom xml (既定)

  • custom

  • flatfile

  • reliable

注

  • これ以外の文字列の場合は、実行時にエラーが発生します。

プロパティが "custom" に設定されている場合は、Reference プロパティが必要です。また、このプロパティが "custom" に設定されている入力ドキュメントのために、カスタム パーサー コンポーネントをサーバーに登録する必要があります。カスタム パーサー コンポーネントの詳細については、「IBizTalkParserComponent インターフェイスの使用」を参照してください。

すべてのドキュメント インスタンスは、関連付けられたエンベロープと同じドキュメント型である必要があります。たとえば、Format が "x12" に設定されてる場合、BizTalkDocument オブジェクトのType プロパティも "x12" である必要があります。

Format が、"x12"、"edifact"、または "reliable" に設定されている場合は、Reference プロパティを設定してはなりません。

エンベロープ書式の詳細については、「エンベロープの作成」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

エンベロープ


IBizTalkEnvelope::NameSpace プロパティ [C++]

BizTalkEnvelope.NameSpace プロパティ [Visual Basic]

NameSpace プロパティには、エンベロープ書式内の要素間の名前の競合を解決する文字列が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_NameSpace(
BSTR* pstrNameSpace
);

[Visual Basic]

object.NameSpace

パラメータ

[C++]

pstrNameSpace

[out, retval] 名前空間を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、名前空間を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。Create メソッドまたは Save メソッドが呼び出されると、Reference プロパティが確認されます。Create を呼び出したときにこの文字列が空でない場合、Content プロパティはエンベロープ仕様のコンテンツに設定され、NameSpace はエンベロープ仕様内で検出された値に変更されます。

Reference がエンベロープ仕様に設定されている状態でオブジェクトを作成または保存すると、参照されるエンベロープ仕様の Content または NameSpace を変更しても、その内容は、参照しているオブジェクトでは自動的には更新されません。変更が加えられたエンベロープ仕様を参照するオブジェクトを更新するには、まず、エンベロープ仕様を保存し、オブジェクトの Reference プロパティを現在の値に設定します。その後、参照しているオブジェクトで Save を呼び出します。

注

  • エンベロープを作成する場合は、NameSpace 内の文字数と仕様名の文字数を足した数が 255 を超えてはなりません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEnvelope::Reference プロパティ [C++]

BizTalkEnvelope.Reference プロパティ [Visual Basic]

Reference プロパティには、エンベロープ書式仕様ファイルの完全な Web Distributed Authoring and Versioning (WebDAV) URL が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Reference(
BSTR* pReference
);

Put メソッド :

HRESULT put_Reference(
BSTR Reference
);

[Visual Basic]

object.Reference

パラメータ

[C++]

Get メソッド :

pReference

[out, retval] 参照を含む BSTR へのポインタです。

Put メソッド :

Reference

[in] 参照を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、参照を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Format プロパティが "custom" に設定されている場合は、このプロパティは必須プロパティです。Create メソッドまたは Save メソッドが呼び出されると、Reference が確認されます。Create を呼び出したときにこの文字列が空でない場合、Content プロパティはエンベロープ仕様のコンテンツに設定され、NameSpace プロパティはエンベロープ仕様内で検出された値に変更されます。

Reference がエンベロープ仕様に設定されている状態でオブジェクトを作成または保存すると、参照されるエンベロープ仕様の Content または NameSpace を変更しても、その内容は、参照しているオブジェクトでは自動的には更新されません。変更が加えられたエンベロープ仕様を参照するオブジェクトを更新するには、まず、エンベロープ仕様を保存し、オブジェクトの Reference プロパティを現在の値に設定します。その後、参照しているオブジェクトで Save を呼び出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkEnvelope::Version プロパティ [C++]

BizTalkEnvelope.Version プロパティ [Visual Basic]

Version プロパティには、エンベロープ書式仕様のバージョンが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Version(
BSTR* pstrVersion
);

[Visual Basic]

object.Version

パラメータ

[C++]

pstrVersion

[out, retval] バージョンを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、バージョンを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkLoggingInfo インターフェイス [C++]

BizTalkLoggingInfo オブジェクト [Visual Basic]

BizTalkLoggingInfo オブジェクトは、関連付けられた BizTalkChannel オブジェクトのドキュメント ログ情報を構成するために使用します。

C++ では、BizTalkLoggingInfo オブジェクトのメソッドにアクセスするには IBizTalkLoggingInfo インターフェイスを使用します。

IBizTalkLoggingInfo インターフェイスは、次のプロパティを定義します。

プロパティ | 種類 | 説明
LogNativeInputDocument (入力ドキュメントのネイティブ形式ログ) | VARIANT_BOOL | 入力ドキュメント インスタンスがネイティブ形式で保存およびログに記録されるかどうかを示すフラグです。
LogNativeOutputDocument (出力ドキュメントのネイティブ形式ログ) | VARIANT_BOOL | 出力ドキュメント インスタンスがネイティブ形式で保存およびログに記録されるかどうかを示すフラグです。
LogXMLInputDocument (XML 入力ドキュメントのログ) | VARIANT_BOOL | XML 入力ドキュメントが保存およびログに記録されるかどうかを示すフラグです。
LogXMLOutputDocument (XML 出力ドキュメントのログ) | VARIANT_BOOL | XML 出力ドキュメントが保存およびログに記録されるかどうかを示すフラグです。

解説

BizTalkConfig オブジェクトの CreateChannel メソッドを使用して BizTalkChannel オブジェクトのインスタンスを作成すると、BizTalkLoggingInfo オブジェクトが自動的に作成されます。BizTalkLoggingInfo オブジェクトには、BizTalkChannel オブジェクトの LoggingInfo プロパティを使用してアクセスできます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント格納


IBizTalkLoggingInfo::LogNativeInputDocument プロパティ [C++]

BizTalkLoggingInfo.LogNativeInputDocument プロパティ [Visual Basic]

LogNativeInputDocument プロパティには、入力ドキュメント インスタンスがネイティブ形式で保存およびログに記録されるかどうかを示すフラグが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_LogNativeInputDocument(
VARIANT_BOOL* pbLogNativeInDoc
);

Put メソッド :

HRESULT put_LogNativeInputDocument(
VARIANT_BOOL bLogNativeInDoc
);

[Visual Basic]

object.LogNativeInputDocument

パラメータ

[C++]

Get メソッド :

pbLogNativeInDoc

[out, retval] フラグを含む VARIANT_BOOL 型へのポインタです。VARIANT_TRUE の値は、入力ドキュメントがネイティブ形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、入力ドキュメントがネイティブ形式で保存およびログに記録されないことを示します。

Put メソッド :

bLogNativeInDoc

[in] フラグを含む VARIANT_BOOL 型です。VARIANT_TRUE の値は、ドキュメントがネイティブ形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、ドキュメントがネイティブ形式で保存およびログに記録されないことを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、フラグを含む Variant を返します。True の値は、入力ドキュメントがネイティブ形式で保存およびログに記録されることを示します。False の値は、入力ドキュメントがネイティブ形式で保存およびログに記録されないことを示します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント格納


IBizTalkLoggingInfo::LogNativeOutputDocument プロパティ [C++]

BizTalkLoggingInfo.LogNativeOutputDocument プロパティ [Visual Basic]

LogNativeOutputDocument プロパティには、出力ドキュメント インスタンスがネイティブ形式で保存およびログに記録されるかどうかを示すフラグが含まれています。

構文

[C++]

Get メソッド :

HRESULT get_LogNativeOutputDocument(
VARIANT_BOOL* pbLogNativeOutDoc
);

Put メソッド :

HRESULT put_LogNativeOutputDocument(
VARIANT_BOOL bLogNativeOutDoc
);

[Visual Basic]

object.LogNativeOutputDocument

パラメータ

[C++]

Get メソッド :

pbLogNativeOutDoc

[out, retval] フラグを含む VARIANT_BOOL 型へのポインタです。VARIANT_TRUE の値は、出力ドキュメントがネイティブ形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、出力ドキュメントがネイティブ形式で保存およびログに記録されないことを示します。

Put メソッド :

bLogNativeOutDoc

[in] フラグを含む VARIANT_BOOL 型です。VARIANT_TRUE の値は、出力ドキュメントがネイティブ形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、出力ドキュメントがネイティブ形式で保存およびログに記録されないことを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、フラグを含む Variant を返します。True の値は、出力ドキュメントがネイティブ形式で保存およびログに記録されることを示します。False の値は、出力ドキュメントがネイティブ形式で保存およびログに記録されないことを示します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント格納


IBizTalkLoggingInfo::LogXMLInputDocument プロパティ [C++]

BizTalkLoggingInfo.LogXMLInputDocument プロパティ [Visual Basic]

LogXMLInputDocument プロパティには、XML 入力ドキュメント インスタンスが保存およびログに記録されるかどうかを示すフラグが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_LogXMLInputDocument(
VARIANT_BOOL* pbLogXMLInDoc
);

Put メソッド :

HRESULT put_LogXMLInputDocument(
VARIANT_BOOL bLogXMLInDoc
);

[Visual Basic]

object.LogXMLInputDocument

[C++]

Get メソッド :

pbLogXMLInDoc

[out, retval] フラグを含む VARIANT_BOOL 型へのポインタです。VARIANT_TRUE の値は、入力ドキュメントが XML 形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、入力ドキュメントが XML 形式で保存およびログに記録されないことを示します。

Put メソッド :

bLogXMLInDoc

[in] フラグを含む VARIANT_BOOL 型です。VARIANT_TRUE の値は、入力ドキュメントが XML 形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、入力ドキュメントが XML 形式で保存およびログに記録されないことを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、フラグを含む Variant を返します。True の値は、入力ドキュメントが XML 形式で保存およびログに記録されることを示します。False の値は、入力ドキュメントが XML 形式で保存およびログに記録されないことを示します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント格納


IBizTalkLoggingInfo::LogXMLOutputDocument プロパティ [C++]

BizTalkLoggingInfo.LogXMLOutputDocument プロパティ [Visual Basic]

LogXMLOutputDocument プロパティには、XML 出力ドキュメント インスタンスが保存およびログに記録されるかどうかを示すフラグが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_LogXMLOutputDocument(
VARIANT_BOOL* pbLogXMLOutDoc
);

Put メソッド :

HRESULT put_LogXMLOutputDocument(
VARIANT_BOOL bLogXMLOutDoc
);

[Visual Basic]

object.LogXMLOutputDocument

[C++]

Get メソッド :

pbLogXMLOutDoc

[out, retval] フラグを含む VARIANT_BOOL 型へのポインタです。VARIANT_TRUE の値は、出力ドキュメントが XML 形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、出力ドキュメントが XML 形式で保存およびログに記録されないことを示します。

Put メソッド :

bLogXMLOutDoc

[in] プロパティを設定する場合、フラグを含む VARIANT_BOOL 型です。VARIANT_TRUE の値は、出力ドキュメントが XML 形式で保存およびログに記録されることを示します。VARIANT_FALSE の値は、出力ドキュメントが XML 形式で保存およびログに記録されないことを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、フラグを含む Variant を返します。True の値は、出力ドキュメントが XML 形式で保存およびログに記録されることを示します。False の値は、出力ドキュメントが XML 形式で保存およびログに記録されないことを示します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント格納


IBizTalkOrganization インターフェイス [C++]

BizTalkOrganization オブジェクト [Visual Basic]

BizTalkOrganization オブジェクトは、組織、組織識別子 (エイリアス)、およびドキュメントを送受信する組織内のアプリケーションを構成するために使用します。このアプリケーションは、ドキュメントの最終的な送信元と送信先を示します。

C++ では、BizTalkOrganization オブジェクトのメソッドにアクセスするには IBizTalkOrganization インターフェイスを使用します。

次の表は、BizTalkOrganization オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Aliases (エイリアス) | IDispatch | オブジェクトを参照するエイリアスの ADO レコード セットです。オブジェクトのエイリアスは、組織識別子の種類と値のペアです。
Applications (アプリケーション) | IDispatch | オブジェクトを参照するアプリケーションの ADO レコード セットです。
Comments (コメント) | BSTR | オブジェクトに対するユーザー コメントです。
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Handle (ハンドル) | long | オブジェクトの識別子です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
IsDefault (既定) | VARIANT_BOOL | オブジェクトが既定の組織かどうかを示すフラグです。
Name (名前) | BSTR | オブジェクトの名前です。これは BizTalkBase オブジェクトから取得される必須プロパティです。

次の表は、BizTalkOrganization オブジェクトのメソッドを示しています。

メソッド | 説明
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。このメソッドは BizTalkBase オブジェクトから取得されます。
Create | 新しいオブジェクトをデータベースに作成します。このメソッドは BizTalkBase オブジェクトから取得されます。
CreateAlias | オブジェクトのエイリアスを作成します。エイリアスは、組織識別子の種類と値のペアです。
CreateApplication | 新しいアプリケーションを作成します。
GetDefaultAlias | オブジェクトの既定のエイリアスを取得します。
Load | オブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadAlias | メモリ内のオブジェクトに対する既存のエイリアスをロードします。
LoadApplication | アプリケーションをメモリにロードします。
LoadByName | 名前によってオブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
Remove | オブジェクトをデータベースから削除します。このメソッドは BizTalkBase オブジェクトから取得されます。
RemoveAlias | エイリアスを削除します。
RemoveApplication | アプリケーションを削除します。
Save | オブジェクトをデータベースに保存します。このメソッドは BizTalkBase オブジェクトから取得されます。
SaveAlias | このエイリアスを保存します。
SaveApplication | このアプリケーションを保存します。

解説

BizTalkOrganization オブジェクトは複数のアプリケーションを持つことができますが、各アプリケーション名はそのオブジェクトに対して一意である必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::Aliases プロパティ [C++]

BizTalkOrganization.Aliases プロパティ [Visual Basic]

Aliases プロパティは、このオブジェクトを参照しているすべてのエイリアスを含む ADO レコード セットを返します。オブジェクトのエイリアスは、組織の修飾子と値のペアです。

構文

[C++]

Get メソッド :

HRESULT get_Aliases(
IDispatch** ppAliasesDisp
);

[Visual Basic]

object.Aliases

パラメータ

[C++]

ppAliasesDisp

[out, retval] IDispatch インターフェイスへのポインタのアドレスで、IDispatch インターフェイスには、オブジェクトを参照するエイリアスすべてが含まれます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、オブジェクトを参照するエイリアスすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalk メッセージ マネージャは、エイリアスを識別子として参照します。

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkOrganization オブジェクトのエイリアスに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • エイリアスに割り当てられる Handle

  • CreateAlias メソッドで指定される名前

  • CreateAlias メソッドで指定されるブール値

  • CreateAlias メソッドで指定される修飾子

  • CreateAlias メソッドで指定される値

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::Applications プロパティ [C++]

BizTalkOrganization.Applications プロパティ [Visual Basic]

Applications プロパティは、Organization オブジェクトを参照するアプリケーションすべてに関する情報を含む ADO レコード セットを返します。

構文

[C++]

Get メソッド :

HRESULT get_Applications(
IDispatch** ppApplicationsDisp
);

[Visual Basic]

object.Applications

パラメータ

[C++]

ppApplicationsDisp

[out, retval] IDispatch インターフェイスへのポインタのアドレスで、IDispatch インターフェイスには、オブジェクトを参照するアプリケーションすべてが含まれます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、オブジェクトを参照するアプリケーションすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティによって返される ADO レコード セット内の各レコードには、データベース内の既存の BizTalkOrganization オブジェクトのアプリケーションに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • CreateApplication メソッドで指定される名前

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkOrganization::Comments プロパティ [C++]

BizTalkOrganization.Comments プロパティ [Visual Basic]

Comments プロパティには、オブジェクトに対するユーザー コメントが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Comments(
BSTR* pstrComments
);

Put メソッド :

HRESULT put_Comments(
BSTR strComments
);

[Visual Basic]

object.Comments

パラメータ

[C++]

Get メソッド :

pstrComments

[out, retval] コメントを含む BSTR へのポインタです。

Put メソッド :

strComments

[in] プロパティを設定する場合、コメントを含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、コメントを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkOrganization::CreateAlias メソッド [C++]

BizTalkOrganization.CreateAlias メソッド [Visual Basic]

CreateAlias メソッドは、この Organization オブジェクトの新しいエイリアスを作成します。オブジェクトのエイリアスは、名前、および修飾子と値のペアを含む組織識別子です。

構文

[C++]

HRESULT CreateAlias(
BSTR strName,
 VARIANT_BOOL bDefault,
 BSTR strQualifier,
 BSTR strValue
);

[Visual Basic]

object.CreateAlias( _
 strName As String, _
bDefault As Boolean, _
strQualifier As String, _
strValue As String _
)

パラメータ

[C++]

strName

[in] エイリアスの名前を含む BSTR です。

bDefault

[in] フラグを含む VARIANT_BOOL 型です。VARIANT_TRUE に設定されている場合、この既定のエイリアスは直前の既定のエイリアスを上書きします。VARIANT_FALSE の値は、このエイリアスが直前の既定のエイリアスを上書きしないことを示します。あるエイリアスが既定として指定されていない場合、Create メソッドを呼び出したときに、任意に割り当てられます。

strQualifier

[in] 修飾子を含む BSTR です。このパラメータは、"グループ" には設定できません。

strValue

[in] 値を含む BSTR です。

[Visual Basic]

strName

エイリアスの名前を含む文字列です。

bDefault

フラグを含む Boolean です。True に設定されている場合、この既定のエイリアスは直前の既定のエイリアスを上書きします。あるエイリアスが既定として指定されていない場合、Create メソッドを呼び出したときに、任意に割り当てられます。

strQualifier

修飾子を含む文字列です。このパラメータは、"グループ" には設定できません。

strValue

値を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalkOrganization オブジェクト 1 つに対して複数のエイリアスを作成できます。組織エイリアスには、指定した BizTalkOrganization オブジェクトに対する一意な名前、およびすべての BizTalkOrganization オブジェクトに対する一意な修飾子と値のペアが含まれる必要があります。これらのエイリアスのうちの 1 つを、このオブジェクトの既定のエイリアスとして指定する必要があります。

サーバーは、Organization という名前のエイリアスを自動的に作成します。このエイリアスの既定の識別子は OrganizationName で、値は新しい組織の組織名に設定されます。組織名が変更されると、その値は新しい名前に自動的に更新されます。このエイリアスは削除できません。

注

  • EDIFACT 形式のエンベロープを使用しているときに、送信元か送信元のヘッダー内の空の修飾子に NULL 値を使用する場合、ダッシュ (-) 1 つを修飾子にしたカスタム識別子を作成します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::CreateApplication メソッド [C++]

BizTalkOrganization.CreateApplication メソッド [Visual Basic]

CreateApplication メソッドは、新しいアプリケーションを作成します。

構文

[C++]

HRESULT CreateApplication(
BSTR strName
);

[Visual Basic]

object.CreateApplication( _
 strName As String _

)

パラメータ

[C++]

strName

[in] アプリケーションの名前を含む BSTR です。

[Visual Basic]

strName

アプリケーションの名前を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

1 つの BizTalkOrganization オブジェクトが複数のアプリケーションに関連付けられている場合、各アプリケーションの名前は一意である必要があります。

注

  • BizTalk メッセージ マネージャでは、基本となる組織を既定の組織といいます。

  • BizTalk メッセージ マネージャでは、既定の組織に対して作成されたアプリケーションのみ扱うことができます。BizTalk メッセージ構成オブジェクト モデルには、この制約は強制されません。したがって、既定の組織以外の組織に使用するアプリケーションを作成した場合、BizTalk メッセージ マネージャを使用してその組織を変更することはできません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::GetDefaultAlias メソッド [C++]

BizTalkOrganization.GetDefaultAlias メソッド [Visual Basic]

GetDefaultAlias メソッドは、オブジェクトの既定のエイリアスへのハンドルを返します。オブジェクトの既定のエイリアスは、既定の組織識別子の種類と値のペアです。

構文

[C++]

HRESULT GetDefaultAlias(
long* plAliasHandle
);

[Visual Basic]

object.GetDefaultAlias()

パラメータ

[C++]

plAliasHandle

[out, retval] ハンドルを含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、ハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::IsDefault プロパティ [C++]

BizTalkOrganization.IsDefault プロパティ [Visual Basic]

IsDefault プロパティには、オブジェクトが既定の組織かどうかを示すフラグが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_IsDefault(
VARIANT_BOOL* pbIsDefault
);

[Visual Basic]

object.IsDefault

パラメータ

[C++]

Get メソッド :

pbIsDefault

[out, retval] この組織が既定の組織かどうかを示す VARIANT_BOOL へのポインタです。VARIANT_TRUE の値は、この組織が既定の組織であることを示します。VARIANT_FALSE の値は、この組織が既定の組織ではないことを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、フラグを含む Boolean を返します。True の場合、この組織は既定の組織です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。既定の組織は常に 1 つだけ存在している必要があります。

注

  • BizTalk メッセージ マネージャでは、基本となる組織を既定の組織といいます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkOrganization::LoadAlias メソッド [C++]

BizTalkOrganization.LoadAlias メソッド [Visual Basic]

LoadAlias メソッドは、オブジェクトに対する関連付けられたエイリアスをメモリにロードします。オブジェクトのエイリアスは、組織の修飾子と値のペアです。

構文

[C++]

HRESULT LoadAlias(
long lAliasHandle,
 VARIANT* pvarName,
 VARIANT* pvarDefault,
 VARIANT* pvarQualifier,
 VARIANT* pvarValue
);

[Visual Basic]

object.LoadAlias( _
lAliasHandle As Long, _
 pvarName As Variant, _
 pvarDefault As Variant, _
 pvarQualifier As Variant, _
 pvarValue As Variant _
)

パラメータ

[C++]

lAliasHandle

[in] エイリアスへのハンドルを含む Long です。

pvarName

[in, out] 組織識別子名を含む VARIANT へのポインタです。

pvarDefault

[in, out] 既定のフラグを含む VARIANT へのポインタです。

pvarQualifier

[in, out] 組織識別子の修飾子を含む VARIANT へのポインタです。

pvarValue

[in, out] 組織識別子の値を含む VARIANT へのポインタです。

[Visual Basic]

lAliasHandle

エイリアスへのハンドルを含む Long です。

pvarName

組織識別子名を含む Variant です。

pvarDefault

既定のフラグを含む Variant です。

pvarQualifier

組織識別子の修飾子を含む Variant です。

pvarValue

組織識別子の値を含む Variant です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドのパラメータと共に使用する値は、Aliases プロパティから取得できます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::LoadApplication メソッド [C++]

BizTalkOrganization.LoadApplication メソッド [Visual Basic]

LoadApplication メソッドは、オブジェクトに対する関連付けられたアプリケーションをメモリにロードします。

構文

[C++]

HRESULT LoadApplication(
long lApplicationHandle,
 VARIANT* pvarName
);

[Visual Basic]

object.LoadApplication( _
 lApplicationHandle As Long, _
 pvarName As Variant _
)

パラメータ

[C++]

lApplicationHandle

[in] アプリケーション ハンドルを含む Long です。

pvarName

[in, out] アプリケーション名を含む VARIANT へのポインタです。

[Visual Basic]

lApplicationHandle

アプリケーション ハンドルを含む Long です。

pvarName

アプリケーション名を含む Variant です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドのパラメータと共に使用する値は、Applications プロパティから取得できます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkOrganization::RemoveAlias メソッド [C++]

BizTalkOrganization.RemoveAlias メソッド [Visual Basic]

RemoveAlias メソッドはエイリアスを削除します。オブジェクトのエイリアスは、組織識別子の種類と値のペアです。

構文

[C++]

HRESULT RemoveAlias(
long lAliasHandle
);

[Visual Basic]

object.RemoveAlias( _
 lAliasHandle As Long _
)

パラメータ

[C++]

lAliasHandle

[in] エイリアスへのハンドルを含む Long です。

[Visual Basic]

lAliasHandle

エイリアスへのハンドルを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

次の条件のいずれかに該当する場合は、このレコードを削除できません。

  • BizTalkPort オブジェクトまたは BizTalkChannel オブジェクトがこのレコードを参照している場合

  • 既定の組織識別子として指定されている場合

  • このエイリアスが自動生成された場合

エイリアス ハンドルは、Aliases プロパティから取得できます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::RemoveApplication メソッド [C++]

BizTalkOrganization.RemoveApplication メソッド [Visual Basic]

RemoveApplication メソッドは、既定の組織からアプリケーションを削除します。

構文

[C++]

HRESULT RemoveApplication(
long lApplicationHandle
);

[Visual Basic]

object.RemoveApplication( _
 lApplicationHandle As Long _
)

パラメータ

[C++]

lApplicationHandle

[in] ハンドルを含む Long です。

[Visual Basic]

lApplicationHandle

ハンドルを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalkPort オブジェクトまたは BizTalkChannel オブジェクトがこのレコードを参照している場合は、このレコードを削除できません。

アプリケーション ハンドルは、Applications プロパティから取得できます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkOrganization::SaveAlias メソッド [C++]

BizTalkOrganization.SaveAlias メソッド [Visual Basic]

SaveAlias メソッドは、オブジェクトのエイリアスを保存します。オブジェクトのエイリアスは、組織識別子の種類と値のペアです。

構文

[C++]

HRESULT SaveAlias(
long lAliasHandle,
 BSTR strName,
 VARIANT_BOOL bDefault,
 BSTR strQualifier,
 BSTR strValue
);

[Visual Basic]

object.SaveAlias( _
 lAliasHandle As Long, _
 strName As String, _
 bDefault As Boolean, _
 strQualifier As String, _
 strValue As String _
)

パラメータ

[C++]

lAliasHandle

[in] エイリアスへのハンドルを含む Long です。

strName

[in] 組織識別子の名前を含む BSTR です。このエイリアスが自動生成されている場合、このパラメータは変更できません。

bDefault

[in] 既定のフラグを含む VARIANT_BOOL 型です。VARIANT_TRUE の値は、このエイリアスが、組織の既定のエイリアスであることを示します。VARIANT_FALSE の値は、このエイリアスが、組織の既定のエイリアスではないことを示します。

strQualifier

[in] 組織識別子の修飾子を含む BSTR です。このエイリアスが自動生成されている場合、このパラメータは変更できません。このパラメータは、"グループ" には設定できません。

strValue

[in] 組織識別子の値を含む BSTR です。このエイリアスが自動生成されている場合、このパラメータは変更できません。

[Visual Basic]

lAliasHandle

エイリアスへのハンドルを含む Long です。

strName

組織識別子名を含む文字列です。このエイリアスが自動生成されている場合、このパラメータは変更できません。

bDefault

既定のフラグを含む Variant です。True の値は、このエイリアスが、組織の既定のエイリアスであることを示します。False の値は、このエイリアスが、組織の既定のエイリアスではないことを示します。

strQualifier

組織識別子の修飾子を含む文字列です。このエイリアスが自動生成されている場合、このパラメータは変更できません。このパラメータは、"グループ" には設定できません。

strValue

組織識別子の値を含む文字列です。このエイリアスが自動生成されている場合、このパラメータは変更できません。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

組織


IBizTalkOrganization::SaveApplication メソッド [C++]

BizTalkOrganization.SaveApplication メソッド [Visual Basic]

SaveApplication メソッドは、既定の組織オブジェクトに対してこのアプリケーションを保存します。

構文

[C++]

HRESULT SaveApplication(
long lApplicationHandle,
 BSTR strName
);

[Visual Basic]

object.SaveApplication( _
lApplicationHandle As Long, _
 strName As String _
)

パラメータ

[C++]

lApplicationHandle

[in] アプリケーションへのハンドルを含む Long です。

strName

[in] アプリケーションの名前を含む BSTR です。

[Visual Basic]

lApplicationHandle

アプリケーションへのハンドルを含む Long です。

strName

アプリケーションの名前を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort インターフェイス [C++]

BizTalkPort オブジェクト [Visual Basic]

BizTalkPort オブジェクトは、組織とアプリケーションの間でのドキュメントの一方向転送を構成します。このオブジェクトは、送信元の組織とアプリケーション、送信先の組織とアプリケーション、プライマリ トランスポート タイプ、および選択されている場合は関連付けられた送信用エンベロープを識別します。

C++ では、BizTalkPort オブジェクトのメソッドにアクセスするには IBizTalkPort インターフェイスを使用します。

次の表は、BizTalkPort オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Channels (チャネル) | IDispatch | このオブジェクトを参照する BizTalkChannel オブジェクトすべてに関する情報を含む ADO レコード セットです。これは読み取り専用プロパティです。
Comments (コメント) | BSTR | Port オブジェクトに対するユーザー コメントです。
ControlNumberValue (制御番号の値) | BSTR | インターチェンジ制御番号の値です。関連付けられた BizTalkEnvelope オブジェクトの Format プロパティが "x12"、"edifact"、または "custom" に設定されている場合、このプロパティは必須プロパティです。この制約は現行リリースでは強制されませんが、この制約に従わないとサーバーに障害が発生します。
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Delimiters (区切り記号) | IDispatch | ドキュメント仕様に使用する区切り記号すべてを含む Dictionary オブジェクトです。関連付けられた BizTalkEnvelope オブジェクトの Format プロパティが "x12"、"edifact"、または "custom" に設定されている場合、このプロパティは必須プロパティです。
DestinationEndpoint (送信先エンドポイント) | IDispatch | 送信先に関する情報です。
EncodingType (エンコードの種類) | BIZTALK_ENCODING_ TYPE | ドキュメントのエンコードの種類を示す列挙値です。
EncryptionCertificateInfo (暗号化証明書情報) | IDispatch | ドキュメントを暗号化する証明書に関する情報です。
EncryptionType (暗号化の種類) | BIZTALK_ENCRYPTION_ TYPE | ドキュメントの暗号化の種類を示す列挙値です。
Envelope (エンベロープ) | long | この BizTalkPort オブジェクトに関連付けられた BizTalkEnvelope オブジェクトへのハンドルです。
Handle (ハンドル) | long | オブジェクトへのハンドルです。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Name (名前) | BSTR | オブジェクトの名前です。これは BizTalkBase オブジェクトから取得される必須プロパティです。
PrimaryTransport (プライマリ トランスポート) | IDispatch | プライマリ トランスポート コンポーネントの情報です。
SecondaryTransport (セカンダリ トランスポート) | IDispatch | セカンダリ トランスポート コンポーネントの情報です。
ServiceWindowInfo (サービス ウィンドウ情報) | IDispatch | サービス ウィンドウの情報です。
SignatureType (署名の種類) | BIZTALK_SIGNATURE_ TYPE | デジタル署名と検証の種類を示す列挙値です。

次の表は、BizTalkPort オブジェクトのメソッドを示しています。

メソッド | 説明
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。このメソッドは BizTalkBase オブジェクトから取得されます。
Create | 新しいオブジェクトをデータベースに作成します。このメソッドは BizTalkBase オブジェクトから取得されます。
Load | オブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadByName | 名前によってオブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
Remove | オブジェクトをデータベースから削除します。このメソッドは BizTalkBase オブジェクトから取得されます。
Save | オブジェクトをデータベースに保存します。このメソッドは BizTalkBase オブジェクトから取得されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ドキュメント処理

メッセージ ポート


IBizTalkPort::Channels プロパティ [C++]

BizTalkPort.Channels プロパティ [Visual Basic]

Channels プロパティには、オブジェクトを参照するすべての BizTalkChannel オブジェクトについての情報を含む ADO レコード セットが含まれています。

構文

[C++]

Get メソッド :

HRESULT get_Channels(
 IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

パラメータ

[C++]

ppChannelsDisp

[out, retval] IDispatch インターフェイスへのポインタのアドレスで、IDispatch インターフェイスには、このオブジェクトを参照する BizTalkChannel オブジェクトが含まれます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、そのオブジェクトを参照する BizTalkChannel オブジェクトを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティによって返される ADO レコード セット内の各レコードには、この BizTalkPort オブジェクトに関連付けられたデータベースにある、BizTalkChannel オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

  • GUID 書式による一意のチャネル識別子

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::Comments プロパティ [C++]

BizTalkPort.Comments プロパティ [Visual Basic]

Comments プロパティには、Port オブジェクトに対するユーザー コメントが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Comments(
BSTR* pstrComments
);

Put メソッド :

HRESULT put_Comments(
BSTR strComments
);

[Visual Basic]

object.Comments

パラメータ

[C++]

Get メソッド :

pstrComments

[out, retval] コメントを含む BSTR へのポインタです。

Put メソッド :

strComments

[in] コメントを含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、コメントを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::ControlNumberValue プロパティ [C++]

BizTalkPort.ControlNumberValue プロパティ [Visual Basic]

ControlNumberValue プロパティには、インターチェンジ制御番号の値が含まれます。

構文

[C++]

HRESULT get_ControlNumberValue(
BSTR* pstrControlNumberValue
);

Put メソッド :

HRESULT put_ControlNumberValue(
BSTR strControlNumberValue
);

[Visual Basic]

object.ControlNumberValue

パラメータ

[C++]

Get メソッド :

pstrControlNumberValue

[out, retval] インターチェンジ制御番号を含む BSTR へのポインタです。

Put メソッド :

strControlNumberValue

[in] インターチェンジ制御番号を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、インターチェンジ制御番号を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

ControlNumberValue プロパティに含まれる値は、1 から 999999999 の間である必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::Delimiters プロパティ [C++]

BizTalkPort.Delimiters プロパティ [Visual Basic]

Delimiters プロパティには、ドキュメント仕様に使用される区切り記号すべてを含む Dictionary オブジェクトが含まれます。Delimiters プロパティは、エンベロープ内、およびこのエンベロープを使用して送信されるドキュメント内のデータを区切る文字を指定します。

構文

[C++]

Get メソッド :

HRESULT get_Delimiters(
IDispatch** ppDelimitersDisp
);

Putref メソッド :

HRESULT putref_Delimiters(
IDispatch* pDelimitersDisp
);

[Visual Basic]

object.Delimiters

パラメータ

[C++]

Get メソッド :

ppDelimitersDisp

[out, retval] 区切り記号を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pDelimitersDisp

[in] 区切り記号を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、区切り記号を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

関連付けられた BizTalkEnvelope オブジェクトの Format プロパティが "x12"、"edifact"、または "custom" に設定されている場合、このプロパティは、オブジェクトが完了するための必須プロパティです。関連付けられた BizTalkDocument オブジェクトの PropertySet プロパティも定義する必要があります。次の表は、各種書式に対して必要な、Dictionary オブジェクトの区切り記号の名前を示しています。

区切り記号 | ANSI X12 | EDIFACT
Record_delim | 必要 | 必要
Field_delim | 必要 | 必要
Subfield_delim | 必要 | 必要
Escape_char | 不要 | 必要

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::DestinationEndpoint プロパティ [C++]

BizTalkPort.DestinationEndpoint プロパティ [Visual Basic]

DestinationEndpoint プロパティには、送信先に関する情報が含まれます。この情報には、Alias、Application、および Organization プロパティが含まれ、BizTalkEndPoint オブジェクトのメモリ内に作成および格納されます。

構文

[C++]

Get メソッド :

HRESULT get_DestinationEndpoint(
IDispatch** ppDestEndpointDisp
);

Putref メソッド :

HRESULT putref_DestinationEndpoint(
IDispatch* pDestEndpointDisp
);

[Visual Basic]

object.DestinationEndpoint

パラメータ

[C++]

Get メソッド :

ppDestEndpointDisp

[out, retval] 送信先に関する情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pDestEndpointDisp

[in] 送信先に関する情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、送信先に関する情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalkPort オブジェクトをいったん作成すると、送信先 BizTalkOrganization オブジェクトは変更できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::EncodingType プロパティ [C++]

BizTalkPort.EncodingType プロパティ [Visual Basic]

EncodingType プロパティには、ドキュメントのエンコードの種類を示す列挙値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_EncodingType(
BIZTALK_ENCODING_TYPE* pEncodingType
);

Put メソッド :

HRESULT put_EncodingType(
BIZTALK_ENCODING_TYPE EncodingType
);

[Visual Basic]

object.EncodingType

パラメータ

[C++]

Get メソッド :

pEncodingType

[out, retval] 列挙値へのポインタです。有効な値は、BIZTALK_ENCODING_TYPE 列挙からの値です。

Put メソッド :

EncodingType

[in] プロパティを設定する場合は、列挙値です。有効な値は、BIZTALK_ENCODING_TYPE 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は、BIZTALK_ENCODING_TYPE 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Clear メソッドは、EncodingType を BIZTALK_ENCODING_TYPE_NONE に設定します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::EncryptionCertificateInfo プロパティ [C++]

BizTalkPort.EncryptionCertificateInfo プロパティ [Visual Basic]

EncryptionCertificateInfo プロパティには、ドキュメントを暗号化する証明書に関する情報が含まれます。この情報には、Name、Reference、Store、および Usage プロパティが含まれ、BizTalkCertificateInfo オブジェクトのメモリ内に作成および格納されます。

構文

[C++]

Get メソッド :

HRESULT get_EncryptionCertificateInfo(
IDispatch** ppEncryptionCertificateInfoDisp
);

Putref メソッド :

HRESULT putref_EncryptionCertificateInfo(
IDispatch* pEncryptionCertificateInfoDisp
);

[Visual Basic]

object.EncryptionCertificateInfo

パラメータ

[C++]

Get メソッド :

ppEncryptionCertificateInfoDisp

[out, retval] 証明書情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pEncryptionCertificateInfoDisp

[in] 証明書情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、証明書情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::EncryptionType プロパティ [C++]

BizTalkPort.EncryptionType プロパティ [Visual Basic]

EncryptionType プロパティには、ドキュメントの暗号化の種類を示す列挙値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_EncryptionType(
BIZTALK_ENCRYPTION_TYPE* pEncryptionType
);

Put メソッド :

HRESULT put_EncryptionType(
BIZTALK_ENCRYPTION_TYPE EncryptionType
);

[Visual Basic]

object.EncryptionType

パラメータ

[C++]

Get メソッド :

pEncryptionType

[out, retval] 列挙値へのポインタです。有効な値は、BIZTALK_ENCRYPTION_TYPE 列挙からの値です。

Put メソッド :

EncryptionType

[in] 列挙値です。有効な値は、BIZTALK_ENCRYPTION_TYPE 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は、BIZTALK_ENCRYPTION_TYPE 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Clear メソッドは、EncryptionType を BIZTALK_ENCRYPTION_TYPE_NONE に設定します。

EncryptionType を BIZTALK_ENCRYPTION_TYPE_SMIME に設定した場合は、EncryptionCertificateInfo プロパティを設定する必要があります。

オープンなメッセージ ポートの場合は、EncryptionType を BIZTALK_ENCRYPTION_TYPE_NONE に設定する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::Envelope プロパティ [C++]

BizTalkPort.Envelope プロパティ [Visual Basic]

Envelope プロパティには、関連付けられた BizTalkEnvelope オブジェクトへのハンドルが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Envelope(
long* plEnvelopeHandle
);

Put メソッド :

HRESULT put_Envelope(
long lEnvelopeHandle
);

[Visual Basic]

object.Envelope

パラメータ

[C++]

Get メソッド :

plEnvelopeHandle

[out, retval] オブジェクトへのハンドルを含む long へのポインタです。

Put メソッド :

lEnvelopeHandle

[in] オブジェクトへのハンドルを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、オブジェクトへのハンドルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

エンベロープ


IBizTalkPort::PrimaryTransport プロパティ [C++]

BizTalkPort.PrimaryTransport プロパティ [Visual Basic]

PrimaryTransport プロパティには、BizTalkTransportInfo オブジェクトの Address プロパティ、Parameter プロパティ、および Type プロパティなど、プライマリ トランスポート コンポーネント情報が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_PrimaryTransport(
IDispatch** ppTransportInfoDisp
);

Putref メソッド :

HRESULT putref_PrimaryTransport(
IDispatch* pTransportInfoDisp
);

[Visual Basic]

object.PrimaryTransport

パラメータ

[C++]

Get メソッド :

ppTransportInfoDisp

[out, retval] プライマリ トランスポート コンポーネント情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pTransportInfoDisp

[in] プライマリ トランスポート コンポーネント情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、プライマリ トランスポート コンポーネント情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティは、このオブジェクトの必須プロパティです。

次の制約が適用されます。

  • 関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_EX_DESTINATION に設定されている場合、Address プロパティは設定できず、PrimaryTransport を BIZTALK_TRANSPORT_TYPE_OPENDESTINATION に設定する必要があります。BizTalkServiceWindowInfo オブジェクトを、オープンな送信先ポートと共に使用することはできません。

  • BizTalkPort オブジェクトが作成されると、それに関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティは変更できません。

  • Openness プロパティは、BIZTALK_OPENNESS_TYPE_EX_SOURCE または BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW には設定できません。

  • BIZTALK_TRANSPORT_TYPE_LOOPBACK の Type プロパティを使用する場合、プライマリ トランスポートおよびセカンダリ トランスポートの Address プロパティは設定できず、BizTalkServiceWindowInfo オブジェクトは使用できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::SecondaryTransport プロパティ [C++]

BizTalkPort.SecondaryTransport プロパティ [Visual Basic]

SecondaryTransport プロパティには、Address プロパティ、Parameter プロパティ、および Type プロパティなどの、セカンダリ トランスポート コンポーネント情報が含まれます。このプロパティは、BizTalkTransportInfo オブジェクトのメモリ内に作成され、格納されます。

構文

[C++]

Get メソッド :

HRESULT get_SecondaryTransport(
IDispatch** ppTransportInfoDisp
);

Putref メソッド :

HRESULT putref_SecondaryTransport(
IDispatch* pTransportInfoDisp
);

[Visual Basic]

object.SecondaryTransport

パラメータ

[C++]

Get メソッド :

ppTransportInfoDisp

[out, retval] セカンダリ トランスポート コンポーネント情報を含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pTransportInfoDisp

[in] セカンダリ トランスポート コンポーネント情報を含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、セカンダリ トランスポート コンポーネント情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティは、このオブジェクトが完了するための必須プロパティです。

次の制約が適用されます。

  • 関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_EX_DESTINATION に設定されている場合、Address プロパティは設定できず、SecondaryTransport を BIZTALK_TRANSPORT_TYPE_OPENDESTINATION に設定する必要があります。

  • BizTalkPort オブジェクトが作成されると、それに関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティは変更できません。

  • Openness プロパティは、BIZTALK_OPENNESS_TYPE_EX_SOURCE または BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW には設定できません。

  • Type プロパティを BIZTALK_TRANSPORT_TYPE_LOOPBACK に設定することはできません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::ServiceWindowInfo プロパティ [C++]

BizTalkPort.ServiceWindowInfo プロパティ [Visual Basic]

ServiceWindowInfo プロパティには、サービス ウィンドウに関する情報が含まれます。この情報には、FromTime プロパティ、IsEnabled プロパティ、および ToTime プロパティが含まれ、これらは BizTalkServiceWindowInfo オブジェクトのメモリ内に作成され、格納されます。

構文

[C++]

Get メソッド :

HRESULT get_ServiceWindowInfo(
IDispatch** ppServiceWindowInfoDisp
);

Putref メソッド :

HRESULT putref_ServiceWindowInfo(
IDispatch* pServiceWindowInfoDisp
);

[Visual Basic]

object.ServiceWindowInfo

パラメータ

[C++]

Get メソッド :

ppServiceWindowInfoDisp

[out, retval] サービス ウィンドウを含む IDispatch インターフェイスへのポインタのアドレスです。

Putref メソッド :

pServiceWindowInfoDisp

[in] サービス ウィンドウを含む IDispatch インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、サービス ウィンドウに関する情報を含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティを使用する場合、BizTalkServiceWindowInfo オブジェクトでは、FromTime プロパティと ToTime プロパティを使用して有効な時間帯を指定する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPort::SignatureType プロパティ [C++]

BizTalkPort.SignatureType プロパティ [Visual Basic]

SignatureType プロパティには、デジタル署名と検証の種類を示す列挙値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_SignatureType(
BIZTALK_SIGNATURE_TYPE* pSignatureType
);

Put メソッド :

HRESULT put_SignatureType(
BIZTALK_SIGNATURE_TYPE SignatureType
);

[Visual Basic]

object.SignatureType

パラメータ

[C++]

Get メソッド :

pSignatureType

[out, retval] 列挙値へのポインタです。有効な値は、BIZTALK_SIGNATURE_TYPE 列挙からの値です。

Put メソッド :

SignatureType

[in] 列挙値です。有効な値は、BIZTALK_SIGNATURE_TYPE 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は、BIZTALK_SIGNATURE_TYPE 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Clear メソッドは、SignatureType を BIZTALK_SIGNATURE_TYPE_NONE に設定します。

オープン チャネルに関連付けられた BizTalkPort オブジェクトには SignatureType を設定できません。

BizTalkPort オブジェクトの SignatureType を BIZTALK_SIGNATURE_TYPE_NONE から BIZTALK_SIGNATURE_TYPE_SMIME に変更する場合は、この BizTalkPort オブジェクトに関連付けられているすべてのチャネルを、SignatureCertificateInfo オブジェクトを使用して保存しておく必要があります。また、BizTalkChannel に SignatureCertificateInfo オブジェクトが含まれていて、BizTalkPort の SignatureType が BIZTALK_SIGNATURE_TYPE_NONE に設定されている場合、署名は無視されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPortGroup インターフェイス [C++]

BizTalkPortGroup オブジェクト [Visual Basic]

BizTalkPortGroup オブジェクトは、同一のドキュメントを多数の組織に配布するためのポート グループを構成するために使用します。

C++ では、BizTalkPortGroup オブジェクトのメソッドにアクセスするには IBizTalkPortGroup インターフェイスを使用します。

次の表は、BizTalkPortGroup オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Channels (チャネル) | IDispatch | このオブジェクトを参照する BizTalkChannel オブジェクトすべてに関する情報を含む ADO レコード セットです。
DateModified (更新日付) | BSTR | オブジェクトの情報が作成または最後に変更された日付と時刻です。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Handle (ハンドル) | long | オブジェクトへのハンドルです。これは BizTalkBase オブジェクトから取得される読み取り専用プロパティです。
Name (名前) | BSTR | オブジェクトの名前です。これは BizTalkBase オブジェクトから取得される必須プロパティです。
Port (ポート) | IDispatch | このオブジェクトを参照する BizTalkPort オブジェクトすべてに関する情報を含む ADO レコード セットです。

次の表は、BizTalkPortGroup オブジェクトのメソッドを示しています。

メソッド | 説明
AddPort | BizTalkPort オブジェクトをこのポート グループに追加します。ポート グループには、BizTalkPort オブジェクトが少なくとも 1 つある必要があります。
Clear | メモリ内のオブジェクトを消去します。メモリ内のオブジェクトのすべてのメンバ変数が、既定値に初期化されます。このメソッドは BizTalkBase オブジェクトから取得されます。
Create | 新しいオブジェクトをデータベースに作成します。このメソッドは BizTalkBase オブジェクトから取得されます。
Load | オブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
LoadByName | 名前によってオブジェクトをメモリにロードします。このメソッドは BizTalkBase オブジェクトから取得されます。
Remove | BizTalkPortGroup オブジェクトをデータベースから削除します。このメソッドは BizTalkBase オブジェクトから取得されます。
RemovePort | BizTalkPort オブジェクトをポート グループから削除します。ポート グループには、BizTalkPort オブジェクトが少なくとも 1 つある必要があります。
Save | オブジェクトをデータベースに保存します。このメソッドは BizTalkBase オブジェクトから取得されます。

解説

BizTalkPortGroup オブジェクトには、BizTalkPort オブジェクトと BizTalkChannel オブジェクトが少なくとも 1 つずつ関連付けられている必要があります。BizTalkChannel オブジェクトは、グループ内の BizTalkPort オブジェクトでなく、BizTalkPortGroup オブジェクトに関連付けられます。グループ内の各 BizTalkPort オブジェクトには、別の BizTalkChannel オブジェクトが 1 つまたは複数関連付けられますが、ポート グループ チャネルが呼び出されるとその BizTalkChannel オブジェクトは無視されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。

関連項目

ポート グループ


IBizTalkPortGroup::AddPort メソッド [C++]

BizTalkPortGroup.AddPort メソッド [Visual Basic]

AddPort メソッドは、BizTalkPort オブジェクトをこのポート グループに追加します。

構文

[C++]

HRESULT AddPort(
 long lPortHandle
);

[Visual Basic]

object.AddPort( _
 lPortHandle As Long _
)

パラメータ

[C++]

lPortHandle

[in] オブジェクトへのハンドルを含む Long です。

[Visual Basic]

lPortHandle

オブジェクトへのハンドルを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドには、次の制約が適用されます。

  • この BizTalkPortGroup オブジェクト内には BizTalkPort が少なくとも 1 つ存在している必要があります。

  • 追加する、関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティが、BIZTALK_OPENNESS_TYPE_NOTOPEN に設定されている必要があります。

  • このオブジェクトによって指定されるポート グループ内には、BizTalkPort オブジェクトが重複して存在することはできません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPortGroup::Channels プロパティ [C++]

BizTalkPortGroup.Channels プロパティ [Visual Basic]

Channels プロパティには、オブジェクトを参照するすべての BizTalkChannel オブジェクトについての情報を含む ADO レコード セットが含まれています。

構文

[C++]

Get メソッド :

HRESULT get_Channels(
 IDispatch** ppChannelsDisp
);

[Visual Basic]

object.Channels

パラメータ

[C++]

ppChannelsDisp

[out, retval] IDispatch インターフェイスへのポインタのアドレスで、IDispatch インターフェイスには、このオブジェクトを参照する BizTalkChannel オブジェクトすべてを含む ADO レコード セットがあります。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、このオブジェクトを参照する BizTalkChannel オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティによって返される ADO レコード セット内の各レコードには、このBizTalkPortGroup オブジェクトに関連付けられたデータベースにある、BizTalkChannel オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPortGroup::Ports プロパティ [C++]

BizTalkPortGroup.Ports プロパティ [Visual Basic]

Ports プロパティには、このオブジェクトを参照する BizTalkPort オブジェクトすべてに関する情報を持つ ADO レコードセットが含まれます。

構文

[C++]

Get メソッド :

HRESULT Ports(
IDispatch** ppPortsDisp
);

[Visual Basic]

object.Ports

パラメータ

[C++]

ppPortsDisp

[out, retval] IDispatch インターフェイスのポインタのアドレスで、IDispatch インターフェイスには、このオブジェクトを参照する BizTalkPort オブジェクトすべてを含む ADO レコード セットがあります。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

このプロパティは、このオブジェクトを参照する BizTalkPort オブジェクトすべてを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティによって返される ADO レコード セット内の各レコードには、この BizTalkPortGroup オブジェクトに関連付けられたデータベースにある、BizTalkPort オブジェクトに関する情報が含まれます。各レコードのフィールドは、次の情報を次の順番どおりに含んでいます。

  • Handle

  • Name

Microsoft ActiveX Data Objects の追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkPortGroup::RemovePort メソッド [C++]

BizTalkPortGroup.RemovePort メソッド [Visual Basic]

RemovePort メソッドは、BizTalkPort オブジェクトをこのポート グループから削除します。

構文

[C++]

HRESULT RemovePort(
long lPortHandle
);

[Visual Basic]

object.RemovePort( _
 lPortHandle As Long _

)

パラメータ

[C++]

lPortHandle

[in] 削除するオブジェクトへのハンドルを含む Long です。

[Visual Basic]

lPortHandle

削除するオブジェクトへのハンドルを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

注

  • このメソッドは、エラー メッセージ ページの一覧にある HRESULT 値だけでなく、OLEDB プロバイダ エラーも返します。OLEDB に関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。
[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このオブジェクトに関連付けられている最後の BizTalkPort オブジェクトは削除できません。BizTalkChannel オブジェクトが BizTalkPort オブジェクトを参照している場合、その BizTalkPort オブジェクトは削除できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkServiceWindowInfo インターフェイス [C++]

BizTalkServiceWindowInfo オブジェクト [Visual Basic]

BizTalkServiceWindowInfo オブジェクトは、関連付けられた BizTalkPort オブジェクトに対してサービス ウィンドウを構成するために使用します。サービス ウィンドウは、ドキュメントの送信に有効な時間帯を示します。

C++ では、BizTalkServiceWindowInfo オブジェクトのメソッドにアクセスするには IBizTalkServiceWindowInfo インターフェイスを使用します。

次の表は、BizTalkServiceWindowInfo オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
FromTime (開始時刻) | BSTR | インターチェンジを送信できる時間帯の最も早い時刻です。
IsEnabled (有効) | VARIANT_BOOL | サービス ウィンドウが有効かどうかを示すフラグです。
ToTime (終了時刻) | BSTR | インターチェンジを送信できる時間帯の最も遅い時刻です。

解説

BizTalkServiceWindowInfo オブジェクトは、BizTalkConfig オブジェクトの CreatePort メソッドを使用して BizTalkPort オブジェクトのインスタンスが作成されると、自動的に作成されます。BizTalkServiceWindowInfo オブジェクトのプロパティにアクセスするには、BizTalkPort オブジェクトの ServiceWindowInfo プロパティを使用します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkServiceWindowInfo::FromTime プロパティ [C++]

BizTalkServiceWindowInfo.FromTime プロパティ [Visual Basic]

FromTime プロパティは、インターチェンジを送信できる時間帯の最も早い時刻を示します。

構文

[C++]

Get メソッド :

HRESULT get_FromTime(
BSTR* pstrFromTime
);

Put メソッド :

HRESULT put_FromTime(
BSTR strFromTime
);

[Visual Basic]

object.FromTime

パラメータ

[C++]

Get メソッド :

pstrFromTime

[out, retval] インターチェンジを送信できる時間帯の最も早い時刻を含む BSTR へのポインタです。

Put メソッド :

strFromTime

[in] インターチェンジを送信できる時間帯の最も早い時刻を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、インターチェンジを送信できる時間帯の最も早い時刻を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

FromTime プロパティには、0 から 23 の整数値を使用する必要があります。小数値や分単位の値は指定できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkServiceWindowInfo::IsEnabled プロパティ [C++]

BizTalkServiceWindowInfo.IsEnabled プロパティ [Visual Basic]

IsEnabled プロパティは、サービス ウィンドウが有効かどうかを示します。

構文

[C++]

Get メソッド :

HRESULT get_IsEnabled(
VARIANT_BOOL* pbIsEnabled
);

Put メソッド :

HRESULT put_IsEnabled(
VARIANT_BOOL bIsEnabled
);

[Visual Basic]

object.IsEnabled

パラメータ

[C++]

Get メソッド :

pbIsEnabled

[out, retval] サービス ウィンドウが有効かどうかを示す VARIANT_BOOL へのポインタです。VARIANT_TRUE の値は、サービス ウィンドウが有効であることを示しています。VARIANT_FALSE の値は、サービス ウィンドウが有効でないことを示しています。

Put メソッド :

bIsEnabled

[in] サービス ウィンドウが有効かどうかを示す VARIANT_BOOL です。VARIANT_TRUE の値は、サービス ウィンドウが有効であることを示しています。VARIANT_FALSE の値は、サービス ウィンドウが有効でないことを示しています。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、サービス ウィンドウが有効かどうかを示す文字列を返します。True の値は、サービス ウィンドウが有効であることを示しています。False の値は、サービス ウィンドウが有効でないことを示しています。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkServiceWindowInfo::ToTime プロパティ [C++]

BizTalkServiceWindowInfo.ToTime プロパティ [Visual Basic]

ToTime プロパティには、インターチェンジを送信できる時間帯の最も遅い時刻が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ToTime(
BSTR* pstrToTime
);

Put メソッド :

HRESULT put_ToTime(
BSTR strToTime
);

[Visual Basic]

object.ToTime

パラメータ

[C++]

Get メソッド :

pstrToTime

[out, retval] インターチェンジを送信できる時間帯の最も遅い時刻を含む BSTR へのポインタです。

Put メソッド :

strToTime

[in] インターチェンジを送信できる時間帯の最も遅い時刻を含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、インターチェンジを送信できる時間帯の最も遅い時刻を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

ToTime プロパティには、0 から 23 の整数値を使用する必要があります。小数値や分単位の値は指定できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkTransportInfo インターフェイス [C++]

BizTalkTransportInfo オブジェクト [Visual Basic]

BizTalkTransportInfo オブジェクトは、関連付けられた BizTalkPort オブジェクトに対してトランスポート サービスを構成するために使用します。

C++ では、BizTalkTransportInfo オブジェクトのメソッドにアクセスするには IBizTalkTransportInfo インターフェイスを使用します。

次の表は、BizTalkTransportInfo オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Address (アドレス) | BSTR | プライマリ トランスポート コンポーネントの送信先アドレスです。
Parameter (パラメータ) | BSTR | Type プロパティが BIZTALK_TRANSPORT_TYPE_SMTP である場合に、関連付けられた送信元 BizTalkOrganization オブジェクトに必要な差出人電子メール アドレスです。
Type (種類) | BIZTALK_TRANSPORT_ TYPE | プライマリ トランスポートに使用するトランスポート コンポーネントの種類を示す列挙値です。

解説

BizTalkTransportInfo オブジェクトは、BizTalkConfig オブジェクトの CreatePort メソッドを使用して BizTalkPort オブジェクトがインスタンス化されると、自動的に作成されます。BizTalkTransportInfo オブジェクトへのアクセスには、BizTalkPort オブジェクトの PrimaryTransport プロパティまたは SecondaryTransport プロパティを使用します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkTransportInfo::Address プロパティ [C++]

BizTalkTransportInfo.Address プロパティ [Visual Basic]

Address プロパティには、送信先アドレスが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Address(
BSTR* pstrTransportAddress
);

Put メソッド :

HRESULT put_Address(
BSTR strTransportAddress
);

[Visual Basic]

object.Address

パラメータ

[C++]

Get メソッド :

pstrTransportAddress

[out, retval] アドレスを含む BSTR へのポインタです。

Put メソッド :

strTransportAddress

[in] アドレスを含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、アドレスを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合、Address は設定できず、Type プロパティを BIZTALK_TRANSPORT_TYPE_OPENDESTINATION に設定する必要があります。

Address には、Type プロパティに応じて次のプレフィックスのいずれかが必要です。

トランスポートの種類 | プレフィックス | Address の値の例
APPINTEGRATION | なし | {11111111-1111-1111-1111-111111111111}
FILE | file:// | file://C:\Test\MyFile.xml
HTTP | http:// | http://www.vigorair-18.com/repository/bts.asp
HTTPS | https:// | https://www.vigorair-18.com/secure/btss.asp
LOOPBACK | なし | なし
MSMQ | なし | DIRECT=OS:.\private$\myqueue
NONE | なし | なし
OPENDESTINATION | なし | なし
ORCHESTRATIONACTIVATION | なし | C:\XLANG\Schedules\mysched.skx
SMTP | mailto: | mailto:patricia@vigorair-18.com

注

  • メッセージ キューが送信先アドレスとして指定されている場合は、オープンなメッセージ ポートに queue:// プレフィックスを使用する必要があります。オープンなメッセージ ポートの場合、アドレスは、ドキュメント インスタンス内で指定されるか、ドキュメントを送信するときにパラメータとして指定されます。詳細については、「ルーティング」を参照してください。

  • オーケストレーション アクティベーション コンポーネント トランスポート タイプを使用している場合、Address プロパティには、ローカル コンピュータの XLANG スケジュールの完全パスが含まれている必要があります。file:// プレフィックスは、XLANG スケジュール (.skx) ファイルのパスを指定するときには使用できません。

  • HTTP トランスポート タイプか HTTPS トランスポート タイプを使用している場合、BizTalk Server は既定ではプロキシ サーバーを使用してデータを送信します。これは、企業のファイアウォールの外部にあるコンピュータにデータをトランスポートするのに適した設定です。ただし、企業のイントラネット内でデータを送信する場合は、プロキシ サーバーの使用をバイパスできます。プロキシ サーバーの使用をバイパスするには、トランスポート ディクショナリの UseProxy フィールドを False に設定します。詳細については、「SetConfigData」を参照してください。

file:// トランスポート タイプを使用している場合、ファイル名を変更する記号を使用できます。サーバーで作成されたファイル名には、Address プロパティで指定した静的な文字のほか、記号の実際の値が含まれています。たとえば、Address プロパティが file://C:\Orders\Invoice_%tracking_id%.xml に設定されている場合、実際のファイル名の書式は、C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF} のようになります。次の表は、file:// トランスポート タイプで使用できる記号を示しています。

記号 | 説明 | 一意なファイル名
%datetime% | ファイル作成の日時 (ミリ秒単位)。ローカル時間ではなくグリニッジ標準時 (GMT) が使用されます。 | なし
%document_name% | BizTalk Server で処理されたドキュメントの名前。 | なし
%server% | ドキュメントを処理したサーバーの名前。 | なし
%tracking_id% | 一意なグローバル追跡番号。 | あり
%uid% | 時間の経過に従って増加するカウンタ (ミリ秒単位)。この数値はサーバーを再起動するとリセットされます。 | なし

SMTP トランスポート プロトコルを使用して信頼できるメッセージの受信確認を送信する場合、Reliable Messaging Acknowledgement SMTP From Address という名前の識別子で指定された値が From アドレスとして使用されます。この識別子は、既定の BizTalkOrganization オブジェクトに対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。詳細については、「信頼できるメッセージを使用した受信確認処理」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkTransportInfo::Parameter プロパティ [C++]

BizTalkTransportInfo.Parameter プロパティ [Visual Basic]

Type プロパティが BIZTALK_TRANSPORT_TYPE_SMTP に設定されている場合、Parameter プロパティには、関連付けられた送信元 BizTalkOrganization オブジェクトの差出人電子メール アドレスが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Parameter(
BSTR* pstrPrimaryTransportParameter
);

Put メソッド :

HRESULT put_Parameter(
BSTR strPrimaryTransportParameter
);

[Visual Basic]

object.Parameter

パラメータ

[C++]

Get メソッド :

pstrPrimaryTransportParameter

[out, retval] アドレスを含む BSTR へのポインタです。

Put メソッド :

strPrimaryTransportParameter

[in] アドレスを含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、アドレスを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IBizTalkTransportInfo::Type プロパティ [C++]

BizTalkTransportInfo.Type プロパティ [Visual Basic]

Type プロパティには、トランスポート コンポーネントの種類を示す列挙値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Type(
BIZTALK_TRANSPORT_TYPE* pTransportType
);

Put メソッド :

HRESULT put_Type(
BIZTALK_TRANSPORT_TYPE TransportType
);

[Visual Basic]

object.Type

パラメータ

[C++]

Get メソッド :

pTransportType

[out, retval] 列挙値へのポインタです。有効な値は、BIZTALK_TRANSPORT_TYPE 列挙からの値です。

Put メソッド :

TransportType

[in] 列挙値です。有効な値は、BIZTALK_TRANSPORT_TYPE 列挙からの値です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは列挙値を返します。有効な値は、BIZTALK_TRANSPORT_TYPE 列挙からの値です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

次の制約が適用されます。

  • 関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合、Address プロパティは設定できず、Type を BIZTALK_TRANSPORT_TYPE_OPENDESTINATION に設定する必要があります。

メッセージ キュー トランスポート タイプ (BIZTALK_TRANSPORT_TYPE_MSMQ) を使用する場合は、次の制約が適用されます。

  • エンベロープを使用する場合、BizTalk Server に送信するドキュメントの最大サイズは 4 MB です。

  • エンベロープを使用しない場合、BizTalk Server に送信するドキュメントの最大サイズは 2 MB です。

  • BIZTALK_TRANSPORT_TYPE_SMTP を使用する場合は、Parameter プロパティを返信先 SMTP アドレスに設定する必要があります。

  • BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION というトランスポートの種類は、関連付けられた BizTalkEndPoint オブジェクトの Openness プロパティが BIZTALK_OPENNESS_TYPE_TOWORKFLOW に設定されているときにしかサポートされません。

  • オーケストレーション アクティベーション コンポーネント タイプ (BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION) を使用している場合、XLANG スケジュール上のポートに送信するドキュメントの最大サイズは 2 MB です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BizTalkObjectModel.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll) を使用します。


IDictionary インターフェイス [C++]

CDictionary オブジェクト [Visual Basic]

Dictionary オブジェクトは、メモリ内の名前と値のペアの作成、格納、および取得をサポートする収集オブジェクトです。このオブジェクトは、BizTalk メッセージ構成オブジェクト モデル内のいくつかのメソッドによって使用されます。

C++ では、Dictionary オブジェクトのメソッドにアクセスするには IDictionary インターフェイスを使用します。Microsoft Visual Basic では、CDictionary クラスは Dictionary オブジェクトのメソッドとプロパティを定義します。

次の表は、Dictionary オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Count (数) | long | Dictionary オブジェクト内のエントリの数です。これは読み取り専用プロパティです。
NewEnum (新しい列挙子) | IUnknown | Dictionary オブジェクトに対する IUnknown インターフェイス ポインタを返します。呼び出し元は、このインターフェイス ポインタを使用して、このオブジェクトに対する列挙子の QueryInterface を呼び出すことができます。これは読み取り専用プロパティです。
Prefix (プレフィックス) | BSTR | Dictionary オブジェクトのコンテンツが保存されるときに、特定のプレフィックスが付いたエントリをすべて除外するフィルタです。
Value (値) | VARIANT | エントリ名に関連付けられている値です。

次の表は、Dictionary オブジェクトのメソッドを示しています。

メソッド | 説明
GetMultiple | Dictionary オブジェクトの複数のエントリの値を返します。
PutMultiple | 指定されたエントリを Dictionary オブジェクトに追加するか、またはそのエントリを変更します。

解説

Dictionary オブジェクトは、汎用の収集オブジェクトとして設計されています。したがって、このオブジェクトの内部構造によってサポートされている、すべてのものに対して使用できます。Dictionary オブジェクト内の値のデータ型はすべて Variant です。つまり、作成する Dictionary オブジェクトの構成要素には、ほかの Dictionary オブジェクトも含めて、ほとんどすべての種類の値が使用できます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


IDictionary::Count プロパティ [C++]

CDictionary.Count プロパティ [Visual Basic]

Count プロパティは、Dictionary オブジェクト内の要素の数を返します。

構文

[C++]

HRESULT get_Count(
long* Count
);

[Visual Basic]

object.Count

パラメータ

[C++]

Count

[out, retval] 要素数を返すために使用される Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、要素数を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティは読み取り専用です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


IDictionary::GetMultiple メソッド [C++]

CDictionary.GetMultiple メソッド [Visual Basic]

GetMultiple メソッドは、Dictionary オブジェクトの複数のエントリを返します。

構文

[C++]

HRESULT GetMultiple(
long cb,
 const LPOLESTR rgolestr[],
 VARIANT rgvar[]
);

[Visual Basic]

object.GetMultiple( _
 cb As Long, _
 rgolestr As String, _
 rgvar As Variant _
)

パラメータ

[C++]

cb

[in] 取得する値の数を指定する Long です。

rgolestr

[in, size_is(cb)] 値の取得対象の Dictionary オブジェクト エントリを識別する文字列値の配列です。

rgvar

[out, size_is(cb)] VARIANT の配列です。GetMultiple が戻る場合、この配列には、rgolestr[] 配列によって識別される Dictionary オブジェクト エントリに関連付けられた値が含まれます。

[Visual Basic]

cb

取得する値の数を指定する Long です。

rgolestr

値の取得対象の CDictionary オブジェクト エントリを識別する文字列値の配列です。

rgvar

Variant の配列です。GetMultiple が戻る場合、この配列には、rgolestr 配列によって識別される CDictionary オブジェクト エントリに関連付けられた値が含まれます。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

Microsoft Visual Basic Scripting Edition (VBScript) から PutMultiple または GetMultiple を呼び出すと、エラーが発生します。これらのメソッドは VBScript がサポートしていないデータ型を必要とするためです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


IDictionary::NewEnum プロパティ [C++]

CDictionary.NewEnum プロパティ [Visual Basic]

[C++]

NewEnum プロパティは、Dictionary オブジェクトの IEnumVariant インターフェイスを実装する Enumerator オブジェクトを取得します。

[Visual Basic]

このプロパティは Microsoft Visual Basic では使用できません。

構文

[C++]

Get メソッド :

HRESULT get_NewEnum(
IUnknown** _NewEnum
);

[Visual Basic]

なし

パラメータ

[C++]

_NewEnum

[out, retval] このコレクションの IEnumVariant を実装するオブジェクトの IUnknown インターフェイスへのポインタのアドレスです。返されたポインタを使用して QueryInterface を呼び出すことにより、このオブジェクトの IEnumVariant へのポインタを取得できます。これらの要素に関連付けられた値を取得するには、IEnumVariant インターフェイスの Next メソッドを使用して要素を順番に検索し、それらの要素に対して Value メソッドを呼び出します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

なし

解説

[C++]

このプロパティは読み取り専用です。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。

[Visual Basic]

なし


IDictionary::Prefix プロパティ [C++]

CDictionary.Prefix プロパティ [Visual Basic]

Prefix プロパティには、Dictionary オブジェクトのコンテンツが保存されるときに、特定のプレフィックスが付いたエントリを除外するフィルタが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Prefix(
BSTR* Prefix
);

Put メソッド :

HRESULT put_Prefix(
BSTR Prefix
);

[Visual Basic]

object.Prefix

パラメータ

[C++]

Get メソッド :

Prefix

[out, retval] プレフィックスを含む BSTR へのポインタです。

Put メソッド :

Prefix

[in] プレフィックスを含む BSTR です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、プレフィックスを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

名前の先頭に指定されたプレフィックスがある場合、その名前と値のペアは、データベースに保存されません。既定のプレフィックスはアンダースコア (_) です。したがって、アンダースコアで始まるキーワードは、そのプレフィックスが変更されない限り、保存されません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


IDictionary::PutMultiple メソッド [C++]

CDictionary.PutMultiple メソッド [Visual Basic]

PutMultiple メソッドは、指定されたエントリを Dictionary オブジェクトに追加するか、またはそのエントリを変更します。

構文

[C++]

HRESULT PutMultiple(
long cb,
 const LPOLESTR rgolestr[],
 const VARIANT rgvar[]
);

[Visual Basic]

object.PutMultiple( _
 cb As Long, _
 rgolestr As String, _
 rgvar As Variant _
)

パラメータ

[C++]

cb

[in] rgolestr 配列と rgvar 配列内の要素数を識別する Long です。

rgolestr

[in, size_is(cb)] Dictionary オブジェクトに追加する名前を含む文字列の配列です。

rgvar

[in, size_is(cb)] Dictionary オブジェクトに追加する値を含む VARIANT の配列です。

[Visual Basic]

cb

rgolestr 配列と rgvar 配列内の要素数を識別する Long です。

rgolestr

CDictionary オブジェクトに追加する名前を含む文字列の配列です。

rgvar

CDictionary オブジェクトに追加する値を含む Variant の配列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

rgolestr 配列と rgvar 配列の各要素は 1 対 1 でマッピングされています。つまり、rgolestr[n] を Dictionary オブジェクトに追加すると、rgvar[n] の値で初期化されます。rgolestr[n] で指定される要素がすでに Dictionary オブジェクトに存在する場合、その要素に関連付けられている値は、rgvar[n] に格納されている値で上書きされます。

[Visual Basic]

Microsoft Visual Basic Scripting Edition (VBScript) から PutMultiple または GetMultiple を呼び出すと、エラーが発生します。これらのメソッドは VBScript がサポートしていないデータ型を必要とするためです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


IDictionary::Value プロパティ [C++]

CDictionary.Value プロパティ [Visual Basic]

Value プロパティは、エントリ名に関連付けられた値を返すか、または設定します。

構文

[C++]

Get メソッド :

HRESULT get_Value(
BSTR bstrName,
 VARIANT* Value
);

Put メソッド :

HRESULT put_Value(
BSTR bstrName,
 VARIANT Value
);

[Visual Basic]

object.Value( _
bstrName As String _
)

パラメータ

[C++]

Get メソッド :

bstrName

[in] 名前を含む BSTR です。

Value

[out, retval] 値を返すために使用される VARIANT へのポインタです。

Put メソッド :

bstrName

[in] 名前を含む BSTR です。

Value

[in] プロパティを設定する場合、値を含む VARIANT です。

[Visual Basic]

bstrName

名前を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、値を含む Variant をオプションで返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

名前付きエントリを Dictionary オブジェクトのプロパティとして処理することによって、Value メソッドを明示的に使用せずに、Dictionary オブジェクトの値を読み取ったり、書き込んだりできます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


ISimpleList インターフェイス [C++]

CSimpleList オブジェクト [Visual Basic]

SimpleList オブジェクトは、列挙をサポートするバリアントの配列を作成するために使用します。

C++ では、SimpleList オブジェクトのメソッドにアクセスするには ISimpleList インターフェイスを使用します。Microsoft Visual Basic では、CSimpleList クラスは SimpleList オブジェクトのメソッドとプロパティを定義します。

次の表は、SimpleList オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
Count (数) | long | SimpleList オブジェクト内の要素の数です。これは読み取り専用プロパティです。
Item (項目) | VARIANT | SimpleList オブジェクトの要素のコンテナです。

次の表は、SimpleList オブジェクトのメソッドを示しています。

メソッド | 説明
Add | 指定した項目を SimpleList オブジェクトに追加します。
Delete | 指定した項目を SimpleList オブジェクトから削除します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


ISimpleList::Add メソッド [C++]

CSimpleList.Add メソッド [Visual Basic]

Add メソッドは、指定した項目を SimpleList オブジェクトに追加します。

構文

[C++]

HRESULT Add(
VARIANT* pVar
);

[Visual Basic]

object.Add( _
 pVar As Variant _
)

パラメータ

[C++]

pVar

[in] SimpleList オブジェクトに追加する VARIANT へのポインタです。

[Visual Basic]

pVar

CSimpleList オブジェクトに追加する Variant です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


ISimpleList::Count プロパティ [C++]

CSimpleList.Count プロパティ [Visual Basic]

Count プロパティは、SimpleList オブジェクト内の要素の数を返します。

構文

[C++]

Get メソッド :

HRESULT get_Count(
long* Count
);

[Visual Basic]

object.Count

パラメータ

[C++]

Count

[out, retval] SimpleList オブジェクト内の項目の数を返すために使用される long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、CSimpleList オブジェクト内の項目の数を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティは読み取り専用です。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


ISimpleList::Delete メソッド [C++]

CSimpleList.Delete メソッド [Visual Basic]

Delete メソッドは、指定した項目を SimpleList オブジェクトから削除します。

構文

[C++]

HRESULT Delete(
long Index
);

[Visual Basic]

object.Delete( _
 Index As Long _
)

パラメータ

[C++]

Index

[in] 削除する項目のインデックス値を含む Long です。

[Visual Basic]

Index

削除する項目のインデックス値を含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


ISimpleList::Item プロパティ [C++]

CSimpleList.Item プロパティ [Visual Basic]

Item プロパティは、SimpleList オブジェクトの要素を含む、読み取り/書き込み Variant です。初期化された Variant は、指定した配列インデックスに格納されます。指定したインデックスに既に項目が格納されている場合、その項目は put メソッドによって上書きされます。

構文

[C++]

Get メソッド :

HRESULT get_Item(
long Index
 VARIANT* Item
);

Put メソッド :

HRESULT put_Item(
long Index,
VARIANT Item
);

Putref メソッド :

HRESULT putref_Item(
long Index,
VARIANT Item
);

[Visual Basic]

object.Item( _
Index As Long _
)

パラメータ

[C++]

Get メソッド :

Index

[in] 項目のインデックスを含む Long です。

Item

[out, retval] 項目を返すために使用される VARIANT へのポインタです。

Put メソッドと Putref メソッド :

Index

[in] 項目のインデックスを含む Long です。

Item

[in] 新しい項目を含む VARIANT です。

[Visual Basic]

Index

項目のインデックスを含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、新しい項目を含む Variant を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

値を設定する場合、オブジェクト参照を設定するには putref_Item メソッドを使用し、スカラ値を設定するには put_Item メソッドを使用します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : commerce.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll) を使用します。


オブジェクト モデルの列挙

以下の列挙について、プロパティとパラメータの値を説明します。

  • BIZTALK_ENCODING_TYPE

  • BIZTALK_ENCRYPTION_TYPE

  • BIZTALK_OPENNESS_TYPE

  • BIZTALK_OPENNESS_TYPE_EX

  • BIZTALK_SIGNATURE_TYPE

  • BIZTALK_STORE_TYPE

  • BIZTALK_TRANSPORT_TYPE

  • BIZTALK_USAGE_TYPE

  • BIZTALK_CONFIGDATA_TYPE


BIZTALK_ENCODING_TYPE

BIZTALK_ENCODING_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_ENCODING_TYPE_NONE | 1 | エンコードを使用しないことを示します。
BIZTALK_ENCODING_TYPE_MIME | 2 | Multipurpose Internet Mail Extensions (MIME) エンコードを示します。
BIZTALK_ENCODING_TYPE_CUSTOM | 3 | カスタム エンコードを示します。


BIZTALK_ENCRYPTION_TYPE

BIZTALK_ENCRYPTION_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_ENCRYPTION_TYPE_NONE | 1 | 暗号化を使用しないことを示します。
BIZTALK_ENCRYPTION_TYPE_CUSTOM | 2 | カスタム暗号化を示します。
BIZTALK_ENCRYPTION_TYPE_SMIME | 4 | Secure Multipurpose Internet Mail Extensions (S/MIME) 暗号化を示します。


BIZTALK_OPENNESS_TYPE

BIZTALK_OPENNESS_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_OPENNESS_TYPE_NOTOPEN | 1 | このオブジェクトのインスタンスがオープンでないことを示します。
BIZTALK_OPENNESS_TYPE_SOURCE | 2 | このオブジェクトのインスタンスの送信元組織がオープンであることを示します。
BIZTALK_OPENNESS_TYPE_DESTINATION | 4 | このオブジェクトのインスタンスの送信先組織がオープンであることを示します。


BIZTALK_OPENNESS_TYPE_EX

BIZTALK_OPENNESS_TYPE_EX 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_OPENNESS_TYPE_EX_NOTOPEN | 1 | このオブジェクトのインスタンスがオープンでないことを示します。
BIZTALK_OPENNESS_TYPE_EX_SOURCE | 2 | このオブジェクトのインスタンスの送信元組織がオープンであることを示します。
BIZTALK_OPENNESS_TYPE_EX_DESTINATION | 4 | このオブジェクトのインスタンスの送信先組織がオープンであることを示します。
BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW | 8 | BizTalk Server が、XLANG スケジュール インスタンスからドキュメントを受信していることを示します。
BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW | 16 | BizTalk Server が、XLANG スケジュール インスタンスにドキュメントを送信していることを示します。


BIZTALK_SIGNATURE_TYPE

BIZTALK_SIGNATURE_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_SIGNATURE_TYPE_NONE | 1 | 署名がないことを示します。
BIZTALK_SIGNATURE_TYPE_CUSTOM | 2 | ドキュメントのカスタム署名を示します。
BIZTALK_SIGNATURE_TYPE_SMIME | 4 | ドキュメントの S/MIME 署名を示します。


BIZTALK_STORE_TYPE

BIZTALK_STORE_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_STORE_TYPE_MY | 1 | 証明書ストアが MY 型であることを示します。このストアには、ユーザーの組織が認証した証明書しか含まれません。
BIZTALK_STORE_TYPE_BIZTALK | 2 | 専用の BizTalk Server 2000 ストアに証明書が格納されることを示します。


BIZTALK_TRANSPORT_TYPE

BIZTALK_TRANSPORT_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_TRANSPORT_TYPE_NONE | 1 | オブジェクトのこのインスタンスがトランスポート コンポーネントを選択しないことを示します。
BIZTALK_TRANSPORT_TYPE_HTTP | 4 | オブジェクトのこのインスタンスが Hypertext Transport Protocol (HTTP) トランスポート コンポーネントを選択することを示します。
BIZTALK_TRANSPORT_TYPE_SMTP | 8 | オブジェクトのこのインスタンスが Simple Mail Transfer Protocol (SMTP) トランスポート コンポーネントを選択することを示します。
BIZTALK_TRANSPORT_TYPE_ APPINTEGRATION | 32 | オブジェクトのこのインスタンスがアプリケーション統合コンポーネント (AIC) トランスポート コンポーネントを選択することを示します。
BIZTALK_TRANSPORT_TYPE_MSMQ | 128 | オブジェクトのこのインスタンスが Microsoft メッセージ キュー トランスポート コンポーネントを選択することを示します。
BIZTALK_TRANSPORT_TYPE_FILE | 256 | オブジェクトのこのインスタンスが、トランスポート コンポーネントとしてファイルを選択することを示します。
BIZTALK_TRANSPORT_TYPE_HTTPS | 1024 | オブジェクトのこのインスタンスが Secure Hypertext Transfer Protocol (HTTPS) トランスポート コンポーネントを選択することを示します。
BIZTALK_TRANSPORT_TYPE_ OPENDESTINATION | 2048 | メッセージ ポートが、オープンな送信先であることを示します。
BIZTALK_TRANSPORT_TYPE_LOOPBACK | 4096 | SubmitSync メソッドを使用してサーバーに送信されたドキュメントが、処理されてからそのメソッドの応答ドキュメントとして返されることを示します。
BIZTALK_TRANSPORT_TYPE_ ORCHESTRATIONACTIVATION | 8192 | Address プロパティに、実行される XLANG スケジュールのパスが含まれることを示します。


BIZTALK_USAGE_TYPE

BIZTALK_USAGE_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_USAGE_TYPE_ENCRYPTION | 1 | これが暗号化証明書であることを示します。
BIZTALK_USAGE_TYPE_SIGNATURE | 2 | これが署名証明書であることを示します。
BIZTALK_USAGE_TYPE_BOTH | 4 | この証明書が暗号化と署名の両方に使用されることを示します。


BIZTALK_CONFIGDATA_TYPE

BIZTALK_CONFIGDATA_TYPE 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT | 0 | メッセージ ポートのプライマリ トランスポートを構成します。
BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT | 1 | メッセージ ポートのセカンダリ トランスポートを構成します。
BIZTALK_CONFIGDATA_TYPE_ENCRYPTION | 2 | メッセージ ポートの暗号化証明書を構成します。
BIZTALK_CONFIGDATA_TYPE_ENCODING | 3 | メッセージ ポートの暗号化の種類を構成します。
BIZTALK_CONFIGDATA_TYPE_SIGNATURE | 4 | メッセージ ポートの署名検証を構成します。
BIZTALK_CONFIGDATA_TYPE_SERIALIZER | 5 | メッセージ ポートのシリアライザを構成します。


エラー メッセージ

BizTalk メッセージ構成オブジェクト モデルのプロパティとメソッドは、標準コンポーネント オブジェクト モデル (COM) の HRESULT 戻り値を使用して、操作が正常に終了したかどうかについて通信します。

C++ では、これらの値はメソッド自身からの実際の戻り値です。このメソッドには、プロパティの get_ メソッドと put_ メソッドが含まれます。プログラムは、これらの戻り値を検査して明示的にエラー チェックを実行するか、構造化されたさまざまなエラー処理を使用する必要があります。

Microsoft Visual Basic (VB) および Visual Basic Scripting Edition (VBS) では、これらの値はグローバル Err オブジェクトの Number プロパティに格納されます。エラー処理では、自動的にエラーを処理して標準エラー ダイアログ ボックスを表示するか、プログラムで明示的に処理してグローバル Err オブジェクトの Number プロパティの値を確認します。On Error Resume Next コマンドを使用すると、自動エラー処理が無効になり、明示的なエラー処理が有効になります。

エラー メッセージの値の詳細については、次のトピックを参照してください。

  • 標準 COM エラー

  • BizTalk Server 2000 エラー メッセージ


標準 COM エラー

次の表は、BizTalk Server オブジェクトのプロパティおよびメソッドによって返される最も一般的な標準 COM エラーを示しています。

定数 | 値 (32 ビット) | 説明
S_OK | 00000000 | 正常終了を通信するときに使用される標準戻り値です。
S_FALSE | 00000001 | 正常値の代替です。一般的には、正常だが標準的ではない完了を通信するときに使用されます。正確な意味は、使用するメソッドまたはプロパティによって異なります。
E_UNEXPECTED | 8000FFFF | 致命的なエラーです。
E_NOTIMPL | 80004001 | 未実装によるエラーです。
E_OUTOFMEMORY | 8007000E | メモリ不足によるエラーです。
E_INVALIDARG | 80070057 | 1 つ以上の引数が無効であることによるエラーです。
E_NOINTERFACE | 80004002 | インターフェイスがサポートされていないことによるエラーです。
E_POINTER | 80004003 | ポインタが無効であることによるエラーです。
E_HANDLE | 80070006 | ハンドルが無効であることによるエラーです。
E_ABORT | 80004004 | 操作中止エラーです。
E_FAIL | 80004005 | 特定できないエラーです。
E_ACCESSDENIED | 80070005 | 一般アクセス拒否エラーです。
MK_E_NOOBJECT | 800401E5 | このモニカで識別されるオブジェクトが見つかりません。

グローバル Err オブジェクトを使用すると、追加情報を利用できることがあります。Visual Basic では、Err オブジェクトの Description プロパティにエラーの説明が格納されていることがあります。

C++ では、IErrorRecords インターフェイスの OLE DB メソッド GetErrorInfo を呼び出して、現在の論理スレッドで最も最近に設定された IErrorInfo ポインタを取得します。IErrorInfo インターフェイスの GetDescription メソッドが、エラーの説明を返すことがあります。GetErrorInfo メソッドの詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/) で、「プラットフォーム SDK ドキュメント」、「プラットフォーム SDK ドキュメント (日本語)」、「データ アクセス サービス」、「Microsoft OLE DB 2.0 プログラマーズ リファレンス & データ アクセス SDK」の順に展開し、「第 2 部 OLE DB リファレンス」を参照してください。


BizTalk Server 2000 エラー メッセージ

BizTalk Server で定義されている BizTalk メッセージ構成オブジェクト モデルのエラー メッセージは、BizTalk Server をインストールしたディレクトリの \Program Files\Microsoft BizTalk Server\SDK\Include にある bts_config_errors.h ファイルを含めることにより、アプリケーションで使用できるようになります。設計時にオブジェクト モデルのメソッドとプロパティが返すエラー メッセージについては、メッセージ名にプレフィックス BTS_ が含まれています。そのほかのエラーはすべて、BizTalk Server がドキュメントを処理する実行時に発生するものです。

次の表は、設計時のエラーと実行時のエラーの両方を示しています。

メッセージ名 | 値 | 説明
CIS_E_OBJECT_NOT_FOUND | 0x0100 | オブジェクトが見つかりませんでした。
CIS_E_STATE_NOT_FOUND | 0x0101 | ステータス エンジンの状態がメッセージ ポート定義の中に見つかりませんでした。
CIS_E_STATE_TRANSITION | 0x0103 | ステータス テーブルに、正しくないエンジン ステータス移行が含まれています。
CIS_E_BAD_ENGINE_CONFIG_FILE | 0x0105 | 入力ステータスの構成を記述している文字列が無効です。
CIS_E_CANNOT_ADD_STATE | 0x0106 | BizTalk Server がユーザー定義のステータスをシステムに追加できませんでした。
CIS_E_NO_COMPONENT_FOUND | 0x0107 | ステータス定義にコンポーネントがないか、ProgID が正しくありません。
CIS_E_PIPECOMP_ADMIN_REQUIRED | 0x0108 | 必要な IPipelineComponentAdmin インターフェイスがコンポーネントに見つかりませんでした。
CIS_E_BAD_COMPONENT_TYPE | 0x0109 | ステータス エンジンの指定されたコンポーネントの種類は認識されません。
CIS_E_BAD_STATE_CONFIG | 0x010A | ステータス構成が無効です。
CIS_E_BAD_STATE_TYPE | 0x010B | 指定したステータスの種類は認識されません。
CIS_E_BAD_COMPONENT_CONFIG | 0x010C | コンポーネントの構成が無効です。
CIS_E_INTERNAL_FAILURE | 0x010F | 原因不明の理由により、内部サーバー エラーが発生しました。
CIS_E_CREATE_SCHEDULER_FAILED | 0x0111 | サービスのキュー スケジューラを作成できませんでした。
CIS_E_AGREEMENT_SELECT_FAILED | 0x0112 | 入力基準に一致するチャネルがありません。メッセージ ポートおよびチャネルが存在するかどうか、またそれらが次のフィールドに一致するかどうかを確認してください。送信元修飾子 : "%1" 送信元識別子値 : "%2" 送信元ドキュメント名 : "%3" 送信先修飾子 : "%4" 送信先識別子値 : "%5" また、チャネル用に指定されている式がこのドキュメントと互換性があるかどうかも確認してください。
CIS_E_ERROR | 0x0113 | BizTalk Server でエラーが発生しました。%n %n 詳細 :%n ------------------------------%n %1
CIS_E_SERVICE_INITIALIZATION_FAILURE | 0x0114 | サービスの開始に失敗しました。このサーバーが BizTalk Server グループに入っているか確認してください。
CIS_E_SCHEDULER_FAILED | 0x0115 | キュー スケジューラが失敗し、終了しました。
CIS_E_WORKER_THREAD_FAILED | 0x0116 | 作業スレッドが失敗し、終了しました。
CIS_E_SHARED_QUEUE_DB_EXEC_FAILED | 0x0117 | 共有キュー データベースの実行に失敗しました。
CIS_E_CANT_READ_WORK_ITEM | 0x0119 | 共有キュー データベースの作業項目が読めません。
CIS_E_CHECKPOINT_FAILED | 0x011c | 作業項目のチェックポイントに失敗しました。
CIS_E_CREATE_DEAD_WORK_ITEM_FAILED | 0x011e | 保留キューの新しい作業項目を作成できません。
CIS_E_GET_SNAPSHOT_FAILED | 0x0122 | 共有キュー データベースのスナップショットを取得できません。
CIS_E_FREE_INTERCHANGES_FAILED | 0x0124 | 指定したインターチェンジを解放できません。
CIS_E_DELETE_INTERCHANGE_FAILED | 0x0125 | 指定したインターチェンジを削除できません。
CIS_E_RECEIVING_INTERCHANGE_FAILED | 0x0127 | 指定したインターチェンジが受信されませんでした。
CIS_E_GETTING_NEXT_SCHEDULED_WORK_ITEM_FAILED | 0x0128 | 次のスケジュールされた作業項目を、処理するために取得できません。
CIS_E_GET_COUNT_FAILED | 0x0129 | 共有キューの数を取得できません。
CIS_E_TRANSMISSION_FAILED | 0x012a | 転送の再試行にすべて失敗しました。
CIS_W_TRANSMISSION_ATTEMPT_FAILED | 0x012b | 転送しようとして失敗しました。
CIS_W_TRANSMISSION_XFER_TO_SECONDARY | 0x012c | メッセージ ポート "%1" のプライマリ トランスポートはデータを送信できません。セカンダリ ポートに切り替えられます。
CIS_E_RECEIPT_GENERATION_FAILED | 0x012e | 作業項目を作成した後に、受信を生成しようとして失敗しました。
CIS_E_RECEIPT_GENERATION_FAILED_NO_WORK_ITEM | 0x012f | 作業項目を作成する前に、受信を生成しようとして失敗しました。
CIS_E_L1_RECEIPT_CORRELATION_FAILED | 0x0130 | 受信確認の照合に失敗しました。
CIS_E_AGREEMENT_LACKING_PARAMS | 0x0133 | チャネルの選択に必要なフィールドが、少なくとも 1 つ不足しています。ドキュメントおよびエンベロープが、パーサーの正しいフィールドを抽出しているか、送信に必要なフィールドを指定しているか確認してください。チャネルの選択フィールド :送信元識別子の種類 : "%1" 送信元識別子値 : "%2" 送信元ドキュメント名 : "%3" 送信先識別子の種類 : "%4" 送信先識別子値 : "%5"
CIS_E_AGREEMENT_FAILED | 0x0134 | チャネルを選択できません。
CIS_E_ORIGINAL_L1_INTERCHANGE_MISSING | 0x0135 | 受信を関連付けようとしたとき、元のインターチェンジおよび関連するドキュメントが存在しませんでした。
CIS_E_UNEXPECTED_DB_BEHAVIOR | 0x0136 | 予期しない返答が発生しました。データベースの再起動が必要になる可能性があります。
CIS_E_AGREEMENT_INVALID_MAP | 0x0137 | 参照 "%1" で指定されているマップが無効です。参照が BizTalk マッパーで作成した有効なマップを指定していることを確認してください。
CIS_I_SERVICE_MSG | 0x0138 | 1%
CIS_E_AGREEMENT_MAP_FAILED | 0x0139 | XML ドキュメントを変換できませんでした。参照 "%1" で指定したマップが失敗しました。マップが最新のものかどうかを確認してください。
CIS_E_XML_ERROR | 0x013A | 次の理由により、行 %2 の位置 %3 において XML ドキュメントの解析ができませんでした。"%1"
CIS_E_AGREEMENT_PROCESSING_FAILED | 0x013f | サーバーでドキュメント処理を終了できませんでした。
CIS_E_AGREEMENT_PROCESSING_FAILED_W_NAME | 0x0140 | 次のチャネルの構成は無効です : "%1"
CIS_E_AGREEMENT_INVALID_QUERY | 0x0141 | "%1" ドキュメント追跡項目に対する "%2" クエリは、有効な XSL パターンではありません。パターンを削除するか、修正してください。
CIS_I_SERVICE_START | 0x0142 | サービスを開始しました。
CIS_I_SERVICE_STOP | 0x0143 | サービスを停止しました。
CIS_E_ERROR_EX | 0x0144 | BizTalk Server でエラーが発生しました。%n %n 詳細 :%n ------------------------------%n %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_E_ERROR_EX_HEAD | 0x0145 | ======================================== ======================================= 日付 : %1 送信元 : BizTalk Server 2000 時刻 : %2 カテゴリ : BizTalk Server 2000 ユーザー : %3 コンピュータ : %4 説明 :BizTalk Server でエラーが発生しました。詳細 : -------
CIS_E_ERROR_EX_FOOT | 0x0146 |
CIS_E_INVALID_DATA_FORMAT | 0x0147 | 渡されたビジネス ドキュメントの書式が認識されないため、解析または解読ができませんでした。
CIS_E_CREATE_ENGINE | 0x0148 | BizTalk Server で作業項目を処理するための、処理エンジンの新しいインスタンスを作成できませんでした。新しい COM+ トランザクションの作成に失敗した可能性があります。
CIS_E_MISSING_DESTINATION_DOCUMENT_SPEC | 0x0149 | BizTalk Server により不完全なメッセージ ポートが検出されました。メッセージ ポートで送信先仕様が見つかりません。
CIS_E_PROCESSING_THREAD_FAILED | 0x014A | 処理スレッドの開始に失敗しました。ステータス エンジンの作成に失敗した可能性があります。
CIS_E_NOSRCORG | 0x014B | ID と修飾子の組に対応する送信元組織が指定されていません。
CIS_E_NODESTORG | 0x014C | 識別子と修飾子の組に対応する送信先組織が指定されていません。
CIS_E_NODOC | 0x014D | ドキュメント名に対応するドキュメントが指定されていません。
CIS_E_NOPIPELINES | 0x014E | パラメータに対応するチャネルが指定されていません。
CIS_E_NOT_RESUBMITTABLE | 0x014F | 保留キューにある項目のステータスにより、再送信できません。
CIS_E_PIPESELECT_POLICY_FAILED | 0x0150 | 受信データに見つかった証明書に適合するチャネルがありません。送信されたデータには、次の証明書が添付されています。署名証明書参照 : "%1" 暗号化証明書参照 : "%2"
CIS_E_SUBMIT_INVALIDDOC | 0x0151 | 送信されたドキュメントが無効です。詳細については、次のメッセージを参照してください。
CIS_E_SUBMITSYNC_TOOMANYDOCS | 0x0152 | データ内に複数のドキュメントが見つかったため、SubmitSync メソッドの処理が失敗しました。1 回の同期送信で送信できるドキュメントは 1 つのみです。構造化フラット ファイルの送信が失敗する場合、最も一般的な原因は、データの先頭または末尾に不要なスペースが入っていることです。
CIS_E_SUBMITSYNC_TOOMANYPIPES | 0x0153 | 受信ドキュメントに適合する有効なチャネルが複数あるため、同期送信を完了できませんでした。受信ドキュメントに対して適合が許容されるチャネルは 1 つのみです。
CIS_E_XMIT_NOTRANSPORTCOMP | 0x0154 | トランスポート用のクラス ID "%1" 付きコンポーネントを、このサーバーで作成できませんでした。このコンポーネントが正しく登録されているかどうかを確認してください。次のエラーが返されました。
CIS_E_XMIT_EMPTY_DOCUMENT | 0x0155 | メッセージ ポート "%1" は 0 バイトのドキュメントを送信できません。
CIS_E_XMIT_FAILED_W_NAME | 0x0156 | サーバーは、メッセージ ポート "%1" の処理を完了できませんでした。
CIS_E_XMIT_NO_INTERFACE | 0x0157 | サーバーは、CLSID "%2" のトランスポート コンポーネントから "%1" インターフェイスを取得できませんでした。
CIS_E_XMIT_NO_BTS_AIC_INTERFACES | 0x0158 | サーバーは、CLSID "%3" を持つ BizTalk Server アプリケーション統合コンポーネントから "%1" または "%2" インターフェイスを取得できませんでした。
CIS_E_XMIT_FAILED_W_DETAILS | 0x0159 | サーバーが ProgID "%2" のトランスポート コンポーネントを使用してメッセージ ポート "%1" を処理しているときに、トランスポート エラーが発生しました。
CIS_E_NOHDR_ERROR_EX | 0x015A | %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_W_COMP_NOACK | 0x015B | 関連付けコンポーネント "%1" は、受信確認の送信先となるドキュメントを見つけられませんでした。アクションは実行されません。
CIS_E_CORRELATIONCOMP_FAILED | 0x015C | 関連付けコンポーネント "%1" から予期しないエラーが返されました。ドキュメントは保留キューに配置されます。
CIS_E_CORRELATION_FAILED | 0x015D | 受信確認の照合の処理に失敗しました。
CIS_E_XML_VALIDATE_ERROR | 0x015E | 次の理由により、XML ドキュメントは検証に失敗しました。 %1
CIS_E_CHANNEL_ACCESSDENIED | 0x015F | 送信されたドキュメントには、チャネル "%3" に必要な署名または暗号化機能がありません。以下は、送信されたデータに添付されている証明書です。署名証明書参照 : "%1" 暗号化証明書参照 : "%2"
CIS_I_SERVICE_RESTARTING | 0x0160 | サービスを再開しています。
BTS_E_CONSTRAINT | 0x1201 | 制約エラー
BTS_E_NOOBJECT | 0x1202 | オブジェクトが見つかりませんでした。
BTS_E_INTERNALFAILURE | 0x1203 | 内部エラーが発生しました。
BTS_E_ENVELOPE_CONTROLNUMBER | 0x120C | エンベロープ書式が X12 または EDIFACT に設定されている場合は、制御番号の値を 1 以上に設定する必要があります。
BTS_E_ENVELOPE_DELIMETER | 0x120D | エンベロープ書式を X12 に設定する場合は、区切り記号を設定する必要があります。
BTS_E_ENCRYPTION_CUSTOM_NOCLSID | 0x120E | 暗号化の種類がカスタムの場合は、クラス ID (CLSID) を指定する必要があります。
BTS_E_ENCODING_CUSTOM_NOCLSID | 0x120F | エンコードの種類がカスタムの場合は、クラス ID (CLSID) を指定する必要があります。
BTS_E_SIGNATURE_CUSTOM_NOCLSID | 0x1210 | 署名の種類がカスタムの場合は、クラス ID (CLSID) を指定する必要があります。
BTS_E_INVALIDCONTROLNUMBER | 0x1212 | 制御番号は 1 以上に設定してください。
BTS_E_ENVELOPE_INUSE | 0x1213 | このエンベロープはメッセージ ポートで使用されているため変更することができません。
BTS_E_CHANNEL_MISSINGMAPSOURCE | 0x1215 | チャネルに MapSource ノードがありません。
BTS_E_INVALID_CERT_USAGE | 0x1216 | 現在の使用法では、証明書が無効です。暗号化証明書を署名に使用したり、署名証明書を暗号化に使用したりすることはできません。適切な証明書が選択されていることを確認してください。
BTS_E_MISSINGSMTPHOST | 0x1218 | SMTP ホストがありません。SMTP ホストは、BizTalk Server 管理コンソールで構成可能です。
BTS_E_INVALID_ENCRYPT_STORE | 0x1219 | 暗号化ストアの種類が無効です。ストアの種類を BIZTALK に設定してください。
BTS_E_INVALID_SGNTCERT_STORE | 0x121A | 署名ストアの種類が無効です。ストアの種類を MY に設定してください。
BTS_E_DATATOOLONG | 0x121B | データ長が長すぎます。
BTS_E_INVALID_VERIFY_ENCRYPTCERT_STORE | 0x121C | 暗号化検証ストアの種類が無効です。ストアの種類を MY に設定してください。
BTS_E_INVALID_VERIFY_SGNTCERT_STORE | 0x121D | 署名検証ストアの種類が無効です。ストアの種類を BIZTALK に設定してください。
BTS_E_ORGANIZATION_UNIQUE_ID | 0x121F | 組織の識別子が重複しています。
BTS_E_ORGANIZATION_UNIQUE_NAME | 0x1220 | 組織名が重複しています。
BTS_E_OBJECT_ALREADY_EXISTS | 0x1221 | オブジェクトは既に存在します。Clear() メソッドまたは Remove() メソッドを呼び出さずに、Create() メソッドを BizTalk メッセージ構成オブジェクト上で複数回呼び出すことはできません。
BTS_E_ALIAS_UNIQUE_ID | 0x1222 | 識別子が重複しています。
BTS_E_ALIAS_UNIQUE_NAME | 0x1223 | 組織の識別子名が重複しています。
BTS_E_ALIAS_UNIQUE_QUALIFIERVALUE | 0x1225 | 識別子は、一意の修飾子値の組である必要があります。
BTS_E_ALIAS_FOREIGN_OWNERID | 0x1226 | 識別子に参照されているため、組織を削除できません。
BTS_E_XMLSHARE_UNIQUE_ID | 0x1227 | SQL Server データベースにある XML 共有テーブルのプライマリ識別子が重複しています。
BTS_E_XMLSHARE_UNIQUE_REFERENCE | 0x1228 | SQL Server データベースにある XML 共有テーブルへの参照が重複しています。
BTS_E_DOCUMENT_UNIQUE_ID | 0x1229 | ドキュメントの識別子が重複しています。
BTS_E_DOCUMENT_UNIQUE_NAME | 0x122A | ドキュメント名が重複しています。
BTS_E_DOCUMENT_FOREIGN_SHAREID | 0x122C | ドキュメントによって参照されているため、SQL Server データベースの XML 共有テーブルは削除できません。
BTS_E_ENVELOPE_UNIQUE_ID | 0x122D | エンベロープの識別子が重複しています。
BTS_E_ENVELOPE_UNIQUE_NAME | 0x122E | エンベロープ名が重複しています。
BTS_E_ENVELOPE_FOREIGN_SHAREID | 0x1230 | エンベロープによって参照されているため、SQL Server データベースの XML 共有テーブルは削除できません。
BTS_E_CONTROLNUMBER_UNIQUE_ID | 0x1231 | 制御番号の識別子が重複しています。
BTS_E_PORTGROUP_UNIQUE_ID | 0x1232 | 同報リストの識別子が重複しています。
BTS_E_PORTGROUP_UNIQUE_NAME | 0x1233 | 同報リスト名が重複しています。
BTS_E_MISSING_VALUE | 0x1235 | 識別子の値プロパティに値が必要です。
BTS_E_MISSING_SRCORGID | 0x1236 | チャネルの送信元組織プロパティに値が必要です。
BTS_E_APPLICATION_UNIQUE_ID | 0x1237 | アプリケーションの識別子が重複しています。
BTS_E_APPLICATION_FOREIGN_OWNERID | 0x1238 | アプリケーションに参照されているため、組織を削除できません。
BTS_E_APPLICATION_UNIQUE_NAME | 0x1239 | この組織内のアプリケーション名が重複しています。
BTS_E_CHANNEL_UNIQUE_ID | 0x123A | チャネルの識別子が重複しています。
BTS_E_CHANNEL_UNIQUE_NAME | 0x123B | チャネル名が重複しています。
BTS_E_CHANNEL_FOREIGN_INPDOCID | 0x123D | チャネルが使用しているため、受信ドキュメントを削除できません。
BTS_E_CHANNEL_FOREIGN_OUTDOCID | 0x123E | チャネルが使用しているため、出力ドキュメントを削除できません。
BTS_E_CHANNEL_FOREIGN_PORTGROUPID | 0x123F | チャネルが使用しているため、同報リストを削除できません。
BTS_E_CHANNEL_FOREIGN_SRCORGID | 0x1240 | チャネルが使用しているため、送信元組織を削除できません。
BTS_E_ENVELOPE_INVALIDFORMAT | 0x1241 | 有効なエンベロープ書式文字列は、カスタム、カスタム XML、EDIFACT、FlatFile、X12、および Reliable だけです。指定した書式は変更されません。
BTS_E_CHANNEL_FOREIGN_CONTROLNUMID | 0x1242 | チャネルが使用しているため、制御番号を削除できません。
BTS_E_PORT_UNIQUE_ID | 0x1243 | メッセージ ポートの識別子が重複しています。
BTS_E_PORT_UNIQUE_NAME | 0x1244 | メッセージ ポート名が重複しています。
BTS_E_CHANNEL_FOREIGN_SRCAPPID | 0x1247 | チャネルが使用しているため、送信元アプリケーションを削除できません。
BTS_E_PORT_FOREIGN_DSTORGID | 0x1248 | メッセージ ポートが使用しているため、送信先組織を削除できません。
BTS_E_PORT_FOREIGN_DSTALIASID | 0x1249 | メッセージ ポートが使用しているため、送信先識別子を削除できません。
BTS_E_PORT_FOREIGN_ENVID | 0x124A | メッセージ ポートが使用しているため、エンベロープを削除できません。
BTS_E_CHANNEL_FOREIGN_SRCALIASID | 0x124B | チャネルが使用しているため、送信元識別子を削除できません。
BTS_E_PORT_FOREIGN_DSTAPPID | 0x124C | メッセージ ポートが使用しているため、送信先アプリケーションを削除できません。
BTS_E_PORT_FOREIGN_CONTROLNUMID | 0x124D | メッセージ ポートが使用しているため、制御番号を削除できません。
BTS_E_DOCUMENT_MISSING_REFERENCE | 0x124E | TrackingFields または PropertySet のプロパティが指定されている場合は、Reference プロパティに値が必要です。
BTS_E_DOCUMENT_REFERENCE_CANT_BE_CHANGED | 0x124F | ドキュメントの参照は、チャネルから参照されていると変更できません。
BTS_E_PORTGROUP_NOTOPENGRP | 0x1251 | オープンな送信先または XLANG スケジュール (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) として設定されているメッセージ ポートは同報リストで使用できません。
BTS_E_PORTGROUP_DUPLICATEPORT | 0x1252 | 重複したメッセージ ポートは同報リストに追加できません。
BTS_E_OUTPUTCONFIG_UNIQUE_ID | 0x1255 | 出力構成の識別子が重複しています。
BTS_E_OUTPUTCONFIG_FOREIGN_PORTID | 0x1256 | チャネルが使用しているため、メッセージ ポートを削除できません。
BTS_E_OUTPUTCONFIG_FOREIGN_CHANNELID | 0x1257 | メッセージ ポートが使用しているため、チャネルを削除できません。
BTS_E_PORT_LOOPBACK_RELIABLE | 0x125F | トランスポートの種類がループバックのメッセージ ポートは、Reliable 書式を使用するエンベロープと関連付けられません。
BTS_E_ALIAS_RESERVEDWORD | 0x1262 | "Group" は、修飾子の予約語です。識別子の修飾子としては使用できません。
BTS_E_DOCUMENT_NEEDMAPREF | 0x1268 | ドキュメント仕様が異なる場合は、マップ参照を受信ドキュメントから送信ドキュメントに変換する必要があります。
BTS_E_PORT_DESTORGNOTSPECIFIED | 0x126C | このメッセージ ポートには、送信先組織の指定が必要です。
BTS_E_PORT_MISSING_PRITRANSTYPE | 0x126D | このメッセージ ポートには、プライマリ トランスポートの種類を指定してください。プライマリ トランスポートを指定しなかったり、オープンな送信先を指定したりすることはできません。
BTS_E_PORT_MISSING_PRITRANSADDRESS | 0x126E | このメッセージ ポートには、プライマリ トランスポート アドレスを指定する必要があります。
BTS_E_PORT_INVALID_SECTRANSTYPE | 0x126F | セカンダリ トランスポートの種類は、オープン、ループバック、および BizTalk オーケストレーション アクティベーションに設定できません。
BTS_E_PORT_MISSING_SECTRANSADDRESS | 0x1270 | トランスポートの種類は定義されていますが、セカンダリ トランスポートのアドレスがありません。
BTS_E_PORT_INVALID_ORG | 0x1271 | このメッセージ ポートに指定されている組織は存在しません。
BTS_E_PORT_INVALID_ALIAS | 0x1272 | このメッセージ ポートに指定されている組織の識別子は、存在しないか、この組織に属していません。
BTS_E_PORT_INVALID_APPLICATION | 0x1273 | このメッセージ ポートに指定された組織のアプリケーションは、存在しないか、この組織に属していません。
BTS_E_PORT_INVALID_ENVELOPE | 0x1274 | このメッセージ ポートに指定されたエンベロープは存在しません。
BTS_E_PORT_OPEN_DESTORG_SPECIFIED | 0x127C | オープンな送信先メッセージ ポートには、送信先組織を指定できません。
BTS_E_PORT_OPEN_DESTAPP_SPECIFIED | 0x127E | オープンな送信先メッセージ ポートには、送信先アプリケーションを指定できません。
BTS_E_PORT_OPEN_PRITRANSTYPEOPEN | 0x127F | オープンな送信先メッセージ ポートには、プライマリ トランスポートの種類をオープンな送信先と指定する必要があります。
BTS_E_PORT_OPEN_PRITRANSADDRESS | 0x1280 | オープンな送信先メッセージ ポートに対しては、プライマリ トランスポートのアドレスを指定できません。
BTS_E_PORT_OPEN_PRITRANSPARAMETER | 0x1281 | オープンな送信先メッセージ ポートに対しては、プライマリ トランスポートのパラメータを指定できません。
BTS_E_PORT_OPEN_SECTRANSTYPE | 0x1282 | オープンな送信先メッセージ ポートに対しては、セカンダリ トランスポートの種類を指定できません。
BTS_E_PORT_OPEN_SECTRANSADDRESS | 0x1283 | オープンな送信先メッセージ ポートに対しては、セカンダリ トランスポートのアドレスを指定できません。
BTS_E_PORT_OPEN_SECTRANSPARAMETER | 0x1284 | オープンな送信先メッセージ ポートに対しては、セカンダリ トランスポートのパラメータを指定できません。
BTS_E_PORT_OPEN_ENCRYPTIONTYPE | 0x1285 | オープンな送信先メッセージ ポートに対しては、暗号化の種類を指定できません。
BTS_E_PORT_OPEN_ENCRYPTIONREF | 0x1286 | オープンな送信先メッセージ ポートに対しては、暗号化参照を指定できません。
BTS_E_PORT_SIGNATTYPEANDREFERENCE | 0x1287 | 署名の種類は指定されていますが、署名参照がありません。
BTS_E_PORT_ENCRYPTIONTYPEANDREFERENCE | 0x1288 | 暗号化の種類は指定されていますが、暗号化参照がありません。
BTS_E_ALIAS_DEFAULT | 0x128A | 既定の識別子は常に 1 つ必要であり、1 つだけを指定できます。既定の識別子を省略したり、複数指定したりすることはできません。
BTS_E_ALIAS_AUTO | 0x128B | "組織" という名前と "OrganizationName" という修飾子を使用しているエイリアスは、システムが作成したエイリアスです。これらのエイリアスは削除できません。また、このエイリアスと同じ名前および識別子を持つ別のエイリアスを作成したり、このエイリアスのフィールドに変更を加えることもできません。
BTS_E_TRANSPORT_SYNTAXAPPINT | 0x128E | AppIntegration トランスポートの種類のプロパティに対してアドレス構文が正しくない、コンポーネントが登録されていない、またはコンポーネントが無効な AIC コンポーネントです。
BTS_E_TRANSPORT_SYNTAXFILE | 0x128F | File トランスポートの種類に対して、このアドレスの構文が正しくありません。
BTS_E_TRANSPORT_SYNTAXHTTP | 0x1291 | HTTP トランスポートの種類に対して、アドレスの構文が正しくありません。
BTS_E_TRANSPORT_SYNTAXHTTPS | 0x1292 | HTTPS トランスポートの種類に対して、アドレスの構文が正しくありません。
BTS_E_TRANSPORT_SYNTAXSMTP | 0x1293 | SMTP トランスポートの種類に対して、アドレスの構文が正しくありません。
BTS_E_TRANSPORT_SYNTAXNONE | 0x1294 | トランスポートの種類がなしに設定されている場合や、オープンな送信元あるいはオープンな送信先の場合は、トランスポートのアドレスおよびパラメータを指定できません。
BTS_E_TRANSPORT_LOCALHOST | 0x1295 | トランスポートのアドレスに "localhost" は含められません。コンピュータ名に置き換えてください。
BTS_E_PORTGROUP_LASTPORT | 0x1296 | 同報リストで最後に残されたメッセージ ポートは削除できません。
BTS_E_TRANSPORT_MISSING_PRISMTPPARAMETER | 0x1298 | SMTP トランスポートの種類には、プライマリ トランスポートのパラメータが必要です。
BTS_E_TRANSPORT_MISSING_SECSMTPPARAMETER | 0x1299 | SMTP トランスポートの種類には、セカンダリ トランスポートのパラメータが必要です。
BTS_E_NAMEREQ | 0x129A | Name プロパティは、1 文字以上入力してください。
BTS_E_INVALIDTIMEFORMAT | 0x129B | 時刻の書式が無効です。時刻は、時間単位の 24 時間書式 (0 時から 23 時まで) で入力してください。時間のみ入力可能で、分と秒は入力できません。
BTS_E_TIMESTAMP | 0x129C | タイムスタンプが変更されているため、このオブジェクトを保存または削除できません。
BTS_E_PORTGROUP_MISSING_PORT | 0x129D | 同報リストには、少なくとも 1 つのメッセージ ポートを設定してください。
BTS_E_ORGANIZATION_REMOVEDEFAULT | 0x129E | 既定の組織は削除できません。
BTS_E_PORT_SERVICEWINDOW_EQUAL | 0x129F | サービス時間帯の開始時刻 (FromTime) と終了時刻 (ToTime) は同じにできません。
BTS_E_ENVELOPE_REFERENCENOTALLOWED | 0x12A2 | このエンベロープ書式に対して参照プロパティを設定できません。
BTS_E_ENVELOPE_REFERRED | 0x12A3 | メッセージ ポートまたはチャネルが使用しているため、このエンベロープは削除できません。
BTS_E_TRANSPORT_LOOPBACK_SECTYPECONFLICT | 0x12A4 | プライマリ トランスポートの種類がループバックに設定されている場合は、メッセージ ポートに対してセカンダリ トランスポートの種類を指定できません。
BTS_E_TRANSPORT_LOOPBACK_SECADDRESSCONFLICT | 0x12A5 | トランスポートの種類がループバックに設定されている場合は、メッセージ ポートに対してセカンダリ トランスポートのアドレスを指定できません。
BTS_E_PORT_LOOPBACK_SERVICEWINDOW | 0x12A6 | トランスポートの種類がループバックに設定されている場合は、メッセージ ポートに対してサービス時間帯を指定できません。
BTS_E_PORT_OPEN_DESTALIAS_SPECIFIED | 0x12A7 | オープンな送信先メッセージ ポートに対しては、送信先識別子を指定できません。
BTS_E_PORT_OPEN_SERVICEWINDOW | 0x12A8 | オープンな送信先メッセージ ポートに対しては、サービス時間帯を指定できません。
BTS_E_PORT_SERVICEWINDOWTIMES | 0x12AA | サービス時間帯を使用するには、開始時刻と終了時刻の両方を設定します。または、どちらも設定しないでください。
BTS_E_TRANSPORT_LOOPBACK_PRIADDRESSCONFLICT | 0x12AC | トランスポートの種類がループバックに設定されている場合は、メッセージ ポートに対してプライマリ トランスポートのアドレスを指定できません。
BTS_E_PORT_ORGCHANGE | 0x12AD | 送信先組織の識別子は、作成後の変更ができません。
BTS_E_PORT_OPENNESSCHANGE | 0x12AE | オープンネス プロパティは、作成後には変更できません。
BTS_E_PORT_SIGNATURE_CHANNEL_CERTREF | 0x12AF | チャネルの署名証明参照が、ポートの署名の種類と一致しません。
BTS_E_PORT_SIGNATURE_CHANNEL_OPEN | 0x12B0 | 署名の種類が含まれるメッセージ ポートは、オープンな送信元チャネルに接続できません。また、既にオープンな送信元チャネルに接続しているメッセージ ポートに対して署名の種類を割り当てることもできません。
BTS_E_CHANNEL_OPEN_SRCORG | 0x12B1 | オープンな送信元チャネルに対しては、送信元組織を指定できません。
BTS_E_PORTGROUP_LOOPBACKPORT | 0x12B2 | トランスポートの種類がループバックに設定されているメッセージ ポートは、同報リストに追加できません。また、既に同報リストに含まれているメッセージ ポートのトランスポートの種類をループバックに変更することもできません。
BTS_E_CHANNEL_OPEN_SRCALIAS | 0x12B3 | オープンな送信元チャネルに対しては、送信元識別子を指定できません。
BTS_E_CHANNEL_OPEN_SRCAPP | 0x12B4 | オープンな送信元チャネルは、送信元アプリケーションを指定できません。
BTS_E_CHANNEL_PORTORPORTGROUP | 0x12B5 | チャネルには、メッセージ ポートまたは同報リストのどちらか一方のみ指定してください。
BTS_E_CHANNEL_MISSING_DOCUMENT | 0x12B6 | 1 つのチャネルには、入力ドキュメントと出力ドキュメントの両方が必要です。
BTS_E_CHANNEL_INVALIDTYPE | 0x12B7 | チャネルをオープンな送信先または XLANG スケジュール (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) に設定することはできません。
BTS_E_CHANNEL_MISSING_OUTDOCREFERENCE | 0x12B8 | チャネルの受信ドキュメント定義に仕様への参照がある場合は、送信ドキュメント定義にも仕様への参照が必要です。
BTS_E_CHANNEL_TRACKFIELDSCANTBESET | 0x12B9 | チャネルの受信ドキュメント定義に仕様への参照がない場合は、追跡項目を設定できません。
BTS_E_CHANNEL_EXPRESSIONCANTBESET | 0x12BA | チャネルの受信ドキュメント定義に仕様への参照がない場合は、チャネル フィルタ式を設定できません。
BTS_E_CHANNEL_MAPREFCANTBESET | 0x12BB | チャネルの受信ドキュメント定義に仕様への参照がない場合は、マップへの参照を設定できません。
BTS_E_CHANNEL_NOTSAME_INPDOC_OUTDOC | 0x12BC | チャネルの受信ドキュメント定義に仕様への参照がない場合は、送信ドキュメントのハンドルを受信ドキュメントのハンドルと同じにする必要があります。
BTS_E_CHANNEL_OPEN_RECEIPTCONFLICT | 0x12BD | オープンな送信元から設定されたチャネル、および XLANG スケジュール (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) から設定されたチャネルは、受信確認チャネルになれません。
BTS_E_CHANNEL_RECEIPT_RECEIPTTIMEOUT | 0x12BE | 受信確認チャネルには "受信確認を要求する" プロパティを設定できません。
BTS_E_CHANNEL_RECEIPT_CANTSETRECEIPTCHANNEL | 0x12BF | 識別子は受信確認チャネルに設定できません。
BTS_E_CHANNEL_RECEIPT_CONFLICT | 0x12C0 | 受信確認チャネルでは、元のチャネルの送信元仕様を送信先仕様として使用し、元のチャネルの送信先仕様を送信元仕様として使用する必要があります。
BTS_E_CHANNEL_SRCORGDEFAULT | 0x12C1 | チャネルが XLANG スケジュール (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) から設定されている場合、送信元組織は既定の組織にする必要があります。
BTS_E_CHANNEL_PORT_BOTHOPEN | 0x12C2 | チャネルとメッセージ ポートをオープンに設定できません。
BTS_E_CHANNEL_RECEIPT_INVALID | 0x12C3 | "受信確認チャネルとして使用する" プロパティおよび "受信確認を要求する" プロパティは、オープンな送信元チャネルに対しては設定できません。これらのプロパティは、メッセージ ポートがオープンな送信先または XLANG スケジュール (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) である場合、あるいはメッセージ ポートのトランスポートの種類がループバックに設定されている場合も設定できません。
BTS_E_CHANNEL_RECEIPTMATCHNOTFOUND | 0x12C4 | このチャネルに対応する受信確認チャネルが検出できませんでした。
BTS_E_CHANNEL_RECEIPT_OPENPORT | 0x12C5 | 受信確認チャネルが接続できるのは、オープンでないメッセージ ポートだけです。
BTS_E_CHANNEL_RECEIPT_LOOPBACKPORT | 0x12C6 | 受信確認チャネルは、トランスポートの種類がループバックに設定されているメッセージ ポートには接続できません。また、既に受信確認チャネルに接続されているメッセージ ポートのトランスポートの種類を、ループバックに変更することもできません。
BTS_E_CHANNEL_CANNOTUPDATE | 0x12C8 | チャネルの作成後は、次のプロパティを変更できません : 送信元組織、オープンネス指定、メッセージ ポート、同報リスト、および受信確認チャネル指定。
BTS_E_PORT_INVALIDOPENNESS | 0x12C9 | メッセージ ポートをオープンな送信元に設定したり、XLANG スケジュール (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) から設定することはできません。
BTS_E_CHANNEL_CONTROLNUMBER_ ENVELOPEFORMATMISMATCH | 0x12CA | メッセージ ポートのエンベロープ書式が X12 または EDIFACT の場合は、チャネルの制御番号の値を設定する必要があります。
BTS_E_PORT_ENVELOPE_SERIALIZERCLSID | 0x12CB | メッセージ ポートのエンベロープ書式を "Custom" に設定している場合は、シリアライザ コンポーネントのクラス ID (CLSID) を指定してください。
BTS_E_CHANNEL_AIC_TRANSPORTCLSID | 0x12CD | チャネルに関連付けられたトランスポートの種類がアプリケーション統合コンポーネントである場合は、プライマリ トランスポートのクラス ID (CLSID) を指定する必要があります。
BTS_E_CHANNEL_RECEIPT_PORTGROUP | 0x12CE | チャネルが同報リストに接続されている場合は、受信確認チャネルを指定できません。
BTS_E_COMPONENTREQUIRES2AGGREGATEFTM | 0x12CF | BizTalk オブジェクト モデルを有効なオブジェクトにするには、カスタム コンポーネントに空きスレッド マーシャラを集積してください。
BTS_E_CERTREFNOTFOUND | 0x12D1 | MY ストアまたは BIZTALK ストア内に証明書参照が見つかりません。または有効な証明書参照ではありません。
BTS_E_NODOC | 0x12D2 | ドキュメント定義はデータベースから削除されました。このオブジェクトを参照するドキュメントがキューに存在する可能性がある場合は、このオブジェクトを削除しないでください。
BTS_E_NOENV | 0x12D3 | エンベロープはデータベースから削除されました。このオブジェクトを参照するドキュメントがキューに存在する可能性がある場合は、このオブジェクトを削除しないでください。
BTS_E_NOCHANNEL | 0x12D4 | チャネルはデータベースから削除されました。オブジェクトを参照するドキュメントがキューに存在する可能性がある場合は、オブジェクトを削除しないでください。
BTS_E_INVALIDREFERENCE | 0x12D5 | WebDAV リポジトリの参照に有効な HTTP アドレスが含まれていません。または、参照に "localhost" というテキストが含まれています。有効な HTTP アドレスを指定するか、"localhost" というテキストを実際のコンピュータ名に置き換えてください。
BTS_E_CANNOTCONTAINSUBOBJECTS | 0x12D6 | プロパティ セットおよび区切り記号のオブジェクトには、下位オブジェクトを入れることはできません。
BTS_E_INVALIDTRACKFIELDS | 0x12D7 | 追跡項目ディクショナリの "x_custom_search" フィールドはシンプル リストにする必要があります。
BTS_E_CHANNEL_INVALID_ORG | 0x12D8 | このチャネルで指定した組織は存在しません。
BTS_E_CHANNEL_INVALID_ALIAS | 0x12D9 | このチャネルで指定した組織の識別子は存在しないか、または組織に属していません。
BTS_E_CHANNEL_INVALID_APPLICATION | 0x12DA | このチャネルで指定した組織のアプリケーションは存在しないか、または組織に属していません。
BTS_E_CHANNEL_INVALID_INPDOCID | 0x12DB | このチャネルで指定した入力ドキュメントは存在しません。
BTS_E_CHANNEL_INVALID_OUTDOCID | 0x12DC | このチャネルで指定した出力ドキュメントは存在しません。
BTS_E_CHANNEL_INVALID_PORTGROUP | 0x12DD | このチャネルで指定した同報リストは存在しません。
BTS_E_OBJECT_NOT_XMLSERILIZABLE | 0x12DE | 与えられたディクショナリまたは simplelist オブジェクトには、IPersistXML メソッドを実装する必要があります。
BTS_E_CHANNEL_INVALID_PORT | 0x12E0 | このチャネルで参照されているメッセージ ポートのうち、存在しないか、このチャネルと関連付けられていないものが 1 つ以上あります。
BTS_E_CHANNEL_RECEIPT_VERSIGN_DECRYPT | 0x12E1 | 受信確認チャネルでは、署名の確認または暗号の解読のプロパティを設定できません。
BTS_E_INVALID_REQUEST_CHANNEL | 0x12E2 | 同報リストに接続されているチャネルは、要求チャネルとしては使用できません。
BTS_E_DESTINATION_NOT_FOUND | 0x12E3 | 送信先の URL が指定されておらず、メッセージ ポートがオープンな送信先になっています。送信先の URL、またはメッセージ ポートの送信先を指定してください。
BTS_E_DESTINATION_CONFLICT | 0x12E4 | 送信先の URL とメッセージ ポートの送信先を両方とも指定することはできません。いずれか一方のみ指定してください。
BTS_E_ASYNC_TRANSPORT | 0x12E5 | 要求チャネルのトランスポートの種類が無効です。要求チャネルのトランスポートの種類として有効なのは、HTTP、HTTPS、およびアプリケーション統合コンポーネントのみです。
BTS_E_INVALID_RESPONSE_CHANNEL | 0x12E6 | 応答チャネルを接続できるのは、トランスポートの種類を "ループバック" に設定したメッセージ ポートに限られます。
BTS_E_INVALID_VERSION | 0x12E7 | データベースのバージョンは、インストール済みのサーバーのバージョンと互換性がありません。セットアップをもう一度実行してください。
BTS_E_INVALID_SCHEMA | 0x12E8 | ドキュメント仕様またはエンベロープ仕様が無効です。BizTalk エディタで仕様を開き、[ツール] メニューの [仕様の検証] をクリックしてください。警告された問題をすべて解決し、仕様を有効なものにしてください。
BTS_E_CHANNEL_RECEIPTCHANNEL_PORTGROUP | 0x12E9 | 受信確認チャネルを同報リストに接続することはできません。
BTS_E_TRANSPORT_ORCHESTRATION_OPENNESS | 0x12EA | BizTalk オーケストレーション アクティベーション トランスポート タイプを使用するメッセージ ポートの場合は、オープンネス型プロパティを [XLANG スケジュール] (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) に設定する必要があります。
BTS_E_TRANSPORT_ORCHESTRATION_ ADDRESSPARAMETER | 0x12EB | BizTalk オーケストレーション アクティベーション トランスポート タイプを使用するメッセージ ポートの場合は、プライマリ アドレスとパラメータの両方を指定する必要があります。
BTS_E_ORCHESTRATION_INVALIDORG | 0x12EC | BizTalk オーケストレーション アクティベーション トランスポート タイプを使用するメッセージ ポートの場合は、既定の組織を送信先組織として設定する必要があります。
BTS_E_INVALID_FILTEREXPRESSION | 0x12ED | チャネル フィルタ式が有効ではありません。ノード パスの式が有効なものであることを確認してください。
BTS_E_MULTIPLEDOCDEFSFORPROPSET | 0x12EE | 指定したプロパティ セットに複数のドキュメント定義が見つかりました。指定したプロパティ セットで使用できるドキュメント定義は 1 つだけです。
BTS_E_INVALID_PROPSET | 0x12EF | PropertySet に文字列以外の要素値を含めることはできません。
BTS_E_DBSCHEMA_MISMATCH | 0x1300 | 既存のデータベース スキーマは、この製品の現在のバージョンとは互換性がありません。既存のデータベースを削除してください。
BTS_E_UNEXPECTED_INSTALL | 0x1301 | 既存のデータベース スキーマは、インストールする現在のバージョンより新しいものです。セットアップは変更内容をロールバックします。
CIS_E_DOCSCHEMA_ATTRIB_MISSING | 0x1400 | 属性 "%3" が要素 "%4" にありません。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_ATTRIB_VALUE | 0x1401 | 属性 "%3" の値 "%4" は有効ではありません。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_EMPTY_ELEMENT | 0x1402 | 要素 "%3" を空にできません。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_CHILD_ELEMENT | 0x1403 | 要素 "%3" を要素 "%4" の子にはできません。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_MULTIPLE_INFO | 0x1404 | 各要素の宣言には、1 つのレコード説明または 1 つのフィールドの説明だけ指定できます。どちらか 1 つを削除してください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_FIELD_DECL | 0x1405 | ルート ノードにフィールドを含むことはできません。ドキュメントのルート ノードにはレコードを含める必要があります。ドキュメントのルート ノードがレコードとして宣言されていることを確認してください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_LEN_DECL | 0x1406 | 最小値が最大値を超えないようにしてください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_POSLEN_DECL | 0x1407 | 開始位置が終了位置を超えないようにしてください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_NO_INFO_YET | 0x1408 | フィールドの説明またはレコードの説明は、ほかの要素を参照する前に指定してください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_SCHEMATYPE_XML | 0x1409 | この書式では、非 XML ドキュメントのみ指定できます。Schema_type 属性の値は "xml" です。選択した仕様が、非 XML 仕様であることを確認してください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_NO_INFO | 0x140A | 要素 "%3" にレコード情報またはフィールド情報が見つかりませんでした。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_ATTRIB | 0x140B | 属性 "%3" は要素 "%4" に指定できません。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_MISSING_ELEM_DECL | 0x140C | ドキュメント仕様に "%1" という要素名はありません。
CIS_E_DOCSCHEMA_MISSING_ATTR_DECL | 0x140D | ドキュメント仕様に "%1" という属性名はありません。
CIS_E_DOCSCHEMA_INVALID_POSITIONAL_DECL | 0x140E | レコード "%1" は位置レコード "%2" の子になれません。フィールドのみ位置レコードの子になれます。
CIS_E_DOCSCHEMA_INVALID_RECORD_CHILDREN | 0x140F | 区切られたレコード "%1" の子は、すべてレコードであるか、またはすべてフィールドである必要があります。タグ ID のないレコードは、混在したレコードとフィールドを持てません。
CIS_E_DOCSCHEMA_NO_RECORD_CHILDREN | 0x1410 | 区切られたレコード "%1" には、少なくとも 1 つの子が必要です。タグ ID のないレコードには、少なくとも 1 つの子が必要ですが、そのレコードが非 XML 形式にない可能性があります。レコードに子を追加するか、レコードにタグ ID を付けるか、または仕様からレコードを削除します。
CIS_E_DOCSCHEMA_MISSING_RECORD_TAG | 0x1411 | 区切られたレコード "%1" が繰り返すように指示されていますが、タグ ID がありません。このプロパティを持てるのは、ドキュメント仕様内の最後のレコードだけです。このレコードがドキュメントに 1 回だけ現れる場合は、そのレコードを 1 回と指定します。そうでなければ、レコードにタグ ID を付け、仕様内の次のレコードの検索位置をサーバーに通知します。
CIS_E_DOCSCHEMA_NO_ROOT_ELEMENT | 0x1412 | ルート ノード名 "%3" が仕様内で検出されませんでした。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_ROOT_ELEMENT | 0x1413 | 要素 "%3" をこのドキュメントのルート ノードにできません。<スキーマ> のみ指定できます。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_EMPTY_ATTRIBUTE | 0x1414 | 要素 "%4" の属性 "%3" を空にできません。値を指定するか、属性を削除してください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_INVALID_REFERENCE | 0x1415 | "%1" レコードには、"%2" レコードによる無効な循環パスがあります。システムによる検索の終了を可能にするタグ ID がレコードにある場合に、循環参照だけがレコードに指定できます。循環参照を削除するか、適切なタグ ID をドキュメント仕様に追加してください
CIS_E_DOCSCHEMA_LOADFAILED | 0x1416 | 仕様の読み込みに失敗しました。詳細については、次のメッセージを参照してください。
CIS_E_DOCSCHEMA_MISSING_NS | 0x1417 | 非 XML ドキュメントに対する有効な BizTalk Server 仕様は、そのルート ノードに "urn:schemas-microsoft-com:BizTalkServer"、"urn:schemas-microsoft-com:datatypes"、および "urn:schemas-microsoft-com:xml-data" の名前空間宣言が必要です。
CIS_E_DOCSCHEMA_INVALID_SCHEMA_USAGE | 0x1418 | ドキュメント "%1" で参照された仕様は、形式 "%2" と互換性がありません。この形式と互換性のある仕様を選択してください。また、仕様が定義済みの形式に対して有効な場合は、"%2" を "標準" のプロパティとして割り当ててください。
CIS_E_DOCSCHEMA_MISSING_POSLEN_DECL | 0x1419 | フィールド "%3" の開始位置と終了位置が見つかりません。このフィールドは、位置レコード "%4" に参照されています。このフィールドの有効な開始位置と終了位置を指定してください。行 : %1、位置 : %2。
CIS_E_DOCSCHEMA_DUPLICATE_NAMESPACE | 0x141A | 重複した名前空間宣言 "%3" が検出されました。同じ名前空間に対する重複した参照を削除してください。行 : %1、位置 : %2。
CIS_E_PARSER_EOF | 0x1430 | ファイルの最後に到達するのが早すぎます。
CIS_E_PARSER_MISSING_TAG | 0x1431 | 必要なレコード "%1" が受信ドキュメント内で見つかりませんでした。
CIS_E_PARSER_MISSING_FIELD | 0x1432 | レコード "%2" に必要なフィールド "%1" が、受信ドキュメント内に見つかりませんでした。
CIS_E_PARSER_FAILURE | 0x1433 | 処理エラーのため、パーサーがドキュメントの変換に失敗しました。詳細については、次のメッセージを参照してください。
CIS_E_PARSER_INVALIDDATA | 0x1434 | パーサーがデータの現在位置を仕様と適合できません。仕様のバージョンがデータのバージョンと同じで、ルート解析タグが一致しているか確認してください。
CIS_E_PARSER_NO_DATA | 0x1435 | ディクショナリで解析できるデータがありません。"working_data" フィールドまたは "file_path" フィールドに空でないデータが含まれているか確認してください。
CIS_E_PARSER_INVALID_ENVNAME | 0x1436 | エンベロープ名 "%1" は BizTalk Server のパーサーで有効とされるエンベロープを参照していません。エンベロープ名が存在しないか、無効なエンベロープ仕様が添付されています。
CIS_E_PARSER_NO_COMPONENTS_FOUND | 0x1439 | パーサー コンポーネントがデータを認識しません。原因としては、インターチェンジ仕様が存在しないか有効でないこと、またはデータが有効でないことが考えられます。インターチェンジ仕様 (指定している場合) とデータの両方が、他方にとって適切なものであることを確認してください。
CIS_E_PARSER_COMPONENT_FAILED | 0x1440 | "%1" の送信中にドキュメント #%4 を処理しようとしたとき、パーサー コンポーネント "%2" がメソッド "%3" で失敗しました。エラー コードは "%5" です。原因としては、コンポーネントが受信ストリームで予期しないデータを検出したこと、ドキュメント仕様で所定のデータが見つからなかったこと、またはコンポーネント内部でエラーが発生したことが考えられます。この問題が繰り返し発生する場合は、有効なパーサー コンポーネントの一覧からこのコンポーネントを削除するか、システム管理者に問い合わせてください。
CIS_E_PARSER_DOCUMENT_FAILED | 0x1441 | "%1" の送信に含まれているドキュメント #%4 は、パーサー コンポーネント "%2" から無効なドキュメントとして返されました。ほとんどの場合、原因はドキュメント仕様が有効でないこと、または必要なルーティング フィールドをコンポーネントが特定できなかったことです。このデータに対して適切な仕様が定義されていることを確認してください。
CIS_E_PARSER_INVALID_DATETIME | 0x1442 | "%1" の日付または時刻の書式は、受信データから抽出されたデータ "%2" と互換性がありません。
CIS_E_PARSER_INVALID_COMPONENT | 0x1443 | "%1" の送信中に、パーサー コンポーネント "%2" を読み込めませんでした。このコンポーネントが、スタンドアロンの実行可能プログラムで実行できるか、サーバーにそのプログラムを起動する十分なアクセス許可があるか確認してください。
CIS_W_PARSER_SKIPPED_COMPONENT | 0x1444 | パーサーが指定のコンポーネントを検査できませんでした。このコンポーネントは無視されます。
CIS_E_PARSER_UNUSEABLE_DOCNAME | 0x1445 | ドキュメント "%1" に仕様がないため、パーサーがそのドキュメントを使用できません。このドキュメントに仕様を設定するか、別のドキュメントを指定してください。
CIS_E_PARSER_CONTROL_NUMBER_MISMATCH | 0x1446 | セグメント "%1" (%2) の制御番号がセグメント "%3" (%4) の制御番号と一致しません。
CIS_E_PARSER_DOCCOUNT_INCORRECT | 0x1447 | タグ "%1" (%2) のドキュメント数またはセグメント数が、処理済みのドキュメント数またはセグメント数 (%3) と一致しません。
CIS_E_PARSER_X12_ISA_PARSE_FAILED | 0x1448 | パーサーは X12 ドキュメントの ISA セクションを解析できません。このセグメントは固定長です。このセグメントのフィールドの長さが正しくない場合は、区切り記号が正しくないオフセットから選択されるため解析に失敗します。
CIS_E_PARSER_MIN_LENGTH | 0x1449 | データに含まれるフィールドの値 ("%1") が、タグ "%2" の最小値の要件を満たしません (最小値は %3 です)。
CIS_E_PARSER_MAX_LENGTH | 0x144A | データに含まれるフィールドの値 ("%1") が、タグ "%2"の最大値の要件を満たしません (最大値は %3 です)。
CIS_E_PARSER_NO_DATA_CONSUMED | 0x144B | パーサーはデータを読み取りませんでした。データに対するコード ページが正しく設定されていることを確認してください。データが UNICODE の場合は、そのファイルの先頭にバイト順序記号 (0xFFFE または 0xFEFF) がないことを確認してください。
CIS_E_PARSER_UNSUPPORTED_EDIFACT_SYNTAX | 0x144C | 構文識別子が UNOX または UNOY である EDIFACT ドキュメントは、サポートされていません。
CIS_E_PARSER_DATA_REMAINING | 0x144D | ドキュメント インスタンス内の追加データは解析されませんでした。検証するドキュメント インスタンスに含めるドキュメントは 1 つだけにしてください。
CIS_E_PARSER_MISSING_DELIMITER | 0x144E | レコード "%1" の解析中、パーサーが必要な区切り記号 ("%2") を見つけられません (%3)。
CIS_E_PARSER_MISSING_LEADING_DELIMITER | 0x144F | レコード "%1" の解析中、パーサーが先頭に必要な区切り記号 ("%2") を見つけられません (%3)。
CIS_E_PARSER_MISSING_TRAILING_DELIMITER | 0x1450 | レコード "%1" の解析中、パーサーが末尾に必要な区切り記号 ("%2") を見つけられません (%3)。
CIS_E_VALIDATE_GROUP_RULE | 0x1451 | レコード "%1" に次のフィールドが 1 つでも存在する場合は、すべてのフィールドが存在する必要があります。 %2
CIS_E_VALIDATE_GROUP_ALL | 0x1452 | レコード "%1" には、次のフィールドがすべて存在していなくてはなりません。 %2
CIS_E_VALIDATE_GROUP_ONE | 0x1453 | レコード "%1" には、次のフィールドのうちいずれか 1 つのみ存在できます。 %2
CIS_E_PARSER_INVALID_WRAP_CHAR_FOUND | 0x1454 | レコード "%1" の解析中に囲み文字 "%2" が見つかりましたが、有効な囲み文字ではありません。
CIS_E_VALIDATE_GROUP_ANY | 0x1455 | レコード "%1" には、次のフィールドが 1 つ以上存在していなければなりません : %2
CIS_E_PARSER_EXTRA_DELIMITER | 0x1456 | レコード "%1" の解析中、パーサーが次の不要な区切り記号を見つけました : "%2"。
BTS_E_DOCUMENT_HAS_INVALID_MANIFEST | 0x1457 | 目録の解析でエラーが発生しました。
CIS_E_ADMIN_CACHE_PARSERS | 0x1504 | 管理パーサー テーブルから最終修正日時を読み込めませんでした。
CIS_E_ADMIN_INIT_CACHE | 0x1505 | グローバル キャッシュの構成データを初期化できませんでした。
CIS_E_ADMIN_RELOAD_CACHE | 0x1506 | データベースの構成データを再度読み込めませんでした。
CIS_E_ADMIN_PARSER_GETCLSID | 0x1507 | パーサー レコードのクラス ID (CLSID) を読み込めませんでした。
CIS_E_ADMIN_CACHE_OBJECTNOTCREATED | 0x1509 | 管理キャッシュが作成できませんでした。
CIS_E_ADMIN_CACHE_INITIALLOAD | 0x150A | データベースの構成キャッシュ データの初期読み込みに失敗しました。
CIS_E_ADMIN_ADD_SERVER_ACCESS_DENIED | 0x150B | "%2" へのアクセスを拒否されているため、サーバー "%1" を追加できません。
CIS_E_ADMIN_ADD_SERVER_NO_SERVICE | 0x150C | BizTalk Server がこのコンピュータにインストールされていないため、サーバー "%1" を追加できません。
CIS_E_ADMIN_DELETE_SERVER_NO_ACCESS | 0x150D | サービス "%2" へのアクセスが拒否されてサービスを停止できないため、サーバー "%1" を削除できません。
CIS_E_ADMIN_DELETE_GROUP_SERVER_RUNNING | 0x150E | サーバー "%1" はまだ実行されているため、サーバー グループを削除できません。
CIS_E_ADMIN_DELETE_GROUP_SERVER_ACCESS_DENIED | 0x150F | サーバー "%2" のサービス "%1" へのアクセスが拒否されているため、サーバー グループを削除できません。
CIS_E_ADMIN_NOGROUP | 0x1512 | 指定した管理グループが存在しません。
CIS_E_ADMIN_NOSERVER | 0x1513 | 指定した管理サーバーが存在しません。
CIS_E_ADMIN_NORECEIVESERVICE | 0x1514 | 指定した管理受信機能がデータベースに存在しません。
CIS_E_ADMIN_UNEXPECTED_REMOVE_RECEIVESERVICE | 0x1515 | データベースから受信機能 "%1" を削除しようとして、予期しないエラーが発生しました。
CIS_E_ADMIN_UNEXPECTED_REMOVE_GROUP | 0x1516 | データベースからグループ "%1" を削除しようとして、予期しないエラーが発生しました。
CIS_E_ADMIN_UNEXPECTED_REMOVE_SERVER | 0x1517 | データベースからサーバー "%1" を削除しようとして、予期しないエラーが発生しました。
CIS_E_ADMIN_NOTIMESTAMPS | 0x151A | 指定した管理タイムスタンプ オブジェクトがデータベースに存在しません。
CIS_E_ADMIN_REFRESH_THREAD_ERROR | 0x151B | 構成データの読み込み中に、構成更新スレッドでエラーが発生しました。
CIS_E_ADMIN_REFRESH_THREAD_EXIT | 0x151C | 前回のエラーが原因で、構成更新スレッドで構成データを読み込めません。
CIS_E_ADMIN_RECSVC_GENERAL | 0x151D | 構成更新スレッドで受信機能を設定できません。原因としては、SQL Server が起動していないことが考えられます。
CIS_E_ADMIN_CREATE_GROUP | 0x1529 | "%1" により、サーバー グループを作成できません。
CIS_E_ADMIN_LOAD_GROUP_PROPS | 0x152A | "%1" により、グループのプロパティを読み込めません。
CIS_E_ADMIN_SAVE_GROUP_PROPS | 0x152B | "%1" により、グループのプロパティを保存できません。
CIS_E_ADMIN_REMOVE_GROUP | 0x152C | "%1" により、データベースからサーバー グループを削除できません。
CIS_E_ADMIN_GETALLADMINGROUPS | 0x152D | データベースからすべてのサーバー グループを取得できません。
CIS_E_ADMIN_GETSERVERS | 0x152E | "%2" により、データベースからサーバー グループ "%1" のすべてのサーバーを取得できません。
CIS_E_ADMIN_GETRECEIVESERVICES | 0x152F | "%2" により、データベースからグループ "%1" のすべての受信機能を取得できません。
CIS_E_ADMIN_GETPARSERS_IN_GROUP | 0x1531 | "%2" により、データベースからサーバー グループ "%1" のすべてのパーサーを取得できません。
CIS_E_ADMIN_GETLOCALSMTPHOST | 0x1538 | "%1" により、ローカル SMTP ホストを取得できません。
CIS_E_ADMIN_CREATE_SERVER | 0x1539 | "%1" により、サーバーを作成できません。
CIS_E_ADMIN_LOAD_SERVER_PROPS | 0x153A | "%1" により、サーバーのプロパティを読み込めません。
CIS_E_ADMIN_SAVE_SERVER_PROPS | 0x153B | "%1" により、サーバーのプロパティを保存できません。
CIS_E_ADMIN_REMOVE_SERVER | 0x153C | "%1" により、データベースからサーバーを削除できません。
CIS_E_ADMIN_GETALLADMINSERVRES | 0x153D | データベースからすべてのサーバーを取得することができません。
CIS_E_ADMIN_GETSERVERBYNAME | 0x153E | "%2" により、"%1" のサーバーのプロパティを取得できません。
CIS_E_ADMIN_DECRYPT_PASSWORD | 0x1540 | "%1" のプロパティを取得できません。
CIS_E_ADMIN_EXEC_COMMMAND_ON_PARSER | 0x154F | "%2" により、パーサー データベース テーブルの SQL コマンド "%1" を実行できません。
CIS_E_ADMIN_CREATE_RECEIVESERVICE | 0x155D | "%1" により、受信機能を作成できません。
CIS_E_ADMIN_LOAD_RECEIVESERVICE_PROPS | 0x155E | "%1" により、受信機能のプロパティを読み込めません。
CIS_E_ADMIN_SAVE_RECEIVESERVICE_PROPS | 0x155F | "%1" により、受信機能のプロパティを保存できません。
CIS_E_ADMIN_REMOVE_RECEIVESERVICE | 0x1560 | "%1" により、データベースから受信機能を削除できません。
CIS_E_ADMIN_GETALLRECEIVESERVICES | 0x1561 | "%1" により、データベースからすべての受信機能を取得することができません。
CIS_E_ADMIN_GETALLRECEIVESERVICESINSERVER | 0x1562 | "%2" により、"%1" サーバーのすべての受信機能を取得することができません。
CIS_E_ADMIN_LOAD_TIMESTAMPS | 0x1563 | "%1" により、データベースからすべてのタイムスタンプを取得することができません。
CIS_E_ADMIN_GETSQCONNECT | 0x1570 | 共有キュー データベースの接続文字列をデータベースから取得できません。
CIS_E_ADMIN_GETCOMPUTERNAME | 0x1571 | ローカル コンピュータの名前を取得できません。BizTalk Server は、コンピュータ名として内部的に "localhost" を使用しています。
CIS_E_ADMIN_MIN_CONSTRAINT | 0x1573 | "%1" のプロパティのサイズが "%2" に必要な最小の長さ未満です。
CIS_E_ADMIN_MAX_CONSTRAINT | 0x1574 | "%1" のプロパティのサイズが "%2" で許されている最大の長さを超えています。
CIS_E_ADMIN_GET_MGMTDB_CONNECT_PROPS | 0x1575 | BizTalk メッセージ管理データベースのプロパティを取得できません。
CIS_E_ADMIN_KEY_EMPTY | 0x1576 | データベース テーブルへのキーであるプロパティ "%1" が空です。
CIS_E_ADMIN_COCREATE_IN_CREATE | 0x1577 | 新しいオブジェクト "%2" の作成中に、オブジェクト "%1" のインスタンスを作成できませんでした。
CIS_E_ADMIN_ADO_OPEN_CONNECTSTRING | 0x1578 | BizTalk メッセージ管理データベースに接続できませんでした。
CIS_E_ADMIN_COCREATE_IN_LOAD | 0x1579 | "%2" のプロパティの読み込み中に、オブジェクト "%1" のインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_SAVE | 0x1580 | "%2" のプロパティの保存中に、オブジェクト "%1" のインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_REMOVE | 0x1581 | "%2" オブジェクトの削除中に、オブジェクト "%1" のインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_GETALL | 0x1582 | "%2" のすべてのインスタンスを取得中に、オブジェクト "%1" のインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_GETALL_INSERVER | 0x1583 | "%3" サーバーのオブジェクト "%2" のすべてのインスタンスを取得中に、オブジェクト "%1" のインスタンスを作成できませんでした。
CIS_E_ADMIN_GET_PROP | 0x1584 | "%1" のプロパティを取得できません。
CIS_E_ADMIN_CLOSE_ADO_CONNECTION | 0x1585 | ADO 接続を閉じられません。
CIS_E_ADMIN_CLOSE_ADO_RECORDSET | 0x1586 | ADO レコード セットを取得できません。
CIS_E_ADMIN_ENCRYPT_PASSWORD | 0x1587 | "%1" のプロパティを処理できません。
CIS_E_ADMIN_COCREATE_IN_GETALLNAMES | 0x1588 | すべての "%2" オブジェクトのインスタンス名を取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_GETOTHERS_OF_GROUP | 0x1589 | グループ "%3" にあるオブジェクト "%2" のすべてのインスタンスを取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_GET_SMTPHOST | 0x158A | ローカル サーバーの "%2" を取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_GET_SQ_CONNECTSTRING | 0x158B | データベース接続するための "%2" の共有キューのパラメータを取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_SERVER_BYNAME | 0x158C | クラス "%3" のサーバーのインスタンス "%2" のプロパティを取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_GETSQCONNECT_IN_OPEN | 0x158D | "%1" の理由により、共有キュー データベースの接続文字列をデータベースから取得できませんでした。
CIS_E_ADMIN_COCREATE_EXEC_SQL_COMMAND_ ON_PARSER | 0x158E | データベース テーブル "%2" の SQL コマンドを実行中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_PARSER_CLSIDS_IN_GROUP | 0x158F | グループ "%2" に属しているパーサーのクラス ID (CLSID) を取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_INVALID_ARGUMENT | 0x1590 | 予期しない内部エラーが発生しました。メソッド "%2" を呼び出すときに無効な引数 "%1" が使用されました。
CIS_E_ADMIN_MAX_ENUM_CONSTRAINT | 0x1591 | "%1" のプロパティ値が、"%2" で許容される最大値を超えています。
CIS_E_ADMIN_MIN_ENUM_CONSTRAINT | 0x1592 | "%1" のプロパティの値が、"%2" で許容される最小値未満です。
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BSTR | 0x1593 | "%1" のプロパティの種類を文字列に変更できませんでした。
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BOOL | 0x1594 | "%1" のプロパティの種類をブール値に変更できませんでした。
CIS_E_ADMIN_COCREATE_IN_ENUMINSTANCES | 0x1595 | "%2" オブジェクトのインスタンスの列挙中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_PUTINSTANCE | 0x1596 | "%2" オブジェクトのインスタンスの設定中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_GETOBJECT | 0x1597 | "%2" オブジェクトのインスタンスを取得中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_DELETEINSTANCE | 0x1598 | "%2" オブジェクトのインスタンスの削除中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_LOADPROPS | 0x1599 | "%2" オブジェクトのインスタンスのプロパティを読み込み中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_LOADPARSERS | 0x159B | データベースから "%2" オブジェクトのインスタンス用のパーサーを読み込み中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_ REGISTRY | 0x159C | レジストリから "%2" オブジェクトのインスタンス用のパーサーを設定中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_CLIENT | 0x159D | クライアントから "%2" オブジェクトのインスタンス用のパーサーを設定中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_REFRESHPARSERLIST | 0x159E | "%2" オブジェクトのインスタンス用のパーサーの一覧を更新中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_MOVETOSUSPENDED_Q | 0x159F | "%2" のインスタンスを保留キューに移動中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_RESUBMIT | 0x15A0 | "%2" のインスタンスを再送信中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_VIEWDOC | 0x15A2 | "%2" のドキュメント インスタンスを表示中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_VIEWERRORDESC | 0x15A3 | "%2" のインスタンスのエラーの説明を表示中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_VIEWINTERCHANGE | 0x15A4 | "%2" のインスタンスのインターチェンジを表示中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_FREEINTERCHANGES | 0x15A5 | "%2" のインスタンスのインターチェンジを解放中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_STARTSERVER | 0x15A6 | "%2" のインスタンスのサーバーを起動中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_COCREATE_IN_STOPSERVER | 0x15A7 | "%2" のインスタンスのサーバーを停止中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_NO_DELETE_SERVER_IN_RECVSERVICE | 0x15A8 | 少なくとも 1 つの受信機能を処理するサーバーであるため、サーバー "%1" を削除できません。
CIS_E_ADMIN_UPDATE_GROUP_SERVER_RUNNING | 0x15A9 | サーバー "%1" はまだ実行されているため、サーバー グループのプロパティを変更できません。
CIS_E_ADMIN_UPDATE_GROUP_SERVER_ACCESS_DENIED | 0x15AA | サーバー "%2" のサービス "%1" へのアクセスが拒否されているため、サーバー グループのプロパティを変更できません。
CIS_E_ADMIN_UPDATE_SERVER_SERVER_RUNNING | 0x15AC | サーバー "%1" はまだ実行されているため、サーバーのプロパティを変更できません。
CIS_E_ADMIN_UPDATE_SERVER_SERVER_ACCESS_DENIED | 0x15AD | サーバー "%2" のサービス "%1" へのアクセスが拒否されているため、サーバーのプロパティを変更できません。
CIS_E_ADMIN_UPDATE_READ_ONLY_PROP | 0x15AE | "%1" のプロパティを変更できません。これは読み取り専用のプロパティです。
CIS_E_ADMIN_DIFFERENT_ROOT | 0x15AF | サーバー "%1" が別の BizTalk Server インストールに属している可能性があります。
CIS_E_ADMIN_NOT_RESUBMITABLE | 0x15B0 | 保留キュー項目を再送信できません。
CIS_E_ADMIN_DBCONNECT | 0x15B1 | BizTalk Server は、このデータベース接続情報では "%2" サーバーの "%1" データベースにアクセスできませんでした。
CIS_E_ADMIN_PURGE_SUSPENDEDQ | 0x15B2 | "%2" からドキュメントを削除中に、"%1" オブジェクトのインスタンスを作成できませんでした。
CIS_E_ADMIN_REQ_PROP_MISSING | 0x15B3 | "%1" は NULL にできません。
CIS_E_ADMIN_WMI_ERROR_HANDLING | 0x15B4 | BizTalk Server WMI プロバイダのエラー処理メソッドが失敗しました。エラー処理メソッドを呼び出したエラーに対する元のエラーの説明は、"%1" です。
CIS_W_ADMIN_QUERY_FAILED | 0x15B5 | WMI クエリの WHERE 句の値を取得できませんでした。
CIS_E_ADMIN_INVALID_ENUM_CONSTRAINT | 0x15B6 | "%1" プロパティの値 "%2" は有効ではありません。
CIS_E_ADMIN_OPENNESS_CONSTRAINT | 0x15B7 | IsPassThrough プロパティが TRUE に設定されている場合、"%1" プロパティに値 "%2" を指定することはできません。
CIS_E_ADMIN_RECEIVE_INVALID_SERVER_GROUP | 0x15B8 | 指定されたサーバーとグループの両方、またはどちらか一方が有効ではありません
CIS_E_ADMIN_INVALID_INSTANCE_NAME | 0x15B9 | 指定したインスタンス名 "%1" には、次の無効な文字が 1 つ以上含まれています。 [ ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \ ; " ' < > , . ? ]
BTS_E_ADMIN_GROUP_UNIQUE_NAME | 0x15BA | 同じ名前の BizTalk サーバー グループが既に BizTalk メッセージ管理データベースに存在します。
BTS_E_ADMIN_TIMESTAMPS_DATA_CORRUPTION | 0x15BB | BizTalk メッセージ管理データベースの adm_TimeStamps テーブルで内部データの破損が検出されました。
BTS_E_ADMIN_SERVER_UNIQUE_NAME | 0x15BC | 同じ名前の BizTalk Server が既に BizTalk メッセージ管理データベースに存在します。
BTS_E_ADMIN_SERVER_FOREIGN_GROUPNAME | 0x15BD | この BizTalk Server は BizTalk メッセージ管理データベース内の有効な BizTalk Server グループを参照していません。
BTS_E_ADMIN_RECSVC_UNIQUE_NAME | 0x15BE | 同じ名前の BizTalk Server 受信機能が既に BizTalk メッセージ管理データベースに存在します。
BTS_E_ADMIN_RECSVC_FOREIGN_GROUPNAME | 0x15BF | この BizTalk Server 受信機能は BizTalk メッセージ管理データベース内の有効な BizTalk Server グループを参照していません。
BTS_E_ADMIN_PARSER_UNIQUE_ID | 0x15C1 | 同じ CLSID およびグループ名を持つ BizTalk Server パーサーが既に BizTalk メッセージ管理データベースに存在します。
BTS_E_ADMIN_PARSER_FOREIGN_GROUPNAME | 0x15C2 | この BizTalk Server パーサーは BizTalk メッセージ管理データベース内の有効な BizTalk Server グループを参照していません。
CIS_E_ADMIN_DB_SPROCVERSION | 0x15C3 | "%2" サーバーの "%1" データベースには、必要なデータベース スキーマが含まれていません。
CIS_E_ADMIN_DB_VERSION | 0x15C4 | "%2" サーバーの "%1" データベースは、製品に含まれているバージョンとは互換性がありません。
CIS_E_DTA_LOG_INTERCHANGE_DETAILS_FAILED | 0x1604 | インターチェンジの詳細を記録できませんでした。
CIS_E_DTA_LOG_DOCUMENT_DETAILS_FAILED | 0x1605 | ドキュメントの詳細を記録できませんでした。
CIS_E_DTA_LOG_GROUP_DETAILS_FAILED | 0x1606 | グループの詳細を記録できませんでした。
CIS_E_DTA_INIT_FAILED | 0x160A | DTA オブジェクトを初期化できませんでした。
CIS_E_DTA_FAILED_TO_GET_ADMIN_PROPERTIES | 0x160E | 管理のプロパティを取得できませんでした。
CIS_E_DTA_DATABASE_CONNECTION | 0x160F | サーバーは追跡データベースへの接続を確立できませんでした。
CIS_E_DTA_LOG_DOCUMENT_FAILED | 0x1619 | ドキュメントのコピーを記録できませんでした。
CIS_E_DTA_LOG_INTERCHANGE_FAILED | 0x1620 | インターチェンジのコピーを記録できませんでした。
CIS_E_DTA_OBJECT_IS_UNINITIALIZED | 0x1623 | DTA メソッドを呼び出す前に、DTA 初期化メソッドを明示的に呼び出す必要があります。
CIS_E_DTA_FAILED_TO_COMMIT | 0x1625 | データベースに変更をコミットできませんでした。
CIS_E_DTA_FAILED_TO_LOG_SOURCE_XML | 0x1626 | 中間送信元 XML を記録できませんでした。
CIS_E_DTA_FAILED_TO_LOG_DEST_XML | 0x1627 | 中間送信先 XML を記録できませんでした。
CIS_E_DTA_ACK_NO_ROW_FOUND | 0x162B | 受信確認の関連付けに失敗しました。与えられた関連付けキーが、追跡データベースのいずれのレコードとも一致しませんでした。
CIS_E_DTA_ACK_MULTIPLE_ROWS_FOUND | 0x162C | 受信確認の関連付けに失敗しました。与えられた関連付けキーが、追跡データベース内の複数のレコードと一致しました。
CIS_E_DTA_LOG_MIME_FAILED | 0x162D | 送信 "%1" の MIME データを記録できませんでした。
CIS_W_DTA_LOG_TRACKING_FIELD_FAILED | 0x162E | 送信 "%1" の次の追跡項目をログに記録できませんでした。追跡項目 : %2 仕様フィールド名 : %3 実際の値 : %4 変換エラーまたは演算オーバーフローが原因として考えられます。ドキュメントまたはチャネル構成の、追跡項目の設定を確認してください。
CIS_W_DTA_LOG_BINARY_TRACKING_FIELD_FAILED | 0x162F | 送信 "%1" の次の追跡項目をログに記録できませんでした。追跡項目 : %2 仕様フィールド名 : %3 対応する XML の要素または属性が、カスタム データ型としてのみ追跡できるバイナリ データ型に設定されているため、送信をログに記録できませんでした。ドキュメントまたはチャネル構成の、追跡項目の設定を確認してください。
CIS_E_DTA_INIT_TRANSACTIONAL_SESSION | 0x1631 | サーバーは追跡オブジェクトのためのトランザクション セッションを作成できませんでした。
CIS_W_DTA_RECORD_UPDATE_FAILED | 0x1632 | 追跡レコードの更新に失敗しました。更新アクションの実行前に、レコードが削除された可能性があります。
CIS_E_RESPONSE_DOM_LOAD_FAILED | 0x1701 | 応答データから XML-DOM を読み込めませんでした。
CIS_E_RECEIVE_MSMQ_BYOT_CREATE_FAILED | 0x1702 | メッセージ キュー受信機能は、Bring Your Own Transaction (BYOT) オブジェクトを使用してインターチェンジ オブジェクトを作成できませんでした。BizTalk Server COM+ アプリケーションを編集しているか、または COM+ アプリケーション自身を構成していると考えられます。BizTalk メッセージ キュー受信機能を停止します。
CIS_E_RECEIVE_MSMQ_ZERO_BYTE_DOC | 0x1703 | メッセージ キュー受信機能は 0 バイトのドキュメントを読み取ったため、破棄されました。
CIS_E_RECEIVE_SERVICE_FAILED | 0x1704 | 受信機能 "%1" の処理に失敗しました。BizTalk Server 管理コンソールの受信機能構成を確認してください。
CIS_E_INITWORKITEM | 0x1705 | 内部作業項目の作成に失敗しました。SQL Server が実行されているか確認してください。
CIS_E_NOPIPELINE | 0x1706 | "%1" というチャネル名は検索できませんでした。
CIS_E_OPEN_PASSTHROUGH | 0x1707 | チャネルおよびメッセージ ポートのオープンネス型が、送信メソッド呼び出しと互換性がありません。
CIS_E_DLQ_DETAILS | 0x1708 | 保留キューについての詳細を取得できませんでした。
CIS_E_INVALID_OPENDEST | 0x1709 | 次のオープンな送信先メッセージ ポートに対して指定されている送信先は、有効ではありません : %1
CIS_E_SQL_MISSINGROWS | 0x170a | SQL OLEDB プロバイダから返されたレコードから行が見つかりませんでした。
CIS_E_BTF_TIME_STAMP_EXPIRED | 0x170b | BizTalk フレームワーク ドキュメント "%1" は、期限切れの "%2" タイムスタンプ付きで受信されました。このメッセージは破棄されます。
CIS_E_ACCESS_DENIED | 0x170c | 現在のプロセスには管理者特権がないため、保留キューにアクセスできません。
CIS_E_BTF_ERROR_FINDING_TAG | 0x170d | パーサーが BizTalk フレームワーク タグ "%1" を見つけられませんでした。または、タグに値が含まれていませんでした。このドキュメントは保留キューに移動されます。
CIS_E_INVALID_FORMAT | 0x170e | "%1" エンベロープ書式がサーバーに認識されていません。有効なエンベロープ書式を指定してください。
CIS_E_INVALID_MAP | 0x170f | このチャネルで参照されるマップをサーバーが読み込めませんでした。
CIS_E_MALFORMED_EXPR | 0x1710 | 式 "%1" の形式が正しくないため、サーバーが解釈できません。
CIS_E_DB_SHUTDOWN | 0x1711 | データベース障害のため、サーバーをシャットダウンします。
CIS_E_SUBMIT_BLOCKED | 0x1712 | データベース障害により、すべての送信呼び出しがブロックされました。問題を解決した後、送信メソッドを呼び出す前に、[コンポーネント サービス] を起動して "BizTalk Server インターチェンジ アプリケーション" をシャットダウンしてください。
CIS_E_CERT_NOT_FOUND | 0x1713 | 必要な証明書が証明書ストアに見つかりません。
CIS_E_NODATA | 0x1714 | 送信メソッドの呼び出しに、ドキュメントまたはファイルのパスが含まれていません。
CIS_E_TOOMUCH_DATA | 0x1715 | 送信メソッドの呼び出しに、ドキュメントとファイルのパスの両方が含まれています。
CIS_E_INVALID_OPENFLAG | 0x1716 | 送信メソッド呼び出しに無効なオープンネス型が渡されました。これらの値については、BizTalk Server 2000 ヘルプ ドキュメントを参照してください。
CIS_E_PASSTHROUGH_PARAMS | 0x1717 | 送信メソッドの呼び出しで、送信元、送信先、またはドキュメント名の情報にチャネルが含まれていました。チャネルをパラメータとして渡すときは、送信元、送信先、ドキュメント名の情報を含めることはできません。
CIS_E_NOSRCID | 0x1718 | 送信メソッドの呼び出しに送信元修飾子が含まれていましたが、送信元識別子は含まれていませんでした。
CIS_E_NODESTID | 0x1719 | 送信メソッドの呼び出しに送信先修飾子が含まれていましたが、送信先識別子は含まれていませんでした。
MSG_TIMEBOMB_EXPIRED | 0x171A | Microsoft Biztalk Server 2000 をご評価いただき、ありがとうございました。この評価版の評価期間は終了しました。Microsoft BizTalk Server 2000 のライセンスされたバージョンの入手に関しては、Microsoft にお問い合わせください。
CIS_E_LOOPBACK | 0x171B | トランスポートの種類にループバックを指定したドキュメントを送信しようとしました。トランスポートの種類にループバックを指定できるのは、SubmitSync メソッドを呼び出すときに限られます。
CIS_E_DBEXECUTE | 0x171C | 次のストアド プロシージャの呼び出しに失敗しました : "%1"。
CIS_E_MISSING_SMTPHOST | 0x171D | SMTP トランスポートを使用するには、SMTP ホストを指定してください。SMTP ホストを指定するには、BizTalk Server 管理コンソールの [Microsoft BizTalk Server 2000] を展開します。次に、[BizTalk Server グループ] を右クリックし、[プロパティ] をクリックして [BizTalk Server グループのプロパティ] ダイアログ ボックスを開きます。[全般] タブの [SMTP ホスト] ボックスで、使用する SMTP ホストを指定します。
CIS_E_INVALIDHANDLE | 0x171E | このメソッドには、送信ハンドル、または送信ハンドルの配列が必要ですが、受信したデータは有効ではありませんでした。パラメータが正しいことを確認してください。
CIS_E_DBCONNECT | 0x171F | BizTalk Server は、サーバー "%2" の "%1" データベースへの接続を初期化できませんでした。
CIS_E_PASSTHROUGH_WITH_NOCHANNEL | 0x1720 | パススルー フラグを true に設定した場合は、Submit メソッド呼び出しまたは SubmitSync メソッド呼び出しの送信パラメータとして有効なチャネル名を指定する必要があります。
CIS_W_DBFAILURE | 0x1721 | データベースの呼び出しに失敗したため、次のエラー文字列が返されました : "%1"。この呼び出しを再試行します。
CIS_E_GET_BTMPARAMS | 0x1722 | BTM データベースへの接続パラメータを読み込めません。BizTalk Server 管理コンソールを使用して、この問題を解決してください。
CIS_E_UNABLE_TO_CREATE_CUSTOM_PRE_PROC | 0x1723 | 受信機能 "%1" 用のカスタム プリプロセッサ コンポーネントを作成できませんでした。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_PRE_PROC_FAILED | 0x1724 | 受信機能 "%1" によって使用されているカスタム プリプロセッサ コンポーネントを実行できませんでした。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_PRE_PROC_NO_BSTR | 0x1725 | ファイル受信機能 "%1" によって使用されているカスタム プリプロセッサ コンポーネントは、有効な BSTR を返すことができませんでした。有効な BSTR が必要です。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA | 0x1726 | メッセージ キュー受信機能 "%1" によって使用されているカスタム プリプロセッサ コンポーネントを呼び出すことができません。これは、メッセージに BSTR でないデータまたは BYTE 型の配列でないデータが含まれているためです。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_PRE_PROC_INVALID_CP | 0x1727 | メッセージ キュー受信機能 "%1" によって使用されているカスタム プリプロセッサ コンポーネントは、有効なコード ページを返すことができませんでした。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA_OUT | 0x1728 | メッセージ キュー受信機能 "%1" によって使用されているカスタム プリプロセッサ コンポーネントは、有効なドキュメントを返すことができませんでした。ドキュメントは、BSTR、または BYTE 型配列のいずれかである必要があります。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_FILE_PRE_PROC_FAIL | 0x1729 | ファイル受信機能 "%1" によって使用されているカスタム プリプロセッサ コンポーネントを実行できませんでした。ドキュメント "%2" は保留キューに移動されます。
CIS_E_CUSTOM_PRE_PROC_CANT_SET_CTX | 0x172A | サーバーは、受信機能 "%1" が使用しているカスタム プリプロセッサ コンポーネントに対してコンテキストを設定できませんでした。このドキュメントは保留キューに移動されます。
CIS_E_FILERCV_FILE_SHARE_DOWN | 0x172B | ファイル受信機能 "%1" はネットワーク共有 "%2" に接続できませんでした。この受信機能はもう一度接続を試行します。
CIS_E_FILERCV_NETWORK_DOWN | 0x172C | ネットワークに問題が発生したため、ファイル受信機能 "%1" はネットワーク共有 "%2" に接続できませんでした。この受信機能はもう一度接続を試行します。
CIS_E_RECEIVE_FUNCTION_DISABLED | 0x172D | 受信機能 "%1" は問題が発生したためにシャットダウンされ、無効にされます。問題を解決した後、BizTalk 管理コンソールでこの受信機能をもう一度有効にしてください。
CIS_E_UNRECOVERABLE | 0x172E | BizTalk Server スケジューラ コンポーネントで重大なエラーが発生しました。サーバーはシャットダウン処理中です。問題を解決し、サーバーをもう一度起動してください。
CIS_E_RELIABLE_NOACK | 0x172F | サーバーは、信頼できるメッセージの受信確認を受信していません。
CIS_E_DLQ_ID | 0x1730 | 保留キュー ID: "%1"
CIS_E_CANNOT_FIRE_EVENT | 0x1731 | 保留キュー内の項目 "%1" のための WMI イベントを送信できません。最も一般的な原因は、この送信を構成したユーザーに、WMI にアクセスするための十分な特権がないことです。
CIS_E_SERIALIZER_INVALID_DOCUMENT | 0x1800 | トラッキング ID "%1" のドキュメントは、無効な XML です。シリアライザを続行できません。
CIS_E_BTF_INVALID_ADDRESS_TYPE | 0x1801 | BizTalk フレームワーク ドキュメントの "%1" アドレス フィールドに無効な "種類" が指定されています。このドキュメントは保留キューに移動されます。
CIS_E_RELIABLE_MSG_RECEIPT_REQ_BY | 0x1802 | BizTalk フレームワーク ドキュメント "%1" に期限切れの "receiptRequiredBy" タイムスタンプが存在するため、このドキュメントは送信されません。このメッセージは破棄されます。
CIS_E_CUSTOM_ENVELOPE_ERROR | 0x1803 | カスタム エンベロープ "%1" にプロパティ "%2" が指定されていますが、カスタム エンベロープ ジェネレータは XML ノードの位置を特定できませんでした。このドキュメントは保留キューに移動されます。
CIS_E_SERIALIZER_INVALID_DATETIME | 0x1804 | "%1" の日付または時刻の書式が無効です。書式の仕様を修正してください。
CIS_E_SERIALIZER_INVALID_DTDATA | 0x1805 | "%1" の日付または時刻フィールドは、無効な ISO8601 形式です。XML の日付または時刻が正しくフォーマットされているか確認してください。
CIS_E_SERIALIZER_INVALID_DELIMITER | 0x1806 | 区切り記号 "%1" がないか、無効な値が指定されています。区切り記号の値を更新してください。
CIS_E_SERIALIZER_MISSING_PROPSET | 0x1807 | ドキュメント "%1" に、このシリアライザの実行に必要なプロパティ セットが見つかりません。
CIS_E_SERIALIZER_MISSING_PROP | 0x1808 | ドキュメント "%1" のプロパティの設定がないか、"%2" のプロパティに対する有効な値が含まれていません。このプロパティを追加するか修正してください。
CIS_E_SERIALIZER_INVALIDARG | 0x1809 | このシリアライザを実行するには、送信元および送信先の修飾子と値の両方が必要です。このトランザクション用のメッセージ ポートに修飾子と値を指定してください。
CIS_E_SERIALIZER_MISMATCH_SPEC | 0x180A | シリアライズで何も出力されませんでした。ドキュメント仕様が送信 XML ドキュメントに適合していることを確認してください。
CIS_E_SERIALIZER_FAILED | 0x180B | シリアライザが処理を終了できませんでした。詳細については、次のメッセージを参照してください。
CIS_E_SERIALIZER_INVALID_SRCQUAL | 0x180C | 送信元識別子の修飾子 "%1" が長すぎるため、送信ドキュメントのヘッダーに置くことができません。短い修飾子でチャネルを更新してください。
CIS_E_SERIALIZER_INVALID_SRCID | 0x180D | 送信元識別子の値 "%1" が長すぎるため、出力ヘッダーに置くことができません。短い値でチャネルを更新してください。
CIS_E_SERIALIZER_INVALID_DESTQUAL | 0x180E | 送信先識別子の修飾子 "%1" が長すぎるため、出力ヘッダーに置くことができません。短い修飾子でポートを更新してください。
CIS_E_SERIALIZER_INVALID_DESTID | 0x180F | 送信先識別子の値 "%1" が長すぎるため、出力ヘッダーに置くことができません。短い識別子でポートを更新してください。
CIS_E_SERIALIZER_INVALID_POSREC | 0x1810 | 位置レコード "%1" は、レコード長が 0 を含むように定義されています。これは、タグがなく、このレコードのすべてのフィールドに開始位置と終了位置が指定されていない場合に起こります。レコードに対して有効な開始位置と終了位置を持つようにフィールドを更新してください。
CIS_E_SERIALIZER_NODELIMS | 0x1811 | このシリアライザ コンポーネントに対して、メッセージ ポート内の区切り記号を指定する必要があります。このコンポーネント用の有効な区切り記号セットを指定してください。
CIS_E_SERIALIZER_INVALID_CHAR | 0x1812 | シリアライザ コンポーネントが無効な文字 "%1" を検出しました。ドキュメント仕様の InvalidCharacterMap タグで指定したエントリでは、"%2" から "%3" の間にある文字は無効であると宣言されています。
CIS_E_SERIALIZER_INVALID_LENGTH | 0x1813 | "%1" フィールド ("%2") の長さが無効です。長さを %3 から %4 までで設定してください。このドキュメントは拒否されます。
CIS_E_SERIALIZER_SELECT_SINGLE_NODE_FAILED | 0x1814 | シリアライザ コンポーネントでクエリ "%1" を使用してノードを検出できません。このドキュメントは拒否されます。
CIS_E_SERIALIZER_RELIABLE_URL_MISSING | 0x1815 | 信頼できるメッセージに必要な、返信先 URL が設定されていません。このドキュメントは拒否されます。
CIS_E_SERIALIZER_CONTROL_NUMBER | 0x1816 | シリアライザ コンポーネントは、BizTalk 管理データベースの %1 %2 の制御番号を見つけられません。このドキュメントは拒否されます。
CIS_E_CUSTOM_ENV_PARSE_TABLE_ERROR | 0x1817 | シリアライザ コンポーネントは、カスタム エンベロープ ID : "%1" を構築できませんでした。これは、提供された XML スキーマにエラーがあるためです。このドキュメントは保留キューに移動されます。
CIS_E_SUBSYNC_RELIABLE_MSG | 0x1818 | 送信された BizTalk フレームワーク ドキュメントに、"信頼できる" 情報が指定されています。この情報には、同期呼び出しが許可されていません。
CIS_E_CUSTXML_BODY_NOT_FOUND | 0x1819 | パーサーは、XML 仕様 : "%1" で指定されたクエリを使用して、XML ドキュメント ノードを見つけられませんでした。
CIS_E_BTF_ACK_BAD_MSG_ID | 0x181A | BizTalk フレームワークの受信に、無効な <prop:identity> タグ : "%1" が存在しています。このドキュメントは保留キューに移動されます。
CIS_E_BTF_MANIFEST_REF_MISSING | 0x181B | BizTalk フレームワーク ドキュメントに、<manifest> タグに必須の <reference> タグがない状態で <manifest> タグが存在しています。このドキュメントは保留キューに移動されます。
CIS_E_CUSTOM_ENV_NO_DOC_NODE | 0x181C | シリアライザがカスタム エンベロープの作成に失敗しました。XML 仕様にドキュメント コンテナ ノード プロパティが指定されていません。このドキュメントは保留キューに移動されます。
CIS_E_BTF_INVALID_XSI_TYPE | 0x181D | BizTalk フレームワーク ドキュメントに、有効でない xsi:type 属性 "%1" が含まれています。この属性にはスペースを使用せず、先頭の文字はアルファベットにしてください。このドキュメントは保留キューに移動されます。
CIS_E_SERIALIZER_INVALID_SYNTAX_IDENTIFIER | 0x181E | EDIFACT 構文識別子 "%1" は有効ではありません。正しい識別子でチャネルを更新してください。
CIS_E_SERIALIZER_INVALID_UNA_CONTROL | 0x181F | EDIFACT UNA 制御値 "%1" は有効ではありません。正しい値でチャネルを更新してください。
CIS_E_SERIALIZER_EXPECT_BSTR_VALUE | 0x1820 | フィールド "%1" の構成データは文字列にする必要があります。このフィールドのデータを更新してください。
BTS_E_XMLSERIALIZER_MISSING_DEST | 0x1821 | 送信先識別子が指定されていなかったため、BizTalk フレームワークのヘッダーを生成できませんでした。
BTS_E_XMLSERIALIZER_MISSING_SRC | 0x1822 | 送信元識別子が指定されていなかったため、BizTalk フレームワークのヘッダーを生成できませんでした。
CIS_E_BTF_IDENTITY_MISSING | 0x1904 | パーサーは、必須の BizTalk フレームワーク タグ "identity" を見つけることができませんでした。このドキュメントは保留キューに移動されます。
CIS_E_BTF_EXPIRESAT_MISSING | 0x1905 | パーサーは、必須の BizTalk フレームワーク タグ "expiresAt" を見つけることができませんでした。このドキュメントは保留キューに移動されます。
CIS_E_MSMQ_NOT_INSTALLED | 0x1906 | メッセージ キュー サービスがサーバーにインストールされていないため、メッセージ キュー受信機能を起動できませんでした。
CIS_W_FILE_RECEIVE_RETRY_FAILURE | 0x1907 | ディレクトリ "%1" に、ファイル受信機能によってアクセスできないファイルがあります。受信サービスは、"%2" 秒後にもう一度そのファイルにアクセスします。
CIS_E_FTP_RECEIVE_DELETE_FAILURE | 0x1908 | FTP 受信機能 "%1" は、次のファイルを処理した後に削除できませんでした。FTP サーバー : "%2" ディレクトリのパス : "%3" ファイル名 : "%4"
CIS_E_FILE_RECEIVE_DELETE_FAILURE | 0x1909 | "%1" のファイルを、処理した後に削除できませんでした。ファイル属性が読み取り専用に設定されていないか確認してください。
CIS_E_LOGON_USER_FAILURE | 0x190a | アカウント %1 でのログオンに失敗しました。%2 にこのサーバーへの "ローカル ログオン" 特権が付与されていることと、BizTalk Server アカウントに "オペレーティング システムの一部として動作する" 特権が付与されていることを確認してください。
CIS_E_MSMQ_RECEIVE_IMPERSONATION_FAILURE | 0x190b | メッセージ キュー受信機能 "%1" は、ログオンしたユーザーを偽装できませんでした。
CIS_E_RECEIVE_CANNOT_CREATE_THREAD | 0x190c | システム エラーが発生したため、受信機能スレッドを作成できません。
CIS_E_MSMQ_RECEIVE_OPENQ_FAILURE | 0x190d | 次のメッセージ キューのキューを開けません : "%1" (メッセージ キューのエラー コード : 0x%2=%3)。このキューの存在およびセキュリティの設定を確認してください。
CIS_E_MSMQ_RECEIVE_PEEKQ_FAILURE | 0x190e | メッセージ キューのキューの読み込みに失敗しました : "%1" (メッセージ キューのエラー コード : 0x%2=%3)。
CIS_E_MSMQ_RECEIVE_RETRIEVEQ_FAILURE | 0x190f | 次のメッセージ キューのキューからメッセージを取得できませんでした : '%1' (メッセージ キューのエラー コード : 0x%2=%3)。
CIS_E_FILE_RECEIVE_FINDCHANGE_FAILURE | 0x1910 | "%1" ディレクトリにファイルの変更通知を設定できません。パスが正しいか確認してください。
CIS_E_SET_CURRENT_DIR_FAILURE | 0x1911 | 現在のディレクトリを "%1" に設定できません。パスが正しいか確認してください。
CIS_E_FTP_RECEIVE_OPENCONNECT_FAILURE | 0x1912 | "%1" サーバーへの FTP 接続を開くことができません。ユーザー "%2" のパスワードが正しいこと、適切なアクセス許可を付与されていること、および正しいドメインに属していることを確認してください。メッセージ ポート番号 "%3" が正しいかどうかも確認してください。
CIS_E_FTP_RECEIVE_GET_FAILURE | 0x1913 | FTP GET 処理で、サーバー "%2" からファイル "%1" を取得できませんでした。
CIS_W_RECEIVE_SUBMIT_FAILURE | 0x1914 | 受信機能 "%1" から送信要求を実行できません。
CIS_E_READONLY_FILE | 0x1915 | 受信機能 "%1" がファイル '%2' を選択しました。このファイルは読み取り専用であるため、処理できません。
CIS_E_BAD_RECSVC | 0x1916 | 受信機能 "%1" で重大なエラーが発生しました。この受信サービスをシャットダウンします。詳細なエラー メッセージについては、イベント ログを確認してください。
CIS_E_FILE_RECEIVE_IMPERSONATION_FAILURE | 0x1917 | ファイル受信機能 "%1" は、ログオンしたユーザーを偽装できませんでした。
CIS_E_MSMQ_RECEIVE_UNEXPECTED_PASSTHROUGH | 0x1918 | 以前にパススルー送信として送信されたドキュメントが見つかりましたが、パススルー送信用のメッセージ キュー受信機能 ""%1"" が構成されていません。受信機能を変更してパススルー送信を受け入れるようにするか、キューからパススルー ドキュメントを削除してください。この受信機能はシャットダウンされます。
CIS_E_BTSDOCUMENT_INVALIDNAME | 0x1A00 | ドキュメント "%1" は存在しません。ドキュメント名を修正するか、ドキュメントを BizTalk メッセージ管理データベースに追加してください。
CIS_E_BTSDOCUMENT_INVALIDDOC | 0x1A01 | サーバーは、与えられた基準を使用してドキュメントを読み込めませんでした。
CIS_E_BTSDOCUMENT_AMBIGUOUS_NAMESPACE | 0x1A02 | XML ルート ノード "%1" を特定できません。ドキュメント "%2" および "%3" が、ノード名を別々の仕様として参照しています。仕様を変更してあいまいさをなくすか、ドキュメント名を明示的に使用してください。
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSET | 0x1A03 | ドキュメント "%1" および "%2" が、同じプロパティ セットを参照しているため、プロパティ セットがあいまいです。
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSETSHAREID | 0x1A04 | ドキュメント "%1" および "%2" が同じプロパティ セットを参照し、参照 "%3" を持っているため、プロパティ セットがあいまいです。
CIS_E_BTSDOCUMENT_INVALIDPROPERTYSET | 0x1A05 | 次のプロパティ セットが指定されました : %1。
CIS_E_BTSDOCUMENT_EMPTYPROPERTYSET | 0x1A06 | プロパティ セットが空です。
CIS_E_BTSDOCUMENT_LOADFAILED | 0x1A07 | ドキュメント "%1" を読み込めませんでした。非エンベロープ仕様を使用しているか、追跡の詳細構成が正しくないと考えられます。
CIS_E_BTSENVELOPE_LOADFAILED | 0x1A20 | エンベロープ "%1" を読み込めませんでした。仕様が有効なものでないと考えられます。有効なエンベロープ仕様を構成してください。
CIS_E_FAILED_TO_JOIN_TX | 0x1A21 | トランザクションの結合に失敗しました。DTC および SQL Server データベースを実行する必要があります。
MSG_COM_CREATE_FAILED | 0x1B01 | %1 クラスのインスタンスを作成できません : %2。
MSG_CONNECT_WMI_FAILED | 0x1B02 | "%1" での Windows Management への接続を確立できませんでした : %2。
MSG_COSETPROXY_FAILED | 0x1B03 | Windows Management 接続に認証の資格情報を設定できません : %1。
MSG_WMI_ENUMINST_FAILED | 0x1B04 | BizTalk Server WMI プロバイダ クラス "%1" のインスタンスを列挙できません : %2。
MSG_WMI_GETPROP_FAILED | 0x1B05 | 予期しないエラーのため、"%1" に対するプロパティの値を BizTalk Server WMI プロバイダから取得できません : %2。
MSG_WMI_EXECQUERY_FAILED | 0x1B06 | 予期しないエラーのため、BizTalk Server WMI プロバイダ クエリ "%1" を実行できません : %2。
MSG_WMI_GETOBJ_FAILED | 0x1B07 | 予期しないエラーのため、"%1" の BizTalk Server WMI プロバイダのインスタンスを取得できません : %2。
MSG_WMI_PUTPROP_FAILED | 0x1B08 | 予期しないエラーのため、"%1" のプロパティ値を変更できません : %2。
MSG_WMI_PUTINST_FAILED | 0x1B09 | 予期しないエラーのため、BizTalk Server WMI プロバイダのインスタンス "%1" のプロパティ値を更新できません : %2。
MSG_WMI_DELINST_FAILED | 0x1B0A | 予期しないエラーのため、"%1" の BizTalk Server WMI プロバイダのインスタンスを削除できません : %2。
MSG_WMI_CREATEINST_FAILED | 0x1B0B | WMI クラスの新しいインスタンス "%1" を BizTalk Server WMI プロバイダで作成できません : %2。
MSG_WMI_CREATEGETOBJ_FAILED | 0x1B0C | 予期しないエラーのため、BizTalk Server WMI プロバイダ クラス "%1" の新しいインスタンスを作成できません : %2。
MSG_WMI_EXECMETHOD_GETOBJ_FAILED | 0x1B0D | クラスの取得に失敗したため、BizTalk Server WMI プロバイダ クラス "%2" のメソッド "%1" を実行できません : %3。
MSG_WMI_EXECMETHODCLASS_FAILED | 0x1B0E | メソッドの情報の取得に失敗したため、BizTalk Server WMI プロバイダ クラス "%2" のメソッド "%1" を実行できません : %3。
MSG_WMI_EXECMETHODSPAWN_FAILED | 0x1B0F | 予期しないエラーのため、BizTalk Server WMI プロバイダ クラス "%2" のメソッド "%1" を実行できません : %3。
MSG_WMI_EXECMETHODPUTPARAM_FAILED | 0x1B10 | パラメータ値の設定に失敗したため、BizTalk Server WMI プロバイダ クラス "%2" のメソッド "%1" を実行できません : %3。
MSG_WMI_EXECMETHOD_FAILED | 0x1B11 | WMI クラス "%2" のメソッド "%1" を実行できません : %3。
MSG_GET_HOSTNAME_FAILED | 0x1B12 | 予期しないエラーのため、ローカル コンピュータ名を取得できません : %1。
MSG_OUT_OF_MEMORY | 0x1B14 | メモリ不足。
MSG_FAIL_LOAD_BMP | 0x1B17 | 少なくとも 1 つのビットマップを BizTalk Server 管理コンソールに読み込めません : %1。
MSG_FAIL_SET_BMPSTRIP | 0x1B18 | 少なくとも 1 組のビットマップを BizTalk Server 管理コンソールの画像リストに追加できません : %1。
MSG_ERROR_WMI_PATH_EMPTY | 0x1B19 | 以前の WMI 障害により、要求された操作を完了できません。この場合、WMI オブジェクト パスは空です。
MSG_ERROR_BTM_GRP_ENUM_FAIL | 0x1B20 | 不明な問題により、WMI プロバイダが BizTalk メッセージ管理データベースからサーバー グループの一覧を列挙できません : %1。
MSG_ERROR_GRP_DTA_DB_FAIL | 0x1B21 | 不明な問題により、WMI プロバイダが "%1" グループの追跡データベースにアクセスできません。
MSG_ERROR_GRP_SQ_DB_FAIL | 0x1B22 | 不明な問題により、WMI プロバイダが "%1" グループの共有キュー データベースにアクセスできません。
MSG_ERROR_GRP_BOTH_DB_FAIL | 0x1B23 | 不明な問題により、WMI プロバイダが "%1" グループの追跡データベースおよび共有キュー データベースにアクセスできません。
MSG_ERROR_DECRYPT_FAIL | 0x1B24 | パスワードの解読に失敗しました : %1。
MSG_WARN_ENUM4ROOTUPD_FAILED | 0x1B27 | 不明な問題により、WMI プロバイダは BizTalk メッセージ管理データベースの更新を準備するための次のサーバー一覧およびステータスを取得できません : %1
MSG_ERROR_CHANGE_ROOTDB | 0x1B28 | サーバー "%1" を新しい BizTalk メッセージ管理データベース情報に更新できません : %2。
MSG_ERROR_CHANGE_ROOTDB_CONNECT | 0x1B29 | WMI 名前空間 "%1" に接続して、新しい BizTalk メッセージ管理データベース情報にサーバー "%2" を更新できません : %3
MSG_CHANGE_ROOTDB_SUMMARY | 0x1B30 | BizTalk メッセージ管理データベースの変更要求が完了しました。 %1%2 %3%4
MSG_CHANGE_ROOTDB_ON_LOCAL | 0x1B3A | 元の BizTalk メッセージ管理データベースからサーバーおよびサーバー グループの情報を取得できないため、ローカル コンピュータ "%1" に関する BizTalk メッセージ管理データベース情報のみが更新されます。更新に成功しました。
MSG_ERROR_UNEXPECTED_ENDOFLIST | 0x1B3C | 予期しない "%1" クラス列挙の一覧の最後 (EOL) です。
MSG_ERROR_ORG_QUALIFIERS_FROM_DB_FAILED | 0x1B3D | 予期しないエラーにより、組織の修飾子を BizTalk メッセージ管理データベースから取得できません。"%1"。
MSG_ERROR_ORG_VALUES_FROM_DB_FAILED | 0x1B3E | 予期しないエラーにより、BizTalk メッセージ管理データベースから組織の値を取得できません。"%1"。
MSG_WARN_NOT_RESUBMITABLE | 0x1B3F | 選択した複数の項目の少なくとも 1 つが再送信できません。
MSG_WARNING_PROP_VALUES_CHANGED | 0x1B40 | 受信機能 "%3" に対して指定された %1 "%2" は、BizTalk メッセージ管理データベースから削除されています。
MSG_WARNING_QUALIFIER_CHANGED | 0x1B41 | 受信機能 "%3" に対して指定された修飾子 "%1" および識別子 "%2" の組は、BizTalk メッセージ管理データベースでは無効です。
MSG_WARNING_ORGANIZATION_CHANGED | 0x1B42 | 受信機能 "%2" に対して指定された組織 "%1" は、BizTalk メッセージ管理データベースでは無効です。
MSG_TIMEBOMB_DAYS_LEFT | 0x1B43 | Microsoft BizTalk Server 2000 をご評価いただき、ありがとうございます。この評価版の評価期間は、あと %1 日間です。Microsoft BizTalk Server 2000 のライセンスされたバージョンの入手に関しては、Microsoft にお問い合わせください。
INTERCHANGE_EVENT | 0x3005 | BizTalk Server: %1

注

  • エラーが発生すると、%n 変数はオブジェクト名など適切な情報に置き換えられます。


ドキュメントの送信

ここでは、Microsoft BizTalk Server 2000 にドキュメントを送信する方法に関する情報を提供します。詳細については次のトピックを参照してください。

  • 特定の作業のヘルプについては、「操作方法」を参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • COM インターフェイスおよび列挙については、「ドキュメント送信に関するリファレンス」を参照してください。

  • コード例については、「BizTalk メッセージ サービスのコード サンプル」を参照してください。


操作方法

ここでは、Microsoft BizTalk Server 2000 にドキュメントを送信する方法を作業ごとに説明します。「概念」を参照し、十分に理解しておいてください。次のトピックが含まれます。

  • 追跡データベースの読み取り

  • リモート クライアントからのドキュメントの送信


追跡データベースの読み取り

追跡インターフェイス IBizTalkTrackData の目的は、Microsoft BizTalk Server 2000 の追跡情報へのプログラムによるアクセスを簡単にすることです。このインターフェイスは IInterchange インターフェイスを補足して、IInterchange 呼び出しからの戻り値をこれらの IBizTalkTrackData メソッドに渡し、BizTalk Server 2000 に送信されるドキュメントの利用状況についてのデータにアクセスできるようにします。

入力ドキュメントと出力ドキュメントとの間には、一対一または一対多の関係が存在します。通常のドキュメント フローでは、1 つのドキュメントがサーバーに送信され、追跡され、場合によっては変換されて、結果としてサーバーから 1 つのドキュメントが出力されます。ただし、1 つのドキュメントの送信によって、複数の宛先に多くのドキュメントが出力されるようにメッセージ ポートを構成することもできます。

  1. IInterchange インターフェイスの Submit メソッドから SubmissionHandle 戻り値を取得します。

  2. 入力として SubmissionHandle 戻り値を使用して、GetInterchanges メソッドを呼び出します。このメソッドは、その送信に含まれるインターチェンジの一覧を返します。これには追跡データベースからのすべてのデータが含まれます。配信時間、受信確認フラグなどのトランスポートに固有の情報は、インターチェンジ データに表示されるため、このデータを調べて配信のステータスなどを確認または検査できます。

  3. 入力として SubmissionHandle 戻り値を使用して、GetInDocDetails メソッドを呼び出します。このメソッドは、送信に含まれていたドキュメントの一覧を返します。この一覧を参照して、特定のドキュメントの有効性、ドキュメントのバイト数など、入力ドキュメントに関する情報を入手できます。

  4. 入力として SubmissionHandle 戻り値を使用して、GetOutDocDetails メソッドを呼び出します。このメソッドは、送信の結果として生成されたドキュメントの一覧を返します。このリストを参照して、出力ドキュメントについての情報を入手できます。たとえば、今日これまでに実行した送信から PO #123456 を探すことができます。

関連項目

ドキュメント送信に関するリファレンス


リモート クライアントからのドキュメントの送信

ドキュメントは、IInterchange インターフェイスを使用するアプリケーションを実行しているリモート クライアントから Microsoft BizTalk Server 2000 に送信できます。これを実行するには、次の操作を行います。

  1. Microsoft BizTalk Server 2000 をインストールしたコンピュータで、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [管理ツール] をポイントし、[コンポーネント サービス] をクリックします。

  2. ツリー ウィンドウで、[コンポーネント サービス] をクリックし、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。そして、[BizTalk Server Interchange Application] をクリックします。

  3. [操作] メニューの [エクスポート] をクリックします。

  4. [COM アプリケーション エクスポート ウィザードへようこそ] ダイアログ ボックスで、作成するエクスポート インストール パッケージの名前を入力します。

  5. [名前を付けてエクスポート] の [アプリケーション プロキシ] をクリックし、[次へ] をクリックしてウィザードを終了します。

COM アプリケーション エクスポート ウィザードは、拡張子が .msi である Windows インストーラ パッケージ ファイルと、拡張子が .cab である関連のキャビネット ファイルを作成します。これらのファイルをリモート クライアントにコピーし、Windows インストーラ パッケージ ファイルを実行します。これで、リモート クライアントは IInterchange インターフェイスを使用するアプリケーションを実行できるようになります。

注

  • リモート クライアントは Microsoft Windows 2000 を実行している必要があります。

  • インストール パッケージを作成するために使用するコンピュータは、ドキュメントを送信するリモート クライアントの "インターチェンジ サーバー" の役割を果たします。したがって、リモート クライアントに送信するドキュメントはすべて、そのサーバーを経由してルーティングされます。

  • BizTalk Server 2000 のインストール中にリモート クライアントを作成することもできます。


ドキュメント送信に関するリファレンス

ここでは、Microsoft Visual C++ または Visual Basic を使用したプログラミングで、Microsoft BizTalk Server 2000 にドキュメントを送信するために使用するコンポーネントとインターフェイスに関するリファレンスを紹介します。BizTalk Server 2000 にドキュメントを送信するためのすべてのインターフェイス、オブジェクトおよび列挙に関する参照情報を提供します。

次の COM インターフェイスまたは列挙が、このリファレンスで説明されています。

  • IBizTalkTrackData

  • IBTSCustomProcess

  • IBTSCustomProcessContext

  • IInterchange

  • インターチェンジの列挙


IBizTalkTrackData インターフェイス [C++]

BTSDocTracking オブジェクト [Visual Basic]

このオブジェクトは、Microsoft BizTalk Server 2000 の追跡情報へのプログラムによるアクセスを簡単にするために使用します。このオブジェクトは、Interchange オブジェクトを補足して、Interchange メソッドからの戻り値をこれらのメソッドに渡し、BizTalk Server 2000 に送信されるドキュメントに関する追跡データを読み取ることができるようにします。

C++ では、BizTalkTrackData オブジェクトのメソッドにアクセスするには IBizTalkTrackData インターフェイスを使用します。

次の表は、BizTalkTrackData オブジェクトのメソッドを示しています。

メソッド | 説明
GetInDocDetails | IInterchange インターフェイスの Submit メソッドからの SubmissionHandle 戻り値に含まれていたドキュメントの一覧を含む ADO レコードセットを返します。このメソッドは、入力ドキュメントの特定の情報を返します。
GetInterchanges | IInterchange インターフェイスの Submit メソッドからの SubmissionHandle 戻り値に含まれていたインターチェンジの一覧を含む ADO レコードセットを返します。これには追跡データベースからのすべてのデータが含まれます。配信時間や受信確認フラグなどのトランスポートに固有の情報は、追跡データベースに格納されます。これらを調べて、配信のステータスなどを確認または検査できます。
GetOutDocDetails | IInterchange インターフェイスの Submit メソッドが呼び出されたときに生成されたドキュメントの一覧を含む ADO レコードセットを返します。このメソッドは、出力ドキュメントの特定の情報を返します。たとえば、今日これまでに Submit 呼び出しによって作成された PO #123456 などです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。

関連項目

追跡データベース スキーマについて

ドキュメント定義

追跡データベースの読み取り

ドキュメント トラッキング


IBizTalkTrackData::GetInDocDetails メソッド [C++]

BTSDocTracking.GetInDocDetails メソッド [Visual Basic]

GetInDocDetails メソッドは、IInterchange インターフェイスの Submit メソッドからの SubmissionHandle 戻り値に含まれていたドキュメントの一覧を含む ADO レコードセットを返します。このメソッドは、入力ドキュメントの特定の情報を返します。

構文

[C++]

HRESULT GetInDocDetails(
BSTR bstrSubmissionID,
 IDispatch** ppdispResult

);

[Visual Basic]

object.GetInDocDetails( _
 bstrSubmissionID As String _
)

パラメータ

[C++]

bstrSubmissionID

[in] このドキュメント インスタンスに対する Submit によって返された SubmissionHandle 文字列を含む BSTR です。

ppdispResult

[out, retval] 送信に含まれていたドキュメントの一覧を含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

bstrSubmissionID

このドキュメント インスタンスに対する Submit によって返された SubmissionHandle 文字列を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、送信に含まれていたドキュメントの一覧を含むオブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。

関連項目

追跡データベース スキーマについて


IBizTalkTrackData::GetInterchanges メソッド [C++]

BTSDocTracking.GetInterchanges メソッド [Visual Basic]

GetInterchanges メソッドは、IInterchange インターフェイスの Submit メソッドの SubmissionHandle 戻り値に含まれるインターチェンジの一覧を含む ADO レコードセットを返します。これには追跡データベースからのすべてのデータが含まれます。配信時間や受信確認フラグなどのトランスポートに固有の情報が追跡データベースに格納されるので、これらを調べて、配信のステータスなどを確認または検査できます。

構文

[C++]

HRESULT GetInterchanges(
BSTR bstrSubmissionID,
 IDispatch** ppdispResult
);

[Visual Basic]

object.GetInterchanges( _
 bstrSubmissionID As String, _
)

パラメータ

[C++]

bstrSubmissionID

[in] このドキュメント インスタンスに対する Submit によって返された SubmissionHandle 文字列を含む BSTR です。

ppdispResult

[out, retval] この送信に含まれるインターチェンジの一覧を含む IDispatch インターフェイスへのポインタのアドレスです。これには追跡データベースからのすべてのデータが含まれます。

[Visual Basic]

bstrSubmissionID

このドキュメント インスタンスに対する Submit によって返された SubmissionHandle 文字列を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、オプションとして、この送信に含まれるインターチェンジの一覧を含むオブジェクトを返します。これには追跡データベースからのすべてのデータが含まれます。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。

関連項目

追跡データベース スキーマについて


IBizTalkTrackData::GetOutDocDetails メソッド [C++]

BTSDocTracking.GetOutDocDetails メソッド [Visual Basic]

GetOutDocDetails メソッドは、IInterchange インターフェイスの Submit メソッドの結果として生成されたドキュメントの一覧を含む ADO レコードセットを返します。このメソッドは、出力ドキュメントの特定の情報を返します。たとえば、今日これまでに Submit 呼び出しによって作成された PO #123456 などです。

構文

[C++]

HRESULT GetOutDocDetails(
BSTR bstrSubmissionID,
 IDispatch** ppdispResult
);

[Visual Basic]

object.GetOutDocDetails( _
 bstrSubmissionID As String _
)

パラメータ

[C++]

bstrSubmissionID

[in] このドキュメント インスタンスに対する Submit によって返された SubmissionHandle 文字列を含む BSTR です。

ppdispResult

[out, retval] 送信の結果として生成されたドキュメントの一覧を含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

bstrSubmissionID

このドキュメント インスタンスに対する Submit によって返された SubmissionHandle 文字列を含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、送信の結果として生成されたドキュメントの一覧を含むオブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。

関連項目

追跡データベース スキーマについて


IBTSCustomProcess インターフェイス [C++]

IBTSCustomProcess オブジェクト [Visual Basic]

IBTSCustomProcess は、BizTalk Server 受信機能用のカスタム プリプロセッサを作成するために実装します。

次の表は、IBTSCustomProcess のメソッドを示しています。

メソッド | 説明
Execute | 処理のために BizTalk Server にデータを送信する前に、データのカスタム処理を実行します。
SetContext | 処理されるデータに関連するコンテキスト情報を取得します。

解説

カスタム プリプロセッサの詳細については、「受信機能でのドキュメントの前処理」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcess::Execute メソッド [C++]

IBTSCustomProcess.Execute メソッド [Visual Basic]

Execute メソッドは、受信機能から取得したデータのカスタム処理を実行します。

構文

[C++]

HRESULT Execute(
VARIANT vDataIn,
 long nCodePageIn,
 VARIANT_BOOL bIsFilePath,
 VARIANT* nCodePageOut,
 VARIANT* vDataOut
);

[Visual Basic]

object.Execute( _
 vDataIn As Variant, _
 nCodePageIn As Long, _
 bIsFilePath As Boolean, _
 nCodePageOut As Variant, _
 vDataOut As Variant _
)

パラメータ

[C++]

vDataIn

[in] 受信機能によって読み取られる入力データを含む VARIANT です。メッセージ キューから読み取られるデータは、配列または BSTR のいずれかになります。データがファイル受信機能から読み取られる場合は、このパラメータにはファイル パスが含まれます。ファイル受信機能では、bIsFilePath パラメータは VARIANT_TRUE に設定します。

nCodePageIn

[in] 入力データのコード ページを含む Long です。コード ページは、コンピュータで使用される文字セットとキーボード レイアウトを示します。

bIsFilePath

[in] 入力データの型を示す VARIANT_BOOL フラグです。VARIANT_TRUE の値は、vDataIn パラメータにファイル パスが含まれていることを示します。VARIANT_FALSE の値は、vDataIn パラメータにメッセージ キューからのデータが含まれていることを示します。

nCodePageOut

[out] 出力データのコード ページを含む VARIANT へのポインタです。コード ページは、コンピュータで使用される文字セットとキーボード レイアウトを示します。

vDataOut

[out] 出力データを含む VARIANT へのポインタです。ファイル受信機能では、これは BSTR になります。このパラメータのデータは BizTalk Server に送信され、処理されます。

[Visual Basic]

vDataIn

受信機能によって読み取られる入力データを含む VARIANT です。データが受信機能から読み取られる場合は、このパラメータにはファイル パスが含まれます。ファイル受信機能では、bIsFilePath パラメータは True に設定する必要があります。

nCodePageIn

入力データのコード ページを含む Long です。コード ページは、コンピュータで使用される文字セットとキーボード レイアウトを示します。

bIsFilePath

入力データの型を示す VARIANT_BOOL フラグです。True の値は、vDataIn パラメータにファイル パスが含まれていることを示します。False の値は、vDataIn パラメータにメッセージ キューからのデータが含まれていることを示します。

nCodePageOut

出力データのコード ページを含む VARIANT です。コード ページは、コンピュータで使用される文字セットとキーボード レイアウトを示します。

vDataOut

出力データを含む VARIANT です。このパラメータのデータは BizTalk Server に送信され、処理されます。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalk Server がカスタム プリプロセッサ コンポーネントの作成に失敗した場合や、Execute メソッドがエラーまたは無効なデータを返した場合は、処理中のドキュメントは保留キューに格納されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcess::SetContext メソッド [C++]

IBTSCustomProcess.SetContext メソッド [Visual Basic]

SetContext メソッドは、BizTalk Server に送信されるドキュメントに関連する情報を取得します。

構文

[C++]

HRESULT SetContext(
IBTSCustomProcessContext* pCtx
);

[Visual Basic]

object.SetContext( _
 pCtx As IBTSCustomProcessContext _
)

パラメータ

[C++]

pCtx

[in] BizTalk Server によって処理されているドキュメントに関連する情報を含む IBTSCustomProcessContext です。

[Visual Basic]

pCtx

BizTalk Server によって処理されているドキュメントに関連する情報を含む IBTSCustomProcessContext です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

カスタムプロセス コンテキスト オブジェクトの詳細については、「IBTSCustomProcessContext」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext インターフェイス [C++]

IBTSCustomProcessContext オブジェクト [Visual Basic]

このオブジェクトは、カスタム プリプロセッサ コンポーネントで処理されているデータに関連する情報を取得するために使用します。

C++ では、BTSCustomProcessContext オブジェクトのメソッドにアクセスするには IBTSCustomProcessContext インターフェイスを使用します。

次の表は、BTSCustomProcessContext オブジェクトのプロパティを示しています。

プロパティ | 種類 | 説明
ChannelName (チャネル名) | BSTR | チャネルの名前です。
DestID (送信先 ID) | BSTR | 送信先組織修飾子の値です。
DestQualifier (送信先修飾子) | BSTR | 送信先組織修飾子の種類です。
DocName (ドキュメント名) | BSTR | ドキュメントの名前です。
EnvelopeName (エンベロープ名) | BSTR | ドキュメントで使用するエンベロープの名前です。
Openness (オープンネス) | long | メッセージ ポートがオープンであるかどうかを示す値です。
PassThrough (パススルー) | long | パススルー送信モードが使用されているかどうかを示す値です。
SourceID (送信元 ID) | BSTR | 送信元組織修飾子の値です。
SourceQualifier (送信元修飾子) | BSTR | 送信元組織修飾子の種類です。

解説

このオブジェクトは、IBTSCustomProcess オブジェクトで SetContext メソッドを呼び出すことにより取得できます。カスタム プリプロセッサの詳細については、「受信機能でのドキュメントの前処理」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::ChannelName プロパティ [C++]

IBTSCustomProcessContext.ChannelName プロパティ [Visual Basic]

ChannelName プロパティは、現在のドキュメントを処理するために使用するチャネルの名前を返します。

構文

[C++]

Get メソッド :

HRESULT get_ChannelName(
BSTR* bstrPipelineName
);

[Visual Basic]

object.ChannelName()

パラメータ

[C++]

bstrPipelineName

[out, retval] 現在のドキュメントの処理に使用するチャネルの名前を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、チャネル名を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::DestID プロパティ [C++]

IBTSCustomProcessContext.DestID プロパティ [Visual Basic]

DestID プロパティは、送信先組織修飾子の値を返します。

構文

[C++]

Get メソッド :

HRESULT get_DestID(
BSTR* bstrDestID
);

[Visual Basic]

object.DestID()

パラメータ

[C++]

bstrDestID

[out, retval] 送信先組織修飾子の値を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、送信先組織修飾子の値を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::DestQualifier プロパティ [C++]

IBTSCustomProcessContext.DestQualifier プロパティ [Visual Basic]

DestQualifier プロパティは、送信先組織修飾子の種類を返します。

構文

[C++]

Get メソッド :

HRESULT get_DestQualifier(
BSTR* bstrDestQualifier
);

[Visual Basic]

object.DestQualifier()

パラメータ

[C++]

bstrDestQualifier

[out, retval] 送信先組織修飾子の種類を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

[Visual Basic]

このプロパティは、送信先組織修飾子の種類を含む文字列を返します。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::DocName プロパティ [C++]

IBTSCustomProcessContext.DocName プロパティ [Visual Basic]

DocName プロパティは、現在のドキュメントによって使用されるドキュメント定義の名前を返します。

構文

[C++]

Get メソッド :

HRESULT get_DocName(
BSTR* bstrDocName
);

[Visual Basic]

object.DocName()

パラメータ

[C++]

bstrDocName

[out, retval] ドキュメント定義名を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、ドキュメント定義名を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::EnvelopeName プロパティ [C++]

IBTSCustomProcessContext.EnvelopeName プロパティ [Visual Basic]

EnvelopeName プロパティは、現在のドキュメントで使用するエンベロープの名前を返します。

構文

[C++]

Get メソッド :

HRESULT get_EnvelopeName(
BSTR* bstrEnvelopeName
);

[Visual Basic]

object.EnvelopeName()

パラメータ

[C++]

bstrEnvelopeName

[out, retval] エンベロープの名前を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、現在のドキュメントのエンベロープを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::Openness プロパティ [C++]

IBTSCustomProcessContext.Openness プロパティ [Visual Basic]

Openness プロパティは、メッセージ ポートに関するオープンネスを返します。

構文

[C++]

Get メソッド :

HRESULT get_Openness(
long* lOpenness
);

[Visual Basic]

object.Openness()

パラメータ

[C++]

lOpenness

[out, retval] メッセージ ポートのオープンネスを示す long へのポインタです。このパラメータで返される long は、BIZTALK_OPENNESS_TYPE 列挙の値を表します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、メッセージ ポートのオープンネスを示す Long を返します。このプロパティで返される Long は、BIZTALK_OPENNESS_TYPE 列挙の値を表します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::PassThrough プロパティ [C++]

IBTSCustomProcessContext.PassThrough プロパティ [Visual Basic]

PassThrough プロパティは、ドキュメントがパススルー送信モードを使用するかどうかを示します。

構文

[C++]

Get メソッド :

HRESULT get_PassThrough(
long* fPassThrough
);

[Visual Basic]

object.PassThrough()

パラメータ

[C++]

fPassThrough

[out, retval] ドキュメントがパススルー送信モードを使用するかどうかを示す long へのポインタです。値 0 は、パススルー送信モードが使用されていないことを示します。非ゼロの値は、パススルー送信モードが現在のドキュメントで使用されていることを示します。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、ドキュメントがパススルー送信モードを使用するかどうかを示す Long を返します。値 0 は、パススルー送信モードが使用されていないことを示します。非ゼロの値は、パススルー送信モードが現在のドキュメントで使用されていることを示します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::SourceID プロパティ [C++]

IBTSCustomProcessContext.SourceID プロパティ [Visual Basic]

SourceID プロパティは、送信元組織修飾子の値を返します。

構文

[C++]

Get メソッド :

HRESULT get_SourceID(
BSTR* bstrSourceID
);

[Visual Basic]

object.SourceID()

パラメータ

[C++]

bstrSourceID

[out, retval] 送信元組織修飾子の値を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、送信元組織修飾子の値を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IBTSCustomProcessContext::SourceQualifier プロパティ [C++]

IBTSCustomProcessContext.SourceQualifier プロパティ [Visual Basic]

SourceQualifier プロパティは、送信元組織修飾子の種類を返します。

構文

[C++]

Get メソッド :

HRESULT get_SourceQualifier(
BSTR* bstrSourceQualifier
);

[Visual Basic]

object.SourceQualifier()

パラメータ

[C++]

bstrSourceQualifier

[out, retval] 送信元組織修飾子の種類を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、送信元組織修飾子の種類を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IInterchange インターフェイス [C++]

Interchange オブジェクト [Visual Basic]

このオブジェクトは、直接にまたは受信機能によって、アプリケーションと BizTalk Server 2000 間でドキュメントを交換するために使用します。

C++ では、Interchange オブジェクトのメソッドにアクセスするには IInterchange インターフェイスを使用します。

次の表は、Interchange オブジェクトのメソッドを示しています。

メソッド | 説明
CheckSuspendedQueue | 保留キューを確認し、要求基準と一致するキュー内のドキュメントまたはインターチェンジへのハンドルの一覧を返します。
DeleteFromSuspendedQueue | すべての指定されたドキュメントを保留キューから削除します。
GetSuspendedQueueItemDetails | 保留キューのドキュメントの詳細を返します。
Submit | 非同期処理のために BizTalk Server 2000 にインターチェンジを送信します。このメソッドは、ドキュメントまたはインターチェンジとしての文字列変数のみ受け入れます。これは、アプリケーションがほかのオブジェクト (DOM オブジェクト、CDictionary オブジェクト、ADO オブジェクト、またはほかのデータ型やオブジェクト型) を送信できないことを示します。
SubmitSync | 同期送信のために、BizTalk Server 2000 にインターチェンジを送信します。このメソッドは、提供された場合に応答を返します。このメソッドは、ドキュメントまたはインターチェンジとしての文字列変数のみ受け入れます。これは、アプリケーションがほかのオブジェクト (DOM オブジェクト、CDictionary オブジェクト、ADO オブジェクト、またはほかのデータ型やオブジェクト型) を送信できないことを示します。

解説

Submit と SubmitSync でパラメータを使用すると、セルフルーティング ドキュメントのヘッダーにある特定のフィールドが上書きされます。

リモート クライアントからのドキュメントの送信の詳細については、「操作方法」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : cisapi.h をインクルードします。
ライブラリ : (cisapi.tlb)

関連項目

送信

ルーティング

COM インターフェイスの使用によるドキュメント送信の手順


IInterchange::CheckSuspendedQueue メソッド [C++]

Interchange.CheckSuspendedQueue メソッド [Visual Basic]

CheckSuspendedQueue メソッドは保留キューを確認し、要求基準と一致するドキュメントの一覧を返します。

構文

[C++]

HRESULT CheckSuspendedQueue(
 BSTR DocName,
 BSTR SourceName,
 BSTR DestName,
 VARIANT* DocumentHandleList
);

[Visual Basic]

object.CheckSuspendedQueue( _
 DocName As String, _
 SourceName As String, _
 DestName As String _
)

パラメータ

[C++]

DocName

[in] BizTalkDocument オブジェクトの名前を含む BSTR です。このパラメータは、保留キューの項目の検索範囲を限定します。このパラメータを指定しない場合、このメソッドはすべての BizTalkDocument オブジェクトに一致します。このパラメータは省略可能です。

SourceName

[in] 送信元 BizTalkOrganization オブジェクトの名前を含む BSTR です。このパラメータは、保留キューの項目の検索条件を限定します。このパラメータを指定しない場合、このメソッドはすべての BizTalkOrganization オブジェクトに一致します。このパラメータは省略可能です。

DestName

[in] 送信先 BizTalkOrganization オブジェクトの名前を含む BSTR です。このパラメータは、保留キューの項目の検索条件を限定します。このパラメータを指定しない場合、このメソッドはすべての BizTalkOrganization オブジェクトに一致します。このパラメータは省略可能です。

DocumentHandleList

[out] 保留キュー内のすべてのドキュメントへのハンドルの一覧を含む VARIANT へのポインタです。

[Visual Basic]

DocName

BizTalkDocument オブジェクトの名前を含む文字列です。このパラメータは、保留キューの項目の検索範囲を限定します。このパラメータを指定しない場合、このメソッドはすべての BizTalkDocument オブジェクトに一致します。このパラメータは省略可能です。

SourceName

送信元 BizTalkOrganization オブジェクトの名前を含む文字列です。このパラメータは、保留キューの項目の検索条件を限定します。このパラメータを指定しない場合、このメソッドはすべての BizTalkOrganization オブジェクトに一致します。このパラメータは省略可能です。

DestName

送信先 BizTalkOrganization オブジェクトの名前を含む文字列です。このパラメータは、保留キューの項目の検索条件を限定します。このパラメータを指定しない場合、このメソッドはすべての BizTalkOrganization オブジェクトに一致します。このパラメータは省略可能です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、保留キュー内のすべてのドキュメントへのハンドルの一覧を含む Variant を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

返される項目はキューから削除されません。保留キューから項目を削除するには、DeleteFromSuspendedQueue メソッドを使用します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : cisapi.h をインクルードします。
ライブラリ : (cisapi.tlb)

関連項目

送信

COM インターフェイスの使用によるドキュメント送信の手順


IInterchange::DeleteFromSuspendedQueue メソッド [C++]

Interchange.DeleteFromSuspendedQueue メソッド [Visual Basic]

DeleteFromSuspendedQueue メソッドは、すべての指定されたドキュメントを保留キューから削除します。

構文

[C++]

HRESULT DeleteFromSuspendedQueue(
VARIANT* DocumentHandleList
);

[Visual Basic]

object.DeleteFromSuspendedQueue( _
 DocumentHandleList As Variant _
)

パラメータ

[C++]

DocumentHandleList

[in] 保留キューから削除するドキュメントのハンドルの完全な一覧またはサブセットを含む VARIANT へのポインタです。

[Visual Basic]

DocumentHandleList

保留キューから削除するドキュメントのハンドルの完全な一覧またはサブセットを含む VARIANT です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : cisapi.h をインクルードします。
ライブラリ : (cisapi.tlb)

関連項目

送信

COM インターフェイスの使用によるドキュメント送信の手順


IInterchange::GetSuspendedQueueItemDetails メソッド [C++]

Interchange.GetSuspendedQueueItemDetails メソッド [Visual Basic]

GetSuspendedQueueItemDetails メソッドは、CheckSuspendedQueue メソッドによって返されるハンドルの一覧を使用して、保留キューの 1 つのエントリに関する情報を取得します。

構文

[C++]
HRESULT GetSuspendedQueueItemDetails(
    BSTR ItemHandle,
    VARIANT* SourceName,
    VARIANT* DestName,
    VARIANT* DocName,
    VARIANT* ReasonCode,
    VARIANT* ItemData
);
[Visual Basic]
object.GetSuspendedQueueItemDetails( _
    ItemHandle As String, _
    SourceName As Variant, _
    DestName As Variant, _
    DocName As Variant, _
    ReasonCode As Variant, _
    ItemData As Variant _
)

パラメータ

[C++]

ItemHandle

[in] 保留キュー内の項目へのハンドルを含む BSTR です。

SourceName

[out] 送信元 BizTalkOrganization オブジェクトの名前を含む VARIANT バリアントへのポインタです。

DestName

[out] 送信先 BizTalkOrganization オブジェクトの名前を含む VARIANT へのポインタです。

DocName

[out] BizTalkDocument オブジェクトの名前を含む VARIANT へのポインタです。

ReasonCode

[out] ドキュメントまたはインターチェンジが保留キューに格納されている理由を含む VARIANT へのポインタです。この値の詳細については、CISReasonToQueue列挙を参照してください。

ItemData

[out] ドキュメント インスタンスまたはインターチェンジを含む VARIANT へのポインタです。

[Visual Basic]

ItemHandle

保留キュー内の項目へのハンドルを含む文字列です。

SourceName

送信元 BizTalkOrganization オブジェクトの名前を含む Variant です。この出力パラメータの値は、このメソッドを呼び出すことによって設定されます。

DestName

送信先 BizTalkOrganization オブジェクトの名前を含む Variant です。この出力パラメータの値は、このメソッドを呼び出すことによって設定されます。

DocName

関連付けられた BizTalkDocument オブジェクトの名前を含む Variant です。この出力パラメータの値は、このメソッドを呼び出すことによって設定されます。

ReasonCode

ドキュメントまたはインターチェンジが保留キューに格納されている理由を含む Variant です。この値の詳細については、CISReasonToQueue列挙を参照してください。この出力パラメータの値は、このメソッドを呼び出すことによって設定されます。

ItemData

ドキュメント インスタンスまたはインターチェンジを含む Variant です。この出力パラメータの値は、このメソッドを呼び出すことによって設定されます。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : cisapi.h をインクルードします。
ライブラリ : (cisapi.tlb)

関連項目

送信

COM インターフェイスの使用によるドキュメント送信の手順


IInterchange::Submit メソッド [C++]

Interchange.Submit メソッド [Visual Basic]

Submit メソッドは、非同期処理のために BizTalk Server 2000 にドキュメントを送信します。BizTalk Server 2000 は、利用できる次のサーバーで処理できるまで、キューにドキュメントを格納します。

構文

[C++]

HRESULT Submit(
BIZTALK_OPENNESS_TYPE lOpenness,
 BSTR Document,
 BSTR DocName,
 BSTR SourceQualifier,
 BSTR SourceID,
 BSTR DestQualifier,
 BSTR DestID,
 BSTR ChannelName,
 BSTR FilePath,
 BSTR EnvelopeName,
 long PassThrough,
 BSTR* SubmissionHandle
);

[Visual Basic]

object.Submit( _
lOpenness As BIZTALK_OPENNESS_TYPE, _
 Document As String, _
 DocName As String, _
 SourceQualifier As String, _
 SourceID As String, _
 DestQualifier As String, _
 DestID As String, _
 ChannelName As String, _
 FilePath As String, _
 EnvelopeName As String, _
 PassThrough As Long _
)

パラメータ

[C++]

lOpenness

[in] 関連付けられている BizTalkPort オブジェクトを開くことができるかどうかを示す列挙値です。有効な値は BIZTALK_OPENNESS_TYPE 列挙からの値です。

Document

[in] 送信されたドキュメント インスタンスを含む BSTR です。このパラメータは、ドキュメントまたはインターチェンジとしての文字列バッファのみ受け入れます。これは、アプリケーションがほかのオブジェクト (DOM オブジェクト、CDictionary オブジェクト、ADO オブジェクト、またはほかのデータ型やオブジェクト型) を送信できないことを示します。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。このパラメータは省略可能です。

DocName

[in] 送信するドキュメントのインスタンスと関連付けられた BizTalkDocument オブジェクトの名前を含む BSTR です。lOpenness パラメータが BIZTALK_OPENNESS_TYPE_SOURCE に設定されている場合は、仕様が X12 または EDIFACT である入力 BizTalkDocument オブジェクトを選択できます。ただし、その場合、出力 BizTalkDocument の仕様として X12 や EDIFACT を指定することはできません。lOpenness が BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合は、BizTalkDocument オブジェクトの仕様として X12 や EDIFACT を指定することはできません。DocName パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

SourceQualifier

[in] 送信元組織の修飾子を含む BSTR です。これは、SourceID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。SourceID を指定する必要があります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。SourceQualifier パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

SourceID

[in] 送信元組織の修飾子の値を含む BSTR です。たとえば、SourceQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenSrc に設定されている場合、SourceID は送信元組織の名前として解釈されます。SourceID パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

DestQualifier

[in] 送信先組織の修飾子を含む BSTR です。これは、DestID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。DestID を指定する必要があります。すべての新しい組織の規定の修飾子は OrganizationName で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。DestQualifier パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

DestID

[in] 送信先組織の修飾子の値を含む BSTR です。たとえば、DestQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenDest に設定されている場合、DestID は送信先アドレスとして使用されます。メッセージ キューが送信先アドレスとして指定されている場合は、オープンなメッセージ ポートに queue:// プレフィックスを使用する必要があります。DestID パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

ChannelName

[in] このドキュメントに対して実行される BizTalkChannel オブジェクトの名前を含む BSTR です。これは、パーサーが実行対象のメッセージ ポートとチャネルの組を決定するという通常の処理をバイパスするもので、実行はパラメータまたはドキュメントのルーティング情報に基づいて行われます。このパラメータは、PassThrough パラメータが TRUE に設定されていない場合は省略可能です。

FilePath

[in] 送信対象のドキュメントを含む完全修飾パスを示す BSTR です。ドキュメントを文字列として直接送信しません。BizTalk Server 2000 では、URL、UNC、<ドライブ名>: の書式のみサポートしています。ドキュメントが FilePath パラメータで示されるファイルとして送信される場合は、BizTalk Server 2000 がファイルを作業キューに適切にコピーした後で、呼び出しが正常に戻ります。このメソッドが正常に戻ったらすぐに、指定したパスからファイルを削除してください。FilePath でデータを指定してサーバーにドキュメントを送信するときに、利用できないリモート サーバーにファイルの格納場所がある場合、UNC パスが無効な場合、または SQL サーバーがダウンしている場合は、Submit に 30 秒以上かかることがあります。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。FilePath パラメータは、PassThrough パラメータが TRUE に設定され、マップが指定されている場合は使用できません。このパラメータは省略可能です。

EnvelopeName

[in] インターチェンジをドキュメントに分割するために使用するエンベロープ仕様の名前を含む BSTR です。このパラメータで名前が指定されるエンベロープには、有効なインターチェンジ仕様がある必要があります。この要件は、カスタム XML 書式で作成されるエンベロープにも同様に適用されます。フラット ファイルを BizTalk Server 2000 に送信する場合は、このフラット ファイルに対してエンベロープを作成し、EnvelopeName でそのエンベロープの名前を指定する必要があります。このパラメータは省略可能です。

PassThrough

[in] サーバーによるドキュメントの処理方法を示す Long です。このパラメータが TRUE に設定されている場合は、ドキュメントの暗号解読、デコード、署名検証は行われません。FALSE に設定されている場合は、ドキュメントの暗号解読、デコード、署名検証が行われます。パススルー送信モード (TRUE) を使用する場合は、BIZTALK_OPENNESS_TYPE の値が BIZTALK_OPENNESS_TYPE_NOTOPEN に設定され、ChannelName パラメータが指定されている必要があります。また、DocName、SourceQualifier、SourceID、DestQualifier、および DestID の各パラメータを、パススルー送信モードで指定することはできません。パススルー送信モードは、バイナリ ファイルを交換する場合またはサーバー トランスポートとグローバル追跡の機能だけが使用されている場合に、データの破損を防ぐために使用されます。

SubmissionHandle

[out, retval] 送信するドキュメントまたはインターチェンジの一意な識別子を含む BSTR へのポインタです。このハンドルは、追跡データベースにクエリを発行し、送信されるインターチェンジやドキュメントのステータスを確認するために使用できます。複数のドキュメントが送信されても (インターチェンジ)、返されるハンドルは 1 つです。ただし、追跡データベースは、このインターチェンジ識別子に関連するすべての子ドキュメントのステータスにアクセスできます。

[Visual Basic]

lOpenness

関連付けられている BizTalkPort オブジェクトを開くことができるかどうかを示す列挙値です。有効な値は BIZTALK_OPENNESS_TYPE 列挙からの値です。

Document

送信されるドキュメント インスタンスを含む文字列です。このパラメータは、ドキュメントまたはインターチェンジとしての文字列バッファのみ受け入れます。これは、アプリケーションがほかのオブジェクト (DOM オブジェクト、CDictionary オブジェクト、ADO オブジェクト、またはほかのデータ型やオブジェクト型) を送信できないことを示します。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。このパラメータは省略可能です。

DocName

送信するドキュメントのインスタンスと関連付けられた BizTalkDocument オブジェクトの名前を含む文字列です。lOpenness パラメータが BIZTALK_OPENNESS_TYPE_SOURCE に設定されている場合は、仕様が X12 または EDIFACT である入力 BizTalkDocument オブジェクトを選択できます。ただし、その場合、出力 BizTalkDocument の仕様として X12 や EDIFACT を指定することはできません。lOpenness が BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合は、BizTalkDocument オブジェクトの仕様として X12 や EDIFACT を指定することはできません。DocName パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

SourceQualifier

送信元組織の修飾子を含む文字列です。これは、SourceID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。SourceID を指定する必要があります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。SourceQualifier パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

SourceID

送信元組織の修飾子の値を含む文字列です。たとえば、SourceQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenSrc に設定されている場合、SourceID は送信元組織の名前として解釈されます。SourceID パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

DestQualifier

送信先組織の修飾子を含む文字列です。これは、DestID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。DestID を指定する必要があります。すべての新しい組織の規定の修飾子は OrganizationName で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。DestQualifier パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

DestID

送信先組織の修飾子の値を含む文字列です。たとえば、DestQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenDest に設定されている場合、DestID は送信先アドレスとして使用されます。メッセージ キューが送信先アドレスとして指定されている場合は、オープンなメッセージ ポートに queue:// プレフィックスを使用する必要があります。DestID パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

ChannelName

このドキュメントで実行される BizTalkChannel オブジェクトの名前を含む文字列です。これは、パーサーが実行対象のメッセージ ポートとチャネルの組を決定するという通常の処理をバイパスするもので、実行はパラメータまたはドキュメントのルーティング情報に基づいて行われます。このパラメータは、PassThrough パラメータが True に設定されていない場合は省略可能です。

FilePath

送信対象のドキュメントを含む完全修飾パスを示す文字列です。ドキュメントを文字列として直接送信しません。BizTalk Server 2000 では、URL、UNC、<ドライブ名>: の書式のみサポートしています。ドキュメントが FilePath パラメータで示されるファイルとして送信される場合は、BizTalk Server 2000 がファイルを作業キューに適切にコピーした後で、呼び出しが正常に戻ります。このメソッドが正常に戻ったらすぐに、指定したパスからファイルを削除してください。FilePath でデータを指定してサーバーにドキュメントを送信するときに、利用できないリモート サーバーにファイルの格納場所がある場合、UNC パスが無効な場合、または SQL サーバーがダウンしている場合は、Submit に 30 秒以上かかることがあります。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。FilePath パラメータは、PassThrough パラメータが True に設定され、マップが指定されている場合は使用できません。このパラメータは省略可能です。

EnvelopeName

インターチェンジをドキュメントに分割するために使用するエンベロープ仕様の名前を含む文字列です。引数として名前が指定されるエンベロープには、有効なインターチェンジ仕様がある必要があります。この要件は、カスタム XML 書式で作成されるエンベロープにも同様に適用されます。フラット ファイルを BizTalk Server 2000 に送信する場合は、このフラット ファイルに対してエンベロープを作成し、EnvelopeName でそのエンベロープの名前を指定する必要があります。このパラメータは省略可能です。

PassThrough

サーバーによるドキュメントの処理方法を示す Long です。このパラメータが True の場合は、ドキュメントの暗号解読、デコード、署名検証は行われません。False に設定されている場合は、ドキュメントの暗号解読、デコード、署名検証が行われます。パススルー送信モード (True) を使用する場合は、BIZTALK_OPENNESS_TYPE の値が BIZTALK_OPENNESS_TYPE_NOTOPEN に設定され、ChannelName パラメータが指定されている必要があります。また、DocName、SourceQualifier、SourceID、DestQualifier、および DestID の各パラメータを、パススルー送信モードで指定することはできません。パススルー送信モードは、バイナリ ファイルを交換する場合またはサーバー トランスポートとグローバル追跡の機能だけが使用されている場合に、データの破損を防ぐために使用されます。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、送信するドキュメントまたはインターチェンジの一意な識別子を含む文字列を返します。このハンドルは、追跡データベースにクエリを発行し、送信されるインターチェンジやドキュメントのステータスを確認するために使用できます。複数のドキュメントが送信されても (インターチェンジ)、返されるハンドルは 1 つです。ただし、追跡データベースは、このインターチェンジ識別子に関連するすべての子ドキュメントのステータスにアクセスできます。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : cisapi.h をインクルードします。
ライブラリ : (cisapi.tlb)

関連項目

オープンネス

ルーティング

送信

COM インターフェイスの使用によるドキュメント送信の手順


IInterchange::SubmitSync メソッド [C++]

Interchange.SubmitSync メソッド [Visual Basic]

SubmitSync メソッドは、同期処理のために BizTalk Server 2000 にインターチェンジまたはドキュメントを送信します。オプションの応答ドキュメントが呼び出し元に返されます。

構文

[C++]

HRESULT SubmitSync(
BIZTALK_OPENNESS_TYPE lOpenness,
 BSTR Document,
 BSTR DocName,
 BSTR SourceQualifier,
 BSTR SourceID,
 BSTR DestQualifier,
 BSTR DestID,
 BSTR ChannelName,
 BSTR FilePath,
 BSTR EnvelopeName,
long PassThrough,
 VARIANT* SubmissionHandle,
 VARIANT* ResponseDocument
);

[Visual Basic]

object.SubmitSync( _
lOpenness As BIZTALK_OPENNESS_TYPE, _
 Document As String, _
 DocName As String, _
 SourceQualifier As String, _
 SourceID As String, _
 DestQualifier As String, _
 DestID As String, _
 ChannelName As String, _
 FilePath As String, _
 EnvelopeName As String, _
PassThrough As Long, _
 SubmissionHandle As Variant, _
ResponseDocument As Variant _
)

パラメータ

[C++]

lOpenness

[in] 関連付けられている BizTalkPort オブジェクトを開くことができるかどうかを示す列挙値です。有効な値は BIZTALK_OPENNESS_TYPE 列挙からの値です。

Document

[in] 送信されたドキュメント インスタンスを含む BSTR です。このパラメータは、ドキュメントまたはインターチェンジとしての文字列バッファのみ受け入れます。これは、アプリケーションがほかのオブジェクト (DOM オブジェクト、CDictionary オブジェクト、ADO オブジェクト、またはほかのデータ型やオブジェクト型) を送信できないことを示します。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。このパラメータは省略可能です。

DocName

[in] 送信するドキュメントのインスタンスと関連付けられた BizTalkDocument オブジェクトの名前を含む BSTR です。lOpenness パラメータが BIZTALK_OPENNESS_TYPE_SOURCE に設定されている場合は、仕様が X12 または EDIFACT である入力 BizTalkDocument オブジェクトを選択できます。ただし、その場合、出力 BizTalkDocument の仕様として X12 や EDIFACT を指定することはできません。lOpenness が BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合は、BizTalkDocument オブジェクトの仕様として X12 や EDIFACT を指定することはできません。DocName パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

SourceQualifier

[in] 送信元組織の修飾子を含む BSTR です。これは、SourceID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。SourceID を指定する必要があります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。SourceQualifier パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

SourceID

[in] 送信元組織の修飾子の値を含む BSTR です。たとえば、SourceQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenSrc に設定されている場合、SourceID は送信元組織の名前として解釈されます。SourceID パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

DestQualifier

[in] 送信先組織の修飾子を含む BSTR です。これは、DestID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。DestID パラメータを指定する必要があります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。DestQualifier パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

DestID

[in] 送信先組織の修飾子の値を含む BSTR です。たとえば、DestQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenDest に設定されている場合、DestID は送信先アドレスとして使用されます。メッセージ キューが送信先アドレスとして指定されている場合は、オープンなメッセージ ポートに queue:// プレフィックスを使用する必要があります。DestID パラメータは、PassThrough パラメータが TRUE に設定されている場合は使用できません。このパラメータは省略可能です。

ChannelName

[in] このドキュメントに対して実行される BizTalkChannel オブジェクトの名前を含む BSTR です。これは、パーサーが実行対象のメッセージ ポートとチャネルの組を決定するという通常の処理をバイパスするもので、実行はパラメータまたはドキュメントのルーティング情報に基づいて行われます。このパラメータは、PassThrough パラメータが TRUE に設定されていない場合は省略可能です。

FilePath

[in] 送信対象のドキュメントを含む完全修飾パスを示す BSTR です。ドキュメントを文字列として直接送信しません。BizTalk Server 2000 では、URL、UNC、<ドライブ名>: の書式のみサポートしています。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。FilePath パラメータは、PassThrough パラメータが TRUE に設定され、マップが指定されている場合は使用できません。このパラメータは省略可能です。

EnvelopeName

[in] インターチェンジをドキュメントに分割するために使用するエンベロープ仕様の名前を含む BSTR です。このパラメータで名前が指定されるエンベロープには、有効なインターチェンジ仕様がある必要があります。この要件は、カスタム XML 書式で作成されるエンベロープにも同様に適用されます。このパラメータは省略可能です。

PassThrough

[in] サーバーによるドキュメントの処理方法を示す Long です。このパラメータが TRUE に設定されている場合は、ドキュメントの暗号解読、デコード、署名検証は行われません。FALSE に設定されている場合は、ドキュメントの暗号解読、デコード、署名検証が行われます。パススルー送信モード (TRUE) を使用する場合は、BIZTALK_OPENNESS_TYPE の値が BIZTALK_OPENNESS_TYPE_NOTOPEN に設定され、ChannelName パラメータが指定されている必要があります。また、DocName、SourceQualifier、SourceID、DestQualifier、および DestID の各パラメータを、パススルー送信モードで指定することはできません。パススルー送信モードは、バイナリ ファイルを交換する場合またはサーバー トランスポートとグローバル追跡の機能だけが使用されている場合に、データの破損を防ぐために使用されます。

SubmissionHandle

[out] 送信するドキュメントまたはインターチェンジの一意な識別子を含む BSTR へのポインタです。このハンドルは、追跡データベースにクエリを発行し、送信されるインターチェンジやドキュメントのステータスを確認するために使用できます。複数のドキュメントが送信されても (インターチェンジ)、返されるハンドルは 1 つです。ただし、追跡データベースは、このインターチェンジ識別子に関連するすべての子ドキュメントのステータスにアクセスできます。

ResponseDocument

[out] オプションの応答ドキュメントを含む VARIANT へのポインタです。

[Visual Basic]

lOpenness

関連付けられている BizTalkPort オブジェクトを開くことができるかどうかを示す列挙値です。有効な値は BIZTALK_OPENNESS_TYPE 列挙からの値です。

Document

送信されるドキュメント インスタンスを含む文字列です。このパラメータは、ドキュメントまたはインターチェンジとしての文字列バッファのみ受け入れます。これは、アプリケーションがほかのオブジェクト (DOM オブジェクト、CDictionary オブジェクト、ADO オブジェクト、またはほかのデータ型やオブジェクト型) を送信できないことを示します。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。このパラメータは省略可能です。

DocName

送信するドキュメントのインスタンスと関連付けられた BizTalkDocument オブジェクトの名前を含む文字列です。lOpenness パラメータが BIZTALK_OPENNESS_TYPE_SOURCE に設定されている場合は、仕様が X12 または EDIFACT である入力 BizTalkDocument オブジェクトを選択できます。ただし、その場合、出力 BizTalkDocument の仕様として X12 や EDIFACT を指定することはできません。lOpenness が BIZTALK_OPENNESS_TYPE_DESTINATION に設定されている場合は、BizTalkDocument オブジェクトの仕様として X12 や EDIFACT を指定することはできません。DocName パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

SourceQualifier

送信元組織の修飾子を含む文字列です。これは、SourceID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。SourceID を指定する必要があります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。SourceQualifier パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

SourceID

送信元組織の修飾子の値を含む文字列です。たとえば、SourceQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenSrc に設定されている場合、SourceID は送信元組織の名前として解釈されます。SourceID パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

DestQualifier

送信先組織の修飾子を含む文字列です。これは、DestID パラメータがどのように解釈されるかを示します。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。DestID を指定する必要があります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。DestQualifier パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

DestID

送信先組織の修飾子の値を含む文字列です。たとえば、DestQualifier パラメータが Telephone である場合、この値は電話番号になります。Openness フラグが OpenDest に設定されている場合、DestID は送信先アドレスとして使用されます。メッセージ キューが送信先アドレスとして指定されている場合は、オープンなメッセージ ポートに queue:// プレフィックスを使用する必要があります。DestID パラメータは、PassThrough パラメータが True に設定されている場合は使用できません。このパラメータは省略可能です。

ChannelName

このドキュメントで実行される BizTalkChannel オブジェクトの名前を含む文字列です。これは、パーサーが実行対象のメッセージ ポートとチャネルの組を決定するという通常の処理をバイパスするもので、実行はパラメータまたはドキュメントのルーティング情報に基づいて行われます。このパラメータは、PassThrough パラメータが True に設定されていない場合は省略可能です。

FilePath

送信対象のドキュメントを含む完全修飾パスを示す文字列です。ドキュメントを文字列として直接送信しません。BizTalk Server 2000 では、URL、UNC、<ドライブ名>: の書式のみサポートしています。Document パラメータまたは FilePath パラメータのいずれか 1 つを指定します。両方指定することはできません。FilePath パラメータは、PassThrough パラメータが True に設定され、マップが指定されている場合は使用できません。このパラメータは省略可能です。

EnvelopeName

インターチェンジをドキュメントに分割するために使用するエンベロープ仕様の名前を含む文字列です。このパラメータで名前が指定されるエンベロープには、有効なインターチェンジ仕様がある必要があります。この要件は、カスタム XML 書式で作成されるエンベロープにも同様に適用されます。このパラメータは省略可能です。

PassThrough

サーバーによるドキュメントの処理方法を示す Long です。このパラメータが True の場合は、ドキュメントの暗号解読、デコード、署名検証は行われません。False に設定されている場合は、ドキュメントの暗号解読、デコード、署名検証が行われます。パススルー送信モード (True) を使用する場合は、BIZTALK_OPENNESS_TYPE の値が BIZTALK_OPENNESS_TYPE_NOTOPEN に設定され、ChannelName パラメータが指定されている必要があります。また、DocName、SourceQualifier、SourceID、DestQualifier、および DestID の各パラメータを、パススルー送信モードで指定することはできません。パススルー送信モードは、バイナリ ファイルを交換する場合またはサーバー トランスポートとグローバル追跡の機能だけが使用されている場合に、データの破損を防ぐために使用されます。

SubmissionHandle

送信するドキュメントまたはインターチェンジの一意な識別子を含む Variant です。このハンドルは、追跡データベースにクエリを発行し、送信されるインターチェンジやドキュメントのステータスを確認するために使用できます。複数のドキュメントが送信されても (インターチェンジ)、返されるハンドルは 1 つです。ただし、追跡データベースは、このインターチェンジ識別子に関連するすべての子ドキュメントのステータスにアクセスできます。

ResponseDocument

オプションの応答ドキュメントを含む Variant です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

SubmitSync は提供された場合にオプションの応答ドキュメントを返します。応答が返されない場合は、その呼び出しは正常に返されますが、応答はなく、HRESULT 値は S_FALSE になります。送信先が別の BizTalk Server の場合は、応答を返すために ASP ページを使用する必要があります。

同期インターチェンジは、すべてのキューをバイパスし、呼び出し元のスレッドのメッセージ ポートで必要とされるすべてのコンポーネントを実行します。同期プロトコル (HTTP と AIC) では、利用できる場合にはオプションの応答ドキュメントが返されます。このメソッドは、単一チャネル一致にのみ有効です。複数チャネルを一致させるようにパラメータが設定されている場合、同期送信は、複数チャネルの一致が同期送信で許可されていないことを示すエラーを返します。このメソッドは、単一ドキュメント インターチェンジにのみ使用されます。送信に複数のドキュメントが含まれる場合、同期送信は、複数ドキュメントの送信が許可されていないことを示すエラーを返します。このメソッドは、ポート グループをサポートしていません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : cisapi.h をインクルードします。
ライブラリ : (cisapi.tlb)

関連項目

オープンネス

ルーティング

送信

COM インターフェイスの使用によるドキュメント送信の手順


インターチェンジの列挙

以下の列挙について、プロパティとパラメータの値を説明します。

  • CISReasonToQueue


CISReasonToQueue

CISReasonToQueue 列挙は、BizTalk Server をインストールしたドライブの Program Files\Microsoft BizTalk Server\SDK\Include フォルダにある cisapi.h ヘッダー ファイルで定義されています。

CISReasonToQueue 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
noReason | 0 | このリリースではサポートされていません。
rtdlqParserFailure | 1 | パーサーの障害のために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqParserDocFailure | 2 | ビジネス ドキュメントが無効であるために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqDocValidation | 3 | ドキュメントの検証に失敗したために、ドキュメントがキューに格納されたことを示します。
rtdlqChannelSelectFailure | 4 | 正しい BizTalkChannel オブジェクトの選択に失敗したために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqInvalidMap | 5 | BizTalkChannel オブジェクトによって参照されるマップが正しく書式設定されていないために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqFieldTrackingFailure | 6 | ドキュメント内に要求されるフィールドをサーバーが追跡できないために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqMappingFailure | 7 | 変換の失敗のために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqSerializerFailure | 8 | サーバーがドキュメントをネイティブ形式に変換できなかったために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqEncodingFailure | 9 | サーバーがインターチェンジをエンコードできなかったために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqSigningFailure | 10 | サーバーがインターチェンジに署名できなかったために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqEncryptionFailure | 11 | サーバーがインターチェンジを暗号化できなかったために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqTransmissionFailure | 12 | サーバーがドキュメントを配信できなかったために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqUserMove | 13 | 管理者がドキュメントのこのインスタンスをキューに移動したことを示します。
rtdlqTimeout | 14 | タイムアウトが発生したために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqCustomCompFailure | 15 | カスタム コンポーネントの障害のために、ドキュメントのインスタンスがキューに格納されたことを示します。
unkReason | 16 | この項目が、アクティブでないサーバーによって "処理中" であるとマークされたことを示します。サーバーの再起動時に、この項目は自動的に保留キューに移動されました。処理元のサーバーで重大なエラーが発生した可能性があります。詳細については、システム管理者に問い合わせてください。
rtdlqNoChannel | 17 | BizTalkChannel オブジェクトが削除されたために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqMissingChannel | 18 | IInterchange インターフェイスの Submit メソッドによって指定された BizTalkChannel オブジェクトが見つからないために、ドキュメントのインスタンスがキューに格納されたことを示します。
rtdlqInvalidChannel | 19 | IInterchange インターフェイスの Submit メソッドによって指定された BizTalkChannel オブジェクトが、オープンな BizTalkPort オブジェクトを指定しているために、ドキュメントのインスタンスがキューに格納されたことを示します。これは許可されていません。
rtdlqOutOfMemory | 20 | コンピュータのメモリが不足していることを示します。再起動してください。
rtdlqBTFRecReqExpired | 21 | BTF タイムスタンプ receiptRequiredBy の有効期限が切れているために、ドキュメントがキューに格納されたことを示します。
rtdlqBTFExpiresAtExpired | 22 | BTF タイムスタンプ expiresAt の有効期限が切れているために、ドキュメントがキューに格納されたことを示します。
rtdlqCorrelationFailure | 23 | ドキュメントの受信に失敗したことを示します。


概念

ここでは、Microsoft BizTalk Server 2000 にドキュメントを送信する方法を理解するうえで重要な概念について説明します。次のトピックが含まれます。

  • 送信

  • 保留キューへのアクセス

  • ルーティング

  • 受信機能でのドキュメントの前処理

  • COM インターフェイスの使用によるドキュメント送信の手順


送信

すべてのドキュメントは、処理のために IInterchange インターフェイスの Submit メソッドまたは SubmitSync メソッドを使用して、Microsoft BizTalk Server 2000 に送信する必要があります。アプリケーションが Microsoft Windows ベースのもので、COM オブジェクトのメソッドを呼び出すことができる場合は、直接ドキュメントを送信できます。業務用アプリケーションは、IInterchange インターフェイスの Submit メソッドまたは SubmitSync メソッドを呼び出して、パラメータとして提供する文字列でドキュメントまたはドキュメントのファイル パスを渡します。これは追加の構成が不要なため、最も簡単な方法です。ただし、この方法では、業務用アプリケーションが BizTalk Server 2000 への直接呼び出しをサポートするように設計されていることが必要です。

アプリケーションが COM オブジェクトのメソッドを呼び出すことができない場合は、受信機能を使用して、BizTalk Server にドキュメントを送信できます。受信機能を使用すると、アプリケーションは BizTalk Server 2000 が監視している特定の場所にドキュメントまたはインターチェンジをポストできます。これらの場所は、特定の受信機能に従って定義されます。各受信機能は、イベントベースの監視を使用して、ドキュメントまたはインターチェンジの存在を認識します。受信機能は、データを受信すると、そのデータを BizTalk Server 2000 に送信します。たとえば、業務用アプリケーションがドキュメントをファイルとして保存できるが、直接そのドキュメントを送信できない場合に、ファイル受信機能が BizTalk Server 2000 にドキュメントを送信するように構成できます。受信機能の追加と構成の詳細については、「サーバー グループの受信機能の管理」を参照してください。

受信機能は、特定のディレクトリまたはキューを継続的に監視し、受信したファイルを表示して BizTalk Server 2000 に送信するように構成するものです。HTTP プロトコルと SMTP プロトコルは、BizTalk Server 2000 の外部で構成します。これらのトランスポート サービス用のスクリプト ページを作成する必要があります。

注

  • ログ機能を使用するインターチェンジとドキュメントにはサイズに制限があり、制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

  • BizTalk Server にドキュメントを送信するために IInterchange インターフェイスを使用するスクリプトまたはアプリケーションは、任意のユーザー アカウントで実行できます。

  • BizTalk Framework 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2000 はエンドポイントと考えてください。アプリケーションまたは取引先から、BizTalk Framework 2.0 に準拠したドキュメントが BizTalk Server 2000 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

    <prop:identity>

    <prop:sentAt>

    <expiresAt>

    • 受信情報サブセクション :

    <sendTo>

    <address>

    <sendReceiptBy>

コード例については、「BizTalk メッセージ サービスのコード サンプル」を参照してください。

BizTalk Server 2000 への非同期的なドキュメントの送信

BizTalk Server 2000 に非同期的にドキュメントを送信するアプリケーションは、Submit を呼び出します。受信機能も Submit を呼び出します。Submit は、ドキュメントを送信した後に戻り値を返します。プロトコルによってサポートされていないため、応答ドキュメントは返されません。

Submit は、ドキュメントまたはインターチェンジとしての文字列バッファまたはファイル パスのみ受け入れます。BizTalk Server 2000 では、UNC 形式とローカル ファイル パス形式をサポートしています。

BizTalk Server 2000 への同期的なドキュメントの送信

BizTalk Server 2000 に同期的にドキュメントを送信するアプリケーションは、SubmitSync を呼び出します。

同期インターチェンジは、すべてのキューをバイパスし、呼び出し元のスレッドのメッセージ ポートで必要とされるすべてのコンポーネントを実行します。同期プロトコルでは、利用できる場合にはオプションの応答ドキュメントが返されます。このメソッドは、単一チャネル一致にのみ有効です。複数チャネルを一致させるようにパラメータが設定されている場合、同期送信は、複数チャネルの一致が同期送信で許可されていないことを示すエラーを返します。このメソッドは、単一ドキュメント インターチェンジにのみ使用されます。送信に複数のドキュメントが含まれる場合、同期送信は、複数ドキュメントの送信が許可されていないことを示すエラーを返します。このメソッドは、ポート グループをサポートしていません。

SubmitSync は、ドキュメントまたはインターチェンジとしての文字列バッファまたはファイル パスのみ受け入れます。BizTalk Server 2000 では、UNC 形式とローカル ファイル パス形式をサポートしています。

Submit メソッドと SubmitSync メソッドでのエラー処理

BizTalk Server 2000 にインターチェンジまたはドキュメントを送信するときにエラーが発生した場合は、イベント ログ エントリが作成されるか、または呼び出し元にエラーが返されます。これは、呼び出されたメソッドと障害の性質によって異なります。送信されたドキュメントは、状況によっては、保留キューに格納されることがあります。次の表は、送信された 1 つ以上のドキュメントまたはインターチェンジが、送信中のエラーのために保留キューに格納される場合の結果について示しています。

呼び出されるメソッド | 呼び出し元に返されるエラー | イベント ログ エントリ
Submit | ドキュメント失敗エラー | 処理中に障害が発生したすべてのドキュメント
SubmitSync | ドキュメント失敗エラー | なし

関連項目

ルーティング

COM インターフェイスの使用によるドキュメント送信の手順

ドキュメント送信に関するリファレンス


保留キューへのアクセス

保留キューには、解析エラー、シリアライズ エラー、送信の失敗、またはチャネル構成を見つけられないことなど、さまざまな理由で処理が失敗した作業項目が含まれます。提供されるインターフェイスを使用して、キューから項目を取り出したり、削除することができます。

注

  • 保留キューの項目にアクセスする場合、または項目を削除する場合、スクリプトまたはアプリケーションは BizTalk Server Administrators グループのユーザー アカウントで実行する必要があります。BizTalk Server Administrators グループは、BizTalk Server 2000 がインストールされると作成されます。このグループには、必要に応じてユーザーを追加することができます。

保留キューからの項目の取得

保留キューから項目を取得するには、アプリケーションは IInterchange インターフェイスの CheckSuspendedQueue メソッドを呼び出します。

CheckSuspendedQueue は、メソッドのパラメータによって指定される検索条件を満たす保留キューの項目の一覧を取得します。これは、後に IInterchange インターフェイスの DeleteFromSuspendedQueue メソッドまたは GetSuspendedQueueItemDetails メソッドを呼び出すために使用するハンドルの一覧を返します。

保留キューからの項目詳細の取得

CheckSuspendedQueue は、保留キューにある項目へのハンドルの一覧を返します。これらの項目を処理するには、GetSuspendedQueueItemDetails を使用して、保留キューの各項目と関連付けられている項目詳細を取得する必要があります。

GetSuspendedQueueItemDetails は、保留キューの項目についての詳細を取得します。このメソッドが (CheckSuspendedQueue の呼び出し時とこのメソッドの呼び出し時の間に当該項目が削除されたことなどのために)、項目についての個々の詳細を返さない場合は、特定できない各パラメータが返されます。

保留キューからの項目の削除

保留キューから項目を削除するには、アプリケーションは DeleteFromSuspendedQueue を呼び出します。

DeleteFromSuspendedQueue は、メソッドのパラメータによって指定される検索条件を満たす保留キューから項目の一覧を削除します。


ルーティング

ドキュメントを処理するには、Microsoft BizTalk Server 2000 は受信ドキュメント インスタンスを処理する方法を制御する規則を読み込む必要があります。これらの規則をチャネルといいます。特定の BizTalkChannel オブジェクトは BizTalkPort オブジェクトと関連付けられ、2 つの組織を接続します。

受信ドキュメントを処理するチャネルを検出するには、サーバーには送信元組織、送信先組織、およびドキュメント定義が必要です。サーバーは、次のいずれかの方法でこの情報を取得できます。

  • この情報は、ドキュメント自体のコンテンツに含まれるルーティング フィールドのデータから検出されることがあります (セルフルーティング ドキュメント)。

  • この情報は、IInterchange インターフェイスの Submit メソッドのパラメータ一覧で明示的に宣言されることがあります (呼び出しベース ルーティング)。

  • この情報は、カスタム受信機能のプロパティで明示的に宣言されることがあります。受信機能の詳細については、「受信機能とドキュメント ルーティングについて」を参照してください。

  • Submit を呼び出すときに使用するチャネルを指定するように選択できます。これにより、サーバーはチャネル選択処理をバイパスします。

サーバーは、この情報を取得すると、そのルーティング基準と一致するメッセージ ポートとチャネルの組を検索します。複数のチャネルが一致する場合は、各チャネルが処理され、複数のドキュメントが出力されることがあります。

呼び出しベース ルーティング

呼び出しベース ルーティングでは、送信元組織識別子 (SourceID)、送信先組織識別子 (DestID)、およびドキュメント定義の名前 (DocName) を Submit のパラメータとして指定します。SourceQualifier と DestQualifier が指定されていない場合は、それらは既定で OrganizationName になり、データベース内の組織の名前を参照します。BizTalk フレームワーク 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。Openness フラグが OpenDest に設定されている場合、DestID は送信先アドレスとして使用されます。SourceID、DestID、または DocName が空白のままの場合は、不足している情報はドキュメントに含まれるルーティング情報から取得されます。いずれかのパラメータやフィールドが Submit にもドキュメントにも存在しない場合は、そのドキュメントは保留キューに格納されます。

注

  • メッセージ キューが送信先アドレスとして指定されている場合は、オープンなメッセージ ポートに queue:// プレフィックスを使用する必要があります。

セルフルーティング ドキュメント

セルフルーティング ドキュメントには、ドキュメント仕様に基づくルーティング タグで定義される送信元識別子 (SourceID フィールド)、送信先組織識別子 (DestID フィールド)、およびドキュメント定義の名前 (DocName フィールド) があり、これらは <SelectionFields> タグで囲まれて示されます。SourceQualifier と DestQualifier が指定されていない場合は、それらは既定で OrganizationName になり、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。BizTalk Framework 仕様はまた、BizTalk Framework 準拠メッセージのルーティング タグも定義しています。これらのタグは、ルート <biztalk> タグの下で、<header> タグに含まれる <route> タグの下の <to> タグと <from> タグとして定義されています。<body> タグの下の最初のタグは、ドキュメント型を特定します。詳細については、『BizTalk Framework 2.0 Independent Document Messaging Specification』を参照してください。ANSI X12 ルーティングまたは EDIFACT ルーティングでは、ルーティング フィールドの場所はハードコードされ、ドキュメント仕様で指定されていません。


受信機能でのドキュメントの前処理

ドキュメントは、受信機能を使用して、処理のために BizTalk Server 2000 に送信できます。ほかのアプリケーションは、このメカニズムを使用して、それぞれの出力ファイルを指定されたディレクトリまたはメッセージ キューに送信できます。BizTalk Server は、指定された場所を定期的に監視し、その場所に格納されるファイルまたはメッセージを処理します。BizTalk Server は、カスタム プリプロセッサ コンポーネントを作成するためのインターフェイスを提供します。これらのコンポーネントは、処理のためにデータを BizTalk Server に送信する前に、受信機能によって選択されるファイルまたはメッセージを処理します。

カスタム プリプロセッサ コンポーネントは、レジストリにカテゴリ識別子 (CATID)、CATID_BIZTALK_CUSTOM_PROCESS を実装するために必要です。これにより、BizTalk Server 管理コンソールのユーザー インターフェイスは、カスタム プリプロセッサを認識し、選択対象として [プリプロセッサ] ボックスの一覧に表示することができます。

詳細については、「IBTSCustomProcess」と「IBTSCustomProcessContext」を参照してください。

関連項目

BizTalk Server 管理コンソールのユーザー インターフェイス

受信機能


COM インターフェイスの使用によるドキュメント送信の手順

IInterchange インターフェイスで BizTalk Server にドキュメントを送信するには、次の操作を行います。

  1. 送信元組織、送信先組織、およびドキュメント定義名が、IInterchange インターフェイスの Submit メソッドまたは SubmitSync メソッドのパラメータで指定されるか、それともドキュメントに含まれるかを特定します。両方で指定する場合もあります。
    • この情報は、Submit または SubmitSync のパラメータ一覧で明示的に宣言されることがあります (呼び出しベース ルーティング)。

      1 つ以上のパラメータを空白のままにして、不足している情報はドキュメントに含まれるルーティング情報から取得できます。

    • この情報は、ドキュメント自体のコンテンツに含まれるルーティング フィールドのデータから検出されることがあります (セルフルーティング ドキュメント)。

    • Submit を呼び出す場合に使用する特定のチャネルを明示的に指定するように選択できます。これにより、サーバーはチャネルの選択をバイパスします。

    • この情報は、カスタム受信機能のプロパティで明示的に宣言されることがあります。
  2. 非同期的に送信するか、同期的に送信するかを決定します。
    • パラメータとして指定する文字列でドキュメントまたはドキュメントのファイル パスを渡して、Submit を呼び出します。BizTalk Server 2000 では、ファイル パスの書式として、URL、UNC、<ドライブ名>: の書式のみサポートしています。

      Submit はドキュメントまたはインターチェンジとして、文字列変数だけを受け入れます。

    • パラメータとして指定する文字列でドキュメントまたはドキュメントのファイル パスを渡し、SubmitSync を呼び出します。
      • 利用できる場合には、応答ドキュメントが返されます。

      • このメソッドは、単一チャネル一致にのみ有効です。

      • このメソッドは、単一ドキュメント インターチェンジにのみ使用されます。
  3. 保留キュー メソッドを呼び出すかどうかを決定します。これはオプションで、同じアプリケーションまたは別のアプリケーションに実装できます。
    • IInterchange インターフェイスの CheckSuspendedQueue メソッドを呼び出します。
      • 保留キューから項目を取得します。

      • これは、後に IInterchange インターフェイスの DeleteFromSuspendedQueue メソッドまたは GetSuspendedQueueItemDetails メソッドを呼び出すために使用するハンドルの一覧を返します。
    • GetSuspendedQueueItemDetails を呼び出します。

      保留キューの特定の項目についての詳細を取得します。

    • DeleteFromSuspendedQueue を呼び出します。

      保留キューから項目を削除します。


カスタム コンポーネントの作成

ここでは、カスタム コンポーネントを作成して Microsoft BizTalk Server 2000 を拡張し、基幹業務アプリケーションの統合、暗号化と暗号解読やデジタル署名などの機能の追加を行う方法について説明します。この情報を利用して、次の操作を行うことができます。

  • アプリケーションで BizTalk Server 2000 を使用してビジネス ドキュメントを受信できるようにするアプリケーション統合コンポーネント (AIC) を作成する。

  • デジタル署名、暗号化と暗号解読、ドキュメントの解析、シリアライズ、およびトランスポートを実行するカスタム コンポーネントを開発して、BizTalk Server 2000 の機能を拡張する。

詳細については、次のトピックを参照してください。

  • 特定の作業のヘルプについては、「操作方法」を参照してください。

  • 一般的な情報については、「概念」を参照してください。

  • COM インターフェイスの詳細については、「カスタム コンポーネントの作成に関するリファレンス」を参照してください。

  • コード例については、「BizTalk メッセージ サービスのコード サンプル」を参照してください。


操作方法

ここでは、サーバー コンポーネントを作成する方法を作業ごとに説明します。「カスタム コンポーネントの作成」の「概念」を参照し、内容を十分に理解しておいてください。次のトピックが含まれます。

  • パイプライン コンポーネントの作成

  • SAP R/3 AIC の使用


パイプライン コンポーネントの作成

パイプライン コンポーネントを作成するには、次の操作を行います。

  1. Active Template Library ウィザードで Inproc サーバー プロジェクトを作成します。

  2. シンプル オブジェクトを追加します。

  3. Projectname.idl ファイルに移動し、Active Template Library ウィザードで作成したデュアル インターフェイスまたはカスタム インターフェイスを削除します。

  4. IDL ファイルの内容が、次のコード例のようになることを確認します。Pipecomp.idl に定義されているインターフェイスの中から、必要なものを選んで実装します。
    // SimplePipeComponent.idl : IDL source for SimplePipeComponent.dll
//
import "oaidl.idl";
import "ocidl.idl";
import "pipecomp.idl";

[
    uuid(D26A52F6-63A0-42B1-8C88-3C71C66BB189),
    version(1.0),
    helpstring("SimplePipeComponent 1.0 Type Library")
]
library SIMPLEPIPECOMPONENTLib
{
    importlib("stdole32.tlb");
    importlib("stdole2.tlb");
    [
        uuid(E66CAF06-18D8-4C70-9D39-5ED9756C21AD),
        helpstring("MySimplePipelineComponent Class")
    ]
    coclass MySimplePipelineComponent
    {
        [default] interface IPipelineComponentAdmin;
        interface IPipelineComponent;
        interface IPipelineComponentDescription;
    };
};
  5. ヘッダー ファイルに、次のように MySimplePipelineComponent [coclass] 実装のうちの 1 つが定義されます。
    // MySimplePipelineComponent.h : Declaration of the
// CMySimplePipelineComponent

#ifndef __MYSIMPLEPIPELINECOMPONENT_H_
#define __MYSIMPLEPIPELINECOMPONENT_H_

#include "resource.h"       // main symbols

/////////////////////////////////////////////////////////////////////////////
// CMySimplePipelineComponent
class ATL_NO_VTABLE CMySimplePipelineComponent :
    public CComObjectRootEx<CComSingleThreadModel>,
    public CComCoClass<CMySimplePipelineComponent, &CLSID_MySimplePipelineComponent>,
    public ISupportErrorInfo,
    public IDispatchImpl<IPipelineComponentAdmin, &IID_IPipelineComponentAdmin, &LIBID_SIMPLEPIPECOMPONENTLib>,
    public IDispatchImpl<IPipelineComponent, &IID_IPipelineComponent, &LIBID_SIMPLEPIPECOMPONENTLib>,
    public IDispatchImpl<IPipelineComponentDescription, &IID_IPipelineComponentDescription, &LIBID_SIMPLEPIPECOMPONENTLib>
{
public:
    CMySimplePipelineComponent()
    {
    }

DECLARE_REGISTRY_RESOURCEID(IDR_MYSIMPLEPIPELINECOMPONENT)

DECLARE_PROTECT_FINAL_CONSTRUCT()

BEGIN_COM_MAP(CMySimplePipelineComponent)
    COM_INTERFACE_ENTRY2(IDispatch,IPipelineComponentAdmin)
    COM_INTERFACE_ENTRY(IPipelineComponentAdmin)
    COM_INTERFACE_ENTRY(IPipelineComponent)
    COM_INTERFACE_ENTRY(IPipelineComponentDescription)
    COM_INTERFACE_ENTRY(ISupportErrorInfo)
END_COM_MAP()

// ISupportsErrorInfo
    STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);

public://IPipelineComponentAdmin
    STDMETHODIMP GetConfigData(IDispatch** ppDict );
    STDMETHODIMP SetConfigData(IDispatch* pDict );

public://IPipelineComponent
    STDMETHODIMP Execute(IDispatch*  pdispObject,IDispatch*  pdispContext,LONG lFlags,LONG* plErrorLevel);
    STDMETHODIMP EnableDesign(BOOL fEnable);
public: //IPipelineComponentDescription
    STDMETHODIMP ValuesRead(VARIANT* pvar);
    STDMETHODIMP ValuesWritten(VARIANT* pvar);
    STDMETHODIMP ContextValuesRead(VARIANT* pvar);

};

#endif //__MYSIMPLEPIPELINECOMPONENT_H_

関連項目

アプリケーション統合コンポーネントの作成

IPipelineComponent

IPipelineComponentAdmin


SAP R/3 AIC の使用

Systems, Applications, and Products in Data Processing (SAP) AIC を使用するには、次の操作を行います。

DCOM コネクタのインストール

  1. SAP リモート関数呼び出し SDK (www.sap.co.jp/bapi) をダウンロードします。
    • COM セクションに移動し、[DCOM Component Connector] をクリックします。

    • ファイルのダウンロード ウィザードの指示に従います。
  2. イメージを実行し、解凍して、Rfcsdk サブディレクトリをクライアント コンピュータに追加します。

  3. DCOM コネクタをインストールします。

  4. \Ccwww サブディレクトリの Install ページのインストール指示に従います。

BizTalk メッセージ マネージャでの送信先名の入力

SAP DCOM コネクタ構成時に指定した送信先名を入力します。詳細については、「送信先組織の選択」を参照してください。

COM+ サーバー パッケージの作成

  1. COM+ サーバー パッケージを作成します。

  2. 作成したパッケージに、トランザクション未サポートのマークを付けます。

  3. このパッケージに AICOMP.dll を追加します。


カスタム コンポーネントの作成に関するリファレンス

ここでは、C++ または Visual Basic を使用したプログラミングに対して、Microsoft BizTalk Server 2000 で 使用するコンポーネントとインターフェイスに関するリファレンスを紹介します。BizTalk Server 2000 を拡張するために使用するすべてのインターフェイスに関する情報を示します。

次に示す COM インターフェイスは、C++ 開発者を対象にしたものです。

  • IBizTalkParserComponent

  • IBizTalkSerializerComponent

次に示す COM インターフェイスと列挙は、C++ 開発者と Visual Basic 開発者の両方を対象にしたものです。

  • IBizTalkAcknowledge

  • IBizTalkCorrelation

  • IBTSAppIntegration

  • IFunctoid

  • IPipelineComponent

  • IPipelineComponentAdmin

  • ISchemaImporter

  • ISchemaImporterError

  • ISchemaImporterErrorProvider

  • 受信確認列挙

  • Functoid 列挙


IBizTalkAcknowledge インターフェイス[C++]

IBizTalkAcknowledge オブジェクト[Visual Basic]

このオブジェクトは、サーバーに送信された受信確認を処理するために使用します。

C++ では、BizTalkAcknowledge オブジェクトのメソッドにアクセスするには IBizTalkAcknowledge インターフェイスを使用します。

次の表は、BizTalkAcknowledge オブジェクトのメソッドを示しています。

メソッド | 説明
AckDocument | ドキュメントに対して受信した受信確認を処理します。
AckGroup | ドキュメント グループに対して受信した受信確認を処理します。
AckInterchange | ドキュメント インターチェンジに対して受信した受信確認を処理します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。

関連項目

受信確認関連付けコンポーネントの作成

受信確認をログに記録する方法

受信確認について


IBizTalkAcknowledge::AckDocument メソッド [C++]

IBizTalkAcknowledge.AckDocument メソッド [Visual Basic]

AckDocument メソッドは、ドキュメントの受信確認を処理します。

構文

[C++]

HRESULT AckDocument(
BSTR bstrSyntax,
 BSTR bstrTrackingId,
 DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckDocument( _
bstrSyntax As String, _
bstrTrackingId As String, _
enumAckStatus As DTA_ACK_STATUS _
)

パラメータ

[C++]

bstrSyntax

[in] 受信確認される送信ドキュメントの構文 (X12 や EDIFACT など) を含む BSTR です。

bstrTrackingId

[in] ドキュメントの一意なトラッキング識別子を含む BSTR です。この値は、グローバル一意識別子 (GUID) です。dta_outdoc_details テーブルの Tracking_ID フィールドから取得される値です。詳細については、「パーサー コンポーネントとシリアライザ コンポーネントによる追跡データベースのサポート」を参照してください。

enumAckStatus

[in] 受信状況を示す列挙値です。DTA_ACK_STATUS 列挙から取得される有効な値です。

[Visual Basic]

bstrSyntax

受信確認される送信ドキュメントの構文 (X12 や EDIFACT など) を含む文字列です。

bstrTrackingId

ドキュメントの一意なトラッキング識別子を含む文字列です。この値は、グローバル一意識別子 (GUID) です。dta_outdoc_details テーブルの Tracking_ID フィールドから取得される値です。詳細については、「パーサー コンポーネントとシリアライザ コンポーネントによる追跡データベースのサポート」を参照してください。

enumAckStatus

受信状況を示す列挙値です。DTA_ACK_STATUS 列挙から取得される有効な値です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドは、各ドキュメントの受信確認を行う場合にのみ呼び出されます。受信確認をマップする場合は、WebDAV に付属の CanonicalReceipt.xml をポイントするドキュメント定義を、その受信確認に対して作成する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。


IBizTalkAcknowledge::AckGroup メソッド [C++]

IBizTalkAcknowledge.AckGroup メソッド [Visual Basic]

AckGroup メソッドは、ドキュメント グループの受信確認を処理します。

構文

[C++]

HRESULT AckGroup(
BSTR bstrSyntax,
 BSTR bstrVersion,
 BSTR bstrRelease,
 BSTR bstrFunctionalGroupId,
 BSTR bstrControlId,
 BSTR bstrSrcAppName,
 BSTR bstrDestAppName,
 DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckGroup( _
bstrSyntax As String, _
bstrVersion As String, _
bstrRelease As String, _
bstrFunctionalGroupId As String, _
bstrControlId As String, _
bstrSrcAppName As String, _
bstrDestAppName As String, _
enumAckStatus As DTA_ACK_STATUS _
)

パラメータ

[C++]

bstrSyntax

[in] 受信確認される送信ドキュメントの構文 (X12 や EDIFACT など) を含む BSTR です。次の種類の構文については、正確な文字列を使用する必要があります。

  • ANSI X12

  • EDIFACT

  • カスタム XML

bstrVersion

[in] 構文のバージョンを含む BSTR で、主に EDI で使用されます。

bstrRelease

[in] この構文のバージョンのリリースを含む BSTR で、主に EDI で使用されます。

bstrFunctionalGroupId

[in] グループ内のドキュメントの種類を示すコードを含む BSTR で、主に EDI で使用されます。

bstrControlId

[in] 制御番号の一意識別子を含む BSTR で、主に EDI で使用されます。

bstrSrcAppName

[in] 送信元アプリケーションの名前を含む BSTR です。

bstrDestAppName

[in] 送信先アプリケーションの名前を含む BSTR です。

enumAckStatus

[in] 受信状況を示す列挙値です。DTA_ACK_STATUS 列挙から取得される有効な値です。

[Visual Basic]

bstrSyntax

受信確認される送信ドキュメントの構文 (X12 や EDIFACT など) を含む文字列です。次の種類の構文については、正確な文字列を使用する必要があります。

  • ANSI X12

  • EDIFACT

  • カスタム XML

bstrVersion

構文のバージョンを含む文字列で、主に EDI で使用されます。

bstrRelease

この構文のバージョンのリリースを含む文字列で、主に EDI で使用されます。

bstrFunctionalGroupId

グループ内のドキュメントの種類を示すコードを含む文字列で、主に EDI で使用されます。

bstrControlId

制御番号の一意識別子を含む文字列で、主に EDI で使用されます。

bstrSrcAppName

送信元アプリケーションの名前を含む文字列です。

bstrDestAppName

送信先アプリケーションの名前を含む文字列です。

enumAckStatus

受信状況を示す列挙値です。DTA_ACK_STATUS 列挙から取得される有効な値です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドは、ドキュメント グループの受信確認を行う場合にのみ呼び出されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。


IBizTalkAcknowledge::AckInterchange メソッド [C++]

IBizTalkAcknowledge.AckInterchange メソッド [Visual Basic]

AckInterchange メソッドは、ドキュメント インターチェンジの受信確認を処理します。

構文

[C++]

HRESULT AckInterchange(
BSTR bstrSyntax,
 BSTR bstrInterchangeId,
 BSTR bstrVersion,
 BSTR bstrControlId,
 BSTR bstrSrcAliasQualifier,
 BSTR bstrSrcAliasId,
 BSTR bstrSrcAppName,
 BSTR bstrDestAliasQualifier,
 BSTR bstrDestAliasId,
 BSTR bstrDestAppName,
 DTA_ACK_STATUS enumAckStatus
);

[Visual Basic]

object.AckInterchange( _
bstrSyntax As String, _
bstrInterchangeId As String, _
bstrVersion As String, _
bstrControlId As String, _
bstrSrcAliasQualifier As String, _
bstrSrcAliasId As String, _
bstrSrcAppName As String, _
bstrDestAliasQualifier As String, _
bstrDestAliasId As String, _
bstrDestAppName As String, _
enumAckStatus As DTA_ACK_STATUS _
)

パラメータ

[C++]

bstrSyntax

[in] 受信確認される送信ドキュメントの構文 (X12 や EDIFACT など) を含む BSTR です。次の種類の構文については、正確な文字列を使用する必要があります。

  • ANSI X12

  • EDIFACT

  • カスタム XML

bstrInterchangeId

[in] インターチェンジの一意なトラッキング識別子を含む BSTR です。この値は、グローバル一意識別子 (GUID) です。

bstrVersion

[in] 構文のバージョンを含む BSTR で、主に EDI で使用されます。

bstrControlId

[in] 制御番号の一意識別子を含む BSTR で、主に EDI で使用されます。

bstrSrcAliasQualifier

[in] 送信元組織の修飾子を含む BSTR です。これは、bstrSrcAliasID パラメータがどのように解釈されるかを示しています。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。

bstrSrcAliasId

[in] 送信元組織の修飾子の値を含む BSTR です。たとえば、bstrSrcAliasQualifier パラメータが Telephone である場合、この値は電話番号になります。

bstrSrcAppName

[in] 送信元アプリケーションの名前を含む BSTR です。

bstrDestAliasQualifier

[in] 送信元組織の修飾子を含む BSTR です。これは、bstrDestAliasID パラメータがどのように解釈されるかを示しています。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。

bstrDestAliasId

[in] 送信元組織の修飾子の値を含む BSTR です。たとえば、bstrDestAliasQualifier パラメータが Telephone である場合、この値は電話番号になります。

bstrDestAppName

[in] 送信先アプリケーションの名前を含む BSTR です。

enumAckStatus

[in] 受信状況を示す列挙値です。DTA_ACK_STATUS 列挙から取得される有効な値です。

[Visual Basic]

bstrSyntax

受信確認される送信ドキュメントの構文 (X12 や EDIFACT など) を含む文字列です。次の種類の構文については、正確な文字列を使用する必要があります。

  • ANSI X12

  • EDIFACT

  • カスタム XML

bstrInterchangeId

インターチェンジの一意なトラッキング識別子を含む文字列です。この値は、グローバル一意識別子 (GUID) です。

bstrVersion

構文のバージョンを含む文字列で、主に EDI で使用されます。

bstrControlId

制御番号の一意識別子を含む文字列で、主に EDI で使用されます。

bstrSrcAliasQualifier

送信元組織の修飾子を含む文字列です。これは、bstrSrcAliasID パラメータがどのように解釈されるかを示しています。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。

bstrSrcAliasId

送信元組織の修飾子の値を含む文字列です。たとえば、bstrSrcAliasQualifier パラメータが Telephone である場合、この値は電話番号になります。

bstrSrcAppName

送信元アプリケーションの名前を含む文字列です。

bstrDestAliasQualifier

送信元組織の修飾子を含む文字列です。これは、bstrDestAliasID パラメータがどのように解釈されるかを示しています。ユーザーが組織のエイリアスを作成すると、組織識別子の修飾子が作成され、そこから有効な値が取得されます。共通の修飾子としては DUNS 番号、電話番号、BizTalk などがあります。すべての新しい組織の既定の修飾子は Organization Name で、データベース内の組織の名前を参照します。BizTalk Framework 2.0 準拠のドキュメントが送信されて、解析中に修飾子が見つからなかった場合は、修飾子は既定で BizTalk になります。

bstrDestAliasId

送信元組織の修飾子の値を含む文字列です。たとえば、bstrDestAliasQualifier パラメータが Telephone である場合、この値は電話番号になります。

bstrDestAppName

送信先アプリケーションの名前を含む文字列です。

enumAckStatus

受信状況を示す列挙値です。DTA_ACK_STATUS 列挙から取得される有効な値です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドは、ドキュメント インターチェンジの受信確認を行う場合にのみ呼び出されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSDocTracking.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll) を使用します。


IBizTalkCorrelation インターフェイス

IBizTalkCorrelation は、受信確認関連付けコンポーネントを作成するために実装します。

次の表は、BizTalkCorrelation オブジェクトのメソッドを示しています。

メソッド | 説明
Correlate | ドキュメント、ドキュメント グループ、またはインターチェンジから、必要なすべての情報を抽出します。

注

  • このインターフェイスは Microsoft Visual Basic では使用できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

関連項目

受信確認関連付けコンポーネントの作成


IBizTalkCorrelation::Correlate メソッド

Correlate メソッドは、ドキュメント、ドキュメント グループ、またはインターチェンジから、必要なすべての情報を抽出します。

構文

[C++]

HRESULT Correlate(
IUnknown* Acknowledge,
IDictionary* Dict
);

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

パラメータ

[C++]

Acknowledge

[in] 受信確認フラグを呼び出して設定する IBizTalkAcknowledge インターフェイスへのポインタです。

Dict

[in] 受信確認情報を含むオブジェクトの IDictionary インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし


IFunctoid インターフェイス[C++]

CannedFunctoid オブジェクト [Visual Basic]

C++ では、カスタム マッピング関数を作成するには IFunctoid を実装します。IFunctoid は、マッピング ツールで使用するカスタム関数を呼び出すための汎用プロトコルを定義します。

Microsoft Visual Basic では、カスタム マッピング関数を作成するには CannedFunctoid を実装します。CannedFunctoid は、マッピング ツールで使用するカスタム関数を呼び出すための汎用プロトコルを定義します。

このオブジェクトでは、そのクラス識別子 (CLSID) を、マッピング ツールで列挙した関数オブジェクトのカテゴリ識別子 (CATID) の下に登録する必要があります。CATID は {2560F3BF-DB47-11D2-B3AE-00C04F72D6C1} です。各カスタム オブジェクトは複数の関数をサポートしており、各サポート関数のアイコンと名前を含むことができます。

0 から 1000 までの関数識別子は、BizTalk マッパーの組み込み関数用に予約されています。ユーザー定義関数 (カスタム関数) には、1001 以降の関数識別子を使用します。

次の表は、CannedFunctoid オブジェクトのプロパティを示しています。

プロパティ | 説明
FunctionsCount (関数の数) | Functoid によって実装される関数の数を返します。
Version (バージョン) | Functoid のバージョンを返します。

次の表は、CannedFunctoid オブジェクトのメソッドを示しています。

メソッド | 説明
GetFunctionParameter | 指定されたパラメータの接続の種類のビット フラグを取得します。
GetFunctionDescripter | 指定された Functoid に関する情報を取得します。
GetScriptBuffer | Functoid の実装に使用するスクリプト コードを取得します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : CannedFunctoid.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll) を使用します。


IFunctoid::FunctionsCount プロパティ [C++]

CannedFunctoid.FunctionsCount プロパティ [Visual Basic]

FunctionsCount プロパティは、Functoid によって実装される関数の数を返します。

構文

[C++]

HRESULT get_FunctionsCount(
 long* plCount
);

[Visual Basic]

object.FunctionsCount

パラメータ

[C++]

plCount

[out, retval] Functoid によって実装される関数の数を含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、Functoid によって実装される関数の数を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : CannedFunctoid.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll) を使用します。


IFunctoid::GetFunctionDescripter メソッド [C++]

CannedFunctoid.GetFunctionDescripter メソッド [Visual Basic]

GetFunctionDescripter メソッドは、指定された Functoid に関する情報を返します。

構文

[C++]

HRESULT GetFunctionDescripter(
long lIndex,
 FUNC_CATEGORY* pFuncCategory,
 SCRIPT_CATEGORY* pScriptCategory,
 FUNC_TYPE* pFuncType,
 BSTR* pbstrName,
 BSTR* pbstrToolTip,
 long* plBitmapID,
 long* plParmCount,
 FUNCID* pFuncId
);

[Visual Basic]

object.GetFunctionDescripter( _
lIndex As Long, _
pFuncCategory As FUNC_CATEGORY, _
pScriptCategory As SCRIPT_CATEGORY, _
pFuncType As FUNC_TYPE, _
pbstrName As String, _
pbstrToolTip As String, _
plBitmapID As Long, _
plParmCount As Long _
)

パラメータ

[C++]

lIndex

[in] 関数のインデックス数を指定する Long です。

pFuncCategory

[in, out] この関数の FUNC_CATEGORY ビット フラグを含む値へのポインタです。

pScriptCategory

[in, out] この関数の SCRIPT_CATEGORY ビット フラグを含む値へのポインタです。このリリースでは、この値は SCRIPT_CATEGORY_VBSCRIPT に設定する必要があります。

pFuncType

[in, out] この関数の FUNC_TYPE ビット フラグを含む値へのポインタです。

pbstrName

[in, out] 関数名を含む BSTR へのポインタです。

pbstrToolTip

[in, out] マッピング ツールで、マウス ポインタをカスタム Functoid アイコンの上で静止させたときに表示されるヒントを含む BSTR へのポインタです。

plBitmapID

[in, out] マッピング ツールに表示されるカスタム Functoid アイコンで使用されるビットマップの long ビットマップ識別子へのポインタです。

plParmCount

[in, out] 関数によって実装されるパラメータの数を含む long へのポインタです。

pFuncId

[out, retval] 関数識別子を含む long へのポインタです。

[Visual Basic]

lIndex

関数のインデックス数を指定する Long です。

pFuncCategory

この関数の FUNC_CATEGORY ビット フラグを含む値です。

pScriptCategory

この関数の SCRIPT_CATEGORY ビット フラグを含む値です。このリリースでは、この値は SCRIPT_CATEGORY_VBSCRIPT に設定する必要があります。

pFuncType

この関数の FUNC_TYPE ビット フラグを含む値です。

pbstrName

関数名を含む文字列です。

pbstrToolTip

マッピング ツールで、マウス ポインタをカスタム Functoid アイコンの上で静止させたときに表示されるヒントを含む文字列です。

plBitmapID

マッピング ツールに表示されるカスタム Functoid アイコンで使用されるビットマップのビットマップ識別子を含む Long です。

plParmCount

関数によって実装されるパラメータの数を含む Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、関数識別子を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : CannedFunctoid.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll) を使用します。


IFunctoid::GetFunctionParameter メソッド [C++]

CannedFunctoid.GetFunctionParameter メソッド [Visual Basic]

GetFunctionParameter メソッドは、指定されたパラメータの接続の種類のビット フラグを取得します。

構文

[C++]

HRESULT GetFunctionParameter(
FUNCID funcId,
 long lParameter,
 long* plConnectionType
);

[Visual Basic]

object.GetFunctionParameter( _
funcId As FUNCID, _
lParameter As Long _
)

パラメータ

[C++]

funcId

[in] 関数識別子を含む Long です。

lParameter

[in] 関数パラメータ番号を含む Long です。出力パラメータには、値 -1 が使用されます。

plConnectionType

[out, retval] 指定されたパラメータの CONNECTION_TYPE ビット フラグを含む long へのポインタです。

[Visual Basic]

funcId

関数識別子を含む Long です。

lParameter

関数パラメータ番号を含む Long です。出力パラメータには、値 -1 が使用されます。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、指定されたパラメータの CONNECTION_TYPE ビット フラグを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : CannedFunctoid.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll) を使用します。


IFunctoid::GetScriptBuffer メソッド [C++]

CannedFunctoid.GetScriptBuffer メソッド [Visual Basic]

GetScriptBuffer メソッドは、Functoid の実装に使用するスクリプト コードを取得します。

構文

[C++]

Get メソッド :

HRESULT GetScriptBuffer(
FUNCID cFuncId,
 long lInputParameters,
 BSTR* pbstrScriptBuffer
);

[Visual Basic]

object.GetScriptBuffer( _
cFuncId As FUNCID, _
lInputParameters As Long _
)

パラメータ

[C++]

cFuncId

[in] 関数識別子を含む Long です。

lInputParameters

[in] 指定された関数の接続済み入力パラメータの数を示す Long です。

pbstrScriptBuffer

[out, retval] 関数の実装に使用するスクリプト コードを含む BSTR へのポインタです。

[Visual Basic]

cFuncId

関数識別子を含む Long です。

lInputParameters

指定された関数の接続済み入力パラメータの数を示す Long です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、関数の実装に使用するスクリプト コードを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : CannedFunctoid.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll) を使用します。


IFunctoid::Version プロパティ [C++]

CannedFunctoid.Version プロパティ [Visual Basic]

Version プロパティは、Functoid のバージョンを返します。

構文

[C++]

HRESULT get_Version(
 long* pVersion
);

[Visual Basic]

object.Version

パラメータ

[C++]

pVersion

[out, retval] カスタム Functoid のバージョンを含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、カスタム Functoid のバージョンを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

カスタム Functoid を変更した場合、作成者はバージョン番号を更新する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : CannedFunctoid.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll) を使用します。


IBizTalkParserComponent インターフェイス

このオブジェクトは、後の処理用にドキュメントを XML に変換し、そのドキュメント処理に必要な BizTalkChannel オブジェクトを識別するために使用します。

C++ では、BizTalkParserComponent オブジェクトのメソッドにアクセスするには IBizTalkParserComponent インターフェイスを使用します。

次の表は、BizTalkParserComponent オブジェクトのメソッドを示しています。

メソッド | 説明
GetGroupDetails | 追跡データベースのグループの詳細を取得します。このメソッドは、インターチェンジにグループが存在する場合にのみ呼び出されます。
GetGroupSize | グループ内のすべてのドキュメントが解析された後、そのグループのサイズを取得します。このメソッドは、インターチェンジにグループが存在する場合にのみ呼び出されます。
GetInterchangeDetails | 送信元と送信先の BizTalkOrganization オブジェクトの組織識別子に関する情報を取得します。
GetNativeDocumentOffsets | 最終ログで使用する、追跡データベースのグループに関する最終詳細のストリームの先頭からのオフセットを識別します。
GetNextDocument | ドキュメントのデータを調査し、そのドキュメントが最終ドキュメントでない場合、次のドキュメントを取得するタイミングを決定します。
GroupsExist | インターチェンジにグループが含まれるかどうかを判別します。
ProbeInterchangeFormat | インターチェンジの書式を識別します。

解説

アプリケーション統合コンポーネントは、BizTalk Server 2000 に属していることが認識できるように正しく登録する必要があります。アプリケーション統合コンポーネントの登録は、カテゴリ ID CATID_BIZTALK_AIC で登録されます。CATID は bts_sdk_guids.h ファイルで定義されます。詳細については、「アプリケーション統合コンポーネントの登録」を参照してください。

注

  • このインターフェイスは Microsoft Visual Basic では使用できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

関連項目

識別

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::GetGroupDetails メソッド

[C++]

GetGroupDetails メソッドは、追跡データベースのグループの詳細を取得します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetGroupDetails(
IDictionary* Dict
);

[Visual Basic]

なし

パラメータ

[C++]

Dict

[in] グループに関する詳細を含むオブジェクトの IDictionary インターフェイスへのポインタです。データ内での表示方法にかかわらず、情報はすべて文字列型として返されます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

このメソッドは、インターチェンジでグループが検出される場合にのみ呼び出されます。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::GetGroupSize メソッド

[C++]

GetGroupSize メソッドは、グループ内のすべてのドキュメントが解析された後、そのグループのサイズを取得します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetGroupSize(
long* GroupSize,
BOOL* LastGroup
);

[Visual Basic]

なし

パラメータ

[C++]

GroupSize

[out] インターチェンジのサイズを含む long へのポインタです。

LastGroup

[out] グループが、インターチェンジ内の最後のグループであるかどうかを示すブール値へのポインタです。このパラメータが TRUE に設定されている場合、次に呼び出されるメソッドは、データ内の次のグループの GetGroupDetails になります。FALSE に設定されている場合は、このコンポーネントは終了します。解放されると、最後に読み取られたバイトの後に IStream インターフェイスが残ります。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

グループ内のすべてのドキュメントが呼び出された後は、そのグループの最終詳細が必要です。追跡データベースに両方の出力パラメータが追加され、最終ログに使用されます。

このメソッドは、インターチェンジにグループが存在する場合にのみ呼び出されます。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::GetInterchangeDetails メソッド

[C++]

GetInterchangeDetails メソッドは、送信元と送信先の BizTalkOrganization オブジェクトの組織識別子に関する情報を取得します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetInterchangeDetails(
IDictionary* Dict
);

[Visual Basic]

なし

パラメータ

[C++]

Dict

[in] 送信元と送信先の BizTalkOrganization オブジェクトの組織識別子に関する情報を含むオブジェクトの IDictionary インターフェイスへのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

フィールドの最小セットは次のとおりです。

フィールド | 説明
src_id_type | 送信元修飾子
src_id_value | 送信元 ID
dest_id_type | 送信先修飾子
dest_id_value | 送信先 ID

IInterchange インターフェイスの Submit メソッドの各パラメータは、ここで設定されているすべてのフィールドを上書きします。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::GetNativeDocumentOffsets メソッド

[C++]

GetNativeDocumentOffsets メソッドは、最終ログで使用する、追跡データベースのグループに関する最終詳細のストリームの先頭からのオフセットを識別します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetNativeDocumentOffsets(
BOOL SizeFromXMLDoc,
 LARGE_INTEGER* StartOffset,
 long* DocLength
);

[Visual Basic]

なし

パラメータ

[C++]

SizeFromXMLDoc

[out] GetNextDocument メソッドから渡された XML ドキュメントが、サイズの決定に使用されたことを示すブール値です。このパラメータが TRUE の場合、サーバーは解析済みのドキュメントの StartOffset 値および DocLength 値を書き込みます。FALSE の場合、サーバーは StartOffset 値および DocLength の値を無視します。

StartOffset

[out] ドキュメントの先頭の場所を含む LARGE_INTEGER へのポインタです。このパラメータは、SizeFromXMLDoc パラメータが TRUE に設定されている場合に返されます。

DocLength

[out] ドキュメントの長さを含む long へのポインタです。このパラメータは、SizeFromXMLDoc パラメータが TRUE に設定されている場合に返されます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

このメソッドは、パーサーからエラー値が返されない限り、ドキュメントの有効性にかかわらず、GetNextDocument の直後に呼び出されます。これらは、ストリームの先頭に対する IStream オブジェクトへのオフセットであり、インターチェンジの先頭に対するオフセットではありません。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::GetNextDocument メソッド

[C++]

GetNextDocument メソッドは、ドキュメントのデータを調査し、そのドキュメントが最終ドキュメントでない場合、次のドキュメントを取得するタイミングを決定します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetNextDocument(
IDictionary* Dict,
 BSTR DocSpecName,
 BOOL* DocIsValid,
BOOL* LastDocument,
GeneratedReceiptLevel ReceiptGenerated,
BOOL* DocIsReceipt,
BSTR* CorrelationCompProgID
);

[Visual Basic]

なし

パラメータ

[C++]

Dict

[in] 現在のドキュメントを解析するときに作成される XML インスタンスの設定先であるオブジェクトの IDictionary インターフェイスへのポインタです。解析済みの XML ドキュメントはディクショナリの working_data フィールドに配置されます。

DocSpecName

[in] ドキュメントのネイティブ形式から XML を生成するために使用する、BizTalk ドキュメント仕様の名前を含む BSTR です。

DocIsValid

[out] ドキュメント インスタンスが有効であるかどうかを示すブール値へのポインタです。無効であってもパーサーによって回復できる場合は、このパラメータを FALSE に設定します。このパラメータと LastDocument パラメータは互いに独立しています。したがって、最後のドキュメントが無効で、それ以降のドキュメントが存在しない場合は、両方のフラグが設定されます。ドキュメントが無効で、パーサーが続行できない場合は、エラー値が返されることがあります。その場合、サーバーは IStream ポインタの現在の位置で停止します。コンポーネントは、パーサーによって回復が可能な場合、無効なデータを working_data フィールドに配置し、ドキュメントが無効な場合、システム管理者はこのデータを調査できます。

LastDocument

[out] グループ内またはインターチェンジ内の最後のドキュメント インスタンスであるかどうかを示すブール値へのポインタです。最後のドキュメントが見つかると、LastDocument フラグが TRUE に設定されます。グループが存在する場合、このフラグはそのグループの最後のドキュメントにシグナルを送り、GetGroupSize メソッドが呼び出されます。グループが存在しない場合は、これがパーサーからのドキュメント データ取得の最後の呼び出しとなり、IStream ポインタが適切に設定されます。

ReceiptGenerated

列挙値です。有効な値は GeneratedReceiptLevel 列挙の値です。

DocIsReceipt

[out] このドキュメントが受信確認であるかどうかを示すブール値へのポインタです。

CorrelationCompProgID

[out] ドキュメントの照合用のプログラム ID を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::GroupsExist メソッド

[C++]

GroupsExist メソッドは、インターチェンジにグループが含まれるかどうかを判別します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GroupsExist(
BOOL* GrpsExist
);

[Visual Basic]

なし

パラメータ

[C++]

GrpsExist

[out, retval] データ形式にグループが含まれるかどうかを示すブール値へのポインタです。このパラメータが FALSE に設定されている場合、GetGroupDetails メソッドおよび GetGroupSize メソッドは呼び出されません。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkParserComponent::ProbeInterchangeFormat メソッド

[C++]

ProbeInterchangeFormat メソッドは、インターチェンジの書式を識別します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT ProbeInterchangeFormat(
IStream* pData,
BOOL FromFile,
BSTR EnvName,
IStream* pReceiptData,
BSTR* Format
);

[Visual Basic]

なし

パラメータ

[C++]

pData

[in] ドキュメント インターチェンジのデータを含む IStream オブジェクトへのポインタです。IStream オブジェクトに関する追加情報については、Microsoft Developer Network (www.microsoft.com/japan/developer/library/default.asp) を参照してください。

FromFile

[in] ブール値です。TRUE は、IInterchange インターフェイスの Submit メソッドまたは SubmitSync メソッドの FilePath パラメータが参照するファイルからデータが取得されたことを示します。FALSE は、データが、Submit または SubmitSync の Document パラメータから文字列として取得されたことを示します。データがファイルから取得されている場合は、変換は行われません。データが文字列である場合は、UNICODE/MBCS テクノロジを使用して内容を把握できます。

EnvName

[in] エンベロープの名前を含む BSTR です。

pReceiptData

[in] 受信確認ドキュメントを含む IStream オブジェクトへのポインタです。

Format

[out] 書式を含む BSTR へのポインタです。書式を認識したら、サーバーはこのパラメータに空でない文字列を入力し、IStream インターフェイスを保持する (このインターフェイスの参照カウントをインクリメントする) 必要があります。コンポーネントには返されないためです。この IStream オブジェクトは読み取り専用であり、Read、Stat、および Seek の各メソッドのみサポートします。そのほかのメソッドは E_NOTIMPL を返します。このメソッドは、書式を認識できなくてもエラーを返しません。S_FALSE または空の文字列、つまり NULL Format 文字列が返されます。IStream ポインタはサーバーによってリセットされるため、書式が認識できない場合でも、このポインタを元の位置に戻す必要はありません。書式で要求されていなければ、IStream ポインタを先頭に位置するように設定する必要はありません。検査段階では、このポインタは任意の中間位置に設定できます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

これはサーバーが最初に呼び出すメソッドです。ProbeInterchangeFormat メソッドがドキュメント一覧の途中でエラーを返すと、サーバー上に複数のカスタム パーサーが存在し、エラーが発生したパーサー以降にあるカスタム パーサーがそのドキュメント型を処理できる場合でも、サーバーはドキュメント型をそれ以上検出できなくなります。最初のカスタム パーサーが失敗すると、ほかのカスタム パーサーで解析できるものであっても、後続のドキュメントは解析されません。これは、解析の失敗時に、サーバーがすべての解析処理を終了するためです。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSParserComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

IBizTalkParserComponent インターフェイスの使用


IBizTalkSerializerComponent インターフェイス

このオブジェクトは、ドキュメントを XML からそのドキュメントの元のネイティブ形式に変換するために使用します。

C++ では、BizTalkSerializerComponent オブジェクトのメソッドにアクセスするには IBizTalkSerializerComponent インターフェイスを使用します。

次の表は、BizTalkSerializerComponent オブジェクトのメソッドを示しています。

メソッド | 説明
AddDocument | シリアライザ コンポーネントで格納する XML ドキュメントを追加します。
GetDocInfo | ドキュメントの詳細を取得します。
GetGroupInfo | サイズやオフセットなど、追跡データベースのグループの詳細を取得します。
GetInterchangeInfo | 作成されたインターチェンジに関する情報を取得します。
Init | ドキュメント インスタンスをシリアライザ コンポーネントに出力し、その送信先を示します。

解説

アプリケーション統合コンポーネントは、Microsoft BizTalk Server 2000 に属していることが認識できるように正しく登録する必要があります。アプリケーション統合コンポーネントは、カテゴリ ID CATID_BIZTALK_AIC で登録されます。CATID は bts_sdk_guids.h ファイルで定義されます。詳細については、「アプリケーション統合コンポーネントの登録」を参照してください。

注

  • このインターフェイスは Microsoft Visual Basic では使用できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSSerializerComps.h をインクルードします。

関連項目

IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

IBizTalkSerializerComponent インターフェイスの使用


IBizTalkSerializerComponent::AddDocument メソッド

[C++]

AddDocument メソッドは、シリアライザ コンポーネントで格納する XML ドキュメントを追加します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT AddDocument(
long DocHandle,
IDictionary* Transport,
BSTR TrackID,
long ChannelID
);

[Visual Basic]

なし

パラメータ

[C++]

DocHandle

[in] コンポーネントで格納し、後に GetDocInfo メソッドを呼び出して取得するドキュメントへのハンドルを含む Long です。このパラメータは、ドキュメントの (X12 などによる) 並べ替えが必要な場合に備え、インターチェンジの順不同による再作成をサポートしています。

Transport

[in] 格納する XML ドキュメントを含むオブジェクトの IDictionary インターフェイスへのポインタです。これは、working_data フィールドにあります。このパラメータはコンポーネントでは設定できません。このパラメータは省略可能です。

TrackID

[in] サーバーで使用するドキュメント トラッキング ID を含む BSTR です。

ChannelID

[in] 現在のドキュメントに関連付けられた BizTalkChannel オブジェクトを含む Long です。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

このメソッドは、インターチェンジ 1 つにつき 1 回のみ呼び出されます。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSSerializerComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

IBizTalkSerializerComponent インターフェイスの使用


IBizTalkSerializerComponent::GetDocInfo メソッド

[C++]

GetDocInfo メソッドは、ドキュメントの詳細を取得します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetDocInfo(
long* DocHandle,
BOOL* SizeFromXMLDoc,
LARGE_INTEGER* DocStartOffset,
long* DocLen
);

[Visual Basic]

なし

パラメータ

[C++]

DocHandle

[out] ドキュメント ハンドルを含む long へのポインタです。返される各 ID について、GetGroupInfo メソッドを呼び出したときに作成されたグループ レコードに、このアドレスが割り当てられます。このパラメータはサイズや長さなど、ドキュメントのプロパティも返します。ただし SizeFromXMLDoc パラメータが TRUE に設定された場合は例外で、そのほかのパラメータは無視されます。

SizeFromXMLDoc

[out] ドキュメントのオフセット値および長さが XML ドキュメントから取得されることを示すブール値へのポインタです。このパラメータが TRUE の場合、サーバーはドキュメントの DocStartOffset 値および DocLen 値を書き込みます。FALSE の場合、サーバーは DocStartOffset 値および DocLen の値を無視します。

DocStartOffset

[out] ドキュメントの先頭へのオフセットを含む LARGE_INTEGER へのポインタです。このパラメータは、SizeFromXMLDoc が TRUE に設定されている場合に返されます。

DocLen

[out] ドキュメントの長さを含む long へのポインタです。このパラメータは、SizeFromXMLDoc が TRUE に設定されている場合に返されます。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

このメソッドは、グループ (グループが存在しない場合はインターチェンジ) 内の各ドキュメントにつき 1 回ずつ呼び出されます。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSSerializerComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

IBizTalkSerializerComponent インターフェイスの使用


IBizTalkSerializerComponent::GetGroupInfo メソッド

[C++]

GetGroupInfo メソッドは、サイズやオフセットなど、追跡データベースのグループの詳細を取得します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetGroupInfo(
long* NumDocs,
LARGE_INTEGER* GrpStartOffset,
long* GrpLen
);

[Visual Basic]

なし

パラメータ

[C++]

NumDocs

[out] グループ内のドキュメントの数を含む long へのポインタです。

GrpStartOffset

[out] IStream インターフェイスのグループの開始へのオフセットを含む LARGE_INTEGER へのポインタです。

GrpLen

[out] グループの長さを含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

このメソッドは、GetInterchangeInfo メソッドから返された回数だけ呼び出されます。グループ内の各ドキュメントについて GetDocInfo メソッドを呼び出します。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSSerializerComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

IBizTalkSerializerComponent インターフェイスの使用


IBizTalkSerializerComponent::GetInterchangeInfo メソッド

[C++]

GetInterchangeInfo メソッドは、作成されたインターチェンジに関する情報を取得します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT GetInterchangeInfo(
BSTR* InterchangeID,
long* lNumGroups
);

[Visual Basic]

なし

パラメータ

[C++]

InterchangeID

[out] インターチェンジ ID を含む BSTR へのポインタです。インターチェンジ ID は、追跡データベースに配置されます。

lNumGroups

[out] インターチェンジで生成されたグループの数を含む long へのポインタです。この値は 0 か 1 のいずれかになります。1 つのドキュメントは 1 つのグループにしか所属できません。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

解説

[C++]

このメソッドは、すべてのドキュメントが渡された後に呼び出されます。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSSerializerComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

IBizTalkSerializerComponent インターフェイスの使用


IBizTalkSerializerComponent::Init メソッド

[C++]

Init メソッドは、ドキュメント インスタンスをシリアライザ コンポーネントに出力し、その送信先を示します。

[Visual Basic]

このメソッドは、Microsoft Visual Basic では使用できません。

構文

[C++]

HRESULT Init(
BSTR srcQual,
 BSTR srcID,
 BSTR destQual,
BSTR destID,
long EnvID,
IDictionary* pDelimiters,
IStream* OutputStream,
long NumDocs
);

[Visual Basic]

なし

パラメータ

[C++]

srcQual

[in] 送信元組織識別子の修飾子を含む BSTR です。

srcID

[in] 送信元組織識別子の値を含む BSTR です。

destQual

[in] 送信先組織識別子の修飾子を含む BSTR です。

destID

[in] 送信先組織識別子の値を含む BSTR です。

EnvID

[in] エンベロープの識別子の値を含む Long です。

pDelimiters

[in] ドキュメントで使用される区切り記号を含むオブジェクトの IDictionary インターフェイスへのポインタです。

OutputStream

[in] このドキュメントのデータを含む IStream インターフェイスへのポインタです。この IStream ポインタは書き込み専用です。サポートされているメソッドは Write と Stat のみで、そのほかのメソッドはいずれも E_NOTIMPL を返します。IStream オブジェクトに関する追加情報については、Microsoft Developer Network (msdn.microsoft.com/library/) を参照してください。

NumDocs

[in] このインターチェンジの一部として送信されるドキュメントの数を含む Long です。このリリースでは、このパラメータは 1 に設定されています。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

要件

[C++]

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : BTSSerializerComps.h をインクルードします。

[Visual Basic]

なし

関連項目

IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

IBizTalkSerializerComponent インターフェイスの使用


IBTSAppIntegration インターフェイス[C++]

IBTSAppIntegration オブジェクト [Visual Basic]

このオブジェクトは、ドキュメントを受信するためのエントリ ポイントを作成する場合に使用します。

C++ では、BTSAppIntegration オブジェクトのメソッドにアクセスするには IBTSAppIntegration インターフェイスを使用します。

次の表は、BTSAppIntegration オブジェクトのメソッドを示しています。

メソッド | 説明
ProcessMessage | ドキュメントを処理します。

解説

アプリケーション統合コンポーネントは、Microsoft BizTalk Server 2000 に属していることが認識できるように正しく登録する必要があります。アプリケーション統合コンポーネントは、カテゴリ ID CATID_BIZTALK_AIC で登録されます。CATID は bts_sdk_guids.h ファイルで定義されます。詳細については、「アプリケーション統合コンポーネントの登録」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。

関連項目

ライトウェイト アプリケーション統合コンポーネント


IBTSAppIntegration::ProcessMessage メソッド [C++]

IBTSAppIntegration.ProcessMessage メソッド [Visual Basic]

ProcessMessage メソッドは、ドキュメントを処理し、応答ドキュメントがあればこれを返します。このメソッドは、サーバーがコンポーネントにドキュメントを送信する場合、実行時に呼び出されます。

構文

[C++]

HRESULT ProcessMessage(
BSTR bstrDocument,
 BSTR* pbstrResponseDocument
);

[Visual Basic]

object.ProcessMessage( _
 bstrDocument As String _
)

パラメータ

[C++]

bstrDocument

[in] ドキュメントを含む BSTR です。

pbstrResponseDocument

[retval, out] 応答ドキュメントを含む BSTR へのポインタです。

[Visual Basic]

bstrDocument

ドキュメントを含む文字列です。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

応答ドキュメントを含む文字列です。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

コンポーネントは、ドキュメント送信のための IInterchange インターフェイスの SubmitSync メソッドを使用して、応答文字列を返すことにより、テキストベースの応答をアプリケーションに戻すことができます。

処理に関する問題が発生した場合、コンポーネントはエラーを発生させて、ドキュメントが保留キューに再転送または送信されるようにする必要があります。エラーが返されない場合、サーバーは、コンポーネントがデータを正しく処理したと見なします。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : btsaic.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb) を使用します。


IPipelineComponent インターフェイス[C++]

IPipelineComponent オブジェクト [Visual Basic]

このオブジェクトは、Microsoft BizTalk Server 2000 で実行し、機能を拡張するカスタム パイプライン コンポーネントを作成するために使用します。

C++ では、PipelineComponent オブジェクトのメソッドにアクセスするには IPipelineComponent インターフェイスを使用します。

次の表は、PipelineComponent オブジェクトのメソッドを示しています。

メソッド | 説明
EnableDesign | コンポーネントがデザイン モードと実行モードのいずれかで実行されるように構成します。
Execute | トランスポート Dictionary オブジェクト設定およびその他の構成設定で、コンポーネントの必要な処理を実行します。

解説

アプリケーション統合コンポーネントは、BizTalk Server 2000 に属していることが認識できるように正しく登録する必要があります。アプリケーション統合コンポーネントの登録は、カテゴリ ID CATID_BIZTALK_AIC で登録されます。CATID は bts_sdk_guids.h ファイルで定義されます。詳細については、「アプリケーション統合コンポーネントの登録」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : pipecomp.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb) を使用します。

関連項目

アプリケーション統合コンポーネントの作成


IPipelineComponent::EnableDesign メソッド [C++]

IPipelineComponent.EnableDesign メソッド [Visual Basic]

EnableDesign メソッドは、コンポーネントがデザイン モードと実行モードのいずれかで実行されるように構成します。

構文

[C++]

HRESULT EnableDesign(
BOOL fEnable
);

[Visual Basic]

object.EnableDesign( _
fEnable As Boolean _
)

パラメータ

[C++]

fEnable

コンポーネントのモードを示すブール値です。TRUE の値は、コンポーネントがデザイン モードで実行されることを示します。FALSE (既定) の値は実行モードを示します。

[Visual Basic]

fEnable

コンポーネントのモードを示す Boolean です。True の値は、コンポーネントがデザイン モードで実行されることを示します。False (既定) の値は実行モードを示します。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

既定では、パイプライン コンポーネントは実行モードで実行されます。

このメソッドは、チャネル ウィザードの [詳細構成] ページで [メッセージ ポート既定値の変更] ページを開いたときに呼び出されます。また、プロパティ ページを閉じたり、fEnable パラメータを True に設定したときも呼び出されます。デザイン モードは、fEnable パラメータを True に設定してこのメソッドを呼び出さない限り有効になりません。

デザインのみのフィールドが返されるのは、fEnable パラメータを True に設定した場合のみです。それ以外の場合、サーバーに渡された Dictionary オブジェクトには不要な情報が含まれています。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : pipecomp.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb) を使用します。


IPipelineComponent::Execute メソッド [C++]

IPipelineComponent.Execute メソッド [Visual Basic]

Microsoft BizTalk Server 2000 は、トランスポート Dictionary オブジェクトを設定して、Execute メソッドを呼び出します。コンポーネントはこれらの Dictionary オブジェクトの値を読み取り、必要な処理を実行します。また、オプションでその後の処理のために、トランスポート Dictionary オブジェクトに新しい値を書き込みます。

構文

[C++]

HRESULT Execute(
IDispatch* pDispOrder,
 IDispatch* pDispContext,
 long lFlags,
 long* plErrorLevel
);

[Visual Basic]

object.Execute( _
pDispOrder As Object, _
pDispContext As Object, _
lFlags As Long _
)

パラメータ

[C++]

pDispOrder

[in] トランスポート Dictionary オブジェクトへのポインタです。

pDispContext

[in] このリリースではサポートされていません。

lFlags

[in] 予約済みです。

PlErrorLevel

[out, retval] 予約済みです。

[Visual Basic]

pDispOrder

トランスポート CDictionary オブジェクトを含む Object です。

pDispContext

このリリースではサポートされていません。

lFlags

予約済みです。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、エラー レベルを含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalk Server 2000 で実行するように設計されているコンポーネントの最初のパラメータは、Transport Dictionary オブジェクトです。Transport Dictionary の値は、そのコンポーネントが読み取って処理します。サーバーからすべてのアプリケーション統合コンポーネント用として提供される文字列値は、次のとおりです。

  • Src_ID_Type : 送信元組織に使用する識別子の種類です。

  • Src_ID_Value : 送信元組織識別子の値です。

  • Dest_ID_Type : 送信先組織に使用する識別子の種類です。

  • Dest_ID_Value : 送信先組織識別子の値です。

  • Document_Name : 入力ドキュメント定義の名前です。

  • Tracking_ID : グローバル一意識別子 (GUID) に基づいたキー値で、追跡に使用します。

Commerce Server の注文処理パイプラインで実行するコンポーネントの最初のパラメータには、OrderForm オブジェクトが含まれています。

このメソッドは、サーバーがコンポーネントにドキュメントを送信する場合、実行時に呼び出されます。このメソッドは、IPipelineComponentAdmin インターフェイスの SetConfigData メソッドの直後に呼び出されます。ドキュメントは、Dictionary オブジェクトの working_data フィールド内のディクショナリとして最初のパラメータに渡されます。コンポーネントは、IInterchange インターフェイスの SubmitSync メソッドを使用して、ResponseField キーを Dictionary オブジェクトに追加し、アプリケーションにテキストベースの応答を返すことができます。

コンポーネントは、処理に関する問題が発生した場合、エラーを発生させ、サーバーが後で送信を再試行できるようにする必要があります。また、再試行がすべて完了したら、ドキュメントを保留キューに送信できるようにする必要があります。エラーが返されない場合、サーバーは、コンポーネントがデータを正しく処理したと見なします。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : pipecomp.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb) を使用します。


IPipelineComponentAdmin インターフェイス[C++]

IPipelineComponentAdmin オブジェクト [Visual Basic]

このオブジェクトは、コンポーネントとコンポーネントのユーザー インターフェイスとの間で使用します。

C++ では、PipelineComponentAdmin オブジェクトのメソッドにアクセスするには IPipelineComponentAdmin インターフェイスを使用します。

次の表は、PipelineComponentAdmin オブジェクトのメソッドを示しています。

メソッド | 説明
GetConfigData | ユーザー インターフェイスのコンポーネントの構成データを含む Dictionary オブジェクトを返し、これらの値を表示します。
SetConfigData | Dictionary オブジェクトのコンテンツを使用して、コンポーネントの構成設定を設定します。

解説

アプリケーション統合コンポーネントは、BizTalk Server 2000 に属していることが認識できるように正しく登録する必要があります。アプリケーション統合コンポーネントの登録は、カテゴリ ID CATID_BIZTALK_AIC で登録されます。CATID は bts_sdk_guids.h ファイルで定義されます。詳細については、「アプリケーション統合コンポーネントの登録」を参照してください。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : pipecomp.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb) を使用します。

関連項目

アプリケーション統合コンポーネントの作成


IPipelineComponentAdmin::GetConfigData メソッド [C++]

IPipelineComponentAdmin.GetConfigData メソッド [Visual Basic]

GetConfigData メソッドは、その値を表示するために使用するコンポーネントの構成データを含む Dictionary オブジェクトを返します。GetConfigData を使用すると、ユーザー インターフェイス コンポーネントで、その現在の値を読み取り、最初にプロパティ ページに表示できます。

構文

[C++]

HRESULT GetConfigData(
IDispatch** ppConfigDictionary
);

[Visual Basic]

object.GetConfigData()

パラメータ

[C++]

ppConfigDictionary

[out, retval] ユーザー インターフェイスで構成データを読み取ることができる Dictionary オブジェクトへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、ユーザー インターフェイスで構成データを読み取ることができる CDictionary オブジェクトをオプションで返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

BizTalkPort オブジェクトを初めて保存するとき、このメソッドが呼び出され、提供された Dictionary オブジェクトからのアプリケーション統合コンポーネント (AIC) を自動構成するために使用する既定値が取得されます。コンポーネントはすべての必須プロパティの既定値を、可能な場合は必ず提供する必要があります。

このメソッドは、ユーザーがプロパティ ページを選択したときに呼び出され、プロパティ ページの既定値を提供するのに使用されます。プロパティ ページが閉じられると、このメソッドが再び呼び出されます。この返された Dictionary オブジェクトのコンテンツは使用されません。

コンポーネントは、常に GetConfigData から有効なディクショナリ ポインタを返す必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : pipecomp.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb) を使用します。


IPipelineComponentAdmin::SetConfigData メソッド [C++]

IPipelineComponentAdmin.SetConfigData メソッド [Visual Basic]

SetConfigData メソッドは、Dictionary オブジェクトのコンテンツを使用して、コンポーネントの構成を設定します。このメソッドを使用することにより、ユーザー インターフェイスはこれらの値の設定と変更を行います。SetConfigData を使用すると、ユーザー インターフェイスでプロパティ ページの更新値をコンポーネントに書き込むことができます。

構文

[C++]

HRESULT SetConfigData(
IDispatch* pConfigDictionary
);

[Visual Basic]

object.SetConfigData( _
 pConfigDictionary As Object _
)

パラメータ

[C++]

pConfigDictionary

[in] 構成情報を含む Dictionary オブジェクトへのポインタです。

[Visual Basic]

pConfigDictionary

構成情報を含む CDictionary オブジェクトです。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

プロパティ ページが保存されると、サーバーは SetConfigData メソッドを呼び出します。SetConfigData メソッドは、ユーザーがプロパティ ページに入力した値を確認するために使用されます。この提供された Dictionary オブジェクトのコンテンツは、データベースにも格納されます。

このメソッドは、サーバーがコンポーネントにドキュメントを送信するとき、IPipelineComponent インターフェイスの Execute メソッドの直前の実行時に呼び出されます。設計時に自動構成またはプロパティ ページの更新によって格納されたデータは、コンポーネントに渡され、Execute を呼び出す前のプロパティのセットアップを可能にします。

コンポーネントは SetConfigData で提供されたプロパティを検証し、無効なプロパティまたは欠落しているプロパティがあればエラーを発生させます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : pipecomp.h をインクルードします。
ライブラリ : Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb) を使用します。


ISchemaImporter インターフェイス[C++]

SchemaImporter オブジェクト [Visual Basic]

このオブジェクトは、DTD、XDR、および整形式 XML ドキュメントのインポートを処理するために使用します。

C++ では、SchemaImporter オブジェクトのプロパティとメソッドにアクセスするには ISchemaImporter インターフェイスを使用します。

次の表は、SchemaImporter オブジェクトのプロパティを示しています。

プロパティ | 説明
ImportFormatDescription (インポート書式の説明) | サポートされているインポート書式に関する説明テキストを返します。
ImportFormatIcon (インポート書式のアイコン) | サポートされているインポート書式のアイコンを返します。
NumberOfSupportedImportFormats (サポートされているインポート書式数) | 抽出対象のスキーマがある、サポートされているデータ形式の数を返します。

次の表は、SchemaImporter オブジェクトのメソッドを示しています。

メソッド | 説明
ExtractXMLSchema | ドキュメントからスキーマを抽出します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporter::ExtractXMLSchema メソッド [C++]

SchemaImporter.ExtractXMLSchema メソッド [Visual Basic]

ExtractXMLSchema メソッドは、ドキュメントからスキーマを抽出します。

構文

[C++]

HRESULT ExtractXMLSchema(
long lFormatIndex,
 BSTR strDocumentPath,
IDispatch** ppSchemaDOM
);

[Visual Basic]

object.ExtractXMLSchema( _
lFormatIndex As Long, _
 bstrDocumentPath As String _
)

パラメータ

[C++]

lFormatIndex

[in] インポート対象のスキーマがあるドキュメントの型を指定するインデックス値です。整形式 XML をインポートする場合は 0 を、ドキュメント型定義 (DTD) をインポートする場合は 1 を、XDR スキーマをインポートする場合は 2 を渡します。

strDocumentPath

[in] インポート対象のスキーマがあるドキュメントへのパスです。

ppSchemaDOM

[out, retval] 抽出した XML スキーマを含む IDispatch インターフェイスへのポインタのアドレスです。

[Visual Basic]

lFormatIndex

インポート対象のスキーマがあるドキュメントの型を指定するインデックス値です。整形式 XML をインポートする場合は 0 を、ドキュメント型定義 (DTD) をインポートする場合は 1 を、XDR スキーマをインポートする場合は 2 を渡します。

bstrDocumentPath

インポート対象のスキーマがあるドキュメントへのパスです。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このメソッドは、抽出した XML スキーマに関する情報を含むオブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporter::ImportFormatDescription プロパティ [C++]

SchemaImporter.ImportFormatDescription プロパティ [Visual Basic]

ImportFormatDescription プロパティは、サポートされているインポート書式に関する説明テキストを返します。

構文

[C++]
HRESULT get_ImportFormatDescription(
     long lFormatIndex,
     BSTR* ppbstrDescription
);
[Visual Basic]
object.ImportFormatDescription( _
     lFormatIndex As Long _
)

パラメータ

[C++]

lFormatIndex

[in] インポート対象のスキーマがあるドキュメントの型を指定するインデックス値です。整形式 XML をインポートする場合は 0 を、ドキュメント型定義 (DTD) をインポートする場合は 1 を、XDR スキーマをインポートする場合は 2 を渡します。

ppbstrDescription

[out, retval] 入力ドキュメント書式の説明テキストを含む BSTR へのポインタです。

[Visual Basic]

lFormatIndex

インポート対象のスキーマがあるドキュメントの型を指定するインデックス値です。整形式 XML をインポートする場合は 0 を、ドキュメント型定義 (DTD) をインポートする場合は 1 を、XDR スキーマをインポートする場合は 2 を渡します。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、入力ドキュメント書式の説明テキストを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporter::ImportFormatIcon プロパティ [C++]

ISchemaImporter.ImportFormatIcon プロパティ [Visual Basic]

ImportFormatIcon プロパティは、サポートされているインポート書式のアイコンを返します。

構文

[C++]
HRESULT get_ImportFormatIcon(
     long lFormatIndex,
     long* pIconID
);
[Visual Basic]
object.ImportFormatIcon( _
     lFormatIndex As Long _
)

パラメータ

[C++]

lFormatIndex

[in] インポート対象のスキーマがあるドキュメントの型を指定するインデックス値です。整形式 XML をインポートする場合は 0 を、ドキュメント型定義 (DTD) をインポートする場合は 1 を、XDR スキーマをインポートする場合は 2 を渡します。

pIconID

[out, retval] 入力書式のアイコン識別子を含む long へのポインタです。

[Visual Basic]

lFormatIndex

インポート対象のスキーマがあるドキュメントの型を指定するインデックス値です。整形式 XML をインポートする場合は 0 を、ドキュメント型定義 (DTD) をインポートする場合は 1 を、XDR スキーマをインポートする場合は 2 を渡します。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、入力書式のアイコン識別子を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporter::NumberOfSupportedImportFormats プロパティ [C++]

SchemaImporter.NumberOfSupportedImportFormats プロパティ [Visual Basic]

NumberOfSupportedImportFormats プロパティは、抽出対象のスキーマがある、サポートされているデータ形式の数を返します。

構文

[C++]
HRESULT get_NumberOfSupportedImportFormats(
     long* plNumber
);
[Visual Basic]
object.NumberOfSupportedImportFormats

パラメータ

[C++]

plNumber

[out, retval] サポートされているインポート書式の数を示す long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、サポートされているインポート書式の数を示す Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterError インターフェイス[C++]

SchemaImporterError オブジェクト [Visual Basic]

このオブジェクトは、エラーまたは警告を識別し、解読するために使用します。

C++ では、SchemaImporterError オブジェクトのプロパティにアクセスするには ISchemaImporterError インターフェイスを使用します。

次の表は、SchemaImporterError オブジェクトのプロパティを示しています。

プロパティ | 説明
IsWarning (警告) | オブジェクトがエラーと警告のどちらであるかを示す値を返します。
NodePath (ノード パス) | エラーまたは警告を生成したノードへのパスを返します。
Text (テキスト) | エラー メッセージまたは警告メッセージを返します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterError::IsWarning プロパティ [C++]

SchemaImporterError.IsWarning プロパティ [Visual Basic]

IsWarning プロパティは、オブジェクトがエラーと警告のどちらであるかを示す値を返します。

構文

[C++]
HRESULT get_IsWarning(
     VARIANT_BOOL* pIsWarning
);
[Visual Basic]
object.IsWarning

パラメータ

[C++]

pIsWarning

[out, retval] オブジェクトが警告である場合は VARIANT_TRUE に、エラーであることを示す場合は VARIANT_FALSE に設定します。

[Visual Basic]

None

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは Boolean を返します。オブジェクトが警告である場合は True に、エラーであることを示す場合は False に設定します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterError::NodePath プロパティ [C++]

SchemaImporterError.NodePath プロパティ [Visual Basic]

NodePath プロパティは、エラーまたは警告を生成したノードへのパスを返します。

構文

[C++]
HRESULT get_NodePath(
     BSTR* pbstrNodePath
);
[Visual Basic]
object.NodePath

パラメータ

[C++]

pbstrNodePath

[out, retval] エラーまたは警告を生成したノードの完全修飾名を含む BSTR へのポインタです。

[Visual Basic]

None

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、エラーまたは警告を生成したノードの完全修飾名である文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterError::Text プロパティ [C++]

SchemaImporterError.Text プロパティ [Visual Basic]

Text プロパティは、エラー メッセージまたは警告メッセージを返します。

構文

[C++]
HRESULT get_Text(
     BSTR* pbstrText
);
[Visual Basic]
object.Text

パラメータ

[C++]

pbstrText

[out, retval] エラーまたは警告に関連付けられたテキストを含む BSTR へのポインタです。

[Visual Basic]

None

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、エラーまたは警告に関連付けられたテキストである文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterErrorProvider インターフェイス[C++]

SchemaImporterErrorProvider オブジェクト [Visual Basic]

このオブジェクトは、エラーまたは警告を返すために使用します。

C++ では、SchemaImporterErrorProvider オブジェクトのプロパティにアクセスするには ISchemaImporterErrorProvider インターフェイスを使用します。

次の表は、SchemaImporterErrorProvider オブジェクトのプロパティを示しています。

プロパティ | 説明
Error (エラー) | エラーまたは警告を返します。
NumberOfErrors (エラー数) | エラーまたは警告の数を返します。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterErrorProvider::Error プロパティ [C++]

SchemaImporterErrorProvider.Error プロパティ [Visual Basic]

Error プロパティは、エラーまたは警告を返します。

構文

[C++]
HRESULT get_Error(
     long lIndex,
     ISchemaImporterError** pdswError
);
[Visual Basic]
object.Error( _
     lIndex As Long _
)

パラメータ

[C++]

lIndex

[in] 必要なエラーまたは警告のインデックスです。

pdswError

[out, retval] エラーまたは警告を含む ISchemaImporterError インターフェイスへのポインタのアドレスです。

[Visual Basic]

lIndex

必要なエラーまたは警告のインデックスです。

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、エラーまたは警告を含む SchemaImporterError オブジェクトを返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


ISchemaImporterErrorProvider::NumberOfErrors プロパティ [C++]

SchemaImporterErrorProvider.NumberOfErrors プロパティ [Visual Basic]

NumberOfErrors プロパティは、エラーまたは警告の数を返します。

構文

[C++]
HRESULT get_NumberOfErrors(
     long* plNumberOfErrors
);
[Visual Basic]
object.NumberOfErrors

パラメータ

[C++]

plNumberOfErrors

[out, retval] エラーの数を示す long へのポインタです。

[Visual Basic]

None

戻り値

[C++]

BizTalk Server によって返されるエラー メッセージの一覧については、「エラー メッセージ」を参照してください。

[Visual Basic]

このプロパティは、エラーの数を示す Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「エラー メッセージ」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SchemaImporter.h をインクルードします。
ライブラリ : Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll) を使用します。


受信確認列挙

次に示す受信確認列挙は、IBizTalkAcknowledge インターフェイスのプロパティおよびパラメータの値を提供します。

  • DTA_ACK_STATUS

  • GeneratedReceiptLevel


DTA_ACK_STATUS

DTA_ACK_STATUS 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
DTA_ACK_NONE | 0 | 受信確認は必要ありません。
DTA_ACK_PENDING | 1 | 受信確認が必要ですが、まだ到着していません。
DTA_ACK_OVERDUE | 2 | 受信確認はタイムアウトしました。
DTA_ACK_ACCEPTED | 3 | 受信確認が到着しました。ステータスは [受信済] です。
DTA_ACK_PARTIALLY_ACCEPTED | 4 | 受信確認が到着しました。ステータスは [受信済 (エラー)] です。
DTA_ACK_REJECTED | 5 | 受信確認が到着しました。ステータスは [受信拒否] です。


GeneratedReceiptLevel

GeneratedReceiptLevel 列挙は、次のいずれかの値になります。

名前 | 値 | 説明
NoReceiptGenerated | 0 | 受信確認は作成されません。
DocReceiptGenerated | 1 | 各ドキュメントに受信確認が生成されます。
GroupReceiptGenerated | 2 | 各グループに受信確認が生成されます。
InterchangeReceiptGenerated | 3 | 各インターチェンジに受信確認が生成されます。


Functoid 列挙

以下の Functoid 列挙について、プロパティとパラメータの値を説明します。

  • CONNECTION_TYPE

  • FUNC_CATEGORY

  • FUNC_TYPE

  • SCRIPT_CATEGORY


CONNECTION_TYPE

CONNECTION_TYPE 列挙は、次の値を定義します。

名前 | 値 | 説明
CONNECT_TYPE_NONE | 0 | 接続の種類がありません。
CONNECT_TYPE_FIELD | 1 | 接続の種類はフィールドです。
CONNECT_TYPE_RECORD | 2 | 接続の種類はレコードです。
CONNECT_TYPE_RECORD_CONTENT | 4 | 接続の種類はレコード コンテンツです。
CONNECT_TYPE_FUNC_STRING | 8 | 接続の種類の関数は文字列です。
CONNECT_TYPE_FUNC_MATH | 16 | 接続の種類の関数は数値演算です。
CONNECT_TYPE_FUNC_DATACONV | 32 | 接続の種類の関数はデータ変換です。
CONNECT_TYPE_FUNC_DATETIME_FMT | 64 | 接続の種類の関数は日付/時刻形式です。
CONNECT_TYPE_FUNC_SCIENTIFIC | 128 | 接続の種類の関数は関数です。
CONNECT_TYPE_FUNC_BOOLEAN | 256 | 接続の種類の関数はブール値です。
CONNECT_TYPE_FUNC_SCRIPTER | 512 | 接続の種類の関数はスクリプトです。
CONNECT_TYPE_FUNC_COUNT | 1024 | 接続の種類の関数はカウントです。
CONNECT_TYPE_FUNC_INDEX | 2048 | 接続の種類の関数はインデックスです。
CONNECT_TYPE_FUNC_CUMULATIVE | 4096 | 接続の種類の関数は累積です。
CONNECT_TYPE_FUNC_VALUE_MAPPING | 8192 | 接続の種類の関数は値のマッピングです。
CONNECT_TYPE_FUNC_LOOPING | 16384 | 接続の種類の関数はループです。
CONNECT_TYPE_FUNC_ITERATION | 32768 | 接続の種類の関数は繰り返しです。
CONNECT_TYPE_FUNC_DBLOOKUP | 65536 | 接続の種類の関数はデータベース検索です。
CONNECT_TYPE_FUNC_DBEXTRACT | 131072 | 接続の種類の関数はデータベース抽出です。
CONNECT_TYPE_ALL | -1 | 接続の種類には、すべての種類が含まれています。
CONNECT_TYPE_ALL_EXCEPT_RECORD | -3 | 接続の種類には、レコードを除くすべての種類が含まれています。


FUNC_CATEGORY

FUNC_CATEGORY 列挙は、次の値を定義します。

名前 | 値 | 説明
FUNC_CATEGORY_STRING | 3 | 関数のカテゴリは文字列です。
FUNC_CATEGORY_MATH | 4 | 関数のカテゴリは数値演算です。
FUNC_CATEGORY_DATACONV | 5 | 関数のカテゴリはデータ変換です。
FUNC_CATEGORY_DATETIME_FMT | 6 | 関数のカテゴリは日付/時刻形式です。
FUNC_CATEGORY_SCIENTIFIC | 7 | 関数のカテゴリは関数です。
FUNC_CATEGORY_BOOLEAN | 8 | 関数のカテゴリはブール値です。
FUNC_CATEGORY_SCRIPTER | 9 | 関数のカテゴリはスクリプトです。
FUNC_CATEGORY_COUNT | 10 | 関数のカテゴリはカウントです。この値は、このリリースではサポートされていません。
FUNC_CATEGORY_INDEX | 11 | 関数のカテゴリはインデックスです。
FUNC_CATEGORY_CUMULATIVE | 12 | 関数のカテゴリは累積です。
FUNC_CATEGORY_VALUE_MAPPING | 13 | 関数のカテゴリは値のマッピングです。この値は、このリリースではサポートされていません。
FUNC_CATEGORY_LOOPING | 14 | 関数のカテゴリはループです。この値は、このリリースではサポートされていません。
FUNC_CATEGORY_ITERATION | 15 | 関数のカテゴリは繰り返しです。この値は、このリリースではサポートされていません。
FUNC_CATEGORY_DBLOOKUP | 16 | 関数のカテゴリはデータベース検索です。
FUNC_CATEGORY_DBEXTRACT | 17 | 関数のカテゴリはデータベース抽出です。
FUNC_CATEGORY_UNKNOWN | 31 | 関数のカテゴリは不明です。


FUNC_TYPE

FUNC_TYPE 列挙は、次の値を定義します。

名前 | 値 | 説明
FUNC_TYPE_STD | 1 | 関数の種類は標準です。
FUNC_TYPE_VARIABLEINPUT | 2 | 関数の種類は変数入力です。
FUNC_TYPE_SCRIPTOR | 3 | 関数の種類はスクリプトです。


SCRIPT_CATEGORY

SCRIPT_CATEGORY 列挙は、次の値を定義します。

名前 | 値 | 説明
SCRIPT_CATEGORY_VBSCRIPT | 0 | カスタム Functoid 関数は、Microsoft Visual Basic Scripting Edition (VBScript) 言語で記述されています。
SCRIPT_CATEGORY_JSCRIPT | 1 | カスタム Functoid 関数は、Microsoft JScript 言語で記述されています。この値は、このリリースではサポートされていません。
SCRIPT_CATEGORY_XSLSCRIPT | 2 | カスタム Functoid 関数は、Extensible Stylesheet Language (XSL) で記述されています。この値は、このリリースではサポートされていません。


概念

ここでは、Microsoft BizTalk Server 2000 の拡張方法を理解するうえで重要な概念の詳細について説明します。BizTalk Server 2000 では、データの変換、デジタル署名、暗号化と暗号解読、解析、シリアライズ、およびドキュメントのトランスポートを実行できます。さらに、独自のアプリケーション統合コンポーネント (AIC) を作成して、BizTalk Server 2000 の機能を拡張することもできます。

次のトピックが含まれます。

  • アプリケーション統合コンポーネントの作成

  • IBizTalkParserComponent インターフェイスの使用

  • IBizTalkSerializerComponent インターフェイスの使用

  • パーサー コンポーネントおよびシリアライザ コンポーネントによる追跡データベースのサポート

  • 受信確認関連付けコンポーネントの作成

コードのサンプルについては、「BizTalk メッセージ サービスのコード サンプル」を参照してください。


アプリケーション統合コンポーネントの作成

アプリケーション統合コンポーネント (AIC) を作成する場合、IPipelineComponent インターフェイスを使用するパイプライン モデルか、IBTSAppIntegration インターフェイスを使用するライトウェイト モデルを実装することができます。

アプリケーション統合コンポーネントとは、BizTalk Server ステータス エンジンがアプリケーションにデータを配信するために呼び出す COM オブジェクトのことです。アプリケーション統合時に AIC を使用するように BizTalk Server 2000 でメッセージ ポートを構成すると、このコンポーネントのインスタンスが自動的に作成され、必要なデータが渡されます。そしてコンポーネントは、このデータをアプリケーションに返信する際の処理方法を判断します。これは、プライベート API 呼び出しの使用、ほかの COM オブジェクトの呼び出し、データベース書き込みの使用などによって行われます。

既定では、AIC は LocalSystem アカウントで実行されます。別のセキュリティ コンテキストが必要な場合は、そのセキュリティ コンテキストを AIC の実装の一部として設定します。ただし、AIC を COM+ アプリケーションとしてインストールする場合、管理者はコンポーネント サービスを使用して AIC のセキュリティを構成できます。

関連項目

ライトウェイト アプリケーション統合コンポーネント

パイプライン アプリケーション統合コンポーネント

アプリケーション統合コンポーネントの登録


パイプライン アプリケーション統合コンポーネント

BizTalk Server 2000 でアプリケーションを統合する方法の 1 つに、パイプライン コンポーネントの作成があります。これは、Microsoft Site Server Commerce Edition 3.0 で、Commerce Interchange パイプライン (CIP) および Order Processing パイプライン (OPP) でアプリケーションを統合するために使用されるモデルと同じモデルです。BizTalk Server 2000 では、この方法がサポートされているため、CIP および OPP のアプリケーション統合のために作成されたパイプライン コンポーネントには互換性があります。これは、コンポーネントに構成プロパティが必要な場合に役立つテクニックでもあります。

パイプライン コンポーネントの主なエントリ ポイントは、IPipelineComponent インターフェイスの Execute メソッドです。これは、BizTalk Server 2000 がコントロールをパイプライン コンポーネントに転送し、データをパイプライン コンポーネントに渡すときに呼び出されるメソッドです。このメソッドを実装することにより、コンポーネントの処理が実行されます。

関連項目

IPipelineComponent

IPipelineComponentAdmin


ライトウェイト アプリケーション統合コンポーネント

BizTalk Server 2000 では、ライトウェイト アプリケーション統合モデルが必要なアプリケーション開発者を対象とした追加モデルをサポートしています。このモデルでは、設計時のユーザー インターフェイスおよび構成プロパティはサポートされていません。このモデルには、エントリ ポイントとして単一のメソッドを含む単一のインターフェイスが必要です。コンポーネントを実装すると、ドキュメントは IBTSAppIntegration インターフェイスの ProcessMessage メソッドを介してこのコンポーネントに渡されます。

IBTSAppIntegration は、コンポーネントのプロパティは必要とせず、ドキュメントを受信するためのエントリ ポイントのみ必要とするアプリケーションで使用します。これは、パイプライン コンポーネントよりも簡単なアプリケーション統合の方法です。BizTalk Server 2000 は、まずこのインターフェイスへのクエリを実行します。このインターフェイスが実装されていない場合は、パイプライン コンポーネント インターフェイスへのクエリを実行します。


アプリケーション統合コンポーネントの登録

BizTalk Server 2000 でアプリケーション統合コンポーネント (AIC) を使用するには、すべてのパイプライン コンポーネントのカテゴリ ID と、特定の種類 (この場合はアプリケーション統合) のカテゴリ ID にそのコンポーネントを登録します。

よりよく分離させるために、その AIC をアウトプロセス コンポーネントとして登録します。パフォーマンスを向上させるために、AIC をインプロセス (inproc) コンポーネントとして登録することができます。ただし、inproc コンポーネントがエラー状態で応答ができないと、BizTalk Server の障害の原因となることがあります。したがって、AIC を inproc コンポーネントとして登録する場合は、あらかじめ十分にテストを行う必要があります。

注

  • COM+ アプリケーションとして登録したアウトプロセス コンポーネントは、対話ユーザー以外の ID で実行されるよう構成する必要があります。

  • アプリケーション統合コンポーネントは、BizTalk Server Administrators グループ内のユーザーが登録する必要があります。BizTalk Server Administrators グループは、BizTalk Server 2000 がインストールされると作成されます。このグループには、必要に応じてユーザーを追加することができます。

コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/) で、「Platform SDK Documentation」の「Component Services」を参照してください。

アフィニティの割り当て

各アプリケーション統合コンポーネント (AIC) は、2 つのカテゴリ ID に関連付ける必要があります。1 つのカテゴリ ID は、コンポーネントに BizTalk Server コンポーネントとしてのマークを付けます。このマークが付けられたコンポーネントは、BizTalk Server 管理コンソールのコンポーネントの一覧に表示されます。もう 1 つのカテゴリ ID は、コンポーネントの種類または目的を示します。この 2 つ目の関連付けをアフィニティと呼びます。アフィニティがアプリケーション統合コンポーネントとして登録されているコンポーネントのみ、そのコンポーネントの一覧に表示されます。

Microsoft Visual C++ で ATL を使用して作成した AIC のアフィニティを登録するには、次のコードをヘッダー ファイルに記述します。

#include "bts_sdk_guids.h"
// Implement the Component and AIC Category IDs (CATID)
BEGIN_CATEGORY_MAP(AIC_ClassName)
    IMPLEMENTED_CATEGORY(CATID_BIZTALK_COMPONENT)
    IMPLEMENTED_CATEGORY(CATID_BIZTALK_AIC)
END_CATEGORY_MAP()

Microsoft Visual Basic で作成した AIC のアフィニティを登録するには、次の手順に従ってください。

  1. Regsvr32.exe を使用してコンポーネントを登録した後、レジストリで次のキーの下にある AIC の CLSID を検索します。

    HKEY_CLASSES_ROOT\CLSID

  2. AIC の Implemented Categories キーを展開します。

  3. 次の名前の 2 つの新しいキーを追加します。

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{5C6C30E7-C66D-40e3-889D-08C5C3099E52}

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{BD193E1D-D7DC-4b7c-B9D2-92AE0344C836}

これらの GUID は、Program Files\Microsoft BizTalk Server\SDK\Include フォルダの bts_sdk_guids.h にあります。手順 3 の最初のキーは、AIC が BizTalk Server コンポーネント (CATID_BIZTALK_COMPONENT) であることを示します。2 つ目のキーは、コンポーネントが AIC (CATID_BIZTALK_AIC) であることを示します。

アフィニティのテスト

アフィニティをテストするには、BizTalk メッセージ マネージャを使用して、AIC を使用するポートを作成します。詳細については、「アプリケーション統合コンポーネントの選択」を参照してください。


IBizTalkParserComponent インターフェイスの使用

パーサーには、次の 2 つの役割があります。

  • それ以降の処理のために、ドキュメントを XML に変換する。

  • チャネルの選択に必要なパラメータ (送信元修飾子、送信元識別子、送信先修飾子、送信先識別子、およびドキュメント定義名) を取得する。これらのフィールドが返されると、ドキュメント処理に必要なチャネルを選択するために、IInterchange インターフェイスの Submit メソッドのパラメータと結合されます。

このインターフェイスは、1 つのインターチェンジのコンポーネントから情報を取得します。受信データ ストリームが複数のインターチェンジである場合、サーバーは各インターチェンジの境界でコンポーネントを選択します。これにより、インターチェンジを 1 度に 1 つだけ処理すればよいため、コンポーネントの構築を簡略化できます。スレッド 1 つにつき 1 つのコンポーネントのインスタンスが存在します。オブジェクトは、複数のスレッドで安全である必要がありません。このインターフェイスは C++ でのみサポートされています。

IBizTalkParserComponent インターフェイスの ProbeInterchangeFormat メソッドがドキュメント一覧の途中でエラーを返すと、サーバー上に複数のカスタム パーサーが存在し、エラーが発生したパーサー以降にあるカスタム パーサーがそのドキュメント型を処理できる場合でも、サーバーはドキュメント型をそれ以上検出できなくなります。最初のカスタム パーサーが失敗すると、ほかのカスタム パーサーで解析できるものであっても、後続のドキュメントは解析されません。これは、解析の失敗時に、サーバーがすべての解析処理を終了するためです。

詳細については、「IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序」を参照してください。

関連項目

アプリケーション統合コンポーネントの登録


IBizTalkParserComponent インターフェイスのメソッドの呼び出し順序

次の表は、サンプルのインターチェンジに基づいた、メソッドの呼び出し順序を示しています。

2 つのグループがあり、最初のグループに 2 つのドキュメントがあり、2 つ目のグループに 1 つのドキュメントがあるインターチェンジの場合、メソッドは次の順序で呼び出されます。

メソッド | 戻り値
ProbeInterchangeFormat | 空でない書式の文字列
GetInterchangeDetails | なし
GroupsExist | True
GetGroupDetails | なし
GetNextDocument | LastDoc パラメータは False に設定されます。
GetNativeDocumentOffsets | なし
GetNextDocument | LastDoc パラメータは True に設定されます。
GetNativeDocumentOffsets | なし
GetGroupSize | LastGroup パラメータは False に設定されます。
GetGroupDetails | なし
GetNextDocument | LastDoc パラメータは True に設定されます。
GetNativeDocumentOffsets | なし
GetGroupSize | LastGroup パラメータは True に設定されます。

2 つのドキュメントがあるインターチェンジの場合、メソッドは次の順序で呼び出されます。

メソッド | 戻り値
ProbeInterchangeFormat | 空でない書式の文字列
GetInterchangeDetails | なし
GroupsExist | False
GetNextDocument | LastDoc パラメータは False に設定されます。
GetNativeDocumentOffsets | なし
GetNextDocument | LastDoc パラメータは True に設定されます。
GetNativeDocumentOffsets | なし


IBizTalkSerializerComponent インターフェイスの使用

シリアライザは、ドキュメントを XML 形式から元のネイティブ形式に変換します。このインターフェイスは、1 つのインターチェンジで動作することを想定しており、1 つのインターチェンジのコンポーネントから情報を取得するよう設計されています。これにより、インターチェンジを 1 度に 1 つだけ処理すればよいため、このコンポーネントの構築を簡略化できます。スレッド 1 つにつき 1 つのインスタンスしか存在しません。オブジェクトは、複数のスレッドで安全である必要がありません。このインターフェイスは C++ でのみサポートされています。

関連項目

アプリケーション統合コンポーネントの登録


IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序

次の表は、サンプルのインターチェンジに基づいた、IBizTalkSerializerComponent インターフェイスのメソッドの呼び出し順序を示しています。

1 つのドキュメントがあるインターチェンジの場合、メソッドは次の順序で呼び出されます。

メソッド | 戻り値
Init | numdocs パラメータは 1 に設定されます。
AddDocument | docHandle パラメータは 0 に設定されます。
GetInterchangeInfo | numGroups パラメータは 0 に設定されます。
GetDocInfo | docHandle パラメータは 0 に設定されます。

1 つのグループがあり、そのグループに 1 つのドキュメントがあるインターチェンジの場合、メソッドは次の順序で呼び出されます。

メソッド | 戻り値
Init | numdocs パラメータは 1 に設定されます。
AddDocument | docHandle パラメータは 0 に設定されます。
GetInterchangeInfo | numGroups パラメータは 1 に設定されます。
GetGroupInfo | numdocs パラメータは 1 に設定されます。
GetDocInfo | docHandle パラメータは 0 に設定されます。

2 つのグループがあり、最初のグループに 2 つのドキュメントがあり、2 つ目のグループに 1 つのドキュメントがあるインターチェンジの場合、メソッドは次の順序で呼び出されます (バッチのサポートを前提とします)。

メソッド | 戻り値
Init | numdocs パラメータは 3 に設定されます。
AddDocument | handle パラメータは 0 に設定されます。
AddDocument | handle パラメータは 1 に設定されます。
AddDocument | handle パラメータは 2 に設定されます。
GetInterchangeInfo | numGroups パラメータは 2 に設定されます。
GetGroupInfo | numdocs パラメータは 2 に設定されます。
GetDocInfo | handle パラメータは 1 に設定されます。
GetDocInfo | handle パラメータは 0 に設定されます。
GetGroupInfo | numdocs パラメータは 1 に設定されます。
GetDocInfo | handle パラメータは 2 に設定されます。

関連項目

IBizTalkSerializerComponent


パーサー コンポーネントおよびシリアライザ コンポーネントによる追跡データベースのサポート

カスタム パーサーまたはカスタム シリアライザを作成する場合、コンポーネントが BizTalk Server 追跡データベースをサポートするよう設定できます。追跡データベースをサポートするには、コンポーネントが IDictionary インターフェイスを使用して、キーと値のペアを追跡データベースに追加するよう設定します。

インターチェンジ テーブル

次の表は、カスタム コンポーネントを使用してインターチェンジ レベルで追跡データベースをサポートするために使用するキーの一覧です。追跡データベースで使用されるテーブルは dta_interchange_details です。

ディクショナリ キー | 受信と 送信の区別 | 追跡データベースの ログに記録される列 | 説明
Src_ID_Type | 両方 | *nvcSrcAliasQualifier | これは送信元組織の修飾子です。この値は Submit 呼び出しのパラメータ、または BizTalk Server 管理コンソールのユーザー インターフェイスの受信機能から取得されます。パーサーはこの値を上書きし、チャネルの選択に使用するルーティング情報を操作します。
Src_ID_Value | 両方 | *nvcSrcAliasId | 送信元組織の修飾子の値が含まれます。この値は、Submit 呼び出しのパラメータ、または BizTalk Server 管理コンソールのユーザー インターフェイスの受信機能から取得されます。パーサーはこの値を上書きし、チャネルの選択に使用するルーティング情報を操作します。
In_Src_ID_App | 受信 | nvcSrcAppName | これは、EDI インターチェンジの送信元アプリケーションのインターチェンジ レベル識別子です。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信インターチェンジのログに記録されます。
Dest_ID_Type | 両方 | *nvcDestAliasQualifier | これは送信先組織の修飾子です。この値は、Submit 呼び出しのパラメータ、または BizTalk Server 管理コンソールのユーザー インターフェイスの受信機能から取得されます。パーサーはこの値を上書きし、チャネルの選択に使用するルーティング情報を操作します。
Dest_ID_Value | 両方 | *nvcDestAliasId | 送信先組織の修飾子の値が含まれます。この値は、Submit 呼び出しのパラメータ、または BizTalk Server 管理コンソールのユーザー インターフェイスの受信機能から取得されます。パーサーはこの値を上書きし、チャネルの選択に使用するルーティング情報を操作します。
In_Dest_ID_App | 受信 | nvcDestAppName | これは、EDI インターチェンジの送信先アプリケーションのインターチェンジ レベル識別子です。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信インターチェンジのログに記録されます。
interchange_id | 受信 | nvcControlID | これは、取引先との EDI インターチェンジ インスタンスの識別に使用する一意な制御番号です。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信インターチェンジのログに記録されます。
interchange_version | 受信 | nvcVersion | これは EDI インターチェンジのバージョンです。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信インターチェンジのログに記録されます。
Out_Src_ID_App | 送信 | *nvcSrcAppName | これは、EDI インターチェンジの送信元アプリケーションのインターチェンジ レベル識別子です。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信インターチェンジのログに記録されます。
Out_Dest_ID_App | 送信 | *nvcDestAppName | これは、EDI インターチェンジの送信先アプリケーションのインターチェンジ レベル識別子です。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信インターチェンジのログに記録されます。
out_interchange_id | 送信 | *nvcControlID | これは、取引先との EDI インターチェンジ インスタンスの識別に使用する一意な制御番号です。通常、シリアライザはこの値を生成します。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信インターチェンジのログに記録されます。
out_interchange_version | 送信 | *nvcVersion | これは EDI 標準のバージョンです。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信インターチェンジのログに記録されます。

注

  • dta_interchange_details テーブルのアスタリスク (*) の付いた列は、受信確認の照合に使用されます。

グループ テーブル

次の表は、カスタム コンポーネントを使用してグループ レベルで追跡データベースをサポートするために使用するキーの一覧です。追跡データベースで使用されるテーブルは dta_group_details です。このテーブルは、受信ドキュメントと送信ドキュメントの両方に適用されます。

ディクショナリ キー | 追跡データベースの ログに記録される列 | 説明
group_id | *nvcControlID | これは、EDI インターチェンジ内のグループ インスタンスの一意な制御番号です。パーサーとシリアライザは、このキーで値を設定できます。値は、追跡データベースの受信グループと送信グループのそれぞれのログに記録されます。受信ドキュメントの処理の場合、通常、シリアライザはこの値を生成します。
functional_identifier | *nvcFunctionalGroupID | これは、EDI グループ内のドキュメントの種類を表すコードです。パーサーとシリアライザは、このキーで値を設定できます。値は、追跡データベースの受信グループと送信グループのそれぞれのログに記録されます。シリアライザでは、この値はドキュメントの PropertySet から読み取ることができます。
application_sender_code | *nvcSrcAppName | これは、EDI グループ内の送信元アプリケーションのグループ レベル識別子です。パーサーとシリアライザは、このキーで値を設定できます。値は、追跡データベースの受信グループと送信グループのそれぞれのログに記録されます。シリアライザでは、この値はドキュメントの PropertySet から読み取ることができます。
application_receiver_code | *nvcDestAppName | これは、EDI グループ内の送信先アプリケーションのグループ レベル識別子です。パーサーとシリアライザは、このキーで値を設定できます。値は、追跡データベースの受信グループと送信グループのそれぞれのログに記録されます。シリアライザでは、この値はドキュメントの PropertySet から読み取ることができます。
standards_version | *nvcVersion | これは EDI 標準のバージョンです。パーサーとシリアライザは、このキーで値を設定できます。値は、追跡データベースの受信グループと送信グループのそれぞれのログに記録されます。
standards_release | *nvcRelease | これは、EDI 標準のバージョンのリリースです。パーサーとシリアライザは、このキーで値を設定できます。値は、追跡データベースの受信グループと送信グループのそれぞれのログに記録されます。

注

dta_group_details テーブルのアスタリスク (*) の付いた列は、受信確認の照合に使用されます。

受信ドキュメント テーブル

次の表は、カスタム コンポーネントを使用してドキュメント レベルで追跡データベースをサポートするために使用するキーの一覧です。追跡データベースで使用されるテーブルは dta_indoc_details です。このテーブルは、受信ドキュメントにのみ適用されます。

ディクショナリ キー | 追跡データベースの ログに記録される列 | 説明
doc_id | nvcControlID | これは、EDI ドキュメント インスタンスの一意な制御番号です。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信ドキュメントのログに記録されます。
standards_version | nvcVersion | これは EDI 標準のバージョンです。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信ドキュメントのログに記録されます。
standards_release | nvcRelease | これは、EDI 標準のバージョンのリリースです。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信ドキュメントのログに記録されます。
doc_type | nvcDocType | これは、ドキュメント型またはトランザクション セット識別子です。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信ドキュメントのログに記録されます。

送信ドキュメント テーブル

次の表は、カスタム コンポーネントを使用してドキュメント レベルで追跡データベースをサポートするために使用するキーの一覧です。追跡データベースで使用されるテーブルは dta_outdoc_details です。このテーブルは、送信ドキュメントにのみ適用されます。

ディクショナリ キー | 追跡データベースの ログに記録される列 | 説明
out_doc_doc_id | nvcControlID | これは、EDI ドキュメント インスタンスの一意な制御番号です。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信ドキュメントのログに記録されます。
out_doc_syntax | nvcSyntax | XML、X12、EDIFACT、H7 など、ドキュメントの構文を表すコードです。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信ドキュメントのログに記録されます。
out_doc_standards_version | nvcVersion | これは EDI 標準のバージョンです。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信ドキュメントのログに記録されます。シリアライザでは、この値はドキュメントの PropertySet から読み取ることができます。
out_doc_standards_release | nvcRelease | これは、EDI 標準のバージョンのリリースです。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信ドキュメントのログに記録されます。シリアライザでは、この値はドキュメントの PropertySet から読み取ることができます。
out_doc_doc_type | nvcDocType | これは、ドキュメント型またはトランザクション セット識別子です。シリアライザがこのディクショナリ キーで値を設定すると、値は追跡データベースの送信ドキュメントのログに記録されます。
Tracking_ID | uidTrackingGUID | これは、受信確認が生成されるドキュメントのトラッキング識別子です。

注

  • Tracking_ID キーは、AckDocument メソッドを呼び出す時に使用されます。

インターチェンジ テーブルおよびドキュメント テーブル

次の表は、カスタム コンポーネントを使用してインターチェンジ レベルおよびドキュメント レベルで追跡データベースをサポートするために使用するキーの一覧です。インターチェンジ データの追跡データベースで使用されるテーブルは dta_interchange_data です。ドキュメント データの追跡データベースで使用されるテーブルは dta_document_data です。

ディクショナリ キー | 受信と 送信の区別 | 追跡データベースの ログに記録される列 | 説明
in_codepage | 受信 | nCodePage | これは、インターチェンジやドキュメントのデータをエンコードするシステム コード ページの値です。パーサーがこのディクショナリ キーで値を設定すると、値は追跡データベースの受信インターチェンジ/ドキュメントに関連付けられたデータ レコードに記録されます。
out_codepage | 送信 | nCodePage | これは、インターチェンジやドキュメントのデータをエンコードするシステム コード ページの値です。シリアライザがこのディクショナリ キーで値を設定すると、追跡データベースの送信インターチェンジ/ドキュメントに関連付けられたデータ レコードに記録されます。

関連項目

追跡データベース スキーマについて


受信確認関連付けコンポーネントの作成

受信確認関連付けコンポーネントを実装すると、ドキュメント、ドキュメントのグループ、およびインターチェンジを受信確認に関連付けることができます。受信確認関連付けコンポーネントを使用するには、IBizTalkParserComponent インターフェイスを使用して、カスタム パーサーを実装します。カスタム パーサーを実装する理由は、サーバーが取得できるのは、IBizTalkParserComponent インターフェイスの GetNextDocument メソッドを呼び出すことにより使用される受信確認関連付けコンポーネントの progID のみだからです。

さらに、受信確認が生成される受信者側の BizTalk Server では、パーサー コンポーネントは、受信確認ステータスと必要な情報を受信確認 (既定受信など。ただし、既定受信は EDI の AK997 などの、ほかの受信ドキュメント スキーマにマップできます) に記載し、送信者側の関連付けコンポーネントが元の送信インターチェンジ、グループ、またはドキュメント レコードを識別できるようにする役割を持っています。XML ドキュメントの場合は、通常、GUID を使用するだけで十分です。ただし、EDI インターチェンジの場合は GUID が使用できない (EDI インターチェンジでは GUID 用のプレースホルダが存在しない) ため、一意の識別子として EDI 固有のフィールドを組み合わせる必要があります。たとえば、既定の X12 関連付けコンポーネントでは、バージョン、リリース、機能グループ ID、コントロール ID、送信元アプリケーション名、および送信先アプリケーション名のフィールドが組み合わされて使用されます。

サーバーが受信確認を受信ドキュメントとして受信するときは常に、パーサー コンポーネントの役割は、受信ドキュメントを受信確認として検出すること、関連付けに必要なすべての情報を抽出すること、および受信確認をトランスポート ディクショナリに記載することです。GetNextDocument メソッド呼び出しからの応答があると、パーサーは DocIsReceipt パラメータを TRUE に、CorrelationCompProgID パラメータを対応する関連付けコンポーネントの progID に設定します。

サーバーは、IBizTalkCorrelation インターフェイスの Correlate メソッドを呼び出し、IBizTalkAcknowledge オブジェクトと、作業データとしての受信確認を含むトランスポート ディクショナリにポインタで渡します。そして、受信確認関連付けコンポーネントの実装メソッドである Correlate メソッドは、パーサー コンポーネントが設定したドキュメント、ドキュメント グループ、またはインターチェンジに関する必要なすべての情報を、トランスポート ディクショナリから抽出します。Correlate メソッドは、これらの情報を使用して、IBizTalkAcknowledge インターフェイスの AckDocument、AckInterchange、AckGroup のいずれかを呼び出し、ドキュメント、グループ、またはインターチェンジの DTA_ACK_STATUS 値を設定します。

サーバーは直ちに IBizTalkCorrelation を呼び出すのではないことに注意してください。受信ドキュメントおよび関連付け progID は、データベースに格納されたのちに関連付けされます。処理するドキュメントが選択されると、関連付けコンポーネントが作成され、パーサー コンポーネントおよび IBizTalkAcknowledge へのポインタから提供されたトランスポート ディクショナリによって呼び出されます。

関連項目

受信確認について


XLANG スケジュールの管理

XLANG スケジュールを管理するには、次のインターフェイスを使用します。

  • IWFSystemAdmin

  • IWFGroupAdmin

特定の XLANG スケジュールの実行中のインスタンスにアクセスするには、次のインターフェイスを使用します。

  • IWFWorkflowInstance

  • IWFProxy

詳細については、「プログラムによる管理」を参照してください。


XLANG スケジュールに関するリファレンス

次の図は、ここで説明する XLANG インターフェイスと、それに対応するモニカの関係を示しています。

sked://[host]
システム管理者
IWFSystemAdmin
sked://[host][!group]
XLANG スケジュール
インスタンス
XLANG スケジュール
インスタンス
XLANG スケジュール
インスタンス
グループ管理者
グループ管理者
グループ管理者
WorkflowInstance
IWFProxy
IWFWorkflowInstance
IWFWorkflowInstance
IWFWorkflowInstance
IWFGroupAdmin
IWFGroupAdmin
IWFGroupAdmin
sked://[host][!group]/file.skx
sked://[host][!group]/file.skx/port
COM バインド XLANG ポートへのプロキシ

次の XLANG スケジュール インターフェイスが使用できます。

管理者インターフェイス

  • IWFGroupAdmin

  • IWFSystemAdmin

スケジュール インスタンス インターフェイス

  • IWFProxy

  • IWFWorkflowInstance

関連項目

プログラムによる管理

Copyright © 1999#0150;2000 Microsoft Corporation.


IWFGroupAdmin インターフェイス[C++]

IWFGroupAdmin オブジェクト [Visual Basic]

IWFGroupAdmin インターフェイスを使用すると、クライアント アプリケーションで XLANG スケジュールの実行中のインスタンスを制御できます。このインスタンスは、グループ マネージャに関連付けられたすべてのスケジュール インスタンスを停止、中断、再開し、これらのスケジュール インスタンスに関する情報を取得するために使用します。

IWFGroupAdmin インターフェイスは、次のプロパティを定義します。

プロパティ | 種類 | 説明
Count (数) | long | このグループ マネージャに関連付けられた実行中のスケジュール インスタンスの数です。
FullyQualifiedName (完全修飾名) | BSTR | このグループ マネージャのモニカです。
InstanceIsResident (常駐インスタンス) | VARIANT_BOOL | 指定されたスケジュール インスタンスが現在メモリに常駐しているかどうかを示す値です。
InstanceIsSuspended (中断インスタンス) | VARIANT_BOOL | 指定されたスケジュール インスタンスが現在中断ステータスにあるかどうかを示す値です。
Name (名前) | BSTR | このグループ マネージャの名前です。
UseFileDSN (ファイル DSN の使用) | VARIANT_BOOL | ファイルの DSN (データ ソース名) が、XLANG スケジュール インスタンスのステータス退避に使用されるかどうかを示す値です。

IWFGroupAdmin インターフェイスは、次のメソッドを定義します。

メソッド | 説明
ResumeInstance | 中断ステータスのスケジュールの実行を再開します。
Shutdown | すべての実行中のスケジュール インスタンスをステータス退避し、グループ マネージャを停止します。
Startup | 現在のグループ マネージャのすべてのステータス退避済みスケジュール インスタンスを開始します。
SuspendInstance | スケジュール インスタンスの実行を一時停止します。
TerminateInstance | スケジュール インスタンスの実行を停止します。

解説

IWFGroupAdmin オブジェクトへの参照を取得するには、モニカを使用して COM の GetObject 関数を呼び出します。次の Microsoft Visual Basic のコード サンプルは、ローカル コンピュータの既定の XLANG スケジューラ グループ マネージャへの参照を取得する方法を示しています。

Dim oGM As IWFGroupAdmin
Set oGM = GetObject("sked://!XLANG Scheduler")

ほかのグループ マネージャへの参照を取得するには、"XLANG Scheduler" の部分を、XLANG スケジューラ エンジンのホストまたはグループ マネージャとして指定した COM+ アプリケーションの名前に置き換えます。COM+ アプリケーションがグループ マネージャであるかどうかを確認するには、IWFSystemAdmin インターフェイスで IsWorkflowHost メソッドを使用します。

SysMgr オブジェクトに含まれている IWFGroupAdmin オブジェクトのコレクションを使用すると、XLANG スケジューラ システム マネージャに関連付けられたすべてのグループ マネージャへの参照を取得することもできます。次の Microsoft Visual Basic コードは、各グループ マネージャの完全修飾名を示しています。

Dim oSM As SysMgr
Dim oGM As IWFGroupAdmin
Set oSM = GetObject("sked://")
For Each oGM In oSM
    MsgBox ("Group Manager: " + oGM.FullyQualifiedName)
Next

さらに、IWFGroupAdmin オブジェクトは、このグループ マネージャの現在実行されているスケジュール インスタンスを表す IWFWorkflowInstance オブジェクトのコレクションを列挙します。

グループ マネージャに関連付けられている XLANG スケジューラ システム マネージャを確認するには、次の操作を行います。

  1. IWFGroupAdmin オブジェクトの FullyQualifiedName プロパティを取得します。

  2. 返されたモニカ文字列から、XLANG スケジューラ システム マネージャ名を解析します。

    これは、プレフィックス sked:// と感嘆符 (!) の間にある部分です。

  3. 手順 2. のXLANG スケジューラ システム マネージャ名から作成したモニカを使用して、SysMgr オブジェクトへの参照を取得します。

モニカの詳細については、「モニカの構文」を参照してください。

注

  • C++ を使用する場合は、COM の CoGetObject 関数が GetObject の代わりに使用されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::Count プロパティ [C++]

IWFGroupAdmin.Count プロパティ [Visual Basic]

Count プロパティには、このグループ マネージャに関連付けられた実行中のスケジュール インスタンスの数が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Count(

long* lCount
);

[Visual Basic]

object.Count

パラメータ

[C++]

Get メソッド :

lCount

[out, retval] このグループ マネージャに関連付けられた実行中のスケジュール インスタンスの数を含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、このグループ マネージャに関連付けられた実行中のスケジュール インスタンスの数を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::FullyQualifiedName プロパティ [C++]

IWFGroupAdmin.FullyQualifiedName プロパティ [Visual Basic]

FullyQualifiedName プロパティには、このグループ マネージャのモニカが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_FullyQualifiedName(

BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

パラメータ

[C++]

Get メソッド :

varFullyQualifiedName

[out, retval] このグループ マネージャのモニカを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、このグループ マネージャのモニカを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

グループ マネージャをインスタンス化するにはローカル モニカを使用しますが、このプロパティには常に完全なドメイン ネーム サービス (DNS) 形式のシステム名が含まれます。たとえば、XLANG Scheduler という既定の XLANG スケジューラ グループ マネージャが、vigorair-18.com というドメインの MyMachine という名前のコンピュータで実行されているとします。その場合、FullyQualifiedName プロパティには sked://MyMachine.vigorair-18.com!XLANG Scheduler という値が含まれます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。

関連項目

モニカの構文


IWFGroupAdmin::InstanceIsResident プロパティ [C++]

IWFGroupAdmin.InstanceIsResident プロパティ [Visual Basic]

InstanceIsResident プロパティには、指定された XLANG スケジュール インスタンスが現在メモリに常駐しているかどうかを示す値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_InstanceIsResident(

BSTR varInstanceId,
VARIANT_BOOL* pvarIsResident
);

[Visual Basic]

object.InstanceIsResident( _
 varInstanceId As String _
)

パラメータ

[C++]

Get メソッド :

varInstanceId

[in] スケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む BSTR です。

pvarIsResident

[out, retval] VARIANT_BOOL へのポインタです。指定されたスケジュール インスタンスが現在メモリに常駐している場合、この値は VARIANT_TRUE に設定されます。指定されたスケジュール インスタンスが現在ステータス退避されている場合、このパラメータは VARIANT_FALSE に設定されます。

[Visual Basic]

varInstanceId

スケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、指定されたスケジュール インスタンスが現在メモリに常駐している場合、True に設定された Boolean を返します。指定されたスケジュールが現在ステータス退避されている場合、このプロパティは False に設定されます。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::InstanceIsSuspended プロパティ [C++]

IWFGroupAdmin.InstanceIsSuspended プロパティ [Visual Basic]

InstanceIsSuspended プロパティには、指定された XLANG スケジュール インスタンスが現在中断ステータスにあるかどうかを示す値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_InstanceIsSuspended(

BSTR varInstanceId,
VARIANT_BOOL* pvarIsSuspended
);

[Visual Basic]

object.InstanceIsSuspended( _
 varInstanceId As String _
)

パラメータ

[C++]

Get メソッド :

varInstanceId

[in] スケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む BSTR です。

pvarIsSuspended

[out, retval] VARIANT_BOOL へのポインタです。指定されたスケジュール インスタンスが現在中断ステータスにある場合、この値は VARIANT_TRUE に設定されます。指定されたスケジュール インスタンスが中断されていない場合、このパラメータは VARIANT_FALSE に設定されます。

[Visual Basic]

varInstanceId

スケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、指定されたスケジュール インスタンスが現在中断ステータスにある場合、True に設定された Boolean を返します。指定されたスケジュールが中断されていない場合、このプロパティは False に設定されます。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

ResumeInstance メソッドを呼び出す場合は、事前にこのプロパティを確認する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::Name プロパティ [C++]

IWFGroupAdmin.Name プロパティ [Visual Basic]

Name プロパティには、このグループ マネージャの名前が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Name(

BSTR* varName
);

[Visual Basic]

object.Name

パラメータ

[C++]

Get メソッド :

varName

[out, retval] このグループ マネージャの名前を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、このグループ マネージャの名前を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティは、ホスト COM+ アプリケーションの名前と同じです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::ResumeInstance メソッド [C++]

IWFGroupAdmin.ResumeInstance メソッド [Visual Basic]

ResumeInstance メソッドは、中断ステータスにある XLANG スケジュール インスタンスの実行を開始します。

構文

[C++]

HRESULT ResumeInstance(
 BSTR bInstanceId
);

[Visual Basic]

object.ResumeInstance( _
 bInstanceId As String _
)

パラメータ

[C++]

bInstanceId

[in] 再開するスケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む BSTR です。

[Visual Basic]

bInstanceId

再開するスケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

スケジュール インスタンスを一時停止するには SuspendInstance メソッドを使用します。ResumeInstance メソッドを呼び出す場合は、事前に InstanceIsSuspended プロパティを確認する必要があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::Shutdown メソッド [C++]

IWFGroupAdmin.Shutdown メソッド [Visual Basic]

Shutdown メソッドは、グループ マネージャを停止し、すべての実行中の XLANG スケジュール インスタンスをステータス退避します。

構文

[C++]

HRESULT Shutdown();

[Visual Basic]

object.Shutdown()

パラメータ

[C++]

なし

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

グループ マネージャの停止前、このグループ マネージャに関連付けられたすべての実行中のスケジュール インスタンスは、データ ソース名 (DSN) ファイルで指定されたデータベースにステータス退避され、新しいスケジュール インスタンスのアクティブ化の要求は、シャットダウンが完了するまで拒否されます。

XLANG スケジュールにバインドされたコンポーネントでは、このメソッドを呼び出してグループ マネージャを停止しないでください。予期しない結果が生じる可能性があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::Startup メソッド [C++]

IWFGroupAdmin.Startup メソッド [Visual Basic]

Startup メソッドは、このグループ マネージャに関連付けられ、既に実行されてステータス退避済みのすべての XLANG スケジュール インスタンスを開始します。

構文

[C++]

HRESULT Startup();

[Visual Basic]

object.Startup()

パラメータ

[C++]

なし

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

通常、XLANG スケジューラ システム マネージャがこのメソッドを呼び出します。ユーザーが直接このメソッドを呼び出すべきではありません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::SuspendInstance メソッド [C++]

IWFGroupAdmin.SuspendInstance メソッド [Visual Basic]

SuspendInstance メソッドは、実行中のスケジュール インスタンスを現在のステータスで一時停止します。

構文

[C++]

HRESULT SuspendInstance(
 BSTR bInstanceId
);

[Visual Basic]

object.SuspendInstance( _
 bInstanceId As String _
)

パラメータ

[C++]

bInstanceId

[in] 中断するスケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む BSTR です。

[Visual Basic]

bInstanceId

中断するスケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

スケジュール インスタンスを再開するには ResumeInstance メソッドを使用します。

このメソッドは、COM バインド ポートを持つアクションがメソッドの終了を待機している場合、または短時間トランザクションが進行中である場合は、ブロックする可能性があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::TerminateInstance メソッド [C++]

IWFGroupAdmin.TerminateInstance メソッド [Visual Basic]

TerminateInstance メソッドは、実行中の XLANG スケジュール インスタンスを停止します。

構文

[C++]

HRESULT TerminateInstance(
 BSTR bInstanceId
);

[Visual Basic]

object.TerminateInstance( _
 bInstanceId As String _
)

パラメータ

[C++]

bInstanceId

[in] 停止するスケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む BSTR です。

[Visual Basic]

bInstanceId

停止するスケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

終了したスケジュール インスタンスは再起動も再開もできません。

このメソッドは、COM バインド ポートを持つアクションがメソッドの終了を待機している場合、または短時間トランザクションが進行中である場合は、ブロックする可能性があります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFGroupAdmin::UseFileDSN プロパティ [C++]

IWFGroupAdmin.UseFileDSN プロパティ [Visual Basic]

UseFileDSN プロパティには、DNS (データ ソース名) ファイルが XLANG スケジュール インスタンスのステータス退避に使用されるかどうかを示す値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_UseFileDSN(

VARIANT_BOOL* pfUseFileDSN
);

[Visual Basic]

object.UseFileDSN

パラメータ

[C++]

Get メソッド :

pfUseFileDSN

[out, retval] VARIANT_BOOL へのポインタです。グループ マネージャがスケジュール インスタンスのステータス退避に DSN ファイルを使用する場合、この値は VARIANT_TRUE に設定されます。DSN ファイルが使用されない場合は、このパラメータは VARIANT_FALSE に設定されます。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

グループ マネージャが、スケジュール インスタンスのステータス退避に DSN ファイルを使用する場合、このプロパティは True に設定された Boolean を返します。DSN ファイルが使用されない場合は、False が返されます。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティの値は、グループ マネージャの処理が開始されたときに設定されます。COM+ カタログの DSN 設定を変更するには、[XLANG Scheduler のプロパティ] ダイアログ ボックスの [XLANG] タブを使用するか、IWFSystemAdmin インターフェイスで UseFileDSN プロパティを設定します。グループ マネージャの実行中に DSN 値を変更しても、このプロパティの値は動的には更新されません。グループ マネージャが次に開始されるまで、新しい値は反映されません。このプロパティを更新するには、呼び出し元に XLANG 管理者ロールが必要であり、通常はユーザー コードでは実行できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFProxy インターフェイス [C++]

IWFProxy オブジェクト [Visual Basic]

IWFProxy インターフェイスには、COM コンポーネントにバインドされた XLANG スケジュール インスタンスにあるポートに関する情報が含まれます。このインターフェイスは、スケジュール インスタンスを取得するために使用します。COM にバインドされていないポートに対してこのインターフェイスを使用すると、エラーが返されます。

IWFProxy インターフェイスは、次のプロパティを定義します。

プロパティ | 種類 | 説明
FullyQualifiedName (完全修飾名) | BSTR | COM にバインドされたポートの完全修飾名です。
WorkflowInstance (現在のスケジュール インスタンス) | IWFWorkflowInstance | 現在のスケジュール インスタンスです。

解説

このインターフェイスへの参照は、次から取得できます。

  • IWFWorkflowInstance インターフェイスで利用可能な Port プロパティ

  • ポート名を指定する XLANG スケジュール モニカ

次の Microsoft Visual Basic のコード サンプルは、モニカを使用することでローカル コンピュータ上の XLANG スケジュールをアクティブにし、その XLANG スケジュール インスタンスの名前付きポートへの参照を取得する方法を示しています。

Dim oPort As Object
Set oPort = GetObject("sked:///C:\schedules\test.skx/PortA")

この時点で、スケジュール インスタンスの PortA にバインドされた COM オブジェクトへの参照が、変数 oPort に含まれます。

モニカの詳細については、「モニカの構文」を参照してください。

注

C++ を使用する場合は、COM の CoGetObject 関数が GetObject の代わりに使用されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFProxy::FullyQualifiedName プロパティ [C++]

IWFProxy.FullyQualifiedName プロパティ [Visual Basic]

FullyQualifiedName プロパティには、このプロキシがバインドされているポート インスタンスのモニカが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_FullyQualifiedName(

BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

パラメータ

[C++]

Get メソッド :

varFullyQualifiedName

[out, retval] ポートのモニカを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、ポートのモニカを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

このプロパティで取得されたモニカを COM の GetObject 関数で使用すると、XLANG スケジュール インスタンスへの参照を取得できます。このモニカが有効なのは、そのスケジュール インスタンスの実行中だけです。スケジュール インスタンスが、システムの再起動など、何らかの理由でステータス退避およびステータス復元されると、モニカは有効な状態のまま保持されます。スケジュール インスタンスが完了するか、TerminateInstance メソッドによって終了すると、モニカは使用できなくなります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFProxy::WorkflowInstance プロパティ [C++]

IWFProxy.WorkflowInstance プロパティ [Visual Basic]

WorkflowInstance プロパティには、現在の XLANG スケジュール インスタンスへの参照が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_WorkflowInstance(

IWFWorkflowInstance** varScheduleInst
);

[Visual Basic]

object.WorkflowInstance

パラメータ

[C++]

Get メソッド :

varScheduleInst

[out, retval] 現在のスケジュール インスタンスを含む IWFWorkflowInstance インターフェイスへのポインタのアドレスです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、現在のスケジュール インスタンスを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFSystemAdmin インターフェイス [C++]

SysMgr オブジェクト [Visual Basic]

IWFSystemAdmin インターフェイスは、XLANG スケジューラ エンジンに対するシステム全体での管理制御をクライアント アプリケーションに提供します。このインターフェイスは、グループ マネージャの開始、停止、およびグループ マネージャに関する情報の取得のために使用します。

IWFSystemAdmin インターフェイスは、次のプロパティを定義します。

プロパティ | 種類 | 説明
Count (数) | long | この XLANG スケジューラ システム マネージャに関連付けられているグループ マネージャの数を含みます。
FullyQualifiedName (完全修飾名) | BSTR | XLANG スケジューラ システム マネージャの、DNS 形式の完全修飾名を含みます。
IsWorkflowHost (ホスト) | VARIANT_BOOL | COM+ サーバー アプリケーションが XLANG スケジューラ エンジンのホストかどうかを調べます。
Item (項目) | BSTR | 名前付きスケジュール グループへの参照を返します。
UseFileDSN (ファイル DSN の使用) | VARIANT_BOOL | ファイルの DSN (データ ソース名) が、XLANG スケジュール インスタンスのステータス退避に使用されるかどうかを示します。

IWFSystemAdmin インターフェイスは、次のメソッドを定義します。

メソッド | 説明
ShutdownAll | すべてのグループ マネージャをシャットダウンします。
ShutdownApp | 特定のグループ マネージャをシャットダウンします。
Startup | すべてのグループ マネージャを開始します。
TestAdminStatus | XLANG スケジューラ エンジンに対する管理者アクセスの呼び出し元を調べます。

解説

このオブジェクトへの参照を取得するには、モニカを使用して COM の GetObject 関数を呼び出します。次の Microsoft Visual Basic のコード サンプルは、ローカル コンピュータの XLANG スケジューラ システム マネージャへの参照を取得する方法を示しています。

Dim oSM As SysMgr
Set oSM = GetObject("sked://")

このオブジェクトはまた、この XLANG スケジューラ システム マネージャに関連付けられたグループ マネージャを表す、IWFGroupAdmin オブジェクトの集合を列挙します。

モニカの詳細については、「モニカの構文」を参照してください。

注

  • C++ を使用する場合は、COM の CoGetObject 関数が GetObject の代わりに使用されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::Count プロパティ [C++]

SysMgr.Count プロパティ [Visual Basic]

Count プロパティには、実行中のグループ マネージャの数が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Count(

long* lCount
);

[Visual Basic]

object.Count

パラメータ

[C++]

Get メソッド :

lCount

[out, retval] 実行中のグループ マネージャの数を含む long へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、実行中のグループ マネージャの数を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::FullyQualifiedName プロパティ [C++]

SysMgr.FullyQualifiedName プロパティ [Visual Basic]

FullyQualifiedName プロパティには、この XLANG スケジューラ システム マネージャのモニカが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_FullyQualifiedName(

BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

パラメータ

[C++]

Get メソッド :

varFullyQualifiedName

[out, retval] この XLANG スケジューラ システム マネージャのモニカを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、このグループ マネージャのモニカを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

XLANG スケジューラ システム マネージャをインスタンス化するにはローカル モニカを使用しますが、このプロパティには常に完全なドメイン ネーム サービス (DNS) 形式のシステム名が含まれます。たとえば、XLANG スケジューラ システム マネージャが、vigorair-18.com というドメインの MyMachine という名前のコンピュータで実行されているとします。その場合、FullyQualifiedName プロパティには sked://MyMachine.vigorair-18.com という値が含まれます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。

関連項目

モニカの構文


IWFSystemAdmin::IsWorkflowHost プロパティ [C++]

SysMgr.IsWorkflowHost プロパティ [Visual Basic]

IsWorkflowHost プロパティは、名前を指定した COM+ サーバー アプリケーションが、XLANG スケジューラ エンジンのホストかどうかを制御します。

構文

[C++]

Get メソッド :

HRESULT get_IsWorkflowHost(
BSTR varAppName,
VARIANT_BOOL* pIsWorkflowHost
);

Put メソッド :

HRESULT put_IsWorkflowHost(
BSTR varAppName,
VARIANT_BOOL varIsWorkflowHost
);

[Visual Basic]

object.IsWorkflowHost( _
 varAppName As String _
)

パラメータ

[C++]

Get メソッド :

varAppName

[in] COM+ サーバー アプリケーション名を含む BSTR です。

pIsWorkflowHost

[out, retval] COM+ サーバー アプリケーションが XLANG スケジューラ エンジンをホストしているかどうかを示す VARIANT_BOOL へのポインタです。

Put メソッド :

varAppName

[in] COM+ サーバー アプリケーション名を含む BSTR です。

varIsWorkflowHost

[out, retval] COM+ サーバー アプリケーションが XLANG スケジューラ エンジンをホストしているかどうかを示す VARIANT_BOOL です。

[Visual Basic]

varAppName

COM+ サーバー アプリケーション名を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、COM+ サーバー アプリケーションが XLANG スケジューラ エンジンをホストしているかどうかを示す Boolean を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

このプロパティは、XLANG スケジューラ エンジン アプリケーション上で設定できません。また、読み取り専用のマークが付けられた COM+ アプリケーション上でも設定できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::Item プロパティ [C++]

SysMgr.Item プロパティ [Visual Basic]

Item プロパティは、実行中のグループ マネージャの 1 つへの参照を返します。

構文

[C++]

Get メソッド :

HRESULT get_Item(

BSTR strGrpMgrName,
IUnknown** ppItem
);

[Visual Basic]

object.Item( _
 strGrpMgrName As String _
)

パラメータ

[C++]

Get メソッド :

strGrpMgrName

[in] ホストしている COM+ サーバー アプリケーション名に対応するグループ名を含む BSTR です。グループ名は大文字と小文字を区別し、空白を含めることができます。

ppItem

[out, retval] グループ マネージャを参照する IUnknown インターフェイスへのポインタのアドレスです。

[Visual Basic]

strGrpMgrName

[in] ホストしている COM+ サーバー アプリケーション名に対応するグループ名を含む文字列です。グループ名は大文字と小文字を区別し、空白を含めることができます。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、グループ マネージャの Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::ShutdownAll メソッド [C++]

SysMgr.ShutdownAll メソッド [Visual Basic]

ShutdownAll メソッドは、グループ マネージャを停止し、関連付けられている COM+ アプリケーションを終了します。

構文

[C++]

HRESULT ShutdownAll();

[Visual Basic]

object.ShutdownAll()

パラメータ

[C++]

なし

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

ShutdownAll メソッドが呼び出されると、新しいスケジュールのアクティブ化が無効になり、実行中のすべてのグループ マネージャにシャットダウン通知が伝達されます。このメソッドが完了すると、すべてのグループ マネージャが停止し、システムを安全に再起動できるようになります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::ShutdownApp メソッド [C++]

SysMgr.ShutdownApp メソッド [Visual Basic]

ShutdownApp メソッドは、特定のグループ マネージャ アプリケーションを停止し、関連付けられている COM+ アプリケーションを終了します。

構文

[C++]

HRESULT ShutdownApp(
 BSTR varAppName
);

[Visual Basic]

object.ShutdownApp( _
 varAppName As String _
)

パラメータ

[C++]

varAppName

[in] 停止する COM+ サーバー アプリケーション名を含む BSTR です。

[Visual Basic]

varAppName

停止する COM+ サーバー アプリケーション名を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

ShutdownApp メソッドが呼び出されると、指定されたアプリケーション上での新しいスケジュールのアクティブ化が無効になり、そのアプリケーションに関連付けられた、実行中のすべての XLANG スケジュール インスタンスが停止されます。このメソッドが、既定の XLANG スケジューラ グループ マネージャで呼び出された場合は、すべてのグループ マネージャがシャットダウンされます。既定の XLANG スケジューラ グループ マネージャでこのメソッドを呼び出すことは、ShutdownAll メソッドを呼び出すことと同等です。

注

  • 既定の XLANG スケジューラ グループ マネージャの COM+ アプリケーション名は、XLANG スケジューラです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::StartUp メソッド [C++]

SysMgr.StartUp メソッド [Visual Basic]

StartUp メソッドは、グループ マネージャを開始します。

構文

[C++]

HRESULT StartUp();

[Visual Basic]

object.StartUp()

パラメータ

[C++]

なし

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドが呼び出されると、すべてのグループ マネージャに対してステータス復元が開始され、それに続いてすべての XLANG スケジュールに対してもステータス復元が開始されます。このメソッドは非同期的で、すべてのグループ マネージャおよびスケジュールの実行前に完了することがあります。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::TestAdminStatus メソッド [C++]

SysMgr.TestAdminStatus メソッド [Visual Basic]

TestAdminStatus メソッドは、IWFGroupAdmin インターフェイスの呼び出し元が XLANG スケジューラ エンジンの管理者かどうかを判定します。

構文

[C++]

HRESULT TestAdminStatus();

[Visual Basic]

object.TestAdminStatus()

パラメータ

[C++]

なし

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

このメソッドは、グループ マネージャで内部的に使用するためのものです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFSystemAdmin::UseFileDSN プロパティ [C++]

SysMgr.UseFileDSN プロパティ [Visual Basic]

UseFileDSN プロパティには、COM+ サーバー アプリケーションが XLANG スケジュール インスタンスのステータス退避のために、DSN （データ ソース名) ファイルを使用するかどうかを示す値が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_UseFileDSN(
BSTR varAppName,
VARIANT_BOOL* pfUseFileDSN
);

Put メソッド :

HRESULT put_UseFileDSN(
BSTR varAppName,
VARIANT_BOOL* varUseFileDSN
);

[Visual Basic]

object.UseFileDSN( _
 varAppName As String _
)

パラメータ

[C++]

Get メソッド :

varAppName

[in] COM+ サーバー アプリケーション名を含む BSTR です。

pfUseFileDSN

[out, retval] VARIANT_BOOL へのポインタです。COM+ サーバー アプリケーションがスケジュール インスタンスのステータス退避に DSN ファイルを使用する場合、この値は VARIANT_TRUE に設定されます。DSN ファイルが使用されない場合は、このパラメータは VARIANT_FALSE に設定されます。

Put メソッド :

varAppName

[in] COM+ サーバー アプリケーション名を含む BSTR です。

varUseFileDSN

[out, retval] COM+ サーバー アプリケーションが、スケジュール インスタンスのステータス退避に DSN ファイルを使用するかどうかを示す VARIANT_BOOL です。DSN ファイルが使用されない場合は、このパラメータは VARIANT_FALSE に設定されます。

[Visual Basic]

varUseFileDSN

COM+ サーバー アプリケーションが、スケジュール インスタンスのステータス退避に DSN ファイルを使用するかどうかを示す Boolean です。DSN ファイルが使用されない場合は、このパラメータは False に設定されます。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

COM+ サーバー アプリケーションが、スケジュール インスタンスのステータス退避に DSN ファイルを使用する場合、このプロパティは True に設定された Boolean を返します。DSN ファイルが使用されない場合は、False が返されます。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

グループ マネージャの実行中にこのプロパティが変更されても、そのグループ マネージャ内でこのプロパティの値が動的に更新されるわけではありません。したがって、IWFGroupAdmin インターフェイスが示す UseFileDSN プロパティ値には、不正な値が含まれることになります。グループ マネージャが次に開始されるまで、更新された値は反映されません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SysMgr.h をインクルードします。
ライブラリ : XLANG Scheduler - System Manager (SKEDSMGR.dll) を使用します。


IWFWorkflowInstance インターフェイス [C++]

IWFWorkflowInstance オブジェクト [Visual Basic]

IWFWorkflowInstance インターフェイスを使用すると、クライアント アプリケーションは、XLANG スケジュール インスタンスのポートの参照、完了ステータスの確認、スケジュール インスタンスが正常に完了したかどうかの判定を行うことができます。このインターフェイスは、実行中の特定のスケジュール インスタンスに関する情報を収集するために使用します。

IWFWorkflowInstance インターフェイスは、次のプロパティを定義します。

プロパティ | 種類 | 説明
CompletionStatus (完了ステータス) | long | スケジュール インスタンスの成功または失敗を示す値です。
FullPortName (ポートの完全名) | BSTR | 関連するテクノロジで使用可能な形式による、ポートの完全な名前です。
FullyQualifiedName (完全修飾名) | BSTR | このスケジュール インスタンスの完全修飾名です。
InstanceId (インスタンス ID) | BSTR | このスケジュール インスタンスに関連付けられた一意な識別子です。
IsCompleted (完了) | VARIANT_BOOL | スケジュール インスタンスが完了したかどうかを示す値です。
ModuleId (モジュール ID) | BSTR | スケジュールとバインド情報を含む XML モジュールの一意な識別子です。
ModuleName (モジュール名) | BSTR | スケジュールとバインド情報を含む XML モジュールの名前です。
ParentInstanceID (親インスタンス ID) | BSTR | 親スケジュール インスタンスの一意な識別子です。
Port (ポート) | IUnknown | 名前付きポートへの参照です。これが有効なのは、COM ベースのポート バインドだけです。

IWFWorkflowInstance インターフェイスは、次のメソッドを定義します。

メソッド | 説明
WaitForCompletion | スケジュール インスタンスが完了するまでブロックを行います。

解説

このインターフェイスへの参照は、次から取得できます。

  • IWFProxy インターフェイスで利用可能な WorkflowInstance プロパティ

  • IWFGroupAdmin オブジェクトによって返された IWFWorkflowInstance オブジェクトの集合

  • XLANG スケジュール モニカ

次の Microsoft Visual Basic のコード サンプルは、ローカル コンピュータ上で XLANG スケジュールをインスタンス化し、そのスケジュール インスタンスへの参照を取得する方法を示しています。

Dim oWFI As IWFWorkflowInstance
Set oWFI = GetObject("sked:///C:\schedules\test.skx")

グループ マネージャ内で現在実行中のすべてのスケジュール インスタンスへの参照を取得するには、IWFGroupAdmin オブジェクトに含まれる IWFWorkflowInstance オブジェクトの集合にアクセスします。次の Microsoft Visual Basic のコードは、既定の XLANG スケジューラ グループ マネージャで実行中の、各スケジュール インスタンスの完全修飾名を表示します。

Dim oGM As IWFGroupAdmin
Dim oWFI As IWFWorkflowInstance
Set oGM = GetObject("sked://!XLANG Scheduler")
For Each oWFI In oGM
    MsgBox ("XLANG Schedule: " + oWFI.FullyQualifiedName)
Next

複数のグループ マネージャを使用している場合は、次の操作を実行して、任意のスケジュール インスタンスに関連付けられたグループ マネージャを特定できます。

  1. IWFWorkflowInstance オブジェクトの FullyQualifiedName プロパティを取得します。

  2. 返されたモニカ文字列から、グループ マネージャ名を解析します。

    これは、感嘆符 (!) で始まりスラッシュ (/) で終わる部分です。

  3. 手順 2. のグループ マネージャ名から作成したモニカを使用して、IWFGroupAdmin オブジェクトへの参照を取得します。

モニカの詳細については、「モニカの構文」を参照してください。

注

  • C++ を使用する場合は、COM の CoGetObject 関数が GetObject の代わりに使用されます。

  • Microsoft Visual Basic でこのオブジェクトにアクセスする場合は、Object 型を使用せずに、適切な型情報を持つオブジェクト変数を宣言する必要があります。次に例を示します。
    Dim myInstance As IWFWorkflowInstance

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::CompletionStatus プロパティ [C++]

IWFWorkflowInstance.CompletionStatus プロパティ [Visual Basic]

CompletionStatus プロパティは、XLANG スケジュール インターフェイスの最終完了状態を示します。

構文

[C++]

Get メソッド :

HRESULT get_CompletionStatus(
long* varCompletionStatus
);

[Visual Basic]

object.CompletionStatus

パラメータ

[C++]

Get メソッド :

varCompletionStatus

[out, retval] スケジュール インスタンスの完了状態を含む long へのポインタです。値 0 は成功を示します。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

注

  • 戻り値 S_OK は、スケジュール インスタンスに関連付けられたプロセスまたはアプリケーションが、正常に完了したことを示すものではありません。スケジュール インスタンスの処理が、XLANG スケジューラ エンジンによってエラーなく完了したことを示しているだけです。
[Visual Basic]

このプロパティは、完了状態を含む Long を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::FullPortName プロパティ [C++]

IWFWorkflowInstance.FullPortName プロパティ [Visual Basic]

FullPortName プロパティには、指定されたポートの完全な名前が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_FullPortName(
BSTR varParam,

BSTR* varFullPortName
);

[Visual Basic]

object.FullPortName( _
 varParam As String _
)

パラメータ

[C++]

Get メソッド :

varParam

[in] 取得するポートの名前を含む BSTR です。

varFullPortName

[out, retval] ポートの完全な名前を含む BSTR へのポインタです。

[Visual Basic]

varParam

取得するポートの名前を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、ポートの完全な名前を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

完全なポート名は、関連するバインド テクノロジで使用可能な形式で返されます。たとえば、COM コンポーネントにバインドされたポートでは、ポート名として完全修飾モニカが返されます。Microsoft メッセージ キューにバインドされたポートでは、このメソッドによってキューの完全なパスが返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::FullyQualifiedName プロパティ [C++]

IWFWorkflowInstance.FullyQualifiedName プロパティ [Visual Basic]

FullyQualifiedName プロパティには、XLANG スケジュール インスタンスのモニカが含まれます。

構文

[C++]

Get メソッド :

HRESULT get_FullyQualifiedName(

BSTR* varFullyQualifiedName
);

[Visual Basic]

object.FullyQualifiedName

パラメータ

[C++]

Get メソッド :

varFullyQualifiedName

[out, retval] スケジュール インスタンスのモニカを含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、スケジュール インスタンスのモニカを含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::InstanceId プロパティ [C++]

IWFWorkflowInstance.InstanceId プロパティ [Visual Basic]

InstanceId プロパティには、現在の XLANG スケジュール インスタンスに割り当てられたグローバル一意識別子 (GUID) が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_InstanceId(

BSTR* varInstanceId
);

[Visual Basic]

object.InstanceId

パラメータ

[C++]

Get メソッド :

varInstanceId

[out, retval] スケジュール インスタンスの GUID を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、スケジュール インスタンスの GUID を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::IsCompleted プロパティ [C++]

IWFWorkflowInstance.IsCompleted プロパティ [Visual Basic]

IsCompleted プロパティは、XLANG スケジュール インスタンスの実行が終了したかどうかを示します。

構文

[C++]

Get メソッド :

HRESULT get_IsCompleted(

VARIANT_BOOL* varIsCompleted
);

[Visual Basic]

object.IsCompleted

パラメータ

[C++]

Get メソッド :

varIsCompleted

[out, retval] VARIANT_BOOL へのポインタです。値 VARIANT_TRUE は、スケジュール インスタンスの実行が終了したことを示しています。値 VARIANT_FALSE は、スケジュール インスタンスがまだ実行中であることを示しています。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、Boolean を返します。値 True は、スケジュール インスタンスの実行が終了したことを示しています。値 False は、スケジュール インスタンスがまだ実行中であることを示しています。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::ModuleId プロパティ [C++]

IWFWorkflowInstance.ModuleId プロパティ [Visual Basic]

ModuleId プロパティには、現在の XLANG スケジュール インスタンスに関連付けられた XLANG モジュールのグローバル一意識別子 (GUID) が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ModuleId(

BSTR* varModuleId
);

[Visual Basic]

object.ModuleId

パラメータ

[C++]

Get メソッド :

varModuleId

[out, retval] 現在のスケジュール インスタンスに関連付けられた XLANG モジュールの GUID を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、現在のスケジュール インスタンスに関連付けられた XLANG モジュールの GUID を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::ModuleName プロパティ [C++]

IWFWorkflowInstance.ModuleName プロパティ [Visual Basic]

ModuleName プロパティには、現在の XLANG スケジュール インスタンスに関連付けられた XLANG モジュールの名前が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ModuleName(

BSTR* varModuleName
);

[Visual Basic]

object.ModuleName

パラメータ

[C++]

Get メソッド :

varModuleName

[out, retval] 現在のスケジュール インスタンスに関連付けられた XLANG モジュールの名前を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、現在のスケジュール インスタンスに関連付けられた XLANG モジュールの名前を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

モジュール名は、XLANG スケジュール (.skx) ファイルで定義されています。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::ParentInstanceID プロパティ [C++]

IWFWorkflowInstance.ParentInstanceID プロパティ [Visual Basic]

ParentInstanceID プロパティには、現在のスケジュール インスタンスの親 XLANG スケジュール インスタンスに割り当てられた、グローバル一意識別子 (GUID) が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_ParentInstanceID(

BSTR* varParentInstanceID
);

[Visual Basic]

object.ParentInstanceID

パラメータ

[C++]

Get メソッド :

varParentInstanceID

[out, retval] 現在のスケジュール インスタンスの親スケジュール インスタンスの GUID を含む BSTR へのポインタです。

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、現在のスケジュール インスタンスの親スケジュール インスタンスの GUID を含む文字列を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

親スケジュール インスタンスが存在しない場合は、NULL 値が返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::Port プロパティ [C++]

IWFWorkflowInstance.Port プロパティ [Visual Basic]

Port プロパティには、COM にバインドされているポートへの参照が含まれます。

構文

[C++]

Get メソッド :

HRESULT get_Port(

BSTR varParam,
IUnknown** varPort
);

[Visual Basic]

object.Port

パラメータ

[C++]

Get メソッド :

varParam

[in] 参照の取得対象であるポートの名前を含む BSTR です。

varPort

[out, retval] 現在の XLANG スケジュール インスタンスにあるポートへの参照を含む IUnknown インターフェイスへのポインタのアドレスです。

[Visual Basic]

varParam

参照の取得対象であるポートの名前を含む文字列です。

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

このプロパティは、指定されたポートを含む Object を返します。

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

解説

これは読み取り専用プロパティです。

varParam パラメータで渡されたモニカまたはポート名が正しくない場合は、エラー コード MK_E_NOOBJECT が返されます。

Microsoft Visual Basic を使用する場合は、このプロパティを使用して返されるポート参照に使用する変数を、特定のクラスまたは Variant として宣言しておく必要があります。ポートが実際に返すのは IUnknown 参照であるため、変数を Object として宣言した場合は、ポート参照を取得できません。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


IWFWorkflowInstance::WaitForCompletion メソッド [C++]

IWFWorkflowInstance.WaitForCompletion メソッド [Visual Basic]

WaitForCompletion メソッドは、現在の XLANG スケジュール インスタンスの実行が完了するまで待機します。

構文

[C++]

HRESULT WaitForCompletion();

[Visual Basic]

object.WaitForCompletion()

パラメータ

[C++]

なし

[Visual Basic]

なし

戻り値

[C++]

XLANG スケジューラ エンジンによって返されるエラー メッセージの一覧については、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」を参照してください。

[Visual Basic]

なし

エラー値 [Visual Basic]

[Visual Basic]

エラーが発生すると、「XLANG スケジュールのエラー メッセージ」または「標準 COM エラー」に説明されている値のいずれかが Err.Number として返されます。

要件

Windows NT/2000 : Windows 2000 SP1 以降が必要です。
ヘッダー : SkedCore.h をインクルードします。
ライブラリ : XLANG Scheduler Runtime Type Library (SkedCore.dll) を使用します。


BizTalk メッセージ サービスのコード サンプル

サンプル ファイルは、Microsoft BizTalk Server をインストールしたドライブの Messaging Samples フォルダにあります。サンプル ファイルを参照するには、インストール ドライブ上の \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples に移動してください。これは相対パスです。BizTalk Server 2000 のインストール環境に応じて、このパスを変更してください。

次のサンプルは、BizTalk Server 2000 SDK にあります。

サンプルのフォルダ名 | リリース ノート ファイル | 説明
BTConfigAssistant | Readme.doc | このツールは、構成の詳細を参照するために使用します。また、このツールを使用して、構成のインポートとエクスポートを簡単に行うことができます。
BTFDevToolkit | ReadMe.txt | このフォルダには、BizTalk フレームワーク開発者用ツールキットと XML コンポーネントがあります。
BTSAppIntegration\VB (Visual Basic) | Readme.txt | このサンプルは、IBTSAppIntegration インターフェイスを実装するアプリケーション統合コンポーネント (AIC) について示しています。
BTSAppIntegration\VC (C++) | Readme.txt | このサンプルは、ATL を使用して IBTSAppIntegration インターフェイスを実装する AIC について示しています。
CustomPreProcessor | Readme.txt | このサンプルは、ファイル受信機能またはメッセージ キュー受信機能で使用されるカスタム プリプロセッサの簡単な実装について示しています。
DirectIntegration | Readme.doc | このツールは、ドキュメントを BizTalk メッセージ サービスに送信し、送信の結果を確認するときに役立ちます。結果の判定には追跡情報と保留キュー情報が使用されます。
DistributionList | DistributionListReadme.txt | このサンプルは、BizTalk 同報リスト (ポート グループ) を構成し、ドキュメントをその同報リストに送信します。
MapTest | Readme.txt | このツールは、XML ドキュメント インスタンス、コンパイル済み BizTalk Server マップ、およびオプションのスキーマを使用してドキュメントを作成するために使用します。
Miscellaneous | これらのサンプルにリリース ノート ファイルはありません。 | このフォルダには、各種タスクを実行するいくつかの Microsoft Visual Basic Scripting Edition (VBScript) ファイルが含まれています。これらのファイルの先頭には、説明が記述されたコメント ブロックがあります。この説明を参照するには、拡張子 .vbs の付いたファイルをエディタで開きます。
PipelineComponent\VB (Visual Basic) | Readme.txt | このサンプルは、Visual Basic の IPipelineComponent インターフェイスと IPipelineComponentAdmin インターフェイスを実装する AIC について示しています。
PipelineComponent\VC (C++) | Readme.txt | このサンプルは、ATL を使用して IPipelineComponent インターフェイスと IPipelineComponentAdmin インターフェイスを実装する AIC について示しています。
ReceiveScripts | ReceiveReadme.txt | このフォルダには、データを BizTalk メッセージ サービスで受信するためのサンプル ファイルが含まれています。
Sample1 | Sample1Readme.txt | このサンプルは、BizTalk メッセージ サービスを構成し、ドキュメントを BizTalk Server 2000 に送信する方法を示しています。また、オープンな送信先のメッセージ ポート、組織エイリアス、およびカスタム エンベロープを作成および使用する方法も示しています。
Sample2 | Sample2Readme.txt | このサンプルは、ドキュメントの送信時に BizTalk メッセージ サービスを構成して "受信確認" を生成する方法を示しています。
Sample3 | Sample3Readme.txt | このサンプルは、同報リスト (ポート グループ) を構成し、ドキュメントをその同報リストに送信する方法を示しています。
SampleFunctoid | Readme.txt | このサンプルは、日付の書式を変換するカスタム Functoid について示しています。
SampleImporter | Readme.txt | このサンプルは、区切りフラット ファイルをインポートし、それを BizTalk エディタで表示するカスタム インポート モジュールについて示しています。
SOC | Readme.txt | このサンプルは、XLANG スケジューラ エンジンとの同期対話について示しています。
SQLServerAgentJobs | Readme.txt | このサンプルは、受信確認を監視し、追跡情報を削除する SQL スクリプトについて示しています。
VBCustPreProcessor | Readme.txt | このサンプルは、ファイル受信機能で使用されるカスタム プリプロセッサの簡単な実装について示しています。
XSDConverter | Readme.txt | このサンプルは、XDR スキーマを XSD スキーマに変換します。

注

  • C++ を使用する場合は、Program Files\Microsoft BizTalk Server\SDK\Include をインクルード ディレクトリの一覧に追加する必要があります。

  • サンプルのなかには、Pipecomplib.tlb ファイルに依存しているものがあります。これらのサンプルについては、\Program Files\Common Files\Microsoft Shared\Enterprise Servers\Commerce をインクルード ディレクトリの一覧に追加します。


.topic 5
このチェック ボックスをオンにすると、COM+ アプリケーションが XLANG スケジュール インスタンスを実行できるようになります。

.topic 8
このチェック ボックスをオンにすると、ファイル DSN を使用して、この COM+ アプリケーションのステータス保存データベースを参照します。このチェック ボックスをオフにすると、システムまたはユーザー DSN が使われます。ファイル データ ソース名 (DSN) は、データベース接続に関する情報をファイルに保存します。このファイルは拡張子が .dsn で、既定の設定では $\Program Files\Common Files\ODBC\Data Sources ディレクトリに保存されます。

.topic 3
このフィールドには、この COM+ アプリケーションのステータス保存データベースと通信するために使われる DSN の名前が表示されます。DSN の名前は、常に COM+ アプリケーション名と同じである必要があります。

.topic 2
このボタンをクリックすると、XLANG スケジューラ エンジンをホストする COM+ アプリケーションの ODBC データ ソース名 (DSN) を作成します。 重要: [XLANG スケジューラのプロパティ] ダイアログ ボックスで構成されるデータ ソース名の名前は、COM+ アプリケーション名と同じである必要があります。

.topic 1
このボタンをクリックすると、このコンピュータに定義されたすべてのデータ ソースを管理する ODBC データ ソース アドミニストレータが起動します。

.topic 4
このボタンをクリックすると、XLANG スケジュール インスタンスの永続性をサポートするために必要なテーブルを SQL Server データベースに作成します。

.topic 7
このボタンをクリックすると、すべての実行中の XLANG スケジュール インスタンスをシャットダウンします。実行中のスケジュールのステータスは、ステータス保存データベースに保存されます。

.topic 6
このボタンをクリックすると、XLANG スケジュール インスタンスをホストするすべての実行中の COM+ アプリケーションに対して、スケジュール インスタンスのステータスを復元し、可能であれば実行を継続します。

.topic 0


オンライン サポート
と情報

* | Microsoft BizTalk Server 2000 の Web サイト
* | Microsoft 製品サポート サービスの Web サイト
* | Microsoft COM の Web サイト
* | Microsoft Message Queuing の Web サイト
* | Microsoft SQL Server の Web サイト
* | Microsoft Windows Script Technologies の Web サイト
* | Microsoft XML Developer Center
* | MSDN Online
* | MSDN Online Library
* | マイクロソフト アクセシビリティ Web サイト


著作権情報

このソフトウェアの仕様およびマニュアルに記載されている事柄は、将来予告なしに変更することがあります。特に記載していない場合、このソフトウェアおよびマニュアルで使用している会社、組織、製品、人物、キャラクタ、データなどの名称は架空のものです。実在する商品名、団体名、個人名などとは一切関係ありません。このソフトウェアおよびマニュアルは、本製品の使用許諾契約書のもとでのみ使用することができます。このソフトウェアおよびマニュアルのいかなる部分も、米国 Microsoft Corporation の書面による許諾を受けることなく、その目的を問わず、どのような形態であっても、複製または譲渡することは禁じられています。ここでいう形態とは、複写や記録など、電子的な、または物理的なすべての手段を含みます。

マイクロソフトは、このマニュアルに記載されている内容に関し、特許、特許申請、商標、著作権、またはその他の無体財産権を有する場合があります。このマニュアルはこれらの特許、商標、著作権、またはその他の無体財産権に関する権利をお客様に許諾するものではありません。

Copyright © 1999–2000 Microsoft Corporation.All rights reserved.

Microsoft、Active Directory、ActiveX、BizTalk、JScript、MSDN、MS-DOS、Visio、Visual Basic、Visual C++、Visual Studio、Win32、Windows、および Windows NT は、米国 Microsoft Corporation の米国およびその他の国における登録商標または商標です。

Intel は Intel Corporation の登録商標です。

記載されている会社名、製品名には、各社の商標のものもあります。