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Abstract

This document provides step-by-step instructions for extending the solution you create in Tutorial 2 to incorporate a payment process that includes verifying that the partner received the purchase order, receiving the invoice from the partner, constructing a payment voucher for the partner using rules to determine the payment policy, sending the payment and receiving confirmation that the partner received the payment, and forwarding the payment acknowledgment internally.
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Tutorial 3: Invoice and Payment Process             

In Tutorial 2: Purchase Order Process, you created a business-to-business (B2B) solution by importing schemas and maps, and by designing an orchestration that processes purchase orders.

In this tutorial, you extend the orchestration to process invoices and payments. After you extend the orchestration, you incorporate correlation, connect the solution to the supplier's Web service, and add business rules and incorporate them with the orchestration.

Before you begin this tutorial, you must complete the steps in Tutorial 2: Purchase Order Process.

The scenario in this tutorial continues from the end of Tutorial 2 as follows: 

1.
BizTalk Server applies business rules to ensure that the invoice matches the products received. 

2.
BizTalk Server transforms the invoice to a payment voucher.

3.
BizTalk Server sends the payment voucher to the supplier.

4.
The supplier sends a payment acknowledgment.

5.
BizTalk Server sends the payment acknowledgment to the Enterprise Resource Planning (ERP) system. 

BizTalk Server 2006 ensures that the ERP system and the supplier interact smoothly and efficiently. This includes applying business rules to the payment approval process and routing the payment appropriately. 

For information about downloading a Microsoft Office Word 2003 version of the BizTalk Server 2006 Tutorials, see Step 6: Print the Tutorials.

In this Section


Lesson 1: Design the Invoice and Payment Process

Lesson 2: Incorporate Correlation

Lesson 3: Connect the B2B Solution to the Supplier Web Service

Lesson 4: Create a Payment Policy

Lesson 5: Integrate the Payment Policy with the Orchestration
Lesson 1: Design the Invoice and Payment Process             

In this lesson, you extend the B2BProcess orchestration to include an invoice and payment process.

Before you begin this lesson, you must complete the steps in Tutorial 2: Purchase Order Process.

In this Section


Step 1: Add the Invoice and Payment Shapes to the Orchestration

Step 2: Create the Invoice and Payment Message Instance Variables

Step 3: Construct the Payment Voucher Message

Step 4: Create, Configure, and Connect the Ports
Step 1: Add the Invoice and Payment Shapes to the Orchestration             
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Time to complete: 10 minutes

Objective: In this step, you add additional shapes to the B2BProcess orchestration.

Purpose: In this step, you extend the B2BProcess orchestration to include an invoice and payment process by adding additional shapes to route the shipping notice, invoice, and payment messages that are necessary to complete the procurement process. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete the steps in Before You Begin the Tutorials. 


Before you begin this step you must complete the steps in Tutorial 2: Purchase Order Process.


You must log on as a member of the BizTalk Server Administrators group.
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To add the action shapes for sending and receiving invoices and payments

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
From the Toolbox, drag the Receive shape to the orchestration design surface, and then drop the shape on the connecting line directly below the horizontal line that denotes the bottom of the Route_PO shape.

The following figure shows the new Receive shape.
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6.
On the design surface, right-click the Receive shape, and then click Properties Window.

7.
In the Properties pane, change the value of the Name property to Receive_ASN. 

8.
From the Toolbox, drag another Receive shape to the orchestration design surface, and then drop the shape on the connecting line directly below the Receive_ASN shape.

The following shows the second Receive shape.
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9.
On the design surface, right-click the Receive shape, and then click Properties Window.

10.
In the Properties pane, change the value of the Name property to Receive_Invoice. 

11.
From the Toolbox, drag the Transform shape to the orchestration design surface, and then drop the shape on the connecting line directly below the Receive_Invoice shape. 
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Note

When you drop the Transform shape on the design surface, Orchestration Designer creates the enclosing Construct Message shape for you.

The following figure shows the Transform shape.
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12.
On the design surface, right-click the Construct Message shape, and then click Properties Window.

13.
In the Properties pane, change the value of the Name property to Construct_PaymentVoucher. 

14.
From the Toolbox, drag the Send shape to the orchestration design surface, and then drop the shape on the connecting line directly below the Construct_PaymentVoucher shape.

The following figure shows the new Send shape.
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15.
On the design surface, right-click the Send shape, and then click Properties Window.

16.
In the Properties pane, change the value of the Name property to Send_Payment. 

17.
From the Toolbox, drag the Receive shape to the orchestration design surface, and then drop the shape on the connecting line directly below the Send_Payment shape.

The following figure shows the new Receive shape.
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18.
On the design surface, right-click the Receive shape, and then click Properties Window.

19.
In the Properties pane, change the value of the Name property to Receive_PaymentAck. 

20.
From the Toolbox, drag the Send shape to the orchestration design surface, and then drop the shape on the connecting line directly below the Receive_PaymentAck shape.

The following figure shows the new Send shape.
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21.
On the design surface, right-click the Send shape, and then click Properties Window.

22.
In the Properties pane, change the value of the Name property to Send_PaymentAck. 

23.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 2: Create the Invoice and Payment Message Instance Variables.


What did I just do?

You extended the B2BProcess orchestration.

Next Steps

You assign schemas as message types in Step 2: Create the Invoice and Payment Message Instance Variables.

See Also

Lesson 1: Design the Invoice and Payment Process
Step 2: Create the Invoice and Payment Message Instance Variables
Step 3: Construct the Payment Voucher Message
Step 4: Create, Configure, and Connect the Ports
Step 2: Create the Invoice and Payment Message Instance Variables             
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Time to complete: 10 minutes

Objective: In this step, you define four message instances for the B2BProcess orchestration. For each message instance, you change the value of the message instance Identifier property (name), and define a message type (schema or Web message).

Purpose: Because Orchestration Designer deals with message instances for managing data, rather than directly with the schemas, in this procedure you create variables for the message instances. Note that some of the message types point to schemas in your supplier's Web service, while others point to schemas in the B2BSchemas project. 
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Note

You added existing schemas to the B2BSchemas project in Step 4: Add Existing Schemas and Maps. In this step, you select the schemas as message types.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete the steps in Step 1: Add the Invoice and Payment Shapes to the Orchestration.


You must log on as a member of the BizTalk Server Administrators group.
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To create the message instance variables

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2Bprocess.odx.

5.
In the Orchestration View window, right-click Messages, and then click New Message. 

By default, the new message is named Message_1. 

6.
In the Orchestration View window, right-click Message_1, and then click Properties Window.

7.
In the Properties pane, do the following:

Use this

To do this

Identifier
Type ASN_Instance, and then press ENTER.

Message Type
From the drop-down list, expand Schemas, and then select Select from referenced assembly.

8.
In the Select Artifact Type dialog box, expand References, and then select B2BSchemas.

9.
From the Type Name | Fully Qualified Name list, select AdvancedShipNotice, and then click OK.

10.
Repeat steps 5 through 9 to create the following new messages. 

Message identifier

Message type

Referenced assembly

CommonInvoice_Instance

Schemas

B2BSchemas.CommonInvoice

PaymentVoucher_Instance

Web Message

B2BSchemas.ProcessPayment_request

PaymentAck_Instance

Web Message

B2BSchemas.ProcessPayment_response

11.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 3: Construct the Payment Voucher Message.


What did I just do?

In this step, you defined four message instances for the B2BProcess orchestration. For each message instance, you changed the value of the message instance Identifier property (name), and defined a message type (schema or Web message).

Next Steps

You construct the PaymentVoucher message in Step 3: Construct the Payment Voucher Message.

See Also

Lesson 1: Design the Invoice and Payment Process
Step 1: Add the Invoice and Payment Shapes to the Orchestration
Step 3: Construct the Payment Voucher Message
Step 4: Create, Configure, and Connect the Ports
Step 3: Construct the Payment Voucher Message             
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Time to complete: 10 minutes

Objective: In this step, you construct the PaymentVoucher message.

Purpose: You associate a map with a Transform shape to transform the invoice message received from the supplier into the PaymentVoucher message you send to the supplier. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Create the Invoice and Payment Message Instance Variables.


You must log on as a member of the BizTalk Server Administrators group.
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To construct the PaymentVoucher message using a map

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
On the orchestration design surface, right-click the Construct_PaymentVoucher shape, and then click Properties Window. 

6.
In the Properties pane, from the Messages Constructed drop-down list, select the PaymentVoucher_Instance check box, and then press ENTER.

7.
On the orchestration design surface, double-click the Transform_2 shape. 

8.
In the Transform Configuration dialog box, do the following:

Use this

To do this

Enter the configuration information
Select the Existing Map option.

Fully Qualified Map Name
From the drop-down list, select Select from Referenced Assembly.

9.
In the Select Artifact Type dialog box, do the following:

Use this

To do this

Current Project
Expand References, and then click B2BSchemas.

Type Name
Click InvoiceToPayment.

10.
Click OK. 

11.
In the Transform Configuration dialog box, click Source, and then from the Variable Name drop-down list, select CommonInvoice_Instance. 
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Note

The Source Transform section of the Transform Configuration dialog box is a grid control. You must click in the cell under Variable Name to expose the control. A control is a device you use to select options such as a drop-down list.

12.
In the Transform Configuration dialog box, click Destination, and then from the Variable Name drop-down list, select PaymentVoucher_Instance.Pay_xml. 
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Note

Source and Destination do not automatically show that you have provided the missing information (selected Variable Name). Click Source and Destination to refresh each other.

13.
Click OK. 

14.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 4: Create, Configure, and Connect the Ports.


What did I just do?

You configured the Transform shape to use the InvoiceToPayment map to transform CommonInvoice_Instance messages into PaymentVoucher_Instance messages.

Next Steps

You add two receive ports and two send ports to the B2BProcess orchestration in Step 4: Create, Configure, and Connect the Ports.

See Also

Lesson 1: Design the Invoice and Payment Process
Step 1: Add the Invoice and Payment Shapes to the Orchestration
Step 2: Create the Invoice and Payment Message Instance Variables
Step 4: Create, Configure, and Connect the Ports
Step 4: Create, Configure, and Connect the Ports             
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Time to complete: 8 minutes

Objective: In this step, you add two receive ports and two send ports to the B2BProcess orchestration.

Purpose: The following table describes the ports you create in this step.

	Port
	Purpose

	ReceiveASN_Port
	This port receives PO-received confirmation messages from the supplier.

	ReceiveInvoice_Port
	This port receives invoice messages from the supplier.

	RR_Payment_Port
	This is a request-response port that sends a payment voucher to the supplier and receives a confirmation response from the supplier.

	SendPaymentAck_Port
	This is an internal port that forwards (sends) payment acknowledgment within your company.
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Important

If you are building this solution with a version of BizTalk Server other than English, you must set the Port Type Operation to Operation_1 for the solution to work with the supplier's Web service. To verify that the Port Type Operation is set to Operation_1, in the Orchestration View window, expand Types, expand Port Types, expand each port and verify that the operation listed under the port is called Operation_1.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Construct the Payment Voucher Message.


You must log on as a member of the BizTalk Server Administrators group.
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To create and configure the ports

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
From the Toolbox, drag the Port shape to the right-side port surface, and then drop the shape parallel to the Receive_ASN shape. 
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Note

When you release the port onto the port surface, the Port Configuration Wizard starts automatically.

6.
On the Welcome to thePort Configuration Wizard page, click Next.

7.
On the Port Properties page, in the Name box, type ReceiveASN_Port, and then click Next.

8.
On the Select a Port Type page, do the following:

Use this

To do this

Select the port type to be used for this port
Select the Create a new Port Type option.

Port Type Name
Type ReceiveASN_Type.

Communication Pattern
Select the One-Way option.

Access Restrictions
Select the Public - no limit option.

9.
Click Next. 

10.
On the Port Binding page, do the following:

Use this

To do this

Port direction of communication
From the drop-down list, select I'll always be receiving messages on this port.

Port binding
From the drop-down list, select Specify later.

11.
Click Next, and then click Finish. 

12.
Use the information in the following table to add and configure a receive port called ReceiveInvoice_Port.
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Note

When you release the port onto the port surface, the Port Configuration Wizard starts automatically.
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warning

Be careful not to accept the defaults, because each port has different settings. If the settings are not correct, you will experience difficulties.

Property

Value

Port Name
ReceiveInvoice_Port

Port Type Name
ReceiveInvoice_Type

Communication Pattern
One-Way

Access Restrictions
Public - no limit

Port direction of communication
I'll always be receiving messages on this port

Port binding
Specify later

13.
Use the information in the following table to add and configure a send port called RR_Payment_Port.
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Note

When you release the port onto the port surface, the Port Configuration Wizard starts automatically.
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warning

Be careful not to accept the defaults, because each port has different settings. If the settings are not correct, you will experience difficulties.

Property

Value

Port Name
RR_Payment_Port

Port Type Name
RR_Payment_Type

Communication Pattern
Request-Response

Access Restrictions
Public - no limit

Port direction of communication
I'll be sending a request and receiving a response.

Port binding
Specify later

14.
Use the information in the following table to add and configure a send port called SendPaymentAck_Port.
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Note

When you release the port onto the port surface, the Port Configuration Wizard starts automatically.
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warning

Be careful not to accept the defaults, because each port has different settings. If the settings are not correct, you will experience difficulties.

Property

Value

Port Name
SendPaymentAck_Port

Port Type Name
SendPaymentAck_Type

Communication Pattern
One-Way

Access Restrictions
Internal - limited to this project

Port direction of communication
I'll always be sending messages on this port

Port binding
Specify later

15.
On the File menu, click Save All.

Next, you must connect the ports.
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To select the messages in the Action shapes and connect the ports

	1.
In Orchestration Designer, on the orchestration design surface, right-click the Receive_ASN action shape, and then click Properties Window. 

2.
In the Properties pane, from the Message drop-down list, select ASN_Instance. 

3.
Connect the ReceiveASN_Port port to the Receive_ASN action shape by selecting the green arrow-shaped handle in the ReceiveASN_Port port and dragging it to the green handle on the Receive_ASN action shape. 

4.
Repeat steps 1 and 2 to select messages for the action shapes. 

Action shape

Message

Receive_Invoice
CommonInvoice_Instance
Send_Payment
PaymentVoucher_Instance
Receive_PaymentAck
PaymentAck_Instance
SendPaymentAck
PaymentAck_Instance
5.
Repeat step 3 to connect the ports to the actionshapes. 

Port

Action shape

ReceiveInvoice_Port
Receive_Invoice
RR_Payment_Port
->Request
Send_Payment
RR_Payment_Port
->Response
Receive_PaymentAck
SendPaymentAck_Port
SendPaymentAck
6.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can start Lesson 2: Incorporate Correlation.


What did I just do?

In this step, you added two receive ports, one request-response port, and one send port to the B2BProcess orchestration.

Next Steps

You incorporate correlation into the B2BProcess orchestration in Lesson 2: Incorporate Correlation.

See Also

Lesson 1: Design the Invoice and Payment Process
Step 1: Add the Invoice and Payment Shapes to the Orchestration
Step 2: Create the Invoice and Payment Message Instance Variables
Step 3: Construct the Payment Voucher Message
Lesson 2: Incorporate Correlation             

In this lesson, you incorporate correlation into the B2BProcess orchestration. Correlation is the mechanism by which messages are associated with particular running instances of an orchestration, so that your business process gets the appropriate information when many instances are running and many messages are being sent back and forth.

In this Section


Step 1: Create the Correlation Property Schema

Step 2: Promote the Properties for the Correlation

Step 3: Create the Correlation Types

Step 4: Create the Correlation Set

Step 5: Initialize the Correlation Set

Step 6: Set the Correlation Properties
Step 1: Create the Correlation Property Schema             
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Time to complete: 10 minutes

Objective: In this procedure, you add a property schema to the B2BSchemas project. 

Purpose: The property schema contains only one element to check. The property schema identifies the PO number field element as the field that must be accessible in the business process for correlation. Using the PO number field for correlation enables the process to route messages containing the PO number appropriately. 

Property schemas contain only a flat list of fields (with no hierarchy) under the <Schema> node. For this reason, there is no root node. The XSD schema compiler gives an error if it finds a violation of this condition.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Lesson 1: Design the Invoice and Payment Process.


You must log on as a member of the BizTalk Server Administrators group.
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To create the correlation property schema

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, right-click B2BSchemas, point to Add, and then click New Item.

5.
In the Add New Item dialog box, do the following:

Use this

To do this

Categories
Click Schema Files.

Templates
Click Property Schema.

Name
Type CorProperties.xsd.

6.
Click Add.

7.
In BizTalk Explorer, in the schema tree, right-click Property 1, and then click Properties. 

8.
In the Properties pane, change the value of the Node Name property to PO_Num, and then press ENTER.

9.
In the schema tree, right-click <Schema>, and then click Properties.

10.
In the Properties pane, scroll down and make sure the Schema Type property is set to Property. 

11.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 2: Promote the Properties for the Correlation.


What did I just do?

In this step, you added a property schema to the B2BSchemas project. The CorProperties schema has one field, PO_Num, and is of type Property. Because the CorProperties schema is a property schema, you can promote the PO_Num field so that you can use it for correlation.

Next Steps

You promote the PO_Num property in three schemas in Step 2: Promote the Properties for the Correlation.

See Also

Lesson 2: Incorporate Correlation
Step 2: Promote the Properties for the Correlation
Step 3: Create the Correlation Types
Step 4: Create the Correlation Set
Step 5: Initialize the Correlation Set
Step 6: Set the Correlation Properties
Step 2: Promote the Properties for the Correlation             
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Time to complete: 3 minutes

Objective: In this step, you promote the PO_Num field in three schemas.

Purpose: You use the CorProperties schema inside the document schema to promote the PO_Num property. Notice that you set correlation properties on a schema in the supplier's Web service as well as on schemas from the B2BSchemas project. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Create the Correlation Property Schema.


You must log on as a member of the BizTalk Server Administrators group.
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To promote the correlation properties in the schemas

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BSchemas, expand Web References, expand localhost, expand Reference.map, and then double-click Reference.xsd to open the schema.  

5.
In the schema tree, right-click <Schema>, and then click Properties.

6.
In the Properties pane, click the Promote Properties ellipsis […].

7.
In the Promote Properties dialog box, on the Property Fields tab, click the Folder icon.

8.
In the BizTalkType Picker dialog box, expand B2BSchemas, expand Schemas, click B2BSchemas.CorProperties, and then click OK.

9.
In the Promote Properties dialog box, do the following: 

Use this

To do this

In the tree control

Expand CommonPO, expand POHeader, click Number, and then click Add.

On the Property Fields tab

From the Property fields list drop-down list (in the grid under the Property heading), select ns0:PO_Num.
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Note

Because only one property field is defined, this may be populated by default.

10.
Click OK. 

11.
In the schema change message box, click OK.

12.
In Solution Explorer, expand B2BSchemas, and then double-click CommonInvoice.xsd. 

13.
In the schema tree, right-click <Schema>, and then click Properties.

14.
In the Properties pane, click the Promote Properties ellipsis […].

15.
In the Promote Properties dialog box, on the Property Fields tab, click the Folder icon.

16.
In the BizTalkType Picker dialog box, expand B2BSchemas, expand Schemas, click B2BSchemas.CorProperties, and then click OK.

17.
In the Promote Properties dialog box, do the following: 

Use this

To do this

In the tree control

Expand InvoiceHeader, click PONumber, and then click Add. 

On the Property Fields tab

From the Property fields list drop-down list (in the grid under the Property heading), select ns0:PO_Num.

[image: image38.png]


Note

Because only one property field is defined, this may be populated by default.

18.
Click OK. 

19.
In Solution Explorer, expand B2BSchemas, and then double-click AdvancedShipNotice.xsd.  

20.
In the schema tree, right-click <Schema>, and then click Properties.

21.
In the Properties pane, click the Promote Properties ellipsis […].

22.
In the Promote Properties dialog box, on the Property Fields tab, click the Folder icon.

23.
In the BizTalkType Picker dialog box, expand B2BSchemas, expand Schemas, click B2BSchemas.CorProperties, and then click OK.

24.
In the Promote Properties dialog box, do the following: 

Use this

To do this

In the tree control

Expand Shipment, expand Order, click PONumber, and then click Add. 

On the Property Fields tab

From the Property fields list drop-down list (in the grid under the Property heading), select ns0:PO_Num.
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Note

Because only one property field is defined, this may be populated by default.

25.
Click OK. 

26.
In Solution Explorer, right-click B2BSchemas, and then click Rebuild.

27.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 3: Create the Correlation Types.


What did I just do?

In this step, you promoted the property that contains the PO number in three schemas. This enables you to use the PO number to correlate messages.

Next Steps

You create the correlation types in Step 3: Create the Correlation Types.

See Also

Lesson 2: Incorporate Correlation
Step 1: Create the Correlation Property Schema
Step 3: Create the Correlation Types
Step 4: Create the Correlation Set
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Time to complete: 3 minutes

Objective: In this step, you create the correlation types.

Purpose: A correlation type is a list of message properties. After creating the correlation types, you create a correlation set, which you use to associate values with those properties.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Promote the Properties for the Correlation.


You must log on as a member of the BizTalk Server Administrators group.
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To create the correlation types

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
In the Orchestration View window, expand Types, right-click Correlation Types, and then click New Correlation Type.
6.
In the Correlation Properties dialog box, expand B2BSchemas, click PO_Num, click Add, and then click OK. 
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Note

If B2BSchemas is not present in the Correlation Properties dialog box, you must refresh the reference. To refresh the reference, close the dialog box, and then in Solution Explorer, click the B2BSchemas reference and change the value of the Copy Local property from True to False. Change the value of the Copy Local property from False to True. 

7.
In the Orchestration View window, right-click CorrelationType_1, and then click Properties Window.

8.
In the Properties pane, change the value of the Identifier property to Correl_PO. 

9.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 4: Create the Correlation Set.


What did I just do?

You created a new correlation type based on the PO_Num promoted property.

Next Steps

You create the correlation sets in Step 4: Create the Correlation Set.
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Time to complete: 3 minutes

Objective: In this step, you create the correlation set.

Purpose: Correlation sets are lists of message properties and associated values that you apply when sending and receiving messages in your orchestration, to guarantee that incoming messages are associated with the correct running instance of your orchestration.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Create the Correlation Types.


You must log on as a member of the BizTalk Server Administrators group.
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To create the correlation set

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
In the Orchestration View window, right-click Correlation Sets, and then click New Correlation Set.

6.
In the Orchestration View window, right-click Correlation_1, and then click Properties Window.

7.
In the Properties pane, do the following:

Use this

To do this

Identifier
Type PO_CorrelSet.

Correlation Type
From the drop-down list, select B2BOrchestrations.Correl_PO.

8.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 5: Initialize the Correlation Set.


What did I just do?

You defined a new correlation set to guarantee that incoming messages are associated with the correct running instance of your orchestration.

Next Steps

You initialize the correlation set in Step 5: Initialize the Correlation Set.
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Time to complete: 3 minutes

Objective: In this step, you initialize the correlation set values in the Send shape.

Purpose: You initialize the correlation set values in the Send shape so that subsequent incoming messages will correlate to the PO number. If you expect to receive either a direct or indirect response to a message that you have previously sent, you must correlate the message with the currently running instance of the orchestration. For more information, see Correlating Messages with Orchestration Instances.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 4: Create the Correlation Set.


You must log on as a member of the BizTalk Server Administrators group.
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To initialize the correlation set

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
In Orchestration Designer, on the orchestration design surface, right-click the Send_CommonPO shape, and then click Properties Window. 

6.
In the Properties pane, from the Initializing Correlation Sets drop-down list, select the PO_CorrelSet check box, and then press ENTER.

7.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 6: Set the Correlation Properties.


What did I just do?

You associated the Send_CommonPO shape with the PO_CorrelSet correlation set.

Next Steps

You specify the correlation set that is used to restrict the messages the Receive shapes will accept in Step 6: Set the Correlation Properties.
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Time to complete: 3 minutes

Objective: In this step, you set the correlation properties. 

Purpose: The correlation set restricts the messages the Receive shapes will accept. A correlation set defines a set of properties and values for these properties that a message must contain to be processed by a particular orchestration.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 5: Initialize the Correlation Set.


You must log on as a member of the BizTalk Server Administrators group.
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To set the correlation properties

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2Bprocess.odx.

5.
In Orchestration Designer, on the orchestration design surface, right-click the Receive_ASN shape, and then click Properties Window. 

6.
In the Properties pane, from the FollowingCorrelation Sets drop-down list, select the PO_CorrelSet check box. 

7.
In Orchestration Designer, on the orchestration design surface, right-click the Receive_Invoice shape, and then click Properties Window. 

8.
In the Properties pane, from the FollowingCorrelation Sets drop-down list, select the PO_CorrelSet check box. 

9.
On the File menu, click Save All.

10.
In Solution Explorer, right-click B2BOrchestrations, and then click Rebuild.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Lesson 3: Connect the B2B Solution to the Supplier Web Service.


What did I just do?

In this step, you set the correlation properties that restrict the messages the Receive shapes will accept.

Next Steps

You connect the B2B solution to the supplier's Web service in Lesson 3: Connect the B2B Solution to the Supplier Web Service.
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In this lesson, you connect the B2B solution to the supplier's Web service.

In this Section


Step 1: Configure the Ports that Call the Web Service

Step 2: Undeploy the Solution

Step 3: Redeploy the Solution

Step 4: Publish the Orchestration as a Web Service

Step 5: Update the Supplier Web Service References

Step 6: Configure and Start B2BApplication

Step 7: Test the Solution
Step 1: Configure the Ports that Call the Web Service             
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Time to complete: 10 minutes

Objective: In this step, you reconfigure the SendCommonPO_Port port to call the supplier's Web service, and configure the Payment port to interact with the supplier's Web service.

Purpose: To consume a Web service in an orchestration, you must add a Web reference, a port, and message variables, and construct Web message instances. 

When you add a new port to the orchestration, the Web reference is listed as an existing Web port type. In this step, you use the Port Configuration Wizard to associate the Web reference with the ports and messages.  

To export an orchestration as a Web service, you set the access modifier on the port type of the port to be exposed to Public. When you create a port type, the default access modifier is set to Internal. You must make this change in the Port Type property pages.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Lesson 2: Incorporate Correlation.


You must log on as a member of the BizTalk Server Administrators group.
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To configure a port that sends the PO to the supplier's Web service

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx. 

5.
On the orchestration design surface, right-click SendCommonPO_Port, and then click Configure Port. 

6.
On the Welcome to the Port Configuration Wizard page, click Next.

7.
On the Port Properties page, click Next.

8.
On the Select a Port Type page, do the following:

Use this

To do this

Select the port type to be used for this port
Select the Use an existing Port Type option.

Available Port Types
In the list, expand C:\Tutorial\Lessons\B2BSolution\B2BOrchestrations\Bin\Development\B2BSchemas.DLL, expand Web Port Types, and then click B2BSchemas.localhost.Process_.Process.
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Note

C:\Tutorial\Lessons\B2BSolution\B2BOrchestrations\Bin\Development\B2BSchemas.DLL is at the bottom of the list.

9.
Click Next. 

10.
On the Port Binding page, click Next. 

11.
Click Finish to exit the Port Configuration Wizard. 

12.
Connect the SendCommonPO_Port port to the Send_CommonPO action shape.
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To configure the Payment port to interact with the supplier's Web service

	1.
On the orchestration design surface, right-click RR_Payment_Port, and then click Configure Port. 

2.
On the Welcome to thePort Configuration Wizard page, click Next.

3.
On the Port Properties page, click Next.

4.
On the Select a Port Type page, do the following:

Use this

To do this

Select the port type to be used for this port
Select the Use an existing Port Type option.

Available Port Types
In the list, expand C:\Tutorial\Lessons\B2BSolution\B2BOrchestrations\Bin\Development\B2BSchemas.DLL, expand Web Port Types, and then click B2BSchemas.localhost1.Payment_Service_.Payment_Service.
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Note

C:\Tutorial\Lessons\B2BSolution\B2BOrchestrations\Bin\Development\B2BSchemas.DLL is at the bottom of the list.

5.
Click Next.  

6.
On the Port Binding page, from the Port Binding drop-down list, select Specify now. 
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Note

None of the port binding fields (URI, Transport, Receive pipeline, or Send pipeline) are active.

7.
Click Next, and then click Finish. 

8.
Reconnect RR_Payment_Port (Request) to the Send_Payment shape, and then reconnect RR_Payment_Port (Response) to the Receive_PaymentAck shape. 

9.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 2: Undeploy the Solution.


What did I just do?

In this step, you reconfigured the port type for the RR_Payment_Port and SendCommonPO_Port ports.

Next Steps

You use BizTalk Explorer to stop and unenlist the B2BProcess orchestration, and then you undeploy both projects, B2BOrchestrations and B2BSchemas, in Step 2: Undeploy the Solution.

See Also
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Time to complete: 10 minutes

Objective: In this step, you use BizTalk Explorer to stop and unenlist the B2BProcess orchestration, and then you undeploy both projects: B2BOrchestrations and B2BSchemas.

Purpose: You stop and unenlist the B2BProcess orchestration to remove the orchestration binding. You undeploy both projects so that you can redeploy them. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Configure the Ports that Call the Web Service.


You must log on as a member of the BizTalk Server Administrators group.
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To undeploy the solution

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
On the View menu, click BizTalk Explorer.  

5.
In BizTalk Explorer, expand <ServerName>.BizTalkMgmtDb.dbo, expand Orchestrations, right-click B2BOrchestrations.B2BProcess, and then click Stop. 

6.
Right-click B2BOrchestrations.B2BProcess again, and then click Unenlist. 

7.
In the BizTalk Explorer - Express Unenlist dialog box, select the Terminate existing Orchestration Instances check box, and then click OK. 

8.
In BizTalk Explorer, expand Assemblies, right-click B2BOrchestrations, and then click Undeploy.

9.
In the confirmation message box, click Yes.

10.
In BizTalk Explorer, expand Assemblies, right-click B2BSchemas, and then click Undeploy.

11.
In the confirmation message box, click Yes.


What did I just do?

In this step, you removed the B2BProcess orchestration bindings and undeployed the B2BOrchestrations and B2BSchemas projects.

Next Steps

You deploy the B2BSchemas and B2BOrchestrations projects in Step 3: Redeploy the Solution.
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Time to complete: 3 minutes

Objective: In this step, you deploy the B2BSchemas and B2BOrchestrations projects.

Purpose: You deploy the assemblies (projects) to place a copy of each of the assemblies in the BizTalk Management database (also known as the Configuration database) and install each assembly in the global assembly cache. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Undeploy the Solution.


You must log on as a member of the BizTalk Server Administrators group.
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To redeploy the updated solution

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
On the View menu, click BizTalk Explorer.

5.
In BizTalk Explorer, right-click <ServerName>.BizTalkMgmtDb.dbo, and then click Refresh. 

6.
Expand Assemblies and verify that B2BOrchestrations and B2BSchemas are no longer listed as deployed assemblies.

7.
In Solution Explorer, right-click Solution 'B2BSolution', and then click Deploy Solution. 
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Note

Deployment errors, warnings, and progress can be viewed in the output window and task list at the bottom of the page. 


What did I just do?

In this step, you deployed the projects.

Next Steps

You publish the B2BProcess orchestration as a Web service in Step 4: Publish the Orchestration as a Web Service.

See Also

Lesson 3: Connect the B2B Solution to the Supplier Web Service
Step 1: Configure the Ports that Call the Web Service
Step 2: Undeploy the Solution
Step 4: Publish the Orchestration as a Web Service
Step 5: Update the Supplier Web Service References
Step 6: Configure and Start B2BApplication
Step 7: Test the Solution
Step 4: Publish the Orchestration as a Web Service             

[image: image66.png]Step 4




Time to complete: 5 minutes

Objective: In this step, you publish the B2BProcess orchestration as a Web service.

Purpose: You publish (expose) your orchestration as a Web service to separate the Web service logic from the business process logic. 

To publish an orchestration as a Web service, you first have to design and build the orchestration and generate an assembly. 

Then, you use the BizTalk Web Service Publishing Wizard to create a Web service based on an orchestration in a BizTalk Server assembly. Using the wizard, you can select orchestrations and receive ports to expose as Web services. The wizard enables you to define target namespaces, SOAP header requirements, and the locations for the wizard's generated Web service project.

The wizard creates one Web service (.asmx file) for each receive port. Each operation in the receive port becomes a Web method. The operation message types define the Web method signatures. Each message type part is a parameter in the Web method.

For more information about how ASP.NET Web services work, see http://go.microsoft.com/fwlink/?LinkId=25200.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Redeploy the Solution.


You must log on as a member of the BizTalk Server Administrators group.
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To publish the B2BOrchestration as a Web service

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
On the Tools menu, click BizTalk Web ServicesPublishing Wizard.
5.
 On the Welcome to the BizTalk Web Services Publishing Wizard page, click Next.

6.
On the Create Web Service page, verify that the Publish BizTalk orchestrations as Web services option is selected, and then click Next.

7.
On the BizTalk Assembly page, browse to C:\Tutorial\Lessons\B2BSolution\B2BOrchestrations\bin\Development, select B2BOrchestrations.dll, click Open, and then click Next.  

8.
On the Orchestrations and Ports page, verify that ReceiveASN_Port and ReceiveInvoice_Port are selected, and then click Next.

9.
On the Web Service Properties page, in the Target namespace of Web services box, type http://B2BOrchestrations_WebService.org, and then click Next.

10.
On the Web Service Project page, do the following:

Use this

To do this

Location (http://host(:port)/path)
Type B2BOrchestrations_Proxy.

Allow anonymous access to this Web service
Select this check box to enable anonymous access.

11.
Click Next.

12.
On the Web Service Project Summary page, click Create.

13.
On the Completing the BizTalk Web Services Publishing Wizard page, click Finish.

14.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 5: Update the Supplier Web Service References.


What did I just do?

In this step, you published the B2BProcess orchestration as a Web service.

Next Steps

You update the supplier service Web references in Step 5: Update the Supplier Web Service References.
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Time to complete: 3 minutes

Objective: In this step, you update the supplier Web service references.

Purpose: You update the supplier Web service references to make sure that the published orchestration and the supplier Web service have the correct references.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 4: Publish the Orchestration as a Web Service.


You must log on as a member of the BizTalk Server Administrators group.
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To update the supplier Web service references

	1.
In Windows Explorer, browse to C:\Tutorial\Solutions\SupplierWebServices\.

2.
Double-click B2BSupplierWebService.sln to open it in a new instance of Visual Studio 2005.

3.
In Solution Explorer, expand B2BSupplierProcessPO, and then expand App_Web References. 

4.
Right-click localhost,and then click Update Web References.

5.
Right-click localhost1, and then click Update Web References.

6.
Right-click Solution 'B2BSupplierWebService', and then click Rebuild Solution.

7.
When the build succeeds, close the solution and the instance of Visual Studio. 

8.
Close Windows Explorer.


What did I just do?

In this step, you updated the supplier Web service references.

Next Steps

You create the receive ports and receive locations in Step 6: Configure and Start B2BApplication.
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Time to complete: 15 minutes

Objective: In this step, you configure and start the B2BApplication application.

Purpose: You use the BizTalk Server Administration console to configure the B2BApplication application. When you configure the B2BApplication application, you bind the orchestration to the BizTalkServerApplication host and create the receive ports, receive locations, and send ports. Binding the orchestration associates the logical ports on the orchestration design surface with the physical ports you create in this step. 

Associating the logical ports with physical ports makes the URI and adapter configurations available to the business process during run time. When you define a static one-way send port, you specify the destination address, the Uniform Resource Identifier (URI), and the pipelines that are used to send payment acknowledgments to the ERP system. 

Starting the B2BApplication application enlists and starts the orchestration. Enlisting the orchestration associates the business process that you designed in Orchestration Designer with the physical environment in which it will run, and creates the core subscriptions in the MessageBox database. When you start the application, the orchestration begins processing.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 5: Update the Supplier Web Service References.


You must log on as a member of the BizTalk Server Administrators group.
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To configure the receive ports

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click BizTalk Server Administration. 

2.
In the BizTalk Server Administration console, in the console tree, expand BizTalk Server 2006 Administration, right-click BizTalk Group, and then click Refresh.

3.
In the console tree, expand BizTalk Group, expand Applications, right-click B2BApplication, and then click Configure.

4.
In the Configure Application dialog box, on the B2BProcess tab, do the following: 

Use this

To do this

Host
From the drop-down list, select BizTalkServerApplication.
ReceivePO_Port
From the Receive Ports drop-down list, select ReceivePO_ReceivePort.

ReceiveANS_Port
From the Receive Ports drop-down list, select <New receive port>.

5.
In the ReceivePort1 - Receive Port Properties dialog box, on the General tab, in the Name box, type ASN_ReceivePort.

6.
In the ReceivePort1 - Receive Port Properties dialog box, on the Receive Location tab, click New.

7.
In the ReceiveLocation1 - Receive Location Properties dialog box, do the following:

Use this

To do this

Name
Type ASN Receive Location.

Transport Type
From the drop-down list, select SOAP.

8.
Click Configure.

9.
In the SOAP Transport Properties dialog box, in the Virtual directory plus Web Service asmx file box, type /B2BOrchestrations_WebService/B2BOrchestrations_B2BProcess_ReceiveASN_Port.asmx, and then click OK. 

10.
In the Receive Location Properties dialog box, on the General tab, do the following:

Use this

To do this

Receive Handler
From the drop-down list, select BizTalkServerIsolatedHost.

Receive Pipeline
From the drop-down list, select XMLReceive (Microsoft.BizTalk.DefaultPipelines.XMLReceive, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35).

11.
Click OK to closethe Receive Location Properties dialog box. 

12.
Click OK to closethe ASN_ReceivePort - Receive Port Properties dialog box.

13.
In the Configure Application dialog box, on the B2BProcess tab, in the ReceiveInvoice_Port row, from the Receive Ports drop-down list, select <New receive port>.

14.
In the ReceivePort1 - Receive Port Properties dialog box, on the General tab, in the Name box, type Invoice_ReceivePort.

15.
In the ReceivePort1 - Receive Port Properties dialog box, on the Receive Location tab, click New.

16.
In the ReceiveLocation1 - Receive Location Properties dialog box, do the following:

Use this

To do this

Name
Type Invoice Receive Location.

Transport Type
From the drop-down list, select SOAP.

17.
Click Configure.

18.
In the SOAP Transport Properties dialog box, in the Virtual directory plus Web Service asmx file box, type /B2BOrchestrations_WebService/B2BOrchestrations_B2BProcess_ReceiveInvoice_Port.asmx, and then click OK. 

19.
In the Receive Location Properties dialog box, on the General tab, do the following:

Use this

To do this

Receive Handler
From the drop-down list, select BizTalkServerIsolatedHost.

Receive Pipeline
From the drop-down list, select XMLReceive (Microsoft.BizTalk.DefaultPipelines.XMLReceive, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35).

20.
Click OK to closethe Receive Location Properties dialog box. 

21.
Click OK to closethe Invoice_ReceivePort - Receive Port Properties dialog box.

22.
In the Configure Application dialog box, on the B2BProcess tab, do the following:

Use this

To do this

SendPOConfirmed_Port
From the Send Ports/Send Port Groups drop-down list, select SendPOConfirmed_SendPort.

SendCommonPO_Port
From the Send Ports/Send Port Groups drop-down list, select SendCommonPO_SendPort.

SendPaymentAckPort
From the Send Ports/Send Port Groups drop-down list, select <New send port>.

23.
In the SendPort1 -Send Port Properties dialog box, on the General tab, do the following:

Use this

To do this

Name
Type SendPort_PaymentAck.

Transport Type
From the drop-down list, select File.

24.
Click Configure.

25.
In the FILE Transport Properties dialog box, do the following:

Use this

To do this

Destination folder
Type C:\Tutorial\FileDrop\ERPSys.

File Name
Type PayAck%MessageID%.xml.

26.
Click OK. 

27.
In the SendPort_PaymentAck - Send Port Properties dialog box, on the General tab, from the Send Pipeline drop-down list, select XMLTransmit (Microsoft.BizTalk.DefaultPipelines.XMLTransmit, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35).
28.
Click OK to closethe SendPort_PaymentAck - Send Port Properties dialog box.

29.
Click OK to closethe Configure Application dialog box.

30.
In the console tree, expand BizTalk Group, expand Applications, right-click B2BApplication, and then click Start.

31.
In the Start 'B2BApplication' Application dialog box, click Options, make sure that all of the check boxes are selected, and then click Start.

32.
In the console tree, click Applications.

B2BApplication should show Started in the Status column.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Step 7: Test the Solution.


What did I just do?

In this step, you configured and started the B2BApplication application.

Next Steps

You test the solution to make sure it works in Step 7: Test the Solution.

See Also

Lesson 3: Connect the B2B Solution to the Supplier Web Service
Step 1: Configure the Ports that Call the Web Service
Step 2: Undeploy the Solution
Step 3: Redeploy the Solution
Step 4: Publish the Orchestration as a Web Service
Step 5: Update the Supplier Web Service References
Step 7: Test the Solution
Step 7: Test the Solution             
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Time to complete: 2 minutes

Objective: In this step, you test the solution to make sure it works.

Purpose: You simulate the process of receiving a purchase order (PO) from the Enterprise Resource Planning (ERP) system by dropping an instance of a PO into a file location. The PO will be transformed and routed. A CommonPO will be sent to the supplier's Web service. An advanced shipping notice (ASN) and invoice will be returned from the supplier and a payment will be sent back. When the transaction is complete, you should have a POConfirmed message at the warehouse and a payment acknowledgment sent to the ERP system. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 6: Configure and Start B2BApplication.


You must log on as a member of the BizTalk Server Administrators group.
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To test the solution

	1.
In Windows Explorer, browse to C:\Tutorial, and copy POInstance.xml to C:\Tutorial\Filedrop\ReceivePO. 
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Important

Do not move the file because BizTalk Server processes it and then removes it from the \ReceivePO directory.

2.
Browse to C:\Tutorial\Filedrop\FileArchive to verify that POConfirmed was archived. 

3.
Browse to C:\Tutorial\Filedrop\ERPSys to verify that a payment acknowledgment was sent to the ERP system and that the B2B solution completed. 

4.
Close Windows Explorer.


What did I just do?

In this step, you tested the solution to make sure it works.

Next Steps

You add business rules to the orchestration in Lesson 4: Create a Payment Policy.

See Also

Lesson 3: Connect the B2B Solution to the Supplier Web Service
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In this lesson, you add business rules to the orchestration. The Business Rules Framework provides a way for you to integrate changing business policies with complex business processes. 

The Business Rule Composer is a graphical interface that developers, business analysts, and administrators can use to develop and apply business rules and policies (sets of rules). You use the Rule Composer in this lesson to create vocabularies and business rules that will update the payment voucher so that the payment amount and terms are correct. 

The Rule Engine Deployment Wizard enables you to quickly and easily deploy your policies, and also enables you to import, publish, and export both policies and vocabularies. This architecture also enables you to dynamically change business policies without the need to recompile any code. To do this, you simply create another version, and publish and deploy it. 

In this Section


Step 1: Add a Vocabulary

Step 2: Define Get Elements for the Vocabulary

Step 3: Define Set Elements for the Vocabulary

Step 4: Publish the Vocabulary

Step 5: Add a Business Policy

Step 6: Add Rules to the Policy
Step 1: Add a Vocabulary             
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Time to complete: 1 minute

Objective: In this step, you create the foundation vocabulary that you will use to define the business policy in the next procedure.

Purpose: Vocabularies are used to bind data sources to more user-friendly language expressions. You do not have to use vocabularies when you create business rules, because you can use data elements directly in rule expressions. However, vocabularies enable you to create rules that are easier to understand. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Lesson 3: Connect the B2B Solution to the Supplier Web Service.


You must log on as a member of the BizTalk Server Administrators group.
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To add the new vocabulary

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click Business Rule Composer. 
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Note

If you are prompted to Open the Rule Store, click OK to continue.

2.
In the Business Rule Composer, in the Facts Explorer, on the Vocabularies tab, right-click the Vocabularies node, and then click Add New Vocabulary.

3.
Change the Name to B2BVocabulary, and then press ENTER.  


What did I just do?

In this step, you created the foundation vocabulary that you will use to define the business policy in the next procedure.

Next Steps

You define Get elements for the vocabulary in Step 2: Define Get Elements for the Vocabulary.

See Also

Lesson 4: Create a Payment Policy
Step 2: Define Get Elements for the Vocabulary
Step 3: Define Set Elements for the Vocabulary
Step 4: Publish the Vocabulary
Step 5: Add a Business Policy
Step 6: Add Rules to the Policy
Step 2: Define Get Elements for the Vocabulary             
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Time to complete: 7 minutes

Objective: In this step, you define Get elements for the vocabulary.

Purpose: The Get elements you define in this step identify schema items that correspond to values to get from messages. You use the Get elements in the rules you define in Step 6: Add Rules to the Policy. The rules compare the values returned to the rule by the Get elements. The following table shows the schema and schema item for each Get element.

	Get element
	Schema
	Schema item

	PO Quantity
	PO.xsd
	PO/Item/Quantity

	Quantity Shipped
	AdvancedShipNotice.xsd
	CommonAdvancedShipNotice/ HashTotal/ItemCount

	Quantity Invoiced
	CommonInvoice.xsd
	CommonInvoice/ InvoiceSummary/ ShipDetail/ <AttrGroup:VolumeAttGroupType>/ Volume

	Quantity Paid for
	Reference.xsd
	Payment/Item/Quantity

	Supplier Name
	CommonInvoice.xsd
	Seller/Address/Name


Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Add a Vocabulary.


You must log on as a member of the BizTalk Server Administrators group.
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To define an XML document Get element

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click Business Rule Composer.

2.
In Facts Explorer, expand the B2BVocabulary folder, right-click Version 1.0(not saved), and then select Add New Definition. 

3.
On the Welcome to the Vocabulary Definition Wizard page, select the XML Document Element or Attribute option, and then click Next.

4.
On the XML Document Element or Attribute page, in the Definition Name box, type PO Quantity, and then click Browse.

5.
In the Schema Files dialog box, navigate to C:\Tutorial\Lessons\B2BSolution\B2BSchemas\, and then open PO.xsd.

6.
In the Select Binding dialog box, expand PO, expand Item, select Quantity, and then click OK.

7.
In the Vocabulary Definition Wizard, do the following:

Use this

To do this

Document Type
Type B2BSchemas.PO.

[image: image82.png]


Important

The Document Type must exactly match the fully qualified name for the solution to work.

Select operation
Select the Perform "Get" operation option.

Display Name
Type PO Quantity.
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Note

By default, the Display Name will match the Definition Name.

8.
Click Finish.

9.
Repeat steps 1 through 8 to define additional XML document Get elements with the following values. 

Property

Value

Definition Name
Quantity Shipped

Schema File
AdvancedShipNotice.xsd

Select Binding
CommonAdvancedShipNotice/HashTotal/ItemCount

Document Type
B2BSchemas.AdvancedShipNotice

Select operation
Perform "Get" operation

Display Name
Quantity Shipped

Property

Value

Definition Name
Quantity Invoiced

Schema File
CommonInvoice.xsd

Select Binding
CommonInvoice/InvoiceSummary/ShipDetail/<AttrGroup:VolumeAttGroupType>/Volume

Document Type
B2BSchemas.CommonInvoice

Select operation
Perform "Get" operation

Display Name
Quantity Invoiced

Property

Value

Definition Name
Quantity Paid for

Schema File
Browse to: /Web References/localhost1/Reference.xsd

Select Binding
Payment/Item/Quantity

Document Type
B2BSchemas.localhost1.Reference.Payment

Select operation
Perform "Get" operation
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Note

Click Next. On the Specify the Display Name page, click Finish.

Display Name
Quantity Paid for

Property

Value

Definition Name
Supplier Name

Schema File
In the Schema Files dialog box, navigate to C:\Tutorial\Lessons\B2BSolution\B2BSchemas\ and then open CommonInvoice.xsd.

Select Binding
Seller/Address/Name

Document Type
B2BSchemas.CommonInvoice

Select operation
Perform "Get" operation

Display Name
Supplier Name




What did I just do?

In this step, you defined Get elements for the vocabulary.

Next Steps

You define Set elements for the vocabulary in Step 3: Define Set Elements for the Vocabulary.

See Also

Lesson 4: Create a Payment Policy
Step 1: Add a Vocabulary
Step 3: Define Set Elements for the Vocabulary
Step 4: Publish the Vocabulary
Step 5: Add a Business Policy
Step 6: Add Rules to the Policy
Step 3: Define Set Elements for the Vocabulary             
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Time to complete: 6 minutes

Objective: In this step, you define Set elements for the vocabulary.

Purpose: The Set elements you define in this step identify schema items that correspond to values to set in messages. You use the Set elements in the rules you define in Step 6: Add Rules to the Policy. The following table shows the schema and schema item for each Set element.

	Set element
	Schema
	Schema item

	Set Payment Terms to
	Reference.xsd
	Payment/ PaymentSummary/ Terms

	Set Quantity Paid for to
	Reference.xsd
	Payment/Item/Quantity


Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Define Get Elements for the Vocabulary.


You must log on as a member of the BizTalk Server Administrators group.
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To define an XML document Set element

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click Business Rule Composer.

2.
In Facts Explorer, expand the B2BVocabulary folder, right-click Version 1.0(not saved), and then select Add New Definition. 

3.
On the Welcome to the Vocabulary Definition Wizard page, select the XML DocumentElement or Attribute option, and then click Next.

4.
On the XML Document Element or Attribute page, in the Definition Name box, type Set Payment Terms to, and then click Browse.

5.
In the Schema Files dialog box, navigate to C:\Tutorial\Lessons\B2BSolution\B2BSchemas\Web References\localhost1, click Reference.xsd, and then click Open.

6.
In the Select Binding dialog box, expand Payment, expand PaymentSummary, click Terms, and then click OK.

7.
On the XML Document Element or Attribute page, do the following:

Use this

To do this

Document type
Check that the document type is B2BSchemas.localhost1.Reference.Payment. 

Select operation
Select the Perform "Set" operation option.

8.
Click Next.

9.
On the Specify the Display Name page,accept the defaults, and then click Finish.

10.
Repeat steps 1 through 9 to create a Set element with the following parameters:

Property 

Value

Definition Name
Set Quantity Paid for to

Schema File
C:\Tutorial\Lessons\B2BSolution\B2BSchemas\Web References\localhost1\Reference.xsd

Select Binding
Payment/Item/Quantity

Document Type
B2BSchemas.localhost1.Reference.Payment

Select operation 
Perform "Set" operation




What did I just do?

In this step, you defined Set elements for the vocabulary.

Next Steps

You publish the vocabulary in Step 4: Publish the Vocabulary.

See Also

Lesson 4: Create a Payment Policy
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Step 5: Add a Business Policy
Step 6: Add Rules to the Policy
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Time to complete: 2 minutes

Objective: In this step, you publish the vocabulary.

Purpose: You publish the vocabulary to make the vocabulary available to the policy.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Define Set Elements for the Vocabulary.


You must log on as a member of the BizTalk Server Administrators group.
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To save and publish the vocabulary

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click Business Rule Composer.

2.
In Facts Explorer, expand the B2BVocabulary folder, right-click Version 1.0, and then click Save. 

3.
In Facts Explorer, under the B2BVocabulary folder, right-click Version 1.0, and then click Publish. 


What did I just do?

In this step, you published the vocabulary.

Next Steps

You use the vocabulary that you built in the previous step to construct the business policy in Step 5: Add a Business Policy.

See Also
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Step 3: Define Set Elements for the Vocabulary
Step 5: Add a Business Policy
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Time to complete: 2 minutes

Objective: In this step, you use the vocabulary that you built in the previous step to construct the business policy. You will then publish and deploy this policy.

Purpose: A policy represents a set of rules that can be implemented from the orchestration. When a policy is applied, the conditions for each rule in the policy are evaluated. Rule actions are completed for those rules whose conditions evaluate to True, similar to an IF-THEN semantic. Conditions consist of predicates, facts, and vocabulary definitions. Actions often consist of setting data values or calling functions.

In this procedure, you use the vocabulary that you built in the previous procedure to construct the business policy.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 4: Publish the Vocabulary.


You must log on as a member of the BizTalk Server Administrators group.
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To add a new business policy

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click Business Rule Composer.

2.
In the Policy Explorer pane, right-click Policies, and then select Add New Policy. 

3.
Change the name of Policy1 to Payment Policy, and then press ENTER. 


What did I just do?

In this step, you used the vocabulary that you built in the previous step to construct the business policy. 

Next Steps

You add rules to the policy you created in this step in Step 6: Add Rules to the Policy.

See Also

Lesson 4: Create a Payment Policy
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Step 2: Define Get Elements for the Vocabulary
Step 3: Define Set Elements for the Vocabulary
Step 4: Publish the Vocabulary
Step 6: Add Rules to the Policy
Step 6: Add Rules to the Policy             
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Time to complete: 10 minutes

Objective: In this step, you add rules to the policy you created in Step 5: Add a Business Policy.

Purpose: Rule actions are completed for those rules whose conditions evaluate to True. When a policy is applied, the conditions for each rule in the policy are evaluated.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 5: Add a Business Policy.


You must log on as a member of the BizTalk Server Administrators group.
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To add the policy rule and conditions for the 3 Way Match rule

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click Business Rule Composer.

2.
In the Policy Explorer pane, expand the Payment Policy folder, right-click Version 1.0(not saved), and then select Add New Rule. 

3.
Change the name Rule1 to 3 Way Match, and then press ENTER.
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Note

Next you add the conditions to the 3 Way Match rule. Conditions are the "IF" part of a rule, used to specify what conditions should be evaluated, that is, represented by using a single logical expression that evaluates to true or false. The condition you add to the 3 Way Match rule uses a logical AND operator that combines two or more predicates (statements) to form a logical AND expression. 

4.
In the IF pane, right-click Conditions, and then click Add logical AND.

5.
In the Facts Explorer pane, expand Vocabularies, expand Predicates, expand Version 1.0, and then drag Equal to the IF pane composer surface and drop it on the AND placeholder. 

6.
Repeat step 5 to add a second Equal statement to the conditions.

7.
In the Facts Explorer pane, expand Vocabularies, expand B2BVocabulary, expand Version 1.0 - Published, and drag PO Quantity to the IF pane composer surface and drop it onto the first argument1 placeholder.

8.
Drag Quantity Shipped and drop itonto the first argument2 placeholder.

9.
In the Facts Explorer pane, expand Vocabularies, expand B2BVocabulary, expand Version 1.0 - Published, and drag PO Quantity to the IF pane composer surface and drop it onto the second argument1 placeholder.

10.
Drag Quantity Invoiced and drop itonto the second argument2 placeholder.
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To add the policy rule and conditions for the Negation of 3 Way Match rule

	1.
In the Policy Explorer pane, under the Payment Policy folder, right-click Version 1.0(not saved), and then select Add New Rule. 

2.
Change the name Rule1 to Negation of 3 Way Match, and then press ENTER.

3.
In the IF pane, right-click Conditions, and then click Add logicalNOT.

4.
In the IF pane, right-click NOT, and then click Add logical AND.

5.
In the Facts Explorer pane, under Vocabularies, expand Predicates, expand Version 1.0, and drag Equal to the IF pane composer surface and drop it onto the AND placeholder.

6.
Repeat step 5 to add a second Equal statement to the conditions.

7.
In the Facts Explorer pane, under Vocabularies, expand B2BVocabulary, expand Version 1.0 - Published, and drag PO Quantity and drop it onto the first argument1 placeholder

8.
Drag Quantity Shipped to the IF pane and drop itonto the first argument2 placeholder.

9.
Drag PO Quantity to theIF pane and drop it onto the second argument1 placeholder.

10.
Drag Quantity Invoiced to the IF pane and drop it onto the second argument2 placeholder.


[image: image95.png]


To define the Actions for the rules

	1.
In the Policy Explorer pane, select 3 Way Match.

2.
In the Facts Explorer pane, expand B2BVocabulary, expand Version 1.0 - Published, and then drag Set Quantity Paid for to to the THEN pane and drop it onto the Actions placeholder.

3.
In the Facts Explorer pane, expand B2BVocabulary, expand Version 1.0 - Published, and then drag Quantity Invoiced and drop it onto the 0 in the Action statement. 

The Action statement should read: Set Quantity Paid for to Quantity Invoiced.

4.
In the Policy Explorer pane, select Negation of 3 Way Match.

5.
In the Facts Explorer pane, expand B2BVocabulary, expand Version 1.0 - Published, and then drag Set Quantity Paid forto to theTHENpaneand drop it onto the Actions placeholder.

6.
In the Facts Explorer pane, expand B2BVocabulary, expand Version 1.0 - Published, and then drag Quantity Shipped to the THENpane and drop it onto the 0 in the Action statement. 

The Action statement should read: Set Quantity Paid for to Quantity Shipped.


[image: image96.png]


To add the policy rule for the payment terms

	1.
In the Policy Explorer pane, expand Payment Policy, right-click Version 1.0, and then click Add New Rule. 

2.
Change the name of the new rule to Payment Terms for Supplier A, and then press ENTER.

3.
In the Facts Explorer pane, expand Vocabularies, and then drag the Equal predicateto the IF pane and drop it onto the Conditions placeholder.

4.
In the Facts Explorer pane, expand Vocabularies, and then drag Supplier Name and drop it onto the argument1 placeholder.

5.
In the IF pane, click argument2,type Supplier A, and then press ENTER.

6.
In the Facts Explorer pane, expand Vocabularies, and then drag Set Payment Termsto to the THEN pane, and drop it onto the Actions placeholder.

7.
Click Empty string, type 30, and then press ENTER.

The Action statement should read: Set Payment Terms to 30.

8.
Repeat steps 1 through 7 to create additional rules with the following values: 

Use this

To do this

Rule Name
Payment Terms for Supplier B

Condition
Supplier Name is equal to Supplier B

Action
Set Payment Terms to 15

Use this

To do this

Rule Name
Payment Terms for Other Suppliers

Condition
    AND

      Supplier Name (is) not equal (to)Supplier A

      Supplier Name (is) not equal (to) Supplier B

Action
Set Payment Terms to 45

You must save, publish, and deploy the policy before you leave the Business Rule Composer. 
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To save, publish, and deploy the policy

	1.
In the Policy Explorer pane, expand Payment Policy, right-click Version 1.0, and then click Save.

2.
In the Policy Explorer pane, expand Payment Policy, right-click Version 1.0, and then click Publish.

3.
In the Policy Explorer pane, expand Payment Policy, right-click Version 1.0, and then click Deploy.


What did I just do?

In this step, you added rules to the policy you created in Step 5: Add a Business Policy.

Next Steps

You integrate the rules you created in this lesson with the B2BProcess orchestration in Lesson 5: Integrate the Payment Policy with the Orchestration.

See Also
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In this lesson, you integrate the rules you created in Lesson 4 with the B2BProcess orchestration.

In this Section


Step 1: Add a Reference to the Rule Engine

Step 2: Define an Atomic Rules Scope

Step 3: Add a Call Rules Shape to the Orchestration

Step 4: Undeploy and Redeploy the Solution

Step 5: Configure and Start B2BApplication

Step 6: Test the Solution with the Rules
Step 1: Add a Reference to the Rule Engine             
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Time to complete: 3 minutes

Objective: In this step, you add a reference to the Rule Engine.

Purpose: When the policy is implemented, the Rule Engine populates data in the payment voucher.  

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Lesson 4: Create a Payment Policy.


You must log on as a member of the BizTalk Server Administrators group.

[image: image99.png]


To add a reference to the rule engine DLL

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, right-click References, and then select Add Reference. 

5.
In the Add Reference dialog box, on the Browse tab, browse to <installation drive>:\Program Files\Microsoft BizTalk Server 2006, double-click Microsoft.RuleEngine.dll to add the file as a referenced component, and then click OK. 

6.
On the File menu, click Save All.


What did I just do?

In this step, you added a reference to the Rule Engine.

Next Steps

You define an atomic scope within the orchestration in Step 2: Define an Atomic Rules Scope.

See Also
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Time to complete: 3 minutes

Objective: In this step, you define the B2BProcess orchestration as a long-running process, and add an atomic Scope shape to the orchestration.

Purpose: You add a Call Rules shape to the Scope shape you add in this step in Step 3: Add a Call Rules Shape to the Orchestration. The Call Rules shape connects the B2BProcess orchestration to the payment policy you created in Lesson 4: Create a Payment Policy. By housing the Call Rules shape inside of an atomic Scope shape, you enable the use of nonserializable objects (the policy rules) inside of an orchestration. 

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Add a Reference to the Rule Engine.


You must log on as a member of the BizTalk Server Administrators group.
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To define an atomic rules scope in the B2BProcess

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
On the orchestration design surface, right-click the solid green circle (begin shape) at the top of the design, and then select Properties Window.

6.
In the Properties pane, change the value of the Transaction Type property to Long Running.

7.
From the orchestration Toolbox, drag the Scope shape to the orchestration design surface, and drop the shape on the connecting line directly below the Construct_PaymentVoucher shape.

8.
In the Properties pane, change the value of the Name property to Rules Scope.

9.
In the Properties pane, from the Transaction type drop-down list, select Atomic. 


What did I just do?

In this step, you defined the B2BProcess orchestration as a long-running process, and added an atomic Scope shape to the orchestration.

Next Steps

You integrate the business policy with your orchestration. This is done by adding a Call Rules shape in Step 3: Add a Call Rules Shape to the Orchestration.

See Also
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[image: image102.png]Step 3




Time to complete: 4 minutes

Objective: In this step, you add a Call Rules shape to integrate the business policy with the B2BProcess orchestration.

Purpose: When the policy is implemented, the Rule Engine populates data in the payment voucher.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Define an Atomic Rules Scope.


You must log on as a member of the BizTalk Server Administrators group.
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To add a Call Rules shape to the B2BProcess

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
In Solution Explorer, expand B2BOrchestrations, and then double-click B2BProcess.odx.

5.
In Orchestration Designer, from the Toolbox, drag the Call Rules shape to the design surface, and then drop it inside the Rules Scope shape. 

6.
On the design surface, right-click the Call Rules shape, and then click Properties Window.

7.
In the Properties pane, change the value of the Name property to Call_PaymentPolicy.

8.
On the design surface, double-click the Call_PaymentPolicy shape. 

9.
In the CallRules policy configuration dialog box, from the Select the business policy you wish to call drop-down list, select Payment Policy.

10.
Click OK to exit the CallRules policy configuration dialog box. 

11.
In Solution Explorer, right-click B2Borchestrations, and then click Rebuild.

12.
On the File menu, click Save All.


What did I just do?

In this step, you added a Call Rules shape to integrate the business policy with the B2BProcess orchestration.

Next Steps

You use BizTalk Explorer to stop, unenlist, and undeploy the B2BProcess in Step 4: Undeploy and Redeploy the Solution.
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Time to complete: 5 minutes

Objective: In this step, you use BizTalk Explorer to stop, unenlist, and undeploy the B2BProcess.

Purpose: You stop, unenlist, and undeploy the B2BProcess to ensure that the redeployment succeeds. Then you redeploy the B2BOrchestration to place a copy of the updated assembly in the BizTalk Management database (also known as the Configuration database) and install it in the global assembly cache. Because the B2BSchemas project is unchanged, it is not redeployed.

The orchestration binding also needs to be re-established. You will do this in Step 5: Configure and Start B2BApplication.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Add a Call Rules Shape to the Orchestration.


You must log on as a member of the BizTalk Server Administrators group.
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To undeploy and redeploy the solution

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click B2BSolution, and then click Open.

4.
On the View menu, click BizTalk Explorer.  

5.
In BizTalk Explorer, expand <ServerName>.BizTalkMgmtDb.dbo, expand Orchestrations, right-click B2BOrchestrations.B2BProcess, and then click Stop. 

6.
Right-click B2BOrchestrations.B2BProcess again, and then click Unenlist. 

7.
In the BizTalk Explorer - Express Unenlist dialog box, select all of the Dependency Options check boxes, select the Terminate existing Orchestration Instances check box, and then click OK. 

8.
In BizTalk Explorer, expand Assemblies, right-click B2BOrchestrations, and then click Undeploy.
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Note

In the Are you sure you want to undeploy the assembly message box, click Yes.

9.
In Solution Explorer, right-click B2BOrchestrations, and then click Deploy. 
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Note

You can view deployment errors, warnings, and progress in the output window and task list at the bottom of the page. 


What did I just do?

In this step, you used BizTalk Explorer to stop, unenlist, and undeploy the B2BProcess.

Next Steps

You use the BizTalk Server Administration console to bind the orchestration ports and start the B2BApplication application in Step 5: Configure and Start B2BApplication.
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Time to complete: 4 minutes

Objective: In this step, you use the BizTalk Server Administration console to bind the orchestration ports and enlist the orchestration.

Purpose: When you bind the orchestration ports, you associate the logical ports defined in the orchestration with the physical ports the orchestration uses to receive and send messages. When you enlist an orchestration you associate the business process with the physical environment in which it runs, and create the core subscriptions in the MessageBox database. When you start the service, it begins processing messages.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 4: Undeploy and Redeploy the Solution.


You must log on as a member of the BizTalk Server Administrators group.
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To bind the orchestration ports

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click BizTalk Server Administration. 

2.
In the BizTalk Server Administration console, in the console tree, expand BizTalk Server 2006 Administration, right-click BizTalk Group, and then click Refresh.

3.
In the console tree, expand BizTalk Group, expand Applications, right-click B2BApplication, and then click Configure.

4.
In the Configure Application dialog box, on the B2BProcess tab, do the following: 
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Note

The Configure Application dialog box contains a grid control. You must click in a row to expose the control. A control is a device you use to select options, such as a drop-down list.

Use this

To do this

Host
From the drop-down list, select BizTalkServerApplication.
ReceivePO_Port
From the Receive Ports drop-down list, select ReceivePO_ReceivePort.

ReceiveASN_Port
From the drop-down list, select ASN_ReceivePort.

ReceiveInvoice_Port
From the drop-down list, select Invoice_ReceivePort.

SendPaymentAck_Port
In the drop-down list, expand Send Ports, and then select SendPort_PaymentAck.

5.
Click OK. 

6.
In the console tree, expand BizTalk Group, expand Applications, right-click B2BApplication, and then click Start.

7.
In the Start 'B2BApplication' Application dialog box, click Options, make sure that all of the check boxes are selected, and then click Start.

8.
In the console tree, click Applications.

B2BApplication should show Started in the Status column.


What did I just do?

In this step, you used the BizTalk Server Administration console to bind the orchestration ports and enlist the orchestration.

Next Steps

You test the solution in Step 6: Test the Solution with the Rules.
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Time to complete: 3 minutes

Objective: In this step, you test the solution.

Purpose: You simulate the receipt of a purchase order and verify that a confirmation message arrives, a payment acknowledgment was sent to the ERP system, and the payment voucher was updated before it was sent.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 5: Configure and Start B2BApplication.


You must log on as a member of the BizTalk Server Administrators group.
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To test the solution

	1.
In Windows Explorer, browse to C:\Tutorial, and copy POInstance.xml to C:\Tutorial\Filedrop\ReceivePO. 
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Important

Do not move the file, because BizTalk Server processes it and then removes it from the \ReceivePO directory.

2.
Browse to C:\Tutorial\Filedrop\FileArchive to verify that POConfirmed was archived. 

3.
Browse to C:\Tutorial\Filedrop\ERPSys to verify that a payment acknowledgment was sent to the ERP system and that the B2B solution completed. 

4.
To verify that the payment voucher was updated before it was sent out, use BizTalk Health and Activity Tracking (HAT), or add a port to archive the payment voucher before it is sent out. Then compare the data in the archived payment voucher to the data in the payment acknowledgment.


What did I just do?

In this step, you tested the solution.

Next Steps

You walk through the process in which business users use Business Activity Services (BAS) to set up business partners and business agreements, and the processes that a solution developer uses to implement this business relationship and to route messages into and out of the BAS Web site in Tutorial 4: Trading Partner Management.
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