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Abstract

This document provides step-by-step instructions for implementing a BizTalk solution that receives inventory replacement request messages from a warehouse and evaluates the request messages. If the solution denies a request, it sends a denied message to the warehouse. If the solution approves a request, it forwards the message to an Enterprise Resource Planning (ERP) system.
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Tutorial 1: Enterprise Application Integration             

Microsoft BizTalk Server 2006 provides a development and run-time environment for business process management (BPM) and automation. This tutorial presents an end-to-end exercise in setting up and deploying enterprise application integration (EAI) using BizTalk Server 2006.

In this solution, you are automating a warehouse order process for an enterprise. When inventory in the warehouse reaches an unacceptably low level, the warehouse sends a message to a BizTalk orchestration requesting inventory replacement. The enterprise uses different computer systems for the warehouse and the orchestration. These systems must exchange data to process the inventory replacement requests. You use BizTalk Server 2006 to automate the business process that begins when the inventory is depleted and ends when the inventory is replaced. 

Within the inventory replacement process, several things happen:


The orchestration evaluates whether a request is approved, using the company's business policies for approval criteria.


When the orchestration approves a request, the orchestration submits the request to an Enterprise Resource Planning (ERP) system that generates the purchase order. 


When the orchestration does not approve a request, the orchestration returns the request to the warehouse inventory system. 


When the ERP system receives the approved inventory replacement request, the ERP system generates a purchase order (PO). 

The warehouse inventory system is a stand-alone system that operates separately from the ERP system. BizTalk Server 2006 ensures that the inventory system and the ERP system interact smoothly and efficiently. This includes applying business rules to the approval process and routing the replenishment request appropriately. 

The message flow for this EAI scenario looks similar to the following illustration.
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In this tutorial, you use BizTalk Server developer tools to design and deploy the business process. This tutorial provides detailed instructions so that you can complete the lessons even if you have no programming skills. 

There are three lessons in this tutorial. Instructions for saving your work after each step enable you to stop between lessons. Before you begin this tutorial, you must complete the steps in Before You Begin the Tutorials. To download a Microsoft Office Word 2003 version of the BizTalk Server 2006 Tutorials, see http://go.microsoft.com/fwlink/?LinkId=62503.

In this Section


Lesson 1: Create the EAI Solution

Lesson 2: Define the Business Process

Lesson 3: Deploy the Solution
Lesson 1: Create the EAI Solution             

In this lesson, you create and build the first project in the enterprise application integration (EAI) solution. The project contains two message schemas, a pipeline, and a map.

In the EAI solution, a warehouse system sends a request for inventory replacement message to BizTalk Server for processing. In this lesson, you create the following items:


The EAI solution, to hold the project.


The project, to hold the schemas, pipeline, and map.


The schema for the message the warehouse sends to BizTalk Server to request inventory replacement.


The schema for the message BizTalk Server sends to the warehouse if the request for inventory replacement is denied.


A pipeline, which transforms both messages so BizTalk Server can use the FILE adapter to send and receive the messages. 


A map, which connects the schemas of the two messages. By mapping the schemas, data from the inventory replacement request message can be included in the request denied message.

Finally you build the project before starting Lesson 2: Define the Business Process. In Lesson 2, you create the business process that routes the messages and evaluates the contents of the inventory replacement request message against approval criteria.

The following illustration shows the flow of data through BizTalk Server in the Tutorial 1 scenario. 
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Before you begin this lesson, you must complete the steps in Before You Begin the Tutorials. To download a Microsoft Office Word 2003 version of the BizTalk Server 2006 Tutorials, see http://go.microsoft.com/fwlink/?LinkId=62503.
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Note

To learn more about the BizTalk Server tools used in this lesson, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

In this Section


Step 1: Open a Blank Solution in Visual Studio 2005

Step 2: Add a New Project to the Solution

Step 3: Create the Inventory Request Schema

Step 4: Modify the Request Schema Properties

Step 5: Create the Request Denied Schema

Step 6: Create the Distinguished Fields

Step 7: Create a Custom Send Pipeline

Step 8: Create the Map

Step 9: Build the EAISchemas Project
Step 1: Open a Blank Solution in Visual Studio 2005             
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Time to complete: 5 minutes

Objective: In this step, you open a new empty BizTalk Server 2006 solution in Visual Studio 2005. You delete the project that Visual Studio automatically adds to a new solution.

Purpose: Opening a new BizTalk solution is the first step in building the enterprise application integration (EAI) solution. The BizTalk solution you open is a framework to hold BizTalk artifacts. In subsequent steps, you will add BizTalk artifacts that perform the tasks that automate the EAI process. You delete the project because renaming it causes compilation errors because the namespace in each item does not match the name of the project. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete the steps in Before You Begin the Tutorials (http://go.microsoft.com/fwlink/?LinkId=62503).


You must log on as a member of the BizTalk Server Administrators group.
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To open a blank solution in Visual Studio 2005

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to New, and then click Project. 

3.
In the New Project dialog box, do the following:

Use this

To do this

Project types
Click BizTalk Projects.

Templates
Click Empty BizTalk Server Project.

Name
Type EAISolution.

Location
Type C:\Tutorial\Lessons.

Solution Name
Visual Studio uses the name you typed as the solution name.

Create directory for solution
Select this check box to create a directory for the solution files.

The following figure shows the New Project dialog box.
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4.
Click OK. 
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Note

Both the Solution 'EAISolution' solution and an EAISolution project appear in Solution Explorer. In the next step, you will remove the EAISolution project. If you do not see Solution 'EAISolution', on the Tools menu, click Options. In the Options dialog box, in the tree, click Projects and Solutions. On the right side, select the Always show solution check box, and then click OK.

The following figure shows Solution Explorer with the EAISolution solution and the EAISolution project.
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5.
In Solution Explorer, right-click the EAISolution project, and then click Remove.

6.
In the 'EAISolution' will be removed message box, click OK.
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Note

In this scenario, you use two projects: EAISchemas and EAIOrchestrations. When you create a project, Visual Studio creates the namespace for the project. If you rename a project, Visual Studio does not change the namespace. In this step, you delete the default project that Visual Studio adds to the solution, so that the namespaces for your projects match the project names. The Solution 'EAISolution' solution is still in Solution Explorer.

7.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 2: Add a New Project to the Solution.


What did I just do?

In this step, you opened a new empty BizTalk Server 2006 solution in Visual Studio 2005. You deleted the project that Visual Studio automatically adds to a new solution.

Next Steps

You add a BizTalk project to this solution in Step 2: Add a New Project to the Solution. 

See Also

Before You Begin the Tutorials
Lesson 1: Create the EAI Solution
Step 2: Add a New Project to the Solution
Step 3: Create the Inventory Request Schema
Step 4: Modify the Request Schema Properties
Step 2: Add a New Project to the Solution             
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Time to complete: 5 minutes

Objective: In this step, you add an empty BizTalk project to the BizTalk solution you created in the previous step. 

Purpose: You add BizTalk projects to BizTalk solutions to organize complicated solutions more efficiently. The new project holds the BizTalk artifacts—including schemas, a pipeline, and a map—that you add to the solution in Lesson 1. For example, if you were integrating many diverse processes, you would create a project or set of projects for each process. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Open a Blank Solution in Visual Studio 2005.
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Important

If you completed Step 1: Open a Blank Solution in Visual Studio 2005 without completing the steps in the Before You Begin the Tutorials section, stop now and complete Before You Begin the Tutorials (http://go.microsoft.com/fwlink/?LinkId=62503). 


You must log on as a member of the BizTalk Server Administrators group.
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To add a new project to your solution

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click Solution 'EAISolution', point to Add, and then click New Project. 

5.
In the Add New Project dialog box, do the following:

Use this

To do this

Project types
Click BizTalk Projects.

Templates
Click Empty BizTalk Server Project.

Name
Type EAISchemas.

Location
Verify that the location is C:\Tutorial\Lessons\EAISolution.

The following figure shows the Add New Project dialog box.
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6.
Click OK.
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warning

Do not change the name of your project after it is created. This name is automatically included in the namespaces for all items within this project. Changing the name of the project after it is created produces compilation errors if the namespace in each item does not match the name of the project.

The following figure shows Solution Explorer with the new project.
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7.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step Step 3: Create the Inventory Request Schema.


What did I just do?

In this step, you added an empty BizTalk project to the BizTalk solution you created in the previous step.

Next Steps

You create the schema that defines the format of the message that requests inventory for the warehouse in Step 3: Create the Inventory Request Schema. 

See Also

Lesson 1: Create the EAI Solution
Step 1: Open a Blank Solution in Visual Studio 2005
Step 3: Create the Inventory Request Schema
Step 3: Create the Inventory Request Schema             
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Time to complete: 7 minutes

Objective: In this step, you define the schema of the message that the warehouse system sends to BizTalk Server to request inventory replacement.

Purpose: The schema defines the data and the structure of the inventory replacement request message. BizTalk Server uses the schema to identify and interact with the data in the message.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Add a New Project to the Solution.


You must log on as a member of the BizTalk Server Administrators group.
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To add a new schema to the project

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click the EAISchemas project, point to Add, and then click New Item.

5.
In the Add New Item - EAISchemas dialog box, do the following:

Use this

To do this

Categories
Select Schema Files.

Templates
Select Schema.

Name
Type Request.xsd.

The following figure shows the Add New Item dialog box.
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6.
Click Add.
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Note

The schema tree and XSD pane appear. This area of Visual Studio 2005 is referred to as BizTalk Editor. In addition, your new schema appears in Solution Explorer below the EAISchemas project.

The following figure shows the different parts of BizTalk Explorer, Solution Explorer, and the Properties pane.
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7.
On the File menu, click Save All.
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To add items to the inventory replacement schema

	1.
In the BizTalk Editor schema tree, right-click the Root node, and then click Properties.
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Note

The Properties pane is a grid control. You must click in the property row to change the property value or expose the property control. A control is a device you use to select options, such as a drop-down list.

2.
In the Properties pane, change the value of the Node Name property to Request, and then press ENTER.

The following figure shows the properties for the Root node.
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Note

The root node contains all the elements of the XML document. Every XML document must have a single root element to be well formed.

3.
In the BizTalk Editor schema tree, right-click the Request node, point to Insert Schema Node, and then click Child Record. 

4.
Type Header as the new name for the child record, and then press ENTER.

5.
Create a second child record for the Request node, and name it Item. 

6.
In the BizTalk Editor schema tree, right-click the Header node, point to Insert Schema Node, and then click Child Field Element.

7.
Type ReqID as the new name for the element, and then press ENTER.

8.
Create a second child field element for the Header node, and name it Date. 

9.
In the BizTalk Editor schema tree, right-click the Item node, and add the following child field elements:


Description

Quantity

UnitPrice

TotalPrice
The completed Request.xsd should look similar to the following figure.
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10.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 4: Modify the Request Schema Properties.


What did I just do?

In this step, you defined the schema of the message that the warehouse system sends to BizTalk Server to request inventory replacement.

Next Steps

You modify properties of the items in the inventory replacement request schema in Step 4: Modify the Request Schema Properties. 

See Also

Step 2: Add a New Project to the Solution
Step 4: Modify the Request Schema Properties
Step 4: Modify the Request Schema Properties             
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Time to complete: 7 minutes

Objective: In this step, you change the data type of the Quantity field element to an integer and associate flat file extensions with the Request schema.

Purpose: You change the Quantity field element to an integer so you can create an expression that evaluates whether the value is greater than or less than 500. You will create the expression in Step 8: Write the XLANG/s Expression for the Decision. You associate the Request schema with flat file extensions because flat file extensions add annotations that maintain data in the schema. For more information about flat file extensions, see the “Flat File Schemas” topic in BizTalk Server 2006 Help.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Create the Inventory Request Schema.


You must log on as a member of the BizTalk Server Administrators group.
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To modify the Request schema properties

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click Request.xsd.

5.
In BizTalk Editor, right-click Quantity, and then click Properties. 
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Note

The Properties pane is a grid control. You must click in the property row to expose the property control. A control is a device you use to select options, such as a drop-down list.

6.
In the Properties pane, from the Data Type drop-down list, select xs:unsignedInt. 

The following figure shows the Data Type property.

[image: image36.png]a
xsinorposiivelnteger s
[xsinormalzedstring
Jx:postivelnteger

s:Giame
sishort
sistrng
sitime
sioken
uantit g
o Y B unsignedByte:
8220
aiunsigneclong
Base Dat
Sese Do b unignedshart

wsunsignedint =
Default Value

Derived By (Default)
Fied Type. Element
Final (Default)
Fixed

Form (Default)

Instance xpath | [“locskname)

=





7.
In BizTalk Editor, click <Schema> to highlight the node. 

8.
In the Properties pane, click the Schema Editor Extensions ellipsis […].

The following figure shows the Schema Editor Extensions property.
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9.
In the Schema Editor Extensions dialog box, select the Flat File Extensions check box, and then click OK.

10.
In BizTalk Editor, click Request to highlight the node. 

11.
In the Properties pane, from the Structure drop-down list, select Positional.

The following figure shows the Structure property.
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12.
In the Confirm Change Record Structure dialog box, click Yes. 

13.
For each of the child field elements in the following table, in the BizTalk Editor schema tree, select the child field element. Then, in the Properties pane for each child field element, change the values of the Positional Length and Positional Offset properties. 
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Note

The Positional Length property specifies the length of the value in the field element. The Positional Offset property identifies the space between one field element and the previous element. Setting these properties makes it easier to read the flat file delivered to the ERP system.

The following figure shows the Positional Length and Positional Offset properties for ReqID.
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14.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 5: Create the Request Denied Schema.


What did I just do?

In this step, you changed the data type of the Quantity field element to an integer and associated flat file extensions with the Request schema.

Next Steps

You create the schema for the message BizTalk Server sends back to the warehouse if the business process rejects the inventory request message in Step 5: Create the Request Denied Schema. 

See Also

Lesson 1: Create the EAI Solution
Step 3: Create the Inventory Request Schema
Step 5: Create the Request Denied Schema
Step 5: Create the Request Denied Schema             
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Time to complete: 7 minutes

Objective: In this step, you create the schema for the message BizTalk Server sends back to the warehouse if the business process rejects the inventory request message.

Purpose: The schema defines the data and the structure of the request denied message. BizTalk Server uses the schema to identify and interact with the data in the message.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 4: Modify the Request Schema Properties.


You must log on as a member of the BizTalk Server Administrators group.
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To create the Request Denied schema

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click the EAISchemas project, point to Add, and then click New Item.

5.
In the Add New Item - EAISchemas dialog box, do the following:

Use this

To do this

Categories
Select Schema Files.

Templates
Select Schema.

Name
Type RequestDenied.xsd.

6.
Click Add.
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Note

The schema tree and XSD pane appear. In addition, the RequestDenied schema appears in Solution Explorer in the EAISchemas project.

7.
In BizTalk Editor, right-click the Root node, and then click Properties.
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Note

The Properties pane is a grid control. You must click in the property row to change the property value or expose the property control. A control is a device you use to select options, such as a drop-down list.

8.
In the Properties pane, change the value of the Node Name property to DeclineReq, and then press ENTER.
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Note

The root node contains all the elements of the XML document. A well-formed XML document has a single root element.

9.
In BizTalk Editor, right-click the DeclineReq node, point to Insert Schema Node, and then click Child Field Element. 
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Note

In this task, you are adding child field elements directly to the root node, rather than adding a child record first, and then adding child field elements to the child record. You must add the ReqID and Qty fields as child field elements to promote them in Step 6: Create the Distinguished Fields.

10.
Type ReqID as the new name for the element, and then press ENTER.

11.
Add a second child field element named Qty. 

The following figure shows the RequestDenied schema.
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12.
In BizTalk Editor, right-click Qty, and then click Properties.

13.
In the Properties pane, from the Data Type drop-down list, select xs:unsignedInt. 

14.
On the File menu, click Save All.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 6: Create the Distinguished Fields. 


What did I just do?

In this step, you created the schema for the message BizTalk Server sends back to the warehouse if the business process rejects the inventory request message.

Next Steps

You promote the Quantity field in the Request.xsd schema and the Qty field in the RequestDenied.xsd schema by making them distinguished fields in Step 6: Create the Distinguished Fields.

See Also

Step 4: Modify the Request Schema Properties
Step 6: Create the Distinguished Fields
Step 6: Create the Distinguished Fields             
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Time to complete: 5 minutes

Objective: In this step, you promote the Quantity field in the Request.xsd schema and the Qty field in the RequestDenied.xsd schema by making them distinguished fields.

Purpose: Distinguished fields are message data of special interest that you use primarily to make decisions or to manipulate data in your orchestration. As a distinguished field, the Quantity field is accessible for each instance of a request. The process can evaluate the value of the Quantity field in each request instance because the field is accessible. You promote the Qty field of the request denied instance schema, so that the quantity of the items requested, in addition to the request ID number, are included in the request denied message returned to the warehouse inventory system.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 5: Create the Request Denied Schema.


You must log on as a member of the BizTalk Server Administrators group.
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To create a distinguished field

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click the Request.xsd schema to open it.  

5.
In BizTalk Editor, right-click <Schema>, and then click Properties.

6.
In the Properties pane, click the Promote Properties ellipsis […].

7.
In the Promote Properties dialog box, on the Distinguished Fields tab, on the left side, expand Request, expand Item, select Quantity, click Add, and then click OK.

The following figure shows the Promote Properties dialog box for the Request schema.
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8.
Open the RequestDenied.xsd schema, and add the Qty field as a distinguished field. 

[image: image55.png]


Note

In the Promote Properties dialog box, if you cannot add the Qty field, check that you created it as a child field element, rather than as a child record. You cannot promote child records. If the Qty field is a child record, delete it and then add it to the schema as a child field element.

9.
On the File menu, click Save All to save your work. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 7: Create a Custom Send Pipeline.


What did I just do?

In this step, you promoted the Quantity field in the Request.xsd schema and the Qty field in the RequestDenied.xsd schema by making them distinguished fields.

Next Steps

You create a custom send pipeline that uses the flat file assembler component to serialize the receive message (XML document) into a flat file format in Step 7: Create a Custom Send Pipeline.

See Also

Step 5: Create the Request Denied Schema
Step 7: Create a Custom Send Pipeline
Step 7: Create a Custom Send Pipeline             
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Time to complete: 5 minutes

Objective: In this step, you use Pipeline Designer to create a custom send pipeline that uses the flat file assembler component to serialize your XML document into a flat file format.

Purpose: You create a custom send pipeline to enable the flat file assembler component to engage in the processing of messages. The FILE adapter transfers files into and out of BizTalk Server.

[image: image58.png]


Note

If you plan to create several pipelines, you might want to create a separate project for pipelines. The lessons in this tutorial only require the use of one pipeline. Therefore, you will add the pipeline to the schemas project. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 6: Create the Distinguished Fields.


You must log on as a member of the BizTalk Server Administrators group.
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To add a pipeline to your project

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click EAISchemas, click Add, and then click New Item.

5.
In the Add New Item - EAISchemas dialog box, do the following:

Use this

To do this

Categories
Select Pipeline Files.

Templates
Select Send Pipeline.

Name
Type ERPPipeline.btp.

The following figure shows the Add New Item dialog box.
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6.
Click Add. 

Pipeline Designer opens and the BizTalk Pipeline Components appear in the Toolbox.

[image: image62.png]


Note

If the Toolbox is not open, in the View menu, click Toolbox. To anchor it on the screen, click the thumbtack icon.

7.
From the BizTalk Pipeline Components Toolbox, drag the Flat file assembler from the toolbar to the Assemble Drop Here! target.

The following figure shows the ERPPipeline.
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8.
In the Properties pane for the flat file assembler pipeline component, from the Document Schema drop-down list, select EAISchemas.Request.

[image: image64.png]


Note

The Properties pane is a grid control. You must click in the property row to expose the property control. A control is a device you use to select options, such as a drop-down list.

9.
On the File menu, click Save All to save your work. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 8: Create the Map.


What did I just do?

In this step, you used Pipeline Designer to create a custom send pipeline that uses the flat file assembler component to serialize your XML document into a flat file format.

Next Steps

You create a map that connects fields in the Request schema to fields in the RequestDenied schema in Step 8: Create the Map.

See Also

Step 6: Create the Distinguished Fields
Step 8: Create the Map
Step 8: Create the Map             
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Time to complete: 6 minutes

Objective: In this step, you create a map that connects fields in the Request schema to fields in the RequestDenied schema. 

Purpose: The map ensures that the request ID number and the quantity of the items requested are included in the request denied message returned to the warehouse inventory system. You use BizTalk Mapper to link fields in an incoming message to fields defined for the outgoing message. This is necessary because these two messages do not have the same schema structure.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 7: Create a Custom Send Pipeline.


You must log on as a member of the BizTalk Server Administrators group.
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To create the map

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click the EAISchemas project, point to Add, and then click New Item. 

5.
In the Add New Item dialog box, do the following:

Use this

To do this

Categories
Click Map Files.

Templates
Click Map.

Name
Type MapToReqDenied.btm.

6.
Click Add. 

The following figure shows the Source Schema, Destination Schema, and Mapper Grid. 
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7.
In the Source Schema pane, click Open Source Schema. 

8.
In the BizTalk Type Picker dialog box, expand EAISchemas, expand Schemas, click EAISchemas.Request, and then click OK. 

9.
In the Source Schema pane, right-click <Schema>, and then click Expand Tree Node. 

10.
In the Destination Schema pane, click Open Destination Schema. 

11.
In the BizTalk Type Picker dialog box, expand EAISchemas, expand Schemas, click EAISchemas.RequestDenied, and then click OK. 

12.
In the Destination Schema pane, right-click <Schema>, and then click Expand Tree Node. 

13.
In the Source Schema pane, drag the Quantity field to the Qty field in the Destination Schema pane to map the data from one schema to the other. 

14.
In the Source Schema pane, drag the ReqID field to the ReqID in the Destination Schema pane. 

A line appears connecting the two elements.

The following figure shows the mapped fields.
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15.
On the File menu, click Save All to save your work. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 9: Build the EAISchemas Project.


What did I just do?

In this step, you created a map that connects fields in the Request schema to fields in the RequestDenied schema.

Next Steps

You build the EAI Schema project in Step 9: Build the EAISchemas Project.

See Also

Step 7: Create a Custom Send Pipeline
Step 9: Build the EAISchemas Project
Step 9: Build the EAISchemas Project             
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Time to complete: 6 minutes

Objective: In this step, you build the EAISchema project to generate an assembly file (DLL). 

Purpose: After you create the EAISchema project and add the necessary items to it, you must build the project to generate an assembly. An assembly is a collection of resources in the project, such as schemas and maps, which are stored in a DLL file.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 8: Create the Map.


You must log on as a member of the BizTalk Server Administrators group.
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To build the EAISchema project

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click the EAISchemas project, and then click Properties. 

5.
In the EAISchemas Property Pages dialog box, in the tree control, expand Common Properties, click Assembly, and then in the properties list, click the Assembly Key File ellipsis […].

6.
In the Assembly Key File dialog box, do the following:

Use this

To do this

Look in
Navigate to C:\Tutorial.

File name
Type Tutorial.snk.
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Note

You created the Tutorial.snk strong name key file in Step 4: Create a Strong Name Key File.

7.
Click Open.

8.
In the EAISchemas Property Pages dialog box, in the tree control, expand Configuration Properties, click Deployment, and then in the properties list, do the following:

Use this

To do this

Application Name
Type EAIApplication.
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Note

Building the EAISchema project creates the EAIApplication application, which appears in the BizTalk Server Administration console and contains the EAISchemas assembly.

Redeploy
From the drop-down list, select True.

9.
Click OK. 

10.
On the File menu, click Save All to save your work. 

11.
In Solution Explorer, right-click EAISchemas, and then click Build.
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Note

The Output tab, located at the bottom, displays the results of building the project. To display the Output pane, on the View menu, click Output.

The Output pane at the bottom of the screen should display: Build: 1 succeeded, 0 failed, 0 skipped.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to Lesson 2: Define the Business Process.


What did I just do?

In this step, you built the EAISchema project to generate an assembly file (DLL).

Next Steps

You create the business process that routes the inventory replacement request and request denied messages and evaluates the contents of the inventory replacement request message against approval criteria in Lesson 2: Define the Business Process.

See Also

Step 8: Create the Map
Lesson 2: Define the Business Process
Lesson 2: Define the Business Process             

In this lesson, you create the second project in the Enterprise Application Integration (EAI) solution. The project contains an orchestration.

In the EAI solution, a warehouse system sends a request for inventory replacement message to BizTalk Server for processing. BizTalk Server uses the orchestration you create to automate the business process. The orchestration provides the workflow, actions, and expressions to move messages through the system and process their contents.

Finally you build the project before starting Lesson 3: Deploy the Solution. In Lesson 3, you deploy the solution. 

Before you begin this lesson, you must complete the steps in Lesson 1: Create the EAI Solution. To download a Microsoft Office Word 2003 version of the BizTalk Server 2006 Tutorials, see http://go.microsoft.com/fwlink/?LinkId=62503.
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Note

To learn more about the BizTalk Server tools used in this lesson, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

In this Section


Step 1: Add a Second Project to Your Solution

Step 2: Create the EAI Business Process

Step 3: Add a Reference to the EAISchemas Project

Step 4: Create Message Instance Variables

Step 5: Add Ports to the Orchestration

Step 6: Specify Action Shape Messages and Connect the Ports

Step 7: Configure the Transform Shape to Use the Map

Step 8: Write the XLANG/s Expression for the Decision

Step 9: Build the EAIOrchestrations Project
Step 1: Add a Second Project to Your Solution             
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Time to complete: 5 minutes

Objective: In this step, you add a second project to the EAI solution. Then you add an orchestration to the new project.

Purpose: You create a separate project for the orchestration. This is helpful when you have several different people working on one solution. You use the new orchestration to automate the business process in this lesson. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Lesson 1: Create the EAI Solution.


You must log on as a member of the BizTalk Server Administrators group.
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To add another project to your solution

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click Solution 'EAISolution', point to Add, and then click New Project. 
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Note

If Solution Explorer is not visible in Visual Studio, on the View menu, click Solution Explorer. 

5.
In the Add New Project dialog box, do the following:

Use this

To do this

Project types
Click BizTalk Projects.

Templates
Click Empty BizTalk Server Project.

Name
Type EAIOrchestrations.

6.
The following figure shows the Add New Project dialog box.
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7.
Click OK.

8.
In Solution Explorer, right-click EAIOrchestrations, point to Add, and then click New Item. 

9.
In the Add New Item dialog box, do the following:

Use this

To do this

Categories
Click Orchestration Files.

Templates
Click BizTalk Orchestration.

Name
Type EAIProcess.odx.

10.
Click Add.

Orchestration Designer opens. The following figure shows Orchestration Designer with the EAIProcess orchestration.
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11.
On the File menu, click Save All to save your work. 

[image: image86.png]


Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 2: Create the EAI Business Process. 


What did I just do?

In this step, you added a second project to the EAI solution. Then you added an orchestration to the new project.

Next Steps

You add action shapes to the EAIProcess orchestration in Step 2: Create the EAI Business Process.

See Also

Lesson 1: Create the EAI Solution
Step 2: Create the EAI Business Process
Step 2: Create the EAI Business Process             
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Time to complete: 8 minutes

Objective: In this step, you use Orchestration Designer to define your business process by dragging action shapes from the Toolbox to the orchestration design surface.

Purpose: The workflow of the EAIProcess orchestration represents and automates your company's business process for approving inventory replacement requests. 

In Orchestration Designer, you define your business process by adding action shapes to the workflow. Some shapes require input. For example, in this lesson, some of the shapes require an expression. When you add a shape that requires input to your orchestration, the shape appears marked with a Smart Tag. You will add the missing expressions in later steps in this lesson. 

The following figure shows the Smart Tag.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Add a Second Project to Your Solution.


You must log on as a member of the BizTalk Server Administrators group.
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To create the EAI business process workflow

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click EAIProcess.odx. 

The following figure shows the Begin (green circle) and End (red octagon) shapes.
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5.
In Orchestration Designer, from the orchestration Toolbox, drag the Receive shape to the orchestration design surface, and drop it into the space indicated between the Begin (green circle) and End (red octagon) shapes.

The following figure shows the new Receive shape.
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Note

If the Toolbox is not open, in the View menu, click Toolbox. To anchor it on the screen, click the thumbtack icon. 

6.
On the design surface, right-click the Receive shape, and then click Properties Window.

7.
In the Properties pane for the Receive shape, do the following:

Use this

To do this

Name
Type Receive_Request.

Activate
From the drop-down list, select True.

8.
From the Toolbox, drag the Decide shape onto the connecting line directly below the Receive_Request shape.
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Note

You can alphabetize the tools in the Toolbox by right-clicking the BizTalk Orchestrations tab and clicking Sort Items Alphabetically. This makes each shape easier to find.

The Decide shape expands to show a branch for the If statement (Rule_1) and a branch for the Else statement. The following figure shows the Decide shape.
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9.
On the design surface, right-click the Decide shape, and then click Properties Window.

10.
In the Properties pane for the Decide shape, in the Name property, type CheckQuantity. 

11.
On the design surface, right-click the Rule_1 shape (inside of the Decide shape), and then click Properties Window.

12.
In the Properties pane for Rule_1, in the Name property, type Decline.

13.
From the Toolbox, drag the Transform shape to the space indicated, directly below the Decline shape.

The following figure shows the Transform shape.
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Note

When you drop the Transform shape onto the design surface, Orchestration Designer creates the enclosing Construct Message shape for you.

14.
On the design surface, right-click the ConstructMessage_1 shape, and then click Properties Window.

15.
In the Properties pane for the ConstructMessage_1 shape, in the Name property, type Construct_RequestDenied.  
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Note

Make sure that you select the Construct shape. If there is no Name property in the Properties pane, you have not selected the Construct shape.

16.
From the Toolbox, drag the Send shape to the connecting line directly below the Construct_RequestDenied shape, inside of the CheckQuantity shape.

The following figure shows the Send shape.
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17.
On the design surface, right-click the Send shape, and then click Properties Window.

18.
In the Properties pane for the Send shape, in the Name property, type Send_ReqDenied. 

19.
From the Toolbox, drag a second Send shape to the space indicated, directly below the Else shape, inside of the CheckQuantity shape.

The following figure shows the second Send shape.
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20.
On the design surface, right-click the second Send shape, and then click Properties Window.

21.
In the Properties pane for the second Send shape, in the Name property, type Send_ReqToERP. 

22.
On the File menu, click Save All. 

The following figure shows the completed EAIProcess orchestration.
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Note

There will be several "no expression" Smart Tags within your orchestration. You will resolve these in later steps.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 3: Add a Reference to the EAISchemas Project. 


What did I just do?

In this step, you used Orchestration Designer to define your business process. 

Next Steps

You add a reference from the EAIOrchestrations project to the EAISchemas project in Step 3: Add a Reference to the EAISchemas Project.

See Also

Step 1: Add a Second Project to Your Solution
Step 3: Add a Reference to the EAISchemas Project
Step 3: Add a Reference to the EAISchemas Project             
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Time to complete: 3 minutes

Objective: In this step, you add a reference from the EAIOrchestrations project to the EAISchemas project.

Purpose: In Orchestration Designer, you define the messages that are being sent and received. The messages use the schemas that you created earlier in the EAISchemas project and must be available to your orchestration. To make the schemas available to the orchestration, you need to add a reference to the EAISchemas assembly. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 2: Create the EAI Business Process.


You must log on as a member of the BizTalk Server Administrators group.
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To add a reference to the EAISchemas project

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, expand the EAIOrchestrations project, right-click the References node, and then click Add Reference.

5.
In the Add Reference dialog box, on the Projects tab, double-click the EAISchemas project to add it as a selected component. 

The EAISchemas project appears in the Selected projects and components pane.
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6.
Click OK. 

7.
In Solution Explorer, select the EAISchemas reference, and then in the Properties pane, from the Copy Local drop-down list, select False.

8.
In Solution Explorer, select the EAISchemas reference, and then in the Properties pane, from the Copy Local drop-down list, select True.
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Note

Changing the Copy Local property refreshes the reference. Theoretically, you should be able to set the Copy Local property to False, as that is the setting that ensures that the contents of the EAISchemas project are available to the EAIOrchestrations project. There is an issue with Visual Studio 2005, however, that makes this inadvisable. For more information, see the Knowledge Base article 313512, "BUG: "Could not copy temporary files to the output directory" error message when you build a solution that contains multiple projects" available at http://go.microsoft.com/fwlink/?LinkId=62208.

9.
On the File menu, click Save All. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 4: Create Message Instance Variables. 


What did I just do?

In this step, you added a reference from the EAIOrchestrations project to the EAISchemas project. 

Next Steps

You create message variables for each message instance in the EAIProcess orchestration, and associate each variable with a schema in Step 4: Create Message Instance Variables. 

See Also

Step 2: Create the EAI Business Process
Step 4: Create Message Instance Variables
Step 4: Create Message Instance Variables             
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Time to complete: 5 minutes

Objective: In this step, you create message instance variables and associate them with the schemas you created in the previous lesson.

Purpose: In Orchestration Designer, a message variable identifies an instance of a message that uses a specific schema structure, rather than dealing directly with the schemas. In the following procedure you will create message variables for each message instance, and associate each variable with a schema. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 3: Add a Reference to the EAISchemas Project.


You must log on as a member of the BizTalk Server Administrators group.
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To create message instance variables

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click EAIProcess.odx. 

5.
In the Orchestration View window, right-click Messages, and then click New Message.

The following figure shows the Orchestration View window with the new message.
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6.
In the Properties pane for Message_1, do the following:

Use this

To do this

Identifier
Type RequestInstance, and then press ENTER.

Message Type
From the drop-down list, expand Schemas, and then select Select from referenced assembly.

7.
In the Select Artifact Type dialog box, do the following:

Use this

To do this

Current Project
Expand References, and then select EAISchemas.

Type Name
Select Request.

The following figure shows the Select Artifact Type dialog box.
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8.
Click OK.

9.
Add a second message named RequestDeniedInstance with a reference to the RequestDenied item in EAISchemas.

10.
On the File menu, click Save All. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 5: Add Ports to the Orchestration.


What did I just do?

In this step, you created message instance variables and associated them with the schemas you created in the previous lesson.

Next Steps

You create and configure the ports the EAIProcess orchestration uses to send and receive the inventory replacement request and request denied messages in Step 5: Add Ports to the Orchestration.

See Also

Step 3: Add a Reference to the EAISchemas Project
Step 5: Add Ports to the Orchestration
Step 5: Add Ports to the Orchestration             
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Time to complete: 10 minutes

Objective: In this step, you add three ports to the EAIProcess orchestration and configure them. 

Purpose: The three ports you create and configure in this step fulfill the following roles:


The first port, ReceiveReqPort, receives inventory replacement request messages from the warehouse.


The second port, SendToERP, sends request accepted messages to a purchase order process.


The third port, SendDeclinePort, sends request denied messages back to the warehouse.

In this procedure, for each port, you use the Port Configuration Wizard to: 

1.
Create and configure the port type. A port type is a property that defines the communication pattern (one-way or request-response) and the access restrictions (private, internal, or public) for the port.

2.
Establish the direction of communication for the port (sending or receiving).
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Note

Detailed instructions are provided for creating the first port. Use the same information to create the second and third ports.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 4: Create Message Instance Variables.


You must log on as a member of the BizTalk Server Administrators group.
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To create and configure the ports

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click EAIProcess.odx. 

5.
In Orchestration Designer, from the orchestration Toolbox, drag the Port shape to the left-side Port Surface, parallel to the Receive_Request shape. 
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Note

If the Toolbox overlaps the port surface, enable the autohide option. To enable the Toolbox autohide option, click the thumbtack icon. The autohide option moves the Toolbox out of the way when you drag a shape to the design surface.
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Note

When you release the port onto the port surface, the Port Configuration Wizard starts automatically.

6.
On the Welcome to the Port Configuration Wizard page, click Next.

7.
On the Port Properties page, in the Name box, type ReceiveReqPort, and then click Next.

8.
On the Select a Port Type page, do the following:

Use this

To do this

Select the port type to be used for this port
Select the Create a new Port Type option.

Port Type Name:
Type ReceiveReqType.

Communication Pattern
Select the One-Way option.

Access Restrictions
Select the Internal - limited to this project option.

9.
Click Next. 

10.
On the Port Binding page, do the following:

Use this

To do this

Port direction of communication
From the drop-down list, select I'll always be receiving messages on this port.

Port binding
From the drop-down list, select Specify later.

11.
Click Next.

The following table shows the summary information for ReceiveReqPort displayed on the Completing the Port Wizard page:

Property

Value

Port Name

ReceiveReqPort

Communication

This port will be used to receive messages only. The binding for this port will be specified through BizTalk Explorer or by script.
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Note

In this tutorial, you will use the BizTalk Server Administration console to specify the binding for this port. 

12.
On the Completing the Port Wizard page, click Finish. 

13.
From the orchestration Toolbox, drag the Port shape to the right-side Port Surface, parallel to the Send_ReqToERP shape. 
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Note

When you release the port onto the port surface, the Port Configuration Wizard starts automatically.

14.
Use the information in the following table to complete the Port Configuration Wizard for the SendToERP send port.
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Note

You specify the port binding for the SendToERP port in Lesson 3: Deploy the Solution. When you set the port binding to Specify later, you will complete the binding later in the BizTalk Server Administration console, rather than at design time in Orchestration Designer or BizTalk Explorer. In this lesson, you specify the location of the ERP system in the BizTalk Server Administration console after you deploy the application.

Property

Value

Name
Type SendToERP.

Select the port type to be used for this port
Select the Create a new Port Type option.

Port Type Name
Type SendToERPType.

Communication Pattern 
Select the One-Way option.

Access Restrictions
Select the Internal - limited to this project option.

Port direction of communication
From the drop-down list, select I'll always be sending messages on this port.

Port binding
From the drop-down list, select Specify later.

15.
From the orchestration Toolbox, drag the Port shape to the right-side Port Surface, parallel to the Send_ReqDenied shape. 

16.
Use the information in the following table to create the SendDeclinePort send port.

Property

Value

Name
Type SendDeclinePort.

Select the port type to be used for this port
Select the Create a new Port Type option.

Port Type Name
Type SendDeclineType.

Communication Pattern
Select the One Way option.

Access Restrictions
Select the Internal - limited to this project option.

Port direction of communication
From the drop-down list, select I'll always be sending messages on this port.

Port bindings
From the drop-down list, select Specify later.

The following figure shows the EAIProcess orchestration with the ports.
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17.
On the File menu, click Save All. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 6: Specify Action Shape Messages and Connect the Ports.


What did I just do?

In this step, you added three ports to the EAIProcess orchestration and configured them.

Next Steps

You specify a message for each Send and Receive action shape and connect the action shapes to the ports you created in this step in Step 6: Specify Action Shape Messages and Connect the Ports.

See Also

Step 4: Create Message Instance Variables
Step 6: Specify Action Shape Messages and Connect the Ports
Step 6: Specify Action Shape Messages and Connect the Ports             
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Time to complete: 7 minutes

Objective: In this step, you specify a message for each Send and Receive action shape in the EAIProcess orchestration and then you connect the action shapes to the ports you created in Step 5: Add Ports to the Orchestration.

Purpose: Send actions send messages. Receive actions receive messages. By specifying the messages that send actions send, and receive actions receive, and then connecting the send and receive actions to the appropriate ports, you configure the processing of the messages into and out of BizTalk Server. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 5: Add Ports to the Orchestration.


You must log on as a member of the BizTalk Server Administrators group.
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To specify the message sent or received by the action shapes

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click EAIProcess.odx. 

5.
In Orchestration Designer, on the design surface, right-click the Receive_Request action shape, and then click Properties Window. 

6.
In the Properties pane, from the Message drop-down list, select RequestInstance. 

7.
Use the information in the following table to specify the message for the Send_ReqDenied shape and the Send_ReqToERP shape.

Shape

Message

Send_ReqDenied 
RequestDeniedInstance
Send_ReqToERP 
RequestInstance
8.
On the File menu, click Save All. 
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To connect the ports to the action shapes

	1.
In Orchestration Designer, on the design surface, drag the green arrow-shaped handle for each port to the corresponding green handle of the action shape. 
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Note

In this step, you use the drag-and-drop method to connect ports to action shapes. You could instead use the operation property of an action shape to connect the action shape to a port.

Use the information in the following table to connect ports to the appropriate action shapes.

Connect this port

To this action shape

ReceiveReqPort
Receive_Request
SendDeclinePort
Send_ReqDenied 
SendToERP
Send_ReqToERP 
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Note

The no expression Smart Tags go away for the Receive_Request, Send_ReqDenied, and Send_ReqToERP shapes when you specify the message for the shape and connect the shape to a port. The remaining no expression Smart Tags in the EAIProcess orchestration will be resolved in a later step.

The following figure shows the EAIProcess orchestration with all of the ports connected.
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2.
On the File menu, click Save All. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 7: Configure the Transform Shape to Use the Map.


What did I just do?

In this step, you specified a message for each Send and Receive action shape in the EAIProcess orchestration and then you connected the action shapes to the ports you created in Step 5: Add Ports to the Orchestration.

Next Steps

You connect the map you created in Lesson 2 to the transform shape in the EAIProcess orchestration in Step 7: Configure the Transform Shape to Use the Map.

See Also

Step 5: Add Ports to the Orchestration
Step 7: Configure the Transform Shape to Use the Map
Step 7: Configure the Transform Shape to Use the Map             
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Time to complete: 7 minutes

Objective: In this step, you connect the map you created in Lesson 1: Create the EAI Solution to the transform shape in the EAIProcess orchestration.

Purpose: You defined the schema of the inventory replacement request message that the warehouse sends to BizTalk Server in Lesson 1: Create the EAI Solution. You defined the schema of the request denied message that BizTalk Server sends to the warehouse. You defined a map that connects parts of the two schemas so that data from the request message can be included in the request denied message. When you connect the map to the transform action, the transform action uses the map to construct the request denied message with data from the request message. 

In this step, you use the Transform Configuration dialog box to specify a map, and the input and output messages. 
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 6: Specify Action Shape Messages and Connect the Ports.


You must log on as a member of the BizTalk Server Administrators group.
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To configure the Transform action to use the map

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click EAIProcess.odx. 

5.
In Orchestration Designer, on the design surface, right-click the Construct_RequestDenied shape, and then click Properties Window.

6.
In the Properties pane, from the Messages Constructed drop-down list, select the RequestDeniedInstance check box. 

7.
On the orchestration design surface, double-click the Transform_1 shape.

8.
In the Transform Configuration dialog box, do the following:

Use this

To do this

Enter the configuration information
Select the Existing Map option.

Fully Qualified Map Name
From the drop-down list, select Select from Referenced Assembly.
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Note

Selecting Select from Referenced Assembly opens the Select Artifact Type dialog box

9.
In the Select Artifact Type dialog box, do the following:

Use this

To do this

Current Project
In the tree control, expand References, and then click EAISchemas.

Type Name
Click MapToReqDenied.

The following figure shows the Select Artifact Type dialog box.

[image: image139.png][ e end sl o rferenc:

[eorenrrama
[ Reforeros
5 envscanas
0 eatstenss
Sy -
2 ol eTak doboPropr
3 Hiooaolt ALANGs EseTypes
Doy
Spten
O sptamal

L | il |

[SSecad Type MaproReqpenied meniar of (ERTschemasy
[ Coeane sl € TukaralL ssons\EAISlution EAIOrchestrations i Development.
[\Enischemos.ai

o e e





10.
Click OK.

11.
In the Transform Configuration dialog box, click Source, and then from the Variable Name drop-down list, select RequestInstance.
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Note

The Source Transform section of the Transform Configuration dialog box is a grid control. You must click in the cell under Variable Name to expose the control. A control is a device you use to select options, such as a drop-down list.

12.
In the Transform Configuration dialog box, click Destination, and then from the Variable Name drop-down list, select RequestDeniedInstance. 
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Note

When you select the Source Transform and Destination Transform variables, Source and Destination should show the red X change to a green check. To refresh Source and Destination, click Destination and Source.

The following figure shows the Transform Configuration dialog box.
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13.
Click OK.

14.
On the File menu, click Save All. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 8: Write the XLANG/s Expression for the Decision. 


What did I just do?

In this step, you connected the transform shape in the EAIProcess orchestration to the map you created in Lesson 1: Create the EAI Solution.

Next Steps

You write the expression that determines whether an inventory replacement request message is approved or denied in Step 8: Write the XLANG/s Expression for the Decision.

See Also

Step 6: Specify Action Shape Messages and Connect the Ports
Step 8: Write the XLANG/s Expression for the Decision
Step 8: Write the XLANG/s Expression for the Decision             
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Time to complete: 5 minutes

Objective: In this step, you write an expression for the decision shape. 

Purpose: The expression you write in this step evaluates the value of the quantity field in the inventory replacement request message. If the quantity in a request instance exceeds 500, the orchestration declines the request. In Lesson 1, you defined the quantity field when you created the schema for the message. Because the expression evaluates which messages BizTalk Server rejects, you add the expression to the decline side of the decision shape. 

You use the Expression Editor to create expressions to expand the capabilities of various orchestration shapes. In this procedure, you use it to construct a Boolean expression in the Decision shape. The Expression Editor includes an IntelliSense feature that helps guide you in creating the expression.  
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 7: Configure the Transform Shape to Use the Map.


You must log on as a member of the BizTalk Server Administrators group.
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To write the XLANGs expression for the decision rule

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, double-click EAIProcess.odx. 

5.
In Orchestration Designer, on the design surface, double-click the Decline shape. 
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Note

When you double-click the Decline shape, the Expression Editor opens.

6.
In the BizTalk Expression Editor, type the following expression: 
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Important

The syntax used in the Expression Editor is case sensitive. 

RequestInstance.Item.Quantity >500

The following figure shows the Expression Editor with the expression.
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7.
Click OK to close the BizTalk Expression Editor. 

8.
On the File menu, click Save All. 
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Note

You have now added all of the expressions in the orchestration.
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can go to the next step, Step 9: Build the EAIOrchestrations Project. 


What did I just do?

In this step, you wrote an expression for the decision shape.

Next Steps

You build the project to generate an assembly in Step 9: Build the EAIOrchestrations Project.

See Also

Step 7: Configure the Transform Shape to Use the Map
Step 9: Build the EAIOrchestrations Project
Step 9: Build the EAIOrchestrations Project             
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Time to complete: 5 minutes

Objective: In this step, you compile the EAIOrchestrations project to create a DLL file.

Purpose: After you create the EAIOrchestrations project and add the necessary items to it, you build the project to generate an assembly. An assembly is a collection of resources in the project that are stored in a DLL file. 

All resources the EAIOrchestrations project requires must be available to it before you build the EAIOrchestrations project. You make the resources available by building the project that contains those resources. You did this when you built the EAISchemas project at the end of Lesson 1. In this case, when you built the EAISchemas project, you made the schemas available to the EAIProcess orchestration. 

The output tab located at the bottom of your screen displays the results of building the project.
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Note

For information about the BizTalk Server tools you use in the tutorials, see Step 5: Learn About the BizTalk Server Tools in Before You Begin the Tutorials.

Prerequisites

Note the following requirements before you begin this step: 


Before you begin this step you must complete Step 8: Write the XLANG/s Expression for the Decision.


You must log on as a member of the BizTalk Server Administrators group.
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To build the EAIOrchestrations project

	1.
Click Start, point to Programs, point to Microsoft Visual Studio 2005, and then click Microsoft Visual Studio 2005. 

2.
In Visual Studio 2005, on the File menu, point to Open, and then click Project/Solution.

3.
In the Open Project dialog box, click EAISolution, and then click Open.

4.
In Solution Explorer, right-click the EAIOrchestrations project and click Properties. 

5.
In the EAIOrchestrations Property Pages dialog box, in the tree pane, expand Common Properties, click Assembly, and then in the properties list, click the Assembly Key File ellipsis […].  

The following figure shows the EAIOrchestrations Property Pages dialog box.
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6.
In the Assembly Key File dialog box, do the following:

Use this

To do this

Look in
Navigate to C:\Tutorial.

File name
Type Tutorial.snk.
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Note

You created the Tutorial.snk strong name key file in Step 4: Create a Strong Name Key File.

7.
Click Open.

8.
In the EAIOrchestrations Property Pages dialog box, in the tree pane, expand Configuration Properties, click Deployment, and then do the following:

Use this

To do this

Application Name
Type EAIApplication.
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Note

Building the EAIOrchestrations project creates the EAIApplication application, which appears in the BizTalk Server Administration console and contains the EAIOrchestrations assembly.

Redeploy
From the drop-down list, select True.

9.
Click OK. 

10.
On the File menu, click Save All.

11.
In Solution Explorer, right-click EAIOrchestrations, and then click Build.

The Output pane at the bottom of the screen should read: Build: 2 succeeded or up-to-date, 0 failed, 0 skipped.
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Note

To display the Output pane, on the View menu, click Output.

You are now ready to deploy your solution to a testing environment. 
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Note

You saved your work. You can safely close Visual Studio 2005 at this time, or you can start Lesson 3: Deploy the Solution.


What did I just do?

In this step, you compiled the EAIOrchestrations project to create a DLL file.

Next Steps

You deploy the EAISolution solution in Lesson 3: Deploy the Solution. 

See Also

Step 8: Write the XLANG/s Expression for the Decision
Lesson 3: Deploy the Solution
Lesson 3: Deploy the Solution             

The first step in deploying your BizTalk solution is to add it to the BizTalk Management database and the global assembly cache. 

The second step is to configure EAIApplication and start it. You specified the EAIApplication application for both projects in the EAISolution solution in Lesson 2: Define the Business Process. When you deploy the solution, BizTalk Server adds the projects and their artifacts to the EAIApplication application. You use the BizTalk Server Administration console to configure EAIApplication.

In this lesson, you learn about administering BizTalk Server 2006 artifacts by using the BizTalk Server Administration console. For information about using the BizTalk Server Administration console, see the “Using the BizTalk Administration Console” topic in BizTalk Server 2006 Help.

Configuring an application involves specifying a BizTalk Host for the application, and binding the ports in the application. In Lesson 2, you added logical ports to the EAIProcess orchestration. In this lesson, you define the physical ports that include transport type and location for the ports. 

The last step in the deployment process is to start the EAIApplication application. Starting EAIApplication starts the orchestration and the ports, so the solution can receive and process messages. 

Before you begin this lesson, you must complete the steps in Lesson 2: Define the Business Process. To download a Microsoft Office Word 2003 version of the BizTalk Server 2006 Tutorials, see  http://go.microsoft.com/fwlink/?LinkId=62503.

In this Section


Step 1: Deploy the Projects

Step 2: Configure and Start the EAI Application

Step 3: Test the EAI Solution
Step 1: Deploy the Projects             
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Time to complete: 5 minutes

Objective: In this step, you deploy the EAISchemas and EAIOrchestration projects.

Purpose: You deploy a BizTalk Server project to place a copy of the assembly in the BizTalk Management database (also known as the Configuration database) and install it in the global assembly cache. You created assemblies when you built the EAISchemas and EAIOrchestrations projects in the preceding lesson. 

In this step, you deploy both projects (also known as assemblies) in your solution: EAISchemas.dll and EAIOrchestrations.dll. 

You can run the deploy process on the solution. Deploying the solution deploys both projects in the proper order. If you deploy the projects individually, you must deploy them in reverse order of dependency, starting from the independent assemblies and then moving on to the assemblies that are dependent upon those developed earlier. 
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Note

If you find this confusing, there is no need to be concerned. Visual Studio will tell you the order in which you must build and deploy your projects. Just right-click a project, and then click Project Build Order. The Project Dependencies dialog box shows you the build order for your projects and, on the Dependencies tab, shows the dependency relationship between the projects.

In the EAISolution solution, the EAIOrchestrations project references schemas in the EAISchemas project. If you deploy the projects individually, you would deploy EAISchemas first. If you build or deploy projects in the wrong order, the process fails.

Prerequisites

Note the following requirements before you begin this step: 


Before you begin this step you must complete Step 9: Build the EAIOrchestrations Project.


You must log on as a member of the BizTalk Server Administrators group.
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To deploy the projects

	1.
In Solution Explorer, right-click Solution 'EAISolution', and then click Properties.

2.
In the Solution 'EAISolution' Properties Pages dialog box, in the tree control, expand Configuration Properties, and then click Configuration.

3.
On the Configuration page, in the Deploy column, select the check boxes for both the EAISchemas and EAIOrchestrations projects, and then click OK.

4.
In Solution Explorer, right-click Solution 'EAISolution', and then click Deploy Solution. 
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Note

When you deploy the solution, Visual Studio deploys all of the projects in the solution, in the order of dependency. If you choose to deploy the projects individually yourself, you must deploy the EAISchemas project first, wait for the deployment process to complete, and then deploy the EAIOrchestrations project. 

The Output pane at the bottom of the screen should read: Deploy Operation Succeeded. 

[image: image164.png]


Note

To display the Output pane, on the View menu, click Output.
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Note

 You can safely close Visual Studio 2005 at this time, or you can start Step 2: Configure and Start the EAI Application.


What did I just do?

In this step, you deployed the EAISchemas and EAIOrchestration projects

Next Steps

You add a one-way send port that sends approved inventory replacement messages to an ERP system for fulfillment in Step 2: Configure and Start the EAI Application. 

See Also

Step 9: Build the EAIOrchestrations Project
Step 2: Configure and Start the EAI Application
Step 2: Configure and Start the EAI Application             
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Time to complete: 10 minutes

Objective: In this step, you configure and start the EAIApplication application.

Purpose: When you configure EAIApplication, you associate the logical artifacts you created in Visual Studio with their physical counterparts. In this step, you bind the EAIProcess orchestration to a BizTalk Host. A BizTalk Host is a BizTalk Server run-time process. In addition, you bind the physical ports you define in this step to the logical ports you created in Step 5: Add Ports to the Orchestration.

You use the BizTalk Server Administration console to configure EAIApplication. In the following procedure, you select a host for the application, and define a receive location and physical receive port, and two physical send ports. After you configure the application, you start it. Starting the application means that it can start processing messages.

Prerequisites

Note the following requirements before you begin this step:


Before you begin this step you must complete Step 1: Deploy the Projects.


You must log on as a member of the BizTalk Server Administrators group.
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To configure EAIApplication

	1.
Click Start, point to Programs, point to Microsoft BizTalk Server 2006, and then click BizTalk Server Administration. 

2.
In the console tree on the left side of the BizTalk Server Administration console, expand BizTalk Server 2006 Administration, right-click BizTalk Group, and then click Refresh.

3.
Expand BizTalk Group, expand Applications, right-click EAIApplication, and then click Configure. 

The following figure shows the Configure Application dialog box.
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4.
In the Configure Application dialog box, on the EAIProcess tab, do the following:

Use this

To do this

Host
From the drop-down list, select BizTalkServerApplication.

ReceiveReqPort
From the drop-down list under Receive Ports, select New receive port.
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Note

This is a grid control. You must first click in the cell across from ReceiveReqPort before the drop-down list control appears.

The following figure shows the Receive Ports drop-down list.
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5.
In the ReceivePort1 - Receive Port Properties dialog box, in the Name box, type ReceivePort_ReceiveReq.

6.
On the Receive Locations tab, click New.

The following figure shows the New button.
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7.
In the ReceiveLocation1 - Receive Location Properties dialog box, on the General tab, do the following:

Use this

To do this

Name
Type ReceiveLocation_ReceiveReq.

Type
From the drop-down list, select FILE, and then click Configure.

8.
In the FILE Transport Properties dialog box, on the General tab, click Browse.

9.
In the Browse For Folder dialog box, expand My Computer, navigate to C:\Tutorial\Filedrop\ReceiveRequest, and then click OK.

10.
In the FILE Transport Properties dialog box, click OK.

11.
In the ReceiveLocation_ReceiveReq - Receive Location Properties dialog box, from the Receive pipeline drop-down list, select XMLReceive, and then click OK.

The following figure shows the ReceiveLocation_ReceiveReq - Receive Location Properties dialog box with the XMLReceive pipeline.
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12.
In the ReceivePort_ReceiveReq - Receive Port Properties dialog box, click OK.

13.
In the Configure Application dialog box, on the EAIProcess tab, from the drop-down list for SendDeclinePort, under Send Ports, select New send port.

[image: image173.png]


Note

This is a grid control. You must first click in the cell across from SendDeclinePort before the drop-down list control appears.

14.
In the SendPort1 - Send Port Properties dialog box, on the General tab, do the following:

Use this

To do this

Name
Type SendPort_SendDeclinePort.

Type 
From the drop-down list, select FILE, and then click Configure.

15.
In the FILE Transport Properties dialog box, on the General tab, click Browse.

16.
In the Browse For Folder dialog box, expand My computer, navigate to C:\Tutorial\FileDrop\RequestDenied, and then click OK.

17.
In the FILE Transport Properties dialog box, on the General tab, in the File name box, type Denied%MessageID%.xml, and then click OK.

18.
In the SendPort_SendDeclinePort - Send Port Properties dialog box, click OK.

19.
In the Configure Applications dialog box, on the EAIProcess tab, from the drop-down list for SendToERP, under Send Ports, select New send port.
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Note

This is a grid control. You must first click in the cell across from SendToERP before the drop-down list control appears.

20.
In the SendPort1 - Send Port Properties dialog box, do the following:

Use this

To do this

Name
Type SendPort_SendToERP.

Type
From the drop-down list, select FILE, and then click Configure.

21.
In the FILE Transport Properties dialog box, on the General tab, click Browse.

22.
In the Browse For Folder dialog box, expand My Computer, navigate to C:\Tutorial\FileDrop\ERPSys, and then click OK.

23.
In the FILE Transport Properties dialog box, click OK.

24.
In the SendPort_SendToERP - Send Port Properties dialog box, click OK.

25.
In the Configure Application dialog box, click OK.

26.
In the console tree, right-click EAIApplication, and then click Start.

27.
In the Start 'EAIApplication' Application dialog box, click Options, ensure that all of the check boxes are selected, and then click Start.
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Note

The next steps verify that the application started.

28.
In the console tree, click Applications. 

29.
In the Applications details pane, check that the Status of EAI Application is Started.
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Note

If the status is Partially Started, in the console tree, expand EAIApplication, and then click Receive Locations. In the Receive Locations details pane, right-click the receive location, and then click Enable. In the console tree, click Applications. In the Applications details pane, right-click EAIApplication, and then click Refresh. The status should now be Started.


What did I just do?

In this step, you configured and started the EAIApplication application.

Next Steps

You test how the EAI solution processes messages in Step 3: Test the EAI Solution.

See Also

Step 1: Deploy the Projects
Step 3: Test the EAI Solution
Step 3: Test the EAI Solution             
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Time to complete: 5 minutes

Objective: In this step, you test how the EAI solution processes messages.

Purpose: In this step, you check that the EAIProcess orchestration processes messages correctly. You do this by dropping sample messages into the receive location specified for the EAI application. If the EAI solution is working properly, if the EAIProcess orchestration receives a message from the warehouse requesting more than 500 items, the orchestration generates a decline request message. If the EAIProcess orchestration receives a message from the warehouse requesting fewer than 500 items, the orchestration passes the message on to the ERP system. 

Prerequisites

Before you begin this step you must complete Step 2: Configure and Start the EAI Application.
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To test the EAI solution

	1.
In Windows Explorer, navigate to C:\Tutorial.

2.
Copy RepRequestAccepted.xml and paste it into C:\tutorial\Filedrop\ReceiveRequest.

3.
When the file disappears, check C:\tutorial\Filedrop\ERPSys.

The file name of the approved message is now a GUID. The RepRequestAccepted.xml message meets the condition to be approved. You set the condition for approving messages in the orchestration. 

4.
In Windows Explorer, navigate to C:\Tutorials.

5.
Copy RepRequestDenied.xml and paste it into C:\tutorial\Filedrop\ReceiveRequest.

6.
When the file disappears, check C:\tutorial\Filedrop\RequestDenied.

The file name of the denied message is now "Denied" followed by a GUID. The RepRequestDenied.xml message does not meet the condition to be approved. You set the condition for approving messages in the orchestration. You added "Denied" to the file name when you set the transport properties for the SendPort_SendDeclinePort send port.


What did I just do?

You tested the EAI solution by placing sample messages in the receive location for the EAI application.

Next Steps

If the test worked, congratulations! You have completed the first BizTalk Server 2006 tutorial. If you would like to continue learning about BizTalk Server, there are four more tutorials. To start the next tutorial, go to Tutorial 2: Purchase Order Process.

If the test did not work, carefully check your work to make sure that you added all of the necessary objects and set their properties correctly. 

See Also

Step 2: Configure and Start the EAI Application
Tutorial 2: Purchase Order Process
Lesson 3: Deploy the Solution
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