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Abstract
The Device Stage™ feature in Windows® 7 provides a new way for users to interact with devices that are connected to their computers. It enables device manufacturers to deliver user experiences that match the specific branding, features, and content of their devices. Users simply connect their device to a computer that is running Windows 7, and the manufacturer-supplied experience is automatically installed and presented to them, which ensures a seamless experience between the users and their PCs and devices.
[bookmark: _GoBack]This guide shows device manufacturers how to use the Device Stage Visual Editor tool to develop and build a metadata package for a user Device Stage experience. It defines each step of the development process and references existing documentation that contains technical information and strategies. You are not required to know this information to successfully navigate this tool, but the information will help you improve your customers’ Device Stage experience.

The current version of this guide is maintained on the web at:
http://www.microsoft.com/whdc/device/DeviceExperience/dsve-userguide.docx
References and resources discussed here are listed at the end of this guide.
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[bookmark: _Toc267393131]Overview
Device Stage Visual Editor, Version 1.0, is a tool that device manufacturers use to develop a custom Device Stage™ metadata package for their devices. This metadata package provides specific information that appears to end users as a Device Stage experience.
A Device Stage experience in Windows 7 lets device manufacturers build and brand the device experience that they present to end users. With Device Stage experiences, end users easily interact with their phone, camera, keyboard and mouse, or portable media player from their Windows desktop.
Manufacturers can use the easy-to-navigate user interface of Device Stage Visual Editor to develop and build a Device Stage experience metadata package. The package includes XML documents and graphics files that present photorealistic icons, device descriptions, and custom behaviors about their devices to end users. Manufacturers then submit the device metadata package to Microsoft, which validates the package and makes it available to users for download from the Windows Metadata and Internet Services (WMIS) server. The submission process is outside the scope of the current version of the tool. However, you can find details on the Windows Device Experience portal page on the WHDC website.
Important Note  A Device Stage metadata package is very similar to a Devices and Printers metadata package. When you build a Device Stage metadata package for your device, you also create the components for a Devices and Printers metadata package for your device. Device Stage Visual Editor creates Devices and Printers metadata as a subset of a full Device Stage metadata package for devices that are supported. If your device is not currently supported by Device Stage Visual Editor, you can create a Devices and Printers metadata package in a separate tool. For details, see “How to Create a Device Metadata Package for Devices and Printers” on the WHDC website.
[bookmark: _Toc267393132]Assumptions
This guide assumes the following:
You want to capture and customize the Device Stage experience that end users see when they connect your device to their computer that is running Windows 7.
You can access the latest version of the Device Stage Visual Editor tool.
You have downloaded and installed the latest version of the Microsoft Device Experience Development Kit (MDEDK).
[bookmark: _Toc267393133]Device Categories
Device Stage Visual Editor supports the following device categories:
Document devices
Keyboards and mice
Mobile broadband devices
PCs
Portable devices
Digital cameras (includes digital still and digital video cameras)
Mobile phones
Portable media players
Smart card devices
Others (includes webcams and devices with no default tasks)
[bookmark: _Toc267393134]Languages
Device Stage Visual Editor supports up to 36 languages, including both Simplified and Traditional Chinese, in which to develop device metadata packages. English (en-US) is the default, but you can change the language by modifying the selection in the Properties Device LocaleLanguage field of the tool or by directly manipulating PackageInfo.xml.
Device Stage Visual Editor supports two locale default cases:
LocaleDefault = True
LocaleDefault = False

A LocaleDefault set to “True” specifies the metadata package as the default for the current locale of the computer. To support multiple locales, you must create separate metadata packages for the same device.
You must test the metadata package on a computer that is running Windows 7 and bears the locale of its Device Stage experience target locale (such as Italian, Vietnamese, or Simplified Chinese).
[bookmark: _Toc267393135]Microsoft Device Experience Development Kit 7R2
Device Stage Visual Editor Version 1.0 is compatible with the MDEDK 7R2, which is available on the WHDC website.
[bookmark: _Toc267393136]Getting Started
The following is some basic information to get you started using Device Stage Visual Editor.
[bookmark: _Toc267393137]License Agreement
The first time you open Device Stage Visual Editor after installation, you see the Device Stage Visual Editor License Agreement dialog box as shown in Figure 1.
[image: ]
[bookmark: _Ref265668117]Figure 1. Device Stage Visual Editor License Agreement
Read through the license terms. Click Accept to accept the terms or Decline to decline. As is standard, if you decline the terms, you will not be able to access the tool.
[bookmark: _Toc267393138]10-Minute, 10-Step Quick Start
This 10-minute, 10-step quick start serves as future reference and continually instills in you the confidence to quickly develop an effective Device Stage experience.
1.	Open Device Stage Visual Editor.
2.	Enter test mode, and then restart your computer.
3.	Develop a new or open an existing device metadata package.
4.	Modify or update new default fields or existing fields. (Get GUIDs as needed.) Save changes as you go.
5.	Add new tasks or categories. (Get GUIDs as needed.) Save changes as you go.
6.	To preview metadata changes, refresh the Package Preview pane.
7.	If you are satisfied, build the metadata package. If you are not satisfied, repeat steps 5, 6, and 7.
8.	After the metadata package is built, it is copied to the store in the following location: 
	%programdata%\Microsoft\Windows\DeviceMetadataStore\<locale>
Connect your device to the computer.
9.	Start, test, and review your Device Stage experience.
10.	If you are satisfied, save the metadata package. If you are not satisfied, repeat steps 5, 6, 7, 8, and 9.
[bookmark: _Toc267393139]Quick Reference Table
Table 1 shows all the functions in Device Stage Visual Editor and their paths.
Table 1. Quick Reference Table
	Function
	Menu
	Command
	Icon or Button

	Develop New Metadata Package
	File 
	New
	


	Open Existing Metadata Package
	File 
	Open
	


	Save Metadata Package
	File 
	Save
	


	Add New Category
	Edit 
	New Category
	


	Add New Task
	Edit 
	New Task
	


	Delete Category or Task
	Edit 
	Delete Task/Category
	


	Refresh Preview Package Pane
	Preview
	Refresh
	


	Build Metadata Package
	Build 
	Metadata
	


	Get Computer HWID1
	Tools 
	Get Computer HWID
	


	Create a GUID
	Tools 
	Create a GUID
	

	Enter Test Mode
	Tools 
	Enter Test Mode
	

	Exit Test Mode
	Tools 
	Exit Test Mode
	

	 Get Computer HWID is enabled only for PC Device Stage experiences. It is not required for document devices, keyboards and mice, mobile broadband devices, portable devices, and smart card Device Stage experiences.




[bookmark: _Toc267393140]Functions
For easy reference, the following Device Stage Visual Editor functions are divided by their menu location:
File menu
Edit menu
Preview menu
Build menu
Tools menu
[bookmark: _Toc267393141]File Menu
The File menu contains three commands:
Develop New Metadata Package
Open Existing Metadata Package
Save Metadata Package (Save or Save As…)

The following sections describe how to use these commands.
[bookmark: _Toc267393142]Developing a New Metadata Package
Developing a new device metadata package in Device Stage Visual Editor can be easy and even fun.
To develop a new metadata package
1.	Open Device Stage Visual Editor.
[image: ]
[bookmark: _Ref265070721][bookmark: _Toc265423797]Figure 2. Device Stage Visual Editor user interface


2.	On the File menu, click New or click [image: ] on the toolbar.
3.	In the New_Metadata dialog box, select a device category and click Next, as shown in Figure 2. For our example, we selected Digital Camera. (To cancel the action and close the dialog box click Cancel.)
[image: ]
[bookmark: _Ref262479706][bookmark: _Toc265423798]Figure 3. New_Metadata dialog box with Digital Camera selected
Running Microsoft Device Experience Development Kit _7R2.msi installs a set of “starter” device experience templates for different device categories. These templates contain the behind-the-scenes files and folder hierarchy that are necessary to generate a basic device metadata package. These templates also have the required tasks for the given device category.
Note  Every time you select a device category, a template is loaded and Device Stage Visual Editor generates a new globally unique identifier (GUID) for the ExperienceID of the metadata package, as shown in the ExperienceID field in Figure 4.
Device Stage Visual Editor now displays the Digital Camera template with the default values in the Device Experience and Properties panes on the left in Figure 3. Figure 3 also identifies the other named areas of the Package Preview pane.
 (
Properties Pane
) (
Branding Bar
Text Color
)[image: ]
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[bookmark: _Ref262558514]
[bookmark: _Ref265667220][bookmark: _Toc265423799]Figure 4. Default metadata package device category and values for the Digital Camera template
You can find templates and other device-category specific documentation on the WHDC website.
[bookmark: _Toc267393143]Opening an Existing Metadata Package
Opening an existing metadata package must be done in Device Stage Visual Editor.
To open an existing metadata package for editing
1. 
On the File menu, click Open or click  on the toolbar.
2. In the Open dialog box, browse to locate and select the existing metadata package and click Open. (To cancel the action and close the dialog box click Cancel.)
[bookmark: _Ref262651906][bookmark: _Ref262651918][bookmark: _Ref262651953]Customizing Existing Metadata
After the template for a new metadata package is loaded or you have opened an existing metadata package, you can customize and edit the metadata.
To edit the default metadata
1.	Navigate the elements in the Device Experience pane and corresponding device properties in the Properties pane by clicking the plus sign (+) to expand the options and the minus sign (-) to contract the options, as shown in Figure 4.
As you expand the information in the Device Experience pane, the corresponding task information appears below in the Properties pane.

2.	You can edit existing metadata values in one of four ways:
Edit an existing value.
Select the field and type the appropriate value.
Select the new value from the drop-down list box. 
Click the drop-down arrow ([image: ]), and then select a predefined value.
Tip  You can double-click in any drop-down list box to “click” you way through the available options.
Select a graphic file from the standard Open dialog box.
Click [image: ], and then browse the Open dialog box to select the applicable graphic .ico or .png file.
Add text in the String Collection Editor or in the Raw XML Editor. 
Click [image: ], and then paste or edit the string or XML source as shown in Figure 5.
[image: ]
[bookmark: _Ref262554644][bookmark: _Toc265423800]Figure 5. Properties task requirement field metadata
Appendix B, “Device Fields” shows all device property metadata fields, their content description, whether they are required or optional, and references to associated documentation that has technical details (which includes element type metadata for manually modifying the XML source).
Note  Device Stage Visual Editor does not let you save your metadata package until all required fields are complete.
[bookmark: _Toc267393144]Saving a Metadata Package
When you save a metadata package, Device Stage Visual Editor compresses the build-generated XML and graphic files into a single cabinet file. Even though the usual suffix of a cabinet file is .cab, the suffix for a device metadata package file is 
.devicemetadata-ms. This emphasizes the fact that end users must not decompress or modify these packages.


To save a metadata package

On the File menu, click Save, or click  on the toolbar.
If this is a first-time save, Device Stage Visual Editor automatically assigns a GUID that is similar to bf949168-249f-49e2-be1a-79d998f1e6ae.devicemetadata-ms and displays the Save As… dialog box. In the Save As… dialog box, browse to identify a target folder location, and then click the Save button.
If this is a subsequent save of the same device metadata package, Device Stage Visual Editor saves the experience under the same GUID file name by default.

Note  If you add a category or task and then try to build or save the metadata package before all required metadata fields are filled with valid data, an error message appears that calls out the first field that has no data that Device Stage Visual Editor detects. Device Stage Visual Editor does not let you save a metadata package that is missing required information.
Note  We recommend that you save the metadata package whenever you make changes.
At any time you can save your metadata package under a different file name than the default GUID. First, get a new GUID using the Create a GUID tool. Then, on the File menu, click Save As…, and paste the new GUID in the Save As… dialog box. Note that all metadata packages must have a GUID file name.
[bookmark: _Toc267393145]Edit Menu
The Edit menu contains three commands:
Add a New Category
Add a New Task
Delete a Category or Task

The following sections describe how to use these commands.
[bookmark: _Toc267393146]Adding a New Category
A “category” in Device Stage Visual Editor is defined as an element that enables you to organize multiple tasks into folders by specifying categories. By nesting tasks in a category, you can assign one or more tasks to a subfolder.
To add a new category
1.	In the Device Experience pane, select the TaskCategoryMapping element, as shown in Figure 6.
[image: ]
[bookmark: _Ref262650396][bookmark: _Ref262650324][bookmark: _Toc265423801]Figure 6. Adding a new task by highlighting TaskCategoryMapping

2.	On the Edit menu, click New Category, or clickon the taskbar.
After you add the category, it appears at the bottom of the TaskCategoryMapping element in the Device Experience pane. Click New Category, and its associated fields appear in the Properties pane, as shown in Figure 7.
[image: ]
[bookmark: _Ref265667478][bookmark: _Toc265423803]Figure 7. New category and associated properties
3. After the default category property fields appear, begin entering and editing as described earlier in “Customizing Existing Metadata.”
Note  When you enter a name in the DisplayName field and click[image: ], the name of your category replaces the New Category placeholder and appears in the Category and Task areas of the Device Stage Visual Editor Package Preview pane.
4. 
To add new tasks to your new category to create an organized subfolder of tasks, select the target category in the Device Experience pane to which you want to add tasks and clickon the taskbar, as shown in Figure 8. This step is optional.
[image: ]
[bookmark: _Ref265667877][bookmark: _Toc265423804]Figure 8. Custom task added to custom category
Tip  To develop a good Device Stage experience, we recommend that you limit the number of tasks and categories in the Device Experience pane to 10 items. Ideally, users should not be required to scroll through the window to see additional tasks and categories. Also, limit the number of categories that are nested within categories so that users are not required to hunt for tasks.
Detailed information on category attributes can be found in the “Windows 7 Device Stage Reference Guide,” which is part of the MDEDK.
[bookmark: _Toc267393147]Adding a New Task
A “task” in Device Stage Visual Editor is defined as an action that users can take that is related to the device for which the Device Stage experience is being presented. Tasks appear in Device Stage Visual Editor as icons, titles, and descriptions.
Tasks can link to functionality that is part of Windows 7 or to custom functionality that you define and include in your device experience. Custom tasks can open product manuals or websites for product accessories or can start your own software. Custom tasks include, but are not limited to, links to the following items:
Product manuals
Accessories
Customer support
Device tutorials and videos
Downloading additional IHV-provided software
Starting IHV-provided software


To add a new task
1.	Highlight the TaskCategoryMapping element in the Device Experience pane, which was shown earlier in Figure 6.
2.	On the Edit menu, click New Task, or click[image: ]on the taskbar.
After you add the task, it appears at the bottom of the TaskCategoryMapping element in the Device Experience pane. Click New Task, and its associated properties appear in the Properties pane, as shown in Figure 9.
[image: ]
[bookmark: _Ref265668402][bookmark: _Toc265423802]Figure 9. New task and associated properties
3.	After the default task properties appear, begin entering and editing as described in “Customizing Existing Metadata” earlier in this guide.

Note  When you enter a name in the DisplayName field and click[image: ]on the taskbar, the name of your task replaces the New Task placeholder and appears in the Category and Task area of the Device Stage Visual Editor Package Preview pane.
Custom Task Items and XML
You can implement more sophisticated features in your experience through custom tasks and Tasks.xml. The possibilities are endless. For example, you can reference web pages and display them in-frame in the Device Stage experience window or start an application that is installed on your computer. Your device category may even support the ability to display status that is reported from a connected device. Tasks are defined for each device category in the MDEDK.
Detailed information on task-related XML elements and on the task model itself can be found in the “Windows 7 Device Stage Design Guide,” “Windows 7 Device Stage Development Guide,” and “Windows 7 Device Stage Reference Guide,” which are part of the MDEDK.
[bookmark: _Toc267393148]Deleting a Category or Task
Deleting a category or task occurs in the Device Experience pane of Device Stage Visual Editor, as shown earlier in Figure 4.
To delete a category or task
1.	Select the particular category or task in the Device Experience pane that you want to delete, as shown in Figure 10.
[image: ]
[bookmark: _Ref262724186][bookmark: _Toc265423805]Figure 10. Category selected to delete
2.	On the Edit menu, click Delete Task/Category, or click[image: ] on the taskbar, as shown in Figure 11.
[image: ]
[bookmark: _Ref262724762][bookmark: _Toc265423806]Figure 11. Category from Figure 10 deleted
Note  You can delete only custom added categories and tasks. You cannot delete default categories and tasks in any Device Stage Visual Editor templates because Microsoft requires them for operating system continuity that targets common device functionality.
There is one exception to the above rule. For the keyboards and mice device category, the template that is loaded into Device Stage Visual Editor incorporates default tasks for both keyboard and mouse. You can delete these default tasks to accommodate building a metadata package for one or the other type of device (keyboard or mouse).
[bookmark: _Toc267393149]Preview Menu
The Preview menu contains one command:
Refresh

The following section describes how to use this command.
[bookmark: _Toc267393150]Refreshing the Package Preview Pane
To see real-time updates from the changes that you make to your metadata package, refresh the Package Preview pane.
To refresh the Package Preview pane
On the Preview menu, click Refresh, or click[image: ]on the taskbar.

Note  You can refresh the Package Preview pane as many or as few times as you want.
[bookmark: _Toc267393151]Build Menu
The Build menu contains one command:
Build Metadata

The following section describes how to use this command.
[bookmark: _Toc267393152]Building a Metadata Package
Note  To build your metadata package, you must be in test mode.
When you build a metadata package, Device Stage Visual Editor combines the XML and graphics files, compresses them, and “creates” the final .cab file format, which is masked as a single .devicemetadata-ms file when it is saved. This emphasizes why end users must not extract the files or modify the packages.
Note  To view the compressed set of files, rename the target file’s .devicemetadata‑ms suffix to .cab and extract it. As previously stated, we recommend that end users not do this.
To build a metadata package
1.	On the Build menu, click Build Metadata, or click[image: ]on the toolbar.

2.	Note the outcome.

When you build a metadata package, the files in the package are copied to the metadata store in the following path:
%programdata%\Microsoft\Windows\DeviceMetadataStore\<locale>

where <locale> represents the system (the computer on which DSVE is running) default locale.  For example, metadata packages that are built on a computer with en-US set as the default locale are stored in the following path:
%programdata%\Microsoft\Windows\DeviceMetadataStore\en-us
To see this store, in Control Panel on the View tab, select the Hidden Files and Folders check box 
When the build operation is selected, DSVE evaluates the computer’s default locale. The build operation always creates the metadata package for this locale. Even if a package is developed with the localelanguage property set to something other than the system default locale, the build operation will cause DSVE to reset this value to the system default language as the language locale.  

You can use DSVE to create a package for any supported locale and language. To create packages for languages other than the computer’s default locale, use the Save or Save As function. The Save and Save As functions will not change the localelanguage property of the package to the locale of the PC on which the tool is running.
Important Note  When you build a metadata package, Device Stage Visual Editor auto-assigns a GUID for the “built” package. It is important to know that this GUID file name is different from the GUID file name with which you are developing the experience (that is, the GUID that appears in the Save As dialog box when you first save the file).
If your metadata package does not meet validation, you receive an error message and the build halts. For more information on error messages, see “Appendix C. Error Messages.”
For detailed specifics on locale in Windows 7 and Device Stage Visual Editor, see the “Windows 7 Device Stage Reference Guide,” which is part of the MDEDK.
[bookmark: _Toc267393153]Tools Menu
The Tools menu contains four commands:
Get Computer HWID
Create a GUID
Enter Test Mode
Exit Test Mode
[bookmark: _Toc267393154]Getting the Computer Hardware ID
Getting computer hardware IDs in Device Stage Visual Editor is required only for PC Device Stage experiences. It is not required for document devices, keyboards and mice, mobile broadband devices, portable devices, and smart card Device Stage experiences. Therefore,[image: ] is available only when you develop a PC Device Stage experience.
To get the computer hardware ID
1.	On the Tools menu, click Get Computer HWID, or click[image: ] on the toolbar.
2.	This process takes only a second or two. After you obtain the HWID, you receive the message that is shown in Figure 12.
[image: ]
[bookmark: _Ref262807949][bookmark: _Toc265423807]Figure 12. Computer hardware ID obtained successfully
3.	Click OK.
By default, and behind the scenes, Device Stage Visual Editor auto-runs ComputerHardwareIDs.exe (a command-line tool that is included with Device Stage Visual Editor) to obtain a computer hardware ID. It then reads the first computer hardware ID from the output. This default computer hardware ID is obtained when you click[image: ] on the toolbar.
In addition to obtaining and reading the first hardware ID from the output, ComputerHardwareIDs.exe lists a total of seven hardware ID GUIDs for the computer that are based on information from the system's System Management BIOS (SMBIOS). These computer hardware IDs represent the following: 
Manufacturer
Family
Product Name
Vendor
BIOS Version
System BIOS Major Release
Enclosure Type
You can obtain a specific computer hardware ID with which to identify your device metadata package rather than the default.
To get a specific computer hardware ID
1.	Click Start, and then type “cmd”.
2.	Right-click the cmd.exe application, and then select Run as administrator.
3.	Type the following at the command prompt:
...\resource\ComputerHardwareIds.exe
where “. . .” is the installation location of Device Stage Visual Editor on your computer.
4.	Press Enter.
5.	Manually copy the GUID that represents the computer hardware ID that you want to use, as shown in Figure 13.
[image: C:\Users\HEATHER\Documents\Microsoft\image001.png]
[bookmark: _Ref264982246][bookmark: _Toc265423808]Figure 13. Obtaining non-default computer hardware ID by using ComputerHardwareIDs.exe
6.	Paste the GUID into the String Collection Editor of the HardwareIDs field.
You can find more information on computer hardware IDs at:
http://msdn.microsoft.com/en-us/library/ff552325(VS.85).aspx
[bookmark: _Ref265659466][bookmark: _Toc267393155]Creating a GUID
The definitions of many unseen XML elements in Device Stage Visual Editor metadata packages require the use of GUIDs to decipher different device experiences and tasks. Each task has its own GUID in Device Stage Visual Editor.
Device Stage Visual Editor offers a built-in algorithm function that reliably produces a unique GUID number every time the function runs, as shown in Figure 14 and Figure 15.
Note that Device Stage Visual Editor auto-generates all GUIDs as you load default templates and add custom categories and tasks. You can use the Create a GUID tool for unique situations such as testing or replication when you want to force creation of a new GUID.
[image: ]
[bookmark: _Ref263253350][bookmark: _Toc265423809]Figure 14. Create a GUID dialog box
[image: ]
[bookmark: _Ref265669336]Figure 15. Create a GUID dialog box after clicking the New GUID button
To create a new GUID
1.	On the Tools menu, click Create a GUID.
2.	In the DS_GUID dialog box, click the New GUID button.
3.	Copy the generated number and paste it over the existing GUID in the target Category or Task ID field.
4.	Exit to close the DS_GUID dialog box, or click the New GUID button to create another GUID. Do this as often or as many times as is necessary.

Note  You should create a new GUID only for the ID fields in custom tasks and custom task categories. The GUIDs for the tasks or task categories in the required, template-based tasks for a given device category must remain unchanged.
[bookmark: _Toc267393156]Entering Test Mode
A device metadata package contains all necessary files to display the Device Stage experience in Windows 7. Before the Device Stage experience can run in Windows 7, Microsoft must sign the files.
Device Stage Visual Editor provides the functionality for you to set up a test environment to run preliminary tests on your metadata package. After you assemble your metadata package, you can start the Device Stage experience when your computer is in test mode.
To enter test mode 
1.	On the Tools menu, click Enter Test Mode.
You will be asked to restart your computer to activate test mode. 
2.	Restart your computer.
After you restart your computer, you can see that Device Stage Visual Editor is now running in test mode because of the Test Mode Windows 7 Build xxxx watermark in the lower-right corner of your desktop, as shown in Figure 16.
[image: ]
[bookmark: _Ref262823811][bookmark: _Toc265423810]Figure 16. Test mode Windows 7 build xxxx watermark
After you enable test mode, you can build a metadata package (which “creates” the final .cab file) and start the Device Stage experience.
Important Note  Your computer remains in test mode until you exit test mode and restart your computer.
Note  Windows 7 requires a Microsoft signature on Device Stage experiences. The goal is to ensure that the experience is well formed, that associated devices meet the functionality requirements, and that the Device Stage experience that you designed and developed is delivered to end users. If the computer is not in test mode, the Device Stage platform does not present Device Stage experiences that are unsigned or that have been altered after they were signed.
Testing the Device Stage Experience
To test the experience, plug in the device. Depending on the class of device for which you are developing, either you see an auto-run experience (for nomad devices such as portable media players or mobile phones) or you must double-click the device in the Devices and Printers window. Selecting the device from the Devices and Printers window is necessary for non-nomad devices such as keyboards, mice, or smart cards.
Note  When you work in Device Stage Visual Editor, you build the experience. Therefore, whether the device is connected to the computer is unimportant. You can connect the device to the computer after you build the package and it is stored in the metadata store.
You can debug installation problems with the metadata package by using Event Tracing for Windows (ETW) or the Problem Reports and Solution application.
For more information about how to install and debug the device metadata package, refer to “Device Metadata Package Pipeline” on the WHDC website.
For details on testing, see the MDEDK.
[bookmark: _Toc267393157]Exiting Test Mode
You can exit test mode at any time.
To exit test mode
1.	On the Tools menu, click Exit Test Mode.
You will be asked to restart your computer to deactivate test mode.
2.	Restart your computer.
After you restart your computer, you can see that Device Stage Visual Editor is no longer running in test mode because the Test Mode Windows 7 Build xxxx watermark in the lower-right corner of your desktop is gone, as shown in Figure 17.
[image: ]
[bookmark: _Ref263073815][bookmark: _Ref263073787][bookmark: _Toc265423811]Figure 17. Computer no longer in test mode because the Windows 7 build xxxx watermark is absent
Important Note  Your computer remains in test mode until you exit test mode and restart your computer.
[bookmark: _Toc267393158]Resources 
Reference Materials
WHDC website:
Windows Device Experience portal page 
http://www.microsoft.com/whdc/device/DeviceExperience/default.mspx
Device Metadata Package for Devices and Printers: Resource Roadmap
http://www.microsoft.com/whdc/device/DeviceExperience/DevPrint-Metadata_Over.mspx
Device Metadata Package Pipeline
http://www.microsoft.com/whdc/device/DeviceExperience/DevMetadataPkgPipe.mspx
Device Stage Additional Qualification Overview
http://www.microsoft.com/whdc/winlogo/device-stage.mspx
Devices and Printers - Extensibility Guide
http://www.microsoft.com/whdc/device/DeviceExperience/DevPrintFolder-Ext.mspx
Devices and Printers in Windows 7: Frequently Asked Questions
http://www.microsoft.com/whdc/device/deviceexperience/DevPrintFAQ.mspx
How to Create a Device Metadata Package for Devices and Printers
http://www.microsoft.com/whdc/device/DeviceExperience/CreateDevMetadataPkg.mspx
Multifunction Device Support and Device Container Groupings in Windows 7
http://www.microsoft.com/whdc/Device/DeviceExperience/ContainerIDs.mspx
Kits and Tools:
Device Stage Visual Editor, Version 1.0
http://www.microsoft.com/whdc/device/DeviceExperience/dsve.mspx  
Device Stage Marketing Guide
http://download.microsoft.com/download/7/E/7/7E7662CF-CBEA-470B-A97E-CE7CE0D98DC2/DeviceStage_MarketingGuide.pdf
Microsoft Device Experience Development Kit 7R2
http://www.microsoft.com/whdc/device/deviceexperience/dev-kit.mspx
MSDN:
Icons
http://msdn.microsoft.com/en-us/library/aa511280.aspx
Device Metadata Packages (Windows Driver Kit)
http://msdn.microsoft.com/en-us/library/ff541439(v=VS.85).aspx
Windows Logo Program:
Getting Started with the Windows Logo Program
http://www.microsoft.com/whdc/winlogo/getstart/default.mspx
Prepared Requirements Reports
https://winqual.microsoft.com/member/LogoPoint/Requirements/PreparedRequirementReport.aspx
Windows Quality Online Services (Winqual)
https://winqual.microsoft.com/
Winqual Device Metadata Submissions for PC Devices
https://winqual.microsoft.com/help/WinQual_Device_Metadata_Submissions_for_PC_Devices.xps

Microsoft Device Experience Development Kit 
Following is the list of documents and resources included with the Microsoft Device Experience Development Kit.
Windows 7 Device Stage Design Guide
How to create Device Stage experiences that reflect your company’s corporate and product brand. Includes design best practices.
Windows 7 Device Stage Development Guide
An overview of the Device Stage development process with common steps you need to know to create a Device Stage experience.
Windows 7 Device Stage Reference Guide
Reference guide for developing and assembling Device Stage experiences, including advanced development topics.
Windows 7 Device Stage XML Schemas
Schema files useful for editing Device Stage experience XML files.
Windows 7 Device Stage Development Samples
A collection of sample graphics and tools to help with developing Device Stage experiences.
Windows 7 Device Stage xxxx xxx Device Class Development Guide
One document for each supported device with detailed topics on how to identify a device, add compatible tasks, and other advanced development topics.
Windows 7 Device Stage xxxx xxx Device Planning Worksheet
One planning worksheet for each supported device listing required and optional values needed when planning and building a Device Stage experience.
Devices Tutorials
A set of step-by-step guides for each supported device on how to edit templates to create a custom Device Stage experience for a new device.
xxxx xxx Devices Development Samples
A Device Stage Visual Editor template for each currently supported device.
MICROSOFT LICENSE TERMS
The license terms agreement between Microsoft Corporation and you.
Microsoft Device Experience Development Kit Readme
A basic introduction and summary of kit contents, new components, and revision history.

Note  Documents in the Microsoft Device Experience Development Kit are saved in the .docx format. Microsoft Word 2007 is required to open the files. Files that are saved in .docx format can also be opened in some previous versions of Word by using a conversion tool. For more information, see http://office.microsoft.com/en-us/word/HA100444731033.aspx.
[bookmark: _Toc267393159]Appendix A. Glossary
cabinet file
A file that stores multiple compressed files in a file library. The cabinet format is an efficient way to package and distribute files.
device metadata cache
The folder and path into which the DMRC caches the unpacked device metadata package: %localappdata%\Local\Microsoft\Device Metadata\.
device metadata store
The folder and path into which Device Stage Visual Editor saves a built device metadata package: %programdata%\Microsoft\Windows\DeviceMetadataStore\.
DMRC
Device Metadata Retrieval Client. The DMRC manages the device metadata operation in Windows 7.
GUID
globally unique identifier. A GUID is a 128-bit integer (16 bytes) that can be used across all computers and networks wherever a unique identifier is required.
IHV
independent hardware vendors. A company that manufacturers or sells hardware that is specifically related to electronics or computers.
MDEDK
The Microsoft Device Experience Development Kit. This kit provides the information and materials that you need to develop Device Stage experiences for supported devices.
multifunction device
A device that occupies one device location on its bus but contains more than one functional unit. Each unit corresponds to a driver (or set of drivers that together service the unit). Examples of multifunction devices include modem/network adapters, combination audio/game ports, and so on.
nomad device
Portable devices that are with you on-the-go and can be connected to a computer to download, upload, copy, and transfer images, music, and files. Nomad devices include mobile phones, media players, and digital cameras.
WHDC
Windows Hardware Developer Central. This Microsoft resource is a website for system designers, driver developers, and test engineers.
Winqual
Windows Quality Online Services. A website that enables partners to qualify hardware devices and software applications for the Microsoft Logo Program. They can then provide information about their products on the Windows Product Listing sites and update their driver distribution settings on Windows Update, retrieve end-user crash data, and submit device metadata packages.
WMIS
Windows Metadata and Internet Services. The service that delivers the device metadata packages that partners submit to the Winqual website over the Internet.
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This appendix shows all device property metadata fields, their content description, whether they are required or optional, and references to associated documentation that has technical details (which includes element type metadata for manually modifying the XML source).
Table B-1. Device Fields
	Field
	Description
	Required/ optional
	Associated documents1

	Category
	Functional categories that apply to the device.
	Required
	How to Create a Device Metadata Package for Devices and Printers

	DeviceDescription1
	Descriptive information about the device. Should be a concise, useful description of the physical device.
	Optional
	How to Create a Device Metadata Package for Devices and Printers

	DeviceDescription2
	Additional descriptive information about the device.
	Optional
	How to Create a Device Metadata Package for Devices and Printers

	ExperienceID
	GUID that Microsoft manages. This GUID is used to group one or more metadata packages for the same device identifiers independent of the packages’ locale.
	Optional2
	How to Create a Device Metadata Package for Devices and Printers

	HardwareIDs
	One or more hardware IDs for the device.
	Optional3
	How to Create a Device Metadata Package for Devices and Printers
Windows 7 Device Stage Development Guide

	Icon
	Name of the device icon file in the device metadata package.
	Optional
	How to Create a Device Metadata Package for Devices and Printers
“Icons” on the MSDN® website
Windows 7 Device Stage Design Guide

	LastModifiedDate
	Date/time that the device metadata package was last changed.
	Required
	How to Create a Device Metadata Package for Devices and Printers

	LocaleDefault
	Declared locale of the device metadata package.
	Required
	How to Create a Device Metadata Package for Devices and Printers
Windows 7 Device Stage Reference Guide

	LocaleLanguage
	Default locale of the resident computer.
	Required
	How to Create a Device Metadata Package for Devices and Printers
Windows 7 Device Stage Reference Guide

	Manufacturer
	Name of the device manufacturer. For example, in the case of the Fabrikam mFab 1000, this would be “Fabrikam”.
	Required
	How to Create a Device Metadata Package for Devices and Printers

	ModelIDs
	List of one or more model IDs that the device metadata package supports. Each model ID specifies a device type or model.
	Optional3
	How to Create a Device Metadata Package for Devices and Printers

	ModelName
	Model name of the device. It should not include the manufacturer name or version of the device. For example, “mFab” should be used instead of “Fabrikam mFab 1000”.
	Required
	How to Create a Device Metadata Package for Devices and Printers

	ModelNumber
	Model or part number of the device as the manufacturer defines it.
	Optional
	How to Create a Device Metadata Package for Devices and Printers

	 “Windows 7 Device Stage Document Devices Tutorial Worksheet,” which is installed with the development kit on your computer. The kit can be found on the WHDC website.
2 Winqual sets and manages this element when the device metadata package is submitted for distribution.
3 Either HardwareID or ModelID must be specified.



Table B-2. Device BrandingHeader Fields
	Field
	Description
	Required/ optional
	Associated documents1

	BackgroundColor
	Background color of the branding bar. Use this attribute to control the color of the branding bar if no file is provided in BackgroundImage.
	Required
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	BackgroundImage
	File name to use as a “Background” graphic in the branding bar.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	DeviceImage
	Graphic filename to use as the device “hero” image in the branding bar and taskbar.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	LauncherThumbnail
	Thumbnail image that represents the device that starts a Device Stage experience when the image is clicked (nomad devices only).
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	LogosSplit
	General layout of the logo area, as well as how it should behave when it is resized in mini-mode.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	MarketingBullets
	Up to three brief descriptions of device capabilities that enable manufacturers to showcase key features.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	TextColor
	Color of text that is used to display marketing bullets, status, and the device name and model in the branding bar.
	Required
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	WatermarkAlignment
	How the watermark is positioned in the branding bar. The watermark may be aligned right, left, or center.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	WatermarkImage
	File name to use as the ‘Watermark Overly” graphic in the branding bar.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	 “Windows 7 Device Stage Document Devices Tutorial Worksheet,” which is installed with the development kit on your computer. The kit can be found on the WHDC website.



Table B-3. Device BrandingHeader PrimaryLogo1 Fields
	Field
	Description
	Required/ optional
	Associated documents2

	Halign
	Horizontal alignment for the logo in the branding bar. The default value is “Center”.
	Optional
	Windows 7 Device Stage Reference Guide

	Image
	Primary brand logo that appears in the Device Stage Visual Editor branding bar.
	Required
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	ToolTip
	String to appear as a tooltip when the user moves the pointer over the logo.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	URL
	Website to open if the user clicks the logo.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	Valign
	Vertical alignment for the logo in the branding bar. The default value is “Center”.
	Optional
	Windows 7 Device Stage Reference Guide

	1 The primary category refers to the primary function of a multifunction device. The primary category should be consistent with how the device is marketed and sold, and ultimately how most users identify the device. For example, the primary category for the multifunction printer is typically “printer”.
2 “Windows 7 Device Stage Document Devices Tutorial Worksheet,” which is installed with the development kit on your computer. The kit can be found on the WHDC website.



Table B-4. Device BrandingHeader SecondaryLogo Fields
	Field
	Description
	Required/ optional
	Associated documents1

	Halign
	Horizontal alignment for the logo in the branding bar. The default value is “Center”.
	Optional
	Windows 7 Device Stage Reference Guide

	Image
	Secondary brand logo that appears in the Device Stage Visual Editor branding bar.
	Optional
	Windows 7 Device Stage Design Guide
Windows 7 Device Stage 
Development Guide

	ToolTip
	String to appear as a tooltip when the user moves the pointer over the logo.
	Optional
	Windows 7 Device Stage Development Guide

	URL
	Website to open if the user clicks the logo.
	Optional
	Windows 7 Device Stage Development Guide

	Valign
	Vertical alignment for the logo in the branding bar. The default value is “Center”.
	Optional
	Windows 7 Device Stage Reference Guide

	 “Windows 7 Device Stage Document Devices Tutorial Worksheet, which is installed with the development kit on your computer. The kit can be found on the WHDC website.



Table B-5. Device TaskViewAppearance Fields
	Field
	Description
	Required/ optional
	Associated documents1

	BackgroundColor
	Background color of the task and category area.
	Optional
	Windows 7 Device Stage Development Guide

	DescriptionColor
	Color of the task and category descriptions.
	Optional
	Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	FrameColor
	Color of the single-pixel dividing line between the branding bar and the task and category area.
	Optional
	Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	TextColor
	Color of the task and the category titles.
	Optional
	Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	 “Windows 7 Device Stage Document Devices Tutorial Worksheet, which is installed with the development kit on your computer. The kit can be found on the WHDC website.



Table B-6. Category TaskCategoryMapping Task Fields
	Field
	Description
	Required/ optional
	Associated documents1

	CommandLine
	Path to the functionality of a particular task in the device metadata package. It depends on the TaskType for the URL or the Windows path. Command-line arguments should be executed when the task is begun.
	Required
	Windows 7 Device Stage Reference Guide

	Description
	Descriptive information about the task.
	Required
	Windows 7 Device Stage Design Guide

	DisplayName
	Task name for display.
	Required
	Windows 7 Device Stage Reference Guide

	Icon
	File name of the device icon (.ico file) that appears in the device experience and on the taskbar.
	Required
	How to Create a Device Metadata Package for Devices and Printers
“Icons” on the MSDN website
Windows 7 Device Stage Design Guide

	ID
	Unique GUID that is used to define the category.
	Required
	Windows 7 Device Stage Reference Guide

	IssueTime
	Time at which a task is issued. If no IssueTime exists, then the time at which the task is installed is assumed to be IssueTime.
	Optional
	Windows 7 Device Stage Reference Guide

	Rank
	Value that is used in conjunction with the task execution count to determine UI display order.
	Optional
	Windows 7 Device Stage Reference Guide

	Requirements
	Requirements that must be met for the task to appear. They are evaluated in order and all must pass for the task to appear.
	Optional
	Windows 7 Device Stage Reference Guide

	RequiresElevation
	Indication that the task requires elevation to run.
	Optional
	Windows 7 Device Stage Reference Guide

	TaskType
	Choose from four options:
ShellExecute (default)
HostedSite
HostedSiteWithDevice
InPanelLayout
	Required
	Windows 7 Device Stage Development Guide
Windows 7 Device Stage Reference Guide

	 “Windows 7 Device Stage Document Devices Tutorial Worksheet, which is installed with the development kit on your computer. The kit can be found on the WHDC website.
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The following are tool error messages, their cause, and their resolution. The errors are in no particular order.
Error

[image: ]
Cause
You receive this error message if you build your metadata package before you enter test mode. Note that you can save your metadata package without being in test mode.
Resolution
Enter test mode. On the Tools menu, click Enter Test Mode. We recommend that you enter test mode when you first open a session of Device Stage Visual Editor.
Error

[image: ]
Cause
This error message refers to the incorrect format in the Raw XML Editor of the Requirement field for a custom task.
Resolution
Correct the XML text. If you do not know how to proceed, refer to the field content of the same field in a non-custom, template-based task.


Error

[image: ]
Cause
If you add a category or task and then try to build or save it before you have filled in all the required metadata fields with valid data, this error message appears and identifies the first field that has no data that Device Stage Visual Editor detects. Device Stage Visual Editor does not let you save a metadata package that is missing required information.
Resolution
Before you build or save your metadata package, make sure all the required fields have valid content.
Error
[image: ]
Cause
You can delete only custom added categories and tasks. You cannot delete default categories and tasks in any Device Stage Visual Editor templates because Microsoft requires them for operating system continuity that targets common device functionality.
Resolution
Do not try to delete template-based categories and tasks.


Error

[image: ]


[image: ]
Cause
When you attempted to add a task or category, you clicked your mouse or touchscreen pointer on something other than the TaskCategoryMapping element in the Device Experience pane.
Resolution
To add a new task or category, you must click your mouse or touchscreen pointer on the TaskCategoryMapping element in the Device Experience pane.

The only instance when clicking the TaskCategoryMapping element is unnecessary is when you want to add one or more subtasks under a custom category. In this scenario, you click the custom category under which you want to add one or more subtasks, and then click on the toolbar.
Error
[image: ]
Cause
You entered test mode but did not restart your computer before you tried to build your metadata package.
Resolution
Restart your computer to activate test mode.

Error

[image: ]
Cause
You tried to exit test mode a second time but did not restart your computer the first time you exited test mode.
Resolution
Restart your computer to deactivate test mode.

Error
[image: ]
Cause
You tried to save your metadata package but Device Stage Visual Editor detected that the file you selected for the Properties Icon field is not an .ico file.
Resolution
Add an .ico file to the Properties Icon field and then save your metadata package.

Error
[image: ]
Cause
You receive this error message if you use Save As… to save your metadata package under a file name other than the default GUID or an alternate GUID you generate using the Create a GUID tool.
Resolution
If you want to save your metadata package under a name other than its default GUID, generate a new GUID using the Create a GUID tool and paste it in the SaveAs… dialog box. For details, see “Creating a GUID” earlier in this guide.
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You must be in test mode to test a metadata package. Click Tools >
Enter Test Mode. You will be asked to restart your computer.
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