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Microsoft Office Visio 2007 Overview

Whether you are new to Microsoft® Office Visio® 2007 drawing and diagramming software, evaluating it, or upgrading to it, this product guide helps you in the following ways:

· Demonstrates key benefits. Demonstrates how Microsoft Office Visio 2007 can help solve some of the problems that IT and business professionals typically encounter when trying to visualize, explore, and effectively communicate complex information. 

· Highlights three typical scenarios. Highlights how Microsoft Office Visio 2007 helps solve the specific problems encountered when, for example, documenting and designing a company’s network infrastructure, meeting Sarbanes-Oxley (SOX) compliance requirements, or identifying the sources of waste and bottlenecks in a company’s production process.

· Introduces new and enhanced features. Briefly introduces you to some of the most important new and enhanced features in Microsoft Office Visio 2007, such as new Data Link functionality and a new diagram type called PivotDiagram. The features discussed in this guide are integral to visualizing, exploring, and effectively communicating information. 

Note: For comprehensive information about new and enhanced features, go to the Help menu and click Microsoft Office Visio Help.

· Provides additional resources. Provides information about the system requirements for Microsoft Office Visio 2007 and online locations where you can find additional information.

Microsoft Office Visio 2007 makes it easy for IT and business professionals to visualize, explore, and communicate complex information. Go from complicated text and tables that are hard to understand to Visio diagrams that communicate information at a glance. Instead of static pictures, create data-connected Visio diagrams that display data, are easy to refresh, and dramatically increase your productivity. Use the wide variety of diagrams in Office Visio 2007 to understand, act on, and share information about organizational systems, resources, and processes throughout your enterprise. For example, you can create diagrams to analyze business data; streamline business processes; schedule projects; visualize thought processes; chart your organization; and visualize your network infrastructures, floor plans, facilities equipment, electrical circuits, software systems, and database structures.
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Figure 1: With Microsoft Office Visio 2007, you can create a wide range of diagrams using templates, shapes, and drawing tools while working in a familiar Microsoft environment.

Office Visio 2007 is available in two stand-alone editions: Office Visio Professional and Office Visio Standard, which has the same basic functionality as Visio Professional, but is a subset of its features and templates. Office Visio Professional includes advanced functionality, such as data connectivity and visualization features, that Office Visio Standard does not.

Key Benefits of Using Microsoft Office Visio 2007
The three scenarios in this section highlight the key benefits of using Microsoft Office Visio 2007: 

· Visualize complex information to better understand it.

· Explore information to identify key trends and insights and act on them.

· Communicate using diagrams that can be shared with a broad audience. 

Office Visio 2007 in Action
An IT Manager at rapidly growing Contoso Corporation needs to visually document and design the company’s network infrastructure in a way that best supports the company’s changing business needs. 

The IT Manager faces the following challenges in this situation:
· Difficult to manage the deployment and upgrade of devices when resources are limited.

· Limited understanding of relevant network information in multiple systems.

· Difficult to parse through volumes of data to highlight key device-related information.

· Difficult to track changes in the network environment.

Microsoft Office Visio 2007 provides the following solutions and benefits to this IT Manager:

· Easy to manage new initiatives by using an intuitive visual reference to track information.
· Easy to access network information stored in multiple systems by integrating data with diagrams.

· Easy to display key information by using rich conditional formatting capabilities.

· Access to up-to-date information when using scheduled data refresh.
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Figure 2: Easily visualize complex information with a wide range of Visio diagrams. Make those diagrams even smarter and more useful by linking them to underlying data, which provides a more complete picture of the system or process.
Office Visio 2007 in Action

In six months, Contoso Corporation plans to establish itself as a public company. During that time, the Director of Finance needs to meet Sarbanes-Oxley (SOX) compliance requirements and effectively manage the related financial information.

The Director of Finance faces the following challenges in this situation:

· Challenging to manage compliance risks that include the appropriate controls without an understanding of relevant information stored in multiple systems.

· Difficult to parse volumes of data to identify areas of concern and implement the appropriate controls.

· Limited ability to track the ongoing progress of compliance activities.

Microsoft Office Visio 2007 provides the following solutions and benefits to the Director of Finance:

· Easier to manage complex compliance information with an intuitive visual reference. 

· Dynamic capability to visually explore and analyze information with multiple views. 

· Intuitive progress tracking with rich icons and data bars that highlight key trends, exceptions, and insights. 
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Figure 3: Using PivotDiagrams, visually explore complex information to identify key trends, exceptions, and gain insights. Take Office Visio 2007 even further by analyzing, drilling down into, and creating multiple views of business data for better business insight.
Office Visio 2007 in Action
A Quality Manager at Fabrikam Corporation needs to identify sources of waste and bottlenecks in the company’s production process to efficiently implement a Lean manufacturing initiative.

The Quality Manager faces the following challenges in this situation:

· Difficult to share complex manufacturing processes information with laypeople in an easily understandable way.

· Difficult to highlight the source of a problem due to the volume of data.

· Challenging to collaborate on information captured in paper form.

· Challenging to share information with others, especially people who do not use Office Visio 2007.

Microsoft Office Visio 2007 provides the following solutions and benefits to this quality manager:

· Easy for laypeople to visualize complex manufacturing processes and the relevant information with a value stream map. 

· Easy to flag areas of concern such as long lag times between processes.

· Easy to collaborate on diagrams by using diagram revisions and Microsoft Office SharePoint® Server 2007 Web sites.

· Easy to communicate information to a broad audience in multiple file formats and by publishing diagrams to the Web.
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Figure 4: Communicate effectively with Office Visio 2007 diagrams to maximize the impact on your audience in ways that you cannot when using words and numbers alone. Share professional-looking Office Visio 2007 diagrams with anyone, even those who do not have Office Visio 2007.
Visualize Complex Information to Better Understand It
Using Microsoft Office Visio 2007, you can visualize complex information to better understand it by using a wide range of diagrams—business process flowcharts, network diagrams, work flow diagrams, database models, and software diagrams, to name just a few. 
Get Started Quickly with Templates
You begin an Office Visio 2007 diagram with a template. Template files open a drawing page and a Shapes window that contains stencils from which you drag shapes onto the page to create your diagram. A template also includes the styles, tools, and other settings appropriate for the diagram type. For example, to create a basic flowchart, open the Basic Flowchart template, which includes flowchart shapes and arrowhead line styles appropriate for many types of flowcharts. Then drag flowchart shapes from the stencils in the Shapes window onto the drawing page to create the flowchart. 

Find just the right template to fit your needs in Microsoft Office Visio 2007 by using the simplified diagram categories, such as Basic, Business, Flowchart, Network, or Schedule. Easily access the templates you use often and open a variety of sample diagrams to get ideas for creating your own diagrams. You can also create a broader range of diagrams in Microsoft Office Visio 2007 with new templates, such as the PivotDiagram and Value Stream Map templates. Create more dynamic workflows with new 3-D Workflow shapes that open with stencils in the Workflow Diagram template. 

Open a template

1. Start Office Visio 2007. 
2. On the File menu, point to New, and then click Getting Started.

3. In the Getting Started window that appears, under Template Categories, click a category to view the templates in the category.

4. Double-click a template thumbnail to open the template.

Begin a diagram by opening a template you used recently
5. Start Office Visio 2007. 
6. On the File menu, point to New, and then click Getting Started.

7. In the Getting Started window that appears, under Recent Templates, double-click a template to open it.

Note: If you just acquired Microsoft Office Visio 2007, the Recent Templates list might be empty, because you have not opened any templates yet. After you open a template, Office Visio 2007 adds it to the Recent Templates list. 

Open a sample diagram

8. Start Office Visio 2007. 
9. On the File menu, point to New, and then click Getting Started.

10. In the Getting Started window that appears, under Template Categories, click Samples to view the sample diagrams.

11. Double-click a sample diagram to open the diagram.

Tip: You can simply view sample diagrams to get ideas, or you can modify and save them as your own custom diagrams. If you modify a sample diagram, save it with a different file name so that you do not overwrite the sample diagram with your modifications.

Connect Shapes Without Drawing Connectors

Diagrams such as flowcharts, organization charts, block diagrams, network diagrams, and Web diagrams that you can create in Microsoft Office Visio 2007 all have one thing in common: connections. In Office Visio 2007, you create these connections by attaching, or gluing, one-dimensional shapes called connectors to two-dimensional shapes. Then, when you move the connected shapes, the connectors stay glued to the shapes. For example, when you move a flowchart shape, the connector automatically repositions itself to keep its endpoints glued to the shape.

New AutoConnect functionality in the 2007 Microsoft Office system takes all the work out of connecting shapes. This new functionality automatically connects, evenly distributes, and aligns shapes for you—with only a couple easy clicks.
AutoConnect works with the following three new methods for connecting shapes. The method you choose depends on your work style preference and the state of your diagram:

· Connect shapes as you drag them onto the drawing page. 
Use this method when you want to automatically connect shapes as you drag new shapes from the Shapes window onto the drawing page. You can use this method no matter what the state of your diagram—new with no shapes on the drawing page or in progress with shapes on the drawing page.
· Connect shapes as you click a shape on a stencil in the Shapes window.
Use this method when you want to automatically connect a new shape on a stencil to a shape that is already on the drawing page without dragging the new shape onto the drawing page. When you use this method, Office Visio 2007 automatically adds the shape you click on the stencil to the drawing page for you. You can use this method when your diagram already has one or more shapes on the drawing page.
· Connect shapes that are already on the drawing page.
Use this method when the shapes you want to automatically connect are already on the drawing page in your diagram. Using this method, you can just click the shapes you want to connect instead of drawing connectors between them.
Connect shapes as you drag them onto the drawing page

12. Drag a shape from a stencil in the Shapes window onto the drawing page and position it above, below, or on either side of the shape to which you want to connect.

Blue triangles appear around the shape to which you want to connect. These triangles represent the locations where you can automatically connect the two shapes.

13. While still holding down the mouse button, move the pointer over one of the blue triangles that appear on the shape to which you want to connect. The triangle underneath the pointer turns dark blue, which means that Office Visio 2007 is ready to connect the two shapes in that location.

14. Release the mouse button. Office Visio 2007 adds the shape that you dragged from the stencil in the Shapes window to the drawing page, and then automatically connects, aligns, and evenly distributes both shapes on the drawing page.
Tip: To view a demonstration of this type of AutoConnect procedure, see the Visio home page.
Connect shapes as you click a shape on a stencil in the Shapes window

15. Click the shape on the stencil in the Shapes window that you want to connect to a shape that is already on the drawing page.

16. Pause the pointer over the shape on the drawing page to which you want to connect the shape on the stencil. Blue triangles appear around the shape on the drawing page.
17. Click the blue triangle that is in the location where you want to connect the shapes.

Office Visio 2007 adds the shape that you selected from the stencil in the Shapes window to the drawing page, and then automatically connects, aligns, and evenly distributes both shapes.

Connect shapes that are already on the drawing page

18. Make sure there are not any shapes selected in the stencil that is showing in the Shapes window. To ensure this, click inside the stencil that is showing, and then press the Esc key.

Note: If a shape is selected, Office Visio 2007 adds the shape to the drawing page and connects it with the shape that you pause the pointer over in step 2.

19. Pause the pointer over the shape from which you want to connect.

One or more blue triangles appear around the shape on the drawing page.
Note: If a blue triangle does not appear on the shape from which you want to connect, the shape may be too far away. Move the shape closer and try again. Or, depending on the location of the shapes and number of shapes on the drawing page, it might be more appropriate to use the Connector tool to connect the two shapes.

20. Position the pointer over the blue triangle that is closest to the shape to which you want to connect. The triangle turns dark blue, and a red box appears around the shape to which you want to connect. These visual cues signify that Office Visio 2007 is ready to connect the shapes.

Note: If a red box does not appear around the shape you want to connect to, the shape may be too far away. Move the shape closer and try again. Or, depending on the location of the shapes and number of shapes on the drawing page, it might be more appropriate to use the Connector tool to connect the two shapes. 

21. Click the blue triangle. Office Visio 2007 automatically connects the two shapes.

Explore Information to Identify Trends and Issues and Act on Them
By using Microsoft Office Visio 2007, you can visually explore, analyze, drill down into, and create multiple views of business data to gain deeper insight into the information. Easily identify key issues, track trends, and flag exceptions using a library of shapes that are designed specifically for visually tracking data. 
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Figure 5: Link diagrams to underlying data to provide a more complete picture of the system, project, or process.
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Easily Connect Data to Diagrams and Link Data to Shapes

Integrating data with Office Visio 2007 diagrams has always been one of the most powerful and useful features in Office Visio 2007. Microsoft Office Visio 2007 takes data connectivity even further by making it much easier and faster to connect a data source to any diagram—such as a flowchart, organization chart, network diagram, or facilities management diagram—created with any version of Office Visio 2007. Automatically connect diagrams to data sources, such as worksheets in Microsoft Office Excel® 2007 and databases in Microsoft Office Access 2007 by using the new Data Selector wizard. 
You can even link diagrams to more than one data source. For example, you might have a worksheet that you want link to the employee shapes in a diagram, and a database table you want to link to the equipment shapes in the same diagram so that you can demonstrate the ratio of employees to equipment.

Connect a diagram to a data source

22. On the Data menu, click Import Data into Shapes.
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The Data Selector wizard starts.
23. On the first screen of the Data Selector wizard, choose the type of data source you want to use: 

· Excel workbook 

· Access database 

· SharePoint list 

· Microsoft SQL Server™ database 

· Other OLE Database (OLE DB) or Open Database Connectivity (ODBC) data source 

· Previously created connection

24. Follow the remaining steps in the Data Selector wizard. 

After you click Finish on the last page of the Data Selector wizard, the data from the data source appears in a grid in the External Data window.
Link a diagram to multiple data sources

25. Right-click any tab at the bottom of the External Data window, and then click Add. 

26. Follow the steps in the Data Selector wizard. The new data source appears on a new tab in the External Data window, and the data appears in a grid in the window.
After you connect a diagram to a data source, the next step in integrating data with a diagram is linking the shapes in the diagram to data in the data source so that the data for each shape appears on the drawing page. Save time associating data with shapes by using any of the following intuitive linking methods in Microsoft Office Visio 2007: 

· Automatically link data to all the shapes in a diagram. 
It is best to use this method when you are working with existing diagrams that contain a large number of shapes. This method only works when the shapes already have custom properties (or shape data) that you can match to data in the data source.

· Link rows of data to existing shapes one at a time. 
It is best to use this method when you are working with existing diagrams that contain relatively few shapes.

· Automatically create shapes that are linked to rows of data. 
It is best to use this method when you are working with new or existing diagrams that do not already have shapes on the drawing page and when you do not need to use specific shapes.
Note: When you link data to shapes in a diagram, Office Visio 2007 automatically populates the properties (also known as shape data) for each shape with its corresponding data. To see all the properties for a shape and corresponding data values, right-click a shape on the drawing page, and then, on the shortcut menu, click Properties. Or, on the View menu, click Shape Data Window to display the window. Then click a shape to see its shape data in the Shape Data window.
Automatically link data to all the shapes in a diagram

27. On the Data menu, click Automatically Link. 
[image: image8.png]Automatic Link - Sheet1

Automatically link rows to shapes

The Automatic ik Wizard allows you to quickly Ik rows of data to shapes i your
diagram F existing values i the shape equal values in the row.

Tnant o automaticaly Ik o
@Belecizd Fapes)

Ol shapes o th page





The Automatic Link wizard starts.
28. Follow the steps in the Automatic Link wizard. 

Office Visio 2007 links data from the data source to all the shapes in the diagram and displays the data for each shape on the drawing page.
Link rows of data to existing shapes one at a time 

· Drag a row of data from the External Data window onto a shape in the diagram. 

Tip: If you cannot see the External Data window, on the View menu, click External Data Window.
Office Visio 2007 displays the data for each shape on the drawing page.
Automatically create shapes that are linked to rows of data

29. Click the shape on the stencil in the Shapes window that you want to add to the diagram when you drag rows of data onto the drawing page. 

30. Drag one or more rows from the External Data window onto the drawing page. 

Tip: To select more than one row of data, hold down the Shift or Ctrl key while you click the rows of data. One instance of the shape you clicked on the stencil in the Shapes window appears for each row you dragged onto the drawing page. Office Visio 2007 displays the data for each shape on the drawing page.
Display Data Attractively in Diagrams
When you link data to shapes, Office Visio 2007 displays the data on the drawing page using a default data graphic—a shape designed specifically for viewing data in diagrams. Viewing the data on the drawing page with shapes means you can more easily visualize and understand the data. In addition, you can see the data when you print your diagram and incorporate it into other documents and presentations, such as those created in Microsoft Office Word 2007 and the Microsoft Office PowerPoint® 2007 presentation graphics program.
You can also easily change the default graphic used to display the data in the diagram. With the new Data Graphics task pane, you can choose from a number of data formatting options or create your own data graphics. For example, display data fields as callouts, text, data bars, or icons and use color-coding to identify trends and issues.  
Modify the data graphic already applied to shapes in a diagram

31. In the Data Graphics task pane, pause the pointer over the data graphic that is applied to the diagram or the one you want to modify, click the arrow that appears next to the data graphic, and then, on the menu that appears, click Edit. 

Tip: If you cannot see the Data Graphics task pane, on the View menu, click Task Pane. Then, in the title bar of the task pane, click Data Graphics.
32. In the Edit Data Graphic dialog box, select the options you want, and then click OK.
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Office Visio 2007 updates the data graphic in the diagram.
Create a new data graphic

33. In the Data Graphics task pane, click New Data Graphic. 

[image: image10.png]New Data Graphic

[Em] e Xooes  +

Data Field Displayed as Posiion

Defe postion Dipleycptens
oronea | O ar e [l showborderaround kems t defauk posion
[l shape text when data graphicis sppled

vertical; & Mdde





Tip: If you cannot see the Data Graphics task pane, on the View menu, click Task Pane. Then, in the title bar of the task pane, click Data Graphics. 
34. In the New Data Graphic dialog box, click New Item, and then, in the menu that appears, click the type of data graphic you want to create.
35. In the dialog box that appears, choose the formatting and conditions you want to apply to the data, and then click OK.

36. In the New Data Graphic dialog box, click OK.

The new data graphic appears in the Data Graphics task pane.

37. Select the shapes in the diagram that you want to apply the data graphic to, and then click the new data graphic in the Data Graphics task pane.

The new data graphic appears with the shapes you select.

Apply a new data graphic to one or more shapes in a diagram

38. Select one or more shapes that are linked to data in the diagram.

Tip: To select more than one shape, hold down the Shift or Ctrl key while you click the shapes. To select all the shapes in a diagram, on the Edit menu, click Select All.

39. In the Data Graphics task pane, click the data graphic you want to apply to the shapes.

Office Visio 2007 applies the data graphic to the selected shapes.
Easily Refresh Data in Diagrams 

The new Refresh Data feature in Microsoft Office Visio 2007 automatically refreshes all the data in your diagrams so that you do not have to do it manually. If data conflicts arise, easily resolve them by using the Refresh Conflicts task pane.

Refresh data sources connected to a diagram

40. On the Data menu, click Refresh Data.
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41. In the Refresh Data dialog box, click the data source you want to update, and then click Refresh.

Data changes are shown in the External Data window, and shapes that are linked to data reflect any changes. 
Tip: You can also schedule data refreshes to occur at regular intervals by clicking Configure in this dialog box, and then specifying the interval under Automatic Refresh.
Data conflicts arise if rows of data have been deleted or cannot be uniquely identified. If data conflicts arise, the Refresh Conflicts task pane appears. 

42. If the Refresh Conflicts task pane appears, choose from various options to resolve the conflicts.

Note: If rows of data have been deleted, you can choose to delete the shapes that were linked to the rows. For rows of data that cannot be uniquely identified, you can choose to link the unlinked shape to a new row in the data source or leave the shape as is—without a link to data.

Visualize and Explore Business Data

Explore business data that is normally shown in static text and tables by using a new diagram type in Microsoft Office Visio 2007—PivotDiagram, which is a collection of shapes arranged in a tree structure that helps you analyze and summarize data in a visual, easy-to-understand format. To create a PivotDiagram, open the PivotDiagram template to start the Data Selector wizard. The wizard guides you through connecting the diagram to a data source. As the wizard finishes, it creates a top (or root) node, called the Pivot Node, that is linked to all the data in the data source and places the node on the drawing page. You can then expand the Pivot Node to show various levels of sub-nodes that correspond to the data you want to analyze.
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Figure 6: Explore complex information and track the state of data using the new PivotDiagram template, shapes, and functionality in Microsoft Office Visio Professional 2007. Pivot Node shows various levels of sub-nodes that correspond to the data you want to analyze.
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Tip: Categories in a PivotDiagram correspond to columns or levels in the data source that contain data, which may include values that cannot be totaled. PivotDiagrams generated from Excel worksheets are much easier for everyone to understand if the top cell in each column in the Excel worksheet is a column heading rather than a row of data. If the top cell in a worksheet column isn’t a column heading, then the title for each category corresponding to a column in the PivotDiagram will include indecipherable text that only the person who created the worksheet understands.

Create a PivotDiagram

43. On the File menu, point to New, point to Business, and then click PivotDiagram. 

44. On the first screen of the Data Selector wizard, choose the type of data source you want to use:

· Excel workbook 

· Access database 

· SharePoint Server list 

· SQL Server database 

· SQL Server Analysis Services 

· Other OLEDB or ODBC data source

45. Follow the steps in the Data Selector wizard. After you click Finish, the following three shapes appear on the drawing page: 

· A data legend containing information about the data source 

· A text box that contains the name of the PivotDiagram

· The Pivot Node, which contains the imported data from the data source 

46. Click the Pivot Node on the drawing page, and then, in the PivotDiagram window, under Add Category, click the category by which you want to group the data under the Pivot Node. 
47. To further expand the new sub-nodes and expose more levels, click the sub-node you want to expand, and then add more categories:

In the PivotDiagram window, under Add Category, click the category you want to add to the diagram.

48. In the PivotDiagram window, under Add Total, click the data you want to total or summarize in the diagram. 

Tip: You may need to maximize or simply increase the height of the PivotDiagram window to easily see all of the options. You can also use the PivotDiagram menu or toolbar to arrange the shapes in the diagram.
You can also insert a PivotDiagram into any Visio diagram.

Insert a PivotDiagram into an existing Visio diagram

49. Open the diagram into which you want to insert a PivotDiagram. 

50. On the Data menu, click Insert PivotDiagram.

51. Follow the steps in the Data Selector wizard. After you click Finish, the following three shapes appear on the drawing page: 

· A data legend containing information about the data source 

· A text box that contains the name of the PivotDiagram

· The Pivot Node, which contains the imported data from the data source 
52. Click the Pivot Node on the drawing page, and then, in the PivotDiagram window, under Add Category, click the category by which you want to group the data under the Pivot Node.

53. To further expand the new sub-nodes to expose more levels, click the sub-node you want to expand, and then add more categories.
54. In the PivotDiagram window, under Add Total, click the data you want to total or summarize in the diagram.
Tip: You may need to maximize or simply increase the height of the PivotDiagram window to easily see all of the options.
Add a category to a PivotDiagram

55. Select a Pivot Node on the drawing page.

56. In the PivotDiagram window, under Add Category, click the category you want to add to the diagram.

57. To specify settings for a category or to select all categories in the diagram, in the PivotDiagram window, under Add Category, pause the pointer over the category, and then click the arrow that appears to see a menu:

Add Category Name adds the category to the diagram—the same result as clicking the category in the PivotDiagram window.
Select All selects all the sub-nodes in the diagram that are in the category.
Edit Data Graphic opens the Edit Data Graphic dialog box where you can customize the appearance of data shown in the sub-nodes in the category.

Configure Column opens the Configure Column dialog box (or, for SQL Server Analysis Services, the Configure Dimension dialog box), where you can filter the rows of data into a subset that you want to show in the diagram. To remove the filter, reset the box in the Show data by column to (Select Operation).
Add data totals or summaries to a PivotDiagram

58. In the PivotDiagram window, under Add Total, click the data you want to total or summarize in the diagram.

59. To specify settings for data in the diagram, in the PivotDiagram window, under Add Total, pause the pointer over the data type, and then click the arrow that appears to see a menu:

Sum adds the numeric values of all the data contained in each sub-node. 

Average calculates the average of the numeric values of the data contained in each sub-node. 

Min shows the minimum value of the data contained in each sub-node. 

Max shows the maximum value of the data contained in each sub-node. 

Count shows the number of rows of data contained in each sub-node. 

Configure Column opens the Configure Column dialog box (or, for SQL Server Analysis Services, the Configure Dimension dialog box), where you can filter the rows of data into a subset that you want to show in the diagram. To remove the filter, reset the box in the Show data by column to (Select Operation).
Add a different view of the data in a data source to a PivotDiagram

60. From the PivotDiagram Shapes stencil in the Shapes window, drag a Pivot Node onto the drawing page.

61. Follow the steps in the Data Selector wizard.

62. Add categories and totals to the view of the data source.
Identify Issues, Track Trends, and Flag Exceptions
With Microsoft Office Visio 2007, you can rapidly highlight key issues, trends, and exceptions, and depict the progress of a project, turning Visio diagrams into powerful tracking tools. The new Data Graphics task pane makes conditional formatting easy with good-looking, intuitive shapes such as flags, data bars, warning icons, and signals that can be displayed based on user-defined conditions.
For example, you can show variable data as progress bars, represent data that increases or decreases with arrows, and view rankings as stars. You do not need to format any of this yourself; you need only specify the data conditions under which the tracking shapes appear. Office Visio 2007 does the formatting for you. The result is a unique, professional-looking diagram that communicates a wealth of up-to-date information and makes the data much easier to understand and track.
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Figure 7: Create a professional-looking diagram to communicate up-to-date information and make the data much easier to understand and track.
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Apply conditional formatting to data

63. In the Data Graphics task pane, pause the pointer over the data graphic that you applied to the diagram or the one you want to modify, click the arrow that appears next to the data graphic, and then, on the menu that appears, click Edit. 

Tip: If you cannot see the Data Graphics task pane, on the View menu, click Task Pane. Then, in the title bar of the task pane, click Data Graphics.
64. Click New Item, and then, in the menu that appears, click the type of data graphic you want to create.

65. In the dialog box that appears, choose the formatting and conditions for the data graphic, and then click OK.

66. In the Edit Data Graphic dialog box, click OK.

The new or modified data graphic appears with the shapes that use the graphic.
Communicate Using Diagrams That Can Be Shared with a Broad Audience
Using Microsoft Office Visio 2007, you can communicate effectively with diagrams to maximize the impact on your audience in ways that you cannot by using words and numbers alone. Share professional-looking Office Visio 2007 diagrams with anyone, even those who do not have Office Visio 2007, in more file formats.
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Figure 8: Share Visio diagrams with everyone in even more file formats. Use the Theme task pane to easily apply professional-looking themes to an entire diagram.

Design Professional-Looking Diagrams

The new Themes task pane in Microsoft Office Visio 2007 makes it easy to format the colors and effects in an entire diagram with a single click. Themes are a quick and easy way to give diagrams a fresh and professionally designed look. You can mix and match theme colors and effects in any combination.

A theme has two parts:

· Theme colors—a set of colors designed to work well together

· Theme effects—a set of effects for text, fills, shadows, lines, and connectors

Microsoft Office Visio 2007 comes with a set of standard themes, or you can create and edit your own custom themes. For example, you can create a custom theme to match your company’s logo and branding. The standard themes that come with Office Visio 2007 match the themes available in other Microsoft Office programs, such as Office PowerPoint 2007 and Office Word 2007.

Apply a theme to a diagram

67. On the Format menu, click Theme.

Tip: You can also click the Theme tool on the Formatting toolbar.

68. Do one of the following:

· To choose theme colors, in the Theme task pane, click Theme - Colors.

· To choose theme effects, in the Theme task pane, click Theme - Effects.

· To apply a theme to the drawing page, click a thumbnail.

69. To apply a theme to all the pages in the diagram, pause the pointer over the theme you want to apply, click the arrow that appears next to the theme, and then on the menu that appears, click Apply to All Pages.

Create a custom theme 
70. Do one of the following:

· To create a new theme color, in the Theme - Colors task pane, click New Theme Colors.

· To create a new theme effect, in the Theme - Effects task pane, click New Theme Effects.

Tip: Before you create a custom theme, first apply a theme to the diagram that is similar to the theme you want to create. Then, when you open the New Theme Colors or New Theme Effects dialog box, you might need to make only minor modifications to the theme to customize it.

71. In the New Theme Colors or New Theme Effects dialog box, choose the colors or effects you want, and then click OK.

Share Diagrams with Anyone
You can reach broader audiences with Microsoft Office Visio 2007 by saving your diagrams in Portable Document Format (PDF) file format. And, you can share your diagrams with anyone, even those who do not have Office Visio 2007, by saving them as Web pages, complete with navigation controls, a shape data viewer, reports, choice of image format, and style sheet options.
Tip: You can also share Office Visio 2007 diagrams with people who do not have Office Visio 2007 by mailing diagrams to people who use the Microsoft Office Outlook® 2007 messaging and collaboration client, with which they can preview Visio diagrams the same as any other graphic file format. People who use the Microsoft Internet Explorer® Internet browser can download Visio Viewer from the Microsoft Office Web site and install it. Then, they can view Visio diagrams in Internet Explorer much in the same way they view PDF documents.

Save a diagram as a PDF file
72. On the File menu, click Save.

73. In the Save as type list, click PDF.
74. In the Save in list, open the folder where you want to save the file. 

75. In the File name box, type a name for the file. 

76. Click Save.
Note: You can save as a PDF or XPS file from a 2007 Microsoft Office system program only after you install an add-in. For more information, see Install and use a PDF or XPS add-in.

Save a diagram as a Web page

77. On the File menu, click Save as Web Page. 

78. In the Save in list, open the folder where you want to save the file. 

79. In the File name box, type a name for the Web page file. 

80. To specify the title that appears in the title bar when the page is displayed in a browser, click Change Title. In the Page title box, type a title, and then click OK. 

81. To specify the attributes of the Web page more precisely, click Publish. 

In the Save as Web Page dialog box, click the General tab to specify drawing pages to publish and other display options.

Click the Advanced tab to specify the output format for the Web page, target monitor resolution, a color scheme for the navigation and search frame, or a host Web page for embedding the saved Web page. 

Note: To view a Web page in SVG format, you must have an SVG viewer installed. If you do not have an SVG viewer, the Web page is displayed in an alternate format, such as GIF.

82. Click OK to open your Web browser and view the Web page.
Collaborate Using Office Visio 2007 Diagrams
Coworkers who use SharePoint Web sites to collaborate can incorporate Visio diagrams into that collaborative process. With Office Visio 2007, diagrams saved in a Windows® SharePoint Services workspace can be opened directly in Office Visio 2007 from the Document Management task pane. A shared workspace is an area, hosted by a Web server, where colleagues can share documents and information, maintain lists of pertinent data, and keep each other up-to-date on the status of a given project.

When you open a Visio diagram that is stored in a document library in a Windows SharePoint Services workspace, Office Visio 2007 opens the Document Management task pane that contains all of the information in the workspace, including other files, members, tasks, and links.
Open a Visio diagram saved in a Windows SharePoint Services workspace

83. On the File menu, click Open.

84. To open a list of available servers, click My Network Places.

85. If you have already created a shortcut to the folder on the server that contains the file you want to open, double-click it.

86. If you have not created a shortcut to the server, do the following:

Click the Create New Folder button. 

The Add Network Place Wizard opens. Complete the steps in the wizard. 

Note: If you do not know the URL of the server where the file you want to open is located, contact your network administrator.

87. Double-click the folder that contains the file you want to open, and then double-click the file. 

The Document Management task pane opens and displays the Web site data on the Members, Tasks, Documents, Links, and Status tabs.

Track Revisions and Comments in Visio Diagrams

The Track Markup feature in Microsoft Office Visio 2007 enables multiple people to collaborate on the same Visio diagram. Generally used for reviewing a diagram and incorporating feedback, the feature helps make each reviewer’s contributions clearer to other reviewers and to the person who later incorporates the revisions back into the original file. 

Track markups in Visio diagrams

88. On the Tools menu, click Track Markup.
The Reviewing task pane and Reviewing toolbar open, and a colored markup overlay is created.

89. Do any of the following:

To add a shape, drag a shape from a stencil to the markup overlay or use the Drawing toolbar to create a shape.

To add a comment, on the Reviewing toolbar, click Insert Comment.

To add ink, on the Reviewing toolbar, click Ink Tool.

Note: When you have finished adding ink, click any other tool, such as the Pointer tool.

90. On the File menu, click Save.

Note: When you add markup, the shapes, ink, and comments you add are all the same translucent color as the border around the diagram, regardless of any formatting changes you make. Formatting changes do not appear until a shape is copied from a markup overlay to a drawing page. Markup is translucent, so you can easily see the original diagram and the reviewers’ suggested changes.

Resources

The following list includes online locations where you can find additional information about Microsoft Office Visio 2007:

· Up-to-Date Information about Microsoft Office Visio 2007
The latest information about Microsoft Office Visio 2007 can be found at the Visio Office Online Center. At the Visio Office Online Center, you can find detailed product information, the latest articles on topics most requested by users, and links to resources, including hands-on training, white papers, best practices, and more.
· Answers to Frequently Asked Questions about Microsoft Office Visio 2007
For answers to general questions about Microsoft Office Visio 2007, see the FAQ at http://www.microsoft.com/office/visio.
· Demos for Microsoft Office Visio 2007
To view a demonstration of the new AutoConnect and Theme functionality in Microsoft Office Visio 2007, see  http://www.microsoft.com/office/visio.
· To view a demonstration of the new and enhanced Data Link and PivotDiagram functionality in Microsoft Office Visio 2007, see http://www.microsoft.com/office/visio.
· Training Resources for Microsoft Office Visio 2007
Visit Visio Courses to find online Office Visio 2007 training courses you can complete yourself. In addition, a global network of hundreds of Visio Solution Providers can assist customers with specific deployment, training, and customization assistance.
· Newsgroups for Microsoft Office Visio 2007
The public newsgroup for Office Visio 2007 is microsoft.public.visio.
· Support Resources for Microsoft Office Visio 2007
Visit the Microsoft Office Visio Help and Support site for the latest troubleshooting information and technical articles on Microsoft Office Visio 2007.

· Third-Party Microsoft Office Visio 2007 Solution Developers
Visit Microsoft Office Visio Solutions. IT professionals can also download the Visio Resource Kit for IT Professionals. This kit includes great software products from Microsoft partners that complement the functionality Microsoft Office Visio 2007 delivers to IT professionals.
Note for Beta participants: The Microsoft Office Visio 2007 kit is not yet available.
System Requirements

For complete system requirements, visit http://www.microsoft.com/office/visio.
This document is developed prior to the product’s release to manufacturing, and as such, we cannot guarantee that all details included herein will be exactly as what is found in the shipping product. The information contained in this document represents the current view of Microsoft Corporation on the issues discussed as of the date of publication. Because Microsoft must respond to changing market conditions, this document should not be interpreted to be a commitment on the part of Microsoft, and Microsoft cannot guarantee the accuracy of any information presented after the date of publication. The information represents the product at the time this document was printed and should be used for planning purposes only. Information is subject to change at any time without prior notice.
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