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Microsoft® Office Visio® 2003
Product Tour

Welcome to Microsoft® Office Visio® 2003! Microsoft Visio is a diagramming application that can help business and technical professionals document, design, communicate, and automate complex ideas, processes, and systems so they can take more effective action.
Visio provides a dedicated, familiar, Microsoft drawing environment, complete with a broad range of templates, shapes, and sophisticated tools designed to make creating a wide variety of business and technical diagrams easy.
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Introduction

With Visio, you can easily create business and technical diagrams to think through, organize, and better understand complex ideas, processes, and systems. Visio captures the power of visual communications by representing ideas and relationships in graphical terms, creating a visual language that aids understanding and problem-solving better than words and numbers can do by themselves. 
Visio is designed for a broad range of business and technical professionals. Diagramming solutions use industry- and task-specific templates so that you can work comfortably within your area of expertise. Because of the familiar Microsoft Office System interface and precision drawing tools, Visio is easy to learn. Your focus is on your work, not how to present it. 

Seamless integration with other Microsoft Office tools, as well as the Web, make it easier than ever to share your drawings and diagrams and work collaboratively. Intuitive shape behavior combined with the capability to import and export critical data to and from other applications reduces the effort of diagramming, increases accuracy, and boosts productivity. Plus, Visio provides XML support, enabling interoperability between XML-compatible applications.

Visio products are designed with a common file format, facilitating the easy exchange of drawings, regardless of version. And, Visio 2003 provides improved support for wide-scale deployments, making it easier to install and manage across the enterprise.
Visio Standard 2003: Tools for Business Professionals
The Microsoft Office Visio Standard 2003 suite of business process and schedule management tools make planning, design, and communication simpler and more effective for business professionals—managers, information workers, sales and marketing, HR, operations, and consultants. For example:
· Managers and their teams can use the Business Process category in Visio for documenting, analyzing, modeling, automating, maintaining, and tracking business processes with methodologies such as ISO 9000 or Six Sigma.
· HR professionals and executives can create organization charts to track an organization's hierarchy – and use the chart as a visual front-end for a public or private store of information about the people on the chart, including pictures.

· Project leads, consultants, and people who communicate schedule information across teams can use Project Scheduling drawings to create timelines, calendars, Gantt, and Pert charts.
· Marketing and Sales professionals can drag pre-formatted Venn diagrams, pie charts, market analysis and new technology adoption curves onto the page, type in their numbers, and then copy and paste the finished diagram into Microsoft PowerPoint®.

· Planners and consultants can use charts and graphs to simply and easily convey the significance of numerical data.
Visio Professional 2003: Tools for Technical Professionals

The new and enhanced templates and tools in Microsoft Office Visio Professional 2003, as well as specific diagram types for facilities management and engineering, give technical professionals—IT, developers, engineers—a window on their data so they can manage and maintain complex systems.
· IT professionals can use Visio to document and diagram networks, databases, and generate web site maps from live Web sites. 
· Software developers can create enterprise-system and program structure diagrams, COM and OLE diagrams; Jackson and ROOM diagrams; prototype Microsoft Windows® XP application UIs, Windows XP UI prototyping; and auto-generate UML diagrams from Microsoft Visual Studio® projects. 

· Engineers of any type—electrical, process, mechanical—can use diagrams for planning, designing, and troubleshooting, and for distribution to engineering teams for review and comment on design concepts.
Top Reasons to Upgrade
1. Documentation and analysis of business processes. The new Business Process category makes it easier to locate and use the most common diagram types that support Six Sigma, ISO 9000, total quality management (TQM) and other business process management projects.

2. Ability to track comments by individual. A new Reviewing task pane in Visio 2003 enables comments, shapes, and digital ink added by reviewers to be tracked for easy navigation by the diagram author.

3. New ways to collaborate. Users can publish diagrams to a Microsoft SharePoint™ Document Workspace from within Visio, or export diagrams using updated Save as Web Page functionality or new support for the Scalable Vector Graphics (SVG) format.

4. Ability to annotate diagrams more naturally on the Tablet PC. Users can annotate diagrams using digital ink on the Tablet PC, then format, scale, rotate or associate data with the ink; ink can even be converted to basic geometry and text.

5. New brainstorming tools. Visio 2003 includes a new template for capturing structured ideas from a brainstorming session. The content and structure of a brainstorming diagram can be exported to Microsoft Word, Microsoft Excel, or XML to jump-start creation of other business documents.

6. Ability to create calendars from Microsoft Outlook. Visio 2003 includes a new wizard that converts an Outlook® calendar to a Visio calendar that can be more easily formatted and shared with others.

7. Updated diagramming tools for technical professionals. Visio 2003 includes numerous enhancements to the network, software, database, Web, and engineering diagram types.

8. Productivity enhancements. Visio 2003 includes a number of enhancements that enable diagrams to be created and modified more quickly.

9. Ability to build powerful, connected solutions. Visio 2003 includes new tools that make it easier for developers to incorporate Visio into solutions that utilize Microsoft .NET and XML Web services. 

10. Improved support for global usage. Visio 2003 will be localized in two new languages (Polish and Czech), and Unicode implementation provides better support for Asian and bidirectional text.

11. New ways to use Visio. Context-sensitive help and links to task-specific templates are available from within Visio and updated regularly from the Web. 

The Visio Advantage: Key Benefits and New Features 


The power of Visio 2003 as a visual thinking and problem-solving tool rests on the principal that an image can explain an idea or describe relationships better than words and numbers.

Documenting an idea, process, or system visually helps people understand and clarify information, providing a common language that bridges cultural and technical differences. They can see and explain relationships and dependencies they may otherwise miss. Visio makes it easy for people to create diagrams that represent information specific to their area of expertise in a form that is easy to distribute, maintain, and customize. With Visio, people put the power of visual communications to work.
Key Benefits

Visio 2003 features new and improved components in the following areas:
Productivity. Pre-drafted diagrams, a diagram gallery designed to help you browse for the template that best suits your needs, and improved search features assist you to find up-to-date shapes and info with a single click. With new and improved templates and shapes, you can start creating sharp, sophisticated diagrams fast. 
Integration. Re-use data across multiple applications without retyping, reformatting, or duplicating research. Effortlessly integrate work done in any Microsoft Office System application—including Word, Excel, Outlook, PowerPoint, Microsoft Access, and Microsoft Project—into Visio diagrams. Extract data from Visio for use elsewhere.
Mobility. With Visio support for Tablet PC and digital ink, you can annotate diagrams in your own handwriting, on the road, in meetings, or on location while reviewing sites or projects with customers.

Collaboration. Collaborate on diagrams and communicate clearly in team settings, whether your team is the entire staff of a small business, or spread out across an enterprise in offices around the world.
Programmability. Use the rich Visio object model, built-in Microsoft Visual Basic® for Applications (VBA) environment and the Microsoft Visual Basic Editor, XML file format and extensive software development kit (SDK) to build custom solutions on the extensible Visio platform. Or embed the Visio Drawing in line-of-business applications built on Windows, the Microsoft .NET Framework, and Web platforms.
New Features

New or improved features and templates in Visio 2003 make it easier than ever to create professional diagrams that help you better communicate key information and make a more professional impact on your audience.

Work faster and do more with new or improved Visio 2003 features

You can work faster and do more using the following core group of new or improved features that Visio 2003 provides:
· Easily rotate shapes with the new rotation handle ([image: image1.png]


) that appears on two-dimensional shapes.

· Easily select multiple shapes using the new Area Select ([image: image2.png]


) and Lasso Select ([image: image3.png]


) tools and the Multiple Select mode. Resize all of the selected shapes at once using the new selection handles that enclose them.

· Share information and ideas with colleagues on your Tablet PC wherever you happen to be with the new Ink tool ([image: image4.png]


). Sketch freely and work through ideas as you would on paper or whiteboards.

· Quickly find shapes with the improved Search for Shapes feature in the Shapes window. Drag the shapes you find directly onto the drawing page.

· Organize the shapes you use often in one location so they're easy to find. Save them on the new Favorites stencil or custom stencils in the new My Shapes folder.

· Use the task panes docked to the right of the drawing page to quickly access options for starting diagrams, searching the Web, inserting clip art into diagrams, researching, reviewing, collaborating, and getting Help.

· Mark up Visio diagrams with shapes and annotations using the new Reviewing task pane. It supports global teams, whose members need to review and collaborate on projects, but may not be in the same building, or even the same country.

· Easily collaborate on and share documents with SharePoint integration in Visio 2003. Work with documents in the Shared Workspace task pane, which contains a library of all related files, and provides immediate access to your collaboration group, assignments and action items, and external links to information.

· View, share, and print Visio diagrams in Microsoft Internet Explorer 5.0 or later using the improved Visio Viewer, even if your team members, clients, and partners don't have Visio.

· Ensure CAD files you convert to the Visio file format have higher fidelity than your original CAD files. The DWG Converter also includes improved text handling and graphic support.
Create a lasting impression with new or enhanced templates and shapes

Gain more control over your Visio diagrams and use them to create a lasting impression on your audiences using new or enhanced Visio 2003 templates.
· Templates with shapes already positioned on the drawing page. Create diagrams faster with new Visio templates that come with shapes already on the drawing page. Just download the template from the Web, then fill in the detail without worrying about the layout or starting from a blank page.
· Brainstorming Diagram. Capture and arrange ideas generated by a group or generate and diagram ideas on your own with the new Brainstorming Diagram template. Then, export the diagram to a Word outline for those who prefer to see the information in a linear view, or to an XML file for reuse elsewhere.

· Organization Chart. Specify the employee information you want to show in your organization charts, add employee photographs to shapes, show dotted-line reporting relationships, and experiment with different layouts using the enhanced features and shapes in the Organization Chart template.

· Timeline. Easily communicate schedule information, visualize milestones, and reinforce the progression of time with the improved Timeline template. Create vertical timelines and synchronize milestones and intervals across multiple timelines. Use the new Expanded timeline shape to create a more detailed timeline segment. Edit all date and time formatting at once, and divide your timeline by seconds, minutes, hours, or quarters of the year.

· Basic Network Diagram and Detailed Network Diagram. Create presentation-quality network diagrams with the enhanced Basic Network Diagram template in both Visio Standard 2003 and Visio Professional 2003. Document the physical and logical topology of your network using the Detailed Network Diagram template in Visio Professional 2003. Shapes in both templates have a dramatically improved appearance.

· Rack Diagram. Quickly diagram rack space requirements for new network equipment using the new Rack Diagram template in Visio Professional 2003. The new shapes are designed with industry-standard measurements, to fit together precisely, making it easy to stack shapes in a rack and size them appropriately. You can also store data, such as serial number and location, with the shapes and then generate detailed reports.

· Windows XP User Interface. Prototype user interfaces with the new Windows XP User Interface template in Visio Professional 2003, which includes all the controls you need to draft your user interfaces before you begin coding. Create drop-down menus, tabbed dialog boxes, and toolbars that comply with the Windows XP look and feel.

· Web Site Map. Take advantage of the enhanced features in the Web Site Map template included with Visio Professional 2003. Gain more control over layout options and shape text, use new shapes to represent current and upcoming technologies, and generate Web site maps faster. Using the new interactive discovery feature, you can even map protected Web site areas for which you have the appropriate access rights.

Visio Standard 2003 and Visio Professional 2003 Product Comparison
Visio 2003 is a diagramming application that can help business and technical users document, design, communicate, and automate complex ideas, processes, and systems so they can take more effective action.

Visio Standard 2003 enables users to visualize, document, communicate, and share ideas with attention-grabbing flowcharts, organization charts, office layouts, and more.
Visio Professional 2003 gives information technology (IT) professionals, engineers, and developers the most comprehensive technical diagramming and drawing tools available to create and share information.
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Tour Microsoft Office Visio 2003
Visio 2003 products are flexible, multi-use applications that you can use for a broad range of business and technical diagramming needs. Whether you need to create simple flowcharts or highly complex network documentation, the fundamentals of using Visio are the same across all products. 
This tour begins with an overview of Visio basics – how to navigate the interface, and how to find the type of drawing you want – and then steps thru a few of the most common diagrams created in Visio Standard 2003. Next it takes you through a high-level tour of Visio Professional 2003, and finally, introduces Visio features for developers. 
Start Visio and Tour the Interface
 Step 1. Click Start, point to Programs, click Microsoft Office Visio 2003, and under Category, select Business Process, then Organization Chart, then Project Schedule.

What's happening? In the Choose Drawing Type dialog box you can easily select the appropriate diagram type for the information you want to communicate. Visio provides a wide range of diagrams for visually documenting information specific to user tasks, from flowcharts, to organization charts, timelines, simple network diagrams, and more. 
 Step 2. Under the new Business Process category, double-click Fault Tree Analysis Diagram.

What's happening? Notice that the template includes a drawing page on the right of the screen that looks like a piece of graph paper. This grid helps you place shapes accurately on the page.

 Step 3. Pause your pointer over one of the shapes. 
What's happening? Tool tips associated with each shape indicate its purpose or specific suggestions for how to use it. Click the new More link to display more detailed information about working with shapes. 
 Step 4. Drag a couple of shapes to the page. 

What's happening? When you open the Basic Flowchart template, Visio displays the stencils at the left of the screen. You can drag shapes to the page to document a process flow. One or more stencils relevant to the diagram type open with each Visio template. 

 Step 5. Click the Borders and Titles stencil, and then the Background stencil to view the shapes contained in each. 
What's happening? In addition to flowchart shapes, this template also provides stencils for adding borders, titles, and backgrounds to your diagram. 

Tip: In addition to the familiar Office System toolbars and menus, Visio 2003 includes familiar Office features such as AutoCorrect, the spelling checker, and keyboard shortcuts. 

Find the Templates, Shapes, and Information You Want
 Step 1. On the Help menu, click Diagram Gallery.

What's happening? The new Diagram Gallery displays samples of every template type in Visio, along with suggestions for who might make the best use of them and how. Browse the Diagram Gallery anytime for inspiration on how best to present your data, or to find a template type you can picture but not name.

 Step 2. In the Shapes pane at the left of the screen, type "sport" in the Search for Shapes text box, and then click Go. 

 Step 3. Select the Baseball Diamonds shape and drag it to the page.

What's happening? With Visio 2003, shape keywords have been refined for more efficient search returns, and the Search for Shapes box is always accessible in the Shapes window. 

 Step 4. On the Help menu, click Getting Started Tutorial.
What's happening? Visio 2003 includes a self-paced introduction to the Visio drawing environment. The new tutorial uses four popular Visio diagram types to teach you the basic skills you'll use to create and share your own Visio diagrams.
 Step 5. On the Help menu, click Microsoft Office Online. 
What's happening? Your browser opens and displays the new Microsoft Office Online Web site. Microsoft Office Online provides Assistance (how-to articles, conceptual topics, and tips); Templates (new pre-populated drawings you can download to get started faster); Training (short self-paced courses that cover feature or activity areas in Visio), Clip Art and Media you can download, Downloads (product updates, add-ins, converters, and viewers), and Office Marketplace (third-party products and services that work with Office 2003). 
Document Business Processes and Communicate Project Information
Whether your organization is involved in documenting standards and processes, or whether you're looking for a way to organize information visually to include a report or presentation, Visio includes a variety of useful tools for organizing, connecting, and formatting data, processes, procedures, and other information.

To get a sense of the breadth of business diagramming types Visio supports, do some more exploring in the Choose Drawing Type window. Start Visio, and then, in the Choose Drawing Type window, click Block Diagram, Brainstorming, Charts and Graphs, and Maps in turn to get a sense of some more of your options. When you're finished exploring the diagramming types, start the next procedure to create a flowchart.
Create a Flowchart, and Then Add It to a Word Document
Create a flowchart to clearly and concisely document each step involved in revising your department's internal Web Site. In this tour you'll work with connectors, select and rotate shapes to enhance the appearance of your flowchart, and then copy the diagram into a Microsoft Office Word document. Finally use improved in-place editing tools available in Word to make a change without going back to your original drawing.

Create a basic flowchart
 Step 1. Click Start, point to Programs, click Microsoft Office Visio 2003. Under Category, select Business Process, then double-click Basic Flowchart.
 Step 2. From the Basic Flowchart Shapes stencil, drag a Process shape to the drawing page.

 Step 3. On the Standard Toolbar, click the Connector tool ([image: image69.png]


).

 Step 4. With the process shape still selected, drag a Decision shape to the page below it.

What's happening? When you use the Connector tool in Visio, each shape you drop is connected automatically to the previous shape selected on the page. Unlike clip art, Visio shapes and connectors come with built-in text blocks and intelligent behavior. Connectors stay connected and text blocks stay in place when you reposition shapes.

 Step 5. With the Decision shape selected, drag a Process shape to the drawing page and drop it below and to the left of the Decision shape.
 Step 6. Drag another Process shape to the drawing page below and to the right of the Decision shape.

What's happening? Because Visio is designed as a dedicated diagramming tool, it includes all kinds of helpful features, such as the graph paper-like drawing page grid. The grid helps you place shapes precisely. When you drag a shape onto the page, the dynamic grid shows you exactly where to place it with respect to other shapes on the page for perfect alignment.

 Step 7. Select the first Process shape and type "Review Existing Content."
 Step 8. Select the Decision shape, and then type "Keep or Delete?"
 Step 9. Select the line that exits the Decision shape and type "Keep."
 Step 10. Select the Process shape located below the Decision shape, and then type "Update."
 Step 11. Select the second Process shape, and then type "Post."
What's happening? Another helpful Visio behavior is built-in text blocks. To add text to shapes, simply select the shape and type. There's no need to create a separate text box for every shape, as with other programs. 

 Step 12. Drag another Process shape, and pause it over the line connecting the "Update" and "Post" shapes. When a scissors icon appears, drop the shape. With it selected, type "Proofread."
What's happening? If you discover that an additional step is required after you've created your flowchart, you can simply drop it between existing shapes, without having to detach or move them by hand. Visio automatically reconnects the shapes to accommodate the new step.

 Step 13. Select the "Post" process shape and move it around on the page.

What's happening? Because text blocks are built in to the shape, they stay in place when you move the shapes around on the page. Notice that the connectors stay connected, too. These simple Visio diagramming behaviors completely eliminate time-consuming reformatting as you move shapes on the drawing page, letting you focus on the content of the diagram rather than its formatting.

Enhance your flowchart's appearance 
 Step 1. Click the Borders and Titles stencil title bar to the left of the window.
 Step 2. Drag the Border Modern 1 shape to the drawing page.

 Step 3. Type "Revise Internal Web Site" in the Title field.

What's happening? You can enhance a diagram's appearance by adding a border and title, selecting a background, and adding color. Shapes on the Borders and Titles stencil can be dropped onto the page. They snap into place and adjust to the current page orientation.

 Step 4. Click the Backgrounds stencil title bar, and then drag the Background high tech shape to the page.

What's happening? Drag and drop a background shape onto the page, and it becomes the background for your diagram.

 Step 5. If your flowchart shapes need to be moved or centered, click the Pointer tool and drag a selection net around the shapes to multi-select them, and then drag them where you want them to go. You can also select a single shape and drag its rotation handle ([image: image70.png]


) to easily rotate it.
 Step 6. Right-click the page, and then click Color Schemes.

 Step 7. In the Color Schemes dialog box, click Primary, and then click OK. 

What's happening? Color can add the finishing touch to your diagram. Visio includes 17 different color schemes that you can apply in seconds to add a sharp, coordinated look to your diagrams.

Add your flowchart to a Word document

Now that the flowchart is complete, you can copy it into a Microsoft Office Word document. Once it's in place, you can edit the flowchart from within the Word document.

 Step 1. With no shapes selected, click Edit, and then Copy Drawing.

 Step 2. Switch to Microsoft Office Word and open a new document.

 Step 3. Click the page in Word.
 Step 4. Click Edit, and then Paste.

What's happening? Your diagram is inserted into the Word document. You can now resize the diagram for the page or add borders and shading. 

 Step 5. To edit the flowchart from within Word, double-click the diagram.

 Step 6. Right-click the page, and then click Color Schemes. Select a different Visio color scheme, and then choose OK.

 Step 7. Press and hold the Shift key, and then click each shape in your flowchart. 
 Step 8. On the toolbar, click the Font Size box and select 10 pt.

 Step 9. After completing the revision, click outside the diagram area to return to Word.

What's happening? Rather than going back into Visio, updating the diagram, and cutting and pasting again, you can simply edit the diagram in place, directly within Word. 

Create an Organization Chart and Add Data to Your Shapes
In this tour you create a basic organization chart from scratch, working with the improved intuitive layout behavior unique to Visio 2003. On the way you add a new custom property field to your chart, enriching the information about the organization stored in each position shape. Finally you'll report on the data in your chart in Microsoft Office Excel, and then publish your chart to the Web.
Create an organization chart and add custom properties

 Step 1. Open Visio and point to File > New > Organization Chart, and then click Organization Chart.


What's happening? In addition to the usual stencils and the drawing page, the Organization Chart template includes its own menu and toolbar, from which you can choose commands specific to organization charts.

 Step 2. Drag an Executive shape onto the drawing page, and type "Joseff" in the name field, and "President" for the title.

 Step 3. Drop an Assistant shape onto the Executive, and type "Suzan" in the name field, and then type "Executive assistant" for the title.

What's happening? The organization chart template features intuitive layout behavior, freeing you from having to focus on connecting shapes and adjusting the layout. Simply drop an Assistant shape on an Executive shape, and the two shapes connect automatically.

 Step 4. Drop a Manager shape onto the Executive, and type "Ashley" in the name field, and then type "VP of Marketing" for the title. Drop another manager shape onto the Executive, and then type "Chris" in the name field, and then type "VP of Development" for the title.

What's happening? Visio repositions the shapes appropriately for you.

 Step 5. Drop the Multiple Shapes shape on the "Chris" Manager shape.

 Step 6. In the Add Multiple Shapes dialog box, type "5" in the Number of shapes field, and then click OK.

What's happening? You can add multiple shapes at one time with the Multiple Shapes shape. Just drop it on a manager shape and specify the number and type of positions you want to add.

 Step 7. Select the "Chris" Manager shape with the 5 reports.

 Step 8. On the Organization Chart toolbar, click the Vertical Layout button [image: image71.png]


, and choose the Align Right option [image: image72.png]



What's happening? Reformatting an org chart can be painful with non-specialized organization chart tools, but with Visio you simply select the manager shape and click the button on the toolbar that shows the layout you want.

 Step 9. Double-click and enter names and titles for each position.

 Step 10. Select the lowest position shape, and click the Move Up button [image: image73.png]


 to reposition it.

What's happening? Use the up and down arrows to adjust the order of the people reporting to this manager.

Create a report on your chart and then publish it to the Web
 Step 1. Select the Chris manager shape, and then click View menu, and then click Custom Properties Window.

 Step 2. Type "Development" in the Department field.

What's happening? Each organization chart shape comes with custom property fields already defined for Name, Title, Department, Telephone, and E-mail. Simply type the data into the Custom Properties window to assign new properties to a shape.

 Step 3. Select all the shapes on the page by dragging the mouse over them.

 Step 4. Right-click the Custom Properties Window, and click Define Properties.

 Step 5. Click New, and then type "Username" into the Label field. Click OK.

 Step 6. Click the page away from the shapes.

 Step 7. Select the Chris shape, and then type "ChrisDev" into the Username field.


What's happening? You can easily assign additional property fields to shapes. In this example, you add a Username field to make it easy to keep track of users' network IDs.

 Step 8. On the Tools menu, click Reports. Select Organization Chart Report in the list, and then click Run.

 Step 9. Select Excel in the Run Report dialog box, and then click OK.

What's happening? You can easily run one of the new Visio pre-defined reports on your diagram, or create your own report. Publish the report in Excel, HTML, XML format, or as a Visio shape you can add to the diagram itself.

 Step 10. Click File, and then Save to save your diagram.

 Step 11. Click File, and then Save as Web Page. In the Save As dialog box, specify a file name and a location. 

 Step 12. Click Publish. 
 Step 13. In the Save as Web Page dialog box, uncheck Go to Page and Search Pages, and then click OK.
 Step 14. On the new Web page, hold down the Ctrl key and click the Chris shape.
What's happening? Many organizations share organization charts on the corporate intranet site. Visio improves the speed of publishing your diagram to the Web. You can specify what portions of your diagram to publish, which navigation options to include, and the file format. In this example you've published an organization chart in a VML format and included the Pan and Zoom window to navigate the diagram and a Details control to see custom property details.

Create a Timeline, and Then Revise It and Track Changes
In this tour, you create a timeline for updating your internal Web site. Afterwards you'll revise it and track your changes so that others can see what you've done. Finally, if you have Microsoft Office Project on your computer, you can follow the steps to easily import a number of tasks to create a timeline automatically.
Create a timeline and show details of one section

 Step 1. In Visio, on the File menu, point to New, point to Project Schedule, and then click Timeline. 
 Step 2. From the Timeline Shapes stencil, drag a Block timeline shape onto the drawing page. 
 Step 3. In the Configure Timeline dialog box, in the Time Period tab, select September 1, 2003 as the start and November 3, 2003 as the finish dates for the project. 
 Step 4. In the Time scale list, choose Weeks, and then click OK. 
What's happening? Visio configures the timeline to display the dates and time scale you selected.
 Step 5. Drag a milestone shape from the Timeline Shapes stencil and drop it directly on top of the timeline. 
 Step 6. In the Configure Milestone dialog box, select September 7, 2003 as the date for the milestone, and then in the description box, type "New content team forms." Click OK.
 Step 7. Drag the milestone a few days to the right on the timeline. 
What's happening? The date on the milestone changes to match the new position of the shape. 
 Step 8. Drag an interval shape from the Timeline Shapes stencil and drop it directly on top of the timeline. Select September 15, 2003 for the start date and September 30, 2003 for the finish date.
 Step 9. In the Description box, type "Review existing content" and then click OK.
 Step 10. From Timeline Shapes, drag the Expanded Timeline shape onto the page. 
 Step 11. In the Configure Timeline dialog box, select September 15, 2003 for the start and September 30, 2003 for the finish date, and then click OK. 
What's happening? You can expand a segment of an existing timeline as a second timeline to show more detail. The expanded timeline represents a segment of the original timeline, but you work with it individually; for example, you add milestones or intervals to the expanded timeline just as you would to the original timeline. 
Tip: If you add a milestone or interval to the original timeline, it will also be added to the expanded timeline. 
 Step 12. On the File menu, click Save, and then name, save, and close your timeline.
Mark up your timeline and track changes
 Step 1. Start Visio and click the name of your timeline in the Getting Started task pane, under Open at the right of the screen.

 Step 2. On the Tools menu, click Track Markup.

What's happening? Visio opens the Reviewing task pane, displays the Reviewing toolbar, and creates a markup overlay for you.

 Step 3. From the Borders and Titles stencil, drag a Title block geometric shape to the drawing page.

What's happening? Your changes are tracked in red and identified by your name. When you add markup, the shapes, ink, and comments you add are all the same translucent color as the border around the drawing, regardless of any formatting changes you make. Formatting changes do not appear until a shape is copied from a markup overlay to a drawing page.
 Step 4. On the Reviewing toolbar, click Insert Comment and then type "Please add title."
What's happening? Visio adds a comment icon to your markup overlay that you can click to display your comments.
 Step 5. On the Reviewing toolbar, click the Ink Tool, then circle the milestone on the timeline and indicate that you want it moved to the left. When you've finished adding ink, click the Pointer tool.
 Step 6. On the View menu, click Task Pane, click the arrow in the task pane title bar, and then click Shared Workspace.
What's happening? You've opened the Shared Workspace task pane, where you can create a document workspace so that you can capture all your reviewers' markup in one file, which you could also do by posting the diagram to an intranet site of saving it to a network share. 
Create a timeline from Microsoft Office Project data

If you have Microsoft Project 2000 or later installed on your machine, you can import tasks and milestones from a Project (MPP) file to create a Visio timeline using the Import Timeline Wizard. (And if you want to use the data from a Visio timeline to create a more detailed tracking schedule in Project, you can export it to a Project file.) Similarly, you can create Timelines from data in Excel, calendars from data in Project, and organization charts from Excel and Microsoft Exchange Server.
 Step 1. On the File menu, point to New, point to Project Schedule, and then click Timeline. 
 Step 2. On the Timeline menu, click Import Timeline Data. 
 Step 3. On the first wizard page, enter or select the Project (MPP) file you want to use to create a Visio timeline, or click the Browse button to navigate to the file you want, and then click Next. 
 Step 4. On the next wizard page, select the task types you want to import. See the Description at the bottom for details about each task type. 
 Step 5. On the third wizard page, select the shape types you want to use for the timeline, as well as for the milestones and intervals that appear on your timeline. You can also click the Advanced button to set the time scale and display options for your Visio timeline. Click OK, and then click Next. 
 Step 6. Click Finish to create a Visio timeline with the properties you specified in the wizard. 
Document IT and Facilities Information

Visio Professional 2003 offers business and technical professionals the most comprehensive set of technical drawing and diagramming tools available for network, software, database, Web site, engineering, building, and space planning professionals. 

Create a Network Diagram and an HTML Inventory of Equipment
 Step 1. Open Visio Professional 2003. Point to File > New >Network, and then click Rack Diagram.
 

 Step 2. From Rack-mounted Equipment, drag a Rack shape onto the drawing page. To hide the "U" height, right-click the shape and click Hide U sizes. 

 Step 3. Drag a Server shape onto the Rack shape. 

What's happening? The shapes are designed to fit together precisely, and their connection points make them easy to size and snap into place. After they're connected, they remain together, even when you move them.

 Step 4. Click the Server shape and type "Server1". 

 Step 5. Right-click the Server shape, click Properties, and, in the Custom Properties window, type "Seattle" for Location, and "10" for Building. 

What's happening? You can store data, such as serial number and location, in the custom property fields associated with the Visio equipment shapes. After you've associated data with the shapes, you can generate richly detailed reports.

 Step 6. Add a few other shapes to your rack.
 Step 7. On the Tools menu, click Reports. 
 Step 8. In the Report list, click Inventory, and then click Run.
 Step 9. Click Run, and then, in the Run Report dialog box, click HTML to save your report as a Web page.

 Step 10. Type a name for the report definition, and then click OK.

Generate a Web Site Map from a Live Web Site
Use the Web Site Map template to discover links and generate a site map for a Web site on an HTTP server, network server, or local hard drive.

Site maps help you maintain and troubleshoot your site. Use them to analyze your site's organization and to classify its content. Site maps are particularly helpful when you inherit sites you're not familiar with.

Each shape in the site map represents a link on your Web site and includes information about the link type and location. Shapes include hyperlinks so you can jump directly from a shape to the link it represents.

After you've generated a site map for an existing site, you can use it to do the following:

· Quickly find broken links, view the errors encountered when those links were discovered, and fix those links. 

· Generate a report listing all the links in a Web site, or only those links that contain errors. 

· Track changes on a Web site by comparing two maps of the same site and generating a report listing the differences.

Generate a site map
 Step 1. On the File menu, point to New, point to Web Diagram, and then click Web Site Map. 

 Step 2. In the Address box, leave the default text, http://www.microsoft.com/default.asp, and click Settings.

 Step 3. For Maximum number of links, type "30".

What's happening? A progress dialog box appears while the Web Site Map template generates a memory model and lays out your site map. 

 Step 4. On the Shape menu, click Lay Out Shapes. For Style, select Radial, and then click Apply.

What's happening? You can use Visio's different layout options to easily change the look of your Web site map. For this example, set the initial layout in Radial view. Now change it back to a Flowchart/Tree view, which is the default. You can also decide to expand your diagram further, or even split it up into multiple linked pages.

 Step 5. On the View menu, click Pan & Zoom Window, and then navigate around your diagram 

What's happening? Many Web sites produce large, complicated drawings. The Pan & Zoom window lets you look at different areas of your diagram while maintaining a bird's eye view. Note the different shapes from the stencil that represent each type of web page or link. Broken links are indicated with a red X over any page where Visio encountered an error.

 Step 6. On the Web Site Map menu, click Reports. 

 Step 7. Click Web Site Map Links with Errors, then click Run. 

 Step 8. In the Run Reports dialog box, click HTML.

What's happening? The template generates an HTML file listing the problematic links.

 Step 9. In the Web Site Map, position the pointer over a broken link. 
 Step 10. Click the shape tag button to see the nature of the error.
What's happening? Visio identifies the problem. Many broken links are caused by incorrect file names, incorrect file locations, and missing files, all of which can trigger a 404 or File Not Found error message. Other broken links can be caused by Site Not Found, Access Denied, Password Required, or Site Timed Out errors.
 Step 11. On the Web Site Map menu, click Generate Site Map. 
 Step 12. Click Settings, and then click the Advanced tab.
What's happening? If you're mapping a site that uses HTTP authentication, you can enter a valid name and password into this dialog box and map the protected part of the site.

Create a Database Model Diagram
Database management systems are complex, and visual documentation is an effective means of promoting communication between the technical experts who run them and their clients. With Visio Professional 2003, you can take a snapshot of your database and its code to create a concise and accurate database model diagram—that is, a diagram that models a physical database schema.
Visio Professional 2003 reverse engineers client/server databases such as Microsoft SQL Server, and desktop databases such as Microsoft Office Access, and provides several views of your database schema. Using shapes that represent Relational, IDEF1X, or Crow's Feet notation, you can diagram relational or object-relationship databases and easily keep the diagram up to date as modifications are made to the database.

This tour introduces the Database Model Diagram template, the place to start. You'll tour the interface and get a sense of the power of this tool with which you can describe all or part of a database schema or even create a model that's independent of its implementation on and particular database management system. Usually you'll use this template to reverse engineer a database that already exists. However, you can also use the template to prototype new designs by dragging and dropping shapes that represent tables or entities and connectors that show relationships. 
 Step 1. On the File menu, point to New, point to Database, and then click Database Model Diagram. 
What's happening? Visio opens a new diagram and displays the Output window below the drawing page. This window displays progress and status information when you reverse engineer a database, which you can do by clicking Reverse Engineer on the Database menu. Visio validates your model when you reverse engineer a database. The Output window displays messages about conflicting names, data types, or other errors.
 Step 2. On the Database menu, point to Options, and then click Document. In the Database Document Options dialog box, select IDEF1X or Relational, and then specify the names of the options you want to display.
 Step 3. Click the Table tab, and then choose the attributes you want to have displayed in table shapes, primary key order, data type display, and whether to display IDEF1X optionality.

 Step 4. Click the Relationship tab, and then choose whether you want to display relationships. If so, specify the relationship notation you want to use (such as Crow's Feet,) whether to display cardinal and referential integrity, and how to display the relationship verb phrase and name (role text).

 Step 5. Click OK to apply the settings to the file.

What's happening? You've set up your file to display the attributes you want using the notation you chose. Now you can add shapes to the drawing page. After you add shapes, you can choose Database > View > Tables and Views to see every shape and view in your model.

 Step 6. Choose Database > View > Code.
What's happening? If your database includes code, such as check clauses or stored procedures, Visio can extract it when you reverse engineer a database. The Code window lists all code for a particular database platform. You can view, edit, and delete stored procedures, functions, triggers, check clauses, view definitions, and even raw DDL code, each of which is represented by a different icon in the Code window.

Prototype a Windows XP Application UI
Use the Windows XP User Interface template to make everything from a mock-up of a complex application window or tabbed dialog box to a simple message box or a single button.

The shapes, which are designed to Windows XP guidelines, include the elements commonly used in interfaces, such as a blank form for the basis of an application window, wizard pages, toolbar and menu shapes, and control shapes. 
In this tour you'll assemble the basic pieces for an application window. 
 Step 1. From Windows and Dialogs, drag a Blank form shape onto the drawing page. 
 Step 2. With the shape selected, type "Ice Cream Builder" as a title for the application window. 
 Step 3. To add an icon to the left of the text in the title bar, right-click the Blank form shape and check the Room for Icon check box. 
 Step 4. Drag a Window buttons shape onto the right end of the title bar and select the button type. There are typically three buttons: a Minimize button, a Maximize or Restore button, and a Close button, arranged left to right. 
 Step 5. From Toolbars and Menus, drag a Menu bar shape onto the Blank form shape, glue it to the bottom of the title bar, and then add menu items. 
 Step 6. Drag a Top-level menu item shape to the page and glue it to the left edge of the Menu bar. 
 Step 7. With the shape selected, type a name. If the menu item has a keyboard shortcut, underline the appropriate letter. 
 Step 8. From Toolbars and Menus, drag a Toolbar shape onto the Blank form shape, glue it to the bottom of the menu bar, and then add toolbar buttons. 
 Step 9. Drag one of the Toolbar buttons shapes to the page and glue it to the left edge of the Toolbar shape. 
 Step 10. In the Custom Properties dialog box, choose the type of button you want. If you want to change the button later, right-click the shape and click Set Button Type to reopen the Custom Properties dialog box. 
 Step 11. Drag out more Toolbar buttons and Button separator shapes and glue them to each other. 
 Step 12. From Common Controls, drag horizontal and vertical scroll bars to the right and bottom edges of the Blank form shape. 
 Step 13. Right-click the scroll bars and choose Set Thumb Size to indicate how far the window can scroll. 
 Step 14. Drag a Status bar divider shape to the page and glue it to the Status bar shape's control handle ([image: image74.png]


). 
 Step 15. Drag a Window Resize shape to the right edge of the status bar to indicate that the window is currently resizable. 
What's happening: You've created an application window! Now you can fill in the text and print a copy to take down the hall for informal usability tests against co-workers.
Create a UML Model Diagram

Whether you create formal object models or diagram data flows, Visio includes the software diagramming templates and shapes you need, representing a variety of methodologies and notations.
This tour focuses on the advanced Unified Modeling Language tools, with which you can model the entire software development life cycle and even reverse engineer source code to quickly diagram classes and properties.

With Visio, you can create the eight UML diagram types associated with each phase of the software development life cycle: use case, static structure and sequence, activity and statechart, collaboration, class static structure, component, and deployment diagrams. This tour will give a bird's eye view of some of the UML solution's special features.

 Step 1. In Visio, point to File > New > Software, and then click UML Model Diagram.

 Step 2. On the UML menu, point to View and click Model Explorer.

What's happening? A Visio drawing file represents one software system and can include many models and diagrams for the system. Visio maintains the entire system model in the Model Explorer, a window that gives you a comprehensive picture of the elements of the software system, such as classes, use cases, and components.
 Step 3. On the UML menu, click Models.
 Step 4. Click a cell in the Model column, type a name for your model, and then click OK.
What's happening? In the Model Explorer window, Visio adds the new model.

 Step 5. To set the properties for a model, in the Model Explorer, right-click the model, and then choose Properties.
 Step 6. Select a category, enter the properties, and then click OK.
Document Building Space and Facilities
In Visio, a space plan provides both a visual representation of a facility as well as up-to-date information about its contents that you can use to locate an office or other space, a piece of equipment or other physical asset, or even a person. 
Build a space plan from a list of office numbers

This tour shows how to generate a space plan automatically from a list of office numbers in a spreadsheet. After you create the space plan, you can: 
· Move resources by dragging their icons from one space to another in the Space Explorer. The drawing is updated automatically. 

· Use the Refresh Data command to update the imported data in the drawing if the data in your spreadsheet or database changes. 

· Use the Space report, Asset report, and Move report shapes to generate reports, or you can create your own reports using the Report Definition wizard. 

· Use the Color by Values command to color-code your drawing based on shape custom property values. For example, you can color the offices in the accounting department red and the offices in the finance department blue. You can also add a legend to explain the color-coding. 

· Use the Label Shapes command to label the shapes in your drawing based on shape custom property values. For example, you can show each person's title, phone number, or e-mail alias. 

 Step 1. Create a list of office numbers as a column in a Microsoft Office Excel spreadsheet. To include more information in your space plan, such as the department or space type of each office, add more columns to your spreadsheet.
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 Step 2. After you type all the office numbers and other information into the spreadsheet, save it and then close Excel.

 Step 3. In Visio, on the File menu, point to New, point to Building Plan, and then click Space Plan.

What's happening? The Space Plan Startup Wizard opens automatically.
 Step 4. On the first page of the wizard, choose None, and then click Next. 

 Step 5. On the second wizard page, choose From an existing spreadsheet, click Next, and then browse to the spreadsheet you just created and click Open. 

 Step 6. Click Finish. 

What's happening? When you import your office number information into the space plan, Visio creates one space for each office number. The spaces appear on the Spaces tab of the Explorer window under the Unplaced Data category.

 Step 7. Click the plus sign (+) next to the Unplaced Data icon to check your data. 

 Step 8. From the Categories tab of the Explorer window, drag a space that represents an office number onto the drawing page. 
 Step 9. What’s happening? As you drag spaces onto the drawing page, Visio moves them from the Unplaced Data category in the Explorer window to the Page-1 category.

 Step 10. Continue adding and arranging spaces until you have created a space plan. 

 Step 11. From the Resources stencil, drag a resource shape onto the appropriate Space shape in the drawing. 

 Step 12. If the Custom Properties window is not already open, on the View menu, click Custom Properties Window. 

 Step 13. In the Custom Properties window, click the Name field, and then type the resource name. 

 Step 14. When you are finished creating your space plan, lock the space layer to prevent accidental changes to the Space shapes. To lock the space layer, on the View menu, click Layer Properties, and then for the Space layer, select the Lock check box.
For Developers: The Microsoft Office Visio 2003 Development Platform 
A Visio solution is a combination of Visio shapes and programs that model the real world and solve drawing problems. A Visio solution usually includes shapes that the user can drag and drop onto the drawing page to quickly create a drawing; templates for new drawings that predefine the drawing size and drawing scale; and programs that help create the drawing, analyze the drawing, or transfer information between the drawing and external data sources.

To help you create solutions, the Visio development environment provides the following:

· The ShapeSheet spreadsheet, which lets you create formulas for specific shape appearance and behavior. 

· VBA with which you can create macros and control Visio using Automation. If you have ever used VBA in another Microsoft Office System program, you'll be familiar with the environment in Visio. You can also use the Macro Recorder to quickly create VBA code that you can then view or modify. 

· The Visio type library, which describes the objects, properties, methods, events, constants, and interfaces that Visio exposes to Automation clients. 
New and Improved Features for Developers
ActiveX control. Visio 2003 makes Visio available as a Microsoft ActiveX control, so you can preserve the unity of your host application's design. You can tightly constrain drawing functionality to just what is required by your host application, and your host application controls the user interface. With new deployment options you can configure which shapes and templates are available to the end user.
Control over shape behavior. The new BOUND() and SETATREF() ShapeSheet functions significantly reduce or eliminate the code you have to write to make shapes in the drawing behave according to your design rules.

Formula Tracing window. To assist in the task of identifying interdependencies between ShapeSheet cells, you can use this window to trace both dependent and precedent cells of a given cell.

New keyboard and mouse events. These new features allow developers to handle end-user mouse clicks, mouse movements, and keyboard actions. For example, when a user clicks a shape, you can display a message box or change the shape's color.

Macro recorder. Developers new to the Visio platform will find Visio Automation easier to learn, now that Visio comes with the macro recorder. If you're not sure how to perform a given Visio task programmatically, you can turn on the macro recorder and manually perform the action. The macro recorder translates your actions into VBA code. You can also modify the code generated by the macro recorder to ease the pain of performing repetitive tasks.

Primary interop assemblies (PIAs). You can use the Visio PIA to access the Visio object model from applications that use the common language runtime. The Visio PIA provides the common language runtime with the information it needs to correctly handle Visio type implementations. Visio provides a PIA for every published Visio 2003 interface so that you can integrate Visio with managed code applications.

ShapeStudio. This add-in brings a professional, world-class development environment to Visio for creating SmartShapes symbols. By addressing such areas as specification, validation, and maintenance, ShapeStudio enables the SmartShape developer to concentrate on the drawing aspect of shape development. This add-in is available with the Microsoft Office Visio 2003 SDK.

Smart tags. Now you can make your shapes more usable with smart tags. Include smart tags on shapes to display a drop-down menu when a user hovers over a smart tag button. You can make important shape actions and settings more discoverable, alert users to incomplete custom properties or other data that needs adjustment in shapes, or let users start processes external to the drawing, such as ordering a replacement unit or sending e-mail, from the smart tag.

Style Explorer window. This window provides shape developers with a quick way to determine which shape cells inherit from a given style, or the style from which a given cell inherits its value.

XML Web Service support. With this version of Visio you can integrate XML Web Services into your diagrams simply by selecting the appropriate Web Service reference from a dialog box. This enables you to take advantage of these Web Services within Visio.
Sharing Data with Visio Through XML Web Services
In an Enterprise environment, you can make Visio even more powerful by integrating it as a smart client in line of business applications. For example, you can display a Visio diagram on a SharePoint Web site that is created programmatically from data from an XML Web Service. The diagram updates automatically to represent changes to the data, allowing you to show, dynamically, the progress, process, and status of documents or projects in the corporation. 
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You can use Visio as a drawing surface that's driven by an XML Web Service to show the progress of a workflow captured in an Excel spreadsheet on a SharePoint Web site.

For another example, in an enterprise environment, you could show inventory availability graphically by connecting a Visio diagram through a Web Service to a database of information about the stock on palettes in a warehouse. As the inventory moves off the palettes and depletes in the database, which is accessible through a Web Service, you can see the change. 

Or, you might track workflow status from a single diagram on a SharePoint Web site from data in multiple XML Web Services in a partner community, as illustrated below. The Visio Web part sits in a SharePoint Web site and shows the standard steps in producing a document for a document library. 

First, an employee clicks on the "Purchasing RFP" document to display a workflow for the review process in the Visio Web Part: 
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He then right-clicks the "Initial review" shape and clicks "Assign" to assign a task to himself:
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The drawing updates to reflect the new assignment:
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You could also programmatically color code the shapes according to status, for example, setting completed steps to green. Anyone on the team can quickly check to see which tasks are complete and which tasks aren't. 

System Requirements
The following components are required to install and run Visio 2003.
Windows Operating System. Microsoft Windows 2000 with Service Pack 3 or later or Windows XP or later required.
Processor. Pentium 233 MHz or higher processor, Pentium III recommended.

Random Access Memory. 128 MB of RAM or more recommended. 

Storage Requirements. Hard disk space requirements vary depending on configuration; custom installation choices might require more or less. The minimum hard disk requirements for Visio Standard 2003 and Visio Professional 2003 are as follows:

· Visio Standard 2003. 160 MB of available hard-disk space, including 75 MB on the hard disk where the operating system is installed.

· Visio Professional 2003. 210 MB of available hard-disk space, including 75 MB on the hard disk where the operating system is installed.

Monitor. Super VGA (800X600) or higher resolution monitor.

Internet. Microsoft Internet Explorer 5.5 or later browser. Dial-up or broadband Internet access, provided separately; local or long-distance charges may apply.
Additional items or services required to use certain features.

Speech recognition. Pentium II 400-MHz or higher processor; close-talk microphone and audio output device for speech recognition

Ink. Certain inking features require that you run Visio on Windows XP Tablet PC Edition.
Advanced collaboration functionality. Certain features require Microsoft Windows Server™ 2003 running Microsoft Windows SharePoint Services.
Improvements for International and Enterprise-wide Distribution
Language Handling with Document Creation and Sharing
Support for Unicode, End User Defined Characters (EUDC) sets, and GB18030 is new in Visio 2003. With Unicode you can create drawings in many different languages, create drawings that contain multiple languages, and share and collaborate on drawings across multiple languages. With EUDC you can form Asian names and other Asian words using characters that are not available in standard screen and printer fonts. With support for GB18030, which is a new Chinese character-encoding standard, you can create drawings containing Chinese characters from this new character encoding set.

Corporate Deployment
Enterprise customers can take advantage of Multilingual User Interface packs to manage worldwide deployment of multiple languages.
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