Creating a Course Web Site
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Creating a Course Web Site
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As an educator or administrator, you are always looking for new and exciting ways to communicate with students and others in an easy to use, cost effective, and efficient manner. The World Wide Web satisfies all these criteria and allows almost instant delivery of information, virtually anywhere. You can create a reference page with links and a course calendar, or you can create an entire online course. Microsoft® FrontPage® 2002 enables you to easily create and maintain Web pages suited to your needs without learning any HTML.

In this hands-on session, you will learn how to create a course Web site. You will learn how to use templates and themes to create your site, make your Web site easy to navigate, and view activity on your site. You will also learn how to add a threaded discussion enabling students to interact with each other online.

Before You Begin
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FrontPage is a Web site authoring and management program. It has many powerful features, yet it is still easy to master.

FrontPage enables you to create individual Web pages, entire Web sites, or to update existing Web pages and sites. Some of the functionality is enabled by server extensions, which must be loaded on the server where the Web content will be published. FrontPage server extensions are available for most popular Web servers. You can easily test your Web pages by previewing them in your Web browser. When you are ready to publish your creation to a live Web server, click the Publish button and then specify the server you want to use.

Before you complete this tutorial, you need to install the Course Web template. This template enables you to create a course Web site, and is used in many of the examples. If you have not already done so, make sure that you download the following sample data file that accompanies this tutorial:

· Crseweb.exe
This file extracts automatically to a folder on drive C on your computer, and the template is available in FrontPage.

Note:   If you installed FrontPage to a drive other than drive C (for example, if you chose not to overwrite previous versions of Microsoft Office), you must copy the extracted files and then paste them into the corresponding folder on the drive that has FrontPage installed.
This file can be found on the Microsoft in Education Web site at the following URL: Type course web site in the Search field.
http://www.microsoft.com/education/

Touring FrontPage
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Before you develop a Web page, you should familiarize yourself with the layout and features of FrontPage. The following illustration shows the Navigation view: 
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Using Web Templates

This section describes how to quickly create a class Web site to deliver course materials and timelines, and to provide a forum for your students to communicate electronically.

You will use the New FrontPage Web Wizard to create your Web from a template, name it, and then choose the server on which you want to store your Web.

The following illustration shows the dialog box you use to create a new Web from a Wizard or a template:
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To create a Web site by using a wizard

1. Open FrontPage. The New Page or Web task pane will be open the first time you open FrontPage. If the task pane is not open, on the View menu, click Task Pane, and then click New Page or Web on the task pane drop-down list.

2. In the New Page or Web task pane, click Web Site Templates.
3. In the Web Site Templates dialog box, click Course Web. (Do not click OK yet.)

4. Type the address of your Web server in the Specify the location of the new Web text box, and then click OK.

5. After you type a folder location on your hard disk, FrontPage is in Page view.

6. On the Views bar, click Navigation.

The organizational structure of your new web is shown in the Views pane. You can now add your own information to the pages created by the Wizard, and add additional pages as necessary. Later in this workshop you will learn how to add a Threaded Discussion page to your site.

To create a new page

7. Right-click the Course Title page in Navigation view, point to New, and then click Page.

8. Right-click the new page in Navigation view, and then click Rename.
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9. Type Site Index in the page title box and press ENTER to change the page name.

10. Double-click the Site Index page to open it for editing in Page view.

The new page is already formatted in organization and appearance, in addition to being fully included in the navigational structure of the Web site. This chapter will explain the characteristics that make this possible and how you use them to your advantage in the following section. 

Using Themes

Web templates usually use a theme, which is a standard design for all the pages included in your site. Themes make it easy to format the appearance of a Web site. A theme applies a common format for the colors, graphics, and text on a single page or an entire Web site. If you use a theme, you won’t need to make formatting changes on each individual page. You can apply the theme you want from the list of themes and the entire look of your site will change. Note that any page formatting that has been done will be overwritten with the new theme. Therefore, the general rule of thumb is to choose a theme first and then modify individual page formatting to suit your needs. If you want, you can choose a different theme to apply to your course Web site.

To apply a theme

11. On the Format menu, click Themes. 

12. Click either Selected page or All pages. 

13. Click the theme you want to apply. When you click a theme, the Sample of Theme pane will show you a preview of a page with the theme applied. Click OK The theme is applied to the entire web or to the selected page, based on your selection.
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Note:   If you want to change the components of a theme, click Modify, click the area you want to change (Color, Graphics or Text), and then make your changes in the dialog boxes that open.

Using Shared Borders for Navigation

One of the most important considerations when you create a Web site is ease of navigation for the users. Users need to be able to find and use the pages on your site quickly and easily. If your site is difficult to navigate, it will not be an effective learning tool.

In FrontPage, you can change the structure in the Navigation view to organize your pages. Through this view you can use shared borders to provide complete navigation of your site. Simply drag the pages in the Navigation view to the appropriate spot in the hierarchy of Web pages and then place navigation bars in the appropriate area on a Web page to apply a change to all pages.

To activate Shared Borders

14. In Page view, click Format, and then click Shared Borders. 
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15. Select the check boxes for the borders you want to use, and then click either All pages or Current page.

16. Click OK to accept your changes and close the dialog box.

Everything that is placed in the shared borders will appear on every page on your Web site that includes that shared border.

To add Navigation Bars

17. Click the bottom shared borders and, then on the Insert menu, click Navigation. The Insert Web Component dialog box opens.
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18. Click Bar based on navigation structure, and then click Next.

19. Click the HTML Style at the bottom of the list, and then click Next.
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Click the orientation with the link bars arranged horizontally, and then click Finish. The Link Bar Properties dialog box opens.
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20. Click Child pages under Home to indicate that buttons should be displayed for pages directly under the home page in the structure in Navigation view. As you add new pages to your site, the navigation bars will update automatically. Click OK to add the navigation bars to your web.

Using Categories

Many Web sites use a site index to make it easier for site visitors to find the pages they need. The shared borders you created will make it easier to navigate your Web site, but they will not provide one-click access to all pages within the site. A site index provides an organized set of links to all pages in your Web site based on the content found in those pages. You can easily create a site index by using categories. Categories allow you to organize individual Web pages into groups, for example, assignments, exams, and discussions. You can then organize the display of links to those pages on a site map. Smaller Web sites can accomplish this by using a table of contents, but as the site grows the Table of Contents will merely reflect the hierarchical arrangement of pages in the Navigation view. The site index provides a much more useful way to find the exact page that the student is looking for based a simple index just like you would find at the back of a textbook.

To create categories

21. In any view other than Tasks, right-click a file in the folder list, click Properties, click the Workgroup tab, and then click Categories.
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22. Type the category you want to create in the New Category box, for example, Exams, and then click Add. Repeat this for each new category. Create categories for Assignments, Exams, Information, and Notes, and then click OK, and then click OK a second time to close the Properties dialog box.

To apply categories to pages

23. In Navigation view, right-click a page, click Properties, and then click the Workgroup tab.
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24. Select the check boxes next to the categories you want to assign to the page, and then click OK.

Note:   If you do not want to publish some of the files at this time, you can select the Exclude this file when publishing the rest of the Web check box. This will prevent the Web page from being uploaded to the web server during the publishing process. You also must right-click the same files in Navigation view, and then click Included in Navigation Bars. This will prevent the button from showing up on navigation bars. To publish the pages, reverse the process.

To create a Site Index

25. Click Page in the Views bar to open the Site Index page. 

26. Double-click the page title bar, and in the Page banner text box, type Please select a page from the index below. Click OK. 
27. Click the text box below the page title.
28. Type Exams: and then press SHIFT+ENTER to move the insertion point to the next line.
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29. On the Insert menu, click Web Component. 

30. Click Table of Contents in the left pane, and then click Based on Page Category in the right pane. Click Finish.
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31. Select the Exams check box and then click OK. Press ENTER to start a blank new line. This displays the pages you assigned to the Exams category in this list. Multiple categories can be selected, which allows one page to appear in multiple sections of your site map.

32. Repeat steps 5 and 6 for each category you want to appear in the site map. Add Assignments, Information, Miscellaneous, and Notes.

Note:   If you do not create the list in alphabetical order, you can drag and drop the items in the appropriate order after the list is complete.

Creating a Threaded Discussion

Your students might not have the luxury of being in close proximity to each other, and even if they are, their time is at a premium. You can facilitate out of class discussion by creating a forum on your Web site for a structured, topic-based conversation. A Threaded Discussion allows users to join an online conversation at any time and to be able to quickly understand the current discussion. The Discussion Web Wizard makes it easy to add a threaded discussion to your course Web site.

To create a Threaded Discussion Web

33. On the File menu, point to New, and then click Page or Web. The Task Pane opens.

34. Click Web Site Templates to open the New Web dialog box.

35. Click Discussion Web Wizard, select the check box for Add to current Web, and then click OK. The Discussion Web Wizard opens.

36. Click Next, and then click Next again. This confirms the main features of the discussion. Leave the defaults selected.

37. Type a title for your discussion. Leave the discussion folder as _disc1, and then click Next.

38. Click Next to indicate that you want to have only subject and comments on a submission form.

39. Click Next to indicate that you want to allow anyone to participate in the discussion. 

40. Click Newest to oldest as the sort order for messages on the sixth page, and then click Next.

41. Make sure to leave No selected on the next page, and then click Next.

Choose how you want items found in a search to be displayed, and then click Next.

42. Click Contents beside current article to allow ease of navigation within the discussion, and then click Next. Frames are supported by most browsers now so don’t hesitate to use them.

43. Click Finish on the last page, but pay attention to the fact that the Wizard is giving you the name of the main page in the discussion web’s structure. You will need to place this information into the navigational structure of the main web. The file name of the page is disc1_frm.htm.

44. Switch to Navigation view and drag and drop disc1_frm.htm into the organizational structure at the level directly below the home page.

45. Right-click the page, click Rename and change the page name to Discussion. Press ENTER.

Managing your Web Site
You now have a course Web site that will be a very useful resource for your students to discuss and access information about your class. You have even provided the ability for students to collaborate with peers. Of course you will want all of your work to stay usable and current. It is frustrating to navigate through a stale Web site filled with links that are no longer valid. You also want to see if your Web site is being used.

You can maintain your Web site through reports that allow you to get a bird’s eye view of the health and vitality of your site. Broken hyperlinks, slow pages, stale pages, quantity of pictures, and links are available in a report. Hit counters provide you with the number of visitors to a given page. This enables you to see the popularity of specific pages in your site, although Web sites usually have a Hit Counter only on the home page.

To add a Hit Counter

46. Double-click the home page in Navigation view to open it for editing.

47. On the Insert menu, click Web Component.
48. Click Hit Counter in the left pane and then click a style for the numbers in the right pane. Click Finish.

49. In the Hit Counter dialog box, select a starting number other than zero if you want, and then click OK.

50. After the hit counter type Visitors since and today’s date (for example, Visitors since 9/10/2001). This will explain to the students what the numbers mean. Save your web.

To view site statistics

· On the View menu, point to Reports, and then click the report that you want. If you want an overview of the entire range of items tracked on your site, click Site Summary.
-or-
Click Reports on the Views bar to display the last selected report.
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For more detailed information about Web site traffic, see the many applications available for Web servers that provide a highly detailed analysis. Refer to your Web master for answers to your specific questions.

Getting Help

You can get help from the Office Assistant or from online Help at any time while you are using FrontPage. To open the Office Assistant, click the FrontPage Help button on the Standard toolbar. To open online Help, click Microsoft FrontPage Help on the Help menu. If you have an Internet connection, you can also click Office on the Web on the Help menu and choose from several resources that may be of interest to you such as Product News, Frequently Asked Questions, and Online Support. Don’t forget to go to http://www.microsoft.com/frontpage for all the latest information.

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Companies, names and data used in examples herein are fictitious unless otherwise noted.
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To automate the use of shared borders for website navigation, make sure to use the Navigation view to establish an organizational chart of your web.�





�





The ease of Web page creation is enabled by FrontPage Server Extensions on the Web server. If you do not wish to use these features, you may disable the features that require these extensions from the Options menu.�
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You can test your FrontPage Webs on your own computer before you publish them to a Web server. However, anything that requires server functionality will not be available.�
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Be sure to check the FrontPage section of the Microsoft Web site for enhancements, updates, and breaking news regarding FrontPage.�
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Words to know:�


Browser—A program that allows you to view HTML formatted documents. One example of a browser is Microsoft Internet Explorer.�


HTML—Hypertext Markup Language. The language used to format web pages.�


FrontPage 2002—The latest version of Microsoft’s Web authoring and management program used to create and manage Web sites and pages with no knowledge of programming in HTML. Provides Seamless integration with the Microsoft Office family of applications.�


Internet Explorer 6.0—The latest version of Microsoft’s popular web browser. It enables you to edit and display Web pages and to collaborate on standard Microsoft Office documents through discussions and collaborative reviews.�


Threaded Discussions—A Web page feature that enables individuals to have a topic-based discussions





URL—Uniform Resource Locator. The name and location of a file or Web page.�


World Wide Web— The collection of interconnected computers on the Internet.�

















What you will do:�


Use Web templates �


Use shared borders for navigation�


Apply themes�


Use the categories control�


Add threaded discussions�


Add a hit counter�


View Web site statistics
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A more efficient way to apply categories is to use the Category Report. To access the Category Report, click View, point to Reports, point to Workflow and then click Categories. To use a Category Report, select the pages that you want to apply a category to by holding the CTRL key and successively clicking on files will add the to the selection set.�After the files have been selected, you can right-click one of them and then apply the categories too all the selected files at one time.





�





Similar discussions can be created by using Microsoft SharePoint™ Team Services. FrontPage 2002 includes the software to accomplish this on the installation CDs. Just start the installation, follow the defaults, and in a few minutes you are ready to go!�





�





To easily edit different pages, just double click the page you want to change to in Navigation view.�








�





You can create a customized theme for your institution by clicking Modify in the Themes dialogue box.�





�





Any modifications to an existing theme will be saved with another name. This means that the themes that are included with FrontPage exactly the same on all computers.�
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