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Adding Content 
to a Web Site

In the previous chapter, you planned and created your Web site. Next, you'll work on the home page, which is what visitors usually see first when they come to your Web site on the Web. Think of your home page as introduction to the rest of your site. Use it as a guide to the types of information that viewers can find on the Web site, or a table of contents.

You have also added a theme to your Web site, but because themes are predefined, it may happen that your Web site looks like someone else’s. In this chapter, you learn how to customize a theme to create a unique look for your site.

Before you begin

· You have already decided what type of information you want to have on your Web site. Now you need to write the content text. You can write the text in Microsoft Word and paste it into your Web pages, or you can write the content directly in FrontPage 2000. You have access to most of the features of Word, such as spell checking and thesaurus, even when working directly in FrontPage 2000.

· Choose the content for your header, which is the first thing people see when they visit your site on the Web. Most headers include the name of the organization, a logo or graphic, and a tag line or short description of what visitors should expect. 

· Decide what information you want to include in your page footers. Consistently placed elements in a footer can help unify a Web site's look, aid site navigation, and let people know how to contact you. Information commonly found in footers includes links to the home page, contact information, copyright, and more. 

Organizing the page header

The header, located at the top of the page, contains the title of the Web page. It may also contain banners and navigation buttons to other pages on the Web site. A good header lets visitors know what page they are on and helps them get to the information they are looking for.

To organize the home page header

1. If your Central High School Web site is not open, open it and go to Page view, and then double-click central_high_school_home_page.htm. The Web page already has a banner in the header. It was added when you applied a theme to your Web site.

2. Click to the right of the banner and press ENTER.

3. On the Insert menu, click Navigation Bar.

4. In the Navigation Bar properties dialog box, select the Child level option. This adds navigation buttons on the home page that link to each of the pages on the level below the home page.

5. In the Orientation and appearance area, select the Horizontal and Buttons options, and then click OK.

To change shared borders on the home page

6. On the Format menu, click Shared Borders.

7. In the Shared Borders dialog box, select the Current page option, and clear the Left option. 

8. Click OK. This deletes the left shared border on the home page without deleting the shared border from the other pages.

Adding the body or active page

The body of a Web page, otherwise known as the active page, is located below the header and contains the content or information about the Web page. It may also include images, text, sound clips, motion clips, and links to other pages. 

Adding and formatting text

Adding text to a Web in FrontPage 2000 is very simple. You can type directly in the FrontPage 2000 Web page, paste text from an program like Word 2000, or you can import text from a file. After adding text to the active page, you can make the text bold, italic, or underlined. You can also change the font, the font size, the color, and much more. In addition to easily formatting text, you can also add bullets and numbering to lists, and list indents.

To add text to a page

9. Click in the body of the home page after the “Welcome to the Central High School Home Page!” text you typed earlier.

10. Press ENTER twice.

11. Type Visit Calendar of Events for the daily calendar, sports events, upcoming music performances, and extracurricular activities and programs.
12. On the Formatting toolbar, click the Left align [image: image1.png]


 button.

13. Press ENTER, and type the following sentences:

· Visit Departments and Faculty to see department chairs, faculty room numbers, phone extensions, and office hours.

· Visit Academic Requirements for core graduation requirements, available electives, academic counseling information, and counselor contact information.

· Visit Alumni Activities to find out what your graduating class has planned for reunions, mentoring, and fund-raising.

· Visit Educational Links to see the most interesting and educational sites our students and educators have found on the World Wide Web.

You can also paste text from other word processing tools into your FrontPage 2000 Web page. Simply copy the text in the word processor, place the pointer in the active page, and click Paste [image: image2.png]


. 

To import text from another program

14. Click in the body of the home page after “Welcome to the Central High School Home Page!”

15. On the Import menu, click File. The Select File dialog box appears.

16. In the Files of type box, select the file type the text was saved in. For example, if you saved the text in Microsoft Word 2000, select Word 97-2000 (*.doc) as the file type.

17. Click the file, or find the file and then click it.

18. Click Open. The text appears in the active page.

To change font, font size, and font color

19. Select the “Visit Departments and Faculty …” sentence you typed in the procedure above.

20. To change the font, from the Font drop-down list, select Comic Sans MS.
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21. To change the font size, from the Size drop-down list, select 2 (10 pt).

22. To change the font color, click the arrow to the right of the Font Color button. The standard and theme colors appear, with more colors available by clicking More colors.
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23. To keep a consistent look and feel between pages on your Web site, select a color from the Theme’s Colors area. The selected text changes to the new color you chose.

To copy formatting

24. Click anywhere in the sentence you just formatted.

25. Click the Format Painter [image: image5.png]


 button.

26. Drag the pointer across the other “Visit…” sentences. The text formatting changes to match the first sentence.

Adding bulleted lists

Since information on a Web is most effective when it is presented briefly and concisely, you may want to use lists to share concepts, items, or options. For items that do not necessarily belong in a particular order use a bulleted list, or unordered list. For procedures or other sequential lists, use a numbered list. The procedure for adding lists to a page is simple. Note that a bulleted list created in a shared border appears on all pages of your site.

To add a bulleted list to a page on your site

27. Select all of the “Visit…” sentences you typed in the previous steps. 

28. On the Format toolbar, click the Bulleted List [image: image6.png]


 button. Each of the sentences now has a bullet in front of it, and a hanging indent. 

29. To move the list to the right, click the Increase Indent [image: image7.png]


 button.

You can create numbered lists the same way by clicking the Numbering [image: image8.png]


 button.

Adding graphics

FrontPage 2000 includes a full library of clip art from the Microsoft Clip Gallery. Spice up your Web site with buttons, icons, background patterns, video clips, and other images from the Clip Gallery.

To add a graphic

30. Click to the left of the Welcome text.

31. On the Standard toolbar, click the Center [image: image9.png]


 button.

32. On the Insert menu, click Picture and then click Clipart.

33. In the Microsoft Clip Gallery dialog box, on the Clip Art tab, click Academic, and then click the stacked books graphic.

34. Click the Insert Clip [image: image10.bmp] button. The image appears on the Web page.

35. Click the graphic to select it.

36. Click the handle in the lower-right corner of the image, and drag it up and to the left to resize the image to fit the space.

To change the way text wraps around a graphic

37. Click anywhere on the graphic.

38. On the Format menu, click Position. The Position dialog box appears.

39. Under Wrapping Style, click Left.

40. Click OK. The text remains next to the graphic instead of wrapping below the graphic.

Adding text to the footer 

The footer, located at the bottom of the page, can contain navigational links to other pages, a school district logo, or any contact information such as a phone number or an e-mail address. If the footer is not part of the shared border, it appears only on the page where you place it. 

In this procedure, you add school contact information to the footer. This type of information would probably be best used in a footer in a shared border. That way, you can easily change the information in the footer once, and then it is automatically updated on every other page where it appears.

To add text to the footer

41. Click at the end of the Central High School Home Page text in the bottom shared border and press SHIFT+ENTER. Using the SHIFT key with ENTER gives you single spacing instead of double spacing. 

42. Type Telephone, and press TAB.

43. Type 123-555-0111, and press SHIFT+ENTER.

44. Type Fax, and press TAB until the insertion point is aligned below the telephone number.

45. Type 123-555-0128, and press SHIFT+ENTER.

46. Select the text you just typed.

47. From the Font Size drop-down list, select 1 (8 pt). The contact information appears in the shared border on each of the Web pages you have created.

Checking the spelling in your Web site

Checking the spelling on your Web site helps you have a Web site that looks professional and is error-free. 

To check the spelling

· New in FrontPage 2000 is background spell checking: simply right-click any word with a red squiggly line under it and select the proper spelling.

-or-

· To check spelling throughout your web site:

48. On the Standard toolbar, click the Spelling [image: image11.png]


 button.

49. In the Spelling dialog box, click Change for the correct spelling of any misspelled words.

50. Click OK to close the Editor.

Time-stamping a page

A timestamp shows when a page was last edited or updated. Timestamps allow people to see how current the information is on a Web and whether the information has changed since the last time they visited.

To time-stamp a page

51. Click after the phone numbers in the footer and press ENTER to insert the timestamp in the footer.

52. On the Insert menu, click Date and Time. The Date and Time dialog box appears.

53. Select the Date this page was last edited option.

54. Select a date format from the Date Format drop-down list.

55. Select a time format from the Time Format drop-down list (optional). You may select a date format, a time format, or both.

56. Click OK.

Customizing the look of your Web

Now that you have already chosen a theme, you can customize it so that it suites your needs. You can modify the graphics used in the theme, the fonts, page backgrounds, and layout. Notice that when you change the color scheme, the text colors also change. 

To change the color scheme

57. On the Format menu, click Theme.

58. Click Modify. A new set of buttons appears at the bottom of the Themes dialog box.

59. Click Colors. FrontPage 2000 includes professionally designed color schemes to choose from, or you can create your own color scheme.

60. On the Color Schemes tab, select a new color scheme. A preview of the change appears in the Sample of Theme area.

61. To save the change to your theme, click OK.

62. Select the All pages option, and then click OK again. A dialog box appears asking if you want to save the theme.

63. Click Yes to save the theme, type a name in the Save Theme dialog box, and then click OK. 

To change text styles

64. On the Format menu, click Theme.

65. Click Modify. Another set of buttons appears at the bottom of the Themes dialog box.

66. Click Text. The Modify Theme dialog box appears.

67. To change the font for the headings, select Heading 1 from the Item drop-down list and then select a new font from the Font list.

68. Continue to change fonts for any other styles in the Item drop-down list. A preview of the changes appears in the Sample of Theme area.

69. To save the change to your theme, click OK.

70. Select the All pages option, and then click OK again. A dialog box appears asking if you want to save the theme.

71. Click Yes to save the theme, type a name in the Save Theme dialog box, and then click OK.

Extending your knowledge

To give your site a professional and consistent look, use styles. Styles define the appearance of text elements of a Web, such as headings and text, and can make formatting simple. When you apply a style to a paragraph or word, you can apply a whole group of character or paragraph formats in one simple operation. When you want to change the formatting of all the text of a particular element at once, just change the style that's applied to that element.

You can create a new style and add it to the standard HTML styles listed in the Style box on the Formatting toolbar. Any authors editing that page can then apply the new style to anything on the page, including text, paragraphs, pictures, and tables. The new style can also be applied to a page element in combination with any standard HTML style, resulting in a combination of the two styles.

For example, if you create a style called redbg that specifies a red background behind a page element, it's listed in the Style box as .redbg. When you apply .redbg, the background of the selected page element turns red. If you apply a standard HTML style such as Heading 1 to the same page element, then the page element inherits the styles of both Heading 1 and .redbg, indicated in the Style box as Heading.redbg. 

Creating styles for a Web site

Styles created for one page can't be shared with other pages. However, it’s just as easy to make styles for a whole Web by using an external style sheet. Style Sheets are documents that control formatting. Like themes, a style sheet can help you unify the look of your Web or change the look quickly.

If a style feature is unavailable (that is, it appears dimmed on the menu), or if you do not want to use cascading style sheets in order to ensure compatibility with older browsers, you need to enable or disable specific versions of CSS using the Compatibility options found in Page Options on the Tools menu before creating your style sheet.

To create a style for a page

72. In Page view on the Normal tab, on the Format menu, click Style. 

73. Click New, and then in the Name box, type the name of the new style. 

74. Click the Format button, and then specify the formatting characteristics for the new style: 

75. To set font properties, such as the font family or color, or character spacing, click Font. 

76. To set alignment, indentation, and spacing, click Paragraph. 

77. To set borders and shading, click Border. 

78. To set the style of bullets and numbering, click Numbering. 

79. To set positioning properties, such as the wrapping style or location, click Position. 

Creating or editing an embedded style sheet

An embedded style sheet is a type of cascading style sheet that's "embedded" within the HTML <HEAD> tags of a page. Styles in an embedded style sheet can be used only on that same page.

When you create or modify a style for a page using the Style command on the Format menu, FrontPage 2000 automatically creates an embedded style sheet (if it doesn't already exist), and saves the style as a class selector within the embedded style sheet.

You can edit the styles in the embedded style sheet using the Style command on the Format menu.

If a style feature is unavailable (that is, it appears dimmed on the menu), or if you do not want to use cascading style sheets in order to ensure compatibility with older browsers, you need to enable or disable specific versions of CSS using the Compatibility options found in Page Options on the Tools menu before creating your style sheet.
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Office 2000 files can be saved directly to a FrontPage-based Web site.
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What you will do:





Add content to your home page.�


Put together a page header.�


Add text to your page.�


Format text.�


Create a bulleted list.�


Insert graphics, pictures, and buttons.�


Customize your site's look.
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To match a color to an existing color anywhere on your screen, select More Colors and use the color picker to “pick” the color you want.
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If you resize an image making it smaller, use the Resample button on the Pictures toolbar. Resampling the image creates a smaller file, decreasing the time it takes to download the page.
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