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Creating a Course Web Site

FrontPage 2000 Demo

(10 minutes)

	Feature
	Talk Track
	Demo Instructions

	Introduction
	Hi, My name is <ENTER YOUR NAME HERE> and I’d like to welcome everyone to the Microsoft FrontPage 2000 demonstration. Over the next 10 minutes you’ll see “What Productivity means today” with the powerful new tools of Front Page 2000.

So what do I mean when I say “What Productivity means today?” With FrontPage 2000 you can focus on ways to:

· Use the power of the Web for communication–with FrontPage 2000, you can efficiently share information with others and make collaboration much simpler.

· Streamline work–and make it easier to complete everyday tasks, without worrying about software.

As you’ll see, FrontPage 2000 has some great features that make it easier to create documents for the Web.
	


	Feature
	Talk Track
	Demo Instructions

	Building a Web site
	For this demonstration, I am going to create a web site for a university business department.

The best thing to do first when creating a Web site is to create a home page to act as the "front door" to the site. A good home page welcomes visitors and introduces them to the site's contents. From the home page, a visitor should be able to access the rest of the site.

Now I'll create a few more pages on my Web site.
I'm creating the pages in what's called Navigation View, which gives me an overview of my Web sites' structure, and will keep the site organized.
	· Start FrontPage 2000. 

· On the Standard toolbar, click the arrow next to the New button and then click Web. The New dialog box appears.

· On the Web Sites tab, click Empty Web, and then click OK. The Folder list appears between the Views menu and the page. 

· On the Views menu, click [image: image2.png]


. Click [image: image3.png]


to add a home page. 

· Right-click the home page icon and click Rename, then type WSU Business Department Home Page. This is the text that appears at the top of the page. 

· To add connecting pages to your home page, click the home page and then click [image: image4.png]


 four times to add four pages. 

· Right-click New Page 2, and click Rename. Type Academic Requirements. 

· Repeat step 7 with the other new pages and name them Faculty Members, Class Schedules, Student Activities, Business Reports.
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	Inserting shared borders
	Next, I'll add shared borders to the Web site. With shared borders, I can easily add a consistent look to all of the pages in my site, and create a navigation system that will make getting around the site easier. 

I'm going to add a title to my page, and add some navigation buttons that will link all of the pages in the site together. Adding shared borders hardly takes any time at all, requires no fancy programming knowledge, and goes a long way to giving a Web site a strong presence.

One of the great things about shared borders is that I only have to create them once, and I can make sure that they will be added to each page in the site. 


	· From the Navigation view, double-click the Academic Requirements page. 

· On the Format menu, click Shared Borders. 

· Select the All Pages option, then select the Top, Left, and Bottom checkboxes. 

· Select the Include navigation buttons checkbox below the Left option to add links to all the pages in your Web, and then click OK. Dotted lines appear on the Web page to indicate where shared borders are located. 

· Click in the top shared border area. The text is highlighted. 

· On the Insert menu, click Page Banner. 

· Select the Picture option, verify that Academic Requirements is in the Page banner text box, and then click OK. The title Academic Requirements can now be seen in the top shared border. 

· Click in the left shared border area. The text is highlighted. 

· On the Insert menu, click Navigation Bar. 

· Select the Same level option, then select the Vertical, and Text options and click OK. Hyperlinks to each of the Web pages below the home page are now located in the left shared border. 

· Click on the bottom shared border area. The text is highlighted. 

· On the Insert menu, click Navigation Bar. 

· Select the Top level option, then select the Horizontal and Text options and click OK. The title WSU Business Department Home Page can now be seen in the shared border at the bottom of the page.

· Open some of the other existing pages on the site to show how the shared borders are now on all of the pages.
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	Adding Content (Collect and Paste)
	I've got the Web site off to a good start but now I need to add text and pictures. An important aspect of making sure a site stands out on the World Wide Web is adding excellent content.

I'm going to grab some preliminary text to my site from existing documents I have stored in other Microsoft Office applications. When I use FrontPage 2000 with Office 2000, I can take advantage of a great new feature called Collect and Paste. With Collect and Paste, I no longer have to copy chunks of information to the clipboard and paste them into my paper one piece at a time.

Here’s how Collect and Paste works. First, I will grab a couple of pieces of information from Document X. You will notice that when I am copying multiple chunks of information the Office Clipboard pops up. The Office 2000 clipboard has space for up to twelve pieces of information at once from other documents, email messages, the web, or anything you want.

If I want to see what I’ve got stored on the clipboard, I just need to hover my mouse over the clipboard.

To paste the information, I simply select the spot on the page where I want the text and click on the clipboard.

Next, I will insert some clip art into the site.
	· Go to Document X and copy the first sentence and all bullet points, including the last paragraph (this will copy the formatting and keep the bullets lined up properly).
· Copy table only under “Suggested Global Initiatives” section.

· The clipboard will now appear.

· Hover the mouse over an icon in the clipboard so that a “tooltips” box showing the contents appears. Hover over an additional icon so the “tooltips” box appears there too.

· Return to the document that you’re creating and put the cursor at lowest line under the section heading “Trends Based on Industry Research.”

· Paste first text from Document X under Current Market Situation

· Paste table from Document X below the text.

· Close the Clipboard toolbar.
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	Adding a graphic
	FrontPage 2000 includes an extensive library of clip art that I can use to add pizazz to my site. Not only can I add illustrations, but buttons, icons, background patterns, video clips, and other images from the Front Page Clip Gallery.

Right now I am going to add a simple graphic to let people know what this page is about. Although FrontPage has a lot of clip art to choose from, and I can also download more clip art from the Microsoft Web site.


	· Click below the top horizontal shared border text. 

· On the Standard toolbar, click the Center [image: image5.png]


 button. 

· On the Insert menu, click Picture and then click Clipart. 

· In the Microsoft Clip Gallery dialog box, on the Clip Art tab, click Business, and then click the graphic of the men climbing the arrow on the graph chart. 

· Click the Insert Clip [image: image6.png]


 button. The image appears on the Web page. 

· Click the graphic to select it. 

· Click the handle in the lower-right corner of the image, and drag it up and to the left to resize the image to fit the space. 



	Add a design theme
	I've tied my Web site together using shared borders  and I've added some text and graphics.

The creating a great looking site, what I need to do now is add a design theme.

A good design theme adds an attractive and consistent look to all of my pages, and also gives them a professional look. FrontPage 2000 includes many preset themes that I can quickly and easily add. FrontPage themes are also easily modifiable, if I decide I want to change anything..
	· In the Format menu, click Theme. 

· In the Themes dialog box, select the All Pages option. 

· Select the Straight Edge theme. Straight Edge is a very simple theme. To explore the other themes, click the title and a preview appears in the Sample of Theme box. 

· Select the Active Graphics and Background Image check boxes. 

· Click OK. The theme is applied to all pages in your Web. 
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	Adding and deleting pages
	I think I've got the beginnings of a great site here, but after giving it a little thought, I think I should delete a page that doesn't quite fit and add something better. 
	· On the Views toolbar, click [image: image7.png]s



 to go to the Navigation view. 

· Click the Student Activities page. 

· On the Edit menu, click Delete. The page no longer appears in the Navigation view.

· On the Views toolbar, click [image: image8.png]s



to go to the Navigation view. 

· Click the page to which you want to add a new page. 

· Click [image: image9.png]


to add the new page. 

· To name the page, right-click the new page and click Rename, and then type Department Scholarships. 



	Insert Hyperlinks
	I want to make sure that it's easy for students to get from the scholarship page to the department requirements. I'll add a simple hyperlink to the scholarship page that will take them where they need to be.

On the faculty page, I am going to add a link to the Microsoft web site as a resource for faculty members.
	· Go to Navigation view, and then click the Department Scholarships page.

· Type the following sentence: If you meet the department qualifications, you may be interested in the scholarship programs we offer.
· Highlight the words scholarship programs.

· Click the Hyperlink [image: image10.png]


button. 

· Click the Department Scholarships page in the Create Hyperlink dialog box (you will find it by the title, not the file name)and then click OK. The text changes color and now has an underline indicating that it is a hyperlink. 

· Go to the Faculty page 

· Type Microsoft Faculty Support and make it a bulleted item. Select the text you just typed.

· Click the Hyperlink [image: image11.png]


 button. 

· Type http://www.microsoft.com/education/he/default.htm in the URL area and click OK. (You just entered the URL with a typo so you can fix it in the following step.)

Save the Department Scholarships page.

	Verifying hyperlinks
	Now that I've added the hyperlink to the Microsoft Web site, I want to make sure that I entered the link information correctly.
	· In Reports view, click the Verify Hyperlinks [image: image12.png]


button on the Reports toolbar. 

· Select the Verify all hyperlinks option, and then click Start. The status of all hyperlinks in the current Web appears. 



	Repairing broken hyperlinks
	It looks like I made a typo in the hyperlink I just added to the site. I can easily fix it in Reports view, which will show me the status of the hyperlinks in my web.
	· On the View menu, point to Reports, and then click Broken Hyperlinks. 

· All broken hyperlinks in your Web are listed. If a hyperlink's destination is not in the current Web, the status of the hyperlink is Unknown. 

· Double-click the broken MS URL.

· Fix the typo in the URL (Add an d so that the doc changes from ) If you know the correct URL of the destination, edit it in the Replace hyperlink with box. 


· Click Replace. 



	Reports View
	FrontPage 2000 includes different views that help me create web sites. With Reports View I can get information about my web site: how many pages it includes, which pages will load slowly, which contain broken hyperlinks, which files have been recently changed, and other valuable information.


	In Reports view, click View Reports, and click Site Summary. Highlight different features as you talk about them.



	Other views
	One of the great things about FrontPage 2000 is how simple it makes web site administration. With the different views I've been looking at, I can create my site, view the organization of all the pages, graphics, and files in the site, create navigation for my site, view how the pages are linked together, and set up tasks to keep track of what work needs to be done the site. Assigning tasks to the web site is a great way to keep track of what needs to be done whether you are creating the Web site on your own or if you are working on it in a group.

	In Reports view, from the menue, click View, Reports, and click Site Summary. Highlight different features as you talk about them (Page view, Folders view, Navigation view, Hyperlinks view, and Tasks view).



	Previewing your Web site
	I still have a long way to go before I can publish this web site, but I have a good start. I've got an good overall organizational scheme, some great navigation, the look is professional, and with the different views I just looked at, I have the tools for simple administration.

Now I want to see what my web site rough draft will look like on the Internet. Looks good! Now all that's left for me to do is publish my site.

Publishing a site is easy with FrontPage 2000. Microsoft's FrontPage web site is a great place to go for more information about publishing to the World Wide Web. The web address is http://www.microsoft.com/frontpage/

	Go to the home page, then in Page view, click the Preview tab, and navigate to a couple different pages.



	Conclusion
	That wraps up the presentation. FrontPage 2000 is a great Web site building tool, isn’t it? We're very proud of FrontPage's power and ease of use. I'm sure you'll find that it's a great tool too.

Thanks everyone for coming.
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